D-SoilModel: Packages

D-SoilModel
Tool for the (stochastic) subsoil definition.
Packages
Here are the packages with brief descriptions (if available):
[detail level 12345]
▼N Deltares
▼N DSoilModel
▼N Application
N Properties
N Data
▼N Forms
N Properties
▼N Geometry
▼N Forms
N Properties
▼N Geotechnics
▼N Forms
N Properties
▼N IO
N Exception
▼N Importers
N Exception
N WaternetCreator
▼N Standard
N Application
N DotSpatialDgs
▼N Forms
▼N DExpress
N ComponentWrappers
N Forms
N Interfaces
N MapTools
N Project
N Properties
N ShapeImporters
N DotSpatial
N Properties
▼N Web
N Ajax
N DevExpress
N dinoservices
N Properties
N Waternet
Generated on Tue Dec 15 2015 18:15:40 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares Namespace Reference

Tool for the (stochastic) subsoil definition.
Namespaces
Deltares Namespace Reference

Namespaces

namespace | DSoilModel
namespace | Geometry
namespace | Geotechnics
namespace | Standard
Generated on Tue Dec 15 2015 18:13:46 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.DSoilModel Namespace Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • DSoilModel
Namespaces
Deltares.DSoilModel Namespace Reference

Namespaces

namespace | Application
namespace | Data
namespace | Forms
Generated on Tue Dec 15 2015 18:13:46 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.DSoilModel.Application Namespace Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • DSoilModel
  • Application
Namespaces | Classes
Deltares.DSoilModel.Application Namespace Reference

Namespaces

namespace Properties

Classes

class Program
Generated on Tue Dec 15 2015 18:13:46 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.DSoilModel.Application.Properties Namespace Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • DSoilModel
  • Application
  • Properties
Classes
Deltares.DSoilModel.Application.Properties Namespace Reference

Classes

class | Resources
A strongly-typed resource class, for looking up localized strings, etc. More...
class | Settings
Generated on Tue Dec 15 2015 18:13:47 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.DSoilModel.Data Namespace Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • DSoilModel
  • Data
Classes | Enumerations
Deltares.DSoilModel.Data Namespace Reference

Classes

class | CenterCrestLocation
Helper class to be able to draw the CenterCrestLocation property of a SoilProfile2D. More...
class | DSoilModelDataSourceRedirector
Redirects the data source of a source/property to the data source of another property More...
class | DSoilModelIO
class | DSoilModelProject
D-Soil Model Project More...
class | DSoilModelStiFileTransformer
class | DSoilModelTransformer
class | SoilSegmentSplitLocation
Class to hold the location of the proposed split of a segment. More...
class | SosDeltaModelDatabase
Derived Version of GeoTechnics.IO.DeltaModelDatabase, providing access to WTI-SOS specific data More...
class | SosSoilLayer1D
class | SosSoilProfilesImporter

Enumerations

enum ParameterViewSettings { AllParameters = 0, AsIsParameters = 1, ProbabilisticParameters = 2 }
Generated on Tue Dec 15 2015 18:13:47 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.DSoilModel.Forms Namespace Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • DSoilModel
  • Forms
Namespaces | Classes
Deltares.DSoilModel.Forms Namespace Reference

Namespaces

namespace Properties

Classes

class | CenterCrestLocationPropertyControl
class | DrawingBoringLayer
class | DrawingCenterCrestLocation
class | DrawingLayerObsolete
class | DrawingSoilSegmentSplitLocation
Class for drawing a SoilSegmentSplitLocation on a 2D geometry. More...
class | DrawingSosSoilLayer1D
class | DSoilModelContext
class | DSoilModelGeometryEditor
The D-Soil Model Geometry Editor More...
class | DSoilModelMapEditor
The D-Soil Model MapEditor More...
class | DSoilModelPlugin
Main Class for D-Soil Model More...
class | DSoilModelSegmentGeometryEditor
Class to be able to show a soilsegment as length profile (based on a fictive 2D profile with the length of the segment) In the length profile, the mapped CPTs and Borings belonging to the segment are shown. More...
class | FilmStrip
Control to show the Stochastic Soil Profiles of a Stochastic Soil Model as a film strip under the Geometry Editor. More...
class | FilmStripThumbnail
class | HighlightSoilSegment
UI element used for interactively splitting SoilSegments in the map More...
class | ModalListBox
The ModalListBox class More...
class | SoilSegmentSplitLocationControl
class | SosSoilLayer1DControl
class | SosSoilProfile1DControl
Generated on Tue Dec 15 2015 18:13:49 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.DSoilModel.Forms.Properties Namespace Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • DSoilModel
  • Forms
  • Properties
Classes
Deltares.DSoilModel.Forms.Properties Namespace Reference

Classes

class Resources
A strongly-typed resource class, for looking up localized strings, etc. More...
Generated on Tue Dec 15 2015 18:13:55 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geometry Namespace Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geometry
Namespaces
Deltares.Geometry Namespace Reference

Namespaces

namespace Forms
Generated on Tue Dec 15 2015 18:13:55 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geometry.Forms Namespace Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geometry
  • Forms
Namespaces | Classes | Enumerations | Functions
Deltares.Geometry.Forms Namespace Reference

Namespaces

namespace Properties

Classes

class | ColoredDrawingObject
class | DrawingBoundingBox
Drawing object that represents bounding box (rectangle) entities in the geometry (cross section) editor. More...
class | DrawingLine
Drawing object that represents line (GeometryCurve) entities in the geometry (crossection) editor. More...
class | DrawingObject
Base class for drawing objects that represents geotechnical entities in the geometry (crossection) editor. More...
class | DrawingPoint
class | DrawingPointString
class | DrawingSurface
class | GeometryCurveControl
class | GeometryPlugin
class | GeometryPointControl
class | GeometryStringControl
class | GeometryViewSettings
interface | IDefinitionViewSettings
interface | IDrawingObject
interface | IGeometryViewSettings
interface | ILocationMapViewSettings
interface | ISoilGeometryViewSettings
interface | IWaternetViewSettings
class | SpatialEditorColors

Enumerations

enum DragStyle {
None, All, Horizontal, Vertical,
FixedBoundaries
}
enum ViewSettingsPosition { Top = 0, Middle = 1, Bottom = 2 }

Functions

delegate void GeometrySettingsChange ()
Generated on Tue Dec 15 2015 18:13:55 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geometry.Forms.Properties Namespace Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geometry
  • Forms
  • Properties
Classes
Deltares.Geometry.Forms.Properties Namespace Reference

Classes

class Resources
A strongly-typed resource class, for looking up localized strings, etc. More...
Generated on Tue Dec 15 2015 18:13:59 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics Namespace Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
Namespaces | Classes
Deltares.Geotechnics Namespace Reference

Namespaces

namespace | Forms
namespace | IO
namespace | WaternetCreator

Classes

interface | ISoilProfileProvider
Interface for providing the 1D Soil Profile TODO: Comment More...
class | SoilProfile1D
1D Soil Profile Object TODO: Comment More...
class | SoilProfile1DException
Exception for SoilProfile 1D problem handeling. More...
class | SoilProfileLayersNotSortedDescendingException
Exception for indicating that the soil profile layers are not sorted in descending order. More...
Generated on Tue Dec 15 2015 18:13:59 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.Forms Namespace Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
Namespaces | Classes | Functions
Deltares.Geotechnics.Forms Namespace Reference

Namespaces

namespace Properties

Classes

class | AnchorAttachmentControl
class | BondStressCurveControl
Earthquake Dialog. More...
class | BoringControl
Earthquake Dialog. More...
class | BoringLookupControl
class | CPTControl
Earthquake Dialog. More...
class | CPTLookupControl
class | DegreeOfConsolidationDialog
class | DegreeOfConsolidationMatrixControl
class | DesignPointControl
Earthquake Dialog. More...
class | DikeLineControl
Earthquake Dialog. More...
class | DrawingAnchorAttachment
class | DrawingAsphaltRevetment
Draws the asphalt segment More...
class | DrawingBlockRevetmentSegment
drawing revetment segment More...
class | DrawingBoring
Drawing class for displaying a Boring in the DSL geometry editor see http://www.geffiles.nl/cur/BORE_nl.html More...
class | DrawingCharacteristicPoint
class | DrawingCPT
Drawing class for displaying a CPT (sondering) in the DSL geometry editor see http://www.geffiles.nl/cur/CPT_nl.html (second graph, combined plot used as example) More...
class | DrawingGeometry
class | DrawingHeadLine
class | DrawingLayer
class | DrawingLocalisedGeometryPointString
class | DrawingPhreaticLine
class | DrawingPiezometricHead
Draws the piezometric head. More...
class | DrawingPreConsolidationStress
Drawable for an instance of PreConsolidationStress. More...
class | DrawingRevetment
Draws the piezometric head. More...
class | DrawingRoughnessRevetment
Draws the roughness segment More...
class | DrawingSettlementCurve
class | DrawingSheetPiling
class | DrawingSoilLayerSurface
Drawing object that represents soil layers (SoilLayerSurface) entities in the geometry (crossection) editor. More...
class | DrawingSoilProfile1D
Drawing class for displaying a 1D soilprofile More...
class | DrawingSoilSurface
Drawing object that represents 2D soil layers (SoilLayer2D) entities in the geometry (crossection) editor. More...
class | DrawingSpecificMechanismPointLocation
Drawing class for a new specific point for a mechanism (like Piping Location), which draws a simple square into a 2D Soil Profile. Simplicfication of DrawingCPT class. More...
class | DrawingSurfaceLine2
class | DrawingSwell
Draws a wave object. More...
class | DrawingWaterBasin
class | DrawingWaterLevel
class | DrawingWaternetLine
class | DrawingWaternetPointString
class | DrawingWaterPolderBasin
class | GeometryPropertyControl
class | GeotechnicsPlugin
class | GeotechnicsViewSettings
class | HydraulicBoundaryControl
Hydraulic boundary Dialog. More...
class | MaterialEditorDialog
class | PreconsolidationStressControl
class | ProbabilisticControl
Earthquake Dialog. More...
class | RevetmentLayerControl
class | SchematizedSurfaceLineControl
class | SegmentControl
Soil Segment property control. More...
class | SettlementCurveControl
class | ShearStressCurveControl
Earthquake Dialog. More...
class | SheetPilingControl
class | SoilBondStressCurveControl
same as SoilStressCurveControl, except StressCurve is BondStressCurve More...
class | SoilLayer2DControl
class | SoilLayerControl
class | SoilProfile1DControl
SoilProfile 1D properties control More...
class | SoilProfile2DControl
SoilProfile 2D Dialog. More...
class | SoilStressCurveControl
custom property control for soilsurface and geometrypoints More...
class | SoilSurfacePointsControl
class | SoilSurfacePropertyControl
Custom property control for soilsurface and geometrypoints. More...
class | SpecificMechanismPointLocationControl
class | StochastControl
class | StressCurveControl
Earthquake Dialog. More...
class | StressCurveReader
class | SurfaceLine2Control
class | WaterLineControl
class | WaternetControl
Tree on slope dialog. More...

Functions

delegate void UpdateWaternetUI ()
Generated on Tue Dec 15 2015 18:14:00 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.Forms.Properties Namespace Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • Properties
Classes
Deltares.Geotechnics.Forms.Properties Namespace Reference

Classes

class Resources
A strongly-typed resource class, for looking up localized strings, etc. More...
Generated on Tue Dec 15 2015 18:14:19 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.IO Namespace Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • IO
Namespaces | Classes
Deltares.Geotechnics.IO Namespace Reference

Namespaces

namespace | Exception
namespace | Importers

Classes

class | SurfaceLineClassFactory
class | SurfaceLineInstanceFactory
This factory creates a SurfaceLine instance if it is required by the XML definition This factory exists for backwards compatibility for SurfaceLine2 refactoring More...
class | SurfaceLineXmlHandler
This handler is responsible for handling an object which has been created with the SurfaceLine type. Since the old SurfaceLine has been refactored, this handler will convert the old SurfaceLine to a SurfaceLine2. More...
class | XmlAquiferHandler
class | XmlSoilsToSoilListHandler
Generated on Tue Dec 15 2015 18:14:19 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.IO.Exception Namespace Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • IO
  • Exception
Classes
Deltares.Geotechnics.IO.Exception Namespace Reference

Classes

class CsvImporterSoilProfilesException
Generated on Tue Dec 15 2015 18:14:21 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.IO.Importers Namespace Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • IO
  • Importers
Namespaces | Classes
Deltares.Geotechnics.IO.Importers Namespace Reference

Namespaces

namespace Exception

Classes

class | CharacteristicPointsImporter
struct | Coordinate
class | CsvImporterSurfaceLinesException
class | DGSGEFInterface
Interface for the functions of the DGSGEF.dll More...
class | DGSStandardDLLInterface
struct | DllVersionInfoStructure
class | FetchesImporter
Imports the fetches from a csv file. More...
class | GefBoringFileImporter
Imports a Boring from a GEF-file given by filename or as string More...
class | GefCptFileImporter
Imports a CPT from a GEF-file given by filename or as string More...
class | GEFXmlImporter
This class is used to import data (CPT, Profile, Soils) from a CPTip xml format string or stream More...
class | OldBoundary
class | OldGeometryFileImporter
class | SoilProfilesImporter
Importer for reading 1D soil profiles from CSV format files More...
class | SoilSegmentsImporter
Imports SoilSegment (stochastic soil models) from DAM style segments.csv file Each segment contains an ID/Name and reference to failure mechanism specific soil Models, but no spatial information More...
class | SurfaceLinesImporter
Imports surface line from DAM style surfacelines.csv file More...
Generated on Tue Dec 15 2015 18:14:21 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.IO.Importers.Exception Namespace Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • IO
  • Importers
  • Exception
Classes
Deltares.Geotechnics.IO.Importers.Exception Namespace Reference

Classes

class | CharacteristicPointsImporterException
class | FetchesImporterException
Generated on Tue Dec 15 2015 18:14:23 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.WaternetCreator Namespace Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • WaternetCreator
Classes | Enumerations
Deltares.Geotechnics.WaternetCreator Namespace Reference

Classes

class | DupuitPLLinesCreator
class | ExpertKnowledgePLLinesCreator
class | LineHelper
class | Location
class | PlLinesCreator
class | RingtoetsWTI2017PLLinesCreator
class | SoilVolumeMassCalculator
class | UpliftCalculator
class | WaternetCreator

Enumerations

enum | WaternetCreationMode { CreateWaternet, FillInWaternetValues }
Different options for generating the waternet - either letting it be generated or filling in values self More...
enum | DikeSoilScenario { ClayDikeOnClay, SandDikeOnClay, ClayDikeOnSand, SandDikeOnSand }
enum | PLLinePointPositionXzType { OnPLLine, AbovePLLine, BelowPLLine, BeyondPLLine }
enum | PLLineType { PL1, PL2, PL3, PL4 }
enum PlLineCreationMethod {
ExpertKnowledgeRrd, ExpertKnowledgeLinearInDike, RingtoetsWti2017, DupuitStatic,
DupuitDynamic, Sensors, None
}
enum | SoilGeometryType { SoilGeometry1D, SoilGeometry2D }
enum | PhreaticAdaptionType { None, MakeEmpty, Fill }
enum | GeometryTopBottom { Top, Bottom }

Enumeration Type Documentation

enum Deltares.Geotechnics.WaternetCreator.WaternetCreationMode
strong

Different options for generating the waternet - either letting it be generated or filling in values self

Generated on Tue Dec 15 2015 18:14:24 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard Namespace Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
Namespaces | Classes | Enumerations
Deltares.Standard Namespace Reference

Namespaces

namespace | Application
namespace | DotSpatialDgs
namespace | Forms
namespace | Web

Classes

interface | ICircleHotSpot
interface | ICurrent
interface | IHotSpot
interface | IMap
This interface is a helper for interfacing with ImageMap web control More...
interface | IPolygonHotSpot
interface | IRectangleHotSpot
interface | ITriangleHotSpot
interface | IUrl

Enumerations

enum HotSpotAction { None, Navigate, Execute, Download }
Generated on Tue Dec 15 2015 18:14:25 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Application Namespace Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Application
Classes
Deltares.Standard.Application Namespace Reference

Classes

class | LogHelper
LogHelper is a utility class to simplify logging to different appenders. This class uses log4net to delegate the actual logging. See the log4net documentation to configure this API in the client application using either the configuration file or programmaticaly. More...
class | ProgramBase
Generated on Tue Dec 15 2015 18:14:26 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.DotSpatialDgs Namespace Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • DotSpatialDgs
Classes | Enumerations
Deltares.Standard.DotSpatialDgs Namespace Reference

Classes

class | BackgroundFeature
class | BackgroundMap
class | DotSpatialGeographicAlgorithms
class | DotSpatialGeographicConverter
class | DotSpatialGeographicHelper
class | DotSpatialUtil
class | FeatureSupport
interface | IGeographicFactory
interface | IHasRaster
class | MapProjectionManager
Class for managing the map projections. Add a mapping of the internally used map projections definition (an enumeration) to the map projection definition of the mapping component in use in methode "InitializeMappings()". More...
class | MapProjectionManagerException
Exception class for MapProjectionManager More...

Enumerations

enum MapProjection {
DutchRD = 0, WebMercator = 1, WGS1984 = 2, Belge_Lambert_1972 = 3,
Custom = 999
}
Generated on Tue Dec 15 2015 18:14:27 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms Namespace Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
Namespaces | Classes | Enumerations | Functions
Deltares.Standard.Forms Namespace Reference

Namespaces

namespace | DExpress
namespace | DotSpatial
namespace | Properties

Classes

class | ArrowShape
class | AxesShape
class | ColumnDescription
Contains all data for layout of the columns More...
class | CommandLineWindow
class | CustomConfirmDialog
class | DataGridViewManager
class | DBTableLayoutPanel
Double buffered

See also
TableLayoutPanel

. More...

class | DirectoryEditor
class | DrawingSupport
class | EllipseShape
class | EmptyShape
class | FileEditor
class | FormSupport
struct | GraphicsInfo
class | GridViewCellChangeArgs
Used for cell changes in the grid view. More...
class | GridViewChangeArgs
Used for change actions in the grid view. (add, delete and insert) More...
interface | ICommand
interface | IController
Defines a Interface for controlling the commands. More...
interface | ICustomView
interface | IDynamicPropertyControl
interface to display custom property windows More...
interface | IDynamicTableControl
interface | IGridController
interface | IGridViewControl
class | InsertShape
interface | IPresentable
interface | IPresenter
interface | IProjection
interface | IPropertyControl
Interface for custom property windows. More...
interface | IReloadableUI
interface | IReloadManager
interface | IShape
interface | IViewConfiguration
Contains the properties which will be shown as columns in the table. More...
class | LegendItem
class | LegendShape
class | MatrixViewer
class | MessageBoxManager
class | Messenger
Wrapper around MessageBox, allowing messages to be send via console or message box itself. More...
class | PolygonShape
class | PolylineShape
class | Presenter
class | ProgramSettings
class | ProgressBarWithText
class | Projection
class | RealTimeBackgroundValidator
class | RectangleShape
class | Shape
class | ShapeComparer
Comparer class for Shapes More...
class | ShapeEventArgs
Arguments for Shape Events More...
class | ShapeInfo
Information about the Shape More...
class | ShapesEventArgs
Arguments for Collections of Shape Events More...
class | SourceProperty
class | SpatialEditor
TODO: Comment More...
class | SpatialEditorBarSupport
class | TestRectangleShape
class | TransparentLabel
class | TriangleShape
class | ViewCommand
Represnts a view command More...
class | VisualValidationResult
class | ZoomablePictureBox

Enumerations

enum ColumnType {
ColumnType.Text, ColumnType.Link, ColumnType.Button, ColumnType.CheckBox,
ColumnType.ComboBox
}
Contains column type More...
enum CardinalDirection {
North, East, South, West,
Northeast, Southeast, Southwest, Northwest,
None
}
enum | ProjectStartMode { NewProject, LastProject }
enum EditorMode {
None, Panning, Dragging, Resizing,
Inserting, Brushing, RectangleZoom, RectangleSelect,
PolygonSelect
}
Enumeration for Editor Mode (None, Panning, Dragging, Inserting...) More...
enum ShapeAction {
Dragging, BeginDrag, EndDrag, PointAdded,
BeginInsert, EndInsert, Created, Deleted
}
Enumeration for Shape Action (Dragging, PointAdded, Created, ...) More...
enum | ShapeInsertMode { Point, Line, PolyLine }
Enumeration for Shape Insert Mode (Point, Line, PolyLine) More...
enum | ShapeInsertRepeatMode { None, Repeat, Connect }
Enumeration for Shape Insert Repeat Mode (None, Repeat, Connect) More...
enum | FillZoom { FillArea, FillPicture }

Functions

delegate void | CommandLinePointInputHandler (string aX, string aY, string aZ)
delegate void | ViewChanged (ICustomView aSender, Dictionary< string, object > aViewPropertyDictionary)
delegate void | EditorContextMenuHandler (int aX, int aY, double aX2D, double aY2D, double aX3D, double aY3D, double aZ3D, List< IShape > dragObjectList)

Enumeration Type Documentation

enum Deltares.Standard.Forms.ColumnType
strong

Contains column type

Enumerator
Text | Text element of column type.
Link | Link element of column type.
Button | Button element of column type.
CheckBox | Check box element of column type.
ComboBox | Combo box element of column type.
enum Deltares.Standard.Forms.EditorMode
strong

Enumeration for Editor Mode (None, Panning, Dragging, Inserting...)

enum Deltares.Standard.Forms.ShapeAction
strong

Enumeration for Shape Action (Dragging, PointAdded, Created, ...)

enum Deltares.Standard.Forms.ShapeInsertMode
strong

Enumeration for Shape Insert Mode (Point, Line, PolyLine)

enum Deltares.Standard.Forms.ShapeInsertRepeatMode
strong

Enumeration for Shape Insert Repeat Mode (None, Repeat, Connect)

Generated on Tue Dec 15 2015 18:14:28 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress Namespace Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
Namespaces | Classes | Enumerations | Functions
Deltares.Standard.Forms.DExpress Namespace Reference

Namespaces

namespace | ComponentWrappers
namespace | Forms
namespace | Interfaces
namespace | MapTools
namespace | Project
namespace | Properties
namespace | ShapeImporters

Classes

class | AboutControl
class | AbstractShapeFileImporter
This class is reponsible to handle the import from ShapeFiles More...
class | ActionSubControlFactory
class | ActiveWindowReport
class | AggregatePlugin
TODO: Comment (Only used by Koswat, so not commented by DSoil-Team) More...
class | AssignStrategy
class | BarButtonItemBinding
class | BarEditItemBinding
class | BarItemBinding
class | BarItemExtensions
class | BarStaticItemBinding
class | BarSubItemBinding
class | BaseControlBinding
class | BasicPropertySubControlFactory
the basic abstract class More...
class | BindingRegistration
class | BindSupport
TODO: Comment Explain concept of Binding, how does it work? More...
class | BindSupportAsHelpLocationProvider
Uses BindSupport to determine the help file location. More...
class | BindSupportChartHelper
class | BindSupportLateBinding
class | BindSupportTreeHelper
class | ButtonBinding
class | ButtonEditBinding
class | CategoryDisplayItem
TODO: Comment More...
class | ChangeInfo
class | ChartControlBinding
class | CheckBoxBinding
class | CheckEditBinding
class | ChildObject
class | ColorEditBinding
class | ColumnWidth
class | ComboBoxDisplayItem
This class is used for items displayed in a combo box. More...
class | ComboBoxEditBinding
class | ComponentBinding
class | ControlBinding
class | ControlsRecord
class | CustomDockManagerResXLocalizer
class | CustomLocalizer
class | DateEditBinding
class | DetailReportBandBinding
class | DialogTemplate
class | DisclaimerDialog
class | DisplayItem
class | DivideStrategy
class | DockPanelBinding
class | DynamicChartControl
class | DynamicImageControl
class | DynamicMessagesControl
class | DynamicNavigatorControl
class | DynamicOutputControl
class | DynamicPropertyControl
Control to display custom property windows More...
struct | DynamicPropertyControlDefinition
class | DynamicPropertyTabControl
Container for showing a collection of controls, that can all interpret the same type SelectedObject (type

Template Parameters
T ) based on a conversion delegate.
More...
class | DynamicResourcesControl
class | DynamicTableControl
class | FormsSupport
class | GeoChartControl
class | GeometryEditor
TODO: Comment More...
class | GeoPropertyGrid
class | GeoRepositoryTextEdit
class | GreaterThanStrategy
class | GridColumnBinding
class | GridControlBinding
class | GridEditValueStrategy
This class represents an edit action which can be performed on cell values. These so called GridEditValueStrategies take a gridview and finds the selected cell values for which each strategy can determine a sensible default value and/or can edit the value based on an entered "edit value". More...
class | GridViewControl
Generic Grid Control extend from DXGridControl More...
class | GridViewController
class | HelpLocationShower
This help file manager will open message box pop-ups, displaying the More...
class | HyperLinkEditBinding
interface | IActionSubControlFactory
interface | ILabelEditControl
a simple interface to help with binding of controls More...
class | ImageListBoxBinding
interface | IMainForm
interface | IMainFormActiveControlController
Allows for controls in the MainForm to be put in the front and active. More...
interface | IMainFormPlugin
TODO: Comment More...
interface | IPropertySubControlFactory
interface | IShapeImporter
class | LabelBinding
class | LabelControlBinding
class | LateBindingComponent
class | LessThanStrategy
class | ListBoxBinding
class | ListViewControl
class | LocalizationSupport
Allows components to register to be automatically translated. More...
class | MainForm
TODO: Comment More...
class | MapEditor
Map component of DSL Mainform More...
class | MapLayerDefinition
Class defining various property of a map layer, like feature type, name, symbology. More...
class | MapLayersPropertyControl
class | MapLegendPropertyControl
class | MinusStrategy
class | ModelDialog
class | MultiplyStrategy
class | MyFeatureSet
This class is a customized version of DotSpatial FeatureSet adding specific feature selection functionality More...
class | MyMapLineLayer
This class is a customized version of DotSpatial MapLineLayer, adding specific feature selection functionality More...
class | MyMapPointLayer
This class is a customized version of DotSpatial MapPointLayer, adding specific feature selection functionality More...
class | MyMapPolygonLayer
This class is a customized version of DotSpatial MapPolygonLayer, adding specific feature selection functionality More...
class | NavBarItemBinding
class | NewDataSet
Represents a strongly typed in-memory cache of data. /summary> More...
class | PanelAction
class | PanelLinearConversionValue
class | PanelTextBooleanValue
class | PanelTextComboBoxValue
class | PanelTextLinkValue
class | PanelTextNumericValue
class | PanelTextPathValue
class | PanelTextPopupContainerEdit
class | PanelTextStringValue
class | PdfHelpFileManager
Interacts with a pdf help file. More...
class | PictureBoxBinding
class | PlusStrategy
class | PopupContainerEditBinding
class | ProgramOptionsControl
class | ProgressDialog
class | PropertyControl
class | PropertyControlFactory
A factory to dynamically create property controls for data classes. (easiest way to use this is from the mainform: MainForm.CreateAndRegisterPropertyFormFor<T>(System.Linq.Expressions.Expression<System.Func<T,object>>[]) More...
class | RadioButtonBinding
class | RadioGroupBinding
class | RasterLayerDefinition
class | RegisteredSubControlFactories
class that manages IPropertySubControlFactory objects, so the PropertyControlFactory can get them to create controls for properties. More...
class | ReloadManager
class | Report
class | ReportChapter
class | ReportControl
class | ReportDlg
Form that displays a report document More...
class | ReportItem
class | ReportManager
class | RepositoryItemTrackBarBinding
class | ScrollableControlBinding
Binding class for GroupBox, GroupControl, Panel, XtraTabPage and UserControl More...
class | SelectionHyperLinkEdit
class | ShapeFileImporter
class | ShapeFileMetaDataImporter
class | SimpleButtonBinding
class | SimplePropertySubControlFactory
class | SingleUnitDialog
class | SpatialEditorProperties
class | SpinEditBinding
class | SplashDialog
class | StateIndicatorGaugeBinding
class | StatusBar
class | SubControlFactoryForBoolean
class | SubControlFactoryForDecimal
class | SubControlFactoryForDomainProperty
class | SubControlFactoryForDouble
class | SubControlFactoryForEnum
class | SubControlFactoryForFileInfo
class | SubControlFactoryForInteger
class | SubControlFactoryForLinkedObject
class | SubControlFactoryForList
class | SubControlFactoryForStochast
class | SubControlFactoryForString
class | TextEditBinding
class | ToolStripMenuItemBinding
class | ToolTipVisibilityEventArgs
class | TrackBarControlBinding
class | TreeListBinding
class | TreeListColumnBinding
class | TreeViewControl
Generic Grid Control extend from DXTreeList More...
class | UnitsDialog
class | UserColumnFilterDisplayItem
class | WebMapPlugin
class | XRCheckBoxBinding
class | XRControlBinding
class | XRLabelBinding
class | XRPictureBoxBinding
class | XRShapeBinding
class | XRSubreportBinding
class | XtraTabPageBinding

Enumerations

enum BindingType {
Value, Label, Unit, LabelAndUnit,
LabelAndValue, Visibility, Assign
}
enum | HandleType { Immediate, Timer, LeftControl }
enum GeometryTypes {
Point = 1, LineString = 2, Polygon = 3, MultiPoint = 4,
MultiLineString = 5, MultiPolygon = 6, GeometryCollection = 7
}
Defines the different geometry types More...
enum | HyperLinkSelectionAction { Selection, SubSelection, None }
enum HeaderInfoType {
Company, Product, Version, Date,
PageInfo
}
enum ReportItemType {
Title, SubTitle, Chapter1, Chapter2,
Chapter3, Property, PropertyList, SubPropertyList,
PropertyGrid, SubPropertyGrid, Image, Table,
SubReport, Auto
}

Functions

delegate void | ToolTipVisibilityEventHandler (object sender, ToolTipVisibilityEventArgs e)
delegate IPropertyControl | CreatePropertyControlDelegate ()
delegate void | NewItemButtonHandler ()
delegate object | NewFile ()
delegate object | OpenFile (string fileName)
delegate void | SaveFile (string fileName, object data)
delegate void | UpdateToDataSourceEventHandler ()

Enumeration Type Documentation

enum Deltares.Standard.Forms.DExpress.GeometryTypes
strong

Defines the different geometry types

Generated on Tue Dec 15 2015 18:14:40 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.ComponentWrappers Namespace Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • ComponentWrappers
Classes
Deltares.Standard.Forms.DExpress.ComponentWrappers Namespace Reference

Classes

class | GaugeControlBinding
Binding for the parent of StateIndicatorGaugeBinding. More...
interface | IGetBoundControl
Generated on Tue Dec 15 2015 18:15:26 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.Forms Namespace Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • Forms
Classes
Deltares.Standard.Forms.DExpress.Forms Namespace Reference

Classes

class | ExportLayersController
Controller of MVC pattern, V = ExportLayerDialog, M = Layers More...
class | ExportLayersDialog
class | FieldMappingControl
interface | IExportLayersDialog
Interface (for testing) More...
class | SelectableLayerItem
Data item for binding More...
Generated on Tue Dec 15 2015 18:15:27 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.Interfaces Namespace Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • Interfaces
Classes
Deltares.Standard.Forms.DExpress.Interfaces Namespace Reference

Classes

interface | IHasBindableChildren
Class with child components that also need to be bound by BindSupport. More...
interface | IHelpFileManager
Interface for interacting with help files More...
interface | IHelpLocationProvider
Interface for classes that provide a help location to be consumed by IHelpFileManager classes. More...
interface | ILateBinding
interface | ISelectableLayer
Interface for selectable map layers More...
interface | ISettingsDialogPlugin
interface | ISettingsFormPlugin
interface | ISettingsValidator
Generated on Tue Dec 15 2015 18:15:27 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.MapTools Namespace Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • MapTools
Classes
Deltares.Standard.Forms.DExpress.MapTools Namespace Reference

Classes

class | AddFeatureMapTool
Add features map tool More...
class | BaseMapTool
Base tool for all maptools More...
class | ConnectFeaturesMapTool
Connect features map tool More...
class | DeleteFeatureMapTool
Delete featute on map More...
interface | IContextMenuMapTool
Interface for providing menu items for context menu More...
interface | IMapTool
Interface for Map tools More...
class | MoveFeatureMapTool
MoveTool moves features on the map. A related layer can be used for snapping More...
class | RectangleZoomMapTool
Rectangle Zoom in/out map tool More...
class | SelectFeatureMapTool
Select object on the map map tool More...
Generated on Tue Dec 15 2015 18:15:28 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.Project Namespace Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • Project
Classes
Deltares.Standard.Forms.DExpress.Project Namespace Reference

Classes

class DescriptionDialog
Generated on Tue Dec 15 2015 18:15:31 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.Properties Namespace Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • Properties
Classes
Deltares.Standard.Forms.DExpress.Properties Namespace Reference

Classes

class | Resources
A strongly-typed resource class, for looking up localized strings, etc. More...
class | Settings
Generated on Tue Dec 15 2015 18:15:31 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.ShapeImporters Namespace Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • ShapeImporters
Classes
Deltares.Standard.Forms.DExpress.ShapeImporters Namespace Reference

Classes

class | LineStringImporter
class | MultiLineStringImporter
class | MultiPolygonImporter
class | PointImporter
class | PolygonImporter
class | ShapeImporter
class | SmartLineStringImporter
This class initializes the geometry of different types in the data model from imported geometries of type GeometryType.LineString. Either the geometry of the type in the data model IS a point string, or ACCEPTS a point string. This can be defined by implementing the IGeographicString or the IGeographicPointFromString interfaces. More...
Generated on Tue Dec 15 2015 18:15:32 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DotSpatial Namespace Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DotSpatial
Classes
Deltares.Standard.Forms.DotSpatial Namespace Reference

Classes

interface | IShapeImporter
class | LineStringImporter
class | PointImporter
Generated on Tue Dec 15 2015 18:15:34 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.Properties Namespace Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • Properties
Classes
Deltares.Standard.Forms.Properties Namespace Reference

Classes

class | Resources
A strongly-typed resource class, for looking up localized strings, etc. More...
class | Settings
Generated on Tue Dec 15 2015 18:15:35 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Web Namespace Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Web
Namespaces | Classes | Enumerations
Deltares.Standard.Web Namespace Reference

Namespaces

namespace | Ajax
namespace | DevExpress
namespace | dinoservices
namespace | Properties

Classes

class | ASPPageSupportHandler
class | Chart
class | Cpt
class | CptServiceAgent
TODO add more actions to current class (maybe redesign). Now this agent only supports the GetGEF action More...
class | DINOInterface
class | Encryption
interface | IChart
class | ImageHttpHandler
interface | IPageSupportHandler
interface | IUploadDownload
class | Log
class | LogDetect
class | PageSupport
Class which takes care for all interaction between an ASP page and an IPropertyObject. This class takes care that properties are displayed in the ASP page and in the event the user changes values, they are sent back to the source object. All web controls in your web page associated with a property or method in the source object, should start with an underscoare followed by the property or method name. More...

Enumerations

enum LogType {
Debug, Info, Warning, Serious,
Fatal
}
Generated on Tue Dec 15 2015 18:15:35 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Web.Ajax Namespace Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Web
  • Ajax
Classes
Deltares.Standard.Web.Ajax Namespace Reference

Classes

class | AjaxPageSupportHandler
class | ExtenderControlBase
class | ExtenderControlPropertyAttribute
class | ScriptControlBase
class | ScriptControlPropertyAttribute
class | ScriptReferenceAttribute
Generated on Tue Dec 15 2015 18:15:36 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Web.DevExpress Namespace Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Web
  • DevExpress
Classes
Deltares.Standard.Web.DevExpress Namespace Reference

Classes

class DevExpressPageSupportHandler
Generated on Tue Dec 15 2015 18:15:38 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Web.dinoservices Namespace Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Web
  • dinoservices
Classes | Functions
Deltares.Standard.Web.dinoservices Namespace Reference

Classes

class | CptService
class | CPTType
class | CriteriaType
class | EnvelopeType
class | findCPTCompletedEventArgs
class | findCPTWithCriteriaCompletedEventArgs
class | getGEFCompletedEventArgs
class | RequestWithCriteriaType

Functions

delegate void | findCPTCompletedEventHandler (object sender, findCPTCompletedEventArgs e)
delegate void | findCPTWithCriteriaCompletedEventHandler (object sender, findCPTWithCriteriaCompletedEventArgs e)
delegate void | getGEFCompletedEventHandler (object sender, getGEFCompletedEventArgs e)
Generated on Tue Dec 15 2015 18:15:38 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Web.Properties Namespace Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Web
  • Properties
Classes
Deltares.Standard.Web.Properties Namespace Reference

Classes

class Settings
Generated on Tue Dec 15 2015 18:15:40 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Waternet Namespace Reference

Tool for the (stochastic) subsoil definition.
Classes
Waternet Namespace Reference

Classes

class | HeadLine
class | PhreaticLine
class | Waternet
class | WaternetCurve
class | WaternetLine
class | WaternetPoint
class | WaternetPolyCurve
Generated on Tue Dec 15 2015 18:15:40 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Package Functions

Tool for the (stochastic) subsoil definition.
Here is a list of all documented namespace members with links to the namespaces they belong to:
  • ColumnType : Deltares.Standard.Forms
  • EditorMode : Deltares.Standard.Forms
  • findCPTCompletedEventHandler() : Deltares.Standard.Web.dinoservices
  • findCPTWithCriteriaCompletedEventHandler() : Deltares.Standard.Web.dinoservices
  • GeometryTypes : Deltares.Standard.Forms.DExpress
  • getGEFCompletedEventHandler() : Deltares.Standard.Web.dinoservices
  • ShapeAction : Deltares.Standard.Forms
  • ShapeInsertMode : Deltares.Standard.Forms
  • ShapeInsertRepeatMode : Deltares.Standard.Forms
  • WaternetCreationMode : Deltares.Geotechnics.WaternetCreator
Generated on Tue Dec 15 2015 18:15:40 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Package Functions

Tool for the (stochastic) subsoil definition.
  • findCPTCompletedEventHandler() : Deltares.Standard.Web.dinoservices
  • findCPTWithCriteriaCompletedEventHandler() : Deltares.Standard.Web.dinoservices
  • getGEFCompletedEventHandler() : Deltares.Standard.Web.dinoservices
Generated on Tue Dec 15 2015 18:15:40 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Package Functions

Tool for the (stochastic) subsoil definition.
  • ColumnType : Deltares.Standard.Forms
  • EditorMode : Deltares.Standard.Forms
  • GeometryTypes : Deltares.Standard.Forms.DExpress
  • ShapeAction : Deltares.Standard.Forms
  • ShapeInsertMode : Deltares.Standard.Forms
  • ShapeInsertRepeatMode : Deltares.Standard.Forms
  • WaternetCreationMode : Deltares.Geotechnics.WaternetCreator
Generated on Tue Dec 15 2015 18:15:40 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Class List

Tool for the (stochastic) subsoil definition.
Class List
Here are the classes, structs, unions and interfaces with brief descriptions:
[detail level 123456]
▼N Deltares
▼N DSoilModel
►N Application
►N Properties
C Resources | A strongly-typed resource class, for looking up localized strings, etc.
C Settings
C Program
►N Data
C CenterCrestLocation | Helper class to be able to draw the CenterCrestLocation property of a SoilProfile2D.
C DSoilModelDataSourceRedirector | Redirects the data source of a source/property to the data source of another property
C DSoilModelIO
C DSoilModelProject | D-Soil Model Project
C DSoilModelStiFileTransformer
C DSoilModelTransformer
C SoilSegmentSplitLocation | Class to hold the location of the proposed split of a segment.
C SosDeltaModelDatabase | Derived Version of GeoTechnics.IO.DeltaModelDatabase, providing access to WTI-SOS specific data
C SosSoilLayer1D
C SosSoilProfilesImporter
►N Forms
►N Properties
C Resources | A strongly-typed resource class, for looking up localized strings, etc.
C CenterCrestLocationPropertyControl
C DrawingBoringLayer
C DrawingCenterCrestLocation
C DrawingLayerObsolete
C DrawingSoilSegmentSplitLocation | Class for drawing a SoilSegmentSplitLocation on a 2D geometry.
C DrawingSosSoilLayer1D
C DSoilModelContext
C DSoilModelGeometryEditor | The D-Soil Model Geometry Editor
C DSoilModelMapEditor | The D-Soil Model MapEditor
C DSoilModelPlugin | Main Class for D-Soil Model
C DSoilModelSegmentGeometryEditor | Class to be able to show a soilsegment as length profile (based on a fictive 2D profile with the length of the segment) In the length profile, the mapped CPTs and Borings belonging to the segment are shown.
C FilmStrip | Control to show the Stochastic Soil Profiles of a Stochastic Soil Model as a film strip under the Geometry Editor.
C FilmStripThumbnail
C HighlightSoilSegment | UI element used for interactively splitting SoilSegments in the map
C ModalListBox | The ModalListBox class
C SoilSegmentSplitLocationControl
C SosSoilLayer1DControl
C SosSoilProfile1DControl
▼N Geometry
►N Forms
►N Properties
C Resources | A strongly-typed resource class, for looking up localized strings, etc.
C ColoredDrawingObject
C DrawingBoundingBox | Drawing object that represents bounding box (rectangle) entities in the geometry (cross section) editor.
C DrawingLine | Drawing object that represents line (GeometryCurve) entities in the geometry (crossection) editor.
C DrawingObject | Base class for drawing objects that represents geotechnical entities in the geometry (crossection) editor.
C DrawingPoint
C DrawingPointString
C DrawingSurface
C GeometryCurveControl
C GeometryPlugin
C GeometryPointControl
C GeometryStringControl
C GeometryViewSettings
C IDefinitionViewSettings
C IDrawingObject
C IGeometryViewSettings
C ILocationMapViewSettings
C ISoilGeometryViewSettings
C IWaternetViewSettings
C SpatialEditorColors
▼N Geotechnics
►N Forms
►N Properties
C Resources | A strongly-typed resource class, for looking up localized strings, etc.
C AnchorAttachmentControl
C BondStressCurveControl | Earthquake Dialog.
C BoringControl | Earthquake Dialog.
C BoringLookupControl
C CPTControl | Earthquake Dialog.
C CPTLookupControl
C DegreeOfConsolidationDialog
C DegreeOfConsolidationMatrixControl
C DesignPointControl | Earthquake Dialog.
C DikeLineControl | Earthquake Dialog.
C DrawingAnchorAttachment
C DrawingAsphaltRevetment | Draws the asphalt segment
C DrawingBlockRevetmentSegment | drawing revetment segment
C DrawingBoring | Drawing class for displaying a Boring in the DSL geometry editor see http://www.geffiles.nl/cur/BORE_nl.html
C DrawingCharacteristicPoint
C DrawingCPT | Drawing class for displaying a CPT (sondering) in the DSL geometry editor see http://www.geffiles.nl/cur/CPT_nl.html (second graph, combined plot used as example)
C DrawingGeometry
C DrawingHeadLine
C DrawingLayer
C DrawingLocalisedGeometryPointString
C DrawingPhreaticLine
C DrawingPiezometricHead | Draws the piezometric head.
C DrawingPreConsolidationStress | Drawable for an instance of PreConsolidationStress.
C DrawingRevetment | Draws the piezometric head.
C DrawingRoughnessRevetment | Draws the roughness segment
C DrawingSettlementCurve
C DrawingSheetPiling
C DrawingSoilLayerSurface | Drawing object that represents soil layers (SoilLayerSurface) entities in the geometry (crossection) editor.
C DrawingSoilProfile1D | Drawing class for displaying a 1D soilprofile
C DrawingSoilSurface | Drawing object that represents 2D soil layers (SoilLayer2D) entities in the geometry (crossection) editor.
C DrawingSpecificMechanismPointLocation | Drawing class for a new specific point for a mechanism (like Piping Location), which draws a simple square into a 2D Soil Profile. Simplicfication of DrawingCPT class.
C DrawingSurfaceLine2
C DrawingSwell | Draws a wave object.
C DrawingWaterBasin
C DrawingWaterLevel
C DrawingWaternetLine
C DrawingWaternetPointString
C DrawingWaterPolderBasin
C GeometryPropertyControl
C GeotechnicsPlugin
C GeotechnicsViewSettings
C HydraulicBoundaryControl | Hydraulic boundary Dialog.
C MaterialEditorDialog
C PreconsolidationStressControl
C ProbabilisticControl | Earthquake Dialog.
C RevetmentLayerControl
C SchematizedSurfaceLineControl
C SegmentControl | Soil Segment property control.
C SettlementCurveControl
C ShearStressCurveControl | Earthquake Dialog.
C SheetPilingControl
C SoilBondStressCurveControl | same as SoilStressCurveControl, except StressCurve is BondStressCurve
C SoilLayer2DControl
C SoilLayerControl
C SoilProfile1DControl | SoilProfile 1D properties control
C SoilProfile2DControl | SoilProfile 2D Dialog.
C SoilStressCurveControl | custom property control for soilsurface and geometrypoints
C SoilSurfacePointsControl
C SoilSurfacePropertyControl | Custom property control for soilsurface and geometrypoints.
C SpecificMechanismPointLocationControl
C StochastControl
C StressCurveControl | Earthquake Dialog.
C StressCurveReader
C SurfaceLine2Control
C WaterLineControl
C WaternetControl | Tree on slope dialog.
►N IO
►N Exception
C CsvImporterSoilProfilesException
►N Importers
►N Exception
C CharacteristicPointsImporterException
C FetchesImporterException
C CharacteristicPointsImporter
C Coordinate
C CsvImporterSurfaceLinesException
C DGSGEFInterface | Interface for the functions of the DGSGEF.dll
C DGSStandardDLLInterface
C DllVersionInfoStructure
C FetchesImporter | Imports the fetches from a csv file.
C GefBoringFileImporter | Imports a Boring from a GEF-file given by filename or as string
C GefCptFileImporter | Imports a CPT from a GEF-file given by filename or as string
C GEFXmlImporter | This class is used to import data (CPT, Profile, Soils) from a CPTip xml format string or stream
C OldBoundary
C OldGeometryFileImporter
C SoilProfilesImporter | Importer for reading 1D soil profiles from CSV format files
►C SoilSegmentsImporter | Imports SoilSegment (stochastic soil models) from DAM style segments.csv file Each segment contains an ID/Name and reference to failure mechanism specific soil Models, but no spatial information
C CsvRecordClass
C SurfaceLinesImporter | Imports surface line from DAM style surfacelines.csv file
C SurfaceLineClassFactory
C SurfaceLineInstanceFactory | This factory creates a SurfaceLine instance if it is required by the XML definition This factory exists for backwards compatibility for SurfaceLine2 refactoring
C SurfaceLineXmlHandler | This handler is responsible for handling an object which has been created with the SurfaceLine type. Since the old SurfaceLine has been refactored, this handler will convert the old SurfaceLine to a SurfaceLine2.
C XmlAquiferHandler
C XmlSoilsToSoilListHandler
►N WaternetCreator
C DupuitPLLinesCreator
C ExpertKnowledgePLLinesCreator
C LineHelper
C Location
C PlLinesCreator
C RingtoetsWTI2017PLLinesCreator
C SoilVolumeMassCalculator
C UpliftCalculator
C WaternetCreator
C ISoilProfileProvider | Interface for providing the 1D Soil Profile TODO: Comment
C SoilProfile1D | 1D Soil Profile Object TODO: Comment
C SoilProfile1DException | Exception for SoilProfile 1D problem handeling.
C SoilProfileLayersNotSortedDescendingException | Exception for indicating that the soil profile layers are not sorted in descending order.
▼N Standard
►N Application
C LogHelper | LogHelper is a utility class to simplify logging to different appenders. This class uses log4net to delegate the actual logging. See the log4net documentation to configure this API in the client application using either the configuration file or programmaticaly
C ProgramBase
►N DotSpatialDgs
C BackgroundFeature
C BackgroundMap
C DotSpatialGeographicAlgorithms
C DotSpatialGeographicConverter
C DotSpatialGeographicHelper
C DotSpatialUtil
C FeatureSupport
C IGeographicFactory
C IHasRaster
C MapProjectionManager | Class for managing the map projections. Add a mapping of the internally used map projections definition (an enumeration) to the map projection definition of the mapping component in use in methode "InitializeMappings()".
C MapProjectionManagerException | Exception class for MapProjectionManager
►N Forms
►N DExpress
►N ComponentWrappers
C GaugeControlBinding | Binding for the parent of StateIndicatorGaugeBinding.
C IGetBoundControl
►N Forms
C ExportLayersController | Controller of MVC pattern, V = ExportLayerDialog, M = Layers
C ExportLayersDialog
C FieldMappingControl
C IExportLayersDialog | Interface (for testing)
C SelectableLayerItem | Data item for binding
►N Interfaces
C IHasBindableChildren | Class with child components that also need to be bound by BindSupport.
C IHelpFileManager | Interface for interacting with help files
C IHelpLocationProvider | Interface for classes that provide a help location to be consumed by IHelpFileManager classes.
C ILateBinding
C ISelectableLayer | Interface for selectable map layers
C ISettingsDialogPlugin
C ISettingsFormPlugin
C ISettingsValidator
►N MapTools
C AddFeatureMapTool | Add features map tool
C BaseMapTool | Base tool for all maptools
C ConnectFeaturesMapTool | Connect features map tool
C DeleteFeatureMapTool | Delete featute on map
C IContextMenuMapTool | Interface for providing menu items for context menu
C IMapTool | Interface for Map tools
C MoveFeatureMapTool | MoveTool moves features on the map. A related layer can be used for snapping
C RectangleZoomMapTool | Rectangle Zoom in/out map tool
C SelectFeatureMapTool | Select object on the map map tool
►N Project
C DescriptionDialog
►N Properties
C Resources | A strongly-typed resource class, for looking up localized strings, etc.
C Settings
►N ShapeImporters
C LineStringImporter
C MultiLineStringImporter
C MultiPolygonImporter
C PointImporter
C PolygonImporter
C ShapeImporter
C SmartLineStringImporter | This class initializes the geometry of different types in the data model from imported geometries of type GeometryType.LineString. Either the geometry of the type in the data model IS a point string, or ACCEPTS a point string. This can be defined by implementing the IGeographicString or the IGeographicPointFromString interfaces.
C AboutControl
C AbstractShapeFileImporter | This class is reponsible to handle the import from ShapeFiles
C ActionSubControlFactory
C ActiveWindowReport
C AggregatePlugin | TODO: Comment (Only used by Koswat, so not commented by DSoil-Team)
C AssignStrategy
C BarButtonItemBinding
C BarEditItemBinding
C BarItemBinding
C BarItemExtensions
C BarStaticItemBinding
C BarSubItemBinding
C BaseControlBinding
C BasicPropertySubControlFactory | the basic abstract class
C BindingRegistration
C BindSupport | TODO: Comment Explain concept of Binding, how does it work?
C BindSupportAsHelpLocationProvider | Uses BindSupport to determine the help file location.
C BindSupportChartHelper
C BindSupportLateBinding
C BindSupportTreeHelper
C ButtonBinding
C ButtonEditBinding
C CategoryDisplayItem | TODO: Comment
C ChangeInfo
C ChartControlBinding
C CheckBoxBinding
C CheckEditBinding
C ChildObject
C ColorEditBinding
C ColumnWidth
C ComboBoxDisplayItem | This class is used for items displayed in a combo box.
C ComboBoxEditBinding
C ComponentBinding
C ControlBinding
C ControlsRecord
C CustomDockManagerResXLocalizer
C CustomLocalizer
C DateEditBinding
C DetailReportBandBinding
C DialogTemplate
C DisclaimerDialog
C DisplayItem
C DivideStrategy
C DockPanelBinding
C DynamicChartControl
C DynamicImageControl
C DynamicMessagesControl
C DynamicNavigatorControl
C DynamicOutputControl
C DynamicPropertyControl | Control to display custom property windows
C DynamicPropertyControlDefinition
C DynamicPropertyTabControl Container for showing a collection of controls, that can all interpret the same type SelectedObject (type

Template Parameters
T ) based on a conversion delegate.
C DynamicResourcesControl
C DynamicTableControl
C FormsSupport
C GeoChartControl
C GeometryEditor | TODO: Comment
C GeoPropertyGrid
C GeoRepositoryTextEdit
C GreaterThanStrategy
C GridColumnBinding
C GridControlBinding
C GridEditValueStrategy | This class represents an edit action which can be performed on cell values. These so called GridEditValueStrategies take a gridview and finds the selected cell values for which each strategy can determine a sensible default value and/or can edit the value based on an entered "edit value".
C GridViewControl | Generic Grid Control extend from DXGridControl
C GridViewController
C HelpLocationShower | This help file manager will open message box pop-ups, displaying the
C HyperLinkEditBinding
C IActionSubControlFactory
C ILabelEditControl | a simple interface to help with binding of controls
C ImageListBoxBinding
C IMainForm
C IMainFormActiveControlController | Allows for controls in the MainForm to be put in the front and active.
C IMainFormPlugin | TODO: Comment
C IPropertySubControlFactory
C IShapeImporter
C LabelBinding
C LabelControlBinding
C LateBindingComponent
C LessThanStrategy
C ListBoxBinding
C ListViewControl
C LocalizationSupport | Allows components to register to be automatically translated.
C MainForm | TODO: Comment
C MapEditor | Map component of DSL Mainform
C MapLayerDefinition | Class defining various property of a map layer, like feature type, name, symbology.
C MapLayersPropertyControl
C MapLegendPropertyControl
C MinusStrategy
C ModelDialog
C MultiplyStrategy
C MyFeatureSet | This class is a customized version of DotSpatial FeatureSet adding specific feature selection functionality
C MyMapLineLayer | This class is a customized version of DotSpatial MapLineLayer, adding specific feature selection functionality
C MyMapPointLayer | This class is a customized version of DotSpatial MapPointLayer, adding specific feature selection functionality
C MyMapPolygonLayer | This class is a customized version of DotSpatial MapPolygonLayer, adding specific feature selection functionality
C NavBarItemBinding
►C NewDataSet | Represents a strongly typed in-memory cache of data. /summary>
C AssembliesDataTable | Represents the strongly named DataTable class. /summary>
C AssembliesRow | Represents strongly named DataRow class. /summary>
C AssembliesRowChangeEvent | Row event argument class /summary>
C AssemblyDataTable | Represents the strongly named DataTable class. /summary>
C AssemblyRow | Represents strongly named DataRow class. /summary>
C AssemblyRowChangeEvent | Row event argument class /summary>
C FileDataTable | Represents the strongly named DataTable class. /summary>
C FileRow | Represents strongly named DataRow class. /summary>
C FileRowChangeEvent | Row event argument class /summary>
C IDDataTable | Represents the strongly named DataTable class. /summary>
C IDRow | Represents strongly named DataRow class. /summary>
C IDRowChangeEvent | Row event argument class /summary>
C StringDataTable | Represents the strongly named DataTable class. /summary>
C StringRow | Represents strongly named DataRow class. /summary>
C StringRowChangeEvent | Row event argument class /summary>
C PanelAction
C PanelLinearConversionValue
C PanelTextBooleanValue
C PanelTextComboBoxValue
C PanelTextLinkValue
C PanelTextNumericValue
C PanelTextPathValue
C PanelTextPopupContainerEdit
C PanelTextStringValue
C PdfHelpFileManager | Interacts with a pdf help file.
C PictureBoxBinding
C PlusStrategy
C PopupContainerEditBinding
C ProgramOptionsControl
C ProgressDialog
C PropertyControl
C PropertyControlFactory | A factory to dynamically create property controls for data classes. (easiest way to use this is from the mainform: MainForm.CreateAndRegisterPropertyFormFor<T>(System.Linq.Expressions.Expression<System.Func<T,object>>[])
C RadioButtonBinding
C RadioGroupBinding
C RasterLayerDefinition
C RegisteredSubControlFactories | class that manages IPropertySubControlFactory objects, so the PropertyControlFactory can get them to create controls for properties
C ReloadManager
C Report
C ReportChapter
C ReportControl
C ReportDlg | Form that displays a report document
C ReportItem
C ReportManager
C RepositoryItemTrackBarBinding
C ScrollableControlBinding | Binding class for GroupBox, GroupControl, Panel, XtraTabPage and UserControl
C SelectionHyperLinkEdit
C ShapeFileImporter
C ShapeFileMetaDataImporter
C SimpleButtonBinding
C SimplePropertySubControlFactory
C SingleUnitDialog
C SpatialEditorProperties
C SpinEditBinding
C SplashDialog
C StateIndicatorGaugeBinding
C StatusBar
C SubControlFactoryForBoolean
C SubControlFactoryForDecimal
C SubControlFactoryForDomainProperty
C SubControlFactoryForDouble
C SubControlFactoryForEnum
C SubControlFactoryForFileInfo
C SubControlFactoryForInteger
C SubControlFactoryForLinkedObject
C SubControlFactoryForList
C SubControlFactoryForStochast
C SubControlFactoryForString
C TextEditBinding
C ToolStripMenuItemBinding
C ToolTipVisibilityEventArgs
C TrackBarControlBinding
C TreeListBinding
C TreeListColumnBinding
C TreeViewControl | Generic Grid Control extend from DXTreeList
C UnitsDialog
C UserColumnFilterDisplayItem
C WebMapPlugin
C XRCheckBoxBinding
C XRControlBinding
C XRLabelBinding
C XRPictureBoxBinding
C XRShapeBinding
C XRSubreportBinding
C XtraTabPageBinding
►N DotSpatial
C IShapeImporter
C LineStringImporter
C PointImporter
►N Properties
C Resources | A strongly-typed resource class, for looking up localized strings, etc.
C Settings
C ArrowShape
C AxesShape
C ColumnDescription | Contains all data for layout of the columns
C CommandLineWindow
C CustomConfirmDialog
C DataGridViewManager
C DBTableLayoutPanel Double buffered

See also
TableLayoutPanel

.

C DirectoryEditor
C DrawingSupport
C EllipseShape
C EmptyShape
C FileEditor
C FormSupport
C GraphicsInfo
C GridViewCellChangeArgs | Used for cell changes in the grid view.
C GridViewChangeArgs | Used for change actions in the grid view. (add, delete and insert)
C ICommand
C IController | Defines a Interface for controlling the commands.
C ICustomView
C IDynamicPropertyControl | interface to display custom property windows
C IDynamicTableControl
C IGridController
C IGridViewControl
C InsertShape
C IPresentable
C IPresenter
C IProjection
C IPropertyControl | Interface for custom property windows.
C IReloadableUI
C IReloadManager
C IShape
C IViewConfiguration | Contains the properties which will be shown as columns in the table.
C LegendItem
C LegendShape
C MatrixViewer
►C MessageBoxManager
C CWPRETSTRUCT
C Messenger | Wrapper around MessageBox, allowing messages to be send via console or message box itself.
C PolygonShape
C PolylineShape
C Presenter
C ProgramSettings
C ProgressBarWithText
C Projection
C RealTimeBackgroundValidator
C RectangleShape
C Shape
C ShapeComparer | Comparer class for Shapes
C ShapeEventArgs | Arguments for Shape Events
C ShapeInfo | Information about the Shape
C ShapesEventArgs | Arguments for Collections of Shape Events
C SourceProperty
C SpatialEditor | TODO: Comment
C SpatialEditorBarSupport
C TestRectangleShape
C TransparentLabel
C TriangleShape
C ViewCommand | Represnts a view command
C VisualValidationResult
C ZoomablePictureBox
►N Web
►N Ajax
C AjaxPageSupportHandler
C ExtenderControlBase
C ExtenderControlPropertyAttribute
C ScriptControlBase
C ScriptControlPropertyAttribute
C ScriptReferenceAttribute
►N DevExpress
C DevExpressPageSupportHandler
►N dinoservices
C CptService
C CPTType
C CriteriaType
C EnvelopeType
C findCPTCompletedEventArgs
C findCPTWithCriteriaCompletedEventArgs
C getGEFCompletedEventArgs
C RequestWithCriteriaType
►N Properties
C Settings
C ASPPageSupportHandler
C Chart
C Cpt
C CptServiceAgent | TODO add more actions to current class (maybe redesign). Now this agent only supports the GetGEF action
C DINOInterface
C Encryption
C IChart
C ImageHttpHandler
C IPageSupportHandler
C IUploadDownload
C Log
C LogDetect
C PageSupport | Class which takes care for all interaction between an ASP page and an IPropertyObject. This class takes care that properties are displayed in the ASP page and in the event the user changes values, they are sent back to the source object. All web controls in your web page associated with a property or method in the source object, should start with an underscoare followed by the property or method name.
C ICircleHotSpot
C ICurrent
C IHotSpot
C IMap | This interface is a helper for interfacing with ImageMap web control
C IPolygonHotSpot
C IRectangleHotSpot
C ITriangleHotSpot
C IUrl
▼N DeltaresStandardNative
C Class1
▼N Waternet
C HeadLine
C PhreaticLine
C Waternet
C WaternetCurve
C WaternetLine
C WaternetPoint
C WaternetPolyCurve
Generated on Tue Dec 15 2015 18:15:40 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.DSoilModel.Application.Properties.Resources Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • DSoilModel
  • Application
  • Properties
  • Resources
Properties | List of all members
Deltares.DSoilModel.Application.Properties.Resources Class Reference

A strongly-typed resource class, for looking up localized strings, etc. More...

Properties

static global::System.Resources.ResourceManager | ResourceManager [get]
Returns the cached ResourceManager instance used by this class. More...
static global::System.Globalization.CultureInfo | Culture [get, set]
Overrides the current thread's CurrentUICulture property for all resource lookups using this strongly typed resource class. More...
static System.Drawing.Bitmap | GenericProgressScreen [get]
Looks up a localized resource of type System.Drawing.Bitmap. More...
static System.Drawing.Bitmap | GenericSplashScreen [get]
Looks up a localized resource of type System.Drawing.Bitmap. More...

Detailed Description

A strongly-typed resource class, for looking up localized strings, etc.

Property Documentation

global.System.Globalization.CultureInfo Deltares.DSoilModel.Application.Properties.Resources.Culture
staticgetsetpackage

Overrides the current thread's CurrentUICulture property for all resource lookups using this strongly typed resource class.

System.Drawing.Bitmap Deltares.DSoilModel.Application.Properties.Resources.GenericProgressScreen
staticgetpackage

Looks up a localized resource of type System.Drawing.Bitmap.

System.Drawing.Bitmap Deltares.DSoilModel.Application.Properties.Resources.GenericSplashScreen
staticgetpackage

Looks up a localized resource of type System.Drawing.Bitmap.

global.System.Resources.ResourceManager Deltares.DSoilModel.Application.Properties.Resources.ResourceManager
staticgetpackage

Returns the cached ResourceManager instance used by this class.

Generated on Tue Dec 15 2015 18:13:47 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • DSoilModel
  • Application
  • Properties
  • Resources
Deltares.DSoilModel.Application.Properties.Resources Member List

This is the complete list of members for Deltares.DSoilModel.Application.Properties.Resources, including all inherited members.

Culture | Deltares.DSoilModel.Application.Properties.Resources | packagestatic
GenericProgressScreen | Deltares.DSoilModel.Application.Properties.Resources | packagestatic
GenericSplashScreen | Deltares.DSoilModel.Application.Properties.Resources | packagestatic
ResourceManager | Deltares.DSoilModel.Application.Properties.Resources | packagestatic
Resources() (defined in Deltares.DSoilModel.Application.Properties.Resources) | Deltares.DSoilModel.Application.Properties.Resources | package
Generated on Tue Dec 15 2015 18:13:47 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.DSoilModel.Application.Properties.Settings Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • DSoilModel
  • Application
  • Properties
  • Settings
Properties | List of all members
Deltares.DSoilModel.Application.Properties.Settings Class Reference
Inheritance diagram for Deltares.DSoilModel.Application.Properties.Settings:

Properties

static Settings Default [get]
Generated on Tue Dec 15 2015 18:13:47 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • DSoilModel
  • Application
  • Properties
  • Settings
Deltares.DSoilModel.Application.Properties.Settings Member List

This is the complete list of members for Deltares.DSoilModel.Application.Properties.Settings, including all inherited members.

Default (defined in Deltares.DSoilModel.Application.Properties.Settings) Deltares.DSoilModel.Application.Properties.Settings static
Generated on Tue Dec 15 2015 18:13:47 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.DSoilModel.Application.Program Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • DSoilModel
  • Application
  • Program
List of all members
Deltares.DSoilModel.Application.Program Class Reference
Inheritance diagram for Deltares.DSoilModel.Application.Program:
Generated on Tue Dec 15 2015 18:13:47 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • DSoilModel
  • Application
  • Program
Deltares.DSoilModel.Application.Program Member List

This is the complete list of members for Deltares.DSoilModel.Application.Program, including all inherited members.

Generated on Tue Dec 15 2015 18:13:47 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.DSoilModel.Data.CenterCrestLocation Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • DSoilModel
  • Data
  • CenterCrestLocation
Public Member Functions | Properties | List of all members
Deltares.DSoilModel.Data.CenterCrestLocation Class Reference

Helper class to be able to draw the CenterCrestLocation property of a SoilProfile2D. More...

Public Member Functions

override string ToString ()
Returns a System.String that represents this instance. More...

Properties

double | Location [get, set]
Gets or sets the location. More...
SoilProfile2D | SoilProfile2D [get, set]
Gets or sets the profile2d. More...

Detailed Description

Helper class to be able to draw the CenterCrestLocation property of a SoilProfile2D.

Member Function Documentation

override string Deltares.DSoilModel.Data.CenterCrestLocation.ToString ( )

Returns a System.String that represents this instance.

Referenced by Deltares.DSoilModel.Forms.DrawingCenterCrestLocation.DrawLabel().

Property Documentation

double Deltares.DSoilModel.Data.CenterCrestLocation.Location
getset

Gets or sets the location.

The location.

Referenced by Deltares.DSoilModel.Forms.DrawingCenterCrestLocation.Draw3D(), Deltares.DSoilModel.Forms.DrawingCenterCrestLocation.OnEndDrag(), Deltares.DSoilModel.Forms.DrawingCenterCrestLocation.SetDataObject(), and Deltares.DSoilModel.Forms.DrawingCenterCrestLocation.UpdateDataDragDrop().

SoilProfile2D Deltares.DSoilModel.Data.CenterCrestLocation.SoilProfile2D
getset

Gets or sets the profile2d.

The profile2 d.

Referenced by Deltares.DSoilModel.Forms.DrawingCenterCrestLocation.BottomForDrawing(), Deltares.DSoilModel.Forms.DrawingCenterCrestLocation.TopForDrawing(), and Deltares.DSoilModel.Forms.DrawingCenterCrestLocation.WidthForDrawing().

Generated on Tue Dec 15 2015 18:13:47 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • DSoilModel
  • Data
  • CenterCrestLocation
Deltares.DSoilModel.Data.CenterCrestLocation Member List

This is the complete list of members for Deltares.DSoilModel.Data.CenterCrestLocation, including all inherited members.

Location | Deltares.DSoilModel.Data.CenterCrestLocation
SoilProfile2D | Deltares.DSoilModel.Data.CenterCrestLocation
ToString() | Deltares.DSoilModel.Data.CenterCrestLocation
Generated on Tue Dec 15 2015 18:13:47 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.DSoilModel.Data.DSoilModelDataSourceRedirector Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • DSoilModel
  • Data
  • DSoilModelDataSourceRedirector
Public Member Functions | Properties | List of all members
Deltares.DSoilModel.Data.DSoilModelDataSourceRedirector Class Reference

Redirects the data source of a source/property to the data source of another property More...

Inheritance diagram for Deltares.DSoilModel.Data.DSoilModelDataSourceRedirector:

Public Member Functions

IEnumerable< SourceProperty > GetRedirectedDataSources (object source, string property)

Properties

static BindPropertyInfo[] StochastProperties [get]
Returns all stochast properties which are used for distributions More...

Detailed Description

Redirects the data source of a source/property to the data source of another property

Property Documentation

BindPropertyInfo [] Deltares.DSoilModel.Data.DSoilModelDataSourceRedirector.StochastProperties
staticget

Returns all stochast properties which are used for distributions

Generated on Tue Dec 15 2015 18:13:47 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • DSoilModel
  • Data
  • DSoilModelDataSourceRedirector
Deltares.DSoilModel.Data.DSoilModelDataSourceRedirector Member List

This is the complete list of members for Deltares.DSoilModel.Data.DSoilModelDataSourceRedirector, including all inherited members.

GetRedirectedDataSources(object source, string property) (defined in Deltares.DSoilModel.Data.DSoilModelDataSourceRedirector) | Deltares.DSoilModel.Data.DSoilModelDataSourceRedirector |
StochastProperties | Deltares.DSoilModel.Data.DSoilModelDataSourceRedirector | static
Generated on Tue Dec 15 2015 18:13:47 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.DSoilModel.Data.DSoilModelIO Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • DSoilModel
  • Data
  • DSoilModelIO
Static Public Member Functions | List of all members
Deltares.DSoilModel.Data.DSoilModelIO Class Reference

Static Public Member Functions

static void | AddOldProjectDataBaseToProject (string fileName, DSoilModelProject project)
Adds data from an old database (gdb or access) to the given project. All name clashes are resolved by renaming (uniquely) the here imported items. More...
static void | AddOldSoilDBToProject (string fileName, DSoilModelProject project)
Adds the soil data from an old database (gdb or access) to the given project. All name clashes are resolved by renaming (uniquely) the here imported items. More...
static object | OpenSoilDatabase (string fileName)
Reads all data from the current database and add that to the newly created current project. More...
static void | SaveSoilDatabase (string fileName, object project)
Saves all data from the given project to the current database More...
static object | OpenXML (string fileName)
Deserializes the XML with the given filename to the project. More...
static void | SaveXML (string fileName, object project)
Serializes the project to the XML with the given filename More...
static void | ReadCsvSurfaceLineFromFileAndAddToProject (string fileName, DSoilModelProject project)
Reads surface line definition from CSV format (DAM Style) More...
static void | ReadCsvCharacteristicPointsFromFileAndAddToProject (string fileName, DSoilModelProject project)
Reads surface line definition from CSV format (DAM Style) More...
static void | ReadCsvSegmentsFromFileAndAddToProject (string fileName, DSoilModelProject project, bool rejectIncompleteSegments=true)
Reads soil segment definition from CSV format (DAM Style) More...
static void | ReadDamDefinitionsFromFileAndAddToProject (string fileName, DSoilModelProject project)
Reads Dam soil segment & surfaceline data from the given file (defx or damx) and adds it to the project ensuring unique names for the imported items More...

Member Function Documentation

static void Deltares.DSoilModel.Data.DSoilModelIO.AddOldProjectDataBaseToProject | ( | string | fileName,
 |  | DSoilModelProject | project
 | ) |  |
static

Adds data from an old database (gdb or access) to the given project. All name clashes are resolved by renaming (uniquely) the here imported items.

Parameters
fileName | Name of the file.
project | The project.

Referenced by Deltares.DSoilModel.Data.DSoilModelProject.ReadOldProjectFromDatabase().

static void Deltares.DSoilModel.Data.DSoilModelIO.AddOldSoilDBToProject | ( | string | fileName,
 |  | DSoilModelProject | project
 | ) |  |
static

Adds the soil data from an old database (gdb or access) to the given project. All name clashes are resolved by renaming (uniquely) the here imported items.

Parameters
fileName | Name of the file.
project | The project.

Referenced by Deltares.DSoilModel.Data.DSoilModelProject.ReadSoilsFromDatabase().

static object Deltares.DSoilModel.Data.DSoilModelIO.OpenSoilDatabase ( string fileName )
static

Reads all data from the current database and add that to the newly created current project.

Parameters
fileName Name of the file.
Returns
the created project
static object Deltares.DSoilModel.Data.DSoilModelIO.OpenXML ( string fileName )
static

Deserializes the XML with the given filename to the project.

Parameters
fileName Name of the file.
Returns
the project
static void Deltares.DSoilModel.Data.DSoilModelIO.ReadCsvCharacteristicPointsFromFileAndAddToProject | ( | string | fileName,
 |  | DSoilModelProject | project
 | ) |  |
static

Reads surface line definition from CSV format (DAM Style)

Parameters
fileName

References Deltares.DSoilModel.Data.DSoilModelProject.SurfaceLines.

static void Deltares.DSoilModel.Data.DSoilModelIO.ReadCsvSegmentsFromFileAndAddToProject | ( | string | fileName,
 |  | DSoilModelProject | project,
 |  | bool | rejectIncompleteSegments = true
 | ) |  |
static

Reads soil segment definition from CSV format (DAM Style)

Parameters
fileName | file name of the CSV file to import
project | the D-SoilModel project
rejectIncompleteSegments | controls rejection of soil segments with incomplete soil profile data (default == true)

References Deltares.DSoilModel.Data.DSoilModelProject.SoilProfiles1D, and Deltares.DSoilModel.Data.DSoilModelProject.SoilProfiles2D.

static void Deltares.DSoilModel.Data.DSoilModelIO.ReadCsvSurfaceLineFromFileAndAddToProject | ( | string | fileName,
 |  | DSoilModelProject | project
 | ) |  |
static

Reads surface line definition from CSV format (DAM Style)

Parameters
fileName
static void Deltares.DSoilModel.Data.DSoilModelIO.ReadDamDefinitionsFromFileAndAddToProject | ( | string | fileName,
 |  | DSoilModelProject | project
 | ) |  |
static

Reads Dam soil segment & surfaceline data from the given file (defx or damx) and adds it to the project ensuring unique names for the imported items

Parameters
fileName | name of the file to import (*.defx; *.damx)
project | project to add the imported data to

References Deltares.DSoilModel.Data.DSoilModelProject.ReadGeometryFromFile(), Deltares.DSoilModel.Data.DSoilModelProject.ReadSoilProfiles1DFromFile(), Deltares.DSoilModel.Data.DSoilModelProject.SoilProfiles1D, Deltares.DSoilModel.Data.DSoilModelProject.SoilProfiles2D, Deltares.DSoilModel.Data.DSoilModelProject.Soils, Deltares.DSoilModel.Data.DSoilModelProject.SoilSegments, and Deltares.DSoilModel.Data.DSoilModelProject.SurfaceLines.

static void Deltares.DSoilModel.Data.DSoilModelIO.SaveSoilDatabase | ( | string | fileName,
 |  | object | project
 | ) |  |
static

Saves all data from the given project to the current database

Parameters
fileName | Name of the file.
project | The project.
static void Deltares.DSoilModel.Data.DSoilModelIO.SaveXML | ( | string | fileName,
 |  | object | project
 | ) |  |
static

Serializes the project to the XML with the given filename

Parameters
fileName | Name of the file.
project | The project.
Generated on Tue Dec 15 2015 18:13:47 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • DSoilModel
  • Data
  • DSoilModelIO
Deltares.DSoilModel.Data.DSoilModelIO Member List

This is the complete list of members for Deltares.DSoilModel.Data.DSoilModelIO, including all inherited members.

AddOldProjectDataBaseToProject(string fileName, DSoilModelProject project) | Deltares.DSoilModel.Data.DSoilModelIO | static
AddOldSoilDBToProject(string fileName, DSoilModelProject project) | Deltares.DSoilModel.Data.DSoilModelIO | static
OpenSoilDatabase(string fileName) | Deltares.DSoilModel.Data.DSoilModelIO | static
OpenXML(string fileName) | Deltares.DSoilModel.Data.DSoilModelIO | static
ReadCsvCharacteristicPointsFromFileAndAddToProject(string fileName, DSoilModelProject project) | Deltares.DSoilModel.Data.DSoilModelIO | static
ReadCsvSegmentsFromFileAndAddToProject(string fileName, DSoilModelProject project, bool rejectIncompleteSegments=true) | Deltares.DSoilModel.Data.DSoilModelIO | static
ReadCsvSurfaceLineFromFileAndAddToProject(string fileName, DSoilModelProject project) | Deltares.DSoilModel.Data.DSoilModelIO | static
ReadDamDefinitionsFromFileAndAddToProject(string fileName, DSoilModelProject project) | Deltares.DSoilModel.Data.DSoilModelIO | static
SaveSoilDatabase(string fileName, object project) | Deltares.DSoilModel.Data.DSoilModelIO | static
SaveXML(string fileName, object project) | Deltares.DSoilModel.Data.DSoilModelIO | static
Generated on Tue Dec 15 2015 18:13:47 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.DSoilModel.Data.DSoilModelProject Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • DSoilModel
  • Data
  • DSoilModelProject
Public Member Functions | Properties | List of all members
Deltares.DSoilModel.Data.DSoilModelProject Class Reference

D-Soil Model Project More...

Inheritance diagram for Deltares.DSoilModel.Data.DSoilModelProject:

Public Member Functions

void | ReadSoilProfiles1DFromFile (string fileName)
Reads a collection of SoilProfile1D from the given file (csv) and adds it to the project ensuring a unique name More...
SoilProfile2D | ReadGeometryFromFile (string fileName, bool skipSoilsWithSameName=false)
Reads a SoilProfile2d (geometry) from the given file (sti or geo) and adds it to the project ensuring a unique name More...
bool | ReadGefCptFromFile (string fileName)
Reads a cpt from the given GEF file and adds it to the project ensuring a unique name More...
bool | ReadGefBoringFromFile (string fileName)
Reads a boring from the given GEF file and adds it to the project ensuring a unique name More...
void | ReadSoilsFromDatabase (string fileName)
Reads soils from the given old style database and adds them to the project ensuring unique names More...
void | ReadOldProjectFromDatabase (string fileName)
Reads data from the given old style database (*.MDB, *.GDB) and adds it to the project ensuring unique names More...
IEnumerable< SoilProfile > | GetProfiles (StochasticSoilProfile profile)
Gets the profiles. More...
IEnumerable< ConePenetrationTestData > | GetCpts (ConePenetrationTestPerSegment conePenetrationTest)
Gets the CPTS. More...
IEnumerable< ConePenetrationTestData > | GetCpts (SoilSegment cpt)
Gets the CPTS. More...
IEnumerable< Boring > | GetBorings (SoilSegment boring)
Gets the borings. More...
IEnumerable< Boring > | GetBorings (BoringPerSegment boring)
Gets the borings. More...
IEnumerable< SurfaceLine2 > | GetSurfaceLines (SoilSegment surfaceLine)
Gets the surfaceLines. More...
ValidationResult[] | ValidateSpecificMechanismPointLocations ()
Validation for the specific mechanism point locations on soil profile 2D. More...
void | AddSoilDataToProject (SoilList newSoilData, bool skipSoilsWithSameName=false)
Add soil data to the project, resolving duplicate names More...
void | RepairAllValidationResults ()
Repair all validation results for which a repair option is available More...
void | UpdateLists ()
Make sure that the separate lists of Soils, SoilProfiles etc. do represent all referenced objects in the datamodel. More...
void | Dispose ()
Dispose of unmanaged resources and delegates More...
void | ActivateFirstData ()
Activates the first data. I.e. it provides a selectionchanged for the first soil or if no soil available, the first CPT. This ensures the proper selection of the data line in the table and the belonging property window. Trying to find other data than soil or CPT is useless as all other data objects should have soils. Note: it does not set the proper table! That is handled in the plugin. More...
ICollection | GetDomain (string property)
Gets the domain. More...
void | SplitSoilSegment (SoilSegment selectedSegment, double xSplit)
Split a soil segment at given relative X coordinate More...

Properties

ParameterViewSettings | ParameterView [get, set]
Currently selected (in the UI) parameter filter More...
Mechanism | CurrentFailureMechanism [get, set]
Currently selected (in the UI) failure mechanism More...
List< SoilSegment > | CurrentSoilSegments [get]
SoilSegments for the currently selected Failure mechanism More...
List< ConePenetrationTestData > | CPTs [get]
Gets the CPTs (Cone Penetration Tests). More...
List< Boring > | Borings [get]
Gets the borings. More...
SoilbaseDB | SoilbaseDb [get, set]
Gets or sets the soilbase database. More...
SoilList | Soils [get, set]
Gets or sets the soils. More...
List< SoilProfile1D > | SoilProfiles1D [get]
Gets the 1D soil profiles. More...
List< SoilProfile2D > | SoilProfiles2D [get]
Gets the 2D soil profiles. More...
List< ConePenetrationTestLookup1D > | CptLookup1Ds [get]
Gets the 1D CPT lookups. More...
List< ConePenetrationTestLookup2D > | CptLookup2Ds [get]
Gets the 2D CPT lookups. More...
List< BoringLookup1D > | BoringLookup1Ds [get]
Gets the 1D boring lookups. More...
List< BoringLookup2D > | BoringLookup2Ds [get]
Gets the 2D boring lookups. More...
List< SpecificMechanismPointLocation > | SpecificMechanismPointLocations [get]
Gets the specific mechanism point locations. These locations define a local position where a 1D soilprofile is to be extracted from a 2D profile for calculations related to a specific failure mechanism. More...
List< SoilProfile1DLookup2D > | Soilprofile1DLookup2Ds [get]
Gets the 1D to 2D lookup list. These loookups define a relative position for a 1D soil profile in a 2D soil profile, More...
List< SoilSegment > | SoilSegments [get]
Gets the soil segments. More...
List< SurfaceLine2 > | SurfaceLines [get]
Gets the surface lines. More...
List< StressCurve > | StressCurves [get]
Gets the stress curves. More...
List< BondStressCurve > | BondStressCurves [get]
Gets the bond stress curves. More...
List< DataSourceInfo > | DataSources [get, set]
Gets the list of data sources More...

Detailed Description

D-Soil Model Project

Member Function Documentation

void Deltares.DSoilModel.Data.DSoilModelProject.ActivateFirstData ( )

Activates the first data. I.e. it provides a selectionchanged for the first soil or if no soil available, the first CPT. This ensures the proper selection of the data line in the table and the belonging property window. Trying to find other data than soil or CPT is useless as all other data objects should have soils. Note: it does not set the proper table! That is handled in the plugin.

void Deltares.DSoilModel.Data.DSoilModelProject.AddSoilDataToProject | ( | SoilList | newSoilData,
 |  | bool | skipSoilsWithSameName = false
 | ) |  |

Add soil data to the project, resolving duplicate names

Parameters
newSoilData | soil data to add
skipSoilsWithSameName | determines how to handle duplicate names
void Deltares.DSoilModel.Data.DSoilModelProject.Dispose ( )

Dispose of unmanaged resources and delegates

IEnumerable<Boring> Deltares.DSoilModel.Data.DSoilModelProject.GetBorings ( SoilSegment boring )

Gets the borings.

Parameters
boring The profile.
Returns
IEnumerable<Boring> Deltares.DSoilModel.Data.DSoilModelProject.GetBorings ( BoringPerSegment boring )

Gets the borings.

Parameters
boring The profile.
Returns
IEnumerable<ConePenetrationTestData> Deltares.DSoilModel.Data.DSoilModelProject.GetCpts ( ConePenetrationTestPerSegment conePenetrationTest )

Gets the CPTS.

Parameters
conePenetrationTest The profile.
Returns
IEnumerable<ConePenetrationTestData> Deltares.DSoilModel.Data.DSoilModelProject.GetCpts ( SoilSegment cpt )

Gets the CPTS.

Parameters
cpt The cpt.
Returns
ICollection Deltares.DSoilModel.Data.DSoilModelProject.GetDomain ( string property )

Gets the domain.

Parameters
property The property.
Returns
the domain
IEnumerable<SoilProfile> Deltares.DSoilModel.Data.DSoilModelProject.GetProfiles ( StochasticSoilProfile profile )

Gets the profiles.

Parameters
profile The profile.
Returns
List of Soil Profiles
IEnumerable<SurfaceLine2> Deltares.DSoilModel.Data.DSoilModelProject.GetSurfaceLines ( SoilSegment surfaceLine )

Gets the surfaceLines.

Parameters
surfaceLine The surfaceLine.
Returns
bool Deltares.DSoilModel.Data.DSoilModelProject.ReadGefBoringFromFile ( string fileName )

Reads a boring from the given GEF file and adds it to the project ensuring a unique name

Parameters
fileName
bool Deltares.DSoilModel.Data.DSoilModelProject.ReadGefCptFromFile ( string fileName )

Reads a cpt from the given GEF file and adds it to the project ensuring a unique name

Parameters
fileName
SoilProfile2D Deltares.DSoilModel.Data.DSoilModelProject.ReadGeometryFromFile | ( | string | fileName,
 |  | bool | skipSoilsWithSameName = false
 | ) |  |

Reads a SoilProfile2d (geometry) from the given file (sti or geo) and adds it to the project ensuring a unique name

Parameters
fileName | file name (*.sti, *.geo)
skipSoilsWithSameName | Option to ignore soils with duplicate names, drequired for DAM defx import

Referenced by Deltares.DSoilModel.Data.DSoilModelIO.ReadDamDefinitionsFromFileAndAddToProject().

void Deltares.DSoilModel.Data.DSoilModelProject.ReadOldProjectFromDatabase ( string fileName )

Reads data from the given old style database (*.MDB, *.GDB) and adds it to the project ensuring unique names

Parameters
fileName

References Deltares.DSoilModel.Data.DSoilModelIO.AddOldProjectDataBaseToProject().

void Deltares.DSoilModel.Data.DSoilModelProject.ReadSoilProfiles1DFromFile ( string fileName )

Reads a collection of SoilProfile1D from the given file (csv) and adds it to the project ensuring a unique name

Parameters
fileName

Referenced by Deltares.DSoilModel.Data.DSoilModelIO.ReadDamDefinitionsFromFileAndAddToProject().

void Deltares.DSoilModel.Data.DSoilModelProject.ReadSoilsFromDatabase ( string fileName )

Reads soils from the given old style database and adds them to the project ensuring unique names

Parameters
fileName

References Deltares.DSoilModel.Data.DSoilModelIO.AddOldSoilDBToProject().

void Deltares.DSoilModel.Data.DSoilModelProject.RepairAllValidationResults ( )

Repair all validation results for which a repair option is available

References Deltares.Standard.Forms.RealTimeBackgroundValidator.Instance, Deltares.Standard.Forms.RealTimeBackgroundValidator.Start(), and Deltares.Standard.Forms.RealTimeBackgroundValidator.Stop().

void Deltares.DSoilModel.Data.DSoilModelProject.SplitSoilSegment | ( | SoilSegment | selectedSegment,
 |  | double | xSplit
 | ) |  |

Split a soil segment at given relative X coordinate

Parameters
selectedSegment | The segment to split
xSplit | Local X coordinate

Referenced by Deltares.DSoilModel.Forms.DSoilModelMapEditor.SplitSegment(), and Deltares.DSoilModel.Forms.DSoilModelMapEditor.SplitSegmentLocation().

void Deltares.DSoilModel.Data.DSoilModelProject.UpdateLists ( )

Make sure that the separate lists of Soils, SoilProfiles etc. do represent all referenced objects in the datamodel.

ValidationResult [] Deltares.DSoilModel.Data.DSoilModelProject.ValidateSpecificMechanismPointLocations ( )

Validation for the specific mechanism point locations on soil profile 2D.

Property Documentation

List<BondStressCurve> Deltares.DSoilModel.Data.DSoilModelProject.BondStressCurves
get

Gets the bond stress curves.

The bond stress curves.

List<BoringLookup1D> Deltares.DSoilModel.Data.DSoilModelProject.BoringLookup1Ds
get

Gets the 1D boring lookups.

The 1D boring lookups.

List<BoringLookup2D> Deltares.DSoilModel.Data.DSoilModelProject.BoringLookup2Ds
get

Gets the 2D boring lookups.

The 2D boring lookups.

List<Boring> Deltares.DSoilModel.Data.DSoilModelProject.Borings
get

Gets the borings.

The borings.

List<ConePenetrationTestLookup1D> Deltares.DSoilModel.Data.DSoilModelProject.CptLookup1Ds
get

Gets the 1D CPT lookups.

The 1D CPT lookups.

List<ConePenetrationTestLookup2D> Deltares.DSoilModel.Data.DSoilModelProject.CptLookup2Ds
get

Gets the 2D CPT lookups.

The 2D CPT lookups.

List<ConePenetrationTestData> Deltares.DSoilModel.Data.DSoilModelProject.CPTs
get

Gets the CPTs (Cone Penetration Tests).

The CPTs.

Mechanism Deltares.DSoilModel.Data.DSoilModelProject.CurrentFailureMechanism
getset

Currently selected (in the UI) failure mechanism

List<SoilSegment> Deltares.DSoilModel.Data.DSoilModelProject.CurrentSoilSegments
get

SoilSegments for the currently selected Failure mechanism

List<DataSourceInfo> Deltares.DSoilModel.Data.DSoilModelProject.DataSources
getset

Gets the list of data sources

ParameterViewSettings Deltares.DSoilModel.Data.DSoilModelProject.ParameterView
getset

Currently selected (in the UI) parameter filter

SoilbaseDB Deltares.DSoilModel.Data.DSoilModelProject.SoilbaseDb
getset

Gets or sets the soilbase database.

The soilbase database.

List<SoilProfile1DLookup2D> Deltares.DSoilModel.Data.DSoilModelProject.Soilprofile1DLookup2Ds
get

Gets the 1D to 2D lookup list. These loookups define a relative position for a 1D soil profile in a 2D soil profile,

List<SoilProfile1D> Deltares.DSoilModel.Data.DSoilModelProject.SoilProfiles1D
get

Gets the 1D soil profiles.

The 1D soil profiles.

Referenced by Deltares.DSoilModel.Data.DSoilModelIO.ReadCsvSegmentsFromFileAndAddToProject(), and Deltares.DSoilModel.Data.DSoilModelIO.ReadDamDefinitionsFromFileAndAddToProject().

List<SoilProfile2D> Deltares.DSoilModel.Data.DSoilModelProject.SoilProfiles2D
get

Gets the 2D soil profiles.

The 2D soil profiles.

Referenced by Deltares.DSoilModel.Data.DSoilModelIO.ReadCsvSegmentsFromFileAndAddToProject(), and Deltares.DSoilModel.Data.DSoilModelIO.ReadDamDefinitionsFromFileAndAddToProject().

SoilList Deltares.DSoilModel.Data.DSoilModelProject.Soils
getset

Gets or sets the soils.

The soils.

Referenced by Deltares.DSoilModel.Data.DSoilModelIO.ReadDamDefinitionsFromFileAndAddToProject().

List<SoilSegment> Deltares.DSoilModel.Data.DSoilModelProject.SoilSegments
get

Gets the soil segments.

The soil segments.

Referenced by Deltares.DSoilModel.Data.DSoilModelIO.ReadDamDefinitionsFromFileAndAddToProject().

List<SpecificMechanismPointLocation> Deltares.DSoilModel.Data.DSoilModelProject.SpecificMechanismPointLocations
get

Gets the specific mechanism point locations. These locations define a local position where a 1D soilprofile is to be extracted from a 2D profile for calculations related to a specific failure mechanism.

List<StressCurve> Deltares.DSoilModel.Data.DSoilModelProject.StressCurves
get

Gets the stress curves.

The stress curves.

List<SurfaceLine2> Deltares.DSoilModel.Data.DSoilModelProject.SurfaceLines
get

Gets the surface lines.

The surface lines.

Referenced by Deltares.DSoilModel.Forms.DSoilModelGeometryEditor.AddSurfaceLineToCreateNew2DProfile(), Deltares.DSoilModel.Data.DSoilModelIO.ReadCsvCharacteristicPointsFromFileAndAddToProject(), and Deltares.DSoilModel.Data.DSoilModelIO.ReadDamDefinitionsFromFileAndAddToProject().

Generated on Tue Dec 15 2015 18:13:48 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • DSoilModel
  • Data
  • DSoilModelProject
Deltares.DSoilModel.Data.DSoilModelProject Member List

This is the complete list of members for Deltares.DSoilModel.Data.DSoilModelProject, including all inherited members.

ActivateFirstData() | Deltares.DSoilModel.Data.DSoilModelProject
AddSoilDataToProject(SoilList newSoilData, bool skipSoilsWithSameName=false) | Deltares.DSoilModel.Data.DSoilModelProject
BondStressCurves | Deltares.DSoilModel.Data.DSoilModelProject
BoringLookup1Ds | Deltares.DSoilModel.Data.DSoilModelProject
BoringLookup2Ds | Deltares.DSoilModel.Data.DSoilModelProject
Borings | Deltares.DSoilModel.Data.DSoilModelProject
CptLookup1Ds | Deltares.DSoilModel.Data.DSoilModelProject
CptLookup2Ds | Deltares.DSoilModel.Data.DSoilModelProject
CPTs | Deltares.DSoilModel.Data.DSoilModelProject
CurrentFailureMechanism | Deltares.DSoilModel.Data.DSoilModelProject
CurrentSoilSegments | Deltares.DSoilModel.Data.DSoilModelProject
DataSources | Deltares.DSoilModel.Data.DSoilModelProject
Dispose() | Deltares.DSoilModel.Data.DSoilModelProject
DSoilModelProject() (defined in Deltares.DSoilModel.Data.DSoilModelProject) | Deltares.DSoilModel.Data.DSoilModelProject
GetBorings(SoilSegment boring) | Deltares.DSoilModel.Data.DSoilModelProject
GetBorings(BoringPerSegment boring) | Deltares.DSoilModel.Data.DSoilModelProject
GetCpts(ConePenetrationTestPerSegment conePenetrationTest) | Deltares.DSoilModel.Data.DSoilModelProject
GetCpts(SoilSegment cpt) | Deltares.DSoilModel.Data.DSoilModelProject
GetDomain(string property) | Deltares.DSoilModel.Data.DSoilModelProject
GetProfiles(StochasticSoilProfile profile) | Deltares.DSoilModel.Data.DSoilModelProject
GetSurfaceLines(SoilSegment surfaceLine) | Deltares.DSoilModel.Data.DSoilModelProject
ParameterView | Deltares.DSoilModel.Data.DSoilModelProject
ReadGefBoringFromFile(string fileName) | Deltares.DSoilModel.Data.DSoilModelProject
ReadGefCptFromFile(string fileName) | Deltares.DSoilModel.Data.DSoilModelProject
ReadGeometryFromFile(string fileName, bool skipSoilsWithSameName=false) | Deltares.DSoilModel.Data.DSoilModelProject
ReadOldProjectFromDatabase(string fileName) | Deltares.DSoilModel.Data.DSoilModelProject
ReadSoilProfiles1DFromFile(string fileName) | Deltares.DSoilModel.Data.DSoilModelProject
ReadSoilsFromDatabase(string fileName) | Deltares.DSoilModel.Data.DSoilModelProject
RepairAllValidationResults() | Deltares.DSoilModel.Data.DSoilModelProject
SoilbaseDb | Deltares.DSoilModel.Data.DSoilModelProject
Soilprofile1DLookup2Ds | Deltares.DSoilModel.Data.DSoilModelProject
SoilProfiles1D | Deltares.DSoilModel.Data.DSoilModelProject
SoilProfiles2D | Deltares.DSoilModel.Data.DSoilModelProject
Soils | Deltares.DSoilModel.Data.DSoilModelProject
SoilSegments | Deltares.DSoilModel.Data.DSoilModelProject
SpecificMechanismPointLocations | Deltares.DSoilModel.Data.DSoilModelProject
SplitSoilSegment(SoilSegment selectedSegment, double xSplit) | Deltares.DSoilModel.Data.DSoilModelProject
StressCurves | Deltares.DSoilModel.Data.DSoilModelProject
SurfaceLines | Deltares.DSoilModel.Data.DSoilModelProject
UpdateLists() | Deltares.DSoilModel.Data.DSoilModelProject
ValidateSpecificMechanismPointLocations() | Deltares.DSoilModel.Data.DSoilModelProject
Generated on Tue Dec 15 2015 18:13:48 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.DSoilModel.Data.DSoilModelStiFileTransformer Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • DSoilModel
  • Data
  • DSoilModelStiFileTransformer
Public Member Functions | List of all members
Deltares.DSoilModel.Data.DSoilModelStiFileTransformer Class Reference
Inheritance diagram for Deltares.DSoilModel.Data.DSoilModelStiFileTransformer:

Public Member Functions

double | GetTransformedValue (object owner, string property, double defaultValue)
double | SetTransformedValue (object owner, string property, double transformedValue)
Generated on Tue Dec 15 2015 18:13:48 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • DSoilModel
  • Data
  • DSoilModelStiFileTransformer
Deltares.DSoilModel.Data.DSoilModelStiFileTransformer Member List

This is the complete list of members for Deltares.DSoilModel.Data.DSoilModelStiFileTransformer, including all inherited members.

GetTransformedValue(object owner, string property, double defaultValue) (defined in Deltares.DSoilModel.Data.DSoilModelStiFileTransformer) | Deltares.DSoilModel.Data.DSoilModelStiFileTransformer
SetTransformedValue(object owner, string property, double transformedValue) (defined in Deltares.DSoilModel.Data.DSoilModelStiFileTransformer) | Deltares.DSoilModel.Data.DSoilModelStiFileTransformer
Generated on Tue Dec 15 2015 18:13:48 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.DSoilModel.Data.DSoilModelTransformer Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • DSoilModel
  • Data
  • DSoilModelTransformer
Public Member Functions | List of all members
Deltares.DSoilModel.Data.DSoilModelTransformer Class Reference
Inheritance diagram for Deltares.DSoilModel.Data.DSoilModelTransformer:

Public Member Functions

double | GetTransformedValue (object owner, string property, double measuredValue)
double | SetTransformedValue (object owner, string property, double transformedValue)
Generated on Tue Dec 15 2015 18:13:48 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • DSoilModel
  • Data
  • DSoilModelTransformer
Deltares.DSoilModel.Data.DSoilModelTransformer Member List

This is the complete list of members for Deltares.DSoilModel.Data.DSoilModelTransformer, including all inherited members.

GetTransformedValue(object owner, string property, double measuredValue) (defined in Deltares.DSoilModel.Data.DSoilModelTransformer) | Deltares.DSoilModel.Data.DSoilModelTransformer
SetTransformedValue(object owner, string property, double transformedValue) (defined in Deltares.DSoilModel.Data.DSoilModelTransformer) | Deltares.DSoilModel.Data.DSoilModelTransformer
Generated on Tue Dec 15 2015 18:13:48 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.DSoilModel.Data.SoilSegmentSplitLocation Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • DSoilModel
  • Data
  • SoilSegmentSplitLocation
Public Member Functions | Properties | List of all members
Deltares.DSoilModel.Data.SoilSegmentSplitLocation Class Reference

Class to hold the location of the proposed split of a segment. More...

Inheritance diagram for Deltares.DSoilModel.Data.SoilSegmentSplitLocation:

Public Member Functions

override void | SetCoordinate (double newX, double newY)
This method is called when the user moves a point on the map More...
override string | ToString ()

Properties

string | Name [get, set]
double | XCoordinate [get, set]
Gets or sets the relative x coordinate of the split location along the segment line. More...
SoilProfile2D | SoilProfile2D [get, set]
Gets or sets the Soil Profile 2D (UI element used by DSoilModelGeometryEditor). More...
SoilSegment | SoilSegment [get, set]
Gets or sets the Soil Profile 2D (UI element used by DSoilModelGeometryEditor). More...

Detailed Description

Class to hold the location of the proposed split of a segment.

Member Function Documentation

override void Deltares.DSoilModel.Data.SoilSegmentSplitLocation.SetCoordinate | ( | double | newX,
 |  | double | newY
 | ) |  |

This method is called when the user moves a point on the map

Parameters
newX | X
newY | Y

Property Documentation

SoilProfile2D Deltares.DSoilModel.Data.SoilSegmentSplitLocation.SoilProfile2D
getset

Gets or sets the Soil Profile 2D (UI element used by DSoilModelGeometryEditor).

Referenced by Deltares.DSoilModel.Forms.DrawingSoilSegmentSplitLocation.BottomForDrawing(), Deltares.DSoilModel.Forms.DrawingSoilSegmentSplitLocation.TopForDrawing(), and Deltares.DSoilModel.Forms.DrawingSoilSegmentSplitLocation.WidthForDrawing().

SoilSegment Deltares.DSoilModel.Data.SoilSegmentSplitLocation.SoilSegment
getset

Gets or sets the Soil Profile 2D (UI element used by DSoilModelGeometryEditor).

double Deltares.DSoilModel.Data.SoilSegmentSplitLocation.XCoordinate
getset

Gets or sets the relative x coordinate of the split location along the segment line.

Referenced by Deltares.DSoilModel.Forms.DrawingSoilSegmentSplitLocation.Draw3D(), Deltares.DSoilModel.Forms.DrawingSoilSegmentSplitLocation.OnEndDrag(), Deltares.DSoilModel.Forms.DrawingSoilSegmentSplitLocation.SetDataObject(), and Deltares.DSoilModel.Forms.DrawingSoilSegmentSplitLocation.UpdateDataDragDrop().

Generated on Tue Dec 15 2015 18:13:49 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • DSoilModel
  • Data
  • SoilSegmentSplitLocation
Deltares.DSoilModel.Data.SoilSegmentSplitLocation Member List

This is the complete list of members for Deltares.DSoilModel.Data.SoilSegmentSplitLocation, including all inherited members.

Name (defined in Deltares.DSoilModel.Data.SoilSegmentSplitLocation) | Deltares.DSoilModel.Data.SoilSegmentSplitLocation
SetCoordinate(double newX, double newY) | Deltares.DSoilModel.Data.SoilSegmentSplitLocation
SoilProfile2D | Deltares.DSoilModel.Data.SoilSegmentSplitLocation
SoilSegment | Deltares.DSoilModel.Data.SoilSegmentSplitLocation
ToString() (defined in Deltares.DSoilModel.Data.SoilSegmentSplitLocation) | Deltares.DSoilModel.Data.SoilSegmentSplitLocation
XCoordinate | Deltares.DSoilModel.Data.SoilSegmentSplitLocation
Generated on Tue Dec 15 2015 18:13:49 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.DSoilModel.Data.SosDeltaModelDatabase Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • DSoilModel
  • Data
  • SosDeltaModelDatabase
Deltares.DSoilModel.Data.SosDeltaModelDatabase Class Reference

Derived Version of GeoTechnics.IO.DeltaModelDatabase, providing access to WTI-SOS specific data More...

Inheritance diagram for Deltares.DSoilModel.Data.SosDeltaModelDatabase:

Detailed Description

Derived Version of GeoTechnics.IO.DeltaModelDatabase, providing access to WTI-SOS specific data

See also
SosSoilLayer1D
Generated on Tue Dec 15 2015 18:13:49 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.DSoilModel.Data.SosSoilLayer1D Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • DSoilModel
  • Data
  • SosSoilLayer1D
Public Member Functions | Properties | List of all members
Deltares.DSoilModel.Data.SosSoilLayer1D Class Reference
Inheritance diagram for Deltares.DSoilModel.Data.SosSoilLayer1D:

Public Member Functions

override object | Clone ()
Clones this instance. More...
virtual void | Assign (SosSoilLayer1D layer)
Assigns the specified layer. More...

Properties

double | MaximumTopLevel [get, set]
Gets or sets the maximum top level. More...
double | MinimumTopLevel [get, set]
Gets or sets the minimum top level. More...
string | RemarkTopLevel [get, set]
Gets or sets the remark top level. More...

Member Function Documentation

virtual void Deltares.DSoilModel.Data.SosSoilLayer1D.Assign ( SosSoilLayer1D layer )
virtual

Assigns the specified layer.

Parameters
layer The layer.
override object Deltares.DSoilModel.Data.SosSoilLayer1D.Clone ( )

Clones this instance.

Returns
Clone of this instance

Property Documentation

double Deltares.DSoilModel.Data.SosSoilLayer1D.MaximumTopLevel
getset

Gets or sets the maximum top level.

The maximum top level.

double Deltares.DSoilModel.Data.SosSoilLayer1D.MinimumTopLevel
getset

Gets or sets the minimum top level.

The minimum top level.

string Deltares.DSoilModel.Data.SosSoilLayer1D.RemarkTopLevel
getset

Gets or sets the remark top level.

The remark top level.

Generated on Tue Dec 15 2015 18:13:49 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • DSoilModel
  • Data
  • SosSoilLayer1D
Deltares.DSoilModel.Data.SosSoilLayer1D Member List

This is the complete list of members for Deltares.DSoilModel.Data.SosSoilLayer1D, including all inherited members.

Assign(SosSoilLayer1D layer) | Deltares.DSoilModel.Data.SosSoilLayer1D | virtual
Clone() | Deltares.DSoilModel.Data.SosSoilLayer1D |
MaximumTopLevel | Deltares.DSoilModel.Data.SosSoilLayer1D |
MinimumTopLevel | Deltares.DSoilModel.Data.SosSoilLayer1D |
RemarkTopLevel | Deltares.DSoilModel.Data.SosSoilLayer1D |
Generated on Tue Dec 15 2015 18:13:49 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.DSoilModel.Data.SosSoilProfilesImporter Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • DSoilModel
  • Data
  • SosSoilProfilesImporter
Protected Member Functions | List of all members
Deltares.DSoilModel.Data.SosSoilProfilesImporter Class Reference
Inheritance diagram for Deltares.DSoilModel.Data.SosSoilProfilesImporter:
Deltares.Geotechnics.IO.Importers.SoilProfilesImporter

Protected Member Functions

override List< SoilProfile1D > | ReadSoilProfiles (string fileName, SoilList soils, IDataFactory factory)
Read soil profiles using SOSSoilLayer1D instead of SoilLayer1D, referencing soils in the provided list or using a factory to get the referenced soils. More...
- Protected Member Functions inherited from Deltares.Geotechnics.IO.Importers.SoilProfilesImporter
Soil | GetSoil (List< Soil > soils, string name)

Additional Inherited Members

- Public Member Functions inherited from Deltares.Geotechnics.IO.Importers.SoilProfilesImporter
List< SoilProfile1D > | ReadSoilProfiles (string fileName, SoilList soils)
Read soil profiles, referencing soils in the provided list More...
override void | Import ()
Standard Importer interface to import file after setting the FileName and Factory properties More...
- Static Protected Member Functions inherited from Deltares.Geotechnics.IO.Importers.SoilProfilesImporter
static void | CheckColumn (int index, string fileName, string fieldName)

Member Function Documentation

override List<SoilProfile1D> Deltares.DSoilModel.Data.SosSoilProfilesImporter.ReadSoilProfiles | ( | string | fileName,
 |  | SoilList | soils,
 |  | IDataFactory | factory
 | ) |  |
protectedvirtual

Read soil profiles using SOSSoilLayer1D instead of SoilLayer1D, referencing soils in the provided list or using a factory to get the referenced soils.

Parameters
fileName | path of the file to import
soils | list of available soil materials to reference
factory
Returns
List of SoilProfile1D objects

Reimplemented from Deltares.Geotechnics.IO.Importers.SoilProfilesImporter.

References Deltares.Geotechnics.SoilProfile1D.Layers.

Generated on Tue Dec 15 2015 18:13:49 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • DSoilModel
  • Data
  • SosSoilProfilesImporter
Deltares.DSoilModel.Data.SosSoilProfilesImporter Member List

This is the complete list of members for Deltares.DSoilModel.Data.SosSoilProfilesImporter, including all inherited members.

CheckColumn(int index, string fileName, string fieldName) (defined in Deltares.Geotechnics.IO.Importers.SoilProfilesImporter) | Deltares.Geotechnics.IO.Importers.SoilProfilesImporter | protectedstatic
GetSoil(List< Soil > soils, string name) (defined in Deltares.Geotechnics.IO.Importers.SoilProfilesImporter) | Deltares.Geotechnics.IO.Importers.SoilProfilesImporter | protected
Import() | Deltares.Geotechnics.IO.Importers.SoilProfilesImporter |
ReadSoilProfiles(string fileName, SoilList soils, IDataFactory factory) | Deltares.DSoilModel.Data.SosSoilProfilesImporter | protectedvirtual
Deltares::Geotechnics::IO::Importers::SoilProfilesImporter.ReadSoilProfiles(string fileName, SoilList soils) | Deltares.Geotechnics.IO.Importers.SoilProfilesImporter |
Generated on Tue Dec 15 2015 18:13:49 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.DSoilModel.Forms.Properties.Resources Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • DSoilModel
  • Forms
  • Properties
  • Resources
Properties | List of all members
Deltares.DSoilModel.Forms.Properties.Resources Class Reference

A strongly-typed resource class, for looking up localized strings, etc. More...

Properties

static global::System.Resources.ResourceManager | ResourceManager [get]
Returns the cached ResourceManager instance used by this class. More...
static global::System.Globalization.CultureInfo | Culture [get, set]
Overrides the current thread's CurrentUICulture property for all resource lookups using this strongly typed resource class. More...
static System.Drawing.Bitmap | Boring [get]
Looks up a localized resource of type System.Drawing.Bitmap. More...
static System.Drawing.Bitmap | CPT [get]
Looks up a localized resource of type System.Drawing.Bitmap. More...
static System.Drawing.Bitmap | CreatePointInLine [get]
Looks up a localized resource of type System.Drawing.Bitmap. More...
static System.Drawing.Bitmap | CreatePolyline [get]
Looks up a localized resource of type System.Drawing.Bitmap. More...
static System.Drawing.Bitmap | csNotRes [get]
Looks up a localized resource of type System.Drawing.Bitmap. More...
static System.Drawing.Bitmap | csNotRes_Approved [get]
Looks up a localized resource of type System.Drawing.Bitmap. More...
static System.Drawing.Bitmap | csNotRes_ApprovedEarlier [get]
Looks up a localized resource of type System.Drawing.Bitmap. More...
static System.Drawing.Bitmap | csNotRes_NotCalculated [get]
Looks up a localized resource of type System.Drawing.Bitmap. More...
static System.Drawing.Bitmap | csNotRes_Rejected [get]
Looks up a localized resource of type System.Drawing.Bitmap. More...
static System.Drawing.Bitmap | dinocpt2b [get]
Looks up a localized resource of type System.Drawing.Bitmap. More...
static System.Drawing.Bitmap | dinocpt2b1 [get]
Looks up a localized resource of type System.Drawing.Bitmap. More...
static System.Drawing.Bitmap | dinocpt2b2 [get]
Looks up a localized resource of type System.Drawing.Bitmap. More...
static System.Drawing.Bitmap | dinocpt2b3 [get]
Looks up a localized resource of type System.Drawing.Bitmap. More...
static System.Drawing.Bitmap | drillicon1 [get]
Looks up a localized resource of type System.Drawing.Bitmap. More...
static System.Drawing.Bitmap | drillicon11 [get]
Looks up a localized resource of type System.Drawing.Bitmap. More...
static System.Drawing.Bitmap | drillicon12 [get]
Looks up a localized resource of type System.Drawing.Bitmap. More...
static System.Drawing.Bitmap | drillicon13 [get]
Looks up a localized resource of type System.Drawing.Bitmap. More...
static System.Drawing.Bitmap | drillicon14 [get]
Looks up a localized resource of type System.Drawing.Bitmap. More...
static System.Drawing.Bitmap | drillicon2 [get]
Looks up a localized resource of type System.Drawing.Bitmap. More...
static System.Drawing.Bitmap | drillicon3 [get]
Looks up a localized resource of type System.Drawing.Bitmap. More...
static System.Drawing.Bitmap | drillicon4 [get]
Looks up a localized resource of type System.Drawing.Bitmap. More...
static System.Drawing.Bitmap | EmptyThumbnail [get]
Looks up a localized resource of type System.Drawing.Bitmap. More...
static System.Drawing.Bitmap | hydraulicboundary [get]
Looks up a localized resource of type System.Drawing.Bitmap. More...
static System.Drawing.Bitmap | Point_grey [get]
Looks up a localized resource of type System.Drawing.Bitmap. More...
static System.Drawing.Bitmap | SoilProfile [get]
Looks up a localized resource of type System.Drawing.Bitmap. More...
static System.Drawing.Bitmap | soilprofile2d [get]
Looks up a localized resource of type System.Drawing.Bitmap. More...
static System.Drawing.Bitmap | SplitPoint [get]
Looks up a localized resource of type System.Drawing.Bitmap. More...
static System.Drawing.Bitmap | SplitSegment [get]
Looks up a localized resource of type System.Drawing.Bitmap. More...
static System.Drawing.Bitmap | structure_00 [get]
Looks up a localized resource of type System.Drawing.Bitmap. More...
static System.Drawing.Bitmap | structure_01 [get]
Looks up a localized resource of type System.Drawing.Bitmap. More...
static System.Drawing.Bitmap | structure_02 [get]
Looks up a localized resource of type System.Drawing.Bitmap. More...
static System.Drawing.Bitmap | structure_03 [get]
Looks up a localized resource of type System.Drawing.Bitmap. More...
static System.Drawing.Bitmap | structure_04 [get]
Looks up a localized resource of type System.Drawing.Bitmap. More...
static System.Drawing.Bitmap | structure_05 [get]
Looks up a localized resource of type System.Drawing.Bitmap. More...
static System.Drawing.Bitmap | structure_06 [get]
Looks up a localized resource of type System.Drawing.Bitmap. More...
static System.Drawing.Bitmap | structure_07 [get]
Looks up a localized resource of type System.Drawing.Bitmap. More...
static System.Drawing.Bitmap | structure_08 [get]
Looks up a localized resource of type System.Drawing.Bitmap. More...
static System.Drawing.Bitmap | structure_09 [get]
Looks up a localized resource of type System.Drawing.Bitmap. More...
static System.Drawing.Bitmap | structure_approved_earlier [get]
Looks up a localized resource of type System.Drawing.Bitmap. More...
static System.Drawing.Bitmap | structure_not_calculated [get]
Looks up a localized resource of type System.Drawing.Bitmap. More...

Detailed Description

A strongly-typed resource class, for looking up localized strings, etc.

Property Documentation

System.Drawing.Bitmap Deltares.DSoilModel.Forms.Properties.Resources.Boring
staticget

Looks up a localized resource of type System.Drawing.Bitmap.

Referenced by Deltares.DSoilModel.Forms.DSoilModelMapEditor.DSoilModelMapEditor().

System.Drawing.Bitmap Deltares.DSoilModel.Forms.Properties.Resources.CPT
staticget

Looks up a localized resource of type System.Drawing.Bitmap.

Referenced by Deltares.DSoilModel.Forms.DSoilModelMapEditor.DSoilModelMapEditor().

System.Drawing.Bitmap Deltares.DSoilModel.Forms.Properties.Resources.CreatePointInLine
staticget

Looks up a localized resource of type System.Drawing.Bitmap.

System.Drawing.Bitmap Deltares.DSoilModel.Forms.Properties.Resources.CreatePolyline
staticget

Looks up a localized resource of type System.Drawing.Bitmap.

System.Drawing.Bitmap Deltares.DSoilModel.Forms.Properties.Resources.csNotRes
staticget

Looks up a localized resource of type System.Drawing.Bitmap.

System.Drawing.Bitmap Deltares.DSoilModel.Forms.Properties.Resources.csNotRes_Approved
staticget

Looks up a localized resource of type System.Drawing.Bitmap.

System.Drawing.Bitmap Deltares.DSoilModel.Forms.Properties.Resources.csNotRes_ApprovedEarlier
staticget

Looks up a localized resource of type System.Drawing.Bitmap.

System.Drawing.Bitmap Deltares.DSoilModel.Forms.Properties.Resources.csNotRes_NotCalculated
staticget

Looks up a localized resource of type System.Drawing.Bitmap.

System.Drawing.Bitmap Deltares.DSoilModel.Forms.Properties.Resources.csNotRes_Rejected
staticget

Looks up a localized resource of type System.Drawing.Bitmap.

global.System.Globalization.CultureInfo Deltares.DSoilModel.Forms.Properties.Resources.Culture
staticgetset

Overrides the current thread's CurrentUICulture property for all resource lookups using this strongly typed resource class.

System.Drawing.Bitmap Deltares.DSoilModel.Forms.Properties.Resources.dinocpt2b
staticget

Looks up a localized resource of type System.Drawing.Bitmap.

System.Drawing.Bitmap Deltares.DSoilModel.Forms.Properties.Resources.dinocpt2b1
staticget

Looks up a localized resource of type System.Drawing.Bitmap.

System.Drawing.Bitmap Deltares.DSoilModel.Forms.Properties.Resources.dinocpt2b2
staticget

Looks up a localized resource of type System.Drawing.Bitmap.

System.Drawing.Bitmap Deltares.DSoilModel.Forms.Properties.Resources.dinocpt2b3
staticget

Looks up a localized resource of type System.Drawing.Bitmap.

System.Drawing.Bitmap Deltares.DSoilModel.Forms.Properties.Resources.drillicon1
staticget

Looks up a localized resource of type System.Drawing.Bitmap.

System.Drawing.Bitmap Deltares.DSoilModel.Forms.Properties.Resources.drillicon11
staticget

Looks up a localized resource of type System.Drawing.Bitmap.

System.Drawing.Bitmap Deltares.DSoilModel.Forms.Properties.Resources.drillicon12
staticget

Looks up a localized resource of type System.Drawing.Bitmap.

System.Drawing.Bitmap Deltares.DSoilModel.Forms.Properties.Resources.drillicon13
staticget

Looks up a localized resource of type System.Drawing.Bitmap.

System.Drawing.Bitmap Deltares.DSoilModel.Forms.Properties.Resources.drillicon14
staticget

Looks up a localized resource of type System.Drawing.Bitmap.

System.Drawing.Bitmap Deltares.DSoilModel.Forms.Properties.Resources.drillicon2
staticget

Looks up a localized resource of type System.Drawing.Bitmap.

System.Drawing.Bitmap Deltares.DSoilModel.Forms.Properties.Resources.drillicon3
staticget

Looks up a localized resource of type System.Drawing.Bitmap.

System.Drawing.Bitmap Deltares.DSoilModel.Forms.Properties.Resources.drillicon4
staticget

Looks up a localized resource of type System.Drawing.Bitmap.

System.Drawing.Bitmap Deltares.DSoilModel.Forms.Properties.Resources.EmptyThumbnail
staticget

Looks up a localized resource of type System.Drawing.Bitmap.

System.Drawing.Bitmap Deltares.DSoilModel.Forms.Properties.Resources.hydraulicboundary
staticget

Looks up a localized resource of type System.Drawing.Bitmap.

System.Drawing.Bitmap Deltares.DSoilModel.Forms.Properties.Resources.Point_grey
staticget

Looks up a localized resource of type System.Drawing.Bitmap.

global.System.Resources.ResourceManager Deltares.DSoilModel.Forms.Properties.Resources.ResourceManager
staticget

Returns the cached ResourceManager instance used by this class.

System.Drawing.Bitmap Deltares.DSoilModel.Forms.Properties.Resources.SoilProfile
staticget

Looks up a localized resource of type System.Drawing.Bitmap.

Referenced by Deltares.DSoilModel.Forms.DSoilModelMapEditor.DSoilModelMapEditor().

System.Drawing.Bitmap Deltares.DSoilModel.Forms.Properties.Resources.soilprofile2d
staticget

Looks up a localized resource of type System.Drawing.Bitmap.

System.Drawing.Bitmap Deltares.DSoilModel.Forms.Properties.Resources.SplitPoint
staticget

Looks up a localized resource of type System.Drawing.Bitmap.

System.Drawing.Bitmap Deltares.DSoilModel.Forms.Properties.Resources.SplitSegment
staticget

Looks up a localized resource of type System.Drawing.Bitmap.

Referenced by Deltares.DSoilModel.Forms.DSoilModelMapEditor.DSoilModelMapEditor().

System.Drawing.Bitmap Deltares.DSoilModel.Forms.Properties.Resources.structure_00
staticget

Looks up a localized resource of type System.Drawing.Bitmap.

System.Drawing.Bitmap Deltares.DSoilModel.Forms.Properties.Resources.structure_01
staticget

Looks up a localized resource of type System.Drawing.Bitmap.

System.Drawing.Bitmap Deltares.DSoilModel.Forms.Properties.Resources.structure_02
staticget

Looks up a localized resource of type System.Drawing.Bitmap.

System.Drawing.Bitmap Deltares.DSoilModel.Forms.Properties.Resources.structure_03
staticget

Looks up a localized resource of type System.Drawing.Bitmap.

System.Drawing.Bitmap Deltares.DSoilModel.Forms.Properties.Resources.structure_04
staticget

Looks up a localized resource of type System.Drawing.Bitmap.

System.Drawing.Bitmap Deltares.DSoilModel.Forms.Properties.Resources.structure_05
staticget

Looks up a localized resource of type System.Drawing.Bitmap.

System.Drawing.Bitmap Deltares.DSoilModel.Forms.Properties.Resources.structure_06
staticget

Looks up a localized resource of type System.Drawing.Bitmap.

System.Drawing.Bitmap Deltares.DSoilModel.Forms.Properties.Resources.structure_07
staticget

Looks up a localized resource of type System.Drawing.Bitmap.

System.Drawing.Bitmap Deltares.DSoilModel.Forms.Properties.Resources.structure_08
staticget

Looks up a localized resource of type System.Drawing.Bitmap.

System.Drawing.Bitmap Deltares.DSoilModel.Forms.Properties.Resources.structure_09
staticget

Looks up a localized resource of type System.Drawing.Bitmap.

System.Drawing.Bitmap Deltares.DSoilModel.Forms.Properties.Resources.structure_approved_earlier
staticget

Looks up a localized resource of type System.Drawing.Bitmap.

System.Drawing.Bitmap Deltares.DSoilModel.Forms.Properties.Resources.structure_not_calculated
staticget

Looks up a localized resource of type System.Drawing.Bitmap.

Generated on Tue Dec 15 2015 18:13:55 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • DSoilModel
  • Forms
  • Properties
  • Resources
Deltares.DSoilModel.Forms.Properties.Resources Member List

This is the complete list of members for Deltares.DSoilModel.Forms.Properties.Resources, including all inherited members.

Boring | Deltares.DSoilModel.Forms.Properties.Resources | static
CPT | Deltares.DSoilModel.Forms.Properties.Resources | static
CreatePointInLine | Deltares.DSoilModel.Forms.Properties.Resources | static
CreatePolyline | Deltares.DSoilModel.Forms.Properties.Resources | static
csNotRes | Deltares.DSoilModel.Forms.Properties.Resources | static
csNotRes_Approved | Deltares.DSoilModel.Forms.Properties.Resources | static
csNotRes_ApprovedEarlier | Deltares.DSoilModel.Forms.Properties.Resources | static
csNotRes_NotCalculated | Deltares.DSoilModel.Forms.Properties.Resources | static
csNotRes_Rejected | Deltares.DSoilModel.Forms.Properties.Resources | static
Culture | Deltares.DSoilModel.Forms.Properties.Resources | static
dinocpt2b | Deltares.DSoilModel.Forms.Properties.Resources | static
dinocpt2b1 | Deltares.DSoilModel.Forms.Properties.Resources | static
dinocpt2b2 | Deltares.DSoilModel.Forms.Properties.Resources | static
dinocpt2b3 | Deltares.DSoilModel.Forms.Properties.Resources | static
drillicon1 | Deltares.DSoilModel.Forms.Properties.Resources | static
drillicon11 | Deltares.DSoilModel.Forms.Properties.Resources | static
drillicon12 | Deltares.DSoilModel.Forms.Properties.Resources | static
drillicon13 | Deltares.DSoilModel.Forms.Properties.Resources | static
drillicon14 | Deltares.DSoilModel.Forms.Properties.Resources | static
drillicon2 | Deltares.DSoilModel.Forms.Properties.Resources | static
drillicon3 | Deltares.DSoilModel.Forms.Properties.Resources | static
drillicon4 | Deltares.DSoilModel.Forms.Properties.Resources | static
EmptyThumbnail | Deltares.DSoilModel.Forms.Properties.Resources | static
hydraulicboundary | Deltares.DSoilModel.Forms.Properties.Resources | static
Point_grey | Deltares.DSoilModel.Forms.Properties.Resources | static
ResourceManager | Deltares.DSoilModel.Forms.Properties.Resources | static
Resources() (defined in Deltares.DSoilModel.Forms.Properties.Resources) | Deltares.DSoilModel.Forms.Properties.Resources | package
SoilProfile | Deltares.DSoilModel.Forms.Properties.Resources | static
soilprofile2d | Deltares.DSoilModel.Forms.Properties.Resources | static
SplitPoint | Deltares.DSoilModel.Forms.Properties.Resources | static
SplitSegment | Deltares.DSoilModel.Forms.Properties.Resources | static
structure_00 | Deltares.DSoilModel.Forms.Properties.Resources | static
structure_01 | Deltares.DSoilModel.Forms.Properties.Resources | static
structure_02 | Deltares.DSoilModel.Forms.Properties.Resources | static
structure_03 | Deltares.DSoilModel.Forms.Properties.Resources | static
structure_04 | Deltares.DSoilModel.Forms.Properties.Resources | static
structure_05 | Deltares.DSoilModel.Forms.Properties.Resources | static
structure_06 | Deltares.DSoilModel.Forms.Properties.Resources | static
structure_07 | Deltares.DSoilModel.Forms.Properties.Resources | static
structure_08 | Deltares.DSoilModel.Forms.Properties.Resources | static
structure_09 | Deltares.DSoilModel.Forms.Properties.Resources | static
structure_approved_earlier | Deltares.DSoilModel.Forms.Properties.Resources | static
structure_not_calculated | Deltares.DSoilModel.Forms.Properties.Resources | static
Generated on Tue Dec 15 2015 18:13:55 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.DSoilModel.Forms.CenterCrestLocationPropertyControl Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • DSoilModel
  • Forms
  • CenterCrestLocationPropertyControl
Protected Member Functions | Properties | List of all members
Deltares.DSoilModel.Forms.CenterCrestLocationPropertyControl Class Reference
Inheritance diagram for Deltares.DSoilModel.Forms.CenterCrestLocationPropertyControl:

Protected Member Functions

override void Dispose (bool disposing)
Clean up any resources being used. More...

Properties

object | SelectedObject [get, set]
bool | IsVisible [get]

Member Function Documentation

override void Deltares.DSoilModel.Forms.CenterCrestLocationPropertyControl.Dispose ( bool disposing )
protected

Clean up any resources being used.

Parameters
disposing true if managed resources should be disposed; otherwise, false.
Generated on Tue Dec 15 2015 18:13:50 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • DSoilModel
  • Forms
  • CenterCrestLocationPropertyControl
Deltares.DSoilModel.Forms.CenterCrestLocationPropertyControl Member List

This is the complete list of members for Deltares.DSoilModel.Forms.CenterCrestLocationPropertyControl, including all inherited members.

CenterCrestLocationPropertyControl() (defined in Deltares.DSoilModel.Forms.CenterCrestLocationPropertyControl) | Deltares.DSoilModel.Forms.CenterCrestLocationPropertyControl |
Dispose(bool disposing) | Deltares.DSoilModel.Forms.CenterCrestLocationPropertyControl | protected
IsVisible (defined in Deltares.DSoilModel.Forms.CenterCrestLocationPropertyControl) | Deltares.DSoilModel.Forms.CenterCrestLocationPropertyControl |
SelectedObject (defined in Deltares.DSoilModel.Forms.CenterCrestLocationPropertyControl) | Deltares.DSoilModel.Forms.CenterCrestLocationPropertyControl |
Generated on Tue Dec 15 2015 18:13:50 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.DSoilModel.Forms.DrawingBoringLayer Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • DSoilModel
  • Forms
  • DrawingBoringLayer
Public Member Functions | List of all members
Deltares.DSoilModel.Forms.DrawingBoringLayer Class Reference
Inheritance diagram for Deltares.DSoilModel.Forms.DrawingBoringLayer:
Deltares.Geotechnics.Forms.DrawingLayer Deltares.Geometry.Forms.DrawingObject Deltares.Geometry.Forms.IDrawingObject Deltares.Standard.Forms.IShape

Public Member Functions

override void | SetDataObject (object dataObject)
override The SetDataObject() Method More...
override object | GetDataObject ()
override The GetDataObject() Method And Rturns DataObject of SoilSurface More...
override void | Draw3D (GraphicsInfo info)
override The Draw3D() Method More...
- Public Member Functions inherited from Deltares.Geotechnics.Forms.DrawingLayer
override void | SetDataObject (object dataObject)
override The SetDataObject() Method More...
override object | GetDataObject ()
override The GetDataObject() Method And Rturns DataObject of SoilSurface More...
override bool | AllowDrop (object data)
Boolean which indicates if other drawing objects can be dropped on given drawing objects More...
override void | Drop (object data)
Ends a drag-drop operation More...
override Rectangle | GetExtents (IProjection projection)
Returns the bounding box of the shape. More...
override bool | ContainsPoint (IProjection projection, Point point)
Determines if a given point screen coordinate is within the drawing object. More...
override void | Draw3D (GraphicsInfo info)
override The Draw3D() Method More...
override void | DrawLabel (GraphicsInfo info)
Renders a label or tooltip to provide some information in text for this object. More...
- Public Member Functions inherited from Deltares.Geometry.Forms.DrawingObject
Point3D | GetScaled3DPoint (IProjection projection, Point3D aOrginalPoint)
Converts the 3DPoint to screen coordinates More...
Point3D | GetScreenPoint (IProjection projection, Point2D orginalPoint)
Converts Point from 3D space to screen coordinates, assuming Y = 0 More...
Point3D | GetScreenPoint (IProjection projection, Point3D orginalPoint)
Converts Point from 3D space to screen coordinates More...
Point3D | GetScreenPoint (IProjection projection, double x, double z)
Converts 3D x, y coordinates to screen coordinates, assuming Y = 0 More...
override string | ToString ()
virtual void | UpdateDataDragDrop (Vector3D aVect3D, List< IDrawingObject > aDraggedObjects)
Update the position and or orientation of a drawing object as the user is dragging it. More...
virtual void | UpdateDataDragDrop (Point3D aBeginDragPoint, Vector3D vector)
Update the position and or orientation of a drawing object as the user is dragging it. More...
virtual void | OnBeginDrag (IProjection projection, Point3D aBeginDragDropPoint, bool isIndividualDrag)
Method which is called when the user initiates a drag-drop operation More...
virtual CardinalDirection | GetCardinalDirectionOnEdgeContainingPoint (Point point)
virtual void | OnDragging (IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D)
Method which is called during drag-drop operations More...
virtual void | OnEndDrag (IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D)
Method which is called when the user ends a drag-drop operation. More...
virtual bool | CheckHitForSelection (IProjection projection, Point3D point, double tolerance)
Check if given point coordinates intersect the rendered drawing object. More...
virtual double | GetStandardSize (object aDraw3DInterface, Point3D aPoint3D)
void | GetScaled3DPoint (IProjection projection, Point3D aOrginalPoint, ref Point3D aPointTobeScaled)
Converts the 3DPoint to screen coordinates More...
double | GetScaledXPoint (IProjection projection, double aOrginalCordinate)
Converts X Coordinate in 3D space to a screen X Coordinate More...
virtual void | Draw (GraphicsInfo info)
Render this object in 3D space. More...
virtual void | Move (IProjection projection, Point2D startPosition, SizeF worldSize)
virtual void | BeginMove (IProjection projection, Point2D startPosition)
virtual void | EndMove (IProjection projection, Point2D startPosition, SizeF worldSize)
virtual IEnumerable< object > | DataItemAt (Point point, Projection projection)

Additional Inherited Members

- Protected Member Functions inherited from Deltares.Geometry.Forms.DrawingObject
virtual int | GetThickness (GraphicsInfo info)
Gets the thickness in screen pixels of a drawing object. More...
- Protected Attributes inherited from Deltares.Geotechnics.Forms.DrawingLayer
GeometryPoint | insertionPoint = new GeometryPoint(0, 0, 0)
List< Point2D > | points = new List<Point2D>()
SoilLayer1D | soilLayer = null
double | width = 10
- Properties inherited from Deltares.Geotechnics.Forms.DrawingLayer
double | Width [get, set]
GeometryPoint | InsertionPoint [get, set]
- Properties inherited from Deltares.Geometry.Forms.DrawingObject
virtual bool | CanResize [get]
Boolean which indicates if a drawing object can be resized. More...
virtual bool | Selected [get, set]
Boolean which indicates if a drawing object is currently selected. More...
string | ToolTip [get]
Description which is shown as a tooltip when the mouse hovers over drawing object. More...
string | Name [get, set]
Gets or sets the name of a drawing object. More...
bool | IsVisible [get, set]
bool | HasBeenUpdated [get, set]
virtual bool | IsDragableOnReslultMode [get]
virtual int | Layer [get, set]
object | DataObject [get, set]
- Properties inherited from Deltares.Geometry.Forms.IDrawingObject
string | Name [get, set]
bool | IsVisible [get, set]
bool | HasBeenUpdated [get, set]
Gets or sets the update status of a drawing object. More...
bool | IsDragableOnReslultMode [get]
- Properties inherited from Deltares.Standard.Forms.IShape
object | DataObject [get, set]
int | Layer [get]

Member Function Documentation

override void Deltares.DSoilModel.Forms.DrawingBoringLayer.Draw3D ( GraphicsInfo info )
virtual

override The Draw3D() Method

Parameters
aDraw3D

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

References Deltares.Standard.Forms.DrawingSupport.CreateConvexPolygonBox(), Deltares.Standard.Forms.DrawingSupport.GetDarkerColor(), Deltares.Standard.Forms.DrawingSupport.Material3D(), Deltares.Standard.Forms.DrawingSupport.Pen3D(), and Deltares.Standard.Forms.DrawingSupport.SetIEPDraw3D().

override object Deltares.DSoilModel.Forms.DrawingBoringLayer.GetDataObject ( )
virtual

override The GetDataObject() Method And Rturns DataObject of SoilSurface

Returns

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

override void Deltares.DSoilModel.Forms.DrawingBoringLayer.SetDataObject ( object dataObject )
virtual

override The SetDataObject() Method

Parameters
dataObject

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

Generated on Tue Dec 15 2015 18:13:50 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • DSoilModel
  • Forms
  • DrawingBoringLayer
Deltares.DSoilModel.Forms.DrawingBoringLayer Member List

This is the complete list of members for Deltares.DSoilModel.Forms.DrawingBoringLayer, including all inherited members.

AllowDrop(object data) | Deltares.Geotechnics.Forms.DrawingLayer | virtual
BeginMove(IProjection projection, Point2D startPosition) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
CanResize | Deltares.Geometry.Forms.DrawingObject |
CheckHitForSelection(IProjection projection, Point3D point, double tolerance) | Deltares.Geometry.Forms.DrawingObject | virtual
ContainsPoint(IProjection projection, Point point) | Deltares.Geotechnics.Forms.DrawingLayer | virtual
DataItemAt(Point point, Projection projection) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
DataObject (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
Draw(GraphicsInfo info) | Deltares.Geometry.Forms.DrawingObject | virtual
Draw3D(GraphicsInfo info) | Deltares.DSoilModel.Forms.DrawingBoringLayer | virtual
DrawingLayer() (defined in Deltares.Geotechnics.Forms.DrawingLayer) | Deltares.Geotechnics.Forms.DrawingLayer |
DrawingObject() (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
DrawLabel(GraphicsInfo info) | Deltares.Geotechnics.Forms.DrawingLayer | virtual
Drop(object data) | Deltares.Geotechnics.Forms.DrawingLayer | virtual
EndMove(IProjection projection, Point2D startPosition, SizeF worldSize) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetCardinalDirectionOnEdgeContainingPoint(Point point) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetDataObject() | Deltares.DSoilModel.Forms.DrawingBoringLayer | virtual
GetExtents(IProjection projection) | Deltares.Geotechnics.Forms.DrawingLayer | virtual
GetScaled3DPoint(IProjection projection, Point3D aOrginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScaled3DPoint(IProjection projection, Point3D aOrginalPoint, ref Point3D aPointTobeScaled) | Deltares.Geometry.Forms.DrawingObject |
GetScaledXPoint(IProjection projection, double aOrginalCordinate) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, Point2D orginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, Point3D orginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, double x, double z) | Deltares.Geometry.Forms.DrawingObject |
GetStandardSize(object aDraw3DInterface, Point3D aPoint3D) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetThickness(GraphicsInfo info) | Deltares.Geometry.Forms.DrawingObject | protectedvirtual
HasBeenUpdated (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
InsertionPoint (defined in Deltares.Geotechnics.Forms.DrawingLayer) | Deltares.Geotechnics.Forms.DrawingLayer |
insertionPoint (defined in Deltares.Geotechnics.Forms.DrawingLayer) | Deltares.Geotechnics.Forms.DrawingLayer | protected
IsDragableOnReslultMode (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
IsVisible (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
Layer (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
Move(IProjection projection, Point2D startPosition, SizeF worldSize) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
Name | Deltares.Geometry.Forms.DrawingObject |
OnBeginDrag(IProjection projection, Point3D aBeginDragDropPoint, bool isIndividualDrag) | Deltares.Geometry.Forms.DrawingObject | virtual
OnDragging(IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D) | Deltares.Geometry.Forms.DrawingObject | virtual
OnEndDrag(IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D) | Deltares.Geometry.Forms.DrawingObject | virtual
points (defined in Deltares.Geotechnics.Forms.DrawingLayer) | Deltares.Geotechnics.Forms.DrawingLayer | protected
Selected | Deltares.Geometry.Forms.DrawingObject |
SetDataObject(object dataObject) | Deltares.DSoilModel.Forms.DrawingBoringLayer | virtual
ToolTip | Deltares.Geometry.Forms.DrawingObject |
ToString() (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
UpdateDataDragDrop(Vector3D aVect3D, List< IDrawingObject > aDraggedObjects) | Deltares.Geometry.Forms.DrawingObject | virtual
UpdateDataDragDrop(Point3D aBeginDragPoint, Vector3D vector) | Deltares.Geometry.Forms.DrawingObject | virtual
Width (defined in Deltares.Geotechnics.Forms.DrawingLayer) | Deltares.Geotechnics.Forms.DrawingLayer |
width (defined in Deltares.Geotechnics.Forms.DrawingLayer) | Deltares.Geotechnics.Forms.DrawingLayer | protected
Generated on Tue Dec 15 2015 18:13:50 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.DSoilModel.Forms.DrawingCenterCrestLocation Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • DSoilModel
  • Forms
  • DrawingCenterCrestLocation
Public Member Functions | Properties | List of all members
Deltares.DSoilModel.Forms.DrawingCenterCrestLocation Class Reference
Inheritance diagram for Deltares.DSoilModel.Forms.DrawingCenterCrestLocation:
Deltares.Geometry.Forms.DrawingObject Deltares.Geometry.Forms.IDrawingObject Deltares.Standard.Forms.IShape

Public Member Functions

double | TopForDrawing ()
Tops for drawing. More...
double | BottomForDrawing ()
Bottoms for drawing. More...
double | WidthForDrawing ()
Width for drawing. More...
override void | SetDataObject (object dataObject)
Sets the data object (SpecificMechanismPointLocation). More...
override object | GetDataObject ()
Gets the data object. More...
override void | Draw3D (GraphicsInfo info)
Draws the Point Location. More...
override void | DrawLabel (GraphicsInfo info)
Draws the label. More...
override void | OnBeginDrag (IProjection projection, Point3D aBeginDragDropPoint, bool isIndividualDrag)
Called when [begin drag]. More...
override void | UpdateDataDragDrop (Point3D beginDragPoint, Vector3D vector)
Updates the data drag drop. More...
override void | OnEndDrag (IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D)
Called when [end drag]. More...
override bool | ContainsPoint (IProjection projection, Point point)
Determines whether the specified projection contains the given point. More...
override Rectangle | GetExtents (IProjection projection)
Gets the extents. More...
- Public Member Functions inherited from Deltares.Geometry.Forms.DrawingObject
Point3D | GetScaled3DPoint (IProjection projection, Point3D aOrginalPoint)
Converts the 3DPoint to screen coordinates More...
Point3D | GetScreenPoint (IProjection projection, Point2D orginalPoint)
Converts Point from 3D space to screen coordinates, assuming Y = 0 More...
Point3D | GetScreenPoint (IProjection projection, Point3D orginalPoint)
Converts Point from 3D space to screen coordinates More...
Point3D | GetScreenPoint (IProjection projection, double x, double z)
Converts 3D x, y coordinates to screen coordinates, assuming Y = 0 More...
override string | ToString ()
virtual void | UpdateDataDragDrop (Vector3D aVect3D, List< IDrawingObject > aDraggedObjects)
Update the position and or orientation of a drawing object as the user is dragging it. More...
virtual CardinalDirection | GetCardinalDirectionOnEdgeContainingPoint (Point point)
virtual void | OnDragging (IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D)
Method which is called during drag-drop operations More...
virtual bool | CheckHitForSelection (IProjection projection, Point3D point, double tolerance)
Check if given point coordinates intersect the rendered drawing object. More...
virtual double | GetStandardSize (object aDraw3DInterface, Point3D aPoint3D)
void | GetScaled3DPoint (IProjection projection, Point3D aOrginalPoint, ref Point3D aPointTobeScaled)
Converts the 3DPoint to screen coordinates More...
double | GetScaledXPoint (IProjection projection, double aOrginalCordinate)
Converts X Coordinate in 3D space to a screen X Coordinate More...
virtual void | Draw (GraphicsInfo info)
Render this object in 3D space. More...
virtual void | Move (IProjection projection, Point2D startPosition, SizeF worldSize)
virtual void | BeginMove (IProjection projection, Point2D startPosition)
virtual void | EndMove (IProjection projection, Point2D startPosition, SizeF worldSize)
virtual bool | AllowDrop (object data)
Boolean which indicates if other drawing objects can be dropped on given drawing objects More...
virtual void | Drop (object data)
Ends a drag-drop operation More...
virtual IEnumerable< object > | DataItemAt (Point point, Projection projection)

Properties

bool | ShowAxes [get, set]
Gets or sets a value indicating whether the axes will be shown. More...
double | X [get]
Gets the x. More...
double | Left [get]
Gets the left. More...
double | Right [get]
Gets the right. More...
- Properties inherited from Deltares.Geometry.Forms.DrawingObject
virtual bool | CanResize [get]
Boolean which indicates if a drawing object can be resized. More...
virtual bool | Selected [get, set]
Boolean which indicates if a drawing object is currently selected. More...
string | ToolTip [get]
Description which is shown as a tooltip when the mouse hovers over drawing object. More...
string | Name [get, set]
Gets or sets the name of a drawing object. More...
bool | IsVisible [get, set]
bool | HasBeenUpdated [get, set]
virtual bool | IsDragableOnReslultMode [get]
virtual int | Layer [get, set]
object | DataObject [get, set]
- Properties inherited from Deltares.Geometry.Forms.IDrawingObject
string | Name [get, set]
bool | IsVisible [get, set]
bool | HasBeenUpdated [get, set]
Gets or sets the update status of a drawing object. More...
bool | IsDragableOnReslultMode [get]
- Properties inherited from Deltares.Standard.Forms.IShape
object | DataObject [get, set]
int | Layer [get]

Additional Inherited Members

- Protected Member Functions inherited from Deltares.Geometry.Forms.DrawingObject
virtual int GetThickness (GraphicsInfo info)
Gets the thickness in screen pixels of a drawing object. More...

Member Function Documentation

double Deltares.DSoilModel.Forms.DrawingCenterCrestLocation.BottomForDrawing ( )

Bottoms for drawing.

References Deltares.DSoilModel.Data.CenterCrestLocation.SoilProfile2D.

override bool Deltares.DSoilModel.Forms.DrawingCenterCrestLocation.ContainsPoint | ( | IProjection | projection,
 |  | Point | point
 | ) |  |
virtual

Determines whether the specified projection contains the given point.

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

override void Deltares.DSoilModel.Forms.DrawingCenterCrestLocation.Draw3D ( GraphicsInfo info )
virtual

Draws the Point Location.

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

References Deltares.DSoilModel.Data.CenterCrestLocation.Location, and Deltares.Standard.Forms.DrawingSupport.SetIEPDraw3D().

override void Deltares.DSoilModel.Forms.DrawingCenterCrestLocation.DrawLabel ( GraphicsInfo info )
virtual

Draws the label.

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

References Deltares.Standard.Forms.DrawingSupport.DrawLabelAtPoint(), Deltares.Standard.Forms.DrawingSupport.GetDarkerColor(), Deltares.Standard.Forms.DrawingSupport.GetLighterColor(), and Deltares.DSoilModel.Data.CenterCrestLocation.ToString().

override object Deltares.DSoilModel.Forms.DrawingCenterCrestLocation.GetDataObject ( )
virtual

Gets the data object.

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

override Rectangle Deltares.DSoilModel.Forms.DrawingCenterCrestLocation.GetExtents ( IProjection projection )
virtual

Gets the extents.

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

override void Deltares.DSoilModel.Forms.DrawingCenterCrestLocation.OnBeginDrag | ( | IProjection | projection,
 |  | Point3D | aBeginDragDropPoint,
 |  | bool | isIndividualDrag
 | ) |  |
virtual

Called when [begin drag].

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

override void Deltares.DSoilModel.Forms.DrawingCenterCrestLocation.OnEndDrag | ( | IProjection | projection,
 |  | Point3D | aCurrentDragPoint,
 |  | Vector3D | aVect3D
 | ) |  |
virtual

Called when [end drag].

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

References Deltares.DSoilModel.Data.CenterCrestLocation.Location.

override void Deltares.DSoilModel.Forms.DrawingCenterCrestLocation.SetDataObject ( object dataObject )
virtual

Sets the data object (SpecificMechanismPointLocation).

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

References Deltares.DSoilModel.Data.CenterCrestLocation.Location.

double Deltares.DSoilModel.Forms.DrawingCenterCrestLocation.TopForDrawing ( )

Tops for drawing.

References Deltares.DSoilModel.Data.CenterCrestLocation.SoilProfile2D.

override void Deltares.DSoilModel.Forms.DrawingCenterCrestLocation.UpdateDataDragDrop | ( | Point3D | beginDragPoint,
 |  | Vector3D | vector
 | ) |  |
virtual

Updates the data drag drop.

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

References Deltares.DSoilModel.Data.CenterCrestLocation.Location.

double Deltares.DSoilModel.Forms.DrawingCenterCrestLocation.WidthForDrawing ( )

Width for drawing.

References Deltares.DSoilModel.Data.CenterCrestLocation.SoilProfile2D.

Property Documentation

double Deltares.DSoilModel.Forms.DrawingCenterCrestLocation.Left
get

Gets the left.

double Deltares.DSoilModel.Forms.DrawingCenterCrestLocation.Right
get

Gets the right.

bool Deltares.DSoilModel.Forms.DrawingCenterCrestLocation.ShowAxes
getset

Gets or sets a value indicating whether the axes will be shown.

double Deltares.DSoilModel.Forms.DrawingCenterCrestLocation.X
get

Gets the x.

Generated on Tue Dec 15 2015 18:13:50 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • DSoilModel
  • Forms
  • DrawingCenterCrestLocation
Deltares.DSoilModel.Forms.DrawingCenterCrestLocation Member List

This is the complete list of members for Deltares.DSoilModel.Forms.DrawingCenterCrestLocation, including all inherited members.

AllowDrop(object data) | Deltares.Geometry.Forms.DrawingObject | virtual
BeginMove(IProjection projection, Point2D startPosition) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
BottomForDrawing() | Deltares.DSoilModel.Forms.DrawingCenterCrestLocation |
CanResize | Deltares.Geometry.Forms.DrawingObject |
CheckHitForSelection(IProjection projection, Point3D point, double tolerance) | Deltares.Geometry.Forms.DrawingObject | virtual
ContainsPoint(IProjection projection, Point point) | Deltares.DSoilModel.Forms.DrawingCenterCrestLocation | virtual
DataItemAt(Point point, Projection projection) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
DataObject (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
Draw(GraphicsInfo info) | Deltares.Geometry.Forms.DrawingObject | virtual
Draw3D(GraphicsInfo info) | Deltares.DSoilModel.Forms.DrawingCenterCrestLocation | virtual
DrawingObject() (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
DrawLabel(GraphicsInfo info) | Deltares.DSoilModel.Forms.DrawingCenterCrestLocation | virtual
Drop(object data) | Deltares.Geometry.Forms.DrawingObject | virtual
EndMove(IProjection projection, Point2D startPosition, SizeF worldSize) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetCardinalDirectionOnEdgeContainingPoint(Point point) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetDataObject() | Deltares.DSoilModel.Forms.DrawingCenterCrestLocation | virtual
GetExtents(IProjection projection) | Deltares.DSoilModel.Forms.DrawingCenterCrestLocation | virtual
GetScaled3DPoint(IProjection projection, Point3D aOrginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScaled3DPoint(IProjection projection, Point3D aOrginalPoint, ref Point3D aPointTobeScaled) | Deltares.Geometry.Forms.DrawingObject |
GetScaledXPoint(IProjection projection, double aOrginalCordinate) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, Point2D orginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, Point3D orginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, double x, double z) | Deltares.Geometry.Forms.DrawingObject |
GetStandardSize(object aDraw3DInterface, Point3D aPoint3D) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetThickness(GraphicsInfo info) | Deltares.Geometry.Forms.DrawingObject | protectedvirtual
HasBeenUpdated (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
IsDragableOnReslultMode (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
IsVisible (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
Layer (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
Left | Deltares.DSoilModel.Forms.DrawingCenterCrestLocation |
Move(IProjection projection, Point2D startPosition, SizeF worldSize) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
Name | Deltares.Geometry.Forms.DrawingObject |
OnBeginDrag(IProjection projection, Point3D aBeginDragDropPoint, bool isIndividualDrag) | Deltares.DSoilModel.Forms.DrawingCenterCrestLocation | virtual
OnDragging(IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D) | Deltares.Geometry.Forms.DrawingObject | virtual
OnEndDrag(IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D) | Deltares.DSoilModel.Forms.DrawingCenterCrestLocation | virtual
Right | Deltares.DSoilModel.Forms.DrawingCenterCrestLocation |
Selected | Deltares.Geometry.Forms.DrawingObject |
SetDataObject(object dataObject) | Deltares.DSoilModel.Forms.DrawingCenterCrestLocation | virtual
ShowAxes | Deltares.DSoilModel.Forms.DrawingCenterCrestLocation |
ToolTip | Deltares.Geometry.Forms.DrawingObject |
TopForDrawing() | Deltares.DSoilModel.Forms.DrawingCenterCrestLocation |
ToString() (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
UpdateDataDragDrop(Point3D beginDragPoint, Vector3D vector) | Deltares.DSoilModel.Forms.DrawingCenterCrestLocation | virtual
Deltares::Geometry::Forms::DrawingObject.UpdateDataDragDrop(Vector3D aVect3D, List< IDrawingObject > aDraggedObjects) | Deltares.Geometry.Forms.DrawingObject | virtual
WidthForDrawing() | Deltares.DSoilModel.Forms.DrawingCenterCrestLocation |
X | Deltares.DSoilModel.Forms.DrawingCenterCrestLocation |
Generated on Tue Dec 15 2015 18:13:50 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.DSoilModel.Forms.DrawingLayerObsolete Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • DSoilModel
  • Forms
  • DrawingLayerObsolete
Public Member Functions | Properties | List of all members
Deltares.DSoilModel.Forms.DrawingLayerObsolete Class Reference
Inheritance diagram for Deltares.DSoilModel.Forms.DrawingLayerObsolete:
Deltares.Geometry.Forms.DrawingObject Deltares.Geometry.Forms.IDrawingObject Deltares.Standard.Forms.IShape

Public Member Functions

override void | SetDataObject (object dataObject)
override The SetDataObject() Method More...
override object | GetDataObject ()
override The GetDataObject() Method And Rturns DataObject of SoilSurface More...
override bool | AllowDrop (object data)
Boolean which indicates if other drawing objects can be dropped on given drawing objects More...
override void | Drop (object data)
Ends a drag-drop operation More...
override Rectangle | GetExtents (IProjection projection)
Returns the bounding box of the shape. More...
override bool | ContainsPoint (IProjection projection, Point point)
Determines if a given point screen coordinate is within the drawing object. More...
override void | Draw3D (GraphicsInfo info)
override The Draw3D() Method More...
override void | DrawLabel (GraphicsInfo info)
Renders a label or tooltip to provide some information in text for this object. More...
- Public Member Functions inherited from Deltares.Geometry.Forms.DrawingObject
Point3D | GetScaled3DPoint (IProjection projection, Point3D aOrginalPoint)
Converts the 3DPoint to screen coordinates More...
Point3D | GetScreenPoint (IProjection projection, Point2D orginalPoint)
Converts Point from 3D space to screen coordinates, assuming Y = 0 More...
Point3D | GetScreenPoint (IProjection projection, Point3D orginalPoint)
Converts Point from 3D space to screen coordinates More...
Point3D | GetScreenPoint (IProjection projection, double x, double z)
Converts 3D x, y coordinates to screen coordinates, assuming Y = 0 More...
override string | ToString ()
virtual void | UpdateDataDragDrop (Vector3D aVect3D, List< IDrawingObject > aDraggedObjects)
Update the position and or orientation of a drawing object as the user is dragging it. More...
virtual void | UpdateDataDragDrop (Point3D aBeginDragPoint, Vector3D vector)
Update the position and or orientation of a drawing object as the user is dragging it. More...
virtual void | OnBeginDrag (IProjection projection, Point3D aBeginDragDropPoint, bool isIndividualDrag)
Method which is called when the user initiates a drag-drop operation More...
virtual CardinalDirection | GetCardinalDirectionOnEdgeContainingPoint (Point point)
virtual void | OnDragging (IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D)
Method which is called during drag-drop operations More...
virtual void | OnEndDrag (IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D)
Method which is called when the user ends a drag-drop operation. More...
virtual bool | CheckHitForSelection (IProjection projection, Point3D point, double tolerance)
Check if given point coordinates intersect the rendered drawing object. More...
virtual double | GetStandardSize (object aDraw3DInterface, Point3D aPoint3D)
void | GetScaled3DPoint (IProjection projection, Point3D aOrginalPoint, ref Point3D aPointTobeScaled)
Converts the 3DPoint to screen coordinates More...
double | GetScaledXPoint (IProjection projection, double aOrginalCordinate)
Converts X Coordinate in 3D space to a screen X Coordinate More...
virtual void | Draw (GraphicsInfo info)
Render this object in 3D space. More...
virtual void | Move (IProjection projection, Point2D startPosition, SizeF worldSize)
virtual void | BeginMove (IProjection projection, Point2D startPosition)
virtual void | EndMove (IProjection projection, Point2D startPosition, SizeF worldSize)
virtual IEnumerable< object > | DataItemAt (Point point, Projection projection)

Properties

double | XPosition [get, set]
double | Probability [get, set]
- Properties inherited from Deltares.Geometry.Forms.DrawingObject
virtual bool | CanResize [get]
Boolean which indicates if a drawing object can be resized. More...
virtual bool | Selected [get, set]
Boolean which indicates if a drawing object is currently selected. More...
string | ToolTip [get]
Description which is shown as a tooltip when the mouse hovers over drawing object. More...
string | Name [get, set]
Gets or sets the name of a drawing object. More...
bool | IsVisible [get, set]
bool | HasBeenUpdated [get, set]
virtual bool | IsDragableOnReslultMode [get]
virtual int | Layer [get, set]
object | DataObject [get, set]
- Properties inherited from Deltares.Geometry.Forms.IDrawingObject
string | Name [get, set]
bool | IsVisible [get, set]
bool | HasBeenUpdated [get, set]
Gets or sets the update status of a drawing object. More...
bool | IsDragableOnReslultMode [get]
- Properties inherited from Deltares.Standard.Forms.IShape
object | DataObject [get, set]
int | Layer [get]

Additional Inherited Members

- Protected Member Functions inherited from Deltares.Geometry.Forms.DrawingObject
virtual int GetThickness (GraphicsInfo info)
Gets the thickness in screen pixels of a drawing object. More...

Member Function Documentation

override bool Deltares.DSoilModel.Forms.DrawingLayerObsolete.AllowDrop ( object data )
virtual

Boolean which indicates if other drawing objects can be dropped on given drawing objects

Parameters
data
Returns

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

override bool Deltares.DSoilModel.Forms.DrawingLayerObsolete.ContainsPoint | ( | IProjection | projection,
 |  | Point | point
 | ) |  |
virtual

Determines if a given point screen coordinate is within the drawing object.

Parameters
projection | Projection used for drawing
point | Point in screen coordinates.
Returns
True if given point is within the rendered drawing object.

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

override void Deltares.DSoilModel.Forms.DrawingLayerObsolete.Draw3D ( GraphicsInfo info )
virtual

override The Draw3D() Method

Parameters
Draw3D

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

References Deltares.Standard.Forms.DrawingSupport.CreateConvexPolygonBox(), Deltares.Standard.Forms.DrawingSupport.GetDarkerColor(), Deltares.Standard.Forms.DrawingSupport.Material3D(), Deltares.Standard.Forms.DrawingSupport.Pen3D(), and Deltares.Standard.Forms.DrawingSupport.SetIEPDraw3D().

override void Deltares.DSoilModel.Forms.DrawingLayerObsolete.DrawLabel ( GraphicsInfo info )
virtual

Renders a label or tooltip to provide some information in text for this object.

Parameters
info Rendering target information.

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

References Deltares.Standard.Forms.DrawingSupport.DrawLabelAtPoint(), Deltares.Standard.Forms.DrawingSupport.GetDarkerColor(), and Deltares.Standard.Forms.DrawingSupport.GetLighterColor().

override void Deltares.DSoilModel.Forms.DrawingLayerObsolete.Drop ( object data )
virtual

Ends a drag-drop operation

Parameters
data

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

override object Deltares.DSoilModel.Forms.DrawingLayerObsolete.GetDataObject ( )
virtual

override The GetDataObject() Method And Rturns DataObject of SoilSurface

Returns

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

override Rectangle Deltares.DSoilModel.Forms.DrawingLayerObsolete.GetExtents ( IProjection projection )
virtual

Returns the bounding box of the shape.

Parameters
projection Projection used for drawing.
Returns
The bounding box of the shape; Null if none can be determined.

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

override void Deltares.DSoilModel.Forms.DrawingLayerObsolete.SetDataObject ( object dataObject )
virtual

override The SetDataObject() Method

Parameters
aDataObject

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

Generated on Tue Dec 15 2015 18:13:51 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • DSoilModel
  • Forms
  • DrawingLayerObsolete
Deltares.DSoilModel.Forms.DrawingLayerObsolete Member List

This is the complete list of members for Deltares.DSoilModel.Forms.DrawingLayerObsolete, including all inherited members.

AllowDrop(object data) | Deltares.DSoilModel.Forms.DrawingLayerObsolete | virtual
BeginMove(IProjection projection, Point2D startPosition) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
CanResize | Deltares.Geometry.Forms.DrawingObject |
CheckHitForSelection(IProjection projection, Point3D point, double tolerance) | Deltares.Geometry.Forms.DrawingObject | virtual
ContainsPoint(IProjection projection, Point point) | Deltares.DSoilModel.Forms.DrawingLayerObsolete | virtual
DataItemAt(Point point, Projection projection) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
DataObject (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
Draw(GraphicsInfo info) | Deltares.Geometry.Forms.DrawingObject | virtual
Draw3D(GraphicsInfo info) | Deltares.DSoilModel.Forms.DrawingLayerObsolete | virtual
DrawingLayerObsolete() (defined in Deltares.DSoilModel.Forms.DrawingLayerObsolete) | Deltares.DSoilModel.Forms.DrawingLayerObsolete |
DrawingObject() (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
DrawLabel(GraphicsInfo info) | Deltares.DSoilModel.Forms.DrawingLayerObsolete | virtual
Drop(object data) | Deltares.DSoilModel.Forms.DrawingLayerObsolete | virtual
EndMove(IProjection projection, Point2D startPosition, SizeF worldSize) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetCardinalDirectionOnEdgeContainingPoint(Point point) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetDataObject() | Deltares.DSoilModel.Forms.DrawingLayerObsolete | virtual
GetExtents(IProjection projection) | Deltares.DSoilModel.Forms.DrawingLayerObsolete | virtual
GetScaled3DPoint(IProjection projection, Point3D aOrginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScaled3DPoint(IProjection projection, Point3D aOrginalPoint, ref Point3D aPointTobeScaled) | Deltares.Geometry.Forms.DrawingObject |
GetScaledXPoint(IProjection projection, double aOrginalCordinate) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, Point2D orginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, Point3D orginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, double x, double z) | Deltares.Geometry.Forms.DrawingObject |
GetStandardSize(object aDraw3DInterface, Point3D aPoint3D) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetThickness(GraphicsInfo info) | Deltares.Geometry.Forms.DrawingObject | protectedvirtual
HasBeenUpdated (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
IsDragableOnReslultMode (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
IsVisible (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
Layer (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
Move(IProjection projection, Point2D startPosition, SizeF worldSize) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
Name | Deltares.Geometry.Forms.DrawingObject |
OnBeginDrag(IProjection projection, Point3D aBeginDragDropPoint, bool isIndividualDrag) | Deltares.Geometry.Forms.DrawingObject | virtual
OnDragging(IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D) | Deltares.Geometry.Forms.DrawingObject | virtual
OnEndDrag(IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D) | Deltares.Geometry.Forms.DrawingObject | virtual
Probability (defined in Deltares.DSoilModel.Forms.DrawingLayerObsolete) | Deltares.DSoilModel.Forms.DrawingLayerObsolete |
Selected | Deltares.Geometry.Forms.DrawingObject |
SetDataObject(object dataObject) | Deltares.DSoilModel.Forms.DrawingLayerObsolete | virtual
ToolTip | Deltares.Geometry.Forms.DrawingObject |
ToString() (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
UpdateDataDragDrop(Vector3D aVect3D, List< IDrawingObject > aDraggedObjects) | Deltares.Geometry.Forms.DrawingObject | virtual
UpdateDataDragDrop(Point3D aBeginDragPoint, Vector3D vector) | Deltares.Geometry.Forms.DrawingObject | virtual
XPosition (defined in Deltares.DSoilModel.Forms.DrawingLayerObsolete) | Deltares.DSoilModel.Forms.DrawingLayerObsolete |
Generated on Tue Dec 15 2015 18:13:51 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.DSoilModel.Forms.DrawingSoilSegmentSplitLocation Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • DSoilModel
  • Forms
  • DrawingSoilSegmentSplitLocation
Public Member Functions | Properties | List of all members
Deltares.DSoilModel.Forms.DrawingSoilSegmentSplitLocation Class Reference

Class for drawing a SoilSegmentSplitLocation on a 2D geometry. More...

Inheritance diagram for Deltares.DSoilModel.Forms.DrawingSoilSegmentSplitLocation:
Deltares.Geometry.Forms.DrawingObject Deltares.Geometry.Forms.IDrawingObject Deltares.Standard.Forms.IShape

Public Member Functions

double | TopForDrawing ()
Top coordinate for drawing (meters). More...
double | BottomForDrawing ()
Bottom coordinate for drawing (meters). More...
double | WidthForDrawing ()
Width for drawing (meters). More...
override void | SetDataObject (object dataObject)
Sets the data object (SoilSegmentSplitLocation). More...
override object | GetDataObject ()
Gets the data object (SoilSegmentSplitLocation). More...
override void | Draw3D (GraphicsInfo info)
Draws the drawing object. More...
override void | DrawLabel (GraphicsInfo info)
Draws the label. More...
override void | OnBeginDrag (IProjection projection, Point3D aBeginDragDropPoint, bool isIndividualDrag)
Called when the user initiates a drag-drop operation. More...
override void | UpdateDataDragDrop (Point3D beginDragPoint, Vector3D vector)
Updates the data during drag drop. More...
override void | OnEndDrag (IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D)
Called when [end drag]. More...
override bool | ContainsPoint (IProjection projection, Point point)
Determines whether the specified projection contains the given point. More...
override Rectangle | GetExtents (IProjection projection)
Gets the extents in pixel coordinates. More...
- Public Member Functions inherited from Deltares.Geometry.Forms.DrawingObject
Point3D | GetScaled3DPoint (IProjection projection, Point3D aOrginalPoint)
Converts the 3DPoint to screen coordinates More...
Point3D | GetScreenPoint (IProjection projection, Point2D orginalPoint)
Converts Point from 3D space to screen coordinates, assuming Y = 0 More...
Point3D | GetScreenPoint (IProjection projection, Point3D orginalPoint)
Converts Point from 3D space to screen coordinates More...
Point3D | GetScreenPoint (IProjection projection, double x, double z)
Converts 3D x, y coordinates to screen coordinates, assuming Y = 0 More...
override string | ToString ()
virtual void | UpdateDataDragDrop (Vector3D aVect3D, List< IDrawingObject > aDraggedObjects)
Update the position and or orientation of a drawing object as the user is dragging it. More...
virtual CardinalDirection | GetCardinalDirectionOnEdgeContainingPoint (Point point)
virtual void | OnDragging (IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D)
Method which is called during drag-drop operations More...
virtual bool | CheckHitForSelection (IProjection projection, Point3D point, double tolerance)
Check if given point coordinates intersect the rendered drawing object. More...
virtual double | GetStandardSize (object aDraw3DInterface, Point3D aPoint3D)
void | GetScaled3DPoint (IProjection projection, Point3D aOrginalPoint, ref Point3D aPointTobeScaled)
Converts the 3DPoint to screen coordinates More...
double | GetScaledXPoint (IProjection projection, double aOrginalCordinate)
Converts X Coordinate in 3D space to a screen X Coordinate More...
virtual void | Draw (GraphicsInfo info)
Render this object in 3D space. More...
virtual void | Move (IProjection projection, Point2D startPosition, SizeF worldSize)
virtual void | BeginMove (IProjection projection, Point2D startPosition)
virtual void | EndMove (IProjection projection, Point2D startPosition, SizeF worldSize)
virtual bool | AllowDrop (object data)
Boolean which indicates if other drawing objects can be dropped on given drawing objects More...
virtual void | Drop (object data)
Ends a drag-drop operation More...
virtual IEnumerable< object > | DataItemAt (Point point, Projection projection)

Properties

double | X [get]
Gets the local X coordinate (meters). More...
double | Left [get]
Gets the left edge X coordinate (meters). More...
double | Right [get]
Gets the right edge X coordinate (meters). More...
- Properties inherited from Deltares.Geometry.Forms.DrawingObject
virtual bool | CanResize [get]
Boolean which indicates if a drawing object can be resized. More...
virtual bool | Selected [get, set]
Boolean which indicates if a drawing object is currently selected. More...
string | ToolTip [get]
Description which is shown as a tooltip when the mouse hovers over drawing object. More...
string | Name [get, set]
Gets or sets the name of a drawing object. More...
bool | IsVisible [get, set]
bool | HasBeenUpdated [get, set]
virtual bool | IsDragableOnReslultMode [get]
virtual int | Layer [get, set]
object | DataObject [get, set]
- Properties inherited from Deltares.Geometry.Forms.IDrawingObject
string | Name [get, set]
bool | IsVisible [get, set]
bool | HasBeenUpdated [get, set]
Gets or sets the update status of a drawing object. More...
bool | IsDragableOnReslultMode [get]
- Properties inherited from Deltares.Standard.Forms.IShape
object | DataObject [get, set]
int | Layer [get]

Additional Inherited Members

- Protected Member Functions inherited from Deltares.Geometry.Forms.DrawingObject
virtual int GetThickness (GraphicsInfo info)
Gets the thickness in screen pixels of a drawing object. More...

Detailed Description

Class for drawing a SoilSegmentSplitLocation on a 2D geometry.

Member Function Documentation

double Deltares.DSoilModel.Forms.DrawingSoilSegmentSplitLocation.BottomForDrawing ( )

Bottom coordinate for drawing (meters).

References Deltares.DSoilModel.Data.SoilSegmentSplitLocation.SoilProfile2D.

override bool Deltares.DSoilModel.Forms.DrawingSoilSegmentSplitLocation.ContainsPoint | ( | IProjection | projection,
 |  | Point | point
 | ) |  |
virtual

Determines whether the specified projection contains the given point.

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

override void Deltares.DSoilModel.Forms.DrawingSoilSegmentSplitLocation.Draw3D ( GraphicsInfo info )
virtual

Draws the drawing object.

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

References Deltares.Standard.Forms.DrawingSupport.SetIEPDraw3D(), and Deltares.DSoilModel.Data.SoilSegmentSplitLocation.XCoordinate.

override void Deltares.DSoilModel.Forms.DrawingSoilSegmentSplitLocation.DrawLabel ( GraphicsInfo info )
virtual

Draws the label.

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

References Deltares.Standard.Forms.DrawingSupport.DrawLabelAtPoint(), Deltares.Standard.Forms.DrawingSupport.GetDarkerColor(), and Deltares.Standard.Forms.DrawingSupport.GetLighterColor().

override object Deltares.DSoilModel.Forms.DrawingSoilSegmentSplitLocation.GetDataObject ( )
virtual

Gets the data object (SoilSegmentSplitLocation).

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

override Rectangle Deltares.DSoilModel.Forms.DrawingSoilSegmentSplitLocation.GetExtents ( IProjection projection )
virtual

Gets the extents in pixel coordinates.

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

override void Deltares.DSoilModel.Forms.DrawingSoilSegmentSplitLocation.OnBeginDrag | ( | IProjection | projection,
 |  | Point3D | aBeginDragDropPoint,
 |  | bool | isIndividualDrag
 | ) |  |
virtual

Called when the user initiates a drag-drop operation.

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

override void Deltares.DSoilModel.Forms.DrawingSoilSegmentSplitLocation.OnEndDrag | ( | IProjection | projection,
 |  | Point3D | aCurrentDragPoint,
 |  | Vector3D | aVect3D
 | ) |  |
virtual

Called when [end drag].

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

References Deltares.DSoilModel.Data.SoilSegmentSplitLocation.XCoordinate.

override void Deltares.DSoilModel.Forms.DrawingSoilSegmentSplitLocation.SetDataObject ( object dataObject )
virtual

Sets the data object (SoilSegmentSplitLocation).

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

References Deltares.DSoilModel.Data.SoilSegmentSplitLocation.XCoordinate.

double Deltares.DSoilModel.Forms.DrawingSoilSegmentSplitLocation.TopForDrawing ( )

Top coordinate for drawing (meters).

References Deltares.DSoilModel.Data.SoilSegmentSplitLocation.SoilProfile2D.

override void Deltares.DSoilModel.Forms.DrawingSoilSegmentSplitLocation.UpdateDataDragDrop | ( | Point3D | beginDragPoint,
 |  | Vector3D | vector
 | ) |  |
virtual

Updates the data during drag drop.

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

References Deltares.DSoilModel.Data.SoilSegmentSplitLocation.XCoordinate.

double Deltares.DSoilModel.Forms.DrawingSoilSegmentSplitLocation.WidthForDrawing ( )

Width for drawing (meters).

References Deltares.DSoilModel.Data.SoilSegmentSplitLocation.SoilProfile2D.

Property Documentation

double Deltares.DSoilModel.Forms.DrawingSoilSegmentSplitLocation.Left
get

Gets the left edge X coordinate (meters).

double Deltares.DSoilModel.Forms.DrawingSoilSegmentSplitLocation.Right
get

Gets the right edge X coordinate (meters).

double Deltares.DSoilModel.Forms.DrawingSoilSegmentSplitLocation.X
get

Gets the local X coordinate (meters).

Generated on Tue Dec 15 2015 18:13:51 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • DSoilModel
  • Forms
  • DrawingSoilSegmentSplitLocation
Deltares.DSoilModel.Forms.DrawingSoilSegmentSplitLocation Member List

This is the complete list of members for Deltares.DSoilModel.Forms.DrawingSoilSegmentSplitLocation, including all inherited members.

AllowDrop(object data) | Deltares.Geometry.Forms.DrawingObject | virtual
BeginMove(IProjection projection, Point2D startPosition) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
BottomForDrawing() | Deltares.DSoilModel.Forms.DrawingSoilSegmentSplitLocation |
CanResize | Deltares.Geometry.Forms.DrawingObject |
CheckHitForSelection(IProjection projection, Point3D point, double tolerance) | Deltares.Geometry.Forms.DrawingObject | virtual
ContainsPoint(IProjection projection, Point point) | Deltares.DSoilModel.Forms.DrawingSoilSegmentSplitLocation | virtual
DataItemAt(Point point, Projection projection) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
DataObject (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
Draw(GraphicsInfo info) | Deltares.Geometry.Forms.DrawingObject | virtual
Draw3D(GraphicsInfo info) | Deltares.DSoilModel.Forms.DrawingSoilSegmentSplitLocation | virtual
DrawingObject() (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
DrawLabel(GraphicsInfo info) | Deltares.DSoilModel.Forms.DrawingSoilSegmentSplitLocation | virtual
Drop(object data) | Deltares.Geometry.Forms.DrawingObject | virtual
EndMove(IProjection projection, Point2D startPosition, SizeF worldSize) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetCardinalDirectionOnEdgeContainingPoint(Point point) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetDataObject() | Deltares.DSoilModel.Forms.DrawingSoilSegmentSplitLocation | virtual
GetExtents(IProjection projection) | Deltares.DSoilModel.Forms.DrawingSoilSegmentSplitLocation | virtual
GetScaled3DPoint(IProjection projection, Point3D aOrginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScaled3DPoint(IProjection projection, Point3D aOrginalPoint, ref Point3D aPointTobeScaled) | Deltares.Geometry.Forms.DrawingObject |
GetScaledXPoint(IProjection projection, double aOrginalCordinate) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, Point2D orginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, Point3D orginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, double x, double z) | Deltares.Geometry.Forms.DrawingObject |
GetStandardSize(object aDraw3DInterface, Point3D aPoint3D) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetThickness(GraphicsInfo info) | Deltares.Geometry.Forms.DrawingObject | protectedvirtual
HasBeenUpdated (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
IsDragableOnReslultMode (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
IsVisible (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
Layer (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
Left | Deltares.DSoilModel.Forms.DrawingSoilSegmentSplitLocation |
Move(IProjection projection, Point2D startPosition, SizeF worldSize) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
Name | Deltares.Geometry.Forms.DrawingObject |
OnBeginDrag(IProjection projection, Point3D aBeginDragDropPoint, bool isIndividualDrag) | Deltares.DSoilModel.Forms.DrawingSoilSegmentSplitLocation | virtual
OnDragging(IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D) | Deltares.Geometry.Forms.DrawingObject | virtual
OnEndDrag(IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D) | Deltares.DSoilModel.Forms.DrawingSoilSegmentSplitLocation | virtual
Right | Deltares.DSoilModel.Forms.DrawingSoilSegmentSplitLocation |
Selected | Deltares.Geometry.Forms.DrawingObject |
SetDataObject(object dataObject) | Deltares.DSoilModel.Forms.DrawingSoilSegmentSplitLocation | virtual
ToolTip | Deltares.Geometry.Forms.DrawingObject |
TopForDrawing() | Deltares.DSoilModel.Forms.DrawingSoilSegmentSplitLocation |
ToString() (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
UpdateDataDragDrop(Point3D beginDragPoint, Vector3D vector) | Deltares.DSoilModel.Forms.DrawingSoilSegmentSplitLocation | virtual
Deltares::Geometry::Forms::DrawingObject.UpdateDataDragDrop(Vector3D aVect3D, List< IDrawingObject > aDraggedObjects) | Deltares.Geometry.Forms.DrawingObject | virtual
WidthForDrawing() | Deltares.DSoilModel.Forms.DrawingSoilSegmentSplitLocation |
X | Deltares.DSoilModel.Forms.DrawingSoilSegmentSplitLocation |
Generated on Tue Dec 15 2015 18:13:51 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.DSoilModel.Forms.DrawingSosSoilLayer1D Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • DSoilModel
  • Forms
  • DrawingSosSoilLayer1D
Public Member Functions | Properties | List of all members
Deltares.DSoilModel.Forms.DrawingSosSoilLayer1D Class Reference
Inheritance diagram for Deltares.DSoilModel.Forms.DrawingSosSoilLayer1D:
Deltares.Geometry.Forms.DrawingObject Deltares.Geometry.Forms.IDrawingObject Deltares.Standard.Forms.IShape

Public Member Functions

DrawingSosSoilLayer1D ()
Initializes a new instance of the DrawingSosSoilLayer1D class. More...
override void | SetDataObject (object dataObject)
override The SetDataObject() Method More...
override object | GetDataObject ()
override The GetDataObject() Method And Rturns DataObject of SoilSurface More...
override bool | AllowDrop (object data)
Checks whether the drop is allowed. More...
override void | Drop (object data)
Drops the specified data. More...
override Rectangle | GetExtents (IProjection projection)
Returns the bounding box of the shape. More...
override bool | ContainsPoint (IProjection projection, Point point)
Determines whether the specified projection contains point. More...
override void | Draw3D (GraphicsInfo info)
override The Draw3D() Method More...
override void | DrawLabel (GraphicsInfo info)
Renders a label or tooltip to provide some information in text for this object. More...
- Public Member Functions inherited from Deltares.Geometry.Forms.DrawingObject
Point3D | GetScaled3DPoint (IProjection projection, Point3D aOrginalPoint)
Converts the 3DPoint to screen coordinates More...
Point3D | GetScreenPoint (IProjection projection, Point2D orginalPoint)
Converts Point from 3D space to screen coordinates, assuming Y = 0 More...
Point3D | GetScreenPoint (IProjection projection, Point3D orginalPoint)
Converts Point from 3D space to screen coordinates More...
Point3D | GetScreenPoint (IProjection projection, double x, double z)
Converts 3D x, y coordinates to screen coordinates, assuming Y = 0 More...
override string | ToString ()
virtual void | UpdateDataDragDrop (Vector3D aVect3D, List< IDrawingObject > aDraggedObjects)
Update the position and or orientation of a drawing object as the user is dragging it. More...
virtual void | UpdateDataDragDrop (Point3D aBeginDragPoint, Vector3D vector)
Update the position and or orientation of a drawing object as the user is dragging it. More...
virtual void | OnBeginDrag (IProjection projection, Point3D aBeginDragDropPoint, bool isIndividualDrag)
Method which is called when the user initiates a drag-drop operation More...
virtual CardinalDirection | GetCardinalDirectionOnEdgeContainingPoint (Point point)
virtual void | OnDragging (IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D)
Method which is called during drag-drop operations More...
virtual void | OnEndDrag (IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D)
Method which is called when the user ends a drag-drop operation. More...
virtual bool | CheckHitForSelection (IProjection projection, Point3D point, double tolerance)
Check if given point coordinates intersect the rendered drawing object. More...
virtual double | GetStandardSize (object aDraw3DInterface, Point3D aPoint3D)
void | GetScaled3DPoint (IProjection projection, Point3D aOrginalPoint, ref Point3D aPointTobeScaled)
Converts the 3DPoint to screen coordinates More...
double | GetScaledXPoint (IProjection projection, double aOrginalCordinate)
Converts X Coordinate in 3D space to a screen X Coordinate More...
virtual void | Draw (GraphicsInfo info)
Render this object in 3D space. More...
virtual void | Move (IProjection projection, Point2D startPosition, SizeF worldSize)
virtual void | BeginMove (IProjection projection, Point2D startPosition)
virtual void | EndMove (IProjection projection, Point2D startPosition, SizeF worldSize)
virtual IEnumerable< object > | DataItemAt (Point point, Projection projection)

Properties

double | Width [get, set]
Gets or sets the width. More...
GeometryPoint | InsertionPoint [get, set]
Gets or sets the insertion point. More...
- Properties inherited from Deltares.Geometry.Forms.DrawingObject
virtual bool | CanResize [get]
Boolean which indicates if a drawing object can be resized. More...
virtual bool | Selected [get, set]
Boolean which indicates if a drawing object is currently selected. More...
string | ToolTip [get]
Description which is shown as a tooltip when the mouse hovers over drawing object. More...
string | Name [get, set]
Gets or sets the name of a drawing object. More...
bool | IsVisible [get, set]
bool | HasBeenUpdated [get, set]
virtual bool | IsDragableOnReslultMode [get]
virtual int | Layer [get, set]
object | DataObject [get, set]
- Properties inherited from Deltares.Geometry.Forms.IDrawingObject
string | Name [get, set]
bool | IsVisible [get, set]
bool | HasBeenUpdated [get, set]
Gets or sets the update status of a drawing object. More...
bool | IsDragableOnReslultMode [get]
- Properties inherited from Deltares.Standard.Forms.IShape
object | DataObject [get, set]
int | Layer [get]

Additional Inherited Members

- Protected Member Functions inherited from Deltares.Geometry.Forms.DrawingObject
virtual int GetThickness (GraphicsInfo info)
Gets the thickness in screen pixels of a drawing object. More...

Constructor & Destructor Documentation

Deltares.DSoilModel.Forms.DrawingSosSoilLayer1D.DrawingSosSoilLayer1D ( )

Initializes a new instance of the DrawingSosSoilLayer1D class.

Member Function Documentation

override bool Deltares.DSoilModel.Forms.DrawingSosSoilLayer1D.AllowDrop ( object data )
virtual

Checks whether the drop is allowed.

Parameters
data The data.
Returns

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

override bool Deltares.DSoilModel.Forms.DrawingSosSoilLayer1D.ContainsPoint | ( | IProjection | projection,
 |  | Point | point
 | ) |  |
virtual

Determines whether the specified projection contains point.

Parameters
projection | The projection.
point | The point.
Returns

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

override void Deltares.DSoilModel.Forms.DrawingSosSoilLayer1D.Draw3D ( GraphicsInfo info )
virtual

override The Draw3D() Method

Parameters
info

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

References Deltares.Standard.Forms.DrawingSupport.CreateConvexPolygonBox(), Deltares.Standard.Forms.DrawingSupport.GetDarkerColor(), Deltares.Standard.Forms.DrawingSupport.Material3D(), Deltares.Standard.Forms.DrawingSupport.Pen3D(), and Deltares.Standard.Forms.DrawingSupport.SetIEPDraw3D().

override void Deltares.DSoilModel.Forms.DrawingSosSoilLayer1D.DrawLabel ( GraphicsInfo info )
virtual

Renders a label or tooltip to provide some information in text for this object.

Parameters
info Rendering target information.

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

References Deltares.Standard.Forms.DrawingSupport.DrawLabelAtPoint(), Deltares.Standard.Forms.DrawingSupport.GetDarkerColor(), and Deltares.Standard.Forms.DrawingSupport.GetLighterColor().

override void Deltares.DSoilModel.Forms.DrawingSosSoilLayer1D.Drop ( object data )
virtual

Drops the specified data.

Parameters
data The data.

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

override object Deltares.DSoilModel.Forms.DrawingSosSoilLayer1D.GetDataObject ( )
virtual

override The GetDataObject() Method And Rturns DataObject of SoilSurface

Returns

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

override Rectangle Deltares.DSoilModel.Forms.DrawingSosSoilLayer1D.GetExtents ( IProjection projection )
virtual

Returns the bounding box of the shape.

Parameters
projection Projection used for drawing.
Returns
The bounding box of the shape; Null if none can be determined.

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

override void Deltares.DSoilModel.Forms.DrawingSosSoilLayer1D.SetDataObject ( object dataObject )
virtual

override The SetDataObject() Method

Parameters
dataObject

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

Property Documentation

GeometryPoint Deltares.DSoilModel.Forms.DrawingSosSoilLayer1D.InsertionPoint
getset

Gets or sets the insertion point.

The insertion point.

double Deltares.DSoilModel.Forms.DrawingSosSoilLayer1D.Width
getset

Gets or sets the width.

The width.

Generated on Tue Dec 15 2015 18:13:51 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • DSoilModel
  • Forms
  • DrawingSosSoilLayer1D
Deltares.DSoilModel.Forms.DrawingSosSoilLayer1D Member List

This is the complete list of members for Deltares.DSoilModel.Forms.DrawingSosSoilLayer1D, including all inherited members.

AllowDrop(object data) | Deltares.DSoilModel.Forms.DrawingSosSoilLayer1D | virtual
BeginMove(IProjection projection, Point2D startPosition) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
CanResize | Deltares.Geometry.Forms.DrawingObject |
CheckHitForSelection(IProjection projection, Point3D point, double tolerance) | Deltares.Geometry.Forms.DrawingObject | virtual
ContainsPoint(IProjection projection, Point point) | Deltares.DSoilModel.Forms.DrawingSosSoilLayer1D | virtual
DataItemAt(Point point, Projection projection) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
DataObject (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
Draw(GraphicsInfo info) | Deltares.Geometry.Forms.DrawingObject | virtual
Draw3D(GraphicsInfo info) | Deltares.DSoilModel.Forms.DrawingSosSoilLayer1D | virtual
DrawingObject() (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
DrawingSosSoilLayer1D() | Deltares.DSoilModel.Forms.DrawingSosSoilLayer1D |
DrawLabel(GraphicsInfo info) | Deltares.DSoilModel.Forms.DrawingSosSoilLayer1D | virtual
Drop(object data) | Deltares.DSoilModel.Forms.DrawingSosSoilLayer1D | virtual
EndMove(IProjection projection, Point2D startPosition, SizeF worldSize) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetCardinalDirectionOnEdgeContainingPoint(Point point) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetDataObject() | Deltares.DSoilModel.Forms.DrawingSosSoilLayer1D | virtual
GetExtents(IProjection projection) | Deltares.DSoilModel.Forms.DrawingSosSoilLayer1D | virtual
GetScaled3DPoint(IProjection projection, Point3D aOrginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScaled3DPoint(IProjection projection, Point3D aOrginalPoint, ref Point3D aPointTobeScaled) | Deltares.Geometry.Forms.DrawingObject |
GetScaledXPoint(IProjection projection, double aOrginalCordinate) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, Point2D orginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, Point3D orginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, double x, double z) | Deltares.Geometry.Forms.DrawingObject |
GetStandardSize(object aDraw3DInterface, Point3D aPoint3D) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetThickness(GraphicsInfo info) | Deltares.Geometry.Forms.DrawingObject | protectedvirtual
HasBeenUpdated (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
InsertionPoint | Deltares.DSoilModel.Forms.DrawingSosSoilLayer1D |
IsDragableOnReslultMode (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
IsVisible (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
Layer (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
Move(IProjection projection, Point2D startPosition, SizeF worldSize) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
Name | Deltares.Geometry.Forms.DrawingObject |
OnBeginDrag(IProjection projection, Point3D aBeginDragDropPoint, bool isIndividualDrag) | Deltares.Geometry.Forms.DrawingObject | virtual
OnDragging(IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D) | Deltares.Geometry.Forms.DrawingObject | virtual
OnEndDrag(IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D) | Deltares.Geometry.Forms.DrawingObject | virtual
Selected | Deltares.Geometry.Forms.DrawingObject |
SetDataObject(object dataObject) | Deltares.DSoilModel.Forms.DrawingSosSoilLayer1D | virtual
ToolTip | Deltares.Geometry.Forms.DrawingObject |
ToString() (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
UpdateDataDragDrop(Vector3D aVect3D, List< IDrawingObject > aDraggedObjects) | Deltares.Geometry.Forms.DrawingObject | virtual
UpdateDataDragDrop(Point3D aBeginDragPoint, Vector3D vector) | Deltares.Geometry.Forms.DrawingObject | virtual
Width | Deltares.DSoilModel.Forms.DrawingSosSoilLayer1D |
Generated on Tue Dec 15 2015 18:13:51 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.DSoilModel.Forms.DSoilModelContext Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • DSoilModel
  • Forms
  • DSoilModelContext
Public Member Functions | Protected Member Functions | Properties | List of all members
Deltares.DSoilModel.Forms.DSoilModelContext Class Reference
Inheritance diagram for Deltares.DSoilModel.Forms.DSoilModelContext:

Public Member Functions

override bool | IsVisible (object source, string member)
override bool | IsEnabled (object source, string member)

Protected Member Functions

override HashSet< string > GetFilteredProperties (object soilUserFilter)

Properties

ParameterViewSettings ParameterView [get, set]
The current filter to display all parameters, stochastic parameters only or as-is parameters only. More...

Property Documentation

ParameterViewSettings Deltares.DSoilModel.Forms.DSoilModelContext.ParameterView
getset

The current filter to display all parameters, stochastic parameters only or as-is parameters only.

Generated on Tue Dec 15 2015 18:13:52 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • DSoilModel
  • Forms
  • DSoilModelContext
Deltares.DSoilModel.Forms.DSoilModelContext Member List

This is the complete list of members for Deltares.DSoilModel.Forms.DSoilModelContext, including all inherited members.

GetFilteredProperties(object soilUserFilter) (defined in Deltares.DSoilModel.Forms.DSoilModelContext) | Deltares.DSoilModel.Forms.DSoilModelContext | protected
IsEnabled(object source, string member) (defined in Deltares.DSoilModel.Forms.DSoilModelContext) | Deltares.DSoilModel.Forms.DSoilModelContext |
IsVisible(object source, string member) (defined in Deltares.DSoilModel.Forms.DSoilModelContext) | Deltares.DSoilModel.Forms.DSoilModelContext |
ParameterView | Deltares.DSoilModel.Forms.DSoilModelContext |
Generated on Tue Dec 15 2015 18:13:52 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.DSoilModel.Forms.DSoilModelGeometryEditor Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • DSoilModel
  • Forms
  • DSoilModelGeometryEditor
Public Member Functions | Properties | List of all members
Deltares.DSoilModel.Forms.DSoilModelGeometryEditor Class Reference

The D-Soil Model Geometry Editor More...

Inheritance diagram for Deltares.DSoilModel.Forms.DSoilModelGeometryEditor:

Public Member Functions

DSoilModelGeometryEditor (MainForm theMainForm)
Initializes a new instance of the DSoilModelGeometryEditor class. More...
void | ShowSoilSegment (SoilSegment selectedSegment, StochasticSoilProfile selectedSoilProfile)
Allow the plugin to show the currently selected soil segment which possibly has a stochastic soil model. This stochastic soil model can have a possibly currently selected stochastic soil profile. If the currently selected stochastic soil profile is undefined, the first profile is selected. More...
void | InsertSpecificMechanismPointLocation ()
Inserts mechanism point location. More...
void | AddCenterCrestLocationTo2DProfile ()
Adds the center crest location to 2d profile. More...
void | AddSurfaceLineToCreateNew2DProfile ()
Adds the surface line to the existing 2D to create new 2D profile. More...
void | Dispose ()
bool | IsVisible (string property)
bool | IsEnabled (string property)

Properties

DSoilModelProject | Project [get, set]
Gets or sets the project. More...
Func< ConePenetrationTestData, bool > | AddCPTCallback [get, set]
Gets or sets a call back method to call when a cpt is added to the geometry editor. More...
bool | CreatePolyline [get, set]
Creates a Polyline. More...
bool | CreatePointInLine [get, set]
Creates a point in the line. More...
Func< string, bool > | IsVisibleCallback [get, set]
Gets or sets the is visible callback. More...
bool | AllowEdit [get, set]

Detailed Description

The D-Soil Model Geometry Editor

Constructor & Destructor Documentation

Deltares.DSoilModel.Forms.DSoilModelGeometryEditor.DSoilModelGeometryEditor ( MainForm theMainForm )

Initializes a new instance of the DSoilModelGeometryEditor class.

Parameters
theMainForm The main form to be able to set the caption of the geometry dock panel.

References Deltares.Standard.Forms.SpatialEditor.RegisterShapeType(), and Deltares.Standard.Forms.DExpress.GeometryEditor.SpatialEditor.

Member Function Documentation

void Deltares.DSoilModel.Forms.DSoilModelGeometryEditor.AddCenterCrestLocationTo2DProfile ( )

Adds the center crest location to 2d profile.

void Deltares.DSoilModel.Forms.DSoilModelGeometryEditor.AddSurfaceLineToCreateNew2DProfile ( )

Adds the surface line to the existing 2D to create new 2D profile.

References Deltares.DSoilModel.Data.DSoilModelProject.SurfaceLines.

void Deltares.DSoilModel.Forms.DSoilModelGeometryEditor.InsertSpecificMechanismPointLocation ( )

Inserts mechanism point location.

void Deltares.DSoilModel.Forms.DSoilModelGeometryEditor.ShowSoilSegment | ( | SoilSegment | selectedSegment,
 |  | StochasticSoilProfile | selectedSoilProfile
 | ) |  |

Allow the plugin to show the currently selected soil segment which possibly has a stochastic soil model. This stochastic soil model can have a possibly currently selected stochastic soil profile. If the currently selected stochastic soil profile is undefined, the first profile is selected.

Parameters
selectedSegment | The segment to show, possibly with a stochastic soil model.
selectedSoilProfile | The possible selected soil segment to show.

Property Documentation

Func<ConePenetrationTestData, bool> Deltares.DSoilModel.Forms.DSoilModelGeometryEditor.AddCPTCallback
getset

Gets or sets a call back method to call when a cpt is added to the geometry editor.

bool Deltares.DSoilModel.Forms.DSoilModelGeometryEditor.CreatePointInLine
getset

Creates a point in the line.

true if create point in line; otherwise, false.

bool Deltares.DSoilModel.Forms.DSoilModelGeometryEditor.CreatePolyline
getset

Creates a Polyline.

true if polyline is created; otherwise, false.

Func<string, bool> Deltares.DSoilModel.Forms.DSoilModelGeometryEditor.IsVisibleCallback
getset

Gets or sets the is visible callback.

The is visible callback.

DSoilModelProject Deltares.DSoilModel.Forms.DSoilModelGeometryEditor.Project
getset

Gets or sets the project.

Generated on Tue Dec 15 2015 18:13:52 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • DSoilModel
  • Forms
  • DSoilModelGeometryEditor
Deltares.DSoilModel.Forms.DSoilModelGeometryEditor Member List

This is the complete list of members for Deltares.DSoilModel.Forms.DSoilModelGeometryEditor, including all inherited members.

AddCenterCrestLocationTo2DProfile() | Deltares.DSoilModel.Forms.DSoilModelGeometryEditor
AddCPTCallback | Deltares.DSoilModel.Forms.DSoilModelGeometryEditor
AddSurfaceLineToCreateNew2DProfile() | Deltares.DSoilModel.Forms.DSoilModelGeometryEditor
AllowEdit (defined in Deltares.DSoilModel.Forms.DSoilModelGeometryEditor) | Deltares.DSoilModel.Forms.DSoilModelGeometryEditor
CreatePointInLine | Deltares.DSoilModel.Forms.DSoilModelGeometryEditor
CreatePolyline | Deltares.DSoilModel.Forms.DSoilModelGeometryEditor
Dispose() (defined in Deltares.DSoilModel.Forms.DSoilModelGeometryEditor) | Deltares.DSoilModel.Forms.DSoilModelGeometryEditor
DSoilModelGeometryEditor(MainForm theMainForm) | Deltares.DSoilModel.Forms.DSoilModelGeometryEditor
InsertSpecificMechanismPointLocation() | Deltares.DSoilModel.Forms.DSoilModelGeometryEditor
IsEnabled(string property) (defined in Deltares.DSoilModel.Forms.DSoilModelGeometryEditor) | Deltares.DSoilModel.Forms.DSoilModelGeometryEditor
IsVisible(string property) (defined in Deltares.DSoilModel.Forms.DSoilModelGeometryEditor) | Deltares.DSoilModel.Forms.DSoilModelGeometryEditor
IsVisibleCallback | Deltares.DSoilModel.Forms.DSoilModelGeometryEditor
Project | Deltares.DSoilModel.Forms.DSoilModelGeometryEditor
ShowSoilSegment(SoilSegment selectedSegment, StochasticSoilProfile selectedSoilProfile) | Deltares.DSoilModel.Forms.DSoilModelGeometryEditor
Generated on Tue Dec 15 2015 18:13:52 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.DSoilModel.Forms.DSoilModelMapEditor Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • DSoilModel
  • Forms
  • DSoilModelMapEditor
Public Member Functions | Properties | List of all members
Deltares.DSoilModel.Forms.DSoilModelMapEditor Class Reference

The D-Soil Model MapEditor More...

Inheritance diagram for Deltares.DSoilModel.Forms.DSoilModelMapEditor:

Public Member Functions

DSoilModelMapEditor (MapEditor mapEditor)
Initializes a new instance of the DSoilModelMapEditor class, registers MapLayerDefinitions for CPT, Boring, SoilProfile1D, SoilProfile2D and Segments. More...
BarButtonItem | CreateButton (Image image)
creates a tool button with the provided info and add them to the tool bar More...
void | SplitSegmentLocation ()
Start (or complete) splitting selected SoilSegment by adding a divisionpoint on the map More...
void | SplitSegment ()
Complete split segment operation (after setting a split location) More...
void | ZoomData ()
Zoom out the map to display all data. More...
bool | IsVisible (string property)
Determine visibility of properties More...
bool | IsEnabled (string property)
Determine if property is enabled More...
IGeographic | GetSnapPointSplitSegment (IGeographicPoint point)
SnapRule method for splitting soil segments, snaps the splitter location to the segment geographically More...
void | Dispose ()
Dispose of unmanaged resources and delegates More...

Properties

DSoilModelProject Project [get, set]
Gets or sets the project (setting: Adding Layers from Project to MapEditor). More...

Detailed Description

The D-Soil Model MapEditor

Constructor & Destructor Documentation

Deltares.DSoilModel.Forms.DSoilModelMapEditor.DSoilModelMapEditor ( MapEditor mapEditor )

Initializes a new instance of the DSoilModelMapEditor class, registers MapLayerDefinitions for CPT, Boring, SoilProfile1D, SoilProfile2D and Segments.

Parameters
mapEditor The map editor.

References Deltares.Standard.Forms.DExpress.BindSupport.Assign(), Deltares.Standard.Forms.DExpress.BindSupport.Bind(), Deltares.DSoilModel.Forms.Properties.Resources.Boring, Deltares.DSoilModel.Forms.Properties.Resources.CPT, Deltares.Standard.Forms.DExpress.MapEditor.RegisterLayer(), Deltares.Standard.Forms.DExpress.MapEditor.ShowSelectWebLayer, Deltares.DSoilModel.Forms.Properties.Resources.SoilProfile, Deltares.DSoilModel.Forms.DSoilModelMapEditor.SplitSegment(), Deltares.DSoilModel.Forms.Properties.Resources.SplitSegment, Deltares.DSoilModel.Forms.DSoilModelMapEditor.SplitSegmentLocation(), and Deltares.Standard.Forms.DExpress.MapEditor.WebLayerType.

Member Function Documentation

BarButtonItem Deltares.DSoilModel.Forms.DSoilModelMapEditor.CreateButton ( Image image )

creates a tool button with the provided info and add them to the tool bar

void Deltares.DSoilModel.Forms.DSoilModelMapEditor.Dispose ( )

Dispose of unmanaged resources and delegates

IGeographic Deltares.DSoilModel.Forms.DSoilModelMapEditor.GetSnapPointSplitSegment ( IGeographicPoint point )

SnapRule method for splitting soil segments, snaps the splitter location to the segment geographically

Parameters
point Point to be snapped
Returns
Snapped point
bool Deltares.DSoilModel.Forms.DSoilModelMapEditor.IsEnabled ( string property )

Determine if property is enabled

Parameters
property
Returns
bool Deltares.DSoilModel.Forms.DSoilModelMapEditor.IsVisible ( string property )

Determine visibility of properties

Parameters
property
Returns
void Deltares.DSoilModel.Forms.DSoilModelMapEditor.SplitSegment ( )

Complete split segment operation (after setting a split location)

References Deltares.DSoilModel.Data.DSoilModelProject.SplitSoilSegment().

Referenced by Deltares.DSoilModel.Forms.DSoilModelMapEditor.DSoilModelMapEditor().

void Deltares.DSoilModel.Forms.DSoilModelMapEditor.SplitSegmentLocation ( )

Start (or complete) splitting selected SoilSegment by adding a divisionpoint on the map

References Deltares.DSoilModel.Data.DSoilModelProject.SplitSoilSegment().

Referenced by Deltares.DSoilModel.Forms.DSoilModelMapEditor.DSoilModelMapEditor().

void Deltares.DSoilModel.Forms.DSoilModelMapEditor.ZoomData ( )

Zoom out the map to display all data.

Property Documentation

DSoilModelProject Deltares.DSoilModel.Forms.DSoilModelMapEditor.Project
getset

Gets or sets the project (setting: Adding Layers from Project to MapEditor).

The project.

Generated on Tue Dec 15 2015 18:13:52 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • DSoilModel
  • Forms
  • DSoilModelMapEditor
Deltares.DSoilModel.Forms.DSoilModelMapEditor Member List

This is the complete list of members for Deltares.DSoilModel.Forms.DSoilModelMapEditor, including all inherited members.

CreateButton(Image image) | Deltares.DSoilModel.Forms.DSoilModelMapEditor
Dispose() | Deltares.DSoilModel.Forms.DSoilModelMapEditor
DSoilModelMapEditor(MapEditor mapEditor) | Deltares.DSoilModel.Forms.DSoilModelMapEditor
GetSnapPointSplitSegment(IGeographicPoint point) | Deltares.DSoilModel.Forms.DSoilModelMapEditor
IsEnabled(string property) | Deltares.DSoilModel.Forms.DSoilModelMapEditor
IsVisible(string property) | Deltares.DSoilModel.Forms.DSoilModelMapEditor
Project | Deltares.DSoilModel.Forms.DSoilModelMapEditor
SplitSegment() | Deltares.DSoilModel.Forms.DSoilModelMapEditor
SplitSegmentLocation() | Deltares.DSoilModel.Forms.DSoilModelMapEditor
ZoomData() | Deltares.DSoilModel.Forms.DSoilModelMapEditor
Generated on Tue Dec 15 2015 18:13:52 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.DSoilModel.Forms.DSoilModelPlugin Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • DSoilModel
  • Forms
  • DSoilModelPlugin
Public Member Functions | Properties | List of all members
Deltares.DSoilModel.Forms.DSoilModelPlugin Class Reference

Main Class for D-Soil Model More...

Inheritance diagram for Deltares.DSoilModel.Forms.DSoilModelPlugin:
Deltares.Standard.Forms.DExpress.IMainFormPlugin

Public Member Functions

void | InvisibleMethod ()
void | ReadSegmentShapefileAndAddToProject (string fileName, DSoilModelProject project, string fieldName="SegmentId")
void | Dispose ()
void | Configure (MainForm aMainForm)
void | Assign (object source)
bool | IsVisible (string property)
bool | IsEnabled (string property)

Properties

DSoilModelProject | Project [get, set]
Gets or sets the D-Soil Model Project. More...
DSoilModelGeometryEditor | GeometryEditor [get, set]
The geometry editor for this DSoilModel plugin. More...
DSoilModelSegmentGeometryEditor | SegmentGeometryEditor [get, set]
The segment geometry editor for this DSoilModel plugin. More...
bool | UseSoilSegments [get, set]
Gets or sets whether Soil Segments are used in the D-Soil Model plugin. More...
bool | Use1DProfiles [get, set]
Gets or sets whether 1D Profiles are used in the D-Soil Model plugin. More...
bool | Use2DProfiles [get, set]
Gets or sets whether 2D Profiles are used in the D-Soil Model plugin. More...
bool | UseSurfaceLines [get, set]
Gets or sets whether Surface Lines are used in the D-Soil Model plugin. More...
bool | UseBorings [get, set]
Gets or sets whether Borings are used in the D-Soil Model plugin. More...

Detailed Description

Main Class for D-Soil Model

Property Documentation

DSoilModelGeometryEditor Deltares.DSoilModel.Forms.DSoilModelPlugin.GeometryEditor
getset

The geometry editor for this DSoilModel plugin.

DSoilModelProject Deltares.DSoilModel.Forms.DSoilModelPlugin.Project
getset

Gets or sets the D-Soil Model Project.

The project.

DSoilModelSegmentGeometryEditor Deltares.DSoilModel.Forms.DSoilModelPlugin.SegmentGeometryEditor
getset

The segment geometry editor for this DSoilModel plugin.

bool Deltares.DSoilModel.Forms.DSoilModelPlugin.Use1DProfiles
getset

Gets or sets whether 1D Profiles are used in the D-Soil Model plugin.

bool Deltares.DSoilModel.Forms.DSoilModelPlugin.Use2DProfiles
getset

Gets or sets whether 2D Profiles are used in the D-Soil Model plugin.

bool Deltares.DSoilModel.Forms.DSoilModelPlugin.UseBorings
getset

Gets or sets whether Borings are used in the D-Soil Model plugin.

bool Deltares.DSoilModel.Forms.DSoilModelPlugin.UseSoilSegments
getset

Gets or sets whether Soil Segments are used in the D-Soil Model plugin.

bool Deltares.DSoilModel.Forms.DSoilModelPlugin.UseSurfaceLines
getset

Gets or sets whether Surface Lines are used in the D-Soil Model plugin.

Generated on Tue Dec 15 2015 18:13:52 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • DSoilModel
  • Forms
  • DSoilModelPlugin
Deltares.DSoilModel.Forms.DSoilModelPlugin Member List

This is the complete list of members for Deltares.DSoilModel.Forms.DSoilModelPlugin, including all inherited members.

Assign(object source) (defined in Deltares.DSoilModel.Forms.DSoilModelPlugin) | Deltares.DSoilModel.Forms.DSoilModelPlugin
Configure(MainForm aMainForm) (defined in Deltares.DSoilModel.Forms.DSoilModelPlugin) | Deltares.DSoilModel.Forms.DSoilModelPlugin
Dispose() (defined in Deltares.DSoilModel.Forms.DSoilModelPlugin) | Deltares.DSoilModel.Forms.DSoilModelPlugin
DSoilModelPlugin() (defined in Deltares.DSoilModel.Forms.DSoilModelPlugin) | Deltares.DSoilModel.Forms.DSoilModelPlugin
GeometryEditor | Deltares.DSoilModel.Forms.DSoilModelPlugin
InvisibleMethod() (defined in Deltares.DSoilModel.Forms.DSoilModelPlugin) | Deltares.DSoilModel.Forms.DSoilModelPlugin
IsEnabled(string property) (defined in Deltares.DSoilModel.Forms.DSoilModelPlugin) | Deltares.DSoilModel.Forms.DSoilModelPlugin
IsVisible(string property) (defined in Deltares.DSoilModel.Forms.DSoilModelPlugin) | Deltares.DSoilModel.Forms.DSoilModelPlugin
Project | Deltares.DSoilModel.Forms.DSoilModelPlugin
ReadSegmentShapefileAndAddToProject(string fileName, DSoilModelProject project, string fieldName="SegmentId") (defined in Deltares.DSoilModel.Forms.DSoilModelPlugin) | Deltares.DSoilModel.Forms.DSoilModelPlugin
SegmentGeometryEditor | Deltares.DSoilModel.Forms.DSoilModelPlugin
Use1DProfiles | Deltares.DSoilModel.Forms.DSoilModelPlugin
Use2DProfiles | Deltares.DSoilModel.Forms.DSoilModelPlugin
UseBorings | Deltares.DSoilModel.Forms.DSoilModelPlugin
UseSoilSegments | Deltares.DSoilModel.Forms.DSoilModelPlugin
UseSurfaceLines | Deltares.DSoilModel.Forms.DSoilModelPlugin
Generated on Tue Dec 15 2015 18:13:52 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.DSoilModel.Forms.DSoilModelSegmentGeometryEditor Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • DSoilModel
  • Forms
  • DSoilModelSegmentGeometryEditor
Public Member Functions | Properties | List of all members
Deltares.DSoilModel.Forms.DSoilModelSegmentGeometryEditor Class Reference

Class to be able to show a soilsegment as length profile (based on a fictive 2D profile with the length of the segment) In the length profile, the mapped CPTs and Borings belonging to the segment are shown. More...

Inheritance diagram for Deltares.DSoilModel.Forms.DSoilModelSegmentGeometryEditor:

Public Member Functions

DSoilModelSegmentGeometryEditor (MainForm theMainForm)
Initializes a new instance of the DSoilModelSegmentGeometryEditor class. More...
void | SetCaption (string caption)
Sets the caption of the Extra Geometry Dock Panel. More...
void | Dispose ()
Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. More...
bool | IsVisible (string property)
Determines whether the specified property is visible. More...
bool | IsEnabled (string property)
Determines whether the specified property is enabled. More...

Properties

DSoilModelProject | Project [get, set]
Gets or sets the project. More...
Func< ConePenetrationTestData, bool > | AddCPTCallback [get, set]
Gets or sets the onselectionchanged callback. More...
Func< string, bool > | IsVisibleCallback [get, set]
Gets or sets the is visible callback. More...

Detailed Description

Class to be able to show a soilsegment as length profile (based on a fictive 2D profile with the length of the segment) In the length profile, the mapped CPTs and Borings belonging to the segment are shown.

Constructor & Destructor Documentation

Deltares.DSoilModel.Forms.DSoilModelSegmentGeometryEditor.DSoilModelSegmentGeometryEditor ( MainForm theMainForm )

Initializes a new instance of the DSoilModelSegmentGeometryEditor class.

Parameters
theMainForm The main form to be able to set the caption of the geometry dock panel.

References Deltares.Standard.Forms.ShapeInfo.AllowEdit, and Deltares.Standard.Forms.ShapeInfo.AllowSelect.

Member Function Documentation

void Deltares.DSoilModel.Forms.DSoilModelSegmentGeometryEditor.Dispose ( )

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

bool Deltares.DSoilModel.Forms.DSoilModelSegmentGeometryEditor.IsEnabled ( string property )

Determines whether the specified property is enabled.

Parameters
property The property.
Returns
bool Deltares.DSoilModel.Forms.DSoilModelSegmentGeometryEditor.IsVisible ( string property )

Determines whether the specified property is visible.

Parameters
property The property.
Returns
void Deltares.DSoilModel.Forms.DSoilModelSegmentGeometryEditor.SetCaption ( string caption )

Sets the caption of the Extra Geometry Dock Panel.

Parameters
caption The string to set.

Property Documentation

Func<ConePenetrationTestData, bool> Deltares.DSoilModel.Forms.DSoilModelSegmentGeometryEditor.AddCPTCallback
getset

Gets or sets the onselectionchanged callback.

The is visible callback.

Func<string, bool> Deltares.DSoilModel.Forms.DSoilModelSegmentGeometryEditor.IsVisibleCallback
getset

Gets or sets the is visible callback.

The is visible callback.

DSoilModelProject Deltares.DSoilModel.Forms.DSoilModelSegmentGeometryEditor.Project
getset

Gets or sets the project.

Generated on Tue Dec 15 2015 18:13:53 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • DSoilModel
  • Forms
  • DSoilModelSegmentGeometryEditor
Deltares.DSoilModel.Forms.DSoilModelSegmentGeometryEditor Member List

This is the complete list of members for Deltares.DSoilModel.Forms.DSoilModelSegmentGeometryEditor, including all inherited members.

AddCPTCallback | Deltares.DSoilModel.Forms.DSoilModelSegmentGeometryEditor
Dispose() | Deltares.DSoilModel.Forms.DSoilModelSegmentGeometryEditor
DSoilModelSegmentGeometryEditor(MainForm theMainForm) | Deltares.DSoilModel.Forms.DSoilModelSegmentGeometryEditor
IsEnabled(string property) | Deltares.DSoilModel.Forms.DSoilModelSegmentGeometryEditor
IsVisible(string property) | Deltares.DSoilModel.Forms.DSoilModelSegmentGeometryEditor
IsVisibleCallback | Deltares.DSoilModel.Forms.DSoilModelSegmentGeometryEditor
Project | Deltares.DSoilModel.Forms.DSoilModelSegmentGeometryEditor
SetCaption(string caption) | Deltares.DSoilModel.Forms.DSoilModelSegmentGeometryEditor
Generated on Tue Dec 15 2015 18:13:53 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.DSoilModel.Forms.FilmStrip Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • DSoilModel
  • Forms
  • FilmStrip
Public Member Functions | Protected Member Functions | Properties | List of all members
Deltares.DSoilModel.Forms.FilmStrip Class Reference

Control to show the Stochastic Soil Profiles of a Stochastic Soil Model as a film strip under the Geometry Editor. More...

Inheritance diagram for Deltares.DSoilModel.Forms.FilmStrip:

Public Member Functions

FilmStrip (SpatialEditor spatialEditorToClone)
Constructor. More...
void Refresh (bool reset=true)
Method to refresh the filmstrip control and redraw the thumbnails. More...

Protected Member Functions

override void Dispose (bool disposing)
Clean up any resources being used. More...

Properties

StochasticSoilModel | SelectedStochasticSoilModel [get, set]
Gets or sets the selected Stochastic Soil Model. More...
StochasticSoilProfile | SelectedStochasticSoilProfile [get, set]
Gets or sets the selected Stochastic Soil Profile. More...

Detailed Description

Control to show the Stochastic Soil Profiles of a Stochastic Soil Model as a film strip under the Geometry Editor.

Constructor & Destructor Documentation

Deltares.DSoilModel.Forms.FilmStrip.FilmStrip ( SpatialEditor spatialEditorToClone )

Constructor.

References Deltares.Standard.Forms.SpatialEditor.CopyShapeInfos().

Member Function Documentation

override void Deltares.DSoilModel.Forms.FilmStrip.Dispose ( bool disposing )
protected

Clean up any resources being used.

Parameters
disposing true if managed resources should be disposed; otherwise, false.
void Deltares.DSoilModel.Forms.FilmStrip.Refresh ( bool reset = true )

Method to refresh the filmstrip control and redraw the thumbnails.

Parameters
reset Whether the thumbnail to display should start from the first thumbnail.

Property Documentation

StochasticSoilModel Deltares.DSoilModel.Forms.FilmStrip.SelectedStochasticSoilModel
getset

Gets or sets the selected Stochastic Soil Model.

StochasticSoilProfile Deltares.DSoilModel.Forms.FilmStrip.SelectedStochasticSoilProfile
getset

Gets or sets the selected Stochastic Soil Profile.

Generated on Tue Dec 15 2015 18:13:53 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • DSoilModel
  • Forms
  • FilmStrip
Deltares.DSoilModel.Forms.FilmStrip Member List

This is the complete list of members for Deltares.DSoilModel.Forms.FilmStrip, including all inherited members.

Dispose(bool disposing) | Deltares.DSoilModel.Forms.FilmStrip | protected
FilmStrip(SpatialEditor spatialEditorToClone) | Deltares.DSoilModel.Forms.FilmStrip |
Refresh(bool reset=true) | Deltares.DSoilModel.Forms.FilmStrip |
SelectedStochasticSoilModel | Deltares.DSoilModel.Forms.FilmStrip |
SelectedStochasticSoilProfile | Deltares.DSoilModel.Forms.FilmStrip |
Generated on Tue Dec 15 2015 18:13:53 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.DSoilModel.Forms.FilmStripThumbnail Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • DSoilModel
  • Forms
  • FilmStripThumbnail
Public Member Functions | Properties | List of all members
Deltares.DSoilModel.Forms.FilmStripThumbnail Class Reference

Public Member Functions

FilmStripThumbnail (Image thumbnailImage, StochasticSoilProfile stochasticSoilProfile)

Properties

StochasticSoilProfile | StochasticSoilProfile [get, set]
The stochastic soil profile on which this thumbnail is based on. More...
Image | ThumbnailImage [get, set]
The image to use as thumbnail for the stochastic soil profile. More...
bool | Selected [get, set]
Whether this thumbnail is selected in the filmstrip control. More...

Property Documentation

bool Deltares.DSoilModel.Forms.FilmStripThumbnail.Selected
getset

Whether this thumbnail is selected in the filmstrip control.

StochasticSoilProfile Deltares.DSoilModel.Forms.FilmStripThumbnail.StochasticSoilProfile
getset

The stochastic soil profile on which this thumbnail is based on.

Image Deltares.DSoilModel.Forms.FilmStripThumbnail.ThumbnailImage
getset

The image to use as thumbnail for the stochastic soil profile.

Generated on Tue Dec 15 2015 18:13:53 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • DSoilModel
  • Forms
  • FilmStripThumbnail
Deltares.DSoilModel.Forms.FilmStripThumbnail Member List

This is the complete list of members for Deltares.DSoilModel.Forms.FilmStripThumbnail, including all inherited members.

FilmStripThumbnail(Image thumbnailImage, StochasticSoilProfile stochasticSoilProfile) (defined in Deltares.DSoilModel.Forms.FilmStripThumbnail) | Deltares.DSoilModel.Forms.FilmStripThumbnail
Selected | Deltares.DSoilModel.Forms.FilmStripThumbnail
StochasticSoilProfile | Deltares.DSoilModel.Forms.FilmStripThumbnail
ThumbnailImage | Deltares.DSoilModel.Forms.FilmStripThumbnail
Generated on Tue Dec 15 2015 18:13:53 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.DSoilModel.Forms.HighlightSoilSegment Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • DSoilModel
  • Forms
  • HighlightSoilSegment
Properties | List of all members
Deltares.DSoilModel.Forms.HighlightSoilSegment Class Reference

UI element used for interactively splitting SoilSegments in the map More...

Inheritance diagram for Deltares.DSoilModel.Forms.HighlightSoilSegment:

Properties

SoilSegment | SoilSegment [get, set]
IList< IGeographicPoint > | Points [get]

Detailed Description

UI element used for interactively splitting SoilSegments in the map

Generated on Tue Dec 15 2015 18:13:53 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • DSoilModel
  • Forms
  • HighlightSoilSegment
Deltares.DSoilModel.Forms.HighlightSoilSegment Member List

This is the complete list of members for Deltares.DSoilModel.Forms.HighlightSoilSegment, including all inherited members.

HighlightSoilSegment() (defined in Deltares.DSoilModel.Forms.HighlightSoilSegment) | Deltares.DSoilModel.Forms.HighlightSoilSegment
Points (defined in Deltares.DSoilModel.Forms.HighlightSoilSegment) | Deltares.DSoilModel.Forms.HighlightSoilSegment
SoilSegment (defined in Deltares.DSoilModel.Forms.HighlightSoilSegment) | Deltares.DSoilModel.Forms.HighlightSoilSegment
Generated on Tue Dec 15 2015 18:13:53 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.DSoilModel.Forms.ModalListBox Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • DSoilModel
  • Forms
  • ModalListBox
Public Member Functions | Protected Member Functions | Properties | List of all members
Deltares.DSoilModel.Forms.ModalListBox Class Reference

The ModalListBox class More...

Inheritance diagram for Deltares.DSoilModel.Forms.ModalListBox:

Public Member Functions

ModalListBox ()
Initializes a new instance of the ModalListBox class. More...

Protected Member Functions

override void Dispose (bool disposing)
Clean up any resources being used. More...

Properties

List< String > | Items [set]
Clears and sets the items. More...
String | SelectedItem [get]
Gets the selected item. More...

Detailed Description

The ModalListBox class

Constructor & Destructor Documentation

Deltares.DSoilModel.Forms.ModalListBox.ModalListBox ( )

Initializes a new instance of the ModalListBox class.

Member Function Documentation

override void Deltares.DSoilModel.Forms.ModalListBox.Dispose ( bool disposing )
protected

Clean up any resources being used.

Parameters
disposing true if managed resources should be disposed; otherwise, false.

Property Documentation

List<String> Deltares.DSoilModel.Forms.ModalListBox.Items
set

Clears and sets the items.

The items.

String Deltares.DSoilModel.Forms.ModalListBox.SelectedItem
get

Gets the selected item.

The selected item.

Generated on Tue Dec 15 2015 18:13:54 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • DSoilModel
  • Forms
  • ModalListBox
Deltares.DSoilModel.Forms.ModalListBox Member List

This is the complete list of members for Deltares.DSoilModel.Forms.ModalListBox, including all inherited members.

Dispose(bool disposing) | Deltares.DSoilModel.Forms.ModalListBox | protected
Items | Deltares.DSoilModel.Forms.ModalListBox |
ModalListBox() | Deltares.DSoilModel.Forms.ModalListBox |
SelectedItem | Deltares.DSoilModel.Forms.ModalListBox |
Generated on Tue Dec 15 2015 18:13:54 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.DSoilModel.Forms.SoilSegmentSplitLocationControl Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • DSoilModel
  • Forms
  • SoilSegmentSplitLocationControl
Protected Member Functions | Properties | List of all members
Deltares.DSoilModel.Forms.SoilSegmentSplitLocationControl Class Reference
Inheritance diagram for Deltares.DSoilModel.Forms.SoilSegmentSplitLocationControl:

Protected Member Functions

override void Dispose (bool disposing)
Clean up any resources being used. More...

Properties

object | SelectedObject [get, set]
bool | IsVisible [get]

Member Function Documentation

override void Deltares.DSoilModel.Forms.SoilSegmentSplitLocationControl.Dispose ( bool disposing )
protected

Clean up any resources being used.

Parameters
disposing true if managed resources should be disposed; otherwise, false.
Generated on Tue Dec 15 2015 18:13:54 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • DSoilModel
  • Forms
  • SoilSegmentSplitLocationControl
Deltares.DSoilModel.Forms.SoilSegmentSplitLocationControl Member List

This is the complete list of members for Deltares.DSoilModel.Forms.SoilSegmentSplitLocationControl, including all inherited members.

Dispose(bool disposing) | Deltares.DSoilModel.Forms.SoilSegmentSplitLocationControl | protected
IsVisible (defined in Deltares.DSoilModel.Forms.SoilSegmentSplitLocationControl) | Deltares.DSoilModel.Forms.SoilSegmentSplitLocationControl |
SelectedObject (defined in Deltares.DSoilModel.Forms.SoilSegmentSplitLocationControl) | Deltares.DSoilModel.Forms.SoilSegmentSplitLocationControl |
SoilSegmentSplitLocationControl() (defined in Deltares.DSoilModel.Forms.SoilSegmentSplitLocationControl) | Deltares.DSoilModel.Forms.SoilSegmentSplitLocationControl |
Generated on Tue Dec 15 2015 18:13:54 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.DSoilModel.Forms.SosSoilLayer1DControl Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • DSoilModel
  • Forms
  • SosSoilLayer1DControl
Protected Member Functions | Properties | List of all members
Deltares.DSoilModel.Forms.SosSoilLayer1DControl Class Reference
Inheritance diagram for Deltares.DSoilModel.Forms.SosSoilLayer1DControl:

Protected Member Functions

override void Dispose (bool disposing)
Clean up any resources being used. More...

Properties

object | SelectedObject [get, set]
bool | IsVisible [get]

Member Function Documentation

override void Deltares.DSoilModel.Forms.SosSoilLayer1DControl.Dispose ( bool disposing )
protected

Clean up any resources being used.

Parameters
disposing true if managed resources should be disposed; otherwise, false.
Generated on Tue Dec 15 2015 18:13:54 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • DSoilModel
  • Forms
  • SosSoilLayer1DControl
Deltares.DSoilModel.Forms.SosSoilLayer1DControl Member List

This is the complete list of members for Deltares.DSoilModel.Forms.SosSoilLayer1DControl, including all inherited members.

Dispose(bool disposing) | Deltares.DSoilModel.Forms.SosSoilLayer1DControl | protected
IsVisible (defined in Deltares.DSoilModel.Forms.SosSoilLayer1DControl) | Deltares.DSoilModel.Forms.SosSoilLayer1DControl |
SelectedObject (defined in Deltares.DSoilModel.Forms.SosSoilLayer1DControl) | Deltares.DSoilModel.Forms.SosSoilLayer1DControl |
SosSoilLayer1DControl() (defined in Deltares.DSoilModel.Forms.SosSoilLayer1DControl) | Deltares.DSoilModel.Forms.SosSoilLayer1DControl |
Generated on Tue Dec 15 2015 18:13:54 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.DSoilModel.Forms.SosSoilProfile1DControl Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • DSoilModel
  • Forms
  • SosSoilProfile1DControl
Public Member Functions | Protected Member Functions | Properties | List of all members
Deltares.DSoilModel.Forms.SosSoilProfile1DControl Class Reference
Inheritance diagram for Deltares.DSoilModel.Forms.SosSoilProfile1DControl:

Public Member Functions

void ClearControl ()
Method to allow clearing the selected object and making this control invisible. More...

Protected Member Functions

override void Dispose (bool disposing)
Clean up any resources being used. More...

Properties

object | SelectedObject [get, set]
Property for selected 1D soil profile. More...
bool | IsVisible [get]
Determine visibility of this control. More...

Member Function Documentation

void Deltares.DSoilModel.Forms.SosSoilProfile1DControl.ClearControl ( )

Method to allow clearing the selected object and making this control invisible.

References Deltares.Standard.Forms.DExpress.BindSupport.Assign().

override void Deltares.DSoilModel.Forms.SosSoilProfile1DControl.Dispose ( bool disposing )
protected

Clean up any resources being used.

Parameters
disposing true if managed resources should be disposed; otherwise, false.

Property Documentation

bool Deltares.DSoilModel.Forms.SosSoilProfile1DControl.IsVisible
get

Determine visibility of this control.

object Deltares.DSoilModel.Forms.SosSoilProfile1DControl.SelectedObject
getset

Property for selected 1D soil profile.

Generated on Tue Dec 15 2015 18:13:55 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • DSoilModel
  • Forms
  • SosSoilProfile1DControl
Deltares.DSoilModel.Forms.SosSoilProfile1DControl Member List

This is the complete list of members for Deltares.DSoilModel.Forms.SosSoilProfile1DControl, including all inherited members.

ClearControl() | Deltares.DSoilModel.Forms.SosSoilProfile1DControl |
Dispose(bool disposing) | Deltares.DSoilModel.Forms.SosSoilProfile1DControl | protected
IsVisible | Deltares.DSoilModel.Forms.SosSoilProfile1DControl |
SelectedObject | Deltares.DSoilModel.Forms.SosSoilProfile1DControl |
SosSoilProfile1DControl() (defined in Deltares.DSoilModel.Forms.SosSoilProfile1DControl) | Deltares.DSoilModel.Forms.SosSoilProfile1DControl |
Generated on Tue Dec 15 2015 18:13:55 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geometry.Forms.Properties.Resources Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geometry
  • Forms
  • Properties
  • Resources
Properties | List of all members
Deltares.Geometry.Forms.Properties.Resources Class Reference

A strongly-typed resource class, for looking up localized strings, etc. More...

Properties

static global::System.Resources.ResourceManager | ResourceManager [get]
Returns the cached ResourceManager instance used by this class. More...
static global::System.Globalization.CultureInfo | Culture [get, set]
Overrides the current thread's CurrentUICulture property for all resource lookups using this strongly typed resource class. More...
static string | AddPointCaption [get]
Looks up a localized string similar to Add Point. More...
static string | AddPolylineCaption [get]
Looks up a localized string similar to Add Polyline. More...
static string | AutomaticRegenerationCaption [get]
Looks up a localized string similar to Automatic Regeneration ON/OFF. More...
static System.Drawing.Bitmap | AutoRegenerationONOFFBarCheckItem_Glyph [get]
static string | ClosedCaption [get]
Looks up a localized string similar to Closed. More...
static string | CopyPointCaption [get]
Looks up a localized string similar to Copy Point. More...
static string | CopyPolylineCaption [get]
Looks up a localized string similar to Copy Polyline. More...
static string | CutPointCaption [get]
Looks up a localized string similar to Cut Point. More...
static string | CutPolylineCaption [get]
Looks up a localized string similar to Cut Polyline. More...
static string | DeletePointCaption [get]
Looks up a localized string similar to Delete Point. More...
static string | DeletePolylineCaption [get]
Looks up a localized string similar to Delete Polyline. More...
static string | InsertPointCaption [get]
Looks up a localized string similar to Insert Point. More...
static string | InsertPolylineCaption [get]
Looks up a localized string similar to Insert Polyline. More...
static string | MoveDownCaption [get]
Looks up a localized string similar to Move Polyline Down. More...
static string | MoveupCaption [get]
Looks up a localized string similar to Move Polyline up. More...
static string | PastePointCaption [get]
Looks up a localized string similar to Paste Point. More...
static string | PastePolylineCaption [get]
Looks up a localized string similar to Paste Polyline. More...

Detailed Description

A strongly-typed resource class, for looking up localized strings, etc.

Property Documentation

string Deltares.Geometry.Forms.Properties.Resources.AddPointCaption
staticgetpackage

Looks up a localized string similar to Add Point.

string Deltares.Geometry.Forms.Properties.Resources.AddPolylineCaption
staticgetpackage

Looks up a localized string similar to Add Polyline.

string Deltares.Geometry.Forms.Properties.Resources.AutomaticRegenerationCaption
staticgetpackage

Looks up a localized string similar to Automatic Regeneration ON/OFF.

string Deltares.Geometry.Forms.Properties.Resources.ClosedCaption
staticgetpackage

Looks up a localized string similar to Closed.

string Deltares.Geometry.Forms.Properties.Resources.CopyPointCaption
staticgetpackage

Looks up a localized string similar to Copy Point.

string Deltares.Geometry.Forms.Properties.Resources.CopyPolylineCaption
staticgetpackage

Looks up a localized string similar to Copy Polyline.

global.System.Globalization.CultureInfo Deltares.Geometry.Forms.Properties.Resources.Culture
staticgetsetpackage

Overrides the current thread's CurrentUICulture property for all resource lookups using this strongly typed resource class.

string Deltares.Geometry.Forms.Properties.Resources.CutPointCaption
staticgetpackage

Looks up a localized string similar to Cut Point.

string Deltares.Geometry.Forms.Properties.Resources.CutPolylineCaption
staticgetpackage

Looks up a localized string similar to Cut Polyline.

string Deltares.Geometry.Forms.Properties.Resources.DeletePointCaption
staticgetpackage

Looks up a localized string similar to Delete Point.

string Deltares.Geometry.Forms.Properties.Resources.DeletePolylineCaption
staticgetpackage

Looks up a localized string similar to Delete Polyline.

string Deltares.Geometry.Forms.Properties.Resources.InsertPointCaption
staticgetpackage

Looks up a localized string similar to Insert Point.

string Deltares.Geometry.Forms.Properties.Resources.InsertPolylineCaption
staticgetpackage

Looks up a localized string similar to Insert Polyline.

string Deltares.Geometry.Forms.Properties.Resources.MoveDownCaption
staticgetpackage

Looks up a localized string similar to Move Polyline Down.

string Deltares.Geometry.Forms.Properties.Resources.MoveupCaption
staticgetpackage

Looks up a localized string similar to Move Polyline up.

string Deltares.Geometry.Forms.Properties.Resources.PastePointCaption
staticgetpackage

Looks up a localized string similar to Paste Point.

string Deltares.Geometry.Forms.Properties.Resources.PastePolylineCaption
staticgetpackage

Looks up a localized string similar to Paste Polyline.

global.System.Resources.ResourceManager Deltares.Geometry.Forms.Properties.Resources.ResourceManager
staticgetpackage

Returns the cached ResourceManager instance used by this class.

Generated on Tue Dec 15 2015 18:13:59 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geometry
  • Forms
  • Properties
  • Resources
Deltares.Geometry.Forms.Properties.Resources Member List

This is the complete list of members for Deltares.Geometry.Forms.Properties.Resources, including all inherited members.

AddPointCaption | Deltares.Geometry.Forms.Properties.Resources | packagestatic
AddPolylineCaption | Deltares.Geometry.Forms.Properties.Resources | packagestatic
AutomaticRegenerationCaption | Deltares.Geometry.Forms.Properties.Resources | packagestatic
AutoRegenerationONOFFBarCheckItem_Glyph (defined in Deltares.Geometry.Forms.Properties.Resources) | Deltares.Geometry.Forms.Properties.Resources | packagestatic
ClosedCaption | Deltares.Geometry.Forms.Properties.Resources | packagestatic
CopyPointCaption | Deltares.Geometry.Forms.Properties.Resources | packagestatic
CopyPolylineCaption | Deltares.Geometry.Forms.Properties.Resources | packagestatic
Culture | Deltares.Geometry.Forms.Properties.Resources | packagestatic
CutPointCaption | Deltares.Geometry.Forms.Properties.Resources | packagestatic
CutPolylineCaption | Deltares.Geometry.Forms.Properties.Resources | packagestatic
DeletePointCaption | Deltares.Geometry.Forms.Properties.Resources | packagestatic
DeletePolylineCaption | Deltares.Geometry.Forms.Properties.Resources | packagestatic
InsertPointCaption | Deltares.Geometry.Forms.Properties.Resources | packagestatic
InsertPolylineCaption | Deltares.Geometry.Forms.Properties.Resources | packagestatic
MoveDownCaption | Deltares.Geometry.Forms.Properties.Resources | packagestatic
MoveupCaption | Deltares.Geometry.Forms.Properties.Resources | packagestatic
PastePointCaption | Deltares.Geometry.Forms.Properties.Resources | packagestatic
PastePolylineCaption | Deltares.Geometry.Forms.Properties.Resources | packagestatic
ResourceManager | Deltares.Geometry.Forms.Properties.Resources | packagestatic
Resources() (defined in Deltares.Geometry.Forms.Properties.Resources) | Deltares.Geometry.Forms.Properties.Resources | package
Generated on Tue Dec 15 2015 18:13:59 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geometry.Forms.ColoredDrawingObject Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geometry
  • Forms
  • ColoredDrawingObject
Public Member Functions | Protected Member Functions | Properties | List of all members
Deltares.Geometry.Forms.ColoredDrawingObject Class Reference
Inheritance diagram for Deltares.Geometry.Forms.ColoredDrawingObject:
Deltares.Geometry.Forms.DrawingObject Deltares.Geometry.Forms.IDrawingObject Deltares.Standard.Forms.IShape Deltares.Geotechnics.Forms.DrawingAnchorAttachment Deltares.Geotechnics.Forms.DrawingSheetPiling

Public Member Functions

ColoredDrawingObject (Color fillColor, Color strokeColor)
- Public Member Functions inherited from Deltares.Geometry.Forms.DrawingObject
Point3D | GetScaled3DPoint (IProjection projection, Point3D aOrginalPoint)
Converts the 3DPoint to screen coordinates More...
Point3D | GetScreenPoint (IProjection projection, Point2D orginalPoint)
Converts Point from 3D space to screen coordinates, assuming Y = 0 More...
Point3D | GetScreenPoint (IProjection projection, Point3D orginalPoint)
Converts Point from 3D space to screen coordinates More...
Point3D | GetScreenPoint (IProjection projection, double x, double z)
Converts 3D x, y coordinates to screen coordinates, assuming Y = 0 More...
override string | ToString ()
virtual void | Draw3D (GraphicsInfo info)
Render this drawing object in 3D space. More...
virtual void | SetDataObject (object aDataObject)
Sets the geotechnics entity that this drawing object represents More...
virtual object | GetDataObject ()
Gets the geotechnics entity that this drawing object represents More...
virtual void | UpdateDataDragDrop (Vector3D aVect3D, List< IDrawingObject > aDraggedObjects)
Update the position and or orientation of a drawing object as the user is dragging it. More...
virtual void | UpdateDataDragDrop (Point3D aBeginDragPoint, Vector3D vector)
Update the position and or orientation of a drawing object as the user is dragging it. More...
virtual void | OnBeginDrag (IProjection projection, Point3D aBeginDragDropPoint, bool isIndividualDrag)
Method which is called when the user initiates a drag-drop operation More...
virtual CardinalDirection | GetCardinalDirectionOnEdgeContainingPoint (Point point)
virtual void | OnDragging (IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D)
Method which is called during drag-drop operations More...
virtual void | OnEndDrag (IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D)
Method which is called when the user ends a drag-drop operation. More...
virtual bool | CheckHitForSelection (IProjection projection, Point3D point, double tolerance)
Check if given point coordinates intersect the rendered drawing object. More...
virtual double | GetStandardSize (object aDraw3DInterface, Point3D aPoint3D)
void | GetScaled3DPoint (IProjection projection, Point3D aOrginalPoint, ref Point3D aPointTobeScaled)
Converts the 3DPoint to screen coordinates More...
double | GetScaledXPoint (IProjection projection, double aOrginalCordinate)
Converts X Coordinate in 3D space to a screen X Coordinate More...
virtual bool | ContainsPoint (IProjection projection, Point point)
Determines if a given point screen coordinate is within the drawing object. More...
virtual Rectangle | GetExtents (IProjection projection)
Returns the bounding box of the shape. More...
virtual void | Draw (GraphicsInfo info)
Render this object in 3D space. More...
virtual void | DrawLabel (GraphicsInfo info)
Renders a label or tooltip to provide some information in text for this object. More...
virtual void | Move (IProjection projection, Point2D startPosition, SizeF worldSize)
virtual void | BeginMove (IProjection projection, Point2D startPosition)
virtual void | EndMove (IProjection projection, Point2D startPosition, SizeF worldSize)
virtual bool | AllowDrop (object data)
Boolean which indicates if other drawing objects can be dropped on given drawing objects More...
virtual void | Drop (object data)
Ends a drag-drop operation More...
virtual IEnumerable< object > | DataItemAt (Point point, Projection projection)

Protected Member Functions

Color | UpdateCurrentColor (GraphicsInfo info, bool draggingElement)
Color | UpdateCurrentColor (GraphicsInfo info, bool draggingElement, bool draggingAnything)
Color | UpdateCurrentColor (GraphicsInfo info, bool draggingElement, bool draggingAnything, Color normalFillColor, Color normalStrokeColor)
void | setCurrentColor (GraphicsInfo info, Color fillColor, Color strokeColor)
- Protected Member Functions inherited from Deltares.Geometry.Forms.DrawingObject
virtual int | GetThickness (GraphicsInfo info)
Gets the thickness in screen pixels of a drawing object. More...

Properties

Color | NormalFillColor [get]
Color | NormalStrokeColor [get]
- Properties inherited from Deltares.Geometry.Forms.DrawingObject
virtual bool | CanResize [get]
Boolean which indicates if a drawing object can be resized. More...
virtual bool | Selected [get, set]
Boolean which indicates if a drawing object is currently selected. More...
string | ToolTip [get]
Description which is shown as a tooltip when the mouse hovers over drawing object. More...
string | Name [get, set]
Gets or sets the name of a drawing object. More...
bool | IsVisible [get, set]
bool | HasBeenUpdated [get, set]
virtual bool | IsDragableOnReslultMode [get]
virtual int | Layer [get, set]
object | DataObject [get, set]
- Properties inherited from Deltares.Geometry.Forms.IDrawingObject
string | Name [get, set]
bool | IsVisible [get, set]
bool | HasBeenUpdated [get, set]
Gets or sets the update status of a drawing object. More...
bool | IsDragableOnReslultMode [get]
- Properties inherited from Deltares.Standard.Forms.IShape
object | DataObject [get, set]
int | Layer [get]
Generated on Tue Dec 15 2015 18:13:55 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geometry
  • Forms
  • ColoredDrawingObject
Deltares.Geometry.Forms.ColoredDrawingObject Member List

This is the complete list of members for Deltares.Geometry.Forms.ColoredDrawingObject, including all inherited members.

AllowDrop(object data) | Deltares.Geometry.Forms.DrawingObject | virtual
BeginMove(IProjection projection, Point2D startPosition) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
CanResize | Deltares.Geometry.Forms.DrawingObject |
CheckHitForSelection(IProjection projection, Point3D point, double tolerance) | Deltares.Geometry.Forms.DrawingObject | virtual
ColoredDrawingObject(Color fillColor, Color strokeColor) (defined in Deltares.Geometry.Forms.ColoredDrawingObject) | Deltares.Geometry.Forms.ColoredDrawingObject |
ContainsPoint(IProjection projection, Point point) | Deltares.Geometry.Forms.DrawingObject | virtual
DataItemAt(Point point, Projection projection) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
DataObject (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
Draw(GraphicsInfo info) | Deltares.Geometry.Forms.DrawingObject | virtual
Draw3D(GraphicsInfo info) | Deltares.Geometry.Forms.DrawingObject | virtual
DrawingObject() (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
DrawLabel(GraphicsInfo info) | Deltares.Geometry.Forms.DrawingObject | virtual
Drop(object data) | Deltares.Geometry.Forms.DrawingObject | virtual
EndMove(IProjection projection, Point2D startPosition, SizeF worldSize) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetCardinalDirectionOnEdgeContainingPoint(Point point) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetDataObject() | Deltares.Geometry.Forms.DrawingObject | virtual
GetExtents(IProjection projection) | Deltares.Geometry.Forms.DrawingObject | virtual
GetScaled3DPoint(IProjection projection, Point3D aOrginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScaled3DPoint(IProjection projection, Point3D aOrginalPoint, ref Point3D aPointTobeScaled) | Deltares.Geometry.Forms.DrawingObject |
GetScaledXPoint(IProjection projection, double aOrginalCordinate) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, Point2D orginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, Point3D orginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, double x, double z) | Deltares.Geometry.Forms.DrawingObject |
GetStandardSize(object aDraw3DInterface, Point3D aPoint3D) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetThickness(GraphicsInfo info) | Deltares.Geometry.Forms.DrawingObject | protectedvirtual
HasBeenUpdated (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
IsDragableOnReslultMode (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
IsVisible (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
Layer (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
Move(IProjection projection, Point2D startPosition, SizeF worldSize) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
Name | Deltares.Geometry.Forms.DrawingObject |
NormalFillColor (defined in Deltares.Geometry.Forms.ColoredDrawingObject) | Deltares.Geometry.Forms.ColoredDrawingObject | protected
NormalStrokeColor (defined in Deltares.Geometry.Forms.ColoredDrawingObject) | Deltares.Geometry.Forms.ColoredDrawingObject | protected
OnBeginDrag(IProjection projection, Point3D aBeginDragDropPoint, bool isIndividualDrag) | Deltares.Geometry.Forms.DrawingObject | virtual
OnDragging(IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D) | Deltares.Geometry.Forms.DrawingObject | virtual
OnEndDrag(IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D) | Deltares.Geometry.Forms.DrawingObject | virtual
Selected | Deltares.Geometry.Forms.DrawingObject |
setCurrentColor(GraphicsInfo info, Color fillColor, Color strokeColor) (defined in Deltares.Geometry.Forms.ColoredDrawingObject) | Deltares.Geometry.Forms.ColoredDrawingObject | protected
SetDataObject(object aDataObject) | Deltares.Geometry.Forms.DrawingObject | virtual
ToolTip | Deltares.Geometry.Forms.DrawingObject |
ToString() (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
UpdateCurrentColor(GraphicsInfo info, bool draggingElement) (defined in Deltares.Geometry.Forms.ColoredDrawingObject) | Deltares.Geometry.Forms.ColoredDrawingObject | protected
UpdateCurrentColor(GraphicsInfo info, bool draggingElement, bool draggingAnything) (defined in Deltares.Geometry.Forms.ColoredDrawingObject) | Deltares.Geometry.Forms.ColoredDrawingObject | protected
UpdateCurrentColor(GraphicsInfo info, bool draggingElement, bool draggingAnything, Color normalFillColor, Color normalStrokeColor) (defined in Deltares.Geometry.Forms.ColoredDrawingObject) | Deltares.Geometry.Forms.ColoredDrawingObject | protected
UpdateDataDragDrop(Vector3D aVect3D, List< IDrawingObject > aDraggedObjects) | Deltares.Geometry.Forms.DrawingObject | virtual
UpdateDataDragDrop(Point3D aBeginDragPoint, Vector3D vector) | Deltares.Geometry.Forms.DrawingObject | virtual
Generated on Tue Dec 15 2015 18:13:55 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geometry.Forms.DrawingBoundingBox Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geometry
  • Forms
  • DrawingBoundingBox
Public Member Functions | List of all members
Deltares.Geometry.Forms.DrawingBoundingBox Class Reference

Drawing object that represents bounding box (rectangle) entities in the geometry (cross section) editor. More...

Inheritance diagram for Deltares.Geometry.Forms.DrawingBoundingBox:
Deltares.Geometry.Forms.DrawingObject Deltares.Geometry.Forms.IDrawingObject Deltares.Standard.Forms.IShape

Public Member Functions

override void | SetDataObject (object aDataObject)
Sets the geotechnics entity that this drawing object represents More...
override object | GetDataObject ()
Gets the geotechnics entity that this drawing object represents More...
override void | Draw3D (GraphicsInfo info)
Render this drawing object in 3D space. More...
override Rectangle | GetExtents (IProjection projection)
Returns the bounding box of the shape. More...
- Public Member Functions inherited from Deltares.Geometry.Forms.DrawingObject
Point3D | GetScaled3DPoint (IProjection projection, Point3D aOrginalPoint)
Converts the 3DPoint to screen coordinates More...
Point3D | GetScreenPoint (IProjection projection, Point2D orginalPoint)
Converts Point from 3D space to screen coordinates, assuming Y = 0 More...
Point3D | GetScreenPoint (IProjection projection, Point3D orginalPoint)
Converts Point from 3D space to screen coordinates More...
Point3D | GetScreenPoint (IProjection projection, double x, double z)
Converts 3D x, y coordinates to screen coordinates, assuming Y = 0 More...
override string | ToString ()
virtual void | UpdateDataDragDrop (Vector3D aVect3D, List< IDrawingObject > aDraggedObjects)
Update the position and or orientation of a drawing object as the user is dragging it. More...
virtual void | UpdateDataDragDrop (Point3D aBeginDragPoint, Vector3D vector)
Update the position and or orientation of a drawing object as the user is dragging it. More...
virtual void | OnBeginDrag (IProjection projection, Point3D aBeginDragDropPoint, bool isIndividualDrag)
Method which is called when the user initiates a drag-drop operation More...
virtual CardinalDirection | GetCardinalDirectionOnEdgeContainingPoint (Point point)
virtual void | OnDragging (IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D)
Method which is called during drag-drop operations More...
virtual void | OnEndDrag (IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D)
Method which is called when the user ends a drag-drop operation. More...
virtual bool | CheckHitForSelection (IProjection projection, Point3D point, double tolerance)
Check if given point coordinates intersect the rendered drawing object. More...
virtual double | GetStandardSize (object aDraw3DInterface, Point3D aPoint3D)
void | GetScaled3DPoint (IProjection projection, Point3D aOrginalPoint, ref Point3D aPointTobeScaled)
Converts the 3DPoint to screen coordinates More...
double | GetScaledXPoint (IProjection projection, double aOrginalCordinate)
Converts X Coordinate in 3D space to a screen X Coordinate More...
virtual bool | ContainsPoint (IProjection projection, Point point)
Determines if a given point screen coordinate is within the drawing object. More...
virtual void | Draw (GraphicsInfo info)
Render this object in 3D space. More...
virtual void | DrawLabel (GraphicsInfo info)
Renders a label or tooltip to provide some information in text for this object. More...
virtual void | Move (IProjection projection, Point2D startPosition, SizeF worldSize)
virtual void | BeginMove (IProjection projection, Point2D startPosition)
virtual void | EndMove (IProjection projection, Point2D startPosition, SizeF worldSize)
virtual bool | AllowDrop (object data)
Boolean which indicates if other drawing objects can be dropped on given drawing objects More...
virtual void | Drop (object data)
Ends a drag-drop operation More...
virtual IEnumerable< object > | DataItemAt (Point point, Projection projection)

Additional Inherited Members

- Protected Member Functions inherited from Deltares.Geometry.Forms.DrawingObject
virtual int | GetThickness (GraphicsInfo info)
Gets the thickness in screen pixels of a drawing object. More...
- Properties inherited from Deltares.Geometry.Forms.DrawingObject
virtual bool | CanResize [get]
Boolean which indicates if a drawing object can be resized. More...
virtual bool | Selected [get, set]
Boolean which indicates if a drawing object is currently selected. More...
string | ToolTip [get]
Description which is shown as a tooltip when the mouse hovers over drawing object. More...
string | Name [get, set]
Gets or sets the name of a drawing object. More...
bool | IsVisible [get, set]
bool | HasBeenUpdated [get, set]
virtual bool | IsDragableOnReslultMode [get]
virtual int | Layer [get, set]
object | DataObject [get, set]
- Properties inherited from Deltares.Geometry.Forms.IDrawingObject
string | Name [get, set]
bool | IsVisible [get, set]
bool | HasBeenUpdated [get, set]
Gets or sets the update status of a drawing object. More...
bool | IsDragableOnReslultMode [get]
- Properties inherited from Deltares.Standard.Forms.IShape
object | DataObject [get, set]
int | Layer [get]

Detailed Description

Drawing object that represents bounding box (rectangle) entities in the geometry (cross section) editor.

Member Function Documentation

override void Deltares.Geometry.Forms.DrawingBoundingBox.Draw3D ( GraphicsInfo info )
virtual

Render this drawing object in 3D space.

Parameters
info Rendering target information.

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

override object Deltares.Geometry.Forms.DrawingBoundingBox.GetDataObject ( )
virtual

Gets the geotechnics entity that this drawing object represents

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

override Rectangle Deltares.Geometry.Forms.DrawingBoundingBox.GetExtents ( IProjection projection )
virtual

Returns the bounding box of the shape.

Parameters
projection Projection used for drawing.
Returns
The bounding box of the shape; Null if none can be determined.

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

override void Deltares.Geometry.Forms.DrawingBoundingBox.SetDataObject ( object aDataObject )
virtual

Sets the geotechnics entity that this drawing object represents

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

Generated on Tue Dec 15 2015 18:13:55 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geometry
  • Forms
  • DrawingBoundingBox
Deltares.Geometry.Forms.DrawingBoundingBox Member List

This is the complete list of members for Deltares.Geometry.Forms.DrawingBoundingBox, including all inherited members.

AllowDrop(object data) | Deltares.Geometry.Forms.DrawingObject | virtual
BeginMove(IProjection projection, Point2D startPosition) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
CanResize | Deltares.Geometry.Forms.DrawingObject |
CheckHitForSelection(IProjection projection, Point3D point, double tolerance) | Deltares.Geometry.Forms.DrawingObject | virtual
ContainsPoint(IProjection projection, Point point) | Deltares.Geometry.Forms.DrawingObject | virtual
DataItemAt(Point point, Projection projection) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
DataObject (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
Draw(GraphicsInfo info) | Deltares.Geometry.Forms.DrawingObject | virtual
Draw3D(GraphicsInfo info) | Deltares.Geometry.Forms.DrawingBoundingBox | virtual
DrawingObject() (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
DrawLabel(GraphicsInfo info) | Deltares.Geometry.Forms.DrawingObject | virtual
Drop(object data) | Deltares.Geometry.Forms.DrawingObject | virtual
EndMove(IProjection projection, Point2D startPosition, SizeF worldSize) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetCardinalDirectionOnEdgeContainingPoint(Point point) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetDataObject() | Deltares.Geometry.Forms.DrawingBoundingBox | virtual
GetExtents(IProjection projection) | Deltares.Geometry.Forms.DrawingBoundingBox | virtual
GetScaled3DPoint(IProjection projection, Point3D aOrginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScaled3DPoint(IProjection projection, Point3D aOrginalPoint, ref Point3D aPointTobeScaled) | Deltares.Geometry.Forms.DrawingObject |
GetScaledXPoint(IProjection projection, double aOrginalCordinate) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, Point2D orginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, Point3D orginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, double x, double z) | Deltares.Geometry.Forms.DrawingObject |
GetStandardSize(object aDraw3DInterface, Point3D aPoint3D) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetThickness(GraphicsInfo info) | Deltares.Geometry.Forms.DrawingObject | protectedvirtual
HasBeenUpdated (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
IsDragableOnReslultMode (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
IsVisible (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
Layer (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
Move(IProjection projection, Point2D startPosition, SizeF worldSize) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
Name | Deltares.Geometry.Forms.DrawingObject |
OnBeginDrag(IProjection projection, Point3D aBeginDragDropPoint, bool isIndividualDrag) | Deltares.Geometry.Forms.DrawingObject | virtual
OnDragging(IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D) | Deltares.Geometry.Forms.DrawingObject | virtual
OnEndDrag(IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D) | Deltares.Geometry.Forms.DrawingObject | virtual
Selected | Deltares.Geometry.Forms.DrawingObject |
SetDataObject(object aDataObject) | Deltares.Geometry.Forms.DrawingBoundingBox | virtual
ToolTip | Deltares.Geometry.Forms.DrawingObject |
ToString() (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
UpdateDataDragDrop(Vector3D aVect3D, List< IDrawingObject > aDraggedObjects) | Deltares.Geometry.Forms.DrawingObject | virtual
UpdateDataDragDrop(Point3D aBeginDragPoint, Vector3D vector) | Deltares.Geometry.Forms.DrawingObject | virtual
Generated on Tue Dec 15 2015 18:13:55 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geometry.Forms.DrawingLine Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geometry
  • Forms
  • DrawingLine
Public Member Functions | Properties | List of all members
Deltares.Geometry.Forms.DrawingLine Class Reference

Drawing object that represents line (GeometryCurve) entities in the geometry (crossection) editor. More...

Inheritance diagram for Deltares.Geometry.Forms.DrawingLine:
Deltares.Geometry.Forms.DrawingObject Deltares.Geometry.Forms.IDrawingObject Deltares.Standard.Forms.IShape

Public Member Functions

override void | SetDataObject (object aDataObject)
Sets the geotechnics entity that this drawing object represents More...
override object | GetDataObject ()
Gets the geotechnics entity that this drawing object represents More...
override void | OnBeginDrag (IProjection projection, Point3D aBeginDragDropPoint, bool isIndividualDrag)
Method which is called when the user initiates a drag-drop operation More...
override void | UpdateDataDragDrop (Point3D beginDragPoint, Vector3D vector)
Update the position and or orientation of a drawing object as the user is dragging it. More...
override bool | ContainsPoint (IProjection projection, Point point)
Determines if a given point screen coordinate is within the drawing object. More...
override void | Draw3D (GraphicsInfo info)
Render this drawing object in 3D space. More...
override void | DrawLabel (GraphicsInfo info)
Renders a label or tooltip to provide some information in text for this object. More...
- Public Member Functions inherited from Deltares.Geometry.Forms.DrawingObject
Point3D | GetScaled3DPoint (IProjection projection, Point3D aOrginalPoint)
Converts the 3DPoint to screen coordinates More...
Point3D | GetScreenPoint (IProjection projection, Point2D orginalPoint)
Converts Point from 3D space to screen coordinates, assuming Y = 0 More...
Point3D | GetScreenPoint (IProjection projection, Point3D orginalPoint)
Converts Point from 3D space to screen coordinates More...
Point3D | GetScreenPoint (IProjection projection, double x, double z)
Converts 3D x, y coordinates to screen coordinates, assuming Y = 0 More...
override string | ToString ()
virtual void | UpdateDataDragDrop (Vector3D aVect3D, List< IDrawingObject > aDraggedObjects)
Update the position and or orientation of a drawing object as the user is dragging it. More...
virtual CardinalDirection | GetCardinalDirectionOnEdgeContainingPoint (Point point)
virtual void | OnDragging (IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D)
Method which is called during drag-drop operations More...
virtual void | OnEndDrag (IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D)
Method which is called when the user ends a drag-drop operation. More...
virtual bool | CheckHitForSelection (IProjection projection, Point3D point, double tolerance)
Check if given point coordinates intersect the rendered drawing object. More...
virtual double | GetStandardSize (object aDraw3DInterface, Point3D aPoint3D)
void | GetScaled3DPoint (IProjection projection, Point3D aOrginalPoint, ref Point3D aPointTobeScaled)
Converts the 3DPoint to screen coordinates More...
double | GetScaledXPoint (IProjection projection, double aOrginalCordinate)
Converts X Coordinate in 3D space to a screen X Coordinate More...
virtual Rectangle | GetExtents (IProjection projection)
Returns the bounding box of the shape. More...
virtual void | Draw (GraphicsInfo info)
Render this object in 3D space. More...
virtual void | Move (IProjection projection, Point2D startPosition, SizeF worldSize)
virtual void | BeginMove (IProjection projection, Point2D startPosition)
virtual void | EndMove (IProjection projection, Point2D startPosition, SizeF worldSize)
virtual bool | AllowDrop (object data)
Boolean which indicates if other drawing objects can be dropped on given drawing objects More...
virtual void | Drop (object data)
Ends a drag-drop operation More...
virtual IEnumerable< object > | DataItemAt (Point point, Projection projection)

Properties

int | LineWidth [get, set]
Control the plotted line width More...
- Properties inherited from Deltares.Geometry.Forms.DrawingObject
virtual bool | CanResize [get]
Boolean which indicates if a drawing object can be resized. More...
virtual bool | Selected [get, set]
Boolean which indicates if a drawing object is currently selected. More...
string | ToolTip [get]
Description which is shown as a tooltip when the mouse hovers over drawing object. More...
string | Name [get, set]
Gets or sets the name of a drawing object. More...
bool | IsVisible [get, set]
bool | HasBeenUpdated [get, set]
virtual bool | IsDragableOnReslultMode [get]
virtual int | Layer [get, set]
object | DataObject [get, set]
- Properties inherited from Deltares.Geometry.Forms.IDrawingObject
string | Name [get, set]
bool | IsVisible [get, set]
bool | HasBeenUpdated [get, set]
Gets or sets the update status of a drawing object. More...
bool | IsDragableOnReslultMode [get]
- Properties inherited from Deltares.Standard.Forms.IShape
object | DataObject [get, set]
int | Layer [get]

Additional Inherited Members

- Protected Member Functions inherited from Deltares.Geometry.Forms.DrawingObject
virtual int GetThickness (GraphicsInfo info)
Gets the thickness in screen pixels of a drawing object. More...

Detailed Description

Drawing object that represents line (GeometryCurve) entities in the geometry (crossection) editor.

See also
GeometryCurve

Member Function Documentation

override bool Deltares.Geometry.Forms.DrawingLine.ContainsPoint | ( | IProjection | projection,
 |  | Point | point
 | ) |  |
virtual

Determines if a given point screen coordinate is within the drawing object.

Parameters
projection | Projection used for drawing
point | Point in screen coordinates.
Returns
True if given point is within the rendered drawing object.

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

override void Deltares.Geometry.Forms.DrawingLine.Draw3D ( GraphicsInfo info )
virtual

Render this drawing object in 3D space.

Parameters
info Rendering target information.

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

References Deltares.Standard.Forms.DrawingSupport.Brush3D(), Deltares.Standard.Forms.DrawingSupport.ColorMaterial3D(), and Deltares.Standard.Forms.DrawingSupport.Pen3D().

override void Deltares.Geometry.Forms.DrawingLine.DrawLabel ( GraphicsInfo info )
virtual

Renders a label or tooltip to provide some information in text for this object.

Parameters
info Rendering target information.

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

References Deltares.Standard.Forms.DrawingSupport.DrawLabelAtPoint().

override object Deltares.Geometry.Forms.DrawingLine.GetDataObject ( )
virtual

Gets the geotechnics entity that this drawing object represents

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

override void Deltares.Geometry.Forms.DrawingLine.OnBeginDrag | ( | IProjection | projection,
 |  | Point3D | aBeginDragDropPoint,
 |  | bool | isIndividualDrag
 | ) |  |
virtual

Method which is called when the user initiates a drag-drop operation

Parameters
projection | Current projection of 3D to screen coordinates.
aBeginDragDropPoint | Initial position of the mouse pointer.
isIndividualDrag

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

override void Deltares.Geometry.Forms.DrawingLine.SetDataObject ( object aDataObject )
virtual

Sets the geotechnics entity that this drawing object represents

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

override void Deltares.Geometry.Forms.DrawingLine.UpdateDataDragDrop | ( | Point3D | aBeginDragPoint,
 |  | Vector3D | vector
 | ) |  |
virtual

Update the position and or orientation of a drawing object as the user is dragging it.

Parameters
aBeginDragPoint | Initial position of the Drawing object
vector | Vector representing the displacement of an object during a drag-drop operation.

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

Property Documentation

int Deltares.Geometry.Forms.DrawingLine.LineWidth
getset

Control the plotted line width

Generated on Tue Dec 15 2015 18:13:56 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geometry
  • Forms
  • DrawingLine
Deltares.Geometry.Forms.DrawingLine Member List

This is the complete list of members for Deltares.Geometry.Forms.DrawingLine, including all inherited members.

AllowDrop(object data) | Deltares.Geometry.Forms.DrawingObject | virtual
BeginMove(IProjection projection, Point2D startPosition) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
CanResize | Deltares.Geometry.Forms.DrawingObject |
CheckHitForSelection(IProjection projection, Point3D point, double tolerance) | Deltares.Geometry.Forms.DrawingObject | virtual
ContainsPoint(IProjection projection, Point point) | Deltares.Geometry.Forms.DrawingLine | virtual
DataItemAt(Point point, Projection projection) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
DataObject (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
Draw(GraphicsInfo info) | Deltares.Geometry.Forms.DrawingObject | virtual
Draw3D(GraphicsInfo info) | Deltares.Geometry.Forms.DrawingLine | virtual
DrawingLine() (defined in Deltares.Geometry.Forms.DrawingLine) | Deltares.Geometry.Forms.DrawingLine |
DrawingObject() (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
DrawLabel(GraphicsInfo info) | Deltares.Geometry.Forms.DrawingLine | virtual
Drop(object data) | Deltares.Geometry.Forms.DrawingObject | virtual
EndMove(IProjection projection, Point2D startPosition, SizeF worldSize) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetCardinalDirectionOnEdgeContainingPoint(Point point) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetDataObject() | Deltares.Geometry.Forms.DrawingLine | virtual
GetExtents(IProjection projection) | Deltares.Geometry.Forms.DrawingObject | virtual
GetScaled3DPoint(IProjection projection, Point3D aOrginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScaled3DPoint(IProjection projection, Point3D aOrginalPoint, ref Point3D aPointTobeScaled) | Deltares.Geometry.Forms.DrawingObject |
GetScaledXPoint(IProjection projection, double aOrginalCordinate) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, Point2D orginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, Point3D orginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, double x, double z) | Deltares.Geometry.Forms.DrawingObject |
GetStandardSize(object aDraw3DInterface, Point3D aPoint3D) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetThickness(GraphicsInfo info) | Deltares.Geometry.Forms.DrawingObject | protectedvirtual
HasBeenUpdated (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
IsDragableOnReslultMode (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
IsVisible (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
Layer (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
LineWidth | Deltares.Geometry.Forms.DrawingLine |
Move(IProjection projection, Point2D startPosition, SizeF worldSize) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
Name | Deltares.Geometry.Forms.DrawingObject |
OnBeginDrag(IProjection projection, Point3D aBeginDragDropPoint, bool isIndividualDrag) | Deltares.Geometry.Forms.DrawingLine | virtual
OnDragging(IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D) | Deltares.Geometry.Forms.DrawingObject | virtual
OnEndDrag(IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D) | Deltares.Geometry.Forms.DrawingObject | virtual
Selected | Deltares.Geometry.Forms.DrawingObject |
SetDataObject(object aDataObject) | Deltares.Geometry.Forms.DrawingLine | virtual
ToolTip | Deltares.Geometry.Forms.DrawingObject |
ToString() (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
UpdateDataDragDrop(Point3D beginDragPoint, Vector3D vector) | Deltares.Geometry.Forms.DrawingLine | virtual
Deltares::Geometry::Forms::DrawingObject.UpdateDataDragDrop(Vector3D aVect3D, List< IDrawingObject > aDraggedObjects) | Deltares.Geometry.Forms.DrawingObject | virtual
Generated on Tue Dec 15 2015 18:13:56 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geometry.Forms.DrawingObject Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geometry
  • Forms
  • DrawingObject
Public Member Functions | Protected Member Functions | Properties | List of all members
Deltares.Geometry.Forms.DrawingObject Class Reference

Base class for drawing objects that represents geotechnical entities in the geometry (crossection) editor. More...

Inheritance diagram for Deltares.Geometry.Forms.DrawingObject:
Deltares.Geometry.Forms.IDrawingObject Deltares.Standard.Forms.IShape Deltares.DSoilModel.Forms.DrawingCenterCrestLocation Deltares.DSoilModel.Forms.DrawingLayerObsolete Deltares.DSoilModel.Forms.DrawingSoilSegmentSplitLocation Deltares.DSoilModel.Forms.DrawingSosSoilLayer1D Deltares.Geometry.Forms.ColoredDrawingObject Deltares.Geometry.Forms.DrawingBoundingBox Deltares.Geometry.Forms.DrawingLine Deltares.Geometry.Forms.DrawingPoint Deltares.Geometry.Forms.DrawingPointString Deltares.Geometry.Forms.DrawingSurface Deltares.Geotechnics.Forms.DrawingBlockRevetmentSegment Deltares.Geotechnics.Forms.DrawingBoring Deltares.Geotechnics.Forms.DrawingCPT Deltares.Geotechnics.Forms.DrawingGeometry Deltares.Geotechnics.Forms.DrawingLayer Deltares.Geotechnics.Forms.DrawingPiezometricHead Deltares.Geotechnics.Forms.DrawingRevetment Deltares.Geotechnics.Forms.DrawingSettlementCurve Deltares.Geotechnics.Forms.DrawingSoilProfile1D Deltares.Geotechnics.Forms.DrawingSoilSurface Deltares.Geotechnics.Forms.DrawingSpecificMechanismPointLocation Deltares.Geotechnics.Forms.DrawingSurfaceLine2 Deltares.Geotechnics.Forms.DrawingSwell Deltares.Geotechnics.Forms.DrawingWaterBasin Deltares.Geotechnics.Forms.DrawingWaterLevel Deltares.Geotechnics.Forms.DrawingWaterPolderBasin

Public Member Functions

Point3D | GetScaled3DPoint (IProjection projection, Point3D aOrginalPoint)
Converts the 3DPoint to screen coordinates More...
Point3D | GetScreenPoint (IProjection projection, Point2D orginalPoint)
Converts Point from 3D space to screen coordinates, assuming Y = 0 More...
Point3D | GetScreenPoint (IProjection projection, Point3D orginalPoint)
Converts Point from 3D space to screen coordinates More...
Point3D | GetScreenPoint (IProjection projection, double x, double z)
Converts 3D x, y coordinates to screen coordinates, assuming Y = 0 More...
override string | ToString ()
virtual void | Draw3D (GraphicsInfo info)
Render this drawing object in 3D space. More...
virtual void | SetDataObject (object aDataObject)
Sets the geotechnics entity that this drawing object represents More...
virtual object | GetDataObject ()
Gets the geotechnics entity that this drawing object represents More...
virtual void | UpdateDataDragDrop (Vector3D aVect3D, List< IDrawingObject > aDraggedObjects)
Update the position and or orientation of a drawing object as the user is dragging it. More...
virtual void | UpdateDataDragDrop (Point3D aBeginDragPoint, Vector3D vector)
Update the position and or orientation of a drawing object as the user is dragging it. More...
virtual void | OnBeginDrag (IProjection projection, Point3D aBeginDragDropPoint, bool isIndividualDrag)
Method which is called when the user initiates a drag-drop operation More...
virtual CardinalDirection | GetCardinalDirectionOnEdgeContainingPoint (Point point)
virtual void | OnDragging (IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D)
Method which is called during drag-drop operations More...
virtual void | OnEndDrag (IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D)
Method which is called when the user ends a drag-drop operation. More...
virtual bool | CheckHitForSelection (IProjection projection, Point3D point, double tolerance)
Check if given point coordinates intersect the rendered drawing object. More...
virtual double | GetStandardSize (object aDraw3DInterface, Point3D aPoint3D)
void | GetScaled3DPoint (IProjection projection, Point3D aOrginalPoint, ref Point3D aPointTobeScaled)
Converts the 3DPoint to screen coordinates More...
double | GetScaledXPoint (IProjection projection, double aOrginalCordinate)
Converts X Coordinate in 3D space to a screen X Coordinate More...
virtual bool | ContainsPoint (IProjection projection, Point point)
Determines if a given point screen coordinate is within the drawing object. More...
virtual Rectangle | GetExtents (IProjection projection)
Returns the bounding box of the shape. More...
virtual void | Draw (GraphicsInfo info)
Render this object in 3D space. More...
virtual void | DrawLabel (GraphicsInfo info)
Renders a label or tooltip to provide some information in text for this object. More...
virtual void | Move (IProjection projection, Point2D startPosition, SizeF worldSize)
virtual void | BeginMove (IProjection projection, Point2D startPosition)
virtual void | EndMove (IProjection projection, Point2D startPosition, SizeF worldSize)
virtual bool | AllowDrop (object data)
Boolean which indicates if other drawing objects can be dropped on given drawing objects More...
virtual void | Drop (object data)
Ends a drag-drop operation More...
virtual IEnumerable< object > | DataItemAt (Point point, Projection projection)

Protected Member Functions

virtual int GetThickness (GraphicsInfo info)
Gets the thickness in screen pixels of a drawing object. More...

Properties

virtual bool | CanResize [get]
Boolean which indicates if a drawing object can be resized. More...
virtual bool | Selected [get, set]
Boolean which indicates if a drawing object is currently selected. More...
string | ToolTip [get]
Description which is shown as a tooltip when the mouse hovers over drawing object. More...
string | Name [get, set]
Gets or sets the name of a drawing object. More...
bool | IsVisible [get, set]
bool | HasBeenUpdated [get, set]
virtual bool | IsDragableOnReslultMode [get]
virtual int | Layer [get, set]
object | DataObject [get, set]
- Properties inherited from Deltares.Geometry.Forms.IDrawingObject
string | Name [get, set]
bool | IsVisible [get, set]
bool | HasBeenUpdated [get, set]
Gets or sets the update status of a drawing object. More...
bool | IsDragableOnReslultMode [get]
- Properties inherited from Deltares.Standard.Forms.IShape
object | DataObject [get, set]
int | Layer [get]

Detailed Description

Base class for drawing objects that represents geotechnical entities in the geometry (crossection) editor.

Member Function Documentation

virtual bool Deltares.Geometry.Forms.DrawingObject.AllowDrop ( object data )
virtual

Boolean which indicates if other drawing objects can be dropped on given drawing objects

Parameters
data
Returns

Implements Deltares.Standard.Forms.IShape.

Reimplemented in Deltares.DSoilModel.Forms.DrawingSosSoilLayer1D, Deltares.Geotechnics.Forms.DrawingLayer, Deltares.DSoilModel.Forms.DrawingLayerObsolete, and Deltares.Geotechnics.Forms.DrawingSoilSurface.

virtual bool Deltares.Geometry.Forms.DrawingObject.CheckHitForSelection | ( | IProjection | projection,
 |  | Point3D | aHitPoint,
 |  | double | tolerance
 | ) |  |
virtual

Check if given point coordinates intersect the rendered drawing object.

Parameters
projection
aHitPoint
tolerance
Returns

Implements Deltares.Geometry.Forms.IDrawingObject.

virtual bool Deltares.Geometry.Forms.DrawingObject.ContainsPoint | ( | IProjection | projection,
 |  | Point | point
 | ) |  |
virtual

Determines if a given point screen coordinate is within the drawing object.

Parameters
projection | Projection used for drawing
point | Point in screen coordinates.
Returns
True if given point is within the rendered drawing object.

Implements Deltares.Standard.Forms.IShape.

Reimplemented in Deltares.Geotechnics.Forms.DrawingCPT, Deltares.Geotechnics.Forms.DrawingBoring, Deltares.Geotechnics.Forms.DrawingSpecificMechanismPointLocation, Deltares.Geotechnics.Forms.DrawingSoilProfile1D, Deltares.DSoilModel.Forms.DrawingCenterCrestLocation, Deltares.DSoilModel.Forms.DrawingSoilSegmentSplitLocation, Deltares.DSoilModel.Forms.DrawingSosSoilLayer1D, Deltares.Geotechnics.Forms.DrawingSwell, Deltares.Geotechnics.Forms.DrawingRevetment, Deltares.Geotechnics.Forms.DrawingLayer, Deltares.Geotechnics.Forms.DrawingBlockRevetmentSegment, Deltares.DSoilModel.Forms.DrawingLayerObsolete, Deltares.Geometry.Forms.DrawingPoint, Deltares.Geotechnics.Forms.DrawingSoilSurface, Deltares.Geotechnics.Forms.DrawingPiezometricHead, Deltares.Geometry.Forms.DrawingLine, Deltares.Geotechnics.Forms.DrawingGeometry, Deltares.Geotechnics.Forms.DrawingCharacteristicPoint, Deltares.Geotechnics.Forms.DrawingWaterBasin, and Deltares.Geotechnics.Forms.DrawingWaterPolderBasin.

virtual void Deltares.Geometry.Forms.DrawingObject.Draw ( GraphicsInfo info )
virtual

Render this object in 3D space.

Parameters
info Rendering target information.
See also
Draw3D

Implements Deltares.Standard.Forms.IShape.

virtual void Deltares.Geometry.Forms.DrawingObject.Draw3D ( GraphicsInfo info )
virtual

Render this drawing object in 3D space.

Parameters
info Rendering target information.

Implements Deltares.Geometry.Forms.IDrawingObject.

Reimplemented in Deltares.Geotechnics.Forms.DrawingCPT, Deltares.Geometry.Forms.DrawingPointString, Deltares.Geotechnics.Forms.DrawingSoilLayerSurface, Deltares.Geotechnics.Forms.DrawingBoring, Deltares.DSoilModel.Forms.DrawingSosSoilLayer1D, Deltares.Geotechnics.Forms.DrawingSoilProfile1D, Deltares.Geotechnics.Forms.DrawingSpecificMechanismPointLocation, Deltares.DSoilModel.Forms.DrawingCenterCrestLocation, Deltares.DSoilModel.Forms.DrawingSoilSegmentSplitLocation, Deltares.Geometry.Forms.DrawingPoint, Deltares.Geotechnics.Forms.DrawingLayer, Deltares.DSoilModel.Forms.DrawingLayerObsolete, Deltares.Geotechnics.Forms.DrawingSoilSurface, Deltares.Geotechnics.Forms.DrawingGeometry, Deltares.Geotechnics.Forms.DrawingSheetPiling, Deltares.Geotechnics.Forms.DrawingAnchorAttachment, Deltares.Geometry.Forms.DrawingSurface, Deltares.Geometry.Forms.DrawingLine, Deltares.Geotechnics.Forms.DrawingSurfaceLine2, Deltares.Geotechnics.Forms.DrawingSwell, Deltares.Geotechnics.Forms.DrawingCharacteristicPoint, Deltares.Geotechnics.Forms.DrawingWaterBasin, Deltares.Geotechnics.Forms.DrawingPiezometricHead, Deltares.Geotechnics.Forms.DrawingWaterPolderBasin, Deltares.Geotechnics.Forms.DrawingWaternetPointString, Deltares.Geotechnics.Forms.DrawingRevetment, Deltares.Geotechnics.Forms.DrawingPreConsolidationStress, Deltares.Geotechnics.Forms.DrawingBlockRevetmentSegment, Deltares.Geotechnics.Forms.DrawingWaterLevel, Deltares.DSoilModel.Forms.DrawingBoringLayer, Deltares.Geotechnics.Forms.DrawingSettlementCurve, and Deltares.Geometry.Forms.DrawingBoundingBox.

virtual void Deltares.Geometry.Forms.DrawingObject.DrawLabel ( GraphicsInfo info )
virtual

Renders a label or tooltip to provide some information in text for this object.

Parameters
info Rendering target information.

Implements Deltares.Standard.Forms.IShape.

Reimplemented in Deltares.Geotechnics.Forms.DrawingCPT, Deltares.Geometry.Forms.DrawingPointString, Deltares.DSoilModel.Forms.DrawingSosSoilLayer1D, Deltares.Geotechnics.Forms.DrawingSpecificMechanismPointLocation, Deltares.DSoilModel.Forms.DrawingCenterCrestLocation, Deltares.DSoilModel.Forms.DrawingSoilSegmentSplitLocation, Deltares.Geotechnics.Forms.DrawingLayer, Deltares.DSoilModel.Forms.DrawingLayerObsolete, Deltares.Geotechnics.Forms.DrawingGeometry, Deltares.Geometry.Forms.DrawingPoint, Deltares.Geotechnics.Forms.DrawingSwell, Deltares.Geotechnics.Forms.DrawingSoilSurface, Deltares.Geotechnics.Forms.DrawingRevetment, Deltares.Geotechnics.Forms.DrawingSurfaceLine2, Deltares.Geotechnics.Forms.DrawingWaterPolderBasin, Deltares.Geometry.Forms.DrawingLine, Deltares.Geotechnics.Forms.DrawingBlockRevetmentSegment, Deltares.Geotechnics.Forms.DrawingCharacteristicPoint, Deltares.Geotechnics.Forms.DrawingPreConsolidationStress, Deltares.Geotechnics.Forms.DrawingPiezometricHead, Deltares.Geotechnics.Forms.DrawingWaterLevel, Deltares.Geotechnics.Forms.DrawingWaterBasin, Deltares.Geotechnics.Forms.DrawingWaternetPointString, Deltares.Geotechnics.Forms.DrawingWaternetLine, and Deltares.Geotechnics.Forms.DrawingLocalisedGeometryPointString.

virtual void Deltares.Geometry.Forms.DrawingObject.Drop ( object data )
virtual

Ends a drag-drop operation

Parameters
data

Implements Deltares.Standard.Forms.IShape.

Reimplemented in Deltares.DSoilModel.Forms.DrawingSosSoilLayer1D, Deltares.Geotechnics.Forms.DrawingLayer, Deltares.DSoilModel.Forms.DrawingLayerObsolete, and Deltares.Geotechnics.Forms.DrawingSoilSurface.

virtual object Deltares.Geometry.Forms.DrawingObject.GetDataObject ( )
virtual

Gets the geotechnics entity that this drawing object represents

Implements Deltares.Geometry.Forms.IDrawingObject.

Reimplemented in Deltares.Geotechnics.Forms.DrawingCPT, Deltares.Geotechnics.Forms.DrawingBoring, Deltares.Geotechnics.Forms.DrawingSoilProfile1D, Deltares.Geotechnics.Forms.DrawingSpecificMechanismPointLocation, Deltares.DSoilModel.Forms.DrawingCenterCrestLocation, Deltares.DSoilModel.Forms.DrawingSoilSegmentSplitLocation, Deltares.Geometry.Forms.DrawingPoint, Deltares.Geometry.Forms.DrawingPointString, Deltares.DSoilModel.Forms.DrawingSosSoilLayer1D, Deltares.Geotechnics.Forms.DrawingLayer, Deltares.DSoilModel.Forms.DrawingLayerObsolete, Deltares.Geotechnics.Forms.DrawingSurfaceLine2, Deltares.Geotechnics.Forms.DrawingSwell, Deltares.Geometry.Forms.DrawingSurface, Deltares.Geotechnics.Forms.DrawingSoilSurface, Deltares.Geotechnics.Forms.DrawingPiezometricHead, Deltares.Geotechnics.Forms.DrawingGeometry, Deltares.Geometry.Forms.DrawingLine, Deltares.Geotechnics.Forms.DrawingAnchorAttachment, Deltares.Geotechnics.Forms.DrawingBlockRevetmentSegment, Deltares.Geotechnics.Forms.DrawingRevetment, Deltares.Geotechnics.Forms.DrawingSheetPiling, Deltares.Geotechnics.Forms.DrawingWaterBasin, Deltares.Geotechnics.Forms.DrawingWaterPolderBasin, Deltares.DSoilModel.Forms.DrawingBoringLayer, Deltares.Geotechnics.Forms.DrawingWaterLevel, Deltares.Geotechnics.Forms.DrawingCharacteristicPoint, Deltares.Geotechnics.Forms.DrawingSettlementCurve, and Deltares.Geometry.Forms.DrawingBoundingBox.

virtual Rectangle Deltares.Geometry.Forms.DrawingObject.GetExtents ( IProjection projection )
virtual

Returns the bounding box of the shape.

Parameters
projection Projection used for drawing.
Returns
The bounding box of the shape; Null if none can be determined.

Implements Deltares.Standard.Forms.IShape.

Reimplemented in Deltares.Geotechnics.Forms.DrawingCPT, Deltares.Geotechnics.Forms.DrawingBoring, Deltares.Geotechnics.Forms.DrawingSpecificMechanismPointLocation, Deltares.Geotechnics.Forms.DrawingSoilProfile1D, Deltares.DSoilModel.Forms.DrawingCenterCrestLocation, Deltares.DSoilModel.Forms.DrawingSoilSegmentSplitLocation, Deltares.DSoilModel.Forms.DrawingSosSoilLayer1D, Deltares.Geotechnics.Forms.DrawingLayer, Deltares.DSoilModel.Forms.DrawingLayerObsolete, Deltares.Geometry.Forms.DrawingBoundingBox, Deltares.Geotechnics.Forms.DrawingPreConsolidationStress, and Deltares.Geotechnics.Forms.DrawingCharacteristicPoint.

Point3D Deltares.Geometry.Forms.DrawingObject.GetScaled3DPoint | ( | IProjection | projection,
 |  | Point3D | aOrginalPoint
 | ) |  |

Converts the 3DPoint to screen coordinates

void Deltares.Geometry.Forms.DrawingObject.GetScaled3DPoint | ( | IProjection | projection,
 |  | Point3D | aOrginalPoint,
 |  | ref Point3D | aPointTobeScaled
 | ) |  |

Converts the 3DPoint to screen coordinates

Implements Deltares.Geometry.Forms.IDrawingObject.

double Deltares.Geometry.Forms.DrawingObject.GetScaledXPoint | ( | IProjection | projection,
 |  | double | aOrginalCordinate
 | ) |  |

Converts X Coordinate in 3D space to a screen X Coordinate

Implements Deltares.Geometry.Forms.IDrawingObject.

Point3D Deltares.Geometry.Forms.DrawingObject.GetScreenPoint | ( | IProjection | projection,
 |  | Point2D | orginalPoint
 | ) |  |

Converts Point from 3D space to screen coordinates, assuming Y = 0

Parameters
projection | Projection used for drawing
orginalPoint | Point coordinate in 3D space
Point3D Deltares.Geometry.Forms.DrawingObject.GetScreenPoint | ( | IProjection | projection,
 |  | Point3D | orginalPoint
 | ) |  |

Converts Point from 3D space to screen coordinates

Parameters
projection | Projection used for drawing.
orginalPoint | Point coordinate in 3D space.
Point3D Deltares.Geometry.Forms.DrawingObject.GetScreenPoint | ( | IProjection | projection,
 |  | double | x,
 |  | double | z
 | ) |  |

Converts 3D x, y coordinates to screen coordinates, assuming Y = 0

virtual int Deltares.Geometry.Forms.DrawingObject.GetThickness ( GraphicsInfo info )
protectedvirtual

Gets the thickness in screen pixels of a drawing object.

Parameters
info Graphics info object
Returns
(Line) thickness in pixels
virtual void Deltares.Geometry.Forms.DrawingObject.OnBeginDrag | ( | IProjection | projection,
 |  | Point3D | aBeginDragDropPoint,
 |  | bool | isIndividualDrag
 | ) |  |
virtual

Method which is called when the user initiates a drag-drop operation

Parameters
projection | Current projection of 3D to screen coordinates.
aBeginDragDropPoint | Initial position of the mouse pointer.
isIndividualDrag

Implements Deltares.Geometry.Forms.IDrawingObject.

Reimplemented in Deltares.Geotechnics.Forms.DrawingCPT, Deltares.Geotechnics.Forms.DrawingBoring, Deltares.Geotechnics.Forms.DrawingSpecificMechanismPointLocation, Deltares.DSoilModel.Forms.DrawingCenterCrestLocation, Deltares.Geotechnics.Forms.DrawingSoilProfile1D, Deltares.DSoilModel.Forms.DrawingSoilSegmentSplitLocation, Deltares.Geotechnics.Forms.DrawingRevetment, Deltares.Geometry.Forms.DrawingPoint, Deltares.Geotechnics.Forms.DrawingSheetPiling, Deltares.Geotechnics.Forms.DrawingSoilSurface, Deltares.Geotechnics.Forms.DrawingSoilLayerSurface, Deltares.Geotechnics.Forms.DrawingGeometry, Deltares.Geometry.Forms.DrawingLine, and Deltares.Geotechnics.Forms.DrawingAnchorAttachment.

virtual void Deltares.Geometry.Forms.DrawingObject.OnDragging | ( | IProjection | projection,
 |  | Point3D | aCurrentDragPoint,
 |  | Vector3D | aVect3D
 | ) |  |
virtual

Method which is called during drag-drop operations

Parameters
projection | Current projection of 3D to screen coordinates.
aCurrentDragPoint | Current position of the drawing object.
aVect3D | 3D vector representing the displacement within the drag operation.

Implements Deltares.Geometry.Forms.IDrawingObject.

Reimplemented in Deltares.Geotechnics.Forms.DrawingRevetment.

virtual void Deltares.Geometry.Forms.DrawingObject.OnEndDrag | ( | IProjection | projection,
 |  | Point3D | aCurrentDragPoint,
 |  | Vector3D | aVect3D
 | ) |  |
virtual

Method which is called when the user ends a drag-drop operation.

Parameters
projection | Current projection
aCurrentDragPoint | Point in 3D space where the darg operation ends
aVect3D | Vector in 3D space which represents the displacement within the drag-drop operation

Implements Deltares.Geometry.Forms.IDrawingObject.

Reimplemented in Deltares.Geotechnics.Forms.DrawingCPT, Deltares.Geotechnics.Forms.DrawingBoring, Deltares.Geotechnics.Forms.DrawingSpecificMechanismPointLocation, Deltares.DSoilModel.Forms.DrawingCenterCrestLocation, Deltares.Geotechnics.Forms.DrawingSoilProfile1D, Deltares.DSoilModel.Forms.DrawingSoilSegmentSplitLocation, Deltares.Geometry.Forms.DrawingPoint, Deltares.Geotechnics.Forms.DrawingSheetPiling, Deltares.Geotechnics.Forms.DrawingSoilLayerSurface, and Deltares.Geotechnics.Forms.DrawingAnchorAttachment.

virtual void Deltares.Geometry.Forms.DrawingObject.SetDataObject ( object aDataObject )
virtual

Sets the geotechnics entity that this drawing object represents

Implements Deltares.Geometry.Forms.IDrawingObject.

Reimplemented in Deltares.Geotechnics.Forms.DrawingCPT, Deltares.Geotechnics.Forms.DrawingSoilLayerSurface, Deltares.Geotechnics.Forms.DrawingBoring, Deltares.Geotechnics.Forms.DrawingSpecificMechanismPointLocation, Deltares.Geotechnics.Forms.DrawingSoilProfile1D, Deltares.DSoilModel.Forms.DrawingCenterCrestLocation, Deltares.DSoilModel.Forms.DrawingSoilSegmentSplitLocation, Deltares.Geometry.Forms.DrawingPoint, Deltares.DSoilModel.Forms.DrawingSosSoilLayer1D, Deltares.Geometry.Forms.DrawingPointString, Deltares.Geotechnics.Forms.DrawingLayer, Deltares.DSoilModel.Forms.DrawingLayerObsolete, Deltares.Geotechnics.Forms.DrawingSurfaceLine2, Deltares.Geotechnics.Forms.DrawingRevetment, Deltares.Geotechnics.Forms.DrawingSwell, Deltares.Geometry.Forms.DrawingSurface, Deltares.Geotechnics.Forms.DrawingSoilSurface, Deltares.Geometry.Forms.DrawingLine, Deltares.Geotechnics.Forms.DrawingAnchorAttachment, Deltares.Geotechnics.Forms.DrawingGeometry, Deltares.Geotechnics.Forms.DrawingPiezometricHead, Deltares.Geotechnics.Forms.DrawingBlockRevetmentSegment, Deltares.Geotechnics.Forms.DrawingPreConsolidationStress, Deltares.Geotechnics.Forms.DrawingSheetPiling, Deltares.Geotechnics.Forms.DrawingWaterBasin, Deltares.Geotechnics.Forms.DrawingWaterPolderBasin, Deltares.Geotechnics.Forms.DrawingWaterLevel, Deltares.Geotechnics.Forms.DrawingCharacteristicPoint, Deltares.DSoilModel.Forms.DrawingBoringLayer, Deltares.Geotechnics.Forms.DrawingSettlementCurve, Deltares.Geotechnics.Forms.DrawingWaternetLine, Deltares.Geometry.Forms.DrawingBoundingBox, Deltares.Geotechnics.Forms.DrawingHeadLine, and Deltares.Geotechnics.Forms.DrawingPhreaticLine.

virtual void Deltares.Geometry.Forms.DrawingObject.UpdateDataDragDrop | ( | Vector3D | aVect3D,
 |  | List< IDrawingObject > | aDraggedObjects
 | ) |  |
virtual

Update the position and or orientation of a drawing object as the user is dragging it.

Parameters
aVect3D | Vector representing the displacement of an object during a drag-drop operation.
aDraggedObjects | The collection of drawing objects to be dragged as a group that this drawing object is part of.

Implements Deltares.Geometry.Forms.IDrawingObject.

virtual void Deltares.Geometry.Forms.DrawingObject.UpdateDataDragDrop | ( | Point3D | aBeginDragPoint,
 |  | Vector3D | vector
 | ) |  |
virtual

Update the position and or orientation of a drawing object as the user is dragging it.

Parameters
aBeginDragPoint | Initial position of the Drawing object
vector | Vector representing the displacement of an object during a drag-drop operation.

Implements Deltares.Geometry.Forms.IDrawingObject.

Reimplemented in Deltares.Geotechnics.Forms.DrawingCPT, Deltares.Geotechnics.Forms.DrawingBoring, Deltares.Geotechnics.Forms.DrawingSpecificMechanismPointLocation, Deltares.DSoilModel.Forms.DrawingCenterCrestLocation, Deltares.Geotechnics.Forms.DrawingSoilProfile1D, Deltares.DSoilModel.Forms.DrawingSoilSegmentSplitLocation, Deltares.Geometry.Forms.DrawingPoint, Deltares.Geometry.Forms.DrawingPointString, Deltares.Geotechnics.Forms.DrawingSoilLayerSurface, Deltares.Geotechnics.Forms.DrawingGeometry, Deltares.Geotechnics.Forms.DrawingSoilSurface, Deltares.Geotechnics.Forms.DrawingSurfaceLine2, Deltares.Geometry.Forms.DrawingSurface, Deltares.Geotechnics.Forms.DrawingAnchorAttachment, Deltares.Geometry.Forms.DrawingLine, Deltares.Geotechnics.Forms.DrawingWaterBasin, Deltares.Geotechnics.Forms.DrawingWaterPolderBasin, Deltares.Geotechnics.Forms.DrawingSheetPiling, Deltares.Geotechnics.Forms.DrawingWaterLevel, and Deltares.Geotechnics.Forms.DrawingSettlementCurve.

Property Documentation

virtual bool Deltares.Geometry.Forms.DrawingObject.CanResize
get

Boolean which indicates if a drawing object can be resized.

string Deltares.Geometry.Forms.DrawingObject.Name
getset

Gets or sets the name of a drawing object.

virtual bool Deltares.Geometry.Forms.DrawingObject.Selected
getset

Boolean which indicates if a drawing object is currently selected.

string Deltares.Geometry.Forms.DrawingObject.ToolTip
get

Description which is shown as a tooltip when the mouse hovers over drawing object.

Generated on Tue Dec 15 2015 18:13:56 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geometry
  • Forms
  • DrawingObject
Deltares.Geometry.Forms.DrawingObject Member List

This is the complete list of members for Deltares.Geometry.Forms.DrawingObject, including all inherited members.

AllowDrop(object data) | Deltares.Geometry.Forms.DrawingObject | virtual
BeginMove(IProjection projection, Point2D startPosition) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
CanResize | Deltares.Geometry.Forms.DrawingObject |
CheckHitForSelection(IProjection projection, Point3D point, double tolerance) | Deltares.Geometry.Forms.DrawingObject | virtual
ContainsPoint(IProjection projection, Point point) | Deltares.Geometry.Forms.DrawingObject | virtual
DataItemAt(Point point, Projection projection) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
DataObject (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
Draw(GraphicsInfo info) | Deltares.Geometry.Forms.DrawingObject | virtual
Draw3D(GraphicsInfo info) | Deltares.Geometry.Forms.DrawingObject | virtual
DrawingObject() (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
DrawLabel(GraphicsInfo info) | Deltares.Geometry.Forms.DrawingObject | virtual
Drop(object data) | Deltares.Geometry.Forms.DrawingObject | virtual
EndMove(IProjection projection, Point2D startPosition, SizeF worldSize) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetCardinalDirectionOnEdgeContainingPoint(Point point) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetDataObject() | Deltares.Geometry.Forms.DrawingObject | virtual
GetExtents(IProjection projection) | Deltares.Geometry.Forms.DrawingObject | virtual
GetScaled3DPoint(IProjection projection, Point3D aOrginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScaled3DPoint(IProjection projection, Point3D aOrginalPoint, ref Point3D aPointTobeScaled) | Deltares.Geometry.Forms.DrawingObject |
GetScaledXPoint(IProjection projection, double aOrginalCordinate) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, Point2D orginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, Point3D orginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, double x, double z) | Deltares.Geometry.Forms.DrawingObject |
GetStandardSize(object aDraw3DInterface, Point3D aPoint3D) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetThickness(GraphicsInfo info) | Deltares.Geometry.Forms.DrawingObject | protectedvirtual
HasBeenUpdated (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
IsDragableOnReslultMode (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
IsVisible (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
Layer (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
Move(IProjection projection, Point2D startPosition, SizeF worldSize) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
Name | Deltares.Geometry.Forms.DrawingObject |
OnBeginDrag(IProjection projection, Point3D aBeginDragDropPoint, bool isIndividualDrag) | Deltares.Geometry.Forms.DrawingObject | virtual
OnDragging(IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D) | Deltares.Geometry.Forms.DrawingObject | virtual
OnEndDrag(IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D) | Deltares.Geometry.Forms.DrawingObject | virtual
Selected | Deltares.Geometry.Forms.DrawingObject |
SetDataObject(object aDataObject) | Deltares.Geometry.Forms.DrawingObject | virtual
ToolTip | Deltares.Geometry.Forms.DrawingObject |
ToString() (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
UpdateDataDragDrop(Vector3D aVect3D, List< IDrawingObject > aDraggedObjects) | Deltares.Geometry.Forms.DrawingObject | virtual
UpdateDataDragDrop(Point3D aBeginDragPoint, Vector3D vector) | Deltares.Geometry.Forms.DrawingObject | virtual
Generated on Tue Dec 15 2015 18:13:56 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geometry.Forms.DrawingPoint Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geometry
  • Forms
  • DrawingPoint
Public Member Functions | Static Public Member Functions | Protected Attributes | Properties | List of all members
Deltares.Geometry.Forms.DrawingPoint Class Reference
Inheritance diagram for Deltares.Geometry.Forms.DrawingPoint:
Deltares.Geometry.Forms.DrawingObject Deltares.Geometry.Forms.IDrawingObject Deltares.Standard.Forms.IShape Deltares.Geotechnics.Forms.DrawingCharacteristicPoint Deltares.Geotechnics.Forms.DrawingPreConsolidationStress

Public Member Functions

DrawingPoint (GeometryPoint aPoint)
override void | SetDataObject (object aDataObject)
Stes the data object for this.dataPoint More...
override object | GetDataObject ()
Gets the IDataobject for this.dataPoint. More...
override bool | ContainsPoint (IProjection projection, Point screenPoint)
Determines if a given point screen coordinate is within the drawing object. More...
override void | OnBeginDrag (IProjection projection, Point3D beginDragDropPoint, bool isIndividualDrag)
Method which is called when the user initiates a drag-drop operation More...
override void | UpdateDataDragDrop (Point3D beginDragPoint, Vector3D vector)
Updates the geometry after publisherEventArgs drag and drop. More...
override void | OnEndDrag (IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D)
Method which is called when the user ends a drag-drop operation. More...
override void | Draw3D (GraphicsInfo info)
Render this drawing object in 3D space. More...
override void | DrawLabel (GraphicsInfo info)
Renders a label or tooltip to provide some information in text for this object. More...
- Public Member Functions inherited from Deltares.Geometry.Forms.DrawingObject
Point3D | GetScaled3DPoint (IProjection projection, Point3D aOrginalPoint)
Converts the 3DPoint to screen coordinates More...
Point3D | GetScreenPoint (IProjection projection, Point2D orginalPoint)
Converts Point from 3D space to screen coordinates, assuming Y = 0 More...
Point3D | GetScreenPoint (IProjection projection, Point3D orginalPoint)
Converts Point from 3D space to screen coordinates More...
Point3D | GetScreenPoint (IProjection projection, double x, double z)
Converts 3D x, y coordinates to screen coordinates, assuming Y = 0 More...
override string | ToString ()
virtual void | UpdateDataDragDrop (Vector3D aVect3D, List< IDrawingObject > aDraggedObjects)
Update the position and or orientation of a drawing object as the user is dragging it. More...
virtual CardinalDirection | GetCardinalDirectionOnEdgeContainingPoint (Point point)
virtual void | OnDragging (IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D)
Method which is called during drag-drop operations More...
virtual bool | CheckHitForSelection (IProjection projection, Point3D point, double tolerance)
Check if given point coordinates intersect the rendered drawing object. More...
virtual double | GetStandardSize (object aDraw3DInterface, Point3D aPoint3D)
void | GetScaled3DPoint (IProjection projection, Point3D aOrginalPoint, ref Point3D aPointTobeScaled)
Converts the 3DPoint to screen coordinates More...
double | GetScaledXPoint (IProjection projection, double aOrginalCordinate)
Converts X Coordinate in 3D space to a screen X Coordinate More...
virtual Rectangle | GetExtents (IProjection projection)
Returns the bounding box of the shape. More...
virtual void | Draw (GraphicsInfo info)
Render this object in 3D space. More...
virtual void | Move (IProjection projection, Point2D startPosition, SizeF worldSize)
virtual void | BeginMove (IProjection projection, Point2D startPosition)
virtual void | EndMove (IProjection projection, Point2D startPosition, SizeF worldSize)
virtual bool | AllowDrop (object data)
Boolean which indicates if other drawing objects can be dropped on given drawing objects More...
virtual void | Drop (object data)
Ends a drag-drop operation More...
virtual IEnumerable< object > | DataItemAt (Point point, Projection projection)

Static Public Member Functions

static void | DrawRoundLabelAtPoint (Graphics graphics, Point screenPoint, string text, Brush textBrush, Brush backgroundBrush, Brush borderBrush)
static void | BeginMovePoints ()
static void | Move (GeometryPoint point, Vector3D vector, Point3D beginDragPoint)

Protected Attributes

Point2D point
The rendered point in screen coordinates. More...

Properties

static bool | Highlighted [get, set]
- Properties inherited from Deltares.Geometry.Forms.DrawingObject
virtual bool | CanResize [get]
Boolean which indicates if a drawing object can be resized. More...
virtual bool | Selected [get, set]
Boolean which indicates if a drawing object is currently selected. More...
string | ToolTip [get]
Description which is shown as a tooltip when the mouse hovers over drawing object. More...
string | Name [get, set]
Gets or sets the name of a drawing object. More...
bool | IsVisible [get, set]
bool | HasBeenUpdated [get, set]
virtual bool | IsDragableOnReslultMode [get]
virtual int | Layer [get, set]
object | DataObject [get, set]
- Properties inherited from Deltares.Geometry.Forms.IDrawingObject
string | Name [get, set]
bool | IsVisible [get, set]
bool | HasBeenUpdated [get, set]
Gets or sets the update status of a drawing object. More...
bool | IsDragableOnReslultMode [get]
- Properties inherited from Deltares.Standard.Forms.IShape
object | DataObject [get, set]
int | Layer [get]

Additional Inherited Members

- Protected Member Functions inherited from Deltares.Geometry.Forms.DrawingObject
virtual int GetThickness (GraphicsInfo info)
Gets the thickness in screen pixels of a drawing object. More...

Member Function Documentation

override bool Deltares.Geometry.Forms.DrawingPoint.ContainsPoint | ( | IProjection | projection,
 |  | Point | point
 | ) |  |
virtual

Determines if a given point screen coordinate is within the drawing object.

Parameters
projection | Projection used for drawing
point | Point in screen coordinates.
Returns
True if given point is within the rendered drawing object.

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

Reimplemented in Deltares.Geotechnics.Forms.DrawingCharacteristicPoint.

override void Deltares.Geometry.Forms.DrawingPoint.Draw3D ( GraphicsInfo info )
virtual

Render this drawing object in 3D space.

Parameters
info Rendering target information.

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

Reimplemented in Deltares.Geotechnics.Forms.DrawingCharacteristicPoint, and Deltares.Geotechnics.Forms.DrawingPreConsolidationStress.

References Deltares.Standard.Forms.DrawingSupport.ColorMaterial3D().

override void Deltares.Geometry.Forms.DrawingPoint.DrawLabel ( GraphicsInfo info )
virtual

Renders a label or tooltip to provide some information in text for this object.

Parameters
info Rendering target information.

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

Reimplemented in Deltares.Geotechnics.Forms.DrawingCharacteristicPoint, and Deltares.Geotechnics.Forms.DrawingPreConsolidationStress.

override object Deltares.Geometry.Forms.DrawingPoint.GetDataObject ( )
virtual

Gets the IDataobject for this.dataPoint.

Returns

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

Reimplemented in Deltares.Geotechnics.Forms.DrawingCharacteristicPoint.

override void Deltares.Geometry.Forms.DrawingPoint.OnBeginDrag | ( | IProjection | projection,
 |  | Point3D | aBeginDragDropPoint,
 |  | bool | isIndividualDrag
 | ) |  |
virtual

Method which is called when the user initiates a drag-drop operation

Parameters
projection | Current projection of 3D to screen coordinates.
aBeginDragDropPoint | Initial position of the mouse pointer.
isIndividualDrag

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

override void Deltares.Geometry.Forms.DrawingPoint.OnEndDrag | ( | IProjection | projection,
 |  | Point3D | aCurrentDragPoint,
 |  | Vector3D | aVect3D
 | ) |  |
virtual

Method which is called when the user ends a drag-drop operation.

Parameters
projection | Current projection
aCurrentDragPoint | Point in 3D space where the darg operation ends
aVect3D | Vector in 3D space which represents the displacement within the drag-drop operation

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

override void Deltares.Geometry.Forms.DrawingPoint.SetDataObject ( object aDataObject )
virtual

Stes the data object for this.dataPoint

Parameters
aDataObject

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

Reimplemented in Deltares.Geotechnics.Forms.DrawingPreConsolidationStress, and Deltares.Geotechnics.Forms.DrawingCharacteristicPoint.

override void Deltares.Geometry.Forms.DrawingPoint.UpdateDataDragDrop | ( | Point3D | beginDragPoint,
 |  | Vector3D | vector
 | ) |  |
virtual

Updates the geometry after publisherEventArgs drag and drop.

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

Member Data Documentation

Point2D Deltares.Geometry.Forms.DrawingPoint.point
protected

The rendered point in screen coordinates.

Generated on Tue Dec 15 2015 18:13:56 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geometry
  • Forms
  • DrawingPoint
Deltares.Geometry.Forms.DrawingPoint Member List

This is the complete list of members for Deltares.Geometry.Forms.DrawingPoint, including all inherited members.

AllowDrop(object data) | Deltares.Geometry.Forms.DrawingObject | virtual
BeginMove(IProjection projection, Point2D startPosition) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
BeginMovePoints() (defined in Deltares.Geometry.Forms.DrawingPoint) | Deltares.Geometry.Forms.DrawingPoint | static
CanResize | Deltares.Geometry.Forms.DrawingObject |
CheckHitForSelection(IProjection projection, Point3D point, double tolerance) | Deltares.Geometry.Forms.DrawingObject | virtual
ContainsPoint(IProjection projection, Point screenPoint) | Deltares.Geometry.Forms.DrawingPoint | virtual
DataItemAt(Point point, Projection projection) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
DataObject (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
Draw(GraphicsInfo info) | Deltares.Geometry.Forms.DrawingObject | virtual
Draw3D(GraphicsInfo info) | Deltares.Geometry.Forms.DrawingPoint | virtual
DrawingObject() (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
DrawingPoint() (defined in Deltares.Geometry.Forms.DrawingPoint) | Deltares.Geometry.Forms.DrawingPoint |
DrawingPoint(GeometryPoint aPoint) (defined in Deltares.Geometry.Forms.DrawingPoint) | Deltares.Geometry.Forms.DrawingPoint |
DrawLabel(GraphicsInfo info) | Deltares.Geometry.Forms.DrawingPoint | virtual
DrawRoundLabelAtPoint(Graphics graphics, Point screenPoint, string text, Brush textBrush, Brush backgroundBrush, Brush borderBrush) (defined in Deltares.Geometry.Forms.DrawingPoint) | Deltares.Geometry.Forms.DrawingPoint | static
Drop(object data) | Deltares.Geometry.Forms.DrawingObject | virtual
EndMove(IProjection projection, Point2D startPosition, SizeF worldSize) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetCardinalDirectionOnEdgeContainingPoint(Point point) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetDataObject() | Deltares.Geometry.Forms.DrawingPoint | virtual
GetExtents(IProjection projection) | Deltares.Geometry.Forms.DrawingObject | virtual
GetScaled3DPoint(IProjection projection, Point3D aOrginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScaled3DPoint(IProjection projection, Point3D aOrginalPoint, ref Point3D aPointTobeScaled) | Deltares.Geometry.Forms.DrawingObject |
GetScaledXPoint(IProjection projection, double aOrginalCordinate) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, Point2D orginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, Point3D orginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, double x, double z) | Deltares.Geometry.Forms.DrawingObject |
GetStandardSize(object aDraw3DInterface, Point3D aPoint3D) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetThickness(GraphicsInfo info) | Deltares.Geometry.Forms.DrawingObject | protectedvirtual
HasBeenUpdated (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
Highlighted (defined in Deltares.Geometry.Forms.DrawingPoint) | Deltares.Geometry.Forms.DrawingPoint | static
IsDragableOnReslultMode (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
IsVisible (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
Layer (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
Move(GeometryPoint point, Vector3D vector, Point3D beginDragPoint) (defined in Deltares.Geometry.Forms.DrawingPoint) | Deltares.Geometry.Forms.DrawingPoint | static
Move(IProjection projection, Point2D startPosition, SizeF worldSize) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
Name | Deltares.Geometry.Forms.DrawingObject |
OnBeginDrag(IProjection projection, Point3D beginDragDropPoint, bool isIndividualDrag) | Deltares.Geometry.Forms.DrawingPoint | virtual
OnDragging(IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D) | Deltares.Geometry.Forms.DrawingObject | virtual
OnEndDrag(IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D) | Deltares.Geometry.Forms.DrawingPoint | virtual
point | Deltares.Geometry.Forms.DrawingPoint | protected
Selected | Deltares.Geometry.Forms.DrawingObject |
SetDataObject(object aDataObject) | Deltares.Geometry.Forms.DrawingPoint | virtual
ToolTip | Deltares.Geometry.Forms.DrawingObject |
ToString() (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
UpdateDataDragDrop(Point3D beginDragPoint, Vector3D vector) | Deltares.Geometry.Forms.DrawingPoint | virtual
Deltares::Geometry::Forms::DrawingObject.UpdateDataDragDrop(Vector3D aVect3D, List< IDrawingObject > aDraggedObjects) | Deltares.Geometry.Forms.DrawingObject | virtual
Generated on Tue Dec 15 2015 18:13:56 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geometry.Forms.DrawingPointString Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geometry
  • Forms
  • DrawingPointString
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
Deltares.Geometry.Forms.DrawingPointString Class Reference
Inheritance diagram for Deltares.Geometry.Forms.DrawingPointString:
Deltares.Geometry.Forms.DrawingObject Deltares.Geometry.Forms.IDrawingObject Deltares.Standard.Forms.IShape Deltares.Geotechnics.Forms.DrawingLocalisedGeometryPointString Deltares.Geotechnics.Forms.DrawingWaternetPointString Deltares.Geotechnics.Forms.DrawingHeadLine Deltares.Geotechnics.Forms.DrawingPhreaticLine Deltares.Geotechnics.Forms.DrawingWaternetLine

Public Member Functions

DrawingPointString (Color lineColor, Color backgroundColor, int layer)
DrawingPointString (DragStyle dragStyle, Color lineColor, Color backgroundColor, int layer)
DrawingPointString (DashStyle dashStyle, Color lineColor, Color backgroundColor, int layer)
DrawingPointString (DragStyle dragStyle, DashStyle dashStyle, Color lineColor, Color backgroundColor, int layer)
override void | SetDataObject (object dataobject)
Sets the geotechnics entity that this drawing object represents More...
override object | GetDataObject ()
Gets the geotechnics entity that this drawing object represents More...
override void | UpdateDataDragDrop (Point3D aBeginDragPoint, Vector3D vector)
override The UpdateDataDragDrop() Method More...
override void | BeginMove (IProjection projection, Point2D startPosition)
override void | Draw3D (GraphicsInfo info)
override The Draw3D() Method More...
override void | DrawLabel (GraphicsInfo info)
Renders a label or tooltip to provide some information in text for this object. More...
override IEnumerable< object > | DataItemAt (Point point, Projection projection)
- Public Member Functions inherited from Deltares.Geometry.Forms.DrawingObject
Point3D | GetScaled3DPoint (IProjection projection, Point3D aOrginalPoint)
Converts the 3DPoint to screen coordinates More...
Point3D | GetScreenPoint (IProjection projection, Point2D orginalPoint)
Converts Point from 3D space to screen coordinates, assuming Y = 0 More...
Point3D | GetScreenPoint (IProjection projection, Point3D orginalPoint)
Converts Point from 3D space to screen coordinates More...
Point3D | GetScreenPoint (IProjection projection, double x, double z)
Converts 3D x, y coordinates to screen coordinates, assuming Y = 0 More...
override string | ToString ()
virtual void | UpdateDataDragDrop (Vector3D aVect3D, List< IDrawingObject > aDraggedObjects)
Update the position and or orientation of a drawing object as the user is dragging it. More...
virtual void | OnBeginDrag (IProjection projection, Point3D aBeginDragDropPoint, bool isIndividualDrag)
Method which is called when the user initiates a drag-drop operation More...
virtual CardinalDirection | GetCardinalDirectionOnEdgeContainingPoint (Point point)
virtual void | OnDragging (IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D)
Method which is called during drag-drop operations More...
virtual void | OnEndDrag (IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D)
Method which is called when the user ends a drag-drop operation. More...
virtual bool | CheckHitForSelection (IProjection projection, Point3D point, double tolerance)
Check if given point coordinates intersect the rendered drawing object. More...
virtual double | GetStandardSize (object aDraw3DInterface, Point3D aPoint3D)
void | GetScaled3DPoint (IProjection projection, Point3D aOrginalPoint, ref Point3D aPointTobeScaled)
Converts the 3DPoint to screen coordinates More...
double | GetScaledXPoint (IProjection projection, double aOrginalCordinate)
Converts X Coordinate in 3D space to a screen X Coordinate More...
virtual bool | ContainsPoint (IProjection projection, Point point)
Determines if a given point screen coordinate is within the drawing object. More...
virtual Rectangle | GetExtents (IProjection projection)
Returns the bounding box of the shape. More...
virtual void | Draw (GraphicsInfo info)
Render this object in 3D space. More...
virtual void | Move (IProjection projection, Point2D startPosition, SizeF worldSize)
virtual void | EndMove (IProjection projection, Point2D startPosition, SizeF worldSize)
virtual bool | AllowDrop (object data)
Boolean which indicates if other drawing objects can be dropped on given drawing objects More...
virtual void | Drop (object data)
Ends a drag-drop operation More...

Protected Member Functions

IList< GeometryPoint > | GetPoints ()
- Protected Member Functions inherited from Deltares.Geometry.Forms.DrawingObject
virtual int | GetThickness (GraphicsInfo info)
Gets the thickness in screen pixels of a drawing object. More...

Protected Attributes

DragStyle dragStyle

Additional Inherited Members

- Properties inherited from Deltares.Geometry.Forms.DrawingObject
virtual bool | CanResize [get]
Boolean which indicates if a drawing object can be resized. More...
virtual bool | Selected [get, set]
Boolean which indicates if a drawing object is currently selected. More...
string | ToolTip [get]
Description which is shown as a tooltip when the mouse hovers over drawing object. More...
string | Name [get, set]
Gets or sets the name of a drawing object. More...
bool | IsVisible [get, set]
bool | HasBeenUpdated [get, set]
virtual bool | IsDragableOnReslultMode [get]
virtual int | Layer [get, set]
object | DataObject [get, set]
- Properties inherited from Deltares.Geometry.Forms.IDrawingObject
string | Name [get, set]
bool | IsVisible [get, set]
bool | HasBeenUpdated [get, set]
Gets or sets the update status of a drawing object. More...
bool | IsDragableOnReslultMode [get]
- Properties inherited from Deltares.Standard.Forms.IShape
object | DataObject [get, set]
int | Layer [get]

Member Function Documentation

override void Deltares.Geometry.Forms.DrawingPointString.Draw3D ( GraphicsInfo info )
virtual

override The Draw3D() Method

Parameters
info The info.

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

Reimplemented in Deltares.Geotechnics.Forms.DrawingWaternetPointString.

References Deltares.Standard.Forms.DrawingSupport.ColorMaterial3D(), Deltares.Standard.Forms.DrawingSupport.DrawPointSelector(), Deltares.Standard.Forms.DrawingSupport.GetLighterColor(), Deltares.Standard.Forms.DrawingSupport.Line3D(), Deltares.Standard.Forms.GraphicsInfo.MousePosition, Deltares.Standard.Forms.DrawingSupport.Pen3D(), and Deltares.Standard.Forms.DrawingSupport.SetIEPDraw3D().

override void Deltares.Geometry.Forms.DrawingPointString.DrawLabel ( GraphicsInfo info )
virtual

Renders a label or tooltip to provide some information in text for this object.

Parameters
info Rendering target information.

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

Reimplemented in Deltares.Geotechnics.Forms.DrawingWaternetPointString, Deltares.Geotechnics.Forms.DrawingWaternetLine, and Deltares.Geotechnics.Forms.DrawingLocalisedGeometryPointString.

References Deltares.Standard.Forms.DrawingSupport.DrawLabelAtPoint().

override object Deltares.Geometry.Forms.DrawingPointString.GetDataObject ( )
virtual

Gets the geotechnics entity that this drawing object represents

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

override void Deltares.Geometry.Forms.DrawingPointString.SetDataObject ( object aDataObject )
virtual

Sets the geotechnics entity that this drawing object represents

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

Reimplemented in Deltares.Geotechnics.Forms.DrawingWaternetLine, Deltares.Geotechnics.Forms.DrawingHeadLine, and Deltares.Geotechnics.Forms.DrawingPhreaticLine.

override void Deltares.Geometry.Forms.DrawingPointString.UpdateDataDragDrop | ( | Point3D | aBeginDragPoint,
 |  | Vector3D | vector
 | ) |  |
virtual

override The UpdateDataDragDrop() Method

Parameters
aBeginDragPoint | A begin drag point.
vector | The vector.

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

Generated on Tue Dec 15 2015 18:13:57 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geometry
  • Forms
  • DrawingPointString
Deltares.Geometry.Forms.DrawingPointString Member List

This is the complete list of members for Deltares.Geometry.Forms.DrawingPointString, including all inherited members.

AllowDrop(object data) | Deltares.Geometry.Forms.DrawingObject | virtual
BeginMove(IProjection projection, Point2D startPosition) (defined in Deltares.Geometry.Forms.DrawingPointString) | Deltares.Geometry.Forms.DrawingPointString | virtual
CanResize | Deltares.Geometry.Forms.DrawingObject |
CheckHitForSelection(IProjection projection, Point3D point, double tolerance) | Deltares.Geometry.Forms.DrawingObject | virtual
ContainsPoint(IProjection projection, Point point) | Deltares.Geometry.Forms.DrawingObject | virtual
DataItemAt(Point point, Projection projection) (defined in Deltares.Geometry.Forms.DrawingPointString) | Deltares.Geometry.Forms.DrawingPointString | virtual
DataObject (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
dragStyle (defined in Deltares.Geometry.Forms.DrawingPointString) | Deltares.Geometry.Forms.DrawingPointString | protected
Draw(GraphicsInfo info) | Deltares.Geometry.Forms.DrawingObject | virtual
Draw3D(GraphicsInfo info) | Deltares.Geometry.Forms.DrawingPointString | virtual
DrawingObject() (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
DrawingPointString() (defined in Deltares.Geometry.Forms.DrawingPointString) | Deltares.Geometry.Forms.DrawingPointString |
DrawingPointString(Color lineColor, Color backgroundColor, int layer) (defined in Deltares.Geometry.Forms.DrawingPointString) | Deltares.Geometry.Forms.DrawingPointString |
DrawingPointString(DragStyle dragStyle, Color lineColor, Color backgroundColor, int layer) (defined in Deltares.Geometry.Forms.DrawingPointString) | Deltares.Geometry.Forms.DrawingPointString |
DrawingPointString(DashStyle dashStyle, Color lineColor, Color backgroundColor, int layer) (defined in Deltares.Geometry.Forms.DrawingPointString) | Deltares.Geometry.Forms.DrawingPointString |
DrawingPointString(DragStyle dragStyle, DashStyle dashStyle, Color lineColor, Color backgroundColor, int layer) (defined in Deltares.Geometry.Forms.DrawingPointString) | Deltares.Geometry.Forms.DrawingPointString |
DrawLabel(GraphicsInfo info) | Deltares.Geometry.Forms.DrawingPointString | virtual
Drop(object data) | Deltares.Geometry.Forms.DrawingObject | virtual
EndMove(IProjection projection, Point2D startPosition, SizeF worldSize) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetCardinalDirectionOnEdgeContainingPoint(Point point) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetDataObject() | Deltares.Geometry.Forms.DrawingPointString | virtual
GetExtents(IProjection projection) | Deltares.Geometry.Forms.DrawingObject | virtual
GetPoints() (defined in Deltares.Geometry.Forms.DrawingPointString) | Deltares.Geometry.Forms.DrawingPointString | protected
GetScaled3DPoint(IProjection projection, Point3D aOrginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScaled3DPoint(IProjection projection, Point3D aOrginalPoint, ref Point3D aPointTobeScaled) | Deltares.Geometry.Forms.DrawingObject |
GetScaledXPoint(IProjection projection, double aOrginalCordinate) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, Point2D orginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, Point3D orginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, double x, double z) | Deltares.Geometry.Forms.DrawingObject |
GetStandardSize(object aDraw3DInterface, Point3D aPoint3D) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetThickness(GraphicsInfo info) | Deltares.Geometry.Forms.DrawingObject | protectedvirtual
HasBeenUpdated (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
IsDragableOnReslultMode (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
IsVisible (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
Layer (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
Move(IProjection projection, Point2D startPosition, SizeF worldSize) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
Name | Deltares.Geometry.Forms.DrawingObject |
OnBeginDrag(IProjection projection, Point3D aBeginDragDropPoint, bool isIndividualDrag) | Deltares.Geometry.Forms.DrawingObject | virtual
OnDragging(IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D) | Deltares.Geometry.Forms.DrawingObject | virtual
OnEndDrag(IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D) | Deltares.Geometry.Forms.DrawingObject | virtual
Selected | Deltares.Geometry.Forms.DrawingObject |
SetDataObject(object dataobject) | Deltares.Geometry.Forms.DrawingPointString | virtual
ToolTip | Deltares.Geometry.Forms.DrawingObject |
ToString() (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
UpdateDataDragDrop(Point3D aBeginDragPoint, Vector3D vector) | Deltares.Geometry.Forms.DrawingPointString | virtual
Deltares::Geometry::Forms::DrawingObject.UpdateDataDragDrop(Vector3D aVect3D, List< IDrawingObject > aDraggedObjects) | Deltares.Geometry.Forms.DrawingObject | virtual
Generated on Tue Dec 15 2015 18:13:57 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geometry.Forms.DrawingSurface Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geometry
  • Forms
  • DrawingSurface
Public Member Functions | Properties | List of all members
Deltares.Geometry.Forms.DrawingSurface Class Reference
Inheritance diagram for Deltares.Geometry.Forms.DrawingSurface:
Deltares.Geometry.Forms.DrawingObject Deltares.Geometry.Forms.IDrawingObject Deltares.Standard.Forms.IShape

Public Member Functions

override void | SetDataObject (object aDataObject)
Stes the data object for this.dataSurface. More...
override object | GetDataObject ()
Gets the IDataobject for this.dataSurface. More...
override void | UpdateDataDragDrop (Point3D beginDragPoint, Vector3D vector)
Updates the geometry after publisherEventArgs drag and drop. More...
override void | Draw3D (GraphicsInfo info)
Draws publisherEventArgs Curve from the set of points. More...
- Public Member Functions inherited from Deltares.Geometry.Forms.DrawingObject
Point3D | GetScaled3DPoint (IProjection projection, Point3D aOrginalPoint)
Converts the 3DPoint to screen coordinates More...
Point3D | GetScreenPoint (IProjection projection, Point2D orginalPoint)
Converts Point from 3D space to screen coordinates, assuming Y = 0 More...
Point3D | GetScreenPoint (IProjection projection, Point3D orginalPoint)
Converts Point from 3D space to screen coordinates More...
Point3D | GetScreenPoint (IProjection projection, double x, double z)
Converts 3D x, y coordinates to screen coordinates, assuming Y = 0 More...
override string | ToString ()
virtual void | UpdateDataDragDrop (Vector3D aVect3D, List< IDrawingObject > aDraggedObjects)
Update the position and or orientation of a drawing object as the user is dragging it. More...
virtual void | OnBeginDrag (IProjection projection, Point3D aBeginDragDropPoint, bool isIndividualDrag)
Method which is called when the user initiates a drag-drop operation More...
virtual CardinalDirection | GetCardinalDirectionOnEdgeContainingPoint (Point point)
virtual void | OnDragging (IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D)
Method which is called during drag-drop operations More...
virtual void | OnEndDrag (IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D)
Method which is called when the user ends a drag-drop operation. More...
virtual bool | CheckHitForSelection (IProjection projection, Point3D point, double tolerance)
Check if given point coordinates intersect the rendered drawing object. More...
virtual double | GetStandardSize (object aDraw3DInterface, Point3D aPoint3D)
void | GetScaled3DPoint (IProjection projection, Point3D aOrginalPoint, ref Point3D aPointTobeScaled)
Converts the 3DPoint to screen coordinates More...
double | GetScaledXPoint (IProjection projection, double aOrginalCordinate)
Converts X Coordinate in 3D space to a screen X Coordinate More...
virtual bool | ContainsPoint (IProjection projection, Point point)
Determines if a given point screen coordinate is within the drawing object. More...
virtual Rectangle | GetExtents (IProjection projection)
Returns the bounding box of the shape. More...
virtual void | Draw (GraphicsInfo info)
Render this object in 3D space. More...
virtual void | DrawLabel (GraphicsInfo info)
Renders a label or tooltip to provide some information in text for this object. More...
virtual void | Move (IProjection projection, Point2D startPosition, SizeF worldSize)
virtual void | BeginMove (IProjection projection, Point2D startPosition)
virtual void | EndMove (IProjection projection, Point2D startPosition, SizeF worldSize)
virtual bool | AllowDrop (object data)
Boolean which indicates if other drawing objects can be dropped on given drawing objects More...
virtual void | Drop (object data)
Ends a drag-drop operation More...
virtual IEnumerable< object > | DataItemAt (Point point, Projection projection)

Properties

byte | Red [get, set]
byte | Green [get, set]
byte | Blue [get, set]
- Properties inherited from Deltares.Geometry.Forms.DrawingObject
virtual bool | CanResize [get]
Boolean which indicates if a drawing object can be resized. More...
virtual bool | Selected [get, set]
Boolean which indicates if a drawing object is currently selected. More...
string | ToolTip [get]
Description which is shown as a tooltip when the mouse hovers over drawing object. More...
string | Name [get, set]
Gets or sets the name of a drawing object. More...
bool | IsVisible [get, set]
bool | HasBeenUpdated [get, set]
virtual bool | IsDragableOnReslultMode [get]
virtual int | Layer [get, set]
object | DataObject [get, set]
- Properties inherited from Deltares.Geometry.Forms.IDrawingObject
string | Name [get, set]
bool | IsVisible [get, set]
bool | HasBeenUpdated [get, set]
Gets or sets the update status of a drawing object. More...
bool | IsDragableOnReslultMode [get]
- Properties inherited from Deltares.Standard.Forms.IShape
object | DataObject [get, set]
int | Layer [get]

Additional Inherited Members

- Protected Member Functions inherited from Deltares.Geometry.Forms.DrawingObject
virtual int GetThickness (GraphicsInfo info)
Gets the thickness in screen pixels of a drawing object. More...

Member Function Documentation

override void Deltares.Geometry.Forms.DrawingSurface.Draw3D ( GraphicsInfo info )
virtual

Draws publisherEventArgs Curve from the set of points.

Parameters
info

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

References Deltares.Standard.Forms.DrawingSupport.Brush3D(), Deltares.Standard.Forms.DrawingSupport.ColorMaterial3D(), Deltares.Standard.Forms.DrawingSupport.CreateConvexPolygonBox(), Deltares.Standard.Forms.DrawingSupport.Font3D(), Deltares.Standard.Forms.DrawingSupport.Pen3D(), and Deltares.Standard.Forms.DrawingSupport.Text3D().

override object Deltares.Geometry.Forms.DrawingSurface.GetDataObject ( )
virtual

Gets the IDataobject for this.dataSurface.

Returns

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

override void Deltares.Geometry.Forms.DrawingSurface.SetDataObject ( object aDataObject )
virtual

Stes the data object for this.dataSurface.

Parameters
aDataObject

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

override void Deltares.Geometry.Forms.DrawingSurface.UpdateDataDragDrop | ( | Point3D | beginDragPoint,
 |  | Vector3D | vector
 | ) |  |
virtual

Updates the geometry after publisherEventArgs drag and drop.

Parameters
beginDragPoint
vector

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

Generated on Tue Dec 15 2015 18:13:57 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geometry
  • Forms
  • DrawingSurface
Deltares.Geometry.Forms.DrawingSurface Member List

This is the complete list of members for Deltares.Geometry.Forms.DrawingSurface, including all inherited members.

AllowDrop(object data) | Deltares.Geometry.Forms.DrawingObject | virtual
BeginMove(IProjection projection, Point2D startPosition) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
Blue (defined in Deltares.Geometry.Forms.DrawingSurface) | Deltares.Geometry.Forms.DrawingSurface | package
CanResize | Deltares.Geometry.Forms.DrawingObject |
CheckHitForSelection(IProjection projection, Point3D point, double tolerance) | Deltares.Geometry.Forms.DrawingObject | virtual
ContainsPoint(IProjection projection, Point point) | Deltares.Geometry.Forms.DrawingObject | virtual
DataItemAt(Point point, Projection projection) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
DataObject (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
Draw(GraphicsInfo info) | Deltares.Geometry.Forms.DrawingObject | virtual
Draw3D(GraphicsInfo info) | Deltares.Geometry.Forms.DrawingSurface | virtual
DrawingObject() (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
DrawingSurface() (defined in Deltares.Geometry.Forms.DrawingSurface) | Deltares.Geometry.Forms.DrawingSurface |
DrawLabel(GraphicsInfo info) | Deltares.Geometry.Forms.DrawingObject | virtual
Drop(object data) | Deltares.Geometry.Forms.DrawingObject | virtual
EndMove(IProjection projection, Point2D startPosition, SizeF worldSize) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetCardinalDirectionOnEdgeContainingPoint(Point point) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetDataObject() | Deltares.Geometry.Forms.DrawingSurface | virtual
GetExtents(IProjection projection) | Deltares.Geometry.Forms.DrawingObject | virtual
GetScaled3DPoint(IProjection projection, Point3D aOrginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScaled3DPoint(IProjection projection, Point3D aOrginalPoint, ref Point3D aPointTobeScaled) | Deltares.Geometry.Forms.DrawingObject |
GetScaledXPoint(IProjection projection, double aOrginalCordinate) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, Point2D orginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, Point3D orginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, double x, double z) | Deltares.Geometry.Forms.DrawingObject |
GetStandardSize(object aDraw3DInterface, Point3D aPoint3D) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetThickness(GraphicsInfo info) | Deltares.Geometry.Forms.DrawingObject | protectedvirtual
Green (defined in Deltares.Geometry.Forms.DrawingSurface) | Deltares.Geometry.Forms.DrawingSurface | package
HasBeenUpdated (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
IsDragableOnReslultMode (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
IsVisible (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
Layer (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
Move(IProjection projection, Point2D startPosition, SizeF worldSize) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
Name | Deltares.Geometry.Forms.DrawingObject |
OnBeginDrag(IProjection projection, Point3D aBeginDragDropPoint, bool isIndividualDrag) | Deltares.Geometry.Forms.DrawingObject | virtual
OnDragging(IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D) | Deltares.Geometry.Forms.DrawingObject | virtual
OnEndDrag(IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D) | Deltares.Geometry.Forms.DrawingObject | virtual
Red (defined in Deltares.Geometry.Forms.DrawingSurface) | Deltares.Geometry.Forms.DrawingSurface | package
Selected | Deltares.Geometry.Forms.DrawingObject |
SetDataObject(object aDataObject) | Deltares.Geometry.Forms.DrawingSurface | virtual
ToolTip | Deltares.Geometry.Forms.DrawingObject |
ToString() (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
UpdateDataDragDrop(Point3D beginDragPoint, Vector3D vector) | Deltares.Geometry.Forms.DrawingSurface | virtual
Deltares::Geometry::Forms::DrawingObject.UpdateDataDragDrop(Vector3D aVect3D, List< IDrawingObject > aDraggedObjects) | Deltares.Geometry.Forms.DrawingObject | virtual
Generated on Tue Dec 15 2015 18:13:57 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geometry.Forms.GeometryCurveControl Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geometry
  • Forms
  • GeometryCurveControl
Public Attributes | Protected Member Functions | Properties | List of all members
Deltares.Geometry.Forms.GeometryCurveControl Class Reference
Inheritance diagram for Deltares.Geometry.Forms.GeometryCurveControl:

Public Attributes

DevExpress.XtraEditors.GroupControl | StartPointGroup
DevExpress.XtraEditors.GroupControl | EndPointGroup

Protected Member Functions

override void Dispose (bool disposing)
Clean up any resources being used. More...

Properties

bool | IsVisible [get]
object | SelectedObject [get, set]

Member Function Documentation

override void Deltares.Geometry.Forms.GeometryCurveControl.Dispose ( bool disposing )
protected

Clean up any resources being used.

Parameters
disposing true if managed resources should be disposed; otherwise, false.
Generated on Tue Dec 15 2015 18:13:57 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geometry
  • Forms
  • GeometryCurveControl
Deltares.Geometry.Forms.GeometryCurveControl Member List

This is the complete list of members for Deltares.Geometry.Forms.GeometryCurveControl, including all inherited members.

Dispose(bool disposing) | Deltares.Geometry.Forms.GeometryCurveControl | protected
EndPointGroup (defined in Deltares.Geometry.Forms.GeometryCurveControl) | Deltares.Geometry.Forms.GeometryCurveControl |
GeometryCurveControl() (defined in Deltares.Geometry.Forms.GeometryCurveControl) | Deltares.Geometry.Forms.GeometryCurveControl |
IsVisible (defined in Deltares.Geometry.Forms.GeometryCurveControl) | Deltares.Geometry.Forms.GeometryCurveControl |
SelectedObject (defined in Deltares.Geometry.Forms.GeometryCurveControl) | Deltares.Geometry.Forms.GeometryCurveControl |
StartPointGroup (defined in Deltares.Geometry.Forms.GeometryCurveControl) | Deltares.Geometry.Forms.GeometryCurveControl |
Generated on Tue Dec 15 2015 18:13:57 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geometry.Forms.GeometryPlugin Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geometry
  • Forms
  • GeometryPlugin
Public Member Functions | List of all members
Deltares.Geometry.Forms.GeometryPlugin Class Reference
Inheritance diagram for Deltares.Geometry.Forms.GeometryPlugin:
Deltares.Standard.Forms.DExpress.IMainFormPlugin

Public Member Functions

void | Configure (MainForm mainForm)
void | Assign (object source)
Generated on Tue Dec 15 2015 18:13:57 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geometry
  • Forms
  • GeometryPlugin
Deltares.Geometry.Forms.GeometryPlugin Member List

This is the complete list of members for Deltares.Geometry.Forms.GeometryPlugin, including all inherited members.

Assign(object source) (defined in Deltares.Geometry.Forms.GeometryPlugin) | Deltares.Geometry.Forms.GeometryPlugin
Configure(MainForm mainForm) (defined in Deltares.Geometry.Forms.GeometryPlugin) | Deltares.Geometry.Forms.GeometryPlugin
Generated on Tue Dec 15 2015 18:13:57 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geometry.Forms.GeometryPointControl Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geometry
  • Forms
  • GeometryPointControl
Public Attributes | Protected Member Functions | Properties | List of all members
Deltares.Geometry.Forms.GeometryPointControl Class Reference
Inheritance diagram for Deltares.Geometry.Forms.GeometryPointControl:

Public Attributes

DevExpress.XtraEditors.GroupControl CoordinatesGroup

Protected Member Functions

override void Dispose (bool disposing)
Clean up any resources being used. More...

Properties

bool | IsVisible [get]
object | SelectedObject [get, set]

Member Function Documentation

override void Deltares.Geometry.Forms.GeometryPointControl.Dispose ( bool disposing )
protected

Clean up any resources being used.

Parameters
disposing true if managed resources should be disposed; otherwise, false.
Generated on Tue Dec 15 2015 18:13:58 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geometry
  • Forms
  • GeometryPointControl
Deltares.Geometry.Forms.GeometryPointControl Member List

This is the complete list of members for Deltares.Geometry.Forms.GeometryPointControl, including all inherited members.

CoordinatesGroup (defined in Deltares.Geometry.Forms.GeometryPointControl) | Deltares.Geometry.Forms.GeometryPointControl |
Dispose(bool disposing) | Deltares.Geometry.Forms.GeometryPointControl | protected
GeometryPointControl() (defined in Deltares.Geometry.Forms.GeometryPointControl) | Deltares.Geometry.Forms.GeometryPointControl |
IsVisible (defined in Deltares.Geometry.Forms.GeometryPointControl) | Deltares.Geometry.Forms.GeometryPointControl |
SelectedObject (defined in Deltares.Geometry.Forms.GeometryPointControl) | Deltares.Geometry.Forms.GeometryPointControl |
Generated on Tue Dec 15 2015 18:13:58 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geometry.Forms.GeometryStringControl Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geometry
  • Forms
  • GeometryStringControl
Protected Member Functions | Properties | List of all members
Deltares.Geometry.Forms.GeometryStringControl Class Reference
Inheritance diagram for Deltares.Geometry.Forms.GeometryStringControl:

Protected Member Functions

override void Dispose (bool disposing)
Clean up any resources being used. More...

Properties

object | SelectedObject [get, set]
bool | IsVisible [get]

Member Function Documentation

override void Deltares.Geometry.Forms.GeometryStringControl.Dispose ( bool disposing )
protected

Clean up any resources being used.

Parameters
disposing true if managed resources should be disposed; otherwise, false.
Generated on Tue Dec 15 2015 18:13:58 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geometry
  • Forms
  • GeometryStringControl
Deltares.Geometry.Forms.GeometryStringControl Member List

This is the complete list of members for Deltares.Geometry.Forms.GeometryStringControl, including all inherited members.

Dispose(bool disposing) | Deltares.Geometry.Forms.GeometryStringControl | protected
GeometryStringControl() (defined in Deltares.Geometry.Forms.GeometryStringControl) | Deltares.Geometry.Forms.GeometryStringControl |
IsVisible (defined in Deltares.Geometry.Forms.GeometryStringControl) | Deltares.Geometry.Forms.GeometryStringControl |
SelectedObject (defined in Deltares.Geometry.Forms.GeometryStringControl) | Deltares.Geometry.Forms.GeometryStringControl |
Generated on Tue Dec 15 2015 18:13:58 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geometry.Forms.GeometryViewSettings Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geometry
  • Forms
  • GeometryViewSettings
Public Member Functions | Properties | List of all members
Deltares.Geometry.Forms.GeometryViewSettings Class Reference
Inheritance diagram for Deltares.Geometry.Forms.GeometryViewSettings:
Deltares.Geometry.Forms.IGeometryViewSettings

Public Member Functions

override bool | GetStandardValuesSupported (ITypeDescriptorContext aContext)
override string | ToString ()

Properties

bool | AreGeometryPointsVisible [get, set]
Gets or sets publisherEventArgs boolean value if the point is visible. More...
bool | AreGeometryCurvesVisible [get, set]
Gets or stes the boolean value if the curve is visiblle. More...
bool | AreGeometrySurfaceVisible [get, set]
Gets or sets the boolean value if the surface is visible. More...
bool | IsGeometryPointLabelsOn [get, set]
Gets or sets publisherEventArgs boolean value if publisherEventArgs lable is visible for points. More...
bool | IsGeometryCurveLabelsOn [get, set]
Gets or sets publisherEventArgs boolean value if the label is visible for publisherEventArgs curve. More...
bool | IsGeometrySurfaceLabelsOn [get, set]
Gets or sets publisherEventArgs boolean value if the label is visible for publisherEventArgs surface. More...
bool | IsGeometrySurfaceMaterialLabelsOn [get, set]
Gets or sets publisherEventArgs boolean value if the label is visible for publisherEventArgs surface. More...
bool | IsGeometrySurfaceNameLabelsOn [get, set]
Gets or sets publisherEventArgs boolean value if the label is visible for publisherEventArgs surface. More...
bool | IsAutomaticRegeneration [get, set]
- Properties inherited from Deltares.Geometry.Forms.IGeometryViewSettings
bool | AreGeometryPointsVisible [get, set]
bool | AreGeometryCurvesVisible [get, set]
Gets or stes the boolean value if the curve is visiblle. More...
bool | AreGeometrySurfaceVisible [get, set]
Gets or sets the boolean value if the surface is visible. More...
bool | IsGeometryPointLabelsOn [get, set]
Gets or sets publisherEventArgs boolean value if publisherEventArgs lable is visible for points. More...
bool | IsGeometryCurveLabelsOn [get, set]
Gets or sets publisherEventArgs boolean value if the label is visible for publisherEventArgs curve. More...
bool | IsGeometrySurfaceLabelsOn [get, set]
Gets or sets publisherEventArgs boolean value if the label is visible for publisherEventArgs surface. More...
bool | IsGeometrySurfaceMaterialLabelsOn [get, set]
Gets or sets publisherEventArgs boolean value if the label is visible for publisherEventArgs surface material. More...
bool | IsGeometrySurfaceNameLabelsOn [get, set]
bool | IsAutomaticRegeneration [get, set]
Gets or sets the Automatic Regeneration More...

Property Documentation

bool Deltares.Geometry.Forms.GeometryViewSettings.AreGeometryCurvesVisible
getset

Gets or stes the boolean value if the curve is visiblle.

bool Deltares.Geometry.Forms.GeometryViewSettings.AreGeometryPointsVisible
getset

Gets or sets publisherEventArgs boolean value if the point is visible.

bool Deltares.Geometry.Forms.GeometryViewSettings.AreGeometrySurfaceVisible
getset

Gets or sets the boolean value if the surface is visible.

bool Deltares.Geometry.Forms.GeometryViewSettings.IsGeometryCurveLabelsOn
getset

Gets or sets publisherEventArgs boolean value if the label is visible for publisherEventArgs curve.

bool Deltares.Geometry.Forms.GeometryViewSettings.IsGeometryPointLabelsOn
getset

Gets or sets publisherEventArgs boolean value if publisherEventArgs lable is visible for points.

bool Deltares.Geometry.Forms.GeometryViewSettings.IsGeometrySurfaceLabelsOn
getset

Gets or sets publisherEventArgs boolean value if the label is visible for publisherEventArgs surface.

bool Deltares.Geometry.Forms.GeometryViewSettings.IsGeometrySurfaceMaterialLabelsOn
getset

Gets or sets publisherEventArgs boolean value if the label is visible for publisherEventArgs surface.

bool Deltares.Geometry.Forms.GeometryViewSettings.IsGeometrySurfaceNameLabelsOn
getset

Gets or sets publisherEventArgs boolean value if the label is visible for publisherEventArgs surface.

Generated on Tue Dec 15 2015 18:13:58 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geometry
  • Forms
  • GeometryViewSettings
Deltares.Geometry.Forms.GeometryViewSettings Member List

This is the complete list of members for Deltares.Geometry.Forms.GeometryViewSettings, including all inherited members.

AreGeometryCurvesVisible | Deltares.Geometry.Forms.GeometryViewSettings
AreGeometryPointsVisible | Deltares.Geometry.Forms.GeometryViewSettings
AreGeometrySurfaceVisible | Deltares.Geometry.Forms.GeometryViewSettings
GeometryViewSettings() (defined in Deltares.Geometry.Forms.GeometryViewSettings) | Deltares.Geometry.Forms.GeometryViewSettings
GetStandardValuesSupported(ITypeDescriptorContext aContext) (defined in Deltares.Geometry.Forms.GeometryViewSettings) | Deltares.Geometry.Forms.GeometryViewSettings
IsAutomaticRegeneration (defined in Deltares.Geometry.Forms.GeometryViewSettings) | Deltares.Geometry.Forms.GeometryViewSettings
IsGeometryCurveLabelsOn | Deltares.Geometry.Forms.GeometryViewSettings
IsGeometryPointLabelsOn | Deltares.Geometry.Forms.GeometryViewSettings
IsGeometrySurfaceLabelsOn | Deltares.Geometry.Forms.GeometryViewSettings
IsGeometrySurfaceMaterialLabelsOn | Deltares.Geometry.Forms.GeometryViewSettings
IsGeometrySurfaceNameLabelsOn | Deltares.Geometry.Forms.GeometryViewSettings
ToString() (defined in Deltares.Geometry.Forms.GeometryViewSettings) | Deltares.Geometry.Forms.GeometryViewSettings
Generated on Tue Dec 15 2015 18:13:58 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geometry.Forms.IDefinitionViewSettings Interface Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geometry
  • Forms
  • IDefinitionViewSettings
Properties | List of all members
Deltares.Geometry.Forms.IDefinitionViewSettings Interface Reference

Properties

bool | AreSlipPlaneVisible [get, set]
bool | IsSlipPlaneLabelsOn [get, set]
bool | AreForbiddenLine [get, set]
bool | AreCalculationAreaVisible [get, set]
bool | IsForbiddenLineLabelsOn [get, set]
bool | AreLoadsVisible [get, set]
Gets or sets the boolean value if the surface is visible. More...
bool | IsLoadsLabelsOn [get, set]
Gets or sets publisherEventArgs boolean value if the label is visible for publisherEventArgs surface. More...
double | LoadsSize [get, set]
bool | IsLoadsDefaultSize [get, set]
double | TreeOnSlopeTopPointY [get, set]
bool | AreGeotextileVisible [get, set]
bool | IsGeotextileLabelsOn [get, set]
bool | IsResultVisble [get, set]
bool | IsComputing [get, set]
bool | StressInGeometryVisible [get, set]

Property Documentation

bool Deltares.Geometry.Forms.IDefinitionViewSettings.AreLoadsVisible
getset

Gets or sets the boolean value if the surface is visible.

bool Deltares.Geometry.Forms.IDefinitionViewSettings.IsLoadsLabelsOn
getset

Gets or sets publisherEventArgs boolean value if the label is visible for publisherEventArgs surface.

Generated on Tue Dec 15 2015 18:13:58 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geometry
  • Forms
  • IDefinitionViewSettings
Deltares.Geometry.Forms.IDefinitionViewSettings Member List

This is the complete list of members for Deltares.Geometry.Forms.IDefinitionViewSettings, including all inherited members.

AreCalculationAreaVisible (defined in Deltares.Geometry.Forms.IDefinitionViewSettings) | Deltares.Geometry.Forms.IDefinitionViewSettings
AreForbiddenLine (defined in Deltares.Geometry.Forms.IDefinitionViewSettings) | Deltares.Geometry.Forms.IDefinitionViewSettings
AreGeotextileVisible (defined in Deltares.Geometry.Forms.IDefinitionViewSettings) | Deltares.Geometry.Forms.IDefinitionViewSettings
AreLoadsVisible | Deltares.Geometry.Forms.IDefinitionViewSettings
AreSlipPlaneVisible (defined in Deltares.Geometry.Forms.IDefinitionViewSettings) | Deltares.Geometry.Forms.IDefinitionViewSettings
IsComputing (defined in Deltares.Geometry.Forms.IDefinitionViewSettings) | Deltares.Geometry.Forms.IDefinitionViewSettings
IsForbiddenLineLabelsOn (defined in Deltares.Geometry.Forms.IDefinitionViewSettings) | Deltares.Geometry.Forms.IDefinitionViewSettings
IsGeotextileLabelsOn (defined in Deltares.Geometry.Forms.IDefinitionViewSettings) | Deltares.Geometry.Forms.IDefinitionViewSettings
IsLoadsDefaultSize (defined in Deltares.Geometry.Forms.IDefinitionViewSettings) | Deltares.Geometry.Forms.IDefinitionViewSettings
IsLoadsLabelsOn | Deltares.Geometry.Forms.IDefinitionViewSettings
IsResultVisble (defined in Deltares.Geometry.Forms.IDefinitionViewSettings) | Deltares.Geometry.Forms.IDefinitionViewSettings
IsSlipPlaneLabelsOn (defined in Deltares.Geometry.Forms.IDefinitionViewSettings) | Deltares.Geometry.Forms.IDefinitionViewSettings
LoadsSize (defined in Deltares.Geometry.Forms.IDefinitionViewSettings) | Deltares.Geometry.Forms.IDefinitionViewSettings
StressInGeometryVisible (defined in Deltares.Geometry.Forms.IDefinitionViewSettings) | Deltares.Geometry.Forms.IDefinitionViewSettings
TreeOnSlopeTopPointY (defined in Deltares.Geometry.Forms.IDefinitionViewSettings) | Deltares.Geometry.Forms.IDefinitionViewSettings
Generated on Tue Dec 15 2015 18:13:58 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geometry.Forms.IDrawingObject Interface Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geometry
  • Forms
  • IDrawingObject
Public Member Functions | Properties | List of all members
Deltares.Geometry.Forms.IDrawingObject Interface Reference
Inheritance diagram for Deltares.Geometry.Forms.IDrawingObject:
Deltares.Standard.Forms.IShape Deltares.Geometry.Forms.DrawingObject Deltares.DSoilModel.Forms.DrawingCenterCrestLocation Deltares.DSoilModel.Forms.DrawingLayerObsolete Deltares.DSoilModel.Forms.DrawingSoilSegmentSplitLocation Deltares.DSoilModel.Forms.DrawingSosSoilLayer1D Deltares.Geometry.Forms.ColoredDrawingObject Deltares.Geometry.Forms.DrawingBoundingBox Deltares.Geometry.Forms.DrawingLine Deltares.Geometry.Forms.DrawingPoint Deltares.Geometry.Forms.DrawingPointString Deltares.Geometry.Forms.DrawingSurface Deltares.Geotechnics.Forms.DrawingBlockRevetmentSegment Deltares.Geotechnics.Forms.DrawingBoring Deltares.Geotechnics.Forms.DrawingCPT Deltares.Geotechnics.Forms.DrawingGeometry Deltares.Geotechnics.Forms.DrawingLayer Deltares.Geotechnics.Forms.DrawingPiezometricHead Deltares.Geotechnics.Forms.DrawingRevetment Deltares.Geotechnics.Forms.DrawingSettlementCurve Deltares.Geotechnics.Forms.DrawingSoilProfile1D Deltares.Geotechnics.Forms.DrawingSoilSurface Deltares.Geotechnics.Forms.DrawingSpecificMechanismPointLocation Deltares.Geotechnics.Forms.DrawingSurfaceLine2 Deltares.Geotechnics.Forms.DrawingSwell Deltares.Geotechnics.Forms.DrawingWaterBasin Deltares.Geotechnics.Forms.DrawingWaterLevel Deltares.Geotechnics.Forms.DrawingWaterPolderBasin

Public Member Functions

void | Draw3D (GraphicsInfo info)
Render this drawing object in 3D space. More...
void | SetDataObject (object aDataObject)
Sets the geotechnics entity that this drawing object represents More...
object | GetDataObject ()
Gets the geotechnics entity that this drawing object represents More...
void | UpdateDataDragDrop (Vector3D aVect3D, List< IDrawingObject > aDraggedObjects)
Update the position and or orientation of a drawing object as the user is dragging it. More...
void | UpdateDataDragDrop (Point3D aBeginDragPoint, Vector3D vector)
Update the position and or orientation of a drawing object as the user is dragging it. More...
void | OnBeginDrag (IProjection projection, Point3D aBeginDragDropPoint, bool isIndividualDrag)
Method which is called when the user initiates a drag-drop operation More...
void | OnDragging (IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D)
Method which is called during drag-drop operations More...
void | OnEndDrag (IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D)
Method which is called when the user ends a drag-drop operation. More...
bool | CheckHitForSelection (IProjection projection, Point3D aHitPoint, double tolerance)
Check if given point coordinates intersect the rendered drawing object. More...
double | GetStandardSize (object aDraw3DInterface, Point3D aPoint3D)
void | GetScaled3DPoint (IProjection projection, Point3D aOrginalPoint, ref Point3D aPointTobeScaled)
Converts the 3DPoint to screen coordinates More...
double | GetScaledXPoint (IProjection projection, double aOrginalCordinate)
Converts X Coordinate in 3D space to a screen X Coordinate More...
- Public Member Functions inherited from Deltares.Standard.Forms.IShape
bool | ContainsPoint (IProjection projection, Point point)
void | Move (IProjection projection, Point2D startPosition, SizeF worldSize)
void | BeginMove (IProjection projection, Point2D startPosition)
CardinalDirection | GetCardinalDirectionOnEdgeContainingPoint (Point point)
void | EndMove (IProjection projection, Point2D startPosition, SizeF worldSize)
bool | AllowDrop (object data)
void | Drop (object data)
void | Draw (GraphicsInfo info)
void | DrawLabel (GraphicsInfo info)
Rectangle | GetExtents (IProjection projection)
IEnumerable< object > | DataItemAt (Point point, Projection projection)

Properties

string | Name [get, set]
bool | IsVisible [get, set]
bool | HasBeenUpdated [get, set]
Gets or sets the update status of a drawing object. More...
bool | IsDragableOnReslultMode [get]
- Properties inherited from Deltares.Standard.Forms.IShape
object | DataObject [get, set]
int | Layer [get]

Member Function Documentation

bool Deltares.Geometry.Forms.IDrawingObject.CheckHitForSelection | ( | IProjection | projection,
 |  | Point3D | aHitPoint,
 |  | double | tolerance
 | ) |  |

Check if given point coordinates intersect the rendered drawing object.

Parameters
projection
aHitPoint
tolerance
Returns

Implemented in Deltares.Geometry.Forms.DrawingObject.

void Deltares.Geometry.Forms.IDrawingObject.Draw3D ( GraphicsInfo info )

Render this drawing object in 3D space.

Parameters
info Rendering target information.

Implemented in Deltares.Geotechnics.Forms.DrawingCPT, Deltares.Geometry.Forms.DrawingPointString, Deltares.Geotechnics.Forms.DrawingSoilLayerSurface, Deltares.Geotechnics.Forms.DrawingBoring, Deltares.DSoilModel.Forms.DrawingSosSoilLayer1D, Deltares.Geometry.Forms.DrawingObject, Deltares.Geotechnics.Forms.DrawingSoilProfile1D, Deltares.Geotechnics.Forms.DrawingSpecificMechanismPointLocation, Deltares.DSoilModel.Forms.DrawingCenterCrestLocation, Deltares.DSoilModel.Forms.DrawingSoilSegmentSplitLocation, Deltares.Geometry.Forms.DrawingPoint, Deltares.Geotechnics.Forms.DrawingLayer, Deltares.DSoilModel.Forms.DrawingLayerObsolete, Deltares.Geotechnics.Forms.DrawingSoilSurface, Deltares.Geotechnics.Forms.DrawingGeometry, Deltares.Geotechnics.Forms.DrawingSheetPiling, Deltares.Geotechnics.Forms.DrawingAnchorAttachment, Deltares.Geometry.Forms.DrawingSurface, Deltares.Geometry.Forms.DrawingLine, Deltares.Geotechnics.Forms.DrawingSurfaceLine2, Deltares.Geotechnics.Forms.DrawingSwell, Deltares.Geotechnics.Forms.DrawingCharacteristicPoint, Deltares.Geotechnics.Forms.DrawingWaterBasin, Deltares.Geotechnics.Forms.DrawingPiezometricHead, Deltares.Geotechnics.Forms.DrawingWaterPolderBasin, Deltares.Geotechnics.Forms.DrawingWaternetPointString, Deltares.Geotechnics.Forms.DrawingRevetment, Deltares.Geotechnics.Forms.DrawingPreConsolidationStress, Deltares.Geotechnics.Forms.DrawingBlockRevetmentSegment, Deltares.Geotechnics.Forms.DrawingWaterLevel, Deltares.DSoilModel.Forms.DrawingBoringLayer, Deltares.Geotechnics.Forms.DrawingSettlementCurve, and Deltares.Geometry.Forms.DrawingBoundingBox.

object Deltares.Geometry.Forms.IDrawingObject.GetDataObject ( )

Gets the geotechnics entity that this drawing object represents

Implemented in Deltares.Geotechnics.Forms.DrawingCPT, Deltares.Geometry.Forms.DrawingObject, Deltares.Geotechnics.Forms.DrawingBoring, Deltares.Geotechnics.Forms.DrawingSoilProfile1D, Deltares.Geotechnics.Forms.DrawingSpecificMechanismPointLocation, Deltares.DSoilModel.Forms.DrawingCenterCrestLocation, Deltares.DSoilModel.Forms.DrawingSoilSegmentSplitLocation, Deltares.Geometry.Forms.DrawingPoint, Deltares.Geometry.Forms.DrawingPointString, Deltares.DSoilModel.Forms.DrawingSosSoilLayer1D, Deltares.Geotechnics.Forms.DrawingLayer, Deltares.DSoilModel.Forms.DrawingLayerObsolete, Deltares.Geotechnics.Forms.DrawingSurfaceLine2, Deltares.Geotechnics.Forms.DrawingSwell, Deltares.Geometry.Forms.DrawingSurface, Deltares.Geotechnics.Forms.DrawingSoilSurface, Deltares.Geotechnics.Forms.DrawingPiezometricHead, Deltares.Geotechnics.Forms.DrawingGeometry, Deltares.Geometry.Forms.DrawingLine, Deltares.Geotechnics.Forms.DrawingAnchorAttachment, Deltares.Geotechnics.Forms.DrawingBlockRevetmentSegment, Deltares.Geotechnics.Forms.DrawingRevetment, Deltares.Geotechnics.Forms.DrawingSheetPiling, Deltares.Geotechnics.Forms.DrawingWaterBasin, Deltares.Geotechnics.Forms.DrawingWaterPolderBasin, Deltares.DSoilModel.Forms.DrawingBoringLayer, Deltares.Geotechnics.Forms.DrawingWaterLevel, Deltares.Geotechnics.Forms.DrawingCharacteristicPoint, Deltares.Geotechnics.Forms.DrawingSettlementCurve, and Deltares.Geometry.Forms.DrawingBoundingBox.

void Deltares.Geometry.Forms.IDrawingObject.GetScaled3DPoint | ( | IProjection | projection,
 |  | Point3D | aOrginalPoint,
 |  | ref Point3D | aPointTobeScaled
 | ) |  |

Converts the 3DPoint to screen coordinates

Implemented in Deltares.Geometry.Forms.DrawingObject.

double Deltares.Geometry.Forms.IDrawingObject.GetScaledXPoint | ( | IProjection | projection,
 |  | double | aOrginalCordinate
 | ) |  |

Converts X Coordinate in 3D space to a screen X Coordinate

Implemented in Deltares.Geometry.Forms.DrawingObject.

void Deltares.Geometry.Forms.IDrawingObject.OnBeginDrag | ( | IProjection | projection,
 |  | Point3D | aBeginDragDropPoint,
 |  | bool | isIndividualDrag
 | ) |  |

Method which is called when the user initiates a drag-drop operation

Parameters
projection | Current projection of 3D to screen coordinates.
aBeginDragDropPoint | Initial position of the mouse pointer.
isIndividualDrag

Implemented in Deltares.Geotechnics.Forms.DrawingCPT, Deltares.Geotechnics.Forms.DrawingBoring, Deltares.Geotechnics.Forms.DrawingSpecificMechanismPointLocation, Deltares.DSoilModel.Forms.DrawingCenterCrestLocation, Deltares.Geotechnics.Forms.DrawingSoilProfile1D, Deltares.DSoilModel.Forms.DrawingSoilSegmentSplitLocation, Deltares.Geotechnics.Forms.DrawingRevetment, Deltares.Geometry.Forms.DrawingObject, Deltares.Geometry.Forms.DrawingPoint, Deltares.Geotechnics.Forms.DrawingSheetPiling, Deltares.Geotechnics.Forms.DrawingSoilSurface, Deltares.Geotechnics.Forms.DrawingSoilLayerSurface, Deltares.Geotechnics.Forms.DrawingGeometry, Deltares.Geometry.Forms.DrawingLine, and Deltares.Geotechnics.Forms.DrawingAnchorAttachment.

void Deltares.Geometry.Forms.IDrawingObject.OnDragging | ( | IProjection | projection,
 |  | Point3D | aCurrentDragPoint,
 |  | Vector3D | aVect3D
 | ) |  |

Method which is called during drag-drop operations

Parameters
projection | Current projection of 3D to screen coordinates.
aCurrentDragPoint | Current position of the drawing object.
aVect3D | 3D vector representing the displacement within the drag operation.

Implemented in Deltares.Geotechnics.Forms.DrawingRevetment, and Deltares.Geometry.Forms.DrawingObject.

void Deltares.Geometry.Forms.IDrawingObject.OnEndDrag | ( | IProjection | projection,
 |  | Point3D | aCurrentDragPoint,
 |  | Vector3D | aVect3D
 | ) |  |

Method which is called when the user ends a drag-drop operation.

Parameters
projection | Current projection
aCurrentDragPoint | Point in 3D space where the darg operation ends
aVect3D | Vector in 3D space which represents the displacement within the drag-drop operation

Implemented in Deltares.Geotechnics.Forms.DrawingCPT, Deltares.Geotechnics.Forms.DrawingBoring, Deltares.Geotechnics.Forms.DrawingSpecificMechanismPointLocation, Deltares.DSoilModel.Forms.DrawingCenterCrestLocation, Deltares.Geotechnics.Forms.DrawingSoilProfile1D, Deltares.DSoilModel.Forms.DrawingSoilSegmentSplitLocation, Deltares.Geometry.Forms.DrawingObject, Deltares.Geometry.Forms.DrawingPoint, Deltares.Geotechnics.Forms.DrawingSheetPiling, Deltares.Geotechnics.Forms.DrawingSoilLayerSurface, and Deltares.Geotechnics.Forms.DrawingAnchorAttachment.

void Deltares.Geometry.Forms.IDrawingObject.SetDataObject ( object aDataObject )

Sets the geotechnics entity that this drawing object represents

Implemented in Deltares.Geotechnics.Forms.DrawingCPT, Deltares.Geotechnics.Forms.DrawingSoilLayerSurface, Deltares.Geometry.Forms.DrawingObject, Deltares.Geotechnics.Forms.DrawingBoring, Deltares.Geotechnics.Forms.DrawingSpecificMechanismPointLocation, Deltares.Geotechnics.Forms.DrawingSoilProfile1D, Deltares.DSoilModel.Forms.DrawingCenterCrestLocation, Deltares.DSoilModel.Forms.DrawingSoilSegmentSplitLocation, Deltares.Geometry.Forms.DrawingPoint, Deltares.DSoilModel.Forms.DrawingSosSoilLayer1D, Deltares.Geometry.Forms.DrawingPointString, Deltares.Geotechnics.Forms.DrawingLayer, Deltares.DSoilModel.Forms.DrawingLayerObsolete, Deltares.Geotechnics.Forms.DrawingSurfaceLine2, Deltares.Geotechnics.Forms.DrawingRevetment, Deltares.Geotechnics.Forms.DrawingSwell, Deltares.Geometry.Forms.DrawingSurface, Deltares.Geotechnics.Forms.DrawingSoilSurface, Deltares.Geometry.Forms.DrawingLine, Deltares.Geotechnics.Forms.DrawingAnchorAttachment, Deltares.Geotechnics.Forms.DrawingGeometry, Deltares.Geotechnics.Forms.DrawingPiezometricHead, Deltares.Geotechnics.Forms.DrawingBlockRevetmentSegment, Deltares.Geotechnics.Forms.DrawingPreConsolidationStress, Deltares.Geotechnics.Forms.DrawingSheetPiling, Deltares.Geotechnics.Forms.DrawingWaterBasin, Deltares.Geotechnics.Forms.DrawingWaterPolderBasin, Deltares.Geotechnics.Forms.DrawingWaterLevel, Deltares.Geotechnics.Forms.DrawingCharacteristicPoint, Deltares.DSoilModel.Forms.DrawingBoringLayer, Deltares.Geotechnics.Forms.DrawingSettlementCurve, Deltares.Geotechnics.Forms.DrawingWaternetLine, Deltares.Geometry.Forms.DrawingBoundingBox, Deltares.Geotechnics.Forms.DrawingHeadLine, and Deltares.Geotechnics.Forms.DrawingPhreaticLine.

void Deltares.Geometry.Forms.IDrawingObject.UpdateDataDragDrop | ( | Vector3D | aVect3D,
 |  | List< IDrawingObject > | aDraggedObjects
 | ) |  |

Update the position and or orientation of a drawing object as the user is dragging it.

Parameters
aVect3D | Vector representing the displacement of an object during a drag-drop operation.
aDraggedObjects | The collection of drawing objects to be dragged as a group that this drawing object is part of.

Implemented in Deltares.Geometry.Forms.DrawingObject.

void Deltares.Geometry.Forms.IDrawingObject.UpdateDataDragDrop | ( | Point3D | aBeginDragPoint,
 |  | Vector3D | vector
 | ) |  |

Update the position and or orientation of a drawing object as the user is dragging it.

Parameters
aBeginDragPoint | Initial position of the Drawing object
vector | Vector representing the displacement of an object during a drag-drop operation.

Implemented in Deltares.Geotechnics.Forms.DrawingCPT, Deltares.Geotechnics.Forms.DrawingBoring, Deltares.Geotechnics.Forms.DrawingSpecificMechanismPointLocation, Deltares.DSoilModel.Forms.DrawingCenterCrestLocation, Deltares.Geotechnics.Forms.DrawingSoilProfile1D, Deltares.DSoilModel.Forms.DrawingSoilSegmentSplitLocation, Deltares.Geometry.Forms.DrawingObject, Deltares.Geometry.Forms.DrawingPoint, Deltares.Geometry.Forms.DrawingPointString, Deltares.Geotechnics.Forms.DrawingSoilLayerSurface, Deltares.Geotechnics.Forms.DrawingGeometry, Deltares.Geotechnics.Forms.DrawingSoilSurface, Deltares.Geotechnics.Forms.DrawingSurfaceLine2, Deltares.Geometry.Forms.DrawingSurface, Deltares.Geotechnics.Forms.DrawingAnchorAttachment, Deltares.Geometry.Forms.DrawingLine, Deltares.Geotechnics.Forms.DrawingWaterBasin, Deltares.Geotechnics.Forms.DrawingWaterPolderBasin, Deltares.Geotechnics.Forms.DrawingSheetPiling, Deltares.Geotechnics.Forms.DrawingWaterLevel, and Deltares.Geotechnics.Forms.DrawingSettlementCurve.

Property Documentation

bool Deltares.Geometry.Forms.IDrawingObject.HasBeenUpdated
getset

Gets or sets the update status of a drawing object.

Generated on Tue Dec 15 2015 18:13:59 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geometry
  • Forms
  • IDrawingObject
Deltares.Geometry.Forms.IDrawingObject Member List

This is the complete list of members for Deltares.Geometry.Forms.IDrawingObject, including all inherited members.

AllowDrop(object data) (defined in Deltares.Standard.Forms.IShape) | Deltares.Standard.Forms.IShape
BeginMove(IProjection projection, Point2D startPosition) (defined in Deltares.Standard.Forms.IShape) | Deltares.Standard.Forms.IShape
CheckHitForSelection(IProjection projection, Point3D aHitPoint, double tolerance) | Deltares.Geometry.Forms.IDrawingObject
ContainsPoint(IProjection projection, Point point) (defined in Deltares.Standard.Forms.IShape) | Deltares.Standard.Forms.IShape
DataItemAt(Point point, Projection projection) (defined in Deltares.Standard.Forms.IShape) | Deltares.Standard.Forms.IShape
DataObject (defined in Deltares.Standard.Forms.IShape) | Deltares.Standard.Forms.IShape
Draw(GraphicsInfo info) (defined in Deltares.Standard.Forms.IShape) | Deltares.Standard.Forms.IShape
Draw3D(GraphicsInfo info) | Deltares.Geometry.Forms.IDrawingObject
DrawLabel(GraphicsInfo info) (defined in Deltares.Standard.Forms.IShape) | Deltares.Standard.Forms.IShape
Drop(object data) (defined in Deltares.Standard.Forms.IShape) | Deltares.Standard.Forms.IShape
EndMove(IProjection projection, Point2D startPosition, SizeF worldSize) (defined in Deltares.Standard.Forms.IShape) | Deltares.Standard.Forms.IShape
GetCardinalDirectionOnEdgeContainingPoint(Point point) (defined in Deltares.Standard.Forms.IShape) | Deltares.Standard.Forms.IShape
GetDataObject() | Deltares.Geometry.Forms.IDrawingObject
GetExtents(IProjection projection) (defined in Deltares.Standard.Forms.IShape) | Deltares.Standard.Forms.IShape
GetScaled3DPoint(IProjection projection, Point3D aOrginalPoint, ref Point3D aPointTobeScaled) | Deltares.Geometry.Forms.IDrawingObject
GetScaledXPoint(IProjection projection, double aOrginalCordinate) | Deltares.Geometry.Forms.IDrawingObject
GetStandardSize(object aDraw3DInterface, Point3D aPoint3D) (defined in Deltares.Geometry.Forms.IDrawingObject) | Deltares.Geometry.Forms.IDrawingObject
HasBeenUpdated | Deltares.Geometry.Forms.IDrawingObject
IsDragableOnReslultMode (defined in Deltares.Geometry.Forms.IDrawingObject) | Deltares.Geometry.Forms.IDrawingObject
IsVisible (defined in Deltares.Geometry.Forms.IDrawingObject) | Deltares.Geometry.Forms.IDrawingObject
Layer (defined in Deltares.Standard.Forms.IShape) | Deltares.Standard.Forms.IShape
Move(IProjection projection, Point2D startPosition, SizeF worldSize) (defined in Deltares.Standard.Forms.IShape) | Deltares.Standard.Forms.IShape
Name (defined in Deltares.Geometry.Forms.IDrawingObject) | Deltares.Geometry.Forms.IDrawingObject
OnBeginDrag(IProjection projection, Point3D aBeginDragDropPoint, bool isIndividualDrag) | Deltares.Geometry.Forms.IDrawingObject
OnDragging(IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D) | Deltares.Geometry.Forms.IDrawingObject
OnEndDrag(IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D) | Deltares.Geometry.Forms.IDrawingObject
SetDataObject(object aDataObject) | Deltares.Geometry.Forms.IDrawingObject
UpdateDataDragDrop(Vector3D aVect3D, List< IDrawingObject > aDraggedObjects) | Deltares.Geometry.Forms.IDrawingObject
UpdateDataDragDrop(Point3D aBeginDragPoint, Vector3D vector) | Deltares.Geometry.Forms.IDrawingObject
Generated on Tue Dec 15 2015 18:13:59 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geometry.Forms.IGeometryViewSettings Interface Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geometry
  • Forms
  • IGeometryViewSettings
Properties | List of all members
Deltares.Geometry.Forms.IGeometryViewSettings Interface Reference
Inheritance diagram for Deltares.Geometry.Forms.IGeometryViewSettings:
Deltares.Geometry.Forms.GeometryViewSettings

Properties

bool | AreGeometryPointsVisible [get, set]
bool | AreGeometryCurvesVisible [get, set]
Gets or stes the boolean value if the curve is visiblle. More...
bool | AreGeometrySurfaceVisible [get, set]
Gets or sets the boolean value if the surface is visible. More...
bool | IsGeometryPointLabelsOn [get, set]
Gets or sets publisherEventArgs boolean value if publisherEventArgs lable is visible for points. More...
bool | IsGeometryCurveLabelsOn [get, set]
Gets or sets publisherEventArgs boolean value if the label is visible for publisherEventArgs curve. More...
bool | IsGeometrySurfaceLabelsOn [get, set]
Gets or sets publisherEventArgs boolean value if the label is visible for publisherEventArgs surface. More...
bool | IsGeometrySurfaceMaterialLabelsOn [get, set]
Gets or sets publisherEventArgs boolean value if the label is visible for publisherEventArgs surface material. More...
bool | IsGeometrySurfaceNameLabelsOn [get, set]
bool | IsAutomaticRegeneration [get, set]
Gets or sets the Automatic Regeneration More...

Property Documentation

bool Deltares.Geometry.Forms.IGeometryViewSettings.AreGeometryCurvesVisible
getset

Gets or stes the boolean value if the curve is visiblle.

bool Deltares.Geometry.Forms.IGeometryViewSettings.AreGeometrySurfaceVisible
getset

Gets or sets the boolean value if the surface is visible.

bool Deltares.Geometry.Forms.IGeometryViewSettings.IsAutomaticRegeneration
getset

Gets or sets the Automatic Regeneration

bool Deltares.Geometry.Forms.IGeometryViewSettings.IsGeometryCurveLabelsOn
getset

Gets or sets publisherEventArgs boolean value if the label is visible for publisherEventArgs curve.

bool Deltares.Geometry.Forms.IGeometryViewSettings.IsGeometryPointLabelsOn
getset

Gets or sets publisherEventArgs boolean value if publisherEventArgs lable is visible for points.

bool Deltares.Geometry.Forms.IGeometryViewSettings.IsGeometrySurfaceLabelsOn
getset

Gets or sets publisherEventArgs boolean value if the label is visible for publisherEventArgs surface.

bool Deltares.Geometry.Forms.IGeometryViewSettings.IsGeometrySurfaceMaterialLabelsOn
getset

Gets or sets publisherEventArgs boolean value if the label is visible for publisherEventArgs surface material.

Generated on Tue Dec 15 2015 18:13:59 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geometry
  • Forms
  • IGeometryViewSettings
Deltares.Geometry.Forms.IGeometryViewSettings Member List

This is the complete list of members for Deltares.Geometry.Forms.IGeometryViewSettings, including all inherited members.

AreGeometryCurvesVisible | Deltares.Geometry.Forms.IGeometryViewSettings
AreGeometryPointsVisible (defined in Deltares.Geometry.Forms.IGeometryViewSettings) | Deltares.Geometry.Forms.IGeometryViewSettings
AreGeometrySurfaceVisible | Deltares.Geometry.Forms.IGeometryViewSettings
IsAutomaticRegeneration | Deltares.Geometry.Forms.IGeometryViewSettings
IsGeometryCurveLabelsOn | Deltares.Geometry.Forms.IGeometryViewSettings
IsGeometryPointLabelsOn | Deltares.Geometry.Forms.IGeometryViewSettings
IsGeometrySurfaceLabelsOn | Deltares.Geometry.Forms.IGeometryViewSettings
IsGeometrySurfaceMaterialLabelsOn | Deltares.Geometry.Forms.IGeometryViewSettings
IsGeometrySurfaceNameLabelsOn (defined in Deltares.Geometry.Forms.IGeometryViewSettings) | Deltares.Geometry.Forms.IGeometryViewSettings
Generated on Tue Dec 15 2015 18:13:59 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geometry.Forms.ILocationMapViewSettings Interface Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geometry
  • Forms
  • ILocationMapViewSettings
Properties | List of all members
Deltares.Geometry.Forms.ILocationMapViewSettings Interface Reference

Properties

bool AreLocationMapVisible [get, set]
Gets or sets the boolean value if the surface is visible. More...

Property Documentation

bool Deltares.Geometry.Forms.ILocationMapViewSettings.AreLocationMapVisible
getset

Gets or sets the boolean value if the surface is visible.

Generated on Tue Dec 15 2015 18:13:59 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geometry
  • Forms
  • ILocationMapViewSettings
Deltares.Geometry.Forms.ILocationMapViewSettings Member List

This is the complete list of members for Deltares.Geometry.Forms.ILocationMapViewSettings, including all inherited members.

AreLocationMapVisible Deltares.Geometry.Forms.ILocationMapViewSettings
Generated on Tue Dec 15 2015 18:13:59 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geometry.Forms.ISoilGeometryViewSettings Interface Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geometry
  • Forms
  • ISoilGeometryViewSettings
Properties | List of all members
Deltares.Geometry.Forms.ISoilGeometryViewSettings Interface Reference

Properties

bool | AreSoilSurfacesVisible [get, set]
bool | AreSoilSurfaceLabelsOn [get, set]
Gets And Sets The Boolean Value For AreSoilSurfaceLabelsOn More...
bool | AreSoilSurfaceMaterialLabelsOn [get, set]
Gets And Sets The Boolean Value For AreSoilSurfaceMaterialLabelsOn More...
bool | AreGeometrySurfaceNameLabelsOn [get, set]

Property Documentation

bool Deltares.Geometry.Forms.ISoilGeometryViewSettings.AreSoilSurfaceLabelsOn
getset

Gets And Sets The Boolean Value For AreSoilSurfaceLabelsOn

bool Deltares.Geometry.Forms.ISoilGeometryViewSettings.AreSoilSurfaceMaterialLabelsOn
getset

Gets And Sets The Boolean Value For AreSoilSurfaceMaterialLabelsOn

Generated on Tue Dec 15 2015 18:13:59 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geometry
  • Forms
  • ISoilGeometryViewSettings
Deltares.Geometry.Forms.ISoilGeometryViewSettings Member List

This is the complete list of members for Deltares.Geometry.Forms.ISoilGeometryViewSettings, including all inherited members.

AreGeometrySurfaceNameLabelsOn (defined in Deltares.Geometry.Forms.ISoilGeometryViewSettings) | Deltares.Geometry.Forms.ISoilGeometryViewSettings
AreSoilSurfaceLabelsOn | Deltares.Geometry.Forms.ISoilGeometryViewSettings
AreSoilSurfaceMaterialLabelsOn | Deltares.Geometry.Forms.ISoilGeometryViewSettings
AreSoilSurfacesVisible (defined in Deltares.Geometry.Forms.ISoilGeometryViewSettings) | Deltares.Geometry.Forms.ISoilGeometryViewSettings
Generated on Tue Dec 15 2015 18:13:59 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geometry.Forms.IWaternetViewSettings Interface Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geometry
  • Forms
  • IWaternetViewSettings
Properties | List of all members
Deltares.Geometry.Forms.IWaternetViewSettings Interface Reference
Inheritance diagram for Deltares.Geometry.Forms.IWaternetViewSettings:
Deltares.Geotechnics.Forms.GeotechnicsViewSettings

Properties

object | CurrentWaternet [get, set]
bool | AreHeadlinesVisible [get, set]
bool | ArePhreaticlinesVisible [get, set]
bool | AreWaternetlinesVisible [get, set]
bool | AreHeadlinesLablesVisible [get, set]
bool | ArePhreaticlinesLablesVisible [get, set]
bool | AreWaternetlinesLablesVisible [get, set]
Generated on Tue Dec 15 2015 18:13:59 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geometry
  • Forms
  • IWaternetViewSettings
Deltares.Geometry.Forms.IWaternetViewSettings Member List

This is the complete list of members for Deltares.Geometry.Forms.IWaternetViewSettings, including all inherited members.

AreHeadlinesLablesVisible (defined in Deltares.Geometry.Forms.IWaternetViewSettings) | Deltares.Geometry.Forms.IWaternetViewSettings
AreHeadlinesVisible (defined in Deltares.Geometry.Forms.IWaternetViewSettings) | Deltares.Geometry.Forms.IWaternetViewSettings
ArePhreaticlinesLablesVisible (defined in Deltares.Geometry.Forms.IWaternetViewSettings) | Deltares.Geometry.Forms.IWaternetViewSettings
ArePhreaticlinesVisible (defined in Deltares.Geometry.Forms.IWaternetViewSettings) | Deltares.Geometry.Forms.IWaternetViewSettings
AreWaternetlinesLablesVisible (defined in Deltares.Geometry.Forms.IWaternetViewSettings) | Deltares.Geometry.Forms.IWaternetViewSettings
AreWaternetlinesVisible (defined in Deltares.Geometry.Forms.IWaternetViewSettings) | Deltares.Geometry.Forms.IWaternetViewSettings
CurrentWaternet (defined in Deltares.Geometry.Forms.IWaternetViewSettings) | Deltares.Geometry.Forms.IWaternetViewSettings
Generated on Tue Dec 15 2015 18:13:59 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geometry.Forms.SpatialEditorColors Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geometry
  • Forms
  • SpatialEditorColors
Static Public Member Functions | Static Public Attributes | List of all members
Deltares.Geometry.Forms.SpatialEditorColors Class Reference

Static Public Member Functions

static Color CurrentColor (GraphicsInfo info, bool draggingElement, bool draggingAnything, Color normalColor)

Static Public Attributes

static readonly Color | DragColor = Color.CornflowerBlue
static readonly Color | SelectedColor = Color.OrangeRed
static readonly Color | HoverColor = Color.SkyBlue
static readonly Color | SelectedHoverColor = Color.DarkOrange
Generated on Tue Dec 15 2015 18:13:59 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geometry
  • Forms
  • SpatialEditorColors
Deltares.Geometry.Forms.SpatialEditorColors Member List

This is the complete list of members for Deltares.Geometry.Forms.SpatialEditorColors, including all inherited members.

CurrentColor(GraphicsInfo info, bool draggingElement, bool draggingAnything, Color normalColor) (defined in Deltares.Geometry.Forms.SpatialEditorColors) | Deltares.Geometry.Forms.SpatialEditorColors | static
DragColor (defined in Deltares.Geometry.Forms.SpatialEditorColors) | Deltares.Geometry.Forms.SpatialEditorColors | static
HoverColor (defined in Deltares.Geometry.Forms.SpatialEditorColors) | Deltares.Geometry.Forms.SpatialEditorColors | static
SelectedColor (defined in Deltares.Geometry.Forms.SpatialEditorColors) | Deltares.Geometry.Forms.SpatialEditorColors | static
SelectedHoverColor (defined in Deltares.Geometry.Forms.SpatialEditorColors) | Deltares.Geometry.Forms.SpatialEditorColors | static
Generated on Tue Dec 15 2015 18:13:59 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.Forms.Properties.Resources Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • Properties
  • Resources
Properties | List of all members
Deltares.Geotechnics.Forms.Properties.Resources Class Reference

A strongly-typed resource class, for looking up localized strings, etc. More...

Properties

static global::System.Resources.ResourceManager | ResourceManager [get]
Returns the cached ResourceManager instance used by this class. More...
static global::System.Globalization.CultureInfo | Culture [get, set]
Overrides the current thread's CurrentUICulture property for all resource lookups using this strongly typed resource class. More...
static string | AddHeadlineCaption [get]
Looks up a localized string similar to Add Head line. More...
static string | AddPointCaption [get]
Looks up a localized string similar to Add Point. More...
static string | AddWaternetlineCaption [get]
Looks up a localized string similar to Add Waternet line. More...
static string | CopyHeadlineCaption [get]
Looks up a localized string similar to Copy Head line. More...
static string | CopyPointCaption [get]
Looks up a localized string similar to Copy Point. More...
static string | CopyWaternetlineCaption [get]
Looks up a localized string similar to Copy Waternetline. More...
static string | Currentwaternet [get]
Looks up a localized string similar to Active Waternet. More...
static string | CutHeadlineCaption [get]
Looks up a localized string similar to Cut Head line. More...
static string | CutPointCaption [get]
Looks up a localized string similar to Cut Point. More...
static string | CutWaternetlineCaption [get]
Looks up a localized string similar to Cut Waternet line. More...
static string | DecimateHeightCaption [get]
Looks up a localized string similar to Decimate height. More...
static string | DegreeOfConsolidationCaption [get]
Looks up a localized string similar to Degree of consolidation [%]. More...
static string | DeleteHeadlineCaption [get]
Looks up a localized string similar to Delete Head line. More...
static string | DeletePointCaption [get]
Looks up a localized string similar to Delete Point. More...
static string | DeleteWaternetlineCaption [get]
Looks up a localized string similar to Delete Waternet line. More...
static string | DescriptionCaption [get]
Looks up a localized string similar to Name. More...
static string | DesignLevelCaption [get]
Looks up a localized string similar to Design level. More...
static string | HeadLinesCaption [get]
Looks up a localized string similar to Head Lines. More...
static string | InsertHeadlineCaption [get]
Looks up a localized string similar to Insert Head line. More...
static string | InsertPointCaption [get]
Looks up a localized string similar to Insert Point. More...
static string | InsertWaternetlineCaption [get]
Looks up a localized string similar to Insert Waternet line. More...
static string | MoveHeadlineDownCaption [get]
Looks up a localized string similar to Move Headline Down. More...
static string | MoveHeadlineupCaption [get]
Looks up a localized string similar to Move Headline up. More...
static string | MoveWaternetlineDownCaption [get]
Looks up a localized string similar to Move Waternetline Down. More...
static string | MoveWaternetlineupCaption [get]
Looks up a localized string similar to Move Waternetline up. More...
static string | NameCaption [get]
Looks up a localized string similar to Description. More...
static string | PasteHeadlineCaption [get]
Looks up a localized string similar to Paste Head line. More...
static string | PastePointCaption [get]
Looks up a localized string similar to Paste Point. More...
static string | PasteWaternetlineCaption [get]
Looks up a localized string similar to Paste Waternet line. More...
static string | PhreaticLineCaption [get]
Looks up a localized string similar to Phreatic Line. More...
static string | PhreaticLineDescription [get]
Looks up a localized string similar to Description. More...
static string | RenamewaternetCaption [get]
Looks up a localized string similar to Rename waternet. More...
static string | Setascurrentwaternet [get]
Looks up a localized string similar to Set as Active Waternet. More...
static string | UnitweightCaption [get]
Looks up a localized string similar to Unit weight. More...
static string | UnitWeightOfWaterCaption [get]
Looks up a localized string similar to Unit weight of water. More...
static string | WaterDataNameCaption [get]
Looks up a localized string similar to Water data name. More...
static string | WaterLevelCaption [get]
Looks up a localized string similar to Level. More...
static string | WaternetCaption [get]
Looks up a localized string similar to Waternet. More...
static string | WaternetLinesCaption [get]
Looks up a localized string similar to Waternet Lines. More...

Detailed Description

A strongly-typed resource class, for looking up localized strings, etc.

Property Documentation

string Deltares.Geotechnics.Forms.Properties.Resources.AddHeadlineCaption
staticgetpackage

Looks up a localized string similar to Add Head line.

string Deltares.Geotechnics.Forms.Properties.Resources.AddPointCaption
staticgetpackage

Looks up a localized string similar to Add Point.

string Deltares.Geotechnics.Forms.Properties.Resources.AddWaternetlineCaption
staticgetpackage

Looks up a localized string similar to Add Waternet line.

string Deltares.Geotechnics.Forms.Properties.Resources.CopyHeadlineCaption
staticgetpackage

Looks up a localized string similar to Copy Head line.

string Deltares.Geotechnics.Forms.Properties.Resources.CopyPointCaption
staticgetpackage

Looks up a localized string similar to Copy Point.

string Deltares.Geotechnics.Forms.Properties.Resources.CopyWaternetlineCaption
staticgetpackage

Looks up a localized string similar to Copy Waternetline.

global.System.Globalization.CultureInfo Deltares.Geotechnics.Forms.Properties.Resources.Culture
staticgetsetpackage

Overrides the current thread's CurrentUICulture property for all resource lookups using this strongly typed resource class.

string Deltares.Geotechnics.Forms.Properties.Resources.Currentwaternet
staticgetpackage

Looks up a localized string similar to Active Waternet.

string Deltares.Geotechnics.Forms.Properties.Resources.CutHeadlineCaption
staticgetpackage

Looks up a localized string similar to Cut Head line.

string Deltares.Geotechnics.Forms.Properties.Resources.CutPointCaption
staticgetpackage

Looks up a localized string similar to Cut Point.

string Deltares.Geotechnics.Forms.Properties.Resources.CutWaternetlineCaption
staticgetpackage

Looks up a localized string similar to Cut Waternet line.

string Deltares.Geotechnics.Forms.Properties.Resources.DecimateHeightCaption
staticgetpackage

Looks up a localized string similar to Decimate height.

string Deltares.Geotechnics.Forms.Properties.Resources.DegreeOfConsolidationCaption
staticgetpackage

Looks up a localized string similar to Degree of consolidation [%].

string Deltares.Geotechnics.Forms.Properties.Resources.DeleteHeadlineCaption
staticgetpackage

Looks up a localized string similar to Delete Head line.

string Deltares.Geotechnics.Forms.Properties.Resources.DeletePointCaption
staticgetpackage

Looks up a localized string similar to Delete Point.

string Deltares.Geotechnics.Forms.Properties.Resources.DeleteWaternetlineCaption
staticgetpackage

Looks up a localized string similar to Delete Waternet line.

string Deltares.Geotechnics.Forms.Properties.Resources.DescriptionCaption
staticgetpackage

Looks up a localized string similar to Name.

string Deltares.Geotechnics.Forms.Properties.Resources.DesignLevelCaption
staticgetpackage

Looks up a localized string similar to Design level.

string Deltares.Geotechnics.Forms.Properties.Resources.HeadLinesCaption
staticgetpackage

Looks up a localized string similar to Head Lines.

string Deltares.Geotechnics.Forms.Properties.Resources.InsertHeadlineCaption
staticgetpackage

Looks up a localized string similar to Insert Head line.

string Deltares.Geotechnics.Forms.Properties.Resources.InsertPointCaption
staticgetpackage

Looks up a localized string similar to Insert Point.

string Deltares.Geotechnics.Forms.Properties.Resources.InsertWaternetlineCaption
staticgetpackage

Looks up a localized string similar to Insert Waternet line.

string Deltares.Geotechnics.Forms.Properties.Resources.MoveHeadlineDownCaption
staticgetpackage

Looks up a localized string similar to Move Headline Down.

string Deltares.Geotechnics.Forms.Properties.Resources.MoveHeadlineupCaption
staticgetpackage

Looks up a localized string similar to Move Headline up.

string Deltares.Geotechnics.Forms.Properties.Resources.MoveWaternetlineDownCaption
staticgetpackage

Looks up a localized string similar to Move Waternetline Down.

string Deltares.Geotechnics.Forms.Properties.Resources.MoveWaternetlineupCaption
staticgetpackage

Looks up a localized string similar to Move Waternetline up.

string Deltares.Geotechnics.Forms.Properties.Resources.NameCaption
staticgetpackage

Looks up a localized string similar to Description.

string Deltares.Geotechnics.Forms.Properties.Resources.PasteHeadlineCaption
staticgetpackage

Looks up a localized string similar to Paste Head line.

string Deltares.Geotechnics.Forms.Properties.Resources.PastePointCaption
staticgetpackage

Looks up a localized string similar to Paste Point.

string Deltares.Geotechnics.Forms.Properties.Resources.PasteWaternetlineCaption
staticgetpackage

Looks up a localized string similar to Paste Waternet line.

string Deltares.Geotechnics.Forms.Properties.Resources.PhreaticLineCaption
staticgetpackage

Looks up a localized string similar to Phreatic Line.

string Deltares.Geotechnics.Forms.Properties.Resources.PhreaticLineDescription
staticgetpackage

Looks up a localized string similar to Description.

string Deltares.Geotechnics.Forms.Properties.Resources.RenamewaternetCaption
staticgetpackage

Looks up a localized string similar to Rename waternet.

global.System.Resources.ResourceManager Deltares.Geotechnics.Forms.Properties.Resources.ResourceManager
staticgetpackage

Returns the cached ResourceManager instance used by this class.

string Deltares.Geotechnics.Forms.Properties.Resources.Setascurrentwaternet
staticgetpackage

Looks up a localized string similar to Set as Active Waternet.

string Deltares.Geotechnics.Forms.Properties.Resources.UnitweightCaption
staticgetpackage

Looks up a localized string similar to Unit weight.

string Deltares.Geotechnics.Forms.Properties.Resources.UnitWeightOfWaterCaption
staticgetpackage

Looks up a localized string similar to Unit weight of water.

string Deltares.Geotechnics.Forms.Properties.Resources.WaterDataNameCaption
staticgetpackage

Looks up a localized string similar to Water data name.

string Deltares.Geotechnics.Forms.Properties.Resources.WaterLevelCaption
staticgetpackage

Looks up a localized string similar to Level.

string Deltares.Geotechnics.Forms.Properties.Resources.WaternetCaption
staticgetpackage

Looks up a localized string similar to Waternet.

string Deltares.Geotechnics.Forms.Properties.Resources.WaternetLinesCaption
staticgetpackage

Looks up a localized string similar to Waternet Lines.

Generated on Tue Dec 15 2015 18:14:19 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • Properties
  • Resources
Deltares.Geotechnics.Forms.Properties.Resources Member List

This is the complete list of members for Deltares.Geotechnics.Forms.Properties.Resources, including all inherited members.

AddHeadlineCaption | Deltares.Geotechnics.Forms.Properties.Resources | packagestatic
AddPointCaption | Deltares.Geotechnics.Forms.Properties.Resources | packagestatic
AddWaternetlineCaption | Deltares.Geotechnics.Forms.Properties.Resources | packagestatic
CopyHeadlineCaption | Deltares.Geotechnics.Forms.Properties.Resources | packagestatic
CopyPointCaption | Deltares.Geotechnics.Forms.Properties.Resources | packagestatic
CopyWaternetlineCaption | Deltares.Geotechnics.Forms.Properties.Resources | packagestatic
Culture | Deltares.Geotechnics.Forms.Properties.Resources | packagestatic
Currentwaternet | Deltares.Geotechnics.Forms.Properties.Resources | packagestatic
CutHeadlineCaption | Deltares.Geotechnics.Forms.Properties.Resources | packagestatic
CutPointCaption | Deltares.Geotechnics.Forms.Properties.Resources | packagestatic
CutWaternetlineCaption | Deltares.Geotechnics.Forms.Properties.Resources | packagestatic
DecimateHeightCaption | Deltares.Geotechnics.Forms.Properties.Resources | packagestatic
DegreeOfConsolidationCaption | Deltares.Geotechnics.Forms.Properties.Resources | packagestatic
DeleteHeadlineCaption | Deltares.Geotechnics.Forms.Properties.Resources | packagestatic
DeletePointCaption | Deltares.Geotechnics.Forms.Properties.Resources | packagestatic
DeleteWaternetlineCaption | Deltares.Geotechnics.Forms.Properties.Resources | packagestatic
DescriptionCaption | Deltares.Geotechnics.Forms.Properties.Resources | packagestatic
DesignLevelCaption | Deltares.Geotechnics.Forms.Properties.Resources | packagestatic
HeadLinesCaption | Deltares.Geotechnics.Forms.Properties.Resources | packagestatic
InsertHeadlineCaption | Deltares.Geotechnics.Forms.Properties.Resources | packagestatic
InsertPointCaption | Deltares.Geotechnics.Forms.Properties.Resources | packagestatic
InsertWaternetlineCaption | Deltares.Geotechnics.Forms.Properties.Resources | packagestatic
MoveHeadlineDownCaption | Deltares.Geotechnics.Forms.Properties.Resources | packagestatic
MoveHeadlineupCaption | Deltares.Geotechnics.Forms.Properties.Resources | packagestatic
MoveWaternetlineDownCaption | Deltares.Geotechnics.Forms.Properties.Resources | packagestatic
MoveWaternetlineupCaption | Deltares.Geotechnics.Forms.Properties.Resources | packagestatic
NameCaption | Deltares.Geotechnics.Forms.Properties.Resources | packagestatic
PasteHeadlineCaption | Deltares.Geotechnics.Forms.Properties.Resources | packagestatic
PastePointCaption | Deltares.Geotechnics.Forms.Properties.Resources | packagestatic
PasteWaternetlineCaption | Deltares.Geotechnics.Forms.Properties.Resources | packagestatic
PhreaticLineCaption | Deltares.Geotechnics.Forms.Properties.Resources | packagestatic
PhreaticLineDescription | Deltares.Geotechnics.Forms.Properties.Resources | packagestatic
RenamewaternetCaption | Deltares.Geotechnics.Forms.Properties.Resources | packagestatic
ResourceManager | Deltares.Geotechnics.Forms.Properties.Resources | packagestatic
Resources() (defined in Deltares.Geotechnics.Forms.Properties.Resources) | Deltares.Geotechnics.Forms.Properties.Resources | package
Setascurrentwaternet | Deltares.Geotechnics.Forms.Properties.Resources | packagestatic
UnitweightCaption | Deltares.Geotechnics.Forms.Properties.Resources | packagestatic
UnitWeightOfWaterCaption | Deltares.Geotechnics.Forms.Properties.Resources | packagestatic
WaterDataNameCaption | Deltares.Geotechnics.Forms.Properties.Resources | packagestatic
WaterLevelCaption | Deltares.Geotechnics.Forms.Properties.Resources | packagestatic
WaternetCaption | Deltares.Geotechnics.Forms.Properties.Resources | packagestatic
WaternetLinesCaption | Deltares.Geotechnics.Forms.Properties.Resources | packagestatic
Generated on Tue Dec 15 2015 18:14:19 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.Forms.AnchorAttachmentControl Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • AnchorAttachmentControl
Protected Member Functions | Properties | List of all members
Deltares.Geotechnics.Forms.AnchorAttachmentControl Class Reference
Inheritance diagram for Deltares.Geotechnics.Forms.AnchorAttachmentControl:

Protected Member Functions

override void Dispose (bool disposing)
Clean up any resources being used. More...

Properties

object | SelectedObject [get, set]
bool | IsVisible [get]

Member Function Documentation

override void Deltares.Geotechnics.Forms.AnchorAttachmentControl.Dispose ( bool disposing )
protected

Clean up any resources being used.

Parameters
disposing true if managed resources should be disposed; otherwise, false.
Generated on Tue Dec 15 2015 18:14:00 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • AnchorAttachmentControl
Deltares.Geotechnics.Forms.AnchorAttachmentControl Member List

This is the complete list of members for Deltares.Geotechnics.Forms.AnchorAttachmentControl, including all inherited members.

AnchorAttachmentControl() (defined in Deltares.Geotechnics.Forms.AnchorAttachmentControl) | Deltares.Geotechnics.Forms.AnchorAttachmentControl |
Dispose(bool disposing) | Deltares.Geotechnics.Forms.AnchorAttachmentControl | protected
IsVisible (defined in Deltares.Geotechnics.Forms.AnchorAttachmentControl) | Deltares.Geotechnics.Forms.AnchorAttachmentControl |
SelectedObject (defined in Deltares.Geotechnics.Forms.AnchorAttachmentControl) | Deltares.Geotechnics.Forms.AnchorAttachmentControl |
Generated on Tue Dec 15 2015 18:14:00 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.Forms.BondStressCurveControl Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • BondStressCurveControl
Public Member Functions | Protected Member Functions | Properties | List of all members
Deltares.Geotechnics.Forms.BondStressCurveControl Class Reference

Earthquake Dialog. More...

Inheritance diagram for Deltares.Geotechnics.Forms.BondStressCurveControl:

Public Member Functions

BondStressCurveControl ()
Constructor. More...

Protected Member Functions

override void Dispose (bool disposing)
Clean up any resources being used. More...

Properties

object | SelectedObject [get, set]
bool | IsVisible [get]

Detailed Description

Earthquake Dialog.

Constructor & Destructor Documentation

Deltares.Geotechnics.Forms.BondStressCurveControl.BondStressCurveControl ( )

Constructor.

References Deltares.Standard.Forms.DExpress.BindSupport.Bind(), Deltares.Standard.Forms.DExpress.BindSupport.BindTextAndValue(), and Deltares.Standard.Forms.DExpress.LocalizationSupport.RegisterAndTranslate().

Member Function Documentation

override void Deltares.Geotechnics.Forms.BondStressCurveControl.Dispose ( bool disposing )
protected

Clean up any resources being used.

Parameters
disposing true if managed resources should be disposed; otherwise, false.
Generated on Tue Dec 15 2015 18:14:01 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • BondStressCurveControl
Deltares.Geotechnics.Forms.BondStressCurveControl Member List

This is the complete list of members for Deltares.Geotechnics.Forms.BondStressCurveControl, including all inherited members.

BondStressCurveControl() | Deltares.Geotechnics.Forms.BondStressCurveControl |
Dispose(bool disposing) | Deltares.Geotechnics.Forms.BondStressCurveControl | protected
IsVisible (defined in Deltares.Geotechnics.Forms.BondStressCurveControl) | Deltares.Geotechnics.Forms.BondStressCurveControl |
SelectedObject (defined in Deltares.Geotechnics.Forms.BondStressCurveControl) | Deltares.Geotechnics.Forms.BondStressCurveControl |
Generated on Tue Dec 15 2015 18:14:01 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.Forms.BoringControl Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • BoringControl
Public Member Functions | Protected Member Functions | Properties | List of all members
Deltares.Geotechnics.Forms.BoringControl Class Reference

Earthquake Dialog. More...

Inheritance diagram for Deltares.Geotechnics.Forms.BoringControl:

Public Member Functions

BoringControl ()
Constructor. More...

Protected Member Functions

override void Dispose (bool disposing)
Clean up any resources being used. More...

Properties

object | SelectedObject [get, set]
bool | IsVisible [get]

Detailed Description

Earthquake Dialog.

Constructor & Destructor Documentation

Deltares.Geotechnics.Forms.BoringControl.BoringControl ( )

Constructor.

References Deltares.Standard.Forms.DExpress.BindSupport.Bind(), Deltares.Standard.Forms.DExpress.BindSupport.BindTextAndValue(), Deltares.Standard.Forms.DExpress.BindSupport.BindTextValueAndUnit(), and Deltares.Standard.Forms.DExpress.LocalizationSupport.RegisterAndTranslate().

Member Function Documentation

override void Deltares.Geotechnics.Forms.BoringControl.Dispose ( bool disposing )
protected

Clean up any resources being used.

Parameters
disposing true if managed resources should be disposed; otherwise, false.
Generated on Tue Dec 15 2015 18:14:01 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • BoringControl
Deltares.Geotechnics.Forms.BoringControl Member List

This is the complete list of members for Deltares.Geotechnics.Forms.BoringControl, including all inherited members.

BoringControl() | Deltares.Geotechnics.Forms.BoringControl |
Dispose(bool disposing) | Deltares.Geotechnics.Forms.BoringControl | protected
IsVisible (defined in Deltares.Geotechnics.Forms.BoringControl) | Deltares.Geotechnics.Forms.BoringControl |
SelectedObject (defined in Deltares.Geotechnics.Forms.BoringControl) | Deltares.Geotechnics.Forms.BoringControl |
Generated on Tue Dec 15 2015 18:14:01 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.Forms.BoringLookupControl Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • BoringLookupControl
Protected Member Functions | Properties | List of all members
Deltares.Geotechnics.Forms.BoringLookupControl Class Reference
Inheritance diagram for Deltares.Geotechnics.Forms.BoringLookupControl:

Protected Member Functions

override void Dispose (bool disposing)
Clean up any resources being used. More...

Properties

object | SelectedObject [get, set]
bool | IsVisible [get]

Member Function Documentation

override void Deltares.Geotechnics.Forms.BoringLookupControl.Dispose ( bool disposing )
protected

Clean up any resources being used.

Parameters
disposing true if managed resources should be disposed; otherwise, false.
Generated on Tue Dec 15 2015 18:14:01 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • BoringLookupControl
Deltares.Geotechnics.Forms.BoringLookupControl Member List

This is the complete list of members for Deltares.Geotechnics.Forms.BoringLookupControl, including all inherited members.

BoringLookupControl() (defined in Deltares.Geotechnics.Forms.BoringLookupControl) | Deltares.Geotechnics.Forms.BoringLookupControl |
Dispose(bool disposing) | Deltares.Geotechnics.Forms.BoringLookupControl | protected
IsVisible (defined in Deltares.Geotechnics.Forms.BoringLookupControl) | Deltares.Geotechnics.Forms.BoringLookupControl |
SelectedObject (defined in Deltares.Geotechnics.Forms.BoringLookupControl) | Deltares.Geotechnics.Forms.BoringLookupControl |
Generated on Tue Dec 15 2015 18:14:01 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.Forms.CPTControl Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • CPTControl
Public Member Functions | Protected Member Functions | Properties | List of all members
Deltares.Geotechnics.Forms.CPTControl Class Reference

Earthquake Dialog. More...

Inheritance diagram for Deltares.Geotechnics.Forms.CPTControl:

Public Member Functions

CPTControl ()
Constructor. More...

Protected Member Functions

override void Dispose (bool disposing)
Clean up any resources being used. More...

Properties

object | SelectedObject [get, set]
bool | IsVisible [get]

Detailed Description

Earthquake Dialog.

Constructor & Destructor Documentation

Deltares.Geotechnics.Forms.CPTControl.CPTControl ( )

Constructor.

References Deltares.Standard.Forms.DExpress.BindSupport.Bind(), Deltares.Standard.Forms.DExpress.BindSupport.BindTextAndValue(), Deltares.Standard.Forms.DExpress.BindSupport.BindTextValueAndUnit(), and Deltares.Standard.Forms.DExpress.LocalizationSupport.RegisterAndTranslate().

Member Function Documentation

override void Deltares.Geotechnics.Forms.CPTControl.Dispose ( bool disposing )
protected

Clean up any resources being used.

Parameters
disposing true if managed resources should be disposed; otherwise, false.
Generated on Tue Dec 15 2015 18:14:02 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • CPTControl
Deltares.Geotechnics.Forms.CPTControl Member List

This is the complete list of members for Deltares.Geotechnics.Forms.CPTControl, including all inherited members.

CPTControl() | Deltares.Geotechnics.Forms.CPTControl |
Dispose(bool disposing) | Deltares.Geotechnics.Forms.CPTControl | protected
IsVisible (defined in Deltares.Geotechnics.Forms.CPTControl) | Deltares.Geotechnics.Forms.CPTControl |
SelectedObject (defined in Deltares.Geotechnics.Forms.CPTControl) | Deltares.Geotechnics.Forms.CPTControl |
Generated on Tue Dec 15 2015 18:14:02 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.Forms.CPTLookupControl Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • CPTLookupControl
Protected Member Functions | Properties | List of all members
Deltares.Geotechnics.Forms.CPTLookupControl Class Reference
Inheritance diagram for Deltares.Geotechnics.Forms.CPTLookupControl:

Protected Member Functions

override void Dispose (bool disposing)
Clean up any resources being used. More...

Properties

object | SelectedObject [get, set]
bool | IsVisible [get]

Member Function Documentation

override void Deltares.Geotechnics.Forms.CPTLookupControl.Dispose ( bool disposing )
protected

Clean up any resources being used.

Parameters
disposing true if managed resources should be disposed; otherwise, false.
Generated on Tue Dec 15 2015 18:14:02 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • CPTLookupControl
Deltares.Geotechnics.Forms.CPTLookupControl Member List

This is the complete list of members for Deltares.Geotechnics.Forms.CPTLookupControl, including all inherited members.

CPTLookupControl() (defined in Deltares.Geotechnics.Forms.CPTLookupControl) | Deltares.Geotechnics.Forms.CPTLookupControl |
Dispose(bool disposing) | Deltares.Geotechnics.Forms.CPTLookupControl | protected
IsVisible (defined in Deltares.Geotechnics.Forms.CPTLookupControl) | Deltares.Geotechnics.Forms.CPTLookupControl |
SelectedObject (defined in Deltares.Geotechnics.Forms.CPTLookupControl) | Deltares.Geotechnics.Forms.CPTLookupControl |
Generated on Tue Dec 15 2015 18:14:02 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.Forms.DegreeOfConsolidationDialog Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • DegreeOfConsolidationDialog
Public Member Functions | Protected Member Functions | Properties | List of all members
Deltares.Geotechnics.Forms.DegreeOfConsolidationDialog Class Reference
Inheritance diagram for Deltares.Geotechnics.Forms.DegreeOfConsolidationDialog:

Public Member Functions

void | RegisterUIComponent (IReloadManager aReloadManager)
void | Reload ()
void | UpdateData (params object[] models)

Protected Member Functions

override void Dispose (bool disposing)
Clean up any resources being used. More...

Properties

PanelControl DegreeofConsolidationPanelControl [get]

Member Function Documentation

override void Deltares.Geotechnics.Forms.DegreeOfConsolidationDialog.Dispose ( bool disposing )
protected

Clean up any resources being used.

Parameters
disposing true if managed resources should be disposed; otherwise, false.
Generated on Tue Dec 15 2015 18:14:02 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • DegreeOfConsolidationDialog
Deltares.Geotechnics.Forms.DegreeOfConsolidationDialog Member List

This is the complete list of members for Deltares.Geotechnics.Forms.DegreeOfConsolidationDialog, including all inherited members.

DegreeOfConsolidationDialog() (defined in Deltares.Geotechnics.Forms.DegreeOfConsolidationDialog) | Deltares.Geotechnics.Forms.DegreeOfConsolidationDialog |
DegreeofConsolidationPanelControl (defined in Deltares.Geotechnics.Forms.DegreeOfConsolidationDialog) | Deltares.Geotechnics.Forms.DegreeOfConsolidationDialog |
Dispose(bool disposing) | Deltares.Geotechnics.Forms.DegreeOfConsolidationDialog | protected
RegisterUIComponent(IReloadManager aReloadManager) (defined in Deltares.Geotechnics.Forms.DegreeOfConsolidationDialog) | Deltares.Geotechnics.Forms.DegreeOfConsolidationDialog |
Reload() (defined in Deltares.Geotechnics.Forms.DegreeOfConsolidationDialog) | Deltares.Geotechnics.Forms.DegreeOfConsolidationDialog |
UpdateData(params object[] models) (defined in Deltares.Geotechnics.Forms.DegreeOfConsolidationDialog) | Deltares.Geotechnics.Forms.DegreeOfConsolidationDialog |
Generated on Tue Dec 15 2015 18:14:02 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.Forms.DegreeOfConsolidationMatrixControl Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • DegreeOfConsolidationMatrixControl
Public Member Functions | Protected Member Functions | List of all members
Deltares.Geotechnics.Forms.DegreeOfConsolidationMatrixControl Class Reference
Inheritance diagram for Deltares.Geotechnics.Forms.DegreeOfConsolidationMatrixControl:

Public Member Functions

DegreeOfConsolidationMatrixControl ()
void SetDataSource (DegreeofConsolidationMatrix degreeOfConsolidationMatrix, bool visibleUseUnderOverPressureCheckEdit, int propertyIndex)

Protected Member Functions

override void Dispose (bool disposing)
Clean up any resources being used. More...

Constructor & Destructor Documentation

Deltares.Geotechnics.Forms.DegreeOfConsolidationMatrixControl.DegreeOfConsolidationMatrixControl ( )

Parameters
a()
aUndoRedoManager
aLocalizationHelper

Member Function Documentation

override void Deltares.Geotechnics.Forms.DegreeOfConsolidationMatrixControl.Dispose ( bool disposing )
protected

Clean up any resources being used.

Parameters
disposing true if managed resources should be disposed; otherwise, false.
Generated on Tue Dec 15 2015 18:14:02 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • DegreeOfConsolidationMatrixControl
Deltares.Geotechnics.Forms.DegreeOfConsolidationMatrixControl Member List

This is the complete list of members for Deltares.Geotechnics.Forms.DegreeOfConsolidationMatrixControl, including all inherited members.

DegreeOfConsolidationMatrixControl() | Deltares.Geotechnics.Forms.DegreeOfConsolidationMatrixControl |
Dispose(bool disposing) | Deltares.Geotechnics.Forms.DegreeOfConsolidationMatrixControl | protected
SetDataSource(DegreeofConsolidationMatrix degreeOfConsolidationMatrix, bool visibleUseUnderOverPressureCheckEdit, int propertyIndex) (defined in Deltares.Geotechnics.Forms.DegreeOfConsolidationMatrixControl) | Deltares.Geotechnics.Forms.DegreeOfConsolidationMatrixControl |
Generated on Tue Dec 15 2015 18:14:02 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.Forms.DesignPointControl Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • DesignPointControl
Public Member Functions | Protected Member Functions | Properties | List of all members
Deltares.Geotechnics.Forms.DesignPointControl Class Reference

Earthquake Dialog. More...

Inheritance diagram for Deltares.Geotechnics.Forms.DesignPointControl:

Public Member Functions

DesignPointControl ()
Constructor. More...

Protected Member Functions

override void Dispose (bool disposing)
Clean up any resources being used. More...

Properties

object | SelectedObject [get, set]
bool | IsVisible [get]

Detailed Description

Earthquake Dialog.

Constructor & Destructor Documentation

Deltares.Geotechnics.Forms.DesignPointControl.DesignPointControl ( )

Constructor.

References Deltares.Standard.Forms.DExpress.BindSupport.Bind(), Deltares.Standard.Forms.DExpress.BindSupport.BindTextValueAndUnit(), and Deltares.Standard.Forms.DExpress.LocalizationSupport.RegisterAndTranslate().

Member Function Documentation

override void Deltares.Geotechnics.Forms.DesignPointControl.Dispose ( bool disposing )
protected

Clean up any resources being used.

Parameters
disposing true if managed resources should be disposed; otherwise, false.
Generated on Tue Dec 15 2015 18:14:03 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • DesignPointControl
Deltares.Geotechnics.Forms.DesignPointControl Member List

This is the complete list of members for Deltares.Geotechnics.Forms.DesignPointControl, including all inherited members.

DesignPointControl() | Deltares.Geotechnics.Forms.DesignPointControl |
Dispose(bool disposing) | Deltares.Geotechnics.Forms.DesignPointControl | protected
IsVisible (defined in Deltares.Geotechnics.Forms.DesignPointControl) | Deltares.Geotechnics.Forms.DesignPointControl |
SelectedObject (defined in Deltares.Geotechnics.Forms.DesignPointControl) | Deltares.Geotechnics.Forms.DesignPointControl |
Generated on Tue Dec 15 2015 18:14:03 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.Forms.DikeLineControl Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • DikeLineControl
Public Member Functions | Protected Member Functions | Properties | List of all members
Deltares.Geotechnics.Forms.DikeLineControl Class Reference

Earthquake Dialog. More...

Inheritance diagram for Deltares.Geotechnics.Forms.DikeLineControl:

Public Member Functions

DikeLineControl ()
Constructor. More...

Protected Member Functions

override void Dispose (bool disposing)
Clean up any resources being used. More...

Properties

object | SelectedObject [get, set]
bool | IsVisible [get]

Detailed Description

Earthquake Dialog.

Constructor & Destructor Documentation

Deltares.Geotechnics.Forms.DikeLineControl.DikeLineControl ( )

Constructor.

References Deltares.Standard.Forms.DExpress.BindSupport.Bind(), Deltares.Standard.Forms.DExpress.BindSupport.BindTextAndValue(), Deltares.Standard.Forms.DExpress.BindSupport.BindTextValueAndUnit(), and Deltares.Standard.Forms.DExpress.LocalizationSupport.RegisterAndTranslate().

Member Function Documentation

override void Deltares.Geotechnics.Forms.DikeLineControl.Dispose ( bool disposing )
protected

Clean up any resources being used.

Parameters
disposing true if managed resources should be disposed; otherwise, false.
Generated on Tue Dec 15 2015 18:14:03 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • DikeLineControl
Deltares.Geotechnics.Forms.DikeLineControl Member List

This is the complete list of members for Deltares.Geotechnics.Forms.DikeLineControl, including all inherited members.

DikeLineControl() | Deltares.Geotechnics.Forms.DikeLineControl |
Dispose(bool disposing) | Deltares.Geotechnics.Forms.DikeLineControl | protected
IsVisible (defined in Deltares.Geotechnics.Forms.DikeLineControl) | Deltares.Geotechnics.Forms.DikeLineControl |
SelectedObject (defined in Deltares.Geotechnics.Forms.DikeLineControl) | Deltares.Geotechnics.Forms.DikeLineControl |
Generated on Tue Dec 15 2015 18:14:03 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.Forms.DrawingAnchorAttachment Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • DrawingAnchorAttachment
Public Member Functions | Public Attributes | Static Protected Attributes | List of all members
Deltares.Geotechnics.Forms.DrawingAnchorAttachment Class Reference
Inheritance diagram for Deltares.Geotechnics.Forms.DrawingAnchorAttachment:
Deltares.Geometry.Forms.ColoredDrawingObject Deltares.Geometry.Forms.DrawingObject Deltares.Geometry.Forms.IDrawingObject Deltares.Standard.Forms.IShape

Public Member Functions

override void | SetDataObject (object dataObject)
Sets the geotechnics entity that this drawing object represents More...
override object | GetDataObject ()
Gets the geotechnics entity that this drawing object represents More...
override void | OnBeginDrag (IProjection projection, Point3D aBeginDragDropPoint, bool isIndividualDrag)
Method which is called when the user initiates a drag-drop operation More...
override void | OnEndDrag (IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D)
Method which is called when the user ends a drag-drop operation. More...
override void | UpdateDataDragDrop (Point3D beginDragPoint, Vector3D vector)
Update the position and or orientation of a drawing object as the user is dragging it. More...
override void | Draw3D (GraphicsInfo info)
Render this drawing object in 3D space. More...
- Public Member Functions inherited from Deltares.Geometry.Forms.ColoredDrawingObject
ColoredDrawingObject (Color fillColor, Color strokeColor)
- Public Member Functions inherited from Deltares.Geometry.Forms.DrawingObject
Point3D | GetScaled3DPoint (IProjection projection, Point3D aOrginalPoint)
Converts the 3DPoint to screen coordinates More...
Point3D | GetScreenPoint (IProjection projection, Point2D orginalPoint)
Converts Point from 3D space to screen coordinates, assuming Y = 0 More...
Point3D | GetScreenPoint (IProjection projection, Point3D orginalPoint)
Converts Point from 3D space to screen coordinates More...
Point3D | GetScreenPoint (IProjection projection, double x, double z)
Converts 3D x, y coordinates to screen coordinates, assuming Y = 0 More...
override string | ToString ()
virtual void | UpdateDataDragDrop (Vector3D aVect3D, List< IDrawingObject > aDraggedObjects)
Update the position and or orientation of a drawing object as the user is dragging it. More...
virtual CardinalDirection | GetCardinalDirectionOnEdgeContainingPoint (Point point)
virtual void | OnDragging (IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D)
Method which is called during drag-drop operations More...
virtual bool | CheckHitForSelection (IProjection projection, Point3D point, double tolerance)
Check if given point coordinates intersect the rendered drawing object. More...
virtual double | GetStandardSize (object aDraw3DInterface, Point3D aPoint3D)
void | GetScaled3DPoint (IProjection projection, Point3D aOrginalPoint, ref Point3D aPointTobeScaled)
Converts the 3DPoint to screen coordinates More...
double | GetScaledXPoint (IProjection projection, double aOrginalCordinate)
Converts X Coordinate in 3D space to a screen X Coordinate More...
virtual bool | ContainsPoint (IProjection projection, Point point)
Determines if a given point screen coordinate is within the drawing object. More...
virtual Rectangle | GetExtents (IProjection projection)
Returns the bounding box of the shape. More...
virtual void | Draw (GraphicsInfo info)
Render this object in 3D space. More...
virtual void | DrawLabel (GraphicsInfo info)
Renders a label or tooltip to provide some information in text for this object. More...
virtual void | Move (IProjection projection, Point2D startPosition, SizeF worldSize)
virtual void | BeginMove (IProjection projection, Point2D startPosition)
virtual void | EndMove (IProjection projection, Point2D startPosition, SizeF worldSize)
virtual bool | AllowDrop (object data)
Boolean which indicates if other drawing objects can be dropped on given drawing objects More...
virtual void | Drop (object data)
Ends a drag-drop operation More...
virtual IEnumerable< object > | DataItemAt (Point point, Projection projection)

Public Attributes

const double PointSizeRadius = 5d

Static Protected Attributes

static readonly Color | FillColor = Color.DarkGray
static readonly Color | StrokeColor = Color.Black

Additional Inherited Members

- Protected Member Functions inherited from Deltares.Geometry.Forms.ColoredDrawingObject
Color | UpdateCurrentColor (GraphicsInfo info, bool draggingElement)
Color | UpdateCurrentColor (GraphicsInfo info, bool draggingElement, bool draggingAnything)
Color | UpdateCurrentColor (GraphicsInfo info, bool draggingElement, bool draggingAnything, Color normalFillColor, Color normalStrokeColor)
void | setCurrentColor (GraphicsInfo info, Color fillColor, Color strokeColor)
- Protected Member Functions inherited from Deltares.Geometry.Forms.DrawingObject
virtual int | GetThickness (GraphicsInfo info)
Gets the thickness in screen pixels of a drawing object. More...
- Properties inherited from Deltares.Geometry.Forms.ColoredDrawingObject
Color | NormalFillColor [get]
Color | NormalStrokeColor [get]
- Properties inherited from Deltares.Geometry.Forms.DrawingObject
virtual bool | CanResize [get]
Boolean which indicates if a drawing object can be resized. More...
virtual bool | Selected [get, set]
Boolean which indicates if a drawing object is currently selected. More...
string | ToolTip [get]
Description which is shown as a tooltip when the mouse hovers over drawing object. More...
string | Name [get, set]
Gets or sets the name of a drawing object. More...
bool | IsVisible [get, set]
bool | HasBeenUpdated [get, set]
virtual bool | IsDragableOnReslultMode [get]
virtual int | Layer [get, set]
object | DataObject [get, set]
- Properties inherited from Deltares.Geometry.Forms.IDrawingObject
string | Name [get, set]
bool | IsVisible [get, set]
bool | HasBeenUpdated [get, set]
Gets or sets the update status of a drawing object. More...
bool | IsDragableOnReslultMode [get]
- Properties inherited from Deltares.Standard.Forms.IShape
object | DataObject [get, set]
int | Layer [get]

Member Function Documentation

override void Deltares.Geotechnics.Forms.DrawingAnchorAttachment.Draw3D ( GraphicsInfo info )
virtual

Render this drawing object in 3D space.

Parameters
info Rendering target information.

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

References Deltares.Standard.Forms.DrawingSupport.SetIEPDraw3D().

override object Deltares.Geotechnics.Forms.DrawingAnchorAttachment.GetDataObject ( )
virtual

Gets the geotechnics entity that this drawing object represents

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

override void Deltares.Geotechnics.Forms.DrawingAnchorAttachment.OnBeginDrag | ( | IProjection | projection,
 |  | Point3D | aBeginDragDropPoint,
 |  | bool | isIndividualDrag
 | ) |  |
virtual

Method which is called when the user initiates a drag-drop operation

Parameters
projection | Current projection of 3D to screen coordinates.
aBeginDragDropPoint | Initial position of the mouse pointer.
isIndividualDrag

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

override void Deltares.Geotechnics.Forms.DrawingAnchorAttachment.OnEndDrag | ( | IProjection | projection,
 |  | Point3D | aCurrentDragPoint,
 |  | Vector3D | aVect3D
 | ) |  |
virtual

Method which is called when the user ends a drag-drop operation.

Parameters
projection | Current projection
aCurrentDragPoint | Point in 3D space where the darg operation ends
aVect3D | Vector in 3D space which represents the displacement within the drag-drop operation

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

override void Deltares.Geotechnics.Forms.DrawingAnchorAttachment.SetDataObject ( object aDataObject )
virtual

Sets the geotechnics entity that this drawing object represents

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

override void Deltares.Geotechnics.Forms.DrawingAnchorAttachment.UpdateDataDragDrop | ( | Point3D | aBeginDragPoint,
 |  | Vector3D | vector
 | ) |  |
virtual

Update the position and or orientation of a drawing object as the user is dragging it.

Parameters
aBeginDragPoint | Initial position of the Drawing object
vector | Vector representing the displacement of an object during a drag-drop operation.

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

Generated on Tue Dec 15 2015 18:14:03 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • DrawingAnchorAttachment
Deltares.Geotechnics.Forms.DrawingAnchorAttachment Member List

This is the complete list of members for Deltares.Geotechnics.Forms.DrawingAnchorAttachment, including all inherited members.

AllowDrop(object data) | Deltares.Geometry.Forms.DrawingObject | virtual
BeginMove(IProjection projection, Point2D startPosition) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
CanResize | Deltares.Geometry.Forms.DrawingObject |
CheckHitForSelection(IProjection projection, Point3D point, double tolerance) | Deltares.Geometry.Forms.DrawingObject | virtual
ColoredDrawingObject(Color fillColor, Color strokeColor) (defined in Deltares.Geometry.Forms.ColoredDrawingObject) | Deltares.Geometry.Forms.ColoredDrawingObject |
ContainsPoint(IProjection projection, Point point) | Deltares.Geometry.Forms.DrawingObject | virtual
DataItemAt(Point point, Projection projection) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
DataObject (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
Draw(GraphicsInfo info) | Deltares.Geometry.Forms.DrawingObject | virtual
Draw3D(GraphicsInfo info) | Deltares.Geotechnics.Forms.DrawingAnchorAttachment | virtual
DrawingAnchorAttachment() (defined in Deltares.Geotechnics.Forms.DrawingAnchorAttachment) | Deltares.Geotechnics.Forms.DrawingAnchorAttachment |
DrawingObject() (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
DrawLabel(GraphicsInfo info) | Deltares.Geometry.Forms.DrawingObject | virtual
Drop(object data) | Deltares.Geometry.Forms.DrawingObject | virtual
EndMove(IProjection projection, Point2D startPosition, SizeF worldSize) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
FillColor (defined in Deltares.Geotechnics.Forms.DrawingAnchorAttachment) | Deltares.Geotechnics.Forms.DrawingAnchorAttachment | protectedstatic
GetCardinalDirectionOnEdgeContainingPoint(Point point) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetDataObject() | Deltares.Geotechnics.Forms.DrawingAnchorAttachment | virtual
GetExtents(IProjection projection) | Deltares.Geometry.Forms.DrawingObject | virtual
GetScaled3DPoint(IProjection projection, Point3D aOrginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScaled3DPoint(IProjection projection, Point3D aOrginalPoint, ref Point3D aPointTobeScaled) | Deltares.Geometry.Forms.DrawingObject |
GetScaledXPoint(IProjection projection, double aOrginalCordinate) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, Point2D orginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, Point3D orginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, double x, double z) | Deltares.Geometry.Forms.DrawingObject |
GetStandardSize(object aDraw3DInterface, Point3D aPoint3D) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetThickness(GraphicsInfo info) | Deltares.Geometry.Forms.DrawingObject | protectedvirtual
HasBeenUpdated (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
IsDragableOnReslultMode (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
IsVisible (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
Layer (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
Move(IProjection projection, Point2D startPosition, SizeF worldSize) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
Name | Deltares.Geometry.Forms.DrawingObject |
NormalFillColor (defined in Deltares.Geometry.Forms.ColoredDrawingObject) | Deltares.Geometry.Forms.ColoredDrawingObject | protected
NormalStrokeColor (defined in Deltares.Geometry.Forms.ColoredDrawingObject) | Deltares.Geometry.Forms.ColoredDrawingObject | protected
OnBeginDrag(IProjection projection, Point3D aBeginDragDropPoint, bool isIndividualDrag) | Deltares.Geotechnics.Forms.DrawingAnchorAttachment | virtual
OnDragging(IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D) | Deltares.Geometry.Forms.DrawingObject | virtual
OnEndDrag(IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D) | Deltares.Geotechnics.Forms.DrawingAnchorAttachment | virtual
PointSizeRadius (defined in Deltares.Geotechnics.Forms.DrawingAnchorAttachment) | Deltares.Geotechnics.Forms.DrawingAnchorAttachment |
Selected | Deltares.Geometry.Forms.DrawingObject |
setCurrentColor(GraphicsInfo info, Color fillColor, Color strokeColor) (defined in Deltares.Geometry.Forms.ColoredDrawingObject) | Deltares.Geometry.Forms.ColoredDrawingObject | protected
SetDataObject(object dataObject) | Deltares.Geotechnics.Forms.DrawingAnchorAttachment | virtual
StrokeColor (defined in Deltares.Geotechnics.Forms.DrawingAnchorAttachment) | Deltares.Geotechnics.Forms.DrawingAnchorAttachment | protectedstatic
ToolTip | Deltares.Geometry.Forms.DrawingObject |
ToString() (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
UpdateCurrentColor(GraphicsInfo info, bool draggingElement) (defined in Deltares.Geometry.Forms.ColoredDrawingObject) | Deltares.Geometry.Forms.ColoredDrawingObject | protected
UpdateCurrentColor(GraphicsInfo info, bool draggingElement, bool draggingAnything) (defined in Deltares.Geometry.Forms.ColoredDrawingObject) | Deltares.Geometry.Forms.ColoredDrawingObject | protected
UpdateCurrentColor(GraphicsInfo info, bool draggingElement, bool draggingAnything, Color normalFillColor, Color normalStrokeColor) (defined in Deltares.Geometry.Forms.ColoredDrawingObject) | Deltares.Geometry.Forms.ColoredDrawingObject | protected
UpdateDataDragDrop(Point3D beginDragPoint, Vector3D vector) | Deltares.Geotechnics.Forms.DrawingAnchorAttachment | virtual
Deltares::Geometry::Forms::ColoredDrawingObject.UpdateDataDragDrop(Vector3D aVect3D, List< IDrawingObject > aDraggedObjects) | Deltares.Geometry.Forms.DrawingObject | virtual
Generated on Tue Dec 15 2015 18:14:03 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.Forms.DrawingAsphaltRevetment Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • DrawingAsphaltRevetment
Protected Member Functions | List of all members
Deltares.Geotechnics.Forms.DrawingAsphaltRevetment Class Reference

Draws the asphalt segment More...

Inheritance diagram for Deltares.Geotechnics.Forms.DrawingAsphaltRevetment:
Deltares.Geotechnics.Forms.DrawingRevetment Deltares.Geometry.Forms.DrawingObject Deltares.Geometry.Forms.IDrawingObject Deltares.Standard.Forms.IShape

Protected Member Functions

override Color | GetRevetmentColor ()
- Protected Member Functions inherited from Deltares.Geometry.Forms.DrawingObject
virtual int | GetThickness (GraphicsInfo info)
Gets the thickness in screen pixels of a drawing object. More...

Additional Inherited Members

- Public Member Functions inherited from Deltares.Geotechnics.Forms.DrawingRevetment
override object | GetDataObject ()
Gets the geotechnics entity that this drawing object represents More...
override void | SetDataObject (object dataObject)
Sets the geotechnics entity that this drawing object represents More...
override void | Draw3D (GraphicsInfo info)
override The Draw3D() Method More...
override void | DrawLabel (GraphicsInfo info)
Draws the label. More...
override bool | ContainsPoint (IProjection projection, Point point)
Determines whether the specified projection contains point. More...
override void | OnBeginDrag (IProjection projection, Point3D beginDragDropPoint, bool isIndividualDrag)
Method which is called when the user initiates a drag-drop operation More...
override void | OnDragging (IProjection projection, Point3D currentDragPoint, Vector3D vector)
Method which is called during drag-drop operations More...
- Public Member Functions inherited from Deltares.Geometry.Forms.DrawingObject
Point3D | GetScaled3DPoint (IProjection projection, Point3D aOrginalPoint)
Converts the 3DPoint to screen coordinates More...
Point3D | GetScreenPoint (IProjection projection, Point2D orginalPoint)
Converts Point from 3D space to screen coordinates, assuming Y = 0 More...
Point3D | GetScreenPoint (IProjection projection, Point3D orginalPoint)
Converts Point from 3D space to screen coordinates More...
Point3D | GetScreenPoint (IProjection projection, double x, double z)
Converts 3D x, y coordinates to screen coordinates, assuming Y = 0 More...
override string | ToString ()
virtual void | UpdateDataDragDrop (Vector3D aVect3D, List< IDrawingObject > aDraggedObjects)
Update the position and or orientation of a drawing object as the user is dragging it. More...
virtual void | UpdateDataDragDrop (Point3D aBeginDragPoint, Vector3D vector)
Update the position and or orientation of a drawing object as the user is dragging it. More...
virtual CardinalDirection | GetCardinalDirectionOnEdgeContainingPoint (Point point)
virtual void | OnEndDrag (IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D)
Method which is called when the user ends a drag-drop operation. More...
virtual bool | CheckHitForSelection (IProjection projection, Point3D point, double tolerance)
Check if given point coordinates intersect the rendered drawing object. More...
virtual double | GetStandardSize (object aDraw3DInterface, Point3D aPoint3D)
void | GetScaled3DPoint (IProjection projection, Point3D aOrginalPoint, ref Point3D aPointTobeScaled)
Converts the 3DPoint to screen coordinates More...
double | GetScaledXPoint (IProjection projection, double aOrginalCordinate)
Converts X Coordinate in 3D space to a screen X Coordinate More...
virtual Rectangle | GetExtents (IProjection projection)
Returns the bounding box of the shape. More...
virtual void | Draw (GraphicsInfo info)
Render this object in 3D space. More...
virtual void | Move (IProjection projection, Point2D startPosition, SizeF worldSize)
virtual void | BeginMove (IProjection projection, Point2D startPosition)
virtual void | EndMove (IProjection projection, Point2D startPosition, SizeF worldSize)
virtual bool | AllowDrop (object data)
Boolean which indicates if other drawing objects can be dropped on given drawing objects More...
virtual void | Drop (object data)
Ends a drag-drop operation More...
virtual IEnumerable< object > | DataItemAt (Point point, Projection projection)
- Properties inherited from Deltares.Geotechnics.Forms.DrawingRevetment
int | LineHeight [get, set]
- Properties inherited from Deltares.Geometry.Forms.DrawingObject
virtual bool | CanResize [get]
Boolean which indicates if a drawing object can be resized. More...
virtual bool | Selected [get, set]
Boolean which indicates if a drawing object is currently selected. More...
string | ToolTip [get]
Description which is shown as a tooltip when the mouse hovers over drawing object. More...
string | Name [get, set]
Gets or sets the name of a drawing object. More...
bool | IsVisible [get, set]
bool | HasBeenUpdated [get, set]
virtual bool | IsDragableOnReslultMode [get]
virtual int | Layer [get, set]
object | DataObject [get, set]
- Properties inherited from Deltares.Geometry.Forms.IDrawingObject
string | Name [get, set]
bool | IsVisible [get, set]
bool | HasBeenUpdated [get, set]
Gets or sets the update status of a drawing object. More...
bool | IsDragableOnReslultMode [get]
- Properties inherited from Deltares.Standard.Forms.IShape
object | DataObject [get, set]
int | Layer [get]

Detailed Description

Draws the asphalt segment

Generated on Tue Dec 15 2015 18:14:04 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • DrawingAsphaltRevetment
Deltares.Geotechnics.Forms.DrawingAsphaltRevetment Member List

This is the complete list of members for Deltares.Geotechnics.Forms.DrawingAsphaltRevetment, including all inherited members.

AllowDrop(object data) | Deltares.Geometry.Forms.DrawingObject | virtual
BeginMove(IProjection projection, Point2D startPosition) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
CanResize | Deltares.Geometry.Forms.DrawingObject |
CheckHitForSelection(IProjection projection, Point3D point, double tolerance) | Deltares.Geometry.Forms.DrawingObject | virtual
ContainsPoint(IProjection projection, Point point) | Deltares.Geotechnics.Forms.DrawingRevetment | virtual
DataItemAt(Point point, Projection projection) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
DataObject (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
Draw(GraphicsInfo info) | Deltares.Geometry.Forms.DrawingObject | virtual
Draw3D(GraphicsInfo info) | Deltares.Geotechnics.Forms.DrawingRevetment | virtual
DrawingAsphaltRevetment() (defined in Deltares.Geotechnics.Forms.DrawingAsphaltRevetment) | Deltares.Geotechnics.Forms.DrawingAsphaltRevetment |
DrawingObject() (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
DrawingRevetment() (defined in Deltares.Geotechnics.Forms.DrawingRevetment) | Deltares.Geotechnics.Forms.DrawingRevetment |
DrawLabel(GraphicsInfo info) | Deltares.Geotechnics.Forms.DrawingRevetment | virtual
Drop(object data) | Deltares.Geometry.Forms.DrawingObject | virtual
EndMove(IProjection projection, Point2D startPosition, SizeF worldSize) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetCardinalDirectionOnEdgeContainingPoint(Point point) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetDataObject() | Deltares.Geotechnics.Forms.DrawingRevetment | virtual
GetExtents(IProjection projection) | Deltares.Geometry.Forms.DrawingObject | virtual
GetRevetmentColor() (defined in Deltares.Geotechnics.Forms.DrawingAsphaltRevetment) | Deltares.Geotechnics.Forms.DrawingAsphaltRevetment | protectedvirtual
GetScaled3DPoint(IProjection projection, Point3D aOrginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScaled3DPoint(IProjection projection, Point3D aOrginalPoint, ref Point3D aPointTobeScaled) | Deltares.Geometry.Forms.DrawingObject |
GetScaledXPoint(IProjection projection, double aOrginalCordinate) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, Point2D orginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, Point3D orginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, double x, double z) | Deltares.Geometry.Forms.DrawingObject |
GetStandardSize(object aDraw3DInterface, Point3D aPoint3D) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetThickness(GraphicsInfo info) | Deltares.Geometry.Forms.DrawingObject | protectedvirtual
HasBeenUpdated (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
IsDragableOnReslultMode (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
IsVisible (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
Layer (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
LineHeight (defined in Deltares.Geotechnics.Forms.DrawingRevetment) | Deltares.Geotechnics.Forms.DrawingRevetment | protected
Move(IProjection projection, Point2D startPosition, SizeF worldSize) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
Name | Deltares.Geometry.Forms.DrawingObject |
OnBeginDrag(IProjection projection, Point3D beginDragDropPoint, bool isIndividualDrag) | Deltares.Geotechnics.Forms.DrawingRevetment | virtual
OnDragging(IProjection projection, Point3D currentDragPoint, Vector3D vector) | Deltares.Geotechnics.Forms.DrawingRevetment | virtual
OnEndDrag(IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D) | Deltares.Geometry.Forms.DrawingObject | virtual
Selected | Deltares.Geometry.Forms.DrawingObject |
SetDataObject(object dataObject) | Deltares.Geotechnics.Forms.DrawingRevetment | virtual
ToolTip | Deltares.Geometry.Forms.DrawingObject |
ToString() (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
UpdateDataDragDrop(Vector3D aVect3D, List< IDrawingObject > aDraggedObjects) | Deltares.Geometry.Forms.DrawingObject | virtual
UpdateDataDragDrop(Point3D aBeginDragPoint, Vector3D vector) | Deltares.Geometry.Forms.DrawingObject | virtual
Generated on Tue Dec 15 2015 18:14:04 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.Forms.DrawingBlockRevetmentSegment Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • DrawingBlockRevetmentSegment
Public Member Functions | Properties | List of all members
Deltares.Geotechnics.Forms.DrawingBlockRevetmentSegment Class Reference

drawing revetment segment More...

Inheritance diagram for Deltares.Geotechnics.Forms.DrawingBlockRevetmentSegment:
Deltares.Geometry.Forms.DrawingObject Deltares.Geometry.Forms.IDrawingObject Deltares.Standard.Forms.IShape

Public Member Functions

override void | SetDataObject (object dataObject)
Sets the geotechnics entity that this drawing object represents More...
override object | GetDataObject ()
Gets the geotechnics entity that this drawing object represents More...
override void | Draw3D (GraphicsInfo info)
override The Draw3D() Method More...
override void | DrawLabel (GraphicsInfo info)
Draws the label. More...
override bool | ContainsPoint (IProjection projection, Point point)
Determines if a given point screen coordinate is within the drawing object. More...
- Public Member Functions inherited from Deltares.Geometry.Forms.DrawingObject
Point3D | GetScaled3DPoint (IProjection projection, Point3D aOrginalPoint)
Converts the 3DPoint to screen coordinates More...
Point3D | GetScreenPoint (IProjection projection, Point2D orginalPoint)
Converts Point from 3D space to screen coordinates, assuming Y = 0 More...
Point3D | GetScreenPoint (IProjection projection, Point3D orginalPoint)
Converts Point from 3D space to screen coordinates More...
Point3D | GetScreenPoint (IProjection projection, double x, double z)
Converts 3D x, y coordinates to screen coordinates, assuming Y = 0 More...
override string | ToString ()
virtual void | UpdateDataDragDrop (Vector3D aVect3D, List< IDrawingObject > aDraggedObjects)
Update the position and or orientation of a drawing object as the user is dragging it. More...
virtual void | UpdateDataDragDrop (Point3D aBeginDragPoint, Vector3D vector)
Update the position and or orientation of a drawing object as the user is dragging it. More...
virtual void | OnBeginDrag (IProjection projection, Point3D aBeginDragDropPoint, bool isIndividualDrag)
Method which is called when the user initiates a drag-drop operation More...
virtual CardinalDirection | GetCardinalDirectionOnEdgeContainingPoint (Point point)
virtual void | OnDragging (IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D)
Method which is called during drag-drop operations More...
virtual void | OnEndDrag (IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D)
Method which is called when the user ends a drag-drop operation. More...
virtual bool | CheckHitForSelection (IProjection projection, Point3D point, double tolerance)
Check if given point coordinates intersect the rendered drawing object. More...
virtual double | GetStandardSize (object aDraw3DInterface, Point3D aPoint3D)
void | GetScaled3DPoint (IProjection projection, Point3D aOrginalPoint, ref Point3D aPointTobeScaled)
Converts the 3DPoint to screen coordinates More...
double | GetScaledXPoint (IProjection projection, double aOrginalCordinate)
Converts X Coordinate in 3D space to a screen X Coordinate More...
virtual Rectangle | GetExtents (IProjection projection)
Returns the bounding box of the shape. More...
virtual void | Draw (GraphicsInfo info)
Render this object in 3D space. More...
virtual void | Move (IProjection projection, Point2D startPosition, SizeF worldSize)
virtual void | BeginMove (IProjection projection, Point2D startPosition)
virtual void | EndMove (IProjection projection, Point2D startPosition, SizeF worldSize)
virtual bool | AllowDrop (object data)
Boolean which indicates if other drawing objects can be dropped on given drawing objects More...
virtual void | Drop (object data)
Ends a drag-drop operation More...
virtual IEnumerable< object > | DataItemAt (Point point, Projection projection)

Properties

int | LineHeight [get, set]
- Properties inherited from Deltares.Geometry.Forms.DrawingObject
virtual bool | CanResize [get]
Boolean which indicates if a drawing object can be resized. More...
virtual bool | Selected [get, set]
Boolean which indicates if a drawing object is currently selected. More...
string | ToolTip [get]
Description which is shown as a tooltip when the mouse hovers over drawing object. More...
string | Name [get, set]
Gets or sets the name of a drawing object. More...
bool | IsVisible [get, set]
bool | HasBeenUpdated [get, set]
virtual bool | IsDragableOnReslultMode [get]
virtual int | Layer [get, set]
object | DataObject [get, set]
- Properties inherited from Deltares.Geometry.Forms.IDrawingObject
string | Name [get, set]
bool | IsVisible [get, set]
bool | HasBeenUpdated [get, set]
Gets or sets the update status of a drawing object. More...
bool | IsDragableOnReslultMode [get]
- Properties inherited from Deltares.Standard.Forms.IShape
object | DataObject [get, set]
int | Layer [get]

Additional Inherited Members

- Protected Member Functions inherited from Deltares.Geometry.Forms.DrawingObject
virtual int GetThickness (GraphicsInfo info)
Gets the thickness in screen pixels of a drawing object. More...

Detailed Description

drawing revetment segment

Member Function Documentation

override bool Deltares.Geotechnics.Forms.DrawingBlockRevetmentSegment.ContainsPoint | ( | IProjection | projection,
 |  | Point | point
 | ) |  |
virtual

Determines if a given point screen coordinate is within the drawing object.

Parameters
projection | Projection used for drawing
point | Point in screen coordinates.
Returns
True if given point is within the rendered drawing object.

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

override void Deltares.Geotechnics.Forms.DrawingBlockRevetmentSegment.Draw3D ( GraphicsInfo info )
virtual

override The Draw3D() Method

Parameters
info The graphics info.

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

References Deltares.Standard.Forms.DrawingSupport.Brush3D(), Deltares.Standard.Forms.DrawingSupport.ColorMaterial3D(), Deltares.Standard.Forms.DrawingSupport.Line3D(), Deltares.Standard.Forms.DrawingSupport.Material3D(), Deltares.Standard.Forms.DrawingSupport.Pen3D(), and Deltares.Standard.Forms.DrawingSupport.SetIEPDraw3D().

override void Deltares.Geotechnics.Forms.DrawingBlockRevetmentSegment.DrawLabel ( GraphicsInfo info )
virtual

Draws the label.

Parameters
info The graphics info.

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

References Deltares.Standard.Forms.DrawingSupport.DrawLabelAtPoint().

override object Deltares.Geotechnics.Forms.DrawingBlockRevetmentSegment.GetDataObject ( )
virtual

Gets the geotechnics entity that this drawing object represents

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

override void Deltares.Geotechnics.Forms.DrawingBlockRevetmentSegment.SetDataObject ( object aDataObject )
virtual

Sets the geotechnics entity that this drawing object represents

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

Generated on Tue Dec 15 2015 18:14:04 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • DrawingBlockRevetmentSegment
Deltares.Geotechnics.Forms.DrawingBlockRevetmentSegment Member List

This is the complete list of members for Deltares.Geotechnics.Forms.DrawingBlockRevetmentSegment, including all inherited members.

AllowDrop(object data) | Deltares.Geometry.Forms.DrawingObject | virtual
BeginMove(IProjection projection, Point2D startPosition) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
CanResize | Deltares.Geometry.Forms.DrawingObject |
CheckHitForSelection(IProjection projection, Point3D point, double tolerance) | Deltares.Geometry.Forms.DrawingObject | virtual
ContainsPoint(IProjection projection, Point point) | Deltares.Geotechnics.Forms.DrawingBlockRevetmentSegment | virtual
DataItemAt(Point point, Projection projection) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
DataObject (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
Draw(GraphicsInfo info) | Deltares.Geometry.Forms.DrawingObject | virtual
Draw3D(GraphicsInfo info) | Deltares.Geotechnics.Forms.DrawingBlockRevetmentSegment | virtual
DrawingBlockRevetmentSegment() (defined in Deltares.Geotechnics.Forms.DrawingBlockRevetmentSegment) | Deltares.Geotechnics.Forms.DrawingBlockRevetmentSegment |
DrawingObject() (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
DrawLabel(GraphicsInfo info) | Deltares.Geotechnics.Forms.DrawingBlockRevetmentSegment | virtual
Drop(object data) | Deltares.Geometry.Forms.DrawingObject | virtual
EndMove(IProjection projection, Point2D startPosition, SizeF worldSize) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetCardinalDirectionOnEdgeContainingPoint(Point point) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetDataObject() | Deltares.Geotechnics.Forms.DrawingBlockRevetmentSegment | virtual
GetExtents(IProjection projection) | Deltares.Geometry.Forms.DrawingObject | virtual
GetScaled3DPoint(IProjection projection, Point3D aOrginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScaled3DPoint(IProjection projection, Point3D aOrginalPoint, ref Point3D aPointTobeScaled) | Deltares.Geometry.Forms.DrawingObject |
GetScaledXPoint(IProjection projection, double aOrginalCordinate) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, Point2D orginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, Point3D orginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, double x, double z) | Deltares.Geometry.Forms.DrawingObject |
GetStandardSize(object aDraw3DInterface, Point3D aPoint3D) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetThickness(GraphicsInfo info) | Deltares.Geometry.Forms.DrawingObject | protectedvirtual
HasBeenUpdated (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
IsDragableOnReslultMode (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
IsVisible (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
Layer (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
LineHeight (defined in Deltares.Geotechnics.Forms.DrawingBlockRevetmentSegment) | Deltares.Geotechnics.Forms.DrawingBlockRevetmentSegment | protected
Move(IProjection projection, Point2D startPosition, SizeF worldSize) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
Name | Deltares.Geometry.Forms.DrawingObject |
OnBeginDrag(IProjection projection, Point3D aBeginDragDropPoint, bool isIndividualDrag) | Deltares.Geometry.Forms.DrawingObject | virtual
OnDragging(IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D) | Deltares.Geometry.Forms.DrawingObject | virtual
OnEndDrag(IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D) | Deltares.Geometry.Forms.DrawingObject | virtual
Selected | Deltares.Geometry.Forms.DrawingObject |
SetDataObject(object dataObject) | Deltares.Geotechnics.Forms.DrawingBlockRevetmentSegment | virtual
ToolTip | Deltares.Geometry.Forms.DrawingObject |
ToString() (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
UpdateDataDragDrop(Vector3D aVect3D, List< IDrawingObject > aDraggedObjects) | Deltares.Geometry.Forms.DrawingObject | virtual
UpdateDataDragDrop(Point3D aBeginDragPoint, Vector3D vector) | Deltares.Geometry.Forms.DrawingObject | virtual
Generated on Tue Dec 15 2015 18:14:04 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.Forms.DrawingBoring Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • DrawingBoring
Public Member Functions | Properties | List of all members
Deltares.Geotechnics.Forms.DrawingBoring Class Reference

Drawing class for displaying a Boring in the DSL geometry editor see http://www.geffiles.nl/cur/BORE_nl.html More...

Inheritance diagram for Deltares.Geotechnics.Forms.DrawingBoring:
Deltares.Geometry.Forms.DrawingObject Deltares.Geometry.Forms.IDrawingObject Deltares.Standard.Forms.IShape

Public Member Functions

override void | SetDataObject (object dataObject)
Sets the data object (Boring, BoringLookup1D or BoringLookup2D). More...
override object | GetDataObject ()
Returns the data object. More...
override void | Draw3D (GraphicsInfo info)
Draws the boring. More...
override void | OnBeginDrag (IProjection projection, Point3D aBeginDragDropPoint, bool isIndividualDrag)
Called when dragging has begun More...
override void | UpdateDataDragDrop (Point3D beginDragPoint, Vector3D vector)
Updates the data drag drop. More...
override void | OnEndDrag (IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D)
Called when dragging has ended More...
override bool | ContainsPoint (IProjection projection, Point point)
Determines whether the specified projection contains point. More...
override Rectangle | GetExtents (IProjection projection)
Gets the extents of the projection. More...
- Public Member Functions inherited from Deltares.Geometry.Forms.DrawingObject
Point3D | GetScaled3DPoint (IProjection projection, Point3D aOrginalPoint)
Converts the 3DPoint to screen coordinates More...
Point3D | GetScreenPoint (IProjection projection, Point2D orginalPoint)
Converts Point from 3D space to screen coordinates, assuming Y = 0 More...
Point3D | GetScreenPoint (IProjection projection, Point3D orginalPoint)
Converts Point from 3D space to screen coordinates More...
Point3D | GetScreenPoint (IProjection projection, double x, double z)
Converts 3D x, y coordinates to screen coordinates, assuming Y = 0 More...
override string | ToString ()
virtual void | UpdateDataDragDrop (Vector3D aVect3D, List< IDrawingObject > aDraggedObjects)
Update the position and or orientation of a drawing object as the user is dragging it. More...
virtual CardinalDirection | GetCardinalDirectionOnEdgeContainingPoint (Point point)
virtual void | OnDragging (IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D)
Method which is called during drag-drop operations More...
virtual bool | CheckHitForSelection (IProjection projection, Point3D point, double tolerance)
Check if given point coordinates intersect the rendered drawing object. More...
virtual double | GetStandardSize (object aDraw3DInterface, Point3D aPoint3D)
void | GetScaled3DPoint (IProjection projection, Point3D aOrginalPoint, ref Point3D aPointTobeScaled)
Converts the 3DPoint to screen coordinates More...
double | GetScaledXPoint (IProjection projection, double aOrginalCordinate)
Converts X Coordinate in 3D space to a screen X Coordinate More...
virtual void | Draw (GraphicsInfo info)
Render this object in 3D space. More...
virtual void | DrawLabel (GraphicsInfo info)
Renders a label or tooltip to provide some information in text for this object. More...
virtual void | Move (IProjection projection, Point2D startPosition, SizeF worldSize)
virtual void | BeginMove (IProjection projection, Point2D startPosition)
virtual void | EndMove (IProjection projection, Point2D startPosition, SizeF worldSize)
virtual bool | AllowDrop (object data)
Boolean which indicates if other drawing objects can be dropped on given drawing objects More...
virtual void | Drop (object data)
Ends a drag-drop operation More...
virtual IEnumerable< object > | DataItemAt (Point point, Projection projection)

Properties

double | X [get]
Gets the x of a 2D boring. More...
double | Z [get]
Gets the z of a 2D boring. More...
double | Top [get]
Gets the top. More...
double | Bottom [get]
Gets the bottom. More...
double | Width [get, set]
Gets or sets the width. More...
double | Left [get]
Gets the left. More...
double | Right [get]
Gets the right. More...
- Properties inherited from Deltares.Geometry.Forms.DrawingObject
virtual bool | CanResize [get]
Boolean which indicates if a drawing object can be resized. More...
virtual bool | Selected [get, set]
Boolean which indicates if a drawing object is currently selected. More...
string | ToolTip [get]
Description which is shown as a tooltip when the mouse hovers over drawing object. More...
string | Name [get, set]
Gets or sets the name of a drawing object. More...
bool | IsVisible [get, set]
bool | HasBeenUpdated [get, set]
virtual bool | IsDragableOnReslultMode [get]
virtual int | Layer [get, set]
object | DataObject [get, set]
- Properties inherited from Deltares.Geometry.Forms.IDrawingObject
string | Name [get, set]
bool | IsVisible [get, set]
bool | HasBeenUpdated [get, set]
Gets or sets the update status of a drawing object. More...
bool | IsDragableOnReslultMode [get]
- Properties inherited from Deltares.Standard.Forms.IShape
object | DataObject [get, set]
int | Layer [get]

Additional Inherited Members

- Protected Member Functions inherited from Deltares.Geometry.Forms.DrawingObject
virtual int GetThickness (GraphicsInfo info)
Gets the thickness in screen pixels of a drawing object. More...

Detailed Description

Drawing class for displaying a Boring in the DSL geometry editor see http://www.geffiles.nl/cur/BORE_nl.html

Member Function Documentation

override bool Deltares.Geotechnics.Forms.DrawingBoring.ContainsPoint | ( | IProjection | projection,
 |  | Point | point
 | ) |  |
virtual

Determines whether the specified projection contains point.

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

override void Deltares.Geotechnics.Forms.DrawingBoring.Draw3D ( GraphicsInfo info )
virtual

Draws the boring.

Parameters
info The information.

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

References Deltares.Standard.Forms.DrawingSupport.GetLighterColor(), and Deltares.Standard.Forms.DrawingSupport.SetIEPDraw3D().

override object Deltares.Geotechnics.Forms.DrawingBoring.GetDataObject ( )
virtual

Returns the data object.

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

override Rectangle Deltares.Geotechnics.Forms.DrawingBoring.GetExtents ( IProjection projection )
virtual

Gets the extents of the projection.

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

override void Deltares.Geotechnics.Forms.DrawingBoring.OnBeginDrag | ( | IProjection | projection,
 |  | Point3D | aBeginDragDropPoint,
 |  | bool | isIndividualDrag
 | ) |  |
virtual

Called when dragging has begun

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

override void Deltares.Geotechnics.Forms.DrawingBoring.OnEndDrag | ( | IProjection | projection,
 |  | Point3D | aCurrentDragPoint,
 |  | Vector3D | aVect3D
 | ) |  |
virtual

Called when dragging has ended

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

override void Deltares.Geotechnics.Forms.DrawingBoring.SetDataObject ( object dataObject )
virtual

Sets the data object (Boring, BoringLookup1D or BoringLookup2D).

Parameters
dataObject The data object.

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

override void Deltares.Geotechnics.Forms.DrawingBoring.UpdateDataDragDrop | ( | Point3D | beginDragPoint,
 |  | Vector3D | vector
 | ) |  |
virtual

Updates the data drag drop.

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

Property Documentation

double Deltares.Geotechnics.Forms.DrawingBoring.Bottom
get

Gets the bottom.

double Deltares.Geotechnics.Forms.DrawingBoring.Left
get

Gets the left.

double Deltares.Geotechnics.Forms.DrawingBoring.Right
get

Gets the right.

double Deltares.Geotechnics.Forms.DrawingBoring.Top
get

Gets the top.

double Deltares.Geotechnics.Forms.DrawingBoring.Width
getset

Gets or sets the width.

double Deltares.Geotechnics.Forms.DrawingBoring.X
get

Gets the x of a 2D boring.

double Deltares.Geotechnics.Forms.DrawingBoring.Z
get

Gets the z of a 2D boring.

Generated on Tue Dec 15 2015 18:14:04 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • DrawingBoring
Deltares.Geotechnics.Forms.DrawingBoring Member List

This is the complete list of members for Deltares.Geotechnics.Forms.DrawingBoring, including all inherited members.

AllowDrop(object data) | Deltares.Geometry.Forms.DrawingObject | virtual
BeginMove(IProjection projection, Point2D startPosition) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
Bottom | Deltares.Geotechnics.Forms.DrawingBoring |
CanResize | Deltares.Geometry.Forms.DrawingObject |
CheckHitForSelection(IProjection projection, Point3D point, double tolerance) | Deltares.Geometry.Forms.DrawingObject | virtual
ContainsPoint(IProjection projection, Point point) | Deltares.Geotechnics.Forms.DrawingBoring | virtual
DataItemAt(Point point, Projection projection) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
DataObject (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
Draw(GraphicsInfo info) | Deltares.Geometry.Forms.DrawingObject | virtual
Draw3D(GraphicsInfo info) | Deltares.Geotechnics.Forms.DrawingBoring | virtual
DrawingObject() (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
DrawLabel(GraphicsInfo info) | Deltares.Geometry.Forms.DrawingObject | virtual
Drop(object data) | Deltares.Geometry.Forms.DrawingObject | virtual
EndMove(IProjection projection, Point2D startPosition, SizeF worldSize) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetCardinalDirectionOnEdgeContainingPoint(Point point) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetDataObject() | Deltares.Geotechnics.Forms.DrawingBoring | virtual
GetExtents(IProjection projection) | Deltares.Geotechnics.Forms.DrawingBoring | virtual
GetScaled3DPoint(IProjection projection, Point3D aOrginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScaled3DPoint(IProjection projection, Point3D aOrginalPoint, ref Point3D aPointTobeScaled) | Deltares.Geometry.Forms.DrawingObject |
GetScaledXPoint(IProjection projection, double aOrginalCordinate) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, Point2D orginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, Point3D orginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, double x, double z) | Deltares.Geometry.Forms.DrawingObject |
GetStandardSize(object aDraw3DInterface, Point3D aPoint3D) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetThickness(GraphicsInfo info) | Deltares.Geometry.Forms.DrawingObject | protectedvirtual
HasBeenUpdated (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
IsDragableOnReslultMode (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
IsVisible (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
Layer (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
Left | Deltares.Geotechnics.Forms.DrawingBoring |
Move(IProjection projection, Point2D startPosition, SizeF worldSize) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
Name | Deltares.Geometry.Forms.DrawingObject |
OnBeginDrag(IProjection projection, Point3D aBeginDragDropPoint, bool isIndividualDrag) | Deltares.Geotechnics.Forms.DrawingBoring | virtual
OnDragging(IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D) | Deltares.Geometry.Forms.DrawingObject | virtual
OnEndDrag(IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D) | Deltares.Geotechnics.Forms.DrawingBoring | virtual
Right | Deltares.Geotechnics.Forms.DrawingBoring |
Selected | Deltares.Geometry.Forms.DrawingObject |
SetDataObject(object dataObject) | Deltares.Geotechnics.Forms.DrawingBoring | virtual
ToolTip | Deltares.Geometry.Forms.DrawingObject |
Top | Deltares.Geotechnics.Forms.DrawingBoring |
ToString() (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
UpdateDataDragDrop(Point3D beginDragPoint, Vector3D vector) | Deltares.Geotechnics.Forms.DrawingBoring | virtual
Deltares::Geometry::Forms::DrawingObject.UpdateDataDragDrop(Vector3D aVect3D, List< IDrawingObject > aDraggedObjects) | Deltares.Geometry.Forms.DrawingObject | virtual
Width | Deltares.Geotechnics.Forms.DrawingBoring |
X | Deltares.Geotechnics.Forms.DrawingBoring |
Z | Deltares.Geotechnics.Forms.DrawingBoring |
Generated on Tue Dec 15 2015 18:14:04 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.Forms.DrawingCharacteristicPoint Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • DrawingCharacteristicPoint
Public Member Functions | List of all members
Deltares.Geotechnics.Forms.DrawingCharacteristicPoint Class Reference
Inheritance diagram for Deltares.Geotechnics.Forms.DrawingCharacteristicPoint:
Deltares.Geometry.Forms.DrawingPoint Deltares.Geometry.Forms.DrawingObject Deltares.Geometry.Forms.IDrawingObject Deltares.Standard.Forms.IShape

Public Member Functions

override void | SetDataObject (object aDataObject)
Stes the data object for this.dataPoint More...
override object | GetDataObject ()
Gets the IDataobject for this.dataPoint. More...
override Rectangle | GetExtents (IProjection projection)
Returns the bounding box of the shape. More...
override bool | ContainsPoint (IProjection projection, Point screenPoint)
Determines if a given point screen coordinate is within the drawing object. More...
override void | Draw3D (GraphicsInfo info)
Draws a single characteristic point. More...
override void | DrawLabel (GraphicsInfo info)
Renders a label or tooltip to provide some information in text for this object. More...
- Public Member Functions inherited from Deltares.Geometry.Forms.DrawingPoint
DrawingPoint (GeometryPoint aPoint)
override void | OnBeginDrag (IProjection projection, Point3D beginDragDropPoint, bool isIndividualDrag)
Method which is called when the user initiates a drag-drop operation More...
override void | UpdateDataDragDrop (Point3D beginDragPoint, Vector3D vector)
Updates the geometry after publisherEventArgs drag and drop. More...
override void | OnEndDrag (IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D)
Method which is called when the user ends a drag-drop operation. More...
- Public Member Functions inherited from Deltares.Geometry.Forms.DrawingObject
Point3D | GetScaled3DPoint (IProjection projection, Point3D aOrginalPoint)
Converts the 3DPoint to screen coordinates More...
Point3D | GetScreenPoint (IProjection projection, Point2D orginalPoint)
Converts Point from 3D space to screen coordinates, assuming Y = 0 More...
Point3D | GetScreenPoint (IProjection projection, Point3D orginalPoint)
Converts Point from 3D space to screen coordinates More...
Point3D | GetScreenPoint (IProjection projection, double x, double z)
Converts 3D x, y coordinates to screen coordinates, assuming Y = 0 More...
override string | ToString ()
virtual void | UpdateDataDragDrop (Vector3D aVect3D, List< IDrawingObject > aDraggedObjects)
Update the position and or orientation of a drawing object as the user is dragging it. More...
virtual CardinalDirection | GetCardinalDirectionOnEdgeContainingPoint (Point point)
virtual void | OnDragging (IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D)
Method which is called during drag-drop operations More...
virtual bool | CheckHitForSelection (IProjection projection, Point3D point, double tolerance)
Check if given point coordinates intersect the rendered drawing object. More...
virtual double | GetStandardSize (object aDraw3DInterface, Point3D aPoint3D)
void | GetScaled3DPoint (IProjection projection, Point3D aOrginalPoint, ref Point3D aPointTobeScaled)
Converts the 3DPoint to screen coordinates More...
double | GetScaledXPoint (IProjection projection, double aOrginalCordinate)
Converts X Coordinate in 3D space to a screen X Coordinate More...
virtual void | Draw (GraphicsInfo info)
Render this object in 3D space. More...
virtual void | Move (IProjection projection, Point2D startPosition, SizeF worldSize)
virtual void | BeginMove (IProjection projection, Point2D startPosition)
virtual void | EndMove (IProjection projection, Point2D startPosition, SizeF worldSize)
virtual bool | AllowDrop (object data)
Boolean which indicates if other drawing objects can be dropped on given drawing objects More...
virtual void | Drop (object data)
Ends a drag-drop operation More...
virtual IEnumerable< object > | DataItemAt (Point point, Projection projection)

Additional Inherited Members

- Static Public Member Functions inherited from Deltares.Geometry.Forms.DrawingPoint
static void | DrawRoundLabelAtPoint (Graphics graphics, Point screenPoint, string text, Brush textBrush, Brush backgroundBrush, Brush borderBrush)
static void | BeginMovePoints ()
static void | Move (GeometryPoint point, Vector3D vector, Point3D beginDragPoint)
- Protected Member Functions inherited from Deltares.Geometry.Forms.DrawingObject
virtual int | GetThickness (GraphicsInfo info)
Gets the thickness in screen pixels of a drawing object. More...
- Protected Attributes inherited from Deltares.Geometry.Forms.DrawingPoint
Point2D | point
The rendered point in screen coordinates. More...
- Properties inherited from Deltares.Geometry.Forms.DrawingPoint
static bool | Highlighted [get, set]
- Properties inherited from Deltares.Geometry.Forms.DrawingObject
virtual bool | CanResize [get]
Boolean which indicates if a drawing object can be resized. More...
virtual bool | Selected [get, set]
Boolean which indicates if a drawing object is currently selected. More...
string | ToolTip [get]
Description which is shown as a tooltip when the mouse hovers over drawing object. More...
string | Name [get, set]
Gets or sets the name of a drawing object. More...
bool | IsVisible [get, set]
bool | HasBeenUpdated [get, set]
virtual bool | IsDragableOnReslultMode [get]
virtual int | Layer [get, set]
object | DataObject [get, set]
- Properties inherited from Deltares.Geometry.Forms.IDrawingObject
string | Name [get, set]
bool | IsVisible [get, set]
bool | HasBeenUpdated [get, set]
Gets or sets the update status of a drawing object. More...
bool | IsDragableOnReslultMode [get]
- Properties inherited from Deltares.Standard.Forms.IShape
object | DataObject [get, set]
int | Layer [get]

Member Function Documentation

override bool Deltares.Geotechnics.Forms.DrawingCharacteristicPoint.ContainsPoint | ( | IProjection | projection,
 |  | Point | point
 | ) |  |
virtual

Determines if a given point screen coordinate is within the drawing object.

Parameters
projection | Projection used for drawing
point | Point in screen coordinates.
Returns
True if given point is within the rendered drawing object.

Reimplemented from Deltares.Geometry.Forms.DrawingPoint.

override void Deltares.Geotechnics.Forms.DrawingCharacteristicPoint.Draw3D ( GraphicsInfo info )
virtual

Draws a single characteristic point.

Reimplemented from Deltares.Geometry.Forms.DrawingPoint.

References Deltares.Standard.Forms.DrawingSupport.ColorMaterial3D(), and Deltares.Standard.Forms.DrawingSupport.DrawPointSelector().

override void Deltares.Geotechnics.Forms.DrawingCharacteristicPoint.DrawLabel ( GraphicsInfo info )
virtual

Renders a label or tooltip to provide some information in text for this object.

Parameters
info Rendering target information.

Reimplemented from Deltares.Geometry.Forms.DrawingPoint.

References Deltares.Standard.Forms.DrawingSupport.DrawLabelAtPoint().

override object Deltares.Geotechnics.Forms.DrawingCharacteristicPoint.GetDataObject ( )
virtual

Gets the IDataobject for this.dataPoint.

Returns

Reimplemented from Deltares.Geometry.Forms.DrawingPoint.

override Rectangle Deltares.Geotechnics.Forms.DrawingCharacteristicPoint.GetExtents ( IProjection projection )
virtual

Returns the bounding box of the shape.

Parameters
projection Projection used for drawing.
Returns
The bounding box of the shape; Null if none can be determined.

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

override void Deltares.Geotechnics.Forms.DrawingCharacteristicPoint.SetDataObject ( object aDataObject )
virtual

Stes the data object for this.dataPoint

Parameters
aDataObject

Reimplemented from Deltares.Geometry.Forms.DrawingPoint.

Generated on Tue Dec 15 2015 18:14:05 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • DrawingCharacteristicPoint
Deltares.Geotechnics.Forms.DrawingCharacteristicPoint Member List

This is the complete list of members for Deltares.Geotechnics.Forms.DrawingCharacteristicPoint, including all inherited members.

AllowDrop(object data) | Deltares.Geometry.Forms.DrawingObject | virtual
BeginMove(IProjection projection, Point2D startPosition) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
BeginMovePoints() (defined in Deltares.Geometry.Forms.DrawingPoint) | Deltares.Geometry.Forms.DrawingPoint | static
CanResize | Deltares.Geometry.Forms.DrawingObject |
CheckHitForSelection(IProjection projection, Point3D point, double tolerance) | Deltares.Geometry.Forms.DrawingObject | virtual
ContainsPoint(IProjection projection, Point screenPoint) | Deltares.Geotechnics.Forms.DrawingCharacteristicPoint | virtual
DataItemAt(Point point, Projection projection) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
DataObject (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
Draw(GraphicsInfo info) | Deltares.Geometry.Forms.DrawingObject | virtual
Draw3D(GraphicsInfo info) | Deltares.Geotechnics.Forms.DrawingCharacteristicPoint | virtual
DrawingCharacteristicPoint() (defined in Deltares.Geotechnics.Forms.DrawingCharacteristicPoint) | Deltares.Geotechnics.Forms.DrawingCharacteristicPoint |
DrawingObject() (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
DrawingPoint() (defined in Deltares.Geometry.Forms.DrawingPoint) | Deltares.Geometry.Forms.DrawingPoint |
DrawingPoint(GeometryPoint aPoint) (defined in Deltares.Geometry.Forms.DrawingPoint) | Deltares.Geometry.Forms.DrawingPoint |
DrawLabel(GraphicsInfo info) | Deltares.Geotechnics.Forms.DrawingCharacteristicPoint | virtual
DrawRoundLabelAtPoint(Graphics graphics, Point screenPoint, string text, Brush textBrush, Brush backgroundBrush, Brush borderBrush) (defined in Deltares.Geometry.Forms.DrawingPoint) | Deltares.Geometry.Forms.DrawingPoint | static
Drop(object data) | Deltares.Geometry.Forms.DrawingObject | virtual
EndMove(IProjection projection, Point2D startPosition, SizeF worldSize) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetCardinalDirectionOnEdgeContainingPoint(Point point) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetDataObject() | Deltares.Geotechnics.Forms.DrawingCharacteristicPoint | virtual
GetExtents(IProjection projection) | Deltares.Geotechnics.Forms.DrawingCharacteristicPoint | virtual
GetScaled3DPoint(IProjection projection, Point3D aOrginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScaled3DPoint(IProjection projection, Point3D aOrginalPoint, ref Point3D aPointTobeScaled) | Deltares.Geometry.Forms.DrawingObject |
GetScaledXPoint(IProjection projection, double aOrginalCordinate) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, Point2D orginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, Point3D orginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, double x, double z) | Deltares.Geometry.Forms.DrawingObject |
GetStandardSize(object aDraw3DInterface, Point3D aPoint3D) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetThickness(GraphicsInfo info) | Deltares.Geometry.Forms.DrawingObject | protectedvirtual
HasBeenUpdated (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
Highlighted (defined in Deltares.Geometry.Forms.DrawingPoint) | Deltares.Geometry.Forms.DrawingPoint | static
IsDragableOnReslultMode (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
IsVisible (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
Layer (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
Move(GeometryPoint point, Vector3D vector, Point3D beginDragPoint) (defined in Deltares.Geometry.Forms.DrawingPoint) | Deltares.Geometry.Forms.DrawingPoint | static
Move(IProjection projection, Point2D startPosition, SizeF worldSize) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
Name | Deltares.Geometry.Forms.DrawingObject |
OnBeginDrag(IProjection projection, Point3D beginDragDropPoint, bool isIndividualDrag) | Deltares.Geometry.Forms.DrawingPoint | virtual
OnDragging(IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D) | Deltares.Geometry.Forms.DrawingObject | virtual
OnEndDrag(IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D) | Deltares.Geometry.Forms.DrawingPoint | virtual
point | Deltares.Geometry.Forms.DrawingPoint | protected
Selected | Deltares.Geometry.Forms.DrawingObject |
SetDataObject(object aDataObject) | Deltares.Geotechnics.Forms.DrawingCharacteristicPoint | virtual
ToolTip | Deltares.Geometry.Forms.DrawingObject |
ToString() (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
UpdateDataDragDrop(Point3D beginDragPoint, Vector3D vector) | Deltares.Geometry.Forms.DrawingPoint | virtual
Deltares::Geometry::Forms::DrawingObject.UpdateDataDragDrop(Vector3D aVect3D, List< IDrawingObject > aDraggedObjects) | Deltares.Geometry.Forms.DrawingObject | virtual
Generated on Tue Dec 15 2015 18:14:05 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.Forms.DrawingCPT Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • DrawingCPT
Public Member Functions | Properties | List of all members
Deltares.Geotechnics.Forms.DrawingCPT Class Reference

Drawing class for displaying a CPT (sondering) in the DSL geometry editor see http://www.geffiles.nl/cur/CPT_nl.html (second graph, combined plot used as example) More...

Inheritance diagram for Deltares.Geotechnics.Forms.DrawingCPT:
Deltares.Geometry.Forms.DrawingObject Deltares.Geometry.Forms.IDrawingObject Deltares.Standard.Forms.IShape

Public Member Functions

override void | SetDataObject (object dataObject)
Sets the data object (CPT, CPTLookup1D or CPTLookup2D). More...
override object | GetDataObject ()
Gets the data object. More...
override void | Draw3D (GraphicsInfo info)
Draws the CPT. More...
override void | DrawLabel (GraphicsInfo info)
Draws the label. More...
override void | OnBeginDrag (IProjection projection, Point3D aBeginDragDropPoint, bool isIndividualDrag)
Called when dragging has begun More...
override void | UpdateDataDragDrop (Point3D beginDragPoint, Vector3D vector)
Updates the data drag drop. More...
override void | OnEndDrag (IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D)
Called when dragging has ended More...
override bool | ContainsPoint (IProjection projection, Point point)
Determines whether the specified projection contains point. More...
override Rectangle | GetExtents (IProjection projection)
Gets the extents. More...
- Public Member Functions inherited from Deltares.Geometry.Forms.DrawingObject
Point3D | GetScaled3DPoint (IProjection projection, Point3D aOrginalPoint)
Converts the 3DPoint to screen coordinates More...
Point3D | GetScreenPoint (IProjection projection, Point2D orginalPoint)
Converts Point from 3D space to screen coordinates, assuming Y = 0 More...
Point3D | GetScreenPoint (IProjection projection, Point3D orginalPoint)
Converts Point from 3D space to screen coordinates More...
Point3D | GetScreenPoint (IProjection projection, double x, double z)
Converts 3D x, y coordinates to screen coordinates, assuming Y = 0 More...
override string | ToString ()
virtual void | UpdateDataDragDrop (Vector3D aVect3D, List< IDrawingObject > aDraggedObjects)
Update the position and or orientation of a drawing object as the user is dragging it. More...
virtual CardinalDirection | GetCardinalDirectionOnEdgeContainingPoint (Point point)
virtual void | OnDragging (IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D)
Method which is called during drag-drop operations More...
virtual bool | CheckHitForSelection (IProjection projection, Point3D point, double tolerance)
Check if given point coordinates intersect the rendered drawing object. More...
virtual double | GetStandardSize (object aDraw3DInterface, Point3D aPoint3D)
void | GetScaled3DPoint (IProjection projection, Point3D aOrginalPoint, ref Point3D aPointTobeScaled)
Converts the 3DPoint to screen coordinates More...
double | GetScaledXPoint (IProjection projection, double aOrginalCordinate)
Converts X Coordinate in 3D space to a screen X Coordinate More...
virtual void | Draw (GraphicsInfo info)
Render this object in 3D space. More...
virtual void | Move (IProjection projection, Point2D startPosition, SizeF worldSize)
virtual void | BeginMove (IProjection projection, Point2D startPosition)
virtual void | EndMove (IProjection projection, Point2D startPosition, SizeF worldSize)
virtual bool | AllowDrop (object data)
Boolean which indicates if other drawing objects can be dropped on given drawing objects More...
virtual void | Drop (object data)
Ends a drag-drop operation More...
virtual IEnumerable< object > | DataItemAt (Point point, Projection projection)

Properties

double | FrictionMax [get, set]
Maximum Friction value used for scaling the CPT graph More...
double | WaterPressureMax [get, set]
Maximum WaterPressure value used for scaling the CPT graph More...
double | QcMax [get, set]
Maximum Qc value used for scaling the CPT graph More...
bool | ShowAxes [get, set]
Gets or sets a value indicating whether the axes will be shown. More...
GeometryPoint | InsertionPoint [get, set]
Gets or sets the insertion point. More...
double | X [get]
Gets the x. More...
double | Z [get]
Gets the z. More...
double | Top [get]
Gets the top. More...
double | Bottom [get]
Gets the bottom. More...
double | Width [get, set]
Gets or sets the width. More...
double | Left [get]
Gets the left. More...
double | Right [get]
Gets the right. More...
- Properties inherited from Deltares.Geometry.Forms.DrawingObject
virtual bool | CanResize [get]
Boolean which indicates if a drawing object can be resized. More...
virtual bool | Selected [get, set]
Boolean which indicates if a drawing object is currently selected. More...
string | ToolTip [get]
Description which is shown as a tooltip when the mouse hovers over drawing object. More...
string | Name [get, set]
Gets or sets the name of a drawing object. More...
bool | IsVisible [get, set]
bool | HasBeenUpdated [get, set]
virtual bool | IsDragableOnReslultMode [get]
virtual int | Layer [get, set]
object | DataObject [get, set]
- Properties inherited from Deltares.Geometry.Forms.IDrawingObject
string | Name [get, set]
bool | IsVisible [get, set]
bool | HasBeenUpdated [get, set]
Gets or sets the update status of a drawing object. More...
bool | IsDragableOnReslultMode [get]
- Properties inherited from Deltares.Standard.Forms.IShape
object | DataObject [get, set]
int | Layer [get]

Additional Inherited Members

- Protected Member Functions inherited from Deltares.Geometry.Forms.DrawingObject
virtual int GetThickness (GraphicsInfo info)
Gets the thickness in screen pixels of a drawing object. More...

Detailed Description

Drawing class for displaying a CPT (sondering) in the DSL geometry editor see http://www.geffiles.nl/cur/CPT_nl.html (second graph, combined plot used as example)

Member Function Documentation

override bool Deltares.Geotechnics.Forms.DrawingCPT.ContainsPoint | ( | IProjection | projection,
 |  | Point | point
 | ) |  |
virtual

Determines whether the specified projection contains point.

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

override void Deltares.Geotechnics.Forms.DrawingCPT.Draw3D ( GraphicsInfo info )
virtual

Draws the CPT.

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

References Deltares.Standard.Forms.DrawingSupport.SetIEPDraw3D().

override void Deltares.Geotechnics.Forms.DrawingCPT.DrawLabel ( GraphicsInfo info )
virtual

Draws the label.

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

References Deltares.Standard.Forms.DrawingSupport.DrawLabelAtPoint(), Deltares.Standard.Forms.DrawingSupport.GetDarkerColor(), and Deltares.Standard.Forms.DrawingSupport.GetLighterColor().

override object Deltares.Geotechnics.Forms.DrawingCPT.GetDataObject ( )
virtual

Gets the data object.

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

override Rectangle Deltares.Geotechnics.Forms.DrawingCPT.GetExtents ( IProjection projection )
virtual

Gets the extents.

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

override void Deltares.Geotechnics.Forms.DrawingCPT.OnBeginDrag | ( | IProjection | projection,
 |  | Point3D | aBeginDragDropPoint,
 |  | bool | isIndividualDrag
 | ) |  |
virtual

Called when dragging has begun

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

override void Deltares.Geotechnics.Forms.DrawingCPT.OnEndDrag | ( | IProjection | projection,
 |  | Point3D | aCurrentDragPoint,
 |  | Vector3D | aVect3D
 | ) |  |
virtual

Called when dragging has ended

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

override void Deltares.Geotechnics.Forms.DrawingCPT.SetDataObject ( object dataObject )
virtual

Sets the data object (CPT, CPTLookup1D or CPTLookup2D).

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

override void Deltares.Geotechnics.Forms.DrawingCPT.UpdateDataDragDrop | ( | Point3D | beginDragPoint,
 |  | Vector3D | vector
 | ) |  |
virtual

Updates the data drag drop.

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

Property Documentation

double Deltares.Geotechnics.Forms.DrawingCPT.Bottom
get

Gets the bottom.

double Deltares.Geotechnics.Forms.DrawingCPT.FrictionMax
getset

Maximum Friction value used for scaling the CPT graph

GeometryPoint Deltares.Geotechnics.Forms.DrawingCPT.InsertionPoint
getset

Gets or sets the insertion point.

double Deltares.Geotechnics.Forms.DrawingCPT.Left
get

Gets the left.

double Deltares.Geotechnics.Forms.DrawingCPT.QcMax
getset

Maximum Qc value used for scaling the CPT graph

double Deltares.Geotechnics.Forms.DrawingCPT.Right
get

Gets the right.

bool Deltares.Geotechnics.Forms.DrawingCPT.ShowAxes
getset

Gets or sets a value indicating whether the axes will be shown.

double Deltares.Geotechnics.Forms.DrawingCPT.Top
get

Gets the top.

double Deltares.Geotechnics.Forms.DrawingCPT.WaterPressureMax
getset

Maximum WaterPressure value used for scaling the CPT graph

double Deltares.Geotechnics.Forms.DrawingCPT.Width
getset

Gets or sets the width.

double Deltares.Geotechnics.Forms.DrawingCPT.X
get

Gets the x.

double Deltares.Geotechnics.Forms.DrawingCPT.Z
get

Gets the z.

Generated on Tue Dec 15 2015 18:14:05 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • DrawingCPT
Deltares.Geotechnics.Forms.DrawingCPT Member List

This is the complete list of members for Deltares.Geotechnics.Forms.DrawingCPT, including all inherited members.

AllowDrop(object data) | Deltares.Geometry.Forms.DrawingObject | virtual
BeginMove(IProjection projection, Point2D startPosition) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
Bottom | Deltares.Geotechnics.Forms.DrawingCPT |
CanResize | Deltares.Geometry.Forms.DrawingObject |
CheckHitForSelection(IProjection projection, Point3D point, double tolerance) | Deltares.Geometry.Forms.DrawingObject | virtual
ContainsPoint(IProjection projection, Point point) | Deltares.Geotechnics.Forms.DrawingCPT | virtual
DataItemAt(Point point, Projection projection) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
DataObject (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
Draw(GraphicsInfo info) | Deltares.Geometry.Forms.DrawingObject | virtual
Draw3D(GraphicsInfo info) | Deltares.Geotechnics.Forms.DrawingCPT | virtual
DrawingObject() (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
DrawLabel(GraphicsInfo info) | Deltares.Geotechnics.Forms.DrawingCPT | virtual
Drop(object data) | Deltares.Geometry.Forms.DrawingObject | virtual
EndMove(IProjection projection, Point2D startPosition, SizeF worldSize) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
FrictionMax | Deltares.Geotechnics.Forms.DrawingCPT |
GetCardinalDirectionOnEdgeContainingPoint(Point point) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetDataObject() | Deltares.Geotechnics.Forms.DrawingCPT | virtual
GetExtents(IProjection projection) | Deltares.Geotechnics.Forms.DrawingCPT | virtual
GetScaled3DPoint(IProjection projection, Point3D aOrginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScaled3DPoint(IProjection projection, Point3D aOrginalPoint, ref Point3D aPointTobeScaled) | Deltares.Geometry.Forms.DrawingObject |
GetScaledXPoint(IProjection projection, double aOrginalCordinate) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, Point2D orginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, Point3D orginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, double x, double z) | Deltares.Geometry.Forms.DrawingObject |
GetStandardSize(object aDraw3DInterface, Point3D aPoint3D) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetThickness(GraphicsInfo info) | Deltares.Geometry.Forms.DrawingObject | protectedvirtual
HasBeenUpdated (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
InsertionPoint | Deltares.Geotechnics.Forms.DrawingCPT |
IsDragableOnReslultMode (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
IsVisible (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
Layer (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
Left | Deltares.Geotechnics.Forms.DrawingCPT |
Move(IProjection projection, Point2D startPosition, SizeF worldSize) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
Name | Deltares.Geometry.Forms.DrawingObject |
OnBeginDrag(IProjection projection, Point3D aBeginDragDropPoint, bool isIndividualDrag) | Deltares.Geotechnics.Forms.DrawingCPT | virtual
OnDragging(IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D) | Deltares.Geometry.Forms.DrawingObject | virtual
OnEndDrag(IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D) | Deltares.Geotechnics.Forms.DrawingCPT | virtual
QcMax | Deltares.Geotechnics.Forms.DrawingCPT |
Right | Deltares.Geotechnics.Forms.DrawingCPT |
Selected | Deltares.Geometry.Forms.DrawingObject |
SetDataObject(object dataObject) | Deltares.Geotechnics.Forms.DrawingCPT | virtual
ShowAxes | Deltares.Geotechnics.Forms.DrawingCPT |
ToolTip | Deltares.Geometry.Forms.DrawingObject |
Top | Deltares.Geotechnics.Forms.DrawingCPT |
ToString() (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
UpdateDataDragDrop(Point3D beginDragPoint, Vector3D vector) | Deltares.Geotechnics.Forms.DrawingCPT | virtual
Deltares::Geometry::Forms::DrawingObject.UpdateDataDragDrop(Vector3D aVect3D, List< IDrawingObject > aDraggedObjects) | Deltares.Geometry.Forms.DrawingObject | virtual
WaterPressureMax | Deltares.Geotechnics.Forms.DrawingCPT |
Width | Deltares.Geotechnics.Forms.DrawingCPT |
X | Deltares.Geotechnics.Forms.DrawingCPT |
Z | Deltares.Geotechnics.Forms.DrawingCPT |
Generated on Tue Dec 15 2015 18:14:05 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.Forms.DrawingGeometry Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • DrawingGeometry
Public Member Functions | List of all members
Deltares.Geotechnics.Forms.DrawingGeometry Class Reference
Inheritance diagram for Deltares.Geotechnics.Forms.DrawingGeometry:
Deltares.Geometry.Forms.DrawingObject Deltares.Geometry.Forms.IDrawingObject Deltares.Standard.Forms.IShape

Public Member Functions

override void | SetDataObject (object dataObject)
Sets the data object for this.dataPoint More...
override object | GetDataObject ()
Gets the IDataobject for this.dataPoint. More...
override bool | ContainsPoint (IProjection projection, Point screenPoint)
Determines if a given point screen coordinate is within the drawing object. More...
override void | OnBeginDrag (IProjection projection, Point3D beginDragDropPoint, bool isIndividualDrag)
Method which is called when the user initiates a drag-drop operation More...
override void | UpdateDataDragDrop (Point3D beginDragPoint, Vector3D vector)
Updates the geometry after publisherEventArgs drag and drop. More...
override void | Draw3D (GraphicsInfo info)
Draws publisherEventArgs Point at the location where the user clicks on the screne.. More...
override void | DrawLabel (GraphicsInfo info)
Renders a label or tooltip to provide some information in text for this object. More...
- Public Member Functions inherited from Deltares.Geometry.Forms.DrawingObject
Point3D | GetScaled3DPoint (IProjection projection, Point3D aOrginalPoint)
Converts the 3DPoint to screen coordinates More...
Point3D | GetScreenPoint (IProjection projection, Point2D orginalPoint)
Converts Point from 3D space to screen coordinates, assuming Y = 0 More...
Point3D | GetScreenPoint (IProjection projection, Point3D orginalPoint)
Converts Point from 3D space to screen coordinates More...
Point3D | GetScreenPoint (IProjection projection, double x, double z)
Converts 3D x, y coordinates to screen coordinates, assuming Y = 0 More...
override string | ToString ()
virtual void | UpdateDataDragDrop (Vector3D aVect3D, List< IDrawingObject > aDraggedObjects)
Update the position and or orientation of a drawing object as the user is dragging it. More...
virtual CardinalDirection | GetCardinalDirectionOnEdgeContainingPoint (Point point)
virtual void | OnDragging (IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D)
Method which is called during drag-drop operations More...
virtual void | OnEndDrag (IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D)
Method which is called when the user ends a drag-drop operation. More...
virtual bool | CheckHitForSelection (IProjection projection, Point3D point, double tolerance)
Check if given point coordinates intersect the rendered drawing object. More...
virtual double | GetStandardSize (object aDraw3DInterface, Point3D aPoint3D)
void | GetScaled3DPoint (IProjection projection, Point3D aOrginalPoint, ref Point3D aPointTobeScaled)
Converts the 3DPoint to screen coordinates More...
double | GetScaledXPoint (IProjection projection, double aOrginalCordinate)
Converts X Coordinate in 3D space to a screen X Coordinate More...
virtual Rectangle | GetExtents (IProjection projection)
Returns the bounding box of the shape. More...
virtual void | Draw (GraphicsInfo info)
Render this object in 3D space. More...
virtual void | Move (IProjection projection, Point2D startPosition, SizeF worldSize)
virtual void | BeginMove (IProjection projection, Point2D startPosition)
virtual void | EndMove (IProjection projection, Point2D startPosition, SizeF worldSize)
virtual bool | AllowDrop (object data)
Boolean which indicates if other drawing objects can be dropped on given drawing objects More...
virtual void | Drop (object data)
Ends a drag-drop operation More...
virtual IEnumerable< object > | DataItemAt (Point point, Projection projection)

Additional Inherited Members

- Protected Member Functions inherited from Deltares.Geometry.Forms.DrawingObject
virtual int | GetThickness (GraphicsInfo info)
Gets the thickness in screen pixels of a drawing object. More...
- Properties inherited from Deltares.Geometry.Forms.DrawingObject
virtual bool | CanResize [get]
Boolean which indicates if a drawing object can be resized. More...
virtual bool | Selected [get, set]
Boolean which indicates if a drawing object is currently selected. More...
string | ToolTip [get]
Description which is shown as a tooltip when the mouse hovers over drawing object. More...
string | Name [get, set]
Gets or sets the name of a drawing object. More...
bool | IsVisible [get, set]
bool | HasBeenUpdated [get, set]
virtual bool | IsDragableOnReslultMode [get]
virtual int | Layer [get, set]
object | DataObject [get, set]
- Properties inherited from Deltares.Geometry.Forms.IDrawingObject
string | Name [get, set]
bool | IsVisible [get, set]
bool | HasBeenUpdated [get, set]
Gets or sets the update status of a drawing object. More...
bool | IsDragableOnReslultMode [get]
- Properties inherited from Deltares.Standard.Forms.IShape
object | DataObject [get, set]
int | Layer [get]

Member Function Documentation

override bool Deltares.Geotechnics.Forms.DrawingGeometry.ContainsPoint | ( | IProjection | projection,
 |  | Point | point
 | ) |  |
virtual

Determines if a given point screen coordinate is within the drawing object.

Parameters
projection | Projection used for drawing
point | Point in screen coordinates.
Returns
True if given point is within the rendered drawing object.

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

override void Deltares.Geotechnics.Forms.DrawingGeometry.Draw3D ( GraphicsInfo info )
virtual

Draws publisherEventArgs Point at the location where the user clicks on the screne..

Parameters
info

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

override void Deltares.Geotechnics.Forms.DrawingGeometry.DrawLabel ( GraphicsInfo info )
virtual

Renders a label or tooltip to provide some information in text for this object.

Parameters
info Rendering target information.

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

override object Deltares.Geotechnics.Forms.DrawingGeometry.GetDataObject ( )
virtual

Gets the IDataobject for this.dataPoint.

Returns

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

override void Deltares.Geotechnics.Forms.DrawingGeometry.OnBeginDrag | ( | IProjection | projection,
 |  | Point3D | aBeginDragDropPoint,
 |  | bool | isIndividualDrag
 | ) |  |
virtual

Method which is called when the user initiates a drag-drop operation

Parameters
projection | Current projection of 3D to screen coordinates.
aBeginDragDropPoint | Initial position of the mouse pointer.
isIndividualDrag

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

override void Deltares.Geotechnics.Forms.DrawingGeometry.SetDataObject ( object dataObject )
virtual

Sets the data object for this.dataPoint

Parameters
dataObject

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

override void Deltares.Geotechnics.Forms.DrawingGeometry.UpdateDataDragDrop | ( | Point3D | beginDragPoint,
 |  | Vector3D | vector
 | ) |  |
virtual

Updates the geometry after publisherEventArgs drag and drop.

Parameters
beginDragPoint
vector

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

Generated on Tue Dec 15 2015 18:14:05 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • DrawingGeometry
Deltares.Geotechnics.Forms.DrawingGeometry Member List

This is the complete list of members for Deltares.Geotechnics.Forms.DrawingGeometry, including all inherited members.

AllowDrop(object data) | Deltares.Geometry.Forms.DrawingObject | virtual
BeginMove(IProjection projection, Point2D startPosition) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
CanResize | Deltares.Geometry.Forms.DrawingObject |
CheckHitForSelection(IProjection projection, Point3D point, double tolerance) | Deltares.Geometry.Forms.DrawingObject | virtual
ContainsPoint(IProjection projection, Point screenPoint) | Deltares.Geotechnics.Forms.DrawingGeometry | virtual
DataItemAt(Point point, Projection projection) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
DataObject (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
Draw(GraphicsInfo info) | Deltares.Geometry.Forms.DrawingObject | virtual
Draw3D(GraphicsInfo info) | Deltares.Geotechnics.Forms.DrawingGeometry | virtual
DrawingGeometry() (defined in Deltares.Geotechnics.Forms.DrawingGeometry) | Deltares.Geotechnics.Forms.DrawingGeometry |
DrawingObject() (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
DrawLabel(GraphicsInfo info) | Deltares.Geotechnics.Forms.DrawingGeometry | virtual
Drop(object data) | Deltares.Geometry.Forms.DrawingObject | virtual
EndMove(IProjection projection, Point2D startPosition, SizeF worldSize) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetCardinalDirectionOnEdgeContainingPoint(Point point) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetDataObject() | Deltares.Geotechnics.Forms.DrawingGeometry | virtual
GetExtents(IProjection projection) | Deltares.Geometry.Forms.DrawingObject | virtual
GetScaled3DPoint(IProjection projection, Point3D aOrginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScaled3DPoint(IProjection projection, Point3D aOrginalPoint, ref Point3D aPointTobeScaled) | Deltares.Geometry.Forms.DrawingObject |
GetScaledXPoint(IProjection projection, double aOrginalCordinate) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, Point2D orginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, Point3D orginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, double x, double z) | Deltares.Geometry.Forms.DrawingObject |
GetStandardSize(object aDraw3DInterface, Point3D aPoint3D) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetThickness(GraphicsInfo info) | Deltares.Geometry.Forms.DrawingObject | protectedvirtual
HasBeenUpdated (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
IsDragableOnReslultMode (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
IsVisible (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
Layer (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
Move(IProjection projection, Point2D startPosition, SizeF worldSize) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
Name | Deltares.Geometry.Forms.DrawingObject |
OnBeginDrag(IProjection projection, Point3D beginDragDropPoint, bool isIndividualDrag) | Deltares.Geotechnics.Forms.DrawingGeometry | virtual
OnDragging(IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D) | Deltares.Geometry.Forms.DrawingObject | virtual
OnEndDrag(IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D) | Deltares.Geometry.Forms.DrawingObject | virtual
Selected | Deltares.Geometry.Forms.DrawingObject |
SetDataObject(object dataObject) | Deltares.Geotechnics.Forms.DrawingGeometry | virtual
ToolTip | Deltares.Geometry.Forms.DrawingObject |
ToString() (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
UpdateDataDragDrop(Point3D beginDragPoint, Vector3D vector) | Deltares.Geotechnics.Forms.DrawingGeometry | virtual
Deltares::Geometry::Forms::DrawingObject.UpdateDataDragDrop(Vector3D aVect3D, List< IDrawingObject > aDraggedObjects) | Deltares.Geometry.Forms.DrawingObject | virtual
Generated on Tue Dec 15 2015 18:14:05 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.Forms.DrawingHeadLine Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • DrawingHeadLine
Public Member Functions | List of all members
Deltares.Geotechnics.Forms.DrawingHeadLine Class Reference
Inheritance diagram for Deltares.Geotechnics.Forms.DrawingHeadLine:
Deltares.Geotechnics.Forms.DrawingWaternetPointString Deltares.Geometry.Forms.DrawingPointString Deltares.Geometry.Forms.DrawingObject Deltares.Geometry.Forms.IDrawingObject Deltares.Standard.Forms.IShape

Public Member Functions

override void | SetDataObject (object dataobject)
Sets the geotechnics entity that this drawing object represents More...
- Public Member Functions inherited from Deltares.Geotechnics.Forms.DrawingWaternetPointString
DrawingWaternetPointString (DragStyle dragStyle, Color lineColor, Color backgroundColor, int layer)
DrawingWaternetPointString (DragStyle dragStyle, DashStyle dashStyle, Color lineColor, Color backgroundColor, int layer)
override void | DrawLabel (GraphicsInfo info)
Renders a label or tooltip to provide some information in text for this object. More...
override void | Draw3D (GraphicsInfo info)
override The Draw3D() Method More...
- Public Member Functions inherited from Deltares.Geometry.Forms.DrawingPointString
DrawingPointString (Color lineColor, Color backgroundColor, int layer)
DrawingPointString (DragStyle dragStyle, Color lineColor, Color backgroundColor, int layer)
DrawingPointString (DashStyle dashStyle, Color lineColor, Color backgroundColor, int layer)
DrawingPointString (DragStyle dragStyle, DashStyle dashStyle, Color lineColor, Color backgroundColor, int layer)
override object | GetDataObject ()
Gets the geotechnics entity that this drawing object represents More...
override void | UpdateDataDragDrop (Point3D aBeginDragPoint, Vector3D vector)
override The UpdateDataDragDrop() Method More...
override void | BeginMove (IProjection projection, Point2D startPosition)
override IEnumerable< object > | DataItemAt (Point point, Projection projection)
- Public Member Functions inherited from Deltares.Geometry.Forms.DrawingObject
Point3D | GetScaled3DPoint (IProjection projection, Point3D aOrginalPoint)
Converts the 3DPoint to screen coordinates More...
Point3D | GetScreenPoint (IProjection projection, Point2D orginalPoint)
Converts Point from 3D space to screen coordinates, assuming Y = 0 More...
Point3D | GetScreenPoint (IProjection projection, Point3D orginalPoint)
Converts Point from 3D space to screen coordinates More...
Point3D | GetScreenPoint (IProjection projection, double x, double z)
Converts 3D x, y coordinates to screen coordinates, assuming Y = 0 More...
override string | ToString ()
virtual void | UpdateDataDragDrop (Vector3D aVect3D, List< IDrawingObject > aDraggedObjects)
Update the position and or orientation of a drawing object as the user is dragging it. More...
virtual void | OnBeginDrag (IProjection projection, Point3D aBeginDragDropPoint, bool isIndividualDrag)
Method which is called when the user initiates a drag-drop operation More...
virtual CardinalDirection | GetCardinalDirectionOnEdgeContainingPoint (Point point)
virtual void | OnDragging (IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D)
Method which is called during drag-drop operations More...
virtual void | OnEndDrag (IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D)
Method which is called when the user ends a drag-drop operation. More...
virtual bool | CheckHitForSelection (IProjection projection, Point3D point, double tolerance)
Check if given point coordinates intersect the rendered drawing object. More...
virtual double | GetStandardSize (object aDraw3DInterface, Point3D aPoint3D)
void | GetScaled3DPoint (IProjection projection, Point3D aOrginalPoint, ref Point3D aPointTobeScaled)
Converts the 3DPoint to screen coordinates More...
double | GetScaledXPoint (IProjection projection, double aOrginalCordinate)
Converts X Coordinate in 3D space to a screen X Coordinate More...
virtual bool | ContainsPoint (IProjection projection, Point point)
Determines if a given point screen coordinate is within the drawing object. More...
virtual Rectangle | GetExtents (IProjection projection)
Returns the bounding box of the shape. More...
virtual void | Draw (GraphicsInfo info)
Render this object in 3D space. More...
virtual void | Move (IProjection projection, Point2D startPosition, SizeF worldSize)
virtual void | EndMove (IProjection projection, Point2D startPosition, SizeF worldSize)
virtual bool | AllowDrop (object data)
Boolean which indicates if other drawing objects can be dropped on given drawing objects More...
virtual void | Drop (object data)
Ends a drag-drop operation More...

Additional Inherited Members

- Protected Member Functions inherited from Deltares.Geometry.Forms.DrawingPointString
IList< GeometryPoint > | GetPoints ()
- Protected Member Functions inherited from Deltares.Geometry.Forms.DrawingObject
virtual int | GetThickness (GraphicsInfo info)
Gets the thickness in screen pixels of a drawing object. More...
- Protected Attributes inherited from Deltares.Geometry.Forms.DrawingPointString
DragStyle | dragStyle
- Properties inherited from Deltares.Geometry.Forms.DrawingObject
virtual bool | CanResize [get]
Boolean which indicates if a drawing object can be resized. More...
virtual bool | Selected [get, set]
Boolean which indicates if a drawing object is currently selected. More...
string | ToolTip [get]
Description which is shown as a tooltip when the mouse hovers over drawing object. More...
string | Name [get, set]
Gets or sets the name of a drawing object. More...
bool | IsVisible [get, set]
bool | HasBeenUpdated [get, set]
virtual bool | IsDragableOnReslultMode [get]
virtual int | Layer [get, set]
object | DataObject [get, set]
- Properties inherited from Deltares.Geometry.Forms.IDrawingObject
string | Name [get, set]
bool | IsVisible [get, set]
bool | HasBeenUpdated [get, set]
Gets or sets the update status of a drawing object. More...
bool | IsDragableOnReslultMode [get]
- Properties inherited from Deltares.Standard.Forms.IShape
object | DataObject [get, set]
int | Layer [get]

Member Function Documentation

override void Deltares.Geotechnics.Forms.DrawingHeadLine.SetDataObject ( object aDataObject )
virtual

Sets the geotechnics entity that this drawing object represents

Reimplemented from Deltares.Geometry.Forms.DrawingPointString.

Generated on Tue Dec 15 2015 18:14:05 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • DrawingHeadLine
Deltares.Geotechnics.Forms.DrawingHeadLine Member List

This is the complete list of members for Deltares.Geotechnics.Forms.DrawingHeadLine, including all inherited members.

AllowDrop(object data) | Deltares.Geometry.Forms.DrawingObject | virtual
BeginMove(IProjection projection, Point2D startPosition) (defined in Deltares.Geometry.Forms.DrawingPointString) | Deltares.Geometry.Forms.DrawingPointString | virtual
CanResize | Deltares.Geometry.Forms.DrawingObject |
CheckHitForSelection(IProjection projection, Point3D point, double tolerance) | Deltares.Geometry.Forms.DrawingObject | virtual
ContainsPoint(IProjection projection, Point point) | Deltares.Geometry.Forms.DrawingObject | virtual
DataItemAt(Point point, Projection projection) (defined in Deltares.Geometry.Forms.DrawingPointString) | Deltares.Geometry.Forms.DrawingPointString | virtual
DataObject (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
dragStyle (defined in Deltares.Geometry.Forms.DrawingPointString) | Deltares.Geometry.Forms.DrawingPointString | protected
Draw(GraphicsInfo info) | Deltares.Geometry.Forms.DrawingObject | virtual
Draw3D(GraphicsInfo info) | Deltares.Geotechnics.Forms.DrawingWaternetPointString | virtual
DrawingHeadLine() (defined in Deltares.Geotechnics.Forms.DrawingHeadLine) | Deltares.Geotechnics.Forms.DrawingHeadLine |
DrawingObject() (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
DrawingPointString() (defined in Deltares.Geometry.Forms.DrawingPointString) | Deltares.Geometry.Forms.DrawingPointString |
DrawingPointString(Color lineColor, Color backgroundColor, int layer) (defined in Deltares.Geometry.Forms.DrawingPointString) | Deltares.Geometry.Forms.DrawingPointString |
DrawingPointString(DragStyle dragStyle, Color lineColor, Color backgroundColor, int layer) (defined in Deltares.Geometry.Forms.DrawingPointString) | Deltares.Geometry.Forms.DrawingPointString |
DrawingPointString(DashStyle dashStyle, Color lineColor, Color backgroundColor, int layer) (defined in Deltares.Geometry.Forms.DrawingPointString) | Deltares.Geometry.Forms.DrawingPointString |
DrawingPointString(DragStyle dragStyle, DashStyle dashStyle, Color lineColor, Color backgroundColor, int layer) (defined in Deltares.Geometry.Forms.DrawingPointString) | Deltares.Geometry.Forms.DrawingPointString |
DrawingWaternetPointString(DragStyle dragStyle, Color lineColor, Color backgroundColor, int layer) (defined in Deltares.Geotechnics.Forms.DrawingWaternetPointString) | Deltares.Geotechnics.Forms.DrawingWaternetPointString |
DrawingWaternetPointString(DragStyle dragStyle, DashStyle dashStyle, Color lineColor, Color backgroundColor, int layer) (defined in Deltares.Geotechnics.Forms.DrawingWaternetPointString) | Deltares.Geotechnics.Forms.DrawingWaternetPointString |
DrawLabel(GraphicsInfo info) | Deltares.Geotechnics.Forms.DrawingWaternetPointString | virtual
Drop(object data) | Deltares.Geometry.Forms.DrawingObject | virtual
EndMove(IProjection projection, Point2D startPosition, SizeF worldSize) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetCardinalDirectionOnEdgeContainingPoint(Point point) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetDataObject() | Deltares.Geometry.Forms.DrawingPointString | virtual
GetExtents(IProjection projection) | Deltares.Geometry.Forms.DrawingObject | virtual
GetPoints() (defined in Deltares.Geometry.Forms.DrawingPointString) | Deltares.Geometry.Forms.DrawingPointString | protected
GetScaled3DPoint(IProjection projection, Point3D aOrginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScaled3DPoint(IProjection projection, Point3D aOrginalPoint, ref Point3D aPointTobeScaled) | Deltares.Geometry.Forms.DrawingObject |
GetScaledXPoint(IProjection projection, double aOrginalCordinate) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, Point2D orginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, Point3D orginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, double x, double z) | Deltares.Geometry.Forms.DrawingObject |
GetStandardSize(object aDraw3DInterface, Point3D aPoint3D) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetThickness(GraphicsInfo info) | Deltares.Geometry.Forms.DrawingObject | protectedvirtual
HasBeenUpdated (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
IsDragableOnReslultMode (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
IsVisible (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
Layer (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
Move(IProjection projection, Point2D startPosition, SizeF worldSize) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
Name | Deltares.Geometry.Forms.DrawingObject |
OnBeginDrag(IProjection projection, Point3D aBeginDragDropPoint, bool isIndividualDrag) | Deltares.Geometry.Forms.DrawingObject | virtual
OnDragging(IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D) | Deltares.Geometry.Forms.DrawingObject | virtual
OnEndDrag(IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D) | Deltares.Geometry.Forms.DrawingObject | virtual
Selected | Deltares.Geometry.Forms.DrawingObject |
SetDataObject(object dataobject) | Deltares.Geotechnics.Forms.DrawingHeadLine | virtual
ToolTip | Deltares.Geometry.Forms.DrawingObject |
ToString() (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
UpdateDataDragDrop(Point3D aBeginDragPoint, Vector3D vector) | Deltares.Geometry.Forms.DrawingPointString | virtual
Deltares::Geometry::Forms::DrawingObject.UpdateDataDragDrop(Vector3D aVect3D, List< IDrawingObject > aDraggedObjects) | Deltares.Geometry.Forms.DrawingObject | virtual
Generated on Tue Dec 15 2015 18:14:05 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.Forms.DrawingLayer Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • DrawingLayer
Public Member Functions | Protected Attributes | Properties | List of all members
Deltares.Geotechnics.Forms.DrawingLayer Class Reference
Inheritance diagram for Deltares.Geotechnics.Forms.DrawingLayer:
Deltares.Geometry.Forms.DrawingObject Deltares.Geometry.Forms.IDrawingObject Deltares.Standard.Forms.IShape Deltares.DSoilModel.Forms.DrawingBoringLayer

Public Member Functions

override void | SetDataObject (object dataObject)
override The SetDataObject() Method More...
override object | GetDataObject ()
override The GetDataObject() Method And Rturns DataObject of SoilSurface More...
override bool | AllowDrop (object data)
Boolean which indicates if other drawing objects can be dropped on given drawing objects More...
override void | Drop (object data)
Ends a drag-drop operation More...
override Rectangle | GetExtents (IProjection projection)
Returns the bounding box of the shape. More...
override bool | ContainsPoint (IProjection projection, Point point)
Determines if a given point screen coordinate is within the drawing object. More...
override void | Draw3D (GraphicsInfo info)
override The Draw3D() Method More...
override void | DrawLabel (GraphicsInfo info)
Renders a label or tooltip to provide some information in text for this object. More...
- Public Member Functions inherited from Deltares.Geometry.Forms.DrawingObject
Point3D | GetScaled3DPoint (IProjection projection, Point3D aOrginalPoint)
Converts the 3DPoint to screen coordinates More...
Point3D | GetScreenPoint (IProjection projection, Point2D orginalPoint)
Converts Point from 3D space to screen coordinates, assuming Y = 0 More...
Point3D | GetScreenPoint (IProjection projection, Point3D orginalPoint)
Converts Point from 3D space to screen coordinates More...
Point3D | GetScreenPoint (IProjection projection, double x, double z)
Converts 3D x, y coordinates to screen coordinates, assuming Y = 0 More...
override string | ToString ()
virtual void | UpdateDataDragDrop (Vector3D aVect3D, List< IDrawingObject > aDraggedObjects)
Update the position and or orientation of a drawing object as the user is dragging it. More...
virtual void | UpdateDataDragDrop (Point3D aBeginDragPoint, Vector3D vector)
Update the position and or orientation of a drawing object as the user is dragging it. More...
virtual void | OnBeginDrag (IProjection projection, Point3D aBeginDragDropPoint, bool isIndividualDrag)
Method which is called when the user initiates a drag-drop operation More...
virtual CardinalDirection | GetCardinalDirectionOnEdgeContainingPoint (Point point)
virtual void | OnDragging (IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D)
Method which is called during drag-drop operations More...
virtual void | OnEndDrag (IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D)
Method which is called when the user ends a drag-drop operation. More...
virtual bool | CheckHitForSelection (IProjection projection, Point3D point, double tolerance)
Check if given point coordinates intersect the rendered drawing object. More...
virtual double | GetStandardSize (object aDraw3DInterface, Point3D aPoint3D)
void | GetScaled3DPoint (IProjection projection, Point3D aOrginalPoint, ref Point3D aPointTobeScaled)
Converts the 3DPoint to screen coordinates More...
double | GetScaledXPoint (IProjection projection, double aOrginalCordinate)
Converts X Coordinate in 3D space to a screen X Coordinate More...
virtual void | Draw (GraphicsInfo info)
Render this object in 3D space. More...
virtual void | Move (IProjection projection, Point2D startPosition, SizeF worldSize)
virtual void | BeginMove (IProjection projection, Point2D startPosition)
virtual void | EndMove (IProjection projection, Point2D startPosition, SizeF worldSize)
virtual IEnumerable< object > | DataItemAt (Point point, Projection projection)

Protected Attributes

GeometryPoint | insertionPoint = new GeometryPoint(0, 0, 0)
List< Point2D > | points = new List<Point2D>()
SoilLayer1D | soilLayer = null
double | width = 10

Properties

double | Width [get, set]
GeometryPoint | InsertionPoint [get, set]
- Properties inherited from Deltares.Geometry.Forms.DrawingObject
virtual bool | CanResize [get]
Boolean which indicates if a drawing object can be resized. More...
virtual bool | Selected [get, set]
Boolean which indicates if a drawing object is currently selected. More...
string | ToolTip [get]
Description which is shown as a tooltip when the mouse hovers over drawing object. More...
string | Name [get, set]
Gets or sets the name of a drawing object. More...
bool | IsVisible [get, set]
bool | HasBeenUpdated [get, set]
virtual bool | IsDragableOnReslultMode [get]
virtual int | Layer [get, set]
object | DataObject [get, set]
- Properties inherited from Deltares.Geometry.Forms.IDrawingObject
string | Name [get, set]
bool | IsVisible [get, set]
bool | HasBeenUpdated [get, set]
Gets or sets the update status of a drawing object. More...
bool | IsDragableOnReslultMode [get]
- Properties inherited from Deltares.Standard.Forms.IShape
object | DataObject [get, set]
int | Layer [get]

Additional Inherited Members

- Protected Member Functions inherited from Deltares.Geometry.Forms.DrawingObject
virtual int GetThickness (GraphicsInfo info)
Gets the thickness in screen pixels of a drawing object. More...

Member Function Documentation

override bool Deltares.Geotechnics.Forms.DrawingLayer.AllowDrop ( object data )
virtual

Boolean which indicates if other drawing objects can be dropped on given drawing objects

Parameters
data
Returns

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

override bool Deltares.Geotechnics.Forms.DrawingLayer.ContainsPoint | ( | IProjection | projection,
 |  | Point | point
 | ) |  |
virtual

Determines if a given point screen coordinate is within the drawing object.

Parameters
projection | Projection used for drawing
point | Point in screen coordinates.
Returns
True if given point is within the rendered drawing object.

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

override void Deltares.Geotechnics.Forms.DrawingLayer.Draw3D ( GraphicsInfo info )
virtual

override The Draw3D() Method

Parameters
aDraw3D

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

References Deltares.Standard.Forms.DrawingSupport.CreateConvexPolygonBox(), Deltares.Standard.Forms.DrawingSupport.GetDarkerColor(), Deltares.Standard.Forms.DrawingSupport.Material3D(), Deltares.Standard.Forms.DrawingSupport.Pen3D(), and Deltares.Standard.Forms.DrawingSupport.SetIEPDraw3D().

override void Deltares.Geotechnics.Forms.DrawingLayer.DrawLabel ( GraphicsInfo info )
virtual

Renders a label or tooltip to provide some information in text for this object.

Parameters
info Rendering target information.

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

References Deltares.Standard.Forms.DrawingSupport.DrawLabelAtPoint(), Deltares.Standard.Forms.DrawingSupport.GetDarkerColor(), and Deltares.Standard.Forms.DrawingSupport.GetLighterColor().

override void Deltares.Geotechnics.Forms.DrawingLayer.Drop ( object data )
virtual

Ends a drag-drop operation

Parameters
data

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

override object Deltares.Geotechnics.Forms.DrawingLayer.GetDataObject ( )
virtual

override The GetDataObject() Method And Rturns DataObject of SoilSurface

Returns

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

override Rectangle Deltares.Geotechnics.Forms.DrawingLayer.GetExtents ( IProjection projection )
virtual

Returns the bounding box of the shape.

Parameters
projection Projection used for drawing.
Returns
The bounding box of the shape; Null if none can be determined.

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

override void Deltares.Geotechnics.Forms.DrawingLayer.SetDataObject ( object dataObject )
virtual

override The SetDataObject() Method

Parameters
aDataObject

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

Generated on Tue Dec 15 2015 18:14:06 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • DrawingLayer
Deltares.Geotechnics.Forms.DrawingLayer Member List

This is the complete list of members for Deltares.Geotechnics.Forms.DrawingLayer, including all inherited members.

AllowDrop(object data) | Deltares.Geotechnics.Forms.DrawingLayer | virtual
BeginMove(IProjection projection, Point2D startPosition) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
CanResize | Deltares.Geometry.Forms.DrawingObject |
CheckHitForSelection(IProjection projection, Point3D point, double tolerance) | Deltares.Geometry.Forms.DrawingObject | virtual
ContainsPoint(IProjection projection, Point point) | Deltares.Geotechnics.Forms.DrawingLayer | virtual
DataItemAt(Point point, Projection projection) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
DataObject (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
Draw(GraphicsInfo info) | Deltares.Geometry.Forms.DrawingObject | virtual
Draw3D(GraphicsInfo info) | Deltares.Geotechnics.Forms.DrawingLayer | virtual
DrawingLayer() (defined in Deltares.Geotechnics.Forms.DrawingLayer) | Deltares.Geotechnics.Forms.DrawingLayer |
DrawingObject() (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
DrawLabel(GraphicsInfo info) | Deltares.Geotechnics.Forms.DrawingLayer | virtual
Drop(object data) | Deltares.Geotechnics.Forms.DrawingLayer | virtual
EndMove(IProjection projection, Point2D startPosition, SizeF worldSize) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetCardinalDirectionOnEdgeContainingPoint(Point point) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetDataObject() | Deltares.Geotechnics.Forms.DrawingLayer | virtual
GetExtents(IProjection projection) | Deltares.Geotechnics.Forms.DrawingLayer | virtual
GetScaled3DPoint(IProjection projection, Point3D aOrginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScaled3DPoint(IProjection projection, Point3D aOrginalPoint, ref Point3D aPointTobeScaled) | Deltares.Geometry.Forms.DrawingObject |
GetScaledXPoint(IProjection projection, double aOrginalCordinate) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, Point2D orginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, Point3D orginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, double x, double z) | Deltares.Geometry.Forms.DrawingObject |
GetStandardSize(object aDraw3DInterface, Point3D aPoint3D) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetThickness(GraphicsInfo info) | Deltares.Geometry.Forms.DrawingObject | protectedvirtual
HasBeenUpdated (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
insertionPoint (defined in Deltares.Geotechnics.Forms.DrawingLayer) | Deltares.Geotechnics.Forms.DrawingLayer | protected
InsertionPoint (defined in Deltares.Geotechnics.Forms.DrawingLayer) | Deltares.Geotechnics.Forms.DrawingLayer |
IsDragableOnReslultMode (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
IsVisible (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
Layer (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
Move(IProjection projection, Point2D startPosition, SizeF worldSize) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
Name | Deltares.Geometry.Forms.DrawingObject |
OnBeginDrag(IProjection projection, Point3D aBeginDragDropPoint, bool isIndividualDrag) | Deltares.Geometry.Forms.DrawingObject | virtual
OnDragging(IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D) | Deltares.Geometry.Forms.DrawingObject | virtual
OnEndDrag(IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D) | Deltares.Geometry.Forms.DrawingObject | virtual
points (defined in Deltares.Geotechnics.Forms.DrawingLayer) | Deltares.Geotechnics.Forms.DrawingLayer | protected
Selected | Deltares.Geometry.Forms.DrawingObject |
SetDataObject(object dataObject) | Deltares.Geotechnics.Forms.DrawingLayer | virtual
soilLayer (defined in Deltares.Geotechnics.Forms.DrawingLayer) | Deltares.Geotechnics.Forms.DrawingLayer | protected
ToolTip | Deltares.Geometry.Forms.DrawingObject |
ToString() (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
UpdateDataDragDrop(Vector3D aVect3D, List< IDrawingObject > aDraggedObjects) | Deltares.Geometry.Forms.DrawingObject | virtual
UpdateDataDragDrop(Point3D aBeginDragPoint, Vector3D vector) | Deltares.Geometry.Forms.DrawingObject | virtual
Width (defined in Deltares.Geotechnics.Forms.DrawingLayer) | Deltares.Geotechnics.Forms.DrawingLayer |
width (defined in Deltares.Geotechnics.Forms.DrawingLayer) | Deltares.Geotechnics.Forms.DrawingLayer | protected
Generated on Tue Dec 15 2015 18:14:06 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.Forms.DrawingLocalisedGeometryPointString Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • DrawingLocalisedGeometryPointString
Public Member Functions | List of all members
Deltares.Geotechnics.Forms.DrawingLocalisedGeometryPointString Class Reference
Inheritance diagram for Deltares.Geotechnics.Forms.DrawingLocalisedGeometryPointString:
Deltares.Geometry.Forms.DrawingPointString Deltares.Geometry.Forms.DrawingObject Deltares.Geometry.Forms.IDrawingObject Deltares.Standard.Forms.IShape

Public Member Functions

override void | DrawLabel (GraphicsInfo info)
Renders a label or tooltip to provide some information in text for this object. More...
- Public Member Functions inherited from Deltares.Geometry.Forms.DrawingPointString
DrawingPointString (Color lineColor, Color backgroundColor, int layer)
DrawingPointString (DragStyle dragStyle, Color lineColor, Color backgroundColor, int layer)
DrawingPointString (DashStyle dashStyle, Color lineColor, Color backgroundColor, int layer)
DrawingPointString (DragStyle dragStyle, DashStyle dashStyle, Color lineColor, Color backgroundColor, int layer)
override void | SetDataObject (object dataobject)
Sets the geotechnics entity that this drawing object represents More...
override object | GetDataObject ()
Gets the geotechnics entity that this drawing object represents More...
override void | UpdateDataDragDrop (Point3D aBeginDragPoint, Vector3D vector)
override The UpdateDataDragDrop() Method More...
override void | BeginMove (IProjection projection, Point2D startPosition)
override void | Draw3D (GraphicsInfo info)
override The Draw3D() Method More...
override IEnumerable< object > | DataItemAt (Point point, Projection projection)
- Public Member Functions inherited from Deltares.Geometry.Forms.DrawingObject
Point3D | GetScaled3DPoint (IProjection projection, Point3D aOrginalPoint)
Converts the 3DPoint to screen coordinates More...
Point3D | GetScreenPoint (IProjection projection, Point2D orginalPoint)
Converts Point from 3D space to screen coordinates, assuming Y = 0 More...
Point3D | GetScreenPoint (IProjection projection, Point3D orginalPoint)
Converts Point from 3D space to screen coordinates More...
Point3D | GetScreenPoint (IProjection projection, double x, double z)
Converts 3D x, y coordinates to screen coordinates, assuming Y = 0 More...
override string | ToString ()
virtual void | UpdateDataDragDrop (Vector3D aVect3D, List< IDrawingObject > aDraggedObjects)
Update the position and or orientation of a drawing object as the user is dragging it. More...
virtual void | OnBeginDrag (IProjection projection, Point3D aBeginDragDropPoint, bool isIndividualDrag)
Method which is called when the user initiates a drag-drop operation More...
virtual CardinalDirection | GetCardinalDirectionOnEdgeContainingPoint (Point point)
virtual void | OnDragging (IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D)
Method which is called during drag-drop operations More...
virtual void | OnEndDrag (IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D)
Method which is called when the user ends a drag-drop operation. More...
virtual bool | CheckHitForSelection (IProjection projection, Point3D point, double tolerance)
Check if given point coordinates intersect the rendered drawing object. More...
virtual double | GetStandardSize (object aDraw3DInterface, Point3D aPoint3D)
void | GetScaled3DPoint (IProjection projection, Point3D aOrginalPoint, ref Point3D aPointTobeScaled)
Converts the 3DPoint to screen coordinates More...
double | GetScaledXPoint (IProjection projection, double aOrginalCordinate)
Converts X Coordinate in 3D space to a screen X Coordinate More...
virtual bool | ContainsPoint (IProjection projection, Point point)
Determines if a given point screen coordinate is within the drawing object. More...
virtual Rectangle | GetExtents (IProjection projection)
Returns the bounding box of the shape. More...
virtual void | Draw (GraphicsInfo info)
Render this object in 3D space. More...
virtual void | Move (IProjection projection, Point2D startPosition, SizeF worldSize)
virtual void | EndMove (IProjection projection, Point2D startPosition, SizeF worldSize)
virtual bool | AllowDrop (object data)
Boolean which indicates if other drawing objects can be dropped on given drawing objects More...
virtual void | Drop (object data)
Ends a drag-drop operation More...

Additional Inherited Members

- Protected Member Functions inherited from Deltares.Geometry.Forms.DrawingPointString
IList< GeometryPoint > | GetPoints ()
- Protected Member Functions inherited from Deltares.Geometry.Forms.DrawingObject
virtual int | GetThickness (GraphicsInfo info)
Gets the thickness in screen pixels of a drawing object. More...
- Protected Attributes inherited from Deltares.Geometry.Forms.DrawingPointString
DragStyle | dragStyle
- Properties inherited from Deltares.Geometry.Forms.DrawingObject
virtual bool | CanResize [get]
Boolean which indicates if a drawing object can be resized. More...
virtual bool | Selected [get, set]
Boolean which indicates if a drawing object is currently selected. More...
string | ToolTip [get]
Description which is shown as a tooltip when the mouse hovers over drawing object. More...
string | Name [get, set]
Gets or sets the name of a drawing object. More...
bool | IsVisible [get, set]
bool | HasBeenUpdated [get, set]
virtual bool | IsDragableOnReslultMode [get]
virtual int | Layer [get, set]
object | DataObject [get, set]
- Properties inherited from Deltares.Geometry.Forms.IDrawingObject
string | Name [get, set]
bool | IsVisible [get, set]
bool | HasBeenUpdated [get, set]
Gets or sets the update status of a drawing object. More...
bool | IsDragableOnReslultMode [get]
- Properties inherited from Deltares.Standard.Forms.IShape
object | DataObject [get, set]
int | Layer [get]

Member Function Documentation

override void Deltares.Geotechnics.Forms.DrawingLocalisedGeometryPointString.DrawLabel ( GraphicsInfo info )
virtual

Renders a label or tooltip to provide some information in text for this object.

Parameters
info Rendering target information.

Reimplemented from Deltares.Geometry.Forms.DrawingPointString.

References Deltares.Standard.Forms.DrawingSupport.DrawLabelAtPoint(), and Deltares.Standard.Forms.DrawingSupport.GetLighterColor().

Generated on Tue Dec 15 2015 18:14:06 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • DrawingLocalisedGeometryPointString
Deltares.Geotechnics.Forms.DrawingLocalisedGeometryPointString Member List

This is the complete list of members for Deltares.Geotechnics.Forms.DrawingLocalisedGeometryPointString, including all inherited members.

AllowDrop(object data) | Deltares.Geometry.Forms.DrawingObject | virtual
BeginMove(IProjection projection, Point2D startPosition) (defined in Deltares.Geometry.Forms.DrawingPointString) | Deltares.Geometry.Forms.DrawingPointString | virtual
CanResize | Deltares.Geometry.Forms.DrawingObject |
CheckHitForSelection(IProjection projection, Point3D point, double tolerance) | Deltares.Geometry.Forms.DrawingObject | virtual
ContainsPoint(IProjection projection, Point point) | Deltares.Geometry.Forms.DrawingObject | virtual
DataItemAt(Point point, Projection projection) (defined in Deltares.Geometry.Forms.DrawingPointString) | Deltares.Geometry.Forms.DrawingPointString | virtual
DataObject (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
dragStyle (defined in Deltares.Geometry.Forms.DrawingPointString) | Deltares.Geometry.Forms.DrawingPointString | protected
Draw(GraphicsInfo info) | Deltares.Geometry.Forms.DrawingObject | virtual
Draw3D(GraphicsInfo info) | Deltares.Geometry.Forms.DrawingPointString | virtual
DrawingObject() (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
DrawingPointString() (defined in Deltares.Geometry.Forms.DrawingPointString) | Deltares.Geometry.Forms.DrawingPointString |
DrawingPointString(Color lineColor, Color backgroundColor, int layer) (defined in Deltares.Geometry.Forms.DrawingPointString) | Deltares.Geometry.Forms.DrawingPointString |
DrawingPointString(DragStyle dragStyle, Color lineColor, Color backgroundColor, int layer) (defined in Deltares.Geometry.Forms.DrawingPointString) | Deltares.Geometry.Forms.DrawingPointString |
DrawingPointString(DashStyle dashStyle, Color lineColor, Color backgroundColor, int layer) (defined in Deltares.Geometry.Forms.DrawingPointString) | Deltares.Geometry.Forms.DrawingPointString |
DrawingPointString(DragStyle dragStyle, DashStyle dashStyle, Color lineColor, Color backgroundColor, int layer) (defined in Deltares.Geometry.Forms.DrawingPointString) | Deltares.Geometry.Forms.DrawingPointString |
DrawLabel(GraphicsInfo info) | Deltares.Geotechnics.Forms.DrawingLocalisedGeometryPointString | virtual
Drop(object data) | Deltares.Geometry.Forms.DrawingObject | virtual
EndMove(IProjection projection, Point2D startPosition, SizeF worldSize) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetCardinalDirectionOnEdgeContainingPoint(Point point) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetDataObject() | Deltares.Geometry.Forms.DrawingPointString | virtual
GetExtents(IProjection projection) | Deltares.Geometry.Forms.DrawingObject | virtual
GetPoints() (defined in Deltares.Geometry.Forms.DrawingPointString) | Deltares.Geometry.Forms.DrawingPointString | protected
GetScaled3DPoint(IProjection projection, Point3D aOrginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScaled3DPoint(IProjection projection, Point3D aOrginalPoint, ref Point3D aPointTobeScaled) | Deltares.Geometry.Forms.DrawingObject |
GetScaledXPoint(IProjection projection, double aOrginalCordinate) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, Point2D orginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, Point3D orginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, double x, double z) | Deltares.Geometry.Forms.DrawingObject |
GetStandardSize(object aDraw3DInterface, Point3D aPoint3D) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetThickness(GraphicsInfo info) | Deltares.Geometry.Forms.DrawingObject | protectedvirtual
HasBeenUpdated (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
IsDragableOnReslultMode (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
IsVisible (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
Layer (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
Move(IProjection projection, Point2D startPosition, SizeF worldSize) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
Name | Deltares.Geometry.Forms.DrawingObject |
OnBeginDrag(IProjection projection, Point3D aBeginDragDropPoint, bool isIndividualDrag) | Deltares.Geometry.Forms.DrawingObject | virtual
OnDragging(IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D) | Deltares.Geometry.Forms.DrawingObject | virtual
OnEndDrag(IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D) | Deltares.Geometry.Forms.DrawingObject | virtual
Selected | Deltares.Geometry.Forms.DrawingObject |
SetDataObject(object dataobject) | Deltares.Geometry.Forms.DrawingPointString | virtual
ToolTip | Deltares.Geometry.Forms.DrawingObject |
ToString() (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
UpdateDataDragDrop(Point3D aBeginDragPoint, Vector3D vector) | Deltares.Geometry.Forms.DrawingPointString | virtual
Deltares::Geometry::Forms::DrawingObject.UpdateDataDragDrop(Vector3D aVect3D, List< IDrawingObject > aDraggedObjects) | Deltares.Geometry.Forms.DrawingObject | virtual
Generated on Tue Dec 15 2015 18:14:06 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.Forms.DrawingPhreaticLine Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • DrawingPhreaticLine
Public Member Functions | List of all members
Deltares.Geotechnics.Forms.DrawingPhreaticLine Class Reference
Inheritance diagram for Deltares.Geotechnics.Forms.DrawingPhreaticLine:
Deltares.Geotechnics.Forms.DrawingWaternetPointString Deltares.Geometry.Forms.DrawingPointString Deltares.Geometry.Forms.DrawingObject Deltares.Geometry.Forms.IDrawingObject Deltares.Standard.Forms.IShape

Public Member Functions

override void | SetDataObject (object dataobject)
Sets the geotechnics entity that this drawing object represents More...
- Public Member Functions inherited from Deltares.Geotechnics.Forms.DrawingWaternetPointString
DrawingWaternetPointString (DragStyle dragStyle, Color lineColor, Color backgroundColor, int layer)
DrawingWaternetPointString (DragStyle dragStyle, DashStyle dashStyle, Color lineColor, Color backgroundColor, int layer)
override void | DrawLabel (GraphicsInfo info)
Renders a label or tooltip to provide some information in text for this object. More...
override void | Draw3D (GraphicsInfo info)
override The Draw3D() Method More...
- Public Member Functions inherited from Deltares.Geometry.Forms.DrawingPointString
DrawingPointString (Color lineColor, Color backgroundColor, int layer)
DrawingPointString (DragStyle dragStyle, Color lineColor, Color backgroundColor, int layer)
DrawingPointString (DashStyle dashStyle, Color lineColor, Color backgroundColor, int layer)
DrawingPointString (DragStyle dragStyle, DashStyle dashStyle, Color lineColor, Color backgroundColor, int layer)
override object | GetDataObject ()
Gets the geotechnics entity that this drawing object represents More...
override void | UpdateDataDragDrop (Point3D aBeginDragPoint, Vector3D vector)
override The UpdateDataDragDrop() Method More...
override void | BeginMove (IProjection projection, Point2D startPosition)
override IEnumerable< object > | DataItemAt (Point point, Projection projection)
- Public Member Functions inherited from Deltares.Geometry.Forms.DrawingObject
Point3D | GetScaled3DPoint (IProjection projection, Point3D aOrginalPoint)
Converts the 3DPoint to screen coordinates More...
Point3D | GetScreenPoint (IProjection projection, Point2D orginalPoint)
Converts Point from 3D space to screen coordinates, assuming Y = 0 More...
Point3D | GetScreenPoint (IProjection projection, Point3D orginalPoint)
Converts Point from 3D space to screen coordinates More...
Point3D | GetScreenPoint (IProjection projection, double x, double z)
Converts 3D x, y coordinates to screen coordinates, assuming Y = 0 More...
override string | ToString ()
virtual void | UpdateDataDragDrop (Vector3D aVect3D, List< IDrawingObject > aDraggedObjects)
Update the position and or orientation of a drawing object as the user is dragging it. More...
virtual void | OnBeginDrag (IProjection projection, Point3D aBeginDragDropPoint, bool isIndividualDrag)
Method which is called when the user initiates a drag-drop operation More...
virtual CardinalDirection | GetCardinalDirectionOnEdgeContainingPoint (Point point)
virtual void | OnDragging (IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D)
Method which is called during drag-drop operations More...
virtual void | OnEndDrag (IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D)
Method which is called when the user ends a drag-drop operation. More...
virtual bool | CheckHitForSelection (IProjection projection, Point3D point, double tolerance)
Check if given point coordinates intersect the rendered drawing object. More...
virtual double | GetStandardSize (object aDraw3DInterface, Point3D aPoint3D)
void | GetScaled3DPoint (IProjection projection, Point3D aOrginalPoint, ref Point3D aPointTobeScaled)
Converts the 3DPoint to screen coordinates More...
double | GetScaledXPoint (IProjection projection, double aOrginalCordinate)
Converts X Coordinate in 3D space to a screen X Coordinate More...
virtual bool | ContainsPoint (IProjection projection, Point point)
Determines if a given point screen coordinate is within the drawing object. More...
virtual Rectangle | GetExtents (IProjection projection)
Returns the bounding box of the shape. More...
virtual void | Draw (GraphicsInfo info)
Render this object in 3D space. More...
virtual void | Move (IProjection projection, Point2D startPosition, SizeF worldSize)
virtual void | EndMove (IProjection projection, Point2D startPosition, SizeF worldSize)
virtual bool | AllowDrop (object data)
Boolean which indicates if other drawing objects can be dropped on given drawing objects More...
virtual void | Drop (object data)
Ends a drag-drop operation More...

Additional Inherited Members

- Protected Member Functions inherited from Deltares.Geometry.Forms.DrawingPointString
IList< GeometryPoint > | GetPoints ()
- Protected Member Functions inherited from Deltares.Geometry.Forms.DrawingObject
virtual int | GetThickness (GraphicsInfo info)
Gets the thickness in screen pixels of a drawing object. More...
- Protected Attributes inherited from Deltares.Geometry.Forms.DrawingPointString
DragStyle | dragStyle
- Properties inherited from Deltares.Geometry.Forms.DrawingObject
virtual bool | CanResize [get]
Boolean which indicates if a drawing object can be resized. More...
virtual bool | Selected [get, set]
Boolean which indicates if a drawing object is currently selected. More...
string | ToolTip [get]
Description which is shown as a tooltip when the mouse hovers over drawing object. More...
string | Name [get, set]
Gets or sets the name of a drawing object. More...
bool | IsVisible [get, set]
bool | HasBeenUpdated [get, set]
virtual bool | IsDragableOnReslultMode [get]
virtual int | Layer [get, set]
object | DataObject [get, set]
- Properties inherited from Deltares.Geometry.Forms.IDrawingObject
string | Name [get, set]
bool | IsVisible [get, set]
bool | HasBeenUpdated [get, set]
Gets or sets the update status of a drawing object. More...
bool | IsDragableOnReslultMode [get]
- Properties inherited from Deltares.Standard.Forms.IShape
object | DataObject [get, set]
int | Layer [get]

Member Function Documentation

override void Deltares.Geotechnics.Forms.DrawingPhreaticLine.SetDataObject ( object aDataObject )
virtual

Sets the geotechnics entity that this drawing object represents

Reimplemented from Deltares.Geometry.Forms.DrawingPointString.

Generated on Tue Dec 15 2015 18:14:06 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • DrawingPhreaticLine
Deltares.Geotechnics.Forms.DrawingPhreaticLine Member List

This is the complete list of members for Deltares.Geotechnics.Forms.DrawingPhreaticLine, including all inherited members.

AllowDrop(object data) | Deltares.Geometry.Forms.DrawingObject | virtual
BeginMove(IProjection projection, Point2D startPosition) (defined in Deltares.Geometry.Forms.DrawingPointString) | Deltares.Geometry.Forms.DrawingPointString | virtual
CanResize | Deltares.Geometry.Forms.DrawingObject |
CheckHitForSelection(IProjection projection, Point3D point, double tolerance) | Deltares.Geometry.Forms.DrawingObject | virtual
ContainsPoint(IProjection projection, Point point) | Deltares.Geometry.Forms.DrawingObject | virtual
DataItemAt(Point point, Projection projection) (defined in Deltares.Geometry.Forms.DrawingPointString) | Deltares.Geometry.Forms.DrawingPointString | virtual
DataObject (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
dragStyle (defined in Deltares.Geometry.Forms.DrawingPointString) | Deltares.Geometry.Forms.DrawingPointString | protected
Draw(GraphicsInfo info) | Deltares.Geometry.Forms.DrawingObject | virtual
Draw3D(GraphicsInfo info) | Deltares.Geotechnics.Forms.DrawingWaternetPointString | virtual
DrawingObject() (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
DrawingPhreaticLine() (defined in Deltares.Geotechnics.Forms.DrawingPhreaticLine) | Deltares.Geotechnics.Forms.DrawingPhreaticLine |
DrawingPointString() (defined in Deltares.Geometry.Forms.DrawingPointString) | Deltares.Geometry.Forms.DrawingPointString |
DrawingPointString(Color lineColor, Color backgroundColor, int layer) (defined in Deltares.Geometry.Forms.DrawingPointString) | Deltares.Geometry.Forms.DrawingPointString |
DrawingPointString(DragStyle dragStyle, Color lineColor, Color backgroundColor, int layer) (defined in Deltares.Geometry.Forms.DrawingPointString) | Deltares.Geometry.Forms.DrawingPointString |
DrawingPointString(DashStyle dashStyle, Color lineColor, Color backgroundColor, int layer) (defined in Deltares.Geometry.Forms.DrawingPointString) | Deltares.Geometry.Forms.DrawingPointString |
DrawingPointString(DragStyle dragStyle, DashStyle dashStyle, Color lineColor, Color backgroundColor, int layer) (defined in Deltares.Geometry.Forms.DrawingPointString) | Deltares.Geometry.Forms.DrawingPointString |
DrawingWaternetPointString(DragStyle dragStyle, Color lineColor, Color backgroundColor, int layer) (defined in Deltares.Geotechnics.Forms.DrawingWaternetPointString) | Deltares.Geotechnics.Forms.DrawingWaternetPointString |
DrawingWaternetPointString(DragStyle dragStyle, DashStyle dashStyle, Color lineColor, Color backgroundColor, int layer) (defined in Deltares.Geotechnics.Forms.DrawingWaternetPointString) | Deltares.Geotechnics.Forms.DrawingWaternetPointString |
DrawLabel(GraphicsInfo info) | Deltares.Geotechnics.Forms.DrawingWaternetPointString | virtual
Drop(object data) | Deltares.Geometry.Forms.DrawingObject | virtual
EndMove(IProjection projection, Point2D startPosition, SizeF worldSize) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetCardinalDirectionOnEdgeContainingPoint(Point point) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetDataObject() | Deltares.Geometry.Forms.DrawingPointString | virtual
GetExtents(IProjection projection) | Deltares.Geometry.Forms.DrawingObject | virtual
GetPoints() (defined in Deltares.Geometry.Forms.DrawingPointString) | Deltares.Geometry.Forms.DrawingPointString | protected
GetScaled3DPoint(IProjection projection, Point3D aOrginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScaled3DPoint(IProjection projection, Point3D aOrginalPoint, ref Point3D aPointTobeScaled) | Deltares.Geometry.Forms.DrawingObject |
GetScaledXPoint(IProjection projection, double aOrginalCordinate) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, Point2D orginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, Point3D orginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, double x, double z) | Deltares.Geometry.Forms.DrawingObject |
GetStandardSize(object aDraw3DInterface, Point3D aPoint3D) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetThickness(GraphicsInfo info) | Deltares.Geometry.Forms.DrawingObject | protectedvirtual
HasBeenUpdated (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
IsDragableOnReslultMode (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
IsVisible (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
Layer (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
Move(IProjection projection, Point2D startPosition, SizeF worldSize) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
Name | Deltares.Geometry.Forms.DrawingObject |
OnBeginDrag(IProjection projection, Point3D aBeginDragDropPoint, bool isIndividualDrag) | Deltares.Geometry.Forms.DrawingObject | virtual
OnDragging(IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D) | Deltares.Geometry.Forms.DrawingObject | virtual
OnEndDrag(IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D) | Deltares.Geometry.Forms.DrawingObject | virtual
Selected | Deltares.Geometry.Forms.DrawingObject |
SetDataObject(object dataobject) | Deltares.Geotechnics.Forms.DrawingPhreaticLine | virtual
ToolTip | Deltares.Geometry.Forms.DrawingObject |
ToString() (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
UpdateDataDragDrop(Point3D aBeginDragPoint, Vector3D vector) | Deltares.Geometry.Forms.DrawingPointString | virtual
Deltares::Geometry::Forms::DrawingObject.UpdateDataDragDrop(Vector3D aVect3D, List< IDrawingObject > aDraggedObjects) | Deltares.Geometry.Forms.DrawingObject | virtual
Generated on Tue Dec 15 2015 18:14:06 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.Forms.DrawingPiezometricHead Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • DrawingPiezometricHead
Classes | Public Member Functions | Properties | List of all members
Deltares.Geotechnics.Forms.DrawingPiezometricHead Class Reference

Draws the piezometric head. More...

Inheritance diagram for Deltares.Geotechnics.Forms.DrawingPiezometricHead:
Deltares.Geometry.Forms.DrawingObject Deltares.Geometry.Forms.IDrawingObject Deltares.Standard.Forms.IShape

Public Member Functions

override void | SetDataObject (object dataObject)
Sets the geotechnics entity that this drawing object represents More...
override object | GetDataObject ()
Gets the geotechnics entity that this drawing object represents More...
override void | Draw3D (GraphicsInfo info)
override The Draw3D() Method More...
override void | DrawLabel (GraphicsInfo info)
Draws the label. More...
override bool | ContainsPoint (IProjection projection, Point point)
Determines whether the specified projection contains point. More...
- Public Member Functions inherited from Deltares.Geometry.Forms.DrawingObject
Point3D | GetScaled3DPoint (IProjection projection, Point3D aOrginalPoint)
Converts the 3DPoint to screen coordinates More...
Point3D | GetScreenPoint (IProjection projection, Point2D orginalPoint)
Converts Point from 3D space to screen coordinates, assuming Y = 0 More...
Point3D | GetScreenPoint (IProjection projection, Point3D orginalPoint)
Converts Point from 3D space to screen coordinates More...
Point3D | GetScreenPoint (IProjection projection, double x, double z)
Converts 3D x, y coordinates to screen coordinates, assuming Y = 0 More...
override string | ToString ()
virtual void | UpdateDataDragDrop (Vector3D aVect3D, List< IDrawingObject > aDraggedObjects)
Update the position and or orientation of a drawing object as the user is dragging it. More...
virtual void | UpdateDataDragDrop (Point3D aBeginDragPoint, Vector3D vector)
Update the position and or orientation of a drawing object as the user is dragging it. More...
virtual void | OnBeginDrag (IProjection projection, Point3D aBeginDragDropPoint, bool isIndividualDrag)
Method which is called when the user initiates a drag-drop operation More...
virtual CardinalDirection | GetCardinalDirectionOnEdgeContainingPoint (Point point)
virtual void | OnDragging (IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D)
Method which is called during drag-drop operations More...
virtual void | OnEndDrag (IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D)
Method which is called when the user ends a drag-drop operation. More...
virtual bool | CheckHitForSelection (IProjection projection, Point3D point, double tolerance)
Check if given point coordinates intersect the rendered drawing object. More...
virtual double | GetStandardSize (object aDraw3DInterface, Point3D aPoint3D)
void | GetScaled3DPoint (IProjection projection, Point3D aOrginalPoint, ref Point3D aPointTobeScaled)
Converts the 3DPoint to screen coordinates More...
double | GetScaledXPoint (IProjection projection, double aOrginalCordinate)
Converts X Coordinate in 3D space to a screen X Coordinate More...
virtual Rectangle | GetExtents (IProjection projection)
Returns the bounding box of the shape. More...
virtual void | Draw (GraphicsInfo info)
Render this object in 3D space. More...
virtual void | Move (IProjection projection, Point2D startPosition, SizeF worldSize)
virtual void | BeginMove (IProjection projection, Point2D startPosition)
virtual void | EndMove (IProjection projection, Point2D startPosition, SizeF worldSize)
virtual bool | AllowDrop (object data)
Boolean which indicates if other drawing objects can be dropped on given drawing objects More...
virtual void | Drop (object data)
Ends a drag-drop operation More...
virtual IEnumerable< object > | DataItemAt (Point point, Projection projection)

Properties

double | RightMostValue [get, set]
- Properties inherited from Deltares.Geometry.Forms.DrawingObject
virtual bool | CanResize [get]
Boolean which indicates if a drawing object can be resized. More...
virtual bool | Selected [get, set]
Boolean which indicates if a drawing object is currently selected. More...
string | ToolTip [get]
Description which is shown as a tooltip when the mouse hovers over drawing object. More...
string | Name [get, set]
Gets or sets the name of a drawing object. More...
bool | IsVisible [get, set]
bool | HasBeenUpdated [get, set]
virtual bool | IsDragableOnReslultMode [get]
virtual int | Layer [get, set]
object | DataObject [get, set]
- Properties inherited from Deltares.Geometry.Forms.IDrawingObject
string | Name [get, set]
bool | IsVisible [get, set]
bool | HasBeenUpdated [get, set]
Gets or sets the update status of a drawing object. More...
bool | IsDragableOnReslultMode [get]
- Properties inherited from Deltares.Standard.Forms.IShape
object | DataObject [get, set]
int | Layer [get]

Additional Inherited Members

- Protected Member Functions inherited from Deltares.Geometry.Forms.DrawingObject
virtual int GetThickness (GraphicsInfo info)
Gets the thickness in screen pixels of a drawing object. More...

Detailed Description

Draws the piezometric head.

Member Function Documentation

override bool Deltares.Geotechnics.Forms.DrawingPiezometricHead.ContainsPoint | ( | IProjection | projection,
 |  | Point | point
 | ) |  |
virtual

Determines whether the specified projection contains point.

Parameters
projection | The projection.
point | The point.
Returns
true if the specified projection contains point; otherwise, false.

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

override void Deltares.Geotechnics.Forms.DrawingPiezometricHead.Draw3D ( GraphicsInfo info )
virtual

override The Draw3D() Method

Parameters
info The graphics info.

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

References Deltares.Standard.Forms.DrawingSupport.Brush3D(), Deltares.Standard.Forms.DrawingSupport.ColorMaterial3D(), Deltares.Standard.Forms.DrawingSupport.Material3D(), Deltares.Standard.Forms.DrawingSupport.Pen3D(), and Deltares.Standard.Forms.DrawingSupport.SetIEPDraw3D().

override void Deltares.Geotechnics.Forms.DrawingPiezometricHead.DrawLabel ( GraphicsInfo info )
virtual

Draws the label.

Parameters
info The graphics info.

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

override object Deltares.Geotechnics.Forms.DrawingPiezometricHead.GetDataObject ( )
virtual

Gets the geotechnics entity that this drawing object represents

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

override void Deltares.Geotechnics.Forms.DrawingPiezometricHead.SetDataObject ( object aDataObject )
virtual

Sets the geotechnics entity that this drawing object represents

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

Generated on Tue Dec 15 2015 18:14:07 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • DrawingPiezometricHead
Deltares.Geotechnics.Forms.DrawingPiezometricHead Member List

This is the complete list of members for Deltares.Geotechnics.Forms.DrawingPiezometricHead, including all inherited members.

AllowDrop(object data) | Deltares.Geometry.Forms.DrawingObject | virtual
BeginMove(IProjection projection, Point2D startPosition) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
CanResize | Deltares.Geometry.Forms.DrawingObject |
CheckHitForSelection(IProjection projection, Point3D point, double tolerance) | Deltares.Geometry.Forms.DrawingObject | virtual
ContainsPoint(IProjection projection, Point point) | Deltares.Geotechnics.Forms.DrawingPiezometricHead | virtual
DataItemAt(Point point, Projection projection) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
DataObject (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
Draw(GraphicsInfo info) | Deltares.Geometry.Forms.DrawingObject | virtual
Draw3D(GraphicsInfo info) | Deltares.Geotechnics.Forms.DrawingPiezometricHead | virtual
DrawingObject() (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
DrawingPiezometricHead() (defined in Deltares.Geotechnics.Forms.DrawingPiezometricHead) | Deltares.Geotechnics.Forms.DrawingPiezometricHead |
DrawLabel(GraphicsInfo info) | Deltares.Geotechnics.Forms.DrawingPiezometricHead | virtual
Drop(object data) | Deltares.Geometry.Forms.DrawingObject | virtual
EndMove(IProjection projection, Point2D startPosition, SizeF worldSize) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetCardinalDirectionOnEdgeContainingPoint(Point point) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetDataObject() | Deltares.Geotechnics.Forms.DrawingPiezometricHead | virtual
GetExtents(IProjection projection) | Deltares.Geometry.Forms.DrawingObject | virtual
GetScaled3DPoint(IProjection projection, Point3D aOrginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScaled3DPoint(IProjection projection, Point3D aOrginalPoint, ref Point3D aPointTobeScaled) | Deltares.Geometry.Forms.DrawingObject |
GetScaledXPoint(IProjection projection, double aOrginalCordinate) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, Point2D orginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, Point3D orginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, double x, double z) | Deltares.Geometry.Forms.DrawingObject |
GetStandardSize(object aDraw3DInterface, Point3D aPoint3D) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetThickness(GraphicsInfo info) | Deltares.Geometry.Forms.DrawingObject | protectedvirtual
HasBeenUpdated (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
IsDragableOnReslultMode (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
IsVisible (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
Layer (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
Move(IProjection projection, Point2D startPosition, SizeF worldSize) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
Name | Deltares.Geometry.Forms.DrawingObject |
OnBeginDrag(IProjection projection, Point3D aBeginDragDropPoint, bool isIndividualDrag) | Deltares.Geometry.Forms.DrawingObject | virtual
OnDragging(IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D) | Deltares.Geometry.Forms.DrawingObject | virtual
OnEndDrag(IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D) | Deltares.Geometry.Forms.DrawingObject | virtual
RightMostValue (defined in Deltares.Geotechnics.Forms.DrawingPiezometricHead) | Deltares.Geotechnics.Forms.DrawingPiezometricHead |
Selected | Deltares.Geometry.Forms.DrawingObject |
SetDataObject(object dataObject) | Deltares.Geotechnics.Forms.DrawingPiezometricHead | virtual
ToolTip | Deltares.Geometry.Forms.DrawingObject |
ToString() (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
UpdateDataDragDrop(Vector3D aVect3D, List< IDrawingObject > aDraggedObjects) | Deltares.Geometry.Forms.DrawingObject | virtual
UpdateDataDragDrop(Point3D aBeginDragPoint, Vector3D vector) | Deltares.Geometry.Forms.DrawingObject | virtual
Generated on Tue Dec 15 2015 18:14:07 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.Forms.DrawingPreConsolidationStress Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • DrawingPreConsolidationStress
Public Member Functions | List of all members
Deltares.Geotechnics.Forms.DrawingPreConsolidationStress Class Reference

Drawable for an instance of PreConsolidationStress. More...

Inheritance diagram for Deltares.Geotechnics.Forms.DrawingPreConsolidationStress:
Deltares.Geometry.Forms.DrawingPoint Deltares.Geometry.Forms.DrawingObject Deltares.Geometry.Forms.IDrawingObject Deltares.Standard.Forms.IShape

Public Member Functions

DrawingPreConsolidationStress ()
Initializes a new instance of the DrawingPreConsolidationStress class at Layer -18. More...
override void | SetDataObject (object aDataObject)
Stes the data object for this.dataPoint More...
override Rectangle | GetExtents (IProjection projection)
Returns the bounding box of the shape. More...
override void | Draw3D (GraphicsInfo info)
Render this drawing object in 3D space. More...
override void | DrawLabel (GraphicsInfo info)
Renders a label or tooltip to provide some information in text for this object. More...
- Public Member Functions inherited from Deltares.Geometry.Forms.DrawingPoint
DrawingPoint (GeometryPoint aPoint)
override object | GetDataObject ()
Gets the IDataobject for this.dataPoint. More...
override bool | ContainsPoint (IProjection projection, Point screenPoint)
Determines if a given point screen coordinate is within the drawing object. More...
override void | OnBeginDrag (IProjection projection, Point3D beginDragDropPoint, bool isIndividualDrag)
Method which is called when the user initiates a drag-drop operation More...
override void | UpdateDataDragDrop (Point3D beginDragPoint, Vector3D vector)
Updates the geometry after publisherEventArgs drag and drop. More...
override void | OnEndDrag (IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D)
Method which is called when the user ends a drag-drop operation. More...
- Public Member Functions inherited from Deltares.Geometry.Forms.DrawingObject
Point3D | GetScaled3DPoint (IProjection projection, Point3D aOrginalPoint)
Converts the 3DPoint to screen coordinates More...
Point3D | GetScreenPoint (IProjection projection, Point2D orginalPoint)
Converts Point from 3D space to screen coordinates, assuming Y = 0 More...
Point3D | GetScreenPoint (IProjection projection, Point3D orginalPoint)
Converts Point from 3D space to screen coordinates More...
Point3D | GetScreenPoint (IProjection projection, double x, double z)
Converts 3D x, y coordinates to screen coordinates, assuming Y = 0 More...
override string | ToString ()
virtual void | UpdateDataDragDrop (Vector3D aVect3D, List< IDrawingObject > aDraggedObjects)
Update the position and or orientation of a drawing object as the user is dragging it. More...
virtual CardinalDirection | GetCardinalDirectionOnEdgeContainingPoint (Point point)
virtual void | OnDragging (IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D)
Method which is called during drag-drop operations More...
virtual bool | CheckHitForSelection (IProjection projection, Point3D point, double tolerance)
Check if given point coordinates intersect the rendered drawing object. More...
virtual double | GetStandardSize (object aDraw3DInterface, Point3D aPoint3D)
void | GetScaled3DPoint (IProjection projection, Point3D aOrginalPoint, ref Point3D aPointTobeScaled)
Converts the 3DPoint to screen coordinates More...
double | GetScaledXPoint (IProjection projection, double aOrginalCordinate)
Converts X Coordinate in 3D space to a screen X Coordinate More...
virtual void | Draw (GraphicsInfo info)
Render this object in 3D space. More...
virtual void | Move (IProjection projection, Point2D startPosition, SizeF worldSize)
virtual void | BeginMove (IProjection projection, Point2D startPosition)
virtual void | EndMove (IProjection projection, Point2D startPosition, SizeF worldSize)
virtual bool | AllowDrop (object data)
Boolean which indicates if other drawing objects can be dropped on given drawing objects More...
virtual void | Drop (object data)
Ends a drag-drop operation More...
virtual IEnumerable< object > | DataItemAt (Point point, Projection projection)

Additional Inherited Members

- Static Public Member Functions inherited from Deltares.Geometry.Forms.DrawingPoint
static void | DrawRoundLabelAtPoint (Graphics graphics, Point screenPoint, string text, Brush textBrush, Brush backgroundBrush, Brush borderBrush)
static void | BeginMovePoints ()
static void | Move (GeometryPoint point, Vector3D vector, Point3D beginDragPoint)
- Protected Member Functions inherited from Deltares.Geometry.Forms.DrawingObject
virtual int | GetThickness (GraphicsInfo info)
Gets the thickness in screen pixels of a drawing object. More...
- Protected Attributes inherited from Deltares.Geometry.Forms.DrawingPoint
Point2D | point
The rendered point in screen coordinates. More...
- Properties inherited from Deltares.Geometry.Forms.DrawingPoint
static bool | Highlighted [get, set]
- Properties inherited from Deltares.Geometry.Forms.DrawingObject
virtual bool | CanResize [get]
Boolean which indicates if a drawing object can be resized. More...
virtual bool | Selected [get, set]
Boolean which indicates if a drawing object is currently selected. More...
string | ToolTip [get]
Description which is shown as a tooltip when the mouse hovers over drawing object. More...
string | Name [get, set]
Gets or sets the name of a drawing object. More...
bool | IsVisible [get, set]
bool | HasBeenUpdated [get, set]
virtual bool | IsDragableOnReslultMode [get]
virtual int | Layer [get, set]
object | DataObject [get, set]
- Properties inherited from Deltares.Geometry.Forms.IDrawingObject
string | Name [get, set]
bool | IsVisible [get, set]
bool | HasBeenUpdated [get, set]
Gets or sets the update status of a drawing object. More...
bool | IsDragableOnReslultMode [get]
- Properties inherited from Deltares.Standard.Forms.IShape
object | DataObject [get, set]
int | Layer [get]

Detailed Description

Drawable for an instance of PreConsolidationStress.

Constructor & Destructor Documentation

Deltares.Geotechnics.Forms.DrawingPreConsolidationStress.DrawingPreConsolidationStress ( )

Initializes a new instance of the DrawingPreConsolidationStress class at Layer -18.

Member Function Documentation

override void Deltares.Geotechnics.Forms.DrawingPreConsolidationStress.Draw3D ( GraphicsInfo info )
virtual

Render this drawing object in 3D space.

Parameters
info Rendering target information.

Reimplemented from Deltares.Geometry.Forms.DrawingPoint.

References Deltares.Standard.Forms.DrawingSupport.ColorMaterial3D(), and Deltares.Standard.Forms.DrawingSupport.DrawPointSelector().

override void Deltares.Geotechnics.Forms.DrawingPreConsolidationStress.DrawLabel ( GraphicsInfo info )
virtual

Renders a label or tooltip to provide some information in text for this object.

Parameters
info Rendering target information.

Reimplemented from Deltares.Geometry.Forms.DrawingPoint.

References Deltares.Standard.Forms.DrawingSupport.DrawLabelAtPoint().

override Rectangle Deltares.Geotechnics.Forms.DrawingPreConsolidationStress.GetExtents ( IProjection projection )
virtual

Returns the bounding box of the shape.

Parameters
projection Projection used for drawing.
Returns
The bounding box of the shape; Null if none can be determined.

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

override void Deltares.Geotechnics.Forms.DrawingPreConsolidationStress.SetDataObject ( object aDataObject )
virtual

Stes the data object for this.dataPoint

Parameters
aDataObject

Reimplemented from Deltares.Geometry.Forms.DrawingPoint.

Generated on Tue Dec 15 2015 18:14:07 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • DrawingPreConsolidationStress
Deltares.Geotechnics.Forms.DrawingPreConsolidationStress Member List

This is the complete list of members for Deltares.Geotechnics.Forms.DrawingPreConsolidationStress, including all inherited members.

AllowDrop(object data) | Deltares.Geometry.Forms.DrawingObject | virtual
BeginMove(IProjection projection, Point2D startPosition) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
BeginMovePoints() (defined in Deltares.Geometry.Forms.DrawingPoint) | Deltares.Geometry.Forms.DrawingPoint | static
CanResize | Deltares.Geometry.Forms.DrawingObject |
CheckHitForSelection(IProjection projection, Point3D point, double tolerance) | Deltares.Geometry.Forms.DrawingObject | virtual
ContainsPoint(IProjection projection, Point screenPoint) | Deltares.Geometry.Forms.DrawingPoint | virtual
DataItemAt(Point point, Projection projection) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
DataObject (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
Draw(GraphicsInfo info) | Deltares.Geometry.Forms.DrawingObject | virtual
Draw3D(GraphicsInfo info) | Deltares.Geotechnics.Forms.DrawingPreConsolidationStress | virtual
DrawingObject() (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
DrawingPoint() (defined in Deltares.Geometry.Forms.DrawingPoint) | Deltares.Geometry.Forms.DrawingPoint |
DrawingPoint(GeometryPoint aPoint) (defined in Deltares.Geometry.Forms.DrawingPoint) | Deltares.Geometry.Forms.DrawingPoint |
DrawingPreConsolidationStress() | Deltares.Geotechnics.Forms.DrawingPreConsolidationStress |
DrawLabel(GraphicsInfo info) | Deltares.Geotechnics.Forms.DrawingPreConsolidationStress | virtual
DrawRoundLabelAtPoint(Graphics graphics, Point screenPoint, string text, Brush textBrush, Brush backgroundBrush, Brush borderBrush) (defined in Deltares.Geometry.Forms.DrawingPoint) | Deltares.Geometry.Forms.DrawingPoint | static
Drop(object data) | Deltares.Geometry.Forms.DrawingObject | virtual
EndMove(IProjection projection, Point2D startPosition, SizeF worldSize) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetCardinalDirectionOnEdgeContainingPoint(Point point) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetDataObject() | Deltares.Geometry.Forms.DrawingPoint | virtual
GetExtents(IProjection projection) | Deltares.Geotechnics.Forms.DrawingPreConsolidationStress | virtual
GetScaled3DPoint(IProjection projection, Point3D aOrginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScaled3DPoint(IProjection projection, Point3D aOrginalPoint, ref Point3D aPointTobeScaled) | Deltares.Geometry.Forms.DrawingObject |
GetScaledXPoint(IProjection projection, double aOrginalCordinate) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, Point2D orginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, Point3D orginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, double x, double z) | Deltares.Geometry.Forms.DrawingObject |
GetStandardSize(object aDraw3DInterface, Point3D aPoint3D) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetThickness(GraphicsInfo info) | Deltares.Geometry.Forms.DrawingObject | protectedvirtual
HasBeenUpdated (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
Highlighted (defined in Deltares.Geometry.Forms.DrawingPoint) | Deltares.Geometry.Forms.DrawingPoint | static
IsDragableOnReslultMode (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
IsVisible (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
Layer (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
Move(GeometryPoint point, Vector3D vector, Point3D beginDragPoint) (defined in Deltares.Geometry.Forms.DrawingPoint) | Deltares.Geometry.Forms.DrawingPoint | static
Move(IProjection projection, Point2D startPosition, SizeF worldSize) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
Name | Deltares.Geometry.Forms.DrawingObject |
OnBeginDrag(IProjection projection, Point3D beginDragDropPoint, bool isIndividualDrag) | Deltares.Geometry.Forms.DrawingPoint | virtual
OnDragging(IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D) | Deltares.Geometry.Forms.DrawingObject | virtual
OnEndDrag(IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D) | Deltares.Geometry.Forms.DrawingPoint | virtual
point | Deltares.Geometry.Forms.DrawingPoint | protected
Selected | Deltares.Geometry.Forms.DrawingObject |
SetDataObject(object aDataObject) | Deltares.Geotechnics.Forms.DrawingPreConsolidationStress | virtual
ToolTip | Deltares.Geometry.Forms.DrawingObject |
ToString() (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
UpdateDataDragDrop(Point3D beginDragPoint, Vector3D vector) | Deltares.Geometry.Forms.DrawingPoint | virtual
Deltares::Geometry::Forms::DrawingObject.UpdateDataDragDrop(Vector3D aVect3D, List< IDrawingObject > aDraggedObjects) | Deltares.Geometry.Forms.DrawingObject | virtual
Generated on Tue Dec 15 2015 18:14:07 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.Forms.DrawingRevetment Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • DrawingRevetment
Public Member Functions | Protected Member Functions | Properties | List of all members
Deltares.Geotechnics.Forms.DrawingRevetment Class Reference

Draws the piezometric head. More...

Inheritance diagram for Deltares.Geotechnics.Forms.DrawingRevetment:
Deltares.Geometry.Forms.DrawingObject Deltares.Geometry.Forms.IDrawingObject Deltares.Standard.Forms.IShape Deltares.Geotechnics.Forms.DrawingAsphaltRevetment Deltares.Geotechnics.Forms.DrawingRoughnessRevetment

Public Member Functions

override object | GetDataObject ()
Gets the geotechnics entity that this drawing object represents More...
override void | SetDataObject (object dataObject)
Sets the geotechnics entity that this drawing object represents More...
override void | Draw3D (GraphicsInfo info)
override The Draw3D() Method More...
override void | DrawLabel (GraphicsInfo info)
Draws the label. More...
override bool | ContainsPoint (IProjection projection, Point point)
Determines whether the specified projection contains point. More...
override void | OnBeginDrag (IProjection projection, Point3D beginDragDropPoint, bool isIndividualDrag)
Method which is called when the user initiates a drag-drop operation More...
override void | OnDragging (IProjection projection, Point3D currentDragPoint, Vector3D vector)
Method which is called during drag-drop operations More...
- Public Member Functions inherited from Deltares.Geometry.Forms.DrawingObject
Point3D | GetScaled3DPoint (IProjection projection, Point3D aOrginalPoint)
Converts the 3DPoint to screen coordinates More...
Point3D | GetScreenPoint (IProjection projection, Point2D orginalPoint)
Converts Point from 3D space to screen coordinates, assuming Y = 0 More...
Point3D | GetScreenPoint (IProjection projection, Point3D orginalPoint)
Converts Point from 3D space to screen coordinates More...
Point3D | GetScreenPoint (IProjection projection, double x, double z)
Converts 3D x, y coordinates to screen coordinates, assuming Y = 0 More...
override string | ToString ()
virtual void | UpdateDataDragDrop (Vector3D aVect3D, List< IDrawingObject > aDraggedObjects)
Update the position and or orientation of a drawing object as the user is dragging it. More...
virtual void | UpdateDataDragDrop (Point3D aBeginDragPoint, Vector3D vector)
Update the position and or orientation of a drawing object as the user is dragging it. More...
virtual CardinalDirection | GetCardinalDirectionOnEdgeContainingPoint (Point point)
virtual void | OnEndDrag (IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D)
Method which is called when the user ends a drag-drop operation. More...
virtual bool | CheckHitForSelection (IProjection projection, Point3D point, double tolerance)
Check if given point coordinates intersect the rendered drawing object. More...
virtual double | GetStandardSize (object aDraw3DInterface, Point3D aPoint3D)
void | GetScaled3DPoint (IProjection projection, Point3D aOrginalPoint, ref Point3D aPointTobeScaled)
Converts the 3DPoint to screen coordinates More...
double | GetScaledXPoint (IProjection projection, double aOrginalCordinate)
Converts X Coordinate in 3D space to a screen X Coordinate More...
virtual Rectangle | GetExtents (IProjection projection)
Returns the bounding box of the shape. More...
virtual void | Draw (GraphicsInfo info)
Render this object in 3D space. More...
virtual void | Move (IProjection projection, Point2D startPosition, SizeF worldSize)
virtual void | BeginMove (IProjection projection, Point2D startPosition)
virtual void | EndMove (IProjection projection, Point2D startPosition, SizeF worldSize)
virtual bool | AllowDrop (object data)
Boolean which indicates if other drawing objects can be dropped on given drawing objects More...
virtual void | Drop (object data)
Ends a drag-drop operation More...
virtual IEnumerable< object > | DataItemAt (Point point, Projection projection)

Protected Member Functions

virtual Color | GetRevetmentColor ()
- Protected Member Functions inherited from Deltares.Geometry.Forms.DrawingObject
virtual int | GetThickness (GraphicsInfo info)
Gets the thickness in screen pixels of a drawing object. More...

Properties

int | LineHeight [get, set]
- Properties inherited from Deltares.Geometry.Forms.DrawingObject
virtual bool | CanResize [get]
Boolean which indicates if a drawing object can be resized. More...
virtual bool | Selected [get, set]
Boolean which indicates if a drawing object is currently selected. More...
string | ToolTip [get]
Description which is shown as a tooltip when the mouse hovers over drawing object. More...
string | Name [get, set]
Gets or sets the name of a drawing object. More...
bool | IsVisible [get, set]
bool | HasBeenUpdated [get, set]
virtual bool | IsDragableOnReslultMode [get]
virtual int | Layer [get, set]
object | DataObject [get, set]
- Properties inherited from Deltares.Geometry.Forms.IDrawingObject
string | Name [get, set]
bool | IsVisible [get, set]
bool | HasBeenUpdated [get, set]
Gets or sets the update status of a drawing object. More...
bool | IsDragableOnReslultMode [get]
- Properties inherited from Deltares.Standard.Forms.IShape
object | DataObject [get, set]
int | Layer [get]

Detailed Description

Draws the piezometric head.

Member Function Documentation

override bool Deltares.Geotechnics.Forms.DrawingRevetment.ContainsPoint | ( | IProjection | projection,
 |  | Point | point
 | ) |  |
virtual

Determines whether the specified projection contains point.

Parameters
projection | The projection.
point | The point.
Returns
true if the specified projection contains point; otherwise, false.

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

override void Deltares.Geotechnics.Forms.DrawingRevetment.Draw3D ( GraphicsInfo info )
virtual

override The Draw3D() Method

Parameters
info The graphics info.

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

References Deltares.Standard.Forms.DrawingSupport.Brush3D(), Deltares.Standard.Forms.DrawingSupport.ColorMaterial3D(), Deltares.Standard.Forms.DrawingSupport.Line3D(), Deltares.Standard.Forms.DrawingSupport.Material3D(), Deltares.Standard.Forms.DrawingSupport.Pen3D(), and Deltares.Standard.Forms.DrawingSupport.SetIEPDraw3D().

override void Deltares.Geotechnics.Forms.DrawingRevetment.DrawLabel ( GraphicsInfo info )
virtual

Draws the label.

Parameters
info The graphics info.

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

References Deltares.Standard.Forms.DrawingSupport.DrawLabelAtPoint().

override object Deltares.Geotechnics.Forms.DrawingRevetment.GetDataObject ( )
virtual

Gets the geotechnics entity that this drawing object represents

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

override void Deltares.Geotechnics.Forms.DrawingRevetment.OnBeginDrag | ( | IProjection | projection,
 |  | Point3D | aBeginDragDropPoint,
 |  | bool | isIndividualDrag
 | ) |  |
virtual

Method which is called when the user initiates a drag-drop operation

Parameters
projection | Current projection of 3D to screen coordinates.
aBeginDragDropPoint | Initial position of the mouse pointer.
isIndividualDrag

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

override void Deltares.Geotechnics.Forms.DrawingRevetment.OnDragging | ( | IProjection | projection,
 |  | Point3D | aCurrentDragPoint,
 |  | Vector3D | aVect3D
 | ) |  |
virtual

Method which is called during drag-drop operations

Parameters
projection | Current projection of 3D to screen coordinates.
aCurrentDragPoint | Current position of the drawing object.
aVect3D | 3D vector representing the displacement within the drag operation.

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

override void Deltares.Geotechnics.Forms.DrawingRevetment.SetDataObject ( object aDataObject )
virtual

Sets the geotechnics entity that this drawing object represents

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

Generated on Tue Dec 15 2015 18:14:07 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • DrawingRevetment
Deltares.Geotechnics.Forms.DrawingRevetment Member List

This is the complete list of members for Deltares.Geotechnics.Forms.DrawingRevetment, including all inherited members.

AllowDrop(object data) | Deltares.Geometry.Forms.DrawingObject | virtual
BeginMove(IProjection projection, Point2D startPosition) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
CanResize | Deltares.Geometry.Forms.DrawingObject |
CheckHitForSelection(IProjection projection, Point3D point, double tolerance) | Deltares.Geometry.Forms.DrawingObject | virtual
ContainsPoint(IProjection projection, Point point) | Deltares.Geotechnics.Forms.DrawingRevetment | virtual
DataItemAt(Point point, Projection projection) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
DataObject (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
Draw(GraphicsInfo info) | Deltares.Geometry.Forms.DrawingObject | virtual
Draw3D(GraphicsInfo info) | Deltares.Geotechnics.Forms.DrawingRevetment | virtual
DrawingObject() (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
DrawingRevetment() (defined in Deltares.Geotechnics.Forms.DrawingRevetment) | Deltares.Geotechnics.Forms.DrawingRevetment |
DrawLabel(GraphicsInfo info) | Deltares.Geotechnics.Forms.DrawingRevetment | virtual
Drop(object data) | Deltares.Geometry.Forms.DrawingObject | virtual
EndMove(IProjection projection, Point2D startPosition, SizeF worldSize) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetCardinalDirectionOnEdgeContainingPoint(Point point) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetDataObject() | Deltares.Geotechnics.Forms.DrawingRevetment | virtual
GetExtents(IProjection projection) | Deltares.Geometry.Forms.DrawingObject | virtual
GetRevetmentColor() (defined in Deltares.Geotechnics.Forms.DrawingRevetment) | Deltares.Geotechnics.Forms.DrawingRevetment | protectedvirtual
GetScaled3DPoint(IProjection projection, Point3D aOrginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScaled3DPoint(IProjection projection, Point3D aOrginalPoint, ref Point3D aPointTobeScaled) | Deltares.Geometry.Forms.DrawingObject |
GetScaledXPoint(IProjection projection, double aOrginalCordinate) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, Point2D orginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, Point3D orginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, double x, double z) | Deltares.Geometry.Forms.DrawingObject |
GetStandardSize(object aDraw3DInterface, Point3D aPoint3D) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetThickness(GraphicsInfo info) | Deltares.Geometry.Forms.DrawingObject | protectedvirtual
HasBeenUpdated (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
IsDragableOnReslultMode (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
IsVisible (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
Layer (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
LineHeight (defined in Deltares.Geotechnics.Forms.DrawingRevetment) | Deltares.Geotechnics.Forms.DrawingRevetment | protected
Move(IProjection projection, Point2D startPosition, SizeF worldSize) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
Name | Deltares.Geometry.Forms.DrawingObject |
OnBeginDrag(IProjection projection, Point3D beginDragDropPoint, bool isIndividualDrag) | Deltares.Geotechnics.Forms.DrawingRevetment | virtual
OnDragging(IProjection projection, Point3D currentDragPoint, Vector3D vector) | Deltares.Geotechnics.Forms.DrawingRevetment | virtual
OnEndDrag(IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D) | Deltares.Geometry.Forms.DrawingObject | virtual
Selected | Deltares.Geometry.Forms.DrawingObject |
SetDataObject(object dataObject) | Deltares.Geotechnics.Forms.DrawingRevetment | virtual
ToolTip | Deltares.Geometry.Forms.DrawingObject |
ToString() (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
UpdateDataDragDrop(Vector3D aVect3D, List< IDrawingObject > aDraggedObjects) | Deltares.Geometry.Forms.DrawingObject | virtual
UpdateDataDragDrop(Point3D aBeginDragPoint, Vector3D vector) | Deltares.Geometry.Forms.DrawingObject | virtual
Generated on Tue Dec 15 2015 18:14:07 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.Forms.DrawingRoughnessRevetment Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • DrawingRoughnessRevetment
Protected Member Functions | List of all members
Deltares.Geotechnics.Forms.DrawingRoughnessRevetment Class Reference

Draws the roughness segment More...

Inheritance diagram for Deltares.Geotechnics.Forms.DrawingRoughnessRevetment:
Deltares.Geotechnics.Forms.DrawingRevetment Deltares.Geometry.Forms.DrawingObject Deltares.Geometry.Forms.IDrawingObject Deltares.Standard.Forms.IShape

Protected Member Functions

override Color | GetRevetmentColor ()
- Protected Member Functions inherited from Deltares.Geometry.Forms.DrawingObject
virtual int | GetThickness (GraphicsInfo info)
Gets the thickness in screen pixels of a drawing object. More...

Additional Inherited Members

- Public Member Functions inherited from Deltares.Geotechnics.Forms.DrawingRevetment
override object | GetDataObject ()
Gets the geotechnics entity that this drawing object represents More...
override void | SetDataObject (object dataObject)
Sets the geotechnics entity that this drawing object represents More...
override void | Draw3D (GraphicsInfo info)
override The Draw3D() Method More...
override void | DrawLabel (GraphicsInfo info)
Draws the label. More...
override bool | ContainsPoint (IProjection projection, Point point)
Determines whether the specified projection contains point. More...
override void | OnBeginDrag (IProjection projection, Point3D beginDragDropPoint, bool isIndividualDrag)
Method which is called when the user initiates a drag-drop operation More...
override void | OnDragging (IProjection projection, Point3D currentDragPoint, Vector3D vector)
Method which is called during drag-drop operations More...
- Public Member Functions inherited from Deltares.Geometry.Forms.DrawingObject
Point3D | GetScaled3DPoint (IProjection projection, Point3D aOrginalPoint)
Converts the 3DPoint to screen coordinates More...
Point3D | GetScreenPoint (IProjection projection, Point2D orginalPoint)
Converts Point from 3D space to screen coordinates, assuming Y = 0 More...
Point3D | GetScreenPoint (IProjection projection, Point3D orginalPoint)
Converts Point from 3D space to screen coordinates More...
Point3D | GetScreenPoint (IProjection projection, double x, double z)
Converts 3D x, y coordinates to screen coordinates, assuming Y = 0 More...
override string | ToString ()
virtual void | UpdateDataDragDrop (Vector3D aVect3D, List< IDrawingObject > aDraggedObjects)
Update the position and or orientation of a drawing object as the user is dragging it. More...
virtual void | UpdateDataDragDrop (Point3D aBeginDragPoint, Vector3D vector)
Update the position and or orientation of a drawing object as the user is dragging it. More...
virtual CardinalDirection | GetCardinalDirectionOnEdgeContainingPoint (Point point)
virtual void | OnEndDrag (IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D)
Method which is called when the user ends a drag-drop operation. More...
virtual bool | CheckHitForSelection (IProjection projection, Point3D point, double tolerance)
Check if given point coordinates intersect the rendered drawing object. More...
virtual double | GetStandardSize (object aDraw3DInterface, Point3D aPoint3D)
void | GetScaled3DPoint (IProjection projection, Point3D aOrginalPoint, ref Point3D aPointTobeScaled)
Converts the 3DPoint to screen coordinates More...
double | GetScaledXPoint (IProjection projection, double aOrginalCordinate)
Converts X Coordinate in 3D space to a screen X Coordinate More...
virtual Rectangle | GetExtents (IProjection projection)
Returns the bounding box of the shape. More...
virtual void | Draw (GraphicsInfo info)
Render this object in 3D space. More...
virtual void | Move (IProjection projection, Point2D startPosition, SizeF worldSize)
virtual void | BeginMove (IProjection projection, Point2D startPosition)
virtual void | EndMove (IProjection projection, Point2D startPosition, SizeF worldSize)
virtual bool | AllowDrop (object data)
Boolean which indicates if other drawing objects can be dropped on given drawing objects More...
virtual void | Drop (object data)
Ends a drag-drop operation More...
virtual IEnumerable< object > | DataItemAt (Point point, Projection projection)
- Properties inherited from Deltares.Geotechnics.Forms.DrawingRevetment
int | LineHeight [get, set]
- Properties inherited from Deltares.Geometry.Forms.DrawingObject
virtual bool | CanResize [get]
Boolean which indicates if a drawing object can be resized. More...
virtual bool | Selected [get, set]
Boolean which indicates if a drawing object is currently selected. More...
string | ToolTip [get]
Description which is shown as a tooltip when the mouse hovers over drawing object. More...
string | Name [get, set]
Gets or sets the name of a drawing object. More...
bool | IsVisible [get, set]
bool | HasBeenUpdated [get, set]
virtual bool | IsDragableOnReslultMode [get]
virtual int | Layer [get, set]
object | DataObject [get, set]
- Properties inherited from Deltares.Geometry.Forms.IDrawingObject
string | Name [get, set]
bool | IsVisible [get, set]
bool | HasBeenUpdated [get, set]
Gets or sets the update status of a drawing object. More...
bool | IsDragableOnReslultMode [get]
- Properties inherited from Deltares.Standard.Forms.IShape
object | DataObject [get, set]
int | Layer [get]

Detailed Description

Draws the roughness segment

Generated on Tue Dec 15 2015 18:14:08 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • DrawingRoughnessRevetment
Deltares.Geotechnics.Forms.DrawingRoughnessRevetment Member List

This is the complete list of members for Deltares.Geotechnics.Forms.DrawingRoughnessRevetment, including all inherited members.

AllowDrop(object data) | Deltares.Geometry.Forms.DrawingObject | virtual
BeginMove(IProjection projection, Point2D startPosition) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
CanResize | Deltares.Geometry.Forms.DrawingObject |
CheckHitForSelection(IProjection projection, Point3D point, double tolerance) | Deltares.Geometry.Forms.DrawingObject | virtual
ContainsPoint(IProjection projection, Point point) | Deltares.Geotechnics.Forms.DrawingRevetment | virtual
DataItemAt(Point point, Projection projection) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
DataObject (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
Draw(GraphicsInfo info) | Deltares.Geometry.Forms.DrawingObject | virtual
Draw3D(GraphicsInfo info) | Deltares.Geotechnics.Forms.DrawingRevetment | virtual
DrawingObject() (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
DrawingRevetment() (defined in Deltares.Geotechnics.Forms.DrawingRevetment) | Deltares.Geotechnics.Forms.DrawingRevetment |
DrawingRoughnessRevetment() (defined in Deltares.Geotechnics.Forms.DrawingRoughnessRevetment) | Deltares.Geotechnics.Forms.DrawingRoughnessRevetment |
DrawLabel(GraphicsInfo info) | Deltares.Geotechnics.Forms.DrawingRevetment | virtual
Drop(object data) | Deltares.Geometry.Forms.DrawingObject | virtual
EndMove(IProjection projection, Point2D startPosition, SizeF worldSize) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetCardinalDirectionOnEdgeContainingPoint(Point point) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetDataObject() | Deltares.Geotechnics.Forms.DrawingRevetment | virtual
GetExtents(IProjection projection) | Deltares.Geometry.Forms.DrawingObject | virtual
GetRevetmentColor() (defined in Deltares.Geotechnics.Forms.DrawingRoughnessRevetment) | Deltares.Geotechnics.Forms.DrawingRoughnessRevetment | protectedvirtual
GetScaled3DPoint(IProjection projection, Point3D aOrginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScaled3DPoint(IProjection projection, Point3D aOrginalPoint, ref Point3D aPointTobeScaled) | Deltares.Geometry.Forms.DrawingObject |
GetScaledXPoint(IProjection projection, double aOrginalCordinate) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, Point2D orginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, Point3D orginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, double x, double z) | Deltares.Geometry.Forms.DrawingObject |
GetStandardSize(object aDraw3DInterface, Point3D aPoint3D) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetThickness(GraphicsInfo info) | Deltares.Geometry.Forms.DrawingObject | protectedvirtual
HasBeenUpdated (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
IsDragableOnReslultMode (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
IsVisible (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
Layer (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
LineHeight (defined in Deltares.Geotechnics.Forms.DrawingRevetment) | Deltares.Geotechnics.Forms.DrawingRevetment | protected
Move(IProjection projection, Point2D startPosition, SizeF worldSize) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
Name | Deltares.Geometry.Forms.DrawingObject |
OnBeginDrag(IProjection projection, Point3D beginDragDropPoint, bool isIndividualDrag) | Deltares.Geotechnics.Forms.DrawingRevetment | virtual
OnDragging(IProjection projection, Point3D currentDragPoint, Vector3D vector) | Deltares.Geotechnics.Forms.DrawingRevetment | virtual
OnEndDrag(IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D) | Deltares.Geometry.Forms.DrawingObject | virtual
Selected | Deltares.Geometry.Forms.DrawingObject |
SetDataObject(object dataObject) | Deltares.Geotechnics.Forms.DrawingRevetment | virtual
ToolTip | Deltares.Geometry.Forms.DrawingObject |
ToString() (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
UpdateDataDragDrop(Vector3D aVect3D, List< IDrawingObject > aDraggedObjects) | Deltares.Geometry.Forms.DrawingObject | virtual
UpdateDataDragDrop(Point3D aBeginDragPoint, Vector3D vector) | Deltares.Geometry.Forms.DrawingObject | virtual
Generated on Tue Dec 15 2015 18:14:08 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.Forms.DrawingSettlementCurve Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • DrawingSettlementCurve
Public Member Functions | Static Public Attributes | Properties | List of all members
Deltares.Geotechnics.Forms.DrawingSettlementCurve Class Reference
Inheritance diagram for Deltares.Geotechnics.Forms.DrawingSettlementCurve:
Deltares.Geometry.Forms.DrawingObject Deltares.Geometry.Forms.IDrawingObject Deltares.Standard.Forms.IShape

Public Member Functions

override void | SetDataObject (object o)
Sets the geotechnics entity that this drawing object represents More...
override object | GetDataObject ()
Gets the geotechnics entity that this drawing object represents More...
override void | UpdateDataDragDrop (Point3D aBeginDragPoint, Vector3D vector)
Update the position and or orientation of a drawing object as the user is dragging it. More...
override void | Draw3D (GraphicsInfo info)
Render this drawing object in 3D space. More...
- Public Member Functions inherited from Deltares.Geometry.Forms.DrawingObject
Point3D | GetScaled3DPoint (IProjection projection, Point3D aOrginalPoint)
Converts the 3DPoint to screen coordinates More...
Point3D | GetScreenPoint (IProjection projection, Point2D orginalPoint)
Converts Point from 3D space to screen coordinates, assuming Y = 0 More...
Point3D | GetScreenPoint (IProjection projection, Point3D orginalPoint)
Converts Point from 3D space to screen coordinates More...
Point3D | GetScreenPoint (IProjection projection, double x, double z)
Converts 3D x, y coordinates to screen coordinates, assuming Y = 0 More...
override string | ToString ()
virtual void | UpdateDataDragDrop (Vector3D aVect3D, List< IDrawingObject > aDraggedObjects)
Update the position and or orientation of a drawing object as the user is dragging it. More...
virtual void | OnBeginDrag (IProjection projection, Point3D aBeginDragDropPoint, bool isIndividualDrag)
Method which is called when the user initiates a drag-drop operation More...
virtual CardinalDirection | GetCardinalDirectionOnEdgeContainingPoint (Point point)
virtual void | OnDragging (IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D)
Method which is called during drag-drop operations More...
virtual void | OnEndDrag (IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D)
Method which is called when the user ends a drag-drop operation. More...
virtual bool | CheckHitForSelection (IProjection projection, Point3D point, double tolerance)
Check if given point coordinates intersect the rendered drawing object. More...
virtual double | GetStandardSize (object aDraw3DInterface, Point3D aPoint3D)
void | GetScaled3DPoint (IProjection projection, Point3D aOrginalPoint, ref Point3D aPointTobeScaled)
Converts the 3DPoint to screen coordinates More...
double | GetScaledXPoint (IProjection projection, double aOrginalCordinate)
Converts X Coordinate in 3D space to a screen X Coordinate More...
virtual bool | ContainsPoint (IProjection projection, Point point)
Determines if a given point screen coordinate is within the drawing object. More...
virtual Rectangle | GetExtents (IProjection projection)
Returns the bounding box of the shape. More...
virtual void | Draw (GraphicsInfo info)
Render this object in 3D space. More...
virtual void | DrawLabel (GraphicsInfo info)
Renders a label or tooltip to provide some information in text for this object. More...
virtual void | Move (IProjection projection, Point2D startPosition, SizeF worldSize)
virtual void | BeginMove (IProjection projection, Point2D startPosition)
virtual void | EndMove (IProjection projection, Point2D startPosition, SizeF worldSize)
virtual bool | AllowDrop (object data)
Boolean which indicates if other drawing objects can be dropped on given drawing objects More...
virtual void | Drop (object data)
Ends a drag-drop operation More...
virtual IEnumerable< object > | DataItemAt (Point point, Projection projection)

Static Public Attributes

static readonly Color | AbsoluteCurveColor = Color.Red
static readonly Color | RelativeCurveColor = Color.DarkOrange

Properties

SettlementCurve | SettlementCurve [get]
- Properties inherited from Deltares.Geometry.Forms.DrawingObject
virtual bool | CanResize [get]
Boolean which indicates if a drawing object can be resized. More...
virtual bool | Selected [get, set]
Boolean which indicates if a drawing object is currently selected. More...
string | ToolTip [get]
Description which is shown as a tooltip when the mouse hovers over drawing object. More...
string | Name [get, set]
Gets or sets the name of a drawing object. More...
bool | IsVisible [get, set]
bool | HasBeenUpdated [get, set]
virtual bool | IsDragableOnReslultMode [get]
virtual int | Layer [get, set]
object | DataObject [get, set]
- Properties inherited from Deltares.Geometry.Forms.IDrawingObject
string | Name [get, set]
bool | IsVisible [get, set]
bool | HasBeenUpdated [get, set]
Gets or sets the update status of a drawing object. More...
bool | IsDragableOnReslultMode [get]
- Properties inherited from Deltares.Standard.Forms.IShape
object | DataObject [get, set]
int | Layer [get]

Additional Inherited Members

- Protected Member Functions inherited from Deltares.Geometry.Forms.DrawingObject
virtual int GetThickness (GraphicsInfo info)
Gets the thickness in screen pixels of a drawing object. More...

Member Function Documentation

override void Deltares.Geotechnics.Forms.DrawingSettlementCurve.Draw3D ( GraphicsInfo info )
virtual

Render this drawing object in 3D space.

Parameters
info Rendering target information.

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

References Deltares.Standard.Forms.DrawingSupport.SetIEPDraw3D().

override object Deltares.Geotechnics.Forms.DrawingSettlementCurve.GetDataObject ( )
virtual

Gets the geotechnics entity that this drawing object represents

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

override void Deltares.Geotechnics.Forms.DrawingSettlementCurve.SetDataObject ( object aDataObject )
virtual

Sets the geotechnics entity that this drawing object represents

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

override void Deltares.Geotechnics.Forms.DrawingSettlementCurve.UpdateDataDragDrop | ( | Point3D | aBeginDragPoint,
 |  | Vector3D | vector
 | ) |  |
virtual

Update the position and or orientation of a drawing object as the user is dragging it.

Parameters
aBeginDragPoint | Initial position of the Drawing object
vector | Vector representing the displacement of an object during a drag-drop operation.

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

Generated on Tue Dec 15 2015 18:14:08 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • DrawingSettlementCurve
Deltares.Geotechnics.Forms.DrawingSettlementCurve Member List

This is the complete list of members for Deltares.Geotechnics.Forms.DrawingSettlementCurve, including all inherited members.

AbsoluteCurveColor (defined in Deltares.Geotechnics.Forms.DrawingSettlementCurve) | Deltares.Geotechnics.Forms.DrawingSettlementCurve | static
AllowDrop(object data) | Deltares.Geometry.Forms.DrawingObject | virtual
BeginMove(IProjection projection, Point2D startPosition) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
CanResize | Deltares.Geometry.Forms.DrawingObject |
CheckHitForSelection(IProjection projection, Point3D point, double tolerance) | Deltares.Geometry.Forms.DrawingObject | virtual
ContainsPoint(IProjection projection, Point point) | Deltares.Geometry.Forms.DrawingObject | virtual
DataItemAt(Point point, Projection projection) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
DataObject (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
Draw(GraphicsInfo info) | Deltares.Geometry.Forms.DrawingObject | virtual
Draw3D(GraphicsInfo info) | Deltares.Geotechnics.Forms.DrawingSettlementCurve | virtual
DrawingObject() (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
DrawLabel(GraphicsInfo info) | Deltares.Geometry.Forms.DrawingObject | virtual
Drop(object data) | Deltares.Geometry.Forms.DrawingObject | virtual
EndMove(IProjection projection, Point2D startPosition, SizeF worldSize) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetCardinalDirectionOnEdgeContainingPoint(Point point) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetDataObject() | Deltares.Geotechnics.Forms.DrawingSettlementCurve | virtual
GetExtents(IProjection projection) | Deltares.Geometry.Forms.DrawingObject | virtual
GetScaled3DPoint(IProjection projection, Point3D aOrginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScaled3DPoint(IProjection projection, Point3D aOrginalPoint, ref Point3D aPointTobeScaled) | Deltares.Geometry.Forms.DrawingObject |
GetScaledXPoint(IProjection projection, double aOrginalCordinate) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, Point2D orginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, Point3D orginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, double x, double z) | Deltares.Geometry.Forms.DrawingObject |
GetStandardSize(object aDraw3DInterface, Point3D aPoint3D) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetThickness(GraphicsInfo info) | Deltares.Geometry.Forms.DrawingObject | protectedvirtual
HasBeenUpdated (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
IsDragableOnReslultMode (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
IsVisible (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
Layer (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
Move(IProjection projection, Point2D startPosition, SizeF worldSize) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
Name | Deltares.Geometry.Forms.DrawingObject |
OnBeginDrag(IProjection projection, Point3D aBeginDragDropPoint, bool isIndividualDrag) | Deltares.Geometry.Forms.DrawingObject | virtual
OnDragging(IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D) | Deltares.Geometry.Forms.DrawingObject | virtual
OnEndDrag(IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D) | Deltares.Geometry.Forms.DrawingObject | virtual
RelativeCurveColor (defined in Deltares.Geotechnics.Forms.DrawingSettlementCurve) | Deltares.Geotechnics.Forms.DrawingSettlementCurve | static
Selected | Deltares.Geometry.Forms.DrawingObject |
SetDataObject(object o) | Deltares.Geotechnics.Forms.DrawingSettlementCurve | virtual
SettlementCurve (defined in Deltares.Geotechnics.Forms.DrawingSettlementCurve) | Deltares.Geotechnics.Forms.DrawingSettlementCurve |
ToolTip | Deltares.Geometry.Forms.DrawingObject |
ToString() (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
UpdateDataDragDrop(Point3D aBeginDragPoint, Vector3D vector) | Deltares.Geotechnics.Forms.DrawingSettlementCurve | virtual
Deltares::Geometry::Forms::DrawingObject.UpdateDataDragDrop(Vector3D aVect3D, List< IDrawingObject > aDraggedObjects) | Deltares.Geometry.Forms.DrawingObject | virtual
Generated on Tue Dec 15 2015 18:14:08 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.Forms.DrawingSheetPiling Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • DrawingSheetPiling
Public Member Functions | List of all members
Deltares.Geotechnics.Forms.DrawingSheetPiling Class Reference
Inheritance diagram for Deltares.Geotechnics.Forms.DrawingSheetPiling:
Deltares.Geometry.Forms.ColoredDrawingObject Deltares.Geometry.Forms.DrawingObject Deltares.Geometry.Forms.IDrawingObject Deltares.Standard.Forms.IShape

Public Member Functions

override void | SetDataObject (object dataObject)
Sets the geotechnics entity that this drawing object represents More...
override object | GetDataObject ()
Gets the geotechnics entity that this drawing object represents More...
override void | UpdateDataDragDrop (Point3D beginDragPoint, Vector3D vector)
Update the position and or orientation of a drawing object as the user is dragging it. More...
override void | OnBeginDrag (IProjection projection, Point3D aBeginDragDropPoint, bool isIndividualDrag)
Method which is called when the user initiates a drag-drop operation More...
override void | OnEndDrag (IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D)
Method which is called when the user ends a drag-drop operation. More...
override void | Draw3D (GraphicsInfo info)
Render this drawing object in 3D space. More...
- Public Member Functions inherited from Deltares.Geometry.Forms.ColoredDrawingObject
ColoredDrawingObject (Color fillColor, Color strokeColor)
- Public Member Functions inherited from Deltares.Geometry.Forms.DrawingObject
Point3D | GetScaled3DPoint (IProjection projection, Point3D aOrginalPoint)
Converts the 3DPoint to screen coordinates More...
Point3D | GetScreenPoint (IProjection projection, Point2D orginalPoint)
Converts Point from 3D space to screen coordinates, assuming Y = 0 More...
Point3D | GetScreenPoint (IProjection projection, Point3D orginalPoint)
Converts Point from 3D space to screen coordinates More...
Point3D | GetScreenPoint (IProjection projection, double x, double z)
Converts 3D x, y coordinates to screen coordinates, assuming Y = 0 More...
override string | ToString ()
virtual void | UpdateDataDragDrop (Vector3D aVect3D, List< IDrawingObject > aDraggedObjects)
Update the position and or orientation of a drawing object as the user is dragging it. More...
virtual CardinalDirection | GetCardinalDirectionOnEdgeContainingPoint (Point point)
virtual void | OnDragging (IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D)
Method which is called during drag-drop operations More...
virtual bool | CheckHitForSelection (IProjection projection, Point3D point, double tolerance)
Check if given point coordinates intersect the rendered drawing object. More...
virtual double | GetStandardSize (object aDraw3DInterface, Point3D aPoint3D)
void | GetScaled3DPoint (IProjection projection, Point3D aOrginalPoint, ref Point3D aPointTobeScaled)
Converts the 3DPoint to screen coordinates More...
double | GetScaledXPoint (IProjection projection, double aOrginalCordinate)
Converts X Coordinate in 3D space to a screen X Coordinate More...
virtual bool | ContainsPoint (IProjection projection, Point point)
Determines if a given point screen coordinate is within the drawing object. More...
virtual Rectangle | GetExtents (IProjection projection)
Returns the bounding box of the shape. More...
virtual void | Draw (GraphicsInfo info)
Render this object in 3D space. More...
virtual void | DrawLabel (GraphicsInfo info)
Renders a label or tooltip to provide some information in text for this object. More...
virtual void | Move (IProjection projection, Point2D startPosition, SizeF worldSize)
virtual void | BeginMove (IProjection projection, Point2D startPosition)
virtual void | EndMove (IProjection projection, Point2D startPosition, SizeF worldSize)
virtual bool | AllowDrop (object data)
Boolean which indicates if other drawing objects can be dropped on given drawing objects More...
virtual void | Drop (object data)
Ends a drag-drop operation More...
virtual IEnumerable< object > | DataItemAt (Point point, Projection projection)

Additional Inherited Members

- Protected Member Functions inherited from Deltares.Geometry.Forms.ColoredDrawingObject
Color | UpdateCurrentColor (GraphicsInfo info, bool draggingElement)
Color | UpdateCurrentColor (GraphicsInfo info, bool draggingElement, bool draggingAnything)
Color | UpdateCurrentColor (GraphicsInfo info, bool draggingElement, bool draggingAnything, Color normalFillColor, Color normalStrokeColor)
void | setCurrentColor (GraphicsInfo info, Color fillColor, Color strokeColor)
- Protected Member Functions inherited from Deltares.Geometry.Forms.DrawingObject
virtual int | GetThickness (GraphicsInfo info)
Gets the thickness in screen pixels of a drawing object. More...
- Properties inherited from Deltares.Geometry.Forms.ColoredDrawingObject
Color | NormalFillColor [get]
Color | NormalStrokeColor [get]
- Properties inherited from Deltares.Geometry.Forms.DrawingObject
virtual bool | CanResize [get]
Boolean which indicates if a drawing object can be resized. More...
virtual bool | Selected [get, set]
Boolean which indicates if a drawing object is currently selected. More...
string | ToolTip [get]
Description which is shown as a tooltip when the mouse hovers over drawing object. More...
string | Name [get, set]
Gets or sets the name of a drawing object. More...
bool | IsVisible [get, set]
bool | HasBeenUpdated [get, set]
virtual bool | IsDragableOnReslultMode [get]
virtual int | Layer [get, set]
object | DataObject [get, set]
- Properties inherited from Deltares.Geometry.Forms.IDrawingObject
string | Name [get, set]
bool | IsVisible [get, set]
bool | HasBeenUpdated [get, set]
Gets or sets the update status of a drawing object. More...
bool | IsDragableOnReslultMode [get]
- Properties inherited from Deltares.Standard.Forms.IShape
object | DataObject [get, set]
int | Layer [get]

Member Function Documentation

override void Deltares.Geotechnics.Forms.DrawingSheetPiling.Draw3D ( GraphicsInfo info )
virtual

Render this drawing object in 3D space.

Parameters
info Rendering target information.

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

References Deltares.Standard.Forms.DrawingSupport.Rectangle3D(), and Deltares.Standard.Forms.DrawingSupport.SetIEPDraw3D().

override object Deltares.Geotechnics.Forms.DrawingSheetPiling.GetDataObject ( )
virtual

Gets the geotechnics entity that this drawing object represents

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

override void Deltares.Geotechnics.Forms.DrawingSheetPiling.OnBeginDrag | ( | IProjection | projection,
 |  | Point3D | aBeginDragDropPoint,
 |  | bool | isIndividualDrag
 | ) |  |
virtual

Method which is called when the user initiates a drag-drop operation

Parameters
projection | Current projection of 3D to screen coordinates.
aBeginDragDropPoint | Initial position of the mouse pointer.
isIndividualDrag

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

override void Deltares.Geotechnics.Forms.DrawingSheetPiling.OnEndDrag | ( | IProjection | projection,
 |  | Point3D | aCurrentDragPoint,
 |  | Vector3D | aVect3D
 | ) |  |
virtual

Method which is called when the user ends a drag-drop operation.

Parameters
projection | Current projection
aCurrentDragPoint | Point in 3D space where the darg operation ends
aVect3D | Vector in 3D space which represents the displacement within the drag-drop operation

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

override void Deltares.Geotechnics.Forms.DrawingSheetPiling.SetDataObject ( object aDataObject )
virtual

Sets the geotechnics entity that this drawing object represents

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

override void Deltares.Geotechnics.Forms.DrawingSheetPiling.UpdateDataDragDrop | ( | Point3D | aBeginDragPoint,
 |  | Vector3D | vector
 | ) |  |
virtual

Update the position and or orientation of a drawing object as the user is dragging it.

Parameters
aBeginDragPoint | Initial position of the Drawing object
vector | Vector representing the displacement of an object during a drag-drop operation.

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

Generated on Tue Dec 15 2015 18:14:08 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • DrawingSheetPiling
Deltares.Geotechnics.Forms.DrawingSheetPiling Member List

This is the complete list of members for Deltares.Geotechnics.Forms.DrawingSheetPiling, including all inherited members.

AllowDrop(object data) | Deltares.Geometry.Forms.DrawingObject | virtual
BeginMove(IProjection projection, Point2D startPosition) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
CanResize | Deltares.Geometry.Forms.DrawingObject |
CheckHitForSelection(IProjection projection, Point3D point, double tolerance) | Deltares.Geometry.Forms.DrawingObject | virtual
ColoredDrawingObject(Color fillColor, Color strokeColor) (defined in Deltares.Geometry.Forms.ColoredDrawingObject) | Deltares.Geometry.Forms.ColoredDrawingObject |
ContainsPoint(IProjection projection, Point point) | Deltares.Geometry.Forms.DrawingObject | virtual
DataItemAt(Point point, Projection projection) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
DataObject (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
Draw(GraphicsInfo info) | Deltares.Geometry.Forms.DrawingObject | virtual
Draw3D(GraphicsInfo info) | Deltares.Geotechnics.Forms.DrawingSheetPiling | virtual
DrawingObject() (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
DrawingSheetPiling() (defined in Deltares.Geotechnics.Forms.DrawingSheetPiling) | Deltares.Geotechnics.Forms.DrawingSheetPiling |
DrawLabel(GraphicsInfo info) | Deltares.Geometry.Forms.DrawingObject | virtual
Drop(object data) | Deltares.Geometry.Forms.DrawingObject | virtual
EndMove(IProjection projection, Point2D startPosition, SizeF worldSize) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetCardinalDirectionOnEdgeContainingPoint(Point point) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetDataObject() | Deltares.Geotechnics.Forms.DrawingSheetPiling | virtual
GetExtents(IProjection projection) | Deltares.Geometry.Forms.DrawingObject | virtual
GetScaled3DPoint(IProjection projection, Point3D aOrginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScaled3DPoint(IProjection projection, Point3D aOrginalPoint, ref Point3D aPointTobeScaled) | Deltares.Geometry.Forms.DrawingObject |
GetScaledXPoint(IProjection projection, double aOrginalCordinate) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, Point2D orginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, Point3D orginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, double x, double z) | Deltares.Geometry.Forms.DrawingObject |
GetStandardSize(object aDraw3DInterface, Point3D aPoint3D) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetThickness(GraphicsInfo info) | Deltares.Geometry.Forms.DrawingObject | protectedvirtual
HasBeenUpdated (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
IsDragableOnReslultMode (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
IsVisible (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
Layer (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
Move(IProjection projection, Point2D startPosition, SizeF worldSize) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
Name | Deltares.Geometry.Forms.DrawingObject |
NormalFillColor (defined in Deltares.Geometry.Forms.ColoredDrawingObject) | Deltares.Geometry.Forms.ColoredDrawingObject | protected
NormalStrokeColor (defined in Deltares.Geometry.Forms.ColoredDrawingObject) | Deltares.Geometry.Forms.ColoredDrawingObject | protected
OnBeginDrag(IProjection projection, Point3D aBeginDragDropPoint, bool isIndividualDrag) | Deltares.Geotechnics.Forms.DrawingSheetPiling | virtual
OnDragging(IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D) | Deltares.Geometry.Forms.DrawingObject | virtual
OnEndDrag(IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D) | Deltares.Geotechnics.Forms.DrawingSheetPiling | virtual
Selected | Deltares.Geometry.Forms.DrawingObject |
setCurrentColor(GraphicsInfo info, Color fillColor, Color strokeColor) (defined in Deltares.Geometry.Forms.ColoredDrawingObject) | Deltares.Geometry.Forms.ColoredDrawingObject | protected
SetDataObject(object dataObject) | Deltares.Geotechnics.Forms.DrawingSheetPiling | virtual
ToolTip | Deltares.Geometry.Forms.DrawingObject |
ToString() (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
UpdateCurrentColor(GraphicsInfo info, bool draggingElement) (defined in Deltares.Geometry.Forms.ColoredDrawingObject) | Deltares.Geometry.Forms.ColoredDrawingObject | protected
UpdateCurrentColor(GraphicsInfo info, bool draggingElement, bool draggingAnything) (defined in Deltares.Geometry.Forms.ColoredDrawingObject) | Deltares.Geometry.Forms.ColoredDrawingObject | protected
UpdateCurrentColor(GraphicsInfo info, bool draggingElement, bool draggingAnything, Color normalFillColor, Color normalStrokeColor) (defined in Deltares.Geometry.Forms.ColoredDrawingObject) | Deltares.Geometry.Forms.ColoredDrawingObject | protected
UpdateDataDragDrop(Point3D beginDragPoint, Vector3D vector) | Deltares.Geotechnics.Forms.DrawingSheetPiling | virtual
Deltares::Geometry::Forms::ColoredDrawingObject.UpdateDataDragDrop(Vector3D aVect3D, List< IDrawingObject > aDraggedObjects) | Deltares.Geometry.Forms.DrawingObject | virtual
Generated on Tue Dec 15 2015 18:14:08 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.Forms.DrawingSoilLayerSurface Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • DrawingSoilLayerSurface
Public Member Functions | List of all members
Deltares.Geotechnics.Forms.DrawingSoilLayerSurface Class Reference

Drawing object that represents soil layers (SoilLayerSurface) entities in the geometry (crossection) editor. More...

Inheritance diagram for Deltares.Geotechnics.Forms.DrawingSoilLayerSurface:
Deltares.Geotechnics.Forms.DrawingSoilSurface Deltares.Geometry.Forms.DrawingObject Deltares.Geometry.Forms.IDrawingObject Deltares.Standard.Forms.IShape

Public Member Functions

void | SetLayerTopLevel (double value)
void | SetLayerBottomLevel (double value)
override void | OnBeginDrag (IProjection projection, Point3D aBeginDragDropPoint, bool isIndividualDrag)
Method which is called when the user initiates a drag-drop operation More...
override void | OnEndDrag (IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D)
Method which is called when the user ends a drag-drop operation. More...
override void | UpdateDataDragDrop (Point3D beginDragPoint, Vector3D vector)
Update the position and or orientation of a drawing object as the user is dragging it. More...
override void | SetDataObject (object aDataObject)
Sets the geotechnics entity that this drawing object represents More...
override void | Draw3D (GraphicsInfo info)
Render this drawing object in 3D space. More...
- Public Member Functions inherited from Deltares.Geotechnics.Forms.DrawingSoilSurface
override void | SetDataObject (object aDataObject)
override The SetDataObject() Method More...
override object | GetDataObject ()
override The GetDataObject() Method And Rturns DataObject of SoilSurface More...
override bool | AllowDrop (object data)
Boolean which indicates if other drawing objects can be dropped on given drawing objects More...
override void | Drop (object data)
Ends a drag-drop operation More...
override void | OnBeginDrag (IProjection projection, Point3D aBeginDragDropPoint, bool isIndividualDrag)
Method which is called when the user initiates a drag-drop operation More...
override void | UpdateDataDragDrop (Point3D beginDragPoint, Vector3D vector)
override The UpdateDataDragDrop() Method More...
override bool | ContainsPoint (IProjection projection, Point point)
Determines if a given point screen coordinate is within the drawing object. More...
override void | Draw3D (GraphicsInfo info)
override The Draw3D() Method More...
override void | DrawLabel (GraphicsInfo info)
Renders a label or tooltip to provide some information in text for this object. More...
void | Dispose ()
- Public Member Functions inherited from Deltares.Geometry.Forms.DrawingObject
Point3D | GetScaled3DPoint (IProjection projection, Point3D aOrginalPoint)
Converts the 3DPoint to screen coordinates More...
Point3D | GetScreenPoint (IProjection projection, Point2D orginalPoint)
Converts Point from 3D space to screen coordinates, assuming Y = 0 More...
Point3D | GetScreenPoint (IProjection projection, Point3D orginalPoint)
Converts Point from 3D space to screen coordinates More...
Point3D | GetScreenPoint (IProjection projection, double x, double z)
Converts 3D x, y coordinates to screen coordinates, assuming Y = 0 More...
override string | ToString ()
virtual void | UpdateDataDragDrop (Vector3D aVect3D, List< IDrawingObject > aDraggedObjects)
Update the position and or orientation of a drawing object as the user is dragging it. More...
virtual CardinalDirection | GetCardinalDirectionOnEdgeContainingPoint (Point point)
virtual void | OnDragging (IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D)
Method which is called during drag-drop operations More...
virtual bool | CheckHitForSelection (IProjection projection, Point3D point, double tolerance)
Check if given point coordinates intersect the rendered drawing object. More...
virtual double | GetStandardSize (object aDraw3DInterface, Point3D aPoint3D)
void | GetScaled3DPoint (IProjection projection, Point3D aOrginalPoint, ref Point3D aPointTobeScaled)
Converts the 3DPoint to screen coordinates More...
double | GetScaledXPoint (IProjection projection, double aOrginalCordinate)
Converts X Coordinate in 3D space to a screen X Coordinate More...
virtual Rectangle | GetExtents (IProjection projection)
Returns the bounding box of the shape. More...
virtual void | Draw (GraphicsInfo info)
Render this object in 3D space. More...
virtual void | Move (IProjection projection, Point2D startPosition, SizeF worldSize)
virtual void | BeginMove (IProjection projection, Point2D startPosition)
virtual void | EndMove (IProjection projection, Point2D startPosition, SizeF worldSize)
virtual IEnumerable< object > | DataItemAt (Point point, Projection projection)

Additional Inherited Members

- Protected Member Functions inherited from Deltares.Geotechnics.Forms.DrawingSoilSurface
Color | GetColor (GraphicsInfo info)
void | SetDrawingProperties (GraphicsInfo info, Color color)
- Protected Member Functions inherited from Deltares.Geometry.Forms.DrawingObject
virtual int | GetThickness (GraphicsInfo info)
Gets the thickness in screen pixels of a drawing object. More...
- Properties inherited from Deltares.Geometry.Forms.DrawingObject
virtual bool | CanResize [get]
Boolean which indicates if a drawing object can be resized. More...
virtual bool | Selected [get, set]
Boolean which indicates if a drawing object is currently selected. More...
string | ToolTip [get]
Description which is shown as a tooltip when the mouse hovers over drawing object. More...
string | Name [get, set]
Gets or sets the name of a drawing object. More...
bool | IsVisible [get, set]
bool | HasBeenUpdated [get, set]
virtual bool | IsDragableOnReslultMode [get]
virtual int | Layer [get, set]
object | DataObject [get, set]
- Properties inherited from Deltares.Geometry.Forms.IDrawingObject
string | Name [get, set]
bool | IsVisible [get, set]
bool | HasBeenUpdated [get, set]
Gets or sets the update status of a drawing object. More...
bool | IsDragableOnReslultMode [get]
- Properties inherited from Deltares.Standard.Forms.IShape
object | DataObject [get, set]
int | Layer [get]

Detailed Description

Drawing object that represents soil layers (SoilLayerSurface) entities in the geometry (crossection) editor.

See also
SoilLayerSurface

Member Function Documentation

override void Deltares.Geotechnics.Forms.DrawingSoilLayerSurface.Draw3D ( GraphicsInfo info )
virtual

Render this drawing object in 3D space.

Parameters
info Rendering target information.

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

override void Deltares.Geotechnics.Forms.DrawingSoilLayerSurface.OnBeginDrag | ( | IProjection | projection,
 |  | Point3D | aBeginDragDropPoint,
 |  | bool | isIndividualDrag
 | ) |  |
virtual

Method which is called when the user initiates a drag-drop operation

Parameters
projection | Current projection of 3D to screen coordinates.
aBeginDragDropPoint | Initial position of the mouse pointer.
isIndividualDrag

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

override void Deltares.Geotechnics.Forms.DrawingSoilLayerSurface.OnEndDrag | ( | IProjection | projection,
 |  | Point3D | aCurrentDragPoint,
 |  | Vector3D | aVect3D
 | ) |  |
virtual

Method which is called when the user ends a drag-drop operation.

Parameters
projection | Current projection
aCurrentDragPoint | Point in 3D space where the darg operation ends
aVect3D | Vector in 3D space which represents the displacement within the drag-drop operation

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

override void Deltares.Geotechnics.Forms.DrawingSoilLayerSurface.SetDataObject ( object aDataObject )
virtual

Sets the geotechnics entity that this drawing object represents

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

override void Deltares.Geotechnics.Forms.DrawingSoilLayerSurface.UpdateDataDragDrop | ( | Point3D | aBeginDragPoint,
 |  | Vector3D | vector
 | ) |  |
virtual

Update the position and or orientation of a drawing object as the user is dragging it.

Parameters
aBeginDragPoint | Initial position of the Drawing object
vector | Vector representing the displacement of an object during a drag-drop operation.

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

Generated on Tue Dec 15 2015 18:14:09 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • DrawingSoilLayerSurface
Deltares.Geotechnics.Forms.DrawingSoilLayerSurface Member List

This is the complete list of members for Deltares.Geotechnics.Forms.DrawingSoilLayerSurface, including all inherited members.

AllowDrop(object data) | Deltares.Geotechnics.Forms.DrawingSoilSurface | virtual
BeginMove(IProjection projection, Point2D startPosition) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
CanResize | Deltares.Geometry.Forms.DrawingObject |
CheckHitForSelection(IProjection projection, Point3D point, double tolerance) | Deltares.Geometry.Forms.DrawingObject | virtual
ContainsPoint(IProjection projection, Point point) | Deltares.Geotechnics.Forms.DrawingSoilSurface | virtual
DataItemAt(Point point, Projection projection) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
DataObject (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
Dispose() (defined in Deltares.Geotechnics.Forms.DrawingSoilSurface) | Deltares.Geotechnics.Forms.DrawingSoilSurface |
Draw(GraphicsInfo info) | Deltares.Geometry.Forms.DrawingObject | virtual
Draw3D(GraphicsInfo info) | Deltares.Geotechnics.Forms.DrawingSoilLayerSurface | virtual
DrawingObject() (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
DrawingSoilSurface() (defined in Deltares.Geotechnics.Forms.DrawingSoilSurface) | Deltares.Geotechnics.Forms.DrawingSoilSurface |
DrawLabel(GraphicsInfo info) | Deltares.Geotechnics.Forms.DrawingSoilSurface | virtual
Drop(object data) | Deltares.Geotechnics.Forms.DrawingSoilSurface | virtual
EndMove(IProjection projection, Point2D startPosition, SizeF worldSize) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetCardinalDirectionOnEdgeContainingPoint(Point point) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetColor(GraphicsInfo info) (defined in Deltares.Geotechnics.Forms.DrawingSoilSurface) | Deltares.Geotechnics.Forms.DrawingSoilSurface | protected
GetDataObject() | Deltares.Geotechnics.Forms.DrawingSoilSurface | virtual
GetExtents(IProjection projection) | Deltares.Geometry.Forms.DrawingObject | virtual
GetScaled3DPoint(IProjection projection, Point3D aOrginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScaled3DPoint(IProjection projection, Point3D aOrginalPoint, ref Point3D aPointTobeScaled) | Deltares.Geometry.Forms.DrawingObject |
GetScaledXPoint(IProjection projection, double aOrginalCordinate) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, Point2D orginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, Point3D orginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, double x, double z) | Deltares.Geometry.Forms.DrawingObject |
GetStandardSize(object aDraw3DInterface, Point3D aPoint3D) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetThickness(GraphicsInfo info) | Deltares.Geometry.Forms.DrawingObject | protectedvirtual
HasBeenUpdated (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
IsDragableOnReslultMode (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
IsVisible (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
Layer (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
Move(IProjection projection, Point2D startPosition, SizeF worldSize) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
Name | Deltares.Geometry.Forms.DrawingObject |
OnBeginDrag(IProjection projection, Point3D aBeginDragDropPoint, bool isIndividualDrag) | Deltares.Geotechnics.Forms.DrawingSoilLayerSurface | virtual
OnDragging(IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D) | Deltares.Geometry.Forms.DrawingObject | virtual
OnEndDrag(IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D) | Deltares.Geotechnics.Forms.DrawingSoilLayerSurface | virtual
Selected | Deltares.Geometry.Forms.DrawingObject |
SetDataObject(object aDataObject) | Deltares.Geotechnics.Forms.DrawingSoilLayerSurface | virtual
SetDrawingProperties(GraphicsInfo info, Color color) (defined in Deltares.Geotechnics.Forms.DrawingSoilSurface) | Deltares.Geotechnics.Forms.DrawingSoilSurface | protected
SetLayerBottomLevel(double value) (defined in Deltares.Geotechnics.Forms.DrawingSoilLayerSurface) | Deltares.Geotechnics.Forms.DrawingSoilLayerSurface |
SetLayerTopLevel(double value) (defined in Deltares.Geotechnics.Forms.DrawingSoilLayerSurface) | Deltares.Geotechnics.Forms.DrawingSoilLayerSurface |
ToolTip | Deltares.Geometry.Forms.DrawingObject |
ToString() (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
UpdateDataDragDrop(Point3D beginDragPoint, Vector3D vector) | Deltares.Geotechnics.Forms.DrawingSoilLayerSurface | virtual
Deltares::Geometry::Forms::DrawingObject.UpdateDataDragDrop(Vector3D aVect3D, List< IDrawingObject > aDraggedObjects) | Deltares.Geometry.Forms.DrawingObject | virtual
Generated on Tue Dec 15 2015 18:14:09 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.Forms.DrawingSoilProfile1D Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • DrawingSoilProfile1D
Public Member Functions | Properties | List of all members
Deltares.Geotechnics.Forms.DrawingSoilProfile1D Class Reference

Drawing class for displaying a 1D soilprofile More...

Inheritance diagram for Deltares.Geotechnics.Forms.DrawingSoilProfile1D:
Deltares.Geometry.Forms.DrawingObject Deltares.Geometry.Forms.IDrawingObject Deltares.Standard.Forms.IShape

Public Member Functions

override void | SetDataObject (object dataObject)
Sets the data object (SoilProfile1D or SoilProfile1DLookup2D). More...
override object | GetDataObject ()
Returns the data object. More...
override void | Draw3D (GraphicsInfo info)
Draws the SoilProfile. More...
override void | OnBeginDrag (IProjection projection, Point3D aBeginDragDropPoint, bool isIndividualDrag)
Called when dragging has begun More...
override void | UpdateDataDragDrop (Point3D beginDragPoint, Vector3D vector)
Updates the data drag drop. More...
override void | OnEndDrag (IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D)
Called when dragging has ended More...
override bool | ContainsPoint (IProjection projection, Point point)
Determines whether the specified projection contains point. More...
override Rectangle | GetExtents (IProjection projection)
Gets the extents of the projection. More...
- Public Member Functions inherited from Deltares.Geometry.Forms.DrawingObject
Point3D | GetScaled3DPoint (IProjection projection, Point3D aOrginalPoint)
Converts the 3DPoint to screen coordinates More...
Point3D | GetScreenPoint (IProjection projection, Point2D orginalPoint)
Converts Point from 3D space to screen coordinates, assuming Y = 0 More...
Point3D | GetScreenPoint (IProjection projection, Point3D orginalPoint)
Converts Point from 3D space to screen coordinates More...
Point3D | GetScreenPoint (IProjection projection, double x, double z)
Converts 3D x, y coordinates to screen coordinates, assuming Y = 0 More...
override string | ToString ()
virtual void | UpdateDataDragDrop (Vector3D aVect3D, List< IDrawingObject > aDraggedObjects)
Update the position and or orientation of a drawing object as the user is dragging it. More...
virtual CardinalDirection | GetCardinalDirectionOnEdgeContainingPoint (Point point)
virtual void | OnDragging (IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D)
Method which is called during drag-drop operations More...
virtual bool | CheckHitForSelection (IProjection projection, Point3D point, double tolerance)
Check if given point coordinates intersect the rendered drawing object. More...
virtual double | GetStandardSize (object aDraw3DInterface, Point3D aPoint3D)
void | GetScaled3DPoint (IProjection projection, Point3D aOrginalPoint, ref Point3D aPointTobeScaled)
Converts the 3DPoint to screen coordinates More...
double | GetScaledXPoint (IProjection projection, double aOrginalCordinate)
Converts X Coordinate in 3D space to a screen X Coordinate More...
virtual void | Draw (GraphicsInfo info)
Render this object in 3D space. More...
virtual void | DrawLabel (GraphicsInfo info)
Renders a label or tooltip to provide some information in text for this object. More...
virtual void | Move (IProjection projection, Point2D startPosition, SizeF worldSize)
virtual void | BeginMove (IProjection projection, Point2D startPosition)
virtual void | EndMove (IProjection projection, Point2D startPosition, SizeF worldSize)
virtual bool | AllowDrop (object data)
Boolean which indicates if other drawing objects can be dropped on given drawing objects More...
virtual void | Drop (object data)
Ends a drag-drop operation More...
virtual IEnumerable< object > | DataItemAt (Point point, Projection projection)

Properties

double | X [get]
Gets the x of a Soil profile. More...
double | Z [get]
Gets the z of a Soil profile. More...
double | Top [get]
Gets the top. More...
double | Bottom [get]
Gets the bottom. More...
double | Width [get, set]
Gets or sets the width. More...
double | Left [get]
Gets the left. More...
double | Right [get]
Gets the right. More...
- Properties inherited from Deltares.Geometry.Forms.DrawingObject
virtual bool | CanResize [get]
Boolean which indicates if a drawing object can be resized. More...
virtual bool | Selected [get, set]
Boolean which indicates if a drawing object is currently selected. More...
string | ToolTip [get]
Description which is shown as a tooltip when the mouse hovers over drawing object. More...
string | Name [get, set]
Gets or sets the name of a drawing object. More...
bool | IsVisible [get, set]
bool | HasBeenUpdated [get, set]
virtual bool | IsDragableOnReslultMode [get]
virtual int | Layer [get, set]
object | DataObject [get, set]
- Properties inherited from Deltares.Geometry.Forms.IDrawingObject
string | Name [get, set]
bool | IsVisible [get, set]
bool | HasBeenUpdated [get, set]
Gets or sets the update status of a drawing object. More...
bool | IsDragableOnReslultMode [get]
- Properties inherited from Deltares.Standard.Forms.IShape
object | DataObject [get, set]
int | Layer [get]

Additional Inherited Members

- Protected Member Functions inherited from Deltares.Geometry.Forms.DrawingObject
virtual int GetThickness (GraphicsInfo info)
Gets the thickness in screen pixels of a drawing object. More...

Detailed Description

Drawing class for displaying a 1D soilprofile

Member Function Documentation

override bool Deltares.Geotechnics.Forms.DrawingSoilProfile1D.ContainsPoint | ( | IProjection | projection,
 |  | Point | point
 | ) |  |
virtual

Determines whether the specified projection contains point.

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

override void Deltares.Geotechnics.Forms.DrawingSoilProfile1D.Draw3D ( GraphicsInfo info )
virtual

Draws the SoilProfile.

Parameters
info Graphic context.

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

References Deltares.Standard.Forms.DrawingSupport.GetLighterColor(), Deltares.Geotechnics.SoilProfile1D.Layers, and Deltares.Standard.Forms.DrawingSupport.SetIEPDraw3D().

override object Deltares.Geotechnics.Forms.DrawingSoilProfile1D.GetDataObject ( )
virtual

Returns the data object.

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

override Rectangle Deltares.Geotechnics.Forms.DrawingSoilProfile1D.GetExtents ( IProjection projection )
virtual

Gets the extents of the projection.

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

override void Deltares.Geotechnics.Forms.DrawingSoilProfile1D.OnBeginDrag | ( | IProjection | projection,
 |  | Point3D | aBeginDragDropPoint,
 |  | bool | isIndividualDrag
 | ) |  |
virtual

Called when dragging has begun

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

override void Deltares.Geotechnics.Forms.DrawingSoilProfile1D.OnEndDrag | ( | IProjection | projection,
 |  | Point3D | aCurrentDragPoint,
 |  | Vector3D | aVect3D
 | ) |  |
virtual

Called when dragging has ended

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

override void Deltares.Geotechnics.Forms.DrawingSoilProfile1D.SetDataObject ( object dataObject )
virtual

Sets the data object (SoilProfile1D or SoilProfile1DLookup2D).

Parameters
dataObject The data object.

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

References Deltares.Geotechnics.SoilProfile1D.SoilProfile1D().

override void Deltares.Geotechnics.Forms.DrawingSoilProfile1D.UpdateDataDragDrop | ( | Point3D | beginDragPoint,
 |  | Vector3D | vector
 | ) |  |
virtual

Updates the data drag drop.

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

Property Documentation

double Deltares.Geotechnics.Forms.DrawingSoilProfile1D.Bottom
get

Gets the bottom.

double Deltares.Geotechnics.Forms.DrawingSoilProfile1D.Left
get

Gets the left.

double Deltares.Geotechnics.Forms.DrawingSoilProfile1D.Right
get

Gets the right.

double Deltares.Geotechnics.Forms.DrawingSoilProfile1D.Top
get

Gets the top.

double Deltares.Geotechnics.Forms.DrawingSoilProfile1D.Width
getset

Gets or sets the width.

double Deltares.Geotechnics.Forms.DrawingSoilProfile1D.X
get

Gets the x of a Soil profile.

double Deltares.Geotechnics.Forms.DrawingSoilProfile1D.Z
get

Gets the z of a Soil profile.

Generated on Tue Dec 15 2015 18:14:09 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • DrawingSoilProfile1D
Deltares.Geotechnics.Forms.DrawingSoilProfile1D Member List

This is the complete list of members for Deltares.Geotechnics.Forms.DrawingSoilProfile1D, including all inherited members.

AllowDrop(object data) | Deltares.Geometry.Forms.DrawingObject | virtual
BeginMove(IProjection projection, Point2D startPosition) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
Bottom | Deltares.Geotechnics.Forms.DrawingSoilProfile1D |
CanResize | Deltares.Geometry.Forms.DrawingObject |
CheckHitForSelection(IProjection projection, Point3D point, double tolerance) | Deltares.Geometry.Forms.DrawingObject | virtual
ContainsPoint(IProjection projection, Point point) | Deltares.Geotechnics.Forms.DrawingSoilProfile1D | virtual
DataItemAt(Point point, Projection projection) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
DataObject (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
Draw(GraphicsInfo info) | Deltares.Geometry.Forms.DrawingObject | virtual
Draw3D(GraphicsInfo info) | Deltares.Geotechnics.Forms.DrawingSoilProfile1D | virtual
DrawingObject() (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
DrawLabel(GraphicsInfo info) | Deltares.Geometry.Forms.DrawingObject | virtual
Drop(object data) | Deltares.Geometry.Forms.DrawingObject | virtual
EndMove(IProjection projection, Point2D startPosition, SizeF worldSize) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetCardinalDirectionOnEdgeContainingPoint(Point point) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetDataObject() | Deltares.Geotechnics.Forms.DrawingSoilProfile1D | virtual
GetExtents(IProjection projection) | Deltares.Geotechnics.Forms.DrawingSoilProfile1D | virtual
GetScaled3DPoint(IProjection projection, Point3D aOrginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScaled3DPoint(IProjection projection, Point3D aOrginalPoint, ref Point3D aPointTobeScaled) | Deltares.Geometry.Forms.DrawingObject |
GetScaledXPoint(IProjection projection, double aOrginalCordinate) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, Point2D orginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, Point3D orginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, double x, double z) | Deltares.Geometry.Forms.DrawingObject |
GetStandardSize(object aDraw3DInterface, Point3D aPoint3D) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetThickness(GraphicsInfo info) | Deltares.Geometry.Forms.DrawingObject | protectedvirtual
HasBeenUpdated (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
IsDragableOnReslultMode (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
IsVisible (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
Layer (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
Left | Deltares.Geotechnics.Forms.DrawingSoilProfile1D |
Move(IProjection projection, Point2D startPosition, SizeF worldSize) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
Name | Deltares.Geometry.Forms.DrawingObject |
OnBeginDrag(IProjection projection, Point3D aBeginDragDropPoint, bool isIndividualDrag) | Deltares.Geotechnics.Forms.DrawingSoilProfile1D | virtual
OnDragging(IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D) | Deltares.Geometry.Forms.DrawingObject | virtual
OnEndDrag(IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D) | Deltares.Geotechnics.Forms.DrawingSoilProfile1D | virtual
Right | Deltares.Geotechnics.Forms.DrawingSoilProfile1D |
Selected | Deltares.Geometry.Forms.DrawingObject |
SetDataObject(object dataObject) | Deltares.Geotechnics.Forms.DrawingSoilProfile1D | virtual
ToolTip | Deltares.Geometry.Forms.DrawingObject |
Top | Deltares.Geotechnics.Forms.DrawingSoilProfile1D |
ToString() (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
UpdateDataDragDrop(Point3D beginDragPoint, Vector3D vector) | Deltares.Geotechnics.Forms.DrawingSoilProfile1D | virtual
Deltares::Geometry::Forms::DrawingObject.UpdateDataDragDrop(Vector3D aVect3D, List< IDrawingObject > aDraggedObjects) | Deltares.Geometry.Forms.DrawingObject | virtual
Width | Deltares.Geotechnics.Forms.DrawingSoilProfile1D |
X | Deltares.Geotechnics.Forms.DrawingSoilProfile1D |
Z | Deltares.Geotechnics.Forms.DrawingSoilProfile1D |
Generated on Tue Dec 15 2015 18:14:09 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.Forms.DrawingSoilSurface Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • DrawingSoilSurface
Public Member Functions | Protected Member Functions | List of all members
Deltares.Geotechnics.Forms.DrawingSoilSurface Class Reference

Drawing object that represents 2D soil layers (SoilLayer2D) entities in the geometry (crossection) editor. More...

Inheritance diagram for Deltares.Geotechnics.Forms.DrawingSoilSurface:
Deltares.Geometry.Forms.DrawingObject Deltares.Geometry.Forms.IDrawingObject Deltares.Standard.Forms.IShape Deltares.Geotechnics.Forms.DrawingSoilLayerSurface

Public Member Functions

override void | SetDataObject (object aDataObject)
override The SetDataObject() Method More...
override object | GetDataObject ()
override The GetDataObject() Method And Rturns DataObject of SoilSurface More...
override bool | AllowDrop (object data)
Boolean which indicates if other drawing objects can be dropped on given drawing objects More...
override void | Drop (object data)
Ends a drag-drop operation More...
override void | OnBeginDrag (IProjection projection, Point3D aBeginDragDropPoint, bool isIndividualDrag)
Method which is called when the user initiates a drag-drop operation More...
override void | UpdateDataDragDrop (Point3D beginDragPoint, Vector3D vector)
override The UpdateDataDragDrop() Method More...
override bool | ContainsPoint (IProjection projection, Point point)
Determines if a given point screen coordinate is within the drawing object. More...
override void | Draw3D (GraphicsInfo info)
override The Draw3D() Method More...
override void | DrawLabel (GraphicsInfo info)
Renders a label or tooltip to provide some information in text for this object. More...
void | Dispose ()
- Public Member Functions inherited from Deltares.Geometry.Forms.DrawingObject
Point3D | GetScaled3DPoint (IProjection projection, Point3D aOrginalPoint)
Converts the 3DPoint to screen coordinates More...
Point3D | GetScreenPoint (IProjection projection, Point2D orginalPoint)
Converts Point from 3D space to screen coordinates, assuming Y = 0 More...
Point3D | GetScreenPoint (IProjection projection, Point3D orginalPoint)
Converts Point from 3D space to screen coordinates More...
Point3D | GetScreenPoint (IProjection projection, double x, double z)
Converts 3D x, y coordinates to screen coordinates, assuming Y = 0 More...
override string | ToString ()
virtual void | UpdateDataDragDrop (Vector3D aVect3D, List< IDrawingObject > aDraggedObjects)
Update the position and or orientation of a drawing object as the user is dragging it. More...
virtual CardinalDirection | GetCardinalDirectionOnEdgeContainingPoint (Point point)
virtual void | OnDragging (IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D)
Method which is called during drag-drop operations More...
virtual void | OnEndDrag (IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D)
Method which is called when the user ends a drag-drop operation. More...
virtual bool | CheckHitForSelection (IProjection projection, Point3D point, double tolerance)
Check if given point coordinates intersect the rendered drawing object. More...
virtual double | GetStandardSize (object aDraw3DInterface, Point3D aPoint3D)
void | GetScaled3DPoint (IProjection projection, Point3D aOrginalPoint, ref Point3D aPointTobeScaled)
Converts the 3DPoint to screen coordinates More...
double | GetScaledXPoint (IProjection projection, double aOrginalCordinate)
Converts X Coordinate in 3D space to a screen X Coordinate More...
virtual Rectangle | GetExtents (IProjection projection)
Returns the bounding box of the shape. More...
virtual void | Draw (GraphicsInfo info)
Render this object in 3D space. More...
virtual void | Move (IProjection projection, Point2D startPosition, SizeF worldSize)
virtual void | BeginMove (IProjection projection, Point2D startPosition)
virtual void | EndMove (IProjection projection, Point2D startPosition, SizeF worldSize)
virtual IEnumerable< object > | DataItemAt (Point point, Projection projection)

Protected Member Functions

Color | GetColor (GraphicsInfo info)
void | SetDrawingProperties (GraphicsInfo info, Color color)
- Protected Member Functions inherited from Deltares.Geometry.Forms.DrawingObject
virtual int | GetThickness (GraphicsInfo info)
Gets the thickness in screen pixels of a drawing object. More...

Additional Inherited Members

- Properties inherited from Deltares.Geometry.Forms.DrawingObject
virtual bool | CanResize [get]
Boolean which indicates if a drawing object can be resized. More...
virtual bool | Selected [get, set]
Boolean which indicates if a drawing object is currently selected. More...
string | ToolTip [get]
Description which is shown as a tooltip when the mouse hovers over drawing object. More...
string | Name [get, set]
Gets or sets the name of a drawing object. More...
bool | IsVisible [get, set]
bool | HasBeenUpdated [get, set]
virtual bool | IsDragableOnReslultMode [get]
virtual int | Layer [get, set]
object | DataObject [get, set]
- Properties inherited from Deltares.Geometry.Forms.IDrawingObject
string | Name [get, set]
bool | IsVisible [get, set]
bool | HasBeenUpdated [get, set]
Gets or sets the update status of a drawing object. More...
bool | IsDragableOnReslultMode [get]
- Properties inherited from Deltares.Standard.Forms.IShape
object | DataObject [get, set]
int | Layer [get]

Detailed Description

Drawing object that represents 2D soil layers (SoilLayer2D) entities in the geometry (crossection) editor.

Member Function Documentation

override bool Deltares.Geotechnics.Forms.DrawingSoilSurface.AllowDrop ( object data )
virtual

Boolean which indicates if other drawing objects can be dropped on given drawing objects

Parameters
data
Returns

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

override bool Deltares.Geotechnics.Forms.DrawingSoilSurface.ContainsPoint | ( | IProjection | projection,
 |  | Point | point
 | ) |  |
virtual

Determines if a given point screen coordinate is within the drawing object.

Parameters
projection | Projection used for drawing
point | Point in screen coordinates.
Returns
True if given point is within the rendered drawing object.

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

override void Deltares.Geotechnics.Forms.DrawingSoilSurface.Draw3D ( GraphicsInfo info )
virtual

override The Draw3D() Method

Parameters
aDraw3D

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

override void Deltares.Geotechnics.Forms.DrawingSoilSurface.DrawLabel ( GraphicsInfo info )
virtual

Renders a label or tooltip to provide some information in text for this object.

Parameters
info Rendering target information.

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

References Deltares.Standard.Forms.DrawingSupport.DrawLabelAtPoint(), Deltares.Standard.Forms.DrawingSupport.GetDarkerColor(), and Deltares.Standard.Forms.DrawingSupport.GetLighterColor().

override void Deltares.Geotechnics.Forms.DrawingSoilSurface.Drop ( object data )
virtual

Ends a drag-drop operation

Parameters
data

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

override object Deltares.Geotechnics.Forms.DrawingSoilSurface.GetDataObject ( )
virtual

override The GetDataObject() Method And Rturns DataObject of SoilSurface

Returns

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

override void Deltares.Geotechnics.Forms.DrawingSoilSurface.OnBeginDrag | ( | IProjection | projection,
 |  | Point3D | aBeginDragDropPoint,
 |  | bool | isIndividualDrag
 | ) |  |
virtual

Method which is called when the user initiates a drag-drop operation

Parameters
projection | Current projection of 3D to screen coordinates.
aBeginDragDropPoint | Initial position of the mouse pointer.
isIndividualDrag

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

override void Deltares.Geotechnics.Forms.DrawingSoilSurface.SetDataObject ( object aDataObject )
virtual

override The SetDataObject() Method

Parameters
aDataObject

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

override void Deltares.Geotechnics.Forms.DrawingSoilSurface.UpdateDataDragDrop | ( | Point3D | beginDragPoint,
 |  | Vector3D | vector
 | ) |  |
virtual

override The UpdateDataDragDrop() Method

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

Generated on Tue Dec 15 2015 18:14:09 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • DrawingSoilSurface
Deltares.Geotechnics.Forms.DrawingSoilSurface Member List

This is the complete list of members for Deltares.Geotechnics.Forms.DrawingSoilSurface, including all inherited members.

AllowDrop(object data) | Deltares.Geotechnics.Forms.DrawingSoilSurface | virtual
BeginMove(IProjection projection, Point2D startPosition) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
CanResize | Deltares.Geometry.Forms.DrawingObject |
CheckHitForSelection(IProjection projection, Point3D point, double tolerance) | Deltares.Geometry.Forms.DrawingObject | virtual
ContainsPoint(IProjection projection, Point point) | Deltares.Geotechnics.Forms.DrawingSoilSurface | virtual
DataItemAt(Point point, Projection projection) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
DataObject (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
Dispose() (defined in Deltares.Geotechnics.Forms.DrawingSoilSurface) | Deltares.Geotechnics.Forms.DrawingSoilSurface |
Draw(GraphicsInfo info) | Deltares.Geometry.Forms.DrawingObject | virtual
Draw3D(GraphicsInfo info) | Deltares.Geotechnics.Forms.DrawingSoilSurface | virtual
DrawingObject() (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
DrawingSoilSurface() (defined in Deltares.Geotechnics.Forms.DrawingSoilSurface) | Deltares.Geotechnics.Forms.DrawingSoilSurface |
DrawLabel(GraphicsInfo info) | Deltares.Geotechnics.Forms.DrawingSoilSurface | virtual
Drop(object data) | Deltares.Geotechnics.Forms.DrawingSoilSurface | virtual
EndMove(IProjection projection, Point2D startPosition, SizeF worldSize) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetCardinalDirectionOnEdgeContainingPoint(Point point) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetColor(GraphicsInfo info) (defined in Deltares.Geotechnics.Forms.DrawingSoilSurface) | Deltares.Geotechnics.Forms.DrawingSoilSurface | protected
GetDataObject() | Deltares.Geotechnics.Forms.DrawingSoilSurface | virtual
GetExtents(IProjection projection) | Deltares.Geometry.Forms.DrawingObject | virtual
GetScaled3DPoint(IProjection projection, Point3D aOrginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScaled3DPoint(IProjection projection, Point3D aOrginalPoint, ref Point3D aPointTobeScaled) | Deltares.Geometry.Forms.DrawingObject |
GetScaledXPoint(IProjection projection, double aOrginalCordinate) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, Point2D orginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, Point3D orginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, double x, double z) | Deltares.Geometry.Forms.DrawingObject |
GetStandardSize(object aDraw3DInterface, Point3D aPoint3D) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetThickness(GraphicsInfo info) | Deltares.Geometry.Forms.DrawingObject | protectedvirtual
HasBeenUpdated (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
IsDragableOnReslultMode (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
IsVisible (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
Layer (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
Move(IProjection projection, Point2D startPosition, SizeF worldSize) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
Name | Deltares.Geometry.Forms.DrawingObject |
OnBeginDrag(IProjection projection, Point3D aBeginDragDropPoint, bool isIndividualDrag) | Deltares.Geotechnics.Forms.DrawingSoilSurface | virtual
OnDragging(IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D) | Deltares.Geometry.Forms.DrawingObject | virtual
OnEndDrag(IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D) | Deltares.Geometry.Forms.DrawingObject | virtual
Selected | Deltares.Geometry.Forms.DrawingObject |
SetDataObject(object aDataObject) | Deltares.Geotechnics.Forms.DrawingSoilSurface | virtual
SetDrawingProperties(GraphicsInfo info, Color color) (defined in Deltares.Geotechnics.Forms.DrawingSoilSurface) | Deltares.Geotechnics.Forms.DrawingSoilSurface | protected
ToolTip | Deltares.Geometry.Forms.DrawingObject |
ToString() (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
UpdateDataDragDrop(Point3D beginDragPoint, Vector3D vector) | Deltares.Geotechnics.Forms.DrawingSoilSurface | virtual
Deltares::Geometry::Forms::DrawingObject.UpdateDataDragDrop(Vector3D aVect3D, List< IDrawingObject > aDraggedObjects) | Deltares.Geometry.Forms.DrawingObject | virtual
Generated on Tue Dec 15 2015 18:14:09 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.Forms.DrawingSpecificMechanismPointLocation Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • DrawingSpecificMechanismPointLocation
Public Member Functions | Properties | List of all members
Deltares.Geotechnics.Forms.DrawingSpecificMechanismPointLocation Class Reference

Drawing class for a new specific point for a mechanism (like Piping Location), which draws a simple square into a 2D Soil Profile. Simplicfication of DrawingCPT class. More...

Inheritance diagram for Deltares.Geotechnics.Forms.DrawingSpecificMechanismPointLocation:
Deltares.Geometry.Forms.DrawingObject Deltares.Geometry.Forms.IDrawingObject Deltares.Standard.Forms.IShape

Public Member Functions

double | TopForDrawing ()
Tops for drawing. More...
double | BottomForDrawing ()
Bottoms for drawing. More...
double | WidthForDrawing ()
Width for drawing. More...
override void | SetDataObject (object dataObject)
Sets the data object (SpecificMechanismPointLocation). More...
override object | GetDataObject ()
Gets the data object. More...
override void | Draw3D (GraphicsInfo info)
Draws the Point Location. More...
override void | DrawLabel (GraphicsInfo info)
Draws the label. More...
override void | OnBeginDrag (IProjection projection, Point3D aBeginDragDropPoint, bool isIndividualDrag)
Called when [begin drag]. More...
override void | UpdateDataDragDrop (Point3D beginDragPoint, Vector3D vector)
Updates the data drag drop. More...
override void | OnEndDrag (IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D)
Called when [end drag]. More...
override bool | ContainsPoint (IProjection projection, Point point)
Determines whether the specified projection contains the given point. More...
override Rectangle | GetExtents (IProjection projection)
Gets the extents. More...
- Public Member Functions inherited from Deltares.Geometry.Forms.DrawingObject
Point3D | GetScaled3DPoint (IProjection projection, Point3D aOrginalPoint)
Converts the 3DPoint to screen coordinates More...
Point3D | GetScreenPoint (IProjection projection, Point2D orginalPoint)
Converts Point from 3D space to screen coordinates, assuming Y = 0 More...
Point3D | GetScreenPoint (IProjection projection, Point3D orginalPoint)
Converts Point from 3D space to screen coordinates More...
Point3D | GetScreenPoint (IProjection projection, double x, double z)
Converts 3D x, y coordinates to screen coordinates, assuming Y = 0 More...
override string | ToString ()
virtual void | UpdateDataDragDrop (Vector3D aVect3D, List< IDrawingObject > aDraggedObjects)
Update the position and or orientation of a drawing object as the user is dragging it. More...
virtual CardinalDirection | GetCardinalDirectionOnEdgeContainingPoint (Point point)
virtual void | OnDragging (IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D)
Method which is called during drag-drop operations More...
virtual bool | CheckHitForSelection (IProjection projection, Point3D point, double tolerance)
Check if given point coordinates intersect the rendered drawing object. More...
virtual double | GetStandardSize (object aDraw3DInterface, Point3D aPoint3D)
void | GetScaled3DPoint (IProjection projection, Point3D aOrginalPoint, ref Point3D aPointTobeScaled)
Converts the 3DPoint to screen coordinates More...
double | GetScaledXPoint (IProjection projection, double aOrginalCordinate)
Converts X Coordinate in 3D space to a screen X Coordinate More...
virtual void | Draw (GraphicsInfo info)
Render this object in 3D space. More...
virtual void | Move (IProjection projection, Point2D startPosition, SizeF worldSize)
virtual void | BeginMove (IProjection projection, Point2D startPosition)
virtual void | EndMove (IProjection projection, Point2D startPosition, SizeF worldSize)
virtual bool | AllowDrop (object data)
Boolean which indicates if other drawing objects can be dropped on given drawing objects More...
virtual void | Drop (object data)
Ends a drag-drop operation More...
virtual IEnumerable< object > | DataItemAt (Point point, Projection projection)

Properties

bool | ShowAxes [get, set]
Gets or sets a value indicating whether the axes will be shown. More...
double | X [get]
Gets the x. More...
double | Left [get]
Gets the left. More...
double | Right [get]
Gets the right. More...
- Properties inherited from Deltares.Geometry.Forms.DrawingObject
virtual bool | CanResize [get]
Boolean which indicates if a drawing object can be resized. More...
virtual bool | Selected [get, set]
Boolean which indicates if a drawing object is currently selected. More...
string | ToolTip [get]
Description which is shown as a tooltip when the mouse hovers over drawing object. More...
string | Name [get, set]
Gets or sets the name of a drawing object. More...
bool | IsVisible [get, set]
bool | HasBeenUpdated [get, set]
virtual bool | IsDragableOnReslultMode [get]
virtual int | Layer [get, set]
object | DataObject [get, set]
- Properties inherited from Deltares.Geometry.Forms.IDrawingObject
string | Name [get, set]
bool | IsVisible [get, set]
bool | HasBeenUpdated [get, set]
Gets or sets the update status of a drawing object. More...
bool | IsDragableOnReslultMode [get]
- Properties inherited from Deltares.Standard.Forms.IShape
object | DataObject [get, set]
int | Layer [get]

Additional Inherited Members

- Protected Member Functions inherited from Deltares.Geometry.Forms.DrawingObject
virtual int GetThickness (GraphicsInfo info)
Gets the thickness in screen pixels of a drawing object. More...

Detailed Description

Drawing class for a new specific point for a mechanism (like Piping Location), which draws a simple square into a 2D Soil Profile. Simplicfication of DrawingCPT class.

Member Function Documentation

double Deltares.Geotechnics.Forms.DrawingSpecificMechanismPointLocation.BottomForDrawing ( )

Bottoms for drawing.

override bool Deltares.Geotechnics.Forms.DrawingSpecificMechanismPointLocation.ContainsPoint | ( | IProjection | projection,
 |  | Point | point
 | ) |  |
virtual

Determines whether the specified projection contains the given point.

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

override void Deltares.Geotechnics.Forms.DrawingSpecificMechanismPointLocation.Draw3D ( GraphicsInfo info )
virtual

Draws the Point Location.

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

References Deltares.Standard.Forms.DrawingSupport.SetIEPDraw3D().

override void Deltares.Geotechnics.Forms.DrawingSpecificMechanismPointLocation.DrawLabel ( GraphicsInfo info )
virtual

Draws the label.

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

References Deltares.Standard.Forms.DrawingSupport.DrawLabelAtPoint(), Deltares.Standard.Forms.DrawingSupport.GetDarkerColor(), and Deltares.Standard.Forms.DrawingSupport.GetLighterColor().

override object Deltares.Geotechnics.Forms.DrawingSpecificMechanismPointLocation.GetDataObject ( )
virtual

Gets the data object.

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

override Rectangle Deltares.Geotechnics.Forms.DrawingSpecificMechanismPointLocation.GetExtents ( IProjection projection )
virtual

Gets the extents.

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

override void Deltares.Geotechnics.Forms.DrawingSpecificMechanismPointLocation.OnBeginDrag | ( | IProjection | projection,
 |  | Point3D | aBeginDragDropPoint,
 |  | bool | isIndividualDrag
 | ) |  |
virtual

Called when [begin drag].

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

override void Deltares.Geotechnics.Forms.DrawingSpecificMechanismPointLocation.OnEndDrag | ( | IProjection | projection,
 |  | Point3D | aCurrentDragPoint,
 |  | Vector3D | aVect3D
 | ) |  |
virtual

Called when [end drag].

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

override void Deltares.Geotechnics.Forms.DrawingSpecificMechanismPointLocation.SetDataObject ( object dataObject )
virtual

Sets the data object (SpecificMechanismPointLocation).

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

double Deltares.Geotechnics.Forms.DrawingSpecificMechanismPointLocation.TopForDrawing ( )

Tops for drawing.

override void Deltares.Geotechnics.Forms.DrawingSpecificMechanismPointLocation.UpdateDataDragDrop | ( | Point3D | beginDragPoint,
 |  | Vector3D | vector
 | ) |  |
virtual

Updates the data drag drop.

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

double Deltares.Geotechnics.Forms.DrawingSpecificMechanismPointLocation.WidthForDrawing ( )

Width for drawing.

Property Documentation

double Deltares.Geotechnics.Forms.DrawingSpecificMechanismPointLocation.Left
get

Gets the left.

double Deltares.Geotechnics.Forms.DrawingSpecificMechanismPointLocation.Right
get

Gets the right.

bool Deltares.Geotechnics.Forms.DrawingSpecificMechanismPointLocation.ShowAxes
getset

Gets or sets a value indicating whether the axes will be shown.

double Deltares.Geotechnics.Forms.DrawingSpecificMechanismPointLocation.X
get

Gets the x.

Generated on Tue Dec 15 2015 18:14:09 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • DrawingSpecificMechanismPointLocation
Deltares.Geotechnics.Forms.DrawingSpecificMechanismPointLocation Member List

This is the complete list of members for Deltares.Geotechnics.Forms.DrawingSpecificMechanismPointLocation, including all inherited members.

AllowDrop(object data) | Deltares.Geometry.Forms.DrawingObject | virtual
BeginMove(IProjection projection, Point2D startPosition) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
BottomForDrawing() | Deltares.Geotechnics.Forms.DrawingSpecificMechanismPointLocation |
CanResize | Deltares.Geometry.Forms.DrawingObject |
CheckHitForSelection(IProjection projection, Point3D point, double tolerance) | Deltares.Geometry.Forms.DrawingObject | virtual
ContainsPoint(IProjection projection, Point point) | Deltares.Geotechnics.Forms.DrawingSpecificMechanismPointLocation | virtual
DataItemAt(Point point, Projection projection) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
DataObject (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
Draw(GraphicsInfo info) | Deltares.Geometry.Forms.DrawingObject | virtual
Draw3D(GraphicsInfo info) | Deltares.Geotechnics.Forms.DrawingSpecificMechanismPointLocation | virtual
DrawingObject() (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
DrawLabel(GraphicsInfo info) | Deltares.Geotechnics.Forms.DrawingSpecificMechanismPointLocation | virtual
Drop(object data) | Deltares.Geometry.Forms.DrawingObject | virtual
EndMove(IProjection projection, Point2D startPosition, SizeF worldSize) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetCardinalDirectionOnEdgeContainingPoint(Point point) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetDataObject() | Deltares.Geotechnics.Forms.DrawingSpecificMechanismPointLocation | virtual
GetExtents(IProjection projection) | Deltares.Geotechnics.Forms.DrawingSpecificMechanismPointLocation | virtual
GetScaled3DPoint(IProjection projection, Point3D aOrginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScaled3DPoint(IProjection projection, Point3D aOrginalPoint, ref Point3D aPointTobeScaled) | Deltares.Geometry.Forms.DrawingObject |
GetScaledXPoint(IProjection projection, double aOrginalCordinate) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, Point2D orginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, Point3D orginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, double x, double z) | Deltares.Geometry.Forms.DrawingObject |
GetStandardSize(object aDraw3DInterface, Point3D aPoint3D) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetThickness(GraphicsInfo info) | Deltares.Geometry.Forms.DrawingObject | protectedvirtual
HasBeenUpdated (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
IsDragableOnReslultMode (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
IsVisible (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
Layer (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
Left | Deltares.Geotechnics.Forms.DrawingSpecificMechanismPointLocation |
Move(IProjection projection, Point2D startPosition, SizeF worldSize) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
Name | Deltares.Geometry.Forms.DrawingObject |
OnBeginDrag(IProjection projection, Point3D aBeginDragDropPoint, bool isIndividualDrag) | Deltares.Geotechnics.Forms.DrawingSpecificMechanismPointLocation | virtual
OnDragging(IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D) | Deltares.Geometry.Forms.DrawingObject | virtual
OnEndDrag(IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D) | Deltares.Geotechnics.Forms.DrawingSpecificMechanismPointLocation | virtual
Right | Deltares.Geotechnics.Forms.DrawingSpecificMechanismPointLocation |
Selected | Deltares.Geometry.Forms.DrawingObject |
SetDataObject(object dataObject) | Deltares.Geotechnics.Forms.DrawingSpecificMechanismPointLocation | virtual
ShowAxes | Deltares.Geotechnics.Forms.DrawingSpecificMechanismPointLocation |
ToolTip | Deltares.Geometry.Forms.DrawingObject |
TopForDrawing() | Deltares.Geotechnics.Forms.DrawingSpecificMechanismPointLocation |
ToString() (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
UpdateDataDragDrop(Point3D beginDragPoint, Vector3D vector) | Deltares.Geotechnics.Forms.DrawingSpecificMechanismPointLocation | virtual
Deltares::Geometry::Forms::DrawingObject.UpdateDataDragDrop(Vector3D aVect3D, List< IDrawingObject > aDraggedObjects) | Deltares.Geometry.Forms.DrawingObject | virtual
WidthForDrawing() | Deltares.Geotechnics.Forms.DrawingSpecificMechanismPointLocation |
X | Deltares.Geotechnics.Forms.DrawingSpecificMechanismPointLocation |
Generated on Tue Dec 15 2015 18:14:09 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.Forms.DrawingSurfaceLine2 Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • DrawingSurfaceLine2
Public Member Functions | Public Attributes | Properties | List of all members
Deltares.Geotechnics.Forms.DrawingSurfaceLine2 Class Reference
Inheritance diagram for Deltares.Geotechnics.Forms.DrawingSurfaceLine2:
Deltares.Geometry.Forms.DrawingObject Deltares.Geometry.Forms.IDrawingObject Deltares.Standard.Forms.IShape

Public Member Functions

override void | SetDataObject (object dataobject)
Sets the geotechnics entity that this drawing object represents More...
override object | GetDataObject ()
Gets the geotechnics entity that this drawing object represents More...
override void | UpdateDataDragDrop (Point3D beginDragPoint, Vector3D vector)
override The UpdateDataDragDrop() Method More...
override void | Draw3D (GraphicsInfo info)
override The Draw3D() Method More...
override void | DrawLabel (GraphicsInfo info)
Renders a label or tooltip to provide some information in text for this object. More...
- Public Member Functions inherited from Deltares.Geometry.Forms.DrawingObject
Point3D | GetScaled3DPoint (IProjection projection, Point3D aOrginalPoint)
Converts the 3DPoint to screen coordinates More...
Point3D | GetScreenPoint (IProjection projection, Point2D orginalPoint)
Converts Point from 3D space to screen coordinates, assuming Y = 0 More...
Point3D | GetScreenPoint (IProjection projection, Point3D orginalPoint)
Converts Point from 3D space to screen coordinates More...
Point3D | GetScreenPoint (IProjection projection, double x, double z)
Converts 3D x, y coordinates to screen coordinates, assuming Y = 0 More...
override string | ToString ()
virtual void | UpdateDataDragDrop (Vector3D aVect3D, List< IDrawingObject > aDraggedObjects)
Update the position and or orientation of a drawing object as the user is dragging it. More...
virtual void | OnBeginDrag (IProjection projection, Point3D aBeginDragDropPoint, bool isIndividualDrag)
Method which is called when the user initiates a drag-drop operation More...
virtual CardinalDirection | GetCardinalDirectionOnEdgeContainingPoint (Point point)
virtual void | OnDragging (IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D)
Method which is called during drag-drop operations More...
virtual void | OnEndDrag (IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D)
Method which is called when the user ends a drag-drop operation. More...
virtual bool | CheckHitForSelection (IProjection projection, Point3D point, double tolerance)
Check if given point coordinates intersect the rendered drawing object. More...
virtual double | GetStandardSize (object aDraw3DInterface, Point3D aPoint3D)
void | GetScaled3DPoint (IProjection projection, Point3D aOrginalPoint, ref Point3D aPointTobeScaled)
Converts the 3DPoint to screen coordinates More...
double | GetScaledXPoint (IProjection projection, double aOrginalCordinate)
Converts X Coordinate in 3D space to a screen X Coordinate More...
virtual bool | ContainsPoint (IProjection projection, Point point)
Determines if a given point screen coordinate is within the drawing object. More...
virtual Rectangle | GetExtents (IProjection projection)
Returns the bounding box of the shape. More...
virtual void | Draw (GraphicsInfo info)
Render this object in 3D space. More...
virtual void | Move (IProjection projection, Point2D startPosition, SizeF worldSize)
virtual void | BeginMove (IProjection projection, Point2D startPosition)
virtual void | EndMove (IProjection projection, Point2D startPosition, SizeF worldSize)
virtual bool | AllowDrop (object data)
Boolean which indicates if other drawing objects can be dropped on given drawing objects More...
virtual void | Drop (object data)
Ends a drag-drop operation More...
virtual IEnumerable< object > | DataItemAt (Point point, Projection projection)

Public Attributes

const double HorizonDistance = 4e7
Distance factor used when drawing to infinity. More...

Properties

static bool | DrawToPositiveInfinity [get, set]
Indicates if the 'positive' endpoint of the surfaceline should be drawn at infinity. More...
static bool | DrawToNegativeInfinity [get, set]
Indicates if the 'negative' endpoint of the sufaceline should be drawn at minus infinity. More...
virtual int | LineDefaultThickness [get, set]
Color | LineColor [get, set]
- Properties inherited from Deltares.Geometry.Forms.DrawingObject
virtual bool | CanResize [get]
Boolean which indicates if a drawing object can be resized. More...
virtual bool | Selected [get, set]
Boolean which indicates if a drawing object is currently selected. More...
string | ToolTip [get]
Description which is shown as a tooltip when the mouse hovers over drawing object. More...
string | Name [get, set]
Gets or sets the name of a drawing object. More...
bool | IsVisible [get, set]
bool | HasBeenUpdated [get, set]
virtual bool | IsDragableOnReslultMode [get]
virtual int | Layer [get, set]
object | DataObject [get, set]
- Properties inherited from Deltares.Geometry.Forms.IDrawingObject
string | Name [get, set]
bool | IsVisible [get, set]
bool | HasBeenUpdated [get, set]
Gets or sets the update status of a drawing object. More...
bool | IsDragableOnReslultMode [get]
- Properties inherited from Deltares.Standard.Forms.IShape
object | DataObject [get, set]
int | Layer [get]

Additional Inherited Members

- Protected Member Functions inherited from Deltares.Geometry.Forms.DrawingObject
virtual int GetThickness (GraphicsInfo info)
Gets the thickness in screen pixels of a drawing object. More...

Member Function Documentation

override void Deltares.Geotechnics.Forms.DrawingSurfaceLine2.Draw3D ( GraphicsInfo info )
virtual

override The Draw3D() Method

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

References Deltares.Standard.Forms.DrawingSupport.Brush3D(), Deltares.Standard.Forms.DrawingSupport.ColorMaterial3D(), Deltares.Standard.Forms.DrawingSupport.Line3D(), Deltares.Standard.Forms.DrawingSupport.Pen3D(), and Deltares.Standard.Forms.DrawingSupport.SetIEPDraw3D().

override void Deltares.Geotechnics.Forms.DrawingSurfaceLine2.DrawLabel ( GraphicsInfo info )
virtual

Renders a label or tooltip to provide some information in text for this object.

Parameters
info Rendering target information.

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

References Deltares.Standard.Forms.DrawingSupport.DrawLabelAtPoint().

override object Deltares.Geotechnics.Forms.DrawingSurfaceLine2.GetDataObject ( )
virtual

Gets the geotechnics entity that this drawing object represents

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

override void Deltares.Geotechnics.Forms.DrawingSurfaceLine2.SetDataObject ( object aDataObject )
virtual

Sets the geotechnics entity that this drawing object represents

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

override void Deltares.Geotechnics.Forms.DrawingSurfaceLine2.UpdateDataDragDrop | ( | Point3D | beginDragPoint,
 |  | Vector3D | vector
 | ) |  |
virtual

override The UpdateDataDragDrop() Method

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

Member Data Documentation

const double Deltares.Geotechnics.Forms.DrawingSurfaceLine2.HorizonDistance = 4e7

Distance factor used when drawing to infinity.

See also
DrawToPositiveInfinity, DrawToNegativeInfinity

Property Documentation

bool Deltares.Geotechnics.Forms.DrawingSurfaceLine2.DrawToNegativeInfinity
staticgetset

Indicates if the 'negative' endpoint of the sufaceline should be drawn at minus infinity.

bool Deltares.Geotechnics.Forms.DrawingSurfaceLine2.DrawToPositiveInfinity
staticgetset

Indicates if the 'positive' endpoint of the surfaceline should be drawn at infinity.

Generated on Tue Dec 15 2015 18:14:10 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • DrawingSurfaceLine2
Deltares.Geotechnics.Forms.DrawingSurfaceLine2 Member List

This is the complete list of members for Deltares.Geotechnics.Forms.DrawingSurfaceLine2, including all inherited members.

AllowDrop(object data) | Deltares.Geometry.Forms.DrawingObject | virtual
BeginMove(IProjection projection, Point2D startPosition) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
CanResize | Deltares.Geometry.Forms.DrawingObject |
CheckHitForSelection(IProjection projection, Point3D point, double tolerance) | Deltares.Geometry.Forms.DrawingObject | virtual
ContainsPoint(IProjection projection, Point point) | Deltares.Geometry.Forms.DrawingObject | virtual
DataItemAt(Point point, Projection projection) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
DataObject (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
Draw(GraphicsInfo info) | Deltares.Geometry.Forms.DrawingObject | virtual
Draw3D(GraphicsInfo info) | Deltares.Geotechnics.Forms.DrawingSurfaceLine2 | virtual
DrawingObject() (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
DrawingSurfaceLine2() (defined in Deltares.Geotechnics.Forms.DrawingSurfaceLine2) | Deltares.Geotechnics.Forms.DrawingSurfaceLine2 |
DrawLabel(GraphicsInfo info) | Deltares.Geotechnics.Forms.DrawingSurfaceLine2 | virtual
DrawToNegativeInfinity | Deltares.Geotechnics.Forms.DrawingSurfaceLine2 | static
DrawToPositiveInfinity | Deltares.Geotechnics.Forms.DrawingSurfaceLine2 | static
Drop(object data) | Deltares.Geometry.Forms.DrawingObject | virtual
EndMove(IProjection projection, Point2D startPosition, SizeF worldSize) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetCardinalDirectionOnEdgeContainingPoint(Point point) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetDataObject() | Deltares.Geotechnics.Forms.DrawingSurfaceLine2 | virtual
GetExtents(IProjection projection) | Deltares.Geometry.Forms.DrawingObject | virtual
GetScaled3DPoint(IProjection projection, Point3D aOrginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScaled3DPoint(IProjection projection, Point3D aOrginalPoint, ref Point3D aPointTobeScaled) | Deltares.Geometry.Forms.DrawingObject |
GetScaledXPoint(IProjection projection, double aOrginalCordinate) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, Point2D orginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, Point3D orginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, double x, double z) | Deltares.Geometry.Forms.DrawingObject |
GetStandardSize(object aDraw3DInterface, Point3D aPoint3D) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetThickness(GraphicsInfo info) | Deltares.Geometry.Forms.DrawingObject | protectedvirtual
HasBeenUpdated (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
HorizonDistance | Deltares.Geotechnics.Forms.DrawingSurfaceLine2 |
IsDragableOnReslultMode (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
IsVisible (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
Layer (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
LineColor (defined in Deltares.Geotechnics.Forms.DrawingSurfaceLine2) | Deltares.Geotechnics.Forms.DrawingSurfaceLine2 | protected
LineDefaultThickness (defined in Deltares.Geotechnics.Forms.DrawingSurfaceLine2) | Deltares.Geotechnics.Forms.DrawingSurfaceLine2 | protected
Move(IProjection projection, Point2D startPosition, SizeF worldSize) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
Name | Deltares.Geometry.Forms.DrawingObject |
OnBeginDrag(IProjection projection, Point3D aBeginDragDropPoint, bool isIndividualDrag) | Deltares.Geometry.Forms.DrawingObject | virtual
OnDragging(IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D) | Deltares.Geometry.Forms.DrawingObject | virtual
OnEndDrag(IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D) | Deltares.Geometry.Forms.DrawingObject | virtual
Selected | Deltares.Geometry.Forms.DrawingObject |
SetDataObject(object dataobject) | Deltares.Geotechnics.Forms.DrawingSurfaceLine2 | virtual
ToolTip | Deltares.Geometry.Forms.DrawingObject |
ToString() (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
UpdateDataDragDrop(Point3D beginDragPoint, Vector3D vector) | Deltares.Geotechnics.Forms.DrawingSurfaceLine2 | virtual
Deltares::Geometry::Forms::DrawingObject.UpdateDataDragDrop(Vector3D aVect3D, List< IDrawingObject > aDraggedObjects) | Deltares.Geometry.Forms.DrawingObject | virtual
Generated on Tue Dec 15 2015 18:14:10 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.Forms.DrawingSwell Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • DrawingSwell
Public Member Functions | Protected Member Functions | Properties | List of all members
Deltares.Geotechnics.Forms.DrawingSwell Class Reference

Draws a wave object. More...

Inheritance diagram for Deltares.Geotechnics.Forms.DrawingSwell:
Deltares.Geometry.Forms.DrawingObject Deltares.Geometry.Forms.IDrawingObject Deltares.Standard.Forms.IShape

Public Member Functions

override void | SetDataObject (object aDataObject)
Sets the data object for swell. More...
override object | GetDataObject ()
Gets the IGeometryObject for swell. More...
override void | Draw3D (GraphicsInfo info)
override The Draw3D() Method Draws the swell as a sinus on top of the waterbasin. More...
override void | DrawLabel (GraphicsInfo info)
Draws the label (name) of the swell. More...
override bool | ContainsPoint (IProjection projection, Point point)
Determines whether the specified projection contains point. More...
- Public Member Functions inherited from Deltares.Geometry.Forms.DrawingObject
Point3D | GetScaled3DPoint (IProjection projection, Point3D aOrginalPoint)
Converts the 3DPoint to screen coordinates More...
Point3D | GetScreenPoint (IProjection projection, Point2D orginalPoint)
Converts Point from 3D space to screen coordinates, assuming Y = 0 More...
Point3D | GetScreenPoint (IProjection projection, Point3D orginalPoint)
Converts Point from 3D space to screen coordinates More...
Point3D | GetScreenPoint (IProjection projection, double x, double z)
Converts 3D x, y coordinates to screen coordinates, assuming Y = 0 More...
override string | ToString ()
virtual void | UpdateDataDragDrop (Vector3D aVect3D, List< IDrawingObject > aDraggedObjects)
Update the position and or orientation of a drawing object as the user is dragging it. More...
virtual void | UpdateDataDragDrop (Point3D aBeginDragPoint, Vector3D vector)
Update the position and or orientation of a drawing object as the user is dragging it. More...
virtual void | OnBeginDrag (IProjection projection, Point3D aBeginDragDropPoint, bool isIndividualDrag)
Method which is called when the user initiates a drag-drop operation More...
virtual CardinalDirection | GetCardinalDirectionOnEdgeContainingPoint (Point point)
virtual void | OnDragging (IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D)
Method which is called during drag-drop operations More...
virtual void | OnEndDrag (IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D)
Method which is called when the user ends a drag-drop operation. More...
virtual bool | CheckHitForSelection (IProjection projection, Point3D point, double tolerance)
Check if given point coordinates intersect the rendered drawing object. More...
virtual double | GetStandardSize (object aDraw3DInterface, Point3D aPoint3D)
void | GetScaled3DPoint (IProjection projection, Point3D aOrginalPoint, ref Point3D aPointTobeScaled)
Converts the 3DPoint to screen coordinates More...
double | GetScaledXPoint (IProjection projection, double aOrginalCordinate)
Converts X Coordinate in 3D space to a screen X Coordinate More...
virtual Rectangle | GetExtents (IProjection projection)
Returns the bounding box of the shape. More...
virtual void | Draw (GraphicsInfo info)
Render this object in 3D space. More...
virtual void | Move (IProjection projection, Point2D startPosition, SizeF worldSize)
virtual void | BeginMove (IProjection projection, Point2D startPosition)
virtual void | EndMove (IProjection projection, Point2D startPosition, SizeF worldSize)
virtual bool | AllowDrop (object data)
Boolean which indicates if other drawing objects can be dropped on given drawing objects More...
virtual void | Drop (object data)
Ends a drag-drop operation More...
virtual IEnumerable< object > | DataItemAt (Point point, Projection projection)

Protected Member Functions

Color | GetColor (GraphicsInfo info)
Gets the color for the swell. More...
void | SetDrawingProperties (GraphicsInfo info, Color color)
Sets the drawing properties. More...
- Protected Member Functions inherited from Deltares.Geometry.Forms.DrawingObject
virtual int | GetThickness (GraphicsInfo info)
Gets the thickness in screen pixels of a drawing object. More...

Properties

LocalizedGeometryPointString | SurfaceLine [set]
double | LeftMostValue [set]
WaterBasin | WaterBasin [set]
- Properties inherited from Deltares.Geometry.Forms.DrawingObject
virtual bool | CanResize [get]
Boolean which indicates if a drawing object can be resized. More...
virtual bool | Selected [get, set]
Boolean which indicates if a drawing object is currently selected. More...
string | ToolTip [get]
Description which is shown as a tooltip when the mouse hovers over drawing object. More...
string | Name [get, set]
Gets or sets the name of a drawing object. More...
bool | IsVisible [get, set]
bool | HasBeenUpdated [get, set]
virtual bool | IsDragableOnReslultMode [get]
virtual int | Layer [get, set]
object | DataObject [get, set]
- Properties inherited from Deltares.Geometry.Forms.IDrawingObject
string | Name [get, set]
bool | IsVisible [get, set]
bool | HasBeenUpdated [get, set]
Gets or sets the update status of a drawing object. More...
bool | IsDragableOnReslultMode [get]
- Properties inherited from Deltares.Standard.Forms.IShape
object | DataObject [get, set]
int | Layer [get]

Detailed Description

Draws a wave object.

Member Function Documentation

override bool Deltares.Geotechnics.Forms.DrawingSwell.ContainsPoint | ( | IProjection | projection,
 |  | Point | point
 | ) |  |
virtual

Determines whether the specified projection contains point.

Parameters
projection | The projection.
point | The point.
Returns
true if the specified projection contains point; otherwise, false.

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

override void Deltares.Geotechnics.Forms.DrawingSwell.Draw3D ( GraphicsInfo info )
virtual

override The Draw3D() Method Draws the swell as a sinus on top of the waterbasin.

Parameters
info The graphics info.

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

References Deltares.Standard.Forms.DrawingSupport.CreateConvexPolygonBox().

override void Deltares.Geotechnics.Forms.DrawingSwell.DrawLabel ( GraphicsInfo info )
virtual

Draws the label (name) of the swell.

Parameters
info The graphics info.

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

References Deltares.Standard.Forms.DrawingSupport.DrawLabelAtPoint().

Color Deltares.Geotechnics.Forms.DrawingSwell.GetColor ( GraphicsInfo info )
protected

Gets the color for the swell.

Parameters
info The graphics info.
Returns

References Deltares.Standard.Forms.DrawingSupport.GetLighterColor().

override object Deltares.Geotechnics.Forms.DrawingSwell.GetDataObject ( )
virtual

Gets the IGeometryObject for swell.

Returns

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

override void Deltares.Geotechnics.Forms.DrawingSwell.SetDataObject ( object aDataObject )
virtual

Sets the data object for swell.

Parameters
aDataObject

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

void Deltares.Geotechnics.Forms.DrawingSwell.SetDrawingProperties | ( | GraphicsInfo | info,
 |  | Color | color
 | ) |  |
protected

Sets the drawing properties.

Parameters
info | The graphics info.
color | The color.

References Deltares.Standard.Forms.DrawingSupport.GetDarkerColor(), Deltares.Standard.Forms.DrawingSupport.Material3D(), Deltares.Standard.Forms.DrawingSupport.Pen3D(), and Deltares.Standard.Forms.DrawingSupport.SetIEPDraw3D().

Generated on Tue Dec 15 2015 18:14:10 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • DrawingSwell
Deltares.Geotechnics.Forms.DrawingSwell Member List

This is the complete list of members for Deltares.Geotechnics.Forms.DrawingSwell, including all inherited members.

AllowDrop(object data) | Deltares.Geometry.Forms.DrawingObject | virtual
BeginMove(IProjection projection, Point2D startPosition) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
CanResize | Deltares.Geometry.Forms.DrawingObject |
CheckHitForSelection(IProjection projection, Point3D point, double tolerance) | Deltares.Geometry.Forms.DrawingObject | virtual
ContainsPoint(IProjection projection, Point point) | Deltares.Geotechnics.Forms.DrawingSwell | virtual
DataItemAt(Point point, Projection projection) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
DataObject (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
Draw(GraphicsInfo info) | Deltares.Geometry.Forms.DrawingObject | virtual
Draw3D(GraphicsInfo info) | Deltares.Geotechnics.Forms.DrawingSwell | virtual
DrawingObject() (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
DrawingSwell() (defined in Deltares.Geotechnics.Forms.DrawingSwell) | Deltares.Geotechnics.Forms.DrawingSwell |
DrawLabel(GraphicsInfo info) | Deltares.Geotechnics.Forms.DrawingSwell | virtual
Drop(object data) | Deltares.Geometry.Forms.DrawingObject | virtual
EndMove(IProjection projection, Point2D startPosition, SizeF worldSize) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetCardinalDirectionOnEdgeContainingPoint(Point point) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetColor(GraphicsInfo info) | Deltares.Geotechnics.Forms.DrawingSwell | protected
GetDataObject() | Deltares.Geotechnics.Forms.DrawingSwell | virtual
GetExtents(IProjection projection) | Deltares.Geometry.Forms.DrawingObject | virtual
GetScaled3DPoint(IProjection projection, Point3D aOrginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScaled3DPoint(IProjection projection, Point3D aOrginalPoint, ref Point3D aPointTobeScaled) | Deltares.Geometry.Forms.DrawingObject |
GetScaledXPoint(IProjection projection, double aOrginalCordinate) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, Point2D orginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, Point3D orginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, double x, double z) | Deltares.Geometry.Forms.DrawingObject |
GetStandardSize(object aDraw3DInterface, Point3D aPoint3D) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetThickness(GraphicsInfo info) | Deltares.Geometry.Forms.DrawingObject | protectedvirtual
HasBeenUpdated (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
IsDragableOnReslultMode (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
IsVisible (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
Layer (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
LeftMostValue (defined in Deltares.Geotechnics.Forms.DrawingSwell) | Deltares.Geotechnics.Forms.DrawingSwell |
Move(IProjection projection, Point2D startPosition, SizeF worldSize) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
Name | Deltares.Geometry.Forms.DrawingObject |
OnBeginDrag(IProjection projection, Point3D aBeginDragDropPoint, bool isIndividualDrag) | Deltares.Geometry.Forms.DrawingObject | virtual
OnDragging(IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D) | Deltares.Geometry.Forms.DrawingObject | virtual
OnEndDrag(IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D) | Deltares.Geometry.Forms.DrawingObject | virtual
Selected | Deltares.Geometry.Forms.DrawingObject |
SetDataObject(object aDataObject) | Deltares.Geotechnics.Forms.DrawingSwell | virtual
SetDrawingProperties(GraphicsInfo info, Color color) | Deltares.Geotechnics.Forms.DrawingSwell | protected
SurfaceLine (defined in Deltares.Geotechnics.Forms.DrawingSwell) | Deltares.Geotechnics.Forms.DrawingSwell |
ToolTip | Deltares.Geometry.Forms.DrawingObject |
ToString() (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
UpdateDataDragDrop(Vector3D aVect3D, List< IDrawingObject > aDraggedObjects) | Deltares.Geometry.Forms.DrawingObject | virtual
UpdateDataDragDrop(Point3D aBeginDragPoint, Vector3D vector) | Deltares.Geometry.Forms.DrawingObject | virtual
WaterBasin (defined in Deltares.Geotechnics.Forms.DrawingSwell) | Deltares.Geotechnics.Forms.DrawingSwell |
Generated on Tue Dec 15 2015 18:14:10 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.Forms.DrawingWaterBasin Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • DrawingWaterBasin
Public Member Functions | List of all members
Deltares.Geotechnics.Forms.DrawingWaterBasin Class Reference
Inheritance diagram for Deltares.Geotechnics.Forms.DrawingWaterBasin:
Deltares.Geometry.Forms.DrawingObject Deltares.Geometry.Forms.IDrawingObject Deltares.Standard.Forms.IShape

Public Member Functions

override void | SetDataObject (object DataObject)
Sets the geotechnics entity that this drawing object represents More...
override object | GetDataObject ()
Gets the geotechnics entity that this drawing object represents More...
override bool | ContainsPoint (IProjection projection, Point point)
Determines if a given point screen coordinate is within the drawing object. More...
override void | UpdateDataDragDrop (Point3D beginDragPoint, Vector3D vector)
override The UpdateDataDragDrop() Method More...
override void | Draw3D (GraphicsInfo info)
override The Draw3D() Method More...
override void | DrawLabel (GraphicsInfo info)
Renders a label or tooltip to provide some information in text for this object. More...
- Public Member Functions inherited from Deltares.Geometry.Forms.DrawingObject
Point3D | GetScaled3DPoint (IProjection projection, Point3D aOrginalPoint)
Converts the 3DPoint to screen coordinates More...
Point3D | GetScreenPoint (IProjection projection, Point2D orginalPoint)
Converts Point from 3D space to screen coordinates, assuming Y = 0 More...
Point3D | GetScreenPoint (IProjection projection, Point3D orginalPoint)
Converts Point from 3D space to screen coordinates More...
Point3D | GetScreenPoint (IProjection projection, double x, double z)
Converts 3D x, y coordinates to screen coordinates, assuming Y = 0 More...
override string | ToString ()
virtual void | UpdateDataDragDrop (Vector3D aVect3D, List< IDrawingObject > aDraggedObjects)
Update the position and or orientation of a drawing object as the user is dragging it. More...
virtual void | OnBeginDrag (IProjection projection, Point3D aBeginDragDropPoint, bool isIndividualDrag)
Method which is called when the user initiates a drag-drop operation More...
virtual CardinalDirection | GetCardinalDirectionOnEdgeContainingPoint (Point point)
virtual void | OnDragging (IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D)
Method which is called during drag-drop operations More...
virtual void | OnEndDrag (IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D)
Method which is called when the user ends a drag-drop operation. More...
virtual bool | CheckHitForSelection (IProjection projection, Point3D point, double tolerance)
Check if given point coordinates intersect the rendered drawing object. More...
virtual double | GetStandardSize (object aDraw3DInterface, Point3D aPoint3D)
void | GetScaled3DPoint (IProjection projection, Point3D aOrginalPoint, ref Point3D aPointTobeScaled)
Converts the 3DPoint to screen coordinates More...
double | GetScaledXPoint (IProjection projection, double aOrginalCordinate)
Converts X Coordinate in 3D space to a screen X Coordinate More...
virtual Rectangle | GetExtents (IProjection projection)
Returns the bounding box of the shape. More...
virtual void | Draw (GraphicsInfo info)
Render this object in 3D space. More...
virtual void | Move (IProjection projection, Point2D startPosition, SizeF worldSize)
virtual void | BeginMove (IProjection projection, Point2D startPosition)
virtual void | EndMove (IProjection projection, Point2D startPosition, SizeF worldSize)
virtual bool | AllowDrop (object data)
Boolean which indicates if other drawing objects can be dropped on given drawing objects More...
virtual void | Drop (object data)
Ends a drag-drop operation More...
virtual IEnumerable< object > | DataItemAt (Point point, Projection projection)

Additional Inherited Members

- Protected Member Functions inherited from Deltares.Geometry.Forms.DrawingObject
virtual int | GetThickness (GraphicsInfo info)
Gets the thickness in screen pixels of a drawing object. More...
- Properties inherited from Deltares.Geometry.Forms.DrawingObject
virtual bool | CanResize [get]
Boolean which indicates if a drawing object can be resized. More...
virtual bool | Selected [get, set]
Boolean which indicates if a drawing object is currently selected. More...
string | ToolTip [get]
Description which is shown as a tooltip when the mouse hovers over drawing object. More...
string | Name [get, set]
Gets or sets the name of a drawing object. More...
bool | IsVisible [get, set]
bool | HasBeenUpdated [get, set]
virtual bool | IsDragableOnReslultMode [get]
virtual int | Layer [get, set]
object | DataObject [get, set]
- Properties inherited from Deltares.Geometry.Forms.IDrawingObject
string | Name [get, set]
bool | IsVisible [get, set]
bool | HasBeenUpdated [get, set]
Gets or sets the update status of a drawing object. More...
bool | IsDragableOnReslultMode [get]
- Properties inherited from Deltares.Standard.Forms.IShape
object | DataObject [get, set]
int | Layer [get]

Member Function Documentation

override bool Deltares.Geotechnics.Forms.DrawingWaterBasin.ContainsPoint | ( | IProjection | projection,
 |  | Point | point
 | ) |  |
virtual

Determines if a given point screen coordinate is within the drawing object.

Parameters
projection | Projection used for drawing
point | Point in screen coordinates.
Returns
True if given point is within the rendered drawing object.

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

override void Deltares.Geotechnics.Forms.DrawingWaterBasin.Draw3D ( GraphicsInfo info )
virtual

override The Draw3D() Method

Parameters
aDraw3D

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

override void Deltares.Geotechnics.Forms.DrawingWaterBasin.DrawLabel ( GraphicsInfo info )
virtual

Renders a label or tooltip to provide some information in text for this object.

Parameters
info Rendering target information.

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

References Deltares.Standard.Forms.DrawingSupport.DrawLabelAtPoint().

override object Deltares.Geotechnics.Forms.DrawingWaterBasin.GetDataObject ( )
virtual

Gets the geotechnics entity that this drawing object represents

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

override void Deltares.Geotechnics.Forms.DrawingWaterBasin.SetDataObject ( object aDataObject )
virtual

Sets the geotechnics entity that this drawing object represents

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

override void Deltares.Geotechnics.Forms.DrawingWaterBasin.UpdateDataDragDrop | ( | Point3D | beginDragPoint,
 |  | Vector3D | vector
 | ) |  |
virtual

override The UpdateDataDragDrop() Method

Parameters
vector

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

Generated on Tue Dec 15 2015 18:14:10 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • DrawingWaterBasin
Deltares.Geotechnics.Forms.DrawingWaterBasin Member List

This is the complete list of members for Deltares.Geotechnics.Forms.DrawingWaterBasin, including all inherited members.

AllowDrop(object data) | Deltares.Geometry.Forms.DrawingObject | virtual
BeginMove(IProjection projection, Point2D startPosition) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
CanResize | Deltares.Geometry.Forms.DrawingObject |
CheckHitForSelection(IProjection projection, Point3D point, double tolerance) | Deltares.Geometry.Forms.DrawingObject | virtual
ContainsPoint(IProjection projection, Point point) | Deltares.Geotechnics.Forms.DrawingWaterBasin | virtual
DataItemAt(Point point, Projection projection) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
DataObject (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
Draw(GraphicsInfo info) | Deltares.Geometry.Forms.DrawingObject | virtual
Draw3D(GraphicsInfo info) | Deltares.Geotechnics.Forms.DrawingWaterBasin | virtual
DrawingObject() (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
DrawingWaterBasin() (defined in Deltares.Geotechnics.Forms.DrawingWaterBasin) | Deltares.Geotechnics.Forms.DrawingWaterBasin |
DrawLabel(GraphicsInfo info) | Deltares.Geotechnics.Forms.DrawingWaterBasin | virtual
Drop(object data) | Deltares.Geometry.Forms.DrawingObject | virtual
EndMove(IProjection projection, Point2D startPosition, SizeF worldSize) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetCardinalDirectionOnEdgeContainingPoint(Point point) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetDataObject() | Deltares.Geotechnics.Forms.DrawingWaterBasin | virtual
GetExtents(IProjection projection) | Deltares.Geometry.Forms.DrawingObject | virtual
GetScaled3DPoint(IProjection projection, Point3D aOrginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScaled3DPoint(IProjection projection, Point3D aOrginalPoint, ref Point3D aPointTobeScaled) | Deltares.Geometry.Forms.DrawingObject |
GetScaledXPoint(IProjection projection, double aOrginalCordinate) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, Point2D orginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, Point3D orginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, double x, double z) | Deltares.Geometry.Forms.DrawingObject |
GetStandardSize(object aDraw3DInterface, Point3D aPoint3D) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetThickness(GraphicsInfo info) | Deltares.Geometry.Forms.DrawingObject | protectedvirtual
HasBeenUpdated (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
IsDragableOnReslultMode (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
IsVisible (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
Layer (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
Move(IProjection projection, Point2D startPosition, SizeF worldSize) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
Name | Deltares.Geometry.Forms.DrawingObject |
OnBeginDrag(IProjection projection, Point3D aBeginDragDropPoint, bool isIndividualDrag) | Deltares.Geometry.Forms.DrawingObject | virtual
OnDragging(IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D) | Deltares.Geometry.Forms.DrawingObject | virtual
OnEndDrag(IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D) | Deltares.Geometry.Forms.DrawingObject | virtual
Selected | Deltares.Geometry.Forms.DrawingObject |
SetDataObject(object DataObject) | Deltares.Geotechnics.Forms.DrawingWaterBasin | virtual
ToolTip | Deltares.Geometry.Forms.DrawingObject |
ToString() (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
UpdateDataDragDrop(Point3D beginDragPoint, Vector3D vector) | Deltares.Geotechnics.Forms.DrawingWaterBasin | virtual
Deltares::Geometry::Forms::DrawingObject.UpdateDataDragDrop(Vector3D aVect3D, List< IDrawingObject > aDraggedObjects) | Deltares.Geometry.Forms.DrawingObject | virtual
Generated on Tue Dec 15 2015 18:14:10 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.Forms.DrawingWaterLevel Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • DrawingWaterLevel
Public Member Functions | List of all members
Deltares.Geotechnics.Forms.DrawingWaterLevel Class Reference
Inheritance diagram for Deltares.Geotechnics.Forms.DrawingWaterLevel:
Deltares.Geometry.Forms.DrawingObject Deltares.Geometry.Forms.IDrawingObject Deltares.Standard.Forms.IShape

Public Member Functions

override void | SetDataObject (object dataObject)
Sets the geotechnics entity that this drawing object represents More...
override object | GetDataObject ()
Gets the geotechnics entity that this drawing object represents More...
override void | UpdateDataDragDrop (Point3D beginDragPoint, Vector3D vector)
override The UpdateDataDragDrop() Method More...
override void | Draw3D (GraphicsInfo info)
override The Draw3D() Method More...
override void | DrawLabel (GraphicsInfo info)
Renders a label or tooltip to provide some information in text for this object. More...
- Public Member Functions inherited from Deltares.Geometry.Forms.DrawingObject
Point3D | GetScaled3DPoint (IProjection projection, Point3D aOrginalPoint)
Converts the 3DPoint to screen coordinates More...
Point3D | GetScreenPoint (IProjection projection, Point2D orginalPoint)
Converts Point from 3D space to screen coordinates, assuming Y = 0 More...
Point3D | GetScreenPoint (IProjection projection, Point3D orginalPoint)
Converts Point from 3D space to screen coordinates More...
Point3D | GetScreenPoint (IProjection projection, double x, double z)
Converts 3D x, y coordinates to screen coordinates, assuming Y = 0 More...
override string | ToString ()
virtual void | UpdateDataDragDrop (Vector3D aVect3D, List< IDrawingObject > aDraggedObjects)
Update the position and or orientation of a drawing object as the user is dragging it. More...
virtual void | OnBeginDrag (IProjection projection, Point3D aBeginDragDropPoint, bool isIndividualDrag)
Method which is called when the user initiates a drag-drop operation More...
virtual CardinalDirection | GetCardinalDirectionOnEdgeContainingPoint (Point point)
virtual void | OnDragging (IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D)
Method which is called during drag-drop operations More...
virtual void | OnEndDrag (IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D)
Method which is called when the user ends a drag-drop operation. More...
virtual bool | CheckHitForSelection (IProjection projection, Point3D point, double tolerance)
Check if given point coordinates intersect the rendered drawing object. More...
virtual double | GetStandardSize (object aDraw3DInterface, Point3D aPoint3D)
void | GetScaled3DPoint (IProjection projection, Point3D aOrginalPoint, ref Point3D aPointTobeScaled)
Converts the 3DPoint to screen coordinates More...
double | GetScaledXPoint (IProjection projection, double aOrginalCordinate)
Converts X Coordinate in 3D space to a screen X Coordinate More...
virtual bool | ContainsPoint (IProjection projection, Point point)
Determines if a given point screen coordinate is within the drawing object. More...
virtual Rectangle | GetExtents (IProjection projection)
Returns the bounding box of the shape. More...
virtual void | Draw (GraphicsInfo info)
Render this object in 3D space. More...
virtual void | Move (IProjection projection, Point2D startPosition, SizeF worldSize)
virtual void | BeginMove (IProjection projection, Point2D startPosition)
virtual void | EndMove (IProjection projection, Point2D startPosition, SizeF worldSize)
virtual bool | AllowDrop (object data)
Boolean which indicates if other drawing objects can be dropped on given drawing objects More...
virtual void | Drop (object data)
Ends a drag-drop operation More...
virtual IEnumerable< object > | DataItemAt (Point point, Projection projection)

Additional Inherited Members

- Protected Member Functions inherited from Deltares.Geometry.Forms.DrawingObject
virtual int | GetThickness (GraphicsInfo info)
Gets the thickness in screen pixels of a drawing object. More...
- Properties inherited from Deltares.Geometry.Forms.DrawingObject
virtual bool | CanResize [get]
Boolean which indicates if a drawing object can be resized. More...
virtual bool | Selected [get, set]
Boolean which indicates if a drawing object is currently selected. More...
string | ToolTip [get]
Description which is shown as a tooltip when the mouse hovers over drawing object. More...
string | Name [get, set]
Gets or sets the name of a drawing object. More...
bool | IsVisible [get, set]
bool | HasBeenUpdated [get, set]
virtual bool | IsDragableOnReslultMode [get]
virtual int | Layer [get, set]
object | DataObject [get, set]
- Properties inherited from Deltares.Geometry.Forms.IDrawingObject
string | Name [get, set]
bool | IsVisible [get, set]
bool | HasBeenUpdated [get, set]
Gets or sets the update status of a drawing object. More...
bool | IsDragableOnReslultMode [get]
- Properties inherited from Deltares.Standard.Forms.IShape
object | DataObject [get, set]
int | Layer [get]

Member Function Documentation

override void Deltares.Geotechnics.Forms.DrawingWaterLevel.Draw3D ( GraphicsInfo info )
virtual

override The Draw3D() Method

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

References Deltares.Standard.Forms.DrawingSupport.Brush3D(), Deltares.Standard.Forms.DrawingSupport.ColorMaterial3D(), Deltares.Standard.Forms.DrawingSupport.Line3D(), Deltares.Standard.Forms.DrawingSupport.Pen3D(), and Deltares.Standard.Forms.DrawingSupport.SetIEPDraw3D().

override void Deltares.Geotechnics.Forms.DrawingWaterLevel.DrawLabel ( GraphicsInfo info )
virtual

Renders a label or tooltip to provide some information in text for this object.

Parameters
info Rendering target information.

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

References Deltares.Standard.Forms.DrawingSupport.DrawLabelAtPoint().

override object Deltares.Geotechnics.Forms.DrawingWaterLevel.GetDataObject ( )
virtual

Gets the geotechnics entity that this drawing object represents

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

override void Deltares.Geotechnics.Forms.DrawingWaterLevel.SetDataObject ( object aDataObject )
virtual

Sets the geotechnics entity that this drawing object represents

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

override void Deltares.Geotechnics.Forms.DrawingWaterLevel.UpdateDataDragDrop | ( | Point3D | beginDragPoint,
 |  | Vector3D | vector
 | ) |  |
virtual

override The UpdateDataDragDrop() Method

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

Generated on Tue Dec 15 2015 18:14:11 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • DrawingWaterLevel
Deltares.Geotechnics.Forms.DrawingWaterLevel Member List

This is the complete list of members for Deltares.Geotechnics.Forms.DrawingWaterLevel, including all inherited members.

AllowDrop(object data) | Deltares.Geometry.Forms.DrawingObject | virtual
BeginMove(IProjection projection, Point2D startPosition) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
CanResize | Deltares.Geometry.Forms.DrawingObject |
CheckHitForSelection(IProjection projection, Point3D point, double tolerance) | Deltares.Geometry.Forms.DrawingObject | virtual
ContainsPoint(IProjection projection, Point point) | Deltares.Geometry.Forms.DrawingObject | virtual
DataItemAt(Point point, Projection projection) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
DataObject (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
Draw(GraphicsInfo info) | Deltares.Geometry.Forms.DrawingObject | virtual
Draw3D(GraphicsInfo info) | Deltares.Geotechnics.Forms.DrawingWaterLevel | virtual
DrawingObject() (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
DrawingWaterLevel() (defined in Deltares.Geotechnics.Forms.DrawingWaterLevel) | Deltares.Geotechnics.Forms.DrawingWaterLevel |
DrawLabel(GraphicsInfo info) | Deltares.Geotechnics.Forms.DrawingWaterLevel | virtual
Drop(object data) | Deltares.Geometry.Forms.DrawingObject | virtual
EndMove(IProjection projection, Point2D startPosition, SizeF worldSize) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetCardinalDirectionOnEdgeContainingPoint(Point point) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetDataObject() | Deltares.Geotechnics.Forms.DrawingWaterLevel | virtual
GetExtents(IProjection projection) | Deltares.Geometry.Forms.DrawingObject | virtual
GetScaled3DPoint(IProjection projection, Point3D aOrginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScaled3DPoint(IProjection projection, Point3D aOrginalPoint, ref Point3D aPointTobeScaled) | Deltares.Geometry.Forms.DrawingObject |
GetScaledXPoint(IProjection projection, double aOrginalCordinate) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, Point2D orginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, Point3D orginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, double x, double z) | Deltares.Geometry.Forms.DrawingObject |
GetStandardSize(object aDraw3DInterface, Point3D aPoint3D) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetThickness(GraphicsInfo info) | Deltares.Geometry.Forms.DrawingObject | protectedvirtual
HasBeenUpdated (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
IsDragableOnReslultMode (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
IsVisible (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
Layer (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
Move(IProjection projection, Point2D startPosition, SizeF worldSize) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
Name | Deltares.Geometry.Forms.DrawingObject |
OnBeginDrag(IProjection projection, Point3D aBeginDragDropPoint, bool isIndividualDrag) | Deltares.Geometry.Forms.DrawingObject | virtual
OnDragging(IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D) | Deltares.Geometry.Forms.DrawingObject | virtual
OnEndDrag(IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D) | Deltares.Geometry.Forms.DrawingObject | virtual
Selected | Deltares.Geometry.Forms.DrawingObject |
SetDataObject(object dataObject) | Deltares.Geotechnics.Forms.DrawingWaterLevel | virtual
ToolTip | Deltares.Geometry.Forms.DrawingObject |
ToString() (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
UpdateDataDragDrop(Point3D beginDragPoint, Vector3D vector) | Deltares.Geotechnics.Forms.DrawingWaterLevel | virtual
Deltares::Geometry::Forms::DrawingObject.UpdateDataDragDrop(Vector3D aVect3D, List< IDrawingObject > aDraggedObjects) | Deltares.Geometry.Forms.DrawingObject | virtual
Generated on Tue Dec 15 2015 18:14:11 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.Forms.DrawingWaternetLine Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • DrawingWaternetLine
Public Member Functions | List of all members
Deltares.Geotechnics.Forms.DrawingWaternetLine Class Reference
Inheritance diagram for Deltares.Geotechnics.Forms.DrawingWaternetLine:
Deltares.Geotechnics.Forms.DrawingWaternetPointString Deltares.Geometry.Forms.DrawingPointString Deltares.Geometry.Forms.DrawingObject Deltares.Geometry.Forms.IDrawingObject Deltares.Standard.Forms.IShape

Public Member Functions

override void | SetDataObject (object dataObject)
Sets the geotechnics entity that this drawing object represents More...
override void | DrawLabel (GraphicsInfo info)
Renders a label or tooltip to provide some information in text for this object. More...
- Public Member Functions inherited from Deltares.Geotechnics.Forms.DrawingWaternetPointString
DrawingWaternetPointString (DragStyle dragStyle, Color lineColor, Color backgroundColor, int layer)
DrawingWaternetPointString (DragStyle dragStyle, DashStyle dashStyle, Color lineColor, Color backgroundColor, int layer)
override void | DrawLabel (GraphicsInfo info)
Renders a label or tooltip to provide some information in text for this object. More...
override void | Draw3D (GraphicsInfo info)
override The Draw3D() Method More...
- Public Member Functions inherited from Deltares.Geometry.Forms.DrawingPointString
DrawingPointString (Color lineColor, Color backgroundColor, int layer)
DrawingPointString (DragStyle dragStyle, Color lineColor, Color backgroundColor, int layer)
DrawingPointString (DashStyle dashStyle, Color lineColor, Color backgroundColor, int layer)
DrawingPointString (DragStyle dragStyle, DashStyle dashStyle, Color lineColor, Color backgroundColor, int layer)
override object | GetDataObject ()
Gets the geotechnics entity that this drawing object represents More...
override void | UpdateDataDragDrop (Point3D aBeginDragPoint, Vector3D vector)
override The UpdateDataDragDrop() Method More...
override void | BeginMove (IProjection projection, Point2D startPosition)
override IEnumerable< object > | DataItemAt (Point point, Projection projection)
- Public Member Functions inherited from Deltares.Geometry.Forms.DrawingObject
Point3D | GetScaled3DPoint (IProjection projection, Point3D aOrginalPoint)
Converts the 3DPoint to screen coordinates More...
Point3D | GetScreenPoint (IProjection projection, Point2D orginalPoint)
Converts Point from 3D space to screen coordinates, assuming Y = 0 More...
Point3D | GetScreenPoint (IProjection projection, Point3D orginalPoint)
Converts Point from 3D space to screen coordinates More...
Point3D | GetScreenPoint (IProjection projection, double x, double z)
Converts 3D x, y coordinates to screen coordinates, assuming Y = 0 More...
override string | ToString ()
virtual void | UpdateDataDragDrop (Vector3D aVect3D, List< IDrawingObject > aDraggedObjects)
Update the position and or orientation of a drawing object as the user is dragging it. More...
virtual void | OnBeginDrag (IProjection projection, Point3D aBeginDragDropPoint, bool isIndividualDrag)
Method which is called when the user initiates a drag-drop operation More...
virtual CardinalDirection | GetCardinalDirectionOnEdgeContainingPoint (Point point)
virtual void | OnDragging (IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D)
Method which is called during drag-drop operations More...
virtual void | OnEndDrag (IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D)
Method which is called when the user ends a drag-drop operation. More...
virtual bool | CheckHitForSelection (IProjection projection, Point3D point, double tolerance)
Check if given point coordinates intersect the rendered drawing object. More...
virtual double | GetStandardSize (object aDraw3DInterface, Point3D aPoint3D)
void | GetScaled3DPoint (IProjection projection, Point3D aOrginalPoint, ref Point3D aPointTobeScaled)
Converts the 3DPoint to screen coordinates More...
double | GetScaledXPoint (IProjection projection, double aOrginalCordinate)
Converts X Coordinate in 3D space to a screen X Coordinate More...
virtual bool | ContainsPoint (IProjection projection, Point point)
Determines if a given point screen coordinate is within the drawing object. More...
virtual Rectangle | GetExtents (IProjection projection)
Returns the bounding box of the shape. More...
virtual void | Draw (GraphicsInfo info)
Render this object in 3D space. More...
virtual void | Move (IProjection projection, Point2D startPosition, SizeF worldSize)
virtual void | EndMove (IProjection projection, Point2D startPosition, SizeF worldSize)
virtual bool | AllowDrop (object data)
Boolean which indicates if other drawing objects can be dropped on given drawing objects More...
virtual void | Drop (object data)
Ends a drag-drop operation More...

Additional Inherited Members

- Protected Member Functions inherited from Deltares.Geometry.Forms.DrawingPointString
IList< GeometryPoint > | GetPoints ()
- Protected Member Functions inherited from Deltares.Geometry.Forms.DrawingObject
virtual int | GetThickness (GraphicsInfo info)
Gets the thickness in screen pixels of a drawing object. More...
- Protected Attributes inherited from Deltares.Geometry.Forms.DrawingPointString
DragStyle | dragStyle
- Properties inherited from Deltares.Geometry.Forms.DrawingObject
virtual bool | CanResize [get]
Boolean which indicates if a drawing object can be resized. More...
virtual bool | Selected [get, set]
Boolean which indicates if a drawing object is currently selected. More...
string | ToolTip [get]
Description which is shown as a tooltip when the mouse hovers over drawing object. More...
string | Name [get, set]
Gets or sets the name of a drawing object. More...
bool | IsVisible [get, set]
bool | HasBeenUpdated [get, set]
virtual bool | IsDragableOnReslultMode [get]
virtual int | Layer [get, set]
object | DataObject [get, set]
- Properties inherited from Deltares.Geometry.Forms.IDrawingObject
string | Name [get, set]
bool | IsVisible [get, set]
bool | HasBeenUpdated [get, set]
Gets or sets the update status of a drawing object. More...
bool | IsDragableOnReslultMode [get]
- Properties inherited from Deltares.Standard.Forms.IShape
object | DataObject [get, set]
int | Layer [get]

Member Function Documentation

override void Deltares.Geotechnics.Forms.DrawingWaternetLine.DrawLabel ( GraphicsInfo info )
virtual

Renders a label or tooltip to provide some information in text for this object.

Parameters
info Rendering target information.

Reimplemented from Deltares.Geometry.Forms.DrawingPointString.

References Deltares.Standard.Forms.GraphicsInfo.MousePosition.

override void Deltares.Geotechnics.Forms.DrawingWaternetLine.SetDataObject ( object aDataObject )
virtual

Sets the geotechnics entity that this drawing object represents

Reimplemented from Deltares.Geometry.Forms.DrawingPointString.

Generated on Tue Dec 15 2015 18:14:11 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • DrawingWaternetLine
Deltares.Geotechnics.Forms.DrawingWaternetLine Member List

This is the complete list of members for Deltares.Geotechnics.Forms.DrawingWaternetLine, including all inherited members.

AllowDrop(object data) | Deltares.Geometry.Forms.DrawingObject | virtual
BeginMove(IProjection projection, Point2D startPosition) (defined in Deltares.Geometry.Forms.DrawingPointString) | Deltares.Geometry.Forms.DrawingPointString | virtual
CanResize | Deltares.Geometry.Forms.DrawingObject |
CheckHitForSelection(IProjection projection, Point3D point, double tolerance) | Deltares.Geometry.Forms.DrawingObject | virtual
ContainsPoint(IProjection projection, Point point) | Deltares.Geometry.Forms.DrawingObject | virtual
DataItemAt(Point point, Projection projection) (defined in Deltares.Geometry.Forms.DrawingPointString) | Deltares.Geometry.Forms.DrawingPointString | virtual
DataObject (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
dragStyle (defined in Deltares.Geometry.Forms.DrawingPointString) | Deltares.Geometry.Forms.DrawingPointString | protected
Draw(GraphicsInfo info) | Deltares.Geometry.Forms.DrawingObject | virtual
Draw3D(GraphicsInfo info) | Deltares.Geotechnics.Forms.DrawingWaternetPointString | virtual
DrawingObject() (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
DrawingPointString() (defined in Deltares.Geometry.Forms.DrawingPointString) | Deltares.Geometry.Forms.DrawingPointString |
DrawingPointString(Color lineColor, Color backgroundColor, int layer) (defined in Deltares.Geometry.Forms.DrawingPointString) | Deltares.Geometry.Forms.DrawingPointString |
DrawingPointString(DragStyle dragStyle, Color lineColor, Color backgroundColor, int layer) (defined in Deltares.Geometry.Forms.DrawingPointString) | Deltares.Geometry.Forms.DrawingPointString |
DrawingPointString(DashStyle dashStyle, Color lineColor, Color backgroundColor, int layer) (defined in Deltares.Geometry.Forms.DrawingPointString) | Deltares.Geometry.Forms.DrawingPointString |
DrawingPointString(DragStyle dragStyle, DashStyle dashStyle, Color lineColor, Color backgroundColor, int layer) (defined in Deltares.Geometry.Forms.DrawingPointString) | Deltares.Geometry.Forms.DrawingPointString |
DrawingWaternetLine() (defined in Deltares.Geotechnics.Forms.DrawingWaternetLine) | Deltares.Geotechnics.Forms.DrawingWaternetLine |
DrawingWaternetPointString(DragStyle dragStyle, Color lineColor, Color backgroundColor, int layer) (defined in Deltares.Geotechnics.Forms.DrawingWaternetPointString) | Deltares.Geotechnics.Forms.DrawingWaternetPointString |
DrawingWaternetPointString(DragStyle dragStyle, DashStyle dashStyle, Color lineColor, Color backgroundColor, int layer) (defined in Deltares.Geotechnics.Forms.DrawingWaternetPointString) | Deltares.Geotechnics.Forms.DrawingWaternetPointString |
DrawLabel(GraphicsInfo info) | Deltares.Geotechnics.Forms.DrawingWaternetLine | virtual
Drop(object data) | Deltares.Geometry.Forms.DrawingObject | virtual
EndMove(IProjection projection, Point2D startPosition, SizeF worldSize) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetCardinalDirectionOnEdgeContainingPoint(Point point) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetDataObject() | Deltares.Geometry.Forms.DrawingPointString | virtual
GetExtents(IProjection projection) | Deltares.Geometry.Forms.DrawingObject | virtual
GetPoints() (defined in Deltares.Geometry.Forms.DrawingPointString) | Deltares.Geometry.Forms.DrawingPointString | protected
GetScaled3DPoint(IProjection projection, Point3D aOrginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScaled3DPoint(IProjection projection, Point3D aOrginalPoint, ref Point3D aPointTobeScaled) | Deltares.Geometry.Forms.DrawingObject |
GetScaledXPoint(IProjection projection, double aOrginalCordinate) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, Point2D orginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, Point3D orginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, double x, double z) | Deltares.Geometry.Forms.DrawingObject |
GetStandardSize(object aDraw3DInterface, Point3D aPoint3D) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetThickness(GraphicsInfo info) | Deltares.Geometry.Forms.DrawingObject | protectedvirtual
HasBeenUpdated (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
IsDragableOnReslultMode (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
IsVisible (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
Layer (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
Move(IProjection projection, Point2D startPosition, SizeF worldSize) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
Name | Deltares.Geometry.Forms.DrawingObject |
OnBeginDrag(IProjection projection, Point3D aBeginDragDropPoint, bool isIndividualDrag) | Deltares.Geometry.Forms.DrawingObject | virtual
OnDragging(IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D) | Deltares.Geometry.Forms.DrawingObject | virtual
OnEndDrag(IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D) | Deltares.Geometry.Forms.DrawingObject | virtual
Selected | Deltares.Geometry.Forms.DrawingObject |
SetDataObject(object dataObject) | Deltares.Geotechnics.Forms.DrawingWaternetLine | virtual
ToolTip | Deltares.Geometry.Forms.DrawingObject |
ToString() (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
UpdateDataDragDrop(Point3D aBeginDragPoint, Vector3D vector) | Deltares.Geometry.Forms.DrawingPointString | virtual
Deltares::Geometry::Forms::DrawingObject.UpdateDataDragDrop(Vector3D aVect3D, List< IDrawingObject > aDraggedObjects) | Deltares.Geometry.Forms.DrawingObject | virtual
Generated on Tue Dec 15 2015 18:14:11 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.Forms.DrawingWaternetPointString Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • DrawingWaternetPointString
Public Member Functions | List of all members
Deltares.Geotechnics.Forms.DrawingWaternetPointString Class Reference
Inheritance diagram for Deltares.Geotechnics.Forms.DrawingWaternetPointString:
Deltares.Geometry.Forms.DrawingPointString Deltares.Geometry.Forms.DrawingObject Deltares.Geometry.Forms.IDrawingObject Deltares.Standard.Forms.IShape Deltares.Geotechnics.Forms.DrawingHeadLine Deltares.Geotechnics.Forms.DrawingPhreaticLine Deltares.Geotechnics.Forms.DrawingWaternetLine

Public Member Functions

DrawingWaternetPointString (DragStyle dragStyle, Color lineColor, Color backgroundColor, int layer)
DrawingWaternetPointString (DragStyle dragStyle, DashStyle dashStyle, Color lineColor, Color backgroundColor, int layer)
override void | DrawLabel (GraphicsInfo info)
Renders a label or tooltip to provide some information in text for this object. More...
override void | Draw3D (GraphicsInfo info)
override The Draw3D() Method More...
- Public Member Functions inherited from Deltares.Geometry.Forms.DrawingPointString
DrawingPointString (Color lineColor, Color backgroundColor, int layer)
DrawingPointString (DragStyle dragStyle, Color lineColor, Color backgroundColor, int layer)
DrawingPointString (DashStyle dashStyle, Color lineColor, Color backgroundColor, int layer)
DrawingPointString (DragStyle dragStyle, DashStyle dashStyle, Color lineColor, Color backgroundColor, int layer)
override void | SetDataObject (object dataobject)
Sets the geotechnics entity that this drawing object represents More...
override object | GetDataObject ()
Gets the geotechnics entity that this drawing object represents More...
override void | UpdateDataDragDrop (Point3D aBeginDragPoint, Vector3D vector)
override The UpdateDataDragDrop() Method More...
override void | BeginMove (IProjection projection, Point2D startPosition)
override IEnumerable< object > | DataItemAt (Point point, Projection projection)
- Public Member Functions inherited from Deltares.Geometry.Forms.DrawingObject
Point3D | GetScaled3DPoint (IProjection projection, Point3D aOrginalPoint)
Converts the 3DPoint to screen coordinates More...
Point3D | GetScreenPoint (IProjection projection, Point2D orginalPoint)
Converts Point from 3D space to screen coordinates, assuming Y = 0 More...
Point3D | GetScreenPoint (IProjection projection, Point3D orginalPoint)
Converts Point from 3D space to screen coordinates More...
Point3D | GetScreenPoint (IProjection projection, double x, double z)
Converts 3D x, y coordinates to screen coordinates, assuming Y = 0 More...
override string | ToString ()
virtual void | UpdateDataDragDrop (Vector3D aVect3D, List< IDrawingObject > aDraggedObjects)
Update the position and or orientation of a drawing object as the user is dragging it. More...
virtual void | OnBeginDrag (IProjection projection, Point3D aBeginDragDropPoint, bool isIndividualDrag)
Method which is called when the user initiates a drag-drop operation More...
virtual CardinalDirection | GetCardinalDirectionOnEdgeContainingPoint (Point point)
virtual void | OnDragging (IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D)
Method which is called during drag-drop operations More...
virtual void | OnEndDrag (IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D)
Method which is called when the user ends a drag-drop operation. More...
virtual bool | CheckHitForSelection (IProjection projection, Point3D point, double tolerance)
Check if given point coordinates intersect the rendered drawing object. More...
virtual double | GetStandardSize (object aDraw3DInterface, Point3D aPoint3D)
void | GetScaled3DPoint (IProjection projection, Point3D aOrginalPoint, ref Point3D aPointTobeScaled)
Converts the 3DPoint to screen coordinates More...
double | GetScaledXPoint (IProjection projection, double aOrginalCordinate)
Converts X Coordinate in 3D space to a screen X Coordinate More...
virtual bool | ContainsPoint (IProjection projection, Point point)
Determines if a given point screen coordinate is within the drawing object. More...
virtual Rectangle | GetExtents (IProjection projection)
Returns the bounding box of the shape. More...
virtual void | Draw (GraphicsInfo info)
Render this object in 3D space. More...
virtual void | Move (IProjection projection, Point2D startPosition, SizeF worldSize)
virtual void | EndMove (IProjection projection, Point2D startPosition, SizeF worldSize)
virtual bool | AllowDrop (object data)
Boolean which indicates if other drawing objects can be dropped on given drawing objects More...
virtual void | Drop (object data)
Ends a drag-drop operation More...

Additional Inherited Members

- Protected Member Functions inherited from Deltares.Geometry.Forms.DrawingPointString
IList< GeometryPoint > | GetPoints ()
- Protected Member Functions inherited from Deltares.Geometry.Forms.DrawingObject
virtual int | GetThickness (GraphicsInfo info)
Gets the thickness in screen pixels of a drawing object. More...
- Protected Attributes inherited from Deltares.Geometry.Forms.DrawingPointString
DragStyle | dragStyle
- Properties inherited from Deltares.Geometry.Forms.DrawingObject
virtual bool | CanResize [get]
Boolean which indicates if a drawing object can be resized. More...
virtual bool | Selected [get, set]
Boolean which indicates if a drawing object is currently selected. More...
string | ToolTip [get]
Description which is shown as a tooltip when the mouse hovers over drawing object. More...
string | Name [get, set]
Gets or sets the name of a drawing object. More...
bool | IsVisible [get, set]
bool | HasBeenUpdated [get, set]
virtual bool | IsDragableOnReslultMode [get]
virtual int | Layer [get, set]
object | DataObject [get, set]
- Properties inherited from Deltares.Geometry.Forms.IDrawingObject
string | Name [get, set]
bool | IsVisible [get, set]
bool | HasBeenUpdated [get, set]
Gets or sets the update status of a drawing object. More...
bool | IsDragableOnReslultMode [get]
- Properties inherited from Deltares.Standard.Forms.IShape
object | DataObject [get, set]
int | Layer [get]

Member Function Documentation

override void Deltares.Geotechnics.Forms.DrawingWaternetPointString.Draw3D ( GraphicsInfo info )
virtual

override The Draw3D() Method

Parameters
info The info.

Reimplemented from Deltares.Geometry.Forms.DrawingPointString.

References Deltares.Standard.Forms.DrawingSupport.DrawPointSelector(), Deltares.Standard.Forms.DrawingSupport.GetLighterColor(), and Deltares.Standard.Forms.GraphicsInfo.MousePosition.

override void Deltares.Geotechnics.Forms.DrawingWaternetPointString.DrawLabel ( GraphicsInfo info )
virtual

Renders a label or tooltip to provide some information in text for this object.

Parameters
info Rendering target information.

Reimplemented from Deltares.Geometry.Forms.DrawingPointString.

References Deltares.Standard.Forms.DrawingSupport.DrawLabelAtPoint(), and Deltares.Standard.Forms.GraphicsInfo.MousePosition.

Generated on Tue Dec 15 2015 18:14:11 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • DrawingWaternetPointString
Deltares.Geotechnics.Forms.DrawingWaternetPointString Member List

This is the complete list of members for Deltares.Geotechnics.Forms.DrawingWaternetPointString, including all inherited members.

AllowDrop(object data) | Deltares.Geometry.Forms.DrawingObject | virtual
BeginMove(IProjection projection, Point2D startPosition) (defined in Deltares.Geometry.Forms.DrawingPointString) | Deltares.Geometry.Forms.DrawingPointString | virtual
CanResize | Deltares.Geometry.Forms.DrawingObject |
CheckHitForSelection(IProjection projection, Point3D point, double tolerance) | Deltares.Geometry.Forms.DrawingObject | virtual
ContainsPoint(IProjection projection, Point point) | Deltares.Geometry.Forms.DrawingObject | virtual
DataItemAt(Point point, Projection projection) (defined in Deltares.Geometry.Forms.DrawingPointString) | Deltares.Geometry.Forms.DrawingPointString | virtual
DataObject (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
dragStyle (defined in Deltares.Geometry.Forms.DrawingPointString) | Deltares.Geometry.Forms.DrawingPointString | protected
Draw(GraphicsInfo info) | Deltares.Geometry.Forms.DrawingObject | virtual
Draw3D(GraphicsInfo info) | Deltares.Geotechnics.Forms.DrawingWaternetPointString | virtual
DrawingObject() (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
DrawingPointString() (defined in Deltares.Geometry.Forms.DrawingPointString) | Deltares.Geometry.Forms.DrawingPointString |
DrawingPointString(Color lineColor, Color backgroundColor, int layer) (defined in Deltares.Geometry.Forms.DrawingPointString) | Deltares.Geometry.Forms.DrawingPointString |
DrawingPointString(DragStyle dragStyle, Color lineColor, Color backgroundColor, int layer) (defined in Deltares.Geometry.Forms.DrawingPointString) | Deltares.Geometry.Forms.DrawingPointString |
DrawingPointString(DashStyle dashStyle, Color lineColor, Color backgroundColor, int layer) (defined in Deltares.Geometry.Forms.DrawingPointString) | Deltares.Geometry.Forms.DrawingPointString |
DrawingPointString(DragStyle dragStyle, DashStyle dashStyle, Color lineColor, Color backgroundColor, int layer) (defined in Deltares.Geometry.Forms.DrawingPointString) | Deltares.Geometry.Forms.DrawingPointString |
DrawingWaternetPointString(DragStyle dragStyle, Color lineColor, Color backgroundColor, int layer) (defined in Deltares.Geotechnics.Forms.DrawingWaternetPointString) | Deltares.Geotechnics.Forms.DrawingWaternetPointString |
DrawingWaternetPointString(DragStyle dragStyle, DashStyle dashStyle, Color lineColor, Color backgroundColor, int layer) (defined in Deltares.Geotechnics.Forms.DrawingWaternetPointString) | Deltares.Geotechnics.Forms.DrawingWaternetPointString |
DrawLabel(GraphicsInfo info) | Deltares.Geotechnics.Forms.DrawingWaternetPointString | virtual
Drop(object data) | Deltares.Geometry.Forms.DrawingObject | virtual
EndMove(IProjection projection, Point2D startPosition, SizeF worldSize) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetCardinalDirectionOnEdgeContainingPoint(Point point) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetDataObject() | Deltares.Geometry.Forms.DrawingPointString | virtual
GetExtents(IProjection projection) | Deltares.Geometry.Forms.DrawingObject | virtual
GetPoints() (defined in Deltares.Geometry.Forms.DrawingPointString) | Deltares.Geometry.Forms.DrawingPointString | protected
GetScaled3DPoint(IProjection projection, Point3D aOrginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScaled3DPoint(IProjection projection, Point3D aOrginalPoint, ref Point3D aPointTobeScaled) | Deltares.Geometry.Forms.DrawingObject |
GetScaledXPoint(IProjection projection, double aOrginalCordinate) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, Point2D orginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, Point3D orginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, double x, double z) | Deltares.Geometry.Forms.DrawingObject |
GetStandardSize(object aDraw3DInterface, Point3D aPoint3D) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetThickness(GraphicsInfo info) | Deltares.Geometry.Forms.DrawingObject | protectedvirtual
HasBeenUpdated (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
IsDragableOnReslultMode (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
IsVisible (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
Layer (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
Move(IProjection projection, Point2D startPosition, SizeF worldSize) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
Name | Deltares.Geometry.Forms.DrawingObject |
OnBeginDrag(IProjection projection, Point3D aBeginDragDropPoint, bool isIndividualDrag) | Deltares.Geometry.Forms.DrawingObject | virtual
OnDragging(IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D) | Deltares.Geometry.Forms.DrawingObject | virtual
OnEndDrag(IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D) | Deltares.Geometry.Forms.DrawingObject | virtual
Selected | Deltares.Geometry.Forms.DrawingObject |
SetDataObject(object dataobject) | Deltares.Geometry.Forms.DrawingPointString | virtual
ToolTip | Deltares.Geometry.Forms.DrawingObject |
ToString() (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
UpdateDataDragDrop(Point3D aBeginDragPoint, Vector3D vector) | Deltares.Geometry.Forms.DrawingPointString | virtual
Deltares::Geometry::Forms::DrawingObject.UpdateDataDragDrop(Vector3D aVect3D, List< IDrawingObject > aDraggedObjects) | Deltares.Geometry.Forms.DrawingObject | virtual
Generated on Tue Dec 15 2015 18:14:11 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.Forms.DrawingWaterPolderBasin Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • DrawingWaterPolderBasin
Public Member Functions | List of all members
Deltares.Geotechnics.Forms.DrawingWaterPolderBasin Class Reference
Inheritance diagram for Deltares.Geotechnics.Forms.DrawingWaterPolderBasin:
Deltares.Geometry.Forms.DrawingObject Deltares.Geometry.Forms.IDrawingObject Deltares.Standard.Forms.IShape

Public Member Functions

override void | SetDataObject (object DataObject)
Sets the geotechnics entity that this drawing object represents More...
override object | GetDataObject ()
Gets the geotechnics entity that this drawing object represents More...
override bool | ContainsPoint (IProjection projection, Point point)
Determines if a given point screen coordinate is within the drawing object. More...
override void | UpdateDataDragDrop (Point3D beginDragPoint, Vector3D vector)
override The UpdateDataDragDrop() Method More...
override void | Draw3D (GraphicsInfo info)
override The Draw3D() Method More...
override void | DrawLabel (GraphicsInfo info)
Renders a label or tooltip to provide some information in text for this object. More...
- Public Member Functions inherited from Deltares.Geometry.Forms.DrawingObject
Point3D | GetScaled3DPoint (IProjection projection, Point3D aOrginalPoint)
Converts the 3DPoint to screen coordinates More...
Point3D | GetScreenPoint (IProjection projection, Point2D orginalPoint)
Converts Point from 3D space to screen coordinates, assuming Y = 0 More...
Point3D | GetScreenPoint (IProjection projection, Point3D orginalPoint)
Converts Point from 3D space to screen coordinates More...
Point3D | GetScreenPoint (IProjection projection, double x, double z)
Converts 3D x, y coordinates to screen coordinates, assuming Y = 0 More...
override string | ToString ()
virtual void | UpdateDataDragDrop (Vector3D aVect3D, List< IDrawingObject > aDraggedObjects)
Update the position and or orientation of a drawing object as the user is dragging it. More...
virtual void | OnBeginDrag (IProjection projection, Point3D aBeginDragDropPoint, bool isIndividualDrag)
Method which is called when the user initiates a drag-drop operation More...
virtual CardinalDirection | GetCardinalDirectionOnEdgeContainingPoint (Point point)
virtual void | OnDragging (IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D)
Method which is called during drag-drop operations More...
virtual void | OnEndDrag (IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D)
Method which is called when the user ends a drag-drop operation. More...
virtual bool | CheckHitForSelection (IProjection projection, Point3D point, double tolerance)
Check if given point coordinates intersect the rendered drawing object. More...
virtual double | GetStandardSize (object aDraw3DInterface, Point3D aPoint3D)
void | GetScaled3DPoint (IProjection projection, Point3D aOrginalPoint, ref Point3D aPointTobeScaled)
Converts the 3DPoint to screen coordinates More...
double | GetScaledXPoint (IProjection projection, double aOrginalCordinate)
Converts X Coordinate in 3D space to a screen X Coordinate More...
virtual Rectangle | GetExtents (IProjection projection)
Returns the bounding box of the shape. More...
virtual void | Draw (GraphicsInfo info)
Render this object in 3D space. More...
virtual void | Move (IProjection projection, Point2D startPosition, SizeF worldSize)
virtual void | BeginMove (IProjection projection, Point2D startPosition)
virtual void | EndMove (IProjection projection, Point2D startPosition, SizeF worldSize)
virtual bool | AllowDrop (object data)
Boolean which indicates if other drawing objects can be dropped on given drawing objects More...
virtual void | Drop (object data)
Ends a drag-drop operation More...
virtual IEnumerable< object > | DataItemAt (Point point, Projection projection)

Additional Inherited Members

- Protected Member Functions inherited from Deltares.Geometry.Forms.DrawingObject
virtual int | GetThickness (GraphicsInfo info)
Gets the thickness in screen pixels of a drawing object. More...
- Properties inherited from Deltares.Geometry.Forms.DrawingObject
virtual bool | CanResize [get]
Boolean which indicates if a drawing object can be resized. More...
virtual bool | Selected [get, set]
Boolean which indicates if a drawing object is currently selected. More...
string | ToolTip [get]
Description which is shown as a tooltip when the mouse hovers over drawing object. More...
string | Name [get, set]
Gets or sets the name of a drawing object. More...
bool | IsVisible [get, set]
bool | HasBeenUpdated [get, set]
virtual bool | IsDragableOnReslultMode [get]
virtual int | Layer [get, set]
object | DataObject [get, set]
- Properties inherited from Deltares.Geometry.Forms.IDrawingObject
string | Name [get, set]
bool | IsVisible [get, set]
bool | HasBeenUpdated [get, set]
Gets or sets the update status of a drawing object. More...
bool | IsDragableOnReslultMode [get]
- Properties inherited from Deltares.Standard.Forms.IShape
object | DataObject [get, set]
int | Layer [get]

Member Function Documentation

override bool Deltares.Geotechnics.Forms.DrawingWaterPolderBasin.ContainsPoint | ( | IProjection | projection,
 |  | Point | point
 | ) |  |
virtual

Determines if a given point screen coordinate is within the drawing object.

Parameters
projection | Projection used for drawing
point | Point in screen coordinates.
Returns
True if given point is within the rendered drawing object.

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

override void Deltares.Geotechnics.Forms.DrawingWaterPolderBasin.Draw3D ( GraphicsInfo info )
virtual

override The Draw3D() Method

Parameters
aDraw3D

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

override void Deltares.Geotechnics.Forms.DrawingWaterPolderBasin.DrawLabel ( GraphicsInfo info )
virtual

Renders a label or tooltip to provide some information in text for this object.

Parameters
info Rendering target information.

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

References Deltares.Standard.Forms.DrawingSupport.DrawLabelAtPoint().

override object Deltares.Geotechnics.Forms.DrawingWaterPolderBasin.GetDataObject ( )
virtual

Gets the geotechnics entity that this drawing object represents

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

override void Deltares.Geotechnics.Forms.DrawingWaterPolderBasin.SetDataObject ( object aDataObject )
virtual

Sets the geotechnics entity that this drawing object represents

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

override void Deltares.Geotechnics.Forms.DrawingWaterPolderBasin.UpdateDataDragDrop | ( | Point3D | beginDragPoint,
 |  | Vector3D | vector
 | ) |  |
virtual

override The UpdateDataDragDrop() Method

Parameters
vector

Reimplemented from Deltares.Geometry.Forms.DrawingObject.

Generated on Tue Dec 15 2015 18:14:12 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • DrawingWaterPolderBasin
Deltares.Geotechnics.Forms.DrawingWaterPolderBasin Member List

This is the complete list of members for Deltares.Geotechnics.Forms.DrawingWaterPolderBasin, including all inherited members.

AllowDrop(object data) | Deltares.Geometry.Forms.DrawingObject | virtual
BeginMove(IProjection projection, Point2D startPosition) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
CanResize | Deltares.Geometry.Forms.DrawingObject |
CheckHitForSelection(IProjection projection, Point3D point, double tolerance) | Deltares.Geometry.Forms.DrawingObject | virtual
ContainsPoint(IProjection projection, Point point) | Deltares.Geotechnics.Forms.DrawingWaterPolderBasin | virtual
DataItemAt(Point point, Projection projection) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
DataObject (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
Draw(GraphicsInfo info) | Deltares.Geometry.Forms.DrawingObject | virtual
Draw3D(GraphicsInfo info) | Deltares.Geotechnics.Forms.DrawingWaterPolderBasin | virtual
DrawingObject() (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
DrawingWaterPolderBasin() (defined in Deltares.Geotechnics.Forms.DrawingWaterPolderBasin) | Deltares.Geotechnics.Forms.DrawingWaterPolderBasin |
DrawLabel(GraphicsInfo info) | Deltares.Geotechnics.Forms.DrawingWaterPolderBasin | virtual
Drop(object data) | Deltares.Geometry.Forms.DrawingObject | virtual
EndMove(IProjection projection, Point2D startPosition, SizeF worldSize) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetCardinalDirectionOnEdgeContainingPoint(Point point) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetDataObject() | Deltares.Geotechnics.Forms.DrawingWaterPolderBasin | virtual
GetExtents(IProjection projection) | Deltares.Geometry.Forms.DrawingObject | virtual
GetScaled3DPoint(IProjection projection, Point3D aOrginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScaled3DPoint(IProjection projection, Point3D aOrginalPoint, ref Point3D aPointTobeScaled) | Deltares.Geometry.Forms.DrawingObject |
GetScaledXPoint(IProjection projection, double aOrginalCordinate) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, Point2D orginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, Point3D orginalPoint) | Deltares.Geometry.Forms.DrawingObject |
GetScreenPoint(IProjection projection, double x, double z) | Deltares.Geometry.Forms.DrawingObject |
GetStandardSize(object aDraw3DInterface, Point3D aPoint3D) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
GetThickness(GraphicsInfo info) | Deltares.Geometry.Forms.DrawingObject | protectedvirtual
HasBeenUpdated (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
IsDragableOnReslultMode (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
IsVisible (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
Layer (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
Move(IProjection projection, Point2D startPosition, SizeF worldSize) (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject | virtual
Name | Deltares.Geometry.Forms.DrawingObject |
OnBeginDrag(IProjection projection, Point3D aBeginDragDropPoint, bool isIndividualDrag) | Deltares.Geometry.Forms.DrawingObject | virtual
OnDragging(IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D) | Deltares.Geometry.Forms.DrawingObject | virtual
OnEndDrag(IProjection projection, Point3D aCurrentDragPoint, Vector3D aVect3D) | Deltares.Geometry.Forms.DrawingObject | virtual
Selected | Deltares.Geometry.Forms.DrawingObject |
SetDataObject(object DataObject) | Deltares.Geotechnics.Forms.DrawingWaterPolderBasin | virtual
ToolTip | Deltares.Geometry.Forms.DrawingObject |
ToString() (defined in Deltares.Geometry.Forms.DrawingObject) | Deltares.Geometry.Forms.DrawingObject |
UpdateDataDragDrop(Point3D beginDragPoint, Vector3D vector) | Deltares.Geotechnics.Forms.DrawingWaterPolderBasin | virtual
Deltares::Geometry::Forms::DrawingObject.UpdateDataDragDrop(Vector3D aVect3D, List< IDrawingObject > aDraggedObjects) | Deltares.Geometry.Forms.DrawingObject | virtual
Generated on Tue Dec 15 2015 18:14:12 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.Forms.GeometryPropertyControl Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • GeometryPropertyControl
Public Member Functions | Protected Member Functions | Properties | List of all members
Deltares.Geotechnics.Forms.GeometryPropertyControl Class Reference
Inheritance diagram for Deltares.Geotechnics.Forms.GeometryPropertyControl:

Public Member Functions

void | RegisterUIComponent (IReloadManager reloadManager)
void | Reload ()
void | UpdateData (params object[] models)

Protected Member Functions

override void Dispose (bool disposing)
Clean up any resources being used. More...

Properties

object | SelectedObject [get, set]
bool | IsVisible [get]

Member Function Documentation

override void Deltares.Geotechnics.Forms.GeometryPropertyControl.Dispose ( bool disposing )
protected

Clean up any resources being used.

Parameters
disposing true if managed resources should be disposed; otherwise, false.
Generated on Tue Dec 15 2015 18:14:12 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • GeometryPropertyControl
Deltares.Geotechnics.Forms.GeometryPropertyControl Member List

This is the complete list of members for Deltares.Geotechnics.Forms.GeometryPropertyControl, including all inherited members.

Dispose(bool disposing) | Deltares.Geotechnics.Forms.GeometryPropertyControl | protected
GeometryPropertyControl() (defined in Deltares.Geotechnics.Forms.GeometryPropertyControl) | Deltares.Geotechnics.Forms.GeometryPropertyControl |
IsVisible (defined in Deltares.Geotechnics.Forms.GeometryPropertyControl) | Deltares.Geotechnics.Forms.GeometryPropertyControl |
RegisterUIComponent(IReloadManager reloadManager) (defined in Deltares.Geotechnics.Forms.GeometryPropertyControl) | Deltares.Geotechnics.Forms.GeometryPropertyControl |
Reload() (defined in Deltares.Geotechnics.Forms.GeometryPropertyControl) | Deltares.Geotechnics.Forms.GeometryPropertyControl |
SelectedObject (defined in Deltares.Geotechnics.Forms.GeometryPropertyControl) | Deltares.Geotechnics.Forms.GeometryPropertyControl |
UpdateData(params object[] models) (defined in Deltares.Geotechnics.Forms.GeometryPropertyControl) | Deltares.Geotechnics.Forms.GeometryPropertyControl |
Generated on Tue Dec 15 2015 18:14:12 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.Forms.GeotechnicsPlugin Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • GeotechnicsPlugin
Public Member Functions | List of all members
Deltares.Geotechnics.Forms.GeotechnicsPlugin Class Reference
Inheritance diagram for Deltares.Geotechnics.Forms.GeotechnicsPlugin:
Deltares.Standard.Forms.DExpress.IMainFormPlugin

Public Member Functions

void | Configure (MainForm form)
void | Assign (object source)
Generated on Tue Dec 15 2015 18:14:12 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • GeotechnicsPlugin
Deltares.Geotechnics.Forms.GeotechnicsPlugin Member List

This is the complete list of members for Deltares.Geotechnics.Forms.GeotechnicsPlugin, including all inherited members.

Assign(object source) (defined in Deltares.Geotechnics.Forms.GeotechnicsPlugin) | Deltares.Geotechnics.Forms.GeotechnicsPlugin
Configure(MainForm form) (defined in Deltares.Geotechnics.Forms.GeotechnicsPlugin) | Deltares.Geotechnics.Forms.GeotechnicsPlugin
Generated on Tue Dec 15 2015 18:14:12 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.Forms.GeotechnicsViewSettings Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • GeotechnicsViewSettings
Properties | Events | List of all members
Deltares.Geotechnics.Forms.GeotechnicsViewSettings Class Reference
Inheritance diagram for Deltares.Geotechnics.Forms.GeotechnicsViewSettings:
Deltares.Geometry.Forms.IWaternetViewSettings

Properties

bool | AreWaternetVisible [get, set]
Waternet | WaternetForCalculation [get]
object | CurrentWaternet [get, set]
bool | AreHeadlinesVisible [get, set]
bool | ArePhreaticlinesVisible [get, set]
bool | AreWaternetlinesVisible [get, set]
bool | AreHeadlinesLablesVisible [get, set]
bool | ArePhreaticlinesLablesVisible [get, set]
bool | AreWaternetlinesLablesVisible [get, set]
- Properties inherited from Deltares.Geometry.Forms.IWaternetViewSettings
object | CurrentWaternet [get, set]
bool | AreHeadlinesVisible [get, set]
bool | ArePhreaticlinesVisible [get, set]
bool | AreWaternetlinesVisible [get, set]
bool | AreHeadlinesLablesVisible [get, set]
bool | ArePhreaticlinesLablesVisible [get, set]
bool | AreWaternetlinesLablesVisible [get, set]

Events

UpdateWaternetUI OnUpdateWaternetUI
Generated on Tue Dec 15 2015 18:14:12 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • GeotechnicsViewSettings
Deltares.Geotechnics.Forms.GeotechnicsViewSettings Member List

This is the complete list of members for Deltares.Geotechnics.Forms.GeotechnicsViewSettings, including all inherited members.

AreHeadlinesLablesVisible (defined in Deltares.Geotechnics.Forms.GeotechnicsViewSettings) | Deltares.Geotechnics.Forms.GeotechnicsViewSettings
AreHeadlinesVisible (defined in Deltares.Geotechnics.Forms.GeotechnicsViewSettings) | Deltares.Geotechnics.Forms.GeotechnicsViewSettings
ArePhreaticlinesLablesVisible (defined in Deltares.Geotechnics.Forms.GeotechnicsViewSettings) | Deltares.Geotechnics.Forms.GeotechnicsViewSettings
ArePhreaticlinesVisible (defined in Deltares.Geotechnics.Forms.GeotechnicsViewSettings) | Deltares.Geotechnics.Forms.GeotechnicsViewSettings
AreWaternetlinesLablesVisible (defined in Deltares.Geotechnics.Forms.GeotechnicsViewSettings) | Deltares.Geotechnics.Forms.GeotechnicsViewSettings
AreWaternetlinesVisible (defined in Deltares.Geotechnics.Forms.GeotechnicsViewSettings) | Deltares.Geotechnics.Forms.GeotechnicsViewSettings
AreWaternetVisible (defined in Deltares.Geotechnics.Forms.GeotechnicsViewSettings) | Deltares.Geotechnics.Forms.GeotechnicsViewSettings
CurrentWaternet (defined in Deltares.Geotechnics.Forms.GeotechnicsViewSettings) | Deltares.Geotechnics.Forms.GeotechnicsViewSettings
GeotechnicsViewSettings() (defined in Deltares.Geotechnics.Forms.GeotechnicsViewSettings) | Deltares.Geotechnics.Forms.GeotechnicsViewSettings
OnUpdateWaternetUI (defined in Deltares.Geotechnics.Forms.GeotechnicsViewSettings) | Deltares.Geotechnics.Forms.GeotechnicsViewSettings
WaternetForCalculation (defined in Deltares.Geotechnics.Forms.GeotechnicsViewSettings) | Deltares.Geotechnics.Forms.GeotechnicsViewSettings
Generated on Tue Dec 15 2015 18:14:12 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.Forms.HydraulicBoundaryControl Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • HydraulicBoundaryControl
Public Member Functions | Protected Member Functions | Properties | List of all members
Deltares.Geotechnics.Forms.HydraulicBoundaryControl Class Reference

Hydraulic boundary Dialog. More...

Inheritance diagram for Deltares.Geotechnics.Forms.HydraulicBoundaryControl:

Public Member Functions

HydraulicBoundaryControl ()
Constructor. More...

Protected Member Functions

override void Dispose (bool disposing)
Clean up any resources being used. More...

Properties

object | SelectedObject [get, set]
bool | IsVisible [get]

Detailed Description

Hydraulic boundary Dialog.

Constructor & Destructor Documentation

Deltares.Geotechnics.Forms.HydraulicBoundaryControl.HydraulicBoundaryControl ( )

Constructor.

References Deltares.Standard.Forms.DExpress.BindSupport.Bind(), Deltares.Standard.Forms.DExpress.BindSupport.BindTextAndValue(), Deltares.Standard.Forms.DExpress.BindSupport.BindTextValueAndUnit(), and Deltares.Standard.Forms.DExpress.LocalizationSupport.RegisterAndTranslate().

Member Function Documentation

override void Deltares.Geotechnics.Forms.HydraulicBoundaryControl.Dispose ( bool disposing )
protected

Clean up any resources being used.

Parameters
disposing true if managed resources should be disposed; otherwise, false.
Generated on Tue Dec 15 2015 18:14:13 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • HydraulicBoundaryControl
Deltares.Geotechnics.Forms.HydraulicBoundaryControl Member List

This is the complete list of members for Deltares.Geotechnics.Forms.HydraulicBoundaryControl, including all inherited members.

Dispose(bool disposing) | Deltares.Geotechnics.Forms.HydraulicBoundaryControl | protected
HydraulicBoundaryControl() | Deltares.Geotechnics.Forms.HydraulicBoundaryControl |
IsVisible (defined in Deltares.Geotechnics.Forms.HydraulicBoundaryControl) | Deltares.Geotechnics.Forms.HydraulicBoundaryControl |
SelectedObject (defined in Deltares.Geotechnics.Forms.HydraulicBoundaryControl) | Deltares.Geotechnics.Forms.HydraulicBoundaryControl |
Generated on Tue Dec 15 2015 18:14:13 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.Forms.MaterialEditorDialog Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • MaterialEditorDialog
Public Member Functions | Public Attributes | Protected Member Functions | Properties | List of all members
Deltares.Geotechnics.Forms.MaterialEditorDialog Class Reference
Inheritance diagram for Deltares.Geotechnics.Forms.MaterialEditorDialog:

Public Member Functions

void | RegisterUIComponent (IReloadManager aReloadManager)
void | Reload ()
void | UpdateData (params object[] models)

Public Attributes

DevExpress.XtraEditors.GroupControl | SoilGroup
DevExpress.XtraEditors.GroupControl | SoilModelsGroup
DevExpress.XtraEditors.GroupControl | SoilPropertiesGroup
DevExpress.XtraEditors.GroupControl | StressTableGroup
DevExpress.XtraEditors.GroupControl | StochastGroup

Protected Member Functions

override void Dispose (bool disposing)
Clean up any resources being used. More...

Properties

object | SelectedObject [get, set]
bool | IsVisible [get]

Member Function Documentation

override void Deltares.Geotechnics.Forms.MaterialEditorDialog.Dispose ( bool disposing )
protected

Clean up any resources being used.

Parameters
disposing true if managed resources should be disposed; otherwise, false.
Generated on Tue Dec 15 2015 18:14:13 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • MaterialEditorDialog
Deltares.Geotechnics.Forms.MaterialEditorDialog Member List

This is the complete list of members for Deltares.Geotechnics.Forms.MaterialEditorDialog, including all inherited members.

Dispose(bool disposing) | Deltares.Geotechnics.Forms.MaterialEditorDialog | protected
IsVisible (defined in Deltares.Geotechnics.Forms.MaterialEditorDialog) | Deltares.Geotechnics.Forms.MaterialEditorDialog |
MaterialEditorDialog() (defined in Deltares.Geotechnics.Forms.MaterialEditorDialog) | Deltares.Geotechnics.Forms.MaterialEditorDialog |
RegisterUIComponent(IReloadManager aReloadManager) (defined in Deltares.Geotechnics.Forms.MaterialEditorDialog) | Deltares.Geotechnics.Forms.MaterialEditorDialog |
Reload() (defined in Deltares.Geotechnics.Forms.MaterialEditorDialog) | Deltares.Geotechnics.Forms.MaterialEditorDialog |
SelectedObject (defined in Deltares.Geotechnics.Forms.MaterialEditorDialog) | Deltares.Geotechnics.Forms.MaterialEditorDialog |
SoilGroup (defined in Deltares.Geotechnics.Forms.MaterialEditorDialog) | Deltares.Geotechnics.Forms.MaterialEditorDialog |
SoilModelsGroup (defined in Deltares.Geotechnics.Forms.MaterialEditorDialog) | Deltares.Geotechnics.Forms.MaterialEditorDialog |
SoilPropertiesGroup (defined in Deltares.Geotechnics.Forms.MaterialEditorDialog) | Deltares.Geotechnics.Forms.MaterialEditorDialog |
StochastGroup (defined in Deltares.Geotechnics.Forms.MaterialEditorDialog) | Deltares.Geotechnics.Forms.MaterialEditorDialog |
StressTableGroup (defined in Deltares.Geotechnics.Forms.MaterialEditorDialog) | Deltares.Geotechnics.Forms.MaterialEditorDialog |
UpdateData(params object[] models) (defined in Deltares.Geotechnics.Forms.MaterialEditorDialog) | Deltares.Geotechnics.Forms.MaterialEditorDialog |
Generated on Tue Dec 15 2015 18:14:13 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.Forms.PreconsolidationStressControl Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • PreconsolidationStressControl
Protected Member Functions | Properties | List of all members
Deltares.Geotechnics.Forms.PreconsolidationStressControl Class Reference
Inheritance diagram for Deltares.Geotechnics.Forms.PreconsolidationStressControl:

Protected Member Functions

override void Dispose (bool disposing)
Clean up any resources being used. More...

Properties

object | SelectedObject [get, set]
bool | IsVisible [get]

Member Function Documentation

override void Deltares.Geotechnics.Forms.PreconsolidationStressControl.Dispose ( bool disposing )
protected

Clean up any resources being used.

Parameters
disposing true if managed resources should be disposed; otherwise, false.
Generated on Tue Dec 15 2015 18:14:13 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • PreconsolidationStressControl
Deltares.Geotechnics.Forms.PreconsolidationStressControl Member List

This is the complete list of members for Deltares.Geotechnics.Forms.PreconsolidationStressControl, including all inherited members.

Dispose(bool disposing) | Deltares.Geotechnics.Forms.PreconsolidationStressControl | protected
IsVisible (defined in Deltares.Geotechnics.Forms.PreconsolidationStressControl) | Deltares.Geotechnics.Forms.PreconsolidationStressControl |
PreconsolidationStressControl() (defined in Deltares.Geotechnics.Forms.PreconsolidationStressControl) | Deltares.Geotechnics.Forms.PreconsolidationStressControl |
SelectedObject (defined in Deltares.Geotechnics.Forms.PreconsolidationStressControl) | Deltares.Geotechnics.Forms.PreconsolidationStressControl |
Generated on Tue Dec 15 2015 18:14:13 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.Forms.ProbabilisticControl Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • ProbabilisticControl
Public Member Functions | Protected Member Functions | Properties | List of all members
Deltares.Geotechnics.Forms.ProbabilisticControl Class Reference

Earthquake Dialog. More...

Inheritance diagram for Deltares.Geotechnics.Forms.ProbabilisticControl:

Public Member Functions

ProbabilisticControl ()
Constructor. More...

Protected Member Functions

override void Dispose (bool disposing)
Clean up any resources being used. More...

Properties

object | SelectedObject [get, set]
bool | IsVisible [get]

Detailed Description

Earthquake Dialog.

Constructor & Destructor Documentation

Deltares.Geotechnics.Forms.ProbabilisticControl.ProbabilisticControl ( )

Constructor.

References Deltares.Standard.Forms.DExpress.BindSupport.BindTextAndValue(), Deltares.Standard.Forms.DExpress.BindSupport.BindTextValueAndUnit(), and Deltares.Standard.Forms.DExpress.LocalizationSupport.RegisterAndTranslate().

Member Function Documentation

override void Deltares.Geotechnics.Forms.ProbabilisticControl.Dispose ( bool disposing )
protected

Clean up any resources being used.

Parameters
disposing true if managed resources should be disposed; otherwise, false.
Generated on Tue Dec 15 2015 18:14:14 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • ProbabilisticControl
Deltares.Geotechnics.Forms.ProbabilisticControl Member List

This is the complete list of members for Deltares.Geotechnics.Forms.ProbabilisticControl, including all inherited members.

Dispose(bool disposing) | Deltares.Geotechnics.Forms.ProbabilisticControl | protected
IsVisible (defined in Deltares.Geotechnics.Forms.ProbabilisticControl) | Deltares.Geotechnics.Forms.ProbabilisticControl |
ProbabilisticControl() | Deltares.Geotechnics.Forms.ProbabilisticControl |
SelectedObject (defined in Deltares.Geotechnics.Forms.ProbabilisticControl) | Deltares.Geotechnics.Forms.ProbabilisticControl |
Generated on Tue Dec 15 2015 18:14:14 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.Forms.RevetmentLayerControl Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • RevetmentLayerControl
Protected Member Functions | Properties | List of all members
Deltares.Geotechnics.Forms.RevetmentLayerControl Class Reference
Inheritance diagram for Deltares.Geotechnics.Forms.RevetmentLayerControl:

Protected Member Functions

override void Dispose (bool disposing)
Clean up any resources being used. More...

Properties

BlockRevetmentTopLayerData | TopLayerData [get]
Geotextile | GeoTextileData [get]
Soil | SoilLayerData [get]
object | SelectedObject [get, set]
bool | IsVisible [get]

Member Function Documentation

override void Deltares.Geotechnics.Forms.RevetmentLayerControl.Dispose ( bool disposing )
protected

Clean up any resources being used.

Parameters
disposing true if managed resources should be disposed; otherwise, false.
Generated on Tue Dec 15 2015 18:14:14 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • RevetmentLayerControl
Deltares.Geotechnics.Forms.RevetmentLayerControl Member List

This is the complete list of members for Deltares.Geotechnics.Forms.RevetmentLayerControl, including all inherited members.

Dispose(bool disposing) | Deltares.Geotechnics.Forms.RevetmentLayerControl | protected
GeoTextileData (defined in Deltares.Geotechnics.Forms.RevetmentLayerControl) | Deltares.Geotechnics.Forms.RevetmentLayerControl |
IsVisible (defined in Deltares.Geotechnics.Forms.RevetmentLayerControl) | Deltares.Geotechnics.Forms.RevetmentLayerControl |
RevetmentLayerControl() (defined in Deltares.Geotechnics.Forms.RevetmentLayerControl) | Deltares.Geotechnics.Forms.RevetmentLayerControl |
SelectedObject (defined in Deltares.Geotechnics.Forms.RevetmentLayerControl) | Deltares.Geotechnics.Forms.RevetmentLayerControl |
SoilLayerData (defined in Deltares.Geotechnics.Forms.RevetmentLayerControl) | Deltares.Geotechnics.Forms.RevetmentLayerControl |
TopLayerData (defined in Deltares.Geotechnics.Forms.RevetmentLayerControl) | Deltares.Geotechnics.Forms.RevetmentLayerControl |
Generated on Tue Dec 15 2015 18:14:14 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.Forms.SchematizedSurfaceLineControl Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • SchematizedSurfaceLineControl
Protected Member Functions | Properties | List of all members
Deltares.Geotechnics.Forms.SchematizedSurfaceLineControl Class Reference
Inheritance diagram for Deltares.Geotechnics.Forms.SchematizedSurfaceLineControl:

Protected Member Functions

override void Dispose (bool disposing)
Clean up any resources being used. More...

Properties

bool | IsVisible [get]
virtual object | SelectedObject [get, set]

Member Function Documentation

override void Deltares.Geotechnics.Forms.SchematizedSurfaceLineControl.Dispose ( bool disposing )
protected

Clean up any resources being used.

Parameters
disposing true if managed resources should be disposed; otherwise, false.
Generated on Tue Dec 15 2015 18:14:14 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • SchematizedSurfaceLineControl
Deltares.Geotechnics.Forms.SchematizedSurfaceLineControl Member List

This is the complete list of members for Deltares.Geotechnics.Forms.SchematizedSurfaceLineControl, including all inherited members.

Dispose(bool disposing) | Deltares.Geotechnics.Forms.SchematizedSurfaceLineControl | protected
IsVisible (defined in Deltares.Geotechnics.Forms.SchematizedSurfaceLineControl) | Deltares.Geotechnics.Forms.SchematizedSurfaceLineControl |
SchematizedSurfaceLineControl() (defined in Deltares.Geotechnics.Forms.SchematizedSurfaceLineControl) | Deltares.Geotechnics.Forms.SchematizedSurfaceLineControl |
SelectedObject (defined in Deltares.Geotechnics.Forms.SchematizedSurfaceLineControl) | Deltares.Geotechnics.Forms.SchematizedSurfaceLineControl |
Generated on Tue Dec 15 2015 18:14:14 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.Forms.SegmentControl Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • SegmentControl
Protected Member Functions | Properties | List of all members
Deltares.Geotechnics.Forms.SegmentControl Class Reference

Soil Segment property control. More...

Inheritance diagram for Deltares.Geotechnics.Forms.SegmentControl:

Protected Member Functions

override void Dispose (bool disposing)
Clean up any resources being used. More...

Properties

StochasticSoilProfile | SelectedSoilProfile [get, set]
object | SelectedObject [get, set]
bool | IsVisible [get]

Detailed Description

Soil Segment property control.

Member Function Documentation

override void Deltares.Geotechnics.Forms.SegmentControl.Dispose ( bool disposing )
protected

Clean up any resources being used.

Parameters
disposing true if managed resources should be disposed; otherwise, false.
Generated on Tue Dec 15 2015 18:14:14 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • SegmentControl
Deltares.Geotechnics.Forms.SegmentControl Member List

This is the complete list of members for Deltares.Geotechnics.Forms.SegmentControl, including all inherited members.

Dispose(bool disposing) | Deltares.Geotechnics.Forms.SegmentControl | protected
IsVisible (defined in Deltares.Geotechnics.Forms.SegmentControl) | Deltares.Geotechnics.Forms.SegmentControl |
SegmentControl() (defined in Deltares.Geotechnics.Forms.SegmentControl) | Deltares.Geotechnics.Forms.SegmentControl |
SelectedObject (defined in Deltares.Geotechnics.Forms.SegmentControl) | Deltares.Geotechnics.Forms.SegmentControl |
SelectedSoilProfile (defined in Deltares.Geotechnics.Forms.SegmentControl) | Deltares.Geotechnics.Forms.SegmentControl |
Generated on Tue Dec 15 2015 18:14:14 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.Forms.SettlementCurveControl Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • SettlementCurveControl
Protected Member Functions | Properties | List of all members
Deltares.Geotechnics.Forms.SettlementCurveControl Class Reference
Inheritance diagram for Deltares.Geotechnics.Forms.SettlementCurveControl:

Protected Member Functions

override void Dispose (bool disposing)
Clean up any resources being used. More...

Properties

object | SelectedObject [get, set]
bool | IsVisible [get]

Member Function Documentation

override void Deltares.Geotechnics.Forms.SettlementCurveControl.Dispose ( bool disposing )
protected

Clean up any resources being used.

Parameters
disposing true if managed resources should be disposed; otherwise, false.
Generated on Tue Dec 15 2015 18:14:15 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • SettlementCurveControl
Deltares.Geotechnics.Forms.SettlementCurveControl Member List

This is the complete list of members for Deltares.Geotechnics.Forms.SettlementCurveControl, including all inherited members.

Dispose(bool disposing) | Deltares.Geotechnics.Forms.SettlementCurveControl | protected
IsVisible (defined in Deltares.Geotechnics.Forms.SettlementCurveControl) | Deltares.Geotechnics.Forms.SettlementCurveControl |
SelectedObject (defined in Deltares.Geotechnics.Forms.SettlementCurveControl) | Deltares.Geotechnics.Forms.SettlementCurveControl |
SettlementCurveControl() (defined in Deltares.Geotechnics.Forms.SettlementCurveControl) | Deltares.Geotechnics.Forms.SettlementCurveControl |
Generated on Tue Dec 15 2015 18:14:15 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.Forms.ShearStressCurveControl Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • ShearStressCurveControl
Public Member Functions | Protected Member Functions | Properties | List of all members
Deltares.Geotechnics.Forms.ShearStressCurveControl Class Reference

Earthquake Dialog. More...

Inheritance diagram for Deltares.Geotechnics.Forms.ShearStressCurveControl:

Public Member Functions

ShearStressCurveControl ()
Constructor. More...

Protected Member Functions

override void Dispose (bool disposing)
Clean up any resources being used. More...

Properties

object | SelectedObject [get, set]
bool | IsVisible [get]

Detailed Description

Earthquake Dialog.

Constructor & Destructor Documentation

Deltares.Geotechnics.Forms.ShearStressCurveControl.ShearStressCurveControl ( )

Constructor.

References Deltares.Standard.Forms.DExpress.BindSupport.Bind().

Member Function Documentation

override void Deltares.Geotechnics.Forms.ShearStressCurveControl.Dispose ( bool disposing )
protected

Clean up any resources being used.

Parameters
disposing true if managed resources should be disposed; otherwise, false.
Generated on Tue Dec 15 2015 18:14:15 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • ShearStressCurveControl
Deltares.Geotechnics.Forms.ShearStressCurveControl Member List

This is the complete list of members for Deltares.Geotechnics.Forms.ShearStressCurveControl, including all inherited members.

Dispose(bool disposing) | Deltares.Geotechnics.Forms.ShearStressCurveControl | protected
IsVisible (defined in Deltares.Geotechnics.Forms.ShearStressCurveControl) | Deltares.Geotechnics.Forms.ShearStressCurveControl |
SelectedObject (defined in Deltares.Geotechnics.Forms.ShearStressCurveControl) | Deltares.Geotechnics.Forms.ShearStressCurveControl |
ShearStressCurveControl() | Deltares.Geotechnics.Forms.ShearStressCurveControl |
Generated on Tue Dec 15 2015 18:14:15 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.Forms.SheetPilingControl Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • SheetPilingControl
Protected Member Functions | Properties | List of all members
Deltares.Geotechnics.Forms.SheetPilingControl Class Reference
Inheritance diagram for Deltares.Geotechnics.Forms.SheetPilingControl:

Protected Member Functions

override void Dispose (bool disposing)
Clean up any resources being used. More...

Properties

object | SelectedObject [get, set]
bool | IsVisible [get]

Member Function Documentation

override void Deltares.Geotechnics.Forms.SheetPilingControl.Dispose ( bool disposing )
protected

Clean up any resources being used.

Parameters
disposing true if managed resources should be disposed; otherwise, false.
Generated on Tue Dec 15 2015 18:14:15 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • SheetPilingControl
Deltares.Geotechnics.Forms.SheetPilingControl Member List

This is the complete list of members for Deltares.Geotechnics.Forms.SheetPilingControl, including all inherited members.

Dispose(bool disposing) | Deltares.Geotechnics.Forms.SheetPilingControl | protected
IsVisible (defined in Deltares.Geotechnics.Forms.SheetPilingControl) | Deltares.Geotechnics.Forms.SheetPilingControl |
SelectedObject (defined in Deltares.Geotechnics.Forms.SheetPilingControl) | Deltares.Geotechnics.Forms.SheetPilingControl |
SheetPilingControl() (defined in Deltares.Geotechnics.Forms.SheetPilingControl) | Deltares.Geotechnics.Forms.SheetPilingControl |
Generated on Tue Dec 15 2015 18:14:15 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.Forms.SoilBondStressCurveControl Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • SoilBondStressCurveControl
Public Member Functions | Protected Member Functions | Properties | List of all members
Deltares.Geotechnics.Forms.SoilBondStressCurveControl Class Reference

same as SoilStressCurveControl, except StressCurve is BondStressCurve More...

Inheritance diagram for Deltares.Geotechnics.Forms.SoilBondStressCurveControl:

Public Member Functions

SoilBondStressCurveControl ()
Initializes a new instance of the SoilSurfacePropertyControl class More...
void | RegisterUIComponent (IReloadManager reloadManager)
registers the control to reload manager More...
void | Reload ()
reloads the dialog on culture change More...
void | UpdateData (params object[] models)

Protected Member Functions

override void Dispose (bool disposing)
Clean up any resources being used. More...

Properties

object | SelectedObject [get, set]
Gets or sets the selected object More...
bool | IsVisible [get]

Detailed Description

same as SoilStressCurveControl, except StressCurve is BondStressCurve

Constructor & Destructor Documentation

Deltares.Geotechnics.Forms.SoilBondStressCurveControl.SoilBondStressCurveControl ( )

Initializes a new instance of the SoilSurfacePropertyControl class

References Deltares.Standard.Forms.DExpress.BindSupport.BindTextAndValue(), and Deltares.Standard.Forms.DExpress.LocalizationSupport.RegisterAndTranslate().

Member Function Documentation

override void Deltares.Geotechnics.Forms.SoilBondStressCurveControl.Dispose ( bool disposing )
protected

Clean up any resources being used.

Parameters
disposing true if managed resources should be disposed; otherwise, false.
void Deltares.Geotechnics.Forms.SoilBondStressCurveControl.RegisterUIComponent ( IReloadManager reloadManager )

registers the control to reload manager

Parameters
reloadManager manager to reload the control on culture change
void Deltares.Geotechnics.Forms.SoilBondStressCurveControl.Reload ( )

reloads the dialog on culture change

Property Documentation

object Deltares.Geotechnics.Forms.SoilBondStressCurveControl.SelectedObject
getset

Gets or sets the selected object

Generated on Tue Dec 15 2015 18:14:16 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • SoilBondStressCurveControl
Deltares.Geotechnics.Forms.SoilBondStressCurveControl Member List

This is the complete list of members for Deltares.Geotechnics.Forms.SoilBondStressCurveControl, including all inherited members.

Dispose(bool disposing) | Deltares.Geotechnics.Forms.SoilBondStressCurveControl | protected
IsVisible (defined in Deltares.Geotechnics.Forms.SoilBondStressCurveControl) | Deltares.Geotechnics.Forms.SoilBondStressCurveControl |
RegisterUIComponent(IReloadManager reloadManager) | Deltares.Geotechnics.Forms.SoilBondStressCurveControl |
Reload() | Deltares.Geotechnics.Forms.SoilBondStressCurveControl |
SelectedObject | Deltares.Geotechnics.Forms.SoilBondStressCurveControl |
SoilBondStressCurveControl() | Deltares.Geotechnics.Forms.SoilBondStressCurveControl |
UpdateData(params object[] models) (defined in Deltares.Geotechnics.Forms.SoilBondStressCurveControl) | Deltares.Geotechnics.Forms.SoilBondStressCurveControl |
Generated on Tue Dec 15 2015 18:14:16 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.Forms.SoilLayer2DControl Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • SoilLayer2DControl
Public Attributes | Protected Member Functions | Properties | List of all members
Deltares.Geotechnics.Forms.SoilLayer2DControl Class Reference
Inheritance diagram for Deltares.Geotechnics.Forms.SoilLayer2DControl:

Public Attributes

DevExpress.XtraEditors.GroupControl SoilGroupControl

Protected Member Functions

override void Dispose (bool disposing)
Clean up any resources being used. More...

Properties

bool | IsVisible [get]
object | SelectedObject [get, set]

Member Function Documentation

override void Deltares.Geotechnics.Forms.SoilLayer2DControl.Dispose ( bool disposing )
protected

Clean up any resources being used.

Parameters
disposing true if managed resources should be disposed; otherwise, false.
Generated on Tue Dec 15 2015 18:14:16 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • SoilLayer2DControl
Deltares.Geotechnics.Forms.SoilLayer2DControl Member List

This is the complete list of members for Deltares.Geotechnics.Forms.SoilLayer2DControl, including all inherited members.

Dispose(bool disposing) | Deltares.Geotechnics.Forms.SoilLayer2DControl | protected
IsVisible (defined in Deltares.Geotechnics.Forms.SoilLayer2DControl) | Deltares.Geotechnics.Forms.SoilLayer2DControl |
SelectedObject (defined in Deltares.Geotechnics.Forms.SoilLayer2DControl) | Deltares.Geotechnics.Forms.SoilLayer2DControl |
SoilGroupControl (defined in Deltares.Geotechnics.Forms.SoilLayer2DControl) | Deltares.Geotechnics.Forms.SoilLayer2DControl |
SoilLayer2DControl() (defined in Deltares.Geotechnics.Forms.SoilLayer2DControl) | Deltares.Geotechnics.Forms.SoilLayer2DControl |
Generated on Tue Dec 15 2015 18:14:16 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.Forms.SoilLayerControl Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • SoilLayerControl
Protected Member Functions | Properties | List of all members
Deltares.Geotechnics.Forms.SoilLayerControl Class Reference
Inheritance diagram for Deltares.Geotechnics.Forms.SoilLayerControl:

Protected Member Functions

override void Dispose (bool disposing)
Clean up any resources being used. More...

Properties

object | SelectedObject [get, set]
bool | IsVisible [get]

Member Function Documentation

override void Deltares.Geotechnics.Forms.SoilLayerControl.Dispose ( bool disposing )
protected

Clean up any resources being used.

Parameters
disposing true if managed resources should be disposed; otherwise, false.
Generated on Tue Dec 15 2015 18:14:16 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • SoilLayerControl
Deltares.Geotechnics.Forms.SoilLayerControl Member List

This is the complete list of members for Deltares.Geotechnics.Forms.SoilLayerControl, including all inherited members.

Dispose(bool disposing) | Deltares.Geotechnics.Forms.SoilLayerControl | protected
IsVisible (defined in Deltares.Geotechnics.Forms.SoilLayerControl) | Deltares.Geotechnics.Forms.SoilLayerControl |
SelectedObject (defined in Deltares.Geotechnics.Forms.SoilLayerControl) | Deltares.Geotechnics.Forms.SoilLayerControl |
SoilLayerControl() (defined in Deltares.Geotechnics.Forms.SoilLayerControl) | Deltares.Geotechnics.Forms.SoilLayerControl |
Generated on Tue Dec 15 2015 18:14:16 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.Forms.SoilProfile1DControl Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • SoilProfile1DControl
Public Member Functions | Protected Member Functions | Properties | List of all members
Deltares.Geotechnics.Forms.SoilProfile1DControl Class Reference

SoilProfile 1D properties control More...

Inheritance diagram for Deltares.Geotechnics.Forms.SoilProfile1DControl:

Public Member Functions

SoilProfile1DControl ()
Constructor More...
void ClearControl ()
Method to allow clearing the selected object and making this control invisible. More...

Protected Member Functions

override void Dispose (bool disposing)
Clean up any resources being used. More...

Properties

bool | LayersGridControlShowToolbar [set]
object | SelectedObject [get, set]
Property for selected 1D soil profile. More...
bool | IsVisible [get]
Determine visibility of this control. More...

Detailed Description

SoilProfile 1D properties control

Constructor & Destructor Documentation

Deltares.Geotechnics.Forms.SoilProfile1DControl.SoilProfile1DControl ( )

Constructor

References Deltares.Standard.Forms.DExpress.BindSupport.Bind(), Deltares.Standard.Forms.DExpress.BindSupport.BindTextAndValue(), Deltares.Standard.Forms.DExpress.BindSupport.BindTextValueAndUnit(), Deltares.Geotechnics.SoilProfile1D.BottomLevel, Deltares.Geotechnics.SoilProfile1D.Height, Deltares.Geotechnics.SoilProfile1D.Layers, Deltares.Geotechnics.SoilProfile1D.MaintainLayerOrderNonStatic, Deltares.Geotechnics.SoilProfile1D.ProbabilityOfOccurrence, Deltares.Standard.Forms.DExpress.LocalizationSupport.RegisterAndTranslate(), Deltares.Geotechnics.SoilProfile1D.TopLevel, Deltares.Geotechnics.SoilProfile1D.X, and Deltares.Geotechnics.SoilProfile1D.Y.

Member Function Documentation

void Deltares.Geotechnics.Forms.SoilProfile1DControl.ClearControl ( )

Method to allow clearing the selected object and making this control invisible.

References Deltares.Standard.Forms.DExpress.BindSupport.Assign().

override void Deltares.Geotechnics.Forms.SoilProfile1DControl.Dispose ( bool disposing )
protected

Clean up any resources being used.

Parameters
disposing true if managed resources should be disposed; otherwise, false.

Property Documentation

bool Deltares.Geotechnics.Forms.SoilProfile1DControl.IsVisible
get

Determine visibility of this control.

object Deltares.Geotechnics.Forms.SoilProfile1DControl.SelectedObject
getset

Property for selected 1D soil profile.

Generated on Tue Dec 15 2015 18:14:16 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • SoilProfile1DControl
Deltares.Geotechnics.Forms.SoilProfile1DControl Member List

This is the complete list of members for Deltares.Geotechnics.Forms.SoilProfile1DControl, including all inherited members.

ClearControl() | Deltares.Geotechnics.Forms.SoilProfile1DControl |
Dispose(bool disposing) | Deltares.Geotechnics.Forms.SoilProfile1DControl | protected
IsVisible | Deltares.Geotechnics.Forms.SoilProfile1DControl |
LayersGridControlShowToolbar (defined in Deltares.Geotechnics.Forms.SoilProfile1DControl) | Deltares.Geotechnics.Forms.SoilProfile1DControl |
SelectedObject | Deltares.Geotechnics.Forms.SoilProfile1DControl |
SoilProfile1DControl() | Deltares.Geotechnics.Forms.SoilProfile1DControl |
Generated on Tue Dec 15 2015 18:14:16 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.Forms.SoilProfile2DControl Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • SoilProfile2DControl
Public Member Functions | Protected Member Functions | Properties | List of all members
Deltares.Geotechnics.Forms.SoilProfile2DControl Class Reference

SoilProfile 2D Dialog. More...

Inheritance diagram for Deltares.Geotechnics.Forms.SoilProfile2DControl:

Public Member Functions

SoilProfile2DControl ()
Constructor. More...
void ClearControl ()
Method to allow clearing the selected object and making this control invisible. More...

Protected Member Functions

override void Dispose (bool disposing)
Clean up any resources being used. More...

Properties

object | SelectedObject [get, set]
bool | IsVisible [get]

Detailed Description

SoilProfile 2D Dialog.

Constructor & Destructor Documentation

Deltares.Geotechnics.Forms.SoilProfile2DControl.SoilProfile2DControl ( )

Constructor.

References Deltares.Standard.Forms.DExpress.BindSupport.Bind(), Deltares.Standard.Forms.DExpress.BindSupport.BindTextAndValue(), Deltares.Standard.Forms.DExpress.BindSupport.BindTextValueAndUnit(), and Deltares.Standard.Forms.DExpress.LocalizationSupport.RegisterAndTranslate().

Member Function Documentation

void Deltares.Geotechnics.Forms.SoilProfile2DControl.ClearControl ( )

Method to allow clearing the selected object and making this control invisible.

References Deltares.Standard.Forms.DExpress.BindSupport.Assign().

override void Deltares.Geotechnics.Forms.SoilProfile2DControl.Dispose ( bool disposing )
protected

Clean up any resources being used.

Parameters
disposing true if managed resources should be disposed; otherwise, false.
Generated on Tue Dec 15 2015 18:14:17 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • SoilProfile2DControl
Deltares.Geotechnics.Forms.SoilProfile2DControl Member List

This is the complete list of members for Deltares.Geotechnics.Forms.SoilProfile2DControl, including all inherited members.

ClearControl() | Deltares.Geotechnics.Forms.SoilProfile2DControl |
Dispose(bool disposing) | Deltares.Geotechnics.Forms.SoilProfile2DControl | protected
IsVisible (defined in Deltares.Geotechnics.Forms.SoilProfile2DControl) | Deltares.Geotechnics.Forms.SoilProfile2DControl |
SelectedObject (defined in Deltares.Geotechnics.Forms.SoilProfile2DControl) | Deltares.Geotechnics.Forms.SoilProfile2DControl |
SoilProfile2DControl() | Deltares.Geotechnics.Forms.SoilProfile2DControl |
Generated on Tue Dec 15 2015 18:14:17 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.Forms.SoilStressCurveControl Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • SoilStressCurveControl
Public Member Functions | Protected Member Functions | Properties | List of all members
Deltares.Geotechnics.Forms.SoilStressCurveControl Class Reference

custom property control for soilsurface and geometrypoints More...

Inheritance diagram for Deltares.Geotechnics.Forms.SoilStressCurveControl:

Public Member Functions

SoilStressCurveControl ()
Initializes a new instance of the SoilSurfacePropertyControl class More...

Protected Member Functions

override void Dispose (bool disposing)
Clean up any resources being used. More...

Properties

object | SelectedObject [get, set]
Gets or sets the selected object More...
bool | IsVisible [get]

Detailed Description

custom property control for soilsurface and geometrypoints

Constructor & Destructor Documentation

Deltares.Geotechnics.Forms.SoilStressCurveControl.SoilStressCurveControl ( )

Initializes a new instance of the SoilSurfacePropertyControl class

References Deltares.Standard.Forms.DExpress.BindSupport.BindTextAndValue(), and Deltares.Standard.Forms.DExpress.LocalizationSupport.RegisterAndTranslate().

Member Function Documentation

override void Deltares.Geotechnics.Forms.SoilStressCurveControl.Dispose ( bool disposing )
protected

Clean up any resources being used.

Parameters
disposing true if managed resources should be disposed; otherwise, false.

Property Documentation

object Deltares.Geotechnics.Forms.SoilStressCurveControl.SelectedObject
getset

Gets or sets the selected object

Generated on Tue Dec 15 2015 18:14:17 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • SoilStressCurveControl
Deltares.Geotechnics.Forms.SoilStressCurveControl Member List

This is the complete list of members for Deltares.Geotechnics.Forms.SoilStressCurveControl, including all inherited members.

Dispose(bool disposing) | Deltares.Geotechnics.Forms.SoilStressCurveControl | protected
IsVisible (defined in Deltares.Geotechnics.Forms.SoilStressCurveControl) | Deltares.Geotechnics.Forms.SoilStressCurveControl |
SelectedObject | Deltares.Geotechnics.Forms.SoilStressCurveControl |
SoilStressCurveControl() | Deltares.Geotechnics.Forms.SoilStressCurveControl |
Generated on Tue Dec 15 2015 18:14:17 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.Forms.SoilSurfacePointsControl Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • SoilSurfacePointsControl
Protected Member Functions | Properties | List of all members
Deltares.Geotechnics.Forms.SoilSurfacePointsControl Class Reference
Inheritance diagram for Deltares.Geotechnics.Forms.SoilSurfacePointsControl:

Protected Member Functions

override void Dispose (bool disposing)
Clean up any resources being used. More...

Properties

object | SelectedObject [get, set]
bool | IsVisible [get]

Member Function Documentation

override void Deltares.Geotechnics.Forms.SoilSurfacePointsControl.Dispose ( bool disposing )
protected

Clean up any resources being used.

Parameters
disposing true if managed resources should be disposed; otherwise, false.
Generated on Tue Dec 15 2015 18:14:17 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • SoilSurfacePointsControl
Deltares.Geotechnics.Forms.SoilSurfacePointsControl Member List

This is the complete list of members for Deltares.Geotechnics.Forms.SoilSurfacePointsControl, including all inherited members.

Dispose(bool disposing) | Deltares.Geotechnics.Forms.SoilSurfacePointsControl | protected
IsVisible (defined in Deltares.Geotechnics.Forms.SoilSurfacePointsControl) | Deltares.Geotechnics.Forms.SoilSurfacePointsControl |
SelectedObject (defined in Deltares.Geotechnics.Forms.SoilSurfacePointsControl) | Deltares.Geotechnics.Forms.SoilSurfacePointsControl |
SoilSurfacePointsControl() (defined in Deltares.Geotechnics.Forms.SoilSurfacePointsControl) | Deltares.Geotechnics.Forms.SoilSurfacePointsControl |
Generated on Tue Dec 15 2015 18:14:17 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.Forms.SoilSurfacePropertyControl Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • SoilSurfacePropertyControl
Public Member Functions | Protected Member Functions | Properties | List of all members
Deltares.Geotechnics.Forms.SoilSurfacePropertyControl Class Reference

Custom property control for soilsurface and geometrypoints. More...

Inheritance diagram for Deltares.Geotechnics.Forms.SoilSurfacePropertyControl:

Public Member Functions

SoilSurfacePropertyControl ()
Initializes a new instance of the SoilSurfacePropertyControl class. More...

Protected Member Functions

override void Dispose (bool disposing)
Clean up any resources being used. More...

Properties

object | SelectedObject [get, set]
Gets or sets the selected object. More...
bool | IsVisible [get]

Detailed Description

Custom property control for soilsurface and geometrypoints.

Constructor & Destructor Documentation

Deltares.Geotechnics.Forms.SoilSurfacePropertyControl.SoilSurfacePropertyControl ( )

Initializes a new instance of the SoilSurfacePropertyControl class.

References Deltares.Standard.Forms.DExpress.BindSupport.Bind(), and Deltares.Standard.Forms.DExpress.BindSupport.BindTextAndValue().

Member Function Documentation

override void Deltares.Geotechnics.Forms.SoilSurfacePropertyControl.Dispose ( bool disposing )
protected

Clean up any resources being used.

Parameters
disposing true if managed resources should be disposed; otherwise, false.

Property Documentation

object Deltares.Geotechnics.Forms.SoilSurfacePropertyControl.SelectedObject
getset

Gets or sets the selected object.

Generated on Tue Dec 15 2015 18:14:18 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • SoilSurfacePropertyControl
Deltares.Geotechnics.Forms.SoilSurfacePropertyControl Member List

This is the complete list of members for Deltares.Geotechnics.Forms.SoilSurfacePropertyControl, including all inherited members.

Dispose(bool disposing) | Deltares.Geotechnics.Forms.SoilSurfacePropertyControl | protected
IsVisible (defined in Deltares.Geotechnics.Forms.SoilSurfacePropertyControl) | Deltares.Geotechnics.Forms.SoilSurfacePropertyControl |
SelectedObject | Deltares.Geotechnics.Forms.SoilSurfacePropertyControl |
SoilSurfacePropertyControl() | Deltares.Geotechnics.Forms.SoilSurfacePropertyControl |
Generated on Tue Dec 15 2015 18:14:18 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.Forms.SpecificMechanismPointLocationControl Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • SpecificMechanismPointLocationControl
Protected Member Functions | Properties | List of all members
Deltares.Geotechnics.Forms.SpecificMechanismPointLocationControl Class Reference
Inheritance diagram for Deltares.Geotechnics.Forms.SpecificMechanismPointLocationControl:

Protected Member Functions

override void Dispose (bool disposing)
Clean up any resources being used. More...

Properties

object | SelectedObject [get, set]
bool | IsVisible [get]

Member Function Documentation

override void Deltares.Geotechnics.Forms.SpecificMechanismPointLocationControl.Dispose ( bool disposing )
protected

Clean up any resources being used.

Parameters
disposing true if managed resources should be disposed; otherwise, false.
Generated on Tue Dec 15 2015 18:14:18 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • SpecificMechanismPointLocationControl
Deltares.Geotechnics.Forms.SpecificMechanismPointLocationControl Member List

This is the complete list of members for Deltares.Geotechnics.Forms.SpecificMechanismPointLocationControl, including all inherited members.

Dispose(bool disposing) | Deltares.Geotechnics.Forms.SpecificMechanismPointLocationControl | protected
IsVisible (defined in Deltares.Geotechnics.Forms.SpecificMechanismPointLocationControl) | Deltares.Geotechnics.Forms.SpecificMechanismPointLocationControl |
SelectedObject (defined in Deltares.Geotechnics.Forms.SpecificMechanismPointLocationControl) | Deltares.Geotechnics.Forms.SpecificMechanismPointLocationControl |
SpecificMechanismPointLocationControl() (defined in Deltares.Geotechnics.Forms.SpecificMechanismPointLocationControl) | Deltares.Geotechnics.Forms.SpecificMechanismPointLocationControl |
Generated on Tue Dec 15 2015 18:14:18 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.Forms.StochastControl Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • StochastControl
Protected Member Functions | List of all members
Deltares.Geotechnics.Forms.StochastControl Class Reference
Inheritance diagram for Deltares.Geotechnics.Forms.StochastControl:

Protected Member Functions

override void Dispose (bool disposing)
Clean up any resources being used. More...

Member Function Documentation

override void Deltares.Geotechnics.Forms.StochastControl.Dispose ( bool disposing )
protected

Clean up any resources being used.

Parameters
disposing true if managed resources should be disposed; otherwise, false.
Generated on Tue Dec 15 2015 18:14:18 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • StochastControl
Deltares.Geotechnics.Forms.StochastControl Member List

This is the complete list of members for Deltares.Geotechnics.Forms.StochastControl, including all inherited members.

Dispose(bool disposing) | Deltares.Geotechnics.Forms.StochastControl | protected
StochastControl() (defined in Deltares.Geotechnics.Forms.StochastControl) | Deltares.Geotechnics.Forms.StochastControl |
Generated on Tue Dec 15 2015 18:14:18 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.Forms.StressCurveControl Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • StressCurveControl
Public Member Functions | Protected Member Functions | Properties | List of all members
Deltares.Geotechnics.Forms.StressCurveControl Class Reference

Earthquake Dialog. More...

Inheritance diagram for Deltares.Geotechnics.Forms.StressCurveControl:

Public Member Functions

StressCurveControl ()
Constructor. More...

Protected Member Functions

override void Dispose (bool disposing)
Clean up any resources being used. More...

Properties

object | SelectedObject [get, set]
bool | IsVisible [get]

Detailed Description

Earthquake Dialog.

Constructor & Destructor Documentation

Deltares.Geotechnics.Forms.StressCurveControl.StressCurveControl ( )

Constructor.

References Deltares.Standard.Forms.DExpress.BindSupport.Bind(), Deltares.Standard.Forms.DExpress.BindSupport.BindTextAndValue(), Deltares.Standard.Forms.DExpress.BindSupport.BindTextValueAndUnit(), and Deltares.Standard.Forms.DExpress.LocalizationSupport.RegisterAndTranslate().

Member Function Documentation

override void Deltares.Geotechnics.Forms.StressCurveControl.Dispose ( bool disposing )
protected

Clean up any resources being used.

Parameters
disposing true if managed resources should be disposed; otherwise, false.
Generated on Tue Dec 15 2015 18:14:18 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • StressCurveControl
Deltares.Geotechnics.Forms.StressCurveControl Member List

This is the complete list of members for Deltares.Geotechnics.Forms.StressCurveControl, including all inherited members.

Dispose(bool disposing) | Deltares.Geotechnics.Forms.StressCurveControl | protected
IsVisible (defined in Deltares.Geotechnics.Forms.StressCurveControl) | Deltares.Geotechnics.Forms.StressCurveControl |
SelectedObject (defined in Deltares.Geotechnics.Forms.StressCurveControl) | Deltares.Geotechnics.Forms.StressCurveControl |
StressCurveControl() | Deltares.Geotechnics.Forms.StressCurveControl |
Generated on Tue Dec 15 2015 18:14:18 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.Forms.StressCurveReader Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • StressCurveReader
Public Member Functions | List of all members
Deltares.Geotechnics.Forms.StressCurveReader Class Reference

Public Member Functions

List< StressCurve > ReadStressCurves (string fileName)
Generated on Tue Dec 15 2015 18:14:18 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • StressCurveReader
Deltares.Geotechnics.Forms.StressCurveReader Member List

This is the complete list of members for Deltares.Geotechnics.Forms.StressCurveReader, including all inherited members.

ReadStressCurves(string fileName) (defined in Deltares.Geotechnics.Forms.StressCurveReader) | Deltares.Geotechnics.Forms.StressCurveReader
StressCurveReader() (defined in Deltares.Geotechnics.Forms.StressCurveReader) | Deltares.Geotechnics.Forms.StressCurveReader
Generated on Tue Dec 15 2015 18:14:18 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.Forms.SurfaceLine2Control Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • SurfaceLine2Control
Public Attributes | Protected Member Functions | Properties | List of all members
Deltares.Geotechnics.Forms.SurfaceLine2Control Class Reference
Inheritance diagram for Deltares.Geotechnics.Forms.SurfaceLine2Control:

Public Attributes

Standard.Forms.DExpress.GridViewControl SurfaceLinePointsGridControl

Protected Member Functions

override void Dispose (bool disposing)
Clean up any resources being used. More...

Properties

bool | IsVisible [get]
object | SelectedObject [get, set]

Member Function Documentation

override void Deltares.Geotechnics.Forms.SurfaceLine2Control.Dispose ( bool disposing )
protected

Clean up any resources being used.

Parameters
disposing true if managed resources should be disposed; otherwise, false.
Generated on Tue Dec 15 2015 18:14:19 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • SurfaceLine2Control
Deltares.Geotechnics.Forms.SurfaceLine2Control Member List

This is the complete list of members for Deltares.Geotechnics.Forms.SurfaceLine2Control, including all inherited members.

Dispose(bool disposing) | Deltares.Geotechnics.Forms.SurfaceLine2Control | protected
IsVisible (defined in Deltares.Geotechnics.Forms.SurfaceLine2Control) | Deltares.Geotechnics.Forms.SurfaceLine2Control |
SelectedObject (defined in Deltares.Geotechnics.Forms.SurfaceLine2Control) | Deltares.Geotechnics.Forms.SurfaceLine2Control |
SurfaceLine2Control() (defined in Deltares.Geotechnics.Forms.SurfaceLine2Control) | Deltares.Geotechnics.Forms.SurfaceLine2Control |
SurfaceLinePointsGridControl (defined in Deltares.Geotechnics.Forms.SurfaceLine2Control) | Deltares.Geotechnics.Forms.SurfaceLine2Control |
Generated on Tue Dec 15 2015 18:14:19 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.Forms.WaterLineControl Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • WaterLineControl
Public Member Functions | Protected Member Functions | Properties | List of all members
Deltares.Geotechnics.Forms.WaterLineControl Class Reference
Inheritance diagram for Deltares.Geotechnics.Forms.WaterLineControl:

Public Member Functions

WaterLineControl ()
Constructor. More...
void | RegisterUIComponent (IReloadManager aReloadManager)
void | Reload ()
void | UpdateData (params object[] models)

Protected Member Functions

override void Dispose (bool disposing)
Clean up any resources being used. More...

Properties

object | SelectedObject [get, set]
Gets or sets the selected object More...
bool | IsVisible [get]

Constructor & Destructor Documentation

Deltares.Geotechnics.Forms.WaterLineControl.WaterLineControl ( )

Constructor.

References Deltares.Standard.Forms.DExpress.BindSupport.Bind(), and Deltares.Standard.Forms.DExpress.BindSupport.BindTextAndValue().

Member Function Documentation

override void Deltares.Geotechnics.Forms.WaterLineControl.Dispose ( bool disposing )
protected

Clean up any resources being used.

Parameters
disposing true if managed resources should be disposed; otherwise, false.

Property Documentation

object Deltares.Geotechnics.Forms.WaterLineControl.SelectedObject
getset

Gets or sets the selected object

Generated on Tue Dec 15 2015 18:14:19 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • WaterLineControl
Deltares.Geotechnics.Forms.WaterLineControl Member List

This is the complete list of members for Deltares.Geotechnics.Forms.WaterLineControl, including all inherited members.

Dispose(bool disposing) | Deltares.Geotechnics.Forms.WaterLineControl | protected
IsVisible (defined in Deltares.Geotechnics.Forms.WaterLineControl) | Deltares.Geotechnics.Forms.WaterLineControl |
RegisterUIComponent(IReloadManager aReloadManager) (defined in Deltares.Geotechnics.Forms.WaterLineControl) | Deltares.Geotechnics.Forms.WaterLineControl |
Reload() (defined in Deltares.Geotechnics.Forms.WaterLineControl) | Deltares.Geotechnics.Forms.WaterLineControl |
SelectedObject | Deltares.Geotechnics.Forms.WaterLineControl |
UpdateData(params object[] models) (defined in Deltares.Geotechnics.Forms.WaterLineControl) | Deltares.Geotechnics.Forms.WaterLineControl |
WaterLineControl() | Deltares.Geotechnics.Forms.WaterLineControl |
Generated on Tue Dec 15 2015 18:14:19 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.Forms.WaternetControl Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • WaternetControl
Public Member Functions | Protected Member Functions | Properties | List of all members
Deltares.Geotechnics.Forms.WaternetControl Class Reference

Tree on slope dialog. More...

Inheritance diagram for Deltares.Geotechnics.Forms.WaternetControl:

Public Member Functions

WaternetControl ()
Constructor. More...
void | RegisterUIComponent (IReloadManager aReloadManager)
void | Reload ()
void | UpdateData (params object[] models)

Protected Member Functions

override void Dispose (bool disposing)
Clean up any resources being used. More...

Properties

object | SelectedObject [get, set]
Gets or sets the selected object More...
bool | IsVisible [get]

Detailed Description

Tree on slope dialog.

Constructor & Destructor Documentation

Deltares.Geotechnics.Forms.WaternetControl.WaternetControl ( )

Constructor.

References Deltares.Standard.Forms.DExpress.BindSupport.Bind(), and Deltares.Standard.Forms.DExpress.BindSupport.BindTextValueAndUnit().

Member Function Documentation

override void Deltares.Geotechnics.Forms.WaternetControl.Dispose ( bool disposing )
protected

Clean up any resources being used.

Parameters
disposing true if managed resources should be disposed; otherwise, false.

Property Documentation

object Deltares.Geotechnics.Forms.WaternetControl.SelectedObject
getset

Gets or sets the selected object

Generated on Tue Dec 15 2015 18:14:19 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • Forms
  • WaternetControl
Deltares.Geotechnics.Forms.WaternetControl Member List

This is the complete list of members for Deltares.Geotechnics.Forms.WaternetControl, including all inherited members.

Dispose(bool disposing) | Deltares.Geotechnics.Forms.WaternetControl | protected
IsVisible (defined in Deltares.Geotechnics.Forms.WaternetControl) | Deltares.Geotechnics.Forms.WaternetControl |
RegisterUIComponent(IReloadManager aReloadManager) (defined in Deltares.Geotechnics.Forms.WaternetControl) | Deltares.Geotechnics.Forms.WaternetControl |
Reload() (defined in Deltares.Geotechnics.Forms.WaternetControl) | Deltares.Geotechnics.Forms.WaternetControl |
SelectedObject | Deltares.Geotechnics.Forms.WaternetControl |
UpdateData(params object[] models) (defined in Deltares.Geotechnics.Forms.WaternetControl) | Deltares.Geotechnics.Forms.WaternetControl |
WaternetControl() | Deltares.Geotechnics.Forms.WaternetControl |
Generated on Tue Dec 15 2015 18:14:19 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.IO.Exception.CsvImporterSoilProfilesException Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • IO
  • Exception
  • CsvImporterSoilProfilesException
Public Member Functions | List of all members
Deltares.Geotechnics.IO.Exception.CsvImporterSoilProfilesException Class Reference
Inheritance diagram for Deltares.Geotechnics.IO.Exception.CsvImporterSoilProfilesException:

Public Member Functions

CsvImporterSoilProfilesException (string message)
Generated on Tue Dec 15 2015 18:14:21 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • IO
  • Exception
  • CsvImporterSoilProfilesException
Deltares.Geotechnics.IO.Exception.CsvImporterSoilProfilesException Member List

This is the complete list of members for Deltares.Geotechnics.IO.Exception.CsvImporterSoilProfilesException, including all inherited members.

CsvImporterSoilProfilesException(string message) (defined in Deltares.Geotechnics.IO.Exception.CsvImporterSoilProfilesException) Deltares.Geotechnics.IO.Exception.CsvImporterSoilProfilesException
Generated on Tue Dec 15 2015 18:14:21 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.IO.Importers.Exception.CharacteristicPointsImporterException Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • IO
  • Importers
  • Exception
  • CharacteristicPointsImporterException
Public Member Functions | List of all members
Deltares.Geotechnics.IO.Importers.Exception.CharacteristicPointsImporterException Class Reference
Inheritance diagram for Deltares.Geotechnics.IO.Importers.Exception.CharacteristicPointsImporterException:

Public Member Functions

CharacteristicPointsImporterException (string message)
Generated on Tue Dec 15 2015 18:14:24 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • IO
  • Importers
  • Exception
  • CharacteristicPointsImporterException
Deltares.Geotechnics.IO.Importers.Exception.CharacteristicPointsImporterException Member List

This is the complete list of members for Deltares.Geotechnics.IO.Importers.Exception.CharacteristicPointsImporterException, including all inherited members.

CharacteristicPointsImporterException(string message) (defined in Deltares.Geotechnics.IO.Importers.Exception.CharacteristicPointsImporterException) Deltares.Geotechnics.IO.Importers.Exception.CharacteristicPointsImporterException
Generated on Tue Dec 15 2015 18:14:24 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.IO.Importers.Exception.FetchesImporterException Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • IO
  • Importers
  • Exception
  • FetchesImporterException
Public Member Functions | List of all members
Deltares.Geotechnics.IO.Importers.Exception.FetchesImporterException Class Reference
Inheritance diagram for Deltares.Geotechnics.IO.Importers.Exception.FetchesImporterException:

Public Member Functions

FetchesImporterException (string message)
Generated on Tue Dec 15 2015 18:14:24 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • IO
  • Importers
  • Exception
  • FetchesImporterException
Deltares.Geotechnics.IO.Importers.Exception.FetchesImporterException Member List

This is the complete list of members for Deltares.Geotechnics.IO.Importers.Exception.FetchesImporterException, including all inherited members.

FetchesImporterException(string message) (defined in Deltares.Geotechnics.IO.Importers.Exception.FetchesImporterException) Deltares.Geotechnics.IO.Importers.Exception.FetchesImporterException
Generated on Tue Dec 15 2015 18:14:24 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.IO.Importers.CharacteristicPointsImporter Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • IO
  • Importers
  • CharacteristicPointsImporter
Classes | Public Member Functions | Protected Member Functions | List of all members
Deltares.Geotechnics.IO.Importers.CharacteristicPointsImporter Class Reference
Inheritance diagram for Deltares.Geotechnics.IO.Importers.CharacteristicPointsImporter:

Public Member Functions

void | Read (string fileName, List< SurfaceLine2 > surfaceLines)
This was the original (public) read used by DAM More...
void | Read (string fileName, IDataFactory factory)
This is the unified Read to be used by the original Read(string, List<SurfaceLine2>) and the new Import() method of the superclass Importer class More...
override void | Import ()

Protected Member Functions

bool AddCharacteristicPointToSurfaceLine (SurfaceLine2 surfaceLine, double xGlobal, double yGlobal, double zGlobal, CharacteristicPointType type, bool isAddPointToSurfaceLineIfMissing)
Adds the characteristic point to the surface line. More...

Member Function Documentation

bool Deltares.Geotechnics.IO.Importers.CharacteristicPointsImporter.AddCharacteristicPointToSurfaceLine | ( | SurfaceLine2 | surfaceLine,
 |  | double | xGlobal,
 |  | double | yGlobal,
 |  | double | zGlobal,
 |  | CharacteristicPointType | type,
 |  | bool | isAddPointToSurfaceLineIfMissing
 | ) |  |
protected

Adds the characteristic point to the surface line.

Parameters
surfaceLine | The surface line.
xGlobal | The x co-ordinate.
yGlobal | The y co-ordinate.
zGlobal | The z co-ordinate.
type | The type.
isAddPointToSurfaceLineIfMissing | if set to true [is add point to surface line if missing].
Returns
void Deltares.Geotechnics.IO.Importers.CharacteristicPointsImporter.Read | ( | string | fileName,
 |  | List< SurfaceLine2 > | surfaceLines
 | ) |  |

This was the original (public) read used by DAM

Parameters
fileName | Name of the file.
surfaceLines | The surface lines.

Note: This method will remove entries from surfaceLines if an error occurred while adding characteristic points to a particular entry.

void Deltares.Geotechnics.IO.Importers.CharacteristicPointsImporter.Read | ( | string | fileName,
 |  | IDataFactory | factory
 | ) |  |

This is the unified Read to be used by the original Read(string, List<SurfaceLine2>) and the new Import() method of the superclass Importer class

Parameters
fileName
factory

This one is used by Ringtoets

Generated on Tue Dec 15 2015 18:14:21 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • IO
  • Importers
  • CharacteristicPointsImporter
Deltares.Geotechnics.IO.Importers.CharacteristicPointsImporter Member List

This is the complete list of members for Deltares.Geotechnics.IO.Importers.CharacteristicPointsImporter, including all inherited members.

AddCharacteristicPointToSurfaceLine(SurfaceLine2 surfaceLine, double xGlobal, double yGlobal, double zGlobal, CharacteristicPointType type, bool isAddPointToSurfaceLineIfMissing) | Deltares.Geotechnics.IO.Importers.CharacteristicPointsImporter | protected
Import() (defined in Deltares.Geotechnics.IO.Importers.CharacteristicPointsImporter) | Deltares.Geotechnics.IO.Importers.CharacteristicPointsImporter |
Read(string fileName, List< SurfaceLine2 > surfaceLines) | Deltares.Geotechnics.IO.Importers.CharacteristicPointsImporter |
Read(string fileName, IDataFactory factory) | Deltares.Geotechnics.IO.Importers.CharacteristicPointsImporter |
Generated on Tue Dec 15 2015 18:14:21 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.IO.Importers.Coordinate Struct Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • IO
  • Importers
  • Coordinate
Public Attributes | List of all members
Deltares.Geotechnics.IO.Importers.Coordinate Struct Reference

Public Attributes

double | x
double | y
Generated on Tue Dec 15 2015 18:14:21 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • IO
  • Importers
  • Coordinate
Deltares.Geotechnics.IO.Importers.Coordinate Member List

This is the complete list of members for Deltares.Geotechnics.IO.Importers.Coordinate, including all inherited members.

x (defined in Deltares.Geotechnics.IO.Importers.Coordinate) | Deltares.Geotechnics.IO.Importers.Coordinate
y (defined in Deltares.Geotechnics.IO.Importers.Coordinate) | Deltares.Geotechnics.IO.Importers.Coordinate
Generated on Tue Dec 15 2015 18:14:21 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.IO.Importers.CsvImporterSurfaceLinesException Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • IO
  • Importers
  • CsvImporterSurfaceLinesException
Public Member Functions | List of all members
Deltares.Geotechnics.IO.Importers.CsvImporterSurfaceLinesException Class Reference
Inheritance diagram for Deltares.Geotechnics.IO.Importers.CsvImporterSurfaceLinesException:

Public Member Functions

CsvImporterSurfaceLinesException (string message)
Generated on Tue Dec 15 2015 18:14:22 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • IO
  • Importers
  • CsvImporterSurfaceLinesException
Deltares.Geotechnics.IO.Importers.CsvImporterSurfaceLinesException Member List

This is the complete list of members for Deltares.Geotechnics.IO.Importers.CsvImporterSurfaceLinesException, including all inherited members.

CsvImporterSurfaceLinesException(string message) (defined in Deltares.Geotechnics.IO.Importers.CsvImporterSurfaceLinesException) Deltares.Geotechnics.IO.Importers.CsvImporterSurfaceLinesException
Generated on Tue Dec 15 2015 18:14:22 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.IO.Importers.DGSGEFInterface Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • IO
  • Importers
  • DGSGEFInterface
Public Member Functions | List of all members
Deltares.Geotechnics.IO.Importers.DGSGEFInterface Class Reference

Interface for the functions of the DGSGEF.dll More...

Inheritance diagram for Deltares.Geotechnics.IO.Importers.DGSGEFInterface:
Deltares.Geotechnics.IO.Importers.DGSStandardDLLInterface

Public Member Functions

new string | GetDllVersion ()
Gets DllVersion More...
string | GetError ()
int | GetCptXmlFromGefCptFile (string fileName, StringBuilder outputXml, ref int bufferSize)
Reads a GEF-CPT file and returns it as XML-string More...
int | GetCptXmlFromGefCptString (string cptString, StringBuilder outputXml, ref int bufferSize)
Transforms a GEF-CPT as string to XML-string More...
int | GetBoringXmlFromGefBoringFile (string fileName, StringBuilder outputXml, ref int bufferSize)
Reads a GEF-Boring file and returns it as XML-string More...
int | GetBoringXmlFromGefBoringString (string boringString, StringBuilder outputXml, ref int bufferSize)
Transforms a GEF-Boring as string to XML-string More...
- Public Member Functions inherited from Deltares.Geotechnics.IO.Importers.DGSStandardDLLInterface
string | GetDllVersion ()
Example! (remove this wrapper if not needed) More...
string | ErrorMessage ()

Additional Inherited Members

- Public Attributes inherited from Deltares.Geotechnics.IO.Importers.DGSStandardDLLInterface
const int | DllUErrorNoLicense = 1
const int | DllErrorUserAborted = 2
const int | DllErrorNonCompliantXml = 3
const int | DllErrorInvalidInputData = 4
const int | DllErrorHandledFatal = 5
const int | DllErrorUnhandledFatal = 6
const int | DllErrorInvalidHandle = 7
const int | DllErrorOutputBufferTooSmall = 8
- Static Public Attributes inherited from Deltares.Geotechnics.IO.Importers.DGSStandardDLLInterface
static int | DllErrorNone = 0
Error constants More...
static int | DllErrorLastErrorCode = 0

Detailed Description

Interface for the functions of the DGSGEF.dll

Member Function Documentation

int Deltares.Geotechnics.IO.Importers.DGSGEFInterface.GetBoringXmlFromGefBoringFile | ( | string | fileName,
 |  | StringBuilder | outputXml,
 |  | ref int | bufferSize
 | ) |  |

Reads a GEF-Boring file and returns it as XML-string

Returns
Error as integer
int Deltares.Geotechnics.IO.Importers.DGSGEFInterface.GetBoringXmlFromGefBoringString | ( | string | boringString,
 |  | StringBuilder | outputXml,
 |  | ref int | bufferSize
 | ) |  |

Transforms a GEF-Boring as string to XML-string

Returns
Error as integer
int Deltares.Geotechnics.IO.Importers.DGSGEFInterface.GetCptXmlFromGefCptFile | ( | string | fileName,
 |  | StringBuilder | outputXml,
 |  | ref int | bufferSize
 | ) |  |

Reads a GEF-CPT file and returns it as XML-string

Returns
Error as integer
int Deltares.Geotechnics.IO.Importers.DGSGEFInterface.GetCptXmlFromGefCptString | ( | string | cptString,
 |  | StringBuilder | outputXml,
 |  | ref int | bufferSize
 | ) |  |

Transforms a GEF-CPT as string to XML-string

Returns
Error as integer
new string Deltares.Geotechnics.IO.Importers.DGSGEFInterface.GetDllVersion ( )

Gets DllVersion

Returns
version as string
Generated on Tue Dec 15 2015 18:14:22 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • IO
  • Importers
  • DGSGEFInterface
Deltares.Geotechnics.IO.Importers.DGSGEFInterface Member List

This is the complete list of members for Deltares.Geotechnics.IO.Importers.DGSGEFInterface, including all inherited members.

DllErrorHandledFatal (defined in Deltares.Geotechnics.IO.Importers.DGSStandardDLLInterface) | Deltares.Geotechnics.IO.Importers.DGSStandardDLLInterface |
DllErrorInvalidHandle (defined in Deltares.Geotechnics.IO.Importers.DGSStandardDLLInterface) | Deltares.Geotechnics.IO.Importers.DGSStandardDLLInterface |
DllErrorInvalidInputData (defined in Deltares.Geotechnics.IO.Importers.DGSStandardDLLInterface) | Deltares.Geotechnics.IO.Importers.DGSStandardDLLInterface |
DllErrorLastErrorCode (defined in Deltares.Geotechnics.IO.Importers.DGSStandardDLLInterface) | Deltares.Geotechnics.IO.Importers.DGSStandardDLLInterface | static
DllErrorNonCompliantXml (defined in Deltares.Geotechnics.IO.Importers.DGSStandardDLLInterface) | Deltares.Geotechnics.IO.Importers.DGSStandardDLLInterface |
DllErrorNone | Deltares.Geotechnics.IO.Importers.DGSStandardDLLInterface | static
DllErrorOutputBufferTooSmall (defined in Deltares.Geotechnics.IO.Importers.DGSStandardDLLInterface) | Deltares.Geotechnics.IO.Importers.DGSStandardDLLInterface |
DllErrorUnhandledFatal (defined in Deltares.Geotechnics.IO.Importers.DGSStandardDLLInterface) | Deltares.Geotechnics.IO.Importers.DGSStandardDLLInterface |
DllErrorUserAborted (defined in Deltares.Geotechnics.IO.Importers.DGSStandardDLLInterface) | Deltares.Geotechnics.IO.Importers.DGSStandardDLLInterface |
DllUErrorNoLicense (defined in Deltares.Geotechnics.IO.Importers.DGSStandardDLLInterface) | Deltares.Geotechnics.IO.Importers.DGSStandardDLLInterface |
ErrorMessage() (defined in Deltares.Geotechnics.IO.Importers.DGSStandardDLLInterface) | Deltares.Geotechnics.IO.Importers.DGSStandardDLLInterface |
GetBoringXmlFromGefBoringFile(string fileName, StringBuilder outputXml, ref int bufferSize) | Deltares.Geotechnics.IO.Importers.DGSGEFInterface |
GetBoringXmlFromGefBoringString(string boringString, StringBuilder outputXml, ref int bufferSize) | Deltares.Geotechnics.IO.Importers.DGSGEFInterface |
GetCptXmlFromGefCptFile(string fileName, StringBuilder outputXml, ref int bufferSize) | Deltares.Geotechnics.IO.Importers.DGSGEFInterface |
GetCptXmlFromGefCptString(string cptString, StringBuilder outputXml, ref int bufferSize) | Deltares.Geotechnics.IO.Importers.DGSGEFInterface |
GetDllVersion() | Deltares.Geotechnics.IO.Importers.DGSGEFInterface |
GetError() (defined in Deltares.Geotechnics.IO.Importers.DGSGEFInterface) | Deltares.Geotechnics.IO.Importers.DGSGEFInterface |
Generated on Tue Dec 15 2015 18:14:22 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.IO.Importers.DGSStandardDLLInterface Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • IO
  • Importers
  • DGSStandardDLLInterface
Public Member Functions | Public Attributes | Static Public Attributes | List of all members
Deltares.Geotechnics.IO.Importers.DGSStandardDLLInterface Class Reference
Inheritance diagram for Deltares.Geotechnics.IO.Importers.DGSStandardDLLInterface:
Deltares.Geotechnics.IO.Importers.DGSGEFInterface

Public Member Functions

string | GetDllVersion ()
Example! (remove this wrapper if not needed) More...
string | ErrorMessage ()

Public Attributes

const int | DllUErrorNoLicense = 1
const int | DllErrorUserAborted = 2
const int | DllErrorNonCompliantXml = 3
const int | DllErrorInvalidInputData = 4
const int | DllErrorHandledFatal = 5
const int | DllErrorUnhandledFatal = 6
const int | DllErrorInvalidHandle = 7
const int | DllErrorOutputBufferTooSmall = 8

Static Public Attributes

static int | DllErrorNone = 0
Error constants More...
static int | DllErrorLastErrorCode = 0

Member Function Documentation

string Deltares.Geotechnics.IO.Importers.DGSStandardDLLInterface.GetDllVersion ( )

Example! (remove this wrapper if not needed)

Returns

Member Data Documentation

int Deltares.Geotechnics.IO.Importers.DGSStandardDLLInterface.DllErrorNone = 0
static

Error constants

Generated on Tue Dec 15 2015 18:14:22 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • IO
  • Importers
  • DGSStandardDLLInterface
Deltares.Geotechnics.IO.Importers.DGSStandardDLLInterface Member List

This is the complete list of members for Deltares.Geotechnics.IO.Importers.DGSStandardDLLInterface, including all inherited members.

DllErrorHandledFatal (defined in Deltares.Geotechnics.IO.Importers.DGSStandardDLLInterface) | Deltares.Geotechnics.IO.Importers.DGSStandardDLLInterface |
DllErrorInvalidHandle (defined in Deltares.Geotechnics.IO.Importers.DGSStandardDLLInterface) | Deltares.Geotechnics.IO.Importers.DGSStandardDLLInterface |
DllErrorInvalidInputData (defined in Deltares.Geotechnics.IO.Importers.DGSStandardDLLInterface) | Deltares.Geotechnics.IO.Importers.DGSStandardDLLInterface |
DllErrorLastErrorCode (defined in Deltares.Geotechnics.IO.Importers.DGSStandardDLLInterface) | Deltares.Geotechnics.IO.Importers.DGSStandardDLLInterface | static
DllErrorNonCompliantXml (defined in Deltares.Geotechnics.IO.Importers.DGSStandardDLLInterface) | Deltares.Geotechnics.IO.Importers.DGSStandardDLLInterface |
DllErrorNone | Deltares.Geotechnics.IO.Importers.DGSStandardDLLInterface | static
DllErrorOutputBufferTooSmall (defined in Deltares.Geotechnics.IO.Importers.DGSStandardDLLInterface) | Deltares.Geotechnics.IO.Importers.DGSStandardDLLInterface |
DllErrorUnhandledFatal (defined in Deltares.Geotechnics.IO.Importers.DGSStandardDLLInterface) | Deltares.Geotechnics.IO.Importers.DGSStandardDLLInterface |
DllErrorUserAborted (defined in Deltares.Geotechnics.IO.Importers.DGSStandardDLLInterface) | Deltares.Geotechnics.IO.Importers.DGSStandardDLLInterface |
DllUErrorNoLicense (defined in Deltares.Geotechnics.IO.Importers.DGSStandardDLLInterface) | Deltares.Geotechnics.IO.Importers.DGSStandardDLLInterface |
ErrorMessage() (defined in Deltares.Geotechnics.IO.Importers.DGSStandardDLLInterface) | Deltares.Geotechnics.IO.Importers.DGSStandardDLLInterface |
GetDllVersion() | Deltares.Geotechnics.IO.Importers.DGSStandardDLLInterface |
Generated on Tue Dec 15 2015 18:14:22 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.IO.Importers.DllVersionInfoStructure Struct Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • IO
  • Importers
  • DllVersionInfoStructure
Public Attributes | List of all members
Deltares.Geotechnics.IO.Importers.DllVersionInfoStructure Struct Reference

Public Attributes

uint | CbSize
uint | DwMajorVersion
uint | DwMinorVersion
uint | DwBuildNumber
uint | DwPlatformID
Generated on Tue Dec 15 2015 18:14:22 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • IO
  • Importers
  • DllVersionInfoStructure
Deltares.Geotechnics.IO.Importers.DllVersionInfoStructure Member List

This is the complete list of members for Deltares.Geotechnics.IO.Importers.DllVersionInfoStructure, including all inherited members.

CbSize (defined in Deltares.Geotechnics.IO.Importers.DllVersionInfoStructure) | Deltares.Geotechnics.IO.Importers.DllVersionInfoStructure
DwBuildNumber (defined in Deltares.Geotechnics.IO.Importers.DllVersionInfoStructure) | Deltares.Geotechnics.IO.Importers.DllVersionInfoStructure
DwMajorVersion (defined in Deltares.Geotechnics.IO.Importers.DllVersionInfoStructure) | Deltares.Geotechnics.IO.Importers.DllVersionInfoStructure
DwMinorVersion (defined in Deltares.Geotechnics.IO.Importers.DllVersionInfoStructure) | Deltares.Geotechnics.IO.Importers.DllVersionInfoStructure
DwPlatformID (defined in Deltares.Geotechnics.IO.Importers.DllVersionInfoStructure) | Deltares.Geotechnics.IO.Importers.DllVersionInfoStructure
Generated on Tue Dec 15 2015 18:14:22 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.IO.Importers.FetchesImporter Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • IO
  • Importers
  • FetchesImporter
Public Member Functions | Properties | List of all members
Deltares.Geotechnics.IO.Importers.FetchesImporter Class Reference

Imports the fetches from a csv file. More...

Inheritance diagram for Deltares.Geotechnics.IO.Importers.FetchesImporter:

Public Member Functions

override void Import ()
Imports the fetches from a csv file. More...

Properties

static IList< string > ErrorMessages [get]

Detailed Description

Imports the fetches from a csv file.

Member Function Documentation

override void Deltares.Geotechnics.IO.Importers.FetchesImporter.Import ( )

Imports the fetches from a csv file.

Generated on Tue Dec 15 2015 18:14:22 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • IO
  • Importers
  • FetchesImporter
Deltares.Geotechnics.IO.Importers.FetchesImporter Member List

This is the complete list of members for Deltares.Geotechnics.IO.Importers.FetchesImporter, including all inherited members.

ErrorMessages (defined in Deltares.Geotechnics.IO.Importers.FetchesImporter) | Deltares.Geotechnics.IO.Importers.FetchesImporter | static
Import() | Deltares.Geotechnics.IO.Importers.FetchesImporter |
Generated on Tue Dec 15 2015 18:14:22 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.IO.Importers.GefBoringFileImporter Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • IO
  • Importers
  • GefBoringFileImporter
Public Member Functions | Properties | List of all members
Deltares.Geotechnics.IO.Importers.GefBoringFileImporter Class Reference

Imports a Boring from a GEF-file given by filename or as string More...

Public Member Functions

bool | FillFromGefFile (string fileName, SoilList soilList)
Imports a CPT from a GEF file defined by filename. More...
bool | FillFromGefString (string name, string input, SoilList soilList)
Imports a Boring from a GEF-file defined as content string More...

Properties

Boring | Boring [get]
List< LogMessage > | ErrorMessages [get, set]
Dictionary< string, Soil > | OriginalSoilNamesDictionary [get, set]

Detailed Description

Imports a Boring from a GEF-file given by filename or as string

Member Function Documentation

bool Deltares.Geotechnics.IO.Importers.GefBoringFileImporter.FillFromGefFile | ( | string | fileName,
 |  | SoilList | soilList
 | ) |  |

Imports a CPT from a GEF file defined by filename.

Parameters
fileName
soilList
bool Deltares.Geotechnics.IO.Importers.GefBoringFileImporter.FillFromGefString | ( | string | name,
 |  | string | input,
 |  | SoilList | soilList
 | ) |  |

Imports a Boring from a GEF-file defined as content string

Parameters
name
input
soilList
Generated on Tue Dec 15 2015 18:14:22 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • IO
  • Importers
  • GefBoringFileImporter
Deltares.Geotechnics.IO.Importers.GefBoringFileImporter Member List

This is the complete list of members for Deltares.Geotechnics.IO.Importers.GefBoringFileImporter, including all inherited members.

Boring (defined in Deltares.Geotechnics.IO.Importers.GefBoringFileImporter) | Deltares.Geotechnics.IO.Importers.GefBoringFileImporter
ErrorMessages (defined in Deltares.Geotechnics.IO.Importers.GefBoringFileImporter) | Deltares.Geotechnics.IO.Importers.GefBoringFileImporter
FillFromGefFile(string fileName, SoilList soilList) | Deltares.Geotechnics.IO.Importers.GefBoringFileImporter
FillFromGefString(string name, string input, SoilList soilList) | Deltares.Geotechnics.IO.Importers.GefBoringFileImporter
OriginalSoilNamesDictionary (defined in Deltares.Geotechnics.IO.Importers.GefBoringFileImporter) | Deltares.Geotechnics.IO.Importers.GefBoringFileImporter
Generated on Tue Dec 15 2015 18:14:22 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.IO.Importers.GefCptFileImporter Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • IO
  • Importers
  • GefCptFileImporter
Public Member Functions | Properties | List of all members
Deltares.Geotechnics.IO.Importers.GefCptFileImporter Class Reference

Imports a CPT from a GEF-file given by filename or as string More...

Public Member Functions

bool | FillFromGefFile (string fileName)
Imports a CPT from a GEF file defined by filename. More...
bool | FillFromGefString (string name, string input)
Imports a CPT from a GEF-file defined as content string More...

Properties

ConePenetrationTest.ConePenetrationTestData | ConePenetrationTestData [get]
List< LogMessage > | ErrorMessages [get, set]

Detailed Description

Imports a CPT from a GEF-file given by filename or as string

Member Function Documentation

bool Deltares.Geotechnics.IO.Importers.GefCptFileImporter.FillFromGefFile ( string fileName )

Imports a CPT from a GEF file defined by filename.

Parameters
fileName
bool Deltares.Geotechnics.IO.Importers.GefCptFileImporter.FillFromGefString | ( | string | name,
 |  | string | input
 | ) |  |

Imports a CPT from a GEF-file defined as content string

Parameters
name
input
Generated on Tue Dec 15 2015 18:14:22 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • IO
  • Importers
  • GefCptFileImporter
Deltares.Geotechnics.IO.Importers.GefCptFileImporter Member List

This is the complete list of members for Deltares.Geotechnics.IO.Importers.GefCptFileImporter, including all inherited members.

ConePenetrationTestData (defined in Deltares.Geotechnics.IO.Importers.GefCptFileImporter) | Deltares.Geotechnics.IO.Importers.GefCptFileImporter
ErrorMessages (defined in Deltares.Geotechnics.IO.Importers.GefCptFileImporter) | Deltares.Geotechnics.IO.Importers.GefCptFileImporter
FillFromGefFile(string fileName) | Deltares.Geotechnics.IO.Importers.GefCptFileImporter
FillFromGefString(string name, string input) | Deltares.Geotechnics.IO.Importers.GefCptFileImporter
Generated on Tue Dec 15 2015 18:14:22 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.IO.Importers.GEFXmlImporter Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • IO
  • Importers
  • GEFXmlImporter
Public Member Functions | List of all members
Deltares.Geotechnics.IO.Importers.GEFXmlImporter Class Reference

This class is used to import data (CPT, Profile, Soils) from a CPTip xml format string or stream More...

Public Member Functions

ConePenetrationTest.ConePenetrationTestData | ReadCPT (Stream input)
Read CPT data More...
ConePenetrationTest.ConePenetrationTestData | ReadCPT (String input)
Read CPT data More...
Boring | ReadBoring (Stream input, SoilList soils)
Read Boring data More...
Boring | ReadBoring (String input, SoilList soils)
Read CPT data More...
SoilProfile1D | ReadSoilProfile1D (Stream input)
Read SoilProfile1D data More...
SoilProfile1D | ReadSoilProfile1D (String input)
Read SoilProfile1D data More...
List< Soil > | ReadSoils (Stream input)
Read Soil data More...
List< Soil > | ReadSoils (String input)
Read Soil data More...

Detailed Description

This class is used to import data (CPT, Profile, Soils) from a CPTip xml format string or stream

Member Function Documentation

Boring Deltares.Geotechnics.IO.Importers.GEFXmlImporter.ReadBoring | ( | Stream | input,
 |  | SoilList | soils
 | ) |  |

Read Boring data

Parameters
input input Stream (xml)
soils
Returns
Deltares.Geotechnics.Boring
Boring Deltares.Geotechnics.IO.Importers.GEFXmlImporter.ReadBoring | ( | String | input,
 |  | SoilList | soils
 | ) |  |

Read CPT data

Parameters
input input String (xml)
Returns
Deltares.Geotechnics.CPT
ConePenetrationTest.ConePenetrationTestData Deltares.Geotechnics.IO.Importers.GEFXmlImporter.ReadCPT ( Stream input )

Read CPT data

Parameters
input input Stream (xml)
Returns
Deltares.Geotechnics.CPT
ConePenetrationTest.ConePenetrationTestData Deltares.Geotechnics.IO.Importers.GEFXmlImporter.ReadCPT ( String input )

Read CPT data

Parameters
input input String (xml)
Returns
Deltares.Geotechnics.CPT
SoilProfile1D Deltares.Geotechnics.IO.Importers.GEFXmlImporter.ReadSoilProfile1D ( Stream input )

Read SoilProfile1D data

Parameters
input input Stream (xml)
Returns
Deltares.Geotechnics.SoilProfile1D

References Deltares.Geotechnics.SoilProfile1D.Layers.

SoilProfile1D Deltares.Geotechnics.IO.Importers.GEFXmlImporter.ReadSoilProfile1D ( String input )

Read SoilProfile1D data

Parameters
input input String (xml)
Returns
Deltares.Geotechnics.SoilProfile1D
List<Soil> Deltares.Geotechnics.IO.Importers.GEFXmlImporter.ReadSoils ( Stream input )

Read Soil data

Parameters
input input Stream (xml)
Returns
List<Deltares.Geotechnics.Soil>
List<Soil> Deltares.Geotechnics.IO.Importers.GEFXmlImporter.ReadSoils ( String input )

Read Soil data

Parameters
input input String (xml)
Returns
List<Deltares.Geotechnics.Soil>
Generated on Tue Dec 15 2015 18:14:22 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • IO
  • Importers
  • GEFXmlImporter
Deltares.Geotechnics.IO.Importers.GEFXmlImporter Member List

This is the complete list of members for Deltares.Geotechnics.IO.Importers.GEFXmlImporter, including all inherited members.

ReadBoring(Stream input, SoilList soils) | Deltares.Geotechnics.IO.Importers.GEFXmlImporter
ReadBoring(String input, SoilList soils) | Deltares.Geotechnics.IO.Importers.GEFXmlImporter
ReadCPT(Stream input) | Deltares.Geotechnics.IO.Importers.GEFXmlImporter
ReadCPT(String input) | Deltares.Geotechnics.IO.Importers.GEFXmlImporter
ReadSoilProfile1D(Stream input) | Deltares.Geotechnics.IO.Importers.GEFXmlImporter
ReadSoilProfile1D(String input) | Deltares.Geotechnics.IO.Importers.GEFXmlImporter
ReadSoils(Stream input) | Deltares.Geotechnics.IO.Importers.GEFXmlImporter
ReadSoils(String input) | Deltares.Geotechnics.IO.Importers.GEFXmlImporter
Generated on Tue Dec 15 2015 18:14:22 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.IO.Importers.OldBoundary Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • IO
  • Importers
  • OldBoundary
Public Attributes | List of all members
Deltares.Geotechnics.IO.Importers.OldBoundary Class Reference

Public Attributes

List< int > | CurveIndices
List< GeometryCurve > | Curves = new List<GeometryCurve>()
bool | Handled
int | NCurves
string | SoilName
Generated on Tue Dec 15 2015 18:14:22 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • IO
  • Importers
  • OldBoundary
Deltares.Geotechnics.IO.Importers.OldBoundary Member List

This is the complete list of members for Deltares.Geotechnics.IO.Importers.OldBoundary, including all inherited members.

CurveIndices (defined in Deltares.Geotechnics.IO.Importers.OldBoundary) | Deltares.Geotechnics.IO.Importers.OldBoundary
Curves (defined in Deltares.Geotechnics.IO.Importers.OldBoundary) | Deltares.Geotechnics.IO.Importers.OldBoundary
Handled (defined in Deltares.Geotechnics.IO.Importers.OldBoundary) | Deltares.Geotechnics.IO.Importers.OldBoundary
NCurves (defined in Deltares.Geotechnics.IO.Importers.OldBoundary) | Deltares.Geotechnics.IO.Importers.OldBoundary
SoilName (defined in Deltares.Geotechnics.IO.Importers.OldBoundary) | Deltares.Geotechnics.IO.Importers.OldBoundary
Generated on Tue Dec 15 2015 18:14:22 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.IO.Importers.OldGeometryFileImporter Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • IO
  • Importers
  • OldGeometryFileImporter
Public Member Functions | Properties | List of all members
Deltares.Geotechnics.IO.Importers.OldGeometryFileImporter Class Reference

Public Member Functions

virtual void | FillFromOldGeoFile (string fileName)
virtual void | FillFromOldGeoFileAsStrings (List< string > fileContent)

Properties

SoilProfile2D | SoilProfile2D [get]
List< Soil > | Soils [get, set]
Dictionary< string, Soil > | OriginalSoilNamesDictionary [get, set]
Generated on Tue Dec 15 2015 18:14:22 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • IO
  • Importers
  • OldGeometryFileImporter
Deltares.Geotechnics.IO.Importers.OldGeometryFileImporter Member List

This is the complete list of members for Deltares.Geotechnics.IO.Importers.OldGeometryFileImporter, including all inherited members.

FillFromOldGeoFile(string fileName) (defined in Deltares.Geotechnics.IO.Importers.OldGeometryFileImporter) | Deltares.Geotechnics.IO.Importers.OldGeometryFileImporter | virtual
FillFromOldGeoFileAsStrings(List< string > fileContent) (defined in Deltares.Geotechnics.IO.Importers.OldGeometryFileImporter) | Deltares.Geotechnics.IO.Importers.OldGeometryFileImporter | virtual
OriginalSoilNamesDictionary (defined in Deltares.Geotechnics.IO.Importers.OldGeometryFileImporter) | Deltares.Geotechnics.IO.Importers.OldGeometryFileImporter |
SoilProfile2D (defined in Deltares.Geotechnics.IO.Importers.OldGeometryFileImporter) | Deltares.Geotechnics.IO.Importers.OldGeometryFileImporter |
Soils (defined in Deltares.Geotechnics.IO.Importers.OldGeometryFileImporter) | Deltares.Geotechnics.IO.Importers.OldGeometryFileImporter |
Generated on Tue Dec 15 2015 18:14:22 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.IO.Importers.SoilProfilesImporter Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • IO
  • Importers
  • SoilProfilesImporter
Public Member Functions | Protected Member Functions | Static Protected Member Functions | List of all members
Deltares.Geotechnics.IO.Importers.SoilProfilesImporter Class Reference

Importer for reading 1D soil profiles from CSV format files More...

Inheritance diagram for Deltares.Geotechnics.IO.Importers.SoilProfilesImporter:
Deltares.DSoilModel.Data.SosSoilProfilesImporter

Public Member Functions

List< SoilProfile1D > | ReadSoilProfiles (string fileName, SoilList soils)
Read soil profiles, referencing soils in the provided list More...
override void | Import ()
Standard Importer interface to import file after setting the FileName and Factory properties More...

Protected Member Functions

virtual List< SoilProfile1D > | ReadSoilProfiles (string fileName, SoilList soils, IDataFactory factory)
Read soil profiles, referencing soils in the provided list or using a factory to get the referenced soils More...
Soil | GetSoil (List< Soil > soils, string name)

Static Protected Member Functions

static void CheckColumn (int index, string fileName, string fieldName)

Detailed Description

Importer for reading 1D soil profiles from CSV format files

Member Function Documentation

override void Deltares.Geotechnics.IO.Importers.SoilProfilesImporter.Import ( )

Standard Importer interface to import file after setting the FileName and Factory properties

List<SoilProfile1D> Deltares.Geotechnics.IO.Importers.SoilProfilesImporter.ReadSoilProfiles | ( | string | fileName,
 |  | SoilList | soils
 | ) |  |

Read soil profiles, referencing soils in the provided list

Parameters
fileName | path of the file to import
soils | list of available soil materials to reference
Returns
List of SoilProfile1D objects
virtual List<SoilProfile1D> Deltares.Geotechnics.IO.Importers.SoilProfilesImporter.ReadSoilProfiles | ( | string | fileName,
 |  | SoilList | soils,
 |  | IDataFactory | factory
 | ) |  |
protectedvirtual

Read soil profiles, referencing soils in the provided list or using a factory to get the referenced soils

Parameters
fileName | path of the file to import
soils | list of available soil materials to reference
factory
Returns
List of SoilProfile1D objects

Reimplemented in Deltares.DSoilModel.Data.SosSoilProfilesImporter.

References Deltares.Geotechnics.SoilProfile1D.Layers.

Generated on Tue Dec 15 2015 18:14:23 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • IO
  • Importers
  • SoilProfilesImporter
Deltares.Geotechnics.IO.Importers.SoilProfilesImporter Member List

This is the complete list of members for Deltares.Geotechnics.IO.Importers.SoilProfilesImporter, including all inherited members.

CheckColumn(int index, string fileName, string fieldName) (defined in Deltares.Geotechnics.IO.Importers.SoilProfilesImporter) | Deltares.Geotechnics.IO.Importers.SoilProfilesImporter | protectedstatic
GetSoil(List< Soil > soils, string name) (defined in Deltares.Geotechnics.IO.Importers.SoilProfilesImporter) | Deltares.Geotechnics.IO.Importers.SoilProfilesImporter | protected
Import() | Deltares.Geotechnics.IO.Importers.SoilProfilesImporter |
ReadSoilProfiles(string fileName, SoilList soils) | Deltares.Geotechnics.IO.Importers.SoilProfilesImporter |
ReadSoilProfiles(string fileName, SoilList soils, IDataFactory factory) | Deltares.Geotechnics.IO.Importers.SoilProfilesImporter | protectedvirtual
Generated on Tue Dec 15 2015 18:14:23 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.IO.Importers.SoilSegmentsImporter Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • IO
  • Importers
  • SoilSegmentsImporter
Classes | Public Member Functions | List of all members
Deltares.Geotechnics.IO.Importers.SoilSegmentsImporter Class Reference

Imports SoilSegment (stochastic soil models) from DAM style segments.csv file Each segment contains an ID/Name and reference to failure mechanism specific soil Models, but no spatial information More...

Inheritance diagram for Deltares.Geotechnics.IO.Importers.SoilSegmentsImporter:

Classes

class CsvRecordClass

Public Member Functions

List< SoilSegment > | ReadSoilSegments (string fileName, List< SoilProfile > soilProfiles)
override void | Import ()

Detailed Description

Imports SoilSegment (stochastic soil models) from DAM style segments.csv file Each segment contains an ID/Name and reference to failure mechanism specific soil Models, but no spatial information

Generated on Tue Dec 15 2015 18:14:23 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • IO
  • Importers
  • SoilSegmentsImporter
Deltares.Geotechnics.IO.Importers.SoilSegmentsImporter Member List

This is the complete list of members for Deltares.Geotechnics.IO.Importers.SoilSegmentsImporter, including all inherited members.

Import() (defined in Deltares.Geotechnics.IO.Importers.SoilSegmentsImporter) | Deltares.Geotechnics.IO.Importers.SoilSegmentsImporter
ReadSoilSegments(string fileName, List< SoilProfile > soilProfiles) (defined in Deltares.Geotechnics.IO.Importers.SoilSegmentsImporter) | Deltares.Geotechnics.IO.Importers.SoilSegmentsImporter
Generated on Tue Dec 15 2015 18:14:23 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.IO.Importers.SoilSegmentsImporter.CsvRecordClass Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • IO
  • Importers
  • SoilSegmentsImporter
  • CsvRecordClass
Properties | List of all members
Deltares.Geotechnics.IO.Importers.SoilSegmentsImporter.CsvRecordClass Class Reference

Properties

string | Id [get, set]
string | SoilProfileId [get, set]
string | SoilProfile2DName [get, set]
double | Probability [get, set]
string | Mechanism [get, set]
Generated on Tue Dec 15 2015 18:14:23 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • IO
  • Importers
  • SoilSegmentsImporter
  • CsvRecordClass
Deltares.Geotechnics.IO.Importers.SoilSegmentsImporter.CsvRecordClass Member List

This is the complete list of members for Deltares.Geotechnics.IO.Importers.SoilSegmentsImporter.CsvRecordClass, including all inherited members.

Id (defined in Deltares.Geotechnics.IO.Importers.SoilSegmentsImporter.CsvRecordClass) | Deltares.Geotechnics.IO.Importers.SoilSegmentsImporter.CsvRecordClass
Mechanism (defined in Deltares.Geotechnics.IO.Importers.SoilSegmentsImporter.CsvRecordClass) | Deltares.Geotechnics.IO.Importers.SoilSegmentsImporter.CsvRecordClass
Probability (defined in Deltares.Geotechnics.IO.Importers.SoilSegmentsImporter.CsvRecordClass) | Deltares.Geotechnics.IO.Importers.SoilSegmentsImporter.CsvRecordClass
SoilProfile2DName (defined in Deltares.Geotechnics.IO.Importers.SoilSegmentsImporter.CsvRecordClass) | Deltares.Geotechnics.IO.Importers.SoilSegmentsImporter.CsvRecordClass
SoilProfileId (defined in Deltares.Geotechnics.IO.Importers.SoilSegmentsImporter.CsvRecordClass) | Deltares.Geotechnics.IO.Importers.SoilSegmentsImporter.CsvRecordClass
Generated on Tue Dec 15 2015 18:14:23 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.IO.Importers.SurfaceLinesImporter Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • IO
  • Importers
  • SurfaceLinesImporter
Public Member Functions | List of all members
Deltares.Geotechnics.IO.Importers.SurfaceLinesImporter Class Reference

Imports surface line from DAM style surfacelines.csv file More...

Inheritance diagram for Deltares.Geotechnics.IO.Importers.SurfaceLinesImporter:

Public Member Functions

List< SurfaceLine2 > | ReadSurfacesLines (string filePath)
List< SurfaceLine2 > | ReadSurfacesLines (string filePath, IDataFactory factory)
Reads the (localized) surfaces lines. More...
override void | Import ()

Detailed Description

Imports surface line from DAM style surfacelines.csv file

Member Function Documentation

List<SurfaceLine2> Deltares.Geotechnics.IO.Importers.SurfaceLinesImporter.ReadSurfacesLines | ( | string | filePath,
 |  | IDataFactory | factory
 | ) |  |

Reads the (localized) surfaces lines.

Parameters
filePath | Full path to the imported file.
factory | The factory (optional). When false, a simple instance of SurfaceLine2 will be constructed.
Returns
All imported, localized, surfacelines.
Generated on Tue Dec 15 2015 18:14:23 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • IO
  • Importers
  • SurfaceLinesImporter
Deltares.Geotechnics.IO.Importers.SurfaceLinesImporter Member List

This is the complete list of members for Deltares.Geotechnics.IO.Importers.SurfaceLinesImporter, including all inherited members.

Import() (defined in Deltares.Geotechnics.IO.Importers.SurfaceLinesImporter) | Deltares.Geotechnics.IO.Importers.SurfaceLinesImporter
ReadSurfacesLines(string filePath) (defined in Deltares.Geotechnics.IO.Importers.SurfaceLinesImporter) | Deltares.Geotechnics.IO.Importers.SurfaceLinesImporter
ReadSurfacesLines(string filePath, IDataFactory factory) | Deltares.Geotechnics.IO.Importers.SurfaceLinesImporter
Generated on Tue Dec 15 2015 18:14:23 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.IO.SurfaceLineClassFactory Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • IO
  • SurfaceLineClassFactory
Public Member Functions | List of all members
Deltares.Geotechnics.IO.SurfaceLineClassFactory Class Reference
Inheritance diagram for Deltares.Geotechnics.IO.SurfaceLineClassFactory:

Public Member Functions

bool | CanHandle (Type type)
object | CreateInstance (Type type, XmlNode node)
Generated on Tue Dec 15 2015 18:14:20 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • IO
  • SurfaceLineClassFactory
Deltares.Geotechnics.IO.SurfaceLineClassFactory Member List

This is the complete list of members for Deltares.Geotechnics.IO.SurfaceLineClassFactory, including all inherited members.

CanHandle(Type type) (defined in Deltares.Geotechnics.IO.SurfaceLineClassFactory) | Deltares.Geotechnics.IO.SurfaceLineClassFactory
CreateInstance(Type type, XmlNode node) (defined in Deltares.Geotechnics.IO.SurfaceLineClassFactory) | Deltares.Geotechnics.IO.SurfaceLineClassFactory
Generated on Tue Dec 15 2015 18:14:20 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.IO.SurfaceLineInstanceFactory Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • IO
  • SurfaceLineInstanceFactory
Public Member Functions | List of all members
Deltares.Geotechnics.IO.SurfaceLineInstanceFactory Class Reference

This factory creates a SurfaceLine instance if it is required by the XML definition This factory exists for backwards compatibility for SurfaceLine2 refactoring More...

Inheritance diagram for Deltares.Geotechnics.IO.SurfaceLineInstanceFactory:

Public Member Functions

bool | CanHandle (Type type)
This method will return true for a SurfaceLine2 type, false otherwise More...
object | CreateInstance (Type type, XmlNode node)
Creates an instance of SurfaceLine if the XMLNode is representing an old SurfaceLine instance. If it is a new SurfaceLine2, a null is returned so the usual instance creation can take place. More...

Detailed Description

This factory creates a SurfaceLine instance if it is required by the XML definition This factory exists for backwards compatibility for SurfaceLine2 refactoring

Member Function Documentation

bool Deltares.Geotechnics.IO.SurfaceLineInstanceFactory.CanHandle ( Type type )

This method will return true for a SurfaceLine2 type, false otherwise

Parameters
type The type for which is checked whether this class can handle it.
Returns
Returns true for SurfaceLine2 type, false otherwise
object Deltares.Geotechnics.IO.SurfaceLineInstanceFactory.CreateInstance | ( | Type | type,
 |  | XmlNode | node
 | ) |  |

Creates an instance of SurfaceLine if the XMLNode is representing an old SurfaceLine instance. If it is a new SurfaceLine2, a null is returned so the usual instance creation can take place.

Parameters
type | The type which would be initialized
node | The XML node which contains information about the serialized instance
Returns
An instance of SurfaceLine if the node is a serialized SurfaceLine, null otherwise.
Generated on Tue Dec 15 2015 18:14:20 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • IO
  • SurfaceLineInstanceFactory
Deltares.Geotechnics.IO.SurfaceLineInstanceFactory Member List

This is the complete list of members for Deltares.Geotechnics.IO.SurfaceLineInstanceFactory, including all inherited members.

CanHandle(Type type) | Deltares.Geotechnics.IO.SurfaceLineInstanceFactory
CreateInstance(Type type, XmlNode node) | Deltares.Geotechnics.IO.SurfaceLineInstanceFactory
Generated on Tue Dec 15 2015 18:14:20 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.IO.SurfaceLineXmlHandler Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • IO
  • SurfaceLineXmlHandler
Public Member Functions | List of all members
Deltares.Geotechnics.IO.SurfaceLineXmlHandler Class Reference

This handler is responsible for handling an object which has been created with the SurfaceLine type. Since the old SurfaceLine has been refactored, this handler will convert the old SurfaceLine to a SurfaceLine2. More...

Inheritance diagram for Deltares.Geotechnics.IO.SurfaceLineXmlHandler:

Public Member Functions

void | SetVersion (string version)
bool | CanHandle (Type type)
This method returns true for a Location type and the Location.Surfaceline property. More...
bool | CanHandle (Type type, string property)
This method returns true for a Location type and the Location.Surfaceline property. More...
void | Handle (object target, string property, object value, object[] objects)
Not implemented for this class. More...
void | HandleObject (object target, object value)
If the value is an old BaseSurfaceLine and the target is a Location, the value will be converted to the new SurfaceLine2 and the Location.Surfaceline property is set for the target. More...
Type | GetFormerPropertyType (Type type, string property)
void | Upgrade (object[] targets)

Detailed Description

This handler is responsible for handling an object which has been created with the SurfaceLine type. Since the old SurfaceLine has been refactored, this handler will convert the old SurfaceLine to a SurfaceLine2.

Member Function Documentation

bool Deltares.Geotechnics.IO.SurfaceLineXmlHandler.CanHandle ( Type type )

This method returns true for a Location type and the Location.Surfaceline property.

Parameters
type | The type to check for.
property | The property of the type to check for
Returns
True if type is Location and property is "SurfaceLine"
bool Deltares.Geotechnics.IO.SurfaceLineXmlHandler.CanHandle | ( | Type | type,
 |  | string | property
 | ) |  |

This method returns true for a Location type and the Location.Surfaceline property.

Parameters
type | The type to check for.
property | The property of the type to check for
Returns
True if type is Location and property is "SurfaceLine"
void Deltares.Geotechnics.IO.SurfaceLineXmlHandler.Handle | ( | object | target,
 |  | string | property,
 |  | object | value,
 |  | object[] | objects
 | ) |  |

Not implemented for this class.

Parameters
target
value
objects
void Deltares.Geotechnics.IO.SurfaceLineXmlHandler.HandleObject | ( | object | target,
 |  | object | value
 | ) |  |

If the value is an old BaseSurfaceLine and the target is a Location, the value will be converted to the new SurfaceLine2 and the Location.Surfaceline property is set for the target.

Parameters
target | The target to set the handle the value for
value | The value to handle
Generated on Tue Dec 15 2015 18:14:20 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • IO
  • SurfaceLineXmlHandler
Deltares.Geotechnics.IO.SurfaceLineXmlHandler Member List

This is the complete list of members for Deltares.Geotechnics.IO.SurfaceLineXmlHandler, including all inherited members.

CanHandle(Type type) | Deltares.Geotechnics.IO.SurfaceLineXmlHandler
CanHandle(Type type, string property) | Deltares.Geotechnics.IO.SurfaceLineXmlHandler
GetFormerPropertyType(Type type, string property) (defined in Deltares.Geotechnics.IO.SurfaceLineXmlHandler) | Deltares.Geotechnics.IO.SurfaceLineXmlHandler
Handle(object target, string property, object value, object[] objects) | Deltares.Geotechnics.IO.SurfaceLineXmlHandler
HandleObject(object target, object value) | Deltares.Geotechnics.IO.SurfaceLineXmlHandler
SetVersion(string version) (defined in Deltares.Geotechnics.IO.SurfaceLineXmlHandler) | Deltares.Geotechnics.IO.SurfaceLineXmlHandler
Upgrade(object[] targets) (defined in Deltares.Geotechnics.IO.SurfaceLineXmlHandler) | Deltares.Geotechnics.IO.SurfaceLineXmlHandler
Generated on Tue Dec 15 2015 18:14:20 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.IO.XmlAquiferHandler Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • IO
  • XmlAquiferHandler
Public Member Functions | List of all members
Deltares.Geotechnics.IO.XmlAquiferHandler Class Reference
Inheritance diagram for Deltares.Geotechnics.IO.XmlAquiferHandler:

Public Member Functions

void | SetVersion (string version)
bool | CanHandle (Type type)
bool | CanHandle (Type type, string property)
Type | GetFormerPropertyType (Type type, string property)
void | Handle (object target, string property, object value, object[] objects)
void | HandleObject (object target, object value)
void | Upgrade (object[] targets)
Generated on Tue Dec 15 2015 18:14:20 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • IO
  • XmlAquiferHandler
Deltares.Geotechnics.IO.XmlAquiferHandler Member List

This is the complete list of members for Deltares.Geotechnics.IO.XmlAquiferHandler, including all inherited members.

CanHandle(Type type) (defined in Deltares.Geotechnics.IO.XmlAquiferHandler) | Deltares.Geotechnics.IO.XmlAquiferHandler
CanHandle(Type type, string property) (defined in Deltares.Geotechnics.IO.XmlAquiferHandler) | Deltares.Geotechnics.IO.XmlAquiferHandler
GetFormerPropertyType(Type type, string property) (defined in Deltares.Geotechnics.IO.XmlAquiferHandler) | Deltares.Geotechnics.IO.XmlAquiferHandler
Handle(object target, string property, object value, object[] objects) (defined in Deltares.Geotechnics.IO.XmlAquiferHandler) | Deltares.Geotechnics.IO.XmlAquiferHandler
HandleObject(object target, object value) (defined in Deltares.Geotechnics.IO.XmlAquiferHandler) | Deltares.Geotechnics.IO.XmlAquiferHandler
SetVersion(string version) (defined in Deltares.Geotechnics.IO.XmlAquiferHandler) | Deltares.Geotechnics.IO.XmlAquiferHandler
Upgrade(object[] targets) (defined in Deltares.Geotechnics.IO.XmlAquiferHandler) | Deltares.Geotechnics.IO.XmlAquiferHandler
Generated on Tue Dec 15 2015 18:14:20 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.IO.XmlSoilsToSoilListHandler Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • IO
  • XmlSoilsToSoilListHandler
Public Member Functions | Properties | List of all members
Deltares.Geotechnics.IO.XmlSoilsToSoilListHandler Class Reference
Inheritance diagram for Deltares.Geotechnics.IO.XmlSoilsToSoilListHandler:

Public Member Functions

void | SetVersion (string version)
bool | CanHandle (Type type)
bool | CanHandle (Type type, string property)
void | Handle (object target, string property, object value, object[] objects)
void | HandleObject (object target, object value)
Type | GetFormerPropertyType (Type type, string property)
void | Upgrade (object[] targets)

Properties

SoilList SoilList [get, set]
Generated on Tue Dec 15 2015 18:14:21 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • IO
  • XmlSoilsToSoilListHandler
Deltares.Geotechnics.IO.XmlSoilsToSoilListHandler Member List

This is the complete list of members for Deltares.Geotechnics.IO.XmlSoilsToSoilListHandler, including all inherited members.

CanHandle(Type type) (defined in Deltares.Geotechnics.IO.XmlSoilsToSoilListHandler) | Deltares.Geotechnics.IO.XmlSoilsToSoilListHandler
CanHandle(Type type, string property) (defined in Deltares.Geotechnics.IO.XmlSoilsToSoilListHandler) | Deltares.Geotechnics.IO.XmlSoilsToSoilListHandler
GetFormerPropertyType(Type type, string property) (defined in Deltares.Geotechnics.IO.XmlSoilsToSoilListHandler) | Deltares.Geotechnics.IO.XmlSoilsToSoilListHandler
Handle(object target, string property, object value, object[] objects) (defined in Deltares.Geotechnics.IO.XmlSoilsToSoilListHandler) | Deltares.Geotechnics.IO.XmlSoilsToSoilListHandler
HandleObject(object target, object value) (defined in Deltares.Geotechnics.IO.XmlSoilsToSoilListHandler) | Deltares.Geotechnics.IO.XmlSoilsToSoilListHandler
SetVersion(string version) (defined in Deltares.Geotechnics.IO.XmlSoilsToSoilListHandler) | Deltares.Geotechnics.IO.XmlSoilsToSoilListHandler
SoilList (defined in Deltares.Geotechnics.IO.XmlSoilsToSoilListHandler) | Deltares.Geotechnics.IO.XmlSoilsToSoilListHandler
Upgrade(object[] targets) (defined in Deltares.Geotechnics.IO.XmlSoilsToSoilListHandler) | Deltares.Geotechnics.IO.XmlSoilsToSoilListHandler
Generated on Tue Dec 15 2015 18:14:21 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.WaternetCreator.DupuitPLLinesCreator Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • WaternetCreator
  • DupuitPLLinesCreator
Public Member Functions | List of all members
Deltares.Geotechnics.WaternetCreator.DupuitPLLinesCreator Class Reference

Public Member Functions

void CreatePL1 ()
Generated on Tue Dec 15 2015 18:14:24 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • WaternetCreator
  • DupuitPLLinesCreator
Deltares.Geotechnics.WaternetCreator.DupuitPLLinesCreator Member List

This is the complete list of members for Deltares.Geotechnics.WaternetCreator.DupuitPLLinesCreator, including all inherited members.

CreatePL1() (defined in Deltares.Geotechnics.WaternetCreator.DupuitPLLinesCreator) Deltares.Geotechnics.WaternetCreator.DupuitPLLinesCreator
Generated on Tue Dec 15 2015 18:14:24 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.WaternetCreator.ExpertKnowledgePLLinesCreator Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • WaternetCreator
  • ExpertKnowledgePLLinesCreator
Public Member Functions | List of all members
Deltares.Geotechnics.WaternetCreator.ExpertKnowledgePLLinesCreator Class Reference
Inheritance diagram for Deltares.Geotechnics.WaternetCreator.ExpertKnowledgePLLinesCreator:
Deltares.Geotechnics.WaternetCreator.PlLinesCreator

Public Member Functions

void | CreatePL1 ()
- Public Member Functions inherited from Deltares.Geotechnics.WaternetCreator.PlLinesCreator
PlLinesCreator ()
Constructor More...
Dictionary< PLLineType, GeometryPointString > | CreateAllPLLines (Location location)
Create all PL-lines More...
GeometryPointString | CreatePLLineByExpertKnowledge (PLLineType plLineType, Location location)
Create 4 PL-lines for the waternet creator of Ringtoets WTI 2017. More...
GeometryPointString | CreatePLLine2ByExpertKnowledge (Location location)
Create PL2 (is pl line for penetration) More...
GeometryPointString | CreatePLLine3ByExpertKnowledge (Location location)
Create PL-line 3 (= head in the Pleistocene) More...
GeometryPointString | CreatePLLine4ByExpertKnowledge (Location location)
Create PL-line 4 (= head in the in-between aquifer) More...
GeometryPointString | CreatePLLine3ClayDikeOnSand (Location location)
Create PL-line 3 (= head in Pleistocene) for "Clay dike on sand" (used only for Ringtoets WTI 2017 method) More...
Dictionary< double, double > | GetUpliftOutputValuesPl4 ()
get uplift factors for x, regarding pl4 More...
Dictionary< double, double > | GetUpliftOutputValuesPl3 ()
get uplift factors for x, regarding pl3 More...
bool | IsNonWaterRetainingObjectPoint (GeometryPoint point, SurfaceLine2 surfaceline)
GeometryPoint | DetermineIntersectionBetweenWaterLevelAndDike (double waterLevelRiver, SurfaceLine2 surfaceline)
Intersection between two line segments: More...
GeometryPoint | DetermineIntersectionBetweenTaludRiverSideAndWaterLevel (double level, SurfaceLine2 surfaceline)
Determines the intersection between talud river side and water level. Search starts from DikeTopAtRiver to SurfaceLevelOutside More...
GeometryPoint | DetermineIntersectionBetweenPl2Or1AndFinalSlope100OfPl3 (GeometryPoint firstPointOfObliqueLine, double slopeOfObliqueLine, Location location)
GeometryPointString | CreatePLLine1ByExpertKnowledge (Location location)
Create PL1 (= phreatic level) For methods Expert Knowledge, refer to the user manual of DAM. For method Ringtoets WTI 2017 , refer to the memo of Alexander van Duinen in: https://repos.deltares.nl/repos/delftgeosystems/delftgeosystems/trunk/documents/Geotechnics More...
double | EnsureWaterLevelIsAboveRiverBottom (double riverLevel, SurfaceLine2 surfaceline)
Make sure that river level is above the bottom of the river More...
GeometryPoint | GetDikeToeInward (SurfaceLine2 surfaceline)
If shoulder is present then the toe of the shoulder is returned Else the toe of the dike (ShoulderSaseInside) is returned More...
double | DetermineZValueAtX (double x, double x1, double x2, double z1, double z2)

Additional Inherited Members

- Static Public Member Functions inherited from Deltares.Geotechnics.WaternetCreator.PlLinesCreator
static bool | Equal (double aValue1, double aValue2)
- Properties inherited from Deltares.Geotechnics.WaternetCreator.PlLinesCreator
bool | IsUseOvenDryUnitWeight [get, set]
SoilGeometryType | SoilGeometryType [get, set]
string | SoilGeometry2DName [get, set]
Soil | DikeEmbankmentMaterial [get, set]
double | HeadInPLLine2 [get, set]
double | GaugeMissVal [get, set]
double | Pl3HeadAdjusted [get]
double | Pl3LocationXMinUplift [get]
double | Pl4HeadAdjusted [get]
double | Pl4LocationXMinUplift [get]
bool | Inwards [get, set]
Generated on Tue Dec 15 2015 18:14:24 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • WaternetCreator
  • ExpertKnowledgePLLinesCreator
Deltares.Geotechnics.WaternetCreator.ExpertKnowledgePLLinesCreator Member List

This is the complete list of members for Deltares.Geotechnics.WaternetCreator.ExpertKnowledgePLLinesCreator, including all inherited members.

CreateAllPLLines(Location location) | Deltares.Geotechnics.WaternetCreator.PlLinesCreator |
CreatePL1() (defined in Deltares.Geotechnics.WaternetCreator.ExpertKnowledgePLLinesCreator) | Deltares.Geotechnics.WaternetCreator.ExpertKnowledgePLLinesCreator |
CreatePLLine1ByExpertKnowledge(Location location) | Deltares.Geotechnics.WaternetCreator.PlLinesCreator |
CreatePLLine2ByExpertKnowledge(Location location) | Deltares.Geotechnics.WaternetCreator.PlLinesCreator |
CreatePLLine3ByExpertKnowledge(Location location) | Deltares.Geotechnics.WaternetCreator.PlLinesCreator |
CreatePLLine3ClayDikeOnSand(Location location) | Deltares.Geotechnics.WaternetCreator.PlLinesCreator |
CreatePLLine4ByExpertKnowledge(Location location) | Deltares.Geotechnics.WaternetCreator.PlLinesCreator |
CreatePLLineByExpertKnowledge(PLLineType plLineType, Location location) | Deltares.Geotechnics.WaternetCreator.PlLinesCreator |
DetermineIntersectionBetweenPl2Or1AndFinalSlope100OfPl3(GeometryPoint firstPointOfObliqueLine, double slopeOfObliqueLine, Location location) (defined in Deltares.Geotechnics.WaternetCreator.PlLinesCreator) | Deltares.Geotechnics.WaternetCreator.PlLinesCreator |
DetermineIntersectionBetweenTaludRiverSideAndWaterLevel(double level, SurfaceLine2 surfaceline) | Deltares.Geotechnics.WaternetCreator.PlLinesCreator |
DetermineIntersectionBetweenWaterLevelAndDike(double waterLevelRiver, SurfaceLine2 surfaceline) | Deltares.Geotechnics.WaternetCreator.PlLinesCreator |
DetermineZValueAtX(double x, double x1, double x2, double z1, double z2) (defined in Deltares.Geotechnics.WaternetCreator.PlLinesCreator) | Deltares.Geotechnics.WaternetCreator.PlLinesCreator |
DikeEmbankmentMaterial (defined in Deltares.Geotechnics.WaternetCreator.PlLinesCreator) | Deltares.Geotechnics.WaternetCreator.PlLinesCreator |
EnsureWaterLevelIsAboveRiverBottom(double riverLevel, SurfaceLine2 surfaceline) | Deltares.Geotechnics.WaternetCreator.PlLinesCreator |
Equal(double aValue1, double aValue2) (defined in Deltares.Geotechnics.WaternetCreator.PlLinesCreator) | Deltares.Geotechnics.WaternetCreator.PlLinesCreator | static
GaugeMissVal (defined in Deltares.Geotechnics.WaternetCreator.PlLinesCreator) | Deltares.Geotechnics.WaternetCreator.PlLinesCreator |
GetDikeToeInward(SurfaceLine2 surfaceline) | Deltares.Geotechnics.WaternetCreator.PlLinesCreator |
GetUpliftOutputValuesPl3() | Deltares.Geotechnics.WaternetCreator.PlLinesCreator |
GetUpliftOutputValuesPl4() | Deltares.Geotechnics.WaternetCreator.PlLinesCreator |
HeadInPLLine2 (defined in Deltares.Geotechnics.WaternetCreator.PlLinesCreator) | Deltares.Geotechnics.WaternetCreator.PlLinesCreator |
Inwards (defined in Deltares.Geotechnics.WaternetCreator.PlLinesCreator) | Deltares.Geotechnics.WaternetCreator.PlLinesCreator |
IsNonWaterRetainingObjectPoint(GeometryPoint point, SurfaceLine2 surfaceline) (defined in Deltares.Geotechnics.WaternetCreator.PlLinesCreator) | Deltares.Geotechnics.WaternetCreator.PlLinesCreator |
IsUseOvenDryUnitWeight (defined in Deltares.Geotechnics.WaternetCreator.PlLinesCreator) | Deltares.Geotechnics.WaternetCreator.PlLinesCreator |
Pl3HeadAdjusted (defined in Deltares.Geotechnics.WaternetCreator.PlLinesCreator) | Deltares.Geotechnics.WaternetCreator.PlLinesCreator |
Pl3LocationXMinUplift (defined in Deltares.Geotechnics.WaternetCreator.PlLinesCreator) | Deltares.Geotechnics.WaternetCreator.PlLinesCreator |
Pl4HeadAdjusted (defined in Deltares.Geotechnics.WaternetCreator.PlLinesCreator) | Deltares.Geotechnics.WaternetCreator.PlLinesCreator |
Pl4LocationXMinUplift (defined in Deltares.Geotechnics.WaternetCreator.PlLinesCreator) | Deltares.Geotechnics.WaternetCreator.PlLinesCreator |
PlLinesCreator() | Deltares.Geotechnics.WaternetCreator.PlLinesCreator |
SoilGeometry2DName (defined in Deltares.Geotechnics.WaternetCreator.PlLinesCreator) | Deltares.Geotechnics.WaternetCreator.PlLinesCreator |
SoilGeometryType (defined in Deltares.Geotechnics.WaternetCreator.PlLinesCreator) | Deltares.Geotechnics.WaternetCreator.PlLinesCreator |
Generated on Tue Dec 15 2015 18:14:24 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.WaternetCreator.LineHelper Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • WaternetCreator
  • LineHelper
Static Public Member Functions | List of all members
Deltares.Geotechnics.WaternetCreator.LineHelper Class Reference

Static Public Member Functions

static GeometryPoint | GetIntersectPoint (Line line1, Line line2, PointType pointType)
Calculate intersection between two lines More...
static GeometryPoint | GetIntersectPoint (GeometryPoint p1, GeometryPoint p2, GeometryPoint p3, GeometryPoint p4)
static double | GetSlope (GeometryPoint point1, GeometryPoint point2)
static GeometryPoint | IntersectionPoint (this Line thisLine, Line otherLine)
static GeometryPoint | IntersectionPoint (GeometryPoint p1, GeometryPoint p2, GeometryPoint p3, GeometryPoint p4)
Calculates the intersection point between two line (segments) More...
static PLLinePointPositionXzType | PositionXzOfPointRelatedToPLLine (GeometryPoint point, IList< GeometryPoint > points)
Determines whether the given point is above, beneath or on the surfaceline. More...
static double | ZFromX (double X, IList< GeometryPoint > points)
static bool | IsXAscending (IList< GeometryPoint > points)
Check if all the points are in ascending X order More...
static void | DeleteCoinsidingPoints (IList< GeometryPoint > points, double tolerance)
Deletes the coinsiding points. More...
static GeometryPoint | EnsurePointAtX (double X, IList< GeometryPoint > points, double tolerance)
Gets point at X if present within tolerance; creates one there if not present. More...
static GeometryPoint | GetPointAtX (double X, IList< GeometryPoint > points, double tolerance)
Gets point at X if present within tolerance or null if not present. More...
static IEnumerable< GeometryPoint > | GetPointSegmentBetween (double startX, double endX, IList< GeometryPoint > points)
Gets the points in the segment between starting x and ending x More...
static void | RemoveAllPointsOfGeometryPointStringAfterIndex (GeometryPointString pointString, int startIndex)
Removes the index of all points of GeometryPointString after the start index. More...

Member Function Documentation

static void Deltares.Geotechnics.WaternetCreator.LineHelper.DeleteCoinsidingPoints | ( | IList< GeometryPoint > | points,
 |  | double | tolerance
 | ) |  |
static

Deletes the coinsiding points.

Parameters
points
tolerance The tolerance.

Referenced by Deltares.Geotechnics.WaternetCreator.PlLinesCreator.CreatePLLineByExpertKnowledge().

static GeometryPoint Deltares.Geotechnics.WaternetCreator.LineHelper.EnsurePointAtX | ( | double | X,
 |  | IList< GeometryPoint > | points,
 |  | double | tolerance
 | ) |  |
static

Gets point at X if present within tolerance; creates one there if not present.

Returns
static GeometryPoint Deltares.Geotechnics.WaternetCreator.LineHelper.GetIntersectPoint | ( | Line | line1,
 |  | Line | line2,
 |  | PointType | pointType
 | ) |  |
static

Calculate intersection between two lines

Parameters
line1
line2
pointType
Returns
static GeometryPoint Deltares.Geotechnics.WaternetCreator.LineHelper.GetPointAtX | ( | double | X,
 |  | IList< GeometryPoint > | points,
 |  | double | tolerance
 | ) |  |
static

Gets point at X if present within tolerance or null if not present.

Returns
static IEnumerable<GeometryPoint> Deltares.Geotechnics.WaternetCreator.LineHelper.GetPointSegmentBetween | ( | double | startX,
 |  | double | endX,
 |  | IList< GeometryPoint > | points
 | ) |  |
static

Gets the points in the segment between starting x and ending x

Parameters
startX
endX
points
Returns
static GeometryPoint Deltares.Geotechnics.WaternetCreator.LineHelper.IntersectionPoint | ( | GeometryPoint | p1,
 |  | GeometryPoint | p2,
 |  | GeometryPoint | p3,
 |  | GeometryPoint | p4
 | ) |  |
static

Calculates the intersection point between two line (segments)

Parameters
p1 | Starting point line segment 1
p2 | End point line segment 1
p3 | Starting point line segment 2
p4 | End point line segment 2
Returns
The intersection point

The point can contain infinite values if the lines are parallel

static bool Deltares.Geotechnics.WaternetCreator.LineHelper.IsXAscending ( IList< GeometryPoint > points )
static

Check if all the points are in ascending X order

Parameters
points
Returns

Referenced by Deltares.Geotechnics.WaternetCreator.PlLinesCreator.CreateAllPLLines().

static PLLinePointPositionXzType Deltares.Geotechnics.WaternetCreator.LineHelper.PositionXzOfPointRelatedToPLLine | ( | GeometryPoint | point,
 |  | IList< GeometryPoint > | points
 | ) |  |
static

Determines whether the given point is above, beneath or on the surfaceline.

Parameters
point
Returns
static void Deltares.Geotechnics.WaternetCreator.LineHelper.RemoveAllPointsOfGeometryPointStringAfterIndex | ( | GeometryPointString | pointString,
 |  | int | startIndex
 | ) |  |
static

Removes the index of all points of GeometryPointString after the start index.

Parameters
pointString
startIndex
Generated on Tue Dec 15 2015 18:14:24 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • WaternetCreator
  • LineHelper
Deltares.Geotechnics.WaternetCreator.LineHelper Member List

This is the complete list of members for Deltares.Geotechnics.WaternetCreator.LineHelper, including all inherited members.

DeleteCoinsidingPoints(IList< GeometryPoint > points, double tolerance) | Deltares.Geotechnics.WaternetCreator.LineHelper | static
EnsurePointAtX(double X, IList< GeometryPoint > points, double tolerance) | Deltares.Geotechnics.WaternetCreator.LineHelper | static
GetIntersectPoint(Line line1, Line line2, PointType pointType) | Deltares.Geotechnics.WaternetCreator.LineHelper | static
GetIntersectPoint(GeometryPoint p1, GeometryPoint p2, GeometryPoint p3, GeometryPoint p4) (defined in Deltares.Geotechnics.WaternetCreator.LineHelper) | Deltares.Geotechnics.WaternetCreator.LineHelper | static
GetPointAtX(double X, IList< GeometryPoint > points, double tolerance) | Deltares.Geotechnics.WaternetCreator.LineHelper | static
GetPointSegmentBetween(double startX, double endX, IList< GeometryPoint > points) | Deltares.Geotechnics.WaternetCreator.LineHelper | static
GetSlope(GeometryPoint point1, GeometryPoint point2) (defined in Deltares.Geotechnics.WaternetCreator.LineHelper) | Deltares.Geotechnics.WaternetCreator.LineHelper | static
IntersectionPoint(this Line thisLine, Line otherLine) (defined in Deltares.Geotechnics.WaternetCreator.LineHelper) | Deltares.Geotechnics.WaternetCreator.LineHelper | static
IntersectionPoint(GeometryPoint p1, GeometryPoint p2, GeometryPoint p3, GeometryPoint p4) | Deltares.Geotechnics.WaternetCreator.LineHelper | static
IsXAscending(IList< GeometryPoint > points) | Deltares.Geotechnics.WaternetCreator.LineHelper | static
PositionXzOfPointRelatedToPLLine(GeometryPoint point, IList< GeometryPoint > points) | Deltares.Geotechnics.WaternetCreator.LineHelper | static
RemoveAllPointsOfGeometryPointStringAfterIndex(GeometryPointString pointString, int startIndex) | Deltares.Geotechnics.WaternetCreator.LineHelper | static
ZFromX(double X, IList< GeometryPoint > points) (defined in Deltares.Geotechnics.WaternetCreator.LineHelper) | Deltares.Geotechnics.WaternetCreator.LineHelper | static
Generated on Tue Dec 15 2015 18:14:24 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.WaternetCreator.Location Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • WaternetCreator
  • Location
Public Member Functions | Properties | List of all members
Deltares.Geotechnics.WaternetCreator.Location Class Reference
Inheritance diagram for Deltares.Geotechnics.WaternetCreator.Location:

Public Member Functions

virtual bool | IsEnabled (string property)
virtual bool | IsVisible (string property)
ValidationResult[] | Validate ()
ValidationResult[] | ValidateAquifers ()
Validates whether aquifer definitions are all right More...
ValidationResult[] | ValidateWaterLevelRiver ()
Validatates case when Toetspeil was not calculated yet and therefor there is no value for WaterLevelRiver More...
ValidationResult[] | ValidateSoilProfile ()
Validates SoilProfile1D if it has the expected number of aquifer layers. More...
void | Dispose ()

Properties

virtual SoilProfile2D | SoilProfile2D [get, set]
virtual SoilProfile1D | SoilProfile1D [get, set]
virtual SurfaceLine2 | Surfaceline [get, set]
PhreaticAdaptionType | NWOPhreaticAdaption [get, set]
virtual PhreaticLine | LocalXzpl1Line [get, set]
WaternetCreationMode | WaternetCreationMode [get, set]
Gets or sets the general setting - autogenerate or self filling in. Sets the Auto and the UserDefinedPl3AndPl4 parameters of Location. More...
DikeSoilScenario | DikeSoilScenario [get, set]
PlLineCreationMethod | PlLineCreationMethod [get, set]
double | WaterLevelRiver [get, set]
double | WaterLevelRiverAverage [get, set]
double | WaterLevelRiverLow [get, set]
double | WaterLevelPolder [get, set]
bool | DrainageConstructionPresent [get, set]
double | XCoordMiddleDrainageConstruction [get, set]
double | ZCoordMiddleDrainageConstruction [get, set]
double | MinimumLevelPhreaticLineAtDikeTopRiver [get, set]
double | MinimumLevelPhreaticLineAtDikeTopPolder [get, set]
bool | UseDefaultOffsets [get, set]
double | PlLineOffsetBelowDikeTopAtRiver [get, set]
double | PlLineOffsetBelowPointBRingtoetsWti2017 [get, set]
The offset of PL-line 1 (= phreatic line) below point B, according to Ringtoets WTI 2017 mehtod: More...
double | PlLineOffsetBelowDikeTopAtPolder [get, set]
double | PlLineOffsetBelowShoulderBaseInside [get, set]
double | PlLineOffsetBelowDikeToeAtPolder [get, set]
double | HeadInPLLine3 [get, set]
double | HeadInPLLine4 [get, set]
bool | AdjustPl3And4ForUplift [get, set]
double | LeakageLengthOutwardsPl3 [get, set]
double | LeakageLengthInwardsPl3 [get, set]
double | LeakageLengthOutwardsPl4 [get, set]
double | LeakageLengthInwardsPl4 [get, set]
double | SlopeDampingPiezometricHeightPolderSide [get, set]
double | HeadInPLLine2Outwards [get, set]
double | CorrectedHeadInPLLine2Outwards [get]
double | HeadInPLLine2Inwards [get, set]
double | CorrectedHeadInPLLine2Inwards [get]
double | PenetrationLength [get, set]
PiezometricHeads | PiezometricHeads [get, set]
virtual bool | Inwards [get, set]
double | X [get, set]
double | Y [get, set]

Member Function Documentation

ValidationResult [] Deltares.Geotechnics.WaternetCreator.Location.ValidateAquifers ( )

Validates whether aquifer definitions are all right

Don't decorate with Validate attribute, since it is called by the Validate method

Returns
Validation results

References Deltares.Geotechnics.SoilProfile1D.Layers.

ValidationResult [] Deltares.Geotechnics.WaternetCreator.Location.ValidateSoilProfile ( )

Validates SoilProfile1D if it has the expected number of aquifer layers.

Returns
The collection with all detected validation problems.

This method has sideseffects: setting SoilProfile1D.

References Deltares.Geotechnics.SoilProfile1D.BottomAquiferLayer, and Deltares.Geotechnics.SoilProfile1D.Layers.

ValidationResult [] Deltares.Geotechnics.WaternetCreator.Location.ValidateWaterLevelRiver ( )

Validatates case when Toetspeil was not calculated yet and therefor there is no value for WaterLevelRiver

Returns
The collection with all detected validation problems

Property Documentation

double Deltares.Geotechnics.WaternetCreator.Location.PlLineOffsetBelowPointBRingtoetsWti2017
getset

The offset of PL-line 1 (= phreatic line) below point B, according to Ringtoets WTI 2017 mehtod:

  • for clay dikes: point B is situated 1 meter at the right side of point A (intersection dike with phreatic line at river side)
  • for sand dike on clay: point B is situated 1 cm at the right side of point A
  • for sand dike on sand: point B is dike top at river side
WaternetCreationMode Deltares.Geotechnics.WaternetCreator.Location.WaternetCreationMode
getset

Gets or sets the general setting - autogenerate or self filling in. Sets the Auto and the UserDefinedPl3AndPl4 parameters of Location.

Generated on Tue Dec 15 2015 18:14:25 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • WaternetCreator
  • Location
Deltares.Geotechnics.WaternetCreator.Location Member List

This is the complete list of members for Deltares.Geotechnics.WaternetCreator.Location, including all inherited members.

AdjustPl3And4ForUplift (defined in Deltares.Geotechnics.WaternetCreator.Location) | Deltares.Geotechnics.WaternetCreator.Location |
CorrectedHeadInPLLine2Inwards (defined in Deltares.Geotechnics.WaternetCreator.Location) | Deltares.Geotechnics.WaternetCreator.Location |
CorrectedHeadInPLLine2Outwards (defined in Deltares.Geotechnics.WaternetCreator.Location) | Deltares.Geotechnics.WaternetCreator.Location |
DikeSoilScenario (defined in Deltares.Geotechnics.WaternetCreator.Location) | Deltares.Geotechnics.WaternetCreator.Location |
Dispose() (defined in Deltares.Geotechnics.WaternetCreator.Location) | Deltares.Geotechnics.WaternetCreator.Location |
DrainageConstructionPresent (defined in Deltares.Geotechnics.WaternetCreator.Location) | Deltares.Geotechnics.WaternetCreator.Location |
HeadInPLLine2Inwards (defined in Deltares.Geotechnics.WaternetCreator.Location) | Deltares.Geotechnics.WaternetCreator.Location |
HeadInPLLine2Outwards (defined in Deltares.Geotechnics.WaternetCreator.Location) | Deltares.Geotechnics.WaternetCreator.Location |
HeadInPLLine3 (defined in Deltares.Geotechnics.WaternetCreator.Location) | Deltares.Geotechnics.WaternetCreator.Location |
HeadInPLLine4 (defined in Deltares.Geotechnics.WaternetCreator.Location) | Deltares.Geotechnics.WaternetCreator.Location |
Inwards (defined in Deltares.Geotechnics.WaternetCreator.Location) | Deltares.Geotechnics.WaternetCreator.Location |
IsEnabled(string property) (defined in Deltares.Geotechnics.WaternetCreator.Location) | Deltares.Geotechnics.WaternetCreator.Location | virtual
IsVisible(string property) (defined in Deltares.Geotechnics.WaternetCreator.Location) | Deltares.Geotechnics.WaternetCreator.Location | virtual
LeakageLengthInwardsPl3 (defined in Deltares.Geotechnics.WaternetCreator.Location) | Deltares.Geotechnics.WaternetCreator.Location |
LeakageLengthInwardsPl4 (defined in Deltares.Geotechnics.WaternetCreator.Location) | Deltares.Geotechnics.WaternetCreator.Location |
LeakageLengthOutwardsPl3 (defined in Deltares.Geotechnics.WaternetCreator.Location) | Deltares.Geotechnics.WaternetCreator.Location |
LeakageLengthOutwardsPl4 (defined in Deltares.Geotechnics.WaternetCreator.Location) | Deltares.Geotechnics.WaternetCreator.Location |
LocalXzpl1Line (defined in Deltares.Geotechnics.WaternetCreator.Location) | Deltares.Geotechnics.WaternetCreator.Location |
Location() (defined in Deltares.Geotechnics.WaternetCreator.Location) | Deltares.Geotechnics.WaternetCreator.Location |
MinimumLevelPhreaticLineAtDikeTopPolder (defined in Deltares.Geotechnics.WaternetCreator.Location) | Deltares.Geotechnics.WaternetCreator.Location |
MinimumLevelPhreaticLineAtDikeTopRiver (defined in Deltares.Geotechnics.WaternetCreator.Location) | Deltares.Geotechnics.WaternetCreator.Location |
NWOPhreaticAdaption (defined in Deltares.Geotechnics.WaternetCreator.Location) | Deltares.Geotechnics.WaternetCreator.Location |
PenetrationLength (defined in Deltares.Geotechnics.WaternetCreator.Location) | Deltares.Geotechnics.WaternetCreator.Location |
PiezometricHeads (defined in Deltares.Geotechnics.WaternetCreator.Location) | Deltares.Geotechnics.WaternetCreator.Location |
PlLineCreationMethod (defined in Deltares.Geotechnics.WaternetCreator.Location) | Deltares.Geotechnics.WaternetCreator.Location |
PlLineOffsetBelowDikeToeAtPolder (defined in Deltares.Geotechnics.WaternetCreator.Location) | Deltares.Geotechnics.WaternetCreator.Location |
PlLineOffsetBelowDikeTopAtPolder (defined in Deltares.Geotechnics.WaternetCreator.Location) | Deltares.Geotechnics.WaternetCreator.Location |
PlLineOffsetBelowDikeTopAtRiver (defined in Deltares.Geotechnics.WaternetCreator.Location) | Deltares.Geotechnics.WaternetCreator.Location |
PlLineOffsetBelowPointBRingtoetsWti2017 | Deltares.Geotechnics.WaternetCreator.Location |
PlLineOffsetBelowShoulderBaseInside (defined in Deltares.Geotechnics.WaternetCreator.Location) | Deltares.Geotechnics.WaternetCreator.Location |
SlopeDampingPiezometricHeightPolderSide (defined in Deltares.Geotechnics.WaternetCreator.Location) | Deltares.Geotechnics.WaternetCreator.Location |
SoilProfile1D (defined in Deltares.Geotechnics.WaternetCreator.Location) | Deltares.Geotechnics.WaternetCreator.Location |
SoilProfile2D (defined in Deltares.Geotechnics.WaternetCreator.Location) | Deltares.Geotechnics.WaternetCreator.Location |
Surfaceline (defined in Deltares.Geotechnics.WaternetCreator.Location) | Deltares.Geotechnics.WaternetCreator.Location |
UseDefaultOffsets (defined in Deltares.Geotechnics.WaternetCreator.Location) | Deltares.Geotechnics.WaternetCreator.Location |
Validate() (defined in Deltares.Geotechnics.WaternetCreator.Location) | Deltares.Geotechnics.WaternetCreator.Location |
ValidateAquifers() | Deltares.Geotechnics.WaternetCreator.Location |
ValidateSoilProfile() | Deltares.Geotechnics.WaternetCreator.Location |
ValidateWaterLevelRiver() | Deltares.Geotechnics.WaternetCreator.Location |
WaterLevelPolder (defined in Deltares.Geotechnics.WaternetCreator.Location) | Deltares.Geotechnics.WaternetCreator.Location |
WaterLevelRiver (defined in Deltares.Geotechnics.WaternetCreator.Location) | Deltares.Geotechnics.WaternetCreator.Location |
WaterLevelRiverAverage (defined in Deltares.Geotechnics.WaternetCreator.Location) | Deltares.Geotechnics.WaternetCreator.Location |
WaterLevelRiverLow (defined in Deltares.Geotechnics.WaternetCreator.Location) | Deltares.Geotechnics.WaternetCreator.Location |
WaternetCreationMode | Deltares.Geotechnics.WaternetCreator.Location |
X (defined in Deltares.Geotechnics.WaternetCreator.Location) | Deltares.Geotechnics.WaternetCreator.Location |
XCoordMiddleDrainageConstruction (defined in Deltares.Geotechnics.WaternetCreator.Location) | Deltares.Geotechnics.WaternetCreator.Location |
Y (defined in Deltares.Geotechnics.WaternetCreator.Location) | Deltares.Geotechnics.WaternetCreator.Location |
ZCoordMiddleDrainageConstruction (defined in Deltares.Geotechnics.WaternetCreator.Location) | Deltares.Geotechnics.WaternetCreator.Location |
Generated on Tue Dec 15 2015 18:14:25 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.WaternetCreator.PlLinesCreator Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • WaternetCreator
  • PlLinesCreator
Public Member Functions | Static Public Member Functions | Properties | List of all members
Deltares.Geotechnics.WaternetCreator.PlLinesCreator Class Reference
Inheritance diagram for Deltares.Geotechnics.WaternetCreator.PlLinesCreator:
Deltares.Geotechnics.WaternetCreator.ExpertKnowledgePLLinesCreator

Public Member Functions

PlLinesCreator ()
Constructor More...
Dictionary< PLLineType, GeometryPointString > | CreateAllPLLines (Location location)
Create all PL-lines More...
GeometryPointString | CreatePLLineByExpertKnowledge (PLLineType plLineType, Location location)
Create 4 PL-lines for the waternet creator of Ringtoets WTI 2017. More...
GeometryPointString | CreatePLLine2ByExpertKnowledge (Location location)
Create PL2 (is pl line for penetration) More...
GeometryPointString | CreatePLLine3ByExpertKnowledge (Location location)
Create PL-line 3 (= head in the Pleistocene) More...
GeometryPointString | CreatePLLine4ByExpertKnowledge (Location location)
Create PL-line 4 (= head in the in-between aquifer) More...
GeometryPointString | CreatePLLine3ClayDikeOnSand (Location location)
Create PL-line 3 (= head in Pleistocene) for "Clay dike on sand" (used only for Ringtoets WTI 2017 method) More...
Dictionary< double, double > | GetUpliftOutputValuesPl4 ()
get uplift factors for x, regarding pl4 More...
Dictionary< double, double > | GetUpliftOutputValuesPl3 ()
get uplift factors for x, regarding pl3 More...
bool | IsNonWaterRetainingObjectPoint (GeometryPoint point, SurfaceLine2 surfaceline)
GeometryPoint | DetermineIntersectionBetweenWaterLevelAndDike (double waterLevelRiver, SurfaceLine2 surfaceline)
Intersection between two line segments: More...
GeometryPoint | DetermineIntersectionBetweenTaludRiverSideAndWaterLevel (double level, SurfaceLine2 surfaceline)
Determines the intersection between talud river side and water level. Search starts from DikeTopAtRiver to SurfaceLevelOutside More...
GeometryPoint | DetermineIntersectionBetweenPl2Or1AndFinalSlope100OfPl3 (GeometryPoint firstPointOfObliqueLine, double slopeOfObliqueLine, Location location)
GeometryPointString | CreatePLLine1ByExpertKnowledge (Location location)
Create PL1 (= phreatic level) For methods Expert Knowledge, refer to the user manual of DAM. For method Ringtoets WTI 2017 , refer to the memo of Alexander van Duinen in: https://repos.deltares.nl/repos/delftgeosystems/delftgeosystems/trunk/documents/Geotechnics More...
double | EnsureWaterLevelIsAboveRiverBottom (double riverLevel, SurfaceLine2 surfaceline)
Make sure that river level is above the bottom of the river More...
GeometryPoint | GetDikeToeInward (SurfaceLine2 surfaceline)
If shoulder is present then the toe of the shoulder is returned Else the toe of the dike (ShoulderSaseInside) is returned More...
double | DetermineZValueAtX (double x, double x1, double x2, double z1, double z2)

Static Public Member Functions

static bool Equal (double aValue1, double aValue2)

Properties

bool | IsUseOvenDryUnitWeight [get, set]
SoilGeometryType | SoilGeometryType [get, set]
string | SoilGeometry2DName [get, set]
Soil | DikeEmbankmentMaterial [get, set]
double | HeadInPLLine2 [get, set]
double | GaugeMissVal [get, set]
double | Pl3HeadAdjusted [get]
double | Pl3LocationXMinUplift [get]
double | Pl4HeadAdjusted [get]
double | Pl4LocationXMinUplift [get]
bool | Inwards [get, set]

Constructor & Destructor Documentation

Deltares.Geotechnics.WaternetCreator.PlLinesCreator.PlLinesCreator ( )

Constructor

Member Function Documentation

Dictionary<PLLineType, GeometryPointString> Deltares.Geotechnics.WaternetCreator.PlLinesCreator.CreateAllPLLines ( Location location )

Create all PL-lines

Parameters
location Class containing all hydraulic data's needed for PL-line creation
Returns
PL1 (phreatic line), PL2, PL3 and PL4

References Deltares.Geotechnics.WaternetCreator.LineHelper.IsXAscending().

GeometryPointString Deltares.Geotechnics.WaternetCreator.PlLinesCreator.CreatePLLine1ByExpertKnowledge ( Location location )

Create PL1 (= phreatic level) For methods Expert Knowledge, refer to the user manual of DAM. For method Ringtoets WTI 2017 , refer to the memo of Alexander van Duinen in: https://repos.deltares.nl/repos/delftgeosystems/delftgeosystems/trunk/documents/Geotechnics

Returns
PL1 (= phreatic level)
GeometryPointString Deltares.Geotechnics.WaternetCreator.PlLinesCreator.CreatePLLine2ByExpertKnowledge ( Location location )

Create PL2 (is pl line for penetration)

Returns
GeometryPointString Deltares.Geotechnics.WaternetCreator.PlLinesCreator.CreatePLLine3ByExpertKnowledge ( Location location )

Create PL-line 3 (= head in the Pleistocene)

Returns
PL-line 3
GeometryPointString Deltares.Geotechnics.WaternetCreator.PlLinesCreator.CreatePLLine3ClayDikeOnSand ( Location location )

Create PL-line 3 (= head in Pleistocene) for "Clay dike on sand" (used only for Ringtoets WTI 2017 method)

Parameters
location
Returns
GeometryPointString Deltares.Geotechnics.WaternetCreator.PlLinesCreator.CreatePLLine4ByExpertKnowledge ( Location location )

Create PL-line 4 (= head in the in-between aquifer)

Returns
PL-line 4
GeometryPointString Deltares.Geotechnics.WaternetCreator.PlLinesCreator.CreatePLLineByExpertKnowledge | ( | PLLineType | plLineType,
 |  | Location | location
 | ) |  |

Create 4 PL-lines for the waternet creator of Ringtoets WTI 2017.

Parameters
plLineType | Enter the PL type you want to create
location | Class containing all hydraulic data needed for the creation of PL-lines
Returns
All the points of the desired PL-line>

References Deltares.Geotechnics.WaternetCreator.LineHelper.DeleteCoinsidingPoints().

GeometryPoint Deltares.Geotechnics.WaternetCreator.PlLinesCreator.DetermineIntersectionBetweenTaludRiverSideAndWaterLevel | ( | double | level,
 |  | SurfaceLine2 | surfaceline
 | ) |  |

Determines the intersection between talud river side and water level. Search starts from DikeTopAtRiver to SurfaceLevelOutside

Parameters
level The water level or z value of the horizontal line
surfaceline
Returns
An intersection point if any null otherswise
GeometryPoint Deltares.Geotechnics.WaternetCreator.PlLinesCreator.DetermineIntersectionBetweenWaterLevelAndDike | ( | double | waterLevelRiver,
 |  | SurfaceLine2 | surfaceline
 | ) |  |

Intersection between two line segments:

  • Horizontal waterlevel
  • Surface line (until DikeTopAtRiver)
Parameters
waterLevelRiver
surfaceline
Returns
double Deltares.Geotechnics.WaternetCreator.PlLinesCreator.EnsureWaterLevelIsAboveRiverBottom | ( | double | riverLevel,
 |  | SurfaceLine2 | surfaceline
 | ) |  |

Make sure that river level is above the bottom of the river

Parameters
riverLevel
surfaceline
Returns
bottom of the river if it is above riverLevel, else riverLevel
GeometryPoint Deltares.Geotechnics.WaternetCreator.PlLinesCreator.GetDikeToeInward ( SurfaceLine2 surfaceline )

If shoulder is present then the toe of the shoulder is returned Else the toe of the dike (ShoulderSaseInside) is returned

Parameters
surfaceline
Returns
toe of the dike
Dictionary<double, double> Deltares.Geotechnics.WaternetCreator.PlLinesCreator.GetUpliftOutputValuesPl3 ( )

get uplift factors for x, regarding pl3

Returns

Referenced by Deltares.Geotechnics.WaternetCreator.WaternetCreator.UpdateWaternet().

Dictionary<double, double> Deltares.Geotechnics.WaternetCreator.PlLinesCreator.GetUpliftOutputValuesPl4 ( )

get uplift factors for x, regarding pl4

Returns

Referenced by Deltares.Geotechnics.WaternetCreator.WaternetCreator.UpdateWaternet().

Generated on Tue Dec 15 2015 18:14:25 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • WaternetCreator
  • PlLinesCreator
Deltares.Geotechnics.WaternetCreator.PlLinesCreator Member List

This is the complete list of members for Deltares.Geotechnics.WaternetCreator.PlLinesCreator, including all inherited members.

CreateAllPLLines(Location location) | Deltares.Geotechnics.WaternetCreator.PlLinesCreator |
CreatePLLine1ByExpertKnowledge(Location location) | Deltares.Geotechnics.WaternetCreator.PlLinesCreator |
CreatePLLine2ByExpertKnowledge(Location location) | Deltares.Geotechnics.WaternetCreator.PlLinesCreator |
CreatePLLine3ByExpertKnowledge(Location location) | Deltares.Geotechnics.WaternetCreator.PlLinesCreator |
CreatePLLine3ClayDikeOnSand(Location location) | Deltares.Geotechnics.WaternetCreator.PlLinesCreator |
CreatePLLine4ByExpertKnowledge(Location location) | Deltares.Geotechnics.WaternetCreator.PlLinesCreator |
CreatePLLineByExpertKnowledge(PLLineType plLineType, Location location) | Deltares.Geotechnics.WaternetCreator.PlLinesCreator |
DetermineIntersectionBetweenPl2Or1AndFinalSlope100OfPl3(GeometryPoint firstPointOfObliqueLine, double slopeOfObliqueLine, Location location) (defined in Deltares.Geotechnics.WaternetCreator.PlLinesCreator) | Deltares.Geotechnics.WaternetCreator.PlLinesCreator |
DetermineIntersectionBetweenTaludRiverSideAndWaterLevel(double level, SurfaceLine2 surfaceline) | Deltares.Geotechnics.WaternetCreator.PlLinesCreator |
DetermineIntersectionBetweenWaterLevelAndDike(double waterLevelRiver, SurfaceLine2 surfaceline) | Deltares.Geotechnics.WaternetCreator.PlLinesCreator |
DetermineZValueAtX(double x, double x1, double x2, double z1, double z2) (defined in Deltares.Geotechnics.WaternetCreator.PlLinesCreator) | Deltares.Geotechnics.WaternetCreator.PlLinesCreator |
DikeEmbankmentMaterial (defined in Deltares.Geotechnics.WaternetCreator.PlLinesCreator) | Deltares.Geotechnics.WaternetCreator.PlLinesCreator |
EnsureWaterLevelIsAboveRiverBottom(double riverLevel, SurfaceLine2 surfaceline) | Deltares.Geotechnics.WaternetCreator.PlLinesCreator |
Equal(double aValue1, double aValue2) (defined in Deltares.Geotechnics.WaternetCreator.PlLinesCreator) | Deltares.Geotechnics.WaternetCreator.PlLinesCreator | static
GaugeMissVal (defined in Deltares.Geotechnics.WaternetCreator.PlLinesCreator) | Deltares.Geotechnics.WaternetCreator.PlLinesCreator |
GetDikeToeInward(SurfaceLine2 surfaceline) | Deltares.Geotechnics.WaternetCreator.PlLinesCreator |
GetUpliftOutputValuesPl3() | Deltares.Geotechnics.WaternetCreator.PlLinesCreator |
GetUpliftOutputValuesPl4() | Deltares.Geotechnics.WaternetCreator.PlLinesCreator |
HeadInPLLine2 (defined in Deltares.Geotechnics.WaternetCreator.PlLinesCreator) | Deltares.Geotechnics.WaternetCreator.PlLinesCreator |
Inwards (defined in Deltares.Geotechnics.WaternetCreator.PlLinesCreator) | Deltares.Geotechnics.WaternetCreator.PlLinesCreator |
IsNonWaterRetainingObjectPoint(GeometryPoint point, SurfaceLine2 surfaceline) (defined in Deltares.Geotechnics.WaternetCreator.PlLinesCreator) | Deltares.Geotechnics.WaternetCreator.PlLinesCreator |
IsUseOvenDryUnitWeight (defined in Deltares.Geotechnics.WaternetCreator.PlLinesCreator) | Deltares.Geotechnics.WaternetCreator.PlLinesCreator |
Pl3HeadAdjusted (defined in Deltares.Geotechnics.WaternetCreator.PlLinesCreator) | Deltares.Geotechnics.WaternetCreator.PlLinesCreator |
Pl3LocationXMinUplift (defined in Deltares.Geotechnics.WaternetCreator.PlLinesCreator) | Deltares.Geotechnics.WaternetCreator.PlLinesCreator |
Pl4HeadAdjusted (defined in Deltares.Geotechnics.WaternetCreator.PlLinesCreator) | Deltares.Geotechnics.WaternetCreator.PlLinesCreator |
Pl4LocationXMinUplift (defined in Deltares.Geotechnics.WaternetCreator.PlLinesCreator) | Deltares.Geotechnics.WaternetCreator.PlLinesCreator |
PlLinesCreator() | Deltares.Geotechnics.WaternetCreator.PlLinesCreator |
SoilGeometry2DName (defined in Deltares.Geotechnics.WaternetCreator.PlLinesCreator) | Deltares.Geotechnics.WaternetCreator.PlLinesCreator |
SoilGeometryType (defined in Deltares.Geotechnics.WaternetCreator.PlLinesCreator) | Deltares.Geotechnics.WaternetCreator.PlLinesCreator |
Generated on Tue Dec 15 2015 18:14:25 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.WaternetCreator.RingtoetsWTI2017PLLinesCreator Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • WaternetCreator
  • RingtoetsWTI2017PLLinesCreator
Public Member Functions | List of all members
Deltares.Geotechnics.WaternetCreator.RingtoetsWTI2017PLLinesCreator Class Reference

Public Member Functions

void CreatePL1 ()
Generated on Tue Dec 15 2015 18:14:25 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • WaternetCreator
  • RingtoetsWTI2017PLLinesCreator
Deltares.Geotechnics.WaternetCreator.RingtoetsWTI2017PLLinesCreator Member List

This is the complete list of members for Deltares.Geotechnics.WaternetCreator.RingtoetsWTI2017PLLinesCreator, including all inherited members.

CreatePL1() (defined in Deltares.Geotechnics.WaternetCreator.RingtoetsWTI2017PLLinesCreator) Deltares.Geotechnics.WaternetCreator.RingtoetsWTI2017PLLinesCreator
Generated on Tue Dec 15 2015 18:14:25 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.WaternetCreator.SoilVolumeMassCalculator Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • WaternetCreator
  • SoilVolumeMassCalculator
Public Member Functions | Properties | List of all members
Deltares.Geotechnics.WaternetCreator.SoilVolumeMassCalculator Class Reference

Public Member Functions

double Calculate ()

Properties

bool | IsUseOvenDryUnitWeight [get, set]
double | VolumicWeightOfWater [get, set]
double | PhreaticLevel [get, set]
double | SurfaceLevel [get, set]
double | TopOfLayerToBeEvaluated [get, set]
SoilProfile1D | SoilProfile [get, set]
Generated on Tue Dec 15 2015 18:14:25 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • WaternetCreator
  • SoilVolumeMassCalculator
Deltares.Geotechnics.WaternetCreator.SoilVolumeMassCalculator Member List

This is the complete list of members for Deltares.Geotechnics.WaternetCreator.SoilVolumeMassCalculator, including all inherited members.

Calculate() (defined in Deltares.Geotechnics.WaternetCreator.SoilVolumeMassCalculator) | Deltares.Geotechnics.WaternetCreator.SoilVolumeMassCalculator
IsUseOvenDryUnitWeight (defined in Deltares.Geotechnics.WaternetCreator.SoilVolumeMassCalculator) | Deltares.Geotechnics.WaternetCreator.SoilVolumeMassCalculator
PhreaticLevel (defined in Deltares.Geotechnics.WaternetCreator.SoilVolumeMassCalculator) | Deltares.Geotechnics.WaternetCreator.SoilVolumeMassCalculator
SoilProfile (defined in Deltares.Geotechnics.WaternetCreator.SoilVolumeMassCalculator) | Deltares.Geotechnics.WaternetCreator.SoilVolumeMassCalculator
SoilVolumeMassCalculator() (defined in Deltares.Geotechnics.WaternetCreator.SoilVolumeMassCalculator) | Deltares.Geotechnics.WaternetCreator.SoilVolumeMassCalculator
SurfaceLevel (defined in Deltares.Geotechnics.WaternetCreator.SoilVolumeMassCalculator) | Deltares.Geotechnics.WaternetCreator.SoilVolumeMassCalculator
TopOfLayerToBeEvaluated (defined in Deltares.Geotechnics.WaternetCreator.SoilVolumeMassCalculator) | Deltares.Geotechnics.WaternetCreator.SoilVolumeMassCalculator
VolumicWeightOfWater (defined in Deltares.Geotechnics.WaternetCreator.SoilVolumeMassCalculator) | Deltares.Geotechnics.WaternetCreator.SoilVolumeMassCalculator
Generated on Tue Dec 15 2015 18:14:25 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.WaternetCreator.UpliftCalculator Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • WaternetCreator
  • UpliftCalculator
Public Member Functions | Properties | List of all members
Deltares.Geotechnics.WaternetCreator.UpliftCalculator Class Reference

Public Member Functions

double | CalculateUpliftFactor (double headOfPLLine)
double | CalculateExtraHeight (double headOfPLLine, double upliftFactor)
Calculate soil extra height to be added to obtain the specified upliftFactor with a given head of PLline More...
double | CalculateHeadOfPLLine (double upliftFactor)

Properties

bool | IsUseOvenDryUnitWeight [get, set]
double | VolumicWeightOfWater [get, set]
SoilProfile1D | SoilProfile [get, set]
double | TopOfLayerToBeEvaluated [get, set]
List< GeometryPointString > | PLLines [get, set]
double | SurfaceLevel [get, set]
double | PhreaticLevel [get, set]
double | UpLiftTopLevel [get, set]
double | UnitWeightSoilEmbankment [get, set]

Member Function Documentation

double Deltares.Geotechnics.WaternetCreator.UpliftCalculator.CalculateExtraHeight | ( | double | headOfPLLine,
 |  | double | upliftFactor
 | ) |  |

Calculate soil extra height to be added to obtain the specified upliftFactor with a given head of PLline

Parameters
headOfPLLine
upliftFactor
unitWeightSoil
Returns
Required extra height
double Deltares.Geotechnics.WaternetCreator.UpliftCalculator.CalculateHeadOfPLLine ( double upliftFactor )

Parameters
upliftFactor
Returns
double Deltares.Geotechnics.WaternetCreator.UpliftCalculator.CalculateUpliftFactor ( double headOfPLLine )

Parameters
headOfPLLine
Returns
Generated on Tue Dec 15 2015 18:14:25 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • WaternetCreator
  • UpliftCalculator
Deltares.Geotechnics.WaternetCreator.UpliftCalculator Member List

This is the complete list of members for Deltares.Geotechnics.WaternetCreator.UpliftCalculator, including all inherited members.

CalculateExtraHeight(double headOfPLLine, double upliftFactor) | Deltares.Geotechnics.WaternetCreator.UpliftCalculator
CalculateHeadOfPLLine(double upliftFactor) | Deltares.Geotechnics.WaternetCreator.UpliftCalculator
CalculateUpliftFactor(double headOfPLLine) | Deltares.Geotechnics.WaternetCreator.UpliftCalculator
IsUseOvenDryUnitWeight (defined in Deltares.Geotechnics.WaternetCreator.UpliftCalculator) | Deltares.Geotechnics.WaternetCreator.UpliftCalculator
PhreaticLevel (defined in Deltares.Geotechnics.WaternetCreator.UpliftCalculator) | Deltares.Geotechnics.WaternetCreator.UpliftCalculator
PLLines (defined in Deltares.Geotechnics.WaternetCreator.UpliftCalculator) | Deltares.Geotechnics.WaternetCreator.UpliftCalculator
SoilProfile (defined in Deltares.Geotechnics.WaternetCreator.UpliftCalculator) | Deltares.Geotechnics.WaternetCreator.UpliftCalculator
SurfaceLevel (defined in Deltares.Geotechnics.WaternetCreator.UpliftCalculator) | Deltares.Geotechnics.WaternetCreator.UpliftCalculator
TopOfLayerToBeEvaluated (defined in Deltares.Geotechnics.WaternetCreator.UpliftCalculator) | Deltares.Geotechnics.WaternetCreator.UpliftCalculator
UnitWeightSoilEmbankment (defined in Deltares.Geotechnics.WaternetCreator.UpliftCalculator) | Deltares.Geotechnics.WaternetCreator.UpliftCalculator
UpliftCalculator() (defined in Deltares.Geotechnics.WaternetCreator.UpliftCalculator) | Deltares.Geotechnics.WaternetCreator.UpliftCalculator
UpLiftTopLevel (defined in Deltares.Geotechnics.WaternetCreator.UpliftCalculator) | Deltares.Geotechnics.WaternetCreator.UpliftCalculator
VolumicWeightOfWater (defined in Deltares.Geotechnics.WaternetCreator.UpliftCalculator) | Deltares.Geotechnics.WaternetCreator.UpliftCalculator
Generated on Tue Dec 15 2015 18:14:25 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.WaternetCreator.WaternetCreator Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • WaternetCreator
  • WaternetCreator
Public Member Functions | Package Functions | List of all members
Deltares.Geotechnics.WaternetCreator.WaternetCreator Class Reference

Public Member Functions

void | ClearWaternet (Waternet waternet)
Clears the waternet, to be used when there is no valid input More...
void | UpdateWaternet (Waternet waternet, Location location)
Create a waternet based on a soil profile 2D, a surface line and the output from PL-lines creator, for different scenario's: Sand dike on sand has only phreatic line. Clay dike on sand have only a PL-line 2 on the top of first aquifer. The 2 other scenario's may have an in-between aquifer (PL-line 4) and an in-between aquitard (PL-line 2) More...
List< GeometryCurve > | OrderCurves (GeometryCurve firstCurve, List< GeometryCurve > boundaryCurves)
order curves clockwise, curve.EndPoint == nextCurve.HeadPoint More...
GeometryCurve | GetNextCurve (GeometryCurve curve, List< GeometryCurve > boundaryCurves)
get next curve so that curve.EndPoint == nextCurve.HeadPoint More...
Dictionary< double, double > | GetUpliftOutputValuesPl4 ()
get uplift factors for x, regarding pl4 More...
Dictionary< double, double > | GetUpliftOutputValuesPl3 ()
get uplift factors for x, regarding pl3 More...
bool | CanGenerateWaternet (Location location)

Package Functions

GeometryCurve CreateParallelCurve (GeometryCurve curve, double distance)
create parallel curve ad distance to each original curve More...

Member Function Documentation

void Deltares.Geotechnics.WaternetCreator.WaternetCreator.ClearWaternet ( Waternet waternet )

Clears the waternet, to be used when there is no valid input

GeometryCurve Deltares.Geotechnics.WaternetCreator.WaternetCreator.CreateParallelCurve | ( | GeometryCurve | curve,
 |  | double | distance
 | ) |  |
package

create parallel curve ad distance to each original curve

Parameters
curve
distance
Returns
GeometryCurve Deltares.Geotechnics.WaternetCreator.WaternetCreator.GetNextCurve | ( | GeometryCurve | curve,
 |  | List< GeometryCurve > | boundaryCurves
 | ) |  |

get next curve so that curve.EndPoint == nextCurve.HeadPoint

Parameters
curve
boundaryCurves
Returns
Dictionary<double, double> Deltares.Geotechnics.WaternetCreator.WaternetCreator.GetUpliftOutputValuesPl3 ( )

get uplift factors for x, regarding pl3

Returns
Dictionary<double, double> Deltares.Geotechnics.WaternetCreator.WaternetCreator.GetUpliftOutputValuesPl4 ( )

get uplift factors for x, regarding pl4

Returns
List<GeometryCurve> Deltares.Geotechnics.WaternetCreator.WaternetCreator.OrderCurves | ( | GeometryCurve | firstCurve,
 |  | List< GeometryCurve > | boundaryCurves
 | ) |  |

order curves clockwise, curve.EndPoint == nextCurve.HeadPoint

Parameters
firstCurve
boundaryCurves
Returns
void Deltares.Geotechnics.WaternetCreator.WaternetCreator.UpdateWaternet | ( | Waternet | waternet,
 |  | Location | location
 | ) |  |

Create a waternet based on a soil profile 2D, a surface line and the output from PL-lines creator, for different scenario's: Sand dike on sand has only phreatic line. Clay dike on sand have only a PL-line 2 on the top of first aquifer. The 2 other scenario's may have an in-between aquifer (PL-line 4) and an in-between aquitard (PL-line 2)

Parameters
waternet | The actual waternet
location | The input parameters for waternet creator (Location class)
inwards | Is the inwards orientation
Returns
The updated waternet

References Deltares.Geotechnics.WaternetCreator.PlLinesCreator.GetUpliftOutputValuesPl3(), and Deltares.Geotechnics.WaternetCreator.PlLinesCreator.GetUpliftOutputValuesPl4().

Generated on Tue Dec 15 2015 18:14:25 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • WaternetCreator
  • WaternetCreator
Deltares.Geotechnics.WaternetCreator.WaternetCreator Member List

This is the complete list of members for Deltares.Geotechnics.WaternetCreator.WaternetCreator, including all inherited members.

CanGenerateWaternet(Location location) (defined in Deltares.Geotechnics.WaternetCreator.WaternetCreator) | Deltares.Geotechnics.WaternetCreator.WaternetCreator |
ClearWaternet(Waternet waternet) | Deltares.Geotechnics.WaternetCreator.WaternetCreator |
CreateParallelCurve(GeometryCurve curve, double distance) | Deltares.Geotechnics.WaternetCreator.WaternetCreator | package
GetNextCurve(GeometryCurve curve, List< GeometryCurve > boundaryCurves) | Deltares.Geotechnics.WaternetCreator.WaternetCreator |
GetUpliftOutputValuesPl3() | Deltares.Geotechnics.WaternetCreator.WaternetCreator |
GetUpliftOutputValuesPl4() | Deltares.Geotechnics.WaternetCreator.WaternetCreator |
OrderCurves(GeometryCurve firstCurve, List< GeometryCurve > boundaryCurves) | Deltares.Geotechnics.WaternetCreator.WaternetCreator |
UpdateWaternet(Waternet waternet, Location location) | Deltares.Geotechnics.WaternetCreator.WaternetCreator |
WaternetCreator() (defined in Deltares.Geotechnics.WaternetCreator.WaternetCreator) | Deltares.Geotechnics.WaternetCreator.WaternetCreator |
Generated on Tue Dec 15 2015 18:14:25 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.ISoilProfileProvider Interface Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • ISoilProfileProvider
Properties | List of all members
Deltares.Geotechnics.ISoilProfileProvider Interface Reference

Interface for providing the 1D Soil Profile TODO: Comment More...

Properties

SoilProfile1D SoilProfile [get]

Detailed Description

Interface for providing the 1D Soil Profile TODO: Comment

Generated on Tue Dec 15 2015 18:13:59 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • ISoilProfileProvider
Deltares.Geotechnics.ISoilProfileProvider Member List

This is the complete list of members for Deltares.Geotechnics.ISoilProfileProvider, including all inherited members.

SoilProfile (defined in Deltares.Geotechnics.ISoilProfileProvider) Deltares.Geotechnics.ISoilProfileProvider
Generated on Tue Dec 15 2015 18:13:59 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.SoilProfile1D Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • SoilProfile1D
Public Member Functions | Public Attributes | Static Public Attributes | Properties | List of all members
Deltares.Geotechnics.SoilProfile1D Class Reference

1D Soil Profile Object TODO: Comment More...

Inheritance diagram for Deltares.Geotechnics.SoilProfile1D:

Public Member Functions

SoilProfile1D ()
Default constructor TODO: Comment More...
SoilProfile1D (double topLevel, double bottomLevel, Soil soil)
Constructor to construct simple soilprofile More...
void | AssignProfileToLayers ()
Make sure all layers have this profile assigned More...
object | Clone ()
Creates a new object that is a copy of the current instance. More...
void | Assign (SoilProfile1D profile)
Assigns the specified profile. TODO: Comment More...
virtual double | GetLayerHeight (SoilLayer1D soilLayer)
Gets (calculates) the height for a given layer in the profile More...
double | GetLayerHeight (int layerIndex)
Gets the height of the layer. More...
string | GetNewUniqueLayerId ()
Gets the first unused unique layer identifier. More...
SoilLayer1D | GetLayerWithId (string id)
Gets the layer with the given ID. More...
void | EnsureUniqueLayerIds ()
This method makes sure all id's are unique More...
bool | AreAllLayerIdsUnique ()
Checks weather all layer ids are unique. More...
void | ValidateDirect ()
Validates this instance on direct call (does not use Validator mechanism). throws SoilProfileLayersNotSortedDescendingException if not valid. More...
ValidationResult[] | Validate ()
Validates this instance (using validator mechanism). More...
void | DetermineInfiltrationLayer (double penetrationLength)
Determines the infiltration layer. TODO: Comment More...
IList< SoilLayer1D > | GetAquiferLayers ()
Gets the aquifer layers. More...
double | GetBottomLevel (SoilLayer1D soilLayer)
Gets the bottom level. More...
void | OrderLayersByDescending ()
Orders the layers descending. More...
bool | IsStrictlyDescending (out SoilLayer1D erroneousLayer)
Determines whether the layers are strictly ordered in descending order. If erroneous layer is found, false is returned and the layer is stored in the parameter More...
bool | HasInvalidThicknessLayers (out SoilLayer1D erroneousLayer)
Determines whether there are layers with invalid thickness. More...
bool | HasLayersWithoutSoil (out SoilLayer1D erroneousLayer)
Determines whether there are layers without soil. More...
SoilLayer1D | GetLayerByInsetOffset (SoilLayer1D layer, int offset)
Gets the layer by inset offset, seen from the given layer plus the given offset. More...
SoilLayer1D | GetLayerBelow (SoilLayer1D layer)
Gets the layer below the given layer. More...
SoilLayer1D | GetLayerAbove (SoilLayer1D layer)
Gets the layer above the given layer. More...
int | GetLayerIndexAt (SoilLayer1D layer)
Gets the layer index of the given layer. More...
int | GetLayerIndexAtCoordinate (double Z)
Gets the layer index at coordinate. More...
int | CompareTo (object obj)
Compares the current instance with another object of the same type More...
ICollection | GetDomain (string property)
Gets the domain. More...
override string | ToString ()
Returns a System.String that represents this instance. More...
SoilLayer1D | GetLayerAt (double z)
Gets the layer at a given z coordinate. More...
void | determineAverageSandDiameters (ref double D15, ref double D50)
Determines the average d15 and d50 from the sand layers in soilprofile TODO: Comment More...
void | EnsureLastLayerHasHeight ()
Make sure the last layer has a height More...
bool | IsVisible (string property)
Determines whether the specified property is visible. More...
bool | IsEnabled (string property)
Determines whether the specified property is enabled. More...
double | GetTopLevelOfHighestAquifer ()
Gets the top level of highest aquifer. More...
double | GetTotalPressure (double z, double phreaticLevel, double UnitWeightWater)
Gets the soil pressure. TODO: Comment More...

Public Attributes

const string SoilProfileBottomLevelId = "DummyForBottomLevel"

Static Public Attributes

static readonly string | XProperty = StaticReflection.GetMemberName<SoilProfile1D>(p => p.X)
static readonly string | YProperty = StaticReflection.GetMemberName<SoilProfile1D>(p => p.Y)
static readonly string | TopLevelProperty = StaticReflection.GetMemberName<SoilProfile1D>(p => p.TopLevel)
static readonly string | BottomLevelProperty = StaticReflection.GetMemberName<SoilProfile1D>(p => p.BottomLevel)
static readonly string | HeightProperty = StaticReflection.GetMemberName<SoilProfile1D>(p => p.Height)
static readonly string | ProbabilityOfOccurrenceProperty = StaticReflection.GetMemberName<SoilProfile1D>(p => p.ProbabilityOfOccurrence)
static Func< SoilProfile1D, string, bool?> | VisibilityDelegate

Properties

static bool | MaintainLayerOrder [get, set]
Gets or sets a value for maintaining the layer order. More...
bool | MaintainLayerOrderNonStatic [get, set]
non static property for bind support. just delegates to the static property More...
virtual List< SoilLayer1D > | Layers [get]
Gets the soil layer collection for this profile More...
IEnumerable< Soil > | Soils [get]
Gets the a list of distinct soils for the layers of this profile More...
int | LayerCount [get]
Gets the number of layers. More...
double | X [get, set]
Gets or sets the x. More...
double | Y [get, set]
Gets or sets the y. More...
double | PhreaticLevel [get, set]
Gets or sets the phreatic level. More...
bool | HasPhreaticLevel [get, set]
Gets or sets a value indicating whether this profile has a phreatic level. More...
virtual double | BottomLevel [get, set]
Gets or sets the bottom level. TODO: Comment More...
virtual double | TopLevel [get, set]
Gets or sets the top level. TODO: Comment More...
double | Height [get]
Gets the height of the profile. More...
static IDomain | SoilPropertyManager [get, set]
Gets or sets the soil property manager. More...
virtual SoilLayer1D | TopAquitardLayer [get]
virtual SoilLayer1D | TopAquiferLayer [get]
The topmost aquifer layer, or null. More...
virtual SoilLayer1D | BottomAquiferLayer [get]
Gets the bottom aquifer layer. TODO: Comment More...
SoilLayer1D | InBetweenAquiferLayer [get]
Gets the in-between aquifer layer. More...
SoilLayer1D | InfiltrationLayer [get]
Gets the infiltration layer. More...
double | ProbabilityOfOccurrence [get, set]
Gets or sets the probability of occurrence. More...

Detailed Description

1D Soil Profile Object TODO: Comment

Constructor & Destructor Documentation

Deltares.Geotechnics.SoilProfile1D.SoilProfile1D ( )

Default constructor TODO: Comment

Referenced by Deltares.Geotechnics.Forms.DrawingSoilProfile1D.SetDataObject().

Deltares.Geotechnics.SoilProfile1D.SoilProfile1D | ( | double | topLevel,
 |  | double | bottomLevel,
 |  | Soil | soil
 | ) |  |

Constructor to construct simple soilprofile

Parameters
topLevel
bottomLevel
soil

Member Function Documentation

bool Deltares.Geotechnics.SoilProfile1D.AreAllLayerIdsUnique ( )

Checks weather all layer ids are unique.

true if all layer IDs are unique; otherwise, false.

void Deltares.Geotechnics.SoilProfile1D.Assign ( SoilProfile1D profile )

Assigns the specified profile. TODO: Comment

Parameters
profile The profile.

References Deltares.Geotechnics.SoilProfile1D.HasPhreaticLevel, Deltares.Geotechnics.SoilProfile1D.PhreaticLevel, Deltares.Geotechnics.SoilProfile1D.X, and Deltares.Geotechnics.SoilProfile1D.Y.

void Deltares.Geotechnics.SoilProfile1D.AssignProfileToLayers ( )

Make sure all layers have this profile assigned

object Deltares.Geotechnics.SoilProfile1D.Clone ( )

Creates a new object that is a copy of the current instance.

Returns
A new object that is a copy of this instance.
int Deltares.Geotechnics.SoilProfile1D.CompareTo ( object obj )

Compares the current instance with another object of the same type

Parameters
obj An soil profile to compare with this one.
Returns
Result of comparing propability of occurence

References Deltares.Geotechnics.SoilProfile1D.CompareTo().

Referenced by Deltares.Geotechnics.SoilProfile1D.CompareTo().

void Deltares.Geotechnics.SoilProfile1D.determineAverageSandDiameters | ( | ref double | D15,
 |  | ref double | D50
 | ) |  |

Determines the average d15 and d50 from the sand layers in soilprofile TODO: Comment

Parameters
D15 | The D15.
D50 | The D50.
void Deltares.Geotechnics.SoilProfile1D.DetermineInfiltrationLayer ( double penetrationLength )

Determines the infiltration layer. TODO: Comment

Parameters
penetrationLength Length of the penetration.
void Deltares.Geotechnics.SoilProfile1D.EnsureLastLayerHasHeight ( )

Make sure the last layer has a height

void Deltares.Geotechnics.SoilProfile1D.EnsureUniqueLayerIds ( )

This method makes sure all id's are unique

IList<SoilLayer1D> Deltares.Geotechnics.SoilProfile1D.GetAquiferLayers ( )

Gets the aquifer layers.

Returns
list of Aquifer layers
double Deltares.Geotechnics.SoilProfile1D.GetBottomLevel ( SoilLayer1D soilLayer )

Gets the bottom level.

Parameters
soilLayer The soil layer.
Returns
Bottom level
ICollection Deltares.Geotechnics.SoilProfile1D.GetDomain ( string property )

Gets the domain.

Parameters
property The property.
Returns
Domain
SoilLayer1D Deltares.Geotechnics.SoilProfile1D.GetLayerAbove ( SoilLayer1D layer )

Gets the layer above the given layer.

Parameters
layer The given layer.
Returns
The found layer
SoilLayer1D Deltares.Geotechnics.SoilProfile1D.GetLayerAt ( double z )

Gets the layer at a given z coordinate.

Parameters
z The z.
Returns
the found layer
SoilLayer1D Deltares.Geotechnics.SoilProfile1D.GetLayerBelow ( SoilLayer1D layer )

Gets the layer below the given layer.

Parameters
layer The given layer.
Returns
The found layer
SoilLayer1D Deltares.Geotechnics.SoilProfile1D.GetLayerByInsetOffset | ( | SoilLayer1D | layer,
 |  | int | offset
 | ) |  |

Gets the layer by inset offset, seen from the given layer plus the given offset.

Parameters
layer | The layer.
offset | The offset.
Returns
the found layer, if no layer found, null
virtual double Deltares.Geotechnics.SoilProfile1D.GetLayerHeight ( SoilLayer1D soilLayer )
virtual

Gets (calculates) the height for a given layer in the profile

Parameters
soilLayer The layer to process
Returns
The height
double Deltares.Geotechnics.SoilProfile1D.GetLayerHeight ( int layerIndex )

Gets the height of the layer.

Parameters
layerIndex Index of the layer.
Returns
The height
int Deltares.Geotechnics.SoilProfile1D.GetLayerIndexAt ( SoilLayer1D layer )

Gets the layer index of the given layer.

Parameters
layer The layer.
Returns
The index, -1 if not found
int Deltares.Geotechnics.SoilProfile1D.GetLayerIndexAtCoordinate ( double Z )

Gets the layer index at coordinate.

Parameters
Z The z.
Returns
The found layer
SoilLayer1D Deltares.Geotechnics.SoilProfile1D.GetLayerWithId ( string id )

Gets the layer with the given ID.

Parameters
id The identifier.
Returns
the layer with the given identifier, null if non-existent
string Deltares.Geotechnics.SoilProfile1D.GetNewUniqueLayerId ( )

Gets the first unused unique layer identifier.

Returns
new unique layer ID
double Deltares.Geotechnics.SoilProfile1D.GetTopLevelOfHighestAquifer ( )

Gets the top level of highest aquifer.

Returns
double Deltares.Geotechnics.SoilProfile1D.GetTotalPressure | ( | double | z,
 |  | double | phreaticLevel,
 |  | double | UnitWeightWater
 | ) |  |

Gets the soil pressure. TODO: Comment

Parameters
z | The z.
phreaticLevel | The phreatic level.
Returns
the soil pressure
bool Deltares.Geotechnics.SoilProfile1D.HasInvalidThicknessLayers ( out SoilLayer1D erroneousLayer )

Determines whether there are layers with invalid thickness.

Parameters
erroneousLayer The erroneous layer.
Returns
True when a layer with invalid thickness exists
bool Deltares.Geotechnics.SoilProfile1D.HasLayersWithoutSoil ( out SoilLayer1D erroneousLayer )

Determines whether there are layers without soil.

Parameters
erroneousLayer The erroneous layer.
Returns
true when a layer without soil is found
bool Deltares.Geotechnics.SoilProfile1D.IsEnabled ( string property )

Determines whether the specified property is enabled.

Parameters
property The property.
Returns
true
bool Deltares.Geotechnics.SoilProfile1D.IsStrictlyDescending ( out SoilLayer1D erroneousLayer )

Determines whether the layers are strictly ordered in descending order. If erroneous layer is found, false is returned and the layer is stored in the parameter

Parameters
erroneousLayer The erroneous layer.
Returns
true if the layers are strictly ordered in descending order; otherwise, false.
bool Deltares.Geotechnics.SoilProfile1D.IsVisible ( string property )

Determines whether the specified property is visible.

Parameters
property The property.
Returns
value of visibilityDelegate, if no visibilityDelegate, true
void Deltares.Geotechnics.SoilProfile1D.OrderLayersByDescending ( )

Orders the layers descending.

override string Deltares.Geotechnics.SoilProfile1D.ToString ( )

Returns a System.String that represents this instance.

Returns
A System.String that represents this instance.
ValidationResult [] Deltares.Geotechnics.SoilProfile1D.Validate ( )

Validates this instance (using validator mechanism).

Returns
void Deltares.Geotechnics.SoilProfile1D.ValidateDirect ( )

Validates this instance on direct call (does not use Validator mechanism). throws SoilProfileLayersNotSortedDescendingException if not valid.

Exceptions
Deltares.Geotechnics.SoilProfileLayersNotSortedDescendingException

Property Documentation

virtual SoilLayer1D Deltares.Geotechnics.SoilProfile1D.BottomAquiferLayer
get

Gets the bottom aquifer layer. TODO: Comment

The bottom aquifer layer.

Referenced by Deltares.Geotechnics.WaternetCreator.Location.ValidateSoilProfile().

virtual double Deltares.Geotechnics.SoilProfile1D.BottomLevel
getset

Gets or sets the bottom level. TODO: Comment

The bottom level.

Referenced by Deltares.Geotechnics.Forms.SoilProfile1DControl.SoilProfile1DControl().

bool Deltares.Geotechnics.SoilProfile1D.HasPhreaticLevel
getset

Gets or sets a value indicating whether this profile has a phreatic level.

true if this profile has a phreatic level; otherwise, false.

Referenced by Deltares.Geotechnics.SoilProfile1D.Assign().

double Deltares.Geotechnics.SoilProfile1D.Height
get

Gets the height of the profile.

The height.

Referenced by Deltares.Geotechnics.Forms.SoilProfile1DControl.SoilProfile1DControl().

SoilLayer1D Deltares.Geotechnics.SoilProfile1D.InBetweenAquiferLayer
get

Gets the in-between aquifer layer.

The in-between aquifer layer.

SoilLayer1D Deltares.Geotechnics.SoilProfile1D.InfiltrationLayer
get

Gets the infiltration layer.

The infiltration layer.

int Deltares.Geotechnics.SoilProfile1D.LayerCount
get

Gets the number of layers.

The layer count.

virtual List<SoilLayer1D> Deltares.Geotechnics.SoilProfile1D.Layers
get

Gets the soil layer collection for this profile

Referenced by Deltares.Geotechnics.Forms.DrawingSoilProfile1D.Draw3D(), Deltares.Geotechnics.IO.Importers.GEFXmlImporter.ReadSoilProfile1D(), Deltares.DSoilModel.Data.SosSoilProfilesImporter.ReadSoilProfiles(), Deltares.Geotechnics.IO.Importers.SoilProfilesImporter.ReadSoilProfiles(), Deltares.Geotechnics.Forms.SoilProfile1DControl.SoilProfile1DControl(), Deltares.Geotechnics.WaternetCreator.Location.ValidateAquifers(), and Deltares.Geotechnics.WaternetCreator.Location.ValidateSoilProfile().

bool Deltares.Geotechnics.SoilProfile1D.MaintainLayerOrder
staticgetset

Gets or sets a value for maintaining the layer order.

true if the layer order shall be maintained; otherwise, false.

bool Deltares.Geotechnics.SoilProfile1D.MaintainLayerOrderNonStatic
getset

non static property for bind support. just delegates to the static property

true if the layer order shall be maintained; otherwise, false.

Referenced by Deltares.Geotechnics.Forms.SoilProfile1DControl.SoilProfile1DControl().

double Deltares.Geotechnics.SoilProfile1D.PhreaticLevel
getset

Gets or sets the phreatic level.

The phreatic level.

Referenced by Deltares.Geotechnics.SoilProfile1D.Assign().

double Deltares.Geotechnics.SoilProfile1D.ProbabilityOfOccurrence
getset

Gets or sets the probability of occurrence.

The probability of occurrence.

Referenced by Deltares.Geotechnics.Forms.SoilProfile1DControl.SoilProfile1DControl().

IDomain Deltares.Geotechnics.SoilProfile1D.SoilPropertyManager
staticgetset

Gets or sets the soil property manager.

The soil property manager.

IEnumerable<Soil> Deltares.Geotechnics.SoilProfile1D.Soils
get

Gets the a list of distinct soils for the layers of this profile

The soils.

virtual SoilLayer1D Deltares.Geotechnics.SoilProfile1D.TopAquiferLayer
get

The topmost aquifer layer, or null.

virtual double Deltares.Geotechnics.SoilProfile1D.TopLevel
getset

Gets or sets the top level. TODO: Comment

The top level.

Referenced by Deltares.Geotechnics.Forms.SoilProfile1DControl.SoilProfile1DControl().

double Deltares.Geotechnics.SoilProfile1D.X
getset

Gets or sets the x.

The x.

Referenced by Deltares.Geotechnics.SoilProfile1D.Assign(), and Deltares.Geotechnics.Forms.SoilProfile1DControl.SoilProfile1DControl().

double Deltares.Geotechnics.SoilProfile1D.Y
getset

Gets or sets the y.

The y.

Referenced by Deltares.Geotechnics.SoilProfile1D.Assign(), and Deltares.Geotechnics.Forms.SoilProfile1DControl.SoilProfile1DControl().

Generated on Tue Dec 15 2015 18:14:00 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • SoilProfile1D
Deltares.Geotechnics.SoilProfile1D Member List

This is the complete list of members for Deltares.Geotechnics.SoilProfile1D, including all inherited members.

AreAllLayerIdsUnique() | Deltares.Geotechnics.SoilProfile1D |
Assign(SoilProfile1D profile) | Deltares.Geotechnics.SoilProfile1D |
AssignProfileToLayers() | Deltares.Geotechnics.SoilProfile1D |
BottomAquiferLayer | Deltares.Geotechnics.SoilProfile1D |
BottomLevel | Deltares.Geotechnics.SoilProfile1D |
BottomLevelProperty (defined in Deltares.Geotechnics.SoilProfile1D) | Deltares.Geotechnics.SoilProfile1D | static
Clone() | Deltares.Geotechnics.SoilProfile1D |
CompareTo(object obj) | Deltares.Geotechnics.SoilProfile1D |
determineAverageSandDiameters(ref double D15, ref double D50) | Deltares.Geotechnics.SoilProfile1D |
DetermineInfiltrationLayer(double penetrationLength) | Deltares.Geotechnics.SoilProfile1D |
EnsureLastLayerHasHeight() | Deltares.Geotechnics.SoilProfile1D |
EnsureUniqueLayerIds() | Deltares.Geotechnics.SoilProfile1D |
GetAquiferLayers() | Deltares.Geotechnics.SoilProfile1D |
GetBottomLevel(SoilLayer1D soilLayer) | Deltares.Geotechnics.SoilProfile1D |
GetDomain(string property) | Deltares.Geotechnics.SoilProfile1D |
GetLayerAbove(SoilLayer1D layer) | Deltares.Geotechnics.SoilProfile1D |
GetLayerAt(double z) | Deltares.Geotechnics.SoilProfile1D |
GetLayerBelow(SoilLayer1D layer) | Deltares.Geotechnics.SoilProfile1D |
GetLayerByInsetOffset(SoilLayer1D layer, int offset) | Deltares.Geotechnics.SoilProfile1D |
GetLayerHeight(SoilLayer1D soilLayer) | Deltares.Geotechnics.SoilProfile1D | virtual
GetLayerHeight(int layerIndex) | Deltares.Geotechnics.SoilProfile1D |
GetLayerIndexAt(SoilLayer1D layer) | Deltares.Geotechnics.SoilProfile1D |
GetLayerIndexAtCoordinate(double Z) | Deltares.Geotechnics.SoilProfile1D |
GetLayerWithId(string id) | Deltares.Geotechnics.SoilProfile1D |
GetNewUniqueLayerId() | Deltares.Geotechnics.SoilProfile1D |
GetTopLevelOfHighestAquifer() | Deltares.Geotechnics.SoilProfile1D |
GetTotalPressure(double z, double phreaticLevel, double UnitWeightWater) | Deltares.Geotechnics.SoilProfile1D |
HasInvalidThicknessLayers(out SoilLayer1D erroneousLayer) | Deltares.Geotechnics.SoilProfile1D |
HasLayersWithoutSoil(out SoilLayer1D erroneousLayer) | Deltares.Geotechnics.SoilProfile1D |
HasPhreaticLevel | Deltares.Geotechnics.SoilProfile1D |
Height | Deltares.Geotechnics.SoilProfile1D |
HeightProperty (defined in Deltares.Geotechnics.SoilProfile1D) | Deltares.Geotechnics.SoilProfile1D | static
InBetweenAquiferLayer | Deltares.Geotechnics.SoilProfile1D |
InfiltrationLayer | Deltares.Geotechnics.SoilProfile1D |
IsEnabled(string property) | Deltares.Geotechnics.SoilProfile1D |
IsStrictlyDescending(out SoilLayer1D erroneousLayer) | Deltares.Geotechnics.SoilProfile1D |
IsVisible(string property) | Deltares.Geotechnics.SoilProfile1D |
LayerCount | Deltares.Geotechnics.SoilProfile1D |
Layers | Deltares.Geotechnics.SoilProfile1D |
MaintainLayerOrder | Deltares.Geotechnics.SoilProfile1D | static
MaintainLayerOrderNonStatic | Deltares.Geotechnics.SoilProfile1D |
OrderLayersByDescending() | Deltares.Geotechnics.SoilProfile1D |
PhreaticLevel | Deltares.Geotechnics.SoilProfile1D |
ProbabilityOfOccurrence | Deltares.Geotechnics.SoilProfile1D |
ProbabilityOfOccurrenceProperty (defined in Deltares.Geotechnics.SoilProfile1D) | Deltares.Geotechnics.SoilProfile1D | static
SoilProfile1D() | Deltares.Geotechnics.SoilProfile1D |
SoilProfile1D(double topLevel, double bottomLevel, Soil soil) | Deltares.Geotechnics.SoilProfile1D |
SoilProfileBottomLevelId (defined in Deltares.Geotechnics.SoilProfile1D) | Deltares.Geotechnics.SoilProfile1D |
SoilPropertyManager | Deltares.Geotechnics.SoilProfile1D | static
Soils | Deltares.Geotechnics.SoilProfile1D |
TopAquiferLayer | Deltares.Geotechnics.SoilProfile1D |
TopAquitardLayer (defined in Deltares.Geotechnics.SoilProfile1D) | Deltares.Geotechnics.SoilProfile1D |
TopLevel | Deltares.Geotechnics.SoilProfile1D |
TopLevelProperty (defined in Deltares.Geotechnics.SoilProfile1D) | Deltares.Geotechnics.SoilProfile1D | static
ToString() | Deltares.Geotechnics.SoilProfile1D |
Validate() | Deltares.Geotechnics.SoilProfile1D |
ValidateDirect() | Deltares.Geotechnics.SoilProfile1D |
VisibilityDelegate (defined in Deltares.Geotechnics.SoilProfile1D) | Deltares.Geotechnics.SoilProfile1D | static
X | Deltares.Geotechnics.SoilProfile1D |
XProperty (defined in Deltares.Geotechnics.SoilProfile1D) | Deltares.Geotechnics.SoilProfile1D | static
Y | Deltares.Geotechnics.SoilProfile1D |
YProperty (defined in Deltares.Geotechnics.SoilProfile1D) | Deltares.Geotechnics.SoilProfile1D | static
Generated on Tue Dec 15 2015 18:14:00 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.SoilProfile1DException Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • SoilProfile1DException
Public Member Functions | List of all members
Deltares.Geotechnics.SoilProfile1DException Class Reference

Exception for SoilProfile 1D problem handeling. More...

Inheritance diagram for Deltares.Geotechnics.SoilProfile1DException:

Public Member Functions

SoilProfile1DException (string message)

Detailed Description

Exception for SoilProfile 1D problem handeling.

Generated on Tue Dec 15 2015 18:14:00 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • SoilProfile1DException
Deltares.Geotechnics.SoilProfile1DException Member List

This is the complete list of members for Deltares.Geotechnics.SoilProfile1DException, including all inherited members.

SoilProfile1DException(string message) (defined in Deltares.Geotechnics.SoilProfile1DException) Deltares.Geotechnics.SoilProfile1DException
Generated on Tue Dec 15 2015 18:14:00 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Geotechnics.SoilProfileLayersNotSortedDescendingException Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • SoilProfileLayersNotSortedDescendingException
Public Member Functions | List of all members
Deltares.Geotechnics.SoilProfileLayersNotSortedDescendingException Class Reference

Exception for indicating that the soil profile layers are not sorted in descending order. More...

Inheritance diagram for Deltares.Geotechnics.SoilProfileLayersNotSortedDescendingException:

Public Member Functions

SoilProfileLayersNotSortedDescendingException (string message)

Detailed Description

Exception for indicating that the soil profile layers are not sorted in descending order.

Generated on Tue Dec 15 2015 18:14:00 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Geotechnics
  • SoilProfileLayersNotSortedDescendingException
Deltares.Geotechnics.SoilProfileLayersNotSortedDescendingException Member List

This is the complete list of members for Deltares.Geotechnics.SoilProfileLayersNotSortedDescendingException, including all inherited members.

SoilProfileLayersNotSortedDescendingException(string message) (defined in Deltares.Geotechnics.SoilProfileLayersNotSortedDescendingException) Deltares.Geotechnics.SoilProfileLayersNotSortedDescendingException
Generated on Tue Dec 15 2015 18:14:00 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Application.LogHelper Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Application
  • LogHelper
Public Member Functions | Static Public Member Functions | Properties | List of all members
Deltares.Standard.Application.LogHelper Class Reference

LogHelper is a utility class to simplify logging to different appenders. This class uses log4net to delegate the actual logging. See the log4net documentation to configure this API in the client application using either the configuration file or programmaticaly. More...

Public Member Functions

LogHelper (ILog logger)
void | LogFatal (string message, Exception exception=null)
Logs fatal messages if ALL, DEBUG, INFO, WARN, ERROR or FATAL is enabled in the config. More...
void | LogError (string message, Exception exception=null)
Logs error messages if ALL, DEBUG, INFO, WARN or ERROR level is enabled in the config. More...
void | LogWarning (string message, Exception exception=null)
Logs warning messages if ALL, DEBUG, INFO or WARN level is enabled in the config. More...
void | LogInfo (string message, Exception exception=null)
Logs info messages if ALL, DEBUG or INFO is enabled in the config. More...
void | LogDebug (string message, Exception exception=null)
Logs debug messages if ALL or DEBUG is enabled in the config. More...
void | Flush ()
Flushes all appenders across the whole logging repository More...
void | Clear ()
Clears the internal exception list More...

Static Public Member Functions

static LogHelper | Create (object obj)
Creates a LogHelper class to simplify logging More...
static LogHelper | Create (Type type)
Creates a LogHelper to simplify logging. More...
static LogHelper | Create< T > ()
Creates a LogHelper class to simplify logging More...
static LogHelper | Create (string name)
Creates a LogHelper class to simplify logging More...

Properties

bool HasLoggedExceptions [get]
Gets a value indicating whether this instance has logged exceptions. More...

Detailed Description

LogHelper is a utility class to simplify logging to different appenders. This class uses log4net to delegate the actual logging. See the log4net documentation to configure this API in the client application using either the configuration file or programmaticaly.

TODO: This logger should be able to log to EntLib too! see http://stackoverflow.com/questions/710863/log4net-vs-nlog

Member Function Documentation

void Deltares.Standard.Application.LogHelper.Clear ( )

Clears the internal exception list

static LogHelper Deltares.Standard.Application.LogHelper.Create ( object obj )
static

Creates a LogHelper class to simplify logging

Parameters
obj The target object to log for. This object type name will be used in the log
Returns
An instance of this helper
static LogHelper Deltares.Standard.Application.LogHelper.Create ( Type type )
static

Creates a LogHelper to simplify logging.

Parameters
type The target type to log for.
Returns
An instance of this helper
static LogHelper Deltares.Standard.Application.LogHelper.Create ( string name )
static

Creates a LogHelper class to simplify logging

Parameters
name The name.
Returns
static LogHelper Deltares.Standard.Application.LogHelper.Create< T > ( )
static

Creates a LogHelper class to simplify logging

Template Parameters
T The target type to log for.
Returns
An instance of this helper
void Deltares.Standard.Application.LogHelper.Flush ( )

Flushes all appenders across the whole logging repository

This call is in most cases not needed

void Deltares.Standard.Application.LogHelper.LogDebug | ( | string | message,
 |  | Exception | exception = null
 | ) |  |

Logs debug messages if ALL or DEBUG is enabled in the config.

Parameters
message | The message.
exception | The exception.
void Deltares.Standard.Application.LogHelper.LogError | ( | string | message,
 |  | Exception | exception = null
 | ) |  |

Logs error messages if ALL, DEBUG, INFO, WARN or ERROR level is enabled in the config.

Parameters
message | The message.
exception | The exception.
void Deltares.Standard.Application.LogHelper.LogFatal | ( | string | message,
 |  | Exception | exception = null
 | ) |  |

Logs fatal messages if ALL, DEBUG, INFO, WARN, ERROR or FATAL is enabled in the config.

Parameters
message | The message.
exception | The exception.
void Deltares.Standard.Application.LogHelper.LogInfo | ( | string | message,
 |  | Exception | exception = null
 | ) |  |

Logs info messages if ALL, DEBUG or INFO is enabled in the config.

Parameters
message | The message.
exception | The exception.
void Deltares.Standard.Application.LogHelper.LogWarning | ( | string | message,
 |  | Exception | exception = null
 | ) |  |

Logs warning messages if ALL, DEBUG, INFO or WARN level is enabled in the config.

Parameters
message | The message.
exception | The exception.

Property Documentation

bool Deltares.Standard.Application.LogHelper.HasLoggedExceptions
get

Gets a value indicating whether this instance has logged exceptions.

true if this instance has logged exceptions; otherwise, false.

Generated on Tue Dec 15 2015 18:14:26 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Application
  • LogHelper
Deltares.Standard.Application.LogHelper Member List

This is the complete list of members for Deltares.Standard.Application.LogHelper, including all inherited members.

Clear() | Deltares.Standard.Application.LogHelper |
Create(object obj) | Deltares.Standard.Application.LogHelper | static
Create(Type type) | Deltares.Standard.Application.LogHelper | static
Create(string name) | Deltares.Standard.Application.LogHelper | static
Create< T >() | Deltares.Standard.Application.LogHelper | static
Flush() | Deltares.Standard.Application.LogHelper |
HasLoggedExceptions | Deltares.Standard.Application.LogHelper |
LogDebug(string message, Exception exception=null) | Deltares.Standard.Application.LogHelper |
LogError(string message, Exception exception=null) | Deltares.Standard.Application.LogHelper |
LogFatal(string message, Exception exception=null) | Deltares.Standard.Application.LogHelper |
LogHelper(ILog logger) (defined in Deltares.Standard.Application.LogHelper) | Deltares.Standard.Application.LogHelper |
LogInfo(string message, Exception exception=null) | Deltares.Standard.Application.LogHelper |
LogWarning(string message, Exception exception=null) | Deltares.Standard.Application.LogHelper |
Generated on Tue Dec 15 2015 18:14:26 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Application.ProgramBase Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Application
  • ProgramBase
Public Member Functions | Protected Member Functions | Protected Attributes | Properties | List of all members
Deltares.Standard.Application.ProgramBase Class Reference
Inheritance diagram for Deltares.Standard.Application.ProgramBase:

Public Member Functions

void | SetSplashImageFromManifestResourceStream (Assembly resourceAssembly, string resourceName)
Sets the splash image from manifest resource stream. More...
void | SetIconFromManifestResourceStream (Assembly resourceAssembly, string resourceName)
Sets the icon from manifest resource stream. More...

Protected Member Functions

void | RegisterPlugin (IMainFormPlugin plugin)
Registers the plugins when the application (main form) initializes. More...
virtual void | Start ()
Starts the application main form. More...
virtual void | Initialize ()
Initializes the app. More...
void | RunInDebugMode ()
Runs the app in debug mode. More...
void | RunInReleaseMode ()
Runs the app in release mode. More...

Protected Attributes

bool IsReleaseVersion = false

Properties

string | BetaString [get, set]
string | LicenseType [get]
Image | SplashImage [set]
Sets the splash image. More...
Icon | Icon [set]
Sets the icon. More...

Member Function Documentation

virtual void Deltares.Standard.Application.ProgramBase.Initialize ( )
protectedvirtual

Initializes the app.

void Deltares.Standard.Application.ProgramBase.RegisterPlugin ( IMainFormPlugin plugin )
protected

Registers the plugins when the application (main form) initializes.

Parameters
plugin The plugin.
void Deltares.Standard.Application.ProgramBase.RunInDebugMode ( )
protected

Runs the app in debug mode.

void Deltares.Standard.Application.ProgramBase.RunInReleaseMode ( )
protected

Runs the app in release mode.

void Deltares.Standard.Application.ProgramBase.SetIconFromManifestResourceStream | ( | Assembly | resourceAssembly,
 |  | string | resourceName
 | ) |  |

Sets the icon from manifest resource stream.

Parameters
resourceAssembly
resourceName The name.
void Deltares.Standard.Application.ProgramBase.SetSplashImageFromManifestResourceStream | ( | Assembly | resourceAssembly,
 |  | string | resourceName
 | ) |  |

Sets the splash image from manifest resource stream.

Parameters
resourceAssembly
resourceName The name.
virtual void Deltares.Standard.Application.ProgramBase.Start ( )
protectedvirtual

Starts the application main form.

References Deltares.Standard.Forms.DExpress.MainForm.SplashDialog.

Property Documentation

Icon Deltares.Standard.Application.ProgramBase.Icon
setpackage

Sets the icon.

The icon.

Image Deltares.Standard.Application.ProgramBase.SplashImage
setpackage

Sets the splash image.

The splash image.

Generated on Tue Dec 15 2015 18:14:27 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Application
  • ProgramBase
Deltares.Standard.Application.ProgramBase Member List

This is the complete list of members for Deltares.Standard.Application.ProgramBase, including all inherited members.

BetaString (defined in Deltares.Standard.Application.ProgramBase) | Deltares.Standard.Application.ProgramBase | protected
Icon | Deltares.Standard.Application.ProgramBase | package
Initialize() | Deltares.Standard.Application.ProgramBase | protectedvirtual
IsReleaseVersion (defined in Deltares.Standard.Application.ProgramBase) | Deltares.Standard.Application.ProgramBase | protected
LicenseType (defined in Deltares.Standard.Application.ProgramBase) | Deltares.Standard.Application.ProgramBase |
ProgramBase() (defined in Deltares.Standard.Application.ProgramBase) | Deltares.Standard.Application.ProgramBase | protected
RegisterPlugin(IMainFormPlugin plugin) | Deltares.Standard.Application.ProgramBase | protected
RunInDebugMode() | Deltares.Standard.Application.ProgramBase | protected
RunInReleaseMode() | Deltares.Standard.Application.ProgramBase | protected
SetIconFromManifestResourceStream(Assembly resourceAssembly, string resourceName) | Deltares.Standard.Application.ProgramBase |
SetSplashImageFromManifestResourceStream(Assembly resourceAssembly, string resourceName) | Deltares.Standard.Application.ProgramBase |
SplashImage | Deltares.Standard.Application.ProgramBase | package
Start() | Deltares.Standard.Application.ProgramBase | protectedvirtual
Generated on Tue Dec 15 2015 18:14:27 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.DotSpatialDgs.BackgroundFeature Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • DotSpatialDgs
  • BackgroundFeature
Properties | List of all members
Deltares.Standard.DotSpatialDgs.BackgroundFeature Class Reference
Inheritance diagram for Deltares.Standard.DotSpatialDgs.BackgroundFeature:

Properties

string | Attributes [get, set]
string | WKT [get, set]
Generated on Tue Dec 15 2015 18:14:27 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • DotSpatialDgs
  • BackgroundFeature
Deltares.Standard.DotSpatialDgs.BackgroundFeature Member List

This is the complete list of members for Deltares.Standard.DotSpatialDgs.BackgroundFeature, including all inherited members.

Attributes (defined in Deltares.Standard.DotSpatialDgs.BackgroundFeature) | Deltares.Standard.DotSpatialDgs.BackgroundFeature
WKT (defined in Deltares.Standard.DotSpatialDgs.BackgroundFeature) | Deltares.Standard.DotSpatialDgs.BackgroundFeature
Generated on Tue Dec 15 2015 18:14:27 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.DotSpatialDgs.BackgroundMap Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • DotSpatialDgs
  • BackgroundMap
Public Member Functions | Properties | List of all members
Deltares.Standard.DotSpatialDgs.BackgroundMap Class Reference

Public Member Functions

void | SaveToTable (DataTable dataTable)
void | LoadFromTable (DataTable dataTable)

Properties

string | Name [get, set]
string | Projection [get, set]
List< BackgroundFeature > | Features [get]
string | Columns [get, set]
string | ColumnTypes [get, set]
Generated on Tue Dec 15 2015 18:14:27 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • DotSpatialDgs
  • BackgroundMap
Deltares.Standard.DotSpatialDgs.BackgroundMap Member List

This is the complete list of members for Deltares.Standard.DotSpatialDgs.BackgroundMap, including all inherited members.

BackgroundMap() (defined in Deltares.Standard.DotSpatialDgs.BackgroundMap) | Deltares.Standard.DotSpatialDgs.BackgroundMap
Columns (defined in Deltares.Standard.DotSpatialDgs.BackgroundMap) | Deltares.Standard.DotSpatialDgs.BackgroundMap
ColumnTypes (defined in Deltares.Standard.DotSpatialDgs.BackgroundMap) | Deltares.Standard.DotSpatialDgs.BackgroundMap
Features (defined in Deltares.Standard.DotSpatialDgs.BackgroundMap) | Deltares.Standard.DotSpatialDgs.BackgroundMap
LoadFromTable(DataTable dataTable) (defined in Deltares.Standard.DotSpatialDgs.BackgroundMap) | Deltares.Standard.DotSpatialDgs.BackgroundMap
Name (defined in Deltares.Standard.DotSpatialDgs.BackgroundMap) | Deltares.Standard.DotSpatialDgs.BackgroundMap
Projection (defined in Deltares.Standard.DotSpatialDgs.BackgroundMap) | Deltares.Standard.DotSpatialDgs.BackgroundMap
SaveToTable(DataTable dataTable) (defined in Deltares.Standard.DotSpatialDgs.BackgroundMap) | Deltares.Standard.DotSpatialDgs.BackgroundMap
Generated on Tue Dec 15 2015 18:14:27 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.DotSpatialDgs.DotSpatialGeographicAlgorithms Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • DotSpatialDgs
  • DotSpatialGeographicAlgorithms
Static Public Member Functions | List of all members
Deltares.Standard.DotSpatialDgs.DotSpatialGeographicAlgorithms Class Reference

Static Public Member Functions

static IGeographic | Intersection (IGeographic geographic1, IGeographic geographic2)
Gets the intersected geographic if any. More...
static double | Distance (IGeographic geographic1, IGeographic geographic2)
Calculate the distance between two geographic objects (features) More...
static double | Distance (IWKT wktObject, IGeographic geographic2)
Calculate the distance between two geographic objects (features) More...
static IGeographicPoint | NearestPointOnGeographicString (this IGeographicString line, IGeographicPoint point)
Calculate the closest point on a LineString from given point More...
static bool | Intersects (this IGeographicPoint point, IGeographicPolygon polygon)
Determines whether the point intersects the specified polygon. More...
static double | LineStringLength (IGeographicString lineString)
Gets the length of the line string. More...
static double | LineStringLength (IFeature feature)
Gets the length of the line string. More...

Member Function Documentation

static double Deltares.Standard.DotSpatialDgs.DotSpatialGeographicAlgorithms.Distance | ( | IGeographic | geographic1,
 |  | IGeographic | geographic2
 | ) |  |
static

Calculate the distance between two geographic objects (features)

Parameters
geographic1 | The first geographic.
geographic2 | The second geographic.
Returns
static double Deltares.Standard.DotSpatialDgs.DotSpatialGeographicAlgorithms.Distance | ( | IWKT | wktObject,
 |  | IGeographic | geographic2
 | ) |  |
static

Calculate the distance between two geographic objects (features)

Parameters
geographic1 | The first geographic.
geographic2 | The second geographic.
Returns
static IGeographic Deltares.Standard.DotSpatialDgs.DotSpatialGeographicAlgorithms.Intersection | ( | IGeographic | geographic1,
 |  | IGeographic | geographic2
 | ) |  |
static

Gets the intersected geographic if any.

Parameters
geographic1 | The first geographic.
geographic2 | The second geographic.
Returns
A new geographic if an intersection is found, null otherwise
static bool Deltares.Standard.DotSpatialDgs.DotSpatialGeographicAlgorithms.Intersects | ( | this IGeographicPoint | point,
 |  | IGeographicPolygon | polygon
 | ) |  |
static

Determines whether the point intersects the specified polygon.

Parameters
point | The point.
polygon | The polygon.
Returns
True if the point is in the polygon, false otherwise
static double Deltares.Standard.DotSpatialDgs.DotSpatialGeographicAlgorithms.LineStringLength ( IGeographicString lineString )
static

Gets the length of the line string.

Parameters
lineString The geographic line string.
Returns
A double value
static double Deltares.Standard.DotSpatialDgs.DotSpatialGeographicAlgorithms.LineStringLength ( IFeature feature )
static

Gets the length of the line string.

Parameters
feature The feature.
Returns
A double value
static IGeographicPoint Deltares.Standard.DotSpatialDgs.DotSpatialGeographicAlgorithms.NearestPointOnGeographicString | ( | this IGeographicString | line,
 |  | IGeographicPoint | point
 | ) |  |
static

Calculate the closest point on a LineString from given point

Parameters
line | The line string.
point | The from-point.
Returns
Generated on Tue Dec 15 2015 18:14:27 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • DotSpatialDgs
  • DotSpatialGeographicAlgorithms
Deltares.Standard.DotSpatialDgs.DotSpatialGeographicAlgorithms Member List

This is the complete list of members for Deltares.Standard.DotSpatialDgs.DotSpatialGeographicAlgorithms, including all inherited members.

Distance(IGeographic geographic1, IGeographic geographic2) | Deltares.Standard.DotSpatialDgs.DotSpatialGeographicAlgorithms | static
Distance(IWKT wktObject, IGeographic geographic2) | Deltares.Standard.DotSpatialDgs.DotSpatialGeographicAlgorithms | static
Intersection(IGeographic geographic1, IGeographic geographic2) | Deltares.Standard.DotSpatialDgs.DotSpatialGeographicAlgorithms | static
Intersects(this IGeographicPoint point, IGeographicPolygon polygon) | Deltares.Standard.DotSpatialDgs.DotSpatialGeographicAlgorithms | static
LineStringLength(IGeographicString lineString) | Deltares.Standard.DotSpatialDgs.DotSpatialGeographicAlgorithms | static
LineStringLength(IFeature feature) | Deltares.Standard.DotSpatialDgs.DotSpatialGeographicAlgorithms | static
NearestPointOnGeographicString(this IGeographicString line, IGeographicPoint point) | Deltares.Standard.DotSpatialDgs.DotSpatialGeographicAlgorithms | static
Generated on Tue Dec 15 2015 18:14:27 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.DotSpatialDgs.DotSpatialGeographicConverter Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • DotSpatialDgs
  • DotSpatialGeographicConverter
Public Member Functions | List of all members
Deltares.Standard.DotSpatialDgs.DotSpatialGeographicConverter Class Reference

Public Member Functions

IFeature | ToFeature (IGeographic geographic)
Converts a geographic type to a DotSpatial feature (without attribute data). More...
string | ToWKT (IGeographic geographic)
Converts a geographic to a well known text (WKT) string More...
IGeographic | ToGeographic (string wkt)
Converts a well known text string (WKT) to a geographic type. More...
IFeature | ToFeature (string wkt)
Converts a well known text string (WKT) to a geographic type. More...
IGeographic | ToGeographic (IFeature feature)
Converts a DotSpatial feature to a specific geographic type (point, line, polygon etc.) More...
ILinearRing | ToLinearRing (IGeographicLoop loop)
Converts a geographic loop to a DotSpatial linear ring More...
IEnumerable< Coordinate > | ToCoordinates (IEnumerable< IGeographicPoint > geographicPoints)
Converts a geographic point collection to a DotSpatial coordinate list More...
IGeographicMultiString | ToGeographicMultiString (IMultiLineString multiLineString)
Toes the geographic multi string. More...
IGeographicString | ToGeographicString (ILineString lineString)
Toes the geographic string. More...
IGeographicString | ToGeographicString (IMultiPoint multiPoint)
Toes the geographic string. More...
IGeographicPoint | ToGeographicPoint (Coordinate coordinate)
Convert a coordinate to a geographic point More...
IGeographicPoint | ToGeographicPoint (IPoint point)
Convert a coordinate to a geographic point More...
IEnumerable< IGeographicPoint > | ToGeographicPoints (ILinearRing ring)
Converts a linear ring to a collection of points More...
IEnumerable< IGeographicPoint > | ToGeographicPoints (IEnumerable< Coordinate > coordinates)
Converts DotSpatial coordinates to a collection of geographical points. More...
IEnumerable< IGeographicPoint > | ToGeographicPoints (ILineString lineString)
Converts DotSpatial line string to a collection of geographical points. More...
IGeographicLoop | ToGeographicLoop (ILinearRing ring)
Converts DotSpatial line ring to a geographical loop IGeographicLoop More...
IGeographicPolygon | ToGeographicPolygon (IPolygon polygon)
Converts a DotSpatial polygon to a geographical polygon IGeographicPolygon More...
IGeographicPolygon | ToGeographicPolygon (IGeographicPolygon dest, IPolygon polygon)
Converts DotSpatial polygon to a geographical polygon IGeographicPolygon More...
IGeographicMultiPolygon | ToGeographicMultiPolygon (IGeographicFactory factory, IMultiPolygon multiPolygon)
Converts DotSpatial multi polygon to a geographical multi polygon IGeographicMultiPolygon More...
IGeographicMultiPolygon | ToGeographicMultiPolygon (IMultiPolygon multiPolygon)
Converts DotSpatial multi polygon to a geographical multi polygon IGeographicMultiPolygon More...
IGeographicMultiPolygon | ToGeographicMultiPolygon (IGeographicMultiPolygon dest, IMultiPolygon multiPolygon)
Converts a DotSpatial multi polygon goemetry to the geographic multi polygon. More...
IFeature | ToFeature (IGeographicPoint point)
Converts a geographic polygon to a DotSpatial feature. More...
IFeature | ToFeature (IGeographicPolygon geographic)
Converts a geographic polygon to a DotSpatial feature. More...
IFeature | ToFeature (IGeographicString geographic)
Converts a geographic string to a DotSpatial feature. More...

Member Function Documentation

IEnumerable<Coordinate> Deltares.Standard.DotSpatialDgs.DotSpatialGeographicConverter.ToCoordinates ( IEnumerable< IGeographicPoint > geographicPoints )

Converts a geographic point collection to a DotSpatial coordinate list

Parameters
geographicPoints The geographic points.
Returns
IFeature Deltares.Standard.DotSpatialDgs.DotSpatialGeographicConverter.ToFeature ( IGeographic geographic )

Converts a geographic type to a DotSpatial feature (without attribute data).

Parameters
geographic The geographic object to convert.
Returns
A DotSpatial feature (without attribute data)
IFeature Deltares.Standard.DotSpatialDgs.DotSpatialGeographicConverter.ToFeature ( string wkt )

Converts a well known text string (WKT) to a geographic type.

Parameters
wkt The WKT.
Returns
IFeature Deltares.Standard.DotSpatialDgs.DotSpatialGeographicConverter.ToFeature ( IGeographicPoint point )

Converts a geographic polygon to a DotSpatial feature.

Parameters
point The geographic to convert.
Returns
A feature instance
IFeature Deltares.Standard.DotSpatialDgs.DotSpatialGeographicConverter.ToFeature ( IGeographicPolygon geographic )

Converts a geographic polygon to a DotSpatial feature.

Parameters
geographic The geographic to convert.
Returns
A feature instance
IFeature Deltares.Standard.DotSpatialDgs.DotSpatialGeographicConverter.ToFeature ( IGeographicString geographic )

Converts a geographic string to a DotSpatial feature.

Parameters
geographic The geographic to convert.
Returns
A feature instance
IGeographic Deltares.Standard.DotSpatialDgs.DotSpatialGeographicConverter.ToGeographic ( string wkt )

Converts a well known text string (WKT) to a geographic type.

Parameters
wkt The WKT.
Returns
IGeographic Deltares.Standard.DotSpatialDgs.DotSpatialGeographicConverter.ToGeographic ( IFeature feature )

Converts a DotSpatial feature to a specific geographic type (point, line, polygon etc.)

Parameters
feature The feature to convert.
Returns
A specific (point, line, polygon etc.) geographic instance
IGeographicLoop Deltares.Standard.DotSpatialDgs.DotSpatialGeographicConverter.ToGeographicLoop ( ILinearRing ring )

Converts DotSpatial line ring to a geographical loop IGeographicLoop

Parameters
ring The ring to convert.
Returns
A new instance of a GeographicLoop
IGeographicMultiPolygon Deltares.Standard.DotSpatialDgs.DotSpatialGeographicConverter.ToGeographicMultiPolygon | ( | IGeographicFactory | factory,
 |  | IMultiPolygon | multiPolygon
 | ) |  |

Converts DotSpatial multi polygon to a geographical multi polygon IGeographicMultiPolygon

Parameters
factory | The factory to create the multi polygon with.
multiPolygon | The multi polygon to convert.
Returns
An instance of a type that implements IGeographicMultiPolygon
IGeographicMultiPolygon Deltares.Standard.DotSpatialDgs.DotSpatialGeographicConverter.ToGeographicMultiPolygon ( IMultiPolygon multiPolygon )

Converts DotSpatial multi polygon to a geographical multi polygon IGeographicMultiPolygon

Parameters
multiPolygon The multi polygon to convert.
Returns
A GeographicMultiPolygon instance
IGeographicMultiPolygon Deltares.Standard.DotSpatialDgs.DotSpatialGeographicConverter.ToGeographicMultiPolygon | ( | IGeographicMultiPolygon | dest,
 |  | IMultiPolygon | multiPolygon
 | ) |  |

Converts a DotSpatial multi polygon goemetry to the geographic multi polygon.

Parameters
dest | The destination or target that will get the converted geometry.
multiPolygon | The multi polygon to convert.
Returns
An instance of IGeographicMultiPolygon
IGeographicMultiString Deltares.Standard.DotSpatialDgs.DotSpatialGeographicConverter.ToGeographicMultiString ( IMultiLineString multiLineString )

Toes the geographic multi string.

Parameters
multiLineString The multi line string.
Returns
IGeographicPoint Deltares.Standard.DotSpatialDgs.DotSpatialGeographicConverter.ToGeographicPoint ( Coordinate coordinate )

Convert a coordinate to a geographic point

Parameters
coordinate The coordinate to convert.
Returns
An instance of IGeographicPoint
IGeographicPoint Deltares.Standard.DotSpatialDgs.DotSpatialGeographicConverter.ToGeographicPoint ( IPoint point )

Convert a coordinate to a geographic point

Parameters
point The point to convert.
Returns
An instance of IGeographicPoint
IEnumerable<IGeographicPoint> Deltares.Standard.DotSpatialDgs.DotSpatialGeographicConverter.ToGeographicPoints ( ILinearRing ring )

Converts a linear ring to a collection of points

Parameters
ring The ring to convert.
Returns
A collection of geographical points
IEnumerable<IGeographicPoint> Deltares.Standard.DotSpatialDgs.DotSpatialGeographicConverter.ToGeographicPoints ( IEnumerable< Coordinate > coordinates )

Converts DotSpatial coordinates to a collection of geographical points.

Parameters
coordinates The DotSpatial coordinates.
Returns
A collection of geographical points
IEnumerable<IGeographicPoint> Deltares.Standard.DotSpatialDgs.DotSpatialGeographicConverter.ToGeographicPoints ( ILineString lineString )

Converts DotSpatial line string to a collection of geographical points.

Parameters
lineString The DotSpatial line string to convert.
Returns
A collection of geographical points
IGeographicPolygon Deltares.Standard.DotSpatialDgs.DotSpatialGeographicConverter.ToGeographicPolygon ( IPolygon polygon )

Converts a DotSpatial polygon to a geographical polygon IGeographicPolygon

Parameters
polygon The polygon.
Returns
A new instance of geographical polygon
IGeographicPolygon Deltares.Standard.DotSpatialDgs.DotSpatialGeographicConverter.ToGeographicPolygon | ( | IGeographicPolygon | dest,
 |  | IPolygon | polygon
 | ) |  |

Converts DotSpatial polygon to a geographical polygon IGeographicPolygon

Parameters
dest | An existing polygon to write the converted geometry to
polygon | The polygon.

The existing geometry data will be reset by the converted geometry data

Returns
An existing instance of IGeographicPolygon with the converted geographical polygon data
IGeographicString Deltares.Standard.DotSpatialDgs.DotSpatialGeographicConverter.ToGeographicString ( ILineString lineString )

Toes the geographic string.

Parameters
lineString The line string.
Returns
IGeographicString Deltares.Standard.DotSpatialDgs.DotSpatialGeographicConverter.ToGeographicString ( IMultiPoint multiPoint )

Toes the geographic string.

Parameters
lineString The line string.
Returns
ILinearRing Deltares.Standard.DotSpatialDgs.DotSpatialGeographicConverter.ToLinearRing ( IGeographicLoop loop )

Converts a geographic loop to a DotSpatial linear ring

Parameters
loop The loop to convert.
Returns
A linear ring instance
string Deltares.Standard.DotSpatialDgs.DotSpatialGeographicConverter.ToWKT ( IGeographic geographic )

Converts a geographic to a well known text (WKT) string

Parameters
geographic The geographic to convert.
Returns
The WKT string
Generated on Tue Dec 15 2015 18:14:27 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • DotSpatialDgs
  • DotSpatialGeographicConverter
Deltares.Standard.DotSpatialDgs.DotSpatialGeographicConverter Member List

This is the complete list of members for Deltares.Standard.DotSpatialDgs.DotSpatialGeographicConverter, including all inherited members.

ToCoordinates(IEnumerable< IGeographicPoint > geographicPoints) | Deltares.Standard.DotSpatialDgs.DotSpatialGeographicConverter
ToFeature(IGeographic geographic) | Deltares.Standard.DotSpatialDgs.DotSpatialGeographicConverter
ToFeature(string wkt) | Deltares.Standard.DotSpatialDgs.DotSpatialGeographicConverter
ToFeature(IGeographicPoint point) | Deltares.Standard.DotSpatialDgs.DotSpatialGeographicConverter
ToFeature(IGeographicPolygon geographic) | Deltares.Standard.DotSpatialDgs.DotSpatialGeographicConverter
ToFeature(IGeographicString geographic) | Deltares.Standard.DotSpatialDgs.DotSpatialGeographicConverter
ToGeographic(string wkt) | Deltares.Standard.DotSpatialDgs.DotSpatialGeographicConverter
ToGeographic(IFeature feature) | Deltares.Standard.DotSpatialDgs.DotSpatialGeographicConverter
ToGeographicLoop(ILinearRing ring) | Deltares.Standard.DotSpatialDgs.DotSpatialGeographicConverter
ToGeographicMultiPolygon(IGeographicFactory factory, IMultiPolygon multiPolygon) | Deltares.Standard.DotSpatialDgs.DotSpatialGeographicConverter
ToGeographicMultiPolygon(IMultiPolygon multiPolygon) | Deltares.Standard.DotSpatialDgs.DotSpatialGeographicConverter
ToGeographicMultiPolygon(IGeographicMultiPolygon dest, IMultiPolygon multiPolygon) | Deltares.Standard.DotSpatialDgs.DotSpatialGeographicConverter
ToGeographicMultiString(IMultiLineString multiLineString) | Deltares.Standard.DotSpatialDgs.DotSpatialGeographicConverter
ToGeographicPoint(Coordinate coordinate) | Deltares.Standard.DotSpatialDgs.DotSpatialGeographicConverter
ToGeographicPoint(IPoint point) | Deltares.Standard.DotSpatialDgs.DotSpatialGeographicConverter
ToGeographicPoints(ILinearRing ring) | Deltares.Standard.DotSpatialDgs.DotSpatialGeographicConverter
ToGeographicPoints(IEnumerable< Coordinate > coordinates) | Deltares.Standard.DotSpatialDgs.DotSpatialGeographicConverter
ToGeographicPoints(ILineString lineString) | Deltares.Standard.DotSpatialDgs.DotSpatialGeographicConverter
ToGeographicPolygon(IPolygon polygon) | Deltares.Standard.DotSpatialDgs.DotSpatialGeographicConverter
ToGeographicPolygon(IGeographicPolygon dest, IPolygon polygon) | Deltares.Standard.DotSpatialDgs.DotSpatialGeographicConverter
ToGeographicString(ILineString lineString) | Deltares.Standard.DotSpatialDgs.DotSpatialGeographicConverter
ToGeographicString(IMultiPoint multiPoint) | Deltares.Standard.DotSpatialDgs.DotSpatialGeographicConverter
ToLinearRing(IGeographicLoop loop) | Deltares.Standard.DotSpatialDgs.DotSpatialGeographicConverter
ToWKT(IGeographic geographic) | Deltares.Standard.DotSpatialDgs.DotSpatialGeographicConverter
Generated on Tue Dec 15 2015 18:14:27 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.DotSpatialDgs.DotSpatialGeographicHelper Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • DotSpatialDgs
  • DotSpatialGeographicHelper
Public Member Functions | List of all members
Deltares.Standard.DotSpatialDgs.DotSpatialGeographicHelper Class Reference
Inheritance diagram for Deltares.Standard.DotSpatialDgs.DotSpatialGeographicHelper:

Public Member Functions

double | GetOffsetOnGeographicLineString (IGeographicPoint point, IGeographicString line)
Gets the offset for point on line . If point is not on the line or the line contains too few (< 2) points, this method will return a -1 to indicate that no offset could be determined for given point and line . More...
IGeographicPoint | FindGeographicPointByOffsetOnLine (double offset, IGeographicString line)
IList< IGeographicPoint > | GetPointsBetweenOffsets (double beginOffset, double endOffset, IGeographicString line)
double | GetLineStringLength (IGeographicString line)
IGeographicString | GetNearestGeographicString (IGeographicPoint geographicPoint, List< IGeographicString > geographicStrings)
Get nearest IGeographicString, by using search parameter IGeographicPoint. Find KD-tree node whose key is nearest neighbor to key. Implements the Nearest Neighbor algorithm Only unique IGeographicStrings and IGeographicPoint are alowed in the tree the tree object is Tuple GeographicPoint, IGeographicString, return value IGeographicString More...
IGeographicPoint | GetNearestCoordinatesOnGeographicString (IGeographicString geographicString, double lookupX, double lookupY)
IGeographicString | GetNearestString (IGeographicString targetString, List< IGeographicString > sourceStrings)
IGeographic | GetIntersection (IList< IGeographicPoint > geo1, IList< IGeographicPoint > geo2)
IGeographicPoint | Intersection (IGeographicString string1, IGeographic string2)
double | GetDistanceToNearestPointOnWkt (string wkTstring, IGeographicPoint point, double tolerance)

Member Function Documentation

IGeographicString Deltares.Standard.DotSpatialDgs.DotSpatialGeographicHelper.GetNearestGeographicString | ( | IGeographicPoint | geographicPoint,
 |  | List< IGeographicString > | geographicStrings
 | ) |  |

Get nearest IGeographicString, by using search parameter IGeographicPoint. Find KD-tree node whose key is nearest neighbor to key. Implements the Nearest Neighbor algorithm Only unique IGeographicStrings and IGeographicPoint are alowed in the tree the tree object is Tuple GeographicPoint, IGeographicString, return value IGeographicString

Parameters
geographicPoint
geographicStrings
Returns
double Deltares.Standard.DotSpatialDgs.DotSpatialGeographicHelper.GetOffsetOnGeographicLineString | ( | IGeographicPoint | point,
 |  | IGeographicString | line
 | ) |  |

Gets the offset for point on line . If point is not on the line or the line contains too few (< 2) points, this method will return a -1 to indicate that no offset could be determined for given point and line .

Parameters
point | The IGeographicPoint to determine the offset for on the line
line | The IGeographicString on which the point should be.
Returns
The offset of the point on the line, or -1 if the point could not be found on the line.
Generated on Tue Dec 15 2015 18:14:27 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • DotSpatialDgs
  • DotSpatialGeographicHelper
Deltares.Standard.DotSpatialDgs.DotSpatialGeographicHelper Member List

This is the complete list of members for Deltares.Standard.DotSpatialDgs.DotSpatialGeographicHelper, including all inherited members.

FindGeographicPointByOffsetOnLine(double offset, IGeographicString line) (defined in Deltares.Standard.DotSpatialDgs.DotSpatialGeographicHelper) | Deltares.Standard.DotSpatialDgs.DotSpatialGeographicHelper
GetDistanceToNearestPointOnWkt(string wkTstring, IGeographicPoint point, double tolerance) (defined in Deltares.Standard.DotSpatialDgs.DotSpatialGeographicHelper) | Deltares.Standard.DotSpatialDgs.DotSpatialGeographicHelper
GetIntersection(IList< IGeographicPoint > geo1, IList< IGeographicPoint > geo2) (defined in Deltares.Standard.DotSpatialDgs.DotSpatialGeographicHelper) | Deltares.Standard.DotSpatialDgs.DotSpatialGeographicHelper
GetLineStringLength(IGeographicString line) (defined in Deltares.Standard.DotSpatialDgs.DotSpatialGeographicHelper) | Deltares.Standard.DotSpatialDgs.DotSpatialGeographicHelper
GetNearestCoordinatesOnGeographicString(IGeographicString geographicString, double lookupX, double lookupY) (defined in Deltares.Standard.DotSpatialDgs.DotSpatialGeographicHelper) | Deltares.Standard.DotSpatialDgs.DotSpatialGeographicHelper
GetNearestGeographicString(IGeographicPoint geographicPoint, List< IGeographicString > geographicStrings) | Deltares.Standard.DotSpatialDgs.DotSpatialGeographicHelper
GetNearestString(IGeographicString targetString, List< IGeographicString > sourceStrings) (defined in Deltares.Standard.DotSpatialDgs.DotSpatialGeographicHelper) | Deltares.Standard.DotSpatialDgs.DotSpatialGeographicHelper
GetOffsetOnGeographicLineString(IGeographicPoint point, IGeographicString line) | Deltares.Standard.DotSpatialDgs.DotSpatialGeographicHelper
GetPointsBetweenOffsets(double beginOffset, double endOffset, IGeographicString line) (defined in Deltares.Standard.DotSpatialDgs.DotSpatialGeographicHelper) | Deltares.Standard.DotSpatialDgs.DotSpatialGeographicHelper
Intersection(IGeographicString string1, IGeographic string2) (defined in Deltares.Standard.DotSpatialDgs.DotSpatialGeographicHelper) | Deltares.Standard.DotSpatialDgs.DotSpatialGeographicHelper
Generated on Tue Dec 15 2015 18:14:27 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.DotSpatialDgs.DotSpatialUtil Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • DotSpatialDgs
  • DotSpatialUtil
Static Public Member Functions | List of all members
Deltares.Standard.DotSpatialDgs.DotSpatialUtil Class Reference

Static Public Member Functions

static IGeographicPoint | Intersection (IGeographicString geometryPointString, IGeographic geographic)
Gets the intersected GeometryPoint if any works on Deltares.Geometry domain (GeometryObject) More...
static ProjectionInfo | GetShapeFileProjection (string fileName)
Get the Projection for a ESRI shapefile (*.shp/*.prj) More...

Member Function Documentation

static ProjectionInfo Deltares.Standard.DotSpatialDgs.DotSpatialUtil.GetShapeFileProjection ( string fileName )
static

Get the Projection for a ESRI shapefile (*.shp/*.prj)

Parameters
fileName
Returns
static IGeographicPoint Deltares.Standard.DotSpatialDgs.DotSpatialUtil.Intersection | ( | IGeographicString | geometryPointString,
 |  | IGeographic | geographic
 | ) |  |
static

Gets the intersected GeometryPoint if any works on Deltares.Geometry domain (GeometryObject)

Parameters
geometryPointString
geographic
Returns
Generated on Tue Dec 15 2015 18:14:27 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • DotSpatialDgs
  • DotSpatialUtil
Deltares.Standard.DotSpatialDgs.DotSpatialUtil Member List

This is the complete list of members for Deltares.Standard.DotSpatialDgs.DotSpatialUtil, including all inherited members.

GetShapeFileProjection(string fileName) | Deltares.Standard.DotSpatialDgs.DotSpatialUtil | static
Intersection(IGeographicString geometryPointString, IGeographic geographic) | Deltares.Standard.DotSpatialDgs.DotSpatialUtil | static
Generated on Tue Dec 15 2015 18:14:27 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.DotSpatialDgs.FeatureSupport Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • DotSpatialDgs
  • FeatureSupport
Static Public Member Functions | List of all members
Deltares.Standard.DotSpatialDgs.FeatureSupport Class Reference

Static Public Member Functions

static string | GetWKT (IFeature feature)
static IFeature | GetFeature (string wkt)
static BackgroundMap | GetBackgroundMap (string fileName)

Member Function Documentation

static BackgroundMap Deltares.Standard.DotSpatialDgs.FeatureSupport.GetBackgroundMap ( string fileName )
static

!! this line is necessary otherwise the code doesn't work

Generated on Tue Dec 15 2015 18:14:27 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • DotSpatialDgs
  • FeatureSupport
Deltares.Standard.DotSpatialDgs.FeatureSupport Member List

This is the complete list of members for Deltares.Standard.DotSpatialDgs.FeatureSupport, including all inherited members.

GetBackgroundMap(string fileName) | Deltares.Standard.DotSpatialDgs.FeatureSupport | static
GetFeature(string wkt) (defined in Deltares.Standard.DotSpatialDgs.FeatureSupport) | Deltares.Standard.DotSpatialDgs.FeatureSupport | static
GetWKT(IFeature feature) (defined in Deltares.Standard.DotSpatialDgs.FeatureSupport) | Deltares.Standard.DotSpatialDgs.FeatureSupport | static
Generated on Tue Dec 15 2015 18:14:27 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.DotSpatialDgs.IGeographicFactory Interface Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • DotSpatialDgs
  • IGeographicFactory
Public Member Functions | List of all members
Deltares.Standard.DotSpatialDgs.IGeographicFactory Interface Reference

Public Member Functions

IGeographicMultiPolygon | CreateMultiPolygon ()
IGeographicPolygon | CreatePolygon ()
IGeographicString | CreateLine ()
IGeographicMultiString | CreateMultiLine ()
IGeographicLoop | CreateLoop ()
IGeographicPoint | CreatePoint ()
Generated on Tue Dec 15 2015 18:14:27 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • DotSpatialDgs
  • IGeographicFactory
Deltares.Standard.DotSpatialDgs.IGeographicFactory Member List

This is the complete list of members for Deltares.Standard.DotSpatialDgs.IGeographicFactory, including all inherited members.

CreateLine() (defined in Deltares.Standard.DotSpatialDgs.IGeographicFactory) | Deltares.Standard.DotSpatialDgs.IGeographicFactory
CreateLoop() (defined in Deltares.Standard.DotSpatialDgs.IGeographicFactory) | Deltares.Standard.DotSpatialDgs.IGeographicFactory
CreateMultiLine() (defined in Deltares.Standard.DotSpatialDgs.IGeographicFactory) | Deltares.Standard.DotSpatialDgs.IGeographicFactory
CreateMultiPolygon() (defined in Deltares.Standard.DotSpatialDgs.IGeographicFactory) | Deltares.Standard.DotSpatialDgs.IGeographicFactory
CreatePoint() (defined in Deltares.Standard.DotSpatialDgs.IGeographicFactory) | Deltares.Standard.DotSpatialDgs.IGeographicFactory
CreatePolygon() (defined in Deltares.Standard.DotSpatialDgs.IGeographicFactory) | Deltares.Standard.DotSpatialDgs.IGeographicFactory
Generated on Tue Dec 15 2015 18:14:27 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.DotSpatialDgs.IHasRaster Interface Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • DotSpatialDgs
  • IHasRaster
Properties | List of all members
Deltares.Standard.DotSpatialDgs.IHasRaster Interface Reference

Properties

string | Raster [get, set]
string | RasterType [get]
string | RasterDataType [get]
string | RasterId [get]
Generated on Tue Dec 15 2015 18:14:27 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • DotSpatialDgs
  • IHasRaster
Deltares.Standard.DotSpatialDgs.IHasRaster Member List

This is the complete list of members for Deltares.Standard.DotSpatialDgs.IHasRaster, including all inherited members.

Raster (defined in Deltares.Standard.DotSpatialDgs.IHasRaster) | Deltares.Standard.DotSpatialDgs.IHasRaster
RasterDataType (defined in Deltares.Standard.DotSpatialDgs.IHasRaster) | Deltares.Standard.DotSpatialDgs.IHasRaster
RasterId (defined in Deltares.Standard.DotSpatialDgs.IHasRaster) | Deltares.Standard.DotSpatialDgs.IHasRaster
RasterType (defined in Deltares.Standard.DotSpatialDgs.IHasRaster) | Deltares.Standard.DotSpatialDgs.IHasRaster
Generated on Tue Dec 15 2015 18:14:27 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.DotSpatialDgs.MapProjectionManager Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • DotSpatialDgs
  • MapProjectionManager
Public Member Functions | Properties | List of all members
Deltares.Standard.DotSpatialDgs.MapProjectionManager Class Reference

Class for managing the map projections. Add a mapping of the internally used map projections definition (an enumeration) to the map projection definition of the mapping component in use in methode "InitializeMappings()". More...

Public Member Functions

ProjectionInfo | GetActiveMapProjectionAsDotSpatial ()
Gets the active map projection as dot spatial object. More...
void | SetActiveMapProjection (MapProjection mapProjection)
Sets the active map projection. More...
void | SetActiveMapProjectionAsDotSpatial (ProjectionInfo mapProjection)
Sets the active map projection as dot spatial object. More...
ProjectionInfo | GetMapProjectionAsDotSpatial (MapProjection mapProjection)
Gets the map projection as dot spatial. More...

Properties

static MapProjectionManager Instance [get]
Method to access the Singleton More...

Detailed Description

Class for managing the map projections. Add a mapping of the internally used map projections definition (an enumeration) to the map projection definition of the mapping component in use in methode "InitializeMappings()".

Member Function Documentation

ProjectionInfo Deltares.Standard.DotSpatialDgs.MapProjectionManager.GetActiveMapProjectionAsDotSpatial ( )

Gets the active map projection as dot spatial object.

Returns

Referenced by Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool.GetSnapObject(), and Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool.GetWorldPoint().

ProjectionInfo Deltares.Standard.DotSpatialDgs.MapProjectionManager.GetMapProjectionAsDotSpatial ( MapProjection mapProjection )

Gets the map projection as dot spatial.

Parameters
mapProjection The map projection.
Returns
void Deltares.Standard.DotSpatialDgs.MapProjectionManager.SetActiveMapProjection ( MapProjection mapProjection )

Sets the active map projection.

Parameters
mapProjection The map projection.
void Deltares.Standard.DotSpatialDgs.MapProjectionManager.SetActiveMapProjectionAsDotSpatial ( ProjectionInfo mapProjection )

Sets the active map projection as dot spatial object.

Parameters
mapProjection The map projection.

Property Documentation

MapProjectionManager Deltares.Standard.DotSpatialDgs.MapProjectionManager.Instance
staticget

Method to access the Singleton

Referenced by Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool.GetSnapObject(), and Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool.GetWorldPoint().

Generated on Tue Dec 15 2015 18:14:27 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • DotSpatialDgs
  • MapProjectionManager
Deltares.Standard.DotSpatialDgs.MapProjectionManager Member List

This is the complete list of members for Deltares.Standard.DotSpatialDgs.MapProjectionManager, including all inherited members.

GetActiveMapProjectionAsDotSpatial() | Deltares.Standard.DotSpatialDgs.MapProjectionManager |
GetMapProjectionAsDotSpatial(MapProjection mapProjection) | Deltares.Standard.DotSpatialDgs.MapProjectionManager |
Instance | Deltares.Standard.DotSpatialDgs.MapProjectionManager | static
SetActiveMapProjection(MapProjection mapProjection) | Deltares.Standard.DotSpatialDgs.MapProjectionManager |
SetActiveMapProjectionAsDotSpatial(ProjectionInfo mapProjection) | Deltares.Standard.DotSpatialDgs.MapProjectionManager |
Generated on Tue Dec 15 2015 18:14:27 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.DotSpatialDgs.MapProjectionManagerException Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • DotSpatialDgs
  • MapProjectionManagerException
Public Member Functions | List of all members
Deltares.Standard.DotSpatialDgs.MapProjectionManagerException Class Reference

Exception class for MapProjectionManager More...

Inheritance diagram for Deltares.Standard.DotSpatialDgs.MapProjectionManagerException:

Public Member Functions

MapProjectionManagerException (string message)

Detailed Description

Exception class for MapProjectionManager

Generated on Tue Dec 15 2015 18:14:28 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • DotSpatialDgs
  • MapProjectionManagerException
Deltares.Standard.DotSpatialDgs.MapProjectionManagerException Member List

This is the complete list of members for Deltares.Standard.DotSpatialDgs.MapProjectionManagerException, including all inherited members.

MapProjectionManagerException(string message) (defined in Deltares.Standard.DotSpatialDgs.MapProjectionManagerException) Deltares.Standard.DotSpatialDgs.MapProjectionManagerException
Generated on Tue Dec 15 2015 18:14:28 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.ComponentWrappers.GaugeControlBinding Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • ComponentWrappers
  • GaugeControlBinding
Public Member Functions | Protected Member Functions | Properties | List of all members
Deltares.Standard.Forms.DExpress.ComponentWrappers.GaugeControlBinding Class Reference

Binding for the parent of StateIndicatorGaugeBinding. More...

Inheritance diagram for Deltares.Standard.Forms.DExpress.ComponentWrappers.GaugeControlBinding:
Deltares.Standard.Forms.DExpress.BaseControlBinding Deltares.Standard.Forms.DExpress.ControlBinding Deltares.Standard.Forms.DExpress.ComponentBinding Deltares.Standard.Forms.DExpress.ComponentWrappers.IGetBoundControl

Public Member Functions

GaugeControlBinding (Component component)
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.BaseControlBinding
override void | Initialize (BindPropertyInfo propertyInfo, params string[] properties)
override void | SetLabel (string text)
override void | SetDescription (string description)
override void | Invalidate ()
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.ControlBinding
override void | SetVisible (bool visible)
override void | SetEnabled (bool enabled)
override void | SetLabel (string text)
Sets the label/title/name associated with this control. More...
override void | SetDescription (string description)
Sets the textual description associated with this control. More...
override void | SetForegroundColor (Color color)
override void | SetBackgroundColor (Color color)
override void | Invalidate ()
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
ComponentBinding (Component component)
virtual void | Initialize (BindPropertyInfo propertyInfo, Type rootObjectType, params string[] properties)
virtual void | SetTrueMapping (object trueMapping)
virtual void | SetValue (object value)
virtual void | SetValue (object value, object parent)
virtual void | SetDomain (ICollection collection)
virtual object | GetValue ()
virtual void | Refresh ()
virtual void | RegisterSelectionAssignment (Component targetComponent, IConverter converter=null)
Indicates that the selection of the bound control must be assigned to another control. More...
virtual void | SetControlColors (Color fore, Color back)
Sets the controls foreground and background colors. Can be overridden by a specific binding to set other colors if necessary. More...

Protected Member Functions

override void | Dispose (bool disposing)
Clean up any resources being used. More...
- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.BaseControlBinding
BaseControlBinding (Component component)
DXPopupMenu | GetPopupMenu ()
This method uses reflection to make the context menu accessible, which otherwise is protected. The Menu property is implemented for TextEdit, so we first make sure the control is actually of this type. More...
override void | OnToolTipShown (PopupEventArgs e)
Called when Tooltip is shown, and fires ToolTipShown event. More...
override void | OnToolTipClosed ()
Called when Tooltip is hidden, and fires ToolTipHidden. More...
override void | Dispose (bool disposing)
- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.ControlBinding
ControlBinding (Component component)
void | ThreadSafeRefresh ()
override void | Dispose (bool disposing)
- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
void | RaiseValueChanged ()
void | RaiseLeave ()
void | RaiseActionPerformed ()
Type | GetGenericType (Type type)
string | ValueToString (object value)
bool | IsAssociatedPropertyVisible (object source, BindPropertyInfo associatedPropertyInfo)
Indicates whether the associated property (i.e. the property which is used to display the original property in a textbox) is visible More...
void | EditFileInfo (object source, BindPropertyInfo propertyInfo)
string | EditFileInfo (string value, string format, string label, string description, bool isDirectory)
string | GetDoubleString (string text)
bool | HasValidNumericValue (string text)
double | GetNumericValue (string text)
List< BindPropertyInfo > | GetDictionaryProperties (ICollection domain, BindPropertyInfo dynamicPropertyInfo)

Properties

override bool | IsTransparant [get]
- Properties inherited from Deltares.Standard.Forms.DExpress.ControlBinding
ToolTip | Tooltip [get]
Gets the tooltip for the bound control. More...
Control | BoundControl [get]
- Properties inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
Component | Component [get]
virtual bool | IsTransparant [get]
virtual HandleType | HandleDelayed [get]
virtual bool | HasDomain [get]
- Properties inherited from Deltares.Standard.Forms.DExpress.ComponentWrappers.IGetBoundControl
Control | BoundControl [get]

Additional Inherited Members

- Protected Attributes inherited from Deltares.Standard.Forms.DExpress.BaseControlBinding
readonly SuperToolTip | superTip
- Protected Attributes inherited from Deltares.Standard.Forms.DExpress.ControlBinding
readonly ToolTip | tooltip
string | Description
The textual description associated with this

See also
Control

. More...

string | Label
The label/title/name associated with this Control. More...
- Protected Attributes inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
BindPropertyInfo | propInfo
- Events inherited from Deltares.Standard.Forms.DExpress.ControlBinding
ToolTipVisibilityEventHandler | ToolTipHidden
ToolTipVisibilityEventHandler | ToolTipShown
- Events inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
EventHandler< EventArgs > | ActionPerformed
EventHandler< EventArgs > | Leave
EventHandler< EventArgs > | ValueChanged

Detailed Description

Binding for the parent of StateIndicatorGaugeBinding.

Support visibility and enabledness. Does not have a value.

Member Function Documentation

override void Deltares.Standard.Forms.DExpress.ComponentWrappers.GaugeControlBinding.Dispose ( bool disposing )
protected

Clean up any resources being used.

Parameters
disposing true if managed resources should be disposed; otherwise, false.
Generated on Tue Dec 15 2015 18:15:26 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • ComponentWrappers
  • GaugeControlBinding
Deltares.Standard.Forms.DExpress.ComponentWrappers.GaugeControlBinding Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.ComponentWrappers.GaugeControlBinding, including all inherited members.

ActionPerformed (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
BaseControlBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.BaseControlBinding) | Deltares.Standard.Forms.DExpress.BaseControlBinding | protected
BoundControl (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding |
Component (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ComponentBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ControlBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Description | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Dispose(bool disposing) | Deltares.Standard.Forms.DExpress.ComponentWrappers.GaugeControlBinding | protected
EditFileInfo(object source, BindPropertyInfo propertyInfo) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
EditFileInfo(string value, string format, string label, string description, bool isDirectory) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GaugeControlBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.ComponentWrappers.GaugeControlBinding) | Deltares.Standard.Forms.DExpress.ComponentWrappers.GaugeControlBinding |
GetDictionaryProperties(ICollection domain, BindPropertyInfo dynamicPropertyInfo) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetDoubleString(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetGenericType(Type type) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetNumericValue(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetPopupMenu() | Deltares.Standard.Forms.DExpress.BaseControlBinding | protected
GetValue() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
HandleDelayed (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
HasDomain (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
HasValidNumericValue(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Initialize(BindPropertyInfo propertyInfo, params string[] properties) (defined in Deltares.Standard.Forms.DExpress.BaseControlBinding) | Deltares.Standard.Forms.DExpress.BaseControlBinding | virtual
Initialize(BindPropertyInfo propertyInfo, Type rootObjectType, params string[] properties) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
Invalidate() (defined in Deltares.Standard.Forms.DExpress.BaseControlBinding) | Deltares.Standard.Forms.DExpress.BaseControlBinding | virtual
IsAssociatedPropertyVisible(object source, BindPropertyInfo associatedPropertyInfo) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
IsTransparant (defined in Deltares.Standard.Forms.DExpress.ComponentWrappers.GaugeControlBinding) | Deltares.Standard.Forms.DExpress.ComponentWrappers.GaugeControlBinding |
Label | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Leave (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
OnToolTipClosed() | Deltares.Standard.Forms.DExpress.BaseControlBinding | protectedvirtual
OnToolTipShown(PopupEventArgs e) | Deltares.Standard.Forms.DExpress.BaseControlBinding | protectedvirtual
propInfo (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseActionPerformed() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseLeave() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseValueChanged() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Refresh() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
RegisterSelectionAssignment(Component targetComponent, IConverter converter=null) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetBackgroundColor(Color color) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
SetControlColors(Color fore, Color back) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetDescription(string description) (defined in Deltares.Standard.Forms.DExpress.BaseControlBinding) | Deltares.Standard.Forms.DExpress.BaseControlBinding | virtual
SetDomain(ICollection collection) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetEnabled(bool enabled) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
SetForegroundColor(Color color) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
SetLabel(string text) (defined in Deltares.Standard.Forms.DExpress.BaseControlBinding) | Deltares.Standard.Forms.DExpress.BaseControlBinding | virtual
SetTrueMapping(object trueMapping) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetValue(object value) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetValue(object value, object parent) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetVisible(bool visible) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
superTip (defined in Deltares.Standard.Forms.DExpress.BaseControlBinding) | Deltares.Standard.Forms.DExpress.BaseControlBinding | protected
ThreadSafeRefresh() (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Tooltip | Deltares.Standard.Forms.DExpress.ControlBinding | protected
tooltip (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | protected
ToolTipHidden (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding |
ToolTipShown (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding |
ValueChanged (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ValueToString(object value) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Generated on Tue Dec 15 2015 18:15:26 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.ComponentWrappers.IGetBoundControl Interface Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • ComponentWrappers
  • IGetBoundControl
Properties | List of all members
Deltares.Standard.Forms.DExpress.ComponentWrappers.IGetBoundControl Interface Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.ComponentWrappers.IGetBoundControl:
Deltares.Standard.Forms.DExpress.ControlBinding Deltares.Standard.Forms.DExpress.GridColumnBinding Deltares.Standard.Forms.DExpress.BaseControlBinding Deltares.Standard.Forms.DExpress.ButtonBinding Deltares.Standard.Forms.DExpress.ChartControlBinding Deltares.Standard.Forms.DExpress.CheckBoxBinding Deltares.Standard.Forms.DExpress.GridControlBinding Deltares.Standard.Forms.DExpress.ImageListBoxBinding Deltares.Standard.Forms.DExpress.LabelBinding Deltares.Standard.Forms.DExpress.ListBoxBinding Deltares.Standard.Forms.DExpress.RadioButtonBinding Deltares.Standard.Forms.DExpress.ScrollableControlBinding Deltares.Standard.Forms.DExpress.TreeListBinding

Properties

Control BoundControl [get]
Generated on Tue Dec 15 2015 18:15:27 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • ComponentWrappers
  • IGetBoundControl
Deltares.Standard.Forms.DExpress.ComponentWrappers.IGetBoundControl Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.ComponentWrappers.IGetBoundControl, including all inherited members.

BoundControl (defined in Deltares.Standard.Forms.DExpress.ComponentWrappers.IGetBoundControl) Deltares.Standard.Forms.DExpress.ComponentWrappers.IGetBoundControl
Generated on Tue Dec 15 2015 18:15:27 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.Forms.ExportLayersController Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • Forms
  • ExportLayersController
Public Member Functions | Protected Member Functions | Package Functions | List of all members
Deltares.Standard.Forms.DExpress.Forms.ExportLayersController Class Reference

Controller of MVC pattern, V = ExportLayerDialog, M = Layers More...

Public Member Functions

ExportLayersController (IMapLayerCollection mapLayerCollection, IExportLayersDialog exportLayersDialog)
void ShowDialog ()

Protected Member Functions

void ExportLayers ()

Package Functions

virtual void | SaveSelectedLayer (IMapRasterLayer layer)
virtual void | SaveSelectedLayer (IMapFeatureLayer layer)
virtual string | GetFullDestinationPath (string name, string extension)
virtual List< SelectableLayerItem > | GetSelectLayerItemsOfRastersAndFeatures (IMapLayerCollection mapLayerCollection)

Detailed Description

Controller of MVC pattern, V = ExportLayerDialog, M = Layers

Generated on Tue Dec 15 2015 18:15:27 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • Forms
  • ExportLayersController
Deltares.Standard.Forms.DExpress.Forms.ExportLayersController Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.Forms.ExportLayersController, including all inherited members.

ExportLayers() (defined in Deltares.Standard.Forms.DExpress.Forms.ExportLayersController) | Deltares.Standard.Forms.DExpress.Forms.ExportLayersController | protected
ExportLayersController(IMapLayerCollection mapLayerCollection, IExportLayersDialog exportLayersDialog) (defined in Deltares.Standard.Forms.DExpress.Forms.ExportLayersController) | Deltares.Standard.Forms.DExpress.Forms.ExportLayersController |
GetFullDestinationPath(string name, string extension) (defined in Deltares.Standard.Forms.DExpress.Forms.ExportLayersController) | Deltares.Standard.Forms.DExpress.Forms.ExportLayersController | packagevirtual
GetSelectLayerItemsOfRastersAndFeatures(IMapLayerCollection mapLayerCollection) (defined in Deltares.Standard.Forms.DExpress.Forms.ExportLayersController) | Deltares.Standard.Forms.DExpress.Forms.ExportLayersController | packagevirtual
SaveSelectedLayer(IMapRasterLayer layer) (defined in Deltares.Standard.Forms.DExpress.Forms.ExportLayersController) | Deltares.Standard.Forms.DExpress.Forms.ExportLayersController | packagevirtual
SaveSelectedLayer(IMapFeatureLayer layer) (defined in Deltares.Standard.Forms.DExpress.Forms.ExportLayersController) | Deltares.Standard.Forms.DExpress.Forms.ExportLayersController | packagevirtual
ShowDialog() (defined in Deltares.Standard.Forms.DExpress.Forms.ExportLayersController) | Deltares.Standard.Forms.DExpress.Forms.ExportLayersController |
Generated on Tue Dec 15 2015 18:15:27 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.Forms.ExportLayersDialog Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • Forms
  • ExportLayersDialog
Protected Member Functions | Protected Attributes | Properties | List of all members
Deltares.Standard.Forms.DExpress.Forms.ExportLayersDialog Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.Forms.ExportLayersDialog:
Deltares.Standard.Forms.DExpress.Forms.IExportLayersDialog

Protected Member Functions

override void Dispose (bool disposing)
Clean up any resources being used. More...

Protected Attributes

Standard.Forms.DExpress.GridViewControl LayersGridViewControl

Properties

DirectoryInfo | DestinationDirectory [get, set]
Get selected directory to export to More...
List< SelectableLayerItem > | SelectableLayerItems [get, set]
Get selected layers by the user More...
- Properties inherited from Deltares.Standard.Forms.DExpress.Forms.IExportLayersDialog
DirectoryInfo | DestinationDirectory [get, set]
Get selected directory to export to More...
List< SelectableLayerItem > | SelectableLayerItems [get, set]
Get/Set selected layer items More...

Member Function Documentation

override void Deltares.Standard.Forms.DExpress.Forms.ExportLayersDialog.Dispose ( bool disposing )
protected

Clean up any resources being used.

Parameters
disposing true if managed resources should be disposed; otherwise, false.

Property Documentation

DirectoryInfo Deltares.Standard.Forms.DExpress.Forms.ExportLayersDialog.DestinationDirectory
getset

Get selected directory to export to

List<SelectableLayerItem> Deltares.Standard.Forms.DExpress.Forms.ExportLayersDialog.SelectableLayerItems
getset

Get selected layers by the user

Generated on Tue Dec 15 2015 18:15:27 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • Forms
  • ExportLayersDialog
Deltares.Standard.Forms.DExpress.Forms.ExportLayersDialog Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.Forms.ExportLayersDialog, including all inherited members.

DestinationDirectory | Deltares.Standard.Forms.DExpress.Forms.ExportLayersDialog |
Dispose(bool disposing) | Deltares.Standard.Forms.DExpress.Forms.ExportLayersDialog | protected
ExportLayersDialog() (defined in Deltares.Standard.Forms.DExpress.Forms.ExportLayersDialog) | Deltares.Standard.Forms.DExpress.Forms.ExportLayersDialog |
LayersGridViewControl (defined in Deltares.Standard.Forms.DExpress.Forms.ExportLayersDialog) | Deltares.Standard.Forms.DExpress.Forms.ExportLayersDialog | protected
SelectableLayerItems | Deltares.Standard.Forms.DExpress.Forms.ExportLayersDialog |
Generated on Tue Dec 15 2015 18:15:27 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.Forms.FieldMappingControl Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • Forms
  • FieldMappingControl
Public Member Functions | Public Attributes | Protected Member Functions | Properties | List of all members
Deltares.Standard.Forms.DExpress.Forms.FieldMappingControl Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.Forms.FieldMappingControl:

Public Member Functions

FieldMappingControl (List< FieldDefinition > fieldDefinitions)

Public Attributes

DevExpress.XtraEditors.SimpleButton | CancelButton
DevExpress.XtraEditors.SimpleButton | ImportButton

Protected Member Functions

override void Dispose (bool disposing)
Clean up any resources being used. More...

Properties

List< FieldDefinition > FieldDefinitions [get]

Member Function Documentation

override void Deltares.Standard.Forms.DExpress.Forms.FieldMappingControl.Dispose ( bool disposing )
protected

Clean up any resources being used.

Parameters
disposing true if managed resources should be disposed; otherwise, false.
Generated on Tue Dec 15 2015 18:15:27 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • Forms
  • FieldMappingControl
Deltares.Standard.Forms.DExpress.Forms.FieldMappingControl Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.Forms.FieldMappingControl, including all inherited members.

CancelButton (defined in Deltares.Standard.Forms.DExpress.Forms.FieldMappingControl) | Deltares.Standard.Forms.DExpress.Forms.FieldMappingControl |
Dispose(bool disposing) | Deltares.Standard.Forms.DExpress.Forms.FieldMappingControl | protected
FieldDefinitions (defined in Deltares.Standard.Forms.DExpress.Forms.FieldMappingControl) | Deltares.Standard.Forms.DExpress.Forms.FieldMappingControl |
FieldMappingControl(List< FieldDefinition > fieldDefinitions) (defined in Deltares.Standard.Forms.DExpress.Forms.FieldMappingControl) | Deltares.Standard.Forms.DExpress.Forms.FieldMappingControl |
ImportButton (defined in Deltares.Standard.Forms.DExpress.Forms.FieldMappingControl) | Deltares.Standard.Forms.DExpress.Forms.FieldMappingControl |
Generated on Tue Dec 15 2015 18:15:27 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.Forms.IExportLayersDialog Interface Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • Forms
  • IExportLayersDialog
Properties | List of all members
Deltares.Standard.Forms.DExpress.Forms.IExportLayersDialog Interface Reference

Interface (for testing) More...

Inheritance diagram for Deltares.Standard.Forms.DExpress.Forms.IExportLayersDialog:
Deltares.Standard.Forms.DExpress.Forms.ExportLayersDialog

Properties

DirectoryInfo | DestinationDirectory [get, set]
Get selected directory to export to More...
List< SelectableLayerItem > | SelectableLayerItems [get, set]
Get/Set selected layer items More...

Detailed Description

Interface (for testing)

Property Documentation

DirectoryInfo Deltares.Standard.Forms.DExpress.Forms.IExportLayersDialog.DestinationDirectory
getset

Get selected directory to export to

List<SelectableLayerItem> Deltares.Standard.Forms.DExpress.Forms.IExportLayersDialog.SelectableLayerItems
getset

Get/Set selected layer items

Generated on Tue Dec 15 2015 18:15:27 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • Forms
  • IExportLayersDialog
Deltares.Standard.Forms.DExpress.Forms.IExportLayersDialog Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.Forms.IExportLayersDialog, including all inherited members.

DestinationDirectory | Deltares.Standard.Forms.DExpress.Forms.IExportLayersDialog
SelectableLayerItems | Deltares.Standard.Forms.DExpress.Forms.IExportLayersDialog
Generated on Tue Dec 15 2015 18:15:27 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.Forms.SelectableLayerItem Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • Forms
  • SelectableLayerItem
Properties | List of all members
Deltares.Standard.Forms.DExpress.Forms.SelectableLayerItem Class Reference

Data item for binding More...

Properties

bool | Selected [get, set]
ILayer | Layer [get, set]
string | LayerName [get]

Detailed Description

Data item for binding

Generated on Tue Dec 15 2015 18:15:27 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • Forms
  • SelectableLayerItem
Deltares.Standard.Forms.DExpress.Forms.SelectableLayerItem Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.Forms.SelectableLayerItem, including all inherited members.

Layer (defined in Deltares.Standard.Forms.DExpress.Forms.SelectableLayerItem) | Deltares.Standard.Forms.DExpress.Forms.SelectableLayerItem
LayerName (defined in Deltares.Standard.Forms.DExpress.Forms.SelectableLayerItem) | Deltares.Standard.Forms.DExpress.Forms.SelectableLayerItem
Selected (defined in Deltares.Standard.Forms.DExpress.Forms.SelectableLayerItem) | Deltares.Standard.Forms.DExpress.Forms.SelectableLayerItem
Generated on Tue Dec 15 2015 18:15:27 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.Interfaces.IHasBindableChildren Interface Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • Interfaces
  • IHasBindableChildren
Public Member Functions | List of all members
Deltares.Standard.Forms.DExpress.Interfaces.IHasBindableChildren Interface Reference

Class with child components that also need to be bound by BindSupport. More...

Public Member Functions

IEnumerable< Component > GetChildComponents ()
Gets the child components to be bound by BindSupport. More...

Detailed Description

Class with child components that also need to be bound by BindSupport.

Member Function Documentation

IEnumerable<Component> Deltares.Standard.Forms.DExpress.Interfaces.IHasBindableChildren.GetChildComponents ( )

Gets the child components to be bound by BindSupport.

Does not return null.

Generated on Tue Dec 15 2015 18:15:27 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • Interfaces
  • IHasBindableChildren
Deltares.Standard.Forms.DExpress.Interfaces.IHasBindableChildren Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.Interfaces.IHasBindableChildren, including all inherited members.

GetChildComponents() Deltares.Standard.Forms.DExpress.Interfaces.IHasBindableChildren
Generated on Tue Dec 15 2015 18:15:27 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.Interfaces.IHelpFileManager Interface Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • Interfaces
  • IHelpFileManager
Public Member Functions | Properties | List of all members
Deltares.Standard.Forms.DExpress.Interfaces.IHelpFileManager Interface Reference

Interface for interacting with help files More...

Inheritance diagram for Deltares.Standard.Forms.DExpress.Interfaces.IHelpFileManager:
Deltares.Standard.Forms.DExpress.HelpLocationShower Deltares.Standard.Forms.DExpress.PdfHelpFileManager

Public Member Functions

void OpenHelp (Control control)
Request to open the help at a given location. More...

Properties

string | HelpFilePath [get, set]
Gets or sets the help file path. More...
IHelpLocationProvider | HelpLocationProvider [get]
Gets the help location provider. More...

Detailed Description

Interface for interacting with help files

Member Function Documentation

void Deltares.Standard.Forms.DExpress.Interfaces.IHelpFileManager.OpenHelp ( Control control )

Request to open the help at a given location.

<preCondition>HelpFilePath should be a path to a valid file.</preCondition>

Exceptions
FileNotFoundException | When HelpFilePath does not exist.
InvalidOperationException | When HelpFilePath is not of the correct type (for example .txt file while it should be .pdf).

Implemented in Deltares.Standard.Forms.DExpress.PdfHelpFileManager, and Deltares.Standard.Forms.DExpress.HelpLocationShower.

Property Documentation

string Deltares.Standard.Forms.DExpress.Interfaces.IHelpFileManager.HelpFilePath
getset

Gets or sets the help file path.

The help file path.

IHelpLocationProvider Deltares.Standard.Forms.DExpress.Interfaces.IHelpFileManager.HelpLocationProvider
get

Gets the help location provider.

The help location provider.

Generated on Tue Dec 15 2015 18:15:28 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • Interfaces
  • IHelpFileManager
Deltares.Standard.Forms.DExpress.Interfaces.IHelpFileManager Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.Interfaces.IHelpFileManager, including all inherited members.

HelpFilePath | Deltares.Standard.Forms.DExpress.Interfaces.IHelpFileManager
HelpLocationProvider | Deltares.Standard.Forms.DExpress.Interfaces.IHelpFileManager
OpenHelp(Control control) | Deltares.Standard.Forms.DExpress.Interfaces.IHelpFileManager
Generated on Tue Dec 15 2015 18:15:28 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.Interfaces.IHelpLocationProvider Interface Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • Interfaces
  • IHelpLocationProvider
Public Member Functions | List of all members
Deltares.Standard.Forms.DExpress.Interfaces.IHelpLocationProvider Interface Reference

Interface for classes that provide a help location to be consumed by IHelpFileManager classes. More...

Inheritance diagram for Deltares.Standard.Forms.DExpress.Interfaces.IHelpLocationProvider:
Deltares.Standard.Forms.DExpress.BindSupportAsHelpLocationProvider

Public Member Functions

string GetHelpLocation (Control control)
Gets the help location from a HelpAttribute if defined. More...

Detailed Description

Interface for classes that provide a help location to be consumed by IHelpFileManager classes.

See also
IHelpFileManager, HelpAttribute

Member Function Documentation

string Deltares.Standard.Forms.DExpress.Interfaces.IHelpLocationProvider.GetHelpLocation ( Control control )

Gets the help location from a HelpAttribute if defined.

Parameters
control The control for which the help file location should be extracted.
Returns
The help location string, or null.

Implemented in Deltares.Standard.Forms.DExpress.BindSupportAsHelpLocationProvider.

Referenced by Deltares.Standard.Forms.DExpress.HelpLocationShower.OpenHelp().

Generated on Tue Dec 15 2015 18:15:28 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • Interfaces
  • IHelpLocationProvider
Deltares.Standard.Forms.DExpress.Interfaces.IHelpLocationProvider Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.Interfaces.IHelpLocationProvider, including all inherited members.

GetHelpLocation(Control control) Deltares.Standard.Forms.DExpress.Interfaces.IHelpLocationProvider
Generated on Tue Dec 15 2015 18:15:28 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.Interfaces.ILateBinding Interface Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • Interfaces
  • ILateBinding
Public Member Functions | Properties | List of all members
Deltares.Standard.Forms.DExpress.Interfaces.ILateBinding Interface Reference

Public Member Functions

void | DoLateBinding ()
Does the late binding. More...
void | RemoveLateBinding ()
Removes the late binding. More...

Properties

bool UseLateBinding [get, set]
Gets or sets a value indicating whether the late binding is used More...

Member Function Documentation

void Deltares.Standard.Forms.DExpress.Interfaces.ILateBinding.DoLateBinding ( )

Does the late binding.

void Deltares.Standard.Forms.DExpress.Interfaces.ILateBinding.RemoveLateBinding ( )

Removes the late binding.

Property Documentation

bool Deltares.Standard.Forms.DExpress.Interfaces.ILateBinding.UseLateBinding
getset

Gets or sets a value indicating whether the late binding is used

true if [use late binding]; otherwise, false.

Generated on Tue Dec 15 2015 18:15:28 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • Interfaces
  • ILateBinding
Deltares.Standard.Forms.DExpress.Interfaces.ILateBinding Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.Interfaces.ILateBinding, including all inherited members.

DoLateBinding() | Deltares.Standard.Forms.DExpress.Interfaces.ILateBinding
RemoveLateBinding() | Deltares.Standard.Forms.DExpress.Interfaces.ILateBinding
UseLateBinding | Deltares.Standard.Forms.DExpress.Interfaces.ILateBinding
Generated on Tue Dec 15 2015 18:15:28 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.Interfaces.ISelectableLayer Interface Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • Interfaces
  • ISelectableLayer
Public Member Functions | Properties | List of all members
Deltares.Standard.Forms.DExpress.Interfaces.ISelectableLayer Interface Reference

Interface for selectable map layers More...

Inheritance diagram for Deltares.Standard.Forms.DExpress.Interfaces.ISelectableLayer:
Deltares.Standard.Forms.DExpress.MyMapLineLayer Deltares.Standard.Forms.DExpress.MyMapPointLayer Deltares.Standard.Forms.DExpress.MyMapPolygonLayer

Public Member Functions

IFeature | GetFeature (object selectObject)
IFeature | SetSelected (object selectObject, bool selected)

Properties

IList DataSource [get, set]

Detailed Description

Interface for selectable map layers

Generated on Tue Dec 15 2015 18:15:28 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • Interfaces
  • ISelectableLayer
Deltares.Standard.Forms.DExpress.Interfaces.ISelectableLayer Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.Interfaces.ISelectableLayer, including all inherited members.

DataSource (defined in Deltares.Standard.Forms.DExpress.Interfaces.ISelectableLayer) | Deltares.Standard.Forms.DExpress.Interfaces.ISelectableLayer
GetFeature(object selectObject) (defined in Deltares.Standard.Forms.DExpress.Interfaces.ISelectableLayer) | Deltares.Standard.Forms.DExpress.Interfaces.ISelectableLayer
SetSelected(object selectObject, bool selected) (defined in Deltares.Standard.Forms.DExpress.Interfaces.ISelectableLayer) | Deltares.Standard.Forms.DExpress.Interfaces.ISelectableLayer
Generated on Tue Dec 15 2015 18:15:28 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.Interfaces.ISettingsDialogPlugin Interface Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • Interfaces
  • ISettingsDialogPlugin
Public Member Functions | List of all members
Deltares.Standard.Forms.DExpress.Interfaces.ISettingsDialogPlugin Interface Reference

Public Member Functions

void Save ()
Generated on Tue Dec 15 2015 18:15:28 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • Interfaces
  • ISettingsDialogPlugin
Deltares.Standard.Forms.DExpress.Interfaces.ISettingsDialogPlugin Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.Interfaces.ISettingsDialogPlugin, including all inherited members.

Save() (defined in Deltares.Standard.Forms.DExpress.Interfaces.ISettingsDialogPlugin) Deltares.Standard.Forms.DExpress.Interfaces.ISettingsDialogPlugin
Generated on Tue Dec 15 2015 18:15:28 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.Interfaces.ISettingsFormPlugin Interface Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • Interfaces
  • ISettingsFormPlugin
Public Member Functions | List of all members
Deltares.Standard.Forms.DExpress.Interfaces.ISettingsFormPlugin Interface Reference

Public Member Functions

void | CreateSettings ()
void | LoadSettings ()
void | SaveSettings ()
void | Settings ()
Generated on Tue Dec 15 2015 18:15:28 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • Interfaces
  • ISettingsFormPlugin
Deltares.Standard.Forms.DExpress.Interfaces.ISettingsFormPlugin Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.Interfaces.ISettingsFormPlugin, including all inherited members.

CreateSettings() (defined in Deltares.Standard.Forms.DExpress.Interfaces.ISettingsFormPlugin) | Deltares.Standard.Forms.DExpress.Interfaces.ISettingsFormPlugin
LoadSettings() (defined in Deltares.Standard.Forms.DExpress.Interfaces.ISettingsFormPlugin) | Deltares.Standard.Forms.DExpress.Interfaces.ISettingsFormPlugin
SaveSettings() (defined in Deltares.Standard.Forms.DExpress.Interfaces.ISettingsFormPlugin) | Deltares.Standard.Forms.DExpress.Interfaces.ISettingsFormPlugin
Settings() (defined in Deltares.Standard.Forms.DExpress.Interfaces.ISettingsFormPlugin) | Deltares.Standard.Forms.DExpress.Interfaces.ISettingsFormPlugin
Generated on Tue Dec 15 2015 18:15:28 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.Interfaces.ISettingsValidator Interface Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • Interfaces
  • ISettingsValidator
Public Member Functions | List of all members
Deltares.Standard.Forms.DExpress.Interfaces.ISettingsValidator Interface Reference

Public Member Functions

void Repair ()
Generated on Tue Dec 15 2015 18:15:28 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • Interfaces
  • ISettingsValidator
Deltares.Standard.Forms.DExpress.Interfaces.ISettingsValidator Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.Interfaces.ISettingsValidator, including all inherited members.

Repair() (defined in Deltares.Standard.Forms.DExpress.Interfaces.ISettingsValidator) Deltares.Standard.Forms.DExpress.Interfaces.ISettingsValidator
Generated on Tue Dec 15 2015 18:15:28 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.MapTools.AddFeatureMapTool Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • MapTools
  • AddFeatureMapTool
Public Member Functions | Properties | List of all members
Deltares.Standard.Forms.DExpress.MapTools.AddFeatureMapTool Class Reference

Add features map tool More...

Inheritance diagram for Deltares.Standard.Forms.DExpress.MapTools.AddFeatureMapTool:
Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool Deltares.Standard.Forms.DExpress.MapTools.IContextMenuMapTool Deltares.Standard.Forms.DExpress.MapTools.IMapTool

Public Member Functions

AddFeatureMapTool ()
Constructor More...
override void | MapControl_MouseDown (object sender, MouseEventArgs e)
Mouse down handler More...
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool
BaseMapTool ()
Constructor More...
void | Initialize ()
Initialize More...
virtual void | MapControl_MouseMove (object sender, MouseEventArgs e)
Event handler controlled from outside More...
virtual void | MapControl_MouseUp (object sender, MouseEventArgs e)
Event handler controlled from outside More...
virtual void | MapControl_MouseWheel (object sender, MouseEventArgs e)
Event handler controlled from outside More...
virtual void | MapControl_Paint (object sender, PaintEventArgs e)
Event handler controlled from outside More...

Properties

ToolStripMenuItem | ToolStripMenuItem [get]
ToolstripMenu for context menu More...
- Properties inherited from Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool
bool | IsMoving [get, set]
bool | IsActive [get, set]
Set the map tool active/not active Only used by the map tool if they need to operate alone... More...
Map | MapControl [protected get, set]
virtual IFeature | SelectedFeature [get, set]
IMapFeatureLayer | SelectedLayer [get, set]
IList | SelectedList [get, set]
IDictionary< IFeatureLayer, MapLayerDefinition > | RegisteredLayers [get]
- Properties inherited from Deltares.Standard.Forms.DExpress.MapTools.IMapTool
bool | IsActive [get, set]
Is tool active More...
Map | MapControl [set]
MapControl More...
IFeature | SelectedFeature [get, set]
Selected feature at time map tool starts More...
IMapFeatureLayer | SelectedLayer [get, set]
Layer of the selected feature More...
IList | SelectedList [get, set]
Underlying list of the selected layer More...
IDictionary< IFeatureLayer, MapLayerDefinition > | RegisteredLayers [get]
Register layer and an optional rule for snapping More...
- Properties inherited from Deltares.Standard.Forms.DExpress.MapTools.IContextMenuMapTool
ToolStripMenuItem | ToolStripMenuItem [get]

Additional Inherited Members

- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool
bool | IsSelectedFeatureGeographicPointAndInHitArea (IFeature feature, int xMousePoint, int yMousePoint)
Point | GetSnapPointMouse (Point location, Func< IGeographicPoint, IGeographic > snapRule)
Gets the point where the mouse location snaps to. More...
Coordinate | GetSnapPointCoordinates (Point location, Func< IGeographicPoint, IGeographic > snapRule)
Gets the geographical point of where the geographical point under the mouse location snaps to. More...
Coordinate | GetWorldPoint (Point screenPoint)
Gets the world coordinates of the given screen point. More...
object | GetSnapObject (MouseEventArgs e, Func< IGeographicPoint, IGeographic > snapRule)
Get snap object More...
- Protected Attributes inherited from Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool
const int | HitTolerance = 20

Detailed Description

Add features map tool

Constructor & Destructor Documentation

Deltares.Standard.Forms.DExpress.MapTools.AddFeatureMapTool.AddFeatureMapTool ( )

Constructor

References Deltares.Standard.Forms.DExpress.LocalizationSupport.Register().

Member Function Documentation

override void Deltares.Standard.Forms.DExpress.MapTools.AddFeatureMapTool.MapControl_MouseDown | ( | object | sender,
 |  | MouseEventArgs | e
 | ) |  |
virtual

Mouse down handler

Parameters
sender
e

Reimplemented from Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool.

Property Documentation

ToolStripMenuItem Deltares.Standard.Forms.DExpress.MapTools.AddFeatureMapTool.ToolStripMenuItem
get

ToolstripMenu for context menu

Generated on Tue Dec 15 2015 18:15:29 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • MapTools
  • AddFeatureMapTool
Deltares.Standard.Forms.DExpress.MapTools.AddFeatureMapTool Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.MapTools.AddFeatureMapTool, including all inherited members.

AddFeatureMapTool() | Deltares.Standard.Forms.DExpress.MapTools.AddFeatureMapTool |
BaseMapTool() | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool |
GetSnapObject(MouseEventArgs e, Func< IGeographicPoint, IGeographic > snapRule) | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool | protected
GetSnapPointCoordinates(Point location, Func< IGeographicPoint, IGeographic > snapRule) | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool | protected
GetSnapPointMouse(Point location, Func< IGeographicPoint, IGeographic > snapRule) | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool | protected
GetWorldPoint(Point screenPoint) | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool | protected
HitTolerance (defined in Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool) | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool | protected
Initialize() | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool |
IsActive | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool |
IsMoving (defined in Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool) | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool |
IsSelectedFeatureGeographicPointAndInHitArea(IFeature feature, int xMousePoint, int yMousePoint) (defined in Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool) | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool | protected
MapControl (defined in Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool) | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool |
MapControl_MouseDown(object sender, MouseEventArgs e) | Deltares.Standard.Forms.DExpress.MapTools.AddFeatureMapTool | virtual
MapControl_MouseMove(object sender, MouseEventArgs e) | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool | virtual
MapControl_MouseUp(object sender, MouseEventArgs e) | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool | virtual
MapControl_MouseWheel(object sender, MouseEventArgs e) | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool | virtual
MapControl_Paint(object sender, PaintEventArgs e) | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool | virtual
RegisteredLayers (defined in Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool) | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool |
SelectedFeature (defined in Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool) | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool |
SelectedLayer (defined in Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool) | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool |
SelectedList (defined in Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool) | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool |
ToolStripMenuItem | Deltares.Standard.Forms.DExpress.MapTools.AddFeatureMapTool |
Generated on Tue Dec 15 2015 18:15:29 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • MapTools
  • BaseMapTool
Public Member Functions | Protected Member Functions | Protected Attributes | Properties | List of all members
Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool Class Reference

Base tool for all maptools More...

Inheritance diagram for Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool:
Deltares.Standard.Forms.DExpress.MapTools.IMapTool Deltares.Standard.Forms.DExpress.MapTools.AddFeatureMapTool Deltares.Standard.Forms.DExpress.MapTools.ConnectFeaturesMapTool Deltares.Standard.Forms.DExpress.MapTools.DeleteFeatureMapTool Deltares.Standard.Forms.DExpress.MapTools.MoveFeatureMapTool Deltares.Standard.Forms.DExpress.MapTools.RectangleZoomMapTool Deltares.Standard.Forms.DExpress.MapTools.SelectFeatureMapTool

Public Member Functions

BaseMapTool ()
Constructor More...
void | Initialize ()
Initialize More...
virtual void | MapControl_MouseDown (object sender, MouseEventArgs e)
Event handler controlled from outside More...
virtual void | MapControl_MouseMove (object sender, MouseEventArgs e)
Event handler controlled from outside More...
virtual void | MapControl_MouseUp (object sender, MouseEventArgs e)
Event handler controlled from outside More...
virtual void | MapControl_MouseWheel (object sender, MouseEventArgs e)
Event handler controlled from outside More...
virtual void | MapControl_Paint (object sender, PaintEventArgs e)
Event handler controlled from outside More...

Protected Member Functions

bool | IsSelectedFeatureGeographicPointAndInHitArea (IFeature feature, int xMousePoint, int yMousePoint)
Point | GetSnapPointMouse (Point location, Func< IGeographicPoint, IGeographic > snapRule)
Gets the point where the mouse location snaps to. More...
Coordinate | GetSnapPointCoordinates (Point location, Func< IGeographicPoint, IGeographic > snapRule)
Gets the geographical point of where the geographical point under the mouse location snaps to. More...
Coordinate | GetWorldPoint (Point screenPoint)
Gets the world coordinates of the given screen point. More...
object | GetSnapObject (MouseEventArgs e, Func< IGeographicPoint, IGeographic > snapRule)
Get snap object More...

Protected Attributes

const int HitTolerance = 20

Properties

bool | IsMoving [get, set]
bool | IsActive [get, set]
Set the map tool active/not active Only used by the map tool if they need to operate alone... More...
Map | MapControl [protected get, set]
virtual IFeature | SelectedFeature [get, set]
IMapFeatureLayer | SelectedLayer [get, set]
IList | SelectedList [get, set]
IDictionary< IFeatureLayer, MapLayerDefinition > | RegisteredLayers [get]
- Properties inherited from Deltares.Standard.Forms.DExpress.MapTools.IMapTool
bool | IsActive [get, set]
Is tool active More...
Map | MapControl [set]
MapControl More...
IFeature | SelectedFeature [get, set]
Selected feature at time map tool starts More...
IMapFeatureLayer | SelectedLayer [get, set]
Layer of the selected feature More...
IList | SelectedList [get, set]
Underlying list of the selected layer More...
IDictionary< IFeatureLayer, MapLayerDefinition > | RegisteredLayers [get]
Register layer and an optional rule for snapping More...

Detailed Description

Base tool for all maptools

Constructor & Destructor Documentation

Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool.BaseMapTool ( )

Constructor

Member Function Documentation

object Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool.GetSnapObject | ( | MouseEventArgs | e,
 |  | Func< IGeographicPoint, IGeographic > | snapRule
 | ) |  |
protected

Get snap object

Parameters
e
snapRule
Returns

References Deltares.Standard.DotSpatialDgs.MapProjectionManager.GetActiveMapProjectionAsDotSpatial(), and Deltares.Standard.DotSpatialDgs.MapProjectionManager.Instance.

Coordinate Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool.GetSnapPointCoordinates | ( | Point | location,
 |  | Func< IGeographicPoint, IGeographic > | snapRule
 | ) |  |
protected

Gets the geographical point of where the geographical point under the mouse location snaps to.

Parameters
location | The location of the mouse click.
snapRule | The rule to apply when determining the snapped location.
Returns
The coordinates of the snapped point.
Point Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool.GetSnapPointMouse | ( | Point | location,
 |  | Func< IGeographicPoint, IGeographic > | snapRule
 | ) |  |
protected

Gets the point where the mouse location snaps to.

Parameters
location | The location of the mouse click.
snapRule | The rule to apply when determining the snapped location.
Returns
The screen location of the snapped point.
Coordinate Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool.GetWorldPoint ( Point screenPoint )
protected

Gets the world coordinates of the given screen point.

Parameters
screenPoint The point on the screen to get the world (geographical) coordinates for.
Returns
A Coordinate containing the location on the world of the screenPoint .

References Deltares.Standard.DotSpatialDgs.MapProjectionManager.GetActiveMapProjectionAsDotSpatial(), and Deltares.Standard.DotSpatialDgs.MapProjectionManager.Instance.

void Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool.Initialize ( )

Initialize

virtual void Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool.MapControl_MouseDown | ( | object | sender,
 |  | MouseEventArgs | e
 | ) |  |
virtual

Event handler controlled from outside

Parameters
sender
e

Implements Deltares.Standard.Forms.DExpress.MapTools.IMapTool.

Reimplemented in Deltares.Standard.Forms.DExpress.MapTools.SelectFeatureMapTool, Deltares.Standard.Forms.DExpress.MapTools.ConnectFeaturesMapTool, Deltares.Standard.Forms.DExpress.MapTools.AddFeatureMapTool, Deltares.Standard.Forms.DExpress.MapTools.MoveFeatureMapTool, and Deltares.Standard.Forms.DExpress.MapTools.RectangleZoomMapTool.

virtual void Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool.MapControl_MouseMove | ( | object | sender,
 |  | MouseEventArgs | e
 | ) |  |
virtual

Event handler controlled from outside

Parameters
sender
e

Implements Deltares.Standard.Forms.DExpress.MapTools.IMapTool.

Reimplemented in Deltares.Standard.Forms.DExpress.MapTools.SelectFeatureMapTool, Deltares.Standard.Forms.DExpress.MapTools.ConnectFeaturesMapTool, Deltares.Standard.Forms.DExpress.MapTools.MoveFeatureMapTool, and Deltares.Standard.Forms.DExpress.MapTools.RectangleZoomMapTool.

virtual void Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool.MapControl_MouseUp | ( | object | sender,
 |  | MouseEventArgs | e
 | ) |  |
virtual

Event handler controlled from outside

Parameters
sender
e

Implements Deltares.Standard.Forms.DExpress.MapTools.IMapTool.

Reimplemented in Deltares.Standard.Forms.DExpress.MapTools.SelectFeatureMapTool, Deltares.Standard.Forms.DExpress.MapTools.ConnectFeaturesMapTool, Deltares.Standard.Forms.DExpress.MapTools.MoveFeatureMapTool, Deltares.Standard.Forms.DExpress.MapTools.RectangleZoomMapTool, and Deltares.Standard.Forms.DExpress.MapTools.DeleteFeatureMapTool.

virtual void Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool.MapControl_MouseWheel | ( | object | sender,
 |  | MouseEventArgs | e
 | ) |  |
virtual

Event handler controlled from outside

Parameters
sender
e

Implements Deltares.Standard.Forms.DExpress.MapTools.IMapTool.

virtual void Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool.MapControl_Paint | ( | object | sender,
 |  | PaintEventArgs | e
 | ) |  |
virtual

Event handler controlled from outside

Parameters
sender
e

Implements Deltares.Standard.Forms.DExpress.MapTools.IMapTool.

Reimplemented in Deltares.Standard.Forms.DExpress.MapTools.SelectFeatureMapTool, Deltares.Standard.Forms.DExpress.MapTools.ConnectFeaturesMapTool, Deltares.Standard.Forms.DExpress.MapTools.MoveFeatureMapTool, and Deltares.Standard.Forms.DExpress.MapTools.RectangleZoomMapTool.

Property Documentation

bool Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool.IsActive
getset

Set the map tool active/not active Only used by the map tool if they need to operate alone...

Generated on Tue Dec 15 2015 18:15:29 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • MapTools
  • BaseMapTool
Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool, including all inherited members.

BaseMapTool() | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool |
GetSnapObject(MouseEventArgs e, Func< IGeographicPoint, IGeographic > snapRule) | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool | protected
GetSnapPointCoordinates(Point location, Func< IGeographicPoint, IGeographic > snapRule) | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool | protected
GetSnapPointMouse(Point location, Func< IGeographicPoint, IGeographic > snapRule) | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool | protected
GetWorldPoint(Point screenPoint) | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool | protected
HitTolerance (defined in Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool) | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool | protected
Initialize() | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool |
IsActive | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool |
IsMoving (defined in Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool) | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool |
IsSelectedFeatureGeographicPointAndInHitArea(IFeature feature, int xMousePoint, int yMousePoint) (defined in Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool) | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool | protected
MapControl (defined in Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool) | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool |
MapControl_MouseDown(object sender, MouseEventArgs e) | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool | virtual
MapControl_MouseMove(object sender, MouseEventArgs e) | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool | virtual
MapControl_MouseUp(object sender, MouseEventArgs e) | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool | virtual
MapControl_MouseWheel(object sender, MouseEventArgs e) | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool | virtual
MapControl_Paint(object sender, PaintEventArgs e) | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool | virtual
RegisteredLayers (defined in Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool) | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool |
SelectedFeature (defined in Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool) | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool |
SelectedLayer (defined in Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool) | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool |
SelectedList (defined in Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool) | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool |
Generated on Tue Dec 15 2015 18:15:29 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.MapTools.ConnectFeaturesMapTool Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • MapTools
  • ConnectFeaturesMapTool
Public Member Functions | Properties | List of all members
Deltares.Standard.Forms.DExpress.MapTools.ConnectFeaturesMapTool Class Reference

Connect features map tool More...

Inheritance diagram for Deltares.Standard.Forms.DExpress.MapTools.ConnectFeaturesMapTool:
Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool Deltares.Standard.Forms.DExpress.MapTools.IMapTool

Public Member Functions

bool | IsEnabled ()
override void | MapControl_MouseDown (object sender, MouseEventArgs e)
Mouse down event handler More...
override void | MapControl_MouseMove (object sender, MouseEventArgs e)
Mouse move event handler More...
override void | MapControl_MouseUp (object sender, MouseEventArgs e)
Mouse up event handler More...
override void | MapControl_Paint (object sender, PaintEventArgs e)
Mouse paint event handler More...
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool
BaseMapTool ()
Constructor More...
void | Initialize ()
Initialize More...
virtual void | MapControl_MouseWheel (object sender, MouseEventArgs e)
Event handler controlled from outside More...

Properties

override IFeature | SelectedFeature [get, set]
Selected feature sets also IConnectable object More...
- Properties inherited from Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool
bool | IsMoving [get, set]
bool | IsActive [get, set]
Set the map tool active/not active Only used by the map tool if they need to operate alone... More...
Map | MapControl [protected get, set]
virtual IFeature | SelectedFeature [get, set]
IMapFeatureLayer | SelectedLayer [get, set]
IList | SelectedList [get, set]
IDictionary< IFeatureLayer, MapLayerDefinition > | RegisteredLayers [get]
- Properties inherited from Deltares.Standard.Forms.DExpress.MapTools.IMapTool
bool | IsActive [get, set]
Is tool active More...
Map | MapControl [set]
MapControl More...
IFeature | SelectedFeature [get, set]
Selected feature at time map tool starts More...
IMapFeatureLayer | SelectedLayer [get, set]
Layer of the selected feature More...
IList | SelectedList [get, set]
Underlying list of the selected layer More...
IDictionary< IFeatureLayer, MapLayerDefinition > | RegisteredLayers [get]
Register layer and an optional rule for snapping More...

Additional Inherited Members

- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool
bool | IsSelectedFeatureGeographicPointAndInHitArea (IFeature feature, int xMousePoint, int yMousePoint)
Point | GetSnapPointMouse (Point location, Func< IGeographicPoint, IGeographic > snapRule)
Gets the point where the mouse location snaps to. More...
Coordinate | GetSnapPointCoordinates (Point location, Func< IGeographicPoint, IGeographic > snapRule)
Gets the geographical point of where the geographical point under the mouse location snaps to. More...
Coordinate | GetWorldPoint (Point screenPoint)
Gets the world coordinates of the given screen point. More...
object | GetSnapObject (MouseEventArgs e, Func< IGeographicPoint, IGeographic > snapRule)
Get snap object More...
- Protected Attributes inherited from Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool
const int | HitTolerance = 20

Detailed Description

Connect features map tool

Member Function Documentation

override void Deltares.Standard.Forms.DExpress.MapTools.ConnectFeaturesMapTool.MapControl_MouseDown | ( | object | sender,
 |  | MouseEventArgs | e
 | ) |  |
virtual

Mouse down event handler

Parameters
sender
e

Reimplemented from Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool.

override void Deltares.Standard.Forms.DExpress.MapTools.ConnectFeaturesMapTool.MapControl_MouseMove | ( | object | sender,
 |  | MouseEventArgs | e
 | ) |  |
virtual

Mouse move event handler

Parameters
sender
e

Reimplemented from Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool.

override void Deltares.Standard.Forms.DExpress.MapTools.ConnectFeaturesMapTool.MapControl_MouseUp | ( | object | sender,
 |  | MouseEventArgs | e
 | ) |  |
virtual

Mouse up event handler

Parameters
sender
e

Reimplemented from Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool.

override void Deltares.Standard.Forms.DExpress.MapTools.ConnectFeaturesMapTool.MapControl_Paint | ( | object | sender,
 |  | PaintEventArgs | e
 | ) |  |
virtual

Mouse paint event handler

Parameters
sender
e

Reimplemented from Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool.

Property Documentation

override IFeature Deltares.Standard.Forms.DExpress.MapTools.ConnectFeaturesMapTool.SelectedFeature
getset

Selected feature sets also IConnectable object

Generated on Tue Dec 15 2015 18:15:29 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • MapTools
  • ConnectFeaturesMapTool
Deltares.Standard.Forms.DExpress.MapTools.ConnectFeaturesMapTool Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.MapTools.ConnectFeaturesMapTool, including all inherited members.

BaseMapTool() | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool |
GetSnapObject(MouseEventArgs e, Func< IGeographicPoint, IGeographic > snapRule) | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool | protected
GetSnapPointCoordinates(Point location, Func< IGeographicPoint, IGeographic > snapRule) | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool | protected
GetSnapPointMouse(Point location, Func< IGeographicPoint, IGeographic > snapRule) | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool | protected
GetWorldPoint(Point screenPoint) | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool | protected
HitTolerance (defined in Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool) | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool | protected
Initialize() | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool |
IsActive | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool |
IsEnabled() (defined in Deltares.Standard.Forms.DExpress.MapTools.ConnectFeaturesMapTool) | Deltares.Standard.Forms.DExpress.MapTools.ConnectFeaturesMapTool |
IsMoving (defined in Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool) | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool |
IsSelectedFeatureGeographicPointAndInHitArea(IFeature feature, int xMousePoint, int yMousePoint) (defined in Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool) | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool | protected
MapControl (defined in Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool) | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool |
MapControl_MouseDown(object sender, MouseEventArgs e) | Deltares.Standard.Forms.DExpress.MapTools.ConnectFeaturesMapTool | virtual
MapControl_MouseMove(object sender, MouseEventArgs e) | Deltares.Standard.Forms.DExpress.MapTools.ConnectFeaturesMapTool | virtual
MapControl_MouseUp(object sender, MouseEventArgs e) | Deltares.Standard.Forms.DExpress.MapTools.ConnectFeaturesMapTool | virtual
MapControl_MouseWheel(object sender, MouseEventArgs e) | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool | virtual
MapControl_Paint(object sender, PaintEventArgs e) | Deltares.Standard.Forms.DExpress.MapTools.ConnectFeaturesMapTool | virtual
RegisteredLayers (defined in Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool) | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool |
SelectedFeature | Deltares.Standard.Forms.DExpress.MapTools.ConnectFeaturesMapTool |
SelectedLayer (defined in Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool) | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool |
SelectedList (defined in Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool) | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool |
Generated on Tue Dec 15 2015 18:15:29 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.MapTools.DeleteFeatureMapTool Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • MapTools
  • DeleteFeatureMapTool
Public Member Functions | Properties | List of all members
Deltares.Standard.Forms.DExpress.MapTools.DeleteFeatureMapTool Class Reference

Delete featute on map More...

Inheritance diagram for Deltares.Standard.Forms.DExpress.MapTools.DeleteFeatureMapTool:
Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool Deltares.Standard.Forms.DExpress.MapTools.IContextMenuMapTool Deltares.Standard.Forms.DExpress.MapTools.IMapTool

Public Member Functions

DeleteFeatureMapTool ()
Constructor More...
override void | MapControl_MouseUp (object sender, MouseEventArgs e)
Mouse up handler More...
void | deleteMenuItem_Click (object sender, EventArgs e)
Menu click handler More...
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool
BaseMapTool ()
Constructor More...
void | Initialize ()
Initialize More...
virtual void | MapControl_MouseDown (object sender, MouseEventArgs e)
Event handler controlled from outside More...
virtual void | MapControl_MouseMove (object sender, MouseEventArgs e)
Event handler controlled from outside More...
virtual void | MapControl_MouseWheel (object sender, MouseEventArgs e)
Event handler controlled from outside More...
virtual void | MapControl_Paint (object sender, PaintEventArgs e)
Event handler controlled from outside More...

Properties

ToolStripMenuItem | ToolStripMenuItem [get]
ToolStrip menu for context menu More...
- Properties inherited from Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool
bool | IsMoving [get, set]
bool | IsActive [get, set]
Set the map tool active/not active Only used by the map tool if they need to operate alone... More...
Map | MapControl [protected get, set]
virtual IFeature | SelectedFeature [get, set]
IMapFeatureLayer | SelectedLayer [get, set]
IList | SelectedList [get, set]
IDictionary< IFeatureLayer, MapLayerDefinition > | RegisteredLayers [get]
- Properties inherited from Deltares.Standard.Forms.DExpress.MapTools.IMapTool
bool | IsActive [get, set]
Is tool active More...
Map | MapControl [set]
MapControl More...
IFeature | SelectedFeature [get, set]
Selected feature at time map tool starts More...
IMapFeatureLayer | SelectedLayer [get, set]
Layer of the selected feature More...
IList | SelectedList [get, set]
Underlying list of the selected layer More...
IDictionary< IFeatureLayer, MapLayerDefinition > | RegisteredLayers [get]
Register layer and an optional rule for snapping More...
- Properties inherited from Deltares.Standard.Forms.DExpress.MapTools.IContextMenuMapTool
ToolStripMenuItem | ToolStripMenuItem [get]

Additional Inherited Members

- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool
bool | IsSelectedFeatureGeographicPointAndInHitArea (IFeature feature, int xMousePoint, int yMousePoint)
Point | GetSnapPointMouse (Point location, Func< IGeographicPoint, IGeographic > snapRule)
Gets the point where the mouse location snaps to. More...
Coordinate | GetSnapPointCoordinates (Point location, Func< IGeographicPoint, IGeographic > snapRule)
Gets the geographical point of where the geographical point under the mouse location snaps to. More...
Coordinate | GetWorldPoint (Point screenPoint)
Gets the world coordinates of the given screen point. More...
object | GetSnapObject (MouseEventArgs e, Func< IGeographicPoint, IGeographic > snapRule)
Get snap object More...
- Protected Attributes inherited from Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool
const int | HitTolerance = 20

Detailed Description

Delete featute on map

Constructor & Destructor Documentation

Deltares.Standard.Forms.DExpress.MapTools.DeleteFeatureMapTool.DeleteFeatureMapTool ( )

Constructor

References Deltares.Standard.Forms.DExpress.LocalizationSupport.Register().

Member Function Documentation

void Deltares.Standard.Forms.DExpress.MapTools.DeleteFeatureMapTool.deleteMenuItem_Click | ( | object | sender,
 |  | EventArgs | e
 | ) |  |

Menu click handler

Parameters
sender
e
override void Deltares.Standard.Forms.DExpress.MapTools.DeleteFeatureMapTool.MapControl_MouseUp | ( | object | sender,
 |  | MouseEventArgs | e
 | ) |  |
virtual

Mouse up handler

Parameters
sender
e

Reimplemented from Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool.

Property Documentation

ToolStripMenuItem Deltares.Standard.Forms.DExpress.MapTools.DeleteFeatureMapTool.ToolStripMenuItem
get

ToolStrip menu for context menu

Generated on Tue Dec 15 2015 18:15:30 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • MapTools
  • DeleteFeatureMapTool
Deltares.Standard.Forms.DExpress.MapTools.DeleteFeatureMapTool Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.MapTools.DeleteFeatureMapTool, including all inherited members.

BaseMapTool() | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool |
DeleteFeatureMapTool() | Deltares.Standard.Forms.DExpress.MapTools.DeleteFeatureMapTool |
deleteMenuItem_Click(object sender, EventArgs e) | Deltares.Standard.Forms.DExpress.MapTools.DeleteFeatureMapTool |
GetSnapObject(MouseEventArgs e, Func< IGeographicPoint, IGeographic > snapRule) | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool | protected
GetSnapPointCoordinates(Point location, Func< IGeographicPoint, IGeographic > snapRule) | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool | protected
GetSnapPointMouse(Point location, Func< IGeographicPoint, IGeographic > snapRule) | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool | protected
GetWorldPoint(Point screenPoint) | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool | protected
HitTolerance (defined in Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool) | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool | protected
Initialize() | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool |
IsActive | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool |
IsMoving (defined in Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool) | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool |
IsSelectedFeatureGeographicPointAndInHitArea(IFeature feature, int xMousePoint, int yMousePoint) (defined in Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool) | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool | protected
MapControl (defined in Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool) | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool |
MapControl_MouseDown(object sender, MouseEventArgs e) | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool | virtual
MapControl_MouseMove(object sender, MouseEventArgs e) | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool | virtual
MapControl_MouseUp(object sender, MouseEventArgs e) | Deltares.Standard.Forms.DExpress.MapTools.DeleteFeatureMapTool | virtual
MapControl_MouseWheel(object sender, MouseEventArgs e) | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool | virtual
MapControl_Paint(object sender, PaintEventArgs e) | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool | virtual
RegisteredLayers (defined in Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool) | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool |
SelectedFeature (defined in Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool) | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool |
SelectedLayer (defined in Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool) | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool |
SelectedList (defined in Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool) | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool |
ToolStripMenuItem | Deltares.Standard.Forms.DExpress.MapTools.DeleteFeatureMapTool |
Generated on Tue Dec 15 2015 18:15:30 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.MapTools.IContextMenuMapTool Interface Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • MapTools
  • IContextMenuMapTool
Properties | List of all members
Deltares.Standard.Forms.DExpress.MapTools.IContextMenuMapTool Interface Reference

Interface for providing menu items for context menu More...

Inheritance diagram for Deltares.Standard.Forms.DExpress.MapTools.IContextMenuMapTool:
Deltares.Standard.Forms.DExpress.MapTools.AddFeatureMapTool Deltares.Standard.Forms.DExpress.MapTools.DeleteFeatureMapTool Deltares.Standard.Forms.DExpress.MapTools.SelectFeatureMapTool

Properties

ToolStripMenuItem ToolStripMenuItem [get]

Detailed Description

Interface for providing menu items for context menu

Generated on Tue Dec 15 2015 18:15:30 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • MapTools
  • IContextMenuMapTool
Deltares.Standard.Forms.DExpress.MapTools.IContextMenuMapTool Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.MapTools.IContextMenuMapTool, including all inherited members.

ToolStripMenuItem (defined in Deltares.Standard.Forms.DExpress.MapTools.IContextMenuMapTool) Deltares.Standard.Forms.DExpress.MapTools.IContextMenuMapTool
Generated on Tue Dec 15 2015 18:15:30 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.MapTools.IMapTool Interface Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • MapTools
  • IMapTool
Public Member Functions | Properties | List of all members
Deltares.Standard.Forms.DExpress.MapTools.IMapTool Interface Reference

Interface for Map tools More...

Inheritance diagram for Deltares.Standard.Forms.DExpress.MapTools.IMapTool:
Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool Deltares.Standard.Forms.DExpress.MapTools.AddFeatureMapTool Deltares.Standard.Forms.DExpress.MapTools.ConnectFeaturesMapTool Deltares.Standard.Forms.DExpress.MapTools.DeleteFeatureMapTool Deltares.Standard.Forms.DExpress.MapTools.MoveFeatureMapTool Deltares.Standard.Forms.DExpress.MapTools.RectangleZoomMapTool Deltares.Standard.Forms.DExpress.MapTools.SelectFeatureMapTool

Public Member Functions

void | MapControl_MouseDown (object sender, MouseEventArgs e)
Event handler controlled from outside More...
void | MapControl_MouseMove (object sender, MouseEventArgs e)
Event handler controlled from outside More...
void | MapControl_MouseUp (object sender, MouseEventArgs e)
Event handler controlled from outside More...
void | MapControl_MouseWheel (object sender, MouseEventArgs e)
Event handler controlled from outside More...
void | MapControl_Paint (object sender, PaintEventArgs e)
Event handler controlled from outside More...

Properties

bool | IsActive [get, set]
Is tool active More...
Map | MapControl [set]
MapControl More...
IFeature | SelectedFeature [get, set]
Selected feature at time map tool starts More...
IMapFeatureLayer | SelectedLayer [get, set]
Layer of the selected feature More...
IList | SelectedList [get, set]
Underlying list of the selected layer More...
IDictionary< IFeatureLayer, MapLayerDefinition > | RegisteredLayers [get]
Register layer and an optional rule for snapping More...

Detailed Description

Interface for Map tools

Member Function Documentation

void Deltares.Standard.Forms.DExpress.MapTools.IMapTool.MapControl_MouseDown | ( | object | sender,
 |  | MouseEventArgs | e
 | ) |  |

Event handler controlled from outside

Parameters
sender
e

Implemented in Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool, Deltares.Standard.Forms.DExpress.MapTools.SelectFeatureMapTool, Deltares.Standard.Forms.DExpress.MapTools.ConnectFeaturesMapTool, Deltares.Standard.Forms.DExpress.MapTools.AddFeatureMapTool, Deltares.Standard.Forms.DExpress.MapTools.MoveFeatureMapTool, and Deltares.Standard.Forms.DExpress.MapTools.RectangleZoomMapTool.

void Deltares.Standard.Forms.DExpress.MapTools.IMapTool.MapControl_MouseMove | ( | object | sender,
 |  | MouseEventArgs | e
 | ) |  |

Event handler controlled from outside

Parameters
sender
e

Implemented in Deltares.Standard.Forms.DExpress.MapTools.SelectFeatureMapTool, Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool, Deltares.Standard.Forms.DExpress.MapTools.ConnectFeaturesMapTool, Deltares.Standard.Forms.DExpress.MapTools.MoveFeatureMapTool, and Deltares.Standard.Forms.DExpress.MapTools.RectangleZoomMapTool.

void Deltares.Standard.Forms.DExpress.MapTools.IMapTool.MapControl_MouseUp | ( | object | sender,
 |  | MouseEventArgs | e
 | ) |  |

Event handler controlled from outside

Parameters
sender
e

Implemented in Deltares.Standard.Forms.DExpress.MapTools.SelectFeatureMapTool, Deltares.Standard.Forms.DExpress.MapTools.ConnectFeaturesMapTool, Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool, Deltares.Standard.Forms.DExpress.MapTools.MoveFeatureMapTool, Deltares.Standard.Forms.DExpress.MapTools.RectangleZoomMapTool, and Deltares.Standard.Forms.DExpress.MapTools.DeleteFeatureMapTool.

void Deltares.Standard.Forms.DExpress.MapTools.IMapTool.MapControl_MouseWheel | ( | object | sender,
 |  | MouseEventArgs | e
 | ) |  |

Event handler controlled from outside

Parameters
sender
e

Implemented in Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool.

void Deltares.Standard.Forms.DExpress.MapTools.IMapTool.MapControl_Paint | ( | object | sender,
 |  | PaintEventArgs | e
 | ) |  |

Event handler controlled from outside

Parameters
sender
e

Implemented in Deltares.Standard.Forms.DExpress.MapTools.SelectFeatureMapTool, Deltares.Standard.Forms.DExpress.MapTools.ConnectFeaturesMapTool, Deltares.Standard.Forms.DExpress.MapTools.MoveFeatureMapTool, Deltares.Standard.Forms.DExpress.MapTools.RectangleZoomMapTool, and Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool.

Property Documentation

bool Deltares.Standard.Forms.DExpress.MapTools.IMapTool.IsActive
getset

Is tool active

Map Deltares.Standard.Forms.DExpress.MapTools.IMapTool.MapControl
set

MapControl

IDictionary<IFeatureLayer, MapLayerDefinition> Deltares.Standard.Forms.DExpress.MapTools.IMapTool.RegisteredLayers
get

Register layer and an optional rule for snapping

IFeature Deltares.Standard.Forms.DExpress.MapTools.IMapTool.SelectedFeature
getset

Selected feature at time map tool starts

IMapFeatureLayer Deltares.Standard.Forms.DExpress.MapTools.IMapTool.SelectedLayer
getset

Layer of the selected feature

IList Deltares.Standard.Forms.DExpress.MapTools.IMapTool.SelectedList
getset

Underlying list of the selected layer

Generated on Tue Dec 15 2015 18:15:30 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • MapTools
  • IMapTool
Deltares.Standard.Forms.DExpress.MapTools.IMapTool Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.MapTools.IMapTool, including all inherited members.

IsActive | Deltares.Standard.Forms.DExpress.MapTools.IMapTool
MapControl | Deltares.Standard.Forms.DExpress.MapTools.IMapTool
MapControl_MouseDown(object sender, MouseEventArgs e) | Deltares.Standard.Forms.DExpress.MapTools.IMapTool
MapControl_MouseMove(object sender, MouseEventArgs e) | Deltares.Standard.Forms.DExpress.MapTools.IMapTool
MapControl_MouseUp(object sender, MouseEventArgs e) | Deltares.Standard.Forms.DExpress.MapTools.IMapTool
MapControl_MouseWheel(object sender, MouseEventArgs e) | Deltares.Standard.Forms.DExpress.MapTools.IMapTool
MapControl_Paint(object sender, PaintEventArgs e) | Deltares.Standard.Forms.DExpress.MapTools.IMapTool
RegisteredLayers | Deltares.Standard.Forms.DExpress.MapTools.IMapTool
SelectedFeature | Deltares.Standard.Forms.DExpress.MapTools.IMapTool
SelectedLayer | Deltares.Standard.Forms.DExpress.MapTools.IMapTool
SelectedList | Deltares.Standard.Forms.DExpress.MapTools.IMapTool
Generated on Tue Dec 15 2015 18:15:30 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.MapTools.MoveFeatureMapTool Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • MapTools
  • MoveFeatureMapTool
Public Member Functions | List of all members
Deltares.Standard.Forms.DExpress.MapTools.MoveFeatureMapTool Class Reference

MoveTool moves features on the map. A related layer can be used for snapping More...

Inheritance diagram for Deltares.Standard.Forms.DExpress.MapTools.MoveFeatureMapTool:
Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool Deltares.Standard.Forms.DExpress.MapTools.IMapTool

Public Member Functions

override void | MapControl_MouseDown (object sender, MouseEventArgs e)
Mouse down handler More...
override void | MapControl_MouseMove (object sender, MouseEventArgs e)
Mouse move handler More...
override void | MapControl_MouseUp (object sender, MouseEventArgs e)
Mouse up handler More...
override void | MapControl_Paint (object sender, PaintEventArgs e)
Paint handler More...
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool
BaseMapTool ()
Constructor More...
void | Initialize ()
Initialize More...
virtual void | MapControl_MouseWheel (object sender, MouseEventArgs e)
Event handler controlled from outside More...

Additional Inherited Members

- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool
bool | IsSelectedFeatureGeographicPointAndInHitArea (IFeature feature, int xMousePoint, int yMousePoint)
Point | GetSnapPointMouse (Point location, Func< IGeographicPoint, IGeographic > snapRule)
Gets the point where the mouse location snaps to. More...
Coordinate | GetSnapPointCoordinates (Point location, Func< IGeographicPoint, IGeographic > snapRule)
Gets the geographical point of where the geographical point under the mouse location snaps to. More...
Coordinate | GetWorldPoint (Point screenPoint)
Gets the world coordinates of the given screen point. More...
object | GetSnapObject (MouseEventArgs e, Func< IGeographicPoint, IGeographic > snapRule)
Get snap object More...
- Protected Attributes inherited from Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool
const int | HitTolerance = 20
- Properties inherited from Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool
bool | IsMoving [get, set]
bool | IsActive [get, set]
Set the map tool active/not active Only used by the map tool if they need to operate alone... More...
Map | MapControl [protected get, set]
virtual IFeature | SelectedFeature [get, set]
IMapFeatureLayer | SelectedLayer [get, set]
IList | SelectedList [get, set]
IDictionary< IFeatureLayer, MapLayerDefinition > | RegisteredLayers [get]
- Properties inherited from Deltares.Standard.Forms.DExpress.MapTools.IMapTool
bool | IsActive [get, set]
Is tool active More...
Map | MapControl [set]
MapControl More...
IFeature | SelectedFeature [get, set]
Selected feature at time map tool starts More...
IMapFeatureLayer | SelectedLayer [get, set]
Layer of the selected feature More...
IList | SelectedList [get, set]
Underlying list of the selected layer More...
IDictionary< IFeatureLayer, MapLayerDefinition > | RegisteredLayers [get]
Register layer and an optional rule for snapping More...

Detailed Description

MoveTool moves features on the map. A related layer can be used for snapping

Member Function Documentation

override void Deltares.Standard.Forms.DExpress.MapTools.MoveFeatureMapTool.MapControl_MouseDown | ( | object | sender,
 |  | MouseEventArgs | e
 | ) |  |
virtual

Mouse down handler

Parameters
sender
e

Reimplemented from Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool.

override void Deltares.Standard.Forms.DExpress.MapTools.MoveFeatureMapTool.MapControl_MouseMove | ( | object | sender,
 |  | MouseEventArgs | e
 | ) |  |
virtual

Mouse move handler

Parameters
sender
e

Reimplemented from Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool.

override void Deltares.Standard.Forms.DExpress.MapTools.MoveFeatureMapTool.MapControl_MouseUp | ( | object | sender,
 |  | MouseEventArgs | e
 | ) |  |
virtual

Mouse up handler

Parameters
sender
e

Reimplemented from Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool.

override void Deltares.Standard.Forms.DExpress.MapTools.MoveFeatureMapTool.MapControl_Paint | ( | object | sender,
 |  | PaintEventArgs | e
 | ) |  |
virtual

Paint handler

Parameters
sender
e

Reimplemented from Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool.

Generated on Tue Dec 15 2015 18:15:30 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • MapTools
  • MoveFeatureMapTool
Deltares.Standard.Forms.DExpress.MapTools.MoveFeatureMapTool Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.MapTools.MoveFeatureMapTool, including all inherited members.

BaseMapTool() | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool |
GetSnapObject(MouseEventArgs e, Func< IGeographicPoint, IGeographic > snapRule) | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool | protected
GetSnapPointCoordinates(Point location, Func< IGeographicPoint, IGeographic > snapRule) | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool | protected
GetSnapPointMouse(Point location, Func< IGeographicPoint, IGeographic > snapRule) | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool | protected
GetWorldPoint(Point screenPoint) | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool | protected
HitTolerance (defined in Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool) | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool | protected
Initialize() | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool |
IsActive | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool |
IsMoving (defined in Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool) | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool |
IsSelectedFeatureGeographicPointAndInHitArea(IFeature feature, int xMousePoint, int yMousePoint) (defined in Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool) | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool | protected
MapControl (defined in Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool) | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool |
MapControl_MouseDown(object sender, MouseEventArgs e) | Deltares.Standard.Forms.DExpress.MapTools.MoveFeatureMapTool | virtual
MapControl_MouseMove(object sender, MouseEventArgs e) | Deltares.Standard.Forms.DExpress.MapTools.MoveFeatureMapTool | virtual
MapControl_MouseUp(object sender, MouseEventArgs e) | Deltares.Standard.Forms.DExpress.MapTools.MoveFeatureMapTool | virtual
MapControl_MouseWheel(object sender, MouseEventArgs e) | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool | virtual
MapControl_Paint(object sender, PaintEventArgs e) | Deltares.Standard.Forms.DExpress.MapTools.MoveFeatureMapTool | virtual
RegisteredLayers (defined in Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool) | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool |
SelectedFeature (defined in Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool) | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool |
SelectedLayer (defined in Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool) | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool |
SelectedList (defined in Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool) | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool |
Generated on Tue Dec 15 2015 18:15:30 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.MapTools.RectangleZoomMapTool Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • MapTools
  • RectangleZoomMapTool
Public Member Functions | List of all members
Deltares.Standard.Forms.DExpress.MapTools.RectangleZoomMapTool Class Reference

Rectangle Zoom in/out map tool More...

Inheritance diagram for Deltares.Standard.Forms.DExpress.MapTools.RectangleZoomMapTool:
Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool Deltares.Standard.Forms.DExpress.MapTools.IMapTool

Public Member Functions

override void | MapControl_MouseDown (object sender, MouseEventArgs e)
Mouse down handler More...
override void | MapControl_MouseMove (object sender, MouseEventArgs e)
Mouse move handler More...
override void | MapControl_MouseUp (object sender, MouseEventArgs e)
Mouse up handler More...
override void | MapControl_Paint (object sender, PaintEventArgs e)
Event handler controlled from outside More...
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool
BaseMapTool ()
Constructor More...
void | Initialize ()
Initialize More...
virtual void | MapControl_MouseWheel (object sender, MouseEventArgs e)
Event handler controlled from outside More...

Additional Inherited Members

- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool
bool | IsSelectedFeatureGeographicPointAndInHitArea (IFeature feature, int xMousePoint, int yMousePoint)
Point | GetSnapPointMouse (Point location, Func< IGeographicPoint, IGeographic > snapRule)
Gets the point where the mouse location snaps to. More...
Coordinate | GetSnapPointCoordinates (Point location, Func< IGeographicPoint, IGeographic > snapRule)
Gets the geographical point of where the geographical point under the mouse location snaps to. More...
Coordinate | GetWorldPoint (Point screenPoint)
Gets the world coordinates of the given screen point. More...
object | GetSnapObject (MouseEventArgs e, Func< IGeographicPoint, IGeographic > snapRule)
Get snap object More...
- Protected Attributes inherited from Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool
const int | HitTolerance = 20
- Properties inherited from Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool
bool | IsMoving [get, set]
bool | IsActive [get, set]
Set the map tool active/not active Only used by the map tool if they need to operate alone... More...
Map | MapControl [protected get, set]
virtual IFeature | SelectedFeature [get, set]
IMapFeatureLayer | SelectedLayer [get, set]
IList | SelectedList [get, set]
IDictionary< IFeatureLayer, MapLayerDefinition > | RegisteredLayers [get]
- Properties inherited from Deltares.Standard.Forms.DExpress.MapTools.IMapTool
bool | IsActive [get, set]
Is tool active More...
Map | MapControl [set]
MapControl More...
IFeature | SelectedFeature [get, set]
Selected feature at time map tool starts More...
IMapFeatureLayer | SelectedLayer [get, set]
Layer of the selected feature More...
IList | SelectedList [get, set]
Underlying list of the selected layer More...
IDictionary< IFeatureLayer, MapLayerDefinition > | RegisteredLayers [get]
Register layer and an optional rule for snapping More...

Detailed Description

Rectangle Zoom in/out map tool

Member Function Documentation

override void Deltares.Standard.Forms.DExpress.MapTools.RectangleZoomMapTool.MapControl_MouseDown | ( | object | sender,
 |  | MouseEventArgs | e
 | ) |  |
virtual

Mouse down handler

Parameters
sender
e

Reimplemented from Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool.

override void Deltares.Standard.Forms.DExpress.MapTools.RectangleZoomMapTool.MapControl_MouseMove | ( | object | sender,
 |  | MouseEventArgs | e
 | ) |  |
virtual

Mouse move handler

Parameters
sender
e

Reimplemented from Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool.

override void Deltares.Standard.Forms.DExpress.MapTools.RectangleZoomMapTool.MapControl_MouseUp | ( | object | sender,
 |  | MouseEventArgs | e
 | ) |  |
virtual

Mouse up handler

Parameters
sender
e

Reimplemented from Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool.

override void Deltares.Standard.Forms.DExpress.MapTools.RectangleZoomMapTool.MapControl_Paint | ( | object | sender,
 |  | PaintEventArgs | e
 | ) |  |
virtual

Event handler controlled from outside

Parameters
sender
e

Reimplemented from Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool.

Generated on Tue Dec 15 2015 18:15:31 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • MapTools
  • RectangleZoomMapTool
Deltares.Standard.Forms.DExpress.MapTools.RectangleZoomMapTool Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.MapTools.RectangleZoomMapTool, including all inherited members.

BaseMapTool() | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool |
GetSnapObject(MouseEventArgs e, Func< IGeographicPoint, IGeographic > snapRule) | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool | protected
GetSnapPointCoordinates(Point location, Func< IGeographicPoint, IGeographic > snapRule) | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool | protected
GetSnapPointMouse(Point location, Func< IGeographicPoint, IGeographic > snapRule) | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool | protected
GetWorldPoint(Point screenPoint) | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool | protected
HitTolerance (defined in Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool) | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool | protected
Initialize() | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool |
IsActive | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool |
IsMoving (defined in Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool) | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool |
IsSelectedFeatureGeographicPointAndInHitArea(IFeature feature, int xMousePoint, int yMousePoint) (defined in Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool) | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool | protected
MapControl (defined in Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool) | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool |
MapControl_MouseDown(object sender, MouseEventArgs e) | Deltares.Standard.Forms.DExpress.MapTools.RectangleZoomMapTool | virtual
MapControl_MouseMove(object sender, MouseEventArgs e) | Deltares.Standard.Forms.DExpress.MapTools.RectangleZoomMapTool | virtual
MapControl_MouseUp(object sender, MouseEventArgs e) | Deltares.Standard.Forms.DExpress.MapTools.RectangleZoomMapTool | virtual
MapControl_MouseWheel(object sender, MouseEventArgs e) | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool | virtual
MapControl_Paint(object sender, PaintEventArgs e) | Deltares.Standard.Forms.DExpress.MapTools.RectangleZoomMapTool | virtual
RegisteredLayers (defined in Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool) | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool |
SelectedFeature (defined in Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool) | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool |
SelectedLayer (defined in Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool) | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool |
SelectedList (defined in Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool) | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool |
Generated on Tue Dec 15 2015 18:15:31 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.MapTools.SelectFeatureMapTool Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • MapTools
  • SelectFeatureMapTool
Public Member Functions | Properties | List of all members
Deltares.Standard.Forms.DExpress.MapTools.SelectFeatureMapTool Class Reference

Select object on the map map tool More...

Inheritance diagram for Deltares.Standard.Forms.DExpress.MapTools.SelectFeatureMapTool:
Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool Deltares.Standard.Forms.DExpress.MapTools.IContextMenuMapTool Deltares.Standard.Forms.DExpress.MapTools.IMapTool

Public Member Functions

override void | MapControl_MouseDown (object sender, MouseEventArgs e)
Mouse down handler More...
override void | MapControl_MouseMove (object sender, MouseEventArgs e)
Mouse move handler More...
override void | MapControl_MouseUp (object sender, MouseEventArgs e)
Mouse up handler More...
override void | MapControl_Paint (object sender, PaintEventArgs e)
Event handler controlled from outside More...
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool
BaseMapTool ()
Constructor More...
void | Initialize ()
Initialize More...
virtual void | MapControl_MouseWheel (object sender, MouseEventArgs e)
Event handler controlled from outside More...

Properties

List< Object > | SelectedObjects [get, set]
currently selected object(s) More...
ToolStripMenuItem | ToolStripMenuItem [get]
Tool strip menu item for Context menu More...
- Properties inherited from Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool
bool | IsMoving [get, set]
bool | IsActive [get, set]
Set the map tool active/not active Only used by the map tool if they need to operate alone... More...
Map | MapControl [protected get, set]
virtual IFeature | SelectedFeature [get, set]
IMapFeatureLayer | SelectedLayer [get, set]
IList | SelectedList [get, set]
IDictionary< IFeatureLayer, MapLayerDefinition > | RegisteredLayers [get]
- Properties inherited from Deltares.Standard.Forms.DExpress.MapTools.IMapTool
bool | IsActive [get, set]
Is tool active More...
Map | MapControl [set]
MapControl More...
IFeature | SelectedFeature [get, set]
Selected feature at time map tool starts More...
IMapFeatureLayer | SelectedLayer [get, set]
Layer of the selected feature More...
IList | SelectedList [get, set]
Underlying list of the selected layer More...
IDictionary< IFeatureLayer, MapLayerDefinition > | RegisteredLayers [get]
Register layer and an optional rule for snapping More...
- Properties inherited from Deltares.Standard.Forms.DExpress.MapTools.IContextMenuMapTool
ToolStripMenuItem | ToolStripMenuItem [get]

Additional Inherited Members

- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool
bool | IsSelectedFeatureGeographicPointAndInHitArea (IFeature feature, int xMousePoint, int yMousePoint)
Point | GetSnapPointMouse (Point location, Func< IGeographicPoint, IGeographic > snapRule)
Gets the point where the mouse location snaps to. More...
Coordinate | GetSnapPointCoordinates (Point location, Func< IGeographicPoint, IGeographic > snapRule)
Gets the geographical point of where the geographical point under the mouse location snaps to. More...
Coordinate | GetWorldPoint (Point screenPoint)
Gets the world coordinates of the given screen point. More...
object | GetSnapObject (MouseEventArgs e, Func< IGeographicPoint, IGeographic > snapRule)
Get snap object More...
- Protected Attributes inherited from Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool
const int | HitTolerance = 20

Detailed Description

Select object on the map map tool

Member Function Documentation

override void Deltares.Standard.Forms.DExpress.MapTools.SelectFeatureMapTool.MapControl_MouseDown | ( | object | sender,
 |  | MouseEventArgs | e
 | ) |  |
virtual

Mouse down handler

Parameters
sender
e

Reimplemented from Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool.

override void Deltares.Standard.Forms.DExpress.MapTools.SelectFeatureMapTool.MapControl_MouseMove | ( | object | sender,
 |  | MouseEventArgs | e
 | ) |  |
virtual

Mouse move handler

Parameters
sender
e

Reimplemented from Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool.

override void Deltares.Standard.Forms.DExpress.MapTools.SelectFeatureMapTool.MapControl_MouseUp | ( | object | sender,
 |  | MouseEventArgs | e
 | ) |  |
virtual

Mouse up handler

Parameters
sender
e

Reimplemented from Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool.

override void Deltares.Standard.Forms.DExpress.MapTools.SelectFeatureMapTool.MapControl_Paint | ( | object | sender,
 |  | PaintEventArgs | e
 | ) |  |
virtual

Event handler controlled from outside

Parameters
sender
e

Reimplemented from Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool.

Property Documentation

List<Object> Deltares.Standard.Forms.DExpress.MapTools.SelectFeatureMapTool.SelectedObjects
getset

currently selected object(s)

ToolStripMenuItem Deltares.Standard.Forms.DExpress.MapTools.SelectFeatureMapTool.ToolStripMenuItem
get

Tool strip menu item for Context menu

Generated on Tue Dec 15 2015 18:15:31 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • MapTools
  • SelectFeatureMapTool
Deltares.Standard.Forms.DExpress.MapTools.SelectFeatureMapTool Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.MapTools.SelectFeatureMapTool, including all inherited members.

BaseMapTool() | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool |
GetSnapObject(MouseEventArgs e, Func< IGeographicPoint, IGeographic > snapRule) | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool | protected
GetSnapPointCoordinates(Point location, Func< IGeographicPoint, IGeographic > snapRule) | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool | protected
GetSnapPointMouse(Point location, Func< IGeographicPoint, IGeographic > snapRule) | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool | protected
GetWorldPoint(Point screenPoint) | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool | protected
HitTolerance (defined in Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool) | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool | protected
Initialize() | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool |
IsActive | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool |
IsMoving (defined in Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool) | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool |
IsSelectedFeatureGeographicPointAndInHitArea(IFeature feature, int xMousePoint, int yMousePoint) (defined in Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool) | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool | protected
MapControl (defined in Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool) | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool |
MapControl_MouseDown(object sender, MouseEventArgs e) | Deltares.Standard.Forms.DExpress.MapTools.SelectFeatureMapTool | virtual
MapControl_MouseMove(object sender, MouseEventArgs e) | Deltares.Standard.Forms.DExpress.MapTools.SelectFeatureMapTool | virtual
MapControl_MouseUp(object sender, MouseEventArgs e) | Deltares.Standard.Forms.DExpress.MapTools.SelectFeatureMapTool | virtual
MapControl_MouseWheel(object sender, MouseEventArgs e) | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool | virtual
MapControl_Paint(object sender, PaintEventArgs e) | Deltares.Standard.Forms.DExpress.MapTools.SelectFeatureMapTool | virtual
RegisteredLayers (defined in Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool) | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool |
SelectedFeature (defined in Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool) | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool |
SelectedLayer (defined in Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool) | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool |
SelectedList (defined in Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool) | Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool |
SelectedObjects | Deltares.Standard.Forms.DExpress.MapTools.SelectFeatureMapTool |
SelectFeatureMapTool() (defined in Deltares.Standard.Forms.DExpress.MapTools.SelectFeatureMapTool) | Deltares.Standard.Forms.DExpress.MapTools.SelectFeatureMapTool |
ToolStripMenuItem | Deltares.Standard.Forms.DExpress.MapTools.SelectFeatureMapTool |
Generated on Tue Dec 15 2015 18:15:31 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.Project.DescriptionDialog Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • Project
  • DescriptionDialog
Public Member Functions | Protected Member Functions | Protected Attributes | Properties | List of all members
Deltares.Standard.Forms.DExpress.Project.DescriptionDialog Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.Project.DescriptionDialog:
Deltares.Standard.Forms.IReloadableUI Deltares.Standard.Forms.IPropertyControl

Public Member Functions

void | RegisterUIComponent (IReloadManager aReloadManager)
void | Reload ()
void | UpdateData (params object[] models)

Protected Member Functions

override void Dispose (bool disposing)
Clean up any resources being used. More...

Protected Attributes

DevExpress.XtraEditors.DateEdit | DateEdit
DevExpress.XtraEditors.CheckEdit | UseCurrentDateCheckBox
DevExpress.XtraEditors.LabelControl | AnnexIdLabel
DevExpress.XtraEditors.LabelControl | ProjectIDLabel
DevExpress.XtraEditors.LabelControl | DrawnByLabel
DevExpress.XtraEditors.LabelControl | DateLabel
DevExpress.XtraEditors.TextEdit | AnnexIdTextEdit
DevExpress.XtraEditors.TextEdit | ProjectIdTextEdit
DevExpress.XtraEditors.TextEdit | DrawnByTextEdit

Properties

object | SelectedObject [get, set]
bool | IsVisible [get]
- Properties inherited from Deltares.Standard.Forms.IPropertyControl
string | Name [get, set]
Gets or sets the name to be displayed property. More...
object | SelectedObject [get, set]
Gets or sets the object to be displayed in the property window. More...
bool | IsVisible [get]
Whether or not the property control should be displayed. More...

Member Function Documentation

override void Deltares.Standard.Forms.DExpress.Project.DescriptionDialog.Dispose ( bool disposing )
protected

Clean up any resources being used.

Parameters
disposing true if managed resources should be disposed; otherwise, false.
Generated on Tue Dec 15 2015 18:15:31 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • Project
  • DescriptionDialog
Deltares.Standard.Forms.DExpress.Project.DescriptionDialog Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.Project.DescriptionDialog, including all inherited members.

AnnexIdLabel (defined in Deltares.Standard.Forms.DExpress.Project.DescriptionDialog) | Deltares.Standard.Forms.DExpress.Project.DescriptionDialog | protected
AnnexIdTextEdit (defined in Deltares.Standard.Forms.DExpress.Project.DescriptionDialog) | Deltares.Standard.Forms.DExpress.Project.DescriptionDialog | protected
DateEdit (defined in Deltares.Standard.Forms.DExpress.Project.DescriptionDialog) | Deltares.Standard.Forms.DExpress.Project.DescriptionDialog | protected
DateLabel (defined in Deltares.Standard.Forms.DExpress.Project.DescriptionDialog) | Deltares.Standard.Forms.DExpress.Project.DescriptionDialog | protected
DescriptionDialog() (defined in Deltares.Standard.Forms.DExpress.Project.DescriptionDialog) | Deltares.Standard.Forms.DExpress.Project.DescriptionDialog |
Dispose(bool disposing) | Deltares.Standard.Forms.DExpress.Project.DescriptionDialog | protected
DrawnByLabel (defined in Deltares.Standard.Forms.DExpress.Project.DescriptionDialog) | Deltares.Standard.Forms.DExpress.Project.DescriptionDialog | protected
DrawnByTextEdit (defined in Deltares.Standard.Forms.DExpress.Project.DescriptionDialog) | Deltares.Standard.Forms.DExpress.Project.DescriptionDialog | protected
IsVisible (defined in Deltares.Standard.Forms.DExpress.Project.DescriptionDialog) | Deltares.Standard.Forms.DExpress.Project.DescriptionDialog |
Name | Deltares.Standard.Forms.IPropertyControl |
ProjectIDLabel (defined in Deltares.Standard.Forms.DExpress.Project.DescriptionDialog) | Deltares.Standard.Forms.DExpress.Project.DescriptionDialog | protected
ProjectIdTextEdit (defined in Deltares.Standard.Forms.DExpress.Project.DescriptionDialog) | Deltares.Standard.Forms.DExpress.Project.DescriptionDialog | protected
RegisterUIComponent(IReloadManager aReloadManager) (defined in Deltares.Standard.Forms.DExpress.Project.DescriptionDialog) | Deltares.Standard.Forms.DExpress.Project.DescriptionDialog |
Reload() (defined in Deltares.Standard.Forms.DExpress.Project.DescriptionDialog) | Deltares.Standard.Forms.DExpress.Project.DescriptionDialog |
SelectedObject (defined in Deltares.Standard.Forms.DExpress.Project.DescriptionDialog) | Deltares.Standard.Forms.DExpress.Project.DescriptionDialog |
UpdateData(params object[] models) (defined in Deltares.Standard.Forms.DExpress.Project.DescriptionDialog) | Deltares.Standard.Forms.DExpress.Project.DescriptionDialog |
UseCurrentDateCheckBox (defined in Deltares.Standard.Forms.DExpress.Project.DescriptionDialog) | Deltares.Standard.Forms.DExpress.Project.DescriptionDialog | protected
Generated on Tue Dec 15 2015 18:15:31 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.Properties.Resources Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • Properties
  • Resources
Properties | List of all members
Deltares.Standard.Forms.DExpress.Properties.Resources Class Reference

A strongly-typed resource class, for looking up localized strings, etc. More...

Properties

static global::System.Resources.ResourceManager | ResourceManager [get]
Returns the cached ResourceManager instance used by this class. More...
static global::System.Globalization.CultureInfo | Culture [get, set]
Overrides the current thread's CurrentUICulture property for all resource lookups using this strongly typed resource class. More...
static string | AddCaption [get]
Looks up a localized string similar to Add. More...
static System.Drawing.Bitmap | AddItem_Glyph [get]
Looks up a localized resource of type System.Drawing.Bitmap. More...
static string | AddItemHint [get]
Looks up a localized string similar to Add. More...
static string | AddRowCaption [get]
Looks up a localized string similar to Add row. More...
static string | AddselectedobjectCaption [get]
Looks up a localized string similar to Add object. More...
static string | AllCaption [get]
Looks up a localized string similar to All. More...
static string | CancelCaption [get]
Looks up a localized string similar to Cancel. More...
static string | CannotPasteInSameRow [get]
Looks up a localized string similar to The Item cannot be pasted to the same row.. More...
static string | ClipBoardCleared [get]
Looks up a localized string similar to Clipboard Cleared. More...
static string | ClipBoardEmpty [get]
Looks up a localized string similar to The clipboard is empty.. More...
static System.Drawing.Bitmap | CollapseAll_Glyph [get]
Looks up a localized resource of type System.Drawing.Bitmap. More...
static string | CollapseAllCaption [get]
Looks up a localized string similar to Collapse All. More...
static string | CollapseallHint [get]
Looks up a localized string similar to Collapse all nodes. More...
static string | Column [get]
Looks up a localized string similar to Column: . More...
static string | CombinedMessage [get]
Looks up a localized string similar to {0} {1} {2} {3}. More...
static string | CondensedviewCaption [get]
Looks up a localized string similar to Condensed view. More...
static string | CopyCaption [get]
Looks up a localized string similar to Copy. More...
static System.Drawing.Bitmap | CopyItem_Glyph [get]
Looks up a localized resource of type System.Drawing.Bitmap. More...
static string | CopyItemHint [get]
Looks up a localized string similar to Copy selection. More...
static string | CopytoClipboardCaption [get]
Looks up a localized string similar to Copy to clipboard. More...
static string | CutCaption [get]
Looks up a localized string similar to Cut. More...
static System.Drawing.Bitmap | CutItem_Glyph [get]
Looks up a localized resource of type System.Drawing.Bitmap. More...
static string | CutItemHint [get]
Looks up a localized string similar to Cut selection. More...
static string | CutItemsRemoved [get]
Looks up a localized string similar to Cut item in the clipboard will be removed.. More...
static string | DataSourceEmpty [get]
Looks up a localized string similar to DataSource is empty!. More...
static string | DefaultEmail [get]
Looks up a localized string similar to sales.nosp@m.@del.nosp@m.tares.nosp@m.syst.nosp@m.ems.n.nosp@m.l. More...
static string | DefaultTelephoneNumber [get]
Looks up a localized string similar to 31 (0)88 335 81 88. More...
static System.Drawing.Bitmap | Delete [get]
Looks up a localized resource of type System.Drawing.Bitmap. More...
static string | DeleteCaption [get]
Looks up a localized string similar to Delete. More...
static System.Drawing.Bitmap | DeleteItem_Glyph [get]
Looks up a localized resource of type System.Drawing.Bitmap. More...
static string | DeleteItemHint [get]
Looks up a localized string similar to Delete. More...
static string | DeleterowCaption [get]
Looks up a localized string similar to Delete row. More...
static string | DeleteselectedobjectCaption [get]
Looks up a localized string similar to Delete object. More...
static string | Deletion [get]
Looks up a localized string similar to Deletion. More...
static string | DescriptionCaption [get]
Looks up a localized string similar to Description. More...
static System.Drawing.Bitmap | DownArrow [get]
Looks up a localized resource of type System.Drawing.Bitmap. More...
static string | EditCaption [get]
Looks up a localized string similar to Edit. More...
static string | EditCaptionHint [get]
Looks up a localized string similar to Edits the selected items in the table. More...
static System.Drawing.Bitmap | EditUnit5 [get]
Looks up a localized resource of type System.Drawing.Bitmap. More...
static System.Drawing.Bitmap | Error [get]
Looks up a localized resource of type System.Drawing.Bitmap. More...
static System.Drawing.Bitmap | ExpandAll_Glyph [get]
Looks up a localized resource of type System.Drawing.Bitmap. More...
static string | ExpandAllCaption [get]
Looks up a localized string similar to Expand All. More...
static string | ExpandallItemHint [get]
Looks up a localized string similar to Expand all nodes. More...
static System.Drawing.Bitmap | ExportLayers [get]
Looks up a localized resource of type System.Drawing.Bitmap. More...
static string | ExporttoFileCaption [get]
Looks up a localized string similar to Export to file. More...
static System.Drawing.Bitmap | GenericProgressScreen [get]
Looks up a localized resource of type System.Drawing.Bitmap. More...
static System.Drawing.Bitmap | GenericSplashScreen [get]
Looks up a localized resource of type System.Drawing.Bitmap. More...
static string | GeoGrid [get]
Looks up a localized string similar to GeoGrid. More...
static string | GeoTextEditDimensionalToolTip [get]
Looks up a localized string similar to {0}{1} Valid Input : {2} to {3} [{4}]. More...
static string | GeoTextEditNonDimensionalToolTip [get]
Looks up a localized string similar to {0}{1} Valid Input : {2} to {3}. More...
static string | GeoTextEditToolTip [get]
Looks up a localized string similar to {0}{1}Valid Input : {2}to{3}[{4}]. More...
static string | HorizontalViewCaption [get]
Looks up a localized string similar to Horizontal view. More...
static string | InsertCaption [get]
Looks up a localized string similar to Insert. More...
static System.Drawing.Bitmap | InsertItem_Glyph [get]
Looks up a localized resource of type System.Drawing.Bitmap. More...
static string | InsertItemHint [get]
Looks up a localized string similar to Insert. More...
static string | InsertRowCaption [get]
Looks up a localized string similar to Insert row. More...
static string | InsertselectedobjectCaption [get]
Looks up a localized string similar to Insert object. More...
static string | InValidMessage [get]
Looks up a localized string similar to {0} data is invalid:. More...
static string | LevelPrefrenceCaption [get]
Looks up a localized string similar to Level Prefrence. More...
static string | ListInValidMessage [get]
Looks up a localized string similar to {0} {1} {2} ({3} {4}) is outside the geometry limits ({5} to {6} {7}).. More...
static string | ListTemplateBarCaption [get]
Looks up a localized string similar to List Template Bar. More...
static string | Materials [get]
Looks up a localized string similar to Materials. More...
static string | MenuColumnBestFit [get]
Looks up a localized string similar to Best Fit. More...
static string | MenuColumnBestFitAllColumns [get]
Looks up a localized string similar to Best Fit (all columns). More...
static string | MenuColumnClearFilter [get]
Looks up a localized string similar to Clear Filter. More...
static string | MenuColumnClearSorting [get]
Looks up a localized string similar to Clear Sorting. More...
static string | MenuColumnColumnCustomization [get]
Looks up a localized string similar to Column Chooser. More...
static string | MenuColumnFilterEditor [get]
Looks up a localized string similar to Filter Editor. More...
static string | MenuColumnGroup [get]
Looks up a localized string similar to Group By This Column. More...
static string | MenuColumnGroupBox [get]
Looks up a localized string similar to Group By Box. More...
static string | MenuColumnSortAscending [get]
Looks up a localized string similar to Sort Ascending. More...
static string | MenuColumnSortDescending [get]
Looks up a localized string similar to Sort Descending. More...
static string | MoveDownButtonCaption [get]
Looks up a localized string similar to Move Down. More...
static string | MoveDownCaption [get]
Looks up a localized string similar to Move one step down. More...
static string | MoveDownHint [get]
Looks up a localized string similar to Moves the selected node one step down. More...
static System.Drawing.Bitmap | MoveDownPopUpBarButton_Glyph [get]
Looks up a localized resource of type System.Drawing.Bitmap. More...
static System.Drawing.Bitmap | MoveUpButton_Glyph [get]
Looks up a localized resource of type System.Drawing.Bitmap. More...
static string | MoveUpButtonCaption [get]
Looks up a localized string similar to Move up. More...
static string | MoveupCaption [get]
Looks up a localized string similar to Move one step up. More...
static string | MoveupHint [get]
Looks up a localized string similar to Moves the selected node one step up. More...
static string | NameCaption [get]
Looks up a localized string similar to Name. More...
static string | NoItemtoDeleteCaption [get]
Looks up a localized string similar to No Items to Delete. More...
static string | NoObjectDeleted [get]
Looks up a localized string similar to No object to be deleted.. More...
static string | NoRowSelected [get]
Looks up a localized string similar to No row is currently selected.. More...
static string | OKCaption [get]
Looks up a localized string similar to OK. More...
static byte[] | Pan [get]
Looks up a localized resource of type System.Byte[]. More...
static byte[] | PanMove [get]
Looks up a localized resource of type System.Byte[]. More...
static string | PasteCaption [get]
Looks up a localized string similar to Paste. More...
static System.Drawing.Bitmap | PasteItem_Glyph [get]
Looks up a localized resource of type System.Drawing.Bitmap. More...
static string | PasteItemHint [get]
Looks up a localized string similar to Paste selection. More...
static System.Drawing.Bitmap | Preferences_Glyph [get]
Looks up a localized resource of type System.Drawing.Bitmap. More...
static string | PreferencesFormText [get]
Looks up a localized string similar to Functionalities Of Tree Levels. More...
static string | PrintCaption [get]
Looks up a localized string similar to Print. More...
static string | ProjectDescriptionCaption [get]
Looks up a localized string similar to Project Description. More...
static System.Drawing.Bitmap | Rename_Glyph [get]
Looks up a localized resource of type System.Drawing.Bitmap. More...
static string | RenameCaption [get]
Looks up a localized string similar to Rename. More...
static string | RenameFormCaption [get]
Looks up a localized string similar to Rename . More...
static string | RenameItemHint [get]
Looks up a localized string similar to Rename the selected object. More...
static string | RenameselectedobjectCaption [get]
Looks up a localized string similar to Rename object. More...
static string | SelectedRow [get]
Looks up a localized string similar to Selected row's data will be permanently deleted. More...
static string | SelectOrRowCaption [get]
Looks up a localized string similar to Select a cell or row to delete. More...
static System.Drawing.Bitmap | Showallcolumnsbutton_Glyph [get]
Looks up a localized resource of type System.Drawing.Bitmap. More...
static string | ShowallcolumnsCaption [get]
Looks up a localized string similar to Fit columns . More...
static string | ShowallcolumnsHint [get]
Looks up a localized string similar to Fit all columns in view / Show best column fit. More...
static string | ShowBestColumnFitCaption [get]
Looks up a localized string similar to Show best column fit. More...
static string | TitleCaption1 [get]
Looks up a localized string similar to Title 1. More...
static string | TitleCaption2 [get]
Looks up a localized string similar to Title 2. More...
static string | TitleCaption3 [get]
Looks up a localized string similar to Title 3. More...
static string | UnitCategory [get]
Looks up a localized string similar to Category. More...
static string | UnitType [get]
Looks up a localized string similar to Unit type. More...
static System.Drawing.Bitmap | UpArrow [get]
Looks up a localized resource of type System.Drawing.Bitmap. More...
static string | UserUnitIndex [get]
Looks up a localized string similar to User unit index. More...
static string | ValidateCaption [get]
Looks up a localized string similar to Validate. More...
static string | ValidateItemHint [get]
Looks up a localized string similar to Validate the data. More...
static System.Drawing.Bitmap | Validation [get]
Looks up a localized resource of type System.Drawing.Bitmap. More...
static string | ValueCaption [get]
Looks up a localized string similar to Value. More...
static string | VericalViewCaption [get]
Looks up a localized string similar to Vertical view. More...
static System.Drawing.Bitmap | Warning [get]
Looks up a localized resource of type System.Drawing.Bitmap. More...
static string | XValueNotIncreasing [get]
Looks up a localized string similar to Values in X are not in increasing order in Row: . More...
static string | ZoomtoExtentsCaption [get]
Looks up a localized string similar to Zoom to extents. More...

Detailed Description

A strongly-typed resource class, for looking up localized strings, etc.

Property Documentation

string Deltares.Standard.Forms.DExpress.Properties.Resources.AddCaption
staticget

Looks up a localized string similar to Add.

System.Drawing.Bitmap Deltares.Standard.Forms.DExpress.Properties.Resources.AddItem_Glyph
staticget

Looks up a localized resource of type System.Drawing.Bitmap.

string Deltares.Standard.Forms.DExpress.Properties.Resources.AddItemHint
staticget

Looks up a localized string similar to Add.

string Deltares.Standard.Forms.DExpress.Properties.Resources.AddRowCaption
staticget

Looks up a localized string similar to Add row.

string Deltares.Standard.Forms.DExpress.Properties.Resources.AddselectedobjectCaption
staticget

Looks up a localized string similar to Add object.

string Deltares.Standard.Forms.DExpress.Properties.Resources.AllCaption
staticget

Looks up a localized string similar to All.

string Deltares.Standard.Forms.DExpress.Properties.Resources.CancelCaption
staticget

Looks up a localized string similar to Cancel.

string Deltares.Standard.Forms.DExpress.Properties.Resources.CannotPasteInSameRow
staticget

Looks up a localized string similar to The Item cannot be pasted to the same row..

string Deltares.Standard.Forms.DExpress.Properties.Resources.ClipBoardCleared
staticget

Looks up a localized string similar to Clipboard Cleared.

string Deltares.Standard.Forms.DExpress.Properties.Resources.ClipBoardEmpty
staticget

Looks up a localized string similar to The clipboard is empty..

System.Drawing.Bitmap Deltares.Standard.Forms.DExpress.Properties.Resources.CollapseAll_Glyph
staticget

Looks up a localized resource of type System.Drawing.Bitmap.

string Deltares.Standard.Forms.DExpress.Properties.Resources.CollapseAllCaption
staticget

Looks up a localized string similar to Collapse All.

string Deltares.Standard.Forms.DExpress.Properties.Resources.CollapseallHint
staticget

Looks up a localized string similar to Collapse all nodes.

string Deltares.Standard.Forms.DExpress.Properties.Resources.Column
staticget

Looks up a localized string similar to Column: .

string Deltares.Standard.Forms.DExpress.Properties.Resources.CombinedMessage
staticget

Looks up a localized string similar to {0} {1} {2} {3}.

string Deltares.Standard.Forms.DExpress.Properties.Resources.CondensedviewCaption
staticget

Looks up a localized string similar to Condensed view.

string Deltares.Standard.Forms.DExpress.Properties.Resources.CopyCaption
staticget

Looks up a localized string similar to Copy.

System.Drawing.Bitmap Deltares.Standard.Forms.DExpress.Properties.Resources.CopyItem_Glyph
staticget

Looks up a localized resource of type System.Drawing.Bitmap.

string Deltares.Standard.Forms.DExpress.Properties.Resources.CopyItemHint
staticget

Looks up a localized string similar to Copy selection.

string Deltares.Standard.Forms.DExpress.Properties.Resources.CopytoClipboardCaption
staticget

Looks up a localized string similar to Copy to clipboard.

global.System.Globalization.CultureInfo Deltares.Standard.Forms.DExpress.Properties.Resources.Culture
staticgetset

Overrides the current thread's CurrentUICulture property for all resource lookups using this strongly typed resource class.

string Deltares.Standard.Forms.DExpress.Properties.Resources.CutCaption
staticget

Looks up a localized string similar to Cut.

System.Drawing.Bitmap Deltares.Standard.Forms.DExpress.Properties.Resources.CutItem_Glyph
staticget

Looks up a localized resource of type System.Drawing.Bitmap.

string Deltares.Standard.Forms.DExpress.Properties.Resources.CutItemHint
staticget

Looks up a localized string similar to Cut selection.

string Deltares.Standard.Forms.DExpress.Properties.Resources.CutItemsRemoved
staticget

Looks up a localized string similar to Cut item in the clipboard will be removed..

string Deltares.Standard.Forms.DExpress.Properties.Resources.DataSourceEmpty
staticget

Looks up a localized string similar to DataSource is empty!.

string Deltares.Standard.Forms.DExpress.Properties.Resources.DefaultEmail
staticget

Looks up a localized string similar to sales.nosp@m.@del.nosp@m.tares.nosp@m.syst.nosp@m.ems.n.nosp@m.l.

string Deltares.Standard.Forms.DExpress.Properties.Resources.DefaultTelephoneNumber
staticget

Looks up a localized string similar to 31 (0)88 335 81 88.

System.Drawing.Bitmap Deltares.Standard.Forms.DExpress.Properties.Resources.Delete
staticget

Looks up a localized resource of type System.Drawing.Bitmap.

string Deltares.Standard.Forms.DExpress.Properties.Resources.DeleteCaption
staticget

Looks up a localized string similar to Delete.

System.Drawing.Bitmap Deltares.Standard.Forms.DExpress.Properties.Resources.DeleteItem_Glyph
staticget

Looks up a localized resource of type System.Drawing.Bitmap.

string Deltares.Standard.Forms.DExpress.Properties.Resources.DeleteItemHint
staticget

Looks up a localized string similar to Delete.

string Deltares.Standard.Forms.DExpress.Properties.Resources.DeleterowCaption
staticget

Looks up a localized string similar to Delete row.

string Deltares.Standard.Forms.DExpress.Properties.Resources.DeleteselectedobjectCaption
staticget

Looks up a localized string similar to Delete object.

string Deltares.Standard.Forms.DExpress.Properties.Resources.Deletion
staticget

Looks up a localized string similar to Deletion.

string Deltares.Standard.Forms.DExpress.Properties.Resources.DescriptionCaption
staticget

Looks up a localized string similar to Description.

System.Drawing.Bitmap Deltares.Standard.Forms.DExpress.Properties.Resources.DownArrow
staticget

Looks up a localized resource of type System.Drawing.Bitmap.

string Deltares.Standard.Forms.DExpress.Properties.Resources.EditCaption
staticget

Looks up a localized string similar to Edit.

string Deltares.Standard.Forms.DExpress.Properties.Resources.EditCaptionHint
staticget

Looks up a localized string similar to Edits the selected items in the table.

System.Drawing.Bitmap Deltares.Standard.Forms.DExpress.Properties.Resources.EditUnit5
staticget

Looks up a localized resource of type System.Drawing.Bitmap.

System.Drawing.Bitmap Deltares.Standard.Forms.DExpress.Properties.Resources.Error
staticget

Looks up a localized resource of type System.Drawing.Bitmap.

System.Drawing.Bitmap Deltares.Standard.Forms.DExpress.Properties.Resources.ExpandAll_Glyph
staticget

Looks up a localized resource of type System.Drawing.Bitmap.

string Deltares.Standard.Forms.DExpress.Properties.Resources.ExpandAllCaption
staticget

Looks up a localized string similar to Expand All.

string Deltares.Standard.Forms.DExpress.Properties.Resources.ExpandallItemHint
staticget

Looks up a localized string similar to Expand all nodes.

System.Drawing.Bitmap Deltares.Standard.Forms.DExpress.Properties.Resources.ExportLayers
staticget

Looks up a localized resource of type System.Drawing.Bitmap.

string Deltares.Standard.Forms.DExpress.Properties.Resources.ExporttoFileCaption
staticget

Looks up a localized string similar to Export to file.

System.Drawing.Bitmap Deltares.Standard.Forms.DExpress.Properties.Resources.GenericProgressScreen
staticget

Looks up a localized resource of type System.Drawing.Bitmap.

System.Drawing.Bitmap Deltares.Standard.Forms.DExpress.Properties.Resources.GenericSplashScreen
staticget

Looks up a localized resource of type System.Drawing.Bitmap.

string Deltares.Standard.Forms.DExpress.Properties.Resources.GeoGrid
staticget

Looks up a localized string similar to GeoGrid.

string Deltares.Standard.Forms.DExpress.Properties.Resources.GeoTextEditDimensionalToolTip
staticget

Looks up a localized string similar to {0}{1} Valid Input : {2} to {3} [{4}].

string Deltares.Standard.Forms.DExpress.Properties.Resources.GeoTextEditNonDimensionalToolTip
staticget

Looks up a localized string similar to {0}{1} Valid Input : {2} to {3}.

string Deltares.Standard.Forms.DExpress.Properties.Resources.GeoTextEditToolTip
staticget

Looks up a localized string similar to {0}{1}Valid Input : {2}to{3}[{4}].

string Deltares.Standard.Forms.DExpress.Properties.Resources.HorizontalViewCaption
staticget

Looks up a localized string similar to Horizontal view.

string Deltares.Standard.Forms.DExpress.Properties.Resources.InsertCaption
staticget

Looks up a localized string similar to Insert.

System.Drawing.Bitmap Deltares.Standard.Forms.DExpress.Properties.Resources.InsertItem_Glyph
staticget

Looks up a localized resource of type System.Drawing.Bitmap.

string Deltares.Standard.Forms.DExpress.Properties.Resources.InsertItemHint
staticget

Looks up a localized string similar to Insert.

string Deltares.Standard.Forms.DExpress.Properties.Resources.InsertRowCaption
staticget

Looks up a localized string similar to Insert row.

string Deltares.Standard.Forms.DExpress.Properties.Resources.InsertselectedobjectCaption
staticget

Looks up a localized string similar to Insert object.

string Deltares.Standard.Forms.DExpress.Properties.Resources.InValidMessage
staticget

Looks up a localized string similar to {0} data is invalid:.

string Deltares.Standard.Forms.DExpress.Properties.Resources.LevelPrefrenceCaption
staticget

Looks up a localized string similar to Level Prefrence.

string Deltares.Standard.Forms.DExpress.Properties.Resources.ListInValidMessage
staticget

Looks up a localized string similar to {0} {1} {2} ({3} {4}) is outside the geometry limits ({5} to {6} {7})..

string Deltares.Standard.Forms.DExpress.Properties.Resources.ListTemplateBarCaption
staticget

Looks up a localized string similar to List Template Bar.

string Deltares.Standard.Forms.DExpress.Properties.Resources.Materials
staticget

Looks up a localized string similar to Materials.

string Deltares.Standard.Forms.DExpress.Properties.Resources.MenuColumnBestFit
staticget

Looks up a localized string similar to Best Fit.

string Deltares.Standard.Forms.DExpress.Properties.Resources.MenuColumnBestFitAllColumns
staticget

Looks up a localized string similar to Best Fit (all columns).

string Deltares.Standard.Forms.DExpress.Properties.Resources.MenuColumnClearFilter
staticget

Looks up a localized string similar to Clear Filter.

string Deltares.Standard.Forms.DExpress.Properties.Resources.MenuColumnClearSorting
staticget

Looks up a localized string similar to Clear Sorting.

string Deltares.Standard.Forms.DExpress.Properties.Resources.MenuColumnColumnCustomization
staticget

Looks up a localized string similar to Column Chooser.

string Deltares.Standard.Forms.DExpress.Properties.Resources.MenuColumnFilterEditor
staticget

Looks up a localized string similar to Filter Editor.

string Deltares.Standard.Forms.DExpress.Properties.Resources.MenuColumnGroup
staticget

Looks up a localized string similar to Group By This Column.

string Deltares.Standard.Forms.DExpress.Properties.Resources.MenuColumnGroupBox
staticget

Looks up a localized string similar to Group By Box.

string Deltares.Standard.Forms.DExpress.Properties.Resources.MenuColumnSortAscending
staticget

Looks up a localized string similar to Sort Ascending.

string Deltares.Standard.Forms.DExpress.Properties.Resources.MenuColumnSortDescending
staticget

Looks up a localized string similar to Sort Descending.

string Deltares.Standard.Forms.DExpress.Properties.Resources.MoveDownButtonCaption
staticget

Looks up a localized string similar to Move Down.

string Deltares.Standard.Forms.DExpress.Properties.Resources.MoveDownCaption
staticget

Looks up a localized string similar to Move one step down.

string Deltares.Standard.Forms.DExpress.Properties.Resources.MoveDownHint
staticget

Looks up a localized string similar to Moves the selected node one step down.

System.Drawing.Bitmap Deltares.Standard.Forms.DExpress.Properties.Resources.MoveDownPopUpBarButton_Glyph
staticget

Looks up a localized resource of type System.Drawing.Bitmap.

System.Drawing.Bitmap Deltares.Standard.Forms.DExpress.Properties.Resources.MoveUpButton_Glyph
staticget

Looks up a localized resource of type System.Drawing.Bitmap.

string Deltares.Standard.Forms.DExpress.Properties.Resources.MoveUpButtonCaption
staticget

Looks up a localized string similar to Move up.

string Deltares.Standard.Forms.DExpress.Properties.Resources.MoveupCaption
staticget

Looks up a localized string similar to Move one step up.

string Deltares.Standard.Forms.DExpress.Properties.Resources.MoveupHint
staticget

Looks up a localized string similar to Moves the selected node one step up.

string Deltares.Standard.Forms.DExpress.Properties.Resources.NameCaption
staticget

Looks up a localized string similar to Name.

string Deltares.Standard.Forms.DExpress.Properties.Resources.NoItemtoDeleteCaption
staticget

Looks up a localized string similar to No Items to Delete.

string Deltares.Standard.Forms.DExpress.Properties.Resources.NoObjectDeleted
staticget

Looks up a localized string similar to No object to be deleted..

string Deltares.Standard.Forms.DExpress.Properties.Resources.NoRowSelected
staticget

Looks up a localized string similar to No row is currently selected..

string Deltares.Standard.Forms.DExpress.Properties.Resources.OKCaption
staticget

Looks up a localized string similar to OK.

byte [] Deltares.Standard.Forms.DExpress.Properties.Resources.Pan
staticget

Looks up a localized resource of type System.Byte[].

byte [] Deltares.Standard.Forms.DExpress.Properties.Resources.PanMove
staticget

Looks up a localized resource of type System.Byte[].

string Deltares.Standard.Forms.DExpress.Properties.Resources.PasteCaption
staticget

Looks up a localized string similar to Paste.

System.Drawing.Bitmap Deltares.Standard.Forms.DExpress.Properties.Resources.PasteItem_Glyph
staticget

Looks up a localized resource of type System.Drawing.Bitmap.

string Deltares.Standard.Forms.DExpress.Properties.Resources.PasteItemHint
staticget

Looks up a localized string similar to Paste selection.

System.Drawing.Bitmap Deltares.Standard.Forms.DExpress.Properties.Resources.Preferences_Glyph
staticget

Looks up a localized resource of type System.Drawing.Bitmap.

string Deltares.Standard.Forms.DExpress.Properties.Resources.PreferencesFormText
staticget

Looks up a localized string similar to Functionalities Of Tree Levels.

string Deltares.Standard.Forms.DExpress.Properties.Resources.PrintCaption
staticget

Looks up a localized string similar to Print.

string Deltares.Standard.Forms.DExpress.Properties.Resources.ProjectDescriptionCaption
staticget

Looks up a localized string similar to Project Description.

System.Drawing.Bitmap Deltares.Standard.Forms.DExpress.Properties.Resources.Rename_Glyph
staticget

Looks up a localized resource of type System.Drawing.Bitmap.

string Deltares.Standard.Forms.DExpress.Properties.Resources.RenameCaption
staticget

Looks up a localized string similar to Rename.

string Deltares.Standard.Forms.DExpress.Properties.Resources.RenameFormCaption
staticget

Looks up a localized string similar to Rename .

string Deltares.Standard.Forms.DExpress.Properties.Resources.RenameItemHint
staticget

Looks up a localized string similar to Rename the selected object.

string Deltares.Standard.Forms.DExpress.Properties.Resources.RenameselectedobjectCaption
staticget

Looks up a localized string similar to Rename object.

global.System.Resources.ResourceManager Deltares.Standard.Forms.DExpress.Properties.Resources.ResourceManager
staticget

Returns the cached ResourceManager instance used by this class.

string Deltares.Standard.Forms.DExpress.Properties.Resources.SelectedRow
staticget

Looks up a localized string similar to Selected row's data will be permanently deleted.

string Deltares.Standard.Forms.DExpress.Properties.Resources.SelectOrRowCaption
staticget

Looks up a localized string similar to Select a cell or row to delete.

System.Drawing.Bitmap Deltares.Standard.Forms.DExpress.Properties.Resources.Showallcolumnsbutton_Glyph
staticget

Looks up a localized resource of type System.Drawing.Bitmap.

string Deltares.Standard.Forms.DExpress.Properties.Resources.ShowallcolumnsCaption
staticget

Looks up a localized string similar to Fit columns .

string Deltares.Standard.Forms.DExpress.Properties.Resources.ShowallcolumnsHint
staticget

Looks up a localized string similar to Fit all columns in view / Show best column fit.

string Deltares.Standard.Forms.DExpress.Properties.Resources.ShowBestColumnFitCaption
staticget

Looks up a localized string similar to Show best column fit.

string Deltares.Standard.Forms.DExpress.Properties.Resources.TitleCaption1
staticget

Looks up a localized string similar to Title 1.

string Deltares.Standard.Forms.DExpress.Properties.Resources.TitleCaption2
staticget

Looks up a localized string similar to Title 2.

string Deltares.Standard.Forms.DExpress.Properties.Resources.TitleCaption3
staticget

Looks up a localized string similar to Title 3.

string Deltares.Standard.Forms.DExpress.Properties.Resources.UnitCategory
staticget

Looks up a localized string similar to Category.

string Deltares.Standard.Forms.DExpress.Properties.Resources.UnitType
staticget

Looks up a localized string similar to Unit type.

System.Drawing.Bitmap Deltares.Standard.Forms.DExpress.Properties.Resources.UpArrow
staticget

Looks up a localized resource of type System.Drawing.Bitmap.

string Deltares.Standard.Forms.DExpress.Properties.Resources.UserUnitIndex
staticget

Looks up a localized string similar to User unit index.

string Deltares.Standard.Forms.DExpress.Properties.Resources.ValidateCaption
staticget

Looks up a localized string similar to Validate.

string Deltares.Standard.Forms.DExpress.Properties.Resources.ValidateItemHint
staticget

Looks up a localized string similar to Validate the data.

System.Drawing.Bitmap Deltares.Standard.Forms.DExpress.Properties.Resources.Validation
staticget

Looks up a localized resource of type System.Drawing.Bitmap.

string Deltares.Standard.Forms.DExpress.Properties.Resources.ValueCaption
staticget

Looks up a localized string similar to Value.

string Deltares.Standard.Forms.DExpress.Properties.Resources.VericalViewCaption
staticget

Looks up a localized string similar to Vertical view.

System.Drawing.Bitmap Deltares.Standard.Forms.DExpress.Properties.Resources.Warning
staticget

Looks up a localized resource of type System.Drawing.Bitmap.

string Deltares.Standard.Forms.DExpress.Properties.Resources.XValueNotIncreasing
staticget

Looks up a localized string similar to Values in X are not in increasing order in Row: .

string Deltares.Standard.Forms.DExpress.Properties.Resources.ZoomtoExtentsCaption
staticget

Looks up a localized string similar to Zoom to extents.

Generated on Tue Dec 15 2015 18:15:31 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • Properties
  • Resources
Deltares.Standard.Forms.DExpress.Properties.Resources Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.Properties.Resources, including all inherited members.

AddCaption | Deltares.Standard.Forms.DExpress.Properties.Resources | static
AddItem_Glyph | Deltares.Standard.Forms.DExpress.Properties.Resources | static
AddItemHint | Deltares.Standard.Forms.DExpress.Properties.Resources | static
AddRowCaption | Deltares.Standard.Forms.DExpress.Properties.Resources | static
AddselectedobjectCaption | Deltares.Standard.Forms.DExpress.Properties.Resources | static
AllCaption | Deltares.Standard.Forms.DExpress.Properties.Resources | static
CancelCaption | Deltares.Standard.Forms.DExpress.Properties.Resources | static
CannotPasteInSameRow | Deltares.Standard.Forms.DExpress.Properties.Resources | static
ClipBoardCleared | Deltares.Standard.Forms.DExpress.Properties.Resources | static
ClipBoardEmpty | Deltares.Standard.Forms.DExpress.Properties.Resources | static
CollapseAll_Glyph | Deltares.Standard.Forms.DExpress.Properties.Resources | static
CollapseAllCaption | Deltares.Standard.Forms.DExpress.Properties.Resources | static
CollapseallHint | Deltares.Standard.Forms.DExpress.Properties.Resources | static
Column | Deltares.Standard.Forms.DExpress.Properties.Resources | static
CombinedMessage | Deltares.Standard.Forms.DExpress.Properties.Resources | static
CondensedviewCaption | Deltares.Standard.Forms.DExpress.Properties.Resources | static
CopyCaption | Deltares.Standard.Forms.DExpress.Properties.Resources | static
CopyItem_Glyph | Deltares.Standard.Forms.DExpress.Properties.Resources | static
CopyItemHint | Deltares.Standard.Forms.DExpress.Properties.Resources | static
CopytoClipboardCaption | Deltares.Standard.Forms.DExpress.Properties.Resources | static
Culture | Deltares.Standard.Forms.DExpress.Properties.Resources | static
CutCaption | Deltares.Standard.Forms.DExpress.Properties.Resources | static
CutItem_Glyph | Deltares.Standard.Forms.DExpress.Properties.Resources | static
CutItemHint | Deltares.Standard.Forms.DExpress.Properties.Resources | static
CutItemsRemoved | Deltares.Standard.Forms.DExpress.Properties.Resources | static
DataSourceEmpty | Deltares.Standard.Forms.DExpress.Properties.Resources | static
DefaultEmail | Deltares.Standard.Forms.DExpress.Properties.Resources | static
DefaultTelephoneNumber | Deltares.Standard.Forms.DExpress.Properties.Resources | static
Delete | Deltares.Standard.Forms.DExpress.Properties.Resources | static
DeleteCaption | Deltares.Standard.Forms.DExpress.Properties.Resources | static
DeleteItem_Glyph | Deltares.Standard.Forms.DExpress.Properties.Resources | static
DeleteItemHint | Deltares.Standard.Forms.DExpress.Properties.Resources | static
DeleterowCaption | Deltares.Standard.Forms.DExpress.Properties.Resources | static
DeleteselectedobjectCaption | Deltares.Standard.Forms.DExpress.Properties.Resources | static
Deletion | Deltares.Standard.Forms.DExpress.Properties.Resources | static
DescriptionCaption | Deltares.Standard.Forms.DExpress.Properties.Resources | static
DownArrow | Deltares.Standard.Forms.DExpress.Properties.Resources | static
EditCaption | Deltares.Standard.Forms.DExpress.Properties.Resources | static
EditCaptionHint | Deltares.Standard.Forms.DExpress.Properties.Resources | static
EditUnit5 | Deltares.Standard.Forms.DExpress.Properties.Resources | static
Error | Deltares.Standard.Forms.DExpress.Properties.Resources | static
ExpandAll_Glyph | Deltares.Standard.Forms.DExpress.Properties.Resources | static
ExpandAllCaption | Deltares.Standard.Forms.DExpress.Properties.Resources | static
ExpandallItemHint | Deltares.Standard.Forms.DExpress.Properties.Resources | static
ExportLayers | Deltares.Standard.Forms.DExpress.Properties.Resources | static
ExporttoFileCaption | Deltares.Standard.Forms.DExpress.Properties.Resources | static
GenericProgressScreen | Deltares.Standard.Forms.DExpress.Properties.Resources | static
GenericSplashScreen | Deltares.Standard.Forms.DExpress.Properties.Resources | static
GeoGrid | Deltares.Standard.Forms.DExpress.Properties.Resources | static
GeoTextEditDimensionalToolTip | Deltares.Standard.Forms.DExpress.Properties.Resources | static
GeoTextEditNonDimensionalToolTip | Deltares.Standard.Forms.DExpress.Properties.Resources | static
GeoTextEditToolTip | Deltares.Standard.Forms.DExpress.Properties.Resources | static
HorizontalViewCaption | Deltares.Standard.Forms.DExpress.Properties.Resources | static
InsertCaption | Deltares.Standard.Forms.DExpress.Properties.Resources | static
InsertItem_Glyph | Deltares.Standard.Forms.DExpress.Properties.Resources | static
InsertItemHint | Deltares.Standard.Forms.DExpress.Properties.Resources | static
InsertRowCaption | Deltares.Standard.Forms.DExpress.Properties.Resources | static
InsertselectedobjectCaption | Deltares.Standard.Forms.DExpress.Properties.Resources | static
InValidMessage | Deltares.Standard.Forms.DExpress.Properties.Resources | static
LevelPrefrenceCaption | Deltares.Standard.Forms.DExpress.Properties.Resources | static
ListInValidMessage | Deltares.Standard.Forms.DExpress.Properties.Resources | static
ListTemplateBarCaption | Deltares.Standard.Forms.DExpress.Properties.Resources | static
Materials | Deltares.Standard.Forms.DExpress.Properties.Resources | static
MenuColumnBestFit | Deltares.Standard.Forms.DExpress.Properties.Resources | static
MenuColumnBestFitAllColumns | Deltares.Standard.Forms.DExpress.Properties.Resources | static
MenuColumnClearFilter | Deltares.Standard.Forms.DExpress.Properties.Resources | static
MenuColumnClearSorting | Deltares.Standard.Forms.DExpress.Properties.Resources | static
MenuColumnColumnCustomization | Deltares.Standard.Forms.DExpress.Properties.Resources | static
MenuColumnFilterEditor | Deltares.Standard.Forms.DExpress.Properties.Resources | static
MenuColumnGroup | Deltares.Standard.Forms.DExpress.Properties.Resources | static
MenuColumnGroupBox | Deltares.Standard.Forms.DExpress.Properties.Resources | static
MenuColumnSortAscending | Deltares.Standard.Forms.DExpress.Properties.Resources | static
MenuColumnSortDescending | Deltares.Standard.Forms.DExpress.Properties.Resources | static
MoveDownButtonCaption | Deltares.Standard.Forms.DExpress.Properties.Resources | static
MoveDownCaption | Deltares.Standard.Forms.DExpress.Properties.Resources | static
MoveDownHint | Deltares.Standard.Forms.DExpress.Properties.Resources | static
MoveDownPopUpBarButton_Glyph | Deltares.Standard.Forms.DExpress.Properties.Resources | static
MoveUpButton_Glyph | Deltares.Standard.Forms.DExpress.Properties.Resources | static
MoveUpButtonCaption | Deltares.Standard.Forms.DExpress.Properties.Resources | static
MoveupCaption | Deltares.Standard.Forms.DExpress.Properties.Resources | static
MoveupHint | Deltares.Standard.Forms.DExpress.Properties.Resources | static
NameCaption | Deltares.Standard.Forms.DExpress.Properties.Resources | static
NoItemtoDeleteCaption | Deltares.Standard.Forms.DExpress.Properties.Resources | static
NoObjectDeleted | Deltares.Standard.Forms.DExpress.Properties.Resources | static
NoRowSelected | Deltares.Standard.Forms.DExpress.Properties.Resources | static
OKCaption | Deltares.Standard.Forms.DExpress.Properties.Resources | static
Pan | Deltares.Standard.Forms.DExpress.Properties.Resources | static
PanMove | Deltares.Standard.Forms.DExpress.Properties.Resources | static
PasteCaption | Deltares.Standard.Forms.DExpress.Properties.Resources | static
PasteItem_Glyph | Deltares.Standard.Forms.DExpress.Properties.Resources | static
PasteItemHint | Deltares.Standard.Forms.DExpress.Properties.Resources | static
Preferences_Glyph | Deltares.Standard.Forms.DExpress.Properties.Resources | static
PreferencesFormText | Deltares.Standard.Forms.DExpress.Properties.Resources | static
PrintCaption | Deltares.Standard.Forms.DExpress.Properties.Resources | static
ProjectDescriptionCaption | Deltares.Standard.Forms.DExpress.Properties.Resources | static
Rename_Glyph | Deltares.Standard.Forms.DExpress.Properties.Resources | static
RenameCaption | Deltares.Standard.Forms.DExpress.Properties.Resources | static
RenameFormCaption | Deltares.Standard.Forms.DExpress.Properties.Resources | static
RenameItemHint | Deltares.Standard.Forms.DExpress.Properties.Resources | static
RenameselectedobjectCaption | Deltares.Standard.Forms.DExpress.Properties.Resources | static
ResourceManager | Deltares.Standard.Forms.DExpress.Properties.Resources | static
Resources() (defined in Deltares.Standard.Forms.DExpress.Properties.Resources) | Deltares.Standard.Forms.DExpress.Properties.Resources | package
SelectedRow | Deltares.Standard.Forms.DExpress.Properties.Resources | static
SelectOrRowCaption | Deltares.Standard.Forms.DExpress.Properties.Resources | static
Showallcolumnsbutton_Glyph | Deltares.Standard.Forms.DExpress.Properties.Resources | static
ShowallcolumnsCaption | Deltares.Standard.Forms.DExpress.Properties.Resources | static
ShowallcolumnsHint | Deltares.Standard.Forms.DExpress.Properties.Resources | static
ShowBestColumnFitCaption | Deltares.Standard.Forms.DExpress.Properties.Resources | static
TitleCaption1 | Deltares.Standard.Forms.DExpress.Properties.Resources | static
TitleCaption2 | Deltares.Standard.Forms.DExpress.Properties.Resources | static
TitleCaption3 | Deltares.Standard.Forms.DExpress.Properties.Resources | static
UnitCategory | Deltares.Standard.Forms.DExpress.Properties.Resources | static
UnitType | Deltares.Standard.Forms.DExpress.Properties.Resources | static
UpArrow | Deltares.Standard.Forms.DExpress.Properties.Resources | static
UserUnitIndex | Deltares.Standard.Forms.DExpress.Properties.Resources | static
ValidateCaption | Deltares.Standard.Forms.DExpress.Properties.Resources | static
ValidateItemHint | Deltares.Standard.Forms.DExpress.Properties.Resources | static
Validation | Deltares.Standard.Forms.DExpress.Properties.Resources | static
ValueCaption | Deltares.Standard.Forms.DExpress.Properties.Resources | static
VericalViewCaption | Deltares.Standard.Forms.DExpress.Properties.Resources | static
Warning | Deltares.Standard.Forms.DExpress.Properties.Resources | static
XValueNotIncreasing | Deltares.Standard.Forms.DExpress.Properties.Resources | static
ZoomtoExtentsCaption | Deltares.Standard.Forms.DExpress.Properties.Resources | static
Generated on Tue Dec 15 2015 18:15:31 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.Properties.Settings Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • Properties
  • Settings
Properties | List of all members
Deltares.Standard.Forms.DExpress.Properties.Settings Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.Properties.Settings:

Properties

static Settings | Default [get]
string | LastFolderPath [get, set]
Generated on Tue Dec 15 2015 18:15:32 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • Properties
  • Settings
Deltares.Standard.Forms.DExpress.Properties.Settings Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.Properties.Settings, including all inherited members.

Default (defined in Deltares.Standard.Forms.DExpress.Properties.Settings) | Deltares.Standard.Forms.DExpress.Properties.Settings | static
LastFolderPath (defined in Deltares.Standard.Forms.DExpress.Properties.Settings) | Deltares.Standard.Forms.DExpress.Properties.Settings |
Settings() (defined in Deltares.Standard.Forms.DExpress.Properties.Settings) | Deltares.Standard.Forms.DExpress.Properties.Settings |
Generated on Tue Dec 15 2015 18:15:32 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.ShapeImporters.LineStringImporter Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • ShapeImporters
  • LineStringImporter
Public Member Functions | List of all members
Deltares.Standard.Forms.DExpress.ShapeImporters.LineStringImporter Class Reference

More...

Inheritance diagram for Deltares.Standard.Forms.DExpress.ShapeImporters.LineStringImporter:
Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter Deltares.Standard.Forms.DExpress.IShapeImporter

Public Member Functions

LineStringImporter ()
Initializes a new instance of the LineStringImporter class. More...
override void ImportShapeGeometry (IBasicGeometry geometry, object target)
Sets the geometry data on the target object More...

Additional Inherited Members

- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter
ShapeImporter (GeometryTypes type)
void | ThrowIfGeometryIsNotValid (IBasicGeometry geometry)
Throws if geometry is not valid. More...
void | ThrowIfTargetIsNull (object target, string message)
Throws if target is not valid. More...
void | ThrowIfTargetIsNull (object target)
Throws if target is not valid (null). More...
IGeographicLoop | GetLoop (ILinearRing ring)
IEnumerable< GeographicPoint > | GetPoints (ILinearRing ring)
Gets the points. More...
IEnumerable< GeographicPoint > | GetPoints (IEnumerable< Coordinate > coordinates)
Gets geographical points from DotSpatial coordinates. More...
- Properties inherited from Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter
GeometryTypes | GeometryType [get, protected set]
Gets type of the geometry to import. More...
- Properties inherited from Deltares.Standard.Forms.DExpress.IShapeImporter
GeometryTypes | GeometryType [get]
Gets type of the geometry to import. More...

Detailed Description

Constructor & Destructor Documentation

Deltares.Standard.Forms.DExpress.ShapeImporters.LineStringImporter.LineStringImporter ( )

Initializes a new instance of the LineStringImporter class.

Member Function Documentation

override void Deltares.Standard.Forms.DExpress.ShapeImporters.LineStringImporter.ImportShapeGeometry | ( | IBasicGeometry | geometry,
 |  | object | target
 | ) |  |
virtual

Sets the geometry data on the target object

Parameters
geometry | The base geometry
target | The target

Implements Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter.

Generated on Tue Dec 15 2015 18:15:32 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • ShapeImporters
  • LineStringImporter
Deltares.Standard.Forms.DExpress.ShapeImporters.LineStringImporter Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.ShapeImporters.LineStringImporter, including all inherited members.

GeometryType | Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter |
GetLoop(ILinearRing ring) (defined in Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter) | Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter | protected
GetPoints(ILinearRing ring) | Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter | protected
GetPoints(IEnumerable< Coordinate > coordinates) | Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter | protected
ImportShapeGeometry(IBasicGeometry geometry, object target) | Deltares.Standard.Forms.DExpress.ShapeImporters.LineStringImporter | virtual
LineStringImporter() | Deltares.Standard.Forms.DExpress.ShapeImporters.LineStringImporter |
ShapeImporter(GeometryTypes type) (defined in Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter) | Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter | protected
ThrowIfGeometryIsNotValid(IBasicGeometry geometry) | Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter | protected
ThrowIfTargetIsNull(object target, string message) | Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter | protected
ThrowIfTargetIsNull(object target) | Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter | protected
Generated on Tue Dec 15 2015 18:15:32 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.ShapeImporters.MultiLineStringImporter Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • ShapeImporters
  • MultiLineStringImporter
Public Member Functions | List of all members
Deltares.Standard.Forms.DExpress.ShapeImporters.MultiLineStringImporter Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.ShapeImporters.MultiLineStringImporter:
Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter Deltares.Standard.Forms.DExpress.IShapeImporter

Public Member Functions

override void ImportShapeGeometry (IBasicGeometry geometry, object target)
Imports geometry data on the target object More...

Additional Inherited Members

- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter
ShapeImporter (GeometryTypes type)
void | ThrowIfGeometryIsNotValid (IBasicGeometry geometry)
Throws if geometry is not valid. More...
void | ThrowIfTargetIsNull (object target, string message)
Throws if target is not valid. More...
void | ThrowIfTargetIsNull (object target)
Throws if target is not valid (null). More...
IGeographicLoop | GetLoop (ILinearRing ring)
IEnumerable< GeographicPoint > | GetPoints (ILinearRing ring)
Gets the points. More...
IEnumerable< GeographicPoint > | GetPoints (IEnumerable< Coordinate > coordinates)
Gets geographical points from DotSpatial coordinates. More...
- Properties inherited from Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter
GeometryTypes | GeometryType [get, protected set]
Gets type of the geometry to import. More...
- Properties inherited from Deltares.Standard.Forms.DExpress.IShapeImporter
GeometryTypes | GeometryType [get]
Gets type of the geometry to import. More...

Member Function Documentation

override void Deltares.Standard.Forms.DExpress.ShapeImporters.MultiLineStringImporter.ImportShapeGeometry | ( | IBasicGeometry | geometry,
 |  | object | target
 | ) |  |
virtual

Imports geometry data on the target object

Parameters
geometry | The geometry data to import from
target | The target object to set data on

Implements Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter.

Generated on Tue Dec 15 2015 18:15:32 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • ShapeImporters
  • MultiLineStringImporter
Deltares.Standard.Forms.DExpress.ShapeImporters.MultiLineStringImporter Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.ShapeImporters.MultiLineStringImporter, including all inherited members.

GeometryType | Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter |
GetLoop(ILinearRing ring) (defined in Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter) | Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter | protected
GetPoints(ILinearRing ring) | Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter | protected
GetPoints(IEnumerable< Coordinate > coordinates) | Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter | protected
ImportShapeGeometry(IBasicGeometry geometry, object target) | Deltares.Standard.Forms.DExpress.ShapeImporters.MultiLineStringImporter | virtual
MultiLineStringImporter() (defined in Deltares.Standard.Forms.DExpress.ShapeImporters.MultiLineStringImporter) | Deltares.Standard.Forms.DExpress.ShapeImporters.MultiLineStringImporter |
ShapeImporter(GeometryTypes type) (defined in Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter) | Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter | protected
ThrowIfGeometryIsNotValid(IBasicGeometry geometry) | Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter | protected
ThrowIfTargetIsNull(object target, string message) | Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter | protected
ThrowIfTargetIsNull(object target) | Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter | protected
Generated on Tue Dec 15 2015 18:15:32 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.ShapeImporters.MultiPolygonImporter Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • ShapeImporters
  • MultiPolygonImporter
Public Member Functions | List of all members
Deltares.Standard.Forms.DExpress.ShapeImporters.MultiPolygonImporter Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.ShapeImporters.MultiPolygonImporter:
Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter Deltares.Standard.Forms.DExpress.IShapeImporter

Public Member Functions

override void ImportShapeGeometry (IBasicGeometry geometry, object target)
Imports geometry data on the target object More...

Additional Inherited Members

- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter
ShapeImporter (GeometryTypes type)
void | ThrowIfGeometryIsNotValid (IBasicGeometry geometry)
Throws if geometry is not valid. More...
void | ThrowIfTargetIsNull (object target, string message)
Throws if target is not valid. More...
void | ThrowIfTargetIsNull (object target)
Throws if target is not valid (null). More...
IGeographicLoop | GetLoop (ILinearRing ring)
IEnumerable< GeographicPoint > | GetPoints (ILinearRing ring)
Gets the points. More...
IEnumerable< GeographicPoint > | GetPoints (IEnumerable< Coordinate > coordinates)
Gets geographical points from DotSpatial coordinates. More...
- Properties inherited from Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter
GeometryTypes | GeometryType [get, protected set]
Gets type of the geometry to import. More...
- Properties inherited from Deltares.Standard.Forms.DExpress.IShapeImporter
GeometryTypes | GeometryType [get]
Gets type of the geometry to import. More...

Member Function Documentation

override void Deltares.Standard.Forms.DExpress.ShapeImporters.MultiPolygonImporter.ImportShapeGeometry | ( | IBasicGeometry | geometry,
 |  | object | target
 | ) |  |
virtual

Imports geometry data on the target object

Parameters
geometry | The geometry data to import from
target | The target object to set data on

Implements Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter.

Generated on Tue Dec 15 2015 18:15:33 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • ShapeImporters
  • MultiPolygonImporter
Deltares.Standard.Forms.DExpress.ShapeImporters.MultiPolygonImporter Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.ShapeImporters.MultiPolygonImporter, including all inherited members.

GeometryType | Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter |
GetLoop(ILinearRing ring) (defined in Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter) | Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter | protected
GetPoints(ILinearRing ring) | Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter | protected
GetPoints(IEnumerable< Coordinate > coordinates) | Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter | protected
ImportShapeGeometry(IBasicGeometry geometry, object target) | Deltares.Standard.Forms.DExpress.ShapeImporters.MultiPolygonImporter | virtual
MultiPolygonImporter() (defined in Deltares.Standard.Forms.DExpress.ShapeImporters.MultiPolygonImporter) | Deltares.Standard.Forms.DExpress.ShapeImporters.MultiPolygonImporter |
ShapeImporter(GeometryTypes type) (defined in Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter) | Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter | protected
ThrowIfGeometryIsNotValid(IBasicGeometry geometry) | Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter | protected
ThrowIfTargetIsNull(object target, string message) | Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter | protected
ThrowIfTargetIsNull(object target) | Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter | protected
Generated on Tue Dec 15 2015 18:15:33 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.ShapeImporters.PointImporter Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • ShapeImporters
  • PointImporter
Public Member Functions | List of all members
Deltares.Standard.Forms.DExpress.ShapeImporters.PointImporter Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.ShapeImporters.PointImporter:
Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter Deltares.Standard.Forms.DExpress.IShapeImporter

Public Member Functions

PointImporter ()
Initializes a new instance of the PointImporter class. More...
override void ImportShapeGeometry (IBasicGeometry geometry, object target)
Imports geometry data on the target object More...

Additional Inherited Members

- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter
ShapeImporter (GeometryTypes type)
void | ThrowIfGeometryIsNotValid (IBasicGeometry geometry)
Throws if geometry is not valid. More...
void | ThrowIfTargetIsNull (object target, string message)
Throws if target is not valid. More...
void | ThrowIfTargetIsNull (object target)
Throws if target is not valid (null). More...
IGeographicLoop | GetLoop (ILinearRing ring)
IEnumerable< GeographicPoint > | GetPoints (ILinearRing ring)
Gets the points. More...
IEnumerable< GeographicPoint > | GetPoints (IEnumerable< Coordinate > coordinates)
Gets geographical points from DotSpatial coordinates. More...
- Properties inherited from Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter
GeometryTypes | GeometryType [get, protected set]
Gets type of the geometry to import. More...
- Properties inherited from Deltares.Standard.Forms.DExpress.IShapeImporter
GeometryTypes | GeometryType [get]
Gets type of the geometry to import. More...

Constructor & Destructor Documentation

Deltares.Standard.Forms.DExpress.ShapeImporters.PointImporter.PointImporter ( )

Initializes a new instance of the PointImporter class.

Member Function Documentation

override void Deltares.Standard.Forms.DExpress.ShapeImporters.PointImporter.ImportShapeGeometry | ( | IBasicGeometry | geometry,
 |  | object | target
 | ) |  |
virtual

Imports geometry data on the target object

Parameters
geometry | The geometry data to import from
target | The target object to set data on

Implements Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter.

Generated on Tue Dec 15 2015 18:15:33 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • ShapeImporters
  • PointImporter
Deltares.Standard.Forms.DExpress.ShapeImporters.PointImporter Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.ShapeImporters.PointImporter, including all inherited members.

GeometryType | Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter |
GetLoop(ILinearRing ring) (defined in Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter) | Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter | protected
GetPoints(ILinearRing ring) | Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter | protected
GetPoints(IEnumerable< Coordinate > coordinates) | Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter | protected
ImportShapeGeometry(IBasicGeometry geometry, object target) | Deltares.Standard.Forms.DExpress.ShapeImporters.PointImporter | virtual
PointImporter() | Deltares.Standard.Forms.DExpress.ShapeImporters.PointImporter |
ShapeImporter(GeometryTypes type) (defined in Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter) | Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter | protected
ThrowIfGeometryIsNotValid(IBasicGeometry geometry) | Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter | protected
ThrowIfTargetIsNull(object target, string message) | Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter | protected
ThrowIfTargetIsNull(object target) | Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter | protected
Generated on Tue Dec 15 2015 18:15:33 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.ShapeImporters.PolygonImporter Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • ShapeImporters
  • PolygonImporter
Public Member Functions | List of all members
Deltares.Standard.Forms.DExpress.ShapeImporters.PolygonImporter Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.ShapeImporters.PolygonImporter:
Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter Deltares.Standard.Forms.DExpress.IShapeImporter

Public Member Functions

PolygonImporter ()
Initializes a new instance of the PolygonImporter class. More...
override void ImportShapeGeometry (IBasicGeometry geometry, object target)
Imports geometry data on the target object More...

Additional Inherited Members

- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter
ShapeImporter (GeometryTypes type)
void | ThrowIfGeometryIsNotValid (IBasicGeometry geometry)
Throws if geometry is not valid. More...
void | ThrowIfTargetIsNull (object target, string message)
Throws if target is not valid. More...
void | ThrowIfTargetIsNull (object target)
Throws if target is not valid (null). More...
IGeographicLoop | GetLoop (ILinearRing ring)
IEnumerable< GeographicPoint > | GetPoints (ILinearRing ring)
Gets the points. More...
IEnumerable< GeographicPoint > | GetPoints (IEnumerable< Coordinate > coordinates)
Gets geographical points from DotSpatial coordinates. More...
- Properties inherited from Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter
GeometryTypes | GeometryType [get, protected set]
Gets type of the geometry to import. More...
- Properties inherited from Deltares.Standard.Forms.DExpress.IShapeImporter
GeometryTypes | GeometryType [get]
Gets type of the geometry to import. More...

Constructor & Destructor Documentation

Deltares.Standard.Forms.DExpress.ShapeImporters.PolygonImporter.PolygonImporter ( )

Initializes a new instance of the PolygonImporter class.

Member Function Documentation

override void Deltares.Standard.Forms.DExpress.ShapeImporters.PolygonImporter.ImportShapeGeometry | ( | IBasicGeometry | geometry,
 |  | object | target
 | ) |  |
virtual

Imports geometry data on the target object

Parameters
geometry | The geometry data to import from
target | The target object to set data on

Implements Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter.

Generated on Tue Dec 15 2015 18:15:33 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • ShapeImporters
  • PolygonImporter
Deltares.Standard.Forms.DExpress.ShapeImporters.PolygonImporter Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.ShapeImporters.PolygonImporter, including all inherited members.

GeometryType | Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter |
GetLoop(ILinearRing ring) (defined in Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter) | Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter | protected
GetPoints(ILinearRing ring) | Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter | protected
GetPoints(IEnumerable< Coordinate > coordinates) | Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter | protected
ImportShapeGeometry(IBasicGeometry geometry, object target) | Deltares.Standard.Forms.DExpress.ShapeImporters.PolygonImporter | virtual
PolygonImporter() | Deltares.Standard.Forms.DExpress.ShapeImporters.PolygonImporter |
ShapeImporter(GeometryTypes type) (defined in Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter) | Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter | protected
ThrowIfGeometryIsNotValid(IBasicGeometry geometry) | Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter | protected
ThrowIfTargetIsNull(object target, string message) | Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter | protected
ThrowIfTargetIsNull(object target) | Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter | protected
Generated on Tue Dec 15 2015 18:15:33 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • ShapeImporters
  • ShapeImporter
Public Member Functions | Protected Member Functions | Properties | List of all members
Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter Class Referenceabstract
Inheritance diagram for Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter:
Deltares.Standard.Forms.DExpress.IShapeImporter Deltares.Standard.Forms.DExpress.ShapeImporters.LineStringImporter Deltares.Standard.Forms.DExpress.ShapeImporters.MultiLineStringImporter Deltares.Standard.Forms.DExpress.ShapeImporters.MultiPolygonImporter Deltares.Standard.Forms.DExpress.ShapeImporters.PointImporter Deltares.Standard.Forms.DExpress.ShapeImporters.PolygonImporter Deltares.Standard.Forms.DExpress.ShapeImporters.SmartLineStringImporter

Public Member Functions

abstract void ImportShapeGeometry (IBasicGeometry geometry, object target)
Imports geometry data on the target object More...

Protected Member Functions

ShapeImporter (GeometryTypes type)
void | ThrowIfGeometryIsNotValid (IBasicGeometry geometry)
Throws if geometry is not valid. More...
void | ThrowIfTargetIsNull (object target, string message)
Throws if target is not valid. More...
void | ThrowIfTargetIsNull (object target)
Throws if target is not valid (null). More...
IGeographicLoop | GetLoop (ILinearRing ring)
IEnumerable< GeographicPoint > | GetPoints (ILinearRing ring)
Gets the points. More...
IEnumerable< GeographicPoint > | GetPoints (IEnumerable< Coordinate > coordinates)
Gets geographical points from DotSpatial coordinates. More...

Properties

GeometryTypes | GeometryType [get, protected set]
Gets type of the geometry to import. More...
- Properties inherited from Deltares.Standard.Forms.DExpress.IShapeImporter
GeometryTypes | GeometryType [get]
Gets type of the geometry to import. More...

Member Function Documentation

IEnumerable<GeographicPoint> Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter.GetPoints ( ILinearRing ring )
protected

Gets the points.

Parameters
ring The ring.
Returns
IEnumerable<GeographicPoint> Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter.GetPoints ( IEnumerable< Coordinate > coordinates )
protected

Gets geographical points from DotSpatial coordinates.

Parameters
coordinates The coordinates.
Returns
abstract void Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter.ImportShapeGeometry | ( | IBasicGeometry | geometry,
 |  | object | target
 | ) |  |
pure virtual

Imports geometry data on the target object

Parameters
geometry | The geometry data to import from
target | The target object to set data on

Implements Deltares.Standard.Forms.DExpress.IShapeImporter.

Implemented in Deltares.Standard.Forms.DExpress.ShapeImporters.LineStringImporter, Deltares.Standard.Forms.DExpress.ShapeImporters.SmartLineStringImporter, Deltares.Standard.Forms.DExpress.ShapeImporters.PolygonImporter, Deltares.Standard.Forms.DExpress.ShapeImporters.PointImporter, Deltares.Standard.Forms.DExpress.ShapeImporters.MultiLineStringImporter, and Deltares.Standard.Forms.DExpress.ShapeImporters.MultiPolygonImporter.

void Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter.ThrowIfGeometryIsNotValid ( IBasicGeometry geometry )
protected

Throws if geometry is not valid.

Parameters
geometry The geometry.
void Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter.ThrowIfTargetIsNull | ( | object | target,
 |  | string | message
 | ) |  |
protected

Throws if target is not valid.

Parameters
target | The target.
message | The message to use in the exception
void Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter.ThrowIfTargetIsNull ( object target )
protected

Throws if target is not valid (null).

Parameters
target The target.

Property Documentation

GeometryTypes Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter.GeometryType
getprotected set

Gets type of the geometry to import.

The type of the geometry to import.

Generated on Tue Dec 15 2015 18:15:33 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • ShapeImporters
  • ShapeImporter
Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter, including all inherited members.

GeometryType | Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter |
GetLoop(ILinearRing ring) (defined in Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter) | Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter | protected
GetPoints(ILinearRing ring) | Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter | protected
GetPoints(IEnumerable< Coordinate > coordinates) | Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter | protected
ImportShapeGeometry(IBasicGeometry geometry, object target) | Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter | pure virtual
ShapeImporter(GeometryTypes type) (defined in Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter) | Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter | protected
ThrowIfGeometryIsNotValid(IBasicGeometry geometry) | Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter | protected
ThrowIfTargetIsNull(object target, string message) | Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter | protected
ThrowIfTargetIsNull(object target) | Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter | protected
Generated on Tue Dec 15 2015 18:15:33 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.ShapeImporters.SmartLineStringImporter Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • ShapeImporters
  • SmartLineStringImporter
Public Member Functions | List of all members
Deltares.Standard.Forms.DExpress.ShapeImporters.SmartLineStringImporter Class Reference

This class initializes the geometry of different types in the data model from imported geometries of type GeometryType.LineString. Either the geometry of the type in the data model IS a point string, or ACCEPTS a point string. This can be defined by implementing the IGeographicString or the IGeographicPointFromString interfaces. More...

Inheritance diagram for Deltares.Standard.Forms.DExpress.ShapeImporters.SmartLineStringImporter:
Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter Deltares.Standard.Forms.DExpress.IShapeImporter

Public Member Functions

SmartLineStringImporter ()
Initializes a new instance of the SmartLineStringImporter class. More...
override void ImportShapeGeometry (IBasicGeometry geometry, object target)
Imports geometry data on the target object More...

Additional Inherited Members

- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter
ShapeImporter (GeometryTypes type)
void | ThrowIfGeometryIsNotValid (IBasicGeometry geometry)
Throws if geometry is not valid. More...
void | ThrowIfTargetIsNull (object target, string message)
Throws if target is not valid. More...
void | ThrowIfTargetIsNull (object target)
Throws if target is not valid (null). More...
IGeographicLoop | GetLoop (ILinearRing ring)
IEnumerable< GeographicPoint > | GetPoints (ILinearRing ring)
Gets the points. More...
IEnumerable< GeographicPoint > | GetPoints (IEnumerable< Coordinate > coordinates)
Gets geographical points from DotSpatial coordinates. More...
- Properties inherited from Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter
GeometryTypes | GeometryType [get, protected set]
Gets type of the geometry to import. More...
- Properties inherited from Deltares.Standard.Forms.DExpress.IShapeImporter
GeometryTypes | GeometryType [get]
Gets type of the geometry to import. More...

Detailed Description

This class initializes the geometry of different types in the data model from imported geometries of type GeometryType.LineString. Either the geometry of the type in the data model IS a point string, or ACCEPTS a point string. This can be defined by implementing the IGeographicString or the IGeographicPointFromString interfaces.

Constructor & Destructor Documentation

Deltares.Standard.Forms.DExpress.ShapeImporters.SmartLineStringImporter.SmartLineStringImporter ( )

Initializes a new instance of the SmartLineStringImporter class.

Member Function Documentation

override void Deltares.Standard.Forms.DExpress.ShapeImporters.SmartLineStringImporter.ImportShapeGeometry | ( | IBasicGeometry | geometry,
 |  | object | target
 | ) |  |
virtual

Imports geometry data on the target object

Parameters
geometry | The geometry data to import from
target | The target object to set data on

Implements Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter.

Generated on Tue Dec 15 2015 18:15:34 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • ShapeImporters
  • SmartLineStringImporter
Deltares.Standard.Forms.DExpress.ShapeImporters.SmartLineStringImporter Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.ShapeImporters.SmartLineStringImporter, including all inherited members.

GeometryType | Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter |
GetLoop(ILinearRing ring) (defined in Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter) | Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter | protected
GetPoints(ILinearRing ring) | Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter | protected
GetPoints(IEnumerable< Coordinate > coordinates) | Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter | protected
ImportShapeGeometry(IBasicGeometry geometry, object target) | Deltares.Standard.Forms.DExpress.ShapeImporters.SmartLineStringImporter | virtual
ShapeImporter(GeometryTypes type) (defined in Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter) | Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter | protected
SmartLineStringImporter() | Deltares.Standard.Forms.DExpress.ShapeImporters.SmartLineStringImporter |
ThrowIfGeometryIsNotValid(IBasicGeometry geometry) | Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter | protected
ThrowIfTargetIsNull(object target, string message) | Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter | protected
ThrowIfTargetIsNull(object target) | Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter | protected
Generated on Tue Dec 15 2015 18:15:34 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.AboutControl Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • AboutControl
Protected Member Functions | Properties | List of all members
Deltares.Standard.Forms.DExpress.AboutControl Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.AboutControl:
Deltares.Standard.Forms.IPropertyControl

Protected Member Functions

override void Dispose (bool disposing)
Clean up any resources being used. More...

Properties

bool | IsVisible [get]
object | SelectedObject [get, set]
- Properties inherited from Deltares.Standard.Forms.IPropertyControl
string | Name [get, set]
Gets or sets the name to be displayed property. More...
object | SelectedObject [get, set]
Gets or sets the object to be displayed in the property window. More...
bool | IsVisible [get]
Whether or not the property control should be displayed. More...

Member Function Documentation

override void Deltares.Standard.Forms.DExpress.AboutControl.Dispose ( bool disposing )
protected

Clean up any resources being used.

Parameters
disposing true if managed resources should be disposed; otherwise, false.
Generated on Tue Dec 15 2015 18:14:40 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • AboutControl
Deltares.Standard.Forms.DExpress.AboutControl Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.AboutControl, including all inherited members.

AboutControl() (defined in Deltares.Standard.Forms.DExpress.AboutControl) | Deltares.Standard.Forms.DExpress.AboutControl |
Dispose(bool disposing) | Deltares.Standard.Forms.DExpress.AboutControl | protected
IsVisible (defined in Deltares.Standard.Forms.DExpress.AboutControl) | Deltares.Standard.Forms.DExpress.AboutControl |
Name | Deltares.Standard.Forms.IPropertyControl |
SelectedObject (defined in Deltares.Standard.Forms.DExpress.AboutControl) | Deltares.Standard.Forms.DExpress.AboutControl |
Generated on Tue Dec 15 2015 18:14:40 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.AbstractShapeFileImporter Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • AbstractShapeFileImporter
Public Types | Public Member Functions | Protected Member Functions | Static Protected Member Functions | List of all members
Deltares.Standard.Forms.DExpress.AbstractShapeFileImporter Class Referenceabstract

This class is reponsible to handle the import from ShapeFiles More...

Inheritance diagram for Deltares.Standard.Forms.DExpress.AbstractShapeFileImporter:
Deltares.Standard.Forms.DExpress.ShapeFileMetaDataImporter Deltares.Standard.Forms.DExpress.ShapeFileImporter

Public Types

enum GeometryTypes {
Point = 1, LineString = 2, Polygon = 3, MultiPoint = 4,
MultiLineString = 5, MultiPolygon = 6, GeometryCollection = 7
}
Defines the different geometry types More...

Public Member Functions

void | RegisterShapeImporter (IShapeImporter importer)
Registers the shape importer. More...
override void | Import ()
Imports data from the shape file. More...

Protected Member Functions

AbstractShapeFileImporter (string filename, Type type, IDataFactory factory, FieldPropertyMap propertyMaps)
abstract void | ImportFeature (object target, IFeature feature, IFeatureSet featureSet)
IShapeImporter | GetConverter (string geometryType)
object | CreateTarget (FieldDefinition idFieldDefinition, IFeature feature, IFeatureSet featureSet)

Static Protected Member Functions

static object GetValue (FieldDefinition field, IFeature feature, IFeatureSet featureSet)

Detailed Description

This class is reponsible to handle the import from ShapeFiles

Member Enumeration Documentation

enum Deltares.Standard.Forms.DExpress.AbstractShapeFileImporter.GeometryTypes
strong

Defines the different geometry types

Member Function Documentation

override void Deltares.Standard.Forms.DExpress.AbstractShapeFileImporter.Import ( )

Imports data from the shape file.

void Deltares.Standard.Forms.DExpress.AbstractShapeFileImporter.RegisterShapeImporter ( IShapeImporter importer )

Registers the shape importer.

Parameters
importer The importer.

References Deltares.Standard.Forms.DExpress.IShapeImporter.GeometryType.

Generated on Tue Dec 15 2015 18:14:40 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • AbstractShapeFileImporter
Deltares.Standard.Forms.DExpress.AbstractShapeFileImporter Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.AbstractShapeFileImporter, including all inherited members.

AbstractShapeFileImporter() (defined in Deltares.Standard.Forms.DExpress.AbstractShapeFileImporter) | Deltares.Standard.Forms.DExpress.AbstractShapeFileImporter | protected
AbstractShapeFileImporter(string filename, Type type, IDataFactory factory, FieldPropertyMap propertyMaps) (defined in Deltares.Standard.Forms.DExpress.AbstractShapeFileImporter) | Deltares.Standard.Forms.DExpress.AbstractShapeFileImporter | protected
CreateTarget(FieldDefinition idFieldDefinition, IFeature feature, IFeatureSet featureSet) (defined in Deltares.Standard.Forms.DExpress.AbstractShapeFileImporter) | Deltares.Standard.Forms.DExpress.AbstractShapeFileImporter | protected
GeometryTypes enum name | Deltares.Standard.Forms.DExpress.AbstractShapeFileImporter |
GetConverter(string geometryType) (defined in Deltares.Standard.Forms.DExpress.AbstractShapeFileImporter) | Deltares.Standard.Forms.DExpress.AbstractShapeFileImporter | protected
GetValue(FieldDefinition field, IFeature feature, IFeatureSet featureSet) (defined in Deltares.Standard.Forms.DExpress.AbstractShapeFileImporter) | Deltares.Standard.Forms.DExpress.AbstractShapeFileImporter | protectedstatic
Import() | Deltares.Standard.Forms.DExpress.AbstractShapeFileImporter |
ImportFeature(object target, IFeature feature, IFeatureSet featureSet) (defined in Deltares.Standard.Forms.DExpress.AbstractShapeFileImporter) | Deltares.Standard.Forms.DExpress.AbstractShapeFileImporter | protectedpure virtual
RegisterShapeImporter(IShapeImporter importer) | Deltares.Standard.Forms.DExpress.AbstractShapeFileImporter |
Generated on Tue Dec 15 2015 18:14:40 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.ActionSubControlFactory Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • ActionSubControlFactory
Public Member Functions | List of all members
Deltares.Standard.Forms.DExpress.ActionSubControlFactory Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.ActionSubControlFactory:
Deltares.Standard.Forms.DExpress.IActionSubControlFactory< PanelAction >

Public Member Functions

PanelAction | CreateBoundControl (MethodInfo methodInfo, Type dataType, Component parentComponent)
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.IActionSubControlFactory< PanelAction >
ControlType | CreateBoundControl (MethodInfo methodInfo, Type dataType, Component parentComponent)
Generated on Tue Dec 15 2015 18:14:40 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • ActionSubControlFactory
Deltares.Standard.Forms.DExpress.ActionSubControlFactory Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.ActionSubControlFactory, including all inherited members.

CreateBoundControl(MethodInfo methodInfo, Type dataType, Component parentComponent) (defined in Deltares.Standard.Forms.DExpress.ActionSubControlFactory) Deltares.Standard.Forms.DExpress.ActionSubControlFactory
Generated on Tue Dec 15 2015 18:14:40 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.ActiveWindowReport Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • ActiveWindowReport
Public Member Functions | Public Attributes | Protected Member Functions | List of all members
Deltares.Standard.Forms.DExpress.ActiveWindowReport Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.ActiveWindowReport:

Public Member Functions

ActiveWindowReport (bool aIsLegendVisible, DProject aProjectIdentification, Bitmap aViewpictuere, Bitmap aBitmap)
void SetProjectProperties ()

Public Attributes

DevExpress.XtraReports.UI.XRPanel xrPanel2

Protected Member Functions

override void Dispose (bool disposing)
Clean up any resources being used. More...

Member Function Documentation

override void Deltares.Standard.Forms.DExpress.ActiveWindowReport.Dispose ( bool disposing )
protected

Clean up any resources being used.

Parameters
disposing true if managed resources should be disposed; otherwise, false.
Generated on Tue Dec 15 2015 18:14:41 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • ActiveWindowReport
Deltares.Standard.Forms.DExpress.ActiveWindowReport Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.ActiveWindowReport, including all inherited members.

ActiveWindowReport() (defined in Deltares.Standard.Forms.DExpress.ActiveWindowReport) | Deltares.Standard.Forms.DExpress.ActiveWindowReport |
ActiveWindowReport(bool aIsLegendVisible, DProject aProjectIdentification, Bitmap aViewpictuere, Bitmap aBitmap) (defined in Deltares.Standard.Forms.DExpress.ActiveWindowReport) | Deltares.Standard.Forms.DExpress.ActiveWindowReport |
Dispose(bool disposing) | Deltares.Standard.Forms.DExpress.ActiveWindowReport | protected
SetProjectProperties() (defined in Deltares.Standard.Forms.DExpress.ActiveWindowReport) | Deltares.Standard.Forms.DExpress.ActiveWindowReport |
xrPanel2 (defined in Deltares.Standard.Forms.DExpress.ActiveWindowReport) | Deltares.Standard.Forms.DExpress.ActiveWindowReport |
Generated on Tue Dec 15 2015 18:14:41 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.AggregatePlugin< ProjectType > Class Template Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • AggregatePlugin
Public Member Functions | Properties | List of all members
Deltares.Standard.Forms.DExpress.AggregatePlugin< ProjectType > Class Template Reference

TODO: Comment (Only used by Koswat, so not commented by DSoil-Team) More...

Inheritance diagram for Deltares.Standard.Forms.DExpress.AggregatePlugin< ProjectType >:
Deltares.Standard.Forms.DExpress.IMainFormPlugin

Public Member Functions

void | AddMenu< BoundType > (BarLinksHolder menu, Expression< Action< BoundType >> action, bool beginGroup=false)
void | AddPlugin (IMainFormPlugin plugin)
void | AddPlugins (IEnumerable< IMainFormPlugin > plugins)
void | RegisterAll (MainForm mainForm)
Component | GetComponentForType (Type type)
virtual void | Configure (MainForm mainForm)
virtual void | Assign (object source)

Properties

MainForm | MainForm [get]
ProjectType | CurrentProject [get, set]

Detailed Description

TODO: Comment (Only used by Koswat, so not commented by DSoil-Team)

Template Parameters
ProjectType The type of the project type.
Type Constraints
ProjectType : class
Generated on Tue Dec 15 2015 18:14:41 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • AggregatePlugin
Deltares.Standard.Forms.DExpress.AggregatePlugin< ProjectType > Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.AggregatePlugin< ProjectType >, including all inherited members.

AddMenu< BoundType >(BarLinksHolder menu, Expression< Action< BoundType >> action, bool beginGroup=false) (defined in Deltares.Standard.Forms.DExpress.AggregatePlugin< ProjectType >) | Deltares.Standard.Forms.DExpress.AggregatePlugin< ProjectType > |
AddPlugin(IMainFormPlugin plugin) (defined in Deltares.Standard.Forms.DExpress.AggregatePlugin< ProjectType >) | Deltares.Standard.Forms.DExpress.AggregatePlugin< ProjectType > |
AddPlugins(IEnumerable< IMainFormPlugin > plugins) (defined in Deltares.Standard.Forms.DExpress.AggregatePlugin< ProjectType >) | Deltares.Standard.Forms.DExpress.AggregatePlugin< ProjectType > |
AggregatePlugin() (defined in Deltares.Standard.Forms.DExpress.AggregatePlugin< ProjectType >) | Deltares.Standard.Forms.DExpress.AggregatePlugin< ProjectType > |
Assign(object source) (defined in Deltares.Standard.Forms.DExpress.AggregatePlugin< ProjectType >) | Deltares.Standard.Forms.DExpress.AggregatePlugin< ProjectType > | virtual
Configure(MainForm mainForm) (defined in Deltares.Standard.Forms.DExpress.AggregatePlugin< ProjectType >) | Deltares.Standard.Forms.DExpress.AggregatePlugin< ProjectType > | virtual
CurrentProject (defined in Deltares.Standard.Forms.DExpress.AggregatePlugin< ProjectType >) | Deltares.Standard.Forms.DExpress.AggregatePlugin< ProjectType > |
GetComponentForType(Type type) (defined in Deltares.Standard.Forms.DExpress.AggregatePlugin< ProjectType >) | Deltares.Standard.Forms.DExpress.AggregatePlugin< ProjectType > |
MainForm (defined in Deltares.Standard.Forms.DExpress.AggregatePlugin< ProjectType >) | Deltares.Standard.Forms.DExpress.AggregatePlugin< ProjectType > |
RegisterAll(MainForm mainForm) (defined in Deltares.Standard.Forms.DExpress.AggregatePlugin< ProjectType >) | Deltares.Standard.Forms.DExpress.AggregatePlugin< ProjectType > |
Generated on Tue Dec 15 2015 18:14:41 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.AssignStrategy Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • AssignStrategy
Public Member Functions | Protected Member Functions | List of all members
Deltares.Standard.Forms.DExpress.AssignStrategy Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.AssignStrategy:
Deltares.Standard.Forms.DExpress.GridEditValueStrategy

Public Member Functions

override double | DefaultForSelected (GridView view)
Determines the default value based on the selected values. Not all implementations will use the selected values, but by passing the view, we can generalize the method call. More...
override string | ToString ()
This method has to be overridden so it has a proper representation in the UI. More...
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.GridEditValueStrategy
void | EvaluateForSelected (GridView view, double modificationValue)
Sets new cell values by evaluating the modification value and using the current strategy. More...

Protected Member Functions

override double Evaluate (double value, double modificationValue)
The implementation of this method is used in the EvaluateForSelected method. More...

Additional Inherited Members

- Static Public Attributes inherited from Deltares.Standard.Forms.DExpress.GridEditValueStrategy
static readonly GridEditValueStrategy[] Strategies
Collection of all the strategies which are defined in this file. This is a static list so the strategies will only be instantiated once. Using instantiations make polymorphism possible. More...

Member Function Documentation

override double Deltares.Standard.Forms.DExpress.AssignStrategy.DefaultForSelected ( GridView view )
virtual

Determines the default value based on the selected values. Not all implementations will use the selected values, but by passing the view, we can generalize the method call.

Parameters
view The view (which may not be used at all) containing selected values (or not).
Returns
A sensible default for the strategy, or null if no sensible default can be given.

Implements Deltares.Standard.Forms.DExpress.GridEditValueStrategy.

override double Deltares.Standard.Forms.DExpress.AssignStrategy.Evaluate | ( | double | value,
 |  | double | modificationValue
 | ) |  |
protectedvirtual

The implementation of this method is used in the EvaluateForSelected method.

Parameters
value | The current value.
modificationValue | The value used in evaluating a new value.
Returns
The new value.

Implements Deltares.Standard.Forms.DExpress.GridEditValueStrategy.

override string Deltares.Standard.Forms.DExpress.AssignStrategy.ToString ( )
virtual

This method has to be overridden so it has a proper representation in the UI.

Returns

Implements Deltares.Standard.Forms.DExpress.GridEditValueStrategy.

Generated on Tue Dec 15 2015 18:14:41 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • AssignStrategy
Deltares.Standard.Forms.DExpress.AssignStrategy Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.AssignStrategy, including all inherited members.

DefaultForSelected(GridView view) | Deltares.Standard.Forms.DExpress.AssignStrategy | virtual
Evaluate(double value, double modificationValue) | Deltares.Standard.Forms.DExpress.AssignStrategy | protectedvirtual
EvaluateForSelected(GridView view, double modificationValue) | Deltares.Standard.Forms.DExpress.GridEditValueStrategy |
Strategies | Deltares.Standard.Forms.DExpress.GridEditValueStrategy | static
ToString() | Deltares.Standard.Forms.DExpress.AssignStrategy | virtual
Generated on Tue Dec 15 2015 18:14:41 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.BarButtonItemBinding Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • BarButtonItemBinding
Public Member Functions | List of all members
Deltares.Standard.Forms.DExpress.BarButtonItemBinding Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.BarButtonItemBinding:
Deltares.Standard.Forms.DExpress.BarItemBinding Deltares.Standard.Forms.DExpress.ComponentBinding

Public Member Functions

BarButtonItemBinding (Component component)
override void | Initialize (BindPropertyInfo propertyInfo, params string[] properties)
override void | SetValue (object value)
override object | GetValue ()
override void | SetForegroundColor (Color color)
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.BarItemBinding
BarItemBinding (Component component)
override void | Initialize (BindPropertyInfo propertyInfo, params string[] properties)
override void | SetLabel (string text)
override void | SetDescription (string description)
override void | SetVisible (bool visible)
override void | SetEnabled (bool enabled)
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
ComponentBinding (Component component)
virtual void | Initialize (BindPropertyInfo propertyInfo, Type rootObjectType, params string[] properties)
virtual void | SetTrueMapping (object trueMapping)
virtual void | SetValue (object value, object parent)
virtual void | SetDomain (ICollection collection)
virtual void | SetBackgroundColor (Color color)
virtual void | Refresh ()
virtual void | Invalidate ()
virtual void | RegisterSelectionAssignment (Component targetComponent, IConverter converter=null)
Indicates that the selection of the bound control must be assigned to another control. More...
virtual void | SetControlColors (Color fore, Color back)
Sets the controls foreground and background colors. Can be overridden by a specific binding to set other colors if necessary. More...

Additional Inherited Members

- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
void | RaiseValueChanged ()
void | RaiseLeave ()
void | RaiseActionPerformed ()
Type | GetGenericType (Type type)
string | ValueToString (object value)
bool | IsAssociatedPropertyVisible (object source, BindPropertyInfo associatedPropertyInfo)
Indicates whether the associated property (i.e. the property which is used to display the original property in a textbox) is visible More...
void | EditFileInfo (object source, BindPropertyInfo propertyInfo)
string | EditFileInfo (string value, string format, string label, string description, bool isDirectory)
string | GetDoubleString (string text)
bool | HasValidNumericValue (string text)
double | GetNumericValue (string text)
List< BindPropertyInfo > | GetDictionaryProperties (ICollection domain, BindPropertyInfo dynamicPropertyInfo)
- Protected Attributes inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
BindPropertyInfo | propInfo
- Properties inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
Component | Component [get]
virtual bool | IsTransparant [get]
virtual HandleType | HandleDelayed [get]
virtual bool | HasDomain [get]
- Events inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
EventHandler< EventArgs > | ActionPerformed
EventHandler< EventArgs > | Leave
EventHandler< EventArgs > | ValueChanged
Generated on Tue Dec 15 2015 18:14:42 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • BarButtonItemBinding
Deltares.Standard.Forms.DExpress.BarButtonItemBinding Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.BarButtonItemBinding, including all inherited members.

ActionPerformed (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
BarButtonItemBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.BarButtonItemBinding) | Deltares.Standard.Forms.DExpress.BarButtonItemBinding |
BarItemBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.BarItemBinding) | Deltares.Standard.Forms.DExpress.BarItemBinding |
Component (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ComponentBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
EditFileInfo(object source, BindPropertyInfo propertyInfo) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
EditFileInfo(string value, string format, string label, string description, bool isDirectory) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetDictionaryProperties(ICollection domain, BindPropertyInfo dynamicPropertyInfo) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetDoubleString(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetGenericType(Type type) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetNumericValue(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetValue() (defined in Deltares.Standard.Forms.DExpress.BarButtonItemBinding) | Deltares.Standard.Forms.DExpress.BarButtonItemBinding | virtual
HandleDelayed (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
HasDomain (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
HasValidNumericValue(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Initialize(BindPropertyInfo propertyInfo, params string[] properties) (defined in Deltares.Standard.Forms.DExpress.BarButtonItemBinding) | Deltares.Standard.Forms.DExpress.BarButtonItemBinding | virtual
Initialize(BindPropertyInfo propertyInfo, Type rootObjectType, params string[] properties) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
Invalidate() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
IsAssociatedPropertyVisible(object source, BindPropertyInfo associatedPropertyInfo) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
IsTransparant (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
Leave (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
propInfo (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseActionPerformed() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseLeave() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseValueChanged() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Refresh() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
RegisterSelectionAssignment(Component targetComponent, IConverter converter=null) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetBackgroundColor(Color color) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetControlColors(Color fore, Color back) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetDescription(string description) (defined in Deltares.Standard.Forms.DExpress.BarItemBinding) | Deltares.Standard.Forms.DExpress.BarItemBinding | virtual
SetDomain(ICollection collection) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetEnabled(bool enabled) (defined in Deltares.Standard.Forms.DExpress.BarItemBinding) | Deltares.Standard.Forms.DExpress.BarItemBinding | virtual
SetForegroundColor(Color color) (defined in Deltares.Standard.Forms.DExpress.BarButtonItemBinding) | Deltares.Standard.Forms.DExpress.BarButtonItemBinding | virtual
SetLabel(string text) (defined in Deltares.Standard.Forms.DExpress.BarItemBinding) | Deltares.Standard.Forms.DExpress.BarItemBinding | virtual
SetTrueMapping(object trueMapping) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetValue(object value) (defined in Deltares.Standard.Forms.DExpress.BarButtonItemBinding) | Deltares.Standard.Forms.DExpress.BarButtonItemBinding | virtual
SetValue(object value, object parent) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetVisible(bool visible) (defined in Deltares.Standard.Forms.DExpress.BarItemBinding) | Deltares.Standard.Forms.DExpress.BarItemBinding | virtual
ValueChanged (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ValueToString(object value) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Generated on Tue Dec 15 2015 18:14:42 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.BarEditItemBinding Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • BarEditItemBinding
Public Member Functions | Properties | List of all members
Deltares.Standard.Forms.DExpress.BarEditItemBinding Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.BarEditItemBinding:
Deltares.Standard.Forms.DExpress.BarItemBinding Deltares.Standard.Forms.DExpress.ComponentBinding

Public Member Functions

BarEditItemBinding (Component component)
override void | Initialize (BindPropertyInfo propertyInfo, params string[] properties)
override void | SetValue (object value)
override object | GetValue ()
override void | SetDomain (ICollection domain)
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.BarItemBinding
BarItemBinding (Component component)
override void | Initialize (BindPropertyInfo propertyInfo, params string[] properties)
override void | SetLabel (string text)
override void | SetDescription (string description)
override void | SetVisible (bool visible)
override void | SetEnabled (bool enabled)
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
ComponentBinding (Component component)
virtual void | Initialize (BindPropertyInfo propertyInfo, Type rootObjectType, params string[] properties)
virtual void | SetTrueMapping (object trueMapping)
virtual void | SetValue (object value, object parent)
virtual void | SetForegroundColor (Color color)
virtual void | SetBackgroundColor (Color color)
virtual void | Refresh ()
virtual void | Invalidate ()
virtual void | RegisterSelectionAssignment (Component targetComponent, IConverter converter=null)
Indicates that the selection of the bound control must be assigned to another control. More...
virtual void | SetControlColors (Color fore, Color back)
Sets the controls foreground and background colors. Can be overridden by a specific binding to set other colors if necessary. More...

Properties

override HandleType | HandleDelayed [get]
override bool | HasDomain [get]
- Properties inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
Component | Component [get]
virtual bool | IsTransparant [get]
virtual HandleType | HandleDelayed [get]
virtual bool | HasDomain [get]

Additional Inherited Members

- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
void | RaiseValueChanged ()
void | RaiseLeave ()
void | RaiseActionPerformed ()
Type | GetGenericType (Type type)
string | ValueToString (object value)
bool | IsAssociatedPropertyVisible (object source, BindPropertyInfo associatedPropertyInfo)
Indicates whether the associated property (i.e. the property which is used to display the original property in a textbox) is visible More...
void | EditFileInfo (object source, BindPropertyInfo propertyInfo)
string | EditFileInfo (string value, string format, string label, string description, bool isDirectory)
string | GetDoubleString (string text)
bool | HasValidNumericValue (string text)
double | GetNumericValue (string text)
List< BindPropertyInfo > | GetDictionaryProperties (ICollection domain, BindPropertyInfo dynamicPropertyInfo)
- Protected Attributes inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
BindPropertyInfo | propInfo
- Events inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
EventHandler< EventArgs > | ActionPerformed
EventHandler< EventArgs > | Leave
EventHandler< EventArgs > | ValueChanged
Generated on Tue Dec 15 2015 18:14:42 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • BarEditItemBinding
Deltares.Standard.Forms.DExpress.BarEditItemBinding Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.BarEditItemBinding, including all inherited members.

ActionPerformed (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
BarEditItemBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.BarEditItemBinding) | Deltares.Standard.Forms.DExpress.BarEditItemBinding |
BarItemBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.BarItemBinding) | Deltares.Standard.Forms.DExpress.BarItemBinding |
Component (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ComponentBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
EditFileInfo(object source, BindPropertyInfo propertyInfo) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
EditFileInfo(string value, string format, string label, string description, bool isDirectory) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetDictionaryProperties(ICollection domain, BindPropertyInfo dynamicPropertyInfo) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetDoubleString(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetGenericType(Type type) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetNumericValue(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetValue() (defined in Deltares.Standard.Forms.DExpress.BarEditItemBinding) | Deltares.Standard.Forms.DExpress.BarEditItemBinding | virtual
HandleDelayed (defined in Deltares.Standard.Forms.DExpress.BarEditItemBinding) | Deltares.Standard.Forms.DExpress.BarEditItemBinding |
HasDomain (defined in Deltares.Standard.Forms.DExpress.BarEditItemBinding) | Deltares.Standard.Forms.DExpress.BarEditItemBinding |
HasValidNumericValue(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Initialize(BindPropertyInfo propertyInfo, params string[] properties) (defined in Deltares.Standard.Forms.DExpress.BarEditItemBinding) | Deltares.Standard.Forms.DExpress.BarEditItemBinding | virtual
Initialize(BindPropertyInfo propertyInfo, Type rootObjectType, params string[] properties) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
Invalidate() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
IsAssociatedPropertyVisible(object source, BindPropertyInfo associatedPropertyInfo) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
IsTransparant (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
Leave (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
propInfo (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseActionPerformed() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseLeave() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseValueChanged() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Refresh() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
RegisterSelectionAssignment(Component targetComponent, IConverter converter=null) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetBackgroundColor(Color color) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetControlColors(Color fore, Color back) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetDescription(string description) (defined in Deltares.Standard.Forms.DExpress.BarItemBinding) | Deltares.Standard.Forms.DExpress.BarItemBinding | virtual
SetDomain(ICollection domain) (defined in Deltares.Standard.Forms.DExpress.BarEditItemBinding) | Deltares.Standard.Forms.DExpress.BarEditItemBinding | virtual
SetEnabled(bool enabled) (defined in Deltares.Standard.Forms.DExpress.BarItemBinding) | Deltares.Standard.Forms.DExpress.BarItemBinding | virtual
SetForegroundColor(Color color) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetLabel(string text) (defined in Deltares.Standard.Forms.DExpress.BarItemBinding) | Deltares.Standard.Forms.DExpress.BarItemBinding | virtual
SetTrueMapping(object trueMapping) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetValue(object value) (defined in Deltares.Standard.Forms.DExpress.BarEditItemBinding) | Deltares.Standard.Forms.DExpress.BarEditItemBinding | virtual
SetValue(object value, object parent) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetVisible(bool visible) (defined in Deltares.Standard.Forms.DExpress.BarItemBinding) | Deltares.Standard.Forms.DExpress.BarItemBinding | virtual
ValueChanged (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ValueToString(object value) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Generated on Tue Dec 15 2015 18:14:42 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.BarItemBinding Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • BarItemBinding
Public Member Functions | List of all members
Deltares.Standard.Forms.DExpress.BarItemBinding Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.BarItemBinding:
Deltares.Standard.Forms.DExpress.ComponentBinding Deltares.Standard.Forms.DExpress.BarButtonItemBinding Deltares.Standard.Forms.DExpress.BarEditItemBinding Deltares.Standard.Forms.DExpress.BarStaticItemBinding Deltares.Standard.Forms.DExpress.BarSubItemBinding

Public Member Functions

BarItemBinding (Component component)
override void | Initialize (BindPropertyInfo propertyInfo, params string[] properties)
override void | SetLabel (string text)
override void | SetDescription (string description)
override void | SetVisible (bool visible)
override void | SetEnabled (bool enabled)
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
ComponentBinding (Component component)
virtual void | Initialize (BindPropertyInfo propertyInfo, Type rootObjectType, params string[] properties)
virtual void | SetTrueMapping (object trueMapping)
virtual void | SetValue (object value)
virtual void | SetValue (object value, object parent)
virtual void | SetDomain (ICollection collection)
virtual object | GetValue ()
virtual void | SetForegroundColor (Color color)
virtual void | SetBackgroundColor (Color color)
virtual void | Refresh ()
virtual void | Invalidate ()
virtual void | RegisterSelectionAssignment (Component targetComponent, IConverter converter=null)
Indicates that the selection of the bound control must be assigned to another control. More...
virtual void | SetControlColors (Color fore, Color back)
Sets the controls foreground and background colors. Can be overridden by a specific binding to set other colors if necessary. More...

Additional Inherited Members

- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
void | RaiseValueChanged ()
void | RaiseLeave ()
void | RaiseActionPerformed ()
Type | GetGenericType (Type type)
string | ValueToString (object value)
bool | IsAssociatedPropertyVisible (object source, BindPropertyInfo associatedPropertyInfo)
Indicates whether the associated property (i.e. the property which is used to display the original property in a textbox) is visible More...
void | EditFileInfo (object source, BindPropertyInfo propertyInfo)
string | EditFileInfo (string value, string format, string label, string description, bool isDirectory)
string | GetDoubleString (string text)
bool | HasValidNumericValue (string text)
double | GetNumericValue (string text)
List< BindPropertyInfo > | GetDictionaryProperties (ICollection domain, BindPropertyInfo dynamicPropertyInfo)
- Protected Attributes inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
BindPropertyInfo | propInfo
- Properties inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
Component | Component [get]
virtual bool | IsTransparant [get]
virtual HandleType | HandleDelayed [get]
virtual bool | HasDomain [get]
- Events inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
EventHandler< EventArgs > | ActionPerformed
EventHandler< EventArgs > | Leave
EventHandler< EventArgs > | ValueChanged
Generated on Tue Dec 15 2015 18:14:42 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • BarItemBinding
Deltares.Standard.Forms.DExpress.BarItemBinding Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.BarItemBinding, including all inherited members.

ActionPerformed (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
BarItemBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.BarItemBinding) | Deltares.Standard.Forms.DExpress.BarItemBinding |
Component (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ComponentBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
EditFileInfo(object source, BindPropertyInfo propertyInfo) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
EditFileInfo(string value, string format, string label, string description, bool isDirectory) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetDictionaryProperties(ICollection domain, BindPropertyInfo dynamicPropertyInfo) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetDoubleString(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetGenericType(Type type) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetNumericValue(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetValue() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
HandleDelayed (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
HasDomain (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
HasValidNumericValue(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Initialize(BindPropertyInfo propertyInfo, params string[] properties) (defined in Deltares.Standard.Forms.DExpress.BarItemBinding) | Deltares.Standard.Forms.DExpress.BarItemBinding | virtual
Initialize(BindPropertyInfo propertyInfo, Type rootObjectType, params string[] properties) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
Invalidate() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
IsAssociatedPropertyVisible(object source, BindPropertyInfo associatedPropertyInfo) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
IsTransparant (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
Leave (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
propInfo (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseActionPerformed() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseLeave() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseValueChanged() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Refresh() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
RegisterSelectionAssignment(Component targetComponent, IConverter converter=null) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetBackgroundColor(Color color) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetControlColors(Color fore, Color back) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetDescription(string description) (defined in Deltares.Standard.Forms.DExpress.BarItemBinding) | Deltares.Standard.Forms.DExpress.BarItemBinding | virtual
SetDomain(ICollection collection) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetEnabled(bool enabled) (defined in Deltares.Standard.Forms.DExpress.BarItemBinding) | Deltares.Standard.Forms.DExpress.BarItemBinding | virtual
SetForegroundColor(Color color) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetLabel(string text) (defined in Deltares.Standard.Forms.DExpress.BarItemBinding) | Deltares.Standard.Forms.DExpress.BarItemBinding | virtual
SetTrueMapping(object trueMapping) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetValue(object value) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetValue(object value, object parent) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetVisible(bool visible) (defined in Deltares.Standard.Forms.DExpress.BarItemBinding) | Deltares.Standard.Forms.DExpress.BarItemBinding | virtual
ValueChanged (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ValueToString(object value) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Generated on Tue Dec 15 2015 18:14:42 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.BarItemExtensions Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • BarItemExtensions
Static Public Member Functions | List of all members
Deltares.Standard.Forms.DExpress.BarItemExtensions Class Reference

Static Public Member Functions

static void | CreateAndBindBarItem< T > (this BarLinksHolder bar, RepositoryItem repositoryItem, Component parent, Expression< Func< T, object >> propertyExpression, int width)
Creates a new bar edit item and adds the specified repository item to it (See DevExpress docs about repository items). More...
static void | CreateAndBindBarItem< T > (this BarLinksHolder bar, RepositoryItem repositoryItem, Component parent, Expression< Func< T, object >> propertyExpression)
Creates a new bar edit item and adds the specified repository item to it (See DevExpress docs about repository items). More...
static void | CreateAndBindMenuItem< T > (this BarSubItem parentMenu, BarItem menuItem, Component component, T instance, Expression< Action< T >> expression)
Creates and binds a menu item on the parent. More...
static void | CreateAndBindMenuItem< T > (this BarSubItem parentMenu, Component component, T instance, Expression< Action< T >> expression)
Creates and binds a menu item on the parent. More...

Member Function Documentation

static void Deltares.Standard.Forms.DExpress.BarItemExtensions.CreateAndBindBarItem< T > | ( | this BarLinksHolder | bar,
 |  | RepositoryItem | repositoryItem,
 |  | Component | parent,
 |  | Expression< Func< T, object >> | propertyExpression,
 |  | int | width
 | ) |  |
static

Creates a new bar edit item and adds the specified repository item to it (See DevExpress docs about repository items).

Template Parameters
T The type T is required for the property expression to be resolved. It is also required for getting data through the IDomain interface. See remarks for more info about this
Parameters
bar | The bar where the specific repository item should be added to.
repositoryItem | The repository item to bind to the bar.
parent | The parent or container of the bar item.
propertyExpression | The property expression to resolve the property to bind to to.
width

The property expression is just a way to tell the bind support which property it should use. This could be done using strings (the property name), but it is more type safe to use an expression like x => x.Property vs. "Property"

The type T should implement IDomain. Through this interface the BindSupport will get its data source for the repository item

References Deltares.Standard.Forms.DExpress.BindSupport.Bind().

static void Deltares.Standard.Forms.DExpress.BarItemExtensions.CreateAndBindBarItem< T > | ( | this BarLinksHolder | bar,
 |  | RepositoryItem | repositoryItem,
 |  | Component | parent,
 |  | Expression< Func< T, object >> | propertyExpression
 | ) |  |
static

Creates a new bar edit item and adds the specified repository item to it (See DevExpress docs about repository items).

Template Parameters
T The type T is required for the property expression to be resolved. It is also required for getting data through the IDomain interface. See remarks for more info about this
Parameters
bar | The bar where the specific repository item should be added to.
repositoryItem | The repository item to bind to the bar.
parent | The parent or container of the bar item.
propertyExpression | The property expression to resolve the property to bind to to.

The property expression is just a way to tell the bind support which property it should use. This could be done using strings (the property name), but it is more type safe to use an expression like x => x.Property vs. "Property"

The type T should implement IDomain. Through this interface the BindSupport will get its data source for the repository item

static void Deltares.Standard.Forms.DExpress.BarItemExtensions.CreateAndBindMenuItem< T > | ( | this BarSubItem | parentMenu,
 |  | BarItem | menuItem,
 |  | Component | component,
 |  | T | instance,
 |  | Expression< Action< T >> | expression
 | ) |  |
static

Creates and binds a menu item on the parent.

Template Parameters
T
Parameters
parentMenu | The parent menu.
menuItem | The menu item.
component | The component.
instance | The instance.
expression | The expression.

References Deltares.Standard.Forms.DExpress.BindSupport.Assign(), and Deltares.Standard.Forms.DExpress.BindSupport.Bind().

static void Deltares.Standard.Forms.DExpress.BarItemExtensions.CreateAndBindMenuItem< T > | ( | this BarSubItem | parentMenu,
 |  | Component | component,
 |  | T | instance,
 |  | Expression< Action< T >> | expression
 | ) |  |
static

Creates and binds a menu item on the parent.

Template Parameters
T
Parameters
parentMenu | The parent menu.
component | The component.
instance | The instance.
expression | The expression.
Generated on Tue Dec 15 2015 18:14:42 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • BarItemExtensions
Deltares.Standard.Forms.DExpress.BarItemExtensions Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.BarItemExtensions, including all inherited members.

CreateAndBindBarItem< T >(this BarLinksHolder bar, RepositoryItem repositoryItem, Component parent, Expression< Func< T, object >> propertyExpression, int width) | Deltares.Standard.Forms.DExpress.BarItemExtensions | static
CreateAndBindBarItem< T >(this BarLinksHolder bar, RepositoryItem repositoryItem, Component parent, Expression< Func< T, object >> propertyExpression) | Deltares.Standard.Forms.DExpress.BarItemExtensions | static
CreateAndBindMenuItem< T >(this BarSubItem parentMenu, BarItem menuItem, Component component, T instance, Expression< Action< T >> expression) | Deltares.Standard.Forms.DExpress.BarItemExtensions | static
CreateAndBindMenuItem< T >(this BarSubItem parentMenu, Component component, T instance, Expression< Action< T >> expression) | Deltares.Standard.Forms.DExpress.BarItemExtensions | static
Generated on Tue Dec 15 2015 18:14:42 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.BarStaticItemBinding Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • BarStaticItemBinding
Public Member Functions | List of all members
Deltares.Standard.Forms.DExpress.BarStaticItemBinding Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.BarStaticItemBinding:
Deltares.Standard.Forms.DExpress.BarItemBinding Deltares.Standard.Forms.DExpress.ComponentBinding

Public Member Functions

BarStaticItemBinding (Component component)
override void | SetValue (object value)
override void | SetEnabled (bool enabled)
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.BarItemBinding
BarItemBinding (Component component)
override void | Initialize (BindPropertyInfo propertyInfo, params string[] properties)
override void | SetLabel (string text)
override void | SetDescription (string description)
override void | SetVisible (bool visible)
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
ComponentBinding (Component component)
virtual void | Initialize (BindPropertyInfo propertyInfo, Type rootObjectType, params string[] properties)
virtual void | SetTrueMapping (object trueMapping)
virtual void | SetValue (object value, object parent)
virtual void | SetDomain (ICollection collection)
virtual object | GetValue ()
virtual void | SetForegroundColor (Color color)
virtual void | SetBackgroundColor (Color color)
virtual void | Refresh ()
virtual void | Invalidate ()
virtual void | RegisterSelectionAssignment (Component targetComponent, IConverter converter=null)
Indicates that the selection of the bound control must be assigned to another control. More...
virtual void | SetControlColors (Color fore, Color back)
Sets the controls foreground and background colors. Can be overridden by a specific binding to set other colors if necessary. More...

Additional Inherited Members

- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
void | RaiseValueChanged ()
void | RaiseLeave ()
void | RaiseActionPerformed ()
Type | GetGenericType (Type type)
string | ValueToString (object value)
bool | IsAssociatedPropertyVisible (object source, BindPropertyInfo associatedPropertyInfo)
Indicates whether the associated property (i.e. the property which is used to display the original property in a textbox) is visible More...
void | EditFileInfo (object source, BindPropertyInfo propertyInfo)
string | EditFileInfo (string value, string format, string label, string description, bool isDirectory)
string | GetDoubleString (string text)
bool | HasValidNumericValue (string text)
double | GetNumericValue (string text)
List< BindPropertyInfo > | GetDictionaryProperties (ICollection domain, BindPropertyInfo dynamicPropertyInfo)
- Protected Attributes inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
BindPropertyInfo | propInfo
- Properties inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
Component | Component [get]
virtual bool | IsTransparant [get]
virtual HandleType | HandleDelayed [get]
virtual bool | HasDomain [get]
- Events inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
EventHandler< EventArgs > | ActionPerformed
EventHandler< EventArgs > | Leave
EventHandler< EventArgs > | ValueChanged
Generated on Tue Dec 15 2015 18:14:43 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • BarStaticItemBinding
Deltares.Standard.Forms.DExpress.BarStaticItemBinding Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.BarStaticItemBinding, including all inherited members.

ActionPerformed (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
BarItemBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.BarItemBinding) | Deltares.Standard.Forms.DExpress.BarItemBinding |
BarStaticItemBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.BarStaticItemBinding) | Deltares.Standard.Forms.DExpress.BarStaticItemBinding |
Component (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ComponentBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
EditFileInfo(object source, BindPropertyInfo propertyInfo) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
EditFileInfo(string value, string format, string label, string description, bool isDirectory) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetDictionaryProperties(ICollection domain, BindPropertyInfo dynamicPropertyInfo) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetDoubleString(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetGenericType(Type type) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetNumericValue(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetValue() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
HandleDelayed (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
HasDomain (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
HasValidNumericValue(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Initialize(BindPropertyInfo propertyInfo, params string[] properties) (defined in Deltares.Standard.Forms.DExpress.BarItemBinding) | Deltares.Standard.Forms.DExpress.BarItemBinding | virtual
Initialize(BindPropertyInfo propertyInfo, Type rootObjectType, params string[] properties) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
Invalidate() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
IsAssociatedPropertyVisible(object source, BindPropertyInfo associatedPropertyInfo) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
IsTransparant (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
Leave (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
propInfo (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseActionPerformed() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseLeave() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseValueChanged() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Refresh() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
RegisterSelectionAssignment(Component targetComponent, IConverter converter=null) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetBackgroundColor(Color color) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetControlColors(Color fore, Color back) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetDescription(string description) (defined in Deltares.Standard.Forms.DExpress.BarItemBinding) | Deltares.Standard.Forms.DExpress.BarItemBinding | virtual
SetDomain(ICollection collection) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetEnabled(bool enabled) (defined in Deltares.Standard.Forms.DExpress.BarStaticItemBinding) | Deltares.Standard.Forms.DExpress.BarStaticItemBinding | virtual
SetForegroundColor(Color color) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetLabel(string text) (defined in Deltares.Standard.Forms.DExpress.BarItemBinding) | Deltares.Standard.Forms.DExpress.BarItemBinding | virtual
SetTrueMapping(object trueMapping) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetValue(object value) (defined in Deltares.Standard.Forms.DExpress.BarStaticItemBinding) | Deltares.Standard.Forms.DExpress.BarStaticItemBinding | virtual
SetValue(object value, object parent) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetVisible(bool visible) (defined in Deltares.Standard.Forms.DExpress.BarItemBinding) | Deltares.Standard.Forms.DExpress.BarItemBinding | virtual
ValueChanged (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ValueToString(object value) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Generated on Tue Dec 15 2015 18:14:43 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.BarSubItemBinding Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • BarSubItemBinding
Public Member Functions | Properties | List of all members
Deltares.Standard.Forms.DExpress.BarSubItemBinding Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.BarSubItemBinding:
Deltares.Standard.Forms.DExpress.BarItemBinding Deltares.Standard.Forms.DExpress.ComponentBinding

Public Member Functions

BarSubItemBinding (Component component)
override object | GetValue ()
override void | SetValue (object value)
override void | SetDomain (ICollection domain)
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.BarItemBinding
BarItemBinding (Component component)
override void | Initialize (BindPropertyInfo propertyInfo, params string[] properties)
override void | SetLabel (string text)
override void | SetDescription (string description)
override void | SetVisible (bool visible)
override void | SetEnabled (bool enabled)
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
ComponentBinding (Component component)
virtual void | Initialize (BindPropertyInfo propertyInfo, Type rootObjectType, params string[] properties)
virtual void | SetTrueMapping (object trueMapping)
virtual void | SetValue (object value, object parent)
virtual void | SetForegroundColor (Color color)
virtual void | SetBackgroundColor (Color color)
virtual void | Refresh ()
virtual void | Invalidate ()
virtual void | RegisterSelectionAssignment (Component targetComponent, IConverter converter=null)
Indicates that the selection of the bound control must be assigned to another control. More...
virtual void | SetControlColors (Color fore, Color back)
Sets the controls foreground and background colors. Can be overridden by a specific binding to set other colors if necessary. More...

Properties

override bool | HasDomain [get]
- Properties inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
Component | Component [get]
virtual bool | IsTransparant [get]
virtual HandleType | HandleDelayed [get]
virtual bool | HasDomain [get]

Additional Inherited Members

- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
void | RaiseValueChanged ()
void | RaiseLeave ()
void | RaiseActionPerformed ()
Type | GetGenericType (Type type)
string | ValueToString (object value)
bool | IsAssociatedPropertyVisible (object source, BindPropertyInfo associatedPropertyInfo)
Indicates whether the associated property (i.e. the property which is used to display the original property in a textbox) is visible More...
void | EditFileInfo (object source, BindPropertyInfo propertyInfo)
string | EditFileInfo (string value, string format, string label, string description, bool isDirectory)
string | GetDoubleString (string text)
bool | HasValidNumericValue (string text)
double | GetNumericValue (string text)
List< BindPropertyInfo > | GetDictionaryProperties (ICollection domain, BindPropertyInfo dynamicPropertyInfo)
- Protected Attributes inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
BindPropertyInfo | propInfo
- Events inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
EventHandler< EventArgs > | ActionPerformed
EventHandler< EventArgs > | Leave
EventHandler< EventArgs > | ValueChanged
Generated on Tue Dec 15 2015 18:14:43 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • BarSubItemBinding
Deltares.Standard.Forms.DExpress.BarSubItemBinding Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.BarSubItemBinding, including all inherited members.

ActionPerformed (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
BarItemBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.BarItemBinding) | Deltares.Standard.Forms.DExpress.BarItemBinding |
BarSubItemBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.BarSubItemBinding) | Deltares.Standard.Forms.DExpress.BarSubItemBinding |
Component (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ComponentBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
EditFileInfo(object source, BindPropertyInfo propertyInfo) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
EditFileInfo(string value, string format, string label, string description, bool isDirectory) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetDictionaryProperties(ICollection domain, BindPropertyInfo dynamicPropertyInfo) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetDoubleString(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetGenericType(Type type) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetNumericValue(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetValue() (defined in Deltares.Standard.Forms.DExpress.BarSubItemBinding) | Deltares.Standard.Forms.DExpress.BarSubItemBinding | virtual
HandleDelayed (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
HasDomain (defined in Deltares.Standard.Forms.DExpress.BarSubItemBinding) | Deltares.Standard.Forms.DExpress.BarSubItemBinding |
HasValidNumericValue(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Initialize(BindPropertyInfo propertyInfo, params string[] properties) (defined in Deltares.Standard.Forms.DExpress.BarItemBinding) | Deltares.Standard.Forms.DExpress.BarItemBinding | virtual
Initialize(BindPropertyInfo propertyInfo, Type rootObjectType, params string[] properties) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
Invalidate() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
IsAssociatedPropertyVisible(object source, BindPropertyInfo associatedPropertyInfo) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
IsTransparant (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
Leave (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
propInfo (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseActionPerformed() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseLeave() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseValueChanged() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Refresh() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
RegisterSelectionAssignment(Component targetComponent, IConverter converter=null) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetBackgroundColor(Color color) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetControlColors(Color fore, Color back) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetDescription(string description) (defined in Deltares.Standard.Forms.DExpress.BarItemBinding) | Deltares.Standard.Forms.DExpress.BarItemBinding | virtual
SetDomain(ICollection domain) (defined in Deltares.Standard.Forms.DExpress.BarSubItemBinding) | Deltares.Standard.Forms.DExpress.BarSubItemBinding | virtual
SetEnabled(bool enabled) (defined in Deltares.Standard.Forms.DExpress.BarItemBinding) | Deltares.Standard.Forms.DExpress.BarItemBinding | virtual
SetForegroundColor(Color color) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetLabel(string text) (defined in Deltares.Standard.Forms.DExpress.BarItemBinding) | Deltares.Standard.Forms.DExpress.BarItemBinding | virtual
SetTrueMapping(object trueMapping) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetValue(object value) (defined in Deltares.Standard.Forms.DExpress.BarSubItemBinding) | Deltares.Standard.Forms.DExpress.BarSubItemBinding | virtual
SetValue(object value, object parent) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetVisible(bool visible) (defined in Deltares.Standard.Forms.DExpress.BarItemBinding) | Deltares.Standard.Forms.DExpress.BarItemBinding | virtual
ValueChanged (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ValueToString(object value) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Generated on Tue Dec 15 2015 18:14:43 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.BaseControlBinding Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • BaseControlBinding
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
Deltares.Standard.Forms.DExpress.BaseControlBinding Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.BaseControlBinding:
Deltares.Standard.Forms.DExpress.ControlBinding Deltares.Standard.Forms.DExpress.ComponentBinding Deltares.Standard.Forms.DExpress.ComponentWrappers.IGetBoundControl Deltares.Standard.Forms.DExpress.ButtonEditBinding Deltares.Standard.Forms.DExpress.CheckEditBinding Deltares.Standard.Forms.DExpress.ColorEditBinding Deltares.Standard.Forms.DExpress.ComboBoxEditBinding Deltares.Standard.Forms.DExpress.ComponentWrappers.GaugeControlBinding Deltares.Standard.Forms.DExpress.DateEditBinding Deltares.Standard.Forms.DExpress.HyperLinkEditBinding Deltares.Standard.Forms.DExpress.LabelControlBinding Deltares.Standard.Forms.DExpress.PopupContainerEditBinding Deltares.Standard.Forms.DExpress.RadioGroupBinding Deltares.Standard.Forms.DExpress.RepositoryItemTrackBarBinding Deltares.Standard.Forms.DExpress.SimpleButtonBinding Deltares.Standard.Forms.DExpress.SpinEditBinding Deltares.Standard.Forms.DExpress.StateIndicatorGaugeBinding Deltares.Standard.Forms.DExpress.TextEditBinding Deltares.Standard.Forms.DExpress.TrackBarControlBinding

Public Member Functions

override void | Initialize (BindPropertyInfo propertyInfo, params string[] properties)
override void | SetLabel (string text)
override void | SetDescription (string description)
override void | Invalidate ()
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.ControlBinding
override void | SetVisible (bool visible)
override void | SetEnabled (bool enabled)
override void | SetLabel (string text)
Sets the label/title/name associated with this control. More...
override void | SetDescription (string description)
Sets the textual description associated with this control. More...
override void | SetForegroundColor (Color color)
override void | SetBackgroundColor (Color color)
override void | Invalidate ()
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
ComponentBinding (Component component)
virtual void | Initialize (BindPropertyInfo propertyInfo, Type rootObjectType, params string[] properties)
virtual void | SetTrueMapping (object trueMapping)
virtual void | SetValue (object value)
virtual void | SetValue (object value, object parent)
virtual void | SetDomain (ICollection collection)
virtual object | GetValue ()
virtual void | Refresh ()
virtual void | RegisterSelectionAssignment (Component targetComponent, IConverter converter=null)
Indicates that the selection of the bound control must be assigned to another control. More...
virtual void | SetControlColors (Color fore, Color back)
Sets the controls foreground and background colors. Can be overridden by a specific binding to set other colors if necessary. More...

Protected Member Functions

BaseControlBinding (Component component)
DXPopupMenu | GetPopupMenu ()
This method uses reflection to make the context menu accessible, which otherwise is protected. The Menu property is implemented for TextEdit, so we first make sure the control is actually of this type. More...
override void | OnToolTipShown (PopupEventArgs e)
Called when Tooltip is shown, and fires ToolTipShown event. More...
override void | OnToolTipClosed ()
Called when Tooltip is hidden, and fires ToolTipHidden. More...
override void | Dispose (bool disposing)
- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.ControlBinding
ControlBinding (Component component)
void | ThreadSafeRefresh ()
override void | Dispose (bool disposing)
- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
void | RaiseValueChanged ()
void | RaiseLeave ()
void | RaiseActionPerformed ()
Type | GetGenericType (Type type)
string | ValueToString (object value)
bool | IsAssociatedPropertyVisible (object source, BindPropertyInfo associatedPropertyInfo)
Indicates whether the associated property (i.e. the property which is used to display the original property in a textbox) is visible More...
void | EditFileInfo (object source, BindPropertyInfo propertyInfo)
string | EditFileInfo (string value, string format, string label, string description, bool isDirectory)
string | GetDoubleString (string text)
bool | HasValidNumericValue (string text)
double | GetNumericValue (string text)
List< BindPropertyInfo > | GetDictionaryProperties (ICollection domain, BindPropertyInfo dynamicPropertyInfo)

Protected Attributes

readonly SuperToolTip | superTip
- Protected Attributes inherited from Deltares.Standard.Forms.DExpress.ControlBinding
readonly ToolTip | tooltip
string | Description
The textual description associated with this

See also
Control

. More...

string | Label
The label/title/name associated with this Control. More...
- Protected Attributes inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
BindPropertyInfo | propInfo

Additional Inherited Members

- Properties inherited from Deltares.Standard.Forms.DExpress.ControlBinding
ToolTip | Tooltip [get]
Gets the tooltip for the bound control. More...
Control | BoundControl [get]
- Properties inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
Component | Component [get]
virtual bool | IsTransparant [get]
virtual HandleType | HandleDelayed [get]
virtual bool | HasDomain [get]
- Properties inherited from Deltares.Standard.Forms.DExpress.ComponentWrappers.IGetBoundControl
Control | BoundControl [get]
- Events inherited from Deltares.Standard.Forms.DExpress.ControlBinding
ToolTipVisibilityEventHandler | ToolTipHidden
ToolTipVisibilityEventHandler | ToolTipShown
- Events inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
EventHandler< EventArgs > | ActionPerformed
EventHandler< EventArgs > | Leave
EventHandler< EventArgs > | ValueChanged

Member Function Documentation

DXPopupMenu Deltares.Standard.Forms.DExpress.BaseControlBinding.GetPopupMenu ( )
protected

This method uses reflection to make the context menu accessible, which otherwise is protected. The Menu property is implemented for TextEdit, so we first make sure the control is actually of this type.

Returns
The DXPopupMenu of the bound control if it exists. null otherwise
override void Deltares.Standard.Forms.DExpress.BaseControlBinding.OnToolTipClosed ( )
protectedvirtual

Called when Tooltip is hidden, and fires ToolTipHidden.

Reimplemented from Deltares.Standard.Forms.DExpress.ControlBinding.

override void Deltares.Standard.Forms.DExpress.BaseControlBinding.OnToolTipShown ( PopupEventArgs e )
protectedvirtual

Called when Tooltip is shown, and fires ToolTipShown event.

Parameters
e The PopupEventArgs instance containing the event data.

Reimplemented from Deltares.Standard.Forms.DExpress.ControlBinding.

Generated on Tue Dec 15 2015 18:14:43 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • BaseControlBinding
Deltares.Standard.Forms.DExpress.BaseControlBinding Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.BaseControlBinding, including all inherited members.

ActionPerformed (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
BaseControlBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.BaseControlBinding) | Deltares.Standard.Forms.DExpress.BaseControlBinding | protected
BoundControl (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding |
Component (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ComponentBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ControlBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Description | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Dispose(bool disposing) (defined in Deltares.Standard.Forms.DExpress.BaseControlBinding) | Deltares.Standard.Forms.DExpress.BaseControlBinding | protected
EditFileInfo(object source, BindPropertyInfo propertyInfo) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
EditFileInfo(string value, string format, string label, string description, bool isDirectory) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetDictionaryProperties(ICollection domain, BindPropertyInfo dynamicPropertyInfo) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetDoubleString(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetGenericType(Type type) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetNumericValue(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetPopupMenu() | Deltares.Standard.Forms.DExpress.BaseControlBinding | protected
GetValue() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
HandleDelayed (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
HasDomain (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
HasValidNumericValue(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Initialize(BindPropertyInfo propertyInfo, params string[] properties) (defined in Deltares.Standard.Forms.DExpress.BaseControlBinding) | Deltares.Standard.Forms.DExpress.BaseControlBinding | virtual
Initialize(BindPropertyInfo propertyInfo, Type rootObjectType, params string[] properties) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
Invalidate() (defined in Deltares.Standard.Forms.DExpress.BaseControlBinding) | Deltares.Standard.Forms.DExpress.BaseControlBinding | virtual
IsAssociatedPropertyVisible(object source, BindPropertyInfo associatedPropertyInfo) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
IsTransparant (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
Label | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Leave (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
OnToolTipClosed() | Deltares.Standard.Forms.DExpress.BaseControlBinding | protectedvirtual
OnToolTipShown(PopupEventArgs e) | Deltares.Standard.Forms.DExpress.BaseControlBinding | protectedvirtual
propInfo (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseActionPerformed() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseLeave() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseValueChanged() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Refresh() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
RegisterSelectionAssignment(Component targetComponent, IConverter converter=null) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetBackgroundColor(Color color) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
SetControlColors(Color fore, Color back) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetDescription(string description) (defined in Deltares.Standard.Forms.DExpress.BaseControlBinding) | Deltares.Standard.Forms.DExpress.BaseControlBinding | virtual
SetDomain(ICollection collection) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetEnabled(bool enabled) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
SetForegroundColor(Color color) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
SetLabel(string text) (defined in Deltares.Standard.Forms.DExpress.BaseControlBinding) | Deltares.Standard.Forms.DExpress.BaseControlBinding | virtual
SetTrueMapping(object trueMapping) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetValue(object value) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetValue(object value, object parent) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetVisible(bool visible) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
superTip (defined in Deltares.Standard.Forms.DExpress.BaseControlBinding) | Deltares.Standard.Forms.DExpress.BaseControlBinding | protected
ThreadSafeRefresh() (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | protected
tooltip (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Tooltip | Deltares.Standard.Forms.DExpress.ControlBinding | protected
ToolTipHidden (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding |
ToolTipShown (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding |
ValueChanged (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ValueToString(object value) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Generated on Tue Dec 15 2015 18:14:43 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.BasicPropertySubControlFactory< ShownDataType, ControlType > Class Template Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • BasicPropertySubControlFactory
Public Member Functions | Protected Member Functions | Properties | List of all members
Deltares.Standard.Forms.DExpress.BasicPropertySubControlFactory< ShownDataType, ControlType > Class Template Referenceabstract

the basic abstract class More...

Inheritance diagram for Deltares.Standard.Forms.DExpress.BasicPropertySubControlFactory< ShownDataType, ControlType >:
Deltares.Standard.Forms.DExpress.IPropertySubControlFactory< ControlType > Deltares.Standard.Forms.DExpress.SimplePropertySubControlFactory< ShownDataType, ControlType >

Public Member Functions

ControlType | CreateBoundControl (PropertyInfo propertyInfo, Type dataType, Component parentComponent)
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.IPropertySubControlFactory< ControlType >
ControlType | CreateBoundControl (PropertyInfo propertyInfo, Type dataType, Component parentComponent)

Protected Member Functions

abstract ControlType | CreateControl (string name)
abstract void | BindControl (ControlType control, bool hasUnitInfo, string propertyName)

Properties

Type | ValueType [get]
PropertyInfo | PropertyInfo [get]
Type | DataType [get]
Component | ParentComponent [get]
- Properties inherited from Deltares.Standard.Forms.DExpress.IPropertySubControlFactory< ControlType >
Type | ValueType [get]

Detailed Description

the basic abstract class

Template Parameters
ShownDataType | The type for which the created control can show data
ControlType | The class of the control to be created. Used so this can be used internally instead of just 'Control'
Type Constraints
ControlType : Control
Generated on Tue Dec 15 2015 18:14:43 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • BasicPropertySubControlFactory
Deltares.Standard.Forms.DExpress.BasicPropertySubControlFactory< ShownDataType, ControlType > Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.BasicPropertySubControlFactory< ShownDataType, ControlType >, including all inherited members.

BindControl(ControlType control, bool hasUnitInfo, string propertyName) (defined in Deltares.Standard.Forms.DExpress.BasicPropertySubControlFactory< ShownDataType, ControlType >) | Deltares.Standard.Forms.DExpress.BasicPropertySubControlFactory< ShownDataType, ControlType > | protectedpure virtual
CreateBoundControl(PropertyInfo propertyInfo, Type dataType, Component parentComponent) (defined in Deltares.Standard.Forms.DExpress.BasicPropertySubControlFactory< ShownDataType, ControlType >) | Deltares.Standard.Forms.DExpress.BasicPropertySubControlFactory< ShownDataType, ControlType > |
CreateControl(string name) (defined in Deltares.Standard.Forms.DExpress.BasicPropertySubControlFactory< ShownDataType, ControlType >) | Deltares.Standard.Forms.DExpress.BasicPropertySubControlFactory< ShownDataType, ControlType > | protectedpure virtual
DataType (defined in Deltares.Standard.Forms.DExpress.BasicPropertySubControlFactory< ShownDataType, ControlType >) | Deltares.Standard.Forms.DExpress.BasicPropertySubControlFactory< ShownDataType, ControlType > | protected
ParentComponent (defined in Deltares.Standard.Forms.DExpress.BasicPropertySubControlFactory< ShownDataType, ControlType >) | Deltares.Standard.Forms.DExpress.BasicPropertySubControlFactory< ShownDataType, ControlType > | protected
PropertyInfo (defined in Deltares.Standard.Forms.DExpress.BasicPropertySubControlFactory< ShownDataType, ControlType >) | Deltares.Standard.Forms.DExpress.BasicPropertySubControlFactory< ShownDataType, ControlType > | protected
ValueType (defined in Deltares.Standard.Forms.DExpress.BasicPropertySubControlFactory< ShownDataType, ControlType >) | Deltares.Standard.Forms.DExpress.BasicPropertySubControlFactory< ShownDataType, ControlType > |
Generated on Tue Dec 15 2015 18:14:43 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.BindingRegistration Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • BindingRegistration
Static Public Member Functions | List of all members
Deltares.Standard.Forms.DExpress.BindingRegistration Class Reference

Static Public Member Functions

static ComponentBinding GetBinding (Component component)
Generated on Tue Dec 15 2015 18:14:43 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • BindingRegistration
Deltares.Standard.Forms.DExpress.BindingRegistration Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.BindingRegistration, including all inherited members.

GetBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.BindingRegistration) Deltares.Standard.Forms.DExpress.BindingRegistration static
Generated on Tue Dec 15 2015 18:14:43 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.BindSupport Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • BindSupport
Static Public Member Functions | Static Public Attributes | Static Package Functions | Static Package Attributes | Properties | List of all members
Deltares.Standard.Forms.DExpress.BindSupport Class Reference

TODO: Comment Explain concept of Binding, how does it work? More...

Static Public Member Functions

static void | RegisterPopupControl (Type type, Control control)
Registers the popup control. More...
static Control | GetPopupControl (Type dataType)
Gets the popup control. More...
static void | Update (Component component)
Updates the specified component. TODO: Comment More...
static void | UpdateAll ()
Updates all. TODO: Comment More...
static Control | GetOwner (Component control)
Returns the owner of the given component. TODO: Comment More...
static void | BindText (Component parent, Component textControl, string resourceId)
Binds the text to the component. (Obsolete, Bind with BindingType.Label should be used instead). More...
static void | BindTextAndValue (Component parent, Component textControl, Component valueControl, Type dataObjectType, string dataObjectPropertyName)
Binds the text and value, Obsolete: please use "BindTextAndValue<T>". More...
static void | BindTextAndValue< T > (Component parent, Component textControl, Component valueControl, Type dataObjectType, Expression< Func< T, object >> expression)
Binds the text and value, Obsolete: please use "BindTextAndValue<T>". More...
static void | BindTextAndValue< T > (Component parent, Component textControl, Component valueControl, Expression< Func< T, object >> expression)
Binds the text and value. More...
static void | BindTextAndValue< T > (Component parent, Component textControl, Component valueControl, Type dataObjectType, Expression< Action< T >> expression)
Binds the text and value, Obsolete: please use "BindTextAndValue<T>(Component, Component, Component, Expression<Action<T>>)". More...
static void | BindTextValueAndUnit< T > (Component parent, Component textControl, Component valueControl, Expression< Func< T, object >> expression)
Binds the text, value and unit. More...
static void | BindTextValueAndUnit< T > (Component parent, Component textControl, Component valueControl, Expression< Func< T, object >> expression, params Expression< Func< T, object >>[] subExpression)
Binds the text, value and unit. More...
static void | BindTextValueAndUnit< T > (Component parent, Component textControl, Component valueControl, Expression< Action< T >> expression)
Binds the text, value and unit. More...
static void | BindTextValueAndUnit (Component parent, Component textControl, Type dataObjectType, string dataObjectPropertyName)
Binds the text, value and unit. More...
static void | BindTextValueAndUnit (Component parent, Component textControl, Component valueControl, Type dataObjectType, string dataObjectPropertyName)
Binds the text, value and unit. More...
static void | BindTextValueAndUnit (Component parent, Component textControl, Component valueControl, Type dataObjectType, string dataObjectPropertyName, params string[] subProperties)
Binds the text, value and unit. More...
static void | Bind< T > (Component parent, Component control, Expression< Func< T, object >> expression)
Binds the specified expression to the given control. More...
static void | Bind< T > (Component parent, Component control, Expression< Action< T >> expression)
Binds the specified expression to the given control. More...
static void | Bind< T > (Component parent, Component control, Expression< Func< T, object >> expression, BindingType bindingType)
Binds the specified expression to the given control with the bindingType. More...
static void | Bind< T > (Component parent, Component control, Expression< Func< T, object >> expression, BindingType bindingType, params string[] subProperties)
Binds the specified expression to the given control. More...
static void | Bind< T > (Component parent, Component control, Expression< Func< T, object >> expression, params string[] subProperties)
Binds the specified expression to the given control. More...
static void | Bind< T1, T2 > (Component parent, Component control, Expression< Func< T1, T2 >> expression, params Expression< Func< T2, object >>[] subpropertyExpressions)
Binds the specified expression to the given control. More...
static void | Bind< T > (Component parent, Component control, Expression< Action< T >> expression, BindingType bindingType)
Binds the specified expression to the given control. More...
static void | Bind< T > (Component parent, Component control, Expression< Action< T >> expression, object trueMapping)
Binds the specified expression to the given control. More...
static void | Bind< T > (Component parent, Component control, Expression< Func< T, object >> expression, object trueMapping)
Binds the specified expression to the given control. More...
static void | Bind (Component parent, Component control, Type type, string property)
Binds the specified expression to the given control. More...
static void | Bind (Component parent, Component control, Type type, string property, Type rootObjectType)
Binds the specified expression to the given control. More...
static void | BindProperties (Component parent, Component control, Type type, string property, BindingType bindingType, params string[] subProperties)
Binds the specified expression to the given control. More...
static void | Bind (Component parent, Component control, Type type, string property, params string[] subProperties)
Binds the specified expression to the given control. More...
static void | Bind< T, U > (Component parent, Component control, Expression< Func< T, IEnumerable< U >>> property, params Expression< Func< U, object >>[] subProperties)
Binds the specified expression to the given control. More...
static void | Bind2< T > (Component parent, Component control1, Component control2, Expression< Action< T >> expression)
Binds the specified expression to the given control. More...
static void | Bind2 (Component parent, Component control1, Component control2, Type type, string property, params string[] subProperties)
Binds the specified expression to the given control. More...
static void | Bind (Component parent, Component control, Type type, string property, BindingType bindingType)
Binds the specified expression to the given control. More...
static void | Bind (Component parent, Component control, BindPropertyInfo propertyInfo, BindingType bindingType)
static void | Bind (Component parent, Component control, Type type, string property, object trueMapping)
Binds the specified expression to the given control. More...
static void | Unbind (Component control)
Removes the binding registered with Bind(Component,Component,BindPropertyInfo,BindingType,object,Type,String[]). More...
static void | BindSelection (Component sourceComponent, Component targetComponent, IConverter converter=null)
Assigns the selection within a control to another secondary control (for example: Collection control to detail control) More...
static bool | IsBound (Component component)
Determines whether the specified component is bound. More...
static void | Assign (Component parent, object dataSource)
Assigns the specified dataSource to the specified parent. TODO: Comment More...
static object | GetAssignedObject (Component component)
Gets the object assigned to the given component. More...
static PropertyInfo[] | GetPropertiesSortedByPropertyOrderAttribute (Type type)
Returns a array of properties of argument type ordered by the PropertyOrder attributes No rank or no property order attributed properties will be set at the end of the list More...
static MethodInfo[] | GetActionsSortedByPropertyOrderAttribute (Type type)
Gets the actions sorted by property order attribute. More...
static Dictionary< PropertyInfo, PropertyInfo[]> | GetContainedProperties (Type type)
Gets the properties that are stored for the given type. More...
static PropertyInfo | GetPropertyInfo< TSource > (Expression< Func< TSource, object >> propertyLambda)
Gets the property information. TODO: Comment More...
static UnitType | UnitForProperty< T > (Expression< Func< T, object >> expression)
Gets the unit for propertyInfo of the given expression. More...
static UnitType | UnitForProperty (Type type, string property)
Gets the unit for the given type and property. More...
static UnitType | UnitForProperty (PropertyInfo propertyInfo)
Gets the unit for given propertyInfo. More...
static void | DisableAll ()
Disables all. More...
static void | EnableAll ()
Enables all. More...
static string | GetHelpLocation (Control control)
Gets the help location from HelpAttribute if defined. More...
static void | ClearCaches ()
Clears all internal caching. More...
static void | SetLateBinding (Control parent)
Sets the late binding for all controls in this containercontrol. More...
static void | SetLateBinding (Component parent, Component control)
Sets the late binding for a single control. More...
static bool | UseLateBinding (Component parent)
Is late binding used for this containercontrol. More...
static void | RegisterPopupControl (Type type, Control control)
static Control | GetPopupControl (Type dataType)
static void | Update (Component component)
static void | UpdateAll ()
static Control | GetOwner (Component control)
static void | SetLateBinding (Control parent)
Sets the late binding for all controls in this containercontrol. More...
static void | SetLateBinding (Component parent, Component control)
Sets the late binding for a single control. More...
static bool | UseLateBinding (Component parent)
Is late binding used for this containercontrol. More...
static void | BindText (Component parent, Component textControl, string resourceId)
static void | BindTextAndValue (Component parent, Component textControl, Component valueControl, Type dataObjectType, string dataObjectPropertyName)
static void | BindTextAndValue< T > (Component parent, Component textControl, Component valueControl, Type dataObjectType, Expression< Func< T, object >> expression)
static void | BindTextAndValue< T > (Component parent, Component textControl, Component valueControl, Expression< Func< T, object >> expression)
static void | BindTextAndValue< T > (Component parent, Component textControl, Component valueControl, Type dataObjectType, Expression< Action< T >> expression)
static void | BindTextValueAndUnit< T > (Component parent, Component textControl, Component valueControl, Expression< Func< T, object >> expression)
static void | BindTextValueAndUnit< T > (Component parent, Component textControl, Component valueControl, Expression< Action< T >> expression)
static void | BindTextValueAndUnit (Component parent, Component textControl, Type dataObjectType, string dataObjectPropertyName)
static void | BindTextValueAndUnit (Component parent, Component textControl, Component valueControl, Type dataObjectType, string dataObjectPropertyName)
static void | Bind< T > (Component parent, Component control, Expression< Func< T, object >> expression)
static void | Bind< T > (Component parent, Component control, Expression< Action< T >> expression)
static void | Bind< T > (Component parent, Component control, Expression< Func< T, object >> expression, BindingType bindingType)
static void | Bind< T > (Component parent, Component control, Expression< Func< T, object >> expression, BindingType bindingType, params string[] subProperties)
static void | Bind< T > (Component parent, Component control, Expression< Func< T, object >> expression, params string[] subProperties)
static void | Bind< T > (Component parent, Component control, Expression< Action< T >> expression, BindingType bindingType)
static void | Bind< T > (Component parent, Component control, Expression< Action< T >> expression, object trueMapping)
static void | Bind< T > (Component parent, Component control, Expression< Func< T, object >> expression, object trueMapping)
static void | Bind (Component parent, Component control, Type type, string property)
static void | Bind (Component parent, Component control, Type type, string property, Type rootObjectType)
static void | BindProperties (Component parent, Component control, Type type, string property, BindingType bindingType, params string[] subProperties)
static void | Bind (Component parent, Component control, Type type, string property, params string[] subProperties)
static void | Bind< T, U > (Component parent, Component control, Expression< Func< T, IEnumerable< U >>> property, params Expression< Func< U, object >>[] subProperties)
static void | Bind2< T > (Component parent, Component control1, Component control2, Expression< Action< T >> expression)
static void | Bind2 (Component parent, Component control1, Component control2, Type type, string property)
static void | Bind (Component parent, Component control, Type type, string property, BindingType bindingType)
static void | Bind (Component parent, Component control, Type type, string property, object trueMapping)
static bool | IsBound (Component component)
static void | Assign (Component parent, object dataSource)
static object | GetAssignedObject (Component component)
static PropertyInfo[] | GetPropertiesSortedByPropertyOrderAttribute (Type type)
Returns a array of properties of argument type ordered by the PropertyOrder attributes No rank or no property order attributed properties will be set at the end of the list More...
static MethodInfo[] | GetActionsSortedByPropertyOrderAttribute (Type type)
static Dictionary< PropertyInfo, PropertyInfo[]> | GetContainedProperties (Type type)
static PropertyInfo | GetPropertyInfo< TSource > (Expression< Func< TSource, object >> propertyLambda)
static UnitType | UnitForProperty< T > (Expression< Func< T, object >> expression)
static UnitType | UnitForProperty (Type type, string property)
static UnitType | UnitForProperty (PropertyInfo propertyInfo)
static UnitType | UnitForControl (Component control)
static void | DisableAll ()
static void | EnableAll ()

Static Public Attributes

static readonly Color | InvalidForeColor = Color.Red
static readonly Color | WarningForeColor = Color.Firebrick
static readonly Color | NormalForeColor = Color.Black
static readonly Color | NormalBackColor = Color.Empty
static readonly Color | DisabledForeColor = Color.FromArgb(255, 80, 80, 80)
static readonly Color | DisabledBackColor = Color.FromArgb(255, 233, 233, 233)
static readonly Color | LinkForeColor = Color.DodgerBlue
static readonly Color | UnspecifiedForeColor = Color.FromArgb(255, 0, 127, 0)
static readonly Color | UnspecifiedBackColor = Color.FromArgb(255, 200, 255, 160)

Static Package Functions

static void | UpdateControl (Component control, BindPropertyInfo memberInfo, object dataSource)
static Color | GetForeColor (ComponentBinding component, object dataSource, BindPropertyInfo memberInfo)
static Color | GetBackColor (ComponentBinding component, object dataSource, BindPropertyInfo memberInfo)
static ICollection | GetDomain (object dataSource, BindPropertyInfo propertyInfo, ref object value)
static object | GetMapping (Component control)
static bool | IsEnabled (Component control)
static string | GetFormat (Component control)
static Impact | GetImpact (Component control)
static void | UpdateSource (Component control)
static object | TryConvert2Double (Component control, BindPropertyInfo propertyInfo, object source, object value)
static bool | IsValid (object source, string property)
static bool | HasNoWarning (object source, string property)
static void | BindSupport_EditValueChanged (object sender, EventArgs e)
static void | UpdateControl (Component control, MemberInfo memberInfo, object dataSource)
static Color | GetForeColor (Component component, object dataSource, MemberInfo memberInfo)
static Color | GetBackColor (Component component, object dataSource, MemberInfo memberInfo)
static ICollection | GetDomain (object dataSource, MemberInfo propertyInfo, ref object value)
static void | UpdateSource (Component control)
static bool | SetValue (PropertyInfo propertyInfo, object source, object value)
static object | GetUserValue (object dataSource, Component control, object value, PropertyInfo propertyInfo)
static object | TryConvert2Double (Component control, object value)
static bool | AllowNullInput (PropertyInfo propertyInfo)
static bool | AllowNullInput (MemberInfo memberInfo)
static void | SetTreeListColumnsPanelHeight (TreeList treeList, PropertyInfo[] shownProperties)
static object | GetMapping (Component control)
static bool | IsEnabled (Component control)
static string | GetFormat (Component control)
static Impact | GetImpact (Component control)
static bool | IsValid (object source, string property)
static void | SetColumnCaptionAndName (TreeListColumn column, MemberInfo memberInfo, int index)
static string | GetUnitString (UnitType unitType)

Static Package Attributes

static readonly Dictionary< Component, Component > | parents = new Dictionary<Component, Component>()
static bool | enabledAll = true
static readonly Dictionary< Component, bool > | isEnabled = new Dictionary<Component, bool>()
static readonly Dictionary< Component, string > | formats = new Dictionary<Component, string>()
static readonly Dictionary< Component, Impact > | impacts = new Dictionary<Component, Impact>()

Properties

static bool | BypassTimerForUnitTest [get, set]
Gets or sets a value indicating whether the timer for unit tests shall be bypassed. TODO: Comment More...
static Control | InvokeControl [get, set]
Gets or sets the invoke control. More...
static bool | ForceBeginAction [get, set]
Gets or sets a value indicating whether beginning the action shall be forced. More...
static bool | Delayed [get, set]
Gets or sets a value indicating whether delayed. More...
static bool | Loading [get, set]
static Control | ControlWithOpenToolTip [get]
Gets the control with an open tool tip, if any. More...

Detailed Description

TODO: Comment Explain concept of Binding, how does it work?

Member Function Documentation

static void Deltares.Standard.Forms.DExpress.BindSupport.Assign | ( | Component | parent,
 |  | object | dataSource
 | ) |  |
static

Assigns the specified dataSource to the specified parent. TODO: Comment

References Deltares.Standard.Forms.DExpress.FormsSupport.UpdateDirtyControls().

Referenced by Deltares.Standard.Forms.DExpress.GridViewController< T >.Assign(), Deltares.Geotechnics.Forms.SoilProfile2DControl.ClearControl(), Deltares.Geotechnics.Forms.SoilProfile1DControl.ClearControl(), Deltares.DSoilModel.Forms.SosSoilProfile1DControl.ClearControl(), Deltares.Standard.Forms.DExpress.BarItemExtensions.CreateAndBindMenuItem< T >(), Deltares.Standard.Forms.DExpress.MainForm.CreateRecentlyUsedFilesButton(), Deltares.DSoilModel.Forms.DSoilModelMapEditor.DSoilModelMapEditor(), Deltares.Standard.Forms.DExpress.GeometryEditor.GeometryEditor(), Deltares.Standard.Forms.DExpress.GridViewControl.GridViewControl(), Deltares.Standard.Forms.DExpress.MapEditor.MapEditor(), Deltares.Standard.Forms.DExpress.PopupContainerEditBinding.SetValue(), and Deltares.Standard.Forms.DExpress.TreeViewControl.TreeViewControl().

static void Deltares.Standard.Forms.DExpress.BindSupport.Bind | ( | Component | parent,
 |  | Component | control,
 |  | Type | type,
 |  | string | property
 | ) |  |
static

Binds the specified expression to the given control.

Referenced by Deltares.Geotechnics.Forms.BondStressCurveControl.BondStressCurveControl(), Deltares.Geotechnics.Forms.BoringControl.BoringControl(), Deltares.Geotechnics.Forms.CPTControl.CPTControl(), Deltares.Standard.Forms.DExpress.BarItemExtensions.CreateAndBindBarItem< T >(), Deltares.Standard.Forms.DExpress.BarItemExtensions.CreateAndBindMenuItem< T >(), Deltares.Standard.Forms.DExpress.MainForm.CreateRecentlyUsedFilesButton(), Deltares.Geotechnics.Forms.DesignPointControl.DesignPointControl(), Deltares.Geotechnics.Forms.DikeLineControl.DikeLineControl(), Deltares.DSoilModel.Forms.DSoilModelMapEditor.DSoilModelMapEditor(), Deltares.Standard.Forms.DExpress.GeometryEditor.GeometryEditor(), Deltares.Geotechnics.Forms.HydraulicBoundaryControl.HydraulicBoundaryControl(), Deltares.Standard.Forms.DExpress.MapEditor.MapEditor(), Deltares.Standard.Forms.DExpress.GridViewController< T >.RegisterControl(), Deltares.Geotechnics.Forms.ShearStressCurveControl.ShearStressCurveControl(), Deltares.Geotechnics.Forms.SoilProfile1DControl.SoilProfile1DControl(), Deltares.Geotechnics.Forms.SoilProfile2DControl.SoilProfile2DControl(), Deltares.Geotechnics.Forms.SoilSurfacePropertyControl.SoilSurfacePropertyControl(), Deltares.Geotechnics.Forms.StressCurveControl.StressCurveControl(), Deltares.Standard.Forms.DExpress.TreeViewControl.TreeViewControl(), Deltares.Geotechnics.Forms.WaterLineControl.WaterLineControl(), and Deltares.Geotechnics.Forms.WaternetControl.WaternetControl().

static void Deltares.Standard.Forms.DExpress.BindSupport.Bind | ( | Component | parent,
 |  | Component | control,
 |  | Type | type,
 |  | string | property,
 |  | Type | rootObjectType
 | ) |  |
static

Binds the specified expression to the given control.

static void Deltares.Standard.Forms.DExpress.BindSupport.Bind | ( | Component | parent,
 |  | Component | control,
 |  | Type | type,
 |  | string | property,
 |  | params string[] | subProperties
 | ) |  |
static

Binds the specified expression to the given control.

static void Deltares.Standard.Forms.DExpress.BindSupport.Bind | ( | Component | parent,
 |  | Component | control,
 |  | Type | type,
 |  | string | property,
 |  | BindingType | bindingType
 | ) |  |
static

Binds the specified expression to the given control.

static void Deltares.Standard.Forms.DExpress.BindSupport.Bind | ( | Component | parent,
 |  | Component | control,
 |  | Type | type,
 |  | string | property,
 |  | object | trueMapping
 | ) |  |
static

Binds the specified expression to the given control.

static void Deltares.Standard.Forms.DExpress.BindSupport.Bind2 | ( | Component | parent,
 |  | Component | control1,
 |  | Component | control2,
 |  | Type | type,
 |  | string | property,
 |  | params string[] | subProperties
 | ) |  |
static

Binds the specified expression to the given control.

Referenced by Deltares.Standard.Forms.DExpress.GeometryEditor.GeometryEditor().

static void Deltares.Standard.Forms.DExpress.BindSupport.Bind2< T > | ( | Component | parent,
 |  | Component | control1,
 |  | Component | control2,
 |  | Expression< Action< T >> | expression
 | ) |  |
static

Binds the specified expression to the given control.

static void Deltares.Standard.Forms.DExpress.BindSupport.Bind< T > | ( | Component | parent,
 |  | Component | control,
 |  | Expression< Func< T, object >> | expression
 | ) |  |
static

Binds the specified expression to the given control.

static void Deltares.Standard.Forms.DExpress.BindSupport.Bind< T > | ( | Component | parent,
 |  | Component | control,
 |  | Expression< Action< T >> | expression
 | ) |  |
static

Binds the specified expression to the given control.

static void Deltares.Standard.Forms.DExpress.BindSupport.Bind< T > | ( | Component | parent,
 |  | Component | control,
 |  | Expression< Func< T, object >> | expression,
 |  | BindingType | bindingType
 | ) |  |
static

Binds the specified expression to the given control with the bindingType.

static void Deltares.Standard.Forms.DExpress.BindSupport.Bind< T > | ( | Component | parent,
 |  | Component | control,
 |  | Expression< Func< T, object >> | expression,
 |  | BindingType | bindingType,
 |  | params string[] | subProperties
 | ) |  |
static

Binds the specified expression to the given control.

static void Deltares.Standard.Forms.DExpress.BindSupport.Bind< T > | ( | Component | parent,
 |  | Component | control,
 |  | Expression< Func< T, object >> | expression,
 |  | params string[] | subProperties
 | ) |  |
static

Binds the specified expression to the given control.

static void Deltares.Standard.Forms.DExpress.BindSupport.Bind< T > | ( | Component | parent,
 |  | Component | control,
 |  | Expression< Action< T >> | expression,
 |  | BindingType | bindingType
 | ) |  |
static

Binds the specified expression to the given control.

static void Deltares.Standard.Forms.DExpress.BindSupport.Bind< T > | ( | Component | parent,
 |  | Component | control,
 |  | Expression< Action< T >> | expression,
 |  | object | trueMapping
 | ) |  |
static

Binds the specified expression to the given control.

static void Deltares.Standard.Forms.DExpress.BindSupport.Bind< T > | ( | Component | parent,
 |  | Component | control,
 |  | Expression< Func< T, object >> | expression,
 |  | object | trueMapping
 | ) |  |
static

Binds the specified expression to the given control.

static void Deltares.Standard.Forms.DExpress.BindSupport.Bind< T, U > | ( | Component | parent,
 |  | Component | control,
 |  | Expression< Func< T, IEnumerable< U >>> | property,
 |  | params Expression< Func< U, object >>[] | subProperties
 | ) |  |
static

Binds the specified expression to the given control.

static void Deltares.Standard.Forms.DExpress.BindSupport.Bind< T1, T2 > | ( | Component | parent,
 |  | Component | control,
 |  | Expression< Func< T1, T2 >> | expression,
 |  | params Expression< Func< T2, object >>[] | subpropertyExpressions
 | ) |  |
static

Binds the specified expression to the given control.

static void Deltares.Standard.Forms.DExpress.BindSupport.BindProperties | ( | Component | parent,
 |  | Component | control,
 |  | Type | type,
 |  | string | property,
 |  | BindingType | bindingType,
 |  | params string[] | subProperties
 | ) |  |
static

Binds the specified expression to the given control.

static void Deltares.Standard.Forms.DExpress.BindSupport.BindSelection | ( | Component | sourceComponent,
 |  | Component | targetComponent,
 |  | IConverter | converter = null
 | ) |  |
static

Assigns the selection within a control to another secondary control (for example: Collection control to detail control)

Parameters
sourceComponent | The control containing the selection
targetComponent | Control to which the selection in sourceComponent , or its conversion, is assigned.
converter | Optional converter which converts the selected object in sourceComponent to another object, which will be used for assignment instead.
static void Deltares.Standard.Forms.DExpress.BindSupport.BindText | ( | Component | parent,
 |  | Component | textControl,
 |  | string | resourceId
 | ) |  |
static

Binds the text to the component. (Obsolete, Bind with BindingType.Label should be used instead).

static void Deltares.Standard.Forms.DExpress.BindSupport.BindTextAndValue | ( | Component | parent,
 |  | Component | textControl,
 |  | Component | valueControl,
 |  | Type | dataObjectType,
 |  | string | dataObjectPropertyName
 | ) |  |
static

Binds the text and value, Obsolete: please use "BindTextAndValue<T>".

Referenced by Deltares.Geotechnics.Forms.BondStressCurveControl.BondStressCurveControl(), Deltares.Geotechnics.Forms.BoringControl.BoringControl(), Deltares.Geotechnics.Forms.CPTControl.CPTControl(), Deltares.Geotechnics.Forms.DikeLineControl.DikeLineControl(), Deltares.Geotechnics.Forms.HydraulicBoundaryControl.HydraulicBoundaryControl(), Deltares.Geotechnics.Forms.ProbabilisticControl.ProbabilisticControl(), Deltares.Geotechnics.Forms.SoilBondStressCurveControl.SoilBondStressCurveControl(), Deltares.Geotechnics.Forms.SoilProfile1DControl.SoilProfile1DControl(), Deltares.Geotechnics.Forms.SoilProfile2DControl.SoilProfile2DControl(), Deltares.Geotechnics.Forms.SoilStressCurveControl.SoilStressCurveControl(), Deltares.Geotechnics.Forms.SoilSurfacePropertyControl.SoilSurfacePropertyControl(), Deltares.Geotechnics.Forms.StressCurveControl.StressCurveControl(), and Deltares.Geotechnics.Forms.WaterLineControl.WaterLineControl().

static void Deltares.Standard.Forms.DExpress.BindSupport.BindTextAndValue< T > | ( | Component | parent,
 |  | Component | textControl,
 |  | Component | valueControl,
 |  | Type | dataObjectType,
 |  | Expression< Func< T, object >> | expression
 | ) |  |
static

Binds the text and value, Obsolete: please use "BindTextAndValue<T>".

static void Deltares.Standard.Forms.DExpress.BindSupport.BindTextAndValue< T > | ( | Component | parent,
 |  | Component | textControl,
 |  | Component | valueControl,
 |  | Expression< Func< T, object >> | expression
 | ) |  |
static

Binds the text and value.

static void Deltares.Standard.Forms.DExpress.BindSupport.BindTextAndValue< T > | ( | Component | parent,
 |  | Component | textControl,
 |  | Component | valueControl,
 |  | Type | dataObjectType,
 |  | Expression< Action< T >> | expression
 | ) |  |
static

Binds the text and value, Obsolete: please use "BindTextAndValue<T>(Component, Component, Component, Expression<Action<T>>)".

static void Deltares.Standard.Forms.DExpress.BindSupport.BindTextValueAndUnit | ( | Component | parent,
 |  | Component | textControl,
 |  | Type | dataObjectType,
 |  | string | dataObjectPropertyName
 | ) |  |
static

Binds the text, value and unit.

Referenced by Deltares.Geotechnics.Forms.BoringControl.BoringControl(), Deltares.Geotechnics.Forms.CPTControl.CPTControl(), Deltares.Geotechnics.Forms.DesignPointControl.DesignPointControl(), Deltares.Geotechnics.Forms.DikeLineControl.DikeLineControl(), Deltares.Geotechnics.Forms.HydraulicBoundaryControl.HydraulicBoundaryControl(), Deltares.Geotechnics.Forms.ProbabilisticControl.ProbabilisticControl(), Deltares.Geotechnics.Forms.SoilProfile1DControl.SoilProfile1DControl(), Deltares.Geotechnics.Forms.SoilProfile2DControl.SoilProfile2DControl(), Deltares.Geotechnics.Forms.StressCurveControl.StressCurveControl(), and Deltares.Geotechnics.Forms.WaternetControl.WaternetControl().

static void Deltares.Standard.Forms.DExpress.BindSupport.BindTextValueAndUnit | ( | Component | parent,
 |  | Component | textControl,
 |  | Component | valueControl,
 |  | Type | dataObjectType,
 |  | string | dataObjectPropertyName
 | ) |  |
static

Binds the text, value and unit.

static void Deltares.Standard.Forms.DExpress.BindSupport.BindTextValueAndUnit | ( | Component | parent,
 |  | Component | textControl,
 |  | Component | valueControl,
 |  | Type | dataObjectType,
 |  | string | dataObjectPropertyName,
 |  | params string[] | subProperties
 | ) |  |
static

Binds the text, value and unit.

static void Deltares.Standard.Forms.DExpress.BindSupport.BindTextValueAndUnit< T > | ( | Component | parent,
 |  | Component | textControl,
 |  | Component | valueControl,
 |  | Expression< Func< T, object >> | expression
 | ) |  |
static

Binds the text, value and unit.

static void Deltares.Standard.Forms.DExpress.BindSupport.BindTextValueAndUnit< T > | ( | Component | parent,
 |  | Component | textControl,
 |  | Component | valueControl,
 |  | Expression< Func< T, object >> | expression,
 |  | params Expression< Func< T, object >>[] | subExpression
 | ) |  |
static

Binds the text, value and unit.

static void Deltares.Standard.Forms.DExpress.BindSupport.BindTextValueAndUnit< T > | ( | Component | parent,
 |  | Component | textControl,
 |  | Component | valueControl,
 |  | Expression< Action< T >> | expression
 | ) |  |
static

Binds the text, value and unit.

static void Deltares.Standard.Forms.DExpress.BindSupport.ClearCaches ( )
static

Clears all internal caching.

This method is particularly useful for tests working at plugin and application level

static void Deltares.Standard.Forms.DExpress.BindSupport.DisableAll ( )
static

Disables all.

static void Deltares.Standard.Forms.DExpress.BindSupport.EnableAll ( )
static

Enables all.

static MethodInfo [] Deltares.Standard.Forms.DExpress.BindSupport.GetActionsSortedByPropertyOrderAttribute ( Type type )
static

Gets the actions sorted by property order attribute.

Parameters
type The type.
Returns
static object Deltares.Standard.Forms.DExpress.BindSupport.GetAssignedObject ( Component component )
static

Gets the object assigned to the given component.

Parameters
component The component.
Returns
static Dictionary<PropertyInfo, PropertyInfo[]> Deltares.Standard.Forms.DExpress.BindSupport.GetContainedProperties ( Type type )
static

Gets the properties that are stored for the given type.

Parameters
type The type.
Returns
static string Deltares.Standard.Forms.DExpress.BindSupport.GetHelpLocation ( Control control )
static

Gets the help location from HelpAttribute if defined.

Parameters
control The control.
Returns
The help location string, or null.

Referenced by Deltares.Standard.Forms.DExpress.BindSupportAsHelpLocationProvider.GetHelpLocation().

static Control Deltares.Standard.Forms.DExpress.BindSupport.GetOwner ( Component control )
static

Returns the owner of the given component. TODO: Comment

static Control Deltares.Standard.Forms.DExpress.BindSupport.GetPopupControl ( Type dataType )
static

Gets the popup control.

Referenced by Deltares.Standard.Forms.DExpress.PopupContainerEditBinding.Initialize().

static PropertyInfo [] Deltares.Standard.Forms.DExpress.BindSupport.GetPropertiesSortedByPropertyOrderAttribute ( Type type )
static

Returns a array of properties of argument type ordered by the PropertyOrder attributes No rank or no property order attributed properties will be set at the end of the list

Parameters
type
Returns
static PropertyInfo [] Deltares.Standard.Forms.DExpress.BindSupport.GetPropertiesSortedByPropertyOrderAttribute ( Type type )
static

Returns a array of properties of argument type ordered by the PropertyOrder attributes No rank or no property order attributed properties will be set at the end of the list

Parameters
type
Returns
static PropertyInfo Deltares.Standard.Forms.DExpress.BindSupport.GetPropertyInfo< TSource > ( Expression< Func< TSource, object >> propertyLambda )
static

Gets the property information. TODO: Comment

Template Parameters
TSource The type of the source.
Parameters
propertyLambda The property lambda.
Returns
Exceptions
System.ArgumentException
static bool Deltares.Standard.Forms.DExpress.BindSupport.IsBound ( Component component )
static

Determines whether the specified component is bound.

Parameters
component The component.
Returns
static void Deltares.Standard.Forms.DExpress.BindSupport.RegisterPopupControl | ( | Type | type,
 |  | Control | control
 | ) |  |
static

Registers the popup control.

static void Deltares.Standard.Forms.DExpress.BindSupport.SetLateBinding ( Control parent )
static

Sets the late binding for all controls in this containercontrol.

Parameters
parent The parent.

References Deltares.Standard.Forms.DExpress.BindSupportLateBinding.SetLateBinding().

static void Deltares.Standard.Forms.DExpress.BindSupport.SetLateBinding | ( | Component | parent,
 |  | Component | control
 | ) |  |
static

Sets the late binding for a single control.

Parameters
parent | The parent.
control | The control.

References Deltares.Standard.Forms.DExpress.BindSupportLateBinding.SetLateBinding().

static void Deltares.Standard.Forms.DExpress.BindSupport.SetLateBinding ( Control parent )
static

Sets the late binding for all controls in this containercontrol.

Parameters
parent The parent.

References Deltares.Standard.Forms.DExpress.BindSupportLateBinding.SetLateBinding().

static void Deltares.Standard.Forms.DExpress.BindSupport.SetLateBinding | ( | Component | parent,
 |  | Component | control
 | ) |  |
static

Sets the late binding for a single control.

Parameters
parent | The parent.
control | The control.

References Deltares.Standard.Forms.DExpress.BindSupportLateBinding.SetLateBinding().

static void Deltares.Standard.Forms.DExpress.BindSupport.Unbind ( Component control )
static

Removes the binding registered with Bind(Component,Component,BindPropertyInfo,BindingType,object,Type,String[]).

Parameters
control The control whose registration should be removed.
static UnitType Deltares.Standard.Forms.DExpress.BindSupport.UnitForProperty | ( | Type | type,
 |  | string | property
 | ) |  |
static

Gets the unit for the given type and property.

Parameters
type | The type.
property | The property.
Returns
Exceptions
System.ArgumentException
static UnitType Deltares.Standard.Forms.DExpress.BindSupport.UnitForProperty ( PropertyInfo propertyInfo )
static

Gets the unit for given propertyInfo.

Parameters
propertyInfo The property information.
Returns
static UnitType Deltares.Standard.Forms.DExpress.BindSupport.UnitForProperty< T > ( Expression< Func< T, object >> expression )
static

Gets the unit for propertyInfo of the given expression.

Template Parameters
T
Parameters
expression The expression.
Returns
static void Deltares.Standard.Forms.DExpress.BindSupport.Update ( Component component )
static

Updates the specified component. TODO: Comment

Parameters
component The component.
static void Deltares.Standard.Forms.DExpress.BindSupport.UpdateAll ( )
static

Updates all. TODO: Comment

Referenced by Deltares.Standard.Forms.DExpress.ReloadManager.ApplyCurrentUiCultureToAll().

static bool Deltares.Standard.Forms.DExpress.BindSupport.UseLateBinding ( Component parent )
static

Is late binding used for this containercontrol.

Parameters
parent The parent.
Returns
static bool Deltares.Standard.Forms.DExpress.BindSupport.UseLateBinding ( Component parent )
static

Is late binding used for this containercontrol.

Property Documentation

static bool Deltares.Standard.Forms.DExpress.BindSupport.BypassTimerForUnitTest
staticgetset

Gets or sets a value indicating whether the timer for unit tests shall be bypassed. TODO: Comment

true if [bypass timer for unit test]; otherwise, false.

Control Deltares.Standard.Forms.DExpress.BindSupport.ControlWithOpenToolTip
staticget

Gets the control with an open tool tip, if any.

The control with open tool tip. Can be null.

static bool Deltares.Standard.Forms.DExpress.BindSupport.Delayed
staticgetset

Gets or sets a value indicating whether delayed.

static bool Deltares.Standard.Forms.DExpress.BindSupport.ForceBeginAction
staticgetset

Gets or sets a value indicating whether beginning the action shall be forced.

static Control Deltares.Standard.Forms.DExpress.BindSupport.InvokeControl
staticgetset

Gets or sets the invoke control.

Referenced by Deltares.Standard.Forms.DExpress.StatusBar.DoProgress(), and Deltares.Standard.Forms.DExpress.StatusBar.SetProgressText().

Generated on Tue Dec 15 2015 18:14:44 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • BindSupport
Deltares.Standard.Forms.DExpress.BindSupport Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.BindSupport, including all inherited members.

AllowNullInput(PropertyInfo propertyInfo) (defined in Deltares.Standard.Forms.DExpress.BindSupport) | Deltares.Standard.Forms.DExpress.BindSupport | packagestatic
AllowNullInput(MemberInfo memberInfo) (defined in Deltares.Standard.Forms.DExpress.BindSupport) | Deltares.Standard.Forms.DExpress.BindSupport | packagestatic
Assign(Component parent, object dataSource) | Deltares.Standard.Forms.DExpress.BindSupport | static
Assign(Component parent, object dataSource) (defined in Deltares.Standard.Forms.DExpress.BindSupport) | Deltares.Standard.Forms.DExpress.BindSupport | static
Bind(Component parent, Component control, Type type, string property) | Deltares.Standard.Forms.DExpress.BindSupport | static
Bind(Component parent, Component control, Type type, string property, Type rootObjectType) | Deltares.Standard.Forms.DExpress.BindSupport | static
Bind(Component parent, Component control, Type type, string property, params string[] subProperties) | Deltares.Standard.Forms.DExpress.BindSupport | static
Bind(Component parent, Component control, Type type, string property, BindingType bindingType) | Deltares.Standard.Forms.DExpress.BindSupport | static
Bind(Component parent, Component control, BindPropertyInfo propertyInfo, BindingType bindingType) (defined in Deltares.Standard.Forms.DExpress.BindSupport) | Deltares.Standard.Forms.DExpress.BindSupport | static
Bind(Component parent, Component control, Type type, string property, object trueMapping) | Deltares.Standard.Forms.DExpress.BindSupport | static
Bind(Component parent, Component control, Type type, string property) (defined in Deltares.Standard.Forms.DExpress.BindSupport) | Deltares.Standard.Forms.DExpress.BindSupport | static
Bind(Component parent, Component control, Type type, string property, Type rootObjectType) (defined in Deltares.Standard.Forms.DExpress.BindSupport) | Deltares.Standard.Forms.DExpress.BindSupport | static
Bind(Component parent, Component control, Type type, string property, params string[] subProperties) (defined in Deltares.Standard.Forms.DExpress.BindSupport) | Deltares.Standard.Forms.DExpress.BindSupport | static
Bind(Component parent, Component control, Type type, string property, BindingType bindingType) (defined in Deltares.Standard.Forms.DExpress.BindSupport) | Deltares.Standard.Forms.DExpress.BindSupport | static
Bind(Component parent, Component control, Type type, string property, object trueMapping) (defined in Deltares.Standard.Forms.DExpress.BindSupport) | Deltares.Standard.Forms.DExpress.BindSupport | static
Bind2(Component parent, Component control1, Component control2, Type type, string property, params string[] subProperties) | Deltares.Standard.Forms.DExpress.BindSupport | static
Bind2(Component parent, Component control1, Component control2, Type type, string property) (defined in Deltares.Standard.Forms.DExpress.BindSupport) | Deltares.Standard.Forms.DExpress.BindSupport | static
Bind2< T >(Component parent, Component control1, Component control2, Expression< Action< T >> expression) | Deltares.Standard.Forms.DExpress.BindSupport | static
Bind2< T >(Component parent, Component control1, Component control2, Expression< Action< T >> expression) (defined in Deltares.Standard.Forms.DExpress.BindSupport) | Deltares.Standard.Forms.DExpress.BindSupport | static
Bind< T >(Component parent, Component control, Expression< Func< T, object >> expression) | Deltares.Standard.Forms.DExpress.BindSupport | static
Bind< T >(Component parent, Component control, Expression< Action< T >> expression) | Deltares.Standard.Forms.DExpress.BindSupport | static
Bind< T >(Component parent, Component control, Expression< Func< T, object >> expression, BindingType bindingType) | Deltares.Standard.Forms.DExpress.BindSupport | static
Bind< T >(Component parent, Component control, Expression< Func< T, object >> expression, BindingType bindingType, params string[] subProperties) | Deltares.Standard.Forms.DExpress.BindSupport | static
Bind< T >(Component parent, Component control, Expression< Func< T, object >> expression, params string[] subProperties) | Deltares.Standard.Forms.DExpress.BindSupport | static
Bind< T >(Component parent, Component control, Expression< Action< T >> expression, BindingType bindingType) | Deltares.Standard.Forms.DExpress.BindSupport | static
Bind< T >(Component parent, Component control, Expression< Action< T >> expression, object trueMapping) | Deltares.Standard.Forms.DExpress.BindSupport | static
Bind< T >(Component parent, Component control, Expression< Func< T, object >> expression, object trueMapping) | Deltares.Standard.Forms.DExpress.BindSupport | static
Bind< T >(Component parent, Component control, Expression< Func< T, object >> expression) (defined in Deltares.Standard.Forms.DExpress.BindSupport) | Deltares.Standard.Forms.DExpress.BindSupport | static
Bind< T >(Component parent, Component control, Expression< Action< T >> expression) (defined in Deltares.Standard.Forms.DExpress.BindSupport) | Deltares.Standard.Forms.DExpress.BindSupport | static
Bind< T >(Component parent, Component control, Expression< Func< T, object >> expression, BindingType bindingType) (defined in Deltares.Standard.Forms.DExpress.BindSupport) | Deltares.Standard.Forms.DExpress.BindSupport | static
Bind< T >(Component parent, Component control, Expression< Func< T, object >> expression, BindingType bindingType, params string[] subProperties) (defined in Deltares.Standard.Forms.DExpress.BindSupport) | Deltares.Standard.Forms.DExpress.BindSupport | static
Bind< T >(Component parent, Component control, Expression< Func< T, object >> expression, params string[] subProperties) (defined in Deltares.Standard.Forms.DExpress.BindSupport) | Deltares.Standard.Forms.DExpress.BindSupport | static
Bind< T >(Component parent, Component control, Expression< Action< T >> expression, BindingType bindingType) (defined in Deltares.Standard.Forms.DExpress.BindSupport) | Deltares.Standard.Forms.DExpress.BindSupport | static
Bind< T >(Component parent, Component control, Expression< Action< T >> expression, object trueMapping) (defined in Deltares.Standard.Forms.DExpress.BindSupport) | Deltares.Standard.Forms.DExpress.BindSupport | static
Bind< T >(Component parent, Component control, Expression< Func< T, object >> expression, object trueMapping) (defined in Deltares.Standard.Forms.DExpress.BindSupport) | Deltares.Standard.Forms.DExpress.BindSupport | static
Bind< T, U >(Component parent, Component control, Expression< Func< T, IEnumerable< U >>> property, params Expression< Func< U, object >>[] subProperties) | Deltares.Standard.Forms.DExpress.BindSupport | static
Bind< T, U >(Component parent, Component control, Expression< Func< T, IEnumerable< U >>> property, params Expression< Func< U, object >>[] subProperties) (defined in Deltares.Standard.Forms.DExpress.BindSupport) | Deltares.Standard.Forms.DExpress.BindSupport | static
Bind< T1, T2 >(Component parent, Component control, Expression< Func< T1, T2 >> expression, params Expression< Func< T2, object >>[] subpropertyExpressions) | Deltares.Standard.Forms.DExpress.BindSupport | static
BindProperties(Component parent, Component control, Type type, string property, BindingType bindingType, params string[] subProperties) | Deltares.Standard.Forms.DExpress.BindSupport | static
BindProperties(Component parent, Component control, Type type, string property, BindingType bindingType, params string[] subProperties) (defined in Deltares.Standard.Forms.DExpress.BindSupport) | Deltares.Standard.Forms.DExpress.BindSupport | static
BindSelection(Component sourceComponent, Component targetComponent, IConverter converter=null) | Deltares.Standard.Forms.DExpress.BindSupport | static
BindSupport_EditValueChanged(object sender, EventArgs e) (defined in Deltares.Standard.Forms.DExpress.BindSupport) | Deltares.Standard.Forms.DExpress.BindSupport | packagestatic
BindText(Component parent, Component textControl, string resourceId) | Deltares.Standard.Forms.DExpress.BindSupport | static
BindText(Component parent, Component textControl, string resourceId) (defined in Deltares.Standard.Forms.DExpress.BindSupport) | Deltares.Standard.Forms.DExpress.BindSupport | static
BindTextAndValue(Component parent, Component textControl, Component valueControl, Type dataObjectType, string dataObjectPropertyName) | Deltares.Standard.Forms.DExpress.BindSupport | static
BindTextAndValue(Component parent, Component textControl, Component valueControl, Type dataObjectType, string dataObjectPropertyName) (defined in Deltares.Standard.Forms.DExpress.BindSupport) | Deltares.Standard.Forms.DExpress.BindSupport | static
BindTextAndValue< T >(Component parent, Component textControl, Component valueControl, Type dataObjectType, Expression< Func< T, object >> expression) | Deltares.Standard.Forms.DExpress.BindSupport | static
BindTextAndValue< T >(Component parent, Component textControl, Component valueControl, Expression< Func< T, object >> expression) | Deltares.Standard.Forms.DExpress.BindSupport | static
BindTextAndValue< T >(Component parent, Component textControl, Component valueControl, Type dataObjectType, Expression< Action< T >> expression) | Deltares.Standard.Forms.DExpress.BindSupport | static
BindTextAndValue< T >(Component parent, Component textControl, Component valueControl, Type dataObjectType, Expression< Func< T, object >> expression) (defined in Deltares.Standard.Forms.DExpress.BindSupport) | Deltares.Standard.Forms.DExpress.BindSupport | static
BindTextAndValue< T >(Component parent, Component textControl, Component valueControl, Expression< Func< T, object >> expression) (defined in Deltares.Standard.Forms.DExpress.BindSupport) | Deltares.Standard.Forms.DExpress.BindSupport | static
BindTextAndValue< T >(Component parent, Component textControl, Component valueControl, Type dataObjectType, Expression< Action< T >> expression) (defined in Deltares.Standard.Forms.DExpress.BindSupport) | Deltares.Standard.Forms.DExpress.BindSupport | static
BindTextValueAndUnit(Component parent, Component textControl, Type dataObjectType, string dataObjectPropertyName) | Deltares.Standard.Forms.DExpress.BindSupport | static
BindTextValueAndUnit(Component parent, Component textControl, Component valueControl, Type dataObjectType, string dataObjectPropertyName) | Deltares.Standard.Forms.DExpress.BindSupport | static
BindTextValueAndUnit(Component parent, Component textControl, Component valueControl, Type dataObjectType, string dataObjectPropertyName, params string[] subProperties) | Deltares.Standard.Forms.DExpress.BindSupport | static
BindTextValueAndUnit(Component parent, Component textControl, Type dataObjectType, string dataObjectPropertyName) (defined in Deltares.Standard.Forms.DExpress.BindSupport) | Deltares.Standard.Forms.DExpress.BindSupport | static
BindTextValueAndUnit(Component parent, Component textControl, Component valueControl, Type dataObjectType, string dataObjectPropertyName) (defined in Deltares.Standard.Forms.DExpress.BindSupport) | Deltares.Standard.Forms.DExpress.BindSupport | static
BindTextValueAndUnit< T >(Component parent, Component textControl, Component valueControl, Expression< Func< T, object >> expression) | Deltares.Standard.Forms.DExpress.BindSupport | static
BindTextValueAndUnit< T >(Component parent, Component textControl, Component valueControl, Expression< Func< T, object >> expression, params Expression< Func< T, object >>[] subExpression) | Deltares.Standard.Forms.DExpress.BindSupport | static
BindTextValueAndUnit< T >(Component parent, Component textControl, Component valueControl, Expression< Action< T >> expression) | Deltares.Standard.Forms.DExpress.BindSupport | static
BindTextValueAndUnit< T >(Component parent, Component textControl, Component valueControl, Expression< Func< T, object >> expression) (defined in Deltares.Standard.Forms.DExpress.BindSupport) | Deltares.Standard.Forms.DExpress.BindSupport | static
BindTextValueAndUnit< T >(Component parent, Component textControl, Component valueControl, Expression< Action< T >> expression) (defined in Deltares.Standard.Forms.DExpress.BindSupport) | Deltares.Standard.Forms.DExpress.BindSupport | static
BypassTimerForUnitTest | Deltares.Standard.Forms.DExpress.BindSupport | static
ClearCaches() | Deltares.Standard.Forms.DExpress.BindSupport | static
ControlWithOpenToolTip | Deltares.Standard.Forms.DExpress.BindSupport | static
Delayed | Deltares.Standard.Forms.DExpress.BindSupport | static
DisableAll() | Deltares.Standard.Forms.DExpress.BindSupport | static
DisableAll() (defined in Deltares.Standard.Forms.DExpress.BindSupport) | Deltares.Standard.Forms.DExpress.BindSupport | static
DisabledBackColor (defined in Deltares.Standard.Forms.DExpress.BindSupport) | Deltares.Standard.Forms.DExpress.BindSupport | static
DisabledForeColor (defined in Deltares.Standard.Forms.DExpress.BindSupport) | Deltares.Standard.Forms.DExpress.BindSupport | static
EnableAll() | Deltares.Standard.Forms.DExpress.BindSupport | static
EnableAll() (defined in Deltares.Standard.Forms.DExpress.BindSupport) | Deltares.Standard.Forms.DExpress.BindSupport | static
enabledAll (defined in Deltares.Standard.Forms.DExpress.BindSupport) | Deltares.Standard.Forms.DExpress.BindSupport | packagestatic
ForceBeginAction | Deltares.Standard.Forms.DExpress.BindSupport | static
formats (defined in Deltares.Standard.Forms.DExpress.BindSupport) | Deltares.Standard.Forms.DExpress.BindSupport | packagestatic
GetActionsSortedByPropertyOrderAttribute(Type type) | Deltares.Standard.Forms.DExpress.BindSupport | static
GetActionsSortedByPropertyOrderAttribute(Type type) (defined in Deltares.Standard.Forms.DExpress.BindSupport) | Deltares.Standard.Forms.DExpress.BindSupport | static
GetAssignedObject(Component component) | Deltares.Standard.Forms.DExpress.BindSupport | static
GetAssignedObject(Component component) (defined in Deltares.Standard.Forms.DExpress.BindSupport) | Deltares.Standard.Forms.DExpress.BindSupport | static
GetBackColor(ComponentBinding component, object dataSource, BindPropertyInfo memberInfo) (defined in Deltares.Standard.Forms.DExpress.BindSupport) | Deltares.Standard.Forms.DExpress.BindSupport | packagestatic
GetBackColor(Component component, object dataSource, MemberInfo memberInfo) (defined in Deltares.Standard.Forms.DExpress.BindSupport) | Deltares.Standard.Forms.DExpress.BindSupport | packagestatic
GetContainedProperties(Type type) | Deltares.Standard.Forms.DExpress.BindSupport | static
GetContainedProperties(Type type) (defined in Deltares.Standard.Forms.DExpress.BindSupport) | Deltares.Standard.Forms.DExpress.BindSupport | static
GetDomain(object dataSource, BindPropertyInfo propertyInfo, ref object value) (defined in Deltares.Standard.Forms.DExpress.BindSupport) | Deltares.Standard.Forms.DExpress.BindSupport | packagestatic
GetDomain(object dataSource, MemberInfo propertyInfo, ref object value) (defined in Deltares.Standard.Forms.DExpress.BindSupport) | Deltares.Standard.Forms.DExpress.BindSupport | packagestatic
GetForeColor(ComponentBinding component, object dataSource, BindPropertyInfo memberInfo) (defined in Deltares.Standard.Forms.DExpress.BindSupport) | Deltares.Standard.Forms.DExpress.BindSupport | packagestatic
GetForeColor(Component component, object dataSource, MemberInfo memberInfo) (defined in Deltares.Standard.Forms.DExpress.BindSupport) | Deltares.Standard.Forms.DExpress.BindSupport | packagestatic
GetFormat(Component control) (defined in Deltares.Standard.Forms.DExpress.BindSupport) | Deltares.Standard.Forms.DExpress.BindSupport | packagestatic
GetFormat(Component control) (defined in Deltares.Standard.Forms.DExpress.BindSupport) | Deltares.Standard.Forms.DExpress.BindSupport | packagestatic
GetHelpLocation(Control control) | Deltares.Standard.Forms.DExpress.BindSupport | static
GetImpact(Component control) (defined in Deltares.Standard.Forms.DExpress.BindSupport) | Deltares.Standard.Forms.DExpress.BindSupport | packagestatic
GetImpact(Component control) (defined in Deltares.Standard.Forms.DExpress.BindSupport) | Deltares.Standard.Forms.DExpress.BindSupport | packagestatic
GetMapping(Component control) (defined in Deltares.Standard.Forms.DExpress.BindSupport) | Deltares.Standard.Forms.DExpress.BindSupport | packagestatic
GetMapping(Component control) (defined in Deltares.Standard.Forms.DExpress.BindSupport) | Deltares.Standard.Forms.DExpress.BindSupport | packagestatic
GetOwner(Component control) | Deltares.Standard.Forms.DExpress.BindSupport | static
GetOwner(Component control) (defined in Deltares.Standard.Forms.DExpress.BindSupport) | Deltares.Standard.Forms.DExpress.BindSupport | static
GetPopupControl(Type dataType) | Deltares.Standard.Forms.DExpress.BindSupport | static
GetPopupControl(Type dataType) (defined in Deltares.Standard.Forms.DExpress.BindSupport) | Deltares.Standard.Forms.DExpress.BindSupport | static
GetPropertiesSortedByPropertyOrderAttribute(Type type) | Deltares.Standard.Forms.DExpress.BindSupport | static
GetPropertiesSortedByPropertyOrderAttribute(Type type) | Deltares.Standard.Forms.DExpress.BindSupport | static
GetPropertyInfo< TSource >(Expression< Func< TSource, object >> propertyLambda) | Deltares.Standard.Forms.DExpress.BindSupport | static
GetPropertyInfo< TSource >(Expression< Func< TSource, object >> propertyLambda) (defined in Deltares.Standard.Forms.DExpress.BindSupport) | Deltares.Standard.Forms.DExpress.BindSupport | static
GetUnitString(UnitType unitType) (defined in Deltares.Standard.Forms.DExpress.BindSupport) | Deltares.Standard.Forms.DExpress.BindSupport | packagestatic
GetUserValue(object dataSource, Component control, object value, PropertyInfo propertyInfo) (defined in Deltares.Standard.Forms.DExpress.BindSupport) | Deltares.Standard.Forms.DExpress.BindSupport | packagestatic
HasNoWarning(object source, string property) (defined in Deltares.Standard.Forms.DExpress.BindSupport) | Deltares.Standard.Forms.DExpress.BindSupport | packagestatic
impacts (defined in Deltares.Standard.Forms.DExpress.BindSupport) | Deltares.Standard.Forms.DExpress.BindSupport | packagestatic
InvalidForeColor (defined in Deltares.Standard.Forms.DExpress.BindSupport) | Deltares.Standard.Forms.DExpress.BindSupport | static
InvokeControl | Deltares.Standard.Forms.DExpress.BindSupport | static
IsBound(Component component) | Deltares.Standard.Forms.DExpress.BindSupport | static
IsBound(Component component) (defined in Deltares.Standard.Forms.DExpress.BindSupport) | Deltares.Standard.Forms.DExpress.BindSupport | static
isEnabled (defined in Deltares.Standard.Forms.DExpress.BindSupport) | Deltares.Standard.Forms.DExpress.BindSupport | packagestatic
IsEnabled(Component control) (defined in Deltares.Standard.Forms.DExpress.BindSupport) | Deltares.Standard.Forms.DExpress.BindSupport | packagestatic
IsEnabled(Component control) (defined in Deltares.Standard.Forms.DExpress.BindSupport) | Deltares.Standard.Forms.DExpress.BindSupport | packagestatic
IsValid(object source, string property) (defined in Deltares.Standard.Forms.DExpress.BindSupport) | Deltares.Standard.Forms.DExpress.BindSupport | packagestatic
IsValid(object source, string property) (defined in Deltares.Standard.Forms.DExpress.BindSupport) | Deltares.Standard.Forms.DExpress.BindSupport | packagestatic
LinkForeColor (defined in Deltares.Standard.Forms.DExpress.BindSupport) | Deltares.Standard.Forms.DExpress.BindSupport | static
Loading (defined in Deltares.Standard.Forms.DExpress.BindSupport) | Deltares.Standard.Forms.DExpress.BindSupport | packagestatic
NormalBackColor (defined in Deltares.Standard.Forms.DExpress.BindSupport) | Deltares.Standard.Forms.DExpress.BindSupport | static
NormalForeColor (defined in Deltares.Standard.Forms.DExpress.BindSupport) | Deltares.Standard.Forms.DExpress.BindSupport | static
parents (defined in Deltares.Standard.Forms.DExpress.BindSupport) | Deltares.Standard.Forms.DExpress.BindSupport | packagestatic
RegisterPopupControl(Type type, Control control) | Deltares.Standard.Forms.DExpress.BindSupport | static
RegisterPopupControl(Type type, Control control) (defined in Deltares.Standard.Forms.DExpress.BindSupport) | Deltares.Standard.Forms.DExpress.BindSupport | static
SetColumnCaptionAndName(TreeListColumn column, MemberInfo memberInfo, int index) (defined in Deltares.Standard.Forms.DExpress.BindSupport) | Deltares.Standard.Forms.DExpress.BindSupport | packagestatic
SetLateBinding(Control parent) | Deltares.Standard.Forms.DExpress.BindSupport | static
SetLateBinding(Component parent, Component control) | Deltares.Standard.Forms.DExpress.BindSupport | static
SetLateBinding(Control parent) | Deltares.Standard.Forms.DExpress.BindSupport | static
SetLateBinding(Component parent, Component control) | Deltares.Standard.Forms.DExpress.BindSupport | static
SetTreeListColumnsPanelHeight(TreeList treeList, PropertyInfo[] shownProperties) (defined in Deltares.Standard.Forms.DExpress.BindSupport) | Deltares.Standard.Forms.DExpress.BindSupport | packagestatic
SetValue(PropertyInfo propertyInfo, object source, object value) (defined in Deltares.Standard.Forms.DExpress.BindSupport) | Deltares.Standard.Forms.DExpress.BindSupport | packagestatic
TryConvert2Double(Component control, BindPropertyInfo propertyInfo, object source, object value) (defined in Deltares.Standard.Forms.DExpress.BindSupport) | Deltares.Standard.Forms.DExpress.BindSupport | packagestatic
TryConvert2Double(Component control, object value) (defined in Deltares.Standard.Forms.DExpress.BindSupport) | Deltares.Standard.Forms.DExpress.BindSupport | packagestatic
Unbind(Component control) | Deltares.Standard.Forms.DExpress.BindSupport | static
UnitForControl(Component control) (defined in Deltares.Standard.Forms.DExpress.BindSupport) | Deltares.Standard.Forms.DExpress.BindSupport | static
UnitForProperty(Type type, string property) | Deltares.Standard.Forms.DExpress.BindSupport | static
UnitForProperty(PropertyInfo propertyInfo) | Deltares.Standard.Forms.DExpress.BindSupport | static
UnitForProperty(Type type, string property) (defined in Deltares.Standard.Forms.DExpress.BindSupport) | Deltares.Standard.Forms.DExpress.BindSupport | static
UnitForProperty(PropertyInfo propertyInfo) (defined in Deltares.Standard.Forms.DExpress.BindSupport) | Deltares.Standard.Forms.DExpress.BindSupport | static
UnitForProperty< T >(Expression< Func< T, object >> expression) | Deltares.Standard.Forms.DExpress.BindSupport | static
UnitForProperty< T >(Expression< Func< T, object >> expression) (defined in Deltares.Standard.Forms.DExpress.BindSupport) | Deltares.Standard.Forms.DExpress.BindSupport | static
UnspecifiedBackColor (defined in Deltares.Standard.Forms.DExpress.BindSupport) | Deltares.Standard.Forms.DExpress.BindSupport | static
UnspecifiedForeColor (defined in Deltares.Standard.Forms.DExpress.BindSupport) | Deltares.Standard.Forms.DExpress.BindSupport | static
Update(Component component) | Deltares.Standard.Forms.DExpress.BindSupport | static
Update(Component component) (defined in Deltares.Standard.Forms.DExpress.BindSupport) | Deltares.Standard.Forms.DExpress.BindSupport | static
UpdateAll() | Deltares.Standard.Forms.DExpress.BindSupport | static
UpdateAll() (defined in Deltares.Standard.Forms.DExpress.BindSupport) | Deltares.Standard.Forms.DExpress.BindSupport | static
UpdateControl(Component control, BindPropertyInfo memberInfo, object dataSource) (defined in Deltares.Standard.Forms.DExpress.BindSupport) | Deltares.Standard.Forms.DExpress.BindSupport | packagestatic
UpdateControl(Component control, MemberInfo memberInfo, object dataSource) (defined in Deltares.Standard.Forms.DExpress.BindSupport) | Deltares.Standard.Forms.DExpress.BindSupport | packagestatic
UpdateSource(Component control) (defined in Deltares.Standard.Forms.DExpress.BindSupport) | Deltares.Standard.Forms.DExpress.BindSupport | packagestatic
UpdateSource(Component control) (defined in Deltares.Standard.Forms.DExpress.BindSupport) | Deltares.Standard.Forms.DExpress.BindSupport | packagestatic
UseLateBinding(Component parent) | Deltares.Standard.Forms.DExpress.BindSupport | static
UseLateBinding(Component parent) | Deltares.Standard.Forms.DExpress.BindSupport | static
WarningForeColor (defined in Deltares.Standard.Forms.DExpress.BindSupport) | Deltares.Standard.Forms.DExpress.BindSupport | static
Generated on Tue Dec 15 2015 18:14:44 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.BindSupportAsHelpLocationProvider Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • BindSupportAsHelpLocationProvider
Public Member Functions | List of all members
Deltares.Standard.Forms.DExpress.BindSupportAsHelpLocationProvider Class Reference

Uses BindSupport to determine the help file location. More...

Inheritance diagram for Deltares.Standard.Forms.DExpress.BindSupportAsHelpLocationProvider:
Deltares.Standard.Forms.DExpress.Interfaces.IHelpLocationProvider

Public Member Functions

string GetHelpLocation (Control control)
Gets the help location from a HelpAttribute if defined. More...

Detailed Description

Uses BindSupport to determine the help file location.

See also
IHelpFileManager, HelpAttribute

Member Function Documentation

string Deltares.Standard.Forms.DExpress.BindSupportAsHelpLocationProvider.GetHelpLocation ( Control control )

Gets the help location from a HelpAttribute if defined.

Parameters
control The control for which the help file location should be extracted.
Returns
The help location string, or null.

Implements Deltares.Standard.Forms.DExpress.Interfaces.IHelpLocationProvider.

References Deltares.Standard.Forms.DExpress.BindSupport.GetHelpLocation().

Generated on Tue Dec 15 2015 18:14:44 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • BindSupportAsHelpLocationProvider
Deltares.Standard.Forms.DExpress.BindSupportAsHelpLocationProvider Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.BindSupportAsHelpLocationProvider, including all inherited members.

GetHelpLocation(Control control) Deltares.Standard.Forms.DExpress.BindSupportAsHelpLocationProvider
Generated on Tue Dec 15 2015 18:14:44 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.BindSupportChartHelper Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • BindSupportChartHelper
Static Public Member Functions | Static Package Functions | List of all members
Deltares.Standard.Forms.DExpress.BindSupportChartHelper Class Reference

Static Public Member Functions

static void | SetAxisXText (IDescriptive descriptive, MemberInfo prop, XYDiagram xyDiagram)
static void | SetAxisYText (IDescriptive descriptive, MemberInfo prop, XYDiagram xyDiagram)
static UnitType | GetUnit (IDescriptive descriptive, MemberInfo prop)
static SeriesPoint | GetSeriesPoint (object x, object y, UnitType xUnit, UnitType yUnit)

Static Package Functions

static void SetChartTitle (ChartControl chartControl, IDescriptive descriptive)
Generated on Tue Dec 15 2015 18:14:44 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • BindSupportChartHelper
Deltares.Standard.Forms.DExpress.BindSupportChartHelper Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.BindSupportChartHelper, including all inherited members.

GetSeriesPoint(object x, object y, UnitType xUnit, UnitType yUnit) (defined in Deltares.Standard.Forms.DExpress.BindSupportChartHelper) | Deltares.Standard.Forms.DExpress.BindSupportChartHelper | static
GetUnit(IDescriptive descriptive, MemberInfo prop) (defined in Deltares.Standard.Forms.DExpress.BindSupportChartHelper) | Deltares.Standard.Forms.DExpress.BindSupportChartHelper | static
SetAxisXText(IDescriptive descriptive, MemberInfo prop, XYDiagram xyDiagram) (defined in Deltares.Standard.Forms.DExpress.BindSupportChartHelper) | Deltares.Standard.Forms.DExpress.BindSupportChartHelper | static
SetAxisYText(IDescriptive descriptive, MemberInfo prop, XYDiagram xyDiagram) (defined in Deltares.Standard.Forms.DExpress.BindSupportChartHelper) | Deltares.Standard.Forms.DExpress.BindSupportChartHelper | static
SetChartTitle(ChartControl chartControl, IDescriptive descriptive) (defined in Deltares.Standard.Forms.DExpress.BindSupportChartHelper) | Deltares.Standard.Forms.DExpress.BindSupportChartHelper | packagestatic
Generated on Tue Dec 15 2015 18:14:44 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.BindSupportLateBinding Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • BindSupportLateBinding
Static Public Member Functions | Static Package Functions | List of all members
Deltares.Standard.Forms.DExpress.BindSupportLateBinding Class Reference

Static Public Member Functions

static void | SetLateBinding (Control parent)
Sets the late binding for all controls in this containercontrol. More...
static void | SetLateBinding (Component parent, Component control)
static void | RemoveLateBinding (Component parent)
Removes the late binding. More...
static void | UpdateSourceFromControl (Component parent)
static void | UpdateControlFromSource (Component parent)

Static Package Functions

static bool | IsLateBinding (Component component)
static void | SetDirty (Component control, bool dirty)
Checks the and sets the dirty flag for this control. More...
static bool | SetDirtyIfUsingLateBinding (Component parent, bool dirty)
sets the dirty flag for the associated parent of the specified control More...

Member Function Documentation

static void Deltares.Standard.Forms.DExpress.BindSupportLateBinding.RemoveLateBinding ( Component parent )
static

Removes the late binding.

Parameters
parent The parent.
static void Deltares.Standard.Forms.DExpress.BindSupportLateBinding.SetDirty | ( | Component | control,
 |  | bool | dirty
 | ) |  |
staticpackage

Checks the and sets the dirty flag for this control.

Parameters
control | The control.
dirty | the new dirty state
Returns
static bool Deltares.Standard.Forms.DExpress.BindSupportLateBinding.SetDirtyIfUsingLateBinding | ( | Component | parent,
 |  | bool | dirty
 | ) |  |
staticpackage

sets the dirty flag for the associated parent of the specified control

Parameters
parent | the associated parent
dirty | the new dirty state
Returns
whether the parent is using late binding (if false, the dirty state was not set)
static void Deltares.Standard.Forms.DExpress.BindSupportLateBinding.SetLateBinding ( Control parent )
static

Sets the late binding for all controls in this containercontrol.

Parameters
parent The parent.

Referenced by Deltares.Standard.Forms.DExpress.DialogTemplate.AddTabPage(), and Deltares.Standard.Forms.DExpress.BindSupport.SetLateBinding().

Generated on Tue Dec 15 2015 18:14:44 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • BindSupportLateBinding
Deltares.Standard.Forms.DExpress.BindSupportLateBinding Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.BindSupportLateBinding, including all inherited members.

IsLateBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.BindSupportLateBinding) | Deltares.Standard.Forms.DExpress.BindSupportLateBinding | packagestatic
RemoveLateBinding(Component parent) | Deltares.Standard.Forms.DExpress.BindSupportLateBinding | static
SetDirty(Component control, bool dirty) | Deltares.Standard.Forms.DExpress.BindSupportLateBinding | packagestatic
SetDirtyIfUsingLateBinding(Component parent, bool dirty) | Deltares.Standard.Forms.DExpress.BindSupportLateBinding | packagestatic
SetLateBinding(Control parent) | Deltares.Standard.Forms.DExpress.BindSupportLateBinding | static
SetLateBinding(Component parent, Component control) (defined in Deltares.Standard.Forms.DExpress.BindSupportLateBinding) | Deltares.Standard.Forms.DExpress.BindSupportLateBinding | static
UpdateControlFromSource(Component parent) (defined in Deltares.Standard.Forms.DExpress.BindSupportLateBinding) | Deltares.Standard.Forms.DExpress.BindSupportLateBinding | static
UpdateSourceFromControl(Component parent) (defined in Deltares.Standard.Forms.DExpress.BindSupportLateBinding) | Deltares.Standard.Forms.DExpress.BindSupportLateBinding | static
Generated on Tue Dec 15 2015 18:14:44 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.BindSupportTreeHelper Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • BindSupportTreeHelper
Static Public Attributes | Static Package Functions | List of all members
Deltares.Standard.Forms.DExpress.BindSupportTreeHelper Class Reference

Static Public Attributes

static bool HideRootNodes = false

Static Package Functions

static void | HandleChange (object source)
static void | OnDataListModified (TreeList treeList)
static void | LoadTree (TreeList treeList, object data)
static void | InitializeTreeControl (TreeList treeList, Type type, string[] columns)
static bool | ListContainsKey (TreeList treeList, object key)
Generated on Tue Dec 15 2015 18:14:44 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • BindSupportTreeHelper
Deltares.Standard.Forms.DExpress.BindSupportTreeHelper Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.BindSupportTreeHelper, including all inherited members.

HandleChange(object source) (defined in Deltares.Standard.Forms.DExpress.BindSupportTreeHelper) | Deltares.Standard.Forms.DExpress.BindSupportTreeHelper | packagestatic
HideRootNodes (defined in Deltares.Standard.Forms.DExpress.BindSupportTreeHelper) | Deltares.Standard.Forms.DExpress.BindSupportTreeHelper | static
InitializeTreeControl(TreeList treeList, Type type, string[] columns) (defined in Deltares.Standard.Forms.DExpress.BindSupportTreeHelper) | Deltares.Standard.Forms.DExpress.BindSupportTreeHelper | packagestatic
ListContainsKey(TreeList treeList, object key) (defined in Deltares.Standard.Forms.DExpress.BindSupportTreeHelper) | Deltares.Standard.Forms.DExpress.BindSupportTreeHelper | packagestatic
LoadTree(TreeList treeList, object data) (defined in Deltares.Standard.Forms.DExpress.BindSupportTreeHelper) | Deltares.Standard.Forms.DExpress.BindSupportTreeHelper | packagestatic
OnDataListModified(TreeList treeList) (defined in Deltares.Standard.Forms.DExpress.BindSupportTreeHelper) | Deltares.Standard.Forms.DExpress.BindSupportTreeHelper | packagestatic
Generated on Tue Dec 15 2015 18:14:44 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.ButtonBinding Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • ButtonBinding
Public Member Functions | List of all members
Deltares.Standard.Forms.DExpress.ButtonBinding Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.ButtonBinding:
Deltares.Standard.Forms.DExpress.ControlBinding Deltares.Standard.Forms.DExpress.ComponentBinding Deltares.Standard.Forms.DExpress.ComponentWrappers.IGetBoundControl

Public Member Functions

ButtonBinding (Component component)
override void | Initialize (BindPropertyInfo propertyInfo, params string[] properties)
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.ControlBinding
override void | SetVisible (bool visible)
override void | SetEnabled (bool enabled)
override void | SetLabel (string text)
Sets the label/title/name associated with this control. More...
override void | SetDescription (string description)
Sets the textual description associated with this control. More...
override void | SetForegroundColor (Color color)
override void | SetBackgroundColor (Color color)
override void | Invalidate ()
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
ComponentBinding (Component component)
virtual void | Initialize (BindPropertyInfo propertyInfo, Type rootObjectType, params string[] properties)
virtual void | SetTrueMapping (object trueMapping)
virtual void | SetValue (object value)
virtual void | SetValue (object value, object parent)
virtual void | SetDomain (ICollection collection)
virtual object | GetValue ()
virtual void | Refresh ()
virtual void | RegisterSelectionAssignment (Component targetComponent, IConverter converter=null)
Indicates that the selection of the bound control must be assigned to another control. More...
virtual void | SetControlColors (Color fore, Color back)
Sets the controls foreground and background colors. Can be overridden by a specific binding to set other colors if necessary. More...

Additional Inherited Members

- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.ControlBinding
ControlBinding (Component component)
virtual void | OnToolTipShown (PopupEventArgs e)
Called when Tooltip is shown, and fires ToolTipShown event. More...
virtual void | OnToolTipClosed ()
Called when Tooltip is hidden, and fires ToolTipHidden. More...
void | ThreadSafeRefresh ()
override void | Dispose (bool disposing)
- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
void | RaiseValueChanged ()
void | RaiseLeave ()
void | RaiseActionPerformed ()
Type | GetGenericType (Type type)
string | ValueToString (object value)
bool | IsAssociatedPropertyVisible (object source, BindPropertyInfo associatedPropertyInfo)
Indicates whether the associated property (i.e. the property which is used to display the original property in a textbox) is visible More...
void | EditFileInfo (object source, BindPropertyInfo propertyInfo)
string | EditFileInfo (string value, string format, string label, string description, bool isDirectory)
string | GetDoubleString (string text)
bool | HasValidNumericValue (string text)
double | GetNumericValue (string text)
List< BindPropertyInfo > | GetDictionaryProperties (ICollection domain, BindPropertyInfo dynamicPropertyInfo)
- Protected Attributes inherited from Deltares.Standard.Forms.DExpress.ControlBinding
readonly ToolTip | tooltip
string | Description
The textual description associated with this

See also
Control

. More...

string | Label
The label/title/name associated with this Control. More...
- Protected Attributes inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
BindPropertyInfo | propInfo
- Properties inherited from Deltares.Standard.Forms.DExpress.ControlBinding
ToolTip | Tooltip [get]
Gets the tooltip for the bound control. More...
Control | BoundControl [get]
- Properties inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
Component | Component [get]
virtual bool | IsTransparant [get]
virtual HandleType | HandleDelayed [get]
virtual bool | HasDomain [get]
- Properties inherited from Deltares.Standard.Forms.DExpress.ComponentWrappers.IGetBoundControl
Control | BoundControl [get]
- Events inherited from Deltares.Standard.Forms.DExpress.ControlBinding
ToolTipVisibilityEventHandler | ToolTipHidden
ToolTipVisibilityEventHandler | ToolTipShown
- Events inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
EventHandler< EventArgs > | ActionPerformed
EventHandler< EventArgs > | Leave
EventHandler< EventArgs > | ValueChanged
Generated on Tue Dec 15 2015 18:14:44 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • ButtonBinding
Deltares.Standard.Forms.DExpress.ButtonBinding Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.ButtonBinding, including all inherited members.

ActionPerformed (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
BoundControl (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding |
ButtonBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.ButtonBinding) | Deltares.Standard.Forms.DExpress.ButtonBinding |
Component (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ComponentBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ControlBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Description | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Dispose(bool disposing) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | protected
EditFileInfo(object source, BindPropertyInfo propertyInfo) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
EditFileInfo(string value, string format, string label, string description, bool isDirectory) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetDictionaryProperties(ICollection domain, BindPropertyInfo dynamicPropertyInfo) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetDoubleString(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetGenericType(Type type) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetNumericValue(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetValue() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
HandleDelayed (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
HasDomain (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
HasValidNumericValue(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Initialize(BindPropertyInfo propertyInfo, params string[] properties) (defined in Deltares.Standard.Forms.DExpress.ButtonBinding) | Deltares.Standard.Forms.DExpress.ButtonBinding | virtual
Initialize(BindPropertyInfo propertyInfo, Type rootObjectType, params string[] properties) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
Invalidate() (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
IsAssociatedPropertyVisible(object source, BindPropertyInfo associatedPropertyInfo) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
IsTransparant (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
Label | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Leave (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
OnToolTipClosed() | Deltares.Standard.Forms.DExpress.ControlBinding | protectedvirtual
OnToolTipShown(PopupEventArgs e) | Deltares.Standard.Forms.DExpress.ControlBinding | protectedvirtual
propInfo (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseActionPerformed() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseLeave() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseValueChanged() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Refresh() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
RegisterSelectionAssignment(Component targetComponent, IConverter converter=null) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetBackgroundColor(Color color) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
SetControlColors(Color fore, Color back) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetDescription(string description) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
SetDomain(ICollection collection) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetEnabled(bool enabled) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
SetForegroundColor(Color color) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
SetLabel(string text) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
SetTrueMapping(object trueMapping) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetValue(object value) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetValue(object value, object parent) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetVisible(bool visible) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
ThreadSafeRefresh() (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | protected
tooltip (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Tooltip | Deltares.Standard.Forms.DExpress.ControlBinding | protected
ToolTipHidden (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding |
ToolTipShown (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding |
ValueChanged (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ValueToString(object value) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Generated on Tue Dec 15 2015 18:14:44 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.ButtonEditBinding Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • ButtonEditBinding
Public Member Functions | Properties | List of all members
Deltares.Standard.Forms.DExpress.ButtonEditBinding Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.ButtonEditBinding:
Deltares.Standard.Forms.DExpress.BaseControlBinding Deltares.Standard.Forms.DExpress.ControlBinding Deltares.Standard.Forms.DExpress.ComponentBinding Deltares.Standard.Forms.DExpress.ComponentWrappers.IGetBoundControl

Public Member Functions

ButtonEditBinding (Component component)
override void | Initialize (BindPropertyInfo propertyInfo, params string[] properties)
override void | SetValue (object value)
override object | GetValue ()
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.BaseControlBinding
override void | SetLabel (string text)
override void | SetDescription (string description)
override void | Invalidate ()
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.ControlBinding
override void | SetVisible (bool visible)
override void | SetEnabled (bool enabled)
override void | SetLabel (string text)
Sets the label/title/name associated with this control. More...
override void | SetDescription (string description)
Sets the textual description associated with this control. More...
override void | SetForegroundColor (Color color)
override void | SetBackgroundColor (Color color)
override void | Invalidate ()
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
ComponentBinding (Component component)
virtual void | Initialize (BindPropertyInfo propertyInfo, Type rootObjectType, params string[] properties)
virtual void | SetTrueMapping (object trueMapping)
virtual void | SetValue (object value, object parent)
virtual void | SetDomain (ICollection collection)
virtual void | Refresh ()
virtual void | RegisterSelectionAssignment (Component targetComponent, IConverter converter=null)
Indicates that the selection of the bound control must be assigned to another control. More...
virtual void | SetControlColors (Color fore, Color back)
Sets the controls foreground and background colors. Can be overridden by a specific binding to set other colors if necessary. More...

Properties

override HandleType | HandleDelayed [get]
- Properties inherited from Deltares.Standard.Forms.DExpress.ControlBinding
ToolTip | Tooltip [get]
Gets the tooltip for the bound control. More...
Control | BoundControl [get]
- Properties inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
Component | Component [get]
virtual bool | IsTransparant [get]
virtual HandleType | HandleDelayed [get]
virtual bool | HasDomain [get]
- Properties inherited from Deltares.Standard.Forms.DExpress.ComponentWrappers.IGetBoundControl
Control | BoundControl [get]

Additional Inherited Members

- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.BaseControlBinding
BaseControlBinding (Component component)
DXPopupMenu | GetPopupMenu ()
This method uses reflection to make the context menu accessible, which otherwise is protected. The Menu property is implemented for TextEdit, so we first make sure the control is actually of this type. More...
override void | OnToolTipShown (PopupEventArgs e)
Called when Tooltip is shown, and fires ToolTipShown event. More...
override void | OnToolTipClosed ()
Called when Tooltip is hidden, and fires ToolTipHidden. More...
override void | Dispose (bool disposing)
- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.ControlBinding
ControlBinding (Component component)
void | ThreadSafeRefresh ()
override void | Dispose (bool disposing)
- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
void | RaiseValueChanged ()
void | RaiseLeave ()
void | RaiseActionPerformed ()
Type | GetGenericType (Type type)
string | ValueToString (object value)
bool | IsAssociatedPropertyVisible (object source, BindPropertyInfo associatedPropertyInfo)
Indicates whether the associated property (i.e. the property which is used to display the original property in a textbox) is visible More...
void | EditFileInfo (object source, BindPropertyInfo propertyInfo)
string | EditFileInfo (string value, string format, string label, string description, bool isDirectory)
string | GetDoubleString (string text)
bool | HasValidNumericValue (string text)
double | GetNumericValue (string text)
List< BindPropertyInfo > | GetDictionaryProperties (ICollection domain, BindPropertyInfo dynamicPropertyInfo)
- Protected Attributes inherited from Deltares.Standard.Forms.DExpress.BaseControlBinding
readonly SuperToolTip | superTip
- Protected Attributes inherited from Deltares.Standard.Forms.DExpress.ControlBinding
readonly ToolTip | tooltip
string | Description
The textual description associated with this

See also
Control

. More...

string | Label
The label/title/name associated with this Control. More...
- Protected Attributes inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
BindPropertyInfo | propInfo
- Events inherited from Deltares.Standard.Forms.DExpress.ControlBinding
ToolTipVisibilityEventHandler | ToolTipHidden
ToolTipVisibilityEventHandler | ToolTipShown
- Events inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
EventHandler< EventArgs > | ActionPerformed
EventHandler< EventArgs > | Leave
EventHandler< EventArgs > | ValueChanged
Generated on Tue Dec 15 2015 18:14:45 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • ButtonEditBinding
Deltares.Standard.Forms.DExpress.ButtonEditBinding Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.ButtonEditBinding, including all inherited members.

ActionPerformed (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
BaseControlBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.BaseControlBinding) | Deltares.Standard.Forms.DExpress.BaseControlBinding | protected
BoundControl (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding |
ButtonEditBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.ButtonEditBinding) | Deltares.Standard.Forms.DExpress.ButtonEditBinding |
Component (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ComponentBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ControlBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Description | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Dispose(bool disposing) (defined in Deltares.Standard.Forms.DExpress.BaseControlBinding) | Deltares.Standard.Forms.DExpress.BaseControlBinding | protected
EditFileInfo(object source, BindPropertyInfo propertyInfo) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
EditFileInfo(string value, string format, string label, string description, bool isDirectory) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetDictionaryProperties(ICollection domain, BindPropertyInfo dynamicPropertyInfo) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetDoubleString(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetGenericType(Type type) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetNumericValue(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetPopupMenu() | Deltares.Standard.Forms.DExpress.BaseControlBinding | protected
GetValue() (defined in Deltares.Standard.Forms.DExpress.ButtonEditBinding) | Deltares.Standard.Forms.DExpress.ButtonEditBinding | virtual
HandleDelayed (defined in Deltares.Standard.Forms.DExpress.ButtonEditBinding) | Deltares.Standard.Forms.DExpress.ButtonEditBinding |
HasDomain (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
HasValidNumericValue(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Initialize(BindPropertyInfo propertyInfo, params string[] properties) (defined in Deltares.Standard.Forms.DExpress.ButtonEditBinding) | Deltares.Standard.Forms.DExpress.ButtonEditBinding | virtual
Initialize(BindPropertyInfo propertyInfo, Type rootObjectType, params string[] properties) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
Invalidate() (defined in Deltares.Standard.Forms.DExpress.BaseControlBinding) | Deltares.Standard.Forms.DExpress.BaseControlBinding | virtual
IsAssociatedPropertyVisible(object source, BindPropertyInfo associatedPropertyInfo) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
IsTransparant (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
Label | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Leave (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
OnToolTipClosed() | Deltares.Standard.Forms.DExpress.BaseControlBinding | protectedvirtual
OnToolTipShown(PopupEventArgs e) | Deltares.Standard.Forms.DExpress.BaseControlBinding | protectedvirtual
propInfo (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseActionPerformed() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseLeave() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseValueChanged() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Refresh() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
RegisterSelectionAssignment(Component targetComponent, IConverter converter=null) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetBackgroundColor(Color color) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
SetControlColors(Color fore, Color back) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetDescription(string description) (defined in Deltares.Standard.Forms.DExpress.BaseControlBinding) | Deltares.Standard.Forms.DExpress.BaseControlBinding | virtual
SetDomain(ICollection collection) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetEnabled(bool enabled) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
SetForegroundColor(Color color) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
SetLabel(string text) (defined in Deltares.Standard.Forms.DExpress.BaseControlBinding) | Deltares.Standard.Forms.DExpress.BaseControlBinding | virtual
SetTrueMapping(object trueMapping) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetValue(object value) (defined in Deltares.Standard.Forms.DExpress.ButtonEditBinding) | Deltares.Standard.Forms.DExpress.ButtonEditBinding | virtual
SetValue(object value, object parent) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetVisible(bool visible) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
superTip (defined in Deltares.Standard.Forms.DExpress.BaseControlBinding) | Deltares.Standard.Forms.DExpress.BaseControlBinding | protected
ThreadSafeRefresh() (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | protected
tooltip (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Tooltip | Deltares.Standard.Forms.DExpress.ControlBinding | protected
ToolTipHidden (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding |
ToolTipShown (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding |
ValueChanged (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ValueToString(object value) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Generated on Tue Dec 15 2015 18:14:45 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.CategoryDisplayItem Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • CategoryDisplayItem
Public Member Functions | Properties | List of all members
Deltares.Standard.Forms.DExpress.CategoryDisplayItem Class Reference

TODO: Comment More...

Inheritance diagram for Deltares.Standard.Forms.DExpress.CategoryDisplayItem:
Deltares.Standard.Forms.DExpress.ComboBoxDisplayItem

Public Member Functions

CategoryDisplayItem (string text, string translatedText)
Initializes a new instance of the CategoryDisplayItem class. More...
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.ComboBoxDisplayItem
ComboBoxDisplayItem (string text, string translatedText)
Initializes a new instance of the CategoryDisplayItem class. More...
override string ToString ()
Returns a System.String that represents this instance. More...

Properties

string | TranlatedText [set]
- Properties inherited from Deltares.Standard.Forms.DExpress.ComboBoxDisplayItem
string | Text [get]
Gets the category. More...

Additional Inherited Members

- Protected Attributes inherited from Deltares.Standard.Forms.DExpress.ComboBoxDisplayItem
string TranslatedText

Detailed Description

TODO: Comment

Constructor & Destructor Documentation

Deltares.Standard.Forms.DExpress.CategoryDisplayItem.CategoryDisplayItem | ( | string | text,
 |  | string | translatedText
 | ) |  |

Initializes a new instance of the CategoryDisplayItem class.

Parameters
text | The category text.
translatedText | The translated category text.
Generated on Tue Dec 15 2015 18:14:45 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • CategoryDisplayItem
Deltares.Standard.Forms.DExpress.CategoryDisplayItem Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.CategoryDisplayItem, including all inherited members.

CategoryDisplayItem(string text, string translatedText) | Deltares.Standard.Forms.DExpress.CategoryDisplayItem |
ComboBoxDisplayItem(string text, string translatedText) | Deltares.Standard.Forms.DExpress.ComboBoxDisplayItem |
Text | Deltares.Standard.Forms.DExpress.ComboBoxDisplayItem |
ToString() | Deltares.Standard.Forms.DExpress.ComboBoxDisplayItem |
TranlatedText (defined in Deltares.Standard.Forms.DExpress.CategoryDisplayItem) | Deltares.Standard.Forms.DExpress.CategoryDisplayItem |
TranslatedText (defined in Deltares.Standard.Forms.DExpress.ComboBoxDisplayItem) | Deltares.Standard.Forms.DExpress.ComboBoxDisplayItem | protected
Generated on Tue Dec 15 2015 18:14:45 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.ChangeInfo Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • ChangeInfo
Public Member Functions | Properties | List of all members
Deltares.Standard.Forms.DExpress.ChangeInfo Class Reference

Public Member Functions

ChangeInfo (string aName, object aValue, Type aType)

Properties

string | Name [get]
object | Value [get]
Type | Type [get]
Generated on Tue Dec 15 2015 18:14:45 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • ChangeInfo
Deltares.Standard.Forms.DExpress.ChangeInfo Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.ChangeInfo, including all inherited members.

ChangeInfo(string aName, object aValue, Type aType) (defined in Deltares.Standard.Forms.DExpress.ChangeInfo) | Deltares.Standard.Forms.DExpress.ChangeInfo
Name (defined in Deltares.Standard.Forms.DExpress.ChangeInfo) | Deltares.Standard.Forms.DExpress.ChangeInfo
Type (defined in Deltares.Standard.Forms.DExpress.ChangeInfo) | Deltares.Standard.Forms.DExpress.ChangeInfo
Value (defined in Deltares.Standard.Forms.DExpress.ChangeInfo) | Deltares.Standard.Forms.DExpress.ChangeInfo
Generated on Tue Dec 15 2015 18:14:45 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.ChartControlBinding Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • ChartControlBinding
Public Member Functions | Protected Member Functions | List of all members
Deltares.Standard.Forms.DExpress.ChartControlBinding Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.ChartControlBinding:
Deltares.Standard.Forms.DExpress.ControlBinding Deltares.Standard.Forms.DExpress.ComponentBinding Deltares.Standard.Forms.DExpress.ComponentWrappers.IGetBoundControl

Public Member Functions

ChartControlBinding (Component component)
override void | Refresh ()
override void | SetEnabled (bool enabled)
override void | Initialize (BindPropertyInfo propertyInfo, params string[] properties)
override void | SetValue (object value, object parent)
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.ControlBinding
override void | SetVisible (bool visible)
override void | SetEnabled (bool enabled)
override void | SetLabel (string text)
Sets the label/title/name associated with this control. More...
override void | SetDescription (string description)
Sets the textual description associated with this control. More...
override void | SetForegroundColor (Color color)
override void | SetBackgroundColor (Color color)
override void | Invalidate ()
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
ComponentBinding (Component component)
virtual void | Initialize (BindPropertyInfo propertyInfo, Type rootObjectType, params string[] properties)
virtual void | SetTrueMapping (object trueMapping)
virtual void | SetValue (object value)
virtual void | SetDomain (ICollection collection)
virtual object | GetValue ()
virtual void | RegisterSelectionAssignment (Component targetComponent, IConverter converter=null)
Indicates that the selection of the bound control must be assigned to another control. More...
virtual void | SetControlColors (Color fore, Color back)
Sets the controls foreground and background colors. Can be overridden by a specific binding to set other colors if necessary. More...

Protected Member Functions

override void | Dispose (bool disposing)
- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.ControlBinding
ControlBinding (Component component)
virtual void | OnToolTipShown (PopupEventArgs e)
Called when Tooltip is shown, and fires ToolTipShown event. More...
virtual void | OnToolTipClosed ()
Called when Tooltip is hidden, and fires ToolTipHidden. More...
void | ThreadSafeRefresh ()
override void | Dispose (bool disposing)
- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
void | RaiseValueChanged ()
void | RaiseLeave ()
void | RaiseActionPerformed ()
Type | GetGenericType (Type type)
string | ValueToString (object value)
bool | IsAssociatedPropertyVisible (object source, BindPropertyInfo associatedPropertyInfo)
Indicates whether the associated property (i.e. the property which is used to display the original property in a textbox) is visible More...
void | EditFileInfo (object source, BindPropertyInfo propertyInfo)
string | EditFileInfo (string value, string format, string label, string description, bool isDirectory)
string | GetDoubleString (string text)
bool | HasValidNumericValue (string text)
double | GetNumericValue (string text)
List< BindPropertyInfo > | GetDictionaryProperties (ICollection domain, BindPropertyInfo dynamicPropertyInfo)

Additional Inherited Members

- Protected Attributes inherited from Deltares.Standard.Forms.DExpress.ControlBinding
readonly ToolTip | tooltip
string | Description
The textual description associated with this

See also
Control

. More...

string | Label
The label/title/name associated with this Control. More...
- Protected Attributes inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
BindPropertyInfo | propInfo
- Properties inherited from Deltares.Standard.Forms.DExpress.ControlBinding
ToolTip | Tooltip [get]
Gets the tooltip for the bound control. More...
Control | BoundControl [get]
- Properties inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
Component | Component [get]
virtual bool | IsTransparant [get]
virtual HandleType | HandleDelayed [get]
virtual bool | HasDomain [get]
- Properties inherited from Deltares.Standard.Forms.DExpress.ComponentWrappers.IGetBoundControl
Control | BoundControl [get]
- Events inherited from Deltares.Standard.Forms.DExpress.ControlBinding
ToolTipVisibilityEventHandler | ToolTipHidden
ToolTipVisibilityEventHandler | ToolTipShown
- Events inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
EventHandler< EventArgs > | ActionPerformed
EventHandler< EventArgs > | Leave
EventHandler< EventArgs > | ValueChanged
Generated on Tue Dec 15 2015 18:14:45 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • ChartControlBinding
Deltares.Standard.Forms.DExpress.ChartControlBinding Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.ChartControlBinding, including all inherited members.

ActionPerformed (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
BoundControl (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding |
ChartControlBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.ChartControlBinding) | Deltares.Standard.Forms.DExpress.ChartControlBinding |
Component (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ComponentBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ControlBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Description | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Dispose(bool disposing) (defined in Deltares.Standard.Forms.DExpress.ChartControlBinding) | Deltares.Standard.Forms.DExpress.ChartControlBinding | protected
EditFileInfo(object source, BindPropertyInfo propertyInfo) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
EditFileInfo(string value, string format, string label, string description, bool isDirectory) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetDictionaryProperties(ICollection domain, BindPropertyInfo dynamicPropertyInfo) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetDoubleString(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetGenericType(Type type) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetNumericValue(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetValue() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
HandleDelayed (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
HasDomain (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
HasValidNumericValue(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Initialize(BindPropertyInfo propertyInfo, params string[] properties) (defined in Deltares.Standard.Forms.DExpress.ChartControlBinding) | Deltares.Standard.Forms.DExpress.ChartControlBinding | virtual
Initialize(BindPropertyInfo propertyInfo, Type rootObjectType, params string[] properties) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
Invalidate() (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
IsAssociatedPropertyVisible(object source, BindPropertyInfo associatedPropertyInfo) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
IsTransparant (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
Label | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Leave (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
OnToolTipClosed() | Deltares.Standard.Forms.DExpress.ControlBinding | protectedvirtual
OnToolTipShown(PopupEventArgs e) | Deltares.Standard.Forms.DExpress.ControlBinding | protectedvirtual
propInfo (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseActionPerformed() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseLeave() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseValueChanged() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Refresh() (defined in Deltares.Standard.Forms.DExpress.ChartControlBinding) | Deltares.Standard.Forms.DExpress.ChartControlBinding | virtual
RegisterSelectionAssignment(Component targetComponent, IConverter converter=null) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetBackgroundColor(Color color) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
SetControlColors(Color fore, Color back) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetDescription(string description) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
SetDomain(ICollection collection) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetEnabled(bool enabled) (defined in Deltares.Standard.Forms.DExpress.ChartControlBinding) | Deltares.Standard.Forms.DExpress.ChartControlBinding | virtual
SetForegroundColor(Color color) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
SetLabel(string text) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
SetTrueMapping(object trueMapping) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetValue(object value, object parent) (defined in Deltares.Standard.Forms.DExpress.ChartControlBinding) | Deltares.Standard.Forms.DExpress.ChartControlBinding | virtual
SetValue(object value) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetVisible(bool visible) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
ThreadSafeRefresh() (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Tooltip | Deltares.Standard.Forms.DExpress.ControlBinding | protected
tooltip (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | protected
ToolTipHidden (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding |
ToolTipShown (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding |
ValueChanged (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ValueToString(object value) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Generated on Tue Dec 15 2015 18:14:45 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.CheckBoxBinding Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • CheckBoxBinding
Public Member Functions | List of all members
Deltares.Standard.Forms.DExpress.CheckBoxBinding Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.CheckBoxBinding:
Deltares.Standard.Forms.DExpress.ControlBinding Deltares.Standard.Forms.DExpress.ComponentBinding Deltares.Standard.Forms.DExpress.ComponentWrappers.IGetBoundControl

Public Member Functions

CheckBoxBinding (Component component)
override void | Initialize (BindPropertyInfo propertyInfo, params string[] properties)
override void | SetValue (object value)
override object | GetValue ()
override void | SetLabel (string text)
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.ControlBinding
override void | SetVisible (bool visible)
override void | SetEnabled (bool enabled)
override void | SetLabel (string text)
Sets the label/title/name associated with this control. More...
override void | SetDescription (string description)
Sets the textual description associated with this control. More...
override void | SetForegroundColor (Color color)
override void | SetBackgroundColor (Color color)
override void | Invalidate ()
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
ComponentBinding (Component component)
virtual void | Initialize (BindPropertyInfo propertyInfo, Type rootObjectType, params string[] properties)
virtual void | SetTrueMapping (object trueMapping)
virtual void | SetValue (object value, object parent)
virtual void | SetDomain (ICollection collection)
virtual void | Refresh ()
virtual void | RegisterSelectionAssignment (Component targetComponent, IConverter converter=null)
Indicates that the selection of the bound control must be assigned to another control. More...
virtual void | SetControlColors (Color fore, Color back)
Sets the controls foreground and background colors. Can be overridden by a specific binding to set other colors if necessary. More...

Additional Inherited Members

- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.ControlBinding
ControlBinding (Component component)
virtual void | OnToolTipShown (PopupEventArgs e)
Called when Tooltip is shown, and fires ToolTipShown event. More...
virtual void | OnToolTipClosed ()
Called when Tooltip is hidden, and fires ToolTipHidden. More...
void | ThreadSafeRefresh ()
override void | Dispose (bool disposing)
- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
void | RaiseValueChanged ()
void | RaiseLeave ()
void | RaiseActionPerformed ()
Type | GetGenericType (Type type)
string | ValueToString (object value)
bool | IsAssociatedPropertyVisible (object source, BindPropertyInfo associatedPropertyInfo)
Indicates whether the associated property (i.e. the property which is used to display the original property in a textbox) is visible More...
void | EditFileInfo (object source, BindPropertyInfo propertyInfo)
string | EditFileInfo (string value, string format, string label, string description, bool isDirectory)
string | GetDoubleString (string text)
bool | HasValidNumericValue (string text)
double | GetNumericValue (string text)
List< BindPropertyInfo > | GetDictionaryProperties (ICollection domain, BindPropertyInfo dynamicPropertyInfo)
- Protected Attributes inherited from Deltares.Standard.Forms.DExpress.ControlBinding
readonly ToolTip | tooltip
string | Description
The textual description associated with this

See also
Control

. More...

string | Label
The label/title/name associated with this Control. More...
- Protected Attributes inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
BindPropertyInfo | propInfo
- Properties inherited from Deltares.Standard.Forms.DExpress.ControlBinding
ToolTip | Tooltip [get]
Gets the tooltip for the bound control. More...
Control | BoundControl [get]
- Properties inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
Component | Component [get]
virtual bool | IsTransparant [get]
virtual HandleType | HandleDelayed [get]
virtual bool | HasDomain [get]
- Properties inherited from Deltares.Standard.Forms.DExpress.ComponentWrappers.IGetBoundControl
Control | BoundControl [get]
- Events inherited from Deltares.Standard.Forms.DExpress.ControlBinding
ToolTipVisibilityEventHandler | ToolTipHidden
ToolTipVisibilityEventHandler | ToolTipShown
- Events inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
EventHandler< EventArgs > | ActionPerformed
EventHandler< EventArgs > | Leave
EventHandler< EventArgs > | ValueChanged
Generated on Tue Dec 15 2015 18:14:46 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • CheckBoxBinding
Deltares.Standard.Forms.DExpress.CheckBoxBinding Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.CheckBoxBinding, including all inherited members.

ActionPerformed (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
BoundControl (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding |
CheckBoxBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.CheckBoxBinding) | Deltares.Standard.Forms.DExpress.CheckBoxBinding |
Component (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ComponentBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ControlBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Description | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Dispose(bool disposing) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | protected
EditFileInfo(object source, BindPropertyInfo propertyInfo) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
EditFileInfo(string value, string format, string label, string description, bool isDirectory) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetDictionaryProperties(ICollection domain, BindPropertyInfo dynamicPropertyInfo) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetDoubleString(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetGenericType(Type type) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetNumericValue(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetValue() (defined in Deltares.Standard.Forms.DExpress.CheckBoxBinding) | Deltares.Standard.Forms.DExpress.CheckBoxBinding | virtual
HandleDelayed (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
HasDomain (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
HasValidNumericValue(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Initialize(BindPropertyInfo propertyInfo, params string[] properties) (defined in Deltares.Standard.Forms.DExpress.CheckBoxBinding) | Deltares.Standard.Forms.DExpress.CheckBoxBinding | virtual
Initialize(BindPropertyInfo propertyInfo, Type rootObjectType, params string[] properties) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
Invalidate() (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
IsAssociatedPropertyVisible(object source, BindPropertyInfo associatedPropertyInfo) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
IsTransparant (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
Label | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Leave (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
OnToolTipClosed() | Deltares.Standard.Forms.DExpress.ControlBinding | protectedvirtual
OnToolTipShown(PopupEventArgs e) | Deltares.Standard.Forms.DExpress.ControlBinding | protectedvirtual
propInfo (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseActionPerformed() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseLeave() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseValueChanged() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Refresh() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
RegisterSelectionAssignment(Component targetComponent, IConverter converter=null) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetBackgroundColor(Color color) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
SetControlColors(Color fore, Color back) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetDescription(string description) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
SetDomain(ICollection collection) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetEnabled(bool enabled) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
SetForegroundColor(Color color) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
SetLabel(string text) (defined in Deltares.Standard.Forms.DExpress.CheckBoxBinding) | Deltares.Standard.Forms.DExpress.CheckBoxBinding | virtual
SetTrueMapping(object trueMapping) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetValue(object value) (defined in Deltares.Standard.Forms.DExpress.CheckBoxBinding) | Deltares.Standard.Forms.DExpress.CheckBoxBinding | virtual
SetValue(object value, object parent) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetVisible(bool visible) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
ThreadSafeRefresh() (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | protected
tooltip (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Tooltip | Deltares.Standard.Forms.DExpress.ControlBinding | protected
ToolTipHidden (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding |
ToolTipShown (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding |
ValueChanged (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ValueToString(object value) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Generated on Tue Dec 15 2015 18:14:46 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.CheckEditBinding Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • CheckEditBinding
Public Member Functions | Properties | List of all members
Deltares.Standard.Forms.DExpress.CheckEditBinding Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.CheckEditBinding:
Deltares.Standard.Forms.DExpress.BaseControlBinding Deltares.Standard.Forms.DExpress.ControlBinding Deltares.Standard.Forms.DExpress.ComponentBinding Deltares.Standard.Forms.DExpress.ComponentWrappers.IGetBoundControl

Public Member Functions

CheckEditBinding (Component component)
override void | Initialize (BindPropertyInfo propertyInfo, params string[] properties)
override void | SetTrueMapping (object trueMapping)
override void | SetValue (object value)
override object | GetValue ()
override void | SetLabel (string text)
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.BaseControlBinding
override void | SetDescription (string description)
override void | Invalidate ()
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.ControlBinding
override void | SetVisible (bool visible)
override void | SetEnabled (bool enabled)
override void | SetLabel (string text)
Sets the label/title/name associated with this control. More...
override void | SetDescription (string description)
Sets the textual description associated with this control. More...
override void | SetForegroundColor (Color color)
override void | SetBackgroundColor (Color color)
override void | Invalidate ()
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
ComponentBinding (Component component)
virtual void | Initialize (BindPropertyInfo propertyInfo, Type rootObjectType, params string[] properties)
virtual void | SetValue (object value, object parent)
virtual void | SetDomain (ICollection collection)
virtual void | Refresh ()
virtual void | RegisterSelectionAssignment (Component targetComponent, IConverter converter=null)
Indicates that the selection of the bound control must be assigned to another control. More...
virtual void | SetControlColors (Color fore, Color back)
Sets the controls foreground and background colors. Can be overridden by a specific binding to set other colors if necessary. More...

Properties

override bool | IsTransparant [get]
- Properties inherited from Deltares.Standard.Forms.DExpress.ControlBinding
ToolTip | Tooltip [get]
Gets the tooltip for the bound control. More...
Control | BoundControl [get]
- Properties inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
Component | Component [get]
virtual bool | IsTransparant [get]
virtual HandleType | HandleDelayed [get]
virtual bool | HasDomain [get]
- Properties inherited from Deltares.Standard.Forms.DExpress.ComponentWrappers.IGetBoundControl
Control | BoundControl [get]

Additional Inherited Members

- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.BaseControlBinding
BaseControlBinding (Component component)
DXPopupMenu | GetPopupMenu ()
This method uses reflection to make the context menu accessible, which otherwise is protected. The Menu property is implemented for TextEdit, so we first make sure the control is actually of this type. More...
override void | OnToolTipShown (PopupEventArgs e)
Called when Tooltip is shown, and fires ToolTipShown event. More...
override void | OnToolTipClosed ()
Called when Tooltip is hidden, and fires ToolTipHidden. More...
override void | Dispose (bool disposing)
- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.ControlBinding
ControlBinding (Component component)
void | ThreadSafeRefresh ()
override void | Dispose (bool disposing)
- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
void | RaiseValueChanged ()
void | RaiseLeave ()
void | RaiseActionPerformed ()
Type | GetGenericType (Type type)
string | ValueToString (object value)
bool | IsAssociatedPropertyVisible (object source, BindPropertyInfo associatedPropertyInfo)
Indicates whether the associated property (i.e. the property which is used to display the original property in a textbox) is visible More...
void | EditFileInfo (object source, BindPropertyInfo propertyInfo)
string | EditFileInfo (string value, string format, string label, string description, bool isDirectory)
string | GetDoubleString (string text)
bool | HasValidNumericValue (string text)
double | GetNumericValue (string text)
List< BindPropertyInfo > | GetDictionaryProperties (ICollection domain, BindPropertyInfo dynamicPropertyInfo)
- Protected Attributes inherited from Deltares.Standard.Forms.DExpress.BaseControlBinding
readonly SuperToolTip | superTip
- Protected Attributes inherited from Deltares.Standard.Forms.DExpress.ControlBinding
readonly ToolTip | tooltip
string | Description
The textual description associated with this

See also
Control

. More...

string | Label
The label/title/name associated with this Control. More...
- Protected Attributes inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
BindPropertyInfo | propInfo
- Events inherited from Deltares.Standard.Forms.DExpress.ControlBinding
ToolTipVisibilityEventHandler | ToolTipHidden
ToolTipVisibilityEventHandler | ToolTipShown
- Events inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
EventHandler< EventArgs > | ActionPerformed
EventHandler< EventArgs > | Leave
EventHandler< EventArgs > | ValueChanged
Generated on Tue Dec 15 2015 18:14:46 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • CheckEditBinding
Deltares.Standard.Forms.DExpress.CheckEditBinding Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.CheckEditBinding, including all inherited members.

ActionPerformed (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
BaseControlBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.BaseControlBinding) | Deltares.Standard.Forms.DExpress.BaseControlBinding | protected
BoundControl (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding |
CheckEditBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.CheckEditBinding) | Deltares.Standard.Forms.DExpress.CheckEditBinding |
Component (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ComponentBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ControlBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Description | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Dispose(bool disposing) (defined in Deltares.Standard.Forms.DExpress.BaseControlBinding) | Deltares.Standard.Forms.DExpress.BaseControlBinding | protected
EditFileInfo(object source, BindPropertyInfo propertyInfo) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
EditFileInfo(string value, string format, string label, string description, bool isDirectory) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetDictionaryProperties(ICollection domain, BindPropertyInfo dynamicPropertyInfo) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetDoubleString(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetGenericType(Type type) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetNumericValue(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetPopupMenu() | Deltares.Standard.Forms.DExpress.BaseControlBinding | protected
GetValue() (defined in Deltares.Standard.Forms.DExpress.CheckEditBinding) | Deltares.Standard.Forms.DExpress.CheckEditBinding | virtual
HandleDelayed (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
HasDomain (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
HasValidNumericValue(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Initialize(BindPropertyInfo propertyInfo, params string[] properties) (defined in Deltares.Standard.Forms.DExpress.CheckEditBinding) | Deltares.Standard.Forms.DExpress.CheckEditBinding | virtual
Initialize(BindPropertyInfo propertyInfo, Type rootObjectType, params string[] properties) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
Invalidate() (defined in Deltares.Standard.Forms.DExpress.BaseControlBinding) | Deltares.Standard.Forms.DExpress.BaseControlBinding | virtual
IsAssociatedPropertyVisible(object source, BindPropertyInfo associatedPropertyInfo) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
IsTransparant (defined in Deltares.Standard.Forms.DExpress.CheckEditBinding) | Deltares.Standard.Forms.DExpress.CheckEditBinding |
Label | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Leave (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
OnToolTipClosed() | Deltares.Standard.Forms.DExpress.BaseControlBinding | protectedvirtual
OnToolTipShown(PopupEventArgs e) | Deltares.Standard.Forms.DExpress.BaseControlBinding | protectedvirtual
propInfo (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseActionPerformed() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseLeave() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseValueChanged() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Refresh() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
RegisterSelectionAssignment(Component targetComponent, IConverter converter=null) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetBackgroundColor(Color color) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
SetControlColors(Color fore, Color back) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetDescription(string description) (defined in Deltares.Standard.Forms.DExpress.BaseControlBinding) | Deltares.Standard.Forms.DExpress.BaseControlBinding | virtual
SetDomain(ICollection collection) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetEnabled(bool enabled) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
SetForegroundColor(Color color) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
SetLabel(string text) (defined in Deltares.Standard.Forms.DExpress.CheckEditBinding) | Deltares.Standard.Forms.DExpress.CheckEditBinding | virtual
SetTrueMapping(object trueMapping) (defined in Deltares.Standard.Forms.DExpress.CheckEditBinding) | Deltares.Standard.Forms.DExpress.CheckEditBinding | virtual
SetValue(object value) (defined in Deltares.Standard.Forms.DExpress.CheckEditBinding) | Deltares.Standard.Forms.DExpress.CheckEditBinding | virtual
SetValue(object value, object parent) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetVisible(bool visible) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
superTip (defined in Deltares.Standard.Forms.DExpress.BaseControlBinding) | Deltares.Standard.Forms.DExpress.BaseControlBinding | protected
ThreadSafeRefresh() (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | protected
tooltip (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Tooltip | Deltares.Standard.Forms.DExpress.ControlBinding | protected
ToolTipHidden (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding |
ToolTipShown (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding |
ValueChanged (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ValueToString(object value) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Generated on Tue Dec 15 2015 18:14:46 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.ChildObject Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • ChildObject
Public Member Functions | Properties | List of all members
Deltares.Standard.Forms.DExpress.ChildObject Class Reference

Public Member Functions

ChildObject (object dataObject, bool completeSelection)
override string | ToString ()
ChildObject (object dataObject, bool completeSelection)
override string | ToString ()

Properties

object | DataObject [get, set]
bool | CompleteSelection [get, set]
Generated on Tue Dec 15 2015 18:14:46 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • ChildObject
Deltares.Standard.Forms.DExpress.ChildObject Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.ChildObject, including all inherited members.

ChildObject(object dataObject, bool completeSelection) (defined in Deltares.Standard.Forms.DExpress.ChildObject) | Deltares.Standard.Forms.DExpress.ChildObject
ChildObject(object dataObject, bool completeSelection) (defined in Deltares.Standard.Forms.DExpress.ChildObject) | Deltares.Standard.Forms.DExpress.ChildObject
CompleteSelection (defined in Deltares.Standard.Forms.DExpress.ChildObject) | Deltares.Standard.Forms.DExpress.ChildObject
DataObject (defined in Deltares.Standard.Forms.DExpress.ChildObject) | Deltares.Standard.Forms.DExpress.ChildObject
ToString() (defined in Deltares.Standard.Forms.DExpress.ChildObject) | Deltares.Standard.Forms.DExpress.ChildObject
ToString() (defined in Deltares.Standard.Forms.DExpress.ChildObject) | Deltares.Standard.Forms.DExpress.ChildObject
Generated on Tue Dec 15 2015 18:14:46 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.ColorEditBinding Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • ColorEditBinding
Public Member Functions | List of all members
Deltares.Standard.Forms.DExpress.ColorEditBinding Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.ColorEditBinding:
Deltares.Standard.Forms.DExpress.BaseControlBinding Deltares.Standard.Forms.DExpress.ControlBinding Deltares.Standard.Forms.DExpress.ComponentBinding Deltares.Standard.Forms.DExpress.ComponentWrappers.IGetBoundControl

Public Member Functions

ColorEditBinding (Component component)
override void | Initialize (BindPropertyInfo propertyInfo, params string[] properties)
override void | SetValue (object value)
override object | GetValue ()
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.BaseControlBinding
override void | SetLabel (string text)
override void | SetDescription (string description)
override void | Invalidate ()
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.ControlBinding
override void | SetVisible (bool visible)
override void | SetEnabled (bool enabled)
override void | SetLabel (string text)
Sets the label/title/name associated with this control. More...
override void | SetDescription (string description)
Sets the textual description associated with this control. More...
override void | SetForegroundColor (Color color)
override void | SetBackgroundColor (Color color)
override void | Invalidate ()
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
ComponentBinding (Component component)
virtual void | Initialize (BindPropertyInfo propertyInfo, Type rootObjectType, params string[] properties)
virtual void | SetTrueMapping (object trueMapping)
virtual void | SetValue (object value, object parent)
virtual void | SetDomain (ICollection collection)
virtual void | Refresh ()
virtual void | RegisterSelectionAssignment (Component targetComponent, IConverter converter=null)
Indicates that the selection of the bound control must be assigned to another control. More...
virtual void | SetControlColors (Color fore, Color back)
Sets the controls foreground and background colors. Can be overridden by a specific binding to set other colors if necessary. More...

Additional Inherited Members

- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.BaseControlBinding
BaseControlBinding (Component component)
DXPopupMenu | GetPopupMenu ()
This method uses reflection to make the context menu accessible, which otherwise is protected. The Menu property is implemented for TextEdit, so we first make sure the control is actually of this type. More...
override void | OnToolTipShown (PopupEventArgs e)
Called when Tooltip is shown, and fires ToolTipShown event. More...
override void | OnToolTipClosed ()
Called when Tooltip is hidden, and fires ToolTipHidden. More...
override void | Dispose (bool disposing)
- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.ControlBinding
ControlBinding (Component component)
void | ThreadSafeRefresh ()
override void | Dispose (bool disposing)
- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
void | RaiseValueChanged ()
void | RaiseLeave ()
void | RaiseActionPerformed ()
Type | GetGenericType (Type type)
string | ValueToString (object value)
bool | IsAssociatedPropertyVisible (object source, BindPropertyInfo associatedPropertyInfo)
Indicates whether the associated property (i.e. the property which is used to display the original property in a textbox) is visible More...
void | EditFileInfo (object source, BindPropertyInfo propertyInfo)
string | EditFileInfo (string value, string format, string label, string description, bool isDirectory)
string | GetDoubleString (string text)
bool | HasValidNumericValue (string text)
double | GetNumericValue (string text)
List< BindPropertyInfo > | GetDictionaryProperties (ICollection domain, BindPropertyInfo dynamicPropertyInfo)
- Protected Attributes inherited from Deltares.Standard.Forms.DExpress.BaseControlBinding
readonly SuperToolTip | superTip
- Protected Attributes inherited from Deltares.Standard.Forms.DExpress.ControlBinding
readonly ToolTip | tooltip
string | Description
The textual description associated with this

See also
Control

. More...

string | Label
The label/title/name associated with this Control. More...
- Protected Attributes inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
BindPropertyInfo | propInfo
- Properties inherited from Deltares.Standard.Forms.DExpress.ControlBinding
ToolTip | Tooltip [get]
Gets the tooltip for the bound control. More...
Control | BoundControl [get]
- Properties inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
Component | Component [get]
virtual bool | IsTransparant [get]
virtual HandleType | HandleDelayed [get]
virtual bool | HasDomain [get]
- Properties inherited from Deltares.Standard.Forms.DExpress.ComponentWrappers.IGetBoundControl
Control | BoundControl [get]
- Events inherited from Deltares.Standard.Forms.DExpress.ControlBinding
ToolTipVisibilityEventHandler | ToolTipHidden
ToolTipVisibilityEventHandler | ToolTipShown
- Events inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
EventHandler< EventArgs > | ActionPerformed
EventHandler< EventArgs > | Leave
EventHandler< EventArgs > | ValueChanged
Generated on Tue Dec 15 2015 18:14:46 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • ColorEditBinding
Deltares.Standard.Forms.DExpress.ColorEditBinding Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.ColorEditBinding, including all inherited members.

ActionPerformed (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
BaseControlBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.BaseControlBinding) | Deltares.Standard.Forms.DExpress.BaseControlBinding | protected
BoundControl (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding |
ColorEditBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.ColorEditBinding) | Deltares.Standard.Forms.DExpress.ColorEditBinding |
Component (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ComponentBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ControlBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Description | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Dispose(bool disposing) (defined in Deltares.Standard.Forms.DExpress.BaseControlBinding) | Deltares.Standard.Forms.DExpress.BaseControlBinding | protected
EditFileInfo(object source, BindPropertyInfo propertyInfo) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
EditFileInfo(string value, string format, string label, string description, bool isDirectory) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetDictionaryProperties(ICollection domain, BindPropertyInfo dynamicPropertyInfo) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetDoubleString(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetGenericType(Type type) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetNumericValue(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetPopupMenu() | Deltares.Standard.Forms.DExpress.BaseControlBinding | protected
GetValue() (defined in Deltares.Standard.Forms.DExpress.ColorEditBinding) | Deltares.Standard.Forms.DExpress.ColorEditBinding | virtual
HandleDelayed (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
HasDomain (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
HasValidNumericValue(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Initialize(BindPropertyInfo propertyInfo, params string[] properties) (defined in Deltares.Standard.Forms.DExpress.ColorEditBinding) | Deltares.Standard.Forms.DExpress.ColorEditBinding | virtual
Initialize(BindPropertyInfo propertyInfo, Type rootObjectType, params string[] properties) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
Invalidate() (defined in Deltares.Standard.Forms.DExpress.BaseControlBinding) | Deltares.Standard.Forms.DExpress.BaseControlBinding | virtual
IsAssociatedPropertyVisible(object source, BindPropertyInfo associatedPropertyInfo) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
IsTransparant (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
Label | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Leave (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
OnToolTipClosed() | Deltares.Standard.Forms.DExpress.BaseControlBinding | protectedvirtual
OnToolTipShown(PopupEventArgs e) | Deltares.Standard.Forms.DExpress.BaseControlBinding | protectedvirtual
propInfo (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseActionPerformed() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseLeave() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseValueChanged() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Refresh() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
RegisterSelectionAssignment(Component targetComponent, IConverter converter=null) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetBackgroundColor(Color color) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
SetControlColors(Color fore, Color back) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetDescription(string description) (defined in Deltares.Standard.Forms.DExpress.BaseControlBinding) | Deltares.Standard.Forms.DExpress.BaseControlBinding | virtual
SetDomain(ICollection collection) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetEnabled(bool enabled) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
SetForegroundColor(Color color) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
SetLabel(string text) (defined in Deltares.Standard.Forms.DExpress.BaseControlBinding) | Deltares.Standard.Forms.DExpress.BaseControlBinding | virtual
SetTrueMapping(object trueMapping) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetValue(object value) (defined in Deltares.Standard.Forms.DExpress.ColorEditBinding) | Deltares.Standard.Forms.DExpress.ColorEditBinding | virtual
SetValue(object value, object parent) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetVisible(bool visible) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
superTip (defined in Deltares.Standard.Forms.DExpress.BaseControlBinding) | Deltares.Standard.Forms.DExpress.BaseControlBinding | protected
ThreadSafeRefresh() (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Tooltip | Deltares.Standard.Forms.DExpress.ControlBinding | protected
tooltip (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | protected
ToolTipHidden (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding |
ToolTipShown (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding |
ValueChanged (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ValueToString(object value) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Generated on Tue Dec 15 2015 18:14:46 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.ColumnWidth Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • ColumnWidth
Public Member Functions | Static Public Member Functions | Properties | List of all members
Deltares.Standard.Forms.DExpress.ColumnWidth Class Reference

Public Member Functions

ColumnWidth (string name, int width)
ColumnWidth (string name, int width, int leftPadding)
override string ToString ()

Static Public Member Functions

static ColumnWidth FromString (string str, int width, int leftPadding)

Properties

string | Name [get, set]
int | Width [get, set]
int | LeftPadding [get, set]
Generated on Tue Dec 15 2015 18:14:46 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • ColumnWidth
Deltares.Standard.Forms.DExpress.ColumnWidth Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.ColumnWidth, including all inherited members.

ColumnWidth() (defined in Deltares.Standard.Forms.DExpress.ColumnWidth) | Deltares.Standard.Forms.DExpress.ColumnWidth |
ColumnWidth(string name, int width) (defined in Deltares.Standard.Forms.DExpress.ColumnWidth) | Deltares.Standard.Forms.DExpress.ColumnWidth |
ColumnWidth(string name, int width, int leftPadding) (defined in Deltares.Standard.Forms.DExpress.ColumnWidth) | Deltares.Standard.Forms.DExpress.ColumnWidth |
FromString(string str, int width, int leftPadding) (defined in Deltares.Standard.Forms.DExpress.ColumnWidth) | Deltares.Standard.Forms.DExpress.ColumnWidth | static
LeftPadding (defined in Deltares.Standard.Forms.DExpress.ColumnWidth) | Deltares.Standard.Forms.DExpress.ColumnWidth |
Name (defined in Deltares.Standard.Forms.DExpress.ColumnWidth) | Deltares.Standard.Forms.DExpress.ColumnWidth |
ToString() (defined in Deltares.Standard.Forms.DExpress.ColumnWidth) | Deltares.Standard.Forms.DExpress.ColumnWidth |
Width (defined in Deltares.Standard.Forms.DExpress.ColumnWidth) | Deltares.Standard.Forms.DExpress.ColumnWidth |
Generated on Tue Dec 15 2015 18:14:46 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.ComboBoxDisplayItem Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • ComboBoxDisplayItem
Public Member Functions | Protected Attributes | Properties | List of all members
Deltares.Standard.Forms.DExpress.ComboBoxDisplayItem Class Reference

This class is used for items displayed in a combo box. More...

Inheritance diagram for Deltares.Standard.Forms.DExpress.ComboBoxDisplayItem:
Deltares.Standard.Forms.DExpress.CategoryDisplayItem Deltares.Standard.Forms.DExpress.UserColumnFilterDisplayItem

Public Member Functions

ComboBoxDisplayItem (string text, string translatedText)
Initializes a new instance of the CategoryDisplayItem class. More...
override string ToString ()
Returns a System.String that represents this instance. More...

Protected Attributes

string TranslatedText

Properties

string Text [get]
Gets the category. More...

Detailed Description

This class is used for items displayed in a combo box.

Constructor & Destructor Documentation

Deltares.Standard.Forms.DExpress.ComboBoxDisplayItem.ComboBoxDisplayItem | ( | string | text,
 |  | string | translatedText
 | ) |  |

Initializes a new instance of the CategoryDisplayItem class.

Parameters
text | The category.
translatedText | The translated category.

Member Function Documentation

override string Deltares.Standard.Forms.DExpress.ComboBoxDisplayItem.ToString ( )

Returns a System.String that represents this instance.

Returns
A System.String that represents this instance.

Property Documentation

string Deltares.Standard.Forms.DExpress.ComboBoxDisplayItem.Text
get

Gets the category.

The category.

Generated on Tue Dec 15 2015 18:14:46 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • ComboBoxDisplayItem
Deltares.Standard.Forms.DExpress.ComboBoxDisplayItem Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.ComboBoxDisplayItem, including all inherited members.

ComboBoxDisplayItem(string text, string translatedText) | Deltares.Standard.Forms.DExpress.ComboBoxDisplayItem |
Text | Deltares.Standard.Forms.DExpress.ComboBoxDisplayItem |
ToString() | Deltares.Standard.Forms.DExpress.ComboBoxDisplayItem |
TranslatedText (defined in Deltares.Standard.Forms.DExpress.ComboBoxDisplayItem) | Deltares.Standard.Forms.DExpress.ComboBoxDisplayItem | protected
Generated on Tue Dec 15 2015 18:14:47 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.ComboBoxEditBinding Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • ComboBoxEditBinding
Public Member Functions | Properties | List of all members
Deltares.Standard.Forms.DExpress.ComboBoxEditBinding Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.ComboBoxEditBinding:
Deltares.Standard.Forms.DExpress.BaseControlBinding Deltares.Standard.Forms.DExpress.ControlBinding Deltares.Standard.Forms.DExpress.ComponentBinding Deltares.Standard.Forms.DExpress.ComponentWrappers.IGetBoundControl

Public Member Functions

ComboBoxEditBinding (Component component)
override void | Initialize (BindPropertyInfo propertyInfo, params string[] properties)
override void | SetDomain (ICollection domain)
override void | SetValue (object value)
override object | GetValue ()
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.BaseControlBinding
override void | SetLabel (string text)
override void | SetDescription (string description)
override void | Invalidate ()
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.ControlBinding
override void | SetVisible (bool visible)
override void | SetEnabled (bool enabled)
override void | SetLabel (string text)
Sets the label/title/name associated with this control. More...
override void | SetDescription (string description)
Sets the textual description associated with this control. More...
override void | SetForegroundColor (Color color)
override void | SetBackgroundColor (Color color)
override void | Invalidate ()
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
ComponentBinding (Component component)
virtual void | Initialize (BindPropertyInfo propertyInfo, Type rootObjectType, params string[] properties)
virtual void | SetTrueMapping (object trueMapping)
virtual void | SetValue (object value, object parent)
virtual void | Refresh ()
virtual void | RegisterSelectionAssignment (Component targetComponent, IConverter converter=null)
Indicates that the selection of the bound control must be assigned to another control. More...
virtual void | SetControlColors (Color fore, Color back)
Sets the controls foreground and background colors. Can be overridden by a specific binding to set other colors if necessary. More...

Properties

override bool | HasDomain [get]
- Properties inherited from Deltares.Standard.Forms.DExpress.ControlBinding
ToolTip | Tooltip [get]
Gets the tooltip for the bound control. More...
Control | BoundControl [get]
- Properties inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
Component | Component [get]
virtual bool | IsTransparant [get]
virtual HandleType | HandleDelayed [get]
virtual bool | HasDomain [get]
- Properties inherited from Deltares.Standard.Forms.DExpress.ComponentWrappers.IGetBoundControl
Control | BoundControl [get]

Additional Inherited Members

- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.BaseControlBinding
BaseControlBinding (Component component)
DXPopupMenu | GetPopupMenu ()
This method uses reflection to make the context menu accessible, which otherwise is protected. The Menu property is implemented for TextEdit, so we first make sure the control is actually of this type. More...
override void | OnToolTipShown (PopupEventArgs e)
Called when Tooltip is shown, and fires ToolTipShown event. More...
override void | OnToolTipClosed ()
Called when Tooltip is hidden, and fires ToolTipHidden. More...
override void | Dispose (bool disposing)
- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.ControlBinding
ControlBinding (Component component)
void | ThreadSafeRefresh ()
override void | Dispose (bool disposing)
- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
void | RaiseValueChanged ()
void | RaiseLeave ()
void | RaiseActionPerformed ()
Type | GetGenericType (Type type)
string | ValueToString (object value)
bool | IsAssociatedPropertyVisible (object source, BindPropertyInfo associatedPropertyInfo)
Indicates whether the associated property (i.e. the property which is used to display the original property in a textbox) is visible More...
void | EditFileInfo (object source, BindPropertyInfo propertyInfo)
string | EditFileInfo (string value, string format, string label, string description, bool isDirectory)
string | GetDoubleString (string text)
bool | HasValidNumericValue (string text)
double | GetNumericValue (string text)
List< BindPropertyInfo > | GetDictionaryProperties (ICollection domain, BindPropertyInfo dynamicPropertyInfo)
- Protected Attributes inherited from Deltares.Standard.Forms.DExpress.BaseControlBinding
readonly SuperToolTip | superTip
- Protected Attributes inherited from Deltares.Standard.Forms.DExpress.ControlBinding
readonly ToolTip | tooltip
string | Description
The textual description associated with this

See also
Control

. More...

string | Label
The label/title/name associated with this Control. More...
- Protected Attributes inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
BindPropertyInfo | propInfo
- Events inherited from Deltares.Standard.Forms.DExpress.ControlBinding
ToolTipVisibilityEventHandler | ToolTipHidden
ToolTipVisibilityEventHandler | ToolTipShown
- Events inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
EventHandler< EventArgs > | ActionPerformed
EventHandler< EventArgs > | Leave
EventHandler< EventArgs > | ValueChanged
Generated on Tue Dec 15 2015 18:14:47 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • ComboBoxEditBinding
Deltares.Standard.Forms.DExpress.ComboBoxEditBinding Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.ComboBoxEditBinding, including all inherited members.

ActionPerformed (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
BaseControlBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.BaseControlBinding) | Deltares.Standard.Forms.DExpress.BaseControlBinding | protected
BoundControl (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding |
ComboBoxEditBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.ComboBoxEditBinding) | Deltares.Standard.Forms.DExpress.ComboBoxEditBinding |
Component (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ComponentBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ControlBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Description | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Dispose(bool disposing) (defined in Deltares.Standard.Forms.DExpress.BaseControlBinding) | Deltares.Standard.Forms.DExpress.BaseControlBinding | protected
EditFileInfo(object source, BindPropertyInfo propertyInfo) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
EditFileInfo(string value, string format, string label, string description, bool isDirectory) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetDictionaryProperties(ICollection domain, BindPropertyInfo dynamicPropertyInfo) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetDoubleString(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetGenericType(Type type) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetNumericValue(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetPopupMenu() | Deltares.Standard.Forms.DExpress.BaseControlBinding | protected
GetValue() (defined in Deltares.Standard.Forms.DExpress.ComboBoxEditBinding) | Deltares.Standard.Forms.DExpress.ComboBoxEditBinding | virtual
HandleDelayed (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
HasDomain (defined in Deltares.Standard.Forms.DExpress.ComboBoxEditBinding) | Deltares.Standard.Forms.DExpress.ComboBoxEditBinding |
HasValidNumericValue(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Initialize(BindPropertyInfo propertyInfo, params string[] properties) (defined in Deltares.Standard.Forms.DExpress.ComboBoxEditBinding) | Deltares.Standard.Forms.DExpress.ComboBoxEditBinding | virtual
Initialize(BindPropertyInfo propertyInfo, Type rootObjectType, params string[] properties) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
Invalidate() (defined in Deltares.Standard.Forms.DExpress.BaseControlBinding) | Deltares.Standard.Forms.DExpress.BaseControlBinding | virtual
IsAssociatedPropertyVisible(object source, BindPropertyInfo associatedPropertyInfo) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
IsTransparant (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
Label | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Leave (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
OnToolTipClosed() | Deltares.Standard.Forms.DExpress.BaseControlBinding | protectedvirtual
OnToolTipShown(PopupEventArgs e) | Deltares.Standard.Forms.DExpress.BaseControlBinding | protectedvirtual
propInfo (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseActionPerformed() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseLeave() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseValueChanged() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Refresh() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
RegisterSelectionAssignment(Component targetComponent, IConverter converter=null) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetBackgroundColor(Color color) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
SetControlColors(Color fore, Color back) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetDescription(string description) (defined in Deltares.Standard.Forms.DExpress.BaseControlBinding) | Deltares.Standard.Forms.DExpress.BaseControlBinding | virtual
SetDomain(ICollection domain) (defined in Deltares.Standard.Forms.DExpress.ComboBoxEditBinding) | Deltares.Standard.Forms.DExpress.ComboBoxEditBinding | virtual
SetEnabled(bool enabled) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
SetForegroundColor(Color color) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
SetLabel(string text) (defined in Deltares.Standard.Forms.DExpress.BaseControlBinding) | Deltares.Standard.Forms.DExpress.BaseControlBinding | virtual
SetTrueMapping(object trueMapping) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetValue(object value) (defined in Deltares.Standard.Forms.DExpress.ComboBoxEditBinding) | Deltares.Standard.Forms.DExpress.ComboBoxEditBinding | virtual
SetValue(object value, object parent) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetVisible(bool visible) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
superTip (defined in Deltares.Standard.Forms.DExpress.BaseControlBinding) | Deltares.Standard.Forms.DExpress.BaseControlBinding | protected
ThreadSafeRefresh() (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | protected
tooltip (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Tooltip | Deltares.Standard.Forms.DExpress.ControlBinding | protected
ToolTipHidden (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding |
ToolTipShown (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding |
ValueChanged (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ValueToString(object value) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Generated on Tue Dec 15 2015 18:14:47 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.ComponentBinding Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • ComponentBinding
Public Member Functions | Protected Member Functions | Protected Attributes | Properties | Events | List of all members
Deltares.Standard.Forms.DExpress.ComponentBinding Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.ComponentBinding:
Deltares.Standard.Forms.DExpress.BarItemBinding Deltares.Standard.Forms.DExpress.ControlBinding Deltares.Standard.Forms.DExpress.GridColumnBinding Deltares.Standard.Forms.DExpress.NavBarItemBinding Deltares.Standard.Forms.DExpress.ToolStripMenuItemBinding Deltares.Standard.Forms.DExpress.TreeListColumnBinding Deltares.Standard.Forms.DExpress.XRControlBinding Deltares.Standard.Forms.DExpress.BarButtonItemBinding Deltares.Standard.Forms.DExpress.BarEditItemBinding Deltares.Standard.Forms.DExpress.BarStaticItemBinding Deltares.Standard.Forms.DExpress.BarSubItemBinding Deltares.Standard.Forms.DExpress.BaseControlBinding Deltares.Standard.Forms.DExpress.ButtonBinding Deltares.Standard.Forms.DExpress.ChartControlBinding Deltares.Standard.Forms.DExpress.CheckBoxBinding Deltares.Standard.Forms.DExpress.GridControlBinding Deltares.Standard.Forms.DExpress.ImageListBoxBinding Deltares.Standard.Forms.DExpress.LabelBinding Deltares.Standard.Forms.DExpress.ListBoxBinding Deltares.Standard.Forms.DExpress.RadioButtonBinding Deltares.Standard.Forms.DExpress.ScrollableControlBinding Deltares.Standard.Forms.DExpress.TreeListBinding Deltares.Standard.Forms.DExpress.DetailReportBandBinding Deltares.Standard.Forms.DExpress.XRCheckBoxBinding Deltares.Standard.Forms.DExpress.XRLabelBinding Deltares.Standard.Forms.DExpress.XRPictureBoxBinding Deltares.Standard.Forms.DExpress.XRShapeBinding Deltares.Standard.Forms.DExpress.XRSubreportBinding

Public Member Functions

ComponentBinding (Component component)
virtual void | Initialize (BindPropertyInfo propertyInfo, params string[] properties)
virtual void | Initialize (BindPropertyInfo propertyInfo, Type rootObjectType, params string[] properties)
virtual void | SetTrueMapping (object trueMapping)
virtual void | SetValue (object value)
virtual void | SetValue (object value, object parent)
virtual void | SetDomain (ICollection collection)
virtual object | GetValue ()
virtual void | SetVisible (bool visible)
virtual void | SetEnabled (bool enabled)
virtual void | SetLabel (string text)
virtual void | SetDescription (string description)
virtual void | SetForegroundColor (Color color)
virtual void | SetBackgroundColor (Color color)
virtual void | Refresh ()
virtual void | Invalidate ()
virtual void | RegisterSelectionAssignment (Component targetComponent, IConverter converter=null)
Indicates that the selection of the bound control must be assigned to another control. More...
virtual void | SetControlColors (Color fore, Color back)
Sets the controls foreground and background colors. Can be overridden by a specific binding to set other colors if necessary. More...

Protected Member Functions

void | RaiseValueChanged ()
void | RaiseLeave ()
void | RaiseActionPerformed ()
Type | GetGenericType (Type type)
string | ValueToString (object value)
bool | IsAssociatedPropertyVisible (object source, BindPropertyInfo associatedPropertyInfo)
Indicates whether the associated property (i.e. the property which is used to display the original property in a textbox) is visible More...
void | EditFileInfo (object source, BindPropertyInfo propertyInfo)
string | EditFileInfo (string value, string format, string label, string description, bool isDirectory)
string | GetDoubleString (string text)
bool | HasValidNumericValue (string text)
double | GetNumericValue (string text)
List< BindPropertyInfo > | GetDictionaryProperties (ICollection domain, BindPropertyInfo dynamicPropertyInfo)

Protected Attributes

BindPropertyInfo propInfo

Properties

Component | Component [get]
virtual bool | IsTransparant [get]
virtual HandleType | HandleDelayed [get]
virtual bool | HasDomain [get]

Events

EventHandler< EventArgs > | ActionPerformed
EventHandler< EventArgs > | Leave
EventHandler< EventArgs > | ValueChanged

Member Function Documentation

bool Deltares.Standard.Forms.DExpress.ComponentBinding.IsAssociatedPropertyVisible | ( | object | source,
 |  | BindPropertyInfo | associatedPropertyInfo
 | ) |  |
protected

Indicates whether the associated property (i.e. the property which is used to display the original property in a textbox) is visible

Parameters
source | Owner of the property to be displayed
associatedPropertyInfo | Associated property info
Returns
Visibility
virtual void Deltares.Standard.Forms.DExpress.ComponentBinding.RegisterSelectionAssignment | ( | Component | targetComponent,
 |  | IConverter | converter = null
 | ) |  |
virtual

Indicates that the selection of the bound control must be assigned to another control.

Parameters
targetComponent | The control the selection should be assigned to
converter | Optional converter which converts the selected object within the bound control to another object, which will be used for assignment.

In case the bound control support selection of multiple items, the component binding should determine a proper solution in case targetComponent doesn't also support assignment of multiple items.

Reimplemented in Deltares.Standard.Forms.DExpress.GridControlBinding.

virtual void Deltares.Standard.Forms.DExpress.ComponentBinding.SetControlColors | ( | Color | fore,
 |  | Color | back
 | ) |  |
virtual

Sets the controls foreground and background colors. Can be overridden by a specific binding to set other colors if necessary.

Parameters
fore | The foreground color that should be set
back | The background color that should be set
Generated on Tue Dec 15 2015 18:14:47 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • ComponentBinding
Deltares.Standard.Forms.DExpress.ComponentBinding Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.ComponentBinding, including all inherited members.

ActionPerformed (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
Component (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ComponentBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
EditFileInfo(object source, BindPropertyInfo propertyInfo) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
EditFileInfo(string value, string format, string label, string description, bool isDirectory) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetDictionaryProperties(ICollection domain, BindPropertyInfo dynamicPropertyInfo) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetDoubleString(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetGenericType(Type type) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetNumericValue(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetValue() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
HandleDelayed (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
HasDomain (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
HasValidNumericValue(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Initialize(BindPropertyInfo propertyInfo, params string[] properties) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
Initialize(BindPropertyInfo propertyInfo, Type rootObjectType, params string[] properties) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
Invalidate() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
IsAssociatedPropertyVisible(object source, BindPropertyInfo associatedPropertyInfo) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
IsTransparant (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
Leave (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
propInfo (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseActionPerformed() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseLeave() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseValueChanged() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Refresh() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
RegisterSelectionAssignment(Component targetComponent, IConverter converter=null) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetBackgroundColor(Color color) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetControlColors(Color fore, Color back) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetDescription(string description) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetDomain(ICollection collection) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetEnabled(bool enabled) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetForegroundColor(Color color) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetLabel(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetTrueMapping(object trueMapping) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetValue(object value) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetValue(object value, object parent) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetVisible(bool visible) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
ValueChanged (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ValueToString(object value) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Generated on Tue Dec 15 2015 18:14:47 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.ControlBinding Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • ControlBinding
Public Member Functions | Protected Member Functions | Protected Attributes | Properties | Events | List of all members
Deltares.Standard.Forms.DExpress.ControlBinding Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.ControlBinding:
Deltares.Standard.Forms.DExpress.ComponentBinding Deltares.Standard.Forms.DExpress.ComponentWrappers.IGetBoundControl Deltares.Standard.Forms.DExpress.BaseControlBinding Deltares.Standard.Forms.DExpress.ButtonBinding Deltares.Standard.Forms.DExpress.ChartControlBinding Deltares.Standard.Forms.DExpress.CheckBoxBinding Deltares.Standard.Forms.DExpress.GridControlBinding Deltares.Standard.Forms.DExpress.ImageListBoxBinding Deltares.Standard.Forms.DExpress.LabelBinding Deltares.Standard.Forms.DExpress.ListBoxBinding Deltares.Standard.Forms.DExpress.RadioButtonBinding Deltares.Standard.Forms.DExpress.ScrollableControlBinding Deltares.Standard.Forms.DExpress.TreeListBinding

Public Member Functions

override void | SetVisible (bool visible)
override void | SetEnabled (bool enabled)
override void | SetLabel (string text)
Sets the label/title/name associated with this control. More...
override void | SetDescription (string description)
Sets the textual description associated with this control. More...
override void | SetForegroundColor (Color color)
override void | SetBackgroundColor (Color color)
override void | Invalidate ()
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
ComponentBinding (Component component)
virtual void | Initialize (BindPropertyInfo propertyInfo, params string[] properties)
virtual void | Initialize (BindPropertyInfo propertyInfo, Type rootObjectType, params string[] properties)
virtual void | SetTrueMapping (object trueMapping)
virtual void | SetValue (object value)
virtual void | SetValue (object value, object parent)
virtual void | SetDomain (ICollection collection)
virtual object | GetValue ()
virtual void | Refresh ()
virtual void | RegisterSelectionAssignment (Component targetComponent, IConverter converter=null)
Indicates that the selection of the bound control must be assigned to another control. More...
virtual void | SetControlColors (Color fore, Color back)
Sets the controls foreground and background colors. Can be overridden by a specific binding to set other colors if necessary. More...

Protected Member Functions

ControlBinding (Component component)
virtual void | OnToolTipShown (PopupEventArgs e)
Called when Tooltip is shown, and fires ToolTipShown event. More...
virtual void | OnToolTipClosed ()
Called when Tooltip is hidden, and fires ToolTipHidden. More...
void | ThreadSafeRefresh ()
override void | Dispose (bool disposing)
- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
void | RaiseValueChanged ()
void | RaiseLeave ()
void | RaiseActionPerformed ()
Type | GetGenericType (Type type)
string | ValueToString (object value)
bool | IsAssociatedPropertyVisible (object source, BindPropertyInfo associatedPropertyInfo)
Indicates whether the associated property (i.e. the property which is used to display the original property in a textbox) is visible More...
void | EditFileInfo (object source, BindPropertyInfo propertyInfo)
string | EditFileInfo (string value, string format, string label, string description, bool isDirectory)
string | GetDoubleString (string text)
bool | HasValidNumericValue (string text)
double | GetNumericValue (string text)
List< BindPropertyInfo > | GetDictionaryProperties (ICollection domain, BindPropertyInfo dynamicPropertyInfo)

Protected Attributes

readonly ToolTip | tooltip
string | Description
The textual description associated with this

See also
Control

. More...

string | Label
The label/title/name associated with this Control. More...
- Protected Attributes inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
BindPropertyInfo | propInfo

Properties

ToolTip | Tooltip [get]
Gets the tooltip for the bound control. More...
Control | BoundControl [get]
- Properties inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
Component | Component [get]
virtual bool | IsTransparant [get]
virtual HandleType | HandleDelayed [get]
virtual bool | HasDomain [get]
- Properties inherited from Deltares.Standard.Forms.DExpress.ComponentWrappers.IGetBoundControl
Control | BoundControl [get]

Events

ToolTipVisibilityEventHandler | ToolTipHidden
ToolTipVisibilityEventHandler | ToolTipShown
- Events inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
EventHandler< EventArgs > | ActionPerformed
EventHandler< EventArgs > | Leave
EventHandler< EventArgs > | ValueChanged

Member Function Documentation

virtual void Deltares.Standard.Forms.DExpress.ControlBinding.OnToolTipClosed ( )
protectedvirtual

Called when Tooltip is hidden, and fires ToolTipHidden.

Reimplemented in Deltares.Standard.Forms.DExpress.BaseControlBinding.

virtual void Deltares.Standard.Forms.DExpress.ControlBinding.OnToolTipShown ( PopupEventArgs e )
protectedvirtual

Called when Tooltip is shown, and fires ToolTipShown event.

Parameters
e The PopupEventArgs instance containing the event data.

Reimplemented in Deltares.Standard.Forms.DExpress.BaseControlBinding.

override void Deltares.Standard.Forms.DExpress.ControlBinding.SetDescription ( string description )
virtual

Sets the textual description associated with this control.

Parameters
description The description text; Use string.Empty to clear.

Reimplemented from Deltares.Standard.Forms.DExpress.ComponentBinding.

Reimplemented in Deltares.Standard.Forms.DExpress.GridControlBinding.

override void Deltares.Standard.Forms.DExpress.ControlBinding.SetLabel ( string text )
virtual

Sets the label/title/name associated with this control.

Parameters
text The text; Use String.Empty to clear.

Reimplemented from Deltares.Standard.Forms.DExpress.ComponentBinding.

Member Data Documentation

string Deltares.Standard.Forms.DExpress.ControlBinding.Description
protected

The textual description associated with this

See also
Control

.

See also
SetDescription
string Deltares.Standard.Forms.DExpress.ControlBinding.Label
protected

The label/title/name associated with this Control.

See also
SetLabel
readonly ToolTip Deltares.Standard.Forms.DExpress.ControlBinding.tooltip
protected
Initial value:
= new ToolTip
{
AutoPopDelay = ToolTipController.DefaultController.AutoPopDelay
}

Property Documentation

ToolTip Deltares.Standard.Forms.DExpress.ControlBinding.Tooltip
getprotected

Gets the tooltip for the bound control.

Do not rename to ToolTip: http://documentation.devexpress.com/#windowsforms/clsDevExpressUtilsToolTipControllertopic

Generated on Tue Dec 15 2015 18:14:47 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • ControlBinding
Deltares.Standard.Forms.DExpress.ControlBinding Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.ControlBinding, including all inherited members.

ActionPerformed (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
BoundControl (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding |
Component (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ComponentBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ControlBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Description | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Dispose(bool disposing) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | protected
EditFileInfo(object source, BindPropertyInfo propertyInfo) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
EditFileInfo(string value, string format, string label, string description, bool isDirectory) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetDictionaryProperties(ICollection domain, BindPropertyInfo dynamicPropertyInfo) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetDoubleString(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetGenericType(Type type) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetNumericValue(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetValue() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
HandleDelayed (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
HasDomain (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
HasValidNumericValue(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Initialize(BindPropertyInfo propertyInfo, params string[] properties) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
Initialize(BindPropertyInfo propertyInfo, Type rootObjectType, params string[] properties) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
Invalidate() (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
IsAssociatedPropertyVisible(object source, BindPropertyInfo associatedPropertyInfo) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
IsTransparant (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
Label | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Leave (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
OnToolTipClosed() | Deltares.Standard.Forms.DExpress.ControlBinding | protectedvirtual
OnToolTipShown(PopupEventArgs e) | Deltares.Standard.Forms.DExpress.ControlBinding | protectedvirtual
propInfo (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseActionPerformed() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseLeave() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseValueChanged() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Refresh() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
RegisterSelectionAssignment(Component targetComponent, IConverter converter=null) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetBackgroundColor(Color color) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
SetControlColors(Color fore, Color back) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetDescription(string description) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
SetDomain(ICollection collection) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetEnabled(bool enabled) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
SetForegroundColor(Color color) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
SetLabel(string text) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
SetTrueMapping(object trueMapping) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetValue(object value) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetValue(object value, object parent) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetVisible(bool visible) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
ThreadSafeRefresh() (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Tooltip | Deltares.Standard.Forms.DExpress.ControlBinding | protected
tooltip (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | protected
ToolTipHidden (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding |
ToolTipShown (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding |
ValueChanged (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ValueToString(object value) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Generated on Tue Dec 15 2015 18:14:47 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.ControlsRecord Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • ControlsRecord
Public Member Functions | Static Public Member Functions | Properties | List of all members
Deltares.Standard.Forms.DExpress.ControlsRecord Class Reference

Public Member Functions

bool | OverlapsControl (Control control)
void | AddControl (Control control)

Static Public Member Functions

static void Update (List< ControlsRecord > records)

Properties

int | Height [get]
bool | IsVisible [get]
int | Top [get, set]
int | Bottom [get, set]
Generated on Tue Dec 15 2015 18:14:47 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • ControlsRecord
Deltares.Standard.Forms.DExpress.ControlsRecord Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.ControlsRecord, including all inherited members.

AddControl(Control control) (defined in Deltares.Standard.Forms.DExpress.ControlsRecord) | Deltares.Standard.Forms.DExpress.ControlsRecord |
Bottom (defined in Deltares.Standard.Forms.DExpress.ControlsRecord) | Deltares.Standard.Forms.DExpress.ControlsRecord |
ControlsRecord() (defined in Deltares.Standard.Forms.DExpress.ControlsRecord) | Deltares.Standard.Forms.DExpress.ControlsRecord |
Height (defined in Deltares.Standard.Forms.DExpress.ControlsRecord) | Deltares.Standard.Forms.DExpress.ControlsRecord |
IsVisible (defined in Deltares.Standard.Forms.DExpress.ControlsRecord) | Deltares.Standard.Forms.DExpress.ControlsRecord |
OverlapsControl(Control control) (defined in Deltares.Standard.Forms.DExpress.ControlsRecord) | Deltares.Standard.Forms.DExpress.ControlsRecord |
Top (defined in Deltares.Standard.Forms.DExpress.ControlsRecord) | Deltares.Standard.Forms.DExpress.ControlsRecord |
Update(List< ControlsRecord > records) (defined in Deltares.Standard.Forms.DExpress.ControlsRecord) | Deltares.Standard.Forms.DExpress.ControlsRecord | static
Generated on Tue Dec 15 2015 18:14:48 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.CustomDockManagerResXLocalizer Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • CustomDockManagerResXLocalizer
Public Member Functions | List of all members
Deltares.Standard.Forms.DExpress.CustomDockManagerResXLocalizer Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.CustomDockManagerResXLocalizer:

Public Member Functions

override string GetLocalizedString (DockManagerStringId id)
Generated on Tue Dec 15 2015 18:14:48 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • CustomDockManagerResXLocalizer
Deltares.Standard.Forms.DExpress.CustomDockManagerResXLocalizer Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.CustomDockManagerResXLocalizer, including all inherited members.

GetLocalizedString(DockManagerStringId id) (defined in Deltares.Standard.Forms.DExpress.CustomDockManagerResXLocalizer) Deltares.Standard.Forms.DExpress.CustomDockManagerResXLocalizer
Generated on Tue Dec 15 2015 18:14:48 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.CustomLocalizer Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • CustomLocalizer
Public Member Functions | List of all members
Deltares.Standard.Forms.DExpress.CustomLocalizer Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.CustomLocalizer:

Public Member Functions

override string GetLocalizedString (StringId id)
Generated on Tue Dec 15 2015 18:14:48 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • CustomLocalizer
Deltares.Standard.Forms.DExpress.CustomLocalizer Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.CustomLocalizer, including all inherited members.

GetLocalizedString(StringId id) (defined in Deltares.Standard.Forms.DExpress.CustomLocalizer) Deltares.Standard.Forms.DExpress.CustomLocalizer
Generated on Tue Dec 15 2015 18:14:48 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.DateEditBinding Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • DateEditBinding
Public Member Functions | List of all members
Deltares.Standard.Forms.DExpress.DateEditBinding Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.DateEditBinding:
Deltares.Standard.Forms.DExpress.BaseControlBinding Deltares.Standard.Forms.DExpress.ControlBinding Deltares.Standard.Forms.DExpress.ComponentBinding Deltares.Standard.Forms.DExpress.ComponentWrappers.IGetBoundControl

Public Member Functions

DateEditBinding (Component component)
override void | Initialize (BindPropertyInfo propertyInfo, params string[] properties)
override void | SetValue (object value)
override object | GetValue ()
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.BaseControlBinding
override void | SetLabel (string text)
override void | SetDescription (string description)
override void | Invalidate ()
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.ControlBinding
override void | SetVisible (bool visible)
override void | SetEnabled (bool enabled)
override void | SetLabel (string text)
Sets the label/title/name associated with this control. More...
override void | SetDescription (string description)
Sets the textual description associated with this control. More...
override void | SetForegroundColor (Color color)
override void | SetBackgroundColor (Color color)
override void | Invalidate ()
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
ComponentBinding (Component component)
virtual void | Initialize (BindPropertyInfo propertyInfo, Type rootObjectType, params string[] properties)
virtual void | SetTrueMapping (object trueMapping)
virtual void | SetValue (object value, object parent)
virtual void | SetDomain (ICollection collection)
virtual void | Refresh ()
virtual void | RegisterSelectionAssignment (Component targetComponent, IConverter converter=null)
Indicates that the selection of the bound control must be assigned to another control. More...
virtual void | SetControlColors (Color fore, Color back)
Sets the controls foreground and background colors. Can be overridden by a specific binding to set other colors if necessary. More...

Additional Inherited Members

- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.BaseControlBinding
BaseControlBinding (Component component)
DXPopupMenu | GetPopupMenu ()
This method uses reflection to make the context menu accessible, which otherwise is protected. The Menu property is implemented for TextEdit, so we first make sure the control is actually of this type. More...
override void | OnToolTipShown (PopupEventArgs e)
Called when Tooltip is shown, and fires ToolTipShown event. More...
override void | OnToolTipClosed ()
Called when Tooltip is hidden, and fires ToolTipHidden. More...
override void | Dispose (bool disposing)
- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.ControlBinding
ControlBinding (Component component)
void | ThreadSafeRefresh ()
override void | Dispose (bool disposing)
- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
void | RaiseValueChanged ()
void | RaiseLeave ()
void | RaiseActionPerformed ()
Type | GetGenericType (Type type)
string | ValueToString (object value)
bool | IsAssociatedPropertyVisible (object source, BindPropertyInfo associatedPropertyInfo)
Indicates whether the associated property (i.e. the property which is used to display the original property in a textbox) is visible More...
void | EditFileInfo (object source, BindPropertyInfo propertyInfo)
string | EditFileInfo (string value, string format, string label, string description, bool isDirectory)
string | GetDoubleString (string text)
bool | HasValidNumericValue (string text)
double | GetNumericValue (string text)
List< BindPropertyInfo > | GetDictionaryProperties (ICollection domain, BindPropertyInfo dynamicPropertyInfo)
- Protected Attributes inherited from Deltares.Standard.Forms.DExpress.BaseControlBinding
readonly SuperToolTip | superTip
- Protected Attributes inherited from Deltares.Standard.Forms.DExpress.ControlBinding
readonly ToolTip | tooltip
string | Description
The textual description associated with this

See also
Control

. More...

string | Label
The label/title/name associated with this Control. More...
- Protected Attributes inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
BindPropertyInfo | propInfo
- Properties inherited from Deltares.Standard.Forms.DExpress.ControlBinding
ToolTip | Tooltip [get]
Gets the tooltip for the bound control. More...
Control | BoundControl [get]
- Properties inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
Component | Component [get]
virtual bool | IsTransparant [get]
virtual HandleType | HandleDelayed [get]
virtual bool | HasDomain [get]
- Properties inherited from Deltares.Standard.Forms.DExpress.ComponentWrappers.IGetBoundControl
Control | BoundControl [get]
- Events inherited from Deltares.Standard.Forms.DExpress.ControlBinding
ToolTipVisibilityEventHandler | ToolTipHidden
ToolTipVisibilityEventHandler | ToolTipShown
- Events inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
EventHandler< EventArgs > | ActionPerformed
EventHandler< EventArgs > | Leave
EventHandler< EventArgs > | ValueChanged
Generated on Tue Dec 15 2015 18:14:48 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • DateEditBinding
Deltares.Standard.Forms.DExpress.DateEditBinding Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.DateEditBinding, including all inherited members.

ActionPerformed (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
BaseControlBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.BaseControlBinding) | Deltares.Standard.Forms.DExpress.BaseControlBinding | protected
BoundControl (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding |
Component (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ComponentBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ControlBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | protected
DateEditBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.DateEditBinding) | Deltares.Standard.Forms.DExpress.DateEditBinding |
Description | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Dispose(bool disposing) (defined in Deltares.Standard.Forms.DExpress.BaseControlBinding) | Deltares.Standard.Forms.DExpress.BaseControlBinding | protected
EditFileInfo(object source, BindPropertyInfo propertyInfo) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
EditFileInfo(string value, string format, string label, string description, bool isDirectory) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetDictionaryProperties(ICollection domain, BindPropertyInfo dynamicPropertyInfo) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetDoubleString(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetGenericType(Type type) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetNumericValue(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetPopupMenu() | Deltares.Standard.Forms.DExpress.BaseControlBinding | protected
GetValue() (defined in Deltares.Standard.Forms.DExpress.DateEditBinding) | Deltares.Standard.Forms.DExpress.DateEditBinding | virtual
HandleDelayed (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
HasDomain (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
HasValidNumericValue(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Initialize(BindPropertyInfo propertyInfo, params string[] properties) (defined in Deltares.Standard.Forms.DExpress.DateEditBinding) | Deltares.Standard.Forms.DExpress.DateEditBinding | virtual
Initialize(BindPropertyInfo propertyInfo, Type rootObjectType, params string[] properties) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
Invalidate() (defined in Deltares.Standard.Forms.DExpress.BaseControlBinding) | Deltares.Standard.Forms.DExpress.BaseControlBinding | virtual
IsAssociatedPropertyVisible(object source, BindPropertyInfo associatedPropertyInfo) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
IsTransparant (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
Label | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Leave (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
OnToolTipClosed() | Deltares.Standard.Forms.DExpress.BaseControlBinding | protectedvirtual
OnToolTipShown(PopupEventArgs e) | Deltares.Standard.Forms.DExpress.BaseControlBinding | protectedvirtual
propInfo (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseActionPerformed() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseLeave() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseValueChanged() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Refresh() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
RegisterSelectionAssignment(Component targetComponent, IConverter converter=null) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetBackgroundColor(Color color) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
SetControlColors(Color fore, Color back) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetDescription(string description) (defined in Deltares.Standard.Forms.DExpress.BaseControlBinding) | Deltares.Standard.Forms.DExpress.BaseControlBinding | virtual
SetDomain(ICollection collection) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetEnabled(bool enabled) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
SetForegroundColor(Color color) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
SetLabel(string text) (defined in Deltares.Standard.Forms.DExpress.BaseControlBinding) | Deltares.Standard.Forms.DExpress.BaseControlBinding | virtual
SetTrueMapping(object trueMapping) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetValue(object value) (defined in Deltares.Standard.Forms.DExpress.DateEditBinding) | Deltares.Standard.Forms.DExpress.DateEditBinding | virtual
SetValue(object value, object parent) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetVisible(bool visible) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
superTip (defined in Deltares.Standard.Forms.DExpress.BaseControlBinding) | Deltares.Standard.Forms.DExpress.BaseControlBinding | protected
ThreadSafeRefresh() (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | protected
tooltip (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Tooltip | Deltares.Standard.Forms.DExpress.ControlBinding | protected
ToolTipHidden (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding |
ToolTipShown (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding |
ValueChanged (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ValueToString(object value) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Generated on Tue Dec 15 2015 18:14:48 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.DetailReportBandBinding Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • DetailReportBandBinding
Public Member Functions | List of all members
Deltares.Standard.Forms.DExpress.DetailReportBandBinding Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.DetailReportBandBinding:
Deltares.Standard.Forms.DExpress.XRControlBinding Deltares.Standard.Forms.DExpress.ComponentBinding

Public Member Functions

DetailReportBandBinding (Component component)
override void | SetValue (object value)
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.XRControlBinding
XRControlBinding (Component component)
override void | Initialize (BindPropertyInfo propertyInfo, params string[] properties)
override void | SetLabel (string text)
override void | SetVisible (bool visible)
override void | SetForegroundColor (Color color)
override void | SetBackgroundColor (Color color)
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
ComponentBinding (Component component)
virtual void | Initialize (BindPropertyInfo propertyInfo, Type rootObjectType, params string[] properties)
virtual void | SetTrueMapping (object trueMapping)
virtual void | SetValue (object value, object parent)
virtual void | SetDomain (ICollection collection)
virtual object | GetValue ()
virtual void | SetEnabled (bool enabled)
virtual void | SetDescription (string description)
virtual void | Refresh ()
virtual void | Invalidate ()
virtual void | RegisterSelectionAssignment (Component targetComponent, IConverter converter=null)
Indicates that the selection of the bound control must be assigned to another control. More...
virtual void | SetControlColors (Color fore, Color back)
Sets the controls foreground and background colors. Can be overridden by a specific binding to set other colors if necessary. More...

Additional Inherited Members

- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.XRControlBinding
virtual void | BindSupport_BeforePrint (object sender, PrintEventArgs e)
- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
void | RaiseValueChanged ()
void | RaiseLeave ()
void | RaiseActionPerformed ()
Type | GetGenericType (Type type)
string | ValueToString (object value)
bool | IsAssociatedPropertyVisible (object source, BindPropertyInfo associatedPropertyInfo)
Indicates whether the associated property (i.e. the property which is used to display the original property in a textbox) is visible More...
void | EditFileInfo (object source, BindPropertyInfo propertyInfo)
string | EditFileInfo (string value, string format, string label, string description, bool isDirectory)
string | GetDoubleString (string text)
bool | HasValidNumericValue (string text)
double | GetNumericValue (string text)
List< BindPropertyInfo > | GetDictionaryProperties (ICollection domain, BindPropertyInfo dynamicPropertyInfo)
- Protected Attributes inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
BindPropertyInfo | propInfo
- Properties inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
Component | Component [get]
virtual bool | IsTransparant [get]
virtual HandleType | HandleDelayed [get]
virtual bool | HasDomain [get]
- Events inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
EventHandler< EventArgs > | ActionPerformed
EventHandler< EventArgs > | Leave
EventHandler< EventArgs > | ValueChanged
Generated on Tue Dec 15 2015 18:14:49 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • DetailReportBandBinding
Deltares.Standard.Forms.DExpress.DetailReportBandBinding Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.DetailReportBandBinding, including all inherited members.

ActionPerformed (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
BindSupport_BeforePrint(object sender, PrintEventArgs e) (defined in Deltares.Standard.Forms.DExpress.XRControlBinding) | Deltares.Standard.Forms.DExpress.XRControlBinding | protectedvirtual
Component (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ComponentBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
DetailReportBandBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.DetailReportBandBinding) | Deltares.Standard.Forms.DExpress.DetailReportBandBinding |
EditFileInfo(object source, BindPropertyInfo propertyInfo) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
EditFileInfo(string value, string format, string label, string description, bool isDirectory) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetDictionaryProperties(ICollection domain, BindPropertyInfo dynamicPropertyInfo) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetDoubleString(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetGenericType(Type type) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetNumericValue(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetValue() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
HandleDelayed (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
HasDomain (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
HasValidNumericValue(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Initialize(BindPropertyInfo propertyInfo, params string[] properties) (defined in Deltares.Standard.Forms.DExpress.XRControlBinding) | Deltares.Standard.Forms.DExpress.XRControlBinding | virtual
Initialize(BindPropertyInfo propertyInfo, Type rootObjectType, params string[] properties) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
Invalidate() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
IsAssociatedPropertyVisible(object source, BindPropertyInfo associatedPropertyInfo) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
IsTransparant (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
Leave (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
propInfo (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseActionPerformed() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseLeave() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseValueChanged() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Refresh() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
RegisterSelectionAssignment(Component targetComponent, IConverter converter=null) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetBackgroundColor(Color color) (defined in Deltares.Standard.Forms.DExpress.XRControlBinding) | Deltares.Standard.Forms.DExpress.XRControlBinding | virtual
SetControlColors(Color fore, Color back) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetDescription(string description) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetDomain(ICollection collection) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetEnabled(bool enabled) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetForegroundColor(Color color) (defined in Deltares.Standard.Forms.DExpress.XRControlBinding) | Deltares.Standard.Forms.DExpress.XRControlBinding | virtual
SetLabel(string text) (defined in Deltares.Standard.Forms.DExpress.XRControlBinding) | Deltares.Standard.Forms.DExpress.XRControlBinding | virtual
SetTrueMapping(object trueMapping) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetValue(object value) (defined in Deltares.Standard.Forms.DExpress.DetailReportBandBinding) | Deltares.Standard.Forms.DExpress.DetailReportBandBinding | virtual
SetValue(object value, object parent) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetVisible(bool visible) (defined in Deltares.Standard.Forms.DExpress.XRControlBinding) | Deltares.Standard.Forms.DExpress.XRControlBinding | virtual
ValueChanged (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ValueToString(object value) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
XRControlBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.XRControlBinding) | Deltares.Standard.Forms.DExpress.XRControlBinding |
Generated on Tue Dec 15 2015 18:14:49 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.DialogTemplate Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • DialogTemplate
Public Member Functions | Protected Member Functions | Properties | List of all members
Deltares.Standard.Forms.DExpress.DialogTemplate Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.DialogTemplate:

Public Member Functions

DialogTemplate (string headerText)
Control | AddTabPage (string headerText, UserControl dialogTemplate, Object settingsTemplate)
Adds a new tab page with a control in it. More...
void | SelectTabPage (Control tabPage)
void | Confirm ()
void | Cancel ()
void | RestoreValuesFromDataSource ()

Protected Member Functions

override void Dispose (bool disposing)
Clean up any resources being used. More...

Properties

bool | ShowOkButton [set]
bool | EnableCancelButton [get, set]
bool | ResizeDialog [get, set]

Member Function Documentation

Control Deltares.Standard.Forms.DExpress.DialogTemplate.AddTabPage | ( | string | headerText,
 |  | UserControl | dialogTemplate,
 |  | Object | settingsTemplate
 | ) |  |

Adds a new tab page with a control in it.

Parameters
headerText | The tab header text.
dialogTemplate | The control that implements IPropertyControl.
settingsTemplate | The data to be used to set as IPropertyControl.SelectedObject of dialogTemplate .
Returns
The newly created tab-control.

References Deltares.Standard.Forms.DExpress.BindSupportLateBinding.SetLateBinding().

override void Deltares.Standard.Forms.DExpress.DialogTemplate.Dispose ( bool disposing )
protected

Clean up any resources being used.

Parameters
disposing true if managed resources should be disposed; otherwise, false.
Generated on Tue Dec 15 2015 18:14:49 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • DialogTemplate
Deltares.Standard.Forms.DExpress.DialogTemplate Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.DialogTemplate, including all inherited members.

AddTabPage(string headerText, UserControl dialogTemplate, Object settingsTemplate) | Deltares.Standard.Forms.DExpress.DialogTemplate |
Cancel() (defined in Deltares.Standard.Forms.DExpress.DialogTemplate) | Deltares.Standard.Forms.DExpress.DialogTemplate |
Confirm() (defined in Deltares.Standard.Forms.DExpress.DialogTemplate) | Deltares.Standard.Forms.DExpress.DialogTemplate |
DialogTemplate(string headerText) (defined in Deltares.Standard.Forms.DExpress.DialogTemplate) | Deltares.Standard.Forms.DExpress.DialogTemplate |
Dispose(bool disposing) | Deltares.Standard.Forms.DExpress.DialogTemplate | protected
EnableCancelButton (defined in Deltares.Standard.Forms.DExpress.DialogTemplate) | Deltares.Standard.Forms.DExpress.DialogTemplate |
ResizeDialog (defined in Deltares.Standard.Forms.DExpress.DialogTemplate) | Deltares.Standard.Forms.DExpress.DialogTemplate |
RestoreValuesFromDataSource() (defined in Deltares.Standard.Forms.DExpress.DialogTemplate) | Deltares.Standard.Forms.DExpress.DialogTemplate |
SelectTabPage(Control tabPage) (defined in Deltares.Standard.Forms.DExpress.DialogTemplate) | Deltares.Standard.Forms.DExpress.DialogTemplate |
ShowOkButton (defined in Deltares.Standard.Forms.DExpress.DialogTemplate) | Deltares.Standard.Forms.DExpress.DialogTemplate |
Generated on Tue Dec 15 2015 18:14:49 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.DisclaimerDialog Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • DisclaimerDialog
Public Member Functions | Protected Member Functions | List of all members
Deltares.Standard.Forms.DExpress.DisclaimerDialog Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.DisclaimerDialog:

Public Member Functions

DisclaimerDialog (string text)

Protected Member Functions

override void Dispose (bool disposing)
Clean up any resources being used. More...

Member Function Documentation

override void Deltares.Standard.Forms.DExpress.DisclaimerDialog.Dispose ( bool disposing )
protected

Clean up any resources being used.

Parameters
disposing true if managed resources should be disposed; otherwise, false.
Generated on Tue Dec 15 2015 18:14:49 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • DisclaimerDialog
Deltares.Standard.Forms.DExpress.DisclaimerDialog Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.DisclaimerDialog, including all inherited members.

DisclaimerDialog(string text) (defined in Deltares.Standard.Forms.DExpress.DisclaimerDialog) | Deltares.Standard.Forms.DExpress.DisclaimerDialog |
Dispose(bool disposing) | Deltares.Standard.Forms.DExpress.DisclaimerDialog | protected
Generated on Tue Dec 15 2015 18:14:49 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.DisplayItem Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • DisplayItem
Public Member Functions | Properties | List of all members
Deltares.Standard.Forms.DExpress.DisplayItem Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.DisplayItem:

Public Member Functions

DisplayItem (Enum value)
override bool | Equals (object obj)
override int | GetHashCode ()
override string | ToString ()
int | CompareTo (object obj)

Properties

object Value [get]
Generated on Tue Dec 15 2015 18:14:50 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • DisplayItem
Deltares.Standard.Forms.DExpress.DisplayItem Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.DisplayItem, including all inherited members.

CompareTo(object obj) (defined in Deltares.Standard.Forms.DExpress.DisplayItem) | Deltares.Standard.Forms.DExpress.DisplayItem
DisplayItem(Enum value) (defined in Deltares.Standard.Forms.DExpress.DisplayItem) | Deltares.Standard.Forms.DExpress.DisplayItem
Equals(object obj) (defined in Deltares.Standard.Forms.DExpress.DisplayItem) | Deltares.Standard.Forms.DExpress.DisplayItem
GetHashCode() (defined in Deltares.Standard.Forms.DExpress.DisplayItem) | Deltares.Standard.Forms.DExpress.DisplayItem
ToString() (defined in Deltares.Standard.Forms.DExpress.DisplayItem) | Deltares.Standard.Forms.DExpress.DisplayItem
Value (defined in Deltares.Standard.Forms.DExpress.DisplayItem) | Deltares.Standard.Forms.DExpress.DisplayItem
Generated on Tue Dec 15 2015 18:14:50 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.DivideStrategy Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • DivideStrategy
Public Member Functions | Protected Member Functions | List of all members
Deltares.Standard.Forms.DExpress.DivideStrategy Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.DivideStrategy:
Deltares.Standard.Forms.DExpress.GridEditValueStrategy

Public Member Functions

override double | DefaultForSelected (GridView view)
Determines the default value based on the selected values. Not all implementations will use the selected values, but by passing the view, we can generalize the method call. More...
override string | ToString ()
This method has to be overridden so it has a proper representation in the UI. More...
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.GridEditValueStrategy
void | EvaluateForSelected (GridView view, double modificationValue)
Sets new cell values by evaluating the modification value and using the current strategy. More...

Protected Member Functions

override double Evaluate (double value, double modificationValue)
The implementation of this method is used in the EvaluateForSelected method. More...

Additional Inherited Members

- Static Public Attributes inherited from Deltares.Standard.Forms.DExpress.GridEditValueStrategy
static readonly GridEditValueStrategy[] Strategies
Collection of all the strategies which are defined in this file. This is a static list so the strategies will only be instantiated once. Using instantiations make polymorphism possible. More...

Member Function Documentation

override double Deltares.Standard.Forms.DExpress.DivideStrategy.DefaultForSelected ( GridView view )
virtual

Determines the default value based on the selected values. Not all implementations will use the selected values, but by passing the view, we can generalize the method call.

Parameters
view The view (which may not be used at all) containing selected values (or not).
Returns
A sensible default for the strategy, or null if no sensible default can be given.

Implements Deltares.Standard.Forms.DExpress.GridEditValueStrategy.

override double Deltares.Standard.Forms.DExpress.DivideStrategy.Evaluate | ( | double | value,
 |  | double | modificationValue
 | ) |  |
protectedvirtual

The implementation of this method is used in the EvaluateForSelected method.

Parameters
value | The current value.
modificationValue | The value used in evaluating a new value.
Returns
The new value.

Implements Deltares.Standard.Forms.DExpress.GridEditValueStrategy.

override string Deltares.Standard.Forms.DExpress.DivideStrategy.ToString ( )
virtual

This method has to be overridden so it has a proper representation in the UI.

Returns

Implements Deltares.Standard.Forms.DExpress.GridEditValueStrategy.

Generated on Tue Dec 15 2015 18:14:50 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • DivideStrategy
Deltares.Standard.Forms.DExpress.DivideStrategy Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.DivideStrategy, including all inherited members.

DefaultForSelected(GridView view) | Deltares.Standard.Forms.DExpress.DivideStrategy | virtual
Evaluate(double value, double modificationValue) | Deltares.Standard.Forms.DExpress.DivideStrategy | protectedvirtual
EvaluateForSelected(GridView view, double modificationValue) | Deltares.Standard.Forms.DExpress.GridEditValueStrategy |
Strategies | Deltares.Standard.Forms.DExpress.GridEditValueStrategy | static
ToString() | Deltares.Standard.Forms.DExpress.DivideStrategy | virtual
Generated on Tue Dec 15 2015 18:14:50 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.DockPanelBinding Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • DockPanelBinding
Public Member Functions | List of all members
Deltares.Standard.Forms.DExpress.DockPanelBinding Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.DockPanelBinding:
Deltares.Standard.Forms.DExpress.ScrollableControlBinding Deltares.Standard.Forms.DExpress.ControlBinding Deltares.Standard.Forms.DExpress.ComponentBinding Deltares.Standard.Forms.DExpress.ComponentWrappers.IGetBoundControl

Public Member Functions

DockPanelBinding (Component component)
override void | SetVisible (bool visible)
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.ScrollableControlBinding
ScrollableControlBinding (Component component)
override void | SetEnabled (bool enabled)
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.ControlBinding
override void | SetLabel (string text)
Sets the label/title/name associated with this control. More...
override void | SetDescription (string description)
Sets the textual description associated with this control. More...
override void | SetForegroundColor (Color color)
override void | SetBackgroundColor (Color color)
override void | Invalidate ()
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
ComponentBinding (Component component)
virtual void | Initialize (BindPropertyInfo propertyInfo, params string[] properties)
virtual void | Initialize (BindPropertyInfo propertyInfo, Type rootObjectType, params string[] properties)
virtual void | SetTrueMapping (object trueMapping)
virtual void | SetValue (object value)
virtual void | SetValue (object value, object parent)
virtual void | SetDomain (ICollection collection)
virtual object | GetValue ()
virtual void | Refresh ()
virtual void | RegisterSelectionAssignment (Component targetComponent, IConverter converter=null)
Indicates that the selection of the bound control must be assigned to another control. More...
virtual void | SetControlColors (Color fore, Color back)
Sets the controls foreground and background colors. Can be overridden by a specific binding to set other colors if necessary. More...

Additional Inherited Members

- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.ControlBinding
ControlBinding (Component component)
virtual void | OnToolTipShown (PopupEventArgs e)
Called when Tooltip is shown, and fires ToolTipShown event. More...
virtual void | OnToolTipClosed ()
Called when Tooltip is hidden, and fires ToolTipHidden. More...
void | ThreadSafeRefresh ()
override void | Dispose (bool disposing)
- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
void | RaiseValueChanged ()
void | RaiseLeave ()
void | RaiseActionPerformed ()
Type | GetGenericType (Type type)
string | ValueToString (object value)
bool | IsAssociatedPropertyVisible (object source, BindPropertyInfo associatedPropertyInfo)
Indicates whether the associated property (i.e. the property which is used to display the original property in a textbox) is visible More...
void | EditFileInfo (object source, BindPropertyInfo propertyInfo)
string | EditFileInfo (string value, string format, string label, string description, bool isDirectory)
string | GetDoubleString (string text)
bool | HasValidNumericValue (string text)
double | GetNumericValue (string text)
List< BindPropertyInfo > | GetDictionaryProperties (ICollection domain, BindPropertyInfo dynamicPropertyInfo)
- Protected Attributes inherited from Deltares.Standard.Forms.DExpress.ControlBinding
readonly ToolTip | tooltip
string | Description
The textual description associated with this

See also
Control

. More...

string | Label
The label/title/name associated with this Control. More...
- Protected Attributes inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
BindPropertyInfo | propInfo
- Properties inherited from Deltares.Standard.Forms.DExpress.ControlBinding
ToolTip | Tooltip [get]
Gets the tooltip for the bound control. More...
Control | BoundControl [get]
- Properties inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
Component | Component [get]
virtual bool | IsTransparant [get]
virtual HandleType | HandleDelayed [get]
virtual bool | HasDomain [get]
- Properties inherited from Deltares.Standard.Forms.DExpress.ComponentWrappers.IGetBoundControl
Control | BoundControl [get]
- Events inherited from Deltares.Standard.Forms.DExpress.ControlBinding
ToolTipVisibilityEventHandler | ToolTipHidden
ToolTipVisibilityEventHandler | ToolTipShown
- Events inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
EventHandler< EventArgs > | ActionPerformed
EventHandler< EventArgs > | Leave
EventHandler< EventArgs > | ValueChanged
Generated on Tue Dec 15 2015 18:14:50 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • DockPanelBinding
Deltares.Standard.Forms.DExpress.DockPanelBinding Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.DockPanelBinding, including all inherited members.

ActionPerformed (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
BoundControl (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding |
Component (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ComponentBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ControlBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Description | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Dispose(bool disposing) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | protected
DockPanelBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.DockPanelBinding) | Deltares.Standard.Forms.DExpress.DockPanelBinding |
EditFileInfo(object source, BindPropertyInfo propertyInfo) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
EditFileInfo(string value, string format, string label, string description, bool isDirectory) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetDictionaryProperties(ICollection domain, BindPropertyInfo dynamicPropertyInfo) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetDoubleString(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetGenericType(Type type) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetNumericValue(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetValue() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
HandleDelayed (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
HasDomain (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
HasValidNumericValue(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Initialize(BindPropertyInfo propertyInfo, params string[] properties) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
Initialize(BindPropertyInfo propertyInfo, Type rootObjectType, params string[] properties) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
Invalidate() (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
IsAssociatedPropertyVisible(object source, BindPropertyInfo associatedPropertyInfo) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
IsTransparant (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
Label | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Leave (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
OnToolTipClosed() | Deltares.Standard.Forms.DExpress.ControlBinding | protectedvirtual
OnToolTipShown(PopupEventArgs e) | Deltares.Standard.Forms.DExpress.ControlBinding | protectedvirtual
propInfo (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseActionPerformed() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseLeave() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseValueChanged() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Refresh() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
RegisterSelectionAssignment(Component targetComponent, IConverter converter=null) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
ScrollableControlBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.ScrollableControlBinding) | Deltares.Standard.Forms.DExpress.ScrollableControlBinding |
SetBackgroundColor(Color color) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
SetControlColors(Color fore, Color back) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetDescription(string description) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
SetDomain(ICollection collection) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetEnabled(bool enabled) (defined in Deltares.Standard.Forms.DExpress.ScrollableControlBinding) | Deltares.Standard.Forms.DExpress.ScrollableControlBinding | virtual
SetForegroundColor(Color color) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
SetLabel(string text) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
SetTrueMapping(object trueMapping) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetValue(object value) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetValue(object value, object parent) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetVisible(bool visible) (defined in Deltares.Standard.Forms.DExpress.DockPanelBinding) | Deltares.Standard.Forms.DExpress.DockPanelBinding | virtual
ThreadSafeRefresh() (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | protected
tooltip (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Tooltip | Deltares.Standard.Forms.DExpress.ControlBinding | protected
ToolTipHidden (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding |
ToolTipShown (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding |
ValueChanged (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ValueToString(object value) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Generated on Tue Dec 15 2015 18:14:50 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.DynamicChartControl Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • DynamicChartControl
Public Member Functions | Public Attributes | Protected Member Functions | List of all members
Deltares.Standard.Forms.DExpress.DynamicChartControl Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.DynamicChartControl:

Public Member Functions

void | RegisterChart (Type type, Control table, string caption)
Control | GetChart (Type type)
Type | GetType (Control control)

Public Attributes

DevExpress.XtraTab.XtraTabControl TabControl

Protected Member Functions

override void Dispose (bool disposing)
Clean up any resources being used. More...

Member Function Documentation

override void Deltares.Standard.Forms.DExpress.DynamicChartControl.Dispose ( bool disposing )
protected

Clean up any resources being used.

Parameters
disposing true if managed resources should be disposed; otherwise, false.
Generated on Tue Dec 15 2015 18:14:50 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • DynamicChartControl
Deltares.Standard.Forms.DExpress.DynamicChartControl Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.DynamicChartControl, including all inherited members.

Dispose(bool disposing) | Deltares.Standard.Forms.DExpress.DynamicChartControl | protected
DynamicChartControl() (defined in Deltares.Standard.Forms.DExpress.DynamicChartControl) | Deltares.Standard.Forms.DExpress.DynamicChartControl |
GetChart(Type type) (defined in Deltares.Standard.Forms.DExpress.DynamicChartControl) | Deltares.Standard.Forms.DExpress.DynamicChartControl |
GetType(Control control) (defined in Deltares.Standard.Forms.DExpress.DynamicChartControl) | Deltares.Standard.Forms.DExpress.DynamicChartControl |
RegisterChart(Type type, Control table, string caption) (defined in Deltares.Standard.Forms.DExpress.DynamicChartControl) | Deltares.Standard.Forms.DExpress.DynamicChartControl |
TabControl (defined in Deltares.Standard.Forms.DExpress.DynamicChartControl) | Deltares.Standard.Forms.DExpress.DynamicChartControl |
Generated on Tue Dec 15 2015 18:14:50 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.DynamicImageControl Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • DynamicImageControl
Public Attributes | Protected Member Functions | List of all members
Deltares.Standard.Forms.DExpress.DynamicImageControl Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.DynamicImageControl:

Public Attributes

ZoomablePictureBox ZoomablePictureBox

Protected Member Functions

override void Dispose (bool disposing)
Clean up any resources being used. More...

Member Function Documentation

override void Deltares.Standard.Forms.DExpress.DynamicImageControl.Dispose ( bool disposing )
protected

Clean up any resources being used.

Parameters
disposing true if managed resources should be disposed; otherwise, false.
Generated on Tue Dec 15 2015 18:14:51 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • DynamicImageControl
Deltares.Standard.Forms.DExpress.DynamicImageControl Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.DynamicImageControl, including all inherited members.

Dispose(bool disposing) | Deltares.Standard.Forms.DExpress.DynamicImageControl | protected
DynamicImageControl() (defined in Deltares.Standard.Forms.DExpress.DynamicImageControl) | Deltares.Standard.Forms.DExpress.DynamicImageControl |
ZoomablePictureBox (defined in Deltares.Standard.Forms.DExpress.DynamicImageControl) | Deltares.Standard.Forms.DExpress.DynamicImageControl |
Generated on Tue Dec 15 2015 18:14:51 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.DynamicMessagesControl Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • DynamicMessagesControl
Public Attributes | Protected Member Functions | List of all members
Deltares.Standard.Forms.DExpress.DynamicMessagesControl Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.DynamicMessagesControl:

Public Attributes

GridViewControl UserMessagesGridViewControl

Protected Member Functions

override void Dispose (bool disposing)
Clean up any resources being used. More...

Member Function Documentation

override void Deltares.Standard.Forms.DExpress.DynamicMessagesControl.Dispose ( bool disposing )
protected

Clean up any resources being used.

Parameters
disposing true if managed resources should be disposed; otherwise, false.
Generated on Tue Dec 15 2015 18:14:51 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • DynamicMessagesControl
Deltares.Standard.Forms.DExpress.DynamicMessagesControl Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.DynamicMessagesControl, including all inherited members.

Dispose(bool disposing) | Deltares.Standard.Forms.DExpress.DynamicMessagesControl | protected
DynamicMessagesControl() (defined in Deltares.Standard.Forms.DExpress.DynamicMessagesControl) | Deltares.Standard.Forms.DExpress.DynamicMessagesControl |
UserMessagesGridViewControl (defined in Deltares.Standard.Forms.DExpress.DynamicMessagesControl) | Deltares.Standard.Forms.DExpress.DynamicMessagesControl |
Generated on Tue Dec 15 2015 18:14:51 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.DynamicNavigatorControl Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • DynamicNavigatorControl
Public Member Functions | Protected Member Functions | Properties | List of all members
Deltares.Standard.Forms.DExpress.DynamicNavigatorControl Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.DynamicNavigatorControl:

Public Member Functions

void | RegisterResource (Type type, Control resource, string caption)
Control | GetResource (Type type)

Protected Member Functions

override void Dispose (bool disposing)
Clean up any resources being used. More...

Properties

bool IsUsed [get]

Member Function Documentation

override void Deltares.Standard.Forms.DExpress.DynamicNavigatorControl.Dispose ( bool disposing )
protected

Clean up any resources being used.

Parameters
disposing true if managed resources should be disposed; otherwise, false.
Generated on Tue Dec 15 2015 18:14:51 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • DynamicNavigatorControl
Deltares.Standard.Forms.DExpress.DynamicNavigatorControl Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.DynamicNavigatorControl, including all inherited members.

Dispose(bool disposing) | Deltares.Standard.Forms.DExpress.DynamicNavigatorControl | protected
DynamicNavigatorControl() (defined in Deltares.Standard.Forms.DExpress.DynamicNavigatorControl) | Deltares.Standard.Forms.DExpress.DynamicNavigatorControl |
GetResource(Type type) (defined in Deltares.Standard.Forms.DExpress.DynamicNavigatorControl) | Deltares.Standard.Forms.DExpress.DynamicNavigatorControl |
IsUsed (defined in Deltares.Standard.Forms.DExpress.DynamicNavigatorControl) | Deltares.Standard.Forms.DExpress.DynamicNavigatorControl |
RegisterResource(Type type, Control resource, string caption) (defined in Deltares.Standard.Forms.DExpress.DynamicNavigatorControl) | Deltares.Standard.Forms.DExpress.DynamicNavigatorControl |
Generated on Tue Dec 15 2015 18:14:51 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.DynamicOutputControl Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • DynamicOutputControl
Protected Member Functions | Properties | List of all members
Deltares.Standard.Forms.DExpress.DynamicOutputControl Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.DynamicOutputControl:

Protected Member Functions

override void Dispose (bool disposing)
Clean up any resources being used. More...

Properties

virtual GridViewControl LogMessagesGridViewControl [get]

Member Function Documentation

override void Deltares.Standard.Forms.DExpress.DynamicOutputControl.Dispose ( bool disposing )
protected

Clean up any resources being used.

Parameters
disposing true if managed resources should be disposed; otherwise, false.
Generated on Tue Dec 15 2015 18:14:52 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • DynamicOutputControl
Deltares.Standard.Forms.DExpress.DynamicOutputControl Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.DynamicOutputControl, including all inherited members.

Dispose(bool disposing) | Deltares.Standard.Forms.DExpress.DynamicOutputControl | protected
DynamicOutputControl() (defined in Deltares.Standard.Forms.DExpress.DynamicOutputControl) | Deltares.Standard.Forms.DExpress.DynamicOutputControl |
LogMessagesGridViewControl (defined in Deltares.Standard.Forms.DExpress.DynamicOutputControl) | Deltares.Standard.Forms.DExpress.DynamicOutputControl |
Generated on Tue Dec 15 2015 18:14:52 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.DynamicPropertyControl Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • DynamicPropertyControl
Public Member Functions | Protected Member Functions | Properties | List of all members
Deltares.Standard.Forms.DExpress.DynamicPropertyControl Class Reference

Control to display custom property windows More...

Inheritance diagram for Deltares.Standard.Forms.DExpress.DynamicPropertyControl:
Deltares.Standard.Forms.IDynamicPropertyControl

Public Member Functions

DynamicPropertyControl ()
Initializes a new instance of the DynamicPropertyControl class More...
void | DisplaySelectedObject ()
checks for custom property controls and displays the selected object in the property window More...
bool | HasAssociations (Type type)
bool | HasAssociationsForCurrentObject ()
bool | IsShowingAssociationTabForType (Type type)
void | ClearRegistrationsForType (Type type)
Clear registered property controls for given type More...
void | BuildPropertyControlTabsForProperty< T > (Expression< Func< T, object >> property, params IPropertyControl[] controls)
Creates a tab page for each property control for specified property of a given type. More...
void | BuildPropertyControlTabForTypes (IPropertyControl control, params Type[] types)
Creates a tab page for each specified data type. More...
void | BuildPropertyControlTabsForType (Type type, params IPropertyControl[] controls)
Creates a tab page for each property control for specified data type. More...
void | BuildDelayedPropertyControlsForType (Type type, params CreatePropertyControlDelegate[] controls)
Registers the custom property control but does not invoke the creation of it directly More...
void | BuildDelayedPropertyControlsForProperty< T > (Expression< Func< T, object >> property, params CreatePropertyControlDelegate[] controls)
Registers the custom property control but does not invoke the creation of it directly More...
void | BuildDelayedPropertyControlForTypes (CreatePropertyControlDelegate control, params Type[] types)
Registers the custom property control but does not invoke the creation of it directly More...
void | AddAssociationsForType< T > (params Expression< Func< T, object >>[] associatedProperties)
void | AddAdditionalPropertyControlForType< T > (Expression< Func< T, object >> associatedProperty)

Protected Member Functions

override void Dispose (bool disposing)
Clean up any resources being used. More...

Properties

XtraTabPage | SelectedTabPage [set]
bool | IsUsed [get]
object | SelectedObject [get, set]
Gets or sets the value of the object to be displayed in the property grid More...
IPropertyControl | DefaultPropertyGrid [get]
- Properties inherited from Deltares.Standard.Forms.IDynamicPropertyControl
object | SelectedObject [get, set]
Gets or sets the value of the object to be displayed in the property grid More...
IPropertyControl | DefaultPropertyGrid [get]
Default property grid More...

Detailed Description

Control to display custom property windows

Constructor & Destructor Documentation

Deltares.Standard.Forms.DExpress.DynamicPropertyControl.DynamicPropertyControl ( )

Initializes a new instance of the DynamicPropertyControl class

Member Function Documentation

void Deltares.Standard.Forms.DExpress.DynamicPropertyControl.BuildDelayedPropertyControlForTypes | ( | CreatePropertyControlDelegate | control,
 |  | params Type[] | types
 | ) |  |

Registers the custom property control but does not invoke the creation of it directly

Parameters
control | custom property control to handle the specific type
types | type of the object handled by the control
void Deltares.Standard.Forms.DExpress.DynamicPropertyControl.BuildDelayedPropertyControlsForProperty< T > | ( | Expression< Func< T, object >> | property,
 |  | params CreatePropertyControlDelegate[] | controls
 | ) |  |

Registers the custom property control but does not invoke the creation of it directly

Template Parameters
T type of the object handled by the control
Parameters
property | Property of type T .
controls | custom property control to handle the specific type
void Deltares.Standard.Forms.DExpress.DynamicPropertyControl.BuildDelayedPropertyControlsForType | ( | Type | type,
 |  | params CreatePropertyControlDelegate[] | controls
 | ) |  |

Registers the custom property control but does not invoke the creation of it directly

Parameters
type | type of the object handled by the control
controls | custom property control to handle the specific type
void Deltares.Standard.Forms.DExpress.DynamicPropertyControl.BuildPropertyControlTabForTypes | ( | IPropertyControl | control,
 |  | params Type[] | types
 | ) |  |

Creates a tab page for each specified data type.

Parameters
control | Custom property control to handle types .
types | Data types handled by control .

Referenced by Deltares.Standard.Forms.DExpress.MainForm.CreateAndRegisterPropertyFormFor< T >().

void Deltares.Standard.Forms.DExpress.DynamicPropertyControl.BuildPropertyControlTabsForProperty< T > | ( | Expression< Func< T, object >> | property,
 |  | params IPropertyControl[] | controls
 | ) |  |

Creates a tab page for each property control for specified property of a given type.

Template Parameters
T Data type handled by the controls.
Parameters
property | Property name of T .
controls | Custom property controls to handle T .
void Deltares.Standard.Forms.DExpress.DynamicPropertyControl.BuildPropertyControlTabsForType | ( | Type | type,
 |  | params IPropertyControl[] | controls
 | ) |  |

Creates a tab page for each property control for specified data type.

Parameters
type | Data type handled by the controls.
controls | Custom property controls to handle type .

Implements Deltares.Standard.Forms.IDynamicPropertyControl.

Referenced by Deltares.Standard.Forms.DExpress.MainForm.CreateAndRegisterPropertyFormFor< T >().

void Deltares.Standard.Forms.DExpress.DynamicPropertyControl.ClearRegistrationsForType ( Type type )

Clear registered property controls for given type

Parameters
type
void Deltares.Standard.Forms.DExpress.DynamicPropertyControl.DisplaySelectedObject ( )

checks for custom property controls and displays the selected object in the property window

override void Deltares.Standard.Forms.DExpress.DynamicPropertyControl.Dispose ( bool disposing )
protected

Clean up any resources being used.

Parameters
disposing true if managed resources should be disposed; otherwise, false.

Property Documentation

object Deltares.Standard.Forms.DExpress.DynamicPropertyControl.SelectedObject
getset

Gets or sets the value of the object to be displayed in the property grid

Generated on Tue Dec 15 2015 18:14:52 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • DynamicPropertyControl
Deltares.Standard.Forms.DExpress.DynamicPropertyControl Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.DynamicPropertyControl, including all inherited members.

AddAdditionalPropertyControlForType< T >(Expression< Func< T, object >> associatedProperty) (defined in Deltares.Standard.Forms.DExpress.DynamicPropertyControl) | Deltares.Standard.Forms.DExpress.DynamicPropertyControl |
AddAssociationsForType< T >(params Expression< Func< T, object >>[] associatedProperties) (defined in Deltares.Standard.Forms.DExpress.DynamicPropertyControl) | Deltares.Standard.Forms.DExpress.DynamicPropertyControl |
BuildDelayedPropertyControlForTypes(CreatePropertyControlDelegate control, params Type[] types) | Deltares.Standard.Forms.DExpress.DynamicPropertyControl |
BuildDelayedPropertyControlsForProperty< T >(Expression< Func< T, object >> property, params CreatePropertyControlDelegate[] controls) | Deltares.Standard.Forms.DExpress.DynamicPropertyControl |
BuildDelayedPropertyControlsForType(Type type, params CreatePropertyControlDelegate[] controls) | Deltares.Standard.Forms.DExpress.DynamicPropertyControl |
BuildPropertyControlTabForTypes(IPropertyControl control, params Type[] types) | Deltares.Standard.Forms.DExpress.DynamicPropertyControl |
BuildPropertyControlTabsForProperty< T >(Expression< Func< T, object >> property, params IPropertyControl[] controls) | Deltares.Standard.Forms.DExpress.DynamicPropertyControl |
BuildPropertyControlTabsForType(Type type, params IPropertyControl[] controls) | Deltares.Standard.Forms.DExpress.DynamicPropertyControl |
ClearRegistrationsForType(Type type) | Deltares.Standard.Forms.DExpress.DynamicPropertyControl |
DefaultPropertyGrid (defined in Deltares.Standard.Forms.DExpress.DynamicPropertyControl) | Deltares.Standard.Forms.DExpress.DynamicPropertyControl |
DisplaySelectedObject() | Deltares.Standard.Forms.DExpress.DynamicPropertyControl |
Dispose(bool disposing) | Deltares.Standard.Forms.DExpress.DynamicPropertyControl | protected
DynamicPropertyControl() | Deltares.Standard.Forms.DExpress.DynamicPropertyControl |
HasAssociations(Type type) (defined in Deltares.Standard.Forms.DExpress.DynamicPropertyControl) | Deltares.Standard.Forms.DExpress.DynamicPropertyControl |
HasAssociationsForCurrentObject() (defined in Deltares.Standard.Forms.DExpress.DynamicPropertyControl) | Deltares.Standard.Forms.DExpress.DynamicPropertyControl |
IsShowingAssociationTabForType(Type type) (defined in Deltares.Standard.Forms.DExpress.DynamicPropertyControl) | Deltares.Standard.Forms.DExpress.DynamicPropertyControl |
IsUsed (defined in Deltares.Standard.Forms.DExpress.DynamicPropertyControl) | Deltares.Standard.Forms.DExpress.DynamicPropertyControl |
SelectedObject | Deltares.Standard.Forms.DExpress.DynamicPropertyControl |
SelectedTabPage (defined in Deltares.Standard.Forms.DExpress.DynamicPropertyControl) | Deltares.Standard.Forms.DExpress.DynamicPropertyControl |
Generated on Tue Dec 15 2015 18:14:52 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.DynamicPropertyControlDefinition Struct Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • DynamicPropertyControlDefinition
Public Attributes | List of all members
Deltares.Standard.Forms.DExpress.DynamicPropertyControlDefinition Struct Reference

Public Attributes

CreatePropertyControlDelegate | CreateMethod
string | Property
Type | Type
Generated on Tue Dec 15 2015 18:14:52 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • DynamicPropertyControlDefinition
Deltares.Standard.Forms.DExpress.DynamicPropertyControlDefinition Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.DynamicPropertyControlDefinition, including all inherited members.

CreateMethod (defined in Deltares.Standard.Forms.DExpress.DynamicPropertyControlDefinition) | Deltares.Standard.Forms.DExpress.DynamicPropertyControlDefinition
Property (defined in Deltares.Standard.Forms.DExpress.DynamicPropertyControlDefinition) | Deltares.Standard.Forms.DExpress.DynamicPropertyControlDefinition
Type (defined in Deltares.Standard.Forms.DExpress.DynamicPropertyControlDefinition) | Deltares.Standard.Forms.DExpress.DynamicPropertyControlDefinition
Generated on Tue Dec 15 2015 18:14:52 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.DynamicPropertyTabControl< T > Class Template Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • DynamicPropertyTabControl
Deltares.Standard.Forms.DExpress.DynamicPropertyTabControl< T > Class Template Reference

Container for showing a collection of controls, that can all interpret the same type SelectedObject (type

Template Parameters
T ) based on a conversion delegate.
More...

Detailed Description

Container for showing a collection of controls, that can all interpret the same type SelectedObject (type

Template Parameters
T ) based on a conversion delegate.
Type Constraints
T : class
Generated on Tue Dec 15 2015 18:14:52 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.DynamicResourcesControl Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • DynamicResourcesControl
Public Member Functions | Protected Member Functions | Properties | List of all members
Deltares.Standard.Forms.DExpress.DynamicResourcesControl Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.DynamicResourcesControl:

Public Member Functions

void | RegisterResource (Type type, Control resource, string caption)
Control | GetResource (Type type)

Protected Member Functions

override void Dispose (bool disposing)
Clean up any resources being used. More...

Properties

bool IsUsed [get]

Member Function Documentation

override void Deltares.Standard.Forms.DExpress.DynamicResourcesControl.Dispose ( bool disposing )
protected

Clean up any resources being used.

Parameters
disposing true if managed resources should be disposed; otherwise, false.
Generated on Tue Dec 15 2015 18:14:52 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • DynamicResourcesControl
Deltares.Standard.Forms.DExpress.DynamicResourcesControl Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.DynamicResourcesControl, including all inherited members.

Dispose(bool disposing) | Deltares.Standard.Forms.DExpress.DynamicResourcesControl | protected
DynamicResourcesControl() (defined in Deltares.Standard.Forms.DExpress.DynamicResourcesControl) | Deltares.Standard.Forms.DExpress.DynamicResourcesControl |
GetResource(Type type) (defined in Deltares.Standard.Forms.DExpress.DynamicResourcesControl) | Deltares.Standard.Forms.DExpress.DynamicResourcesControl |
IsUsed (defined in Deltares.Standard.Forms.DExpress.DynamicResourcesControl) | Deltares.Standard.Forms.DExpress.DynamicResourcesControl |
RegisterResource(Type type, Control resource, string caption) (defined in Deltares.Standard.Forms.DExpress.DynamicResourcesControl) | Deltares.Standard.Forms.DExpress.DynamicResourcesControl |
Generated on Tue Dec 15 2015 18:14:52 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.DynamicTableControl Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • DynamicTableControl
Public Member Functions | Public Attributes | Protected Member Functions | List of all members
Deltares.Standard.Forms.DExpress.DynamicTableControl Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.DynamicTableControl:
Deltares.Standard.Forms.IDynamicTableControl

Public Member Functions

void | AssignObject (object o)
void | ClearAssignObjectOfType (Type type)
Set assigned object of a type to null More...
GridViewControl | RegisterTable< ContainerType, ObjectType > (Expression< Func< ContainerType, IEnumerable< ObjectType >>> listProperty, bool onlyShowDuringSelection=false)
IEnumerable< GridViewControl > | RegisterTables< ContainerType > (bool onlyShowDuringSelection=false, params Expression< Func< ContainerType, IEnumerable< object >>>[] listProperties)
Control | GetTable (Type type)
Type | GetType (Control control)
void | AttractAttention (Type type)
void | AttractAttention (Control control)
Component | GetComponent ()
XtraTabPage | RegisterTable (Type type, Control table, string caption)

Public Attributes

DevExpress.XtraTab.XtraTabControl TabControl

Protected Member Functions

override void Dispose (bool disposing)
Clean up any resources being used. More...

Member Function Documentation

void Deltares.Standard.Forms.DExpress.DynamicTableControl.ClearAssignObjectOfType ( Type type )

Set assigned object of a type to null

Parameters
o
override void Deltares.Standard.Forms.DExpress.DynamicTableControl.Dispose ( bool disposing )
protected

Clean up any resources being used.

Parameters
disposing true if managed resources should be disposed; otherwise, false.
Generated on Tue Dec 15 2015 18:14:52 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • DynamicTableControl
Deltares.Standard.Forms.DExpress.DynamicTableControl Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.DynamicTableControl, including all inherited members.

AssignObject(object o) (defined in Deltares.Standard.Forms.DExpress.DynamicTableControl) | Deltares.Standard.Forms.DExpress.DynamicTableControl |
AttractAttention(Type type) (defined in Deltares.Standard.Forms.DExpress.DynamicTableControl) | Deltares.Standard.Forms.DExpress.DynamicTableControl |
AttractAttention(Control control) (defined in Deltares.Standard.Forms.DExpress.DynamicTableControl) | Deltares.Standard.Forms.DExpress.DynamicTableControl |
ClearAssignObjectOfType(Type type) | Deltares.Standard.Forms.DExpress.DynamicTableControl |
Dispose(bool disposing) | Deltares.Standard.Forms.DExpress.DynamicTableControl | protected
DynamicTableControl() (defined in Deltares.Standard.Forms.DExpress.DynamicTableControl) | Deltares.Standard.Forms.DExpress.DynamicTableControl |
GetComponent() (defined in Deltares.Standard.Forms.DExpress.DynamicTableControl) | Deltares.Standard.Forms.DExpress.DynamicTableControl |
GetTable(Type type) (defined in Deltares.Standard.Forms.DExpress.DynamicTableControl) | Deltares.Standard.Forms.DExpress.DynamicTableControl |
GetType(Control control) (defined in Deltares.Standard.Forms.DExpress.DynamicTableControl) | Deltares.Standard.Forms.DExpress.DynamicTableControl |
RegisterTable(Type type, Control table, string caption) (defined in Deltares.Standard.Forms.DExpress.DynamicTableControl) | Deltares.Standard.Forms.DExpress.DynamicTableControl |
RegisterTable< ContainerType, ObjectType >(Expression< Func< ContainerType, IEnumerable< ObjectType >>> listProperty, bool onlyShowDuringSelection=false) (defined in Deltares.Standard.Forms.DExpress.DynamicTableControl) | Deltares.Standard.Forms.DExpress.DynamicTableControl |
RegisterTables< ContainerType >(bool onlyShowDuringSelection=false, params Expression< Func< ContainerType, IEnumerable< object >>>[] listProperties) (defined in Deltares.Standard.Forms.DExpress.DynamicTableControl) | Deltares.Standard.Forms.DExpress.DynamicTableControl |
TabControl (defined in Deltares.Standard.Forms.DExpress.DynamicTableControl) | Deltares.Standard.Forms.DExpress.DynamicTableControl |
Generated on Tue Dec 15 2015 18:14:52 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.FormsSupport Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • FormsSupport
Static Public Member Functions | List of all members
Deltares.Standard.Forms.DExpress.FormsSupport Class Reference

Static Public Member Functions

static void | RepairRightAnchoredControls (Control container)
static void | SetVisible (Control control, bool visible)
Registers that a control has been set to a given visibility state Note that this method doesn't set the control's visibility More...
static bool | IsVisible (Control control)
static void | UpdateDirtyControls ()
Updates the size of all containers More...
static void | MakeTreeVisible (Control control)
Makes a control visible and all of its parents More...
static DockPanel | GetDockPanel (Control control)
static List< Control > | GetAllControls (Control control)
static void | AdjustSizeToContents (Control groupControl)
static void | UpdateSize (Control container)
static void | UpdateContainerSizes (params Control[] containers)
static bool | IsTreeVisible (Control control)
static void | RegisterParent (Component child, Component parent)
static Component | GetParent (Component child)
static void | AttractUserAttention (Control control, string message, bool showAlert)
static void | SetFocus (Control control)
static Control | GetParentOfType (Control control, Type type)
Returns a parent in the control tree of a given type. More...

Member Function Documentation

static Control Deltares.Standard.Forms.DExpress.FormsSupport.GetParentOfType | ( | Control | control,
 |  | Type | type
 | ) |  |
static

Returns a parent in the control tree of a given type.

Parameters
control | The Control to find the parent for.
type | The Type of parent Control to find.
Returns
The parent Control of type type
static void Deltares.Standard.Forms.DExpress.FormsSupport.MakeTreeVisible ( Control control )
static

Makes a control visible and all of its parents

Parameters
control Control

Referenced by Deltares.Standard.Forms.DExpress.MainForm.SetAsActiveChart(), Deltares.Standard.Forms.DExpress.MainForm.SetAsActivePropertyEditor(), Deltares.Standard.Forms.DExpress.MainForm.SetAsActiveTable(), and Deltares.Standard.Forms.DExpress.MainForm.SetAsActiveTabOnMainPanel().

static void Deltares.Standard.Forms.DExpress.FormsSupport.SetVisible | ( | Control | control,
 |  | bool | visible
 | ) |  |
static

Registers that a control has been set to a given visibility state Note that this method doesn't set the control's visibility

Parameters
control | Control
visible | Visibility state
static void Deltares.Standard.Forms.DExpress.FormsSupport.UpdateDirtyControls ( )
static

Updates the size of all containers

Referenced by Deltares.Standard.Forms.DExpress.BindSupport.Assign().

Generated on Tue Dec 15 2015 18:14:52 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • FormsSupport
Deltares.Standard.Forms.DExpress.FormsSupport Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.FormsSupport, including all inherited members.

AdjustSizeToContents(Control groupControl) (defined in Deltares.Standard.Forms.DExpress.FormsSupport) | Deltares.Standard.Forms.DExpress.FormsSupport | static
AttractUserAttention(Control control, string message, bool showAlert) (defined in Deltares.Standard.Forms.DExpress.FormsSupport) | Deltares.Standard.Forms.DExpress.FormsSupport | static
GetAllControls(Control control) (defined in Deltares.Standard.Forms.DExpress.FormsSupport) | Deltares.Standard.Forms.DExpress.FormsSupport | static
GetDockPanel(Control control) (defined in Deltares.Standard.Forms.DExpress.FormsSupport) | Deltares.Standard.Forms.DExpress.FormsSupport | static
GetParent(Component child) (defined in Deltares.Standard.Forms.DExpress.FormsSupport) | Deltares.Standard.Forms.DExpress.FormsSupport | static
GetParentOfType(Control control, Type type) | Deltares.Standard.Forms.DExpress.FormsSupport | static
IsTreeVisible(Control control) (defined in Deltares.Standard.Forms.DExpress.FormsSupport) | Deltares.Standard.Forms.DExpress.FormsSupport | static
IsVisible(Control control) (defined in Deltares.Standard.Forms.DExpress.FormsSupport) | Deltares.Standard.Forms.DExpress.FormsSupport | static
MakeTreeVisible(Control control) | Deltares.Standard.Forms.DExpress.FormsSupport | static
RegisterParent(Component child, Component parent) (defined in Deltares.Standard.Forms.DExpress.FormsSupport) | Deltares.Standard.Forms.DExpress.FormsSupport | static
RepairRightAnchoredControls(Control container) (defined in Deltares.Standard.Forms.DExpress.FormsSupport) | Deltares.Standard.Forms.DExpress.FormsSupport | static
SetFocus(Control control) (defined in Deltares.Standard.Forms.DExpress.FormsSupport) | Deltares.Standard.Forms.DExpress.FormsSupport | static
SetVisible(Control control, bool visible) | Deltares.Standard.Forms.DExpress.FormsSupport | static
UpdateContainerSizes(params Control[] containers) (defined in Deltares.Standard.Forms.DExpress.FormsSupport) | Deltares.Standard.Forms.DExpress.FormsSupport | static
UpdateDirtyControls() | Deltares.Standard.Forms.DExpress.FormsSupport | static
UpdateSize(Control container) (defined in Deltares.Standard.Forms.DExpress.FormsSupport) | Deltares.Standard.Forms.DExpress.FormsSupport | static
Generated on Tue Dec 15 2015 18:14:52 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.GeoChartControl Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • GeoChartControl
Public Member Functions | Protected Member Functions | Properties | List of all members
Deltares.Standard.Forms.DExpress.GeoChartControl Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.GeoChartControl:

Public Member Functions

void | SetLocalizedStrings ()
Sets the localized string for the strings available in this control. More...
void | SetViewType (ViewType aViewType)
Sets the default ViewType for the current chart ViewType. More...
void | SetDataSource (IList aDatasource, int aNumberOfSeries, string aChartTitle, string aChartTitle1)
Gets the main list of data source of all the series in the data source and the necessary details of the chart. More...
void | XAxisTitle (string aXColumnPropertyName)
Sets the Title of X-Axis More...
void | YAxisTitle (string aYColumnPropertyName)
Sets the Title of Y-Axis More...
void | SetSeriesProperties (int aSeariesIndex, bool aIsVisible, bool aIsSearies2DView, ViewType aView2D, ViewType aView3D, string aXColumnPropertyName, Type aXColumnType, string aYColumnPropertyName, Type aYColumnType, string aSeriesName)
Sets the properties for publisherEventArgs particular series. More...
void | PopulateDataTable (int aSeariesIndex, Type type, string aXColumnPropertyName, string aYColumnPropertyName)
Populates the data table with the values given by the DataSource. More...
void | ClearSeries ()
Cleares all the values and datas in the series. More...
void | TableToChart (int aSeariesIndex, bool aIsGrid, GridView aGridView, TreeList aTreeList, int aXColumnIndex, Type aXColumnType, int aYColumnIndex, Type aYColumnType, int aTreeListNodeLevel)
Takes column index of TreeList or Grid and Displays the value in the Chart. More...
void | ChartToTable ()
void | SetMinMax (double aXMin, double aXMax, double aYMin, double aYMax)
Sets the minimum and maximum values of the series. More...
void | OnPrint ()
Print option for the chart control. More...
Image | CopytoClipBoard ()
Copies the image to the clipboard as an image. More...
void | ExportTo ()
Exports the chart to publisherEventArgs particular file format specified. More...

Protected Member Functions

override void OnCreateControl ()

Properties

PopupMenu | ChartPopupMenu [get, set]
Provies the popup control for the chart template. More...
ViewType | ViewType [get, set]
General view type of the chart control. More...
List< DevExpress.XtraCharts.Series > | SeriesList [get]
Contains the list of series added to the chart diagram at publisherEventArgs point of time. More...
List< DataTable > | DataTableList [get]
Contains publisherEventArgs list fo DataTables associated with the series. More...
ViewType | ViewType2D [get, set]
Sets the 2D ViewType of the Chart Control More...
ViewType | ViewType3D [get, set]
Sets the 3D ViewType of the Chart Control More...
XYDiagramSeriesViewBase | CurrentSeriesView [get, set]
Provides the base series view for the type of chart selected. More...
int | SeriesCount [get, set]
Gets or sets the series count of the chart control. More...

Member Function Documentation

void Deltares.Standard.Forms.DExpress.GeoChartControl.ChartToTable ( )

void Deltares.Standard.Forms.DExpress.GeoChartControl.ClearSeries ( )

Cleares all the values and datas in the series.

Image Deltares.Standard.Forms.DExpress.GeoChartControl.CopytoClipBoard ( )

Copies the image to the clipboard as an image.

Returns
void Deltares.Standard.Forms.DExpress.GeoChartControl.ExportTo ( )

Exports the chart to publisherEventArgs particular file format specified.

void Deltares.Standard.Forms.DExpress.GeoChartControl.OnPrint ( )

Print option for the chart control.

void Deltares.Standard.Forms.DExpress.GeoChartControl.PopulateDataTable | ( | int | aSeariesIndex,
 |  | Type | type,
 |  | string | aXColumnPropertyName,
 |  | string | aYColumnPropertyName
 | ) |  |

Populates the data table with the values given by the DataSource.

Parameters
aSeariesIndex | publisherEventArgs zero based index of the series for which the data is being populated.
aXColumnPropertyName | X-Column property name for the current series.
aYColumnPropertyName | Y-Column property name for the current series.
void Deltares.Standard.Forms.DExpress.GeoChartControl.SetDataSource | ( | IList | aDatasource,
 |  | int | aNumberOfSeries,
 |  | string | aChartTitle,
 |  | string | aChartTitle1
 | ) |  |

Gets the main list of data source of all the series in the data source and the necessary details of the chart.

Parameters
aDatasource | A list or publisherEventArgs collection is set as publisherEventArgs data source.
aNumberOfSeries | Number of series to be created in the chart control.
aChartTitle | The main title of the chart
aChartTitle1 | The secondary title
void Deltares.Standard.Forms.DExpress.GeoChartControl.SetLocalizedStrings ( )

Sets the localized string for the strings available in this control.

void Deltares.Standard.Forms.DExpress.GeoChartControl.SetMinMax | ( | double | aXMin,
 |  | double | aXMax,
 |  | double | aYMin,
 |  | double | aYMax
 | ) |  |

Sets the minimum and maximum values of the series.

Parameters
aXMin | Minimum value of X-Coordinate
aXMax | Maximum value of X-Coordinate
aYMin | Minimum value of Y-Coordinate
aYMax | Maximum value of Y-Coordinate
void Deltares.Standard.Forms.DExpress.GeoChartControl.SetSeriesProperties | ( | int | aSeariesIndex,
 |  | bool | aIsVisible,
 |  | bool | aIsSearies2DView,
 |  | ViewType | aView2D,
 |  | ViewType | aView3D,
 |  | string | aXColumnPropertyName,
 |  | Type | aXColumnType,
 |  | string | aYColumnPropertyName,
 |  | Type | aYColumnType,
 |  | string | aSeriesName
 | ) |  |

Sets the properties for publisherEventArgs particular series.

Parameters
aSeariesIndex | A zero based index for which the property is being set.
aIsVisible | Sets the series visibility.
aIsSearies2DView | Sets the viewtype of the series.
aView2D | 2D ViewType of the series.
aView3D | 3D ViewType of the series.
aXColumnPropertyName | X-Column property name from which the X-Column values are to be fetched.
aXColumnType | X-Column property type
aYColumnPropertyName | X-Column property name from which the Y-Column values are to be fetched.
aYColumnType | Y-Column property type
aSeriesName | Name of the series
void Deltares.Standard.Forms.DExpress.GeoChartControl.SetViewType ( ViewType aViewType )

Sets the default ViewType for the current chart ViewType.

Parameters
aTypeName
void Deltares.Standard.Forms.DExpress.GeoChartControl.TableToChart | ( | int | aSeariesIndex,
 |  | bool | aIsGrid,
 |  | GridView | aGridView,
 |  | TreeList | aTreeList,
 |  | int | aXColumnIndex,
 |  | Type | aXColumnType,
 |  | int | aYColumnIndex,
 |  | Type | aYColumnType,
 |  | int | aTreeListNodeLevel
 | ) |  |

Takes column index of TreeList or Grid and Displays the value in the Chart.

Parameters
aIsGrid | True if the Table is Grid
aGridView | GridView of GridControl for retreiving the values from the grid.
aTreeList | TreeList from which the Chart has to populate its values.
aXColumnIndex | A Zero based column index of Grid or TreeList from which X values will be populated
aXColumnType | Type of the columnwhich is being given as X column
aYColumnIndex | A Zero based column index of Grid or TreeList from which Y values will be populated
aYColumnType | Type of the columnwhich is being given as X column
aTreeListNodeLevel | A Zero based TreeList level from which data has to be populated.
void Deltares.Standard.Forms.DExpress.GeoChartControl.XAxisTitle ( string aXColumnPropertyName )

Sets the Title of X-Axis

Parameters
aXColumnPropertyName
void Deltares.Standard.Forms.DExpress.GeoChartControl.YAxisTitle ( string aYColumnPropertyName )

Sets the Title of Y-Axis

Parameters
aXColumnPropertyName

Property Documentation

PopupMenu Deltares.Standard.Forms.DExpress.GeoChartControl.ChartPopupMenu
getset

Provies the popup control for the chart template.

XYDiagramSeriesViewBase Deltares.Standard.Forms.DExpress.GeoChartControl.CurrentSeriesView
getset

Provides the base series view for the type of chart selected.

List<DataTable> Deltares.Standard.Forms.DExpress.GeoChartControl.DataTableList
get

Contains publisherEventArgs list fo DataTables associated with the series.

int Deltares.Standard.Forms.DExpress.GeoChartControl.SeriesCount
getset

Gets or sets the series count of the chart control.

List<DevExpress.XtraCharts.Series> Deltares.Standard.Forms.DExpress.GeoChartControl.SeriesList
get

Contains the list of series added to the chart diagram at publisherEventArgs point of time.

ViewType Deltares.Standard.Forms.DExpress.GeoChartControl.ViewType
getset

General view type of the chart control.

ViewType Deltares.Standard.Forms.DExpress.GeoChartControl.ViewType2D
getset

Sets the 2D ViewType of the Chart Control

ViewType Deltares.Standard.Forms.DExpress.GeoChartControl.ViewType3D
getset

Sets the 3D ViewType of the Chart Control

Generated on Tue Dec 15 2015 18:14:53 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • GeoChartControl
Deltares.Standard.Forms.DExpress.GeoChartControl Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.GeoChartControl, including all inherited members.

ChartPopupMenu | Deltares.Standard.Forms.DExpress.GeoChartControl |
ChartToTable() | Deltares.Standard.Forms.DExpress.GeoChartControl |
ClearSeries() | Deltares.Standard.Forms.DExpress.GeoChartControl |
CopytoClipBoard() | Deltares.Standard.Forms.DExpress.GeoChartControl |
CurrentSeriesView | Deltares.Standard.Forms.DExpress.GeoChartControl |
DataTableList | Deltares.Standard.Forms.DExpress.GeoChartControl |
ExportTo() | Deltares.Standard.Forms.DExpress.GeoChartControl |
GeoChartControl() (defined in Deltares.Standard.Forms.DExpress.GeoChartControl) | Deltares.Standard.Forms.DExpress.GeoChartControl |
OnCreateControl() (defined in Deltares.Standard.Forms.DExpress.GeoChartControl) | Deltares.Standard.Forms.DExpress.GeoChartControl | protected
OnPrint() | Deltares.Standard.Forms.DExpress.GeoChartControl |
PopulateDataTable(int aSeariesIndex, Type type, string aXColumnPropertyName, string aYColumnPropertyName) | Deltares.Standard.Forms.DExpress.GeoChartControl |
SeriesCount | Deltares.Standard.Forms.DExpress.GeoChartControl |
SeriesList | Deltares.Standard.Forms.DExpress.GeoChartControl |
SetDataSource(IList aDatasource, int aNumberOfSeries, string aChartTitle, string aChartTitle1) | Deltares.Standard.Forms.DExpress.GeoChartControl |
SetLocalizedStrings() | Deltares.Standard.Forms.DExpress.GeoChartControl |
SetMinMax(double aXMin, double aXMax, double aYMin, double aYMax) | Deltares.Standard.Forms.DExpress.GeoChartControl |
SetSeriesProperties(int aSeariesIndex, bool aIsVisible, bool aIsSearies2DView, ViewType aView2D, ViewType aView3D, string aXColumnPropertyName, Type aXColumnType, string aYColumnPropertyName, Type aYColumnType, string aSeriesName) | Deltares.Standard.Forms.DExpress.GeoChartControl |
SetViewType(ViewType aViewType) | Deltares.Standard.Forms.DExpress.GeoChartControl |
TableToChart(int aSeariesIndex, bool aIsGrid, GridView aGridView, TreeList aTreeList, int aXColumnIndex, Type aXColumnType, int aYColumnIndex, Type aYColumnType, int aTreeListNodeLevel) | Deltares.Standard.Forms.DExpress.GeoChartControl |
ViewType | Deltares.Standard.Forms.DExpress.GeoChartControl |
ViewType2D | Deltares.Standard.Forms.DExpress.GeoChartControl |
ViewType3D | Deltares.Standard.Forms.DExpress.GeoChartControl |
XAxisTitle(string aXColumnPropertyName) | Deltares.Standard.Forms.DExpress.GeoChartControl |
YAxisTitle(string aYColumnPropertyName) | Deltares.Standard.Forms.DExpress.GeoChartControl |
Generated on Tue Dec 15 2015 18:14:53 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.GeometryEditor Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • GeometryEditor
Public Member Functions | Public Attributes | Protected Member Functions | Package Attributes | Properties | Events | List of all members
Deltares.Standard.Forms.DExpress.GeometryEditor Class Reference

TODO: Comment More...

Inheritance diagram for Deltares.Standard.Forms.DExpress.GeometryEditor:
Deltares.Standard.Forms.IReloadableUI

Public Member Functions

GeometryEditor ()
TODO: Comment More...
void | SetupViewEditor ()
Sets up the view editor. More...
void | BeginUndoAction ()
Begins the undo action. More...
void | Clear ()
Clears the View Control More...
void | OnClickMStabGraphicInputBarSelectionItem (object sender, ItemClickEventArgs e)
Called when [click m stab graphic input bar selection item]. TODO: Comment More...
void | RegisterComponentsToReloadUI (IReloadManager aReloadManager)
Registers the GeometryEditor to the given ReloadManager and sets the reload manager to the given value More...
BarButtonItem | CreateAndRegisterUICommand ()
creates a tool button with the provided info and add them to the tool bar More...
BarButtonItem | CreateButton (Image image)
creates a tool button with the provided info and add them to the tool bar More...
bool | ShowSelectedNonvisibleItems ()
sets the down state of all the Non Visible Items More...
void | RedrawView ()
Redraws the view. More...
void | DeselectAllObjects ()
Deselects all objects. More...
Bar | GetMainBar ()
Gets the main bar. More...
BarManager | GetMainBarManager ()
Gets the main bar manager. More...
void | ZoomToExtends (object sender, EventArgs e)
Zooms to extends. More...
void | AddToolbarItems (ToolStripItem[] items)
Adds the toolbar items. More...
void | AddToolBarItem ()
Adds the tool bar item. More...
void | OnShapeAction (object geometryObject, ShapeAction action, PointF point, IShape shape)
Called when [shape action]. TODO: Comment More...
void | GeometryEditor_MouseLeave (object sender, EventArgs e)
Handles the MouseLeave event of the GeometryEditor control. More...
void | CancelCommand (bool aBreakAll)
Cancels the command. More...
void | DeleteSelectedObjects ()
Deletes the selected objects. More...
Point3D | Get3dTopPoint (Point3D point, bool aIsNearestToppoint)
Gets the 3D top point. More...
void | SetInsertMode (bool showCommandLineWindow)
Sets the insert mode. More...
void | DisableAllButtonDownState (BarButtonItem aButtonToBeEnabled)
Disables the down state of all buttons. TODO: Comment More...
void | Create (object data, string description)
Creating publisherEventArgs IDrawingObject "drawingObject" And Sets its RefKey More...
void | RemoveObject (object anObject)
Removes the given object. More...
void | RegisterUIComponent (IReloadManager aReloadManager)
Registers the GeometryEditor to the given ReloadManager. More...
void | Reload ()
Reloads this instance (empty function). More...
void | UpdateData (params object[] models)
Updates the data (empty function). More...
bool | IsVisible (string property)
Determines whether the specified property is visible. More...
bool | IsEnabled (string property)
Determines whether the specified property is enabled. More...

Public Attributes

DevExpress.XtraBars.BarManager | MainBarManager
DevExpress.XtraBars.Bar | MainBar
DevExpress.XtraBars.BarButtonItem | MStabGraphicInputBarSelectionItem
System.Windows.Forms.ContextMenuStrip | objectContextMenu
DevExpress.XtraBars.BarButtonItem | geometryOptionsButton

Protected Member Functions

override void Dispose (bool disposing)

Package Attributes

DevExpress.XtraBars.BarButtonItem | ZoomInBarItem
DevExpress.XtraBars.BarButtonItem | ZoomOutBarItem
DevExpress.XtraBars.BarManager | barManager1
DevExpress.XtraBars.Bar | defaultNonvisibleItemsbar
DevExpress.XtraBars.BarAndDockingController | barAndDockingController1

Properties

bool | IsNonEditableMode [get, set]
Gets or sets a value indicating whether it the non editable mode is active. More...
List< IGeometryModel > | GeometryModels [get]
Gets the geometry models. More...
IGeometryModel | GeometryEditorMode [set]
Sets the active geometry editor mode. More...
string | StatusString [set]
Sets the status string. More...
bool | GridVisible [get, set]
Gets or sets a value indicating whether the grid is visible. More...
int | SelectedObjectCount [get]
Returns the amount of selected objects. More...
IShape[] | SelectedObjects [get]
Gets the selected objects. More...
SpatialEditor | SpatialEditor [get]
Gets the spatial editor. More...
ToolStripMenuItem | AddPointContextItem [get]
Gets the Context Item "Add point" More...
Control | Control [get]
Gets the control (this). More...
bool | IsZoomRectange [get]
Gets a value indicating whether the zooming to rectangle is active. More...
List< IShape > | DragObjectList [get]
Gets the list of objects that wer in the dragged area. More...
bool | SurpressSpatialSelection [get, set]

Events

EventHandler | OnDragDropEndEvent
Event that occurs when something has been dragged and dropped. More...
EditorContextMenuHandler | OnPopupMenu = null
Event that occurs when when a popu menu is called. More...

Detailed Description

TODO: Comment

Constructor & Destructor Documentation

Deltares.Standard.Forms.DExpress.GeometryEditor.GeometryEditor ( )

TODO: Comment

References Deltares.Standard.Forms.DExpress.BindSupport.Assign(), Deltares.Standard.Forms.DExpress.BindSupport.Bind(), Deltares.Standard.Forms.DExpress.BindSupport.Bind2(), Deltares.Standard.Forms.DExpress.GeometryEditor.DeleteSelectedObjects(), and Deltares.Standard.Forms.DExpress.LocalizationSupport.Register().

Member Function Documentation

void Deltares.Standard.Forms.DExpress.GeometryEditor.AddToolBarItem ( )

Adds the tool bar item.

void Deltares.Standard.Forms.DExpress.GeometryEditor.AddToolbarItems ( ToolStripItem[] items )

Adds the toolbar items.

Parameters
items The items.
void Deltares.Standard.Forms.DExpress.GeometryEditor.BeginUndoAction ( )

Begins the undo action.

void Deltares.Standard.Forms.DExpress.GeometryEditor.CancelCommand ( bool aBreakAll )

Cancels the command.

void Deltares.Standard.Forms.DExpress.GeometryEditor.Clear ( )

Clears the View Control

References Deltares.Standard.Forms.SpatialEditor.Clear().

void Deltares.Standard.Forms.DExpress.GeometryEditor.Create | ( | object | data,
 |  | string | description
 | ) |  |

Creating publisherEventArgs IDrawingObject "drawingObject" And Sets its RefKey

Parameters
data
description
Returns
drawingObject
BarButtonItem Deltares.Standard.Forms.DExpress.GeometryEditor.CreateAndRegisterUICommand ( )

creates a tool button with the provided info and add them to the tool bar

BarButtonItem Deltares.Standard.Forms.DExpress.GeometryEditor.CreateButton ( Image image )

creates a tool button with the provided info and add them to the tool bar

void Deltares.Standard.Forms.DExpress.GeometryEditor.DeleteSelectedObjects ( )

Deletes the selected objects.

References Deltares.Standard.Forms.SpatialEditor.Select().

Referenced by Deltares.Standard.Forms.DExpress.GeometryEditor.GeometryEditor().

void Deltares.Standard.Forms.DExpress.GeometryEditor.DeselectAllObjects ( )

Deselects all objects.

References Deltares.Standard.Forms.SpatialEditor.Select().

void Deltares.Standard.Forms.DExpress.GeometryEditor.DisableAllButtonDownState ( BarButtonItem aButtonToBeEnabled )

Disables the down state of all buttons. TODO: Comment

Parameters
aButtonToBeEnabled A button to be enabled.
void Deltares.Standard.Forms.DExpress.GeometryEditor.GeometryEditor_MouseLeave | ( | object | sender,
 |  | EventArgs | e
 | ) |  |

Handles the MouseLeave event of the GeometryEditor control.

Parameters
sender | The source of the event.
e | The EventArgs instance containing the event data.
Point3D Deltares.Standard.Forms.DExpress.GeometryEditor.Get3dTopPoint | ( | Point3D | point,
 |  | bool | aIsNearestToppoint
 | ) |  |

Gets the 3D top point.

Bar Deltares.Standard.Forms.DExpress.GeometryEditor.GetMainBar ( )

Gets the main bar.

BarManager Deltares.Standard.Forms.DExpress.GeometryEditor.GetMainBarManager ( )

Gets the main bar manager.

bool Deltares.Standard.Forms.DExpress.GeometryEditor.IsEnabled ( string property )

Determines whether the specified property is enabled.

Parameters
property The property.
Returns
false if property = DeleteSectedObjects * SelectedObjectCount > 0, else true

References Deltares.Standard.Forms.ShapeInfo.AllowDelete.

bool Deltares.Standard.Forms.DExpress.GeometryEditor.IsVisible ( string property )

Determines whether the specified property is visible.

Parameters
property The property.
Returns
false for HandleZoomIn/Out, otherwise true
void Deltares.Standard.Forms.DExpress.GeometryEditor.OnClickMStabGraphicInputBarSelectionItem | ( | object | sender,
 |  | ItemClickEventArgs | e
 | ) |  |

Called when [click m stab graphic input bar selection item]. TODO: Comment

Parameters
sender | The sender.
e | The ItemClickEventArgs instance containing the event data.
void Deltares.Standard.Forms.DExpress.GeometryEditor.OnShapeAction | ( | object | geometryObject,
 |  | ShapeAction | action,
 |  | PointF | point,
 |  | IShape | shape
 | ) |  |

Called when [shape action]. TODO: Comment

Parameters
geometryObject | The geometry object.
action | The action.
point | The point.
shape | The shape.
void Deltares.Standard.Forms.DExpress.GeometryEditor.RedrawView ( )

Redraws the view.

void Deltares.Standard.Forms.DExpress.GeometryEditor.RegisterComponentsToReloadUI ( IReloadManager aReloadManager )

Registers the GeometryEditor to the given ReloadManager and sets the reload manager to the given value

Parameters
aReloadManager A reload manager.
void Deltares.Standard.Forms.DExpress.GeometryEditor.RegisterUIComponent ( IReloadManager aReloadManager )

Registers the GeometryEditor to the given ReloadManager.

Parameters
aReloadManager A reload manager.

Implements Deltares.Standard.Forms.IReloadableUI.

void Deltares.Standard.Forms.DExpress.GeometryEditor.Reload ( )

Reloads this instance (empty function).

Implements Deltares.Standard.Forms.IReloadableUI.

void Deltares.Standard.Forms.DExpress.GeometryEditor.RemoveObject ( object anObject )

Removes the given object.

Parameters
anObject The object to remove.
void Deltares.Standard.Forms.DExpress.GeometryEditor.SetInsertMode ( bool showCommandLineWindow )

Sets the insert mode.

Parameters
showCommandLineWindow if set to true show command line window.
void Deltares.Standard.Forms.DExpress.GeometryEditor.SetupViewEditor ( )

Sets up the view editor.

bool Deltares.Standard.Forms.DExpress.GeometryEditor.ShowSelectedNonvisibleItems ( )

sets the down state of all the Non Visible Items

void Deltares.Standard.Forms.DExpress.GeometryEditor.UpdateData ( params object[] models )

Updates the data (empty function).

Implements Deltares.Standard.Forms.IReloadableUI.

void Deltares.Standard.Forms.DExpress.GeometryEditor.ZoomToExtends | ( | object | sender,
 |  | EventArgs | e
 | ) |  |

Zooms to extends.

Parameters
sender | The sender.
e | The EventArgs instance containing the event data.

Property Documentation

ToolStripMenuItem Deltares.Standard.Forms.DExpress.GeometryEditor.AddPointContextItem
get

Gets the Context Item "Add point"

The add point context item.

Control Deltares.Standard.Forms.DExpress.GeometryEditor.Control
get

Gets the control (this).

The control.

List<IShape> Deltares.Standard.Forms.DExpress.GeometryEditor.DragObjectList
get

Gets the list of objects that wer in the dragged area.

The drag object list.

IGeometryModel Deltares.Standard.Forms.DExpress.GeometryEditor.GeometryEditorMode
set

Sets the active geometry editor mode.

The geometry editor mode.

List<IGeometryModel> Deltares.Standard.Forms.DExpress.GeometryEditor.GeometryModels
get

Gets the geometry models.

The geometry models.

bool Deltares.Standard.Forms.DExpress.GeometryEditor.GridVisible
getset

Gets or sets a value indicating whether the grid is visible.

true if grid visible; otherwise, false.

bool Deltares.Standard.Forms.DExpress.GeometryEditor.IsNonEditableMode
getset

Gets or sets a value indicating whether it the non editable mode is active.

true if is non editable mode; otherwise, false.

bool Deltares.Standard.Forms.DExpress.GeometryEditor.IsZoomRectange
get

Gets a value indicating whether the zooming to rectangle is active.

true if is zoom rectangle; otherwise, false.

int Deltares.Standard.Forms.DExpress.GeometryEditor.SelectedObjectCount
get

Returns the amount of selected objects.

The selected object count.

IShape [] Deltares.Standard.Forms.DExpress.GeometryEditor.SelectedObjects
get

Gets the selected objects.

The selected objects.

SpatialEditor Deltares.Standard.Forms.DExpress.GeometryEditor.SpatialEditor
get

Gets the spatial editor.

The spatial editor.

Referenced by Deltares.DSoilModel.Forms.DSoilModelGeometryEditor.DSoilModelGeometryEditor().

string Deltares.Standard.Forms.DExpress.GeometryEditor.StatusString
set

Sets the status string.

The status string.

Event Documentation

EventHandler Deltares.Standard.Forms.DExpress.GeometryEditor.OnDragDropEndEvent

Event that occurs when something has been dragged and dropped.

EditorContextMenuHandler Deltares.Standard.Forms.DExpress.GeometryEditor.OnPopupMenu = null

Event that occurs when when a popu menu is called.

Generated on Tue Dec 15 2015 18:14:53 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • GeometryEditor
Deltares.Standard.Forms.DExpress.GeometryEditor Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.GeometryEditor, including all inherited members.

AddPointContextItem | Deltares.Standard.Forms.DExpress.GeometryEditor |
AddToolBarItem() | Deltares.Standard.Forms.DExpress.GeometryEditor |
AddToolbarItems(ToolStripItem[] items) | Deltares.Standard.Forms.DExpress.GeometryEditor |
barAndDockingController1 (defined in Deltares.Standard.Forms.DExpress.GeometryEditor) | Deltares.Standard.Forms.DExpress.GeometryEditor | package
barManager1 (defined in Deltares.Standard.Forms.DExpress.GeometryEditor) | Deltares.Standard.Forms.DExpress.GeometryEditor | package
BeginUndoAction() | Deltares.Standard.Forms.DExpress.GeometryEditor |
CancelCommand(bool aBreakAll) | Deltares.Standard.Forms.DExpress.GeometryEditor |
Clear() | Deltares.Standard.Forms.DExpress.GeometryEditor |
Control | Deltares.Standard.Forms.DExpress.GeometryEditor |
Create(object data, string description) | Deltares.Standard.Forms.DExpress.GeometryEditor |
CreateAndRegisterUICommand() | Deltares.Standard.Forms.DExpress.GeometryEditor |
CreateButton(Image image) | Deltares.Standard.Forms.DExpress.GeometryEditor |
defaultNonvisibleItemsbar (defined in Deltares.Standard.Forms.DExpress.GeometryEditor) | Deltares.Standard.Forms.DExpress.GeometryEditor | package
DeleteSelectedObjects() | Deltares.Standard.Forms.DExpress.GeometryEditor |
DeselectAllObjects() | Deltares.Standard.Forms.DExpress.GeometryEditor |
DisableAllButtonDownState(BarButtonItem aButtonToBeEnabled) | Deltares.Standard.Forms.DExpress.GeometryEditor |
Dispose(bool disposing) (defined in Deltares.Standard.Forms.DExpress.GeometryEditor) | Deltares.Standard.Forms.DExpress.GeometryEditor | protected
DragObjectList | Deltares.Standard.Forms.DExpress.GeometryEditor |
GeometryEditor() | Deltares.Standard.Forms.DExpress.GeometryEditor |
GeometryEditor_MouseLeave(object sender, EventArgs e) | Deltares.Standard.Forms.DExpress.GeometryEditor |
GeometryEditorMode | Deltares.Standard.Forms.DExpress.GeometryEditor |
GeometryModels | Deltares.Standard.Forms.DExpress.GeometryEditor |
geometryOptionsButton (defined in Deltares.Standard.Forms.DExpress.GeometryEditor) | Deltares.Standard.Forms.DExpress.GeometryEditor |
Get3dTopPoint(Point3D point, bool aIsNearestToppoint) | Deltares.Standard.Forms.DExpress.GeometryEditor |
GetMainBar() | Deltares.Standard.Forms.DExpress.GeometryEditor |
GetMainBarManager() | Deltares.Standard.Forms.DExpress.GeometryEditor |
GridVisible | Deltares.Standard.Forms.DExpress.GeometryEditor |
IsEnabled(string property) | Deltares.Standard.Forms.DExpress.GeometryEditor |
IsNonEditableMode | Deltares.Standard.Forms.DExpress.GeometryEditor |
IsVisible(string property) | Deltares.Standard.Forms.DExpress.GeometryEditor |
IsZoomRectange | Deltares.Standard.Forms.DExpress.GeometryEditor |
MainBar (defined in Deltares.Standard.Forms.DExpress.GeometryEditor) | Deltares.Standard.Forms.DExpress.GeometryEditor |
MainBarManager (defined in Deltares.Standard.Forms.DExpress.GeometryEditor) | Deltares.Standard.Forms.DExpress.GeometryEditor |
MStabGraphicInputBarSelectionItem (defined in Deltares.Standard.Forms.DExpress.GeometryEditor) | Deltares.Standard.Forms.DExpress.GeometryEditor |
objectContextMenu (defined in Deltares.Standard.Forms.DExpress.GeometryEditor) | Deltares.Standard.Forms.DExpress.GeometryEditor |
OnClickMStabGraphicInputBarSelectionItem(object sender, ItemClickEventArgs e) | Deltares.Standard.Forms.DExpress.GeometryEditor |
OnDragDropEndEvent | Deltares.Standard.Forms.DExpress.GeometryEditor |
OnPopupMenu | Deltares.Standard.Forms.DExpress.GeometryEditor |
OnShapeAction(object geometryObject, ShapeAction action, PointF point, IShape shape) | Deltares.Standard.Forms.DExpress.GeometryEditor |
RedrawView() | Deltares.Standard.Forms.DExpress.GeometryEditor |
RegisterComponentsToReloadUI(IReloadManager aReloadManager) | Deltares.Standard.Forms.DExpress.GeometryEditor |
RegisterUIComponent(IReloadManager aReloadManager) | Deltares.Standard.Forms.DExpress.GeometryEditor |
Reload() | Deltares.Standard.Forms.DExpress.GeometryEditor |
RemoveObject(object anObject) | Deltares.Standard.Forms.DExpress.GeometryEditor |
SelectedObjectCount | Deltares.Standard.Forms.DExpress.GeometryEditor |
SelectedObjects | Deltares.Standard.Forms.DExpress.GeometryEditor |
SetInsertMode(bool showCommandLineWindow) | Deltares.Standard.Forms.DExpress.GeometryEditor |
SetupViewEditor() | Deltares.Standard.Forms.DExpress.GeometryEditor |
ShowSelectedNonvisibleItems() | Deltares.Standard.Forms.DExpress.GeometryEditor |
SpatialEditor | Deltares.Standard.Forms.DExpress.GeometryEditor |
StatusString | Deltares.Standard.Forms.DExpress.GeometryEditor |
SurpressSpatialSelection (defined in Deltares.Standard.Forms.DExpress.GeometryEditor) | Deltares.Standard.Forms.DExpress.GeometryEditor |
UpdateData(params object[] models) | Deltares.Standard.Forms.DExpress.GeometryEditor |
ZoomInBarItem (defined in Deltares.Standard.Forms.DExpress.GeometryEditor) | Deltares.Standard.Forms.DExpress.GeometryEditor | package
ZoomOutBarItem (defined in Deltares.Standard.Forms.DExpress.GeometryEditor) | Deltares.Standard.Forms.DExpress.GeometryEditor | package
ZoomToExtends(object sender, EventArgs e) | Deltares.Standard.Forms.DExpress.GeometryEditor |
Generated on Tue Dec 15 2015 18:14:53 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.GeoPropertyGrid Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • GeoPropertyGrid
Public Member Functions | Protected Member Functions | Properties | Events | List of all members
Deltares.Standard.Forms.DExpress.GeoPropertyGrid Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.GeoPropertyGrid:
Deltares.Standard.Forms.IPropertyControl

Public Member Functions

void | RefreshControl ()
void | RefreshObject (object changedObject, bool isSelected)
refreshes the object selection in the grid More...
void | FocusData (object data)
focus the paticular data displayed in the property control More...
bool | IsValidObject (object identifierObject, object changedObject)
checks if the object falls under the current displayed category More...
void | OnLoadPropertyControl ()
when the control is loaded to the property window More...
void | ReloadPropertyGrid ()
void | SetPropertyOrder (Dictionary< string, int > sortorder)
void | AddGridItems (object aItem)
void | SetRowSelection (string property)
void | ClearPropertyGridItems ()
void | AddNewRow (string aCaption, string aPropertyText)
void | ReloadUI ()
ReloadUI - update on language/Unit change More...
void | UpdateDataObject ()

Protected Member Functions

override void Dispose (bool disposing)

Properties

List< ValidationResult > | InValidProperties [get, set]
ToolTipController | RowHeaderToolTip [get, set]
ToolTip for RowHeader when the text is not fully visble.Properties of tooltip such as AutoPopupDalay Can Be Set Here. More...
bool | ShowToolTipOnIndexer [get, set]
Gets or Sets wether RowHeaderToolTip is shown on Indexer Area. More...
bool | IsRepositorySet [get, set]
bool | ToShowDefaultDescription [get, set]
bool | IsMultiselectObject [get, set]
indicates if the control shows a multiselect object More...
bool | IsSelectionChanging [get]
Gets or sets a value indicating if the controls internal selection is changing More...
bool | IsVisible [get]
- Properties inherited from Deltares.Standard.Forms.IPropertyControl
string | Name [get, set]
Gets or sets the name to be displayed property. More...
object | SelectedObject [get, set]
Gets or sets the object to be displayed in the property window. More...
bool | IsVisible [get]
Whether or not the property control should be displayed. More...

Events

new NewItemButtonHandler OnClick

Member Function Documentation

void Deltares.Standard.Forms.DExpress.GeoPropertyGrid.FocusData ( object data )

focus the paticular data displayed in the property control

Parameters
data data displayed in the property control
bool Deltares.Standard.Forms.DExpress.GeoPropertyGrid.IsValidObject | ( | object | identifierObject,
 |  | object | changedObject
 | ) |  |

checks if the object falls under the current displayed category

Parameters
changedObject new selected object
Returns
True if the object falls under current category else false
void Deltares.Standard.Forms.DExpress.GeoPropertyGrid.OnLoadPropertyControl ( )

when the control is loaded to the property window

void Deltares.Standard.Forms.DExpress.GeoPropertyGrid.RefreshObject | ( | object | changedObject,
 |  | bool | isSelected
 | ) |  |

refreshes the object selection in the grid

Parameters
changedObject | modified object
isSelected | selection state of the object
Returns
true if (the object is displayed by the control/changed object is invalid) else false
void Deltares.Standard.Forms.DExpress.GeoPropertyGrid.ReloadUI ( )

ReloadUI - update on language/Unit change

Property Documentation

bool Deltares.Standard.Forms.DExpress.GeoPropertyGrid.IsMultiselectObject
getset

indicates if the control shows a multiselect object

bool Deltares.Standard.Forms.DExpress.GeoPropertyGrid.IsSelectionChanging
get

Gets or sets a value indicating if the controls internal selection is changing

ToolTipController Deltares.Standard.Forms.DExpress.GeoPropertyGrid.RowHeaderToolTip
getset

ToolTip for RowHeader when the text is not fully visble.Properties of tooltip such as AutoPopupDalay Can Be Set Here.

bool Deltares.Standard.Forms.DExpress.GeoPropertyGrid.ShowToolTipOnIndexer
getset

Gets or Sets wether RowHeaderToolTip is shown on Indexer Area.

Generated on Tue Dec 15 2015 18:14:53 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • GeoPropertyGrid
Deltares.Standard.Forms.DExpress.GeoPropertyGrid Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.GeoPropertyGrid, including all inherited members.

AddGridItems(object aItem) (defined in Deltares.Standard.Forms.DExpress.GeoPropertyGrid) | Deltares.Standard.Forms.DExpress.GeoPropertyGrid |
AddNewRow(string aCaption, string aPropertyText) (defined in Deltares.Standard.Forms.DExpress.GeoPropertyGrid) | Deltares.Standard.Forms.DExpress.GeoPropertyGrid |
ClearPropertyGridItems() (defined in Deltares.Standard.Forms.DExpress.GeoPropertyGrid) | Deltares.Standard.Forms.DExpress.GeoPropertyGrid |
Dispose(bool disposing) (defined in Deltares.Standard.Forms.DExpress.GeoPropertyGrid) | Deltares.Standard.Forms.DExpress.GeoPropertyGrid | protected
FocusData(object data) | Deltares.Standard.Forms.DExpress.GeoPropertyGrid |
GeoPropertyGrid() (defined in Deltares.Standard.Forms.DExpress.GeoPropertyGrid) | Deltares.Standard.Forms.DExpress.GeoPropertyGrid |
InValidProperties (defined in Deltares.Standard.Forms.DExpress.GeoPropertyGrid) | Deltares.Standard.Forms.DExpress.GeoPropertyGrid |
IsMultiselectObject | Deltares.Standard.Forms.DExpress.GeoPropertyGrid |
IsRepositorySet (defined in Deltares.Standard.Forms.DExpress.GeoPropertyGrid) | Deltares.Standard.Forms.DExpress.GeoPropertyGrid |
IsSelectionChanging | Deltares.Standard.Forms.DExpress.GeoPropertyGrid |
IsValidObject(object identifierObject, object changedObject) | Deltares.Standard.Forms.DExpress.GeoPropertyGrid |
IsVisible (defined in Deltares.Standard.Forms.DExpress.GeoPropertyGrid) | Deltares.Standard.Forms.DExpress.GeoPropertyGrid |
OnClick (defined in Deltares.Standard.Forms.DExpress.GeoPropertyGrid) | Deltares.Standard.Forms.DExpress.GeoPropertyGrid |
OnLoadPropertyControl() | Deltares.Standard.Forms.DExpress.GeoPropertyGrid |
RefreshControl() (defined in Deltares.Standard.Forms.DExpress.GeoPropertyGrid) | Deltares.Standard.Forms.DExpress.GeoPropertyGrid |
RefreshObject(object changedObject, bool isSelected) | Deltares.Standard.Forms.DExpress.GeoPropertyGrid |
ReloadPropertyGrid() (defined in Deltares.Standard.Forms.DExpress.GeoPropertyGrid) | Deltares.Standard.Forms.DExpress.GeoPropertyGrid |
ReloadUI() | Deltares.Standard.Forms.DExpress.GeoPropertyGrid |
RowHeaderToolTip | Deltares.Standard.Forms.DExpress.GeoPropertyGrid |
SetPropertyOrder(Dictionary< string, int > sortorder) (defined in Deltares.Standard.Forms.DExpress.GeoPropertyGrid) | Deltares.Standard.Forms.DExpress.GeoPropertyGrid |
SetRowSelection(string property) (defined in Deltares.Standard.Forms.DExpress.GeoPropertyGrid) | Deltares.Standard.Forms.DExpress.GeoPropertyGrid |
ShowToolTipOnIndexer | Deltares.Standard.Forms.DExpress.GeoPropertyGrid |
ToShowDefaultDescription (defined in Deltares.Standard.Forms.DExpress.GeoPropertyGrid) | Deltares.Standard.Forms.DExpress.GeoPropertyGrid |
UpdateDataObject() (defined in Deltares.Standard.Forms.DExpress.GeoPropertyGrid) | Deltares.Standard.Forms.DExpress.GeoPropertyGrid |
Generated on Tue Dec 15 2015 18:14:53 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.GeoRepositoryTextEdit Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • GeoRepositoryTextEdit
Public Member Functions | Properties | List of all members
Deltares.Standard.Forms.DExpress.GeoRepositoryTextEdit Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.GeoRepositoryTextEdit:

Public Member Functions

string | GetColumnCaption ()
int | GetDisplayOrder ()
string | GetPropertyCategory ()
UnitType | GetPropertyUnitType ()
void | SetPropertyValues (Type aTargetType, string aPropertyName)
void | SetPropertyValues (Type aTargetType, Attribute[] AttributeArray)

Properties

string | GetPropertyName [get]
double | MinimumRange [get, set]
double | MaximumRange [get, set]
bool | IsToolTipVisible [get, set]
bool | IsUnitsAlreadySet [get, set]
Generated on Tue Dec 15 2015 18:14:54 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • GeoRepositoryTextEdit
Deltares.Standard.Forms.DExpress.GeoRepositoryTextEdit Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.GeoRepositoryTextEdit, including all inherited members.

GeoRepositoryTextEdit() (defined in Deltares.Standard.Forms.DExpress.GeoRepositoryTextEdit) | Deltares.Standard.Forms.DExpress.GeoRepositoryTextEdit
GetColumnCaption() (defined in Deltares.Standard.Forms.DExpress.GeoRepositoryTextEdit) | Deltares.Standard.Forms.DExpress.GeoRepositoryTextEdit
GetDisplayOrder() (defined in Deltares.Standard.Forms.DExpress.GeoRepositoryTextEdit) | Deltares.Standard.Forms.DExpress.GeoRepositoryTextEdit
GetPropertyCategory() (defined in Deltares.Standard.Forms.DExpress.GeoRepositoryTextEdit) | Deltares.Standard.Forms.DExpress.GeoRepositoryTextEdit
GetPropertyName (defined in Deltares.Standard.Forms.DExpress.GeoRepositoryTextEdit) | Deltares.Standard.Forms.DExpress.GeoRepositoryTextEdit
GetPropertyUnitType() (defined in Deltares.Standard.Forms.DExpress.GeoRepositoryTextEdit) | Deltares.Standard.Forms.DExpress.GeoRepositoryTextEdit
IsToolTipVisible (defined in Deltares.Standard.Forms.DExpress.GeoRepositoryTextEdit) | Deltares.Standard.Forms.DExpress.GeoRepositoryTextEdit
IsUnitsAlreadySet (defined in Deltares.Standard.Forms.DExpress.GeoRepositoryTextEdit) | Deltares.Standard.Forms.DExpress.GeoRepositoryTextEdit
MaximumRange (defined in Deltares.Standard.Forms.DExpress.GeoRepositoryTextEdit) | Deltares.Standard.Forms.DExpress.GeoRepositoryTextEdit
MinimumRange (defined in Deltares.Standard.Forms.DExpress.GeoRepositoryTextEdit) | Deltares.Standard.Forms.DExpress.GeoRepositoryTextEdit
SetPropertyValues(Type aTargetType, string aPropertyName) (defined in Deltares.Standard.Forms.DExpress.GeoRepositoryTextEdit) | Deltares.Standard.Forms.DExpress.GeoRepositoryTextEdit
SetPropertyValues(Type aTargetType, Attribute[] AttributeArray) (defined in Deltares.Standard.Forms.DExpress.GeoRepositoryTextEdit) | Deltares.Standard.Forms.DExpress.GeoRepositoryTextEdit
Generated on Tue Dec 15 2015 18:14:54 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.GreaterThanStrategy Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • GreaterThanStrategy
Public Member Functions | Protected Member Functions | List of all members
Deltares.Standard.Forms.DExpress.GreaterThanStrategy Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.GreaterThanStrategy:
Deltares.Standard.Forms.DExpress.GridEditValueStrategy

Public Member Functions

override double | DefaultForSelected (GridView view)
Determines the default value based on the selected values. Not all implementations will use the selected values, but by passing the view, we can generalize the method call. More...
override string | ToString ()
This method has to be overridden so it has a proper representation in the UI. More...
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.GridEditValueStrategy
void | EvaluateForSelected (GridView view, double modificationValue)
Sets new cell values by evaluating the modification value and using the current strategy. More...

Protected Member Functions

override double Evaluate (double value, double modificationValue)
The implementation of this method is used in the EvaluateForSelected method. More...

Additional Inherited Members

- Static Public Attributes inherited from Deltares.Standard.Forms.DExpress.GridEditValueStrategy
static readonly GridEditValueStrategy[] Strategies
Collection of all the strategies which are defined in this file. This is a static list so the strategies will only be instantiated once. Using instantiations make polymorphism possible. More...

Member Function Documentation

override double Deltares.Standard.Forms.DExpress.GreaterThanStrategy.DefaultForSelected ( GridView view )
virtual

Determines the default value based on the selected values. Not all implementations will use the selected values, but by passing the view, we can generalize the method call.

Parameters
view The view (which may not be used at all) containing selected values (or not).
Returns
A sensible default for the strategy, or null if no sensible default can be given.

Implements Deltares.Standard.Forms.DExpress.GridEditValueStrategy.

override double Deltares.Standard.Forms.DExpress.GreaterThanStrategy.Evaluate | ( | double | value,
 |  | double | modificationValue
 | ) |  |
protectedvirtual

The implementation of this method is used in the EvaluateForSelected method.

Parameters
value | The current value.
modificationValue | The value used in evaluating a new value.
Returns
The new value.

Implements Deltares.Standard.Forms.DExpress.GridEditValueStrategy.

override string Deltares.Standard.Forms.DExpress.GreaterThanStrategy.ToString ( )
virtual

This method has to be overridden so it has a proper representation in the UI.

Returns

Implements Deltares.Standard.Forms.DExpress.GridEditValueStrategy.

Generated on Tue Dec 15 2015 18:14:54 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • GreaterThanStrategy
Deltares.Standard.Forms.DExpress.GreaterThanStrategy Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.GreaterThanStrategy, including all inherited members.

DefaultForSelected(GridView view) | Deltares.Standard.Forms.DExpress.GreaterThanStrategy | virtual
Evaluate(double value, double modificationValue) | Deltares.Standard.Forms.DExpress.GreaterThanStrategy | protectedvirtual
EvaluateForSelected(GridView view, double modificationValue) | Deltares.Standard.Forms.DExpress.GridEditValueStrategy |
Strategies | Deltares.Standard.Forms.DExpress.GridEditValueStrategy | static
ToString() | Deltares.Standard.Forms.DExpress.GreaterThanStrategy | virtual
Generated on Tue Dec 15 2015 18:14:54 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.GridColumnBinding Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • GridColumnBinding
Public Member Functions | Properties | List of all members
Deltares.Standard.Forms.DExpress.GridColumnBinding Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.GridColumnBinding:
Deltares.Standard.Forms.DExpress.ComponentBinding Deltares.Standard.Forms.DExpress.ComponentWrappers.IGetBoundControl

Public Member Functions

GridColumnBinding (Component component)
override void | SetEnabled (bool enabled)
override void | SetVisible (bool visible)
override void | SetLabel (string text)
override void | SetDescription (string description)
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
ComponentBinding (Component component)
virtual void | Initialize (BindPropertyInfo propertyInfo, params string[] properties)
virtual void | Initialize (BindPropertyInfo propertyInfo, Type rootObjectType, params string[] properties)
virtual void | SetTrueMapping (object trueMapping)
virtual void | SetValue (object value)
virtual void | SetValue (object value, object parent)
virtual void | SetDomain (ICollection collection)
virtual object | GetValue ()
virtual void | SetForegroundColor (Color color)
virtual void | SetBackgroundColor (Color color)
virtual void | Refresh ()
virtual void | Invalidate ()
virtual void | RegisterSelectionAssignment (Component targetComponent, IConverter converter=null)
Indicates that the selection of the bound control must be assigned to another control. More...
virtual void | SetControlColors (Color fore, Color back)
Sets the controls foreground and background colors. Can be overridden by a specific binding to set other colors if necessary. More...

Properties

override bool | IsTransparant [get]
Control | BoundControl [get]
- Properties inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
Component | Component [get]
virtual bool | IsTransparant [get]
virtual HandleType | HandleDelayed [get]
virtual bool | HasDomain [get]
- Properties inherited from Deltares.Standard.Forms.DExpress.ComponentWrappers.IGetBoundControl
Control | BoundControl [get]

Additional Inherited Members

- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
void | RaiseValueChanged ()
void | RaiseLeave ()
void | RaiseActionPerformed ()
Type | GetGenericType (Type type)
string | ValueToString (object value)
bool | IsAssociatedPropertyVisible (object source, BindPropertyInfo associatedPropertyInfo)
Indicates whether the associated property (i.e. the property which is used to display the original property in a textbox) is visible More...
void | EditFileInfo (object source, BindPropertyInfo propertyInfo)
string | EditFileInfo (string value, string format, string label, string description, bool isDirectory)
string | GetDoubleString (string text)
bool | HasValidNumericValue (string text)
double | GetNumericValue (string text)
List< BindPropertyInfo > | GetDictionaryProperties (ICollection domain, BindPropertyInfo dynamicPropertyInfo)
- Protected Attributes inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
BindPropertyInfo | propInfo
- Events inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
EventHandler< EventArgs > | ActionPerformed
EventHandler< EventArgs > | Leave
EventHandler< EventArgs > | ValueChanged
Generated on Tue Dec 15 2015 18:14:54 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • GridColumnBinding
Deltares.Standard.Forms.DExpress.GridColumnBinding Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.GridColumnBinding, including all inherited members.

ActionPerformed (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
BoundControl (defined in Deltares.Standard.Forms.DExpress.GridColumnBinding) | Deltares.Standard.Forms.DExpress.GridColumnBinding |
Component (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ComponentBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
EditFileInfo(object source, BindPropertyInfo propertyInfo) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
EditFileInfo(string value, string format, string label, string description, bool isDirectory) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetDictionaryProperties(ICollection domain, BindPropertyInfo dynamicPropertyInfo) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetDoubleString(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetGenericType(Type type) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetNumericValue(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetValue() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
GridColumnBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.GridColumnBinding) | Deltares.Standard.Forms.DExpress.GridColumnBinding |
HandleDelayed (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
HasDomain (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
HasValidNumericValue(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Initialize(BindPropertyInfo propertyInfo, params string[] properties) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
Initialize(BindPropertyInfo propertyInfo, Type rootObjectType, params string[] properties) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
Invalidate() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
IsAssociatedPropertyVisible(object source, BindPropertyInfo associatedPropertyInfo) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
IsTransparant (defined in Deltares.Standard.Forms.DExpress.GridColumnBinding) | Deltares.Standard.Forms.DExpress.GridColumnBinding |
Leave (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
propInfo (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseActionPerformed() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseLeave() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseValueChanged() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Refresh() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
RegisterSelectionAssignment(Component targetComponent, IConverter converter=null) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetBackgroundColor(Color color) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetControlColors(Color fore, Color back) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetDescription(string description) (defined in Deltares.Standard.Forms.DExpress.GridColumnBinding) | Deltares.Standard.Forms.DExpress.GridColumnBinding | virtual
SetDomain(ICollection collection) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetEnabled(bool enabled) (defined in Deltares.Standard.Forms.DExpress.GridColumnBinding) | Deltares.Standard.Forms.DExpress.GridColumnBinding | virtual
SetForegroundColor(Color color) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetLabel(string text) (defined in Deltares.Standard.Forms.DExpress.GridColumnBinding) | Deltares.Standard.Forms.DExpress.GridColumnBinding | virtual
SetTrueMapping(object trueMapping) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetValue(object value) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetValue(object value, object parent) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetVisible(bool visible) (defined in Deltares.Standard.Forms.DExpress.GridColumnBinding) | Deltares.Standard.Forms.DExpress.GridColumnBinding | virtual
ValueChanged (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ValueToString(object value) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Generated on Tue Dec 15 2015 18:14:54 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.GridControlBinding Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • GridControlBinding
Public Member Functions | Protected Member Functions | List of all members
Deltares.Standard.Forms.DExpress.GridControlBinding Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.GridControlBinding:
Deltares.Standard.Forms.DExpress.ControlBinding Deltares.Standard.Forms.DExpress.ComponentBinding Deltares.Standard.Forms.DExpress.ComponentWrappers.IGetBoundControl

Public Member Functions

GridControlBinding (Component component)
override void | Refresh ()
override void | Initialize (BindPropertyInfo propertyInfo, Type rootObjectType, params string[] properties)
override void | Initialize (BindPropertyInfo propertyInfo, params string[] properties)
override void | SetValue (object value)
override void | SetEnabled (bool enabled)
override void | SetDescription (string description)
Sets the textual description associated with this control. More...
override void | RegisterSelectionAssignment (Component targetComponent, IConverter converter=null)
Indicates that the selection of the bound control must be assigned to another control. More...
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.ControlBinding
override void | SetVisible (bool visible)
override void | SetLabel (string text)
Sets the label/title/name associated with this control. More...
override void | SetForegroundColor (Color color)
override void | SetBackgroundColor (Color color)
override void | Invalidate ()
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
ComponentBinding (Component component)
virtual void | SetTrueMapping (object trueMapping)
virtual void | SetValue (object value, object parent)
virtual void | SetDomain (ICollection collection)
virtual object | GetValue ()
virtual void | SetControlColors (Color fore, Color back)
Sets the controls foreground and background colors. Can be overridden by a specific binding to set other colors if necessary. More...

Protected Member Functions

override void | Dispose (bool disposing)
- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.ControlBinding
ControlBinding (Component component)
virtual void | OnToolTipShown (PopupEventArgs e)
Called when Tooltip is shown, and fires ToolTipShown event. More...
virtual void | OnToolTipClosed ()
Called when Tooltip is hidden, and fires ToolTipHidden. More...
void | ThreadSafeRefresh ()
override void | Dispose (bool disposing)
- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
void | RaiseValueChanged ()
void | RaiseLeave ()
void | RaiseActionPerformed ()
Type | GetGenericType (Type type)
string | ValueToString (object value)
bool | IsAssociatedPropertyVisible (object source, BindPropertyInfo associatedPropertyInfo)
Indicates whether the associated property (i.e. the property which is used to display the original property in a textbox) is visible More...
void | EditFileInfo (object source, BindPropertyInfo propertyInfo)
string | EditFileInfo (string value, string format, string label, string description, bool isDirectory)
string | GetDoubleString (string text)
bool | HasValidNumericValue (string text)
double | GetNumericValue (string text)
List< BindPropertyInfo > | GetDictionaryProperties (ICollection domain, BindPropertyInfo dynamicPropertyInfo)

Additional Inherited Members

- Protected Attributes inherited from Deltares.Standard.Forms.DExpress.ControlBinding
readonly ToolTip | tooltip
string | Description
The textual description associated with this

See also
Control

. More...

string | Label
The label/title/name associated with this Control. More...
- Protected Attributes inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
BindPropertyInfo | propInfo
- Properties inherited from Deltares.Standard.Forms.DExpress.ControlBinding
ToolTip | Tooltip [get]
Gets the tooltip for the bound control. More...
Control | BoundControl [get]
- Properties inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
Component | Component [get]
virtual bool | IsTransparant [get]
virtual HandleType | HandleDelayed [get]
virtual bool | HasDomain [get]
- Properties inherited from Deltares.Standard.Forms.DExpress.ComponentWrappers.IGetBoundControl
Control | BoundControl [get]
- Events inherited from Deltares.Standard.Forms.DExpress.ControlBinding
ToolTipVisibilityEventHandler | ToolTipHidden
ToolTipVisibilityEventHandler | ToolTipShown
- Events inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
EventHandler< EventArgs > | ActionPerformed
EventHandler< EventArgs > | Leave
EventHandler< EventArgs > | ValueChanged

Member Function Documentation

override void Deltares.Standard.Forms.DExpress.GridControlBinding.RegisterSelectionAssignment | ( | Component | targetComponent,
 |  | IConverter | converter = null
 | ) |  |
virtual

Indicates that the selection of the bound control must be assigned to another control.

Parameters
targetComponent | The control the selection should be assigned to
converter | Optional converter which converts the selected object within the bound control to another object, which will be used for assignment.

In case the bound control support selection of multiple items, the component binding should determine a proper solution in case targetComponent doesn't also support assignment of multiple items.

Reimplemented from Deltares.Standard.Forms.DExpress.ComponentBinding.

override void Deltares.Standard.Forms.DExpress.GridControlBinding.SetDescription ( string description )
virtual

Sets the textual description associated with this control.

Parameters
description The description text; Use string.Empty to clear.

Reimplemented from Deltares.Standard.Forms.DExpress.ControlBinding.

Generated on Tue Dec 15 2015 18:14:55 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • GridControlBinding
Deltares.Standard.Forms.DExpress.GridControlBinding Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.GridControlBinding, including all inherited members.

ActionPerformed (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
BoundControl (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding |
Component (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ComponentBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ControlBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Description | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Dispose(bool disposing) (defined in Deltares.Standard.Forms.DExpress.GridControlBinding) | Deltares.Standard.Forms.DExpress.GridControlBinding | protected
EditFileInfo(object source, BindPropertyInfo propertyInfo) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
EditFileInfo(string value, string format, string label, string description, bool isDirectory) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetDictionaryProperties(ICollection domain, BindPropertyInfo dynamicPropertyInfo) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetDoubleString(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetGenericType(Type type) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetNumericValue(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetValue() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
GridControlBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.GridControlBinding) | Deltares.Standard.Forms.DExpress.GridControlBinding |
HandleDelayed (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
HasDomain (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
HasValidNumericValue(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Initialize(BindPropertyInfo propertyInfo, Type rootObjectType, params string[] properties) (defined in Deltares.Standard.Forms.DExpress.GridControlBinding) | Deltares.Standard.Forms.DExpress.GridControlBinding | virtual
Initialize(BindPropertyInfo propertyInfo, params string[] properties) (defined in Deltares.Standard.Forms.DExpress.GridControlBinding) | Deltares.Standard.Forms.DExpress.GridControlBinding | virtual
Invalidate() (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
IsAssociatedPropertyVisible(object source, BindPropertyInfo associatedPropertyInfo) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
IsTransparant (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
Label | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Leave (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
OnToolTipClosed() | Deltares.Standard.Forms.DExpress.ControlBinding | protectedvirtual
OnToolTipShown(PopupEventArgs e) | Deltares.Standard.Forms.DExpress.ControlBinding | protectedvirtual
propInfo (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseActionPerformed() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseLeave() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseValueChanged() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Refresh() (defined in Deltares.Standard.Forms.DExpress.GridControlBinding) | Deltares.Standard.Forms.DExpress.GridControlBinding | virtual
RegisterSelectionAssignment(Component targetComponent, IConverter converter=null) | Deltares.Standard.Forms.DExpress.GridControlBinding | virtual
SetBackgroundColor(Color color) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
SetControlColors(Color fore, Color back) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetDescription(string description) | Deltares.Standard.Forms.DExpress.GridControlBinding | virtual
SetDomain(ICollection collection) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetEnabled(bool enabled) (defined in Deltares.Standard.Forms.DExpress.GridControlBinding) | Deltares.Standard.Forms.DExpress.GridControlBinding | virtual
SetForegroundColor(Color color) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
SetLabel(string text) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
SetTrueMapping(object trueMapping) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetValue(object value) (defined in Deltares.Standard.Forms.DExpress.GridControlBinding) | Deltares.Standard.Forms.DExpress.GridControlBinding | virtual
SetValue(object value, object parent) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetVisible(bool visible) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
ThreadSafeRefresh() (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Tooltip | Deltares.Standard.Forms.DExpress.ControlBinding | protected
tooltip (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | protected
ToolTipHidden (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding |
ToolTipShown (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding |
ValueChanged (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ValueToString(object value) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Generated on Tue Dec 15 2015 18:14:55 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.GridEditValueStrategy Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • GridEditValueStrategy
Public Member Functions | Static Public Attributes | Protected Member Functions | List of all members
Deltares.Standard.Forms.DExpress.GridEditValueStrategy Class Referenceabstract

This class represents an edit action which can be performed on cell values. These so called GridEditValueStrategies take a gridview and finds the selected cell values for which each strategy can determine a sensible default value and/or can edit the value based on an entered "edit value". More...

Inheritance diagram for Deltares.Standard.Forms.DExpress.GridEditValueStrategy:
Deltares.Standard.Forms.DExpress.AssignStrategy Deltares.Standard.Forms.DExpress.DivideStrategy Deltares.Standard.Forms.DExpress.GreaterThanStrategy Deltares.Standard.Forms.DExpress.LessThanStrategy Deltares.Standard.Forms.DExpress.MinusStrategy Deltares.Standard.Forms.DExpress.MultiplyStrategy Deltares.Standard.Forms.DExpress.PlusStrategy

Public Member Functions

void | EvaluateForSelected (GridView view, double modificationValue)
Sets new cell values by evaluating the modification value and using the current strategy. More...
abstract double | DefaultForSelected (GridView view)
Determines the default value based on the selected values. Not all implementations will use the selected values, but by passing the view, we can generalize the method call. More...
abstract override string | ToString ()
This method has to be overridden so it has a proper representation in the UI. More...

Static Public Attributes

static readonly GridEditValueStrategy[] Strategies
Collection of all the strategies which are defined in this file. This is a static list so the strategies will only be instantiated once. Using instantiations make polymorphism possible. More...

Protected Member Functions

abstract double Evaluate (double value, double modificationValue)
The implementation of this method is used in the EvaluateForSelected method. More...

Detailed Description

This class represents an edit action which can be performed on cell values. These so called GridEditValueStrategies take a gridview and finds the selected cell values for which each strategy can determine a sensible default value and/or can edit the value based on an entered "edit value".

Member Function Documentation

abstract double Deltares.Standard.Forms.DExpress.GridEditValueStrategy.DefaultForSelected ( GridView view )
pure virtual

Determines the default value based on the selected values. Not all implementations will use the selected values, but by passing the view, we can generalize the method call.

Parameters
view The view (which may not be used at all) containing selected values (or not).
Returns
A sensible default for the strategy, or null if no sensible default can be given.

Implemented in Deltares.Standard.Forms.DExpress.GreaterThanStrategy, Deltares.Standard.Forms.DExpress.LessThanStrategy, Deltares.Standard.Forms.DExpress.DivideStrategy, Deltares.Standard.Forms.DExpress.MultiplyStrategy, Deltares.Standard.Forms.DExpress.MinusStrategy, Deltares.Standard.Forms.DExpress.PlusStrategy, and Deltares.Standard.Forms.DExpress.AssignStrategy.

abstract double Deltares.Standard.Forms.DExpress.GridEditValueStrategy.Evaluate | ( | double | value,
 |  | double | modificationValue
 | ) |  |
protectedpure virtual

The implementation of this method is used in the EvaluateForSelected method.

Parameters
value | The current value.
modificationValue | The value used in evaluating a new value.
Returns
The new value.

Implemented in Deltares.Standard.Forms.DExpress.GreaterThanStrategy, Deltares.Standard.Forms.DExpress.LessThanStrategy, Deltares.Standard.Forms.DExpress.DivideStrategy, Deltares.Standard.Forms.DExpress.MultiplyStrategy, Deltares.Standard.Forms.DExpress.MinusStrategy, Deltares.Standard.Forms.DExpress.PlusStrategy, and Deltares.Standard.Forms.DExpress.AssignStrategy.

void Deltares.Standard.Forms.DExpress.GridEditValueStrategy.EvaluateForSelected | ( | GridView | view,
 |  | double | modificationValue
 | ) |  |

Sets new cell values by evaluating the modification value and using the current strategy.

Parameters
view | The GridView which may (or may not) contain selected cells.
modificationValue | The value which is used by the strategy to determine the new value.
abstract override string Deltares.Standard.Forms.DExpress.GridEditValueStrategy.ToString ( )
pure virtual

This method has to be overridden so it has a proper representation in the UI.

Returns

Implemented in Deltares.Standard.Forms.DExpress.GreaterThanStrategy, Deltares.Standard.Forms.DExpress.LessThanStrategy, Deltares.Standard.Forms.DExpress.DivideStrategy, Deltares.Standard.Forms.DExpress.MultiplyStrategy, Deltares.Standard.Forms.DExpress.MinusStrategy, Deltares.Standard.Forms.DExpress.PlusStrategy, and Deltares.Standard.Forms.DExpress.AssignStrategy.

Member Data Documentation

readonly GridEditValueStrategy [] Deltares.Standard.Forms.DExpress.GridEditValueStrategy.Strategies
static
Initial value:
=
{
new AssignStrategy(),
new PlusStrategy(),
new MinusStrategy(),
new MultiplyStrategy(),
new DivideStrategy(),
new LessThanStrategy(),
new GreaterThanStrategy()
}

Collection of all the strategies which are defined in this file. This is a static list so the strategies will only be instantiated once. Using instantiations make polymorphism possible.

Generated on Tue Dec 15 2015 18:14:55 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • GridEditValueStrategy
Deltares.Standard.Forms.DExpress.GridEditValueStrategy Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.GridEditValueStrategy, including all inherited members.

DefaultForSelected(GridView view) | Deltares.Standard.Forms.DExpress.GridEditValueStrategy | pure virtual
Evaluate(double value, double modificationValue) | Deltares.Standard.Forms.DExpress.GridEditValueStrategy | protectedpure virtual
EvaluateForSelected(GridView view, double modificationValue) | Deltares.Standard.Forms.DExpress.GridEditValueStrategy |
Strategies | Deltares.Standard.Forms.DExpress.GridEditValueStrategy | static
ToString() | Deltares.Standard.Forms.DExpress.GridEditValueStrategy | pure virtual
Generated on Tue Dec 15 2015 18:14:55 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.GridViewControl Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • GridViewControl
Public Member Functions | Static Public Member Functions | Public Attributes | Protected Member Functions | Protected Attributes | Properties | Events | List of all members
Deltares.Standard.Forms.DExpress.GridViewControl Class Reference

Generic Grid Control extend from DXGridControl More...

Inheritance diagram for Deltares.Standard.Forms.DExpress.GridViewControl:
Deltares.Standard.Forms.IGridViewControl Deltares.Standard.Forms.IGridController

Public Member Functions

GridViewControl ()
Initializes a new instance of the GeoGrid class. More...
void | ReloadUI ()
ReloadUI - update on language/Unit change More...
void | SelectColumnFilterAll ()
Allows clients to reset the user column filter to the filter 'all'. More...
void | SetLocalizedString ()
Sets the Localized string to Bar items More...
void | InsertRow ()
If new object is not added to datasource, it is inserted as publisherEventArgs copy of focused row after it, if any. More...
void | AddRow ()
If new object is not added to datasource//, it is added as publisherEventArgs copy of focused row, if any. More...
void | InsertRow (int index)
Inserts a row at the given index. More...
void | DeleteRow (int index)
Removes an item at the given index in the collection which is bound to the grid control. More...
object | Append (int index=-1)
Append a new record at the end of the table, or at the specified row index. More...
object | RemoveAt (int index)
Removes the DataSource type of object using the collection at the specified index. More...
override void | Refresh ()
Forces the control to invalidate its client area and immediately redraw itself and any child controls. More...
object | GetControl ()
Gets the control. More...
IEnumerable< Component > | GetChildComponents ()
bool | IsVisible (string property)
Determines whether the specified property is visible. More...
bool | IsEnabled (string property)
Determines whether the specified property is enabled. More...
- Public Member Functions inherited from Deltares.Standard.Forms.IGridViewControl
void | Dispose ()

Static Public Member Functions

static double | ParseDouble (string value)
Parses the string value based on the current culture to a double value. More...
static double | ParseDouble (string value, double defaultValue)
Parses the string value based on the current culture to a double value. More...

Public Attributes

PopupMenu | GeoPopupMenu = null
GridControl | GridControl
ImageCollection | TemplateImageCollection
BarDockControl | barDockControl1
Bar | Toolbar
BarEditItem | ExpandAllBarEditItem
GridView | gridView1

Protected Member Functions

void | CutCommand ()
Triggered when the Cut button is clicked. More...
void | CopyCommand ()
Triggered when the Copy button is clicked. More...
void | PasteCommand ()
Triggered when the Paste button is clicked. More...
void | AddRowCommand ()
Triggered when the AddRow button is clicked. More...
void | InsertRowCommand ()
Triggered when the InsertRow button is clicked. More...
void | DeleteRowCommand ()
Triggered when the DeleteRow button is clicked. More...
void | ShowColumnsCommand ()
Triggered when the Show All Column button's check status is changed. More...
void | EditCommand ()
Triggered when the Edit selected cells button is clicked. More...
void | EditUnitCommand ()
void | ExportTable ()
override void | Dispose (bool disposing)

Protected Attributes

readonly CategoryDisplayItem | categoryAll
readonly Panel | controlPanel = new Panel()
Type | itemType = null
BarManager | barManager1

Properties

bool | IsSelectionChanging [get]
Gets a value indicating whether the selection is changing. More...
UserColumnFilters[] | AllowedUserColumnFilters [get, set]
string | Caption [get]
Gets the caption. More...
bool | AllowInserts [get, set]
Gets or sets a value indicating whether inserting is allowed. More...
bool | AllowUserColumnFilterEdit [get, set]
Gets or sets whether the user column filter is enabled. More...
bool | SendSelectionChanged [get, set]
Gets or sets a value indicating whether the send selection has changed. More...
PropertyEditorReactionType | PropertyEditorReactionType [get, set]
Gets or sets the type of the property editor reaction. More...
bool | ShowToolbar [get, set]
Gets or sets a value indicating whether to show the toolbar. More...
static bool | AlwaysAdjustHeightToFit [get, set]
Gets or sets a value indicating whether to always adjust the height to fit. More...
bool | AdjustHeightToFit [get, set]
Gets or sets a value indicating whether to adjust height to fit. More...
CategoryDisplayItem | SelectedCategory [get, set]
Gets or sets the category. More...
UserColumnFilterDisplayItem | SelectedFilter [get, set]
Gets or sets the column filter. More...
IContext | CurrentContext [get, set]
The Context that determines the visibility of the columns. More...
bool | HideUnusedColumns [get, set]
Gets or sets a value indicating whether to hide unused columns. More...
bool | AllowAddDeleteOnly [get, set]
Gets or sets a value indicating whether to allow add delete only. More...
bool | EnableMasterViewMode [get, set]
Indicates whether the grid control can expand to subtables More...
GridView | GridView [get]
Func< object > | CreateNew [set]
Sets the object factory. This factory is responsible for creating a new object of the type that is in the list, bound to this grid control More...
- Properties inherited from Deltares.Standard.Forms.IGridViewControl
string | Caption [get]
bool | AllowInserts [get, set]
- Properties inherited from Deltares.Standard.Forms.IGridController
Func< object > | CreateNew [set]
Sets the object factory method. More...

Events

EventHandler< GridViewChangeArgs > | AfterRowAdd
Event occurs after row is added. More...
EventHandler< GridViewChangeArgs > | AfterRowDelete
Event occurs after row is deleted. More...
EventHandler< GridViewChangeArgs > | AfterRowInsert
Event occurs after row is inserted. More...
EventHandler< GridViewCellChangeArgs > | AfterRowUpdate
Event occurs after row is updated. More...
- Events inherited from Deltares.Standard.Forms.IGridViewControl
EventHandler< GridViewChangeArgs > | AfterRowAdd
EventHandler< GridViewChangeArgs > | AfterRowDelete
EventHandler< GridViewChangeArgs > | AfterRowInsert

Detailed Description

Generic Grid Control extend from DXGridControl

Constructor & Destructor Documentation

Deltares.Standard.Forms.DExpress.GridViewControl.GridViewControl ( )

Initializes a new instance of the GeoGrid class.

References Deltares.Standard.Forms.DExpress.BindSupport.Assign().

Member Function Documentation

void Deltares.Standard.Forms.DExpress.GridViewControl.AddRow ( )

If new object is not added to datasource//, it is added as publisherEventArgs copy of focused row, if any.

<return>Returns the newly created object</return>

Implements Deltares.Standard.Forms.IGridController.

void Deltares.Standard.Forms.DExpress.GridViewControl.AddRowCommand ( )
protected

Triggered when the AddRow button is clicked.

object Deltares.Standard.Forms.DExpress.GridViewControl.Append ( int index = -1 )

Append a new record at the end of the table, or at the specified row index.

void Deltares.Standard.Forms.DExpress.GridViewControl.CopyCommand ( )
protected

Triggered when the Copy button is clicked.

void Deltares.Standard.Forms.DExpress.GridViewControl.CutCommand ( )
protected

Triggered when the Cut button is clicked.

void Deltares.Standard.Forms.DExpress.GridViewControl.DeleteRow ( int index )

Removes an item at the given index in the collection which is bound to the grid control.

Parameters
index The index.

Implements Deltares.Standard.Forms.IGridController.

void Deltares.Standard.Forms.DExpress.GridViewControl.DeleteRowCommand ( )
protected

Triggered when the DeleteRow button is clicked.

void Deltares.Standard.Forms.DExpress.GridViewControl.EditCommand ( )
protected

Triggered when the Edit selected cells button is clicked.

object Deltares.Standard.Forms.DExpress.GridViewControl.GetControl ( )

Gets the control.

Returns

Implements Deltares.Standard.Forms.IGridViewControl.

void Deltares.Standard.Forms.DExpress.GridViewControl.InsertRow ( )

If new object is not added to datasource, it is inserted as publisherEventArgs copy of focused row after it, if any.

<return>Returns the newly created object</return>

void Deltares.Standard.Forms.DExpress.GridViewControl.InsertRow ( int index )

Inserts a row at the given index.

Parameters
index The index.

Implements Deltares.Standard.Forms.IGridController.

void Deltares.Standard.Forms.DExpress.GridViewControl.InsertRowCommand ( )
protected

Triggered when the InsertRow button is clicked.

bool Deltares.Standard.Forms.DExpress.GridViewControl.IsEnabled ( string property )

Determines whether the specified property is enabled.

Parameters
property The property.
Returns
bool Deltares.Standard.Forms.DExpress.GridViewControl.IsVisible ( string property )

Determines whether the specified property is visible.

Parameters
property The property.
Returns
static double Deltares.Standard.Forms.DExpress.GridViewControl.ParseDouble ( string value )
static

Parses the string value based on the current culture to a double value.

Parameters
value The string value to parse
Returns
The parsed value
Exceptions
ArgumentException Throws an exception if the parsed value is NaN
static double Deltares.Standard.Forms.DExpress.GridViewControl.ParseDouble | ( | string | value,
 |  | double | defaultValue
 | ) |  |
static

Parses the string value based on the current culture to a double value.

Parameters
value | The string value to parse
defaultValue | The default value if parsing fails.
Returns
The parsed or default value
void Deltares.Standard.Forms.DExpress.GridViewControl.PasteCommand ( )
protected

Triggered when the Paste button is clicked.

override void Deltares.Standard.Forms.DExpress.GridViewControl.Refresh ( )

Forces the control to invalidate its client area and immediately redraw itself and any child controls.

void Deltares.Standard.Forms.DExpress.GridViewControl.ReloadUI ( )

ReloadUI - update on language/Unit change

object Deltares.Standard.Forms.DExpress.GridViewControl.RemoveAt ( int index )

Removes the DataSource type of object using the collection at the specified index.

void Deltares.Standard.Forms.DExpress.GridViewControl.SelectColumnFilterAll ( )

Allows clients to reset the user column filter to the filter 'all'.

void Deltares.Standard.Forms.DExpress.GridViewControl.SetLocalizedString ( )

Sets the Localized string to Bar items

void Deltares.Standard.Forms.DExpress.GridViewControl.ShowColumnsCommand ( )
protected

Triggered when the Show All Column button's check status is changed.

Member Data Documentation

readonly CategoryDisplayItem Deltares.Standard.Forms.DExpress.GridViewControl.categoryAll
protected
Initial value:
= new CategoryDisplayItem("All",
LocalizationManager.GetTranslatedText(typeof(GridViewControl), "All"))

Property Documentation

bool Deltares.Standard.Forms.DExpress.GridViewControl.AdjustHeightToFit
getset

Gets or sets a value indicating whether to adjust height to fit.

true if adjust height to fit; otherwise, false.

bool Deltares.Standard.Forms.DExpress.GridViewControl.AllowAddDeleteOnly
getset

Gets or sets a value indicating whether to allow add delete only.

true if allow add delete only; otherwise, false.

bool Deltares.Standard.Forms.DExpress.GridViewControl.AllowInserts
getset

Gets or sets a value indicating whether inserting is allowed.

true if allow inserts; otherwise, false.

bool Deltares.Standard.Forms.DExpress.GridViewControl.AllowUserColumnFilterEdit
getset

Gets or sets whether the user column filter is enabled.

true if enabled; otherwise, false.

bool Deltares.Standard.Forms.DExpress.GridViewControl.AlwaysAdjustHeightToFit
staticgetset

Gets or sets a value indicating whether to always adjust the height to fit.

true if always adjust height to fit; otherwise, false.

string Deltares.Standard.Forms.DExpress.GridViewControl.Caption
get

Gets the caption.

The caption.

Func<object> Deltares.Standard.Forms.DExpress.GridViewControl.CreateNew
set

Sets the object factory. This factory is responsible for creating a new object of the type that is in the list, bound to this grid control

The create new object factory method.

IContext Deltares.Standard.Forms.DExpress.GridViewControl.CurrentContext
getset

The Context that determines the visibility of the columns.

bool Deltares.Standard.Forms.DExpress.GridViewControl.EnableMasterViewMode
getset

Indicates whether the grid control can expand to subtables

bool Deltares.Standard.Forms.DExpress.GridViewControl.HideUnusedColumns
getset

Gets or sets a value indicating whether to hide unused columns.

true if hide unused columns; otherwise, false.

bool Deltares.Standard.Forms.DExpress.GridViewControl.IsSelectionChanging
get

Gets a value indicating whether the selection is changing.

true if selection is changing; otherwise, false.

PropertyEditorReactionType Deltares.Standard.Forms.DExpress.GridViewControl.PropertyEditorReactionType
getset

Gets or sets the type of the property editor reaction.

The type of the property editor reaction.

CategoryDisplayItem Deltares.Standard.Forms.DExpress.GridViewControl.SelectedCategory
getset

Gets or sets the category.

The category.

UserColumnFilterDisplayItem Deltares.Standard.Forms.DExpress.GridViewControl.SelectedFilter
getset

Gets or sets the column filter.

The column filter.

bool Deltares.Standard.Forms.DExpress.GridViewControl.SendSelectionChanged
getset

Gets or sets a value indicating whether the send selection has changed.

true if send selection changed; otherwise, false.

bool Deltares.Standard.Forms.DExpress.GridViewControl.ShowToolbar
getset

Gets or sets a value indicating whether to show the toolbar.

true if show toolbar; otherwise, false.

Event Documentation

EventHandler<GridViewChangeArgs> Deltares.Standard.Forms.DExpress.GridViewControl.AfterRowAdd

Event occurs after row is added.

EventHandler<GridViewChangeArgs> Deltares.Standard.Forms.DExpress.GridViewControl.AfterRowDelete

Event occurs after row is deleted.

EventHandler<GridViewChangeArgs> Deltares.Standard.Forms.DExpress.GridViewControl.AfterRowInsert

Event occurs after row is inserted.

EventHandler<GridViewCellChangeArgs> Deltares.Standard.Forms.DExpress.GridViewControl.AfterRowUpdate

Event occurs after row is updated.

Generated on Tue Dec 15 2015 18:14:55 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • GridViewControl
Deltares.Standard.Forms.DExpress.GridViewControl Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.GridViewControl, including all inherited members.

AddRow() | Deltares.Standard.Forms.DExpress.GridViewControl |
AddRowCommand() | Deltares.Standard.Forms.DExpress.GridViewControl | protected
AdjustHeightToFit | Deltares.Standard.Forms.DExpress.GridViewControl |
AfterRowAdd | Deltares.Standard.Forms.DExpress.GridViewControl |
AfterRowDelete | Deltares.Standard.Forms.DExpress.GridViewControl |
AfterRowInsert | Deltares.Standard.Forms.DExpress.GridViewControl |
AfterRowUpdate | Deltares.Standard.Forms.DExpress.GridViewControl |
AllowAddDeleteOnly | Deltares.Standard.Forms.DExpress.GridViewControl |
AllowedUserColumnFilters (defined in Deltares.Standard.Forms.DExpress.GridViewControl) | Deltares.Standard.Forms.DExpress.GridViewControl |
AllowInserts | Deltares.Standard.Forms.DExpress.GridViewControl |
AllowUserColumnFilterEdit | Deltares.Standard.Forms.DExpress.GridViewControl |
AlwaysAdjustHeightToFit | Deltares.Standard.Forms.DExpress.GridViewControl | static
Append(int index=-1) | Deltares.Standard.Forms.DExpress.GridViewControl |
barDockControl1 (defined in Deltares.Standard.Forms.DExpress.GridViewControl) | Deltares.Standard.Forms.DExpress.GridViewControl |
barManager1 (defined in Deltares.Standard.Forms.DExpress.GridViewControl) | Deltares.Standard.Forms.DExpress.GridViewControl | protected
Caption | Deltares.Standard.Forms.DExpress.GridViewControl |
categoryAll (defined in Deltares.Standard.Forms.DExpress.GridViewControl) | Deltares.Standard.Forms.DExpress.GridViewControl | protected
controlPanel (defined in Deltares.Standard.Forms.DExpress.GridViewControl) | Deltares.Standard.Forms.DExpress.GridViewControl | protected
CopyCommand() | Deltares.Standard.Forms.DExpress.GridViewControl | protected
CreateNew | Deltares.Standard.Forms.DExpress.GridViewControl |
CurrentContext | Deltares.Standard.Forms.DExpress.GridViewControl |
CutCommand() | Deltares.Standard.Forms.DExpress.GridViewControl | protected
DeleteRow(int index) | Deltares.Standard.Forms.DExpress.GridViewControl |
DeleteRowCommand() | Deltares.Standard.Forms.DExpress.GridViewControl | protected
Dispose(bool disposing) (defined in Deltares.Standard.Forms.DExpress.GridViewControl) | Deltares.Standard.Forms.DExpress.GridViewControl | protected
Dispose() (defined in Deltares.Standard.Forms.IGridViewControl) | Deltares.Standard.Forms.IGridViewControl |
EditCommand() | Deltares.Standard.Forms.DExpress.GridViewControl | protected
EditUnitCommand() (defined in Deltares.Standard.Forms.DExpress.GridViewControl) | Deltares.Standard.Forms.DExpress.GridViewControl | protected
EnableMasterViewMode | Deltares.Standard.Forms.DExpress.GridViewControl |
ExpandAllBarEditItem (defined in Deltares.Standard.Forms.DExpress.GridViewControl) | Deltares.Standard.Forms.DExpress.GridViewControl |
ExportTable() (defined in Deltares.Standard.Forms.DExpress.GridViewControl) | Deltares.Standard.Forms.DExpress.GridViewControl | protected
GeoPopupMenu (defined in Deltares.Standard.Forms.DExpress.GridViewControl) | Deltares.Standard.Forms.DExpress.GridViewControl |
GetChildComponents() (defined in Deltares.Standard.Forms.DExpress.GridViewControl) | Deltares.Standard.Forms.DExpress.GridViewControl |
GetControl() | Deltares.Standard.Forms.DExpress.GridViewControl |
GridControl (defined in Deltares.Standard.Forms.DExpress.GridViewControl) | Deltares.Standard.Forms.DExpress.GridViewControl |
GridView (defined in Deltares.Standard.Forms.DExpress.GridViewControl) | Deltares.Standard.Forms.DExpress.GridViewControl | protected
gridView1 (defined in Deltares.Standard.Forms.DExpress.GridViewControl) | Deltares.Standard.Forms.DExpress.GridViewControl |
GridViewControl() | Deltares.Standard.Forms.DExpress.GridViewControl |
HideUnusedColumns | Deltares.Standard.Forms.DExpress.GridViewControl |
InsertRow() | Deltares.Standard.Forms.DExpress.GridViewControl |
InsertRow(int index) | Deltares.Standard.Forms.DExpress.GridViewControl |
InsertRowCommand() | Deltares.Standard.Forms.DExpress.GridViewControl | protected
IsEnabled(string property) | Deltares.Standard.Forms.DExpress.GridViewControl |
IsSelectionChanging | Deltares.Standard.Forms.DExpress.GridViewControl |
IsVisible(string property) | Deltares.Standard.Forms.DExpress.GridViewControl |
itemType (defined in Deltares.Standard.Forms.DExpress.GridViewControl) | Deltares.Standard.Forms.DExpress.GridViewControl | protected
ParseDouble(string value) | Deltares.Standard.Forms.DExpress.GridViewControl | static
ParseDouble(string value, double defaultValue) | Deltares.Standard.Forms.DExpress.GridViewControl | static
PasteCommand() | Deltares.Standard.Forms.DExpress.GridViewControl | protected
PropertyEditorReactionType | Deltares.Standard.Forms.DExpress.GridViewControl |
Refresh() | Deltares.Standard.Forms.DExpress.GridViewControl |
ReloadUI() | Deltares.Standard.Forms.DExpress.GridViewControl |
RemoveAt(int index) | Deltares.Standard.Forms.DExpress.GridViewControl |
SelectColumnFilterAll() | Deltares.Standard.Forms.DExpress.GridViewControl |
SelectedCategory | Deltares.Standard.Forms.DExpress.GridViewControl |
SelectedFilter | Deltares.Standard.Forms.DExpress.GridViewControl |
SendSelectionChanged | Deltares.Standard.Forms.DExpress.GridViewControl |
SetLocalizedString() | Deltares.Standard.Forms.DExpress.GridViewControl |
ShowColumnsCommand() | Deltares.Standard.Forms.DExpress.GridViewControl | protected
ShowToolbar | Deltares.Standard.Forms.DExpress.GridViewControl |
TemplateImageCollection (defined in Deltares.Standard.Forms.DExpress.GridViewControl) | Deltares.Standard.Forms.DExpress.GridViewControl |
Toolbar (defined in Deltares.Standard.Forms.DExpress.GridViewControl) | Deltares.Standard.Forms.DExpress.GridViewControl |
Generated on Tue Dec 15 2015 18:14:55 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.GridViewController< T > Class Template Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • GridViewController
Public Member Functions | Protected Member Functions | Package Functions | Properties | List of all members
Deltares.Standard.Forms.DExpress.GridViewController< T > Class Template Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.GridViewController< T >:

Public Member Functions

GridViewController (IDynamicTableControl tableContainerControl)
Initializes a new instance of the GridViewController<T> class. More...
virtual void | Assign (IEnumerable< T > items)
Assigns the specified items to the grid control. More...
void | RegisterTable ()
Forces the table control to register itself into the bind support. More...
void | AddRow ()
Adds the row. More...
void | DeleteRow (int index)
Deletes the row at given index. More...
void | InsertRow (int index)
Inserts a row at given index. More...
void | Dispose ()

Protected Member Functions

GridViewController (Component parent, IDynamicTableControl tableContainer, IGridViewControl gridView)
Initializes a new instance of the GridViewController<T> class. More...
GridViewController (IDynamicTableControl tableContainerControl, string caption)
Initializes a new instance of the GridViewController<T> class. More...
void | RegisterControl (Component parentComponent, IDynamicTableControl tableControl, IGridViewControl gridViewControl)
Registers the control. More...
virtual void | OnAfterRowInsert (object sender, GridViewChangeArgs gridViewChangeArgs)
Called after a row has been inserted. More...
virtual void | OnAfterRowDelete (object sender, GridViewChangeArgs gridViewChangeArgs)
Called after ar row has been deleted More...
virtual void | OnAfterRowAdd (object sender, GridViewChangeArgs gridViewChangeArgs)
Called after a row has been added More...
virtual void | OnAfterRowUpdate (object sender, GridViewCellChangeArgs gridViewChangeArgs)
Called after a row has been updated More...

Package Functions

GridViewController (IDynamicTableControl tableContainerControl, IGridViewControl gridViewControl)
Initializes a new instance of the GridViewController<T> class. More...

Properties

virtual List< T > | Items [get, protected set]
Gets the items. More...
Action< GridViewChangeArgs > | AfterInsert [get, set]
Gets or sets the after insert. More...
Action< GridViewChangeArgs > | AfterDelete [get, set]
Gets or sets the after delete. More...
Action< GridViewChangeArgs > | AfterAdd [get, set]
Gets or sets the after add method. More...
Action< GridViewCellChangeArgs > | AfterUpdate [get, set]
Gets or sets the after update action. More...
bool | AllowInserts [get, set]
Gets or sets a value indicating whether [allow inserts]. More...
Func< T > | CreateNew [set]
Sets the object factory method. More...
Func< object > | Creator [get, set]
Holds a reference to the internal factory method More...

Constructor & Destructor Documentation

Deltares.Standard.Forms.DExpress.GridViewController< T >.GridViewController ( IDynamicTableControl tableContainerControl )

Initializes a new instance of the GridViewController<T> class.

Parameters
tableContainerControl The table container control.
Deltares.Standard.Forms.DExpress.GridViewController< T >.GridViewController | ( | IDynamicTableControl | tableContainerControl,
 |  | IGridViewControl | gridViewControl
 | ) |  |
package

Initializes a new instance of the GridViewController<T> class.

Parameters
tableContainerControl | The table container control.
gridViewControl | The grid view control.
Deltares.Standard.Forms.DExpress.GridViewController< T >.GridViewController | ( | Component | parent,
 |  | IDynamicTableControl | tableContainer,
 |  | IGridViewControl | gridView
 | ) |  |
protected

Initializes a new instance of the GridViewController<T> class.

Parameters
parent | The parent.
tableContainer | The table control.
gridView | The grid view control.
Deltares.Standard.Forms.DExpress.GridViewController< T >.GridViewController | ( | IDynamicTableControl | tableContainerControl,
 |  | string | caption
 | ) |  |
protected

Initializes a new instance of the GridViewController<T> class.

Parameters
tableContainerControl | The table container control.
caption | The caption of this table

References Deltares.Standard.Forms.Text.

Member Function Documentation

void Deltares.Standard.Forms.DExpress.GridViewController< T >.AddRow ( )

Adds the row.

virtual void Deltares.Standard.Forms.DExpress.GridViewController< T >.Assign ( IEnumerable< T > items )
virtual

Assigns the specified items to the grid control.

Parameters
items The items.

References Deltares.Standard.Forms.DExpress.BindSupport.Assign().

void Deltares.Standard.Forms.DExpress.GridViewController< T >.DeleteRow ( int index )

Deletes the row at given index.

Parameters
index The index.
void Deltares.Standard.Forms.DExpress.GridViewController< T >.InsertRow ( int index )

Inserts a row at given index.

Parameters
index The index.
virtual void Deltares.Standard.Forms.DExpress.GridViewController< T >.OnAfterRowAdd | ( | object | sender,
 |  | GridViewChangeArgs | gridViewChangeArgs
 | ) |  |
protectedvirtual

Called after a row has been added

Parameters
sender | The sender.
gridViewChangeArgs | The grid view change args.
virtual void Deltares.Standard.Forms.DExpress.GridViewController< T >.OnAfterRowDelete | ( | object | sender,
 |  | GridViewChangeArgs | gridViewChangeArgs
 | ) |  |
protectedvirtual

Called after ar row has been deleted

Parameters
sender | The sender.
gridViewChangeArgs | The grid view change args.
virtual void Deltares.Standard.Forms.DExpress.GridViewController< T >.OnAfterRowInsert | ( | object | sender,
 |  | GridViewChangeArgs | gridViewChangeArgs
 | ) |  |
protectedvirtual

Called after a row has been inserted.

Parameters
sender | The sender.
gridViewChangeArgs | The grid view change args.
virtual void Deltares.Standard.Forms.DExpress.GridViewController< T >.OnAfterRowUpdate | ( | object | sender,
 |  | GridViewCellChangeArgs | gridViewChangeArgs
 | ) |  |
protectedvirtual

Called after a row has been updated

Parameters
sender | The sender.
gridViewChangeArgs | The grid view change args.
void Deltares.Standard.Forms.DExpress.GridViewController< T >.RegisterControl | ( | Component | parentComponent,
 |  | IDynamicTableControl | tableControl,
 |  | IGridViewControl | gridViewControl
 | ) |  |
protected

Registers the control.

Parameters
parentComponent | The parent component.
tableControl | The table control.
gridViewControl | The grid view control.

References Deltares.Standard.Forms.DExpress.BindSupport.Bind(), and Deltares.Standard.Forms.DExpress.GridViewController< T >.Items.

void Deltares.Standard.Forms.DExpress.GridViewController< T >.RegisterTable ( )

Forces the table control to register itself into the bind support.

Use this method if you want to control the order of registration. The order of registration will also set the order of tabs of tables in the main form If not used the controller will call this method automatically when data is assigned

Property Documentation

Action<GridViewChangeArgs> Deltares.Standard.Forms.DExpress.GridViewController< T >.AfterAdd
getset

Gets or sets the after add method.

The after add.

Action<GridViewChangeArgs> Deltares.Standard.Forms.DExpress.GridViewController< T >.AfterDelete
getset

Gets or sets the after delete.

The after delete.

Action<GridViewChangeArgs> Deltares.Standard.Forms.DExpress.GridViewController< T >.AfterInsert
getset

Gets or sets the after insert.

The after insert.

Action<GridViewCellChangeArgs> Deltares.Standard.Forms.DExpress.GridViewController< T >.AfterUpdate
getset

Gets or sets the after update action.

The after add action method.

bool Deltares.Standard.Forms.DExpress.GridViewController< T >.AllowInserts
getset

Gets or sets a value indicating whether [allow inserts].

true if [allow inserts]; otherwise, false.

Func<T> Deltares.Standard.Forms.DExpress.GridViewController< T >.CreateNew
set

Sets the object factory method.

The object factory method.

Func<object> Deltares.Standard.Forms.DExpress.GridViewController< T >.Creator
getsetprotected

Holds a reference to the internal factory method

virtual List<T> Deltares.Standard.Forms.DExpress.GridViewController< T >.Items
getprotected set

Gets the items.

Referenced by Deltares.Standard.Forms.DExpress.GridViewController< T >.RegisterControl().

Generated on Tue Dec 15 2015 18:14:55 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • GridViewController
Deltares.Standard.Forms.DExpress.GridViewController< T > Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.GridViewController< T >, including all inherited members.

AddRow() | Deltares.Standard.Forms.DExpress.GridViewController< T > |
AfterAdd | Deltares.Standard.Forms.DExpress.GridViewController< T > |
AfterDelete | Deltares.Standard.Forms.DExpress.GridViewController< T > |
AfterInsert | Deltares.Standard.Forms.DExpress.GridViewController< T > |
AfterUpdate | Deltares.Standard.Forms.DExpress.GridViewController< T > |
AllowInserts | Deltares.Standard.Forms.DExpress.GridViewController< T > |
Assign(IEnumerable< T > items) | Deltares.Standard.Forms.DExpress.GridViewController< T > | virtual
CreateNew | Deltares.Standard.Forms.DExpress.GridViewController< T > |
Creator | Deltares.Standard.Forms.DExpress.GridViewController< T > | protected
DeleteRow(int index) | Deltares.Standard.Forms.DExpress.GridViewController< T > |
Dispose() (defined in Deltares.Standard.Forms.DExpress.GridViewController< T >) | Deltares.Standard.Forms.DExpress.GridViewController< T > |
GridViewController(IDynamicTableControl tableContainerControl) | Deltares.Standard.Forms.DExpress.GridViewController< T > |
GridViewController(IDynamicTableControl tableContainerControl, IGridViewControl gridViewControl) | Deltares.Standard.Forms.DExpress.GridViewController< T > | package
GridViewController(Component parent, IDynamicTableControl tableContainer, IGridViewControl gridView) | Deltares.Standard.Forms.DExpress.GridViewController< T > | protected
GridViewController(IDynamicTableControl tableContainerControl, string caption) | Deltares.Standard.Forms.DExpress.GridViewController< T > | protected
InsertRow(int index) | Deltares.Standard.Forms.DExpress.GridViewController< T > |
Items | Deltares.Standard.Forms.DExpress.GridViewController< T > |
OnAfterRowAdd(object sender, GridViewChangeArgs gridViewChangeArgs) | Deltares.Standard.Forms.DExpress.GridViewController< T > | protectedvirtual
OnAfterRowDelete(object sender, GridViewChangeArgs gridViewChangeArgs) | Deltares.Standard.Forms.DExpress.GridViewController< T > | protectedvirtual
OnAfterRowInsert(object sender, GridViewChangeArgs gridViewChangeArgs) | Deltares.Standard.Forms.DExpress.GridViewController< T > | protectedvirtual
OnAfterRowUpdate(object sender, GridViewCellChangeArgs gridViewChangeArgs) | Deltares.Standard.Forms.DExpress.GridViewController< T > | protectedvirtual
RegisterControl(Component parentComponent, IDynamicTableControl tableControl, IGridViewControl gridViewControl) | Deltares.Standard.Forms.DExpress.GridViewController< T > | protected
RegisterTable() | Deltares.Standard.Forms.DExpress.GridViewController< T > |
Generated on Tue Dec 15 2015 18:14:55 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.HelpLocationShower Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • HelpLocationShower
Public Member Functions | Properties | List of all members
Deltares.Standard.Forms.DExpress.HelpLocationShower Class Reference

This help file manager will open message box pop-ups, displaying the More...

Inheritance diagram for Deltares.Standard.Forms.DExpress.HelpLocationShower:
Deltares.Standard.Forms.DExpress.Interfaces.IHelpFileManager

Public Member Functions

HelpLocationShower (IHelpLocationProvider helpLocationProvider)
void OpenHelp (Control control)
Request to open the help at a given location. More...

Properties

string | HelpFilePath [get, set]
IHelpLocationProvider | HelpLocationProvider [get]
- Properties inherited from Deltares.Standard.Forms.DExpress.Interfaces.IHelpFileManager
string | HelpFilePath [get, set]
Gets or sets the help file path. More...
IHelpLocationProvider | HelpLocationProvider [get]
Gets the help location provider. More...

Detailed Description

This help file manager will open message box pop-ups, displaying the

Member Function Documentation

void Deltares.Standard.Forms.DExpress.HelpLocationShower.OpenHelp ( Control control )

Request to open the help at a given location.

<preCondition>HelpFilePath should be a path to a valid file.</preCondition>

Exceptions
FileNotFoundException | When HelpFilePath does not exist.
InvalidOperationException | When HelpFilePath is not of the correct type (for example .txt file while it should be .pdf).

Implements Deltares.Standard.Forms.DExpress.Interfaces.IHelpFileManager.

References Deltares.Standard.Forms.DExpress.Interfaces.IHelpLocationProvider.GetHelpLocation().

Generated on Tue Dec 15 2015 18:14:56 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • HelpLocationShower
Deltares.Standard.Forms.DExpress.HelpLocationShower Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.HelpLocationShower, including all inherited members.

HelpFilePath (defined in Deltares.Standard.Forms.DExpress.HelpLocationShower) | Deltares.Standard.Forms.DExpress.HelpLocationShower
HelpLocationProvider (defined in Deltares.Standard.Forms.DExpress.HelpLocationShower) | Deltares.Standard.Forms.DExpress.HelpLocationShower
HelpLocationShower(IHelpLocationProvider helpLocationProvider) (defined in Deltares.Standard.Forms.DExpress.HelpLocationShower) | Deltares.Standard.Forms.DExpress.HelpLocationShower
OpenHelp(Control control) | Deltares.Standard.Forms.DExpress.HelpLocationShower
Generated on Tue Dec 15 2015 18:14:56 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.HyperLinkEditBinding Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • HyperLinkEditBinding
Public Member Functions | List of all members
Deltares.Standard.Forms.DExpress.HyperLinkEditBinding Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.HyperLinkEditBinding:
Deltares.Standard.Forms.DExpress.BaseControlBinding Deltares.Standard.Forms.DExpress.ControlBinding Deltares.Standard.Forms.DExpress.ComponentBinding Deltares.Standard.Forms.DExpress.ComponentWrappers.IGetBoundControl

Public Member Functions

HyperLinkEditBinding (Component component)
override void | Initialize (BindPropertyInfo propertyInfo, params string[] properties)
override void | SetValue (object value)
override object | GetValue ()
override void | SetEnabled (bool enabled)
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.BaseControlBinding
override void | SetLabel (string text)
override void | SetDescription (string description)
override void | Invalidate ()
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.ControlBinding
override void | SetVisible (bool visible)
override void | SetLabel (string text)
Sets the label/title/name associated with this control. More...
override void | SetDescription (string description)
Sets the textual description associated with this control. More...
override void | SetForegroundColor (Color color)
override void | SetBackgroundColor (Color color)
override void | Invalidate ()
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
ComponentBinding (Component component)
virtual void | Initialize (BindPropertyInfo propertyInfo, Type rootObjectType, params string[] properties)
virtual void | SetTrueMapping (object trueMapping)
virtual void | SetValue (object value, object parent)
virtual void | SetDomain (ICollection collection)
virtual void | Refresh ()
virtual void | RegisterSelectionAssignment (Component targetComponent, IConverter converter=null)
Indicates that the selection of the bound control must be assigned to another control. More...
virtual void | SetControlColors (Color fore, Color back)
Sets the controls foreground and background colors. Can be overridden by a specific binding to set other colors if necessary. More...

Additional Inherited Members

- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.BaseControlBinding
BaseControlBinding (Component component)
DXPopupMenu | GetPopupMenu ()
This method uses reflection to make the context menu accessible, which otherwise is protected. The Menu property is implemented for TextEdit, so we first make sure the control is actually of this type. More...
override void | OnToolTipShown (PopupEventArgs e)
Called when Tooltip is shown, and fires ToolTipShown event. More...
override void | OnToolTipClosed ()
Called when Tooltip is hidden, and fires ToolTipHidden. More...
override void | Dispose (bool disposing)
- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.ControlBinding
ControlBinding (Component component)
void | ThreadSafeRefresh ()
override void | Dispose (bool disposing)
- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
void | RaiseValueChanged ()
void | RaiseLeave ()
void | RaiseActionPerformed ()
Type | GetGenericType (Type type)
string | ValueToString (object value)
bool | IsAssociatedPropertyVisible (object source, BindPropertyInfo associatedPropertyInfo)
Indicates whether the associated property (i.e. the property which is used to display the original property in a textbox) is visible More...
void | EditFileInfo (object source, BindPropertyInfo propertyInfo)
string | EditFileInfo (string value, string format, string label, string description, bool isDirectory)
string | GetDoubleString (string text)
bool | HasValidNumericValue (string text)
double | GetNumericValue (string text)
List< BindPropertyInfo > | GetDictionaryProperties (ICollection domain, BindPropertyInfo dynamicPropertyInfo)
- Protected Attributes inherited from Deltares.Standard.Forms.DExpress.BaseControlBinding
readonly SuperToolTip | superTip
- Protected Attributes inherited from Deltares.Standard.Forms.DExpress.ControlBinding
readonly ToolTip | tooltip
string | Description
The textual description associated with this

See also
Control

. More...

string | Label
The label/title/name associated with this Control. More...
- Protected Attributes inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
BindPropertyInfo | propInfo
- Properties inherited from Deltares.Standard.Forms.DExpress.ControlBinding
ToolTip | Tooltip [get]
Gets the tooltip for the bound control. More...
Control | BoundControl [get]
- Properties inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
Component | Component [get]
virtual bool | IsTransparant [get]
virtual HandleType | HandleDelayed [get]
virtual bool | HasDomain [get]
- Properties inherited from Deltares.Standard.Forms.DExpress.ComponentWrappers.IGetBoundControl
Control | BoundControl [get]
- Events inherited from Deltares.Standard.Forms.DExpress.ControlBinding
ToolTipVisibilityEventHandler | ToolTipHidden
ToolTipVisibilityEventHandler | ToolTipShown
- Events inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
EventHandler< EventArgs > | ActionPerformed
EventHandler< EventArgs > | Leave
EventHandler< EventArgs > | ValueChanged
Generated on Tue Dec 15 2015 18:14:56 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • HyperLinkEditBinding
Deltares.Standard.Forms.DExpress.HyperLinkEditBinding Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.HyperLinkEditBinding, including all inherited members.

ActionPerformed (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
BaseControlBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.BaseControlBinding) | Deltares.Standard.Forms.DExpress.BaseControlBinding | protected
BoundControl (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding |
Component (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ComponentBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ControlBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Description | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Dispose(bool disposing) (defined in Deltares.Standard.Forms.DExpress.BaseControlBinding) | Deltares.Standard.Forms.DExpress.BaseControlBinding | protected
EditFileInfo(object source, BindPropertyInfo propertyInfo) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
EditFileInfo(string value, string format, string label, string description, bool isDirectory) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetDictionaryProperties(ICollection domain, BindPropertyInfo dynamicPropertyInfo) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetDoubleString(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetGenericType(Type type) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetNumericValue(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetPopupMenu() | Deltares.Standard.Forms.DExpress.BaseControlBinding | protected
GetValue() (defined in Deltares.Standard.Forms.DExpress.HyperLinkEditBinding) | Deltares.Standard.Forms.DExpress.HyperLinkEditBinding | virtual
HandleDelayed (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
HasDomain (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
HasValidNumericValue(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
HyperLinkEditBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.HyperLinkEditBinding) | Deltares.Standard.Forms.DExpress.HyperLinkEditBinding |
Initialize(BindPropertyInfo propertyInfo, params string[] properties) (defined in Deltares.Standard.Forms.DExpress.HyperLinkEditBinding) | Deltares.Standard.Forms.DExpress.HyperLinkEditBinding | virtual
Initialize(BindPropertyInfo propertyInfo, Type rootObjectType, params string[] properties) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
Invalidate() (defined in Deltares.Standard.Forms.DExpress.BaseControlBinding) | Deltares.Standard.Forms.DExpress.BaseControlBinding | virtual
IsAssociatedPropertyVisible(object source, BindPropertyInfo associatedPropertyInfo) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
IsTransparant (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
Label | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Leave (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
OnToolTipClosed() | Deltares.Standard.Forms.DExpress.BaseControlBinding | protectedvirtual
OnToolTipShown(PopupEventArgs e) | Deltares.Standard.Forms.DExpress.BaseControlBinding | protectedvirtual
propInfo (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseActionPerformed() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseLeave() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseValueChanged() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Refresh() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
RegisterSelectionAssignment(Component targetComponent, IConverter converter=null) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetBackgroundColor(Color color) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
SetControlColors(Color fore, Color back) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetDescription(string description) (defined in Deltares.Standard.Forms.DExpress.BaseControlBinding) | Deltares.Standard.Forms.DExpress.BaseControlBinding | virtual
SetDomain(ICollection collection) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetEnabled(bool enabled) (defined in Deltares.Standard.Forms.DExpress.HyperLinkEditBinding) | Deltares.Standard.Forms.DExpress.HyperLinkEditBinding | virtual
SetForegroundColor(Color color) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
SetLabel(string text) (defined in Deltares.Standard.Forms.DExpress.BaseControlBinding) | Deltares.Standard.Forms.DExpress.BaseControlBinding | virtual
SetTrueMapping(object trueMapping) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetValue(object value) (defined in Deltares.Standard.Forms.DExpress.HyperLinkEditBinding) | Deltares.Standard.Forms.DExpress.HyperLinkEditBinding | virtual
SetValue(object value, object parent) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetVisible(bool visible) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
superTip (defined in Deltares.Standard.Forms.DExpress.BaseControlBinding) | Deltares.Standard.Forms.DExpress.BaseControlBinding | protected
ThreadSafeRefresh() (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | protected
tooltip (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Tooltip | Deltares.Standard.Forms.DExpress.ControlBinding | protected
ToolTipHidden (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding |
ToolTipShown (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding |
ValueChanged (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ValueToString(object value) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Generated on Tue Dec 15 2015 18:14:56 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.IActionSubControlFactory< out out ControlType > Interface Template Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • IActionSubControlFactory
Public Member Functions | List of all members
Deltares.Standard.Forms.DExpress.IActionSubControlFactory< out out ControlType > Interface Template Reference

Public Member Functions

ControlType CreateBoundControl (MethodInfo methodInfo, Type dataType, Component parentComponent)
Generated on Tue Dec 15 2015 18:14:56 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • IActionSubControlFactory
Deltares.Standard.Forms.DExpress.IActionSubControlFactory< out out ControlType > Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.IActionSubControlFactory< out out ControlType >, including all inherited members.

CreateBoundControl(MethodInfo methodInfo, Type dataType, Component parentComponent) (defined in Deltares.Standard.Forms.DExpress.IActionSubControlFactory< out out ControlType >) Deltares.Standard.Forms.DExpress.IActionSubControlFactory< out out ControlType >
Generated on Tue Dec 15 2015 18:14:56 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.ILabelEditControl Interface Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • ILabelEditControl
Properties | List of all members
Deltares.Standard.Forms.DExpress.ILabelEditControl Interface Reference

a simple interface to help with binding of controls More...

Inheritance diagram for Deltares.Standard.Forms.DExpress.ILabelEditControl:
Deltares.Standard.Forms.DExpress.PanelLinearConversionValue Deltares.Standard.Forms.DExpress.PanelTextBooleanValue Deltares.Standard.Forms.DExpress.PanelTextComboBoxValue Deltares.Standard.Forms.DExpress.PanelTextLinkValue Deltares.Standard.Forms.DExpress.PanelTextNumericValue Deltares.Standard.Forms.DExpress.PanelTextPathValue Deltares.Standard.Forms.DExpress.PanelTextPopupContainerEdit Deltares.Standard.Forms.DExpress.PanelTextStringValue

Properties

Control | EditControl [get]
Control | LabelControl [get]

Detailed Description

a simple interface to help with binding of controls

Generated on Tue Dec 15 2015 18:14:56 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • ILabelEditControl
Deltares.Standard.Forms.DExpress.ILabelEditControl Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.ILabelEditControl, including all inherited members.

EditControl (defined in Deltares.Standard.Forms.DExpress.ILabelEditControl) | Deltares.Standard.Forms.DExpress.ILabelEditControl
LabelControl (defined in Deltares.Standard.Forms.DExpress.ILabelEditControl) | Deltares.Standard.Forms.DExpress.ILabelEditControl
Generated on Tue Dec 15 2015 18:14:56 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.ImageListBoxBinding Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • ImageListBoxBinding
Public Member Functions | List of all members
Deltares.Standard.Forms.DExpress.ImageListBoxBinding Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.ImageListBoxBinding:
Deltares.Standard.Forms.DExpress.ControlBinding Deltares.Standard.Forms.DExpress.ComponentBinding Deltares.Standard.Forms.DExpress.ComponentWrappers.IGetBoundControl

Public Member Functions

ImageListBoxBinding (Component component)
override void | Initialize (BindPropertyInfo propertyInfo, params string[] properties)
override void | SetEnabled (bool enabled)
override void | SetValue (object value)
override void | Refresh ()
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.ControlBinding
override void | SetVisible (bool visible)
override void | SetLabel (string text)
Sets the label/title/name associated with this control. More...
override void | SetDescription (string description)
Sets the textual description associated with this control. More...
override void | SetForegroundColor (Color color)
override void | SetBackgroundColor (Color color)
override void | Invalidate ()
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
ComponentBinding (Component component)
virtual void | Initialize (BindPropertyInfo propertyInfo, Type rootObjectType, params string[] properties)
virtual void | SetTrueMapping (object trueMapping)
virtual void | SetValue (object value, object parent)
virtual void | SetDomain (ICollection collection)
virtual object | GetValue ()
virtual void | RegisterSelectionAssignment (Component targetComponent, IConverter converter=null)
Indicates that the selection of the bound control must be assigned to another control. More...
virtual void | SetControlColors (Color fore, Color back)
Sets the controls foreground and background colors. Can be overridden by a specific binding to set other colors if necessary. More...

Additional Inherited Members

- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.ControlBinding
ControlBinding (Component component)
virtual void | OnToolTipShown (PopupEventArgs e)
Called when Tooltip is shown, and fires ToolTipShown event. More...
virtual void | OnToolTipClosed ()
Called when Tooltip is hidden, and fires ToolTipHidden. More...
void | ThreadSafeRefresh ()
override void | Dispose (bool disposing)
- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
void | RaiseValueChanged ()
void | RaiseLeave ()
void | RaiseActionPerformed ()
Type | GetGenericType (Type type)
string | ValueToString (object value)
bool | IsAssociatedPropertyVisible (object source, BindPropertyInfo associatedPropertyInfo)
Indicates whether the associated property (i.e. the property which is used to display the original property in a textbox) is visible More...
void | EditFileInfo (object source, BindPropertyInfo propertyInfo)
string | EditFileInfo (string value, string format, string label, string description, bool isDirectory)
string | GetDoubleString (string text)
bool | HasValidNumericValue (string text)
double | GetNumericValue (string text)
List< BindPropertyInfo > | GetDictionaryProperties (ICollection domain, BindPropertyInfo dynamicPropertyInfo)
- Protected Attributes inherited from Deltares.Standard.Forms.DExpress.ControlBinding
readonly ToolTip | tooltip
string | Description
The textual description associated with this

See also
Control

. More...

string | Label
The label/title/name associated with this Control. More...
- Protected Attributes inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
BindPropertyInfo | propInfo
- Properties inherited from Deltares.Standard.Forms.DExpress.ControlBinding
ToolTip | Tooltip [get]
Gets the tooltip for the bound control. More...
Control | BoundControl [get]
- Properties inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
Component | Component [get]
virtual bool | IsTransparant [get]
virtual HandleType | HandleDelayed [get]
virtual bool | HasDomain [get]
- Properties inherited from Deltares.Standard.Forms.DExpress.ComponentWrappers.IGetBoundControl
Control | BoundControl [get]
- Events inherited from Deltares.Standard.Forms.DExpress.ControlBinding
ToolTipVisibilityEventHandler | ToolTipHidden
ToolTipVisibilityEventHandler | ToolTipShown
- Events inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
EventHandler< EventArgs > | ActionPerformed
EventHandler< EventArgs > | Leave
EventHandler< EventArgs > | ValueChanged
Generated on Tue Dec 15 2015 18:14:57 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • ImageListBoxBinding
Deltares.Standard.Forms.DExpress.ImageListBoxBinding Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.ImageListBoxBinding, including all inherited members.

ActionPerformed (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
BoundControl (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding |
Component (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ComponentBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ControlBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Description | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Dispose(bool disposing) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | protected
EditFileInfo(object source, BindPropertyInfo propertyInfo) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
EditFileInfo(string value, string format, string label, string description, bool isDirectory) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetDictionaryProperties(ICollection domain, BindPropertyInfo dynamicPropertyInfo) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetDoubleString(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetGenericType(Type type) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetNumericValue(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetValue() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
HandleDelayed (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
HasDomain (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
HasValidNumericValue(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
ImageListBoxBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.ImageListBoxBinding) | Deltares.Standard.Forms.DExpress.ImageListBoxBinding |
Initialize(BindPropertyInfo propertyInfo, params string[] properties) (defined in Deltares.Standard.Forms.DExpress.ImageListBoxBinding) | Deltares.Standard.Forms.DExpress.ImageListBoxBinding | virtual
Initialize(BindPropertyInfo propertyInfo, Type rootObjectType, params string[] properties) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
Invalidate() (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
IsAssociatedPropertyVisible(object source, BindPropertyInfo associatedPropertyInfo) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
IsTransparant (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
Label | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Leave (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
OnToolTipClosed() | Deltares.Standard.Forms.DExpress.ControlBinding | protectedvirtual
OnToolTipShown(PopupEventArgs e) | Deltares.Standard.Forms.DExpress.ControlBinding | protectedvirtual
propInfo (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseActionPerformed() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseLeave() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseValueChanged() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Refresh() (defined in Deltares.Standard.Forms.DExpress.ImageListBoxBinding) | Deltares.Standard.Forms.DExpress.ImageListBoxBinding | virtual
RegisterSelectionAssignment(Component targetComponent, IConverter converter=null) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetBackgroundColor(Color color) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
SetControlColors(Color fore, Color back) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetDescription(string description) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
SetDomain(ICollection collection) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetEnabled(bool enabled) (defined in Deltares.Standard.Forms.DExpress.ImageListBoxBinding) | Deltares.Standard.Forms.DExpress.ImageListBoxBinding | virtual
SetForegroundColor(Color color) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
SetLabel(string text) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
SetTrueMapping(object trueMapping) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetValue(object value) (defined in Deltares.Standard.Forms.DExpress.ImageListBoxBinding) | Deltares.Standard.Forms.DExpress.ImageListBoxBinding | virtual
SetValue(object value, object parent) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetVisible(bool visible) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
ThreadSafeRefresh() (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | protected
tooltip (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Tooltip | Deltares.Standard.Forms.DExpress.ControlBinding | protected
ToolTipHidden (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding |
ToolTipShown (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding |
ValueChanged (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ValueToString(object value) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Generated on Tue Dec 15 2015 18:14:57 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.IMainForm Interface Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • IMainForm
Public Member Functions | List of all members
Deltares.Standard.Forms.DExpress.IMainForm Interface Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.IMainForm:
Deltares.Standard.Forms.DExpress.MainForm

Public Member Functions

void CreateAndRegisterPropertyFormFor< T > (params Expression< Func< T, object >>[] expressions)
Generated on Tue Dec 15 2015 18:14:57 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • IMainForm
Deltares.Standard.Forms.DExpress.IMainForm Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.IMainForm, including all inherited members.

CreateAndRegisterPropertyFormFor< T >(params Expression< Func< T, object >>[] expressions) (defined in Deltares.Standard.Forms.DExpress.IMainForm) Deltares.Standard.Forms.DExpress.IMainForm
Generated on Tue Dec 15 2015 18:14:57 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.IMainFormActiveControlController Interface Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • IMainFormActiveControlController
Public Member Functions | List of all members
Deltares.Standard.Forms.DExpress.IMainFormActiveControlController Interface Reference

Allows for controls in the MainForm to be put in the front and active. More...

Inheritance diagram for Deltares.Standard.Forms.DExpress.IMainFormActiveControlController:
Deltares.Standard.Forms.DExpress.MainForm

Public Member Functions

void | SetAsActiveChart (Control chart)
Sets a given control as the active chart. More...
void | SetAsActiveTable (Control table)
Sets given table as active table. More...
void | SetAsActiveTabOnMainPanel (Control dynamicControl)
Sets given control as active tab on main panel. More...
void | SetAsActivePropertyEditor (Control propertyControl)
Sets given control as active property editor. More...

Detailed Description

Allows for controls in the MainForm to be put in the front and active.

Member Function Documentation

void Deltares.Standard.Forms.DExpress.IMainFormActiveControlController.SetAsActiveChart ( Control chart )

Sets a given control as the active chart.

Parameters
chart My chart.

Implemented in Deltares.Standard.Forms.DExpress.MainForm.

void Deltares.Standard.Forms.DExpress.IMainFormActiveControlController.SetAsActivePropertyEditor ( Control propertyControl )

Sets given control as active property editor.

Parameters
propertyControl The property control.

Implemented in Deltares.Standard.Forms.DExpress.MainForm.

void Deltares.Standard.Forms.DExpress.IMainFormActiveControlController.SetAsActiveTable ( Control table )

Sets given table as active table.

Parameters
table The table.

Implemented in Deltares.Standard.Forms.DExpress.MainForm.

void Deltares.Standard.Forms.DExpress.IMainFormActiveControlController.SetAsActiveTabOnMainPanel ( Control dynamicControl )

Sets given control as active tab on main panel.

Parameters
dynamicControl The dynamic control.

Implemented in Deltares.Standard.Forms.DExpress.MainForm.

Generated on Tue Dec 15 2015 18:14:57 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • IMainFormActiveControlController
Deltares.Standard.Forms.DExpress.IMainFormActiveControlController Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.IMainFormActiveControlController, including all inherited members.

SetAsActiveChart(Control chart) | Deltares.Standard.Forms.DExpress.IMainFormActiveControlController
SetAsActivePropertyEditor(Control propertyControl) | Deltares.Standard.Forms.DExpress.IMainFormActiveControlController
SetAsActiveTable(Control table) | Deltares.Standard.Forms.DExpress.IMainFormActiveControlController
SetAsActiveTabOnMainPanel(Control dynamicControl) | Deltares.Standard.Forms.DExpress.IMainFormActiveControlController
Generated on Tue Dec 15 2015 18:14:57 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.IMainFormPlugin Interface Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • IMainFormPlugin
Public Member Functions | List of all members
Deltares.Standard.Forms.DExpress.IMainFormPlugin Interface Reference

TODO: Comment More...

Inheritance diagram for Deltares.Standard.Forms.DExpress.IMainFormPlugin:
Deltares.DSoilModel.Forms.DSoilModelPlugin Deltares.Geometry.Forms.GeometryPlugin Deltares.Geotechnics.Forms.GeotechnicsPlugin Deltares.Standard.Forms.DExpress.AggregatePlugin< ProjectType >

Public Member Functions

void | Configure (MainForm mainForm)
void | Assign (object source)

Detailed Description

TODO: Comment

Generated on Tue Dec 15 2015 18:14:58 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • IMainFormPlugin
Deltares.Standard.Forms.DExpress.IMainFormPlugin Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.IMainFormPlugin, including all inherited members.

Assign(object source) (defined in Deltares.Standard.Forms.DExpress.IMainFormPlugin) | Deltares.Standard.Forms.DExpress.IMainFormPlugin
Configure(MainForm mainForm) (defined in Deltares.Standard.Forms.DExpress.IMainFormPlugin) | Deltares.Standard.Forms.DExpress.IMainFormPlugin
Generated on Tue Dec 15 2015 18:14:58 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.IPropertySubControlFactory< out out ControlType > Interface Template Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • IPropertySubControlFactory
Public Member Functions | Properties | List of all members
Deltares.Standard.Forms.DExpress.IPropertySubControlFactory< out out ControlType > Interface Template Reference

Public Member Functions

ControlType CreateBoundControl (PropertyInfo propertyInfo, Type dataType, Component parentComponent)

Properties

Type ValueType [get]
Generated on Tue Dec 15 2015 18:14:58 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • IPropertySubControlFactory
Deltares.Standard.Forms.DExpress.IPropertySubControlFactory< out out ControlType > Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.IPropertySubControlFactory< out out ControlType >, including all inherited members.

CreateBoundControl(PropertyInfo propertyInfo, Type dataType, Component parentComponent) (defined in Deltares.Standard.Forms.DExpress.IPropertySubControlFactory< out out ControlType >) | Deltares.Standard.Forms.DExpress.IPropertySubControlFactory< out out ControlType >
ValueType (defined in Deltares.Standard.Forms.DExpress.IPropertySubControlFactory< out out ControlType >) | Deltares.Standard.Forms.DExpress.IPropertySubControlFactory< out out ControlType >
Generated on Tue Dec 15 2015 18:14:58 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.IShapeImporter Interface Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • IShapeImporter
Public Member Functions | Properties | List of all members
Deltares.Standard.Forms.DExpress.IShapeImporter Interface Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.IShapeImporter:
Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter Deltares.Standard.Forms.DExpress.ShapeImporters.LineStringImporter Deltares.Standard.Forms.DExpress.ShapeImporters.MultiLineStringImporter Deltares.Standard.Forms.DExpress.ShapeImporters.MultiPolygonImporter Deltares.Standard.Forms.DExpress.ShapeImporters.PointImporter Deltares.Standard.Forms.DExpress.ShapeImporters.PolygonImporter Deltares.Standard.Forms.DExpress.ShapeImporters.SmartLineStringImporter

Public Member Functions

void ImportShapeGeometry (IBasicGeometry geometry, object target)
Imports geometry data on the target object More...

Properties

GeometryTypes GeometryType [get]
Gets type of the geometry to import. More...

Member Function Documentation

void Deltares.Standard.Forms.DExpress.IShapeImporter.ImportShapeGeometry | ( | IBasicGeometry | geometry,
 |  | object | target
 | ) |  |

Imports geometry data on the target object

Parameters
geometry | The geometry data to import from
target | The target object to set data on

Implemented in Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter, Deltares.Standard.Forms.DExpress.ShapeImporters.LineStringImporter, Deltares.Standard.Forms.DExpress.ShapeImporters.SmartLineStringImporter, Deltares.Standard.Forms.DExpress.ShapeImporters.PolygonImporter, Deltares.Standard.Forms.DExpress.ShapeImporters.PointImporter, Deltares.Standard.Forms.DExpress.ShapeImporters.MultiLineStringImporter, and Deltares.Standard.Forms.DExpress.ShapeImporters.MultiPolygonImporter.

Property Documentation

GeometryTypes Deltares.Standard.Forms.DExpress.IShapeImporter.GeometryType
get

Gets type of the geometry to import.

The type of the geometry to import.

Referenced by Deltares.Standard.Forms.DExpress.AbstractShapeFileImporter.RegisterShapeImporter().

Generated on Tue Dec 15 2015 18:14:58 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • IShapeImporter
Deltares.Standard.Forms.DExpress.IShapeImporter Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.IShapeImporter, including all inherited members.

GeometryType | Deltares.Standard.Forms.DExpress.IShapeImporter
ImportShapeGeometry(IBasicGeometry geometry, object target) | Deltares.Standard.Forms.DExpress.IShapeImporter
Generated on Tue Dec 15 2015 18:14:58 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.LabelBinding Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • LabelBinding
Public Member Functions | Properties | List of all members
Deltares.Standard.Forms.DExpress.LabelBinding Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.LabelBinding:
Deltares.Standard.Forms.DExpress.ControlBinding Deltares.Standard.Forms.DExpress.ComponentBinding Deltares.Standard.Forms.DExpress.ComponentWrappers.IGetBoundControl

Public Member Functions

LabelBinding (Component component)
override void | SetValue (object value)
override void | SetEnabled (bool enabled)
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.ControlBinding
override void | SetVisible (bool visible)
override void | SetLabel (string text)
Sets the label/title/name associated with this control. More...
override void | SetDescription (string description)
Sets the textual description associated with this control. More...
override void | SetForegroundColor (Color color)
override void | SetBackgroundColor (Color color)
override void | Invalidate ()
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
ComponentBinding (Component component)
virtual void | Initialize (BindPropertyInfo propertyInfo, params string[] properties)
virtual void | Initialize (BindPropertyInfo propertyInfo, Type rootObjectType, params string[] properties)
virtual void | SetTrueMapping (object trueMapping)
virtual void | SetValue (object value, object parent)
virtual void | SetDomain (ICollection collection)
virtual object | GetValue ()
virtual void | Refresh ()
virtual void | RegisterSelectionAssignment (Component targetComponent, IConverter converter=null)
Indicates that the selection of the bound control must be assigned to another control. More...
virtual void | SetControlColors (Color fore, Color back)
Sets the controls foreground and background colors. Can be overridden by a specific binding to set other colors if necessary. More...

Properties

override bool | IsTransparant [get]
- Properties inherited from Deltares.Standard.Forms.DExpress.ControlBinding
ToolTip | Tooltip [get]
Gets the tooltip for the bound control. More...
Control | BoundControl [get]
- Properties inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
Component | Component [get]
virtual bool | IsTransparant [get]
virtual HandleType | HandleDelayed [get]
virtual bool | HasDomain [get]
- Properties inherited from Deltares.Standard.Forms.DExpress.ComponentWrappers.IGetBoundControl
Control | BoundControl [get]

Additional Inherited Members

- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.ControlBinding
ControlBinding (Component component)
virtual void | OnToolTipShown (PopupEventArgs e)
Called when Tooltip is shown, and fires ToolTipShown event. More...
virtual void | OnToolTipClosed ()
Called when Tooltip is hidden, and fires ToolTipHidden. More...
void | ThreadSafeRefresh ()
override void | Dispose (bool disposing)
- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
void | RaiseValueChanged ()
void | RaiseLeave ()
void | RaiseActionPerformed ()
Type | GetGenericType (Type type)
string | ValueToString (object value)
bool | IsAssociatedPropertyVisible (object source, BindPropertyInfo associatedPropertyInfo)
Indicates whether the associated property (i.e. the property which is used to display the original property in a textbox) is visible More...
void | EditFileInfo (object source, BindPropertyInfo propertyInfo)
string | EditFileInfo (string value, string format, string label, string description, bool isDirectory)
string | GetDoubleString (string text)
bool | HasValidNumericValue (string text)
double | GetNumericValue (string text)
List< BindPropertyInfo > | GetDictionaryProperties (ICollection domain, BindPropertyInfo dynamicPropertyInfo)
- Protected Attributes inherited from Deltares.Standard.Forms.DExpress.ControlBinding
readonly ToolTip | tooltip
string | Description
The textual description associated with this

See also
Control

. More...

string | Label
The label/title/name associated with this Control. More...
- Protected Attributes inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
BindPropertyInfo | propInfo
- Events inherited from Deltares.Standard.Forms.DExpress.ControlBinding
ToolTipVisibilityEventHandler | ToolTipHidden
ToolTipVisibilityEventHandler | ToolTipShown
- Events inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
EventHandler< EventArgs > | ActionPerformed
EventHandler< EventArgs > | Leave
EventHandler< EventArgs > | ValueChanged
Generated on Tue Dec 15 2015 18:14:58 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • LabelBinding
Deltares.Standard.Forms.DExpress.LabelBinding Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.LabelBinding, including all inherited members.

ActionPerformed (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
BoundControl (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding |
Component (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ComponentBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ControlBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Description | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Dispose(bool disposing) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | protected
EditFileInfo(object source, BindPropertyInfo propertyInfo) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
EditFileInfo(string value, string format, string label, string description, bool isDirectory) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetDictionaryProperties(ICollection domain, BindPropertyInfo dynamicPropertyInfo) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetDoubleString(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetGenericType(Type type) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetNumericValue(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetValue() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
HandleDelayed (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
HasDomain (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
HasValidNumericValue(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Initialize(BindPropertyInfo propertyInfo, params string[] properties) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
Initialize(BindPropertyInfo propertyInfo, Type rootObjectType, params string[] properties) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
Invalidate() (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
IsAssociatedPropertyVisible(object source, BindPropertyInfo associatedPropertyInfo) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
IsTransparant (defined in Deltares.Standard.Forms.DExpress.LabelBinding) | Deltares.Standard.Forms.DExpress.LabelBinding |
Label | Deltares.Standard.Forms.DExpress.ControlBinding | protected
LabelBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.LabelBinding) | Deltares.Standard.Forms.DExpress.LabelBinding |
Leave (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
OnToolTipClosed() | Deltares.Standard.Forms.DExpress.ControlBinding | protectedvirtual
OnToolTipShown(PopupEventArgs e) | Deltares.Standard.Forms.DExpress.ControlBinding | protectedvirtual
propInfo (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseActionPerformed() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseLeave() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseValueChanged() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Refresh() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
RegisterSelectionAssignment(Component targetComponent, IConverter converter=null) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetBackgroundColor(Color color) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
SetControlColors(Color fore, Color back) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetDescription(string description) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
SetDomain(ICollection collection) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetEnabled(bool enabled) (defined in Deltares.Standard.Forms.DExpress.LabelBinding) | Deltares.Standard.Forms.DExpress.LabelBinding | virtual
SetForegroundColor(Color color) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
SetLabel(string text) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
SetTrueMapping(object trueMapping) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetValue(object value) (defined in Deltares.Standard.Forms.DExpress.LabelBinding) | Deltares.Standard.Forms.DExpress.LabelBinding | virtual
SetValue(object value, object parent) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetVisible(bool visible) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
ThreadSafeRefresh() (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Tooltip | Deltares.Standard.Forms.DExpress.ControlBinding | protected
tooltip (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | protected
ToolTipHidden (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding |
ToolTipShown (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding |
ValueChanged (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ValueToString(object value) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Generated on Tue Dec 15 2015 18:14:58 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.LabelControlBinding Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • LabelControlBinding
Public Member Functions | Properties | List of all members
Deltares.Standard.Forms.DExpress.LabelControlBinding Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.LabelControlBinding:
Deltares.Standard.Forms.DExpress.BaseControlBinding Deltares.Standard.Forms.DExpress.ControlBinding Deltares.Standard.Forms.DExpress.ComponentBinding Deltares.Standard.Forms.DExpress.ComponentWrappers.IGetBoundControl

Public Member Functions

LabelControlBinding (Component component)
override void | SetEnabled (bool enabled)
override void | SetValue (object value)
override void | SetLabel (string text)
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.BaseControlBinding
override void | Initialize (BindPropertyInfo propertyInfo, params string[] properties)
override void | SetDescription (string description)
override void | Invalidate ()
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.ControlBinding
override void | SetVisible (bool visible)
override void | SetDescription (string description)
Sets the textual description associated with this control. More...
override void | SetForegroundColor (Color color)
override void | SetBackgroundColor (Color color)
override void | Invalidate ()
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
ComponentBinding (Component component)
virtual void | Initialize (BindPropertyInfo propertyInfo, Type rootObjectType, params string[] properties)
virtual void | SetTrueMapping (object trueMapping)
virtual void | SetValue (object value, object parent)
virtual void | SetDomain (ICollection collection)
virtual object | GetValue ()
virtual void | Refresh ()
virtual void | RegisterSelectionAssignment (Component targetComponent, IConverter converter=null)
Indicates that the selection of the bound control must be assigned to another control. More...
virtual void | SetControlColors (Color fore, Color back)
Sets the controls foreground and background colors. Can be overridden by a specific binding to set other colors if necessary. More...

Properties

override bool | IsTransparant [get]
- Properties inherited from Deltares.Standard.Forms.DExpress.ControlBinding
ToolTip | Tooltip [get]
Gets the tooltip for the bound control. More...
Control | BoundControl [get]
- Properties inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
Component | Component [get]
virtual bool | IsTransparant [get]
virtual HandleType | HandleDelayed [get]
virtual bool | HasDomain [get]
- Properties inherited from Deltares.Standard.Forms.DExpress.ComponentWrappers.IGetBoundControl
Control | BoundControl [get]

Additional Inherited Members

- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.BaseControlBinding
BaseControlBinding (Component component)
DXPopupMenu | GetPopupMenu ()
This method uses reflection to make the context menu accessible, which otherwise is protected. The Menu property is implemented for TextEdit, so we first make sure the control is actually of this type. More...
override void | OnToolTipShown (PopupEventArgs e)
Called when Tooltip is shown, and fires ToolTipShown event. More...
override void | OnToolTipClosed ()
Called when Tooltip is hidden, and fires ToolTipHidden. More...
override void | Dispose (bool disposing)
- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.ControlBinding
ControlBinding (Component component)
void | ThreadSafeRefresh ()
override void | Dispose (bool disposing)
- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
void | RaiseValueChanged ()
void | RaiseLeave ()
void | RaiseActionPerformed ()
Type | GetGenericType (Type type)
string | ValueToString (object value)
bool | IsAssociatedPropertyVisible (object source, BindPropertyInfo associatedPropertyInfo)
Indicates whether the associated property (i.e. the property which is used to display the original property in a textbox) is visible More...
void | EditFileInfo (object source, BindPropertyInfo propertyInfo)
string | EditFileInfo (string value, string format, string label, string description, bool isDirectory)
string | GetDoubleString (string text)
bool | HasValidNumericValue (string text)
double | GetNumericValue (string text)
List< BindPropertyInfo > | GetDictionaryProperties (ICollection domain, BindPropertyInfo dynamicPropertyInfo)
- Protected Attributes inherited from Deltares.Standard.Forms.DExpress.BaseControlBinding
readonly SuperToolTip | superTip
- Protected Attributes inherited from Deltares.Standard.Forms.DExpress.ControlBinding
readonly ToolTip | tooltip
string | Description
The textual description associated with this

See also
Control

. More...

string | Label
The label/title/name associated with this Control. More...
- Protected Attributes inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
BindPropertyInfo | propInfo
- Events inherited from Deltares.Standard.Forms.DExpress.ControlBinding
ToolTipVisibilityEventHandler | ToolTipHidden
ToolTipVisibilityEventHandler | ToolTipShown
- Events inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
EventHandler< EventArgs > | ActionPerformed
EventHandler< EventArgs > | Leave
EventHandler< EventArgs > | ValueChanged
Generated on Tue Dec 15 2015 18:14:58 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • LabelControlBinding
Deltares.Standard.Forms.DExpress.LabelControlBinding Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.LabelControlBinding, including all inherited members.

ActionPerformed (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
BaseControlBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.BaseControlBinding) | Deltares.Standard.Forms.DExpress.BaseControlBinding | protected
BoundControl (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding |
Component (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ComponentBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ControlBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Description | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Dispose(bool disposing) (defined in Deltares.Standard.Forms.DExpress.BaseControlBinding) | Deltares.Standard.Forms.DExpress.BaseControlBinding | protected
EditFileInfo(object source, BindPropertyInfo propertyInfo) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
EditFileInfo(string value, string format, string label, string description, bool isDirectory) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetDictionaryProperties(ICollection domain, BindPropertyInfo dynamicPropertyInfo) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetDoubleString(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetGenericType(Type type) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetNumericValue(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetPopupMenu() | Deltares.Standard.Forms.DExpress.BaseControlBinding | protected
GetValue() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
HandleDelayed (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
HasDomain (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
HasValidNumericValue(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Initialize(BindPropertyInfo propertyInfo, params string[] properties) (defined in Deltares.Standard.Forms.DExpress.BaseControlBinding) | Deltares.Standard.Forms.DExpress.BaseControlBinding | virtual
Initialize(BindPropertyInfo propertyInfo, Type rootObjectType, params string[] properties) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
Invalidate() (defined in Deltares.Standard.Forms.DExpress.BaseControlBinding) | Deltares.Standard.Forms.DExpress.BaseControlBinding | virtual
IsAssociatedPropertyVisible(object source, BindPropertyInfo associatedPropertyInfo) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
IsTransparant (defined in Deltares.Standard.Forms.DExpress.LabelControlBinding) | Deltares.Standard.Forms.DExpress.LabelControlBinding |
Label | Deltares.Standard.Forms.DExpress.ControlBinding | protected
LabelControlBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.LabelControlBinding) | Deltares.Standard.Forms.DExpress.LabelControlBinding |
Leave (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
OnToolTipClosed() | Deltares.Standard.Forms.DExpress.BaseControlBinding | protectedvirtual
OnToolTipShown(PopupEventArgs e) | Deltares.Standard.Forms.DExpress.BaseControlBinding | protectedvirtual
propInfo (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseActionPerformed() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseLeave() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseValueChanged() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Refresh() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
RegisterSelectionAssignment(Component targetComponent, IConverter converter=null) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetBackgroundColor(Color color) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
SetControlColors(Color fore, Color back) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetDescription(string description) (defined in Deltares.Standard.Forms.DExpress.BaseControlBinding) | Deltares.Standard.Forms.DExpress.BaseControlBinding | virtual
SetDomain(ICollection collection) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetEnabled(bool enabled) (defined in Deltares.Standard.Forms.DExpress.LabelControlBinding) | Deltares.Standard.Forms.DExpress.LabelControlBinding | virtual
SetForegroundColor(Color color) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
SetLabel(string text) (defined in Deltares.Standard.Forms.DExpress.LabelControlBinding) | Deltares.Standard.Forms.DExpress.LabelControlBinding | virtual
SetTrueMapping(object trueMapping) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetValue(object value) (defined in Deltares.Standard.Forms.DExpress.LabelControlBinding) | Deltares.Standard.Forms.DExpress.LabelControlBinding | virtual
SetValue(object value, object parent) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetVisible(bool visible) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
superTip (defined in Deltares.Standard.Forms.DExpress.BaseControlBinding) | Deltares.Standard.Forms.DExpress.BaseControlBinding | protected
ThreadSafeRefresh() (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | protected
tooltip (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Tooltip | Deltares.Standard.Forms.DExpress.ControlBinding | protected
ToolTipHidden (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding |
ToolTipShown (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding |
ValueChanged (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ValueToString(object value) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Generated on Tue Dec 15 2015 18:14:58 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.LateBindingComponent Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • LateBindingComponent
Package Functions | Properties | List of all members
Deltares.Standard.Forms.DExpress.LateBindingComponent Class Reference

Package Functions

LateBindingComponent (Component parent)
bool NeedUpdate (Component parent)

Properties

Component | Parent [get]
bool | Dirty [get, set]
Generated on Tue Dec 15 2015 18:14:58 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • LateBindingComponent
Deltares.Standard.Forms.DExpress.LateBindingComponent Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.LateBindingComponent, including all inherited members.

Dirty (defined in Deltares.Standard.Forms.DExpress.LateBindingComponent) | Deltares.Standard.Forms.DExpress.LateBindingComponent |
LateBindingComponent(Component parent) (defined in Deltares.Standard.Forms.DExpress.LateBindingComponent) | Deltares.Standard.Forms.DExpress.LateBindingComponent | package
NeedUpdate(Component parent) (defined in Deltares.Standard.Forms.DExpress.LateBindingComponent) | Deltares.Standard.Forms.DExpress.LateBindingComponent | package
Parent (defined in Deltares.Standard.Forms.DExpress.LateBindingComponent) | Deltares.Standard.Forms.DExpress.LateBindingComponent |
Generated on Tue Dec 15 2015 18:14:58 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.LessThanStrategy Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • LessThanStrategy
Public Member Functions | Protected Member Functions | List of all members
Deltares.Standard.Forms.DExpress.LessThanStrategy Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.LessThanStrategy:
Deltares.Standard.Forms.DExpress.GridEditValueStrategy

Public Member Functions

override double | DefaultForSelected (GridView view)
Determines the default value based on the selected values. Not all implementations will use the selected values, but by passing the view, we can generalize the method call. More...
override string | ToString ()
This method has to be overridden so it has a proper representation in the UI. More...
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.GridEditValueStrategy
void | EvaluateForSelected (GridView view, double modificationValue)
Sets new cell values by evaluating the modification value and using the current strategy. More...

Protected Member Functions

override double Evaluate (double value, double modificationValue)
The implementation of this method is used in the EvaluateForSelected method. More...

Additional Inherited Members

- Static Public Attributes inherited from Deltares.Standard.Forms.DExpress.GridEditValueStrategy
static readonly GridEditValueStrategy[] Strategies
Collection of all the strategies which are defined in this file. This is a static list so the strategies will only be instantiated once. Using instantiations make polymorphism possible. More...

Member Function Documentation

override double Deltares.Standard.Forms.DExpress.LessThanStrategy.DefaultForSelected ( GridView view )
virtual

Determines the default value based on the selected values. Not all implementations will use the selected values, but by passing the view, we can generalize the method call.

Parameters
view The view (which may not be used at all) containing selected values (or not).
Returns
A sensible default for the strategy, or null if no sensible default can be given.

Implements Deltares.Standard.Forms.DExpress.GridEditValueStrategy.

override double Deltares.Standard.Forms.DExpress.LessThanStrategy.Evaluate | ( | double | value,
 |  | double | modificationValue
 | ) |  |
protectedvirtual

The implementation of this method is used in the EvaluateForSelected method.

Parameters
value | The current value.
modificationValue | The value used in evaluating a new value.
Returns
The new value.

Implements Deltares.Standard.Forms.DExpress.GridEditValueStrategy.

override string Deltares.Standard.Forms.DExpress.LessThanStrategy.ToString ( )
virtual

This method has to be overridden so it has a proper representation in the UI.

Returns

Implements Deltares.Standard.Forms.DExpress.GridEditValueStrategy.

Generated on Tue Dec 15 2015 18:14:59 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • LessThanStrategy
Deltares.Standard.Forms.DExpress.LessThanStrategy Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.LessThanStrategy, including all inherited members.

DefaultForSelected(GridView view) | Deltares.Standard.Forms.DExpress.LessThanStrategy | virtual
Evaluate(double value, double modificationValue) | Deltares.Standard.Forms.DExpress.LessThanStrategy | protectedvirtual
EvaluateForSelected(GridView view, double modificationValue) | Deltares.Standard.Forms.DExpress.GridEditValueStrategy |
Strategies | Deltares.Standard.Forms.DExpress.GridEditValueStrategy | static
ToString() | Deltares.Standard.Forms.DExpress.LessThanStrategy | virtual
Generated on Tue Dec 15 2015 18:14:59 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.ListBoxBinding Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • ListBoxBinding
Public Member Functions | List of all members
Deltares.Standard.Forms.DExpress.ListBoxBinding Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.ListBoxBinding:
Deltares.Standard.Forms.DExpress.ControlBinding Deltares.Standard.Forms.DExpress.ComponentBinding Deltares.Standard.Forms.DExpress.ComponentWrappers.IGetBoundControl

Public Member Functions

ListBoxBinding (Component component)
override void | Initialize (BindPropertyInfo propertyInfo, params string[] properties)
override void | SetEnabled (bool enabled)
override void | SetValue (object value)
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.ControlBinding
override void | SetVisible (bool visible)
override void | SetLabel (string text)
Sets the label/title/name associated with this control. More...
override void | SetDescription (string description)
Sets the textual description associated with this control. More...
override void | SetForegroundColor (Color color)
override void | SetBackgroundColor (Color color)
override void | Invalidate ()
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
ComponentBinding (Component component)
virtual void | Initialize (BindPropertyInfo propertyInfo, Type rootObjectType, params string[] properties)
virtual void | SetTrueMapping (object trueMapping)
virtual void | SetValue (object value, object parent)
virtual void | SetDomain (ICollection collection)
virtual object | GetValue ()
virtual void | Refresh ()
virtual void | RegisterSelectionAssignment (Component targetComponent, IConverter converter=null)
Indicates that the selection of the bound control must be assigned to another control. More...
virtual void | SetControlColors (Color fore, Color back)
Sets the controls foreground and background colors. Can be overridden by a specific binding to set other colors if necessary. More...

Additional Inherited Members

- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.ControlBinding
ControlBinding (Component component)
virtual void | OnToolTipShown (PopupEventArgs e)
Called when Tooltip is shown, and fires ToolTipShown event. More...
virtual void | OnToolTipClosed ()
Called when Tooltip is hidden, and fires ToolTipHidden. More...
void | ThreadSafeRefresh ()
override void | Dispose (bool disposing)
- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
void | RaiseValueChanged ()
void | RaiseLeave ()
void | RaiseActionPerformed ()
Type | GetGenericType (Type type)
string | ValueToString (object value)
bool | IsAssociatedPropertyVisible (object source, BindPropertyInfo associatedPropertyInfo)
Indicates whether the associated property (i.e. the property which is used to display the original property in a textbox) is visible More...
void | EditFileInfo (object source, BindPropertyInfo propertyInfo)
string | EditFileInfo (string value, string format, string label, string description, bool isDirectory)
string | GetDoubleString (string text)
bool | HasValidNumericValue (string text)
double | GetNumericValue (string text)
List< BindPropertyInfo > | GetDictionaryProperties (ICollection domain, BindPropertyInfo dynamicPropertyInfo)
- Protected Attributes inherited from Deltares.Standard.Forms.DExpress.ControlBinding
readonly ToolTip | tooltip
string | Description
The textual description associated with this

See also
Control

. More...

string | Label
The label/title/name associated with this Control. More...
- Protected Attributes inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
BindPropertyInfo | propInfo
- Properties inherited from Deltares.Standard.Forms.DExpress.ControlBinding
ToolTip | Tooltip [get]
Gets the tooltip for the bound control. More...
Control | BoundControl [get]
- Properties inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
Component | Component [get]
virtual bool | IsTransparant [get]
virtual HandleType | HandleDelayed [get]
virtual bool | HasDomain [get]
- Properties inherited from Deltares.Standard.Forms.DExpress.ComponentWrappers.IGetBoundControl
Control | BoundControl [get]
- Events inherited from Deltares.Standard.Forms.DExpress.ControlBinding
ToolTipVisibilityEventHandler | ToolTipHidden
ToolTipVisibilityEventHandler | ToolTipShown
- Events inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
EventHandler< EventArgs > | ActionPerformed
EventHandler< EventArgs > | Leave
EventHandler< EventArgs > | ValueChanged
Generated on Tue Dec 15 2015 18:14:59 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • ListBoxBinding
Deltares.Standard.Forms.DExpress.ListBoxBinding Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.ListBoxBinding, including all inherited members.

ActionPerformed (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
BoundControl (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding |
Component (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ComponentBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ControlBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Description | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Dispose(bool disposing) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | protected
EditFileInfo(object source, BindPropertyInfo propertyInfo) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
EditFileInfo(string value, string format, string label, string description, bool isDirectory) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetDictionaryProperties(ICollection domain, BindPropertyInfo dynamicPropertyInfo) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetDoubleString(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetGenericType(Type type) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetNumericValue(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetValue() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
HandleDelayed (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
HasDomain (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
HasValidNumericValue(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Initialize(BindPropertyInfo propertyInfo, params string[] properties) (defined in Deltares.Standard.Forms.DExpress.ListBoxBinding) | Deltares.Standard.Forms.DExpress.ListBoxBinding | virtual
Initialize(BindPropertyInfo propertyInfo, Type rootObjectType, params string[] properties) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
Invalidate() (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
IsAssociatedPropertyVisible(object source, BindPropertyInfo associatedPropertyInfo) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
IsTransparant (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
Label | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Leave (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ListBoxBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.ListBoxBinding) | Deltares.Standard.Forms.DExpress.ListBoxBinding |
OnToolTipClosed() | Deltares.Standard.Forms.DExpress.ControlBinding | protectedvirtual
OnToolTipShown(PopupEventArgs e) | Deltares.Standard.Forms.DExpress.ControlBinding | protectedvirtual
propInfo (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseActionPerformed() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseLeave() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseValueChanged() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Refresh() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
RegisterSelectionAssignment(Component targetComponent, IConverter converter=null) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetBackgroundColor(Color color) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
SetControlColors(Color fore, Color back) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetDescription(string description) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
SetDomain(ICollection collection) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetEnabled(bool enabled) (defined in Deltares.Standard.Forms.DExpress.ListBoxBinding) | Deltares.Standard.Forms.DExpress.ListBoxBinding | virtual
SetForegroundColor(Color color) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
SetLabel(string text) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
SetTrueMapping(object trueMapping) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetValue(object value) (defined in Deltares.Standard.Forms.DExpress.ListBoxBinding) | Deltares.Standard.Forms.DExpress.ListBoxBinding | virtual
SetValue(object value, object parent) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetVisible(bool visible) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
ThreadSafeRefresh() (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | protected
tooltip (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Tooltip | Deltares.Standard.Forms.DExpress.ControlBinding | protected
ToolTipHidden (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding |
ToolTipShown (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding |
ValueChanged (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ValueToString(object value) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Generated on Tue Dec 15 2015 18:14:59 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.ListViewControl Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • ListViewControl
Public Member Functions | Public Attributes | Protected Member Functions | Properties | List of all members
Deltares.Standard.Forms.DExpress.ListViewControl Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.ListViewControl:

Public Member Functions

IEnumerable< Component > GetChildComponents ()

Public Attributes

DevExpress.XtraEditors.ImageListBoxControl ImageListBox

Protected Member Functions

override void Dispose (bool disposing)
Clean up any resources being used. More...

Properties

bool | SendSelectionChanged [get, set]
PropertyEditorReactionType | PropertyEditorReactionType [get, set]

Member Function Documentation

override void Deltares.Standard.Forms.DExpress.ListViewControl.Dispose ( bool disposing )
protected

Clean up any resources being used.

Parameters
disposing true if managed resources should be disposed; otherwise, false.
Generated on Tue Dec 15 2015 18:14:59 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • ListViewControl
Deltares.Standard.Forms.DExpress.ListViewControl Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.ListViewControl, including all inherited members.

Dispose(bool disposing) | Deltares.Standard.Forms.DExpress.ListViewControl | protected
GetChildComponents() (defined in Deltares.Standard.Forms.DExpress.ListViewControl) | Deltares.Standard.Forms.DExpress.ListViewControl |
ImageListBox (defined in Deltares.Standard.Forms.DExpress.ListViewControl) | Deltares.Standard.Forms.DExpress.ListViewControl |
ListViewControl() (defined in Deltares.Standard.Forms.DExpress.ListViewControl) | Deltares.Standard.Forms.DExpress.ListViewControl |
PropertyEditorReactionType (defined in Deltares.Standard.Forms.DExpress.ListViewControl) | Deltares.Standard.Forms.DExpress.ListViewControl |
SendSelectionChanged (defined in Deltares.Standard.Forms.DExpress.ListViewControl) | Deltares.Standard.Forms.DExpress.ListViewControl |
Generated on Tue Dec 15 2015 18:14:59 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.LocalizationSupport Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • LocalizationSupport
Static Public Member Functions | List of all members
Deltares.Standard.Forms.DExpress.LocalizationSupport Class Reference

Allows components to register to be automatically translated. More...

Static Public Member Functions

static void | Register (Type translationParent, IEnumerable< KeyValuePair< object, string >> componentTranslationKeyAssociations)
Registers a set of components to be automatically translated using the given translation keys. More...
static void | Register (Type type, params object[] components)
Registers a set of components to be automatically translated using translation keys read from Control.Text or similar property if that is available. More...
static void | Unregister (params object[] components)
Removes the registration for the given components. More...
static void | RegisterAndTranslate (Type type, IDictionary< object, string > componentTranslationKeyAssociations)
Registers a set of components for automatic translations using the given translation keys and translates them immediately. More...
static void | RegisterAndTranslate (Type type, params object[] components)
Registers a set of components for automatic translations, using translation keys read from Control.Text or similar property if that is available, and translates them immediately. More...
static void | TranslateAll ()
static string | GetText (object component)
Gets the translation key from Control.Text or similar property if that is available, or from object.ToString if all fails. More...
static void | SetText (object component, string text)

Detailed Description

Allows components to register to be automatically translated.

Member Function Documentation

static string Deltares.Standard.Forms.DExpress.LocalizationSupport.GetText ( object component )
static

Gets the translation key from Control.Text or similar property if that is available, or from object.ToString if all fails.

Parameters
component The component.
Returns
static void Deltares.Standard.Forms.DExpress.LocalizationSupport.Register | ( | Type | translationParent,
 |  | IEnumerable< KeyValuePair< object, string >> | componentTranslationKeyAssociations
 | ) |  |
static

Registers a set of components to be automatically translated using the given translation keys.

Parameters
translationParent | The parent type used to determine which translation file to reference.
componentTranslationKeyAssociations | Collection of components with their corresponding translation ID.

Registration does not cause translation to occur. The registered controls will be translated when a change in language occurs or a 'translate all' is performed.

Referenced by Deltares.Standard.Forms.DExpress.MapTools.AddFeatureMapTool.AddFeatureMapTool(), Deltares.Standard.Forms.DExpress.MainForm.CreateSettingsDialog(), Deltares.Standard.Forms.DExpress.MapTools.DeleteFeatureMapTool.DeleteFeatureMapTool(), Deltares.Standard.Forms.DExpress.GeometryEditor.GeometryEditor(), and Deltares.Standard.Forms.DExpress.MainForm.UseTables().

static void Deltares.Standard.Forms.DExpress.LocalizationSupport.Register | ( | Type | type,
 |  | params object[] | components
 | ) |  |
static

Registers a set of components to be automatically translated using translation keys read from Control.Text or similar property if that is available.

Parameters
type | The parent type used to determine which translation file to reference.
components | Collection of components.

Falls back on object.ToString() in case no property similar to Control.Text exists.

Registration does not cause translation to occur. The registered controls will be translated when a change in language occurs or a 'translate all' is performed.

static void Deltares.Standard.Forms.DExpress.LocalizationSupport.RegisterAndTranslate | ( | Type | type,
 |  | IDictionary< object, string > | componentTranslationKeyAssociations
 | ) |  |
static

Registers a set of components for automatic translations using the given translation keys and translates them immediately.

Parameters
type | The parent type used to determine which translation file to reference.
componentTranslationKeyAssociations | Collection of components with their corresponding translation ID.

Referenced by Deltares.Standard.Forms.DExpress.MainForm.AddProgramSettingsToSettingsDialog(), Deltares.Standard.Forms.DExpress.MainForm.AddUnitsSettingsToSettingsDialog(), Deltares.Geotechnics.Forms.BondStressCurveControl.BondStressCurveControl(), Deltares.Geotechnics.Forms.BoringControl.BoringControl(), Deltares.Geotechnics.Forms.CPTControl.CPTControl(), Deltares.Geotechnics.Forms.DesignPointControl.DesignPointControl(), Deltares.Geotechnics.Forms.DikeLineControl.DikeLineControl(), Deltares.Standard.Forms.DExpress.DynamicPropertyTabControl< T >.DynamicPropertyTabControl(), Deltares.Geotechnics.Forms.HydraulicBoundaryControl.HydraulicBoundaryControl(), Deltares.Geotechnics.Forms.ProbabilisticControl.ProbabilisticControl(), Deltares.Geotechnics.Forms.SoilBondStressCurveControl.SoilBondStressCurveControl(), Deltares.Geotechnics.Forms.SoilProfile1DControl.SoilProfile1DControl(), Deltares.Geotechnics.Forms.SoilProfile2DControl.SoilProfile2DControl(), Deltares.Geotechnics.Forms.SoilStressCurveControl.SoilStressCurveControl(), and Deltares.Geotechnics.Forms.StressCurveControl.StressCurveControl().

static void Deltares.Standard.Forms.DExpress.LocalizationSupport.RegisterAndTranslate | ( | Type | type,
 |  | params object[] | components
 | ) |  |
static

Registers a set of components for automatic translations, using translation keys read from Control.Text or similar property if that is available, and translates them immediately.

Parameters
type | The parent type used to determine which translation file to reference.
components | Collection of components.

Falls back on object.ToString() in case no property similar to Control.Text exists.

static void Deltares.Standard.Forms.DExpress.LocalizationSupport.Unregister ( params object[] components )
static

Removes the registration for the given components.

Parameters
components The components.
Generated on Tue Dec 15 2015 18:14:59 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • LocalizationSupport
Deltares.Standard.Forms.DExpress.LocalizationSupport Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.LocalizationSupport, including all inherited members.

GetText(object component) | Deltares.Standard.Forms.DExpress.LocalizationSupport | static
Register(Type translationParent, IEnumerable< KeyValuePair< object, string >> componentTranslationKeyAssociations) | Deltares.Standard.Forms.DExpress.LocalizationSupport | static
Register(Type type, params object[] components) | Deltares.Standard.Forms.DExpress.LocalizationSupport | static
RegisterAndTranslate(Type type, IDictionary< object, string > componentTranslationKeyAssociations) | Deltares.Standard.Forms.DExpress.LocalizationSupport | static
RegisterAndTranslate(Type type, params object[] components) | Deltares.Standard.Forms.DExpress.LocalizationSupport | static
SetText(object component, string text) (defined in Deltares.Standard.Forms.DExpress.LocalizationSupport) | Deltares.Standard.Forms.DExpress.LocalizationSupport | static
TranslateAll() (defined in Deltares.Standard.Forms.DExpress.LocalizationSupport) | Deltares.Standard.Forms.DExpress.LocalizationSupport | static
Unregister(params object[] components) | Deltares.Standard.Forms.DExpress.LocalizationSupport | static
Generated on Tue Dec 15 2015 18:14:59 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.MainForm Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • MainForm
Public Member Functions | Public Attributes | Protected Member Functions | Protected Attributes | Properties | Events | List of all members
Deltares.Standard.Forms.DExpress.MainForm Class Reference

TODO: Comment More...

Inheritance diagram for Deltares.Standard.Forms.DExpress.MainForm:
Deltares.Standard.Forms.IReloadableUI Deltares.Standard.Forms.DExpress.IMainForm Deltares.Standard.Forms.DExpress.IMainFormActiveControlController

Public Member Functions

MainForm ()
Initializes an empty instance of the MainForm class. More...
MainForm (Type splashAssemblyType, Image splashImage, bool splashDemoMode)
Initializes a new instance of the MainForm class, initializing the splash screen with the given parameters. TODO: Comment More...
void | RegisterUIComponent (IReloadManager aReloadManager)
Registers the Main Form to the given Reload Manager. More...
void | Reload ()
Reloads this instance. More...
void | UpdateData (params object[] models)
Updates the data. More...
string | GetLocalUserDeltaresDirectoryPath ()
Gets the local user deltares directory path. More...
virtual string | GetProjectFileName (string aDirectoryName, string aFileExtension)
Gives publisherEventArgs Project File Name For New and Save More...
virtual string | GetProjectFileName (string aFileExtension)
Gets the name of the project file with the given name extension. TODO: Comment More...
virtual bool | MRUFileOpen (string aFileName)
returns true if the MRU file is open. More...
virtual void | PopulateMRUList (string fileName)
Populates the MRU list. TODO: Comment More...
void | UpdateMenuTablesView (BarSubItem menu, XtraTabControl tabControl)
Updates the menu tables view. So make all the item visible which are also shown in the tableControl. More...
void | UseNavigation ()
Sets UseNavigation to true. More...
void | UseMap ()
Sets UseMap to true. More...
void | UseStatusBar ()
Sets UseStatusBar to true. More...
void | UseSpatialEditor ()
Sets UseSpatialEditor to true. More...
void | UseExtraGeometryEditor ()
Sets UseExtraGeometryEditor to true. More...
void | UseImage ()
Sets UseImage to true. More...
void | UseReport ()
Sets UseReport to true. More...
void | UseProperties ()
Sets UseProperties to true. More...
void | UseTables ()
Sets UseTables to true. More...
void | UseCharts ()
Uses DynamicChartControl More...
void | UseNavigation (bool use)
Uses NavigatorControl More...
void | UseMap (bool use)
Uses MapEditor More...
void | UseStatusBar (bool use)
Uses StatusBar More...
void | UseSpatialEditor (bool use)
Uses mainEsaOcxForm More...
void | UseExtraGeometryEditor (bool use)
Uses ExtraGeometryEditor More...
void | UseImage (bool use)
Uses DynamicImageControl More...
void | UseReport (bool use)
Uses DynamicReportControl More...
void | UseProperties (bool use)
Uses DynamicPropertyControl More...
void | UseTables (bool use, Type type, string caption)
Uses the tables. More...
void | UseTables (bool use)
Uses the tables. More...
void | ShowCharts ()
Shows the charts. More...
void | UseOutput ()
Uses the output. More...
void | UseValidation ()
Uses the validation. More...
void | UseResources ()
Uses the resources. More...
void | UseIcon (Icon aIcon)
Uses the icon. More...
void | CreateRecentlyUsedFilesButton (string aSavedFilePath)
Creates and assings the caption for 'recently used files' button. More...
void | RaiseBeginValidationOrSave ()
Calls Event OnBeginValidationOrSave. More...
void | AddTabPageToAboutDialog (string tabHeader, UserControl propertyControl, object data)
Adds the tab page to about dialog. More...
void | RemoveTabFromAboutDialog (UserControl propertyControl)
Removes the tab from the about dialog. More...
void | RegisterNewFileHandler (NewFile fileHandler)
Registers the new file handler. More...
void | RegisterOpenFileHandler (string extension, string filter, OpenFile openFileHandler)
Registers the open file handler. More...
void | ClearOpenFileHandlers ()
Clears the open file handlers. More...
void | RegisterSaveFileHandler (string extension, string filter, SaveFile saveFileHandler)
Registers the save file handler. More...
void | ClearSaveFileHandlers ()
Clears the save file handlers. More...
void | ProjectIsSaved (string fileName)
Sets the project with the given filename to saved. More...
bool | InitializeUIBeforeNewAndOpen ()
Prompt the user to save current changes to the project, returning false if the user chose not to save the project file. More...
void | SelectUnits ()
Selects the units. TODO: Comment More...
void | SelectProgramOptions ()
Selects the program options. More...
void | SelectLicense ()
Selects the program options. More...
void | CreateSettingsDialog (bool withProgramSettings=true, bool withUnitSettings=true)
Create the settings dialog and optionally add the program settings tab and the unit settings tab to it. The optional adding of the tabs is to allow plugins to add tabs in between. More...
void | AddProgramSettingsToSettingsDialog ()
Add the program settings tab to the settings dialog. More...
void | AddUnitsSettingsToSettingsDialog ()
Add the units settings tab to the settings dialog. More...
Control | AddTabPageToSettingsDialog (string settingsTitle, UserControl settingsControl, Object settingsObject)
Adds the tab page with the given properties to settings dialog. More...
void | ShowSettingsDialog (Control tabPage)
Shows the settings dialog. More...
void | SetMainWindowCaption (string aFileName)
Sets The Window Caption Displaying File Name More...
object | ShowForm (Control control)
loads the template dialog in to a form and displays it as a modless dialog More...
void | Register (object plugin)
Registers the specified plugin. More...
void | SetDefaultWidthPropertyWindow (int useWidth)
Sets the default width of the property window. More...
void | CreateAndRegisterPropertyFormFor< T > (IEnumerable< Expression< Func< T, object >>> propertyIncludeSet, params Type[] additionalTypes)
Creates and registers property form for given type. TODO: Comment More...
GridViewControl | RegisterTable< ContainerType, ObjectType > (Expression< Func< ContainerType, IEnumerable< ObjectType >>> listProperty, bool onlyShowDuringSelection=false)
Registers the table. More...
IEnumerable< GridViewControl > | RegisterTables< ContainerType > (bool onlyShowDuringSelection=false, params Expression< Func< ContainerType, IEnumerable< object >>>[] listProperties)
Registers the tables. More...
void | RegisterTableControl (Type type, Control control, string caption)
Registers the table control. More...
void | LoadDefaultLayoutXML (Assembly assembly, string resource)
Loads the XML holding the default layout. More...
void | SetAsActiveChart (Control myChart)
Sets a given control as the active chart. More...
void | SetAsActiveTable (Control table)
Sets given table as active table. More...
void | SetAsActiveTabOnMainPanel (Control dynamicControl)
Sets given control as active tab on main panel. More...
void | SetAsActivePropertyEditor (Control propertyControl)
Sets given control as active property editor. More...
bool | IsVisible (string property)
Determines whether the specified property is visible. More...
bool | IsEnabled (string property)
Determines whether the specified property is enabled. More...
string | GetName (string property)
string | GetDescription (string property)
string | GetCategory (string property)
string | GetFormat (string property)
Impact | GetImpact (string property)
UnitType | GetUnit (string property)
void | CreateAndRegisterPropertyFormFor< T > (params Expression< Func< T, object >>[] propertyIncludeSet)
Creates and registers a property form control for the given type. The control will be generated with a control factory using reflection. More...

Public Attributes

string | DefaultDirectory = Environment.GetFolderPath(Environment.SpecialFolder.Personal)
List< BarButtonItem > | NewMRUbuttonList = new List<BarButtonItem>()
DevExpress.XtraBars.BarManager | TemplateBarManager
DevExpress.XtraBars.BarButtonItem | NewWindowItem
DevExpress.XtraBars.BarButtonItem | Licensebutton
DevExpress.XtraBars.Bar | ToolBar
DevExpress.XtraBars.BarButtonItem | ServerButton
DevExpress.XtraBars.Docking.DockManager | MainDockManager
DevExpress.XtraEditors.LabelControl | DemoLabel
DevExpress.LookAndFeel.DefaultLookAndFeel | MStabMainLookAndFeel
Deltares.Standard.Forms.DExpress.DynamicResourcesControl | graphicalAssignForm
DynamicChartControl | DynamicChartControl
DevExpress.XtraBars.BarSubItem | ExportMenu
DevExpress.XtraBars.BarSubItem | FileMenu
DevExpress.XtraBars.Bar | MenuBar
DevExpress.XtraBars.BarSubItem | EditMenu
DevExpress.XtraBars.BarSubItem | ViewMenu
DevExpress.XtraBars.BarSubItem | HelpMenu
DevExpress.XtraBars.BarSubItem | ToolsMenu
DevExpress.XtraBars.BarSubItem | CalculationMenu
DevExpress.XtraBars.Docking.DockPanel | GeometryDockPanel
DynamicImageControl | DynamicImageControl
DevExpress.XtraBars.BarSubItem | ImportMenu
DynamicMessagesControl | MessagesControl
DevExpress.XtraBars.BarSubItem | ProjectMenu
DevExpress.XtraBars.BarButtonItem | ExitMenu
DevExpress.XtraBars.BarButtonItem | HelpWebsiteItem
DevExpress.XtraBars.Docking.DockPanel | MessagesDockPanel
DevExpress.XtraBars.Docking.DockPanel | ExtraGeometryDockPanel

Protected Member Functions

virtual void | HookUpWinFormsEvents ()
string | GetDefaultWindowViewFile ()
void | OnFormClosing (object sender, FormClosingEventArgs e)
override void | Dispose (bool disposing)
Clean up any resources being used. More...

Protected Attributes

bool | IsMergedTab = false
DevExpress.XtraBars.BarButtonItem | OpenItem
DevExpress.XtraBars.BarButtonItem | OpeninNewWindowItem
DevExpress.XtraBars.BarButtonItem | MainFormTemplateFileCloseItem
DevExpress.XtraBars.BarSubItem | MainFormTemplateFileImportItem
DevExpress.XtraBars.BarButtonItem | MainFormTemplateFileImportFileItem
DevExpress.XtraBars.BarButtonItem | MainFormTemplateFileImportDatabaseItem
DevExpress.XtraBars.BarSubItem | MainFormTemplateFileExportItem
DevExpress.XtraBars.BarButtonItem | MainFormTemplateFileExitItem
DevExpress.XtraBars.BarButtonItem | MainFormTemplateWindowTilesItem
DevExpress.XtraBars.BarButtonItem | MainFormTemplateWindowCascadeItem
DevExpress.XtraBars.BarButtonItem | MainFormTemplateWindowArrangeAllItem
DevExpress.XtraBars.BarButtonItem | HelpAboutItem
DevExpress.XtraBars.BarButtonItem | ReportSelectionMenuItem
DevExpress.XtraBars.BarButtonItem | ReportPreviewMenuItem
DevExpress.XtraBars.BarButtonItem | ReportPrintMenuItem
DevExpress.XtraBars.BarButtonItem | MStabToolBarValidateButton
DevExpress.Utils.ImageCollection | MStabMainFormImageCollection
DevExpress.XtraBars.BarButtonItem | abortButton
DevExpress.XtraBars.BarButtonItem | calculationBarItem
DevExpress.XtraBars.BarButtonItem | MainFormTemplateEditUndoItem
DevExpress.XtraBars.BarButtonItem | MainFormTemplateEditRedoItem
DevExpress.XtraBars.BarButtonItem | MainFormTemplateEditCutItem
DevExpress.XtraBars.BarButtonItem | MainFormTemplateToolsRenumberItem
DevExpress.XtraBars.BarButtonItem | MStabToolBarRenumberButton
DevExpress.XtraBars.Docking.DockPanel | TableDockPanel
DevExpress.XtraBars.Docking.ControlContainer | dockPanel1_Container
DynamicTableControl | dynamicTableControl
DevExpress.XtraBars.Docking.ControlContainer | dockPanel2_Container
DevExpress.XtraBars.Docking.ControlContainer | controlContainer1
DevExpress.XtraBars.Docking.ControlContainer | controlContainer3
DevExpress.XtraBars.Docking.ControlContainer | controlContainer5
DevExpress.XtraBars.Docking.ControlContainer | controlContainer4
DynamicPropertyControl | dynamicPropertyControl
DynamicOutputControl | dynamicOutputControl
Deltares.Standard.Forms.DExpress.GeometryEditor | mainEsaOcxForm
Deltares.Standard.Forms.DExpress.ReportDlg | dynamicReportControl
Deltares.Standard.Forms.DExpress.MapEditor | mapEditor

Properties

bool | UseTemplateDialog \MStab.chm" [get, set]
int | MaxCalculationCores [get, set]
LanguageType | UseSelectedLanguage [get, set]
bool | PluginSetDescriptionDialog [get, set]
string | DefaultLayoutXML [get, set]
Gets or sets the default layout XML. More...
List< string > | PreviousMRUList [get]
Gets the previous MRU list. More...
string | FileName [get, set]
Gets or sets the name of the application Template File. More...
bool | IsMainFormLoaded [get, set]
ProgramSettings | ProgramSettings [get]
Gets the program settings template. More...
List< VisualValidationResult > | ValidationResults [get]
Gets the validation results. More...
List< LogMessage > | LogMessages [get]
Gets the log messages. More...
IHelpFileManager | HelpFileManager [get, set]
The class used for help file integration. More...
virtual DynamicNavigatorControl | NavigatorControl [get, set]
virtual DynamicTableControl | DynamicTableControl [get, set]
virtual MapEditor | MapEditor [get, set]
virtual GeometryEditor | MainEsaOcxForm [get, set]
virtual GeometryEditor | ExtraGeometryEditor [get, set]
virtual ReportDlg | DynamicReportControl [get, set]
virtual DynamicPropertyControl | DynamicPropertyControl [get, set]
virtual DynamicOutputControl | DynamicOutputControl [get, set]
virtual StatusBar | StatusBar [get, set]
virtual bool | ShowSplashScreen [get]
IReloadManager | ReloadManager [get]
Gets the reload manager. More...
SplashDialog | SplashDialog [get]
Gets the splash dialog. More...
CalculationManager | CalculationManager [get]
Gets the calculation manager. More...
string | HelpFile [get]
Gets the help file. More...
bool | AllowLanguageSelection [get, set]
Gets or sets a value indicating whether language selection is allowed. More...
bool | AllowMultiCoreSelection [get, set]
Gets or sets a value indicating whether multi core selection is allowed. More...

Events

UpdateToDataSourceEventHandler OnBeginValidationOrSave
Event occurs when Validation or Saving process begins. More...

Detailed Description

TODO: Comment

Constructor & Destructor Documentation

Deltares.Standard.Forms.DExpress.MainForm.MainForm ( )

Initializes an empty instance of the MainForm class.

Deltares.Standard.Forms.DExpress.MainForm.MainForm | ( | Type | splashAssemblyType,
 |  | Image | splashImage,
 |  | bool | splashDemoMode
 | ) |  |

Initializes a new instance of the MainForm class, initializing the splash screen with the given parameters. TODO: Comment

Member Function Documentation

void Deltares.Standard.Forms.DExpress.MainForm.AddProgramSettingsToSettingsDialog ( )

Add the program settings tab to the settings dialog.

References Deltares.Standard.Forms.DExpress.LocalizationSupport.RegisterAndTranslate().

void Deltares.Standard.Forms.DExpress.MainForm.AddTabPageToAboutDialog | ( | string | tabHeader,
 |  | UserControl | propertyControl,
 |  | object | data
 | ) |  |

Adds the tab page to about dialog.

Parameters
tabHeader | The tab header text.
propertyControl | The property control.
data | The data.
Exceptions
System.ArgumentException When propertyControl does not implement IPropertyControl.
Control Deltares.Standard.Forms.DExpress.MainForm.AddTabPageToSettingsDialog | ( | string | settingsTitle,
 |  | UserControl | settingsControl,
 |  | Object | settingsObject
 | ) |  |

Adds the tab page with the given properties to settings dialog.

void Deltares.Standard.Forms.DExpress.MainForm.AddUnitsSettingsToSettingsDialog ( )

Add the units settings tab to the settings dialog.

References Deltares.Standard.Forms.DExpress.LocalizationSupport.RegisterAndTranslate().

void Deltares.Standard.Forms.DExpress.MainForm.ClearOpenFileHandlers ( )

Clears the open file handlers.

void Deltares.Standard.Forms.DExpress.MainForm.ClearSaveFileHandlers ( )

Clears the save file handlers.

void Deltares.Standard.Forms.DExpress.MainForm.CreateAndRegisterPropertyFormFor< T > | ( | IEnumerable< Expression< Func< T, object >>> | propertyIncludeSet,
 |  | params Type[] | additionalTypes
 | ) |  |

Creates and registers property form for given type. TODO: Comment

Template Parameters
T
Parameters
propertyIncludeSet | The property include set.
additionalTypes | The additional types.

References Deltares.Standard.Forms.DExpress.DynamicPropertyControl.BuildPropertyControlTabForTypes(), and Deltares.Standard.Forms.DExpress.PropertyControlFactory< T >.GetPropertyControl().

void Deltares.Standard.Forms.DExpress.MainForm.CreateAndRegisterPropertyFormFor< T > ( params Expression< Func< T, object >>[] propertyIncludeSet )

Creates and registers a property form control for the given type. The control will be generated with a control factory using reflection.

Template Parameters
T The type to generate the property control for
Parameters
propertyIncludeSet The a set of properties that will be included. Without this set all properties are candidate for the generation in the control.

Implements Deltares.Standard.Forms.DExpress.IMainForm.

References Deltares.Standard.Forms.DExpress.DynamicPropertyControl.BuildPropertyControlTabsForType(), and Deltares.Standard.Forms.DExpress.PropertyControlFactory< T >.GetPropertyControl().

void Deltares.Standard.Forms.DExpress.MainForm.CreateRecentlyUsedFilesButton ( string aSavedFilePath )

Creates and assings the caption for 'recently used files' button.

Parameters
aSavedFilePath A saved file path.

References Deltares.Standard.Forms.DExpress.BindSupport.Assign(), and Deltares.Standard.Forms.DExpress.BindSupport.Bind().

void Deltares.Standard.Forms.DExpress.MainForm.CreateSettingsDialog | ( | bool | withProgramSettings = true,
 |  | bool | withUnitSettings = true
 | ) |  |

Create the settings dialog and optionally add the program settings tab and the unit settings tab to it. The optional adding of the tabs is to allow plugins to add tabs in between.

Parameters
withProgramSettings | Whether to (already) add the program settings tab to the dialog.
withUnitSettings | Whether to (already) add the unit settings tab to the dialog.

References Deltares.Standard.Forms.DExpress.LocalizationSupport.Register().

override void Deltares.Standard.Forms.DExpress.MainForm.Dispose ( bool disposing )
protected

Clean up any resources being used.

Parameters
disposing true if managed resources should be disposed; otherwise, false.
string Deltares.Standard.Forms.DExpress.MainForm.GetLocalUserDeltaresDirectoryPath ( )

Gets the local user deltares directory path.

virtual string Deltares.Standard.Forms.DExpress.MainForm.GetProjectFileName | ( | string | aDirectoryName,
 |  | string | aFileExtension
 | ) |  |
virtual

Gives publisherEventArgs Project File Name For New and Save

Parameters
aDirectoryName | A Directory Path
aFileExtension | A file Extension : xml,txt,etc., without period symbol
Returns
A Generically Created Project File Name Eg: MstabProject1,MstabProject2,etc.,
virtual string Deltares.Standard.Forms.DExpress.MainForm.GetProjectFileName ( string aFileExtension )
virtual

Gets the name of the project file with the given name extension. TODO: Comment

bool Deltares.Standard.Forms.DExpress.MainForm.InitializeUIBeforeNewAndOpen ( )

Prompt the user to save current changes to the project, returning false if the user chose not to save the project file.

Returns
bool Deltares.Standard.Forms.DExpress.MainForm.IsEnabled ( string property )

Determines whether the specified property is enabled.

Parameters
property The property.
Returns
bool Deltares.Standard.Forms.DExpress.MainForm.IsVisible ( string property )

Determines whether the specified property is visible.

Parameters
property The property.
Returns
void Deltares.Standard.Forms.DExpress.MainForm.LoadDefaultLayoutXML | ( | Assembly | assembly,
 |  | string | resource
 | ) |  |

Loads the XML holding the default layout.

Parameters
assembly | The assembly.
resource | The resource.
virtual bool Deltares.Standard.Forms.DExpress.MainForm.MRUFileOpen ( string aFileName )
virtual

returns true if the MRU file is open.

virtual void Deltares.Standard.Forms.DExpress.MainForm.PopulateMRUList ( string fileName )
virtual

Populates the MRU list. TODO: Comment

void Deltares.Standard.Forms.DExpress.MainForm.ProjectIsSaved ( string fileName )

Sets the project with the given filename to saved.

Parameters
fileName Name of the file.
void Deltares.Standard.Forms.DExpress.MainForm.RaiseBeginValidationOrSave ( )

Calls Event OnBeginValidationOrSave.

void Deltares.Standard.Forms.DExpress.MainForm.Register ( object plugin )

Registers the specified plugin.

Parameters
plugin The plugin.
void Deltares.Standard.Forms.DExpress.MainForm.RegisterNewFileHandler ( NewFile fileHandler )

Registers the new file handler.

Parameters
fileHandler The file handler.
void Deltares.Standard.Forms.DExpress.MainForm.RegisterOpenFileHandler | ( | string | extension,
 |  | string | filter,
 |  | OpenFile | openFileHandler
 | ) |  |

Registers the open file handler.

Parameters
extension | The extension.
filter | The filter.
openFileHandler | The open file handler.
void Deltares.Standard.Forms.DExpress.MainForm.RegisterSaveFileHandler | ( | string | extension,
 |  | string | filter,
 |  | SaveFile | saveFileHandler
 | ) |  |

Registers the save file handler.

Parameters
extension | The extension.
filter | The filter.
saveFileHandler | The save file handler.
GridViewControl Deltares.Standard.Forms.DExpress.MainForm.RegisterTable< ContainerType, ObjectType > | ( | Expression< Func< ContainerType, IEnumerable< ObjectType >>> | listProperty,
 |  | bool | onlyShowDuringSelection = false
 | ) |  |

Registers the table.

Template Parameters
ContainerType | The type of the ontainer type.
ObjectType | The type of the bject type.
Parameters
listProperty | The list property.
onlyShowDuringSelection | if set to true only show during selection.
Returns
void Deltares.Standard.Forms.DExpress.MainForm.RegisterTableControl | ( | Type | type,
 |  | Control | control,
 |  | string | caption
 | ) |  |

Registers the table control.

Parameters
type | The type.
control | The control.
caption | The caption.
IEnumerable<GridViewControl> Deltares.Standard.Forms.DExpress.MainForm.RegisterTables< ContainerType > | ( | bool | onlyShowDuringSelection = false,
 |  | params Expression< Func< ContainerType, IEnumerable< object >>>[] | listProperties
 | ) |  |

Registers the tables.

Template Parameters
ContainerType The type of the ontainer type.
Parameters
onlyShowDuringSelection | if set to true only show during selection.
listProperties | The list properties.
Returns
void Deltares.Standard.Forms.DExpress.MainForm.RegisterUIComponent ( IReloadManager aReloadManager )

Registers the Main Form to the given Reload Manager.

Implements Deltares.Standard.Forms.IReloadableUI.

void Deltares.Standard.Forms.DExpress.MainForm.Reload ( )

Reloads this instance.

Implements Deltares.Standard.Forms.IReloadableUI.

void Deltares.Standard.Forms.DExpress.MainForm.RemoveTabFromAboutDialog ( UserControl propertyControl )

Removes the tab from the about dialog.

Parameters
propertyControl The property control.
void Deltares.Standard.Forms.DExpress.MainForm.SelectLicense ( )

Selects the program options.

void Deltares.Standard.Forms.DExpress.MainForm.SelectProgramOptions ( )

Selects the program options.

void Deltares.Standard.Forms.DExpress.MainForm.SelectUnits ( )

Selects the units. TODO: Comment

void Deltares.Standard.Forms.DExpress.MainForm.SetAsActiveChart ( Control chart )

Sets a given control as the active chart.

Parameters
chart My chart.

Implements Deltares.Standard.Forms.DExpress.IMainFormActiveControlController.

References Deltares.Standard.Forms.DExpress.FormsSupport.MakeTreeVisible().

void Deltares.Standard.Forms.DExpress.MainForm.SetAsActivePropertyEditor ( Control propertyControl )

Sets given control as active property editor.

Parameters
propertyControl The property control.

Implements Deltares.Standard.Forms.DExpress.IMainFormActiveControlController.

References Deltares.Standard.Forms.DExpress.FormsSupport.MakeTreeVisible().

void Deltares.Standard.Forms.DExpress.MainForm.SetAsActiveTable ( Control table )

Sets given table as active table.

Parameters
table The table.

Implements Deltares.Standard.Forms.DExpress.IMainFormActiveControlController.

References Deltares.Standard.Forms.DExpress.FormsSupport.MakeTreeVisible().

void Deltares.Standard.Forms.DExpress.MainForm.SetAsActiveTabOnMainPanel ( Control dynamicControl )

Sets given control as active tab on main panel.

Parameters
dynamicControl The dynamic control.

Implements Deltares.Standard.Forms.DExpress.IMainFormActiveControlController.

References Deltares.Standard.Forms.DExpress.FormsSupport.MakeTreeVisible().

void Deltares.Standard.Forms.DExpress.MainForm.SetDefaultWidthPropertyWindow ( int useWidth )

Sets the default width of the property window.

Parameters
useWidth Width of the use.
void Deltares.Standard.Forms.DExpress.MainForm.SetMainWindowCaption ( string aFileName )

Sets The Window Caption Displaying File Name

Parameters
aFileName

References Deltares.Standard.Forms.Text.

void Deltares.Standard.Forms.DExpress.MainForm.ShowCharts ( )

Shows the charts.

object Deltares.Standard.Forms.DExpress.MainForm.ShowForm ( Control control )

loads the template dialog in to a form and displays it as a modless dialog

Parameters
control The control.
Returns
form with the loaded template dialog
void Deltares.Standard.Forms.DExpress.MainForm.ShowSettingsDialog ( Control tabPage )

Shows the settings dialog.

Parameters
tabPage The tab page.
void Deltares.Standard.Forms.DExpress.MainForm.UpdateData ( params object[] models )

Updates the data.

Implements Deltares.Standard.Forms.IReloadableUI.

void Deltares.Standard.Forms.DExpress.MainForm.UpdateMenuTablesView | ( | BarSubItem | menu,
 |  | XtraTabControl | tabControl
 | ) |  |

Updates the menu tables view. So make all the item visible which are also shown in the tableControl.

void Deltares.Standard.Forms.DExpress.MainForm.UseCharts ( )

Uses DynamicChartControl

void Deltares.Standard.Forms.DExpress.MainForm.UseExtraGeometryEditor ( )

Sets UseExtraGeometryEditor to true.

void Deltares.Standard.Forms.DExpress.MainForm.UseExtraGeometryEditor ( bool use )

Uses ExtraGeometryEditor

void Deltares.Standard.Forms.DExpress.MainForm.UseIcon ( Icon aIcon )

Uses the icon.

Parameters
aIcon A icon.
void Deltares.Standard.Forms.DExpress.MainForm.UseImage ( )

Sets UseImage to true.

void Deltares.Standard.Forms.DExpress.MainForm.UseImage ( bool use )

Uses DynamicImageControl

void Deltares.Standard.Forms.DExpress.MainForm.UseMap ( )

Sets UseMap to true.

void Deltares.Standard.Forms.DExpress.MainForm.UseMap ( bool use )

Uses MapEditor

void Deltares.Standard.Forms.DExpress.MainForm.UseNavigation ( )

Sets UseNavigation to true.

void Deltares.Standard.Forms.DExpress.MainForm.UseNavigation ( bool use )

Uses NavigatorControl

void Deltares.Standard.Forms.DExpress.MainForm.UseOutput ( )

Uses the output.

void Deltares.Standard.Forms.DExpress.MainForm.UseProperties ( )

Sets UseProperties to true.

void Deltares.Standard.Forms.DExpress.MainForm.UseProperties ( bool use )

Uses DynamicPropertyControl

void Deltares.Standard.Forms.DExpress.MainForm.UseReport ( )

Sets UseReport to true.

void Deltares.Standard.Forms.DExpress.MainForm.UseReport ( bool use )

Uses DynamicReportControl

void Deltares.Standard.Forms.DExpress.MainForm.UseResources ( )

Uses the resources.

void Deltares.Standard.Forms.DExpress.MainForm.UseSpatialEditor ( )

Sets UseSpatialEditor to true.

void Deltares.Standard.Forms.DExpress.MainForm.UseSpatialEditor ( bool use )

Uses mainEsaOcxForm

void Deltares.Standard.Forms.DExpress.MainForm.UseStatusBar ( )

Sets UseStatusBar to true.

void Deltares.Standard.Forms.DExpress.MainForm.UseStatusBar ( bool use )

Uses StatusBar

void Deltares.Standard.Forms.DExpress.MainForm.UseTables ( )

Sets UseTables to true.

void Deltares.Standard.Forms.DExpress.MainForm.UseTables | ( | bool | use,
 |  | Type | type,
 |  | string | caption
 | ) |  |

Uses the tables.

Parameters
use | if set to true [use].
type | The type.
caption | The caption.

References Deltares.Standard.Forms.DExpress.LocalizationSupport.Register().

void Deltares.Standard.Forms.DExpress.MainForm.UseTables ( bool use )

Uses the tables.

Parameters
use if set to true [use].
void Deltares.Standard.Forms.DExpress.MainForm.UseValidation ( )

Uses the validation.

Property Documentation

bool Deltares.Standard.Forms.DExpress.MainForm.AllowLanguageSelection
getset

Gets or sets a value indicating whether language selection is allowed.

true if allow language selection; otherwise, false.

bool Deltares.Standard.Forms.DExpress.MainForm.AllowMultiCoreSelection
getset

Gets or sets a value indicating whether multi core selection is allowed.

true if allow multi core selection; otherwise, false.

CalculationManager Deltares.Standard.Forms.DExpress.MainForm.CalculationManager
get

Gets the calculation manager.

The calculation manager.

string Deltares.Standard.Forms.DExpress.MainForm.DefaultLayoutXML
getset

Gets or sets the default layout XML.

string Deltares.Standard.Forms.DExpress.MainForm.FileName
getset

Gets or sets the name of the application Template File.

The name of the file.

string Deltares.Standard.Forms.DExpress.MainForm.HelpFile
get

Gets the help file.

The help file.

IHelpFileManager Deltares.Standard.Forms.DExpress.MainForm.HelpFileManager
getset

The class used for help file integration.

Opt-in: if not set, there will be no impact.

List<LogMessage> Deltares.Standard.Forms.DExpress.MainForm.LogMessages
get

Gets the log messages.

The log messages.

List<string> Deltares.Standard.Forms.DExpress.MainForm.PreviousMRUList
get

Gets the previous MRU list.

ProgramSettings Deltares.Standard.Forms.DExpress.MainForm.ProgramSettings
get

Gets the program settings template.

IReloadManager Deltares.Standard.Forms.DExpress.MainForm.ReloadManager
get

Gets the reload manager.

The reload manager.

SplashDialog Deltares.Standard.Forms.DExpress.MainForm.SplashDialog
get

Gets the splash dialog.

The splash dialog.

Referenced by Deltares.Standard.Application.ProgramBase.Start().

List<VisualValidationResult> Deltares.Standard.Forms.DExpress.MainForm.ValidationResults
get

Gets the validation results.

The validation results.

Event Documentation

UpdateToDataSourceEventHandler Deltares.Standard.Forms.DExpress.MainForm.OnBeginValidationOrSave

Event occurs when Validation or Saving process begins.

Generated on Tue Dec 15 2015 18:15:00 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • MainForm
Deltares.Standard.Forms.DExpress.MainForm Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.MainForm, including all inherited members.

abortButton (defined in Deltares.Standard.Forms.DExpress.MainForm) | Deltares.Standard.Forms.DExpress.MainForm | protected
AddProgramSettingsToSettingsDialog() | Deltares.Standard.Forms.DExpress.MainForm |
AddTabPageToAboutDialog(string tabHeader, UserControl propertyControl, object data) | Deltares.Standard.Forms.DExpress.MainForm |
AddTabPageToSettingsDialog(string settingsTitle, UserControl settingsControl, Object settingsObject) | Deltares.Standard.Forms.DExpress.MainForm |
AddUnitsSettingsToSettingsDialog() | Deltares.Standard.Forms.DExpress.MainForm |
AllowLanguageSelection | Deltares.Standard.Forms.DExpress.MainForm |
AllowMultiCoreSelection | Deltares.Standard.Forms.DExpress.MainForm |
calculationBarItem (defined in Deltares.Standard.Forms.DExpress.MainForm) | Deltares.Standard.Forms.DExpress.MainForm | protected
CalculationManager | Deltares.Standard.Forms.DExpress.MainForm |
CalculationMenu (defined in Deltares.Standard.Forms.DExpress.MainForm) | Deltares.Standard.Forms.DExpress.MainForm |
ClearOpenFileHandlers() | Deltares.Standard.Forms.DExpress.MainForm |
ClearSaveFileHandlers() | Deltares.Standard.Forms.DExpress.MainForm |
controlContainer1 (defined in Deltares.Standard.Forms.DExpress.MainForm) | Deltares.Standard.Forms.DExpress.MainForm | protected
controlContainer3 (defined in Deltares.Standard.Forms.DExpress.MainForm) | Deltares.Standard.Forms.DExpress.MainForm | protected
controlContainer4 (defined in Deltares.Standard.Forms.DExpress.MainForm) | Deltares.Standard.Forms.DExpress.MainForm | protected
controlContainer5 (defined in Deltares.Standard.Forms.DExpress.MainForm) | Deltares.Standard.Forms.DExpress.MainForm | protected
CreateAndRegisterPropertyFormFor< T >(IEnumerable< Expression< Func< T, object >>> propertyIncludeSet, params Type[] additionalTypes) | Deltares.Standard.Forms.DExpress.MainForm |
CreateAndRegisterPropertyFormFor< T >(params Expression< Func< T, object >>[] propertyIncludeSet) | Deltares.Standard.Forms.DExpress.MainForm |
CreateRecentlyUsedFilesButton(string aSavedFilePath) | Deltares.Standard.Forms.DExpress.MainForm |
CreateSettingsDialog(bool withProgramSettings=true, bool withUnitSettings=true) | Deltares.Standard.Forms.DExpress.MainForm |
DefaultDirectory (defined in Deltares.Standard.Forms.DExpress.MainForm) | Deltares.Standard.Forms.DExpress.MainForm |
DefaultLayoutXML | Deltares.Standard.Forms.DExpress.MainForm |
DemoLabel (defined in Deltares.Standard.Forms.DExpress.MainForm) | Deltares.Standard.Forms.DExpress.MainForm |
Dispose(bool disposing) | Deltares.Standard.Forms.DExpress.MainForm | protected
dockPanel1_Container (defined in Deltares.Standard.Forms.DExpress.MainForm) | Deltares.Standard.Forms.DExpress.MainForm | protected
dockPanel2_Container (defined in Deltares.Standard.Forms.DExpress.MainForm) | Deltares.Standard.Forms.DExpress.MainForm | protected
DynamicChartControl (defined in Deltares.Standard.Forms.DExpress.MainForm) | Deltares.Standard.Forms.DExpress.MainForm |
DynamicImageControl (defined in Deltares.Standard.Forms.DExpress.MainForm) | Deltares.Standard.Forms.DExpress.MainForm |
dynamicOutputControl (defined in Deltares.Standard.Forms.DExpress.MainForm) | Deltares.Standard.Forms.DExpress.MainForm | protected
DynamicOutputControl (defined in Deltares.Standard.Forms.DExpress.MainForm) | Deltares.Standard.Forms.DExpress.MainForm |
dynamicPropertyControl (defined in Deltares.Standard.Forms.DExpress.MainForm) | Deltares.Standard.Forms.DExpress.MainForm | protected
DynamicPropertyControl (defined in Deltares.Standard.Forms.DExpress.MainForm) | Deltares.Standard.Forms.DExpress.MainForm |
dynamicReportControl (defined in Deltares.Standard.Forms.DExpress.MainForm) | Deltares.Standard.Forms.DExpress.MainForm | protected
DynamicReportControl (defined in Deltares.Standard.Forms.DExpress.MainForm) | Deltares.Standard.Forms.DExpress.MainForm |
DynamicTableControl (defined in Deltares.Standard.Forms.DExpress.MainForm) | Deltares.Standard.Forms.DExpress.MainForm |
dynamicTableControl (defined in Deltares.Standard.Forms.DExpress.MainForm) | Deltares.Standard.Forms.DExpress.MainForm | protected
EditMenu (defined in Deltares.Standard.Forms.DExpress.MainForm) | Deltares.Standard.Forms.DExpress.MainForm |
ExitMenu (defined in Deltares.Standard.Forms.DExpress.MainForm) | Deltares.Standard.Forms.DExpress.MainForm |
ExportMenu (defined in Deltares.Standard.Forms.DExpress.MainForm) | Deltares.Standard.Forms.DExpress.MainForm |
ExtraGeometryDockPanel (defined in Deltares.Standard.Forms.DExpress.MainForm) | Deltares.Standard.Forms.DExpress.MainForm |
ExtraGeometryEditor (defined in Deltares.Standard.Forms.DExpress.MainForm) | Deltares.Standard.Forms.DExpress.MainForm |
FileMenu (defined in Deltares.Standard.Forms.DExpress.MainForm) | Deltares.Standard.Forms.DExpress.MainForm |
FileName | Deltares.Standard.Forms.DExpress.MainForm |
GeometryDockPanel (defined in Deltares.Standard.Forms.DExpress.MainForm) | Deltares.Standard.Forms.DExpress.MainForm |
GetCategory(string property) (defined in Deltares.Standard.Forms.DExpress.MainForm) | Deltares.Standard.Forms.DExpress.MainForm |
GetDefaultWindowViewFile() (defined in Deltares.Standard.Forms.DExpress.MainForm) | Deltares.Standard.Forms.DExpress.MainForm | protected
GetDescription(string property) (defined in Deltares.Standard.Forms.DExpress.MainForm) | Deltares.Standard.Forms.DExpress.MainForm |
GetFormat(string property) (defined in Deltares.Standard.Forms.DExpress.MainForm) | Deltares.Standard.Forms.DExpress.MainForm |
GetImpact(string property) (defined in Deltares.Standard.Forms.DExpress.MainForm) | Deltares.Standard.Forms.DExpress.MainForm |
GetLocalUserDeltaresDirectoryPath() | Deltares.Standard.Forms.DExpress.MainForm |
GetName(string property) (defined in Deltares.Standard.Forms.DExpress.MainForm) | Deltares.Standard.Forms.DExpress.MainForm |
GetProjectFileName(string aDirectoryName, string aFileExtension) | Deltares.Standard.Forms.DExpress.MainForm | virtual
GetProjectFileName(string aFileExtension) | Deltares.Standard.Forms.DExpress.MainForm | virtual
GetUnit(string property) (defined in Deltares.Standard.Forms.DExpress.MainForm) | Deltares.Standard.Forms.DExpress.MainForm |
graphicalAssignForm (defined in Deltares.Standard.Forms.DExpress.MainForm) | Deltares.Standard.Forms.DExpress.MainForm |
HelpAboutItem (defined in Deltares.Standard.Forms.DExpress.MainForm) | Deltares.Standard.Forms.DExpress.MainForm | protected
HelpFile | Deltares.Standard.Forms.DExpress.MainForm |
HelpFileManager | Deltares.Standard.Forms.DExpress.MainForm |
HelpMenu (defined in Deltares.Standard.Forms.DExpress.MainForm) | Deltares.Standard.Forms.DExpress.MainForm |
HelpWebsiteItem (defined in Deltares.Standard.Forms.DExpress.MainForm) | Deltares.Standard.Forms.DExpress.MainForm |
HookUpWinFormsEvents() (defined in Deltares.Standard.Forms.DExpress.MainForm) | Deltares.Standard.Forms.DExpress.MainForm | protectedvirtual
ImportMenu (defined in Deltares.Standard.Forms.DExpress.MainForm) | Deltares.Standard.Forms.DExpress.MainForm |
InitializeUIBeforeNewAndOpen() | Deltares.Standard.Forms.DExpress.MainForm |
IsEnabled(string property) | Deltares.Standard.Forms.DExpress.MainForm |
IsMainFormLoaded (defined in Deltares.Standard.Forms.DExpress.MainForm) | Deltares.Standard.Forms.DExpress.MainForm |
IsMergedTab (defined in Deltares.Standard.Forms.DExpress.MainForm) | Deltares.Standard.Forms.DExpress.MainForm | protected
IsVisible(string property) | Deltares.Standard.Forms.DExpress.MainForm |
Licensebutton (defined in Deltares.Standard.Forms.DExpress.MainForm) | Deltares.Standard.Forms.DExpress.MainForm |
LoadDefaultLayoutXML(Assembly assembly, string resource) | Deltares.Standard.Forms.DExpress.MainForm |
LogMessages | Deltares.Standard.Forms.DExpress.MainForm |
MainDockManager (defined in Deltares.Standard.Forms.DExpress.MainForm) | Deltares.Standard.Forms.DExpress.MainForm |
MainEsaOcxForm (defined in Deltares.Standard.Forms.DExpress.MainForm) | Deltares.Standard.Forms.DExpress.MainForm |
mainEsaOcxForm (defined in Deltares.Standard.Forms.DExpress.MainForm) | Deltares.Standard.Forms.DExpress.MainForm | protected
MainForm() | Deltares.Standard.Forms.DExpress.MainForm |
MainForm(Type splashAssemblyType, Image splashImage, bool splashDemoMode) | Deltares.Standard.Forms.DExpress.MainForm |
MainFormTemplateEditCutItem (defined in Deltares.Standard.Forms.DExpress.MainForm) | Deltares.Standard.Forms.DExpress.MainForm | protected
MainFormTemplateEditRedoItem (defined in Deltares.Standard.Forms.DExpress.MainForm) | Deltares.Standard.Forms.DExpress.MainForm | protected
MainFormTemplateEditUndoItem (defined in Deltares.Standard.Forms.DExpress.MainForm) | Deltares.Standard.Forms.DExpress.MainForm | protected
MainFormTemplateFileCloseItem (defined in Deltares.Standard.Forms.DExpress.MainForm) | Deltares.Standard.Forms.DExpress.MainForm | protected
MainFormTemplateFileExitItem (defined in Deltares.Standard.Forms.DExpress.MainForm) | Deltares.Standard.Forms.DExpress.MainForm | protected
MainFormTemplateFileExportItem (defined in Deltares.Standard.Forms.DExpress.MainForm) | Deltares.Standard.Forms.DExpress.MainForm | protected
MainFormTemplateFileImportDatabaseItem (defined in Deltares.Standard.Forms.DExpress.MainForm) | Deltares.Standard.Forms.DExpress.MainForm | protected
MainFormTemplateFileImportFileItem (defined in Deltares.Standard.Forms.DExpress.MainForm) | Deltares.Standard.Forms.DExpress.MainForm | protected
MainFormTemplateFileImportItem (defined in Deltares.Standard.Forms.DExpress.MainForm) | Deltares.Standard.Forms.DExpress.MainForm | protected
MainFormTemplateToolsRenumberItem (defined in Deltares.Standard.Forms.DExpress.MainForm) | Deltares.Standard.Forms.DExpress.MainForm | protected
MainFormTemplateWindowArrangeAllItem (defined in Deltares.Standard.Forms.DExpress.MainForm) | Deltares.Standard.Forms.DExpress.MainForm | protected
MainFormTemplateWindowCascadeItem (defined in Deltares.Standard.Forms.DExpress.MainForm) | Deltares.Standard.Forms.DExpress.MainForm | protected
MainFormTemplateWindowTilesItem (defined in Deltares.Standard.Forms.DExpress.MainForm) | Deltares.Standard.Forms.DExpress.MainForm | protected
MapEditor (defined in Deltares.Standard.Forms.DExpress.MainForm) | Deltares.Standard.Forms.DExpress.MainForm |
mapEditor (defined in Deltares.Standard.Forms.DExpress.MainForm) | Deltares.Standard.Forms.DExpress.MainForm | protected
MaxCalculationCores (defined in Deltares.Standard.Forms.DExpress.MainForm) | Deltares.Standard.Forms.DExpress.MainForm |
MenuBar (defined in Deltares.Standard.Forms.DExpress.MainForm) | Deltares.Standard.Forms.DExpress.MainForm |
MessagesControl (defined in Deltares.Standard.Forms.DExpress.MainForm) | Deltares.Standard.Forms.DExpress.MainForm |
MessagesDockPanel (defined in Deltares.Standard.Forms.DExpress.MainForm) | Deltares.Standard.Forms.DExpress.MainForm |
MRUFileOpen(string aFileName) | Deltares.Standard.Forms.DExpress.MainForm | virtual
MStabMainFormImageCollection (defined in Deltares.Standard.Forms.DExpress.MainForm) | Deltares.Standard.Forms.DExpress.MainForm | protected
MStabMainLookAndFeel (defined in Deltares.Standard.Forms.DExpress.MainForm) | Deltares.Standard.Forms.DExpress.MainForm |
MStabToolBarRenumberButton (defined in Deltares.Standard.Forms.DExpress.MainForm) | Deltares.Standard.Forms.DExpress.MainForm | protected
MStabToolBarValidateButton (defined in Deltares.Standard.Forms.DExpress.MainForm) | Deltares.Standard.Forms.DExpress.MainForm | protected
NavigatorControl (defined in Deltares.Standard.Forms.DExpress.MainForm) | Deltares.Standard.Forms.DExpress.MainForm |
NewMRUbuttonList (defined in Deltares.Standard.Forms.DExpress.MainForm) | Deltares.Standard.Forms.DExpress.MainForm |
NewWindowItem (defined in Deltares.Standard.Forms.DExpress.MainForm) | Deltares.Standard.Forms.DExpress.MainForm |
OnBeginValidationOrSave | Deltares.Standard.Forms.DExpress.MainForm |
OnFormClosing(object sender, FormClosingEventArgs e) (defined in Deltares.Standard.Forms.DExpress.MainForm) | Deltares.Standard.Forms.DExpress.MainForm | protected
OpeninNewWindowItem (defined in Deltares.Standard.Forms.DExpress.MainForm) | Deltares.Standard.Forms.DExpress.MainForm | protected
OpenItem (defined in Deltares.Standard.Forms.DExpress.MainForm) | Deltares.Standard.Forms.DExpress.MainForm | protected
PluginSetDescriptionDialog (defined in Deltares.Standard.Forms.DExpress.MainForm) | Deltares.Standard.Forms.DExpress.MainForm |
PopulateMRUList(string fileName) | Deltares.Standard.Forms.DExpress.MainForm | virtual
PreviousMRUList | Deltares.Standard.Forms.DExpress.MainForm |
ProgramSettings | Deltares.Standard.Forms.DExpress.MainForm |
ProjectIsSaved(string fileName) | Deltares.Standard.Forms.DExpress.MainForm |
ProjectMenu (defined in Deltares.Standard.Forms.DExpress.MainForm) | Deltares.Standard.Forms.DExpress.MainForm |
RaiseBeginValidationOrSave() | Deltares.Standard.Forms.DExpress.MainForm |
Register(object plugin) | Deltares.Standard.Forms.DExpress.MainForm |
RegisterNewFileHandler(NewFile fileHandler) | Deltares.Standard.Forms.DExpress.MainForm |
RegisterOpenFileHandler(string extension, string filter, OpenFile openFileHandler) | Deltares.Standard.Forms.DExpress.MainForm |
RegisterSaveFileHandler(string extension, string filter, SaveFile saveFileHandler) | Deltares.Standard.Forms.DExpress.MainForm |
RegisterTable< ContainerType, ObjectType >(Expression< Func< ContainerType, IEnumerable< ObjectType >>> listProperty, bool onlyShowDuringSelection=false) | Deltares.Standard.Forms.DExpress.MainForm |
RegisterTableControl(Type type, Control control, string caption) | Deltares.Standard.Forms.DExpress.MainForm |
RegisterTables< ContainerType >(bool onlyShowDuringSelection=false, params Expression< Func< ContainerType, IEnumerable< object >>>[] listProperties) | Deltares.Standard.Forms.DExpress.MainForm |
RegisterUIComponent(IReloadManager aReloadManager) | Deltares.Standard.Forms.DExpress.MainForm |
Reload() | Deltares.Standard.Forms.DExpress.MainForm |
ReloadManager | Deltares.Standard.Forms.DExpress.MainForm |
RemoveTabFromAboutDialog(UserControl propertyControl) | Deltares.Standard.Forms.DExpress.MainForm |
ReportPreviewMenuItem (defined in Deltares.Standard.Forms.DExpress.MainForm) | Deltares.Standard.Forms.DExpress.MainForm | protected
ReportPrintMenuItem (defined in Deltares.Standard.Forms.DExpress.MainForm) | Deltares.Standard.Forms.DExpress.MainForm | protected
ReportSelectionMenuItem (defined in Deltares.Standard.Forms.DExpress.MainForm) | Deltares.Standard.Forms.DExpress.MainForm | protected
SelectLicense() | Deltares.Standard.Forms.DExpress.MainForm |
SelectProgramOptions() | Deltares.Standard.Forms.DExpress.MainForm |
SelectUnits() | Deltares.Standard.Forms.DExpress.MainForm |
ServerButton (defined in Deltares.Standard.Forms.DExpress.MainForm) | Deltares.Standard.Forms.DExpress.MainForm |
SetAsActiveChart(Control myChart) | Deltares.Standard.Forms.DExpress.MainForm |
SetAsActivePropertyEditor(Control propertyControl) | Deltares.Standard.Forms.DExpress.MainForm |
SetAsActiveTable(Control table) | Deltares.Standard.Forms.DExpress.MainForm |
SetAsActiveTabOnMainPanel(Control dynamicControl) | Deltares.Standard.Forms.DExpress.MainForm |
SetDefaultWidthPropertyWindow(int useWidth) | Deltares.Standard.Forms.DExpress.MainForm |
SetMainWindowCaption(string aFileName) | Deltares.Standard.Forms.DExpress.MainForm |
ShowCharts() | Deltares.Standard.Forms.DExpress.MainForm |
ShowForm(Control control) | Deltares.Standard.Forms.DExpress.MainForm |
ShowSettingsDialog(Control tabPage) | Deltares.Standard.Forms.DExpress.MainForm |
ShowSplashScreen (defined in Deltares.Standard.Forms.DExpress.MainForm) | Deltares.Standard.Forms.DExpress.MainForm | protected
SplashDialog | Deltares.Standard.Forms.DExpress.MainForm |
StatusBar (defined in Deltares.Standard.Forms.DExpress.MainForm) | Deltares.Standard.Forms.DExpress.MainForm |
TableDockPanel (defined in Deltares.Standard.Forms.DExpress.MainForm) | Deltares.Standard.Forms.DExpress.MainForm | protected
TemplateBarManager (defined in Deltares.Standard.Forms.DExpress.MainForm) | Deltares.Standard.Forms.DExpress.MainForm |
ToolBar (defined in Deltares.Standard.Forms.DExpress.MainForm) | Deltares.Standard.Forms.DExpress.MainForm |
ToolsMenu (defined in Deltares.Standard.Forms.DExpress.MainForm) | Deltares.Standard.Forms.DExpress.MainForm |
UpdateData(params object[] models) | Deltares.Standard.Forms.DExpress.MainForm |
UpdateMenuTablesView(BarSubItem menu, XtraTabControl tabControl) | Deltares.Standard.Forms.DExpress.MainForm |
UseCharts() | Deltares.Standard.Forms.DExpress.MainForm |
UseExtraGeometryEditor() | Deltares.Standard.Forms.DExpress.MainForm |
UseExtraGeometryEditor(bool use) | Deltares.Standard.Forms.DExpress.MainForm |
UseIcon(Icon aIcon) | Deltares.Standard.Forms.DExpress.MainForm |
UseImage() | Deltares.Standard.Forms.DExpress.MainForm |
UseImage(bool use) | Deltares.Standard.Forms.DExpress.MainForm |
UseMap() | Deltares.Standard.Forms.DExpress.MainForm |
UseMap(bool use) | Deltares.Standard.Forms.DExpress.MainForm |
UseNavigation() | Deltares.Standard.Forms.DExpress.MainForm |
UseNavigation(bool use) | Deltares.Standard.Forms.DExpress.MainForm |
UseOutput() | Deltares.Standard.Forms.DExpress.MainForm |
UseProperties() | Deltares.Standard.Forms.DExpress.MainForm |
UseProperties(bool use) | Deltares.Standard.Forms.DExpress.MainForm |
UseReport() | Deltares.Standard.Forms.DExpress.MainForm |
UseReport(bool use) | Deltares.Standard.Forms.DExpress.MainForm |
UseResources() | Deltares.Standard.Forms.DExpress.MainForm |
UseSelectedLanguage (defined in Deltares.Standard.Forms.DExpress.MainForm) | Deltares.Standard.Forms.DExpress.MainForm |
UseSpatialEditor() | Deltares.Standard.Forms.DExpress.MainForm |
UseSpatialEditor(bool use) | Deltares.Standard.Forms.DExpress.MainForm |
UseStatusBar() | Deltares.Standard.Forms.DExpress.MainForm |
UseStatusBar(bool use) | Deltares.Standard.Forms.DExpress.MainForm |
UseTables() | Deltares.Standard.Forms.DExpress.MainForm |
UseTables(bool use, Type type, string caption) | Deltares.Standard.Forms.DExpress.MainForm |
UseTables(bool use) | Deltares.Standard.Forms.DExpress.MainForm |
UseTemplateDialog (defined in Deltares.Standard.Forms.DExpress.MainForm) | Deltares.Standard.Forms.DExpress.MainForm |
UseValidation() | Deltares.Standard.Forms.DExpress.MainForm |
ValidationResults | Deltares.Standard.Forms.DExpress.MainForm |
ViewMenu (defined in Deltares.Standard.Forms.DExpress.MainForm) | Deltares.Standard.Forms.DExpress.MainForm |
Generated on Tue Dec 15 2015 18:15:00 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.MapEditor Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • MapEditor
Public Types | Public Member Functions | Static Public Member Functions | Public Attributes | Static Public Attributes | Protected Member Functions | Protected Attributes | Properties | List of all members
Deltares.Standard.Forms.DExpress.MapEditor Class Reference

Map component of DSL Mainform More...

Inheritance diagram for Deltares.Standard.Forms.DExpress.MapEditor:

Public Types

enum WebLayerTypes {
OpenStreetMapnik = 1, PdokAchtergrond = 2, PdokAchtergrondPastel = 3, PdokAchtergrondGrijs = 4,
PdokLuchtfoto = 10, NoWebLayer = 99
}
Enumeration for WebLayers: OpenStreetMap, PDOK Achtergrond or PDOK Luchtfoto More...

Public Member Functions

MapEditor ()
Initializes a new instance of the MapEditor class. More...
void | MapControl_MouseDown (object sender, MouseEventArgs e)
Handles the MouseDown event of the MapControl control. More...
void | MapControl_MouseUp (object sender, MouseEventArgs e)
Handles the MouseUp event of the MapControl control. More...
IMapFeatureLayer | GetBackgroundLayer (BackgroundMap backgroundMap)
Gets the background layer. More...
void | ZoomRectangle ()
Zooms to the given rectangle. More...
void | ZoomExtents ()
Zooms to the extents. More...
void | ZoomData ()
Zooms to the data. More...
void | MoveToFront (IMapLayer layer)
Moves the layer to front. More...
void | Clear ()
Clears this instance. More...
void | RegisterLayer (string rasterType, RasterLayerDefinition scheme)
Registers the layer definition for the given raster type. More...
IMapRasterLayer | AddRaster (IHasRaster rasterData)
Adds the raster. More...
void | RemoveRaster (IHasRaster rasterData)
Removes the raster. More...
void | AddProperty (object source, params string[] properties)
Adds the property. More...
void | RegisterLayer (Type type, MapLayerDefinition scheme)
Registers the layer. More...
void | RemoveLayer (IList list)
Removes the layer. More...
IMapFeatureLayer | AddLayer (IList list, bool enableSelection=true)
Adds the layer. More...
IGeographicPoint | GetPoint (object geographic)
Gets the point. More...
IGeographicString | GetString (object geographic)
Gets the string. More...
bool | IsLayerVisible (IList list)
Indicates whether a layer of a certain list is visible ta the moment More...
void | UpdateAllLayers ()
Updates all layers. More...
void | SuspendLayerEvents ()
Suspends the dotspatial layer events. More...
void | ResumeLayerEvents ()
Resumes the rendering. More...
new void | Dispose ()
Releases all resources used by the T:System.ComponentModel.Component. More...
bool | IsEnabled (string property)
Determines whether the specified property is enabled. More...
bool | IsVisible (string property)
Determines whether the specified property is visible. More...

Static Public Member Functions

static bool IsUrlAlive (string url, int timeoutSeconds)

Public Attributes

const string | ZOOMTOWEBLAYERNAME = "weblayer_extentlayer"
const string | WEBLAYERNAME = "weblayer_extentlayer"
DotSpatial.Controls.Map | MapControl
DevExpress.XtraBars.Bar | Toolbar

Static Public Attributes

static bool LoadExtensions = true

Protected Member Functions

string | GetMouseGeoCoordinateText (double x, double y, ProjectionInfo projection)
void | HandleDirtyLists ()
override void | Dispose (bool disposing)
Clean up any resources being used. More...

Protected Attributes

bool cursorOnMap = false

Properties

WebLayerTypes | WebLayerType [get, set]
Select Web Map Type (default is OpenStreetMap) More...
bool | ShowSelectWebLayer \OpenStreetmap\"http://geodata.nationaalgeoregister.nl/tms/1.0.0/brtachtergrondkaart@EPSG:28992@png8"http://geodata.nationaalgeoregister.nl/tms/1.0.0/brtachtergrondkaartpastel@EPSG:28992@png8"http://geodata.nationaalgeoregister.nl/tms/1.0.0/brtachtergrondkaartgrijs@EPSG:28992@png8"http://geodata1.nationaalgeoregister.nl/luchtfoto/tms/1.0.0/luchtfoto/EPSG28992" [get, set]
Enable the toolbar dropdown to select Web Map Type (off by default, not all applications can handle projection changes) More...
MapProjection | StatusBarProjection [get, set]
Gets or sets the status bar projection. More...
bool | EnableZoomToData [get, set]
Gets or sets a value indicating whether a "zoom to data" button appears on the map toolbar More...
bool | EnableZoomRectangle [get, set]
Gets or sets a value indicating whether a "zoom to rectangle" button appears on the map toolbar More...
bool | EnableZoomToSelection [get, set]
Gets or sets a value indicating whether a "zoom to selection" button appears on the map toolbar More...
bool | EnableSelectButton [get, set]
Gets or sets a value indicating whether a "select" button appears on the map toolbar More...
Extent | MapExtent [get, set]
Extent (in lat-lon !) for ZoomAll (ZoomLayers) button More...
Dictionary< Type, MapLayerDefinition > | RegisteredLayers [get]
Gets the registered layers. More...
object | EmptySelection [get, set]
Gets or sets the empty selection. More...
bool | CursorOnMap [get]
Gets a value indicating whether the cursor is on the map. More...
List< BackgroundMap > | BackgroundMaps [get, set]
Gets or sets the background maps. More...
bool | LegendPropertyControlHasBeenSet [get, set]
Is true when LegendPropertyControl has been set More...
List< object > | SelectedObjects [get, set]
Gets or sets the selected objects in the map. More...
bool | ShowWebLayer [get, set]
Gets or sets a value indicating whether to show web layer. More...
bool | ShowFeatureTextInMapInfoBar [get, set]
Set feature info on/off in the map info bar, where the coordinates are also displayed More...
bool | SendLegendEvent [get, set]
Gets or sets a value indicating whether to send legend event. More...
bool | ShowExportLayersButton [get, set]
Set export layers button on/off More...
List< IMapTool > | MapTools [get]
Gets the map tools. More...

Detailed Description

Map component of DSL Mainform

Member Enumeration Documentation

enum Deltares.Standard.Forms.DExpress.MapEditor.WebLayerTypes
strong

Enumeration for WebLayers: OpenStreetMap, PDOK Achtergrond or PDOK Luchtfoto

Constructor & Destructor Documentation

Deltares.Standard.Forms.DExpress.MapEditor.MapEditor ( )

Initializes a new instance of the MapEditor class.

References Deltares.Standard.Forms.DExpress.BindSupport.Assign(), Deltares.Standard.Forms.DExpress.BindSupport.Bind(), Deltares.Standard.Forms.Properties.Resources.Export, Deltares.Standard.Forms.Properties.Resources.OpenImage, Deltares.Standard.Forms.Properties.Resources.SaveImage, Deltares.Standard.Forms.DExpress.MapEditor.ShowWebLayer, Deltares.Standard.Forms.Properties.Resources.Web, Deltares.Standard.Forms.DExpress.MapEditor.WebLayerType, Deltares.Standard.Forms.Properties.Resources.ZoomAll, Deltares.Standard.Forms.DExpress.MapEditor.ZoomData(), Deltares.Standard.Forms.DExpress.MapEditor.ZoomExtents(), Deltares.Standard.Forms.Properties.Resources.ZoomExtents, Deltares.Standard.Forms.DExpress.MapEditor.ZoomRectangle(), Deltares.Standard.Forms.Properties.Resources.ZoomRectangle, and Deltares.Standard.Forms.Properties.Resources.ZoomSelection.

Member Function Documentation

IMapFeatureLayer Deltares.Standard.Forms.DExpress.MapEditor.AddLayer | ( | IList | list,
 |  | bool | enableSelection = true
 | ) |  |

Adds the layer.

Parameters
list | The list.
enableSelection | if set to true [enable selection].
Returns
void Deltares.Standard.Forms.DExpress.MapEditor.AddProperty | ( | object | source,
 |  | params string[] | properties
 | ) |  |

Adds the property.

Parameters
source | The source.
properties | The properties.
IMapRasterLayer Deltares.Standard.Forms.DExpress.MapEditor.AddRaster ( IHasRaster rasterData )

Adds the raster.

Parameters
rasterData The raster data.
Returns
void Deltares.Standard.Forms.DExpress.MapEditor.Clear ( )

Clears this instance.

override void Deltares.Standard.Forms.DExpress.MapEditor.Dispose ( bool disposing )
protected

Clean up any resources being used.

Parameters
disposing true if managed resources should be disposed; otherwise, false.
new void Deltares.Standard.Forms.DExpress.MapEditor.Dispose ( )

Releases all resources used by the T:System.ComponentModel.Component.

IMapFeatureLayer Deltares.Standard.Forms.DExpress.MapEditor.GetBackgroundLayer ( BackgroundMap backgroundMap )

Gets the background layer.

Parameters
backgroundMap The background map.
Returns
IGeographicPoint Deltares.Standard.Forms.DExpress.MapEditor.GetPoint ( object geographic )

Gets the point.

Parameters
geographic The geographic.
Returns
IGeographicString Deltares.Standard.Forms.DExpress.MapEditor.GetString ( object geographic )

Gets the string.

Parameters
geographic The geographic.
Returns
bool Deltares.Standard.Forms.DExpress.MapEditor.IsEnabled ( string property )

Determines whether the specified property is enabled.

Parameters
property The property.
Returns
bool Deltares.Standard.Forms.DExpress.MapEditor.IsLayerVisible ( IList list )

Indicates whether a layer of a certain list is visible ta the moment

Parameters
list
Returns
bool Deltares.Standard.Forms.DExpress.MapEditor.IsVisible ( string property )

Determines whether the specified property is visible.

Parameters
property The property.
Returns
void Deltares.Standard.Forms.DExpress.MapEditor.MapControl_MouseDown | ( | object | sender,
 |  | MouseEventArgs | e
 | ) |  |

Handles the MouseDown event of the MapControl control.

Parameters
sender | The source of the event.
e | The MouseEventArgs instance containing the event data.
void Deltares.Standard.Forms.DExpress.MapEditor.MapControl_MouseUp | ( | object | sender,
 |  | MouseEventArgs | e
 | ) |  |

Handles the MouseUp event of the MapControl control.

Parameters
sender | The source of the event.
e | The MouseEventArgs instance containing the event data.
void Deltares.Standard.Forms.DExpress.MapEditor.MoveToFront ( IMapLayer layer )

Moves the layer to front.

Parameters
layer The layer.
void Deltares.Standard.Forms.DExpress.MapEditor.RegisterLayer | ( | string | rasterType,
 |  | RasterLayerDefinition | scheme
 | ) |  |

Registers the layer definition for the given raster type.

Parameters
rasterType | Type of the raster.
scheme | The scheme.

Referenced by Deltares.DSoilModel.Forms.DSoilModelMapEditor.DSoilModelMapEditor().

void Deltares.Standard.Forms.DExpress.MapEditor.RegisterLayer | ( | Type | type,
 |  | MapLayerDefinition | scheme
 | ) |  |

Registers the layer.

Parameters
type | The type.
scheme | The scheme.

References Deltares.Standard.Forms.DExpress.MapLayerDefinition.FeatureType.

void Deltares.Standard.Forms.DExpress.MapEditor.RemoveLayer ( IList list )

Removes the layer.

Parameters
list The list.
void Deltares.Standard.Forms.DExpress.MapEditor.RemoveRaster ( IHasRaster rasterData )

Removes the raster.

Parameters
rasterData The raster data.
void Deltares.Standard.Forms.DExpress.MapEditor.ResumeLayerEvents ( )

Resumes the rendering.

See also
SuspendLayerEvents
void Deltares.Standard.Forms.DExpress.MapEditor.SuspendLayerEvents ( )

Suspends the dotspatial layer events.

Use this method to improve performance when adding a batch of map-layers.

See also
ResumeLayerEvents
void Deltares.Standard.Forms.DExpress.MapEditor.UpdateAllLayers ( )

Updates all layers.

void Deltares.Standard.Forms.DExpress.MapEditor.ZoomData ( )

Zooms to the data.

Referenced by Deltares.Standard.Forms.DExpress.MapEditor.MapEditor().

void Deltares.Standard.Forms.DExpress.MapEditor.ZoomExtents ( )

Zooms to the extents.

Referenced by Deltares.Standard.Forms.DExpress.MapEditor.MapEditor().

void Deltares.Standard.Forms.DExpress.MapEditor.ZoomRectangle ( )

Zooms to the given rectangle.

Referenced by Deltares.Standard.Forms.DExpress.MapEditor.MapEditor().

Property Documentation

List<BackgroundMap> Deltares.Standard.Forms.DExpress.MapEditor.BackgroundMaps
getset

Gets or sets the background maps.

The background maps.

bool Deltares.Standard.Forms.DExpress.MapEditor.CursorOnMap
get

Gets a value indicating whether the cursor is on the map.

true if cursor on map; otherwise, false.

object Deltares.Standard.Forms.DExpress.MapEditor.EmptySelection
getset

Gets or sets the empty selection.

The empty selection.

bool Deltares.Standard.Forms.DExpress.MapEditor.EnableSelectButton
getset

Gets or sets a value indicating whether a "select" button appears on the map toolbar

bool Deltares.Standard.Forms.DExpress.MapEditor.EnableZoomRectangle
getset

Gets or sets a value indicating whether a "zoom to rectangle" button appears on the map toolbar

bool Deltares.Standard.Forms.DExpress.MapEditor.EnableZoomToData
getset

Gets or sets a value indicating whether a "zoom to data" button appears on the map toolbar

bool Deltares.Standard.Forms.DExpress.MapEditor.EnableZoomToSelection
getset

Gets or sets a value indicating whether a "zoom to selection" button appears on the map toolbar

bool Deltares.Standard.Forms.DExpress.MapEditor.LegendPropertyControlHasBeenSet
getset

Is true when LegendPropertyControl has been set

Extent Deltares.Standard.Forms.DExpress.MapEditor.MapExtent
getset

Extent (in lat-lon !) for ZoomAll (ZoomLayers) button

List<IMapTool> Deltares.Standard.Forms.DExpress.MapEditor.MapTools
get

Gets the map tools.

The map tools.

Dictionary<Type, MapLayerDefinition> Deltares.Standard.Forms.DExpress.MapEditor.RegisteredLayers
get

Gets the registered layers.

The registered layers.

List<object> Deltares.Standard.Forms.DExpress.MapEditor.SelectedObjects
getset

Gets or sets the selected objects in the map.

The selected objects.

bool Deltares.Standard.Forms.DExpress.MapEditor.SendLegendEvent
getset

Gets or sets a value indicating whether to send legend event.

true if send legend event; otherwise, false.

bool Deltares.Standard.Forms.DExpress.MapEditor.ShowExportLayersButton
getset

Set export layers button on/off

bool Deltares.Standard.Forms.DExpress.MapEditor.ShowFeatureTextInMapInfoBar
getset

Set feature info on/off in the map info bar, where the coordinates are also displayed

bool Deltares.Standard.Forms.DExpress.MapEditor.ShowSelectWebLayer \OpenStreetmap\"http://geodata.nationaalgeoregister.nl/tms/1.0.0/brtachtergrondkaart@EPSG:28992@png8"http://geodata.nationaalgeoregister.nl/tms/1.0.0/brtachtergrondkaartpastel@EPSG:28992@png8"http://geodata.nationaalgeoregister.nl/tms/1.0.0/brtachtergrondkaartgrijs@EPSG:28992@png8"http://geodata1.nationaalgeoregister.nl/luchtfoto/tms/1.0.0/luchtfoto/EPSG28992"
getset

Enable the toolbar dropdown to select Web Map Type (off by default, not all applications can handle projection changes)

Referenced by Deltares.DSoilModel.Forms.DSoilModelMapEditor.DSoilModelMapEditor().

bool Deltares.Standard.Forms.DExpress.MapEditor.ShowWebLayer
getset

Gets or sets a value indicating whether to show web layer.

true if show web layer; otherwise, false.

Referenced by Deltares.Standard.Forms.DExpress.MapEditor.MapEditor().

MapProjection Deltares.Standard.Forms.DExpress.MapEditor.StatusBarProjection
getset

Gets or sets the status bar projection.

The status bar projection.

WebLayerTypes Deltares.Standard.Forms.DExpress.MapEditor.WebLayerType
getset

Select Web Map Type (default is OpenStreetMap)

Referenced by Deltares.DSoilModel.Forms.DSoilModelMapEditor.DSoilModelMapEditor(), and Deltares.Standard.Forms.DExpress.MapEditor.MapEditor().

Generated on Tue Dec 15 2015 18:15:00 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • MapEditor
Deltares.Standard.Forms.DExpress.MapEditor Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.MapEditor, including all inherited members.

AddLayer(IList list, bool enableSelection=true) | Deltares.Standard.Forms.DExpress.MapEditor |
AddProperty(object source, params string[] properties) | Deltares.Standard.Forms.DExpress.MapEditor |
AddRaster(IHasRaster rasterData) | Deltares.Standard.Forms.DExpress.MapEditor |
BackgroundMaps | Deltares.Standard.Forms.DExpress.MapEditor |
Clear() | Deltares.Standard.Forms.DExpress.MapEditor |
CursorOnMap | Deltares.Standard.Forms.DExpress.MapEditor |
cursorOnMap (defined in Deltares.Standard.Forms.DExpress.MapEditor) | Deltares.Standard.Forms.DExpress.MapEditor | protected
Dispose() | Deltares.Standard.Forms.DExpress.MapEditor |
Dispose(bool disposing) | Deltares.Standard.Forms.DExpress.MapEditor | protected
EmptySelection | Deltares.Standard.Forms.DExpress.MapEditor |
EnableSelectButton | Deltares.Standard.Forms.DExpress.MapEditor |
EnableZoomRectangle | Deltares.Standard.Forms.DExpress.MapEditor |
EnableZoomToData | Deltares.Standard.Forms.DExpress.MapEditor |
EnableZoomToSelection | Deltares.Standard.Forms.DExpress.MapEditor |
GetBackgroundLayer(BackgroundMap backgroundMap) | Deltares.Standard.Forms.DExpress.MapEditor |
GetMouseGeoCoordinateText(double x, double y, ProjectionInfo projection) (defined in Deltares.Standard.Forms.DExpress.MapEditor) | Deltares.Standard.Forms.DExpress.MapEditor | protected
GetPoint(object geographic) | Deltares.Standard.Forms.DExpress.MapEditor |
GetString(object geographic) | Deltares.Standard.Forms.DExpress.MapEditor |
HandleDirtyLists() (defined in Deltares.Standard.Forms.DExpress.MapEditor) | Deltares.Standard.Forms.DExpress.MapEditor | protected
IsEnabled(string property) | Deltares.Standard.Forms.DExpress.MapEditor |
IsLayerVisible(IList list) | Deltares.Standard.Forms.DExpress.MapEditor |
IsUrlAlive(string url, int timeoutSeconds) (defined in Deltares.Standard.Forms.DExpress.MapEditor) | Deltares.Standard.Forms.DExpress.MapEditor | static
IsVisible(string property) | Deltares.Standard.Forms.DExpress.MapEditor |
LegendPropertyControlHasBeenSet | Deltares.Standard.Forms.DExpress.MapEditor |
LoadExtensions (defined in Deltares.Standard.Forms.DExpress.MapEditor) | Deltares.Standard.Forms.DExpress.MapEditor | static
MapControl (defined in Deltares.Standard.Forms.DExpress.MapEditor) | Deltares.Standard.Forms.DExpress.MapEditor |
MapControl_MouseDown(object sender, MouseEventArgs e) | Deltares.Standard.Forms.DExpress.MapEditor |
MapControl_MouseUp(object sender, MouseEventArgs e) | Deltares.Standard.Forms.DExpress.MapEditor |
MapEditor() | Deltares.Standard.Forms.DExpress.MapEditor |
MapExtent | Deltares.Standard.Forms.DExpress.MapEditor |
MapTools | Deltares.Standard.Forms.DExpress.MapEditor |
MoveToFront(IMapLayer layer) | Deltares.Standard.Forms.DExpress.MapEditor |
RegisteredLayers | Deltares.Standard.Forms.DExpress.MapEditor |
RegisterLayer(string rasterType, RasterLayerDefinition scheme) | Deltares.Standard.Forms.DExpress.MapEditor |
RegisterLayer(Type type, MapLayerDefinition scheme) | Deltares.Standard.Forms.DExpress.MapEditor |
RemoveLayer(IList list) | Deltares.Standard.Forms.DExpress.MapEditor |
RemoveRaster(IHasRaster rasterData) | Deltares.Standard.Forms.DExpress.MapEditor |
ResumeLayerEvents() | Deltares.Standard.Forms.DExpress.MapEditor |
SelectedObjects | Deltares.Standard.Forms.DExpress.MapEditor |
SendLegendEvent | Deltares.Standard.Forms.DExpress.MapEditor |
ShowExportLayersButton | Deltares.Standard.Forms.DExpress.MapEditor |
ShowFeatureTextInMapInfoBar | Deltares.Standard.Forms.DExpress.MapEditor |
ShowSelectWebLayer | Deltares.Standard.Forms.DExpress.MapEditor |
ShowWebLayer | Deltares.Standard.Forms.DExpress.MapEditor |
StatusBarProjection | Deltares.Standard.Forms.DExpress.MapEditor |
SuspendLayerEvents() | Deltares.Standard.Forms.DExpress.MapEditor |
Toolbar (defined in Deltares.Standard.Forms.DExpress.MapEditor) | Deltares.Standard.Forms.DExpress.MapEditor |
UpdateAllLayers() | Deltares.Standard.Forms.DExpress.MapEditor |
WEBLAYERNAME (defined in Deltares.Standard.Forms.DExpress.MapEditor) | Deltares.Standard.Forms.DExpress.MapEditor |
WebLayerType | Deltares.Standard.Forms.DExpress.MapEditor |
WebLayerTypes enum name | Deltares.Standard.Forms.DExpress.MapEditor |
ZoomData() | Deltares.Standard.Forms.DExpress.MapEditor |
ZoomExtents() | Deltares.Standard.Forms.DExpress.MapEditor |
ZoomRectangle() | Deltares.Standard.Forms.DExpress.MapEditor |
ZOOMTOWEBLAYERNAME (defined in Deltares.Standard.Forms.DExpress.MapEditor) | Deltares.Standard.Forms.DExpress.MapEditor |
Generated on Tue Dec 15 2015 18:15:00 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.MapLayerDefinition Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • MapLayerDefinition
Public Member Functions | Properties | List of all members
Deltares.Standard.Forms.DExpress.MapLayerDefinition Class Reference

Class defining various property of a map layer, like feature type, name, symbology. More...

Public Member Functions

MapLayerDefinition (FeatureType featureType, string name, Image image)
Initializes a new instance of the MapLayerDefinition class with the given feature type, name and image. More...
MapLayerDefinition (FeatureType featureType, string name, Color color)
Initializes a new instance of the MapLayerDefinition class with the given feature name, name and color. More...
MapLayerDefinition (FeatureType featureType, string name, Color color, bool selectable)
Initializes a new instance of the MapLayerDefinition class with the given feature type, name, color and selectable flag. More...
MapLayerDefinition (FeatureType featureType, string name, IFeatureScheme scheme)
Initializes a new instance of the MapLayerDefinition class with the given feature type, name and scheme. More...
MapLayerDefinition (FeatureType featureType, string name, IFeatureScheme scheme, bool allowMoveFeature)
Initializes a new instance of the MapLayerDefinition class with the given feature type, name, scheme and flag if moving features is allowed. More...
MapLayerDefinition (FeatureType featureType, string name, IFeatureScheme scheme, bool useDynamicVisibility, double dynamicVisibilityWidth, DynamicVisibilityMode dynamicVisibilityMode)
Initializes a new instance of the MapLayerDefinition class with the given feature type, name, scheme & parameters for dynamic visibility: the flag, the width and the mode. When useDynamicVisibility is true, DynamicVisibilityMode is used when a layer is created in the MapEditor, the layer will only be visible when zoomed in / out closer than the DynamicVisibilityWidth More...

Properties

FeatureType | FeatureType [get, set]
Gets or sets the type of the feature. More...
string | Name [get, set]
Gets or sets the name. More...
Image | Image [get, set]
Gets or sets the image. More...
Color | Color [get, set]
Gets or sets the color. More...
IFeatureScheme | Scheme [get, set]
Gets or sets the scheme. More...
bool | Selectable [get, set]
Gets or sets a value indicating whether the layer is selectable. More...
bool | Movable [get, set]
Gets or sets a value indicating whether the layer is movable. More...
bool | AllowMoveFeature [get, set]
Allow moving a feature More...
bool | AllowAddNewFeature [get, set]
Allow adding a new feature (snapping to the related layer) More...
bool | AllowDeleteFeature [get, set]
Allow deleting a feature More...
bool | AllowConnectingFeature [get, set]
Allow connecting a feature to the related layer More...
Func< IGeographicPoint, IGeographic > | SnapRule [get, set]
Rule used for snapping (add new, move, connecting) More...
BoolDelegate | EnabledRule [get, set]
Rule used for enabled (add new, move, connecting) More...
bool | UseDynamicVisibility [get]
Gets a value indicating whether to use dynamic visibility. More...
double | DynamicVisibilityWidth [get]
Gets the width of the dynamic visibility. More...
DynamicVisibilityMode | DynamicVisibilityMode [get]
Gets the dynamic visibility mode. More...
bool | HasSearchTree [get, set]
Gets or sets a value indicating whether layer has search tree. More...

Detailed Description

Class defining various property of a map layer, like feature type, name, symbology.

Constructor & Destructor Documentation

Deltares.Standard.Forms.DExpress.MapLayerDefinition.MapLayerDefinition | ( | FeatureType | featureType,
 |  | string | name,
 |  | Image | image
 | ) |  |

Initializes a new instance of the MapLayerDefinition class with the given feature type, name and image.

Deltares.Standard.Forms.DExpress.MapLayerDefinition.MapLayerDefinition | ( | FeatureType | featureType,
 |  | string | name,
 |  | Color | color
 | ) |  |

Initializes a new instance of the MapLayerDefinition class with the given feature name, name and color.

Deltares.Standard.Forms.DExpress.MapLayerDefinition.MapLayerDefinition | ( | FeatureType | featureType,
 |  | string | name,
 |  | Color | color,
 |  | bool | selectable
 | ) |  |

Initializes a new instance of the MapLayerDefinition class with the given feature type, name, color and selectable flag.

Deltares.Standard.Forms.DExpress.MapLayerDefinition.MapLayerDefinition | ( | FeatureType | featureType,
 |  | string | name,
 |  | IFeatureScheme | scheme
 | ) |  |

Initializes a new instance of the MapLayerDefinition class with the given feature type, name and scheme.

Deltares.Standard.Forms.DExpress.MapLayerDefinition.MapLayerDefinition | ( | FeatureType | featureType,
 |  | string | name,
 |  | IFeatureScheme | scheme,
 |  | bool | allowMoveFeature
 | ) |  |

Initializes a new instance of the MapLayerDefinition class with the given feature type, name, scheme and flag if moving features is allowed.

Deltares.Standard.Forms.DExpress.MapLayerDefinition.MapLayerDefinition | ( | FeatureType | featureType,
 |  | string | name,
 |  | IFeatureScheme | scheme,
 |  | bool | useDynamicVisibility,
 |  | double | dynamicVisibilityWidth,
 |  | DynamicVisibilityMode | dynamicVisibilityMode
 | ) |  |

Initializes a new instance of the MapLayerDefinition class with the given feature type, name, scheme & parameters for dynamic visibility: the flag, the width and the mode. When useDynamicVisibility is true, DynamicVisibilityMode is used when a layer is created in the MapEditor, the layer will only be visible when zoomed in / out closer than the DynamicVisibilityWidth

Property Documentation

bool Deltares.Standard.Forms.DExpress.MapLayerDefinition.AllowAddNewFeature
getset

Allow adding a new feature (snapping to the related layer)

bool Deltares.Standard.Forms.DExpress.MapLayerDefinition.AllowConnectingFeature
getset

Allow connecting a feature to the related layer

bool Deltares.Standard.Forms.DExpress.MapLayerDefinition.AllowDeleteFeature
getset

Allow deleting a feature

bool Deltares.Standard.Forms.DExpress.MapLayerDefinition.AllowMoveFeature
getset

Allow moving a feature

Color Deltares.Standard.Forms.DExpress.MapLayerDefinition.Color
getset

Gets or sets the color.

The color.

DynamicVisibilityMode Deltares.Standard.Forms.DExpress.MapLayerDefinition.DynamicVisibilityMode
get

Gets the dynamic visibility mode.

The dynamic visibility mode.

double Deltares.Standard.Forms.DExpress.MapLayerDefinition.DynamicVisibilityWidth
get

Gets the width of the dynamic visibility.

The width of the dynamic visibility.

BoolDelegate Deltares.Standard.Forms.DExpress.MapLayerDefinition.EnabledRule
getset

Rule used for enabled (add new, move, connecting)

FeatureType Deltares.Standard.Forms.DExpress.MapLayerDefinition.FeatureType
getset

Gets or sets the type of the feature.

The type of the feature.

Referenced by Deltares.Standard.Forms.DExpress.MapEditor.RegisterLayer().

bool Deltares.Standard.Forms.DExpress.MapLayerDefinition.HasSearchTree
getset

Gets or sets a value indicating whether layer has search tree.

true if has search tree; otherwise, false.

Image Deltares.Standard.Forms.DExpress.MapLayerDefinition.Image
getset

Gets or sets the image.

The image.

bool Deltares.Standard.Forms.DExpress.MapLayerDefinition.Movable
getset

Gets or sets a value indicating whether the layer is movable.

true if movable; otherwise, false.

string Deltares.Standard.Forms.DExpress.MapLayerDefinition.Name
getset

Gets or sets the name.

The name.

IFeatureScheme Deltares.Standard.Forms.DExpress.MapLayerDefinition.Scheme
getset

Gets or sets the scheme.

The scheme.

bool Deltares.Standard.Forms.DExpress.MapLayerDefinition.Selectable
getset

Gets or sets a value indicating whether the layer is selectable.

true if selectable; otherwise, false.

Func<IGeographicPoint, IGeographic> Deltares.Standard.Forms.DExpress.MapLayerDefinition.SnapRule
getset

Rule used for snapping (add new, move, connecting)

bool Deltares.Standard.Forms.DExpress.MapLayerDefinition.UseDynamicVisibility
get

Gets a value indicating whether to use dynamic visibility.

true if use dynamic visibility; otherwise, false.

Generated on Tue Dec 15 2015 18:15:00 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • MapLayerDefinition
Deltares.Standard.Forms.DExpress.MapLayerDefinition Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.MapLayerDefinition, including all inherited members.

AllowAddNewFeature | Deltares.Standard.Forms.DExpress.MapLayerDefinition
AllowConnectingFeature | Deltares.Standard.Forms.DExpress.MapLayerDefinition
AllowDeleteFeature | Deltares.Standard.Forms.DExpress.MapLayerDefinition
AllowMoveFeature | Deltares.Standard.Forms.DExpress.MapLayerDefinition
Color | Deltares.Standard.Forms.DExpress.MapLayerDefinition
DynamicVisibilityMode | Deltares.Standard.Forms.DExpress.MapLayerDefinition
DynamicVisibilityWidth | Deltares.Standard.Forms.DExpress.MapLayerDefinition
EnabledRule | Deltares.Standard.Forms.DExpress.MapLayerDefinition
FeatureType | Deltares.Standard.Forms.DExpress.MapLayerDefinition
HasSearchTree | Deltares.Standard.Forms.DExpress.MapLayerDefinition
Image | Deltares.Standard.Forms.DExpress.MapLayerDefinition
MapLayerDefinition(FeatureType featureType, string name, Image image) | Deltares.Standard.Forms.DExpress.MapLayerDefinition
MapLayerDefinition(FeatureType featureType, string name, Color color) | Deltares.Standard.Forms.DExpress.MapLayerDefinition
MapLayerDefinition(FeatureType featureType, string name, Color color, bool selectable) | Deltares.Standard.Forms.DExpress.MapLayerDefinition
MapLayerDefinition(FeatureType featureType, string name, IFeatureScheme scheme) | Deltares.Standard.Forms.DExpress.MapLayerDefinition
MapLayerDefinition(FeatureType featureType, string name, IFeatureScheme scheme, bool allowMoveFeature) | Deltares.Standard.Forms.DExpress.MapLayerDefinition
MapLayerDefinition(FeatureType featureType, string name, IFeatureScheme scheme, bool useDynamicVisibility, double dynamicVisibilityWidth, DynamicVisibilityMode dynamicVisibilityMode) | Deltares.Standard.Forms.DExpress.MapLayerDefinition
Movable | Deltares.Standard.Forms.DExpress.MapLayerDefinition
Name | Deltares.Standard.Forms.DExpress.MapLayerDefinition
Scheme | Deltares.Standard.Forms.DExpress.MapLayerDefinition
Selectable | Deltares.Standard.Forms.DExpress.MapLayerDefinition
SnapRule | Deltares.Standard.Forms.DExpress.MapLayerDefinition
UseDynamicVisibility | Deltares.Standard.Forms.DExpress.MapLayerDefinition
Generated on Tue Dec 15 2015 18:15:00 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.MapLayersPropertyControl Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • MapLayersPropertyControl
Protected Member Functions | Properties | List of all members
Deltares.Standard.Forms.DExpress.MapLayersPropertyControl Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.MapLayersPropertyControl:
Deltares.Standard.Forms.IPropertyControl

Protected Member Functions

override void Dispose (bool disposing)
Clean up any resources being used. More...

Properties

object | SelectedObject [get, set]
bool | IsVisible [get]
- Properties inherited from Deltares.Standard.Forms.IPropertyControl
string | Name [get, set]
Gets or sets the name to be displayed property. More...
object | SelectedObject [get, set]
Gets or sets the object to be displayed in the property window. More...
bool | IsVisible [get]
Whether or not the property control should be displayed. More...

Member Function Documentation

override void Deltares.Standard.Forms.DExpress.MapLayersPropertyControl.Dispose ( bool disposing )
protected

Clean up any resources being used.

Parameters
disposing true if managed resources should be disposed; otherwise, false.
Generated on Tue Dec 15 2015 18:15:00 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • MapLayersPropertyControl
Deltares.Standard.Forms.DExpress.MapLayersPropertyControl Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.MapLayersPropertyControl, including all inherited members.

Dispose(bool disposing) | Deltares.Standard.Forms.DExpress.MapLayersPropertyControl | protected
IsVisible (defined in Deltares.Standard.Forms.DExpress.MapLayersPropertyControl) | Deltares.Standard.Forms.DExpress.MapLayersPropertyControl |
MapLayersPropertyControl() (defined in Deltares.Standard.Forms.DExpress.MapLayersPropertyControl) | Deltares.Standard.Forms.DExpress.MapLayersPropertyControl |
Name | Deltares.Standard.Forms.IPropertyControl |
SelectedObject (defined in Deltares.Standard.Forms.DExpress.MapLayersPropertyControl) | Deltares.Standard.Forms.DExpress.MapLayersPropertyControl |
Generated on Tue Dec 15 2015 18:15:00 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.MapLegendPropertyControl Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • MapLegendPropertyControl
Protected Member Functions | Properties | List of all members
Deltares.Standard.Forms.DExpress.MapLegendPropertyControl Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.MapLegendPropertyControl:
Deltares.Standard.Forms.IPropertyControl

Protected Member Functions

override void Dispose (bool disposing)
Clean up any resources being used. More...

Properties

object | SelectedObject [get, set]
bool | IsVisible [get]
- Properties inherited from Deltares.Standard.Forms.IPropertyControl
string | Name [get, set]
Gets or sets the name to be displayed property. More...
object | SelectedObject [get, set]
Gets or sets the object to be displayed in the property window. More...
bool | IsVisible [get]
Whether or not the property control should be displayed. More...

Member Function Documentation

override void Deltares.Standard.Forms.DExpress.MapLegendPropertyControl.Dispose ( bool disposing )
protected

Clean up any resources being used.

Parameters
disposing true if managed resources should be disposed; otherwise, false.
Generated on Tue Dec 15 2015 18:15:01 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • MapLegendPropertyControl
Deltares.Standard.Forms.DExpress.MapLegendPropertyControl Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.MapLegendPropertyControl, including all inherited members.

Dispose(bool disposing) | Deltares.Standard.Forms.DExpress.MapLegendPropertyControl | protected
IsVisible (defined in Deltares.Standard.Forms.DExpress.MapLegendPropertyControl) | Deltares.Standard.Forms.DExpress.MapLegendPropertyControl |
MapLegendPropertyControl() (defined in Deltares.Standard.Forms.DExpress.MapLegendPropertyControl) | Deltares.Standard.Forms.DExpress.MapLegendPropertyControl |
Name | Deltares.Standard.Forms.IPropertyControl |
SelectedObject (defined in Deltares.Standard.Forms.DExpress.MapLegendPropertyControl) | Deltares.Standard.Forms.DExpress.MapLegendPropertyControl |
Generated on Tue Dec 15 2015 18:15:01 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.MinusStrategy Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • MinusStrategy
Public Member Functions | Protected Member Functions | List of all members
Deltares.Standard.Forms.DExpress.MinusStrategy Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.MinusStrategy:
Deltares.Standard.Forms.DExpress.GridEditValueStrategy

Public Member Functions

override double | DefaultForSelected (GridView view)
Determines the default value based on the selected values. Not all implementations will use the selected values, but by passing the view, we can generalize the method call. More...
override string | ToString ()
This method has to be overridden so it has a proper representation in the UI. More...
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.GridEditValueStrategy
void | EvaluateForSelected (GridView view, double modificationValue)
Sets new cell values by evaluating the modification value and using the current strategy. More...

Protected Member Functions

override double Evaluate (double value, double modificationValue)
The implementation of this method is used in the EvaluateForSelected method. More...

Additional Inherited Members

- Static Public Attributes inherited from Deltares.Standard.Forms.DExpress.GridEditValueStrategy
static readonly GridEditValueStrategy[] Strategies
Collection of all the strategies which are defined in this file. This is a static list so the strategies will only be instantiated once. Using instantiations make polymorphism possible. More...

Member Function Documentation

override double Deltares.Standard.Forms.DExpress.MinusStrategy.DefaultForSelected ( GridView view )
virtual

Determines the default value based on the selected values. Not all implementations will use the selected values, but by passing the view, we can generalize the method call.

Parameters
view The view (which may not be used at all) containing selected values (or not).
Returns
A sensible default for the strategy, or null if no sensible default can be given.

Implements Deltares.Standard.Forms.DExpress.GridEditValueStrategy.

override double Deltares.Standard.Forms.DExpress.MinusStrategy.Evaluate | ( | double | value,
 |  | double | modificationValue
 | ) |  |
protectedvirtual

The implementation of this method is used in the EvaluateForSelected method.

Parameters
value | The current value.
modificationValue | The value used in evaluating a new value.
Returns
The new value.

Implements Deltares.Standard.Forms.DExpress.GridEditValueStrategy.

override string Deltares.Standard.Forms.DExpress.MinusStrategy.ToString ( )
virtual

This method has to be overridden so it has a proper representation in the UI.

Returns

Implements Deltares.Standard.Forms.DExpress.GridEditValueStrategy.

Generated on Tue Dec 15 2015 18:15:01 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • MinusStrategy
Deltares.Standard.Forms.DExpress.MinusStrategy Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.MinusStrategy, including all inherited members.

DefaultForSelected(GridView view) | Deltares.Standard.Forms.DExpress.MinusStrategy | virtual
Evaluate(double value, double modificationValue) | Deltares.Standard.Forms.DExpress.MinusStrategy | protectedvirtual
EvaluateForSelected(GridView view, double modificationValue) | Deltares.Standard.Forms.DExpress.GridEditValueStrategy |
Strategies | Deltares.Standard.Forms.DExpress.GridEditValueStrategy | static
ToString() | Deltares.Standard.Forms.DExpress.MinusStrategy | virtual
Generated on Tue Dec 15 2015 18:15:01 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.ModelDialog Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • ModelDialog
Public Member Functions | Public Attributes | Properties | Events | List of all members
Deltares.Standard.Forms.DExpress.ModelDialog Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.ModelDialog:

Public Member Functions

void InitializeComponents ()

Public Attributes

PanelControl | ButtonsPanel = null
SimpleButton | CancelButton = null
SimpleButton | HelpButton = null
bool | IsCancelButtonVisible = true
bool | IsHelpButtonVisible = true
bool | IsOkButtonVisible = true

Properties

SimpleButton OkButton [get, set]

Events

EventHandler | OnCancelButtonClick = null
EventHandler | OnHelpButtonClick = null
EventHandler | OnOkButtonClick = null
Generated on Tue Dec 15 2015 18:15:01 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • ModelDialog
Deltares.Standard.Forms.DExpress.ModelDialog Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.ModelDialog, including all inherited members.

ButtonsPanel (defined in Deltares.Standard.Forms.DExpress.ModelDialog) | Deltares.Standard.Forms.DExpress.ModelDialog
CancelButton (defined in Deltares.Standard.Forms.DExpress.ModelDialog) | Deltares.Standard.Forms.DExpress.ModelDialog
HelpButton (defined in Deltares.Standard.Forms.DExpress.ModelDialog) | Deltares.Standard.Forms.DExpress.ModelDialog
InitializeComponents() (defined in Deltares.Standard.Forms.DExpress.ModelDialog) | Deltares.Standard.Forms.DExpress.ModelDialog
IsCancelButtonVisible (defined in Deltares.Standard.Forms.DExpress.ModelDialog) | Deltares.Standard.Forms.DExpress.ModelDialog
IsHelpButtonVisible (defined in Deltares.Standard.Forms.DExpress.ModelDialog) | Deltares.Standard.Forms.DExpress.ModelDialog
IsOkButtonVisible (defined in Deltares.Standard.Forms.DExpress.ModelDialog) | Deltares.Standard.Forms.DExpress.ModelDialog
ModelDialog() (defined in Deltares.Standard.Forms.DExpress.ModelDialog) | Deltares.Standard.Forms.DExpress.ModelDialog
OkButton (defined in Deltares.Standard.Forms.DExpress.ModelDialog) | Deltares.Standard.Forms.DExpress.ModelDialog
OnCancelButtonClick (defined in Deltares.Standard.Forms.DExpress.ModelDialog) | Deltares.Standard.Forms.DExpress.ModelDialog
OnHelpButtonClick (defined in Deltares.Standard.Forms.DExpress.ModelDialog) | Deltares.Standard.Forms.DExpress.ModelDialog
OnOkButtonClick (defined in Deltares.Standard.Forms.DExpress.ModelDialog) | Deltares.Standard.Forms.DExpress.ModelDialog
Generated on Tue Dec 15 2015 18:15:01 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.MultiplyStrategy Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • MultiplyStrategy
Public Member Functions | Protected Member Functions | List of all members
Deltares.Standard.Forms.DExpress.MultiplyStrategy Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.MultiplyStrategy:
Deltares.Standard.Forms.DExpress.GridEditValueStrategy

Public Member Functions

override double | DefaultForSelected (GridView view)
Determines the default value based on the selected values. Not all implementations will use the selected values, but by passing the view, we can generalize the method call. More...
override string | ToString ()
This method has to be overridden so it has a proper representation in the UI. More...
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.GridEditValueStrategy
void | EvaluateForSelected (GridView view, double modificationValue)
Sets new cell values by evaluating the modification value and using the current strategy. More...

Protected Member Functions

override double Evaluate (double value, double modificationValue)
The implementation of this method is used in the EvaluateForSelected method. More...

Additional Inherited Members

- Static Public Attributes inherited from Deltares.Standard.Forms.DExpress.GridEditValueStrategy
static readonly GridEditValueStrategy[] Strategies
Collection of all the strategies which are defined in this file. This is a static list so the strategies will only be instantiated once. Using instantiations make polymorphism possible. More...

Member Function Documentation

override double Deltares.Standard.Forms.DExpress.MultiplyStrategy.DefaultForSelected ( GridView view )
virtual

Determines the default value based on the selected values. Not all implementations will use the selected values, but by passing the view, we can generalize the method call.

Parameters
view The view (which may not be used at all) containing selected values (or not).
Returns
A sensible default for the strategy, or null if no sensible default can be given.

Implements Deltares.Standard.Forms.DExpress.GridEditValueStrategy.

override double Deltares.Standard.Forms.DExpress.MultiplyStrategy.Evaluate | ( | double | value,
 |  | double | modificationValue
 | ) |  |
protectedvirtual

The implementation of this method is used in the EvaluateForSelected method.

Parameters
value | The current value.
modificationValue | The value used in evaluating a new value.
Returns
The new value.

Implements Deltares.Standard.Forms.DExpress.GridEditValueStrategy.

override string Deltares.Standard.Forms.DExpress.MultiplyStrategy.ToString ( )
virtual

This method has to be overridden so it has a proper representation in the UI.

Returns

Implements Deltares.Standard.Forms.DExpress.GridEditValueStrategy.

Generated on Tue Dec 15 2015 18:15:01 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • MultiplyStrategy
Deltares.Standard.Forms.DExpress.MultiplyStrategy Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.MultiplyStrategy, including all inherited members.

DefaultForSelected(GridView view) | Deltares.Standard.Forms.DExpress.MultiplyStrategy | virtual
Evaluate(double value, double modificationValue) | Deltares.Standard.Forms.DExpress.MultiplyStrategy | protectedvirtual
EvaluateForSelected(GridView view, double modificationValue) | Deltares.Standard.Forms.DExpress.GridEditValueStrategy |
Strategies | Deltares.Standard.Forms.DExpress.GridEditValueStrategy | static
ToString() | Deltares.Standard.Forms.DExpress.MultiplyStrategy | virtual
Generated on Tue Dec 15 2015 18:15:01 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.MyFeatureSet Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • MyFeatureSet
Public Member Functions | Properties | List of all members
Deltares.Standard.Forms.DExpress.MyFeatureSet Class Reference

This class is a customized version of DotSpatial FeatureSet adding specific feature selection functionality More...

Inheritance diagram for Deltares.Standard.Forms.DExpress.MyFeatureSet:

Public Member Functions

override void | Reproject (ProjectionInfo targetProjection)
Reprojects all of the in-ram vertices of this featureset. This will also update the projection to be the specified projection. More...
override List< IFeature > | Select (Extent region)
Select visable features for the given region More...

Properties

bool Dirty [get, set]
Gets or sets a value indicating whether feature set is dirty. More...

Detailed Description

This class is a customized version of DotSpatial FeatureSet adding specific feature selection functionality

Member Function Documentation

override void Deltares.Standard.Forms.DExpress.MyFeatureSet.Reproject ( ProjectionInfo targetProjection )

Reprojects all of the in-ram vertices of this featureset. This will also update the projection to be the specified projection.

Parameters
targetProjection The projection information to reproject the coordinates to.
override List<IFeature> Deltares.Standard.Forms.DExpress.MyFeatureSet.Select ( Extent region )

Select visable features for the given region

Property Documentation

bool Deltares.Standard.Forms.DExpress.MyFeatureSet.Dirty
getset

Gets or sets a value indicating whether feature set is dirty.

true if dirty; otherwise, false.

Generated on Tue Dec 15 2015 18:15:02 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • MyFeatureSet
Deltares.Standard.Forms.DExpress.MyFeatureSet Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.MyFeatureSet, including all inherited members.

Dirty | Deltares.Standard.Forms.DExpress.MyFeatureSet
Reproject(ProjectionInfo targetProjection) | Deltares.Standard.Forms.DExpress.MyFeatureSet
Select(Extent region) | Deltares.Standard.Forms.DExpress.MyFeatureSet
Generated on Tue Dec 15 2015 18:15:02 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.MyMapLineLayer Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • MyMapLineLayer
Public Member Functions | Properties | List of all members
Deltares.Standard.Forms.DExpress.MyMapLineLayer Class Reference

This class is a customized version of DotSpatial MapLineLayer, adding specific feature selection functionality More...

Inheritance diagram for Deltares.Standard.Forms.DExpress.MyMapLineLayer:
Deltares.Standard.Forms.DExpress.Interfaces.ISelectableLayer

Public Member Functions

MyMapLineLayer (IFeatureSet featureSet, MapEditor mapEditor)
Initializes a new instance of the MyMapLineLayer class. More...
IFeature | GetFeature (object selectObject)
Gets the feature. More...
IFeature | SetSelected (object selectObject, bool selected)
Sets the given object to (non-)selected depending on given flag. To select/unselect all features, pass null as the selected object. More...

Properties

bool | Selectable [get, set]
Gets or sets a value indicating whether layer is selectable. More...
IList | DataSource [get, set]
Gets or sets the data source. More...
- Properties inherited from Deltares.Standard.Forms.DExpress.Interfaces.ISelectableLayer
IList | DataSource [get, set]

Detailed Description

This class is a customized version of DotSpatial MapLineLayer, adding specific feature selection functionality

Constructor & Destructor Documentation

Deltares.Standard.Forms.DExpress.MyMapLineLayer.MyMapLineLayer | ( | IFeatureSet | featureSet,
 |  | MapEditor | mapEditor
 | ) |  |

Initializes a new instance of the MyMapLineLayer class.

Parameters
featureSet | The feature set.
mapEditor | The map editor.

Member Function Documentation

IFeature Deltares.Standard.Forms.DExpress.MyMapLineLayer.GetFeature ( object selectObject )

Gets the feature.

Parameters
selectObject The select object.
Returns

Implements Deltares.Standard.Forms.DExpress.Interfaces.ISelectableLayer.

IFeature Deltares.Standard.Forms.DExpress.MyMapLineLayer.SetSelected | ( | object | selectObject,
 |  | bool | selected
 | ) |  |

Sets the given object to (non-)selected depending on given flag. To select/unselect all features, pass null as the selected object.

Implements Deltares.Standard.Forms.DExpress.Interfaces.ISelectableLayer.

Property Documentation

IList Deltares.Standard.Forms.DExpress.MyMapLineLayer.DataSource
getset

Gets or sets the data source.

The data source.

bool Deltares.Standard.Forms.DExpress.MyMapLineLayer.Selectable
getset

Gets or sets a value indicating whether layer is selectable.

true if selectable; otherwise, false.

Generated on Tue Dec 15 2015 18:15:02 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • MyMapLineLayer
Deltares.Standard.Forms.DExpress.MyMapLineLayer Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.MyMapLineLayer, including all inherited members.

DataSource | Deltares.Standard.Forms.DExpress.MyMapLineLayer
GetFeature(object selectObject) | Deltares.Standard.Forms.DExpress.MyMapLineLayer
MyMapLineLayer(IFeatureSet featureSet, MapEditor mapEditor) | Deltares.Standard.Forms.DExpress.MyMapLineLayer
Selectable | Deltares.Standard.Forms.DExpress.MyMapLineLayer
SetSelected(object selectObject, bool selected) | Deltares.Standard.Forms.DExpress.MyMapLineLayer
Generated on Tue Dec 15 2015 18:15:02 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.MyMapPointLayer Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • MyMapPointLayer
Public Member Functions | Properties | List of all members
Deltares.Standard.Forms.DExpress.MyMapPointLayer Class Reference

This class is a customized version of DotSpatial MapPointLayer, adding specific feature selection functionality More...

Inheritance diagram for Deltares.Standard.Forms.DExpress.MyMapPointLayer:
Deltares.Standard.Forms.DExpress.Interfaces.ISelectableLayer

Public Member Functions

MyMapPointLayer (IFeatureSet featureSet, MapEditor mapEditor)
Initializes a new instance of the MyMapPointLayer class using the given feature set and map editor More...
IFeature | GetFeature (object selectObject)
Gets the feature. More...
IFeature | SetSelected (object selectObject, bool selected)
Sets the given object to (non-)selected depending on given flag. To select/unselect all features, pass null as the selected object. More...

Properties

bool | Selectable [get, set]
Gets or sets a value indicating whether layer is selectable. More...
IList | DataSource [get, set]
Gets or sets the data source. More...
- Properties inherited from Deltares.Standard.Forms.DExpress.Interfaces.ISelectableLayer
IList | DataSource [get, set]

Detailed Description

This class is a customized version of DotSpatial MapPointLayer, adding specific feature selection functionality

Constructor & Destructor Documentation

Deltares.Standard.Forms.DExpress.MyMapPointLayer.MyMapPointLayer | ( | IFeatureSet | featureSet,
 |  | MapEditor | mapEditor
 | ) |  |

Initializes a new instance of the MyMapPointLayer class using the given feature set and map editor

Member Function Documentation

IFeature Deltares.Standard.Forms.DExpress.MyMapPointLayer.GetFeature ( object selectObject )

Gets the feature.

Parameters
selectObject The selected object.
Returns

Implements Deltares.Standard.Forms.DExpress.Interfaces.ISelectableLayer.

IFeature Deltares.Standard.Forms.DExpress.MyMapPointLayer.SetSelected | ( | object | selectObject,
 |  | bool | selected
 | ) |  |

Sets the given object to (non-)selected depending on given flag. To select/unselect all features, pass null as the selected object.

Implements Deltares.Standard.Forms.DExpress.Interfaces.ISelectableLayer.

Property Documentation

IList Deltares.Standard.Forms.DExpress.MyMapPointLayer.DataSource
getset

Gets or sets the data source.

The data source.

bool Deltares.Standard.Forms.DExpress.MyMapPointLayer.Selectable
getset

Gets or sets a value indicating whether layer is selectable.

true if selectable; otherwise, false.

Generated on Tue Dec 15 2015 18:15:02 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • MyMapPointLayer
Deltares.Standard.Forms.DExpress.MyMapPointLayer Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.MyMapPointLayer, including all inherited members.

DataSource | Deltares.Standard.Forms.DExpress.MyMapPointLayer
GetFeature(object selectObject) | Deltares.Standard.Forms.DExpress.MyMapPointLayer
MyMapPointLayer(IFeatureSet featureSet, MapEditor mapEditor) | Deltares.Standard.Forms.DExpress.MyMapPointLayer
Selectable | Deltares.Standard.Forms.DExpress.MyMapPointLayer
SetSelected(object selectObject, bool selected) | Deltares.Standard.Forms.DExpress.MyMapPointLayer
Generated on Tue Dec 15 2015 18:15:02 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.MyMapPolygonLayer Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • MyMapPolygonLayer
Public Member Functions | Properties | List of all members
Deltares.Standard.Forms.DExpress.MyMapPolygonLayer Class Reference

This class is a customized version of DotSpatial MapPolygonLayer, adding specific feature selection functionality More...

Inheritance diagram for Deltares.Standard.Forms.DExpress.MyMapPolygonLayer:
Deltares.Standard.Forms.DExpress.Interfaces.ISelectableLayer

Public Member Functions

MyMapPolygonLayer (IFeatureSet featureSet, MapEditor mapEditor)
Initializes a new instance of the Deltares.Standard.Forms.DExpress.MyMapPolygonLayer class. More...
IFeature | GetFeature (object selectObject)
Gets the feature. More...
IFeature | SetSelected (object selectObject, bool selected)
Sets the given object to (non-)selected depending on given flag. To select/unselect all features, pass null as the selected object. More...

Properties

IList | DataSource [get, set]
Gets or sets the data source. More...
- Properties inherited from Deltares.Standard.Forms.DExpress.Interfaces.ISelectableLayer
IList | DataSource [get, set]

Detailed Description

This class is a customized version of DotSpatial MapPolygonLayer, adding specific feature selection functionality

Constructor & Destructor Documentation

Deltares.Standard.Forms.DExpress.MyMapPolygonLayer.MyMapPolygonLayer | ( | IFeatureSet | featureSet,
 |  | MapEditor | mapEditor
 | ) |  |

Initializes a new instance of the Deltares.Standard.Forms.DExpress.MyMapPolygonLayer class.

Parameters
featureSet | The feature set.
mapEditor | The map editor.

Member Function Documentation

IFeature Deltares.Standard.Forms.DExpress.MyMapPolygonLayer.GetFeature ( object selectObject )

Gets the feature.

Parameters
selectObject The select object.
Returns

Implements Deltares.Standard.Forms.DExpress.Interfaces.ISelectableLayer.

IFeature Deltares.Standard.Forms.DExpress.MyMapPolygonLayer.SetSelected | ( | object | selectObject,
 |  | bool | selected
 | ) |  |

Sets the given object to (non-)selected depending on given flag. To select/unselect all features, pass null as the selected object.

Implements Deltares.Standard.Forms.DExpress.Interfaces.ISelectableLayer.

Property Documentation

IList Deltares.Standard.Forms.DExpress.MyMapPolygonLayer.DataSource
getset

Gets or sets the data source.

The data source.

Generated on Tue Dec 15 2015 18:15:03 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • MyMapPolygonLayer
Deltares.Standard.Forms.DExpress.MyMapPolygonLayer Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.MyMapPolygonLayer, including all inherited members.

DataSource | Deltares.Standard.Forms.DExpress.MyMapPolygonLayer
GetFeature(object selectObject) | Deltares.Standard.Forms.DExpress.MyMapPolygonLayer
MyMapPolygonLayer(IFeatureSet featureSet, MapEditor mapEditor) | Deltares.Standard.Forms.DExpress.MyMapPolygonLayer
SetSelected(object selectObject, bool selected) | Deltares.Standard.Forms.DExpress.MyMapPolygonLayer
Generated on Tue Dec 15 2015 18:15:03 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.NavBarItemBinding Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • NavBarItemBinding
Public Member Functions | List of all members
Deltares.Standard.Forms.DExpress.NavBarItemBinding Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.NavBarItemBinding:
Deltares.Standard.Forms.DExpress.ComponentBinding

Public Member Functions

NavBarItemBinding (Component component)
override void | Initialize (BindPropertyInfo propertyInfo, params string[] properties)
override void | SetEnabled (bool enabled)
override void | SetVisible (bool visible)
override void | SetLabel (string text)
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
ComponentBinding (Component component)
virtual void | Initialize (BindPropertyInfo propertyInfo, Type rootObjectType, params string[] properties)
virtual void | SetTrueMapping (object trueMapping)
virtual void | SetValue (object value)
virtual void | SetValue (object value, object parent)
virtual void | SetDomain (ICollection collection)
virtual object | GetValue ()
virtual void | SetDescription (string description)
virtual void | SetForegroundColor (Color color)
virtual void | SetBackgroundColor (Color color)
virtual void | Refresh ()
virtual void | Invalidate ()
virtual void | RegisterSelectionAssignment (Component targetComponent, IConverter converter=null)
Indicates that the selection of the bound control must be assigned to another control. More...
virtual void | SetControlColors (Color fore, Color back)
Sets the controls foreground and background colors. Can be overridden by a specific binding to set other colors if necessary. More...

Additional Inherited Members

- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
void | RaiseValueChanged ()
void | RaiseLeave ()
void | RaiseActionPerformed ()
Type | GetGenericType (Type type)
string | ValueToString (object value)
bool | IsAssociatedPropertyVisible (object source, BindPropertyInfo associatedPropertyInfo)
Indicates whether the associated property (i.e. the property which is used to display the original property in a textbox) is visible More...
void | EditFileInfo (object source, BindPropertyInfo propertyInfo)
string | EditFileInfo (string value, string format, string label, string description, bool isDirectory)
string | GetDoubleString (string text)
bool | HasValidNumericValue (string text)
double | GetNumericValue (string text)
List< BindPropertyInfo > | GetDictionaryProperties (ICollection domain, BindPropertyInfo dynamicPropertyInfo)
- Protected Attributes inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
BindPropertyInfo | propInfo
- Properties inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
Component | Component [get]
virtual bool | IsTransparant [get]
virtual HandleType | HandleDelayed [get]
virtual bool | HasDomain [get]
- Events inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
EventHandler< EventArgs > | ActionPerformed
EventHandler< EventArgs > | Leave
EventHandler< EventArgs > | ValueChanged
Generated on Tue Dec 15 2015 18:15:03 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • NavBarItemBinding
Deltares.Standard.Forms.DExpress.NavBarItemBinding Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.NavBarItemBinding, including all inherited members.

ActionPerformed (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
Component (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ComponentBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
EditFileInfo(object source, BindPropertyInfo propertyInfo) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
EditFileInfo(string value, string format, string label, string description, bool isDirectory) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetDictionaryProperties(ICollection domain, BindPropertyInfo dynamicPropertyInfo) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetDoubleString(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetGenericType(Type type) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetNumericValue(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetValue() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
HandleDelayed (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
HasDomain (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
HasValidNumericValue(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Initialize(BindPropertyInfo propertyInfo, params string[] properties) (defined in Deltares.Standard.Forms.DExpress.NavBarItemBinding) | Deltares.Standard.Forms.DExpress.NavBarItemBinding | virtual
Initialize(BindPropertyInfo propertyInfo, Type rootObjectType, params string[] properties) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
Invalidate() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
IsAssociatedPropertyVisible(object source, BindPropertyInfo associatedPropertyInfo) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
IsTransparant (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
Leave (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
NavBarItemBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.NavBarItemBinding) | Deltares.Standard.Forms.DExpress.NavBarItemBinding |
propInfo (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseActionPerformed() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseLeave() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseValueChanged() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Refresh() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
RegisterSelectionAssignment(Component targetComponent, IConverter converter=null) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetBackgroundColor(Color color) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetControlColors(Color fore, Color back) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetDescription(string description) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetDomain(ICollection collection) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetEnabled(bool enabled) (defined in Deltares.Standard.Forms.DExpress.NavBarItemBinding) | Deltares.Standard.Forms.DExpress.NavBarItemBinding | virtual
SetForegroundColor(Color color) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetLabel(string text) (defined in Deltares.Standard.Forms.DExpress.NavBarItemBinding) | Deltares.Standard.Forms.DExpress.NavBarItemBinding | virtual
SetTrueMapping(object trueMapping) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetValue(object value) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetValue(object value, object parent) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetVisible(bool visible) (defined in Deltares.Standard.Forms.DExpress.NavBarItemBinding) | Deltares.Standard.Forms.DExpress.NavBarItemBinding | virtual
ValueChanged (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ValueToString(object value) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Generated on Tue Dec 15 2015 18:15:03 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.NewDataSet Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • NewDataSet
Classes | Public Member Functions | Static Public Member Functions | Protected Member Functions | Package Functions | Properties | List of all members
Deltares.Standard.Forms.DExpress.NewDataSet Class Reference

Represents a strongly typed in-memory cache of data. /summary> More...

Inheritance diagram for Deltares.Standard.Forms.DExpress.NewDataSet:

Classes

class | AssembliesDataTable
Represents the strongly named DataTable class. /summary> More...
class | AssembliesRow
Represents strongly named DataRow class. /summary> More...
class | AssembliesRowChangeEvent
Row event argument class /summary> More...
class | AssemblyDataTable
Represents the strongly named DataTable class. /summary> More...
class | AssemblyRow
Represents strongly named DataRow class. /summary> More...
class | AssemblyRowChangeEvent
Row event argument class /summary> More...
class | FileDataTable
Represents the strongly named DataTable class. /summary> More...
class | FileRow
Represents strongly named DataRow class. /summary> More...
class | FileRowChangeEvent
Row event argument class /summary> More...
class | IDDataTable
Represents the strongly named DataTable class. /summary> More...
class | IDRow
Represents strongly named DataRow class. /summary> More...
class | IDRowChangeEvent
Row event argument class /summary> More...
class | StringDataTable
Represents the strongly named DataTable class. /summary> More...
class | StringRow
Represents strongly named DataRow class. /summary> More...
class | StringRowChangeEvent
Row event argument class /summary> More...

Public Member Functions

override global::System.Data.DataSet | Clone ()
delegate void | AssembliesRowChangeEventHandler (object sender, AssembliesRowChangeEvent e)
delegate void | AssemblyRowChangeEventHandler (object sender, AssemblyRowChangeEvent e)
delegate void | FileRowChangeEventHandler (object sender, FileRowChangeEvent e)
delegate void | IDRowChangeEventHandler (object sender, IDRowChangeEvent e)
delegate void | StringRowChangeEventHandler (object sender, StringRowChangeEvent e)

Static Public Member Functions

static global::System.Xml.Schema.XmlSchemaComplexType GetTypedDataSetSchema (global::System.Xml.Schema.XmlSchemaSet xs)

Protected Member Functions

NewDataSet (global::System.Runtime.Serialization.SerializationInfo info, global::System.Runtime.Serialization.StreamingContext context)
override void | InitializeDerivedDataSet ()
override bool | ShouldSerializeTables ()
override bool | ShouldSerializeRelations ()
override void | ReadXmlSerializable (global::System.Xml.XmlReader reader)
override global::System.Xml.Schema.XmlSchema | GetSchemaSerializable ()

Package Functions

void | InitVars ()
void | InitVars (bool initTable)

Properties

AssembliesDataTable | Assemblies [get]
AssemblyDataTable | Assembly [get]
FileDataTable | File [get]
IDDataTable | ID [get]
StringDataTable | String [get]
override global::System.Data.SchemaSerializationMode | SchemaSerializationMode [get, set]
new global::System.Data.DataTableCollection | Tables [get]
new global::System.Data.DataRelationCollection | Relations [get]

Detailed Description

Represents a strongly typed in-memory cache of data. /summary>

Generated on Tue Dec 15 2015 18:15:03 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • NewDataSet
Deltares.Standard.Forms.DExpress.NewDataSet Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.NewDataSet, including all inherited members.

Assemblies (defined in Deltares.Standard.Forms.DExpress.NewDataSet) | Deltares.Standard.Forms.DExpress.NewDataSet |
AssembliesRowChangeEventHandler(object sender, AssembliesRowChangeEvent e) (defined in Deltares.Standard.Forms.DExpress.NewDataSet) | Deltares.Standard.Forms.DExpress.NewDataSet |
Assembly (defined in Deltares.Standard.Forms.DExpress.NewDataSet) | Deltares.Standard.Forms.DExpress.NewDataSet |
AssemblyRowChangeEventHandler(object sender, AssemblyRowChangeEvent e) (defined in Deltares.Standard.Forms.DExpress.NewDataSet) | Deltares.Standard.Forms.DExpress.NewDataSet |
Clone() (defined in Deltares.Standard.Forms.DExpress.NewDataSet) | Deltares.Standard.Forms.DExpress.NewDataSet |
File (defined in Deltares.Standard.Forms.DExpress.NewDataSet) | Deltares.Standard.Forms.DExpress.NewDataSet |
FileRowChangeEventHandler(object sender, FileRowChangeEvent e) (defined in Deltares.Standard.Forms.DExpress.NewDataSet) | Deltares.Standard.Forms.DExpress.NewDataSet |
GetSchemaSerializable() (defined in Deltares.Standard.Forms.DExpress.NewDataSet) | Deltares.Standard.Forms.DExpress.NewDataSet | protected
GetTypedDataSetSchema(global::System.Xml.Schema.XmlSchemaSet xs) (defined in Deltares.Standard.Forms.DExpress.NewDataSet) | Deltares.Standard.Forms.DExpress.NewDataSet | static
ID (defined in Deltares.Standard.Forms.DExpress.NewDataSet) | Deltares.Standard.Forms.DExpress.NewDataSet |
IDRowChangeEventHandler(object sender, IDRowChangeEvent e) (defined in Deltares.Standard.Forms.DExpress.NewDataSet) | Deltares.Standard.Forms.DExpress.NewDataSet |
InitializeDerivedDataSet() (defined in Deltares.Standard.Forms.DExpress.NewDataSet) | Deltares.Standard.Forms.DExpress.NewDataSet | protected
InitVars() (defined in Deltares.Standard.Forms.DExpress.NewDataSet) | Deltares.Standard.Forms.DExpress.NewDataSet | package
InitVars(bool initTable) (defined in Deltares.Standard.Forms.DExpress.NewDataSet) | Deltares.Standard.Forms.DExpress.NewDataSet | package
NewDataSet() (defined in Deltares.Standard.Forms.DExpress.NewDataSet) | Deltares.Standard.Forms.DExpress.NewDataSet |
NewDataSet(global::System.Runtime.Serialization.SerializationInfo info, global::System.Runtime.Serialization.StreamingContext context) (defined in Deltares.Standard.Forms.DExpress.NewDataSet) | Deltares.Standard.Forms.DExpress.NewDataSet | protected
ReadXmlSerializable(global::System.Xml.XmlReader reader) (defined in Deltares.Standard.Forms.DExpress.NewDataSet) | Deltares.Standard.Forms.DExpress.NewDataSet | protected
Relations (defined in Deltares.Standard.Forms.DExpress.NewDataSet) | Deltares.Standard.Forms.DExpress.NewDataSet |
SchemaSerializationMode (defined in Deltares.Standard.Forms.DExpress.NewDataSet) | Deltares.Standard.Forms.DExpress.NewDataSet |
ShouldSerializeRelations() (defined in Deltares.Standard.Forms.DExpress.NewDataSet) | Deltares.Standard.Forms.DExpress.NewDataSet | protected
ShouldSerializeTables() (defined in Deltares.Standard.Forms.DExpress.NewDataSet) | Deltares.Standard.Forms.DExpress.NewDataSet | protected
String (defined in Deltares.Standard.Forms.DExpress.NewDataSet) | Deltares.Standard.Forms.DExpress.NewDataSet |
StringRowChangeEventHandler(object sender, StringRowChangeEvent e) (defined in Deltares.Standard.Forms.DExpress.NewDataSet) | Deltares.Standard.Forms.DExpress.NewDataSet |
Tables (defined in Deltares.Standard.Forms.DExpress.NewDataSet) | Deltares.Standard.Forms.DExpress.NewDataSet |
Generated on Tue Dec 15 2015 18:15:03 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.NewDataSet.AssembliesDataTable Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • NewDataSet
  • AssembliesDataTable
Public Member Functions | Static Public Member Functions | Protected Member Functions | Package Functions | Properties | Events | List of all members
Deltares.Standard.Forms.DExpress.NewDataSet.AssembliesDataTable Class Reference

Represents the strongly named DataTable class. /summary> More...

Inheritance diagram for Deltares.Standard.Forms.DExpress.NewDataSet.AssembliesDataTable:

Public Member Functions

void | AddAssembliesRow (AssembliesRow row)
AssembliesRow | AddAssembliesRow (string Path)
override global::System.Data.DataTable | Clone ()
AssembliesRow | NewAssembliesRow ()
void | RemoveAssembliesRow (AssembliesRow row)

Static Public Member Functions

static global::System.Xml.Schema.XmlSchemaComplexType GetTypedTableSchema (global::System.Xml.Schema.XmlSchemaSet xs)

Protected Member Functions

AssembliesDataTable (global::System.Runtime.Serialization.SerializationInfo info, global::System.Runtime.Serialization.StreamingContext context)
override global::System.Data.DataTable | CreateInstance ()
override global::System.Data.DataRow | NewRowFromBuilder (global::System.Data.DataRowBuilder builder)
override global::System.Type | GetRowType ()
override void | OnRowChanged (global::System.Data.DataRowChangeEventArgs e)
override void | OnRowChanging (global::System.Data.DataRowChangeEventArgs e)
override void | OnRowDeleted (global::System.Data.DataRowChangeEventArgs e)
override void | OnRowDeleting (global::System.Data.DataRowChangeEventArgs e)

Package Functions

AssembliesDataTable (global::System.Data.DataTable table)
void InitVars ()

Properties

global::System.Data.DataColumn | PathColumn [get]
global::System.Data.DataColumn | Assemblies_IdColumn [get]
int | Count [get]
AssembliesRow | this[int index] [get]

Events

AssembliesRowChangeEventHandler | AssembliesRowChanging
AssembliesRowChangeEventHandler | AssembliesRowChanged
AssembliesRowChangeEventHandler | AssembliesRowDeleting
AssembliesRowChangeEventHandler | AssembliesRowDeleted

Detailed Description

Represents the strongly named DataTable class. /summary>

Generated on Tue Dec 15 2015 18:15:04 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • NewDataSet
  • AssembliesDataTable
Deltares.Standard.Forms.DExpress.NewDataSet.AssembliesDataTable Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.NewDataSet.AssembliesDataTable, including all inherited members.

AddAssembliesRow(AssembliesRow row) (defined in Deltares.Standard.Forms.DExpress.NewDataSet.AssembliesDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.AssembliesDataTable |
AddAssembliesRow(string Path) (defined in Deltares.Standard.Forms.DExpress.NewDataSet.AssembliesDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.AssembliesDataTable |
Assemblies_IdColumn (defined in Deltares.Standard.Forms.DExpress.NewDataSet.AssembliesDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.AssembliesDataTable |
AssembliesDataTable() (defined in Deltares.Standard.Forms.DExpress.NewDataSet.AssembliesDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.AssembliesDataTable |
AssembliesDataTable(global::System.Data.DataTable table) (defined in Deltares.Standard.Forms.DExpress.NewDataSet.AssembliesDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.AssembliesDataTable | package
AssembliesDataTable(global::System.Runtime.Serialization.SerializationInfo info, global::System.Runtime.Serialization.StreamingContext context) (defined in Deltares.Standard.Forms.DExpress.NewDataSet.AssembliesDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.AssembliesDataTable | protected
AssembliesRowChanged (defined in Deltares.Standard.Forms.DExpress.NewDataSet.AssembliesDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.AssembliesDataTable |
AssembliesRowChanging (defined in Deltares.Standard.Forms.DExpress.NewDataSet.AssembliesDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.AssembliesDataTable |
AssembliesRowDeleted (defined in Deltares.Standard.Forms.DExpress.NewDataSet.AssembliesDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.AssembliesDataTable |
AssembliesRowDeleting (defined in Deltares.Standard.Forms.DExpress.NewDataSet.AssembliesDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.AssembliesDataTable |
Clone() (defined in Deltares.Standard.Forms.DExpress.NewDataSet.AssembliesDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.AssembliesDataTable |
Count (defined in Deltares.Standard.Forms.DExpress.NewDataSet.AssembliesDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.AssembliesDataTable |
CreateInstance() (defined in Deltares.Standard.Forms.DExpress.NewDataSet.AssembliesDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.AssembliesDataTable | protected
GetRowType() (defined in Deltares.Standard.Forms.DExpress.NewDataSet.AssembliesDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.AssembliesDataTable | protected
GetTypedTableSchema(global::System.Xml.Schema.XmlSchemaSet xs) (defined in Deltares.Standard.Forms.DExpress.NewDataSet.AssembliesDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.AssembliesDataTable | static
InitVars() (defined in Deltares.Standard.Forms.DExpress.NewDataSet.AssembliesDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.AssembliesDataTable | package
NewAssembliesRow() (defined in Deltares.Standard.Forms.DExpress.NewDataSet.AssembliesDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.AssembliesDataTable |
NewRowFromBuilder(global::System.Data.DataRowBuilder builder) (defined in Deltares.Standard.Forms.DExpress.NewDataSet.AssembliesDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.AssembliesDataTable | protected
OnRowChanged(global::System.Data.DataRowChangeEventArgs e) (defined in Deltares.Standard.Forms.DExpress.NewDataSet.AssembliesDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.AssembliesDataTable | protected
OnRowChanging(global::System.Data.DataRowChangeEventArgs e) (defined in Deltares.Standard.Forms.DExpress.NewDataSet.AssembliesDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.AssembliesDataTable | protected
OnRowDeleted(global::System.Data.DataRowChangeEventArgs e) (defined in Deltares.Standard.Forms.DExpress.NewDataSet.AssembliesDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.AssembliesDataTable | protected
OnRowDeleting(global::System.Data.DataRowChangeEventArgs e) (defined in Deltares.Standard.Forms.DExpress.NewDataSet.AssembliesDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.AssembliesDataTable | protected
PathColumn (defined in Deltares.Standard.Forms.DExpress.NewDataSet.AssembliesDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.AssembliesDataTable |
RemoveAssembliesRow(AssembliesRow row) (defined in Deltares.Standard.Forms.DExpress.NewDataSet.AssembliesDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.AssembliesDataTable |
this[int index] (defined in Deltares.Standard.Forms.DExpress.NewDataSet.AssembliesDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.AssembliesDataTable |
Generated on Tue Dec 15 2015 18:15:04 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.NewDataSet.AssembliesRow Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • NewDataSet
  • AssembliesRow
Public Member Functions | Package Functions | Properties | List of all members
Deltares.Standard.Forms.DExpress.NewDataSet.AssembliesRow Class Reference

Represents strongly named DataRow class. /summary> More...

Inheritance diagram for Deltares.Standard.Forms.DExpress.NewDataSet.AssembliesRow:

Public Member Functions

bool | IsPathNull ()
void | SetPathNull ()
AssemblyRow[] | GetAssemblyRows ()

Package Functions

AssembliesRow (global::System.Data.DataRowBuilder rb)

Properties

string | Path [get, set]
int | Assemblies_Id [get, set]

Detailed Description

Represents strongly named DataRow class. /summary>

Generated on Tue Dec 15 2015 18:15:04 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • NewDataSet
  • AssembliesRow
Deltares.Standard.Forms.DExpress.NewDataSet.AssembliesRow Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.NewDataSet.AssembliesRow, including all inherited members.

Assemblies_Id (defined in Deltares.Standard.Forms.DExpress.NewDataSet.AssembliesRow) | Deltares.Standard.Forms.DExpress.NewDataSet.AssembliesRow |
AssembliesRow(global::System.Data.DataRowBuilder rb) (defined in Deltares.Standard.Forms.DExpress.NewDataSet.AssembliesRow) | Deltares.Standard.Forms.DExpress.NewDataSet.AssembliesRow | package
GetAssemblyRows() (defined in Deltares.Standard.Forms.DExpress.NewDataSet.AssembliesRow) | Deltares.Standard.Forms.DExpress.NewDataSet.AssembliesRow |
IsPathNull() (defined in Deltares.Standard.Forms.DExpress.NewDataSet.AssembliesRow) | Deltares.Standard.Forms.DExpress.NewDataSet.AssembliesRow |
Path (defined in Deltares.Standard.Forms.DExpress.NewDataSet.AssembliesRow) | Deltares.Standard.Forms.DExpress.NewDataSet.AssembliesRow |
SetPathNull() (defined in Deltares.Standard.Forms.DExpress.NewDataSet.AssembliesRow) | Deltares.Standard.Forms.DExpress.NewDataSet.AssembliesRow |
Generated on Tue Dec 15 2015 18:15:04 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.NewDataSet.AssembliesRowChangeEvent Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • NewDataSet
  • AssembliesRowChangeEvent
Public Member Functions | Properties | List of all members
Deltares.Standard.Forms.DExpress.NewDataSet.AssembliesRowChangeEvent Class Reference

Row event argument class /summary> More...

Inheritance diagram for Deltares.Standard.Forms.DExpress.NewDataSet.AssembliesRowChangeEvent:

Public Member Functions

AssembliesRowChangeEvent (AssembliesRow row, global::System.Data.DataRowAction action)

Properties

AssembliesRow | Row [get]
global::System.Data.DataRowAction | Action [get]

Detailed Description

Row event argument class /summary>

Generated on Tue Dec 15 2015 18:15:04 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • NewDataSet
  • AssembliesRowChangeEvent
Deltares.Standard.Forms.DExpress.NewDataSet.AssembliesRowChangeEvent Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.NewDataSet.AssembliesRowChangeEvent, including all inherited members.

Action (defined in Deltares.Standard.Forms.DExpress.NewDataSet.AssembliesRowChangeEvent) | Deltares.Standard.Forms.DExpress.NewDataSet.AssembliesRowChangeEvent
AssembliesRowChangeEvent(AssembliesRow row, global::System.Data.DataRowAction action) (defined in Deltares.Standard.Forms.DExpress.NewDataSet.AssembliesRowChangeEvent) | Deltares.Standard.Forms.DExpress.NewDataSet.AssembliesRowChangeEvent
Row (defined in Deltares.Standard.Forms.DExpress.NewDataSet.AssembliesRowChangeEvent) | Deltares.Standard.Forms.DExpress.NewDataSet.AssembliesRowChangeEvent
Generated on Tue Dec 15 2015 18:15:04 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.NewDataSet.AssemblyDataTable Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • NewDataSet
  • AssemblyDataTable
Public Member Functions | Static Public Member Functions | Protected Member Functions | Package Functions | Properties | Events | List of all members
Deltares.Standard.Forms.DExpress.NewDataSet.AssemblyDataTable Class Reference

Represents the strongly named DataTable class. /summary> More...

Inheritance diagram for Deltares.Standard.Forms.DExpress.NewDataSet.AssemblyDataTable:

Public Member Functions

void | AddAssemblyRow (AssemblyRow row)
AssemblyRow | AddAssemblyRow (string Path, AssembliesRow parentAssembliesRowByAssemblies_Assembly)
override global::System.Data.DataTable | Clone ()
AssemblyRow | NewAssemblyRow ()
void | RemoveAssemblyRow (AssemblyRow row)

Static Public Member Functions

static global::System.Xml.Schema.XmlSchemaComplexType GetTypedTableSchema (global::System.Xml.Schema.XmlSchemaSet xs)

Protected Member Functions

AssemblyDataTable (global::System.Runtime.Serialization.SerializationInfo info, global::System.Runtime.Serialization.StreamingContext context)
override global::System.Data.DataTable | CreateInstance ()
override global::System.Data.DataRow | NewRowFromBuilder (global::System.Data.DataRowBuilder builder)
override global::System.Type | GetRowType ()
override void | OnRowChanged (global::System.Data.DataRowChangeEventArgs e)
override void | OnRowChanging (global::System.Data.DataRowChangeEventArgs e)
override void | OnRowDeleted (global::System.Data.DataRowChangeEventArgs e)
override void | OnRowDeleting (global::System.Data.DataRowChangeEventArgs e)

Package Functions

AssemblyDataTable (global::System.Data.DataTable table)
void InitVars ()

Properties

global::System.Data.DataColumn | PathColumn [get]
global::System.Data.DataColumn | Assembly_IdColumn [get]
global::System.Data.DataColumn | Assemblies_IdColumn [get]
int | Count [get]
AssemblyRow | this[int index] [get]

Events

AssemblyRowChangeEventHandler | AssemblyRowChanging
AssemblyRowChangeEventHandler | AssemblyRowChanged
AssemblyRowChangeEventHandler | AssemblyRowDeleting
AssemblyRowChangeEventHandler | AssemblyRowDeleted

Detailed Description

Represents the strongly named DataTable class. /summary>

Generated on Tue Dec 15 2015 18:15:04 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • NewDataSet
  • AssemblyDataTable
Deltares.Standard.Forms.DExpress.NewDataSet.AssemblyDataTable Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.NewDataSet.AssemblyDataTable, including all inherited members.

AddAssemblyRow(AssemblyRow row) (defined in Deltares.Standard.Forms.DExpress.NewDataSet.AssemblyDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.AssemblyDataTable |
AddAssemblyRow(string Path, AssembliesRow parentAssembliesRowByAssemblies_Assembly) (defined in Deltares.Standard.Forms.DExpress.NewDataSet.AssemblyDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.AssemblyDataTable |
Assemblies_IdColumn (defined in Deltares.Standard.Forms.DExpress.NewDataSet.AssemblyDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.AssemblyDataTable |
Assembly_IdColumn (defined in Deltares.Standard.Forms.DExpress.NewDataSet.AssemblyDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.AssemblyDataTable |
AssemblyDataTable() (defined in Deltares.Standard.Forms.DExpress.NewDataSet.AssemblyDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.AssemblyDataTable |
AssemblyDataTable(global::System.Data.DataTable table) (defined in Deltares.Standard.Forms.DExpress.NewDataSet.AssemblyDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.AssemblyDataTable | package
AssemblyDataTable(global::System.Runtime.Serialization.SerializationInfo info, global::System.Runtime.Serialization.StreamingContext context) (defined in Deltares.Standard.Forms.DExpress.NewDataSet.AssemblyDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.AssemblyDataTable | protected
AssemblyRowChanged (defined in Deltares.Standard.Forms.DExpress.NewDataSet.AssemblyDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.AssemblyDataTable |
AssemblyRowChanging (defined in Deltares.Standard.Forms.DExpress.NewDataSet.AssemblyDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.AssemblyDataTable |
AssemblyRowDeleted (defined in Deltares.Standard.Forms.DExpress.NewDataSet.AssemblyDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.AssemblyDataTable |
AssemblyRowDeleting (defined in Deltares.Standard.Forms.DExpress.NewDataSet.AssemblyDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.AssemblyDataTable |
Clone() (defined in Deltares.Standard.Forms.DExpress.NewDataSet.AssemblyDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.AssemblyDataTable |
Count (defined in Deltares.Standard.Forms.DExpress.NewDataSet.AssemblyDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.AssemblyDataTable |
CreateInstance() (defined in Deltares.Standard.Forms.DExpress.NewDataSet.AssemblyDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.AssemblyDataTable | protected
GetRowType() (defined in Deltares.Standard.Forms.DExpress.NewDataSet.AssemblyDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.AssemblyDataTable | protected
GetTypedTableSchema(global::System.Xml.Schema.XmlSchemaSet xs) (defined in Deltares.Standard.Forms.DExpress.NewDataSet.AssemblyDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.AssemblyDataTable | static
InitVars() (defined in Deltares.Standard.Forms.DExpress.NewDataSet.AssemblyDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.AssemblyDataTable | package
NewAssemblyRow() (defined in Deltares.Standard.Forms.DExpress.NewDataSet.AssemblyDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.AssemblyDataTable |
NewRowFromBuilder(global::System.Data.DataRowBuilder builder) (defined in Deltares.Standard.Forms.DExpress.NewDataSet.AssemblyDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.AssemblyDataTable | protected
OnRowChanged(global::System.Data.DataRowChangeEventArgs e) (defined in Deltares.Standard.Forms.DExpress.NewDataSet.AssemblyDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.AssemblyDataTable | protected
OnRowChanging(global::System.Data.DataRowChangeEventArgs e) (defined in Deltares.Standard.Forms.DExpress.NewDataSet.AssemblyDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.AssemblyDataTable | protected
OnRowDeleted(global::System.Data.DataRowChangeEventArgs e) (defined in Deltares.Standard.Forms.DExpress.NewDataSet.AssemblyDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.AssemblyDataTable | protected
OnRowDeleting(global::System.Data.DataRowChangeEventArgs e) (defined in Deltares.Standard.Forms.DExpress.NewDataSet.AssemblyDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.AssemblyDataTable | protected
PathColumn (defined in Deltares.Standard.Forms.DExpress.NewDataSet.AssemblyDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.AssemblyDataTable |
RemoveAssemblyRow(AssemblyRow row) (defined in Deltares.Standard.Forms.DExpress.NewDataSet.AssemblyDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.AssemblyDataTable |
this[int index] (defined in Deltares.Standard.Forms.DExpress.NewDataSet.AssemblyDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.AssemblyDataTable |
Generated on Tue Dec 15 2015 18:15:04 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.NewDataSet.AssemblyRow Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • NewDataSet
  • AssemblyRow
Public Member Functions | Package Functions | Properties | List of all members
Deltares.Standard.Forms.DExpress.NewDataSet.AssemblyRow Class Reference

Represents strongly named DataRow class. /summary> More...

Inheritance diagram for Deltares.Standard.Forms.DExpress.NewDataSet.AssemblyRow:

Public Member Functions

bool | IsPathNull ()
void | SetPathNull ()
bool | IsAssemblies_IdNull ()
void | SetAssemblies_IdNull ()
FileRow[] | GetFileRows ()

Package Functions

AssemblyRow (global::System.Data.DataRowBuilder rb)

Properties

string | Path [get, set]
int | Assembly_Id [get, set]
int | Assemblies_Id [get, set]
AssembliesRow | AssembliesRow [get, set]

Detailed Description

Represents strongly named DataRow class. /summary>

Generated on Tue Dec 15 2015 18:15:05 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • NewDataSet
  • AssemblyRow
Deltares.Standard.Forms.DExpress.NewDataSet.AssemblyRow Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.NewDataSet.AssemblyRow, including all inherited members.

Assemblies_Id (defined in Deltares.Standard.Forms.DExpress.NewDataSet.AssemblyRow) | Deltares.Standard.Forms.DExpress.NewDataSet.AssemblyRow |
AssembliesRow (defined in Deltares.Standard.Forms.DExpress.NewDataSet.AssemblyRow) | Deltares.Standard.Forms.DExpress.NewDataSet.AssemblyRow |
Assembly_Id (defined in Deltares.Standard.Forms.DExpress.NewDataSet.AssemblyRow) | Deltares.Standard.Forms.DExpress.NewDataSet.AssemblyRow |
AssemblyRow(global::System.Data.DataRowBuilder rb) (defined in Deltares.Standard.Forms.DExpress.NewDataSet.AssemblyRow) | Deltares.Standard.Forms.DExpress.NewDataSet.AssemblyRow | package
GetFileRows() (defined in Deltares.Standard.Forms.DExpress.NewDataSet.AssemblyRow) | Deltares.Standard.Forms.DExpress.NewDataSet.AssemblyRow |
IsAssemblies_IdNull() (defined in Deltares.Standard.Forms.DExpress.NewDataSet.AssemblyRow) | Deltares.Standard.Forms.DExpress.NewDataSet.AssemblyRow |
IsPathNull() (defined in Deltares.Standard.Forms.DExpress.NewDataSet.AssemblyRow) | Deltares.Standard.Forms.DExpress.NewDataSet.AssemblyRow |
Path (defined in Deltares.Standard.Forms.DExpress.NewDataSet.AssemblyRow) | Deltares.Standard.Forms.DExpress.NewDataSet.AssemblyRow |
SetAssemblies_IdNull() (defined in Deltares.Standard.Forms.DExpress.NewDataSet.AssemblyRow) | Deltares.Standard.Forms.DExpress.NewDataSet.AssemblyRow |
SetPathNull() (defined in Deltares.Standard.Forms.DExpress.NewDataSet.AssemblyRow) | Deltares.Standard.Forms.DExpress.NewDataSet.AssemblyRow |
Generated on Tue Dec 15 2015 18:15:05 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.NewDataSet.AssemblyRowChangeEvent Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • NewDataSet
  • AssemblyRowChangeEvent
Public Member Functions | Properties | List of all members
Deltares.Standard.Forms.DExpress.NewDataSet.AssemblyRowChangeEvent Class Reference

Row event argument class /summary> More...

Inheritance diagram for Deltares.Standard.Forms.DExpress.NewDataSet.AssemblyRowChangeEvent:

Public Member Functions

AssemblyRowChangeEvent (AssemblyRow row, global::System.Data.DataRowAction action)

Properties

AssemblyRow | Row [get]
global::System.Data.DataRowAction | Action [get]

Detailed Description

Row event argument class /summary>

Generated on Tue Dec 15 2015 18:15:05 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • NewDataSet
  • AssemblyRowChangeEvent
Deltares.Standard.Forms.DExpress.NewDataSet.AssemblyRowChangeEvent Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.NewDataSet.AssemblyRowChangeEvent, including all inherited members.

Action (defined in Deltares.Standard.Forms.DExpress.NewDataSet.AssemblyRowChangeEvent) | Deltares.Standard.Forms.DExpress.NewDataSet.AssemblyRowChangeEvent
AssemblyRowChangeEvent(AssemblyRow row, global::System.Data.DataRowAction action) (defined in Deltares.Standard.Forms.DExpress.NewDataSet.AssemblyRowChangeEvent) | Deltares.Standard.Forms.DExpress.NewDataSet.AssemblyRowChangeEvent
Row (defined in Deltares.Standard.Forms.DExpress.NewDataSet.AssemblyRowChangeEvent) | Deltares.Standard.Forms.DExpress.NewDataSet.AssemblyRowChangeEvent
Generated on Tue Dec 15 2015 18:15:05 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.NewDataSet.FileDataTable Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • NewDataSet
  • FileDataTable
Public Member Functions | Static Public Member Functions | Protected Member Functions | Package Functions | Properties | Events | List of all members
Deltares.Standard.Forms.DExpress.NewDataSet.FileDataTable Class Reference

Represents the strongly named DataTable class. /summary> More...

Inheritance diagram for Deltares.Standard.Forms.DExpress.NewDataSet.FileDataTable:

Public Member Functions

void | AddFileRow (FileRow row)
FileRow | AddFileRow (string Path, AssemblyRow parentAssemblyRowByAssembly_File)
override global::System.Data.DataTable | Clone ()
FileRow | NewFileRow ()
void | RemoveFileRow (FileRow row)

Static Public Member Functions

static global::System.Xml.Schema.XmlSchemaComplexType GetTypedTableSchema (global::System.Xml.Schema.XmlSchemaSet xs)

Protected Member Functions

FileDataTable (global::System.Runtime.Serialization.SerializationInfo info, global::System.Runtime.Serialization.StreamingContext context)
override global::System.Data.DataTable | CreateInstance ()
override global::System.Data.DataRow | NewRowFromBuilder (global::System.Data.DataRowBuilder builder)
override global::System.Type | GetRowType ()
override void | OnRowChanged (global::System.Data.DataRowChangeEventArgs e)
override void | OnRowChanging (global::System.Data.DataRowChangeEventArgs e)
override void | OnRowDeleted (global::System.Data.DataRowChangeEventArgs e)
override void | OnRowDeleting (global::System.Data.DataRowChangeEventArgs e)

Package Functions

FileDataTable (global::System.Data.DataTable table)
void InitVars ()

Properties

global::System.Data.DataColumn | PathColumn [get]
global::System.Data.DataColumn | File_IdColumn [get]
global::System.Data.DataColumn | Assembly_IdColumn [get]
int | Count [get]
FileRow | this[int index] [get]

Events

FileRowChangeEventHandler | FileRowChanging
FileRowChangeEventHandler | FileRowChanged
FileRowChangeEventHandler | FileRowDeleting
FileRowChangeEventHandler | FileRowDeleted

Detailed Description

Represents the strongly named DataTable class. /summary>

Generated on Tue Dec 15 2015 18:15:05 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • NewDataSet
  • FileDataTable
Deltares.Standard.Forms.DExpress.NewDataSet.FileDataTable Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.NewDataSet.FileDataTable, including all inherited members.

AddFileRow(FileRow row) (defined in Deltares.Standard.Forms.DExpress.NewDataSet.FileDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.FileDataTable |
AddFileRow(string Path, AssemblyRow parentAssemblyRowByAssembly_File) (defined in Deltares.Standard.Forms.DExpress.NewDataSet.FileDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.FileDataTable |
Assembly_IdColumn (defined in Deltares.Standard.Forms.DExpress.NewDataSet.FileDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.FileDataTable |
Clone() (defined in Deltares.Standard.Forms.DExpress.NewDataSet.FileDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.FileDataTable |
Count (defined in Deltares.Standard.Forms.DExpress.NewDataSet.FileDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.FileDataTable |
CreateInstance() (defined in Deltares.Standard.Forms.DExpress.NewDataSet.FileDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.FileDataTable | protected
File_IdColumn (defined in Deltares.Standard.Forms.DExpress.NewDataSet.FileDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.FileDataTable |
FileDataTable() (defined in Deltares.Standard.Forms.DExpress.NewDataSet.FileDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.FileDataTable |
FileDataTable(global::System.Data.DataTable table) (defined in Deltares.Standard.Forms.DExpress.NewDataSet.FileDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.FileDataTable | package
FileDataTable(global::System.Runtime.Serialization.SerializationInfo info, global::System.Runtime.Serialization.StreamingContext context) (defined in Deltares.Standard.Forms.DExpress.NewDataSet.FileDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.FileDataTable | protected
FileRowChanged (defined in Deltares.Standard.Forms.DExpress.NewDataSet.FileDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.FileDataTable |
FileRowChanging (defined in Deltares.Standard.Forms.DExpress.NewDataSet.FileDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.FileDataTable |
FileRowDeleted (defined in Deltares.Standard.Forms.DExpress.NewDataSet.FileDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.FileDataTable |
FileRowDeleting (defined in Deltares.Standard.Forms.DExpress.NewDataSet.FileDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.FileDataTable |
GetRowType() (defined in Deltares.Standard.Forms.DExpress.NewDataSet.FileDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.FileDataTable | protected
GetTypedTableSchema(global::System.Xml.Schema.XmlSchemaSet xs) (defined in Deltares.Standard.Forms.DExpress.NewDataSet.FileDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.FileDataTable | static
InitVars() (defined in Deltares.Standard.Forms.DExpress.NewDataSet.FileDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.FileDataTable | package
NewFileRow() (defined in Deltares.Standard.Forms.DExpress.NewDataSet.FileDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.FileDataTable |
NewRowFromBuilder(global::System.Data.DataRowBuilder builder) (defined in Deltares.Standard.Forms.DExpress.NewDataSet.FileDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.FileDataTable | protected
OnRowChanged(global::System.Data.DataRowChangeEventArgs e) (defined in Deltares.Standard.Forms.DExpress.NewDataSet.FileDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.FileDataTable | protected
OnRowChanging(global::System.Data.DataRowChangeEventArgs e) (defined in Deltares.Standard.Forms.DExpress.NewDataSet.FileDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.FileDataTable | protected
OnRowDeleted(global::System.Data.DataRowChangeEventArgs e) (defined in Deltares.Standard.Forms.DExpress.NewDataSet.FileDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.FileDataTable | protected
OnRowDeleting(global::System.Data.DataRowChangeEventArgs e) (defined in Deltares.Standard.Forms.DExpress.NewDataSet.FileDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.FileDataTable | protected
PathColumn (defined in Deltares.Standard.Forms.DExpress.NewDataSet.FileDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.FileDataTable |
RemoveFileRow(FileRow row) (defined in Deltares.Standard.Forms.DExpress.NewDataSet.FileDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.FileDataTable |
this[int index] (defined in Deltares.Standard.Forms.DExpress.NewDataSet.FileDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.FileDataTable |
Generated on Tue Dec 15 2015 18:15:05 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.NewDataSet.FileRow Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • NewDataSet
  • FileRow
Public Member Functions | Package Functions | Properties | List of all members
Deltares.Standard.Forms.DExpress.NewDataSet.FileRow Class Reference

Represents strongly named DataRow class. /summary> More...

Inheritance diagram for Deltares.Standard.Forms.DExpress.NewDataSet.FileRow:

Public Member Functions

bool | IsPathNull ()
void | SetPathNull ()
bool | IsAssembly_IdNull ()
void | SetAssembly_IdNull ()
IDRow[] | GetIDRows ()

Package Functions

FileRow (global::System.Data.DataRowBuilder rb)

Properties

string | Path [get, set]
int | File_Id [get, set]
int | Assembly_Id [get, set]
AssemblyRow | AssemblyRow [get, set]

Detailed Description

Represents strongly named DataRow class. /summary>

Generated on Tue Dec 15 2015 18:15:06 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • NewDataSet
  • FileRow
Deltares.Standard.Forms.DExpress.NewDataSet.FileRow Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.NewDataSet.FileRow, including all inherited members.

Assembly_Id (defined in Deltares.Standard.Forms.DExpress.NewDataSet.FileRow) | Deltares.Standard.Forms.DExpress.NewDataSet.FileRow |
AssemblyRow (defined in Deltares.Standard.Forms.DExpress.NewDataSet.FileRow) | Deltares.Standard.Forms.DExpress.NewDataSet.FileRow |
File_Id (defined in Deltares.Standard.Forms.DExpress.NewDataSet.FileRow) | Deltares.Standard.Forms.DExpress.NewDataSet.FileRow |
FileRow(global::System.Data.DataRowBuilder rb) (defined in Deltares.Standard.Forms.DExpress.NewDataSet.FileRow) | Deltares.Standard.Forms.DExpress.NewDataSet.FileRow | package
GetIDRows() (defined in Deltares.Standard.Forms.DExpress.NewDataSet.FileRow) | Deltares.Standard.Forms.DExpress.NewDataSet.FileRow |
IsAssembly_IdNull() (defined in Deltares.Standard.Forms.DExpress.NewDataSet.FileRow) | Deltares.Standard.Forms.DExpress.NewDataSet.FileRow |
IsPathNull() (defined in Deltares.Standard.Forms.DExpress.NewDataSet.FileRow) | Deltares.Standard.Forms.DExpress.NewDataSet.FileRow |
Path (defined in Deltares.Standard.Forms.DExpress.NewDataSet.FileRow) | Deltares.Standard.Forms.DExpress.NewDataSet.FileRow |
SetAssembly_IdNull() (defined in Deltares.Standard.Forms.DExpress.NewDataSet.FileRow) | Deltares.Standard.Forms.DExpress.NewDataSet.FileRow |
SetPathNull() (defined in Deltares.Standard.Forms.DExpress.NewDataSet.FileRow) | Deltares.Standard.Forms.DExpress.NewDataSet.FileRow |
Generated on Tue Dec 15 2015 18:15:06 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.NewDataSet.FileRowChangeEvent Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • NewDataSet
  • FileRowChangeEvent
Public Member Functions | Properties | List of all members
Deltares.Standard.Forms.DExpress.NewDataSet.FileRowChangeEvent Class Reference

Row event argument class /summary> More...

Inheritance diagram for Deltares.Standard.Forms.DExpress.NewDataSet.FileRowChangeEvent:

Public Member Functions

FileRowChangeEvent (FileRow row, global::System.Data.DataRowAction action)

Properties

FileRow | Row [get]
global::System.Data.DataRowAction | Action [get]

Detailed Description

Row event argument class /summary>

Generated on Tue Dec 15 2015 18:15:06 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • NewDataSet
  • FileRowChangeEvent
Deltares.Standard.Forms.DExpress.NewDataSet.FileRowChangeEvent Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.NewDataSet.FileRowChangeEvent, including all inherited members.

Action (defined in Deltares.Standard.Forms.DExpress.NewDataSet.FileRowChangeEvent) | Deltares.Standard.Forms.DExpress.NewDataSet.FileRowChangeEvent
FileRowChangeEvent(FileRow row, global::System.Data.DataRowAction action) (defined in Deltares.Standard.Forms.DExpress.NewDataSet.FileRowChangeEvent) | Deltares.Standard.Forms.DExpress.NewDataSet.FileRowChangeEvent
Row (defined in Deltares.Standard.Forms.DExpress.NewDataSet.FileRowChangeEvent) | Deltares.Standard.Forms.DExpress.NewDataSet.FileRowChangeEvent
Generated on Tue Dec 15 2015 18:15:06 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.NewDataSet.IDDataTable Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • NewDataSet
  • IDDataTable
Public Member Functions | Static Public Member Functions | Protected Member Functions | Package Functions | Properties | Events | List of all members
Deltares.Standard.Forms.DExpress.NewDataSet.IDDataTable Class Reference

Represents the strongly named DataTable class. /summary> More...

Inheritance diagram for Deltares.Standard.Forms.DExpress.NewDataSet.IDDataTable:

Public Member Functions

void | AddIDRow (IDRow row)
IDRow | AddIDRow (string Name, FileRow parentFileRowByFile_ID)
override global::System.Data.DataTable | Clone ()
IDRow | NewIDRow ()
void | RemoveIDRow (IDRow row)

Static Public Member Functions

static global::System.Xml.Schema.XmlSchemaComplexType GetTypedTableSchema (global::System.Xml.Schema.XmlSchemaSet xs)

Protected Member Functions

IDDataTable (global::System.Runtime.Serialization.SerializationInfo info, global::System.Runtime.Serialization.StreamingContext context)
override global::System.Data.DataTable | CreateInstance ()
override global::System.Data.DataRow | NewRowFromBuilder (global::System.Data.DataRowBuilder builder)
override global::System.Type | GetRowType ()
override void | OnRowChanged (global::System.Data.DataRowChangeEventArgs e)
override void | OnRowChanging (global::System.Data.DataRowChangeEventArgs e)
override void | OnRowDeleted (global::System.Data.DataRowChangeEventArgs e)
override void | OnRowDeleting (global::System.Data.DataRowChangeEventArgs e)

Package Functions

IDDataTable (global::System.Data.DataTable table)
void InitVars ()

Properties

global::System.Data.DataColumn | NameColumn [get]
global::System.Data.DataColumn | ID_IdColumn [get]
global::System.Data.DataColumn | File_IdColumn [get]
int | Count [get]
IDRow | this[int index] [get]

Events

IDRowChangeEventHandler | IDRowChanging
IDRowChangeEventHandler | IDRowChanged
IDRowChangeEventHandler | IDRowDeleting
IDRowChangeEventHandler | IDRowDeleted

Detailed Description

Represents the strongly named DataTable class. /summary>

Generated on Tue Dec 15 2015 18:15:06 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • NewDataSet
  • IDDataTable
Deltares.Standard.Forms.DExpress.NewDataSet.IDDataTable Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.NewDataSet.IDDataTable, including all inherited members.

AddIDRow(IDRow row) (defined in Deltares.Standard.Forms.DExpress.NewDataSet.IDDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.IDDataTable |
AddIDRow(string Name, FileRow parentFileRowByFile_ID) (defined in Deltares.Standard.Forms.DExpress.NewDataSet.IDDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.IDDataTable |
Clone() (defined in Deltares.Standard.Forms.DExpress.NewDataSet.IDDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.IDDataTable |
Count (defined in Deltares.Standard.Forms.DExpress.NewDataSet.IDDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.IDDataTable |
CreateInstance() (defined in Deltares.Standard.Forms.DExpress.NewDataSet.IDDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.IDDataTable | protected
File_IdColumn (defined in Deltares.Standard.Forms.DExpress.NewDataSet.IDDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.IDDataTable |
GetRowType() (defined in Deltares.Standard.Forms.DExpress.NewDataSet.IDDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.IDDataTable | protected
GetTypedTableSchema(global::System.Xml.Schema.XmlSchemaSet xs) (defined in Deltares.Standard.Forms.DExpress.NewDataSet.IDDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.IDDataTable | static
ID_IdColumn (defined in Deltares.Standard.Forms.DExpress.NewDataSet.IDDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.IDDataTable |
IDDataTable() (defined in Deltares.Standard.Forms.DExpress.NewDataSet.IDDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.IDDataTable |
IDDataTable(global::System.Data.DataTable table) (defined in Deltares.Standard.Forms.DExpress.NewDataSet.IDDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.IDDataTable | package
IDDataTable(global::System.Runtime.Serialization.SerializationInfo info, global::System.Runtime.Serialization.StreamingContext context) (defined in Deltares.Standard.Forms.DExpress.NewDataSet.IDDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.IDDataTable | protected
IDRowChanged (defined in Deltares.Standard.Forms.DExpress.NewDataSet.IDDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.IDDataTable |
IDRowChanging (defined in Deltares.Standard.Forms.DExpress.NewDataSet.IDDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.IDDataTable |
IDRowDeleted (defined in Deltares.Standard.Forms.DExpress.NewDataSet.IDDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.IDDataTable |
IDRowDeleting (defined in Deltares.Standard.Forms.DExpress.NewDataSet.IDDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.IDDataTable |
InitVars() (defined in Deltares.Standard.Forms.DExpress.NewDataSet.IDDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.IDDataTable | package
NameColumn (defined in Deltares.Standard.Forms.DExpress.NewDataSet.IDDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.IDDataTable |
NewIDRow() (defined in Deltares.Standard.Forms.DExpress.NewDataSet.IDDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.IDDataTable |
NewRowFromBuilder(global::System.Data.DataRowBuilder builder) (defined in Deltares.Standard.Forms.DExpress.NewDataSet.IDDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.IDDataTable | protected
OnRowChanged(global::System.Data.DataRowChangeEventArgs e) (defined in Deltares.Standard.Forms.DExpress.NewDataSet.IDDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.IDDataTable | protected
OnRowChanging(global::System.Data.DataRowChangeEventArgs e) (defined in Deltares.Standard.Forms.DExpress.NewDataSet.IDDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.IDDataTable | protected
OnRowDeleted(global::System.Data.DataRowChangeEventArgs e) (defined in Deltares.Standard.Forms.DExpress.NewDataSet.IDDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.IDDataTable | protected
OnRowDeleting(global::System.Data.DataRowChangeEventArgs e) (defined in Deltares.Standard.Forms.DExpress.NewDataSet.IDDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.IDDataTable | protected
RemoveIDRow(IDRow row) (defined in Deltares.Standard.Forms.DExpress.NewDataSet.IDDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.IDDataTable |
this[int index] (defined in Deltares.Standard.Forms.DExpress.NewDataSet.IDDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.IDDataTable |
Generated on Tue Dec 15 2015 18:15:06 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.NewDataSet.IDRow Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • NewDataSet
  • IDRow
Public Member Functions | Package Functions | Properties | List of all members
Deltares.Standard.Forms.DExpress.NewDataSet.IDRow Class Reference

Represents strongly named DataRow class. /summary> More...

Inheritance diagram for Deltares.Standard.Forms.DExpress.NewDataSet.IDRow:

Public Member Functions

bool | IsNameNull ()
void | SetNameNull ()
bool | IsFile_IdNull ()
void | SetFile_IdNull ()
StringRow[] | GetStringRows ()

Package Functions

IDRow (global::System.Data.DataRowBuilder rb)

Properties

string | Name [get, set]
int | ID_Id [get, set]
int | File_Id [get, set]
FileRow | FileRow [get, set]

Detailed Description

Represents strongly named DataRow class. /summary>

Generated on Tue Dec 15 2015 18:15:06 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • NewDataSet
  • IDRow
Deltares.Standard.Forms.DExpress.NewDataSet.IDRow Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.NewDataSet.IDRow, including all inherited members.

File_Id (defined in Deltares.Standard.Forms.DExpress.NewDataSet.IDRow) | Deltares.Standard.Forms.DExpress.NewDataSet.IDRow |
FileRow (defined in Deltares.Standard.Forms.DExpress.NewDataSet.IDRow) | Deltares.Standard.Forms.DExpress.NewDataSet.IDRow |
GetStringRows() (defined in Deltares.Standard.Forms.DExpress.NewDataSet.IDRow) | Deltares.Standard.Forms.DExpress.NewDataSet.IDRow |
ID_Id (defined in Deltares.Standard.Forms.DExpress.NewDataSet.IDRow) | Deltares.Standard.Forms.DExpress.NewDataSet.IDRow |
IDRow(global::System.Data.DataRowBuilder rb) (defined in Deltares.Standard.Forms.DExpress.NewDataSet.IDRow) | Deltares.Standard.Forms.DExpress.NewDataSet.IDRow | package
IsFile_IdNull() (defined in Deltares.Standard.Forms.DExpress.NewDataSet.IDRow) | Deltares.Standard.Forms.DExpress.NewDataSet.IDRow |
IsNameNull() (defined in Deltares.Standard.Forms.DExpress.NewDataSet.IDRow) | Deltares.Standard.Forms.DExpress.NewDataSet.IDRow |
Name (defined in Deltares.Standard.Forms.DExpress.NewDataSet.IDRow) | Deltares.Standard.Forms.DExpress.NewDataSet.IDRow |
SetFile_IdNull() (defined in Deltares.Standard.Forms.DExpress.NewDataSet.IDRow) | Deltares.Standard.Forms.DExpress.NewDataSet.IDRow |
SetNameNull() (defined in Deltares.Standard.Forms.DExpress.NewDataSet.IDRow) | Deltares.Standard.Forms.DExpress.NewDataSet.IDRow |
Generated on Tue Dec 15 2015 18:15:06 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.NewDataSet.IDRowChangeEvent Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • NewDataSet
  • IDRowChangeEvent
Public Member Functions | Properties | List of all members
Deltares.Standard.Forms.DExpress.NewDataSet.IDRowChangeEvent Class Reference

Row event argument class /summary> More...

Inheritance diagram for Deltares.Standard.Forms.DExpress.NewDataSet.IDRowChangeEvent:

Public Member Functions

IDRowChangeEvent (IDRow row, global::System.Data.DataRowAction action)

Properties

IDRow | Row [get]
global::System.Data.DataRowAction | Action [get]

Detailed Description

Row event argument class /summary>

Generated on Tue Dec 15 2015 18:15:07 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • NewDataSet
  • IDRowChangeEvent
Deltares.Standard.Forms.DExpress.NewDataSet.IDRowChangeEvent Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.NewDataSet.IDRowChangeEvent, including all inherited members.

Action (defined in Deltares.Standard.Forms.DExpress.NewDataSet.IDRowChangeEvent) | Deltares.Standard.Forms.DExpress.NewDataSet.IDRowChangeEvent
IDRowChangeEvent(IDRow row, global::System.Data.DataRowAction action) (defined in Deltares.Standard.Forms.DExpress.NewDataSet.IDRowChangeEvent) | Deltares.Standard.Forms.DExpress.NewDataSet.IDRowChangeEvent
Row (defined in Deltares.Standard.Forms.DExpress.NewDataSet.IDRowChangeEvent) | Deltares.Standard.Forms.DExpress.NewDataSet.IDRowChangeEvent
Generated on Tue Dec 15 2015 18:15:07 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.NewDataSet.StringDataTable Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • NewDataSet
  • StringDataTable
Public Member Functions | Static Public Member Functions | Protected Member Functions | Package Functions | Properties | Events | List of all members
Deltares.Standard.Forms.DExpress.NewDataSet.StringDataTable Class Reference

Represents the strongly named DataTable class. /summary> More...

Inheritance diagram for Deltares.Standard.Forms.DExpress.NewDataSet.StringDataTable:

Public Member Functions

void | AddStringRow (StringRow row)
StringRow | AddStringRow (IDRow parentIDRowByID_String)
override global::System.Data.DataTable | Clone ()
StringRow | NewStringRow ()
void | RemoveStringRow (StringRow row)

Static Public Member Functions

static global::System.Xml.Schema.XmlSchemaComplexType GetTypedTableSchema (global::System.Xml.Schema.XmlSchemaSet xs)

Protected Member Functions

StringDataTable (global::System.Runtime.Serialization.SerializationInfo info, global::System.Runtime.Serialization.StreamingContext context)
override global::System.Data.DataTable | CreateInstance ()
override global::System.Data.DataRow | NewRowFromBuilder (global::System.Data.DataRowBuilder builder)
override global::System.Type | GetRowType ()
override void | OnRowChanged (global::System.Data.DataRowChangeEventArgs e)
override void | OnRowChanging (global::System.Data.DataRowChangeEventArgs e)
override void | OnRowDeleted (global::System.Data.DataRowChangeEventArgs e)
override void | OnRowDeleting (global::System.Data.DataRowChangeEventArgs e)

Package Functions

StringDataTable (global::System.Data.DataTable table)
void InitVars ()

Properties

global::System.Data.DataColumn | ID_IdColumn [get]
int | Count [get]
StringRow | this[int index] [get]

Events

StringRowChangeEventHandler | StringRowChanging
StringRowChangeEventHandler | StringRowChanged
StringRowChangeEventHandler | StringRowDeleting
StringRowChangeEventHandler | StringRowDeleted

Detailed Description

Represents the strongly named DataTable class. /summary>

Generated on Tue Dec 15 2015 18:15:07 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • NewDataSet
  • StringDataTable
Deltares.Standard.Forms.DExpress.NewDataSet.StringDataTable Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.NewDataSet.StringDataTable, including all inherited members.

AddStringRow(StringRow row) (defined in Deltares.Standard.Forms.DExpress.NewDataSet.StringDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.StringDataTable |
AddStringRow(IDRow parentIDRowByID_String) (defined in Deltares.Standard.Forms.DExpress.NewDataSet.StringDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.StringDataTable |
Clone() (defined in Deltares.Standard.Forms.DExpress.NewDataSet.StringDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.StringDataTable |
Count (defined in Deltares.Standard.Forms.DExpress.NewDataSet.StringDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.StringDataTable |
CreateInstance() (defined in Deltares.Standard.Forms.DExpress.NewDataSet.StringDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.StringDataTable | protected
GetRowType() (defined in Deltares.Standard.Forms.DExpress.NewDataSet.StringDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.StringDataTable | protected
GetTypedTableSchema(global::System.Xml.Schema.XmlSchemaSet xs) (defined in Deltares.Standard.Forms.DExpress.NewDataSet.StringDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.StringDataTable | static
ID_IdColumn (defined in Deltares.Standard.Forms.DExpress.NewDataSet.StringDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.StringDataTable |
InitVars() (defined in Deltares.Standard.Forms.DExpress.NewDataSet.StringDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.StringDataTable | package
NewRowFromBuilder(global::System.Data.DataRowBuilder builder) (defined in Deltares.Standard.Forms.DExpress.NewDataSet.StringDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.StringDataTable | protected
NewStringRow() (defined in Deltares.Standard.Forms.DExpress.NewDataSet.StringDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.StringDataTable |
OnRowChanged(global::System.Data.DataRowChangeEventArgs e) (defined in Deltares.Standard.Forms.DExpress.NewDataSet.StringDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.StringDataTable | protected
OnRowChanging(global::System.Data.DataRowChangeEventArgs e) (defined in Deltares.Standard.Forms.DExpress.NewDataSet.StringDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.StringDataTable | protected
OnRowDeleted(global::System.Data.DataRowChangeEventArgs e) (defined in Deltares.Standard.Forms.DExpress.NewDataSet.StringDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.StringDataTable | protected
OnRowDeleting(global::System.Data.DataRowChangeEventArgs e) (defined in Deltares.Standard.Forms.DExpress.NewDataSet.StringDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.StringDataTable | protected
RemoveStringRow(StringRow row) (defined in Deltares.Standard.Forms.DExpress.NewDataSet.StringDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.StringDataTable |
StringDataTable() (defined in Deltares.Standard.Forms.DExpress.NewDataSet.StringDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.StringDataTable |
StringDataTable(global::System.Data.DataTable table) (defined in Deltares.Standard.Forms.DExpress.NewDataSet.StringDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.StringDataTable | package
StringDataTable(global::System.Runtime.Serialization.SerializationInfo info, global::System.Runtime.Serialization.StreamingContext context) (defined in Deltares.Standard.Forms.DExpress.NewDataSet.StringDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.StringDataTable | protected
StringRowChanged (defined in Deltares.Standard.Forms.DExpress.NewDataSet.StringDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.StringDataTable |
StringRowChanging (defined in Deltares.Standard.Forms.DExpress.NewDataSet.StringDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.StringDataTable |
StringRowDeleted (defined in Deltares.Standard.Forms.DExpress.NewDataSet.StringDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.StringDataTable |
StringRowDeleting (defined in Deltares.Standard.Forms.DExpress.NewDataSet.StringDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.StringDataTable |
this[int index] (defined in Deltares.Standard.Forms.DExpress.NewDataSet.StringDataTable) | Deltares.Standard.Forms.DExpress.NewDataSet.StringDataTable |
Generated on Tue Dec 15 2015 18:15:07 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.NewDataSet.StringRow Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • NewDataSet
  • StringRow
Public Member Functions | Package Functions | Properties | List of all members
Deltares.Standard.Forms.DExpress.NewDataSet.StringRow Class Reference

Represents strongly named DataRow class. /summary> More...

Inheritance diagram for Deltares.Standard.Forms.DExpress.NewDataSet.StringRow:

Public Member Functions

bool | IsID_IdNull ()
void | SetID_IdNull ()

Package Functions

StringRow (global::System.Data.DataRowBuilder rb)

Properties

int | ID_Id [get, set]
IDRow | IDRow [get, set]

Detailed Description

Represents strongly named DataRow class. /summary>

Generated on Tue Dec 15 2015 18:15:07 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • NewDataSet
  • StringRow
Deltares.Standard.Forms.DExpress.NewDataSet.StringRow Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.NewDataSet.StringRow, including all inherited members.

ID_Id (defined in Deltares.Standard.Forms.DExpress.NewDataSet.StringRow) | Deltares.Standard.Forms.DExpress.NewDataSet.StringRow |
IDRow (defined in Deltares.Standard.Forms.DExpress.NewDataSet.StringRow) | Deltares.Standard.Forms.DExpress.NewDataSet.StringRow |
IsID_IdNull() (defined in Deltares.Standard.Forms.DExpress.NewDataSet.StringRow) | Deltares.Standard.Forms.DExpress.NewDataSet.StringRow |
SetID_IdNull() (defined in Deltares.Standard.Forms.DExpress.NewDataSet.StringRow) | Deltares.Standard.Forms.DExpress.NewDataSet.StringRow |
StringRow(global::System.Data.DataRowBuilder rb) (defined in Deltares.Standard.Forms.DExpress.NewDataSet.StringRow) | Deltares.Standard.Forms.DExpress.NewDataSet.StringRow | package
Generated on Tue Dec 15 2015 18:15:07 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.NewDataSet.StringRowChangeEvent Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • NewDataSet
  • StringRowChangeEvent
Public Member Functions | Properties | List of all members
Deltares.Standard.Forms.DExpress.NewDataSet.StringRowChangeEvent Class Reference

Row event argument class /summary> More...

Inheritance diagram for Deltares.Standard.Forms.DExpress.NewDataSet.StringRowChangeEvent:

Public Member Functions

StringRowChangeEvent (StringRow row, global::System.Data.DataRowAction action)

Properties

StringRow | Row [get]
global::System.Data.DataRowAction | Action [get]

Detailed Description

Row event argument class /summary>

Generated on Tue Dec 15 2015 18:15:08 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • NewDataSet
  • StringRowChangeEvent
Deltares.Standard.Forms.DExpress.NewDataSet.StringRowChangeEvent Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.NewDataSet.StringRowChangeEvent, including all inherited members.

Action (defined in Deltares.Standard.Forms.DExpress.NewDataSet.StringRowChangeEvent) | Deltares.Standard.Forms.DExpress.NewDataSet.StringRowChangeEvent
Row (defined in Deltares.Standard.Forms.DExpress.NewDataSet.StringRowChangeEvent) | Deltares.Standard.Forms.DExpress.NewDataSet.StringRowChangeEvent
StringRowChangeEvent(StringRow row, global::System.Data.DataRowAction action) (defined in Deltares.Standard.Forms.DExpress.NewDataSet.StringRowChangeEvent) | Deltares.Standard.Forms.DExpress.NewDataSet.StringRowChangeEvent
Generated on Tue Dec 15 2015 18:15:08 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.PanelAction Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • PanelAction
Protected Member Functions | Properties | List of all members
Deltares.Standard.Forms.DExpress.PanelAction Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.PanelAction:

Protected Member Functions

override void Dispose (bool disposing)
Clean up any resources being used. More...

Properties

SimpleButton Button [get]

Member Function Documentation

override void Deltares.Standard.Forms.DExpress.PanelAction.Dispose ( bool disposing )
protected

Clean up any resources being used.

Parameters
disposing true if managed resources should be disposed; otherwise, false.
Generated on Tue Dec 15 2015 18:15:08 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • PanelAction
Deltares.Standard.Forms.DExpress.PanelAction Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.PanelAction, including all inherited members.

Button (defined in Deltares.Standard.Forms.DExpress.PanelAction) | Deltares.Standard.Forms.DExpress.PanelAction |
Dispose(bool disposing) | Deltares.Standard.Forms.DExpress.PanelAction | protected
PanelAction() (defined in Deltares.Standard.Forms.DExpress.PanelAction) | Deltares.Standard.Forms.DExpress.PanelAction |
Generated on Tue Dec 15 2015 18:15:08 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.PanelLinearConversionValue Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • PanelLinearConversionValue
Public Member Functions | Protected Member Functions | Properties | List of all members
Deltares.Standard.Forms.DExpress.PanelLinearConversionValue Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.PanelLinearConversionValue:
Deltares.Standard.Forms.DExpress.ILabelEditControl

Public Member Functions

PanelLinearConversionValue (string name)

Protected Member Functions

override void Dispose (bool disposing)
Clean up any resources being used. More...

Properties

Control | LabelControl [get]
Control | EditControl [get]
- Properties inherited from Deltares.Standard.Forms.DExpress.ILabelEditControl
Control | EditControl [get]
Control | LabelControl [get]

Member Function Documentation

override void Deltares.Standard.Forms.DExpress.PanelLinearConversionValue.Dispose ( bool disposing )
protected

Clean up any resources being used.

Parameters
disposing true if managed resources should be disposed; otherwise, false.
Generated on Tue Dec 15 2015 18:15:08 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • PanelLinearConversionValue
Deltares.Standard.Forms.DExpress.PanelLinearConversionValue Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.PanelLinearConversionValue, including all inherited members.

Dispose(bool disposing) | Deltares.Standard.Forms.DExpress.PanelLinearConversionValue | protected
EditControl (defined in Deltares.Standard.Forms.DExpress.PanelLinearConversionValue) | Deltares.Standard.Forms.DExpress.PanelLinearConversionValue |
LabelControl (defined in Deltares.Standard.Forms.DExpress.PanelLinearConversionValue) | Deltares.Standard.Forms.DExpress.PanelLinearConversionValue |
PanelLinearConversionValue(string name) (defined in Deltares.Standard.Forms.DExpress.PanelLinearConversionValue) | Deltares.Standard.Forms.DExpress.PanelLinearConversionValue |
PanelLinearConversionValue() (defined in Deltares.Standard.Forms.DExpress.PanelLinearConversionValue) | Deltares.Standard.Forms.DExpress.PanelLinearConversionValue |
Generated on Tue Dec 15 2015 18:15:08 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.PanelTextBooleanValue Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • PanelTextBooleanValue
Public Member Functions | Protected Member Functions | Properties | List of all members
Deltares.Standard.Forms.DExpress.PanelTextBooleanValue Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.PanelTextBooleanValue:
Deltares.Standard.Forms.DExpress.ILabelEditControl

Public Member Functions

PanelTextBooleanValue (string name)

Protected Member Functions

override void Dispose (bool disposing)
Clean up any resources being used. More...

Properties

Control | LabelControl [get]
Control | EditControl [get]
- Properties inherited from Deltares.Standard.Forms.DExpress.ILabelEditControl
Control | EditControl [get]
Control | LabelControl [get]

Member Function Documentation

override void Deltares.Standard.Forms.DExpress.PanelTextBooleanValue.Dispose ( bool disposing )
protected

Clean up any resources being used.

Parameters
disposing true if managed resources should be disposed; otherwise, false.
Generated on Tue Dec 15 2015 18:15:08 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • PanelTextBooleanValue
Deltares.Standard.Forms.DExpress.PanelTextBooleanValue Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.PanelTextBooleanValue, including all inherited members.

Dispose(bool disposing) | Deltares.Standard.Forms.DExpress.PanelTextBooleanValue | protected
EditControl (defined in Deltares.Standard.Forms.DExpress.PanelTextBooleanValue) | Deltares.Standard.Forms.DExpress.PanelTextBooleanValue |
LabelControl (defined in Deltares.Standard.Forms.DExpress.PanelTextBooleanValue) | Deltares.Standard.Forms.DExpress.PanelTextBooleanValue |
PanelTextBooleanValue(string name) (defined in Deltares.Standard.Forms.DExpress.PanelTextBooleanValue) | Deltares.Standard.Forms.DExpress.PanelTextBooleanValue |
PanelTextBooleanValue() (defined in Deltares.Standard.Forms.DExpress.PanelTextBooleanValue) | Deltares.Standard.Forms.DExpress.PanelTextBooleanValue |
Generated on Tue Dec 15 2015 18:15:08 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.PanelTextComboBoxValue Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • PanelTextComboBoxValue
Public Member Functions | Protected Member Functions | Properties | List of all members
Deltares.Standard.Forms.DExpress.PanelTextComboBoxValue Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.PanelTextComboBoxValue:
Deltares.Standard.Forms.DExpress.ILabelEditControl

Public Member Functions

PanelTextComboBoxValue (string name)

Protected Member Functions

override void Dispose (bool disposing)
Clean up any resources being used. More...

Properties

Control | LabelControl [get]
Control | EditControl [get]
- Properties inherited from Deltares.Standard.Forms.DExpress.ILabelEditControl
Control | EditControl [get]
Control | LabelControl [get]

Member Function Documentation

override void Deltares.Standard.Forms.DExpress.PanelTextComboBoxValue.Dispose ( bool disposing )
protected

Clean up any resources being used.

Parameters
disposing true if managed resources should be disposed; otherwise, false.
Generated on Tue Dec 15 2015 18:15:09 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • PanelTextComboBoxValue
Deltares.Standard.Forms.DExpress.PanelTextComboBoxValue Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.PanelTextComboBoxValue, including all inherited members.

Dispose(bool disposing) | Deltares.Standard.Forms.DExpress.PanelTextComboBoxValue | protected
EditControl (defined in Deltares.Standard.Forms.DExpress.PanelTextComboBoxValue) | Deltares.Standard.Forms.DExpress.PanelTextComboBoxValue |
LabelControl (defined in Deltares.Standard.Forms.DExpress.PanelTextComboBoxValue) | Deltares.Standard.Forms.DExpress.PanelTextComboBoxValue |
PanelTextComboBoxValue() (defined in Deltares.Standard.Forms.DExpress.PanelTextComboBoxValue) | Deltares.Standard.Forms.DExpress.PanelTextComboBoxValue |
PanelTextComboBoxValue(string name) (defined in Deltares.Standard.Forms.DExpress.PanelTextComboBoxValue) | Deltares.Standard.Forms.DExpress.PanelTextComboBoxValue |
Generated on Tue Dec 15 2015 18:15:09 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.PanelTextLinkValue Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • PanelTextLinkValue
Protected Member Functions | Properties | List of all members
Deltares.Standard.Forms.DExpress.PanelTextLinkValue Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.PanelTextLinkValue:
Deltares.Standard.Forms.DExpress.ILabelEditControl

Protected Member Functions

override void Dispose (bool disposing)
Clean up any resources being used. More...

Properties

Control | LabelControl [get]
Control | EditControl [get]
- Properties inherited from Deltares.Standard.Forms.DExpress.ILabelEditControl
Control | EditControl [get]
Control | LabelControl [get]

Member Function Documentation

override void Deltares.Standard.Forms.DExpress.PanelTextLinkValue.Dispose ( bool disposing )
protected

Clean up any resources being used.

Parameters
disposing true if managed resources should be disposed; otherwise, false.
Generated on Tue Dec 15 2015 18:15:09 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • PanelTextLinkValue
Deltares.Standard.Forms.DExpress.PanelTextLinkValue Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.PanelTextLinkValue, including all inherited members.

Dispose(bool disposing) | Deltares.Standard.Forms.DExpress.PanelTextLinkValue | protected
EditControl (defined in Deltares.Standard.Forms.DExpress.PanelTextLinkValue) | Deltares.Standard.Forms.DExpress.PanelTextLinkValue |
LabelControl (defined in Deltares.Standard.Forms.DExpress.PanelTextLinkValue) | Deltares.Standard.Forms.DExpress.PanelTextLinkValue |
PanelTextLinkValue() (defined in Deltares.Standard.Forms.DExpress.PanelTextLinkValue) | Deltares.Standard.Forms.DExpress.PanelTextLinkValue |
Generated on Tue Dec 15 2015 18:15:09 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.PanelTextNumericValue Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • PanelTextNumericValue
Public Member Functions | Protected Member Functions | Properties | List of all members
Deltares.Standard.Forms.DExpress.PanelTextNumericValue Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.PanelTextNumericValue:
Deltares.Standard.Forms.DExpress.ILabelEditControl

Public Member Functions

PanelTextNumericValue (string name)

Protected Member Functions

override void Dispose (bool disposing)
Clean up any resources being used. More...

Properties

Control | LabelControl [get]
Control | EditControl [get]
- Properties inherited from Deltares.Standard.Forms.DExpress.ILabelEditControl
Control | EditControl [get]
Control | LabelControl [get]

Member Function Documentation

override void Deltares.Standard.Forms.DExpress.PanelTextNumericValue.Dispose ( bool disposing )
protected

Clean up any resources being used.

Parameters
disposing true if managed resources should be disposed; otherwise, false.
Generated on Tue Dec 15 2015 18:15:09 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • PanelTextNumericValue
Deltares.Standard.Forms.DExpress.PanelTextNumericValue Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.PanelTextNumericValue, including all inherited members.

Dispose(bool disposing) | Deltares.Standard.Forms.DExpress.PanelTextNumericValue | protected
EditControl (defined in Deltares.Standard.Forms.DExpress.PanelTextNumericValue) | Deltares.Standard.Forms.DExpress.PanelTextNumericValue |
LabelControl (defined in Deltares.Standard.Forms.DExpress.PanelTextNumericValue) | Deltares.Standard.Forms.DExpress.PanelTextNumericValue |
PanelTextNumericValue(string name) (defined in Deltares.Standard.Forms.DExpress.PanelTextNumericValue) | Deltares.Standard.Forms.DExpress.PanelTextNumericValue |
PanelTextNumericValue() (defined in Deltares.Standard.Forms.DExpress.PanelTextNumericValue) | Deltares.Standard.Forms.DExpress.PanelTextNumericValue |
Generated on Tue Dec 15 2015 18:15:09 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.PanelTextPathValue Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • PanelTextPathValue
Public Member Functions | Protected Member Functions | Properties | List of all members
Deltares.Standard.Forms.DExpress.PanelTextPathValue Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.PanelTextPathValue:
Deltares.Standard.Forms.DExpress.ILabelEditControl

Public Member Functions

PanelTextPathValue (string name)

Protected Member Functions

override void Dispose (bool disposing)
Clean up any resources being used. More...

Properties

string | Filter [get, set]
Filter for lookup files by filesystem More...
Control | LabelControl [get]
Control | EditControl [get]
- Properties inherited from Deltares.Standard.Forms.DExpress.ILabelEditControl
Control | EditControl [get]
Control | LabelControl [get]

Member Function Documentation

override void Deltares.Standard.Forms.DExpress.PanelTextPathValue.Dispose ( bool disposing )
protected

Clean up any resources being used.

Parameters
disposing true if managed resources should be disposed; otherwise, false.

Property Documentation

string Deltares.Standard.Forms.DExpress.PanelTextPathValue.Filter
getset

Filter for lookup files by filesystem

Generated on Tue Dec 15 2015 18:15:10 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • PanelTextPathValue
Deltares.Standard.Forms.DExpress.PanelTextPathValue Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.PanelTextPathValue, including all inherited members.

Dispose(bool disposing) | Deltares.Standard.Forms.DExpress.PanelTextPathValue | protected
EditControl (defined in Deltares.Standard.Forms.DExpress.PanelTextPathValue) | Deltares.Standard.Forms.DExpress.PanelTextPathValue |
Filter | Deltares.Standard.Forms.DExpress.PanelTextPathValue |
LabelControl (defined in Deltares.Standard.Forms.DExpress.PanelTextPathValue) | Deltares.Standard.Forms.DExpress.PanelTextPathValue |
PanelTextPathValue(string name) (defined in Deltares.Standard.Forms.DExpress.PanelTextPathValue) | Deltares.Standard.Forms.DExpress.PanelTextPathValue |
PanelTextPathValue() (defined in Deltares.Standard.Forms.DExpress.PanelTextPathValue) | Deltares.Standard.Forms.DExpress.PanelTextPathValue |
Generated on Tue Dec 15 2015 18:15:10 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.PanelTextPopupContainerEdit Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • PanelTextPopupContainerEdit
Public Member Functions | Protected Member Functions | Properties | List of all members
Deltares.Standard.Forms.DExpress.PanelTextPopupContainerEdit Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.PanelTextPopupContainerEdit:
Deltares.Standard.Forms.DExpress.ILabelEditControl

Public Member Functions

PanelTextPopupContainerEdit (string name)

Protected Member Functions

override void Dispose (bool disposing)
Clean up any resources being used. More...

Properties

Control | LabelControl [get]
Control | EditControl [get]
- Properties inherited from Deltares.Standard.Forms.DExpress.ILabelEditControl
Control | EditControl [get]
Control | LabelControl [get]

Member Function Documentation

override void Deltares.Standard.Forms.DExpress.PanelTextPopupContainerEdit.Dispose ( bool disposing )
protected

Clean up any resources being used.

Parameters
disposing true if managed resources should be disposed; otherwise, false.
Generated on Tue Dec 15 2015 18:15:10 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • PanelTextPopupContainerEdit
Deltares.Standard.Forms.DExpress.PanelTextPopupContainerEdit Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.PanelTextPopupContainerEdit, including all inherited members.

Dispose(bool disposing) | Deltares.Standard.Forms.DExpress.PanelTextPopupContainerEdit | protected
EditControl (defined in Deltares.Standard.Forms.DExpress.PanelTextPopupContainerEdit) | Deltares.Standard.Forms.DExpress.PanelTextPopupContainerEdit |
LabelControl (defined in Deltares.Standard.Forms.DExpress.PanelTextPopupContainerEdit) | Deltares.Standard.Forms.DExpress.PanelTextPopupContainerEdit |
PanelTextPopupContainerEdit(string name) (defined in Deltares.Standard.Forms.DExpress.PanelTextPopupContainerEdit) | Deltares.Standard.Forms.DExpress.PanelTextPopupContainerEdit |
PanelTextPopupContainerEdit() (defined in Deltares.Standard.Forms.DExpress.PanelTextPopupContainerEdit) | Deltares.Standard.Forms.DExpress.PanelTextPopupContainerEdit |
Generated on Tue Dec 15 2015 18:15:10 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.PanelTextStringValue Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • PanelTextStringValue
Public Member Functions | Protected Member Functions | Properties | List of all members
Deltares.Standard.Forms.DExpress.PanelTextStringValue Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.PanelTextStringValue:
Deltares.Standard.Forms.DExpress.ILabelEditControl

Public Member Functions

PanelTextStringValue (string name)

Protected Member Functions

override void Dispose (bool disposing)
Clean up any resources being used. More...

Properties

Control | LabelControl [get]
Control | EditControl [get]
- Properties inherited from Deltares.Standard.Forms.DExpress.ILabelEditControl
Control | EditControl [get]
Control | LabelControl [get]

Member Function Documentation

override void Deltares.Standard.Forms.DExpress.PanelTextStringValue.Dispose ( bool disposing )
protected

Clean up any resources being used.

Parameters
disposing true if managed resources should be disposed; otherwise, false.
Generated on Tue Dec 15 2015 18:15:10 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • PanelTextStringValue
Deltares.Standard.Forms.DExpress.PanelTextStringValue Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.PanelTextStringValue, including all inherited members.

Dispose(bool disposing) | Deltares.Standard.Forms.DExpress.PanelTextStringValue | protected
EditControl (defined in Deltares.Standard.Forms.DExpress.PanelTextStringValue) | Deltares.Standard.Forms.DExpress.PanelTextStringValue |
LabelControl (defined in Deltares.Standard.Forms.DExpress.PanelTextStringValue) | Deltares.Standard.Forms.DExpress.PanelTextStringValue |
PanelTextStringValue(string name) (defined in Deltares.Standard.Forms.DExpress.PanelTextStringValue) | Deltares.Standard.Forms.DExpress.PanelTextStringValue |
PanelTextStringValue() (defined in Deltares.Standard.Forms.DExpress.PanelTextStringValue) | Deltares.Standard.Forms.DExpress.PanelTextStringValue |
Generated on Tue Dec 15 2015 18:15:10 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.PdfHelpFileManager Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • PdfHelpFileManager
Public Member Functions | Properties | List of all members
Deltares.Standard.Forms.DExpress.PdfHelpFileManager Class Reference

Interacts with a pdf help file. More...

Inheritance diagram for Deltares.Standard.Forms.DExpress.PdfHelpFileManager:
Deltares.Standard.Forms.DExpress.Interfaces.IHelpFileManager

Public Member Functions

PdfHelpFileManager (IHelpLocationProvider helpLocationProvider)
Initializes a new instance of the PdfHelpFileManager class. More...
void OpenHelp (Control control)
Request to open the help at a given location. More...

Properties

string | HelpFilePath [get, set]
IHelpLocationProvider | HelpLocationProvider [get]
- Properties inherited from Deltares.Standard.Forms.DExpress.Interfaces.IHelpFileManager
string | HelpFilePath [get, set]
Gets or sets the help file path. More...
IHelpLocationProvider | HelpLocationProvider [get]
Gets the help location provider. More...

Detailed Description

Interacts with a pdf help file.

Allows jumping to help file locations if Adobe Reader is installed and detected.

Constructor & Destructor Documentation

Deltares.Standard.Forms.DExpress.PdfHelpFileManager.PdfHelpFileManager ( IHelpLocationProvider helpLocationProvider )

Initializes a new instance of the PdfHelpFileManager class.

Parameters
helpLocationProvider The help location provider.

Help locations provided by helpLocationProvider should be anchors in the pdf file.

Member Function Documentation

void Deltares.Standard.Forms.DExpress.PdfHelpFileManager.OpenHelp ( Control control )

Request to open the help at a given location.

<preCondition>HelpFilePath should be a path to a valid file.</preCondition>

Exceptions
FileNotFoundException | When HelpFilePath does not exist.
InvalidOperationException | When HelpFilePath is not of the correct type (for example .txt file while it should be .pdf).

Implements Deltares.Standard.Forms.DExpress.Interfaces.IHelpFileManager.

Generated on Tue Dec 15 2015 18:15:11 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • PdfHelpFileManager
Deltares.Standard.Forms.DExpress.PdfHelpFileManager Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.PdfHelpFileManager, including all inherited members.

HelpFilePath (defined in Deltares.Standard.Forms.DExpress.PdfHelpFileManager) | Deltares.Standard.Forms.DExpress.PdfHelpFileManager
HelpLocationProvider (defined in Deltares.Standard.Forms.DExpress.PdfHelpFileManager) | Deltares.Standard.Forms.DExpress.PdfHelpFileManager
OpenHelp(Control control) | Deltares.Standard.Forms.DExpress.PdfHelpFileManager
PdfHelpFileManager(IHelpLocationProvider helpLocationProvider) | Deltares.Standard.Forms.DExpress.PdfHelpFileManager
Generated on Tue Dec 15 2015 18:15:11 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.PictureBoxBinding Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • PictureBoxBinding
Public Member Functions | List of all members
Deltares.Standard.Forms.DExpress.PictureBoxBinding Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.PictureBoxBinding:
Deltares.Standard.Forms.DExpress.ScrollableControlBinding Deltares.Standard.Forms.DExpress.ControlBinding Deltares.Standard.Forms.DExpress.ComponentBinding Deltares.Standard.Forms.DExpress.ComponentWrappers.IGetBoundControl

Public Member Functions

PictureBoxBinding (Component component)
override void | SetValue (object value)
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.ScrollableControlBinding
ScrollableControlBinding (Component component)
override void | SetEnabled (bool enabled)
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.ControlBinding
override void | SetVisible (bool visible)
override void | SetLabel (string text)
Sets the label/title/name associated with this control. More...
override void | SetDescription (string description)
Sets the textual description associated with this control. More...
override void | SetForegroundColor (Color color)
override void | SetBackgroundColor (Color color)
override void | Invalidate ()
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
ComponentBinding (Component component)
virtual void | Initialize (BindPropertyInfo propertyInfo, params string[] properties)
virtual void | Initialize (BindPropertyInfo propertyInfo, Type rootObjectType, params string[] properties)
virtual void | SetTrueMapping (object trueMapping)
virtual void | SetValue (object value, object parent)
virtual void | SetDomain (ICollection collection)
virtual object | GetValue ()
virtual void | Refresh ()
virtual void | RegisterSelectionAssignment (Component targetComponent, IConverter converter=null)
Indicates that the selection of the bound control must be assigned to another control. More...
virtual void | SetControlColors (Color fore, Color back)
Sets the controls foreground and background colors. Can be overridden by a specific binding to set other colors if necessary. More...

Additional Inherited Members

- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.ControlBinding
ControlBinding (Component component)
virtual void | OnToolTipShown (PopupEventArgs e)
Called when Tooltip is shown, and fires ToolTipShown event. More...
virtual void | OnToolTipClosed ()
Called when Tooltip is hidden, and fires ToolTipHidden. More...
void | ThreadSafeRefresh ()
override void | Dispose (bool disposing)
- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
void | RaiseValueChanged ()
void | RaiseLeave ()
void | RaiseActionPerformed ()
Type | GetGenericType (Type type)
string | ValueToString (object value)
bool | IsAssociatedPropertyVisible (object source, BindPropertyInfo associatedPropertyInfo)
Indicates whether the associated property (i.e. the property which is used to display the original property in a textbox) is visible More...
void | EditFileInfo (object source, BindPropertyInfo propertyInfo)
string | EditFileInfo (string value, string format, string label, string description, bool isDirectory)
string | GetDoubleString (string text)
bool | HasValidNumericValue (string text)
double | GetNumericValue (string text)
List< BindPropertyInfo > | GetDictionaryProperties (ICollection domain, BindPropertyInfo dynamicPropertyInfo)
- Protected Attributes inherited from Deltares.Standard.Forms.DExpress.ControlBinding
readonly ToolTip | tooltip
string | Description
The textual description associated with this

See also
Control

. More...

string | Label
The label/title/name associated with this Control. More...
- Protected Attributes inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
BindPropertyInfo | propInfo
- Properties inherited from Deltares.Standard.Forms.DExpress.ControlBinding
ToolTip | Tooltip [get]
Gets the tooltip for the bound control. More...
Control | BoundControl [get]
- Properties inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
Component | Component [get]
virtual bool | IsTransparant [get]
virtual HandleType | HandleDelayed [get]
virtual bool | HasDomain [get]
- Properties inherited from Deltares.Standard.Forms.DExpress.ComponentWrappers.IGetBoundControl
Control | BoundControl [get]
- Events inherited from Deltares.Standard.Forms.DExpress.ControlBinding
ToolTipVisibilityEventHandler | ToolTipHidden
ToolTipVisibilityEventHandler | ToolTipShown
- Events inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
EventHandler< EventArgs > | ActionPerformed
EventHandler< EventArgs > | Leave
EventHandler< EventArgs > | ValueChanged
Generated on Tue Dec 15 2015 18:15:11 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • PictureBoxBinding
Deltares.Standard.Forms.DExpress.PictureBoxBinding Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.PictureBoxBinding, including all inherited members.

ActionPerformed (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
BoundControl (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding |
Component (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ComponentBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ControlBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Description | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Dispose(bool disposing) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | protected
EditFileInfo(object source, BindPropertyInfo propertyInfo) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
EditFileInfo(string value, string format, string label, string description, bool isDirectory) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetDictionaryProperties(ICollection domain, BindPropertyInfo dynamicPropertyInfo) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetDoubleString(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetGenericType(Type type) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetNumericValue(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetValue() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
HandleDelayed (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
HasDomain (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
HasValidNumericValue(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Initialize(BindPropertyInfo propertyInfo, params string[] properties) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
Initialize(BindPropertyInfo propertyInfo, Type rootObjectType, params string[] properties) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
Invalidate() (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
IsAssociatedPropertyVisible(object source, BindPropertyInfo associatedPropertyInfo) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
IsTransparant (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
Label | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Leave (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
OnToolTipClosed() | Deltares.Standard.Forms.DExpress.ControlBinding | protectedvirtual
OnToolTipShown(PopupEventArgs e) | Deltares.Standard.Forms.DExpress.ControlBinding | protectedvirtual
PictureBoxBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.PictureBoxBinding) | Deltares.Standard.Forms.DExpress.PictureBoxBinding |
propInfo (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseActionPerformed() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseLeave() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseValueChanged() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Refresh() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
RegisterSelectionAssignment(Component targetComponent, IConverter converter=null) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
ScrollableControlBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.ScrollableControlBinding) | Deltares.Standard.Forms.DExpress.ScrollableControlBinding |
SetBackgroundColor(Color color) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
SetControlColors(Color fore, Color back) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetDescription(string description) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
SetDomain(ICollection collection) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetEnabled(bool enabled) (defined in Deltares.Standard.Forms.DExpress.ScrollableControlBinding) | Deltares.Standard.Forms.DExpress.ScrollableControlBinding | virtual
SetForegroundColor(Color color) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
SetLabel(string text) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
SetTrueMapping(object trueMapping) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetValue(object value) (defined in Deltares.Standard.Forms.DExpress.PictureBoxBinding) | Deltares.Standard.Forms.DExpress.PictureBoxBinding | virtual
SetValue(object value, object parent) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetVisible(bool visible) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
ThreadSafeRefresh() (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Tooltip | Deltares.Standard.Forms.DExpress.ControlBinding | protected
tooltip (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | protected
ToolTipHidden (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding |
ToolTipShown (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding |
ValueChanged (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ValueToString(object value) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Generated on Tue Dec 15 2015 18:15:11 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.PlusStrategy Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • PlusStrategy
Public Member Functions | Protected Member Functions | List of all members
Deltares.Standard.Forms.DExpress.PlusStrategy Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.PlusStrategy:
Deltares.Standard.Forms.DExpress.GridEditValueStrategy

Public Member Functions

override double | DefaultForSelected (GridView view)
Determines the default value based on the selected values. Not all implementations will use the selected values, but by passing the view, we can generalize the method call. More...
override string | ToString ()
This method has to be overridden so it has a proper representation in the UI. More...
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.GridEditValueStrategy
void | EvaluateForSelected (GridView view, double modificationValue)
Sets new cell values by evaluating the modification value and using the current strategy. More...

Protected Member Functions

override double Evaluate (double value, double modificationValue)
The implementation of this method is used in the EvaluateForSelected method. More...

Additional Inherited Members

- Static Public Attributes inherited from Deltares.Standard.Forms.DExpress.GridEditValueStrategy
static readonly GridEditValueStrategy[] Strategies
Collection of all the strategies which are defined in this file. This is a static list so the strategies will only be instantiated once. Using instantiations make polymorphism possible. More...

Member Function Documentation

override double Deltares.Standard.Forms.DExpress.PlusStrategy.DefaultForSelected ( GridView view )
virtual

Determines the default value based on the selected values. Not all implementations will use the selected values, but by passing the view, we can generalize the method call.

Parameters
view The view (which may not be used at all) containing selected values (or not).
Returns
A sensible default for the strategy, or null if no sensible default can be given.

Implements Deltares.Standard.Forms.DExpress.GridEditValueStrategy.

override double Deltares.Standard.Forms.DExpress.PlusStrategy.Evaluate | ( | double | value,
 |  | double | modificationValue
 | ) |  |
protectedvirtual

The implementation of this method is used in the EvaluateForSelected method.

Parameters
value | The current value.
modificationValue | The value used in evaluating a new value.
Returns
The new value.

Implements Deltares.Standard.Forms.DExpress.GridEditValueStrategy.

override string Deltares.Standard.Forms.DExpress.PlusStrategy.ToString ( )
virtual

This method has to be overridden so it has a proper representation in the UI.

Returns

Implements Deltares.Standard.Forms.DExpress.GridEditValueStrategy.

Generated on Tue Dec 15 2015 18:15:11 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • PlusStrategy
Deltares.Standard.Forms.DExpress.PlusStrategy Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.PlusStrategy, including all inherited members.

DefaultForSelected(GridView view) | Deltares.Standard.Forms.DExpress.PlusStrategy | virtual
Evaluate(double value, double modificationValue) | Deltares.Standard.Forms.DExpress.PlusStrategy | protectedvirtual
EvaluateForSelected(GridView view, double modificationValue) | Deltares.Standard.Forms.DExpress.GridEditValueStrategy |
Strategies | Deltares.Standard.Forms.DExpress.GridEditValueStrategy | static
ToString() | Deltares.Standard.Forms.DExpress.PlusStrategy | virtual
Generated on Tue Dec 15 2015 18:15:11 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.PopupContainerEditBinding Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • PopupContainerEditBinding
Public Member Functions | Protected Member Functions | List of all members
Deltares.Standard.Forms.DExpress.PopupContainerEditBinding Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.PopupContainerEditBinding:
Deltares.Standard.Forms.DExpress.BaseControlBinding Deltares.Standard.Forms.DExpress.ControlBinding Deltares.Standard.Forms.DExpress.ComponentBinding Deltares.Standard.Forms.DExpress.ComponentWrappers.IGetBoundControl

Public Member Functions

PopupContainerEditBinding (Component component)
override void | Initialize (BindPropertyInfo propertyInfo, params string[] subProperties)
When this binding is initialized with a subproperty, the PopupContainerEdit object's textfield value is "bound" to that property. Changes to the textfield will issue een update to that field. Enabling/disabling and setting the visibility of this control is still maintained by the BindPropertyInfo info. More...
override void | SetValue (object value, object parent)
This method will set the control's text and the control showing up in this control's popup. More...
override object | GetValue ()
Returns the value of this binding More...
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.BaseControlBinding
override void | SetLabel (string text)
override void | SetDescription (string description)
override void | Invalidate ()
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.ControlBinding
override void | SetVisible (bool visible)
override void | SetEnabled (bool enabled)
override void | SetLabel (string text)
Sets the label/title/name associated with this control. More...
override void | SetDescription (string description)
Sets the textual description associated with this control. More...
override void | SetForegroundColor (Color color)
override void | SetBackgroundColor (Color color)
override void | Invalidate ()
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
ComponentBinding (Component component)
virtual void | Initialize (BindPropertyInfo propertyInfo, Type rootObjectType, params string[] properties)
virtual void | SetTrueMapping (object trueMapping)
virtual void | SetValue (object value)
virtual void | SetDomain (ICollection collection)
virtual void | Refresh ()
virtual void | RegisterSelectionAssignment (Component targetComponent, IConverter converter=null)
Indicates that the selection of the bound control must be assigned to another control. More...
virtual void | SetControlColors (Color fore, Color back)
Sets the controls foreground and background colors. Can be overridden by a specific binding to set other colors if necessary. More...

Protected Member Functions

override void | Dispose (bool disposing)
- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.BaseControlBinding
BaseControlBinding (Component component)
DXPopupMenu | GetPopupMenu ()
This method uses reflection to make the context menu accessible, which otherwise is protected. The Menu property is implemented for TextEdit, so we first make sure the control is actually of this type. More...
override void | OnToolTipShown (PopupEventArgs e)
Called when Tooltip is shown, and fires ToolTipShown event. More...
override void | OnToolTipClosed ()
Called when Tooltip is hidden, and fires ToolTipHidden. More...
override void | Dispose (bool disposing)
- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.ControlBinding
ControlBinding (Component component)
void | ThreadSafeRefresh ()
override void | Dispose (bool disposing)
- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
void | RaiseValueChanged ()
void | RaiseLeave ()
void | RaiseActionPerformed ()
Type | GetGenericType (Type type)
string | ValueToString (object value)
bool | IsAssociatedPropertyVisible (object source, BindPropertyInfo associatedPropertyInfo)
Indicates whether the associated property (i.e. the property which is used to display the original property in a textbox) is visible More...
void | EditFileInfo (object source, BindPropertyInfo propertyInfo)
string | EditFileInfo (string value, string format, string label, string description, bool isDirectory)
string | GetDoubleString (string text)
bool | HasValidNumericValue (string text)
double | GetNumericValue (string text)
List< BindPropertyInfo > | GetDictionaryProperties (ICollection domain, BindPropertyInfo dynamicPropertyInfo)

Additional Inherited Members

- Protected Attributes inherited from Deltares.Standard.Forms.DExpress.BaseControlBinding
readonly SuperToolTip | superTip
- Protected Attributes inherited from Deltares.Standard.Forms.DExpress.ControlBinding
readonly ToolTip | tooltip
string | Description
The textual description associated with this

See also
Control

. More...

string | Label
The label/title/name associated with this Control. More...
- Protected Attributes inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
BindPropertyInfo | propInfo
- Properties inherited from Deltares.Standard.Forms.DExpress.ControlBinding
ToolTip | Tooltip [get]
Gets the tooltip for the bound control. More...
Control | BoundControl [get]
- Properties inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
Component | Component [get]
virtual bool | IsTransparant [get]
virtual HandleType | HandleDelayed [get]
virtual bool | HasDomain [get]
- Properties inherited from Deltares.Standard.Forms.DExpress.ComponentWrappers.IGetBoundControl
Control | BoundControl [get]
- Events inherited from Deltares.Standard.Forms.DExpress.ControlBinding
ToolTipVisibilityEventHandler | ToolTipHidden
ToolTipVisibilityEventHandler | ToolTipShown
- Events inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
EventHandler< EventArgs > | ActionPerformed
EventHandler< EventArgs > | Leave
EventHandler< EventArgs > | ValueChanged

Member Function Documentation

override object Deltares.Standard.Forms.DExpress.PopupContainerEditBinding.GetValue ( )
virtual

Returns the value of this binding

Reimplemented from Deltares.Standard.Forms.DExpress.ComponentBinding.

override void Deltares.Standard.Forms.DExpress.PopupContainerEditBinding.Initialize | ( | BindPropertyInfo | propertyInfo,
 |  | params string[] | subProperties
 | ) |  |
virtual

When this binding is initialized with a subproperty, the PopupContainerEdit object's textfield value is "bound" to that property. Changes to the textfield will issue een update to that field. Enabling/disabling and setting the visibility of this control is still maintained by the BindPropertyInfo info.

Parameters
propertyInfo | The BindPropertyInfo containing all the information for how this control should be rendered
subProperties | Subproperties

Reimplemented from Deltares.Standard.Forms.DExpress.BaseControlBinding.

References Deltares.Standard.Forms.DExpress.BindSupport.GetPopupControl().

override void Deltares.Standard.Forms.DExpress.PopupContainerEditBinding.SetValue | ( | object | value,
 |  | object | parent
 | ) |  |
virtual

This method will set the control's text and the control showing up in this control's popup.

Parameters
value | The value of bound field of the datasource
parent | The datasource

Reimplemented from Deltares.Standard.Forms.DExpress.ComponentBinding.

References Deltares.Standard.Forms.DExpress.BindSupport.Assign().

Generated on Tue Dec 15 2015 18:15:12 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • PopupContainerEditBinding
Deltares.Standard.Forms.DExpress.PopupContainerEditBinding Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.PopupContainerEditBinding, including all inherited members.

ActionPerformed (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
BaseControlBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.BaseControlBinding) | Deltares.Standard.Forms.DExpress.BaseControlBinding | protected
BoundControl (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding |
Component (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ComponentBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ControlBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Description | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Dispose(bool disposing) (defined in Deltares.Standard.Forms.DExpress.PopupContainerEditBinding) | Deltares.Standard.Forms.DExpress.PopupContainerEditBinding | protected
EditFileInfo(object source, BindPropertyInfo propertyInfo) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
EditFileInfo(string value, string format, string label, string description, bool isDirectory) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetDictionaryProperties(ICollection domain, BindPropertyInfo dynamicPropertyInfo) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetDoubleString(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetGenericType(Type type) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetNumericValue(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetPopupMenu() | Deltares.Standard.Forms.DExpress.BaseControlBinding | protected
GetValue() | Deltares.Standard.Forms.DExpress.PopupContainerEditBinding | virtual
HandleDelayed (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
HasDomain (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
HasValidNumericValue(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Initialize(BindPropertyInfo propertyInfo, params string[] subProperties) | Deltares.Standard.Forms.DExpress.PopupContainerEditBinding | virtual
Initialize(BindPropertyInfo propertyInfo, Type rootObjectType, params string[] properties) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
Invalidate() (defined in Deltares.Standard.Forms.DExpress.BaseControlBinding) | Deltares.Standard.Forms.DExpress.BaseControlBinding | virtual
IsAssociatedPropertyVisible(object source, BindPropertyInfo associatedPropertyInfo) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
IsTransparant (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
Label | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Leave (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
OnToolTipClosed() | Deltares.Standard.Forms.DExpress.BaseControlBinding | protectedvirtual
OnToolTipShown(PopupEventArgs e) | Deltares.Standard.Forms.DExpress.BaseControlBinding | protectedvirtual
PopupContainerEditBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.PopupContainerEditBinding) | Deltares.Standard.Forms.DExpress.PopupContainerEditBinding |
propInfo (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseActionPerformed() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseLeave() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseValueChanged() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Refresh() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
RegisterSelectionAssignment(Component targetComponent, IConverter converter=null) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetBackgroundColor(Color color) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
SetControlColors(Color fore, Color back) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetDescription(string description) (defined in Deltares.Standard.Forms.DExpress.BaseControlBinding) | Deltares.Standard.Forms.DExpress.BaseControlBinding | virtual
SetDomain(ICollection collection) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetEnabled(bool enabled) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
SetForegroundColor(Color color) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
SetLabel(string text) (defined in Deltares.Standard.Forms.DExpress.BaseControlBinding) | Deltares.Standard.Forms.DExpress.BaseControlBinding | virtual
SetTrueMapping(object trueMapping) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetValue(object value, object parent) | Deltares.Standard.Forms.DExpress.PopupContainerEditBinding | virtual
SetValue(object value) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetVisible(bool visible) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
superTip (defined in Deltares.Standard.Forms.DExpress.BaseControlBinding) | Deltares.Standard.Forms.DExpress.BaseControlBinding | protected
ThreadSafeRefresh() (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Tooltip | Deltares.Standard.Forms.DExpress.ControlBinding | protected
tooltip (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | protected
ToolTipHidden (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding |
ToolTipShown (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding |
ValueChanged (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ValueToString(object value) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Generated on Tue Dec 15 2015 18:15:12 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.ProgramOptionsControl Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • ProgramOptionsControl
Protected Member Functions | Protected Attributes | Properties | List of all members
Deltares.Standard.Forms.DExpress.ProgramOptionsControl Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.ProgramOptionsControl:
Deltares.Standard.Forms.IPropertyControl

Protected Member Functions

override void Dispose (bool disposing)
Clean up any resources being used. More...

Protected Attributes

DevExpress.XtraEditors.ComboBoxEdit | comboBoxEdit1
DevExpress.XtraEditors.PanelControl | panelControl2
System.Windows.Forms.RadioButton | NewProjectRadioButton
System.Windows.Forms.RadioButton | LastUsedProjectRadioButton
DevExpress.XtraEditors.ComboBoxEdit | StartUpEdit
DevExpress.XtraEditors.LabelControl | LanguageLabel

Properties

object | SelectedObject [get, set]
bool | IsVisible [get]
- Properties inherited from Deltares.Standard.Forms.IPropertyControl
string | Name [get, set]
Gets or sets the name to be displayed property. More...
object | SelectedObject [get, set]
Gets or sets the object to be displayed in the property window. More...
bool | IsVisible [get]
Whether or not the property control should be displayed. More...

Member Function Documentation

override void Deltares.Standard.Forms.DExpress.ProgramOptionsControl.Dispose ( bool disposing )
protected

Clean up any resources being used.

Parameters
disposing true if managed resources should be disposed; otherwise, false.
Generated on Tue Dec 15 2015 18:15:12 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • ProgramOptionsControl
Deltares.Standard.Forms.DExpress.ProgramOptionsControl Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.ProgramOptionsControl, including all inherited members.

comboBoxEdit1 (defined in Deltares.Standard.Forms.DExpress.ProgramOptionsControl) | Deltares.Standard.Forms.DExpress.ProgramOptionsControl | protected
Dispose(bool disposing) | Deltares.Standard.Forms.DExpress.ProgramOptionsControl | protected
IsVisible (defined in Deltares.Standard.Forms.DExpress.ProgramOptionsControl) | Deltares.Standard.Forms.DExpress.ProgramOptionsControl |
LanguageLabel (defined in Deltares.Standard.Forms.DExpress.ProgramOptionsControl) | Deltares.Standard.Forms.DExpress.ProgramOptionsControl | protected
LastUsedProjectRadioButton (defined in Deltares.Standard.Forms.DExpress.ProgramOptionsControl) | Deltares.Standard.Forms.DExpress.ProgramOptionsControl | protected
Name | Deltares.Standard.Forms.IPropertyControl |
NewProjectRadioButton (defined in Deltares.Standard.Forms.DExpress.ProgramOptionsControl) | Deltares.Standard.Forms.DExpress.ProgramOptionsControl | protected
panelControl2 (defined in Deltares.Standard.Forms.DExpress.ProgramOptionsControl) | Deltares.Standard.Forms.DExpress.ProgramOptionsControl | protected
ProgramOptionsControl() (defined in Deltares.Standard.Forms.DExpress.ProgramOptionsControl) | Deltares.Standard.Forms.DExpress.ProgramOptionsControl |
SelectedObject (defined in Deltares.Standard.Forms.DExpress.ProgramOptionsControl) | Deltares.Standard.Forms.DExpress.ProgramOptionsControl |
StartUpEdit (defined in Deltares.Standard.Forms.DExpress.ProgramOptionsControl) | Deltares.Standard.Forms.DExpress.ProgramOptionsControl | protected
Generated on Tue Dec 15 2015 18:15:12 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.ProgressDialog Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • ProgressDialog
Public Member Functions | Protected Member Functions | Properties | List of all members
Deltares.Standard.Forms.DExpress.ProgressDialog Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.ProgressDialog:

Public Member Functions

ProgressDialog (string preSetMessage="")
Constructor More...
void | SetMessage (string msg)
Set progress message More...
void | SetProgress (double fraction)
Set progress bar to given value (double) More...
void | SetProgress (float fraction)
Set progress bar to given value (float) More...

Protected Member Functions

override void Dispose (bool disposing)
Clean up any resources being used. More...

Properties

Image | ProgressBackgroundImage [get, set]
Progress background image More...
override CreateParams | CreateParams [get]

Constructor & Destructor Documentation

Deltares.Standard.Forms.DExpress.ProgressDialog.ProgressDialog ( string preSetMessage = "" )

Constructor

Member Function Documentation

override void Deltares.Standard.Forms.DExpress.ProgressDialog.Dispose ( bool disposing )
protected

Clean up any resources being used.

Parameters
disposing true if managed resources should be disposed; otherwise, false.
void Deltares.Standard.Forms.DExpress.ProgressDialog.SetMessage ( string msg )

Set progress message

Parameters
msg
void Deltares.Standard.Forms.DExpress.ProgressDialog.SetProgress ( double fraction )

Set progress bar to given value (double)

Parameters
fraction
void Deltares.Standard.Forms.DExpress.ProgressDialog.SetProgress ( float fraction )

Set progress bar to given value (float)

Parameters
fraction

Property Documentation

Image Deltares.Standard.Forms.DExpress.ProgressDialog.ProgressBackgroundImage
getset

Progress background image

Generated on Tue Dec 15 2015 18:15:12 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • ProgressDialog
Deltares.Standard.Forms.DExpress.ProgressDialog Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.ProgressDialog, including all inherited members.

CreateParams (defined in Deltares.Standard.Forms.DExpress.ProgressDialog) | Deltares.Standard.Forms.DExpress.ProgressDialog | protected
Dispose(bool disposing) | Deltares.Standard.Forms.DExpress.ProgressDialog | protected
ProgressBackgroundImage | Deltares.Standard.Forms.DExpress.ProgressDialog |
ProgressDialog(string preSetMessage="") | Deltares.Standard.Forms.DExpress.ProgressDialog |
SetMessage(string msg) | Deltares.Standard.Forms.DExpress.ProgressDialog |
SetProgress(double fraction) | Deltares.Standard.Forms.DExpress.ProgressDialog |
SetProgress(float fraction) | Deltares.Standard.Forms.DExpress.ProgressDialog |
Generated on Tue Dec 15 2015 18:15:12 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.PropertyControl Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • PropertyControl
Public Attributes | Protected Member Functions | Properties | List of all members
Deltares.Standard.Forms.DExpress.PropertyControl Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.PropertyControl:
Deltares.Standard.Forms.IPropertyControl

Public Attributes

Func< object, object > | SelectedObjectSelector
Func< object, bool > | VisiblityDelegate

Protected Member Functions

override void Dispose (bool disposing)
Clean up any resources being used. More...

Properties

object | SelectedObject [get, set]
bool | IsVisible [get]
- Properties inherited from Deltares.Standard.Forms.IPropertyControl
string | Name [get, set]
Gets or sets the name to be displayed property. More...
object | SelectedObject [get, set]
Gets or sets the object to be displayed in the property window. More...
bool | IsVisible [get]
Whether or not the property control should be displayed. More...

Member Function Documentation

override void Deltares.Standard.Forms.DExpress.PropertyControl.Dispose ( bool disposing )
protected

Clean up any resources being used.

Parameters
disposing true if managed resources should be disposed; otherwise, false.
Generated on Tue Dec 15 2015 18:15:12 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • PropertyControl
Deltares.Standard.Forms.DExpress.PropertyControl Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.PropertyControl, including all inherited members.

Dispose(bool disposing) | Deltares.Standard.Forms.DExpress.PropertyControl | protected
IsVisible (defined in Deltares.Standard.Forms.DExpress.PropertyControl) | Deltares.Standard.Forms.DExpress.PropertyControl |
Name | Deltares.Standard.Forms.IPropertyControl |
PropertyControl() (defined in Deltares.Standard.Forms.DExpress.PropertyControl) | Deltares.Standard.Forms.DExpress.PropertyControl |
SelectedObject (defined in Deltares.Standard.Forms.DExpress.PropertyControl) | Deltares.Standard.Forms.DExpress.PropertyControl |
SelectedObjectSelector (defined in Deltares.Standard.Forms.DExpress.PropertyControl) | Deltares.Standard.Forms.DExpress.PropertyControl |
VisiblityDelegate (defined in Deltares.Standard.Forms.DExpress.PropertyControl) | Deltares.Standard.Forms.DExpress.PropertyControl |
Generated on Tue Dec 15 2015 18:15:12 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.PropertyControlFactory< T > Class Template Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • PropertyControlFactory
Static Public Member Functions | List of all members
Deltares.Standard.Forms.DExpress.PropertyControlFactory< T > Class Template Reference

A factory to dynamically create property controls for data classes. (easiest way to use this is from the mainform: MainForm.CreateAndRegisterPropertyFormFor<T>(System.Linq.Expressions.Expression<System.Func<T,object>>[]) More...

Static Public Member Functions

static PropertyControl | GetPropertyControlUsingCustomSelector (Func< object, object > selector, params Expression< Func< T, object >>[] includedProperties)
Returns a dynamically created Property Control based on a data type. All data bindings are set on the returned control. More...
static PropertyControl | GetPropertyControl (params Expression< Func< T, object >>[] includedProperties)
Returns a dynamically created Property Control based on a data type. All data bindings are set on the returned control. More...
static PropertyControl | GetPropertyControl (Expression< Func< T, object >>[] includedProperties, Expression< Action< T >>[] includedMethods)
Returns a dynamically created Property Control based on a data type. All data bindings are set on the returned control. More...
static PropertyControl | GetPropertyControlForType (Type type)
Returns a dynamically created Property Control based on a data type. All data bindings are set on the return control. More...

Detailed Description

A factory to dynamically create property controls for data classes. (easiest way to use this is from the mainform: MainForm.CreateAndRegisterPropertyFormFor<T>(System.Linq.Expressions.Expression<System.Func<T,object>>[])

All non browsable properties are skipped, as is the "Item" property (not sure why though)

The properties are grouped per category, as specified by the Category Attribute. Within a category, properties are grouped by property order, as specified by the Property Order attribute

Using the RegisteredSubControlFactories, clients can register custom ISubControlFactories. These are used to create the actual controls for the properties.

There is a known bug for properties of type List<T> where T is a simple value type, e.g. int or double. The subcontrol factory default is to create a GridViewControl, but bind support fails for these simple types.

Template Parameters
T The type of the data object for which this factory creates property controls

Member Function Documentation

static PropertyControl Deltares.Standard.Forms.DExpress.PropertyControlFactory< T >.GetPropertyControl ( params Expression< Func< T, object >>[] includedProperties )
static

Returns a dynamically created Property Control based on a data type. All data bindings are set on the returned control.

Parameters
includedProperties The set with properties to generate editors/controls for, leave it empty or null to generate all
Returns
A constructed PropertyControl

Referenced by Deltares.Standard.Forms.DExpress.MainForm.CreateAndRegisterPropertyFormFor< T >().

static PropertyControl Deltares.Standard.Forms.DExpress.PropertyControlFactory< T >.GetPropertyControl | ( | Expression< Func< T, object >>[] | includedProperties,
 |  | Expression< Action< T >>[] | includedMethods
 | ) |  |
static

Returns a dynamically created Property Control based on a data type. All data bindings are set on the returned control.

Parameters
includedProperties | The set with properties to generate editors/controls for, leave it empty or null to generate all
includedMethods | The set with methods to generate buttons for, leave it empty or null to generate all
Returns
A constructed PropertyControl
static PropertyControl Deltares.Standard.Forms.DExpress.PropertyControlFactory< T >.GetPropertyControlForType ( Type type )
static

Returns a dynamically created Property Control based on a data type. All data bindings are set on the return control.

Parameters
type The type for which to create the property control. This can be specified at runtime, but that means no nice lambda expression for the incluced properties. If you want that, you need to do some work on PropertyControlFactory
Returns
static PropertyControl Deltares.Standard.Forms.DExpress.PropertyControlFactory< T >.GetPropertyControlUsingCustomSelector | ( | Func< object, object > | selector,
 |  | params Expression< Func< T, object >>[] | includedProperties
 | ) |  |
static

Returns a dynamically created Property Control based on a data type. All data bindings are set on the returned control.

Parameters
selector | A custom function to handle selection of an object from another object
includedProperties | The set with properties to generate editors/controls for, leave it empty or null to generate all
Returns
A constructed PropertyControl
Generated on Tue Dec 15 2015 18:15:12 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • PropertyControlFactory
Deltares.Standard.Forms.DExpress.PropertyControlFactory< T > Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.PropertyControlFactory< T >, including all inherited members.

GetPropertyControl(params Expression< Func< T, object >>[] includedProperties) | Deltares.Standard.Forms.DExpress.PropertyControlFactory< T > | static
GetPropertyControl(Expression< Func< T, object >>[] includedProperties, Expression< Action< T >>[] includedMethods) | Deltares.Standard.Forms.DExpress.PropertyControlFactory< T > | static
GetPropertyControlForType(Type type) | Deltares.Standard.Forms.DExpress.PropertyControlFactory< T > | static
GetPropertyControlUsingCustomSelector(Func< object, object > selector, params Expression< Func< T, object >>[] includedProperties) | Deltares.Standard.Forms.DExpress.PropertyControlFactory< T > | static
Generated on Tue Dec 15 2015 18:15:12 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.RadioButtonBinding Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • RadioButtonBinding
Public Member Functions | List of all members
Deltares.Standard.Forms.DExpress.RadioButtonBinding Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.RadioButtonBinding:
Deltares.Standard.Forms.DExpress.ControlBinding Deltares.Standard.Forms.DExpress.ComponentBinding Deltares.Standard.Forms.DExpress.ComponentWrappers.IGetBoundControl

Public Member Functions

RadioButtonBinding (Component component)
override void | Initialize (BindPropertyInfo propertyInfo, params string[] properties)
override void | SetTrueMapping (object trueMapping)
override void | SetValue (object value)
override object | GetValue ()
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.ControlBinding
override void | SetVisible (bool visible)
override void | SetEnabled (bool enabled)
override void | SetLabel (string text)
Sets the label/title/name associated with this control. More...
override void | SetDescription (string description)
Sets the textual description associated with this control. More...
override void | SetForegroundColor (Color color)
override void | SetBackgroundColor (Color color)
override void | Invalidate ()
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
ComponentBinding (Component component)
virtual void | Initialize (BindPropertyInfo propertyInfo, Type rootObjectType, params string[] properties)
virtual void | SetValue (object value, object parent)
virtual void | SetDomain (ICollection collection)
virtual void | Refresh ()
virtual void | RegisterSelectionAssignment (Component targetComponent, IConverter converter=null)
Indicates that the selection of the bound control must be assigned to another control. More...
virtual void | SetControlColors (Color fore, Color back)
Sets the controls foreground and background colors. Can be overridden by a specific binding to set other colors if necessary. More...

Additional Inherited Members

- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.ControlBinding
ControlBinding (Component component)
virtual void | OnToolTipShown (PopupEventArgs e)
Called when Tooltip is shown, and fires ToolTipShown event. More...
virtual void | OnToolTipClosed ()
Called when Tooltip is hidden, and fires ToolTipHidden. More...
void | ThreadSafeRefresh ()
override void | Dispose (bool disposing)
- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
void | RaiseValueChanged ()
void | RaiseLeave ()
void | RaiseActionPerformed ()
Type | GetGenericType (Type type)
string | ValueToString (object value)
bool | IsAssociatedPropertyVisible (object source, BindPropertyInfo associatedPropertyInfo)
Indicates whether the associated property (i.e. the property which is used to display the original property in a textbox) is visible More...
void | EditFileInfo (object source, BindPropertyInfo propertyInfo)
string | EditFileInfo (string value, string format, string label, string description, bool isDirectory)
string | GetDoubleString (string text)
bool | HasValidNumericValue (string text)
double | GetNumericValue (string text)
List< BindPropertyInfo > | GetDictionaryProperties (ICollection domain, BindPropertyInfo dynamicPropertyInfo)
- Protected Attributes inherited from Deltares.Standard.Forms.DExpress.ControlBinding
readonly ToolTip | tooltip
string | Description
The textual description associated with this

See also
Control

. More...

string | Label
The label/title/name associated with this Control. More...
- Protected Attributes inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
BindPropertyInfo | propInfo
- Properties inherited from Deltares.Standard.Forms.DExpress.ControlBinding
ToolTip | Tooltip [get]
Gets the tooltip for the bound control. More...
Control | BoundControl [get]
- Properties inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
Component | Component [get]
virtual bool | IsTransparant [get]
virtual HandleType | HandleDelayed [get]
virtual bool | HasDomain [get]
- Properties inherited from Deltares.Standard.Forms.DExpress.ComponentWrappers.IGetBoundControl
Control | BoundControl [get]
- Events inherited from Deltares.Standard.Forms.DExpress.ControlBinding
ToolTipVisibilityEventHandler | ToolTipHidden
ToolTipVisibilityEventHandler | ToolTipShown
- Events inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
EventHandler< EventArgs > | ActionPerformed
EventHandler< EventArgs > | Leave
EventHandler< EventArgs > | ValueChanged
Generated on Tue Dec 15 2015 18:15:13 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • RadioButtonBinding
Deltares.Standard.Forms.DExpress.RadioButtonBinding Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.RadioButtonBinding, including all inherited members.

ActionPerformed (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
BoundControl (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding |
Component (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ComponentBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ControlBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Description | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Dispose(bool disposing) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | protected
EditFileInfo(object source, BindPropertyInfo propertyInfo) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
EditFileInfo(string value, string format, string label, string description, bool isDirectory) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetDictionaryProperties(ICollection domain, BindPropertyInfo dynamicPropertyInfo) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetDoubleString(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetGenericType(Type type) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetNumericValue(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetValue() (defined in Deltares.Standard.Forms.DExpress.RadioButtonBinding) | Deltares.Standard.Forms.DExpress.RadioButtonBinding | virtual
HandleDelayed (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
HasDomain (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
HasValidNumericValue(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Initialize(BindPropertyInfo propertyInfo, params string[] properties) (defined in Deltares.Standard.Forms.DExpress.RadioButtonBinding) | Deltares.Standard.Forms.DExpress.RadioButtonBinding | virtual
Initialize(BindPropertyInfo propertyInfo, Type rootObjectType, params string[] properties) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
Invalidate() (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
IsAssociatedPropertyVisible(object source, BindPropertyInfo associatedPropertyInfo) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
IsTransparant (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
Label | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Leave (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
OnToolTipClosed() | Deltares.Standard.Forms.DExpress.ControlBinding | protectedvirtual
OnToolTipShown(PopupEventArgs e) | Deltares.Standard.Forms.DExpress.ControlBinding | protectedvirtual
propInfo (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RadioButtonBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.RadioButtonBinding) | Deltares.Standard.Forms.DExpress.RadioButtonBinding |
RaiseActionPerformed() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseLeave() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseValueChanged() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Refresh() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
RegisterSelectionAssignment(Component targetComponent, IConverter converter=null) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetBackgroundColor(Color color) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
SetControlColors(Color fore, Color back) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetDescription(string description) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
SetDomain(ICollection collection) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetEnabled(bool enabled) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
SetForegroundColor(Color color) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
SetLabel(string text) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
SetTrueMapping(object trueMapping) (defined in Deltares.Standard.Forms.DExpress.RadioButtonBinding) | Deltares.Standard.Forms.DExpress.RadioButtonBinding | virtual
SetValue(object value) (defined in Deltares.Standard.Forms.DExpress.RadioButtonBinding) | Deltares.Standard.Forms.DExpress.RadioButtonBinding | virtual
SetValue(object value, object parent) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetVisible(bool visible) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
ThreadSafeRefresh() (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | protected
tooltip (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Tooltip | Deltares.Standard.Forms.DExpress.ControlBinding | protected
ToolTipHidden (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding |
ToolTipShown (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding |
ValueChanged (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ValueToString(object value) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Generated on Tue Dec 15 2015 18:15:13 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.RadioGroupBinding Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • RadioGroupBinding
Public Member Functions | Properties | List of all members
Deltares.Standard.Forms.DExpress.RadioGroupBinding Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.RadioGroupBinding:
Deltares.Standard.Forms.DExpress.BaseControlBinding Deltares.Standard.Forms.DExpress.ControlBinding Deltares.Standard.Forms.DExpress.ComponentBinding Deltares.Standard.Forms.DExpress.ComponentWrappers.IGetBoundControl

Public Member Functions

RadioGroupBinding (Component component)
override void | Initialize (BindPropertyInfo propertyInfo, params string[] properties)
override void | SetDomain (ICollection domain)
override void | SetValue (object value)
override object | GetValue ()
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.BaseControlBinding
override void | SetLabel (string text)
override void | SetDescription (string description)
override void | Invalidate ()
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.ControlBinding
override void | SetVisible (bool visible)
override void | SetEnabled (bool enabled)
override void | SetLabel (string text)
Sets the label/title/name associated with this control. More...
override void | SetDescription (string description)
Sets the textual description associated with this control. More...
override void | SetForegroundColor (Color color)
override void | SetBackgroundColor (Color color)
override void | Invalidate ()
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
ComponentBinding (Component component)
virtual void | Initialize (BindPropertyInfo propertyInfo, Type rootObjectType, params string[] properties)
virtual void | SetTrueMapping (object trueMapping)
virtual void | SetValue (object value, object parent)
virtual void | Refresh ()
virtual void | RegisterSelectionAssignment (Component targetComponent, IConverter converter=null)
Indicates that the selection of the bound control must be assigned to another control. More...
virtual void | SetControlColors (Color fore, Color back)
Sets the controls foreground and background colors. Can be overridden by a specific binding to set other colors if necessary. More...

Properties

override bool | IsTransparant [get]
override bool | HasDomain [get]
- Properties inherited from Deltares.Standard.Forms.DExpress.ControlBinding
ToolTip | Tooltip [get]
Gets the tooltip for the bound control. More...
Control | BoundControl [get]
- Properties inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
Component | Component [get]
virtual bool | IsTransparant [get]
virtual HandleType | HandleDelayed [get]
virtual bool | HasDomain [get]
- Properties inherited from Deltares.Standard.Forms.DExpress.ComponentWrappers.IGetBoundControl
Control | BoundControl [get]

Additional Inherited Members

- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.BaseControlBinding
BaseControlBinding (Component component)
DXPopupMenu | GetPopupMenu ()
This method uses reflection to make the context menu accessible, which otherwise is protected. The Menu property is implemented for TextEdit, so we first make sure the control is actually of this type. More...
override void | OnToolTipShown (PopupEventArgs e)
Called when Tooltip is shown, and fires ToolTipShown event. More...
override void | OnToolTipClosed ()
Called when Tooltip is hidden, and fires ToolTipHidden. More...
override void | Dispose (bool disposing)
- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.ControlBinding
ControlBinding (Component component)
void | ThreadSafeRefresh ()
override void | Dispose (bool disposing)
- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
void | RaiseValueChanged ()
void | RaiseLeave ()
void | RaiseActionPerformed ()
Type | GetGenericType (Type type)
string | ValueToString (object value)
bool | IsAssociatedPropertyVisible (object source, BindPropertyInfo associatedPropertyInfo)
Indicates whether the associated property (i.e. the property which is used to display the original property in a textbox) is visible More...
void | EditFileInfo (object source, BindPropertyInfo propertyInfo)
string | EditFileInfo (string value, string format, string label, string description, bool isDirectory)
string | GetDoubleString (string text)
bool | HasValidNumericValue (string text)
double | GetNumericValue (string text)
List< BindPropertyInfo > | GetDictionaryProperties (ICollection domain, BindPropertyInfo dynamicPropertyInfo)
- Protected Attributes inherited from Deltares.Standard.Forms.DExpress.BaseControlBinding
readonly SuperToolTip | superTip
- Protected Attributes inherited from Deltares.Standard.Forms.DExpress.ControlBinding
readonly ToolTip | tooltip
string | Description
The textual description associated with this

See also
Control

. More...

string | Label
The label/title/name associated with this Control. More...
- Protected Attributes inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
BindPropertyInfo | propInfo
- Events inherited from Deltares.Standard.Forms.DExpress.ControlBinding
ToolTipVisibilityEventHandler | ToolTipHidden
ToolTipVisibilityEventHandler | ToolTipShown
- Events inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
EventHandler< EventArgs > | ActionPerformed
EventHandler< EventArgs > | Leave
EventHandler< EventArgs > | ValueChanged
Generated on Tue Dec 15 2015 18:15:13 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • RadioGroupBinding
Deltares.Standard.Forms.DExpress.RadioGroupBinding Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.RadioGroupBinding, including all inherited members.

ActionPerformed (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
BaseControlBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.BaseControlBinding) | Deltares.Standard.Forms.DExpress.BaseControlBinding | protected
BoundControl (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding |
Component (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ComponentBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ControlBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Description | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Dispose(bool disposing) (defined in Deltares.Standard.Forms.DExpress.BaseControlBinding) | Deltares.Standard.Forms.DExpress.BaseControlBinding | protected
EditFileInfo(object source, BindPropertyInfo propertyInfo) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
EditFileInfo(string value, string format, string label, string description, bool isDirectory) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetDictionaryProperties(ICollection domain, BindPropertyInfo dynamicPropertyInfo) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetDoubleString(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetGenericType(Type type) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetNumericValue(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetPopupMenu() | Deltares.Standard.Forms.DExpress.BaseControlBinding | protected
GetValue() (defined in Deltares.Standard.Forms.DExpress.RadioGroupBinding) | Deltares.Standard.Forms.DExpress.RadioGroupBinding | virtual
HandleDelayed (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
HasDomain (defined in Deltares.Standard.Forms.DExpress.RadioGroupBinding) | Deltares.Standard.Forms.DExpress.RadioGroupBinding |
HasValidNumericValue(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Initialize(BindPropertyInfo propertyInfo, params string[] properties) (defined in Deltares.Standard.Forms.DExpress.RadioGroupBinding) | Deltares.Standard.Forms.DExpress.RadioGroupBinding | virtual
Initialize(BindPropertyInfo propertyInfo, Type rootObjectType, params string[] properties) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
Invalidate() (defined in Deltares.Standard.Forms.DExpress.BaseControlBinding) | Deltares.Standard.Forms.DExpress.BaseControlBinding | virtual
IsAssociatedPropertyVisible(object source, BindPropertyInfo associatedPropertyInfo) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
IsTransparant (defined in Deltares.Standard.Forms.DExpress.RadioGroupBinding) | Deltares.Standard.Forms.DExpress.RadioGroupBinding |
Label | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Leave (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
OnToolTipClosed() | Deltares.Standard.Forms.DExpress.BaseControlBinding | protectedvirtual
OnToolTipShown(PopupEventArgs e) | Deltares.Standard.Forms.DExpress.BaseControlBinding | protectedvirtual
propInfo (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RadioGroupBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.RadioGroupBinding) | Deltares.Standard.Forms.DExpress.RadioGroupBinding |
RaiseActionPerformed() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseLeave() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseValueChanged() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Refresh() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
RegisterSelectionAssignment(Component targetComponent, IConverter converter=null) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetBackgroundColor(Color color) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
SetControlColors(Color fore, Color back) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetDescription(string description) (defined in Deltares.Standard.Forms.DExpress.BaseControlBinding) | Deltares.Standard.Forms.DExpress.BaseControlBinding | virtual
SetDomain(ICollection domain) (defined in Deltares.Standard.Forms.DExpress.RadioGroupBinding) | Deltares.Standard.Forms.DExpress.RadioGroupBinding | virtual
SetEnabled(bool enabled) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
SetForegroundColor(Color color) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
SetLabel(string text) (defined in Deltares.Standard.Forms.DExpress.BaseControlBinding) | Deltares.Standard.Forms.DExpress.BaseControlBinding | virtual
SetTrueMapping(object trueMapping) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetValue(object value) (defined in Deltares.Standard.Forms.DExpress.RadioGroupBinding) | Deltares.Standard.Forms.DExpress.RadioGroupBinding | virtual
SetValue(object value, object parent) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetVisible(bool visible) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
superTip (defined in Deltares.Standard.Forms.DExpress.BaseControlBinding) | Deltares.Standard.Forms.DExpress.BaseControlBinding | protected
ThreadSafeRefresh() (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Tooltip | Deltares.Standard.Forms.DExpress.ControlBinding | protected
tooltip (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | protected
ToolTipHidden (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding |
ToolTipShown (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding |
ValueChanged (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ValueToString(object value) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Generated on Tue Dec 15 2015 18:15:13 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.RasterLayerDefinition Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • RasterLayerDefinition
Public Member Functions | Properties | List of all members
Deltares.Standard.Forms.DExpress.RasterLayerDefinition Class Reference

Public Member Functions

RasterLayerDefinition (ColorScheme scheme)
RasterLayerDefinition (Color lowColor, Color highColor, int intervals)
RasterLayerDefinition (Color lowColor, Color highColor, params double[] boundaries)
RasterLayerDefinition (Color[] colors, params double[] boundaries)

Properties

ColorScheme | Scheme [get]
Color | LowColor [get]
Color | HighColor [get]
int | Intervals [get]
double[] | Boundaries [get]
Color[] | Colors [get]
Generated on Tue Dec 15 2015 18:15:13 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • RasterLayerDefinition
Deltares.Standard.Forms.DExpress.RasterLayerDefinition Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.RasterLayerDefinition, including all inherited members.

Boundaries (defined in Deltares.Standard.Forms.DExpress.RasterLayerDefinition) | Deltares.Standard.Forms.DExpress.RasterLayerDefinition
Colors (defined in Deltares.Standard.Forms.DExpress.RasterLayerDefinition) | Deltares.Standard.Forms.DExpress.RasterLayerDefinition
HighColor (defined in Deltares.Standard.Forms.DExpress.RasterLayerDefinition) | Deltares.Standard.Forms.DExpress.RasterLayerDefinition
Intervals (defined in Deltares.Standard.Forms.DExpress.RasterLayerDefinition) | Deltares.Standard.Forms.DExpress.RasterLayerDefinition
LowColor (defined in Deltares.Standard.Forms.DExpress.RasterLayerDefinition) | Deltares.Standard.Forms.DExpress.RasterLayerDefinition
RasterLayerDefinition(ColorScheme scheme) (defined in Deltares.Standard.Forms.DExpress.RasterLayerDefinition) | Deltares.Standard.Forms.DExpress.RasterLayerDefinition
RasterLayerDefinition(Color lowColor, Color highColor, int intervals) (defined in Deltares.Standard.Forms.DExpress.RasterLayerDefinition) | Deltares.Standard.Forms.DExpress.RasterLayerDefinition
RasterLayerDefinition(Color lowColor, Color highColor, params double[] boundaries) (defined in Deltares.Standard.Forms.DExpress.RasterLayerDefinition) | Deltares.Standard.Forms.DExpress.RasterLayerDefinition
RasterLayerDefinition(Color[] colors, params double[] boundaries) (defined in Deltares.Standard.Forms.DExpress.RasterLayerDefinition) | Deltares.Standard.Forms.DExpress.RasterLayerDefinition
Scheme (defined in Deltares.Standard.Forms.DExpress.RasterLayerDefinition) | Deltares.Standard.Forms.DExpress.RasterLayerDefinition
Generated on Tue Dec 15 2015 18:15:13 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.RegisteredSubControlFactories Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • RegisteredSubControlFactories
Public Member Functions | Static Public Member Functions | List of all members
Deltares.Standard.Forms.DExpress.RegisteredSubControlFactories Class Reference

class that manages IPropertySubControlFactory objects, so the PropertyControlFactory can get them to create controls for properties. More...

Public Member Functions

IPropertySubControlFactory< Control > | FindSubControlFactoryForSuperType (Type type)
void | ResetDefaultFactories ()

Static Public Member Functions

static IPropertySubControlFactory< Control > | GetSubControlFactory (Type type)
static void | RegisterSubControlFactory (IPropertySubControlFactory< Control > factory)

Detailed Description

class that manages IPropertySubControlFactory objects, so the PropertyControlFactory can get them to create controls for properties.

does NOT support different factories for generic types. I.e. no two different factories can be registered for List<double> and List<int>

this can probably made a bit more customizable by checking for assignability, but I don't feel like implementing this now. But feel free to implement this.

singleton pattern

Generated on Tue Dec 15 2015 18:15:13 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • RegisteredSubControlFactories
Deltares.Standard.Forms.DExpress.RegisteredSubControlFactories Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.RegisteredSubControlFactories, including all inherited members.

FindSubControlFactoryForSuperType(Type type) (defined in Deltares.Standard.Forms.DExpress.RegisteredSubControlFactories) | Deltares.Standard.Forms.DExpress.RegisteredSubControlFactories |
GetSubControlFactory(Type type) (defined in Deltares.Standard.Forms.DExpress.RegisteredSubControlFactories) | Deltares.Standard.Forms.DExpress.RegisteredSubControlFactories | static
RegisterSubControlFactory(IPropertySubControlFactory< Control > factory) (defined in Deltares.Standard.Forms.DExpress.RegisteredSubControlFactories) | Deltares.Standard.Forms.DExpress.RegisteredSubControlFactories | static
ResetDefaultFactories() (defined in Deltares.Standard.Forms.DExpress.RegisteredSubControlFactories) | Deltares.Standard.Forms.DExpress.RegisteredSubControlFactories |
Generated on Tue Dec 15 2015 18:15:13 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.ReloadManager Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • ReloadManager
Public Member Functions | Properties | List of all members
Deltares.Standard.Forms.DExpress.ReloadManager Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.ReloadManager:
Deltares.Standard.Forms.IReloadManager

Public Member Functions

void | AddComponent (object sender, EventArgs aEventArgs)
Adds the registred forms to this.formList,Sets the (LocalizationHelper,SetMessageBoxHelper,Culture) for all forms More...
void | RemoveComponent (object sender, EventArgs aEventArgs)
Removes the components from this.formList More...
void | SetLanguage (string aXmlPath, string aXsdPath, string aLanguage)
Sets the given language xmlpath xsdpath and the default language More...
void | ApplyCurrentUiCultureToAll ()
applies current culture to all forms More...
void | ApplyCurrentUiCulture (IReloadableUI aform)
apply culture to given from More...
void | ApplyDataChangeToAll (List< object > models)
applies the model change to all the registered dialogs More...
void | ApplyCulture (IReloadableUI aform)
applies given "aCurrentUiLanguage" culture to given form "aform" More...

Properties

IReloadableUI[] | Forms [get]
- Properties inherited from Deltares.Standard.Forms.IReloadManager
IReloadableUI[] | Forms [get]

Member Function Documentation

void Deltares.Standard.Forms.DExpress.ReloadManager.AddComponent | ( | object | sender,
 |  | EventArgs | aEventArgs
 | ) |  |

Adds the registred forms to this.formList,Sets the (LocalizationHelper,SetMessageBoxHelper,Culture) for all forms

Parameters
sender
aEventArgs

Implements Deltares.Standard.Forms.IReloadManager.

void Deltares.Standard.Forms.DExpress.ReloadManager.ApplyCulture ( IReloadableUI aform )

applies given "aCurrentUiLanguage" culture to given form "aform"

Parameters
aform

Implements Deltares.Standard.Forms.IReloadManager.

void Deltares.Standard.Forms.DExpress.ReloadManager.ApplyCurrentUiCulture ( IReloadableUI aform )

apply culture to given from

Parameters
aform

Implements Deltares.Standard.Forms.IReloadManager.

void Deltares.Standard.Forms.DExpress.ReloadManager.ApplyCurrentUiCultureToAll ( )

applies current culture to all forms

Implements Deltares.Standard.Forms.IReloadManager.

References Deltares.Standard.Forms.DExpress.BindSupport.UpdateAll().

void Deltares.Standard.Forms.DExpress.ReloadManager.ApplyDataChangeToAll ( List< object > models )

applies the model change to all the registered dialogs

Parameters
models

Implements Deltares.Standard.Forms.IReloadManager.

void Deltares.Standard.Forms.DExpress.ReloadManager.RemoveComponent | ( | object | sender,
 |  | EventArgs | aEventArgs
 | ) |  |

Removes the components from this.formList

Parameters
sender
aEventArgs

Implements Deltares.Standard.Forms.IReloadManager.

void Deltares.Standard.Forms.DExpress.ReloadManager.SetLanguage | ( | string | aXmlPath,
 |  | string | aXsdPath,
 |  | string | aLanguage
 | ) |  |

Sets the given language xmlpath xsdpath and the default language

Parameters
aXmlPath
aXsdPath
aLanguage

Implements Deltares.Standard.Forms.IReloadManager.

Generated on Tue Dec 15 2015 18:15:13 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • ReloadManager
Deltares.Standard.Forms.DExpress.ReloadManager Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.ReloadManager, including all inherited members.

AddComponent(object sender, EventArgs aEventArgs) | Deltares.Standard.Forms.DExpress.ReloadManager
ApplyCulture(IReloadableUI aform) | Deltares.Standard.Forms.DExpress.ReloadManager
ApplyCurrentUiCulture(IReloadableUI aform) | Deltares.Standard.Forms.DExpress.ReloadManager
ApplyCurrentUiCultureToAll() | Deltares.Standard.Forms.DExpress.ReloadManager
ApplyDataChangeToAll(List< object > models) | Deltares.Standard.Forms.DExpress.ReloadManager
Forms (defined in Deltares.Standard.Forms.DExpress.ReloadManager) | Deltares.Standard.Forms.DExpress.ReloadManager
ReloadManager() (defined in Deltares.Standard.Forms.DExpress.ReloadManager) | Deltares.Standard.Forms.DExpress.ReloadManager
RemoveComponent(object sender, EventArgs aEventArgs) | Deltares.Standard.Forms.DExpress.ReloadManager
SetLanguage(string aXmlPath, string aXsdPath, string aLanguage) | Deltares.Standard.Forms.DExpress.ReloadManager
Generated on Tue Dec 15 2015 18:15:13 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.Report Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • Report
Public Member Functions | Properties | List of all members
Deltares.Standard.Forms.DExpress.Report Class Reference

Public Member Functions

void | Add (ReportItemType reportItemType, Type type, params string[] properties)
void | AddProperties (Type type, params string[] properties)
XtraReport | CreateDocument (object source)
void | CreateIndex (object source)

Properties

List< ReportItem > | ReportItems [get]
ReportChapter | MainChapter [get]
Generated on Tue Dec 15 2015 18:15:13 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • Report
Deltares.Standard.Forms.DExpress.Report Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.Report, including all inherited members.

Add(ReportItemType reportItemType, Type type, params string[] properties) (defined in Deltares.Standard.Forms.DExpress.Report) | Deltares.Standard.Forms.DExpress.Report
AddProperties(Type type, params string[] properties) (defined in Deltares.Standard.Forms.DExpress.Report) | Deltares.Standard.Forms.DExpress.Report
CreateDocument(object source) (defined in Deltares.Standard.Forms.DExpress.Report) | Deltares.Standard.Forms.DExpress.Report
CreateIndex(object source) (defined in Deltares.Standard.Forms.DExpress.Report) | Deltares.Standard.Forms.DExpress.Report
MainChapter (defined in Deltares.Standard.Forms.DExpress.Report) | Deltares.Standard.Forms.DExpress.Report
Report() (defined in Deltares.Standard.Forms.DExpress.Report) | Deltares.Standard.Forms.DExpress.Report
ReportItems (defined in Deltares.Standard.Forms.DExpress.Report) | Deltares.Standard.Forms.DExpress.Report
Generated on Tue Dec 15 2015 18:15:13 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.ReportChapter Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • ReportChapter
Properties | List of all members
Deltares.Standard.Forms.DExpress.ReportChapter Class Reference

Properties

string | Name [get, set]
bool | Visible [get, set]
IList< ReportChapter > | SubChapters [get]
ReportItem | ReportItem [get, set]
ReportChapter | ParentChapter [get]
Generated on Tue Dec 15 2015 18:15:13 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • ReportChapter
Deltares.Standard.Forms.DExpress.ReportChapter Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.ReportChapter, including all inherited members.

Name (defined in Deltares.Standard.Forms.DExpress.ReportChapter) | Deltares.Standard.Forms.DExpress.ReportChapter
ParentChapter (defined in Deltares.Standard.Forms.DExpress.ReportChapter) | Deltares.Standard.Forms.DExpress.ReportChapter
ReportChapter() (defined in Deltares.Standard.Forms.DExpress.ReportChapter) | Deltares.Standard.Forms.DExpress.ReportChapter
ReportItem (defined in Deltares.Standard.Forms.DExpress.ReportChapter) | Deltares.Standard.Forms.DExpress.ReportChapter
SubChapters (defined in Deltares.Standard.Forms.DExpress.ReportChapter) | Deltares.Standard.Forms.DExpress.ReportChapter
Visible (defined in Deltares.Standard.Forms.DExpress.ReportChapter) | Deltares.Standard.Forms.DExpress.ReportChapter
Generated on Tue Dec 15 2015 18:15:13 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.ReportControl Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • ReportControl
Protected Member Functions | Properties | List of all members
Deltares.Standard.Forms.DExpress.ReportControl Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.ReportControl:
Deltares.Standard.Forms.IPropertyControl

Protected Member Functions

override void Dispose (bool disposing)
Clean up any resources being used. More...

Properties

bool | IsVisible [get]
object | SelectedObject [get, set]
- Properties inherited from Deltares.Standard.Forms.IPropertyControl
string | Name [get, set]
Gets or sets the name to be displayed property. More...
object | SelectedObject [get, set]
Gets or sets the object to be displayed in the property window. More...
bool | IsVisible [get]
Whether or not the property control should be displayed. More...

Member Function Documentation

override void Deltares.Standard.Forms.DExpress.ReportControl.Dispose ( bool disposing )
protected

Clean up any resources being used.

Parameters
disposing true if managed resources should be disposed; otherwise, false.
Generated on Tue Dec 15 2015 18:15:14 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • ReportControl
Deltares.Standard.Forms.DExpress.ReportControl Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.ReportControl, including all inherited members.

Dispose(bool disposing) | Deltares.Standard.Forms.DExpress.ReportControl | protected
IsVisible (defined in Deltares.Standard.Forms.DExpress.ReportControl) | Deltares.Standard.Forms.DExpress.ReportControl |
Name | Deltares.Standard.Forms.IPropertyControl |
ReportControl() (defined in Deltares.Standard.Forms.DExpress.ReportControl) | Deltares.Standard.Forms.DExpress.ReportControl |
SelectedObject (defined in Deltares.Standard.Forms.DExpress.ReportControl) | Deltares.Standard.Forms.DExpress.ReportControl |
Generated on Tue Dec 15 2015 18:15:14 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.ReportDlg Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • ReportDlg
Public Member Functions | Protected Member Functions | Properties | List of all members
Deltares.Standard.Forms.DExpress.ReportDlg Class Reference

Form that displays a report document More...

Inheritance diagram for Deltares.Standard.Forms.DExpress.ReportDlg:

Public Member Functions

ReportDlg ()
Initializes a new instance of the ReportForm class More...
void | SetReportManagerTarget (object target)
void | UpdateReport ()
void | ShowReportTypeEdit (bool showTypeEdit)

Protected Member Functions

override void Dispose (bool disposing)
Clean up any resources being used. More...

Properties

XtraReport | Report [get, set]
Report | ReportDefinition [get, set]

Detailed Description

Form that displays a report document

Constructor & Destructor Documentation

Deltares.Standard.Forms.DExpress.ReportDlg.ReportDlg ( )

Initializes a new instance of the ReportForm class

Member Function Documentation

override void Deltares.Standard.Forms.DExpress.ReportDlg.Dispose ( bool disposing )
protected

Clean up any resources being used.

Parameters
disposing true if managed resources should be disposed; otherwise, false.
Generated on Tue Dec 15 2015 18:15:14 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • ReportDlg
Deltares.Standard.Forms.DExpress.ReportDlg Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.ReportDlg, including all inherited members.

Dispose(bool disposing) | Deltares.Standard.Forms.DExpress.ReportDlg | protected
Report (defined in Deltares.Standard.Forms.DExpress.ReportDlg) | Deltares.Standard.Forms.DExpress.ReportDlg |
ReportDefinition (defined in Deltares.Standard.Forms.DExpress.ReportDlg) | Deltares.Standard.Forms.DExpress.ReportDlg |
ReportDlg() | Deltares.Standard.Forms.DExpress.ReportDlg |
SetReportManagerTarget(object target) (defined in Deltares.Standard.Forms.DExpress.ReportDlg) | Deltares.Standard.Forms.DExpress.ReportDlg |
ShowReportTypeEdit(bool showTypeEdit) (defined in Deltares.Standard.Forms.DExpress.ReportDlg) | Deltares.Standard.Forms.DExpress.ReportDlg |
UpdateReport() (defined in Deltares.Standard.Forms.DExpress.ReportDlg) | Deltares.Standard.Forms.DExpress.ReportDlg |
Generated on Tue Dec 15 2015 18:15:14 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.ReportItem Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • ReportItem
Public Member Functions | Properties | List of all members
Deltares.Standard.Forms.DExpress.ReportItem Class Reference

Public Member Functions

ReportItem (ReportItemType reportItemType, Type type, params string[] properties)
override string ToString ()

Properties

ReportItemType | ReportItemType [get]
Type | Type [get]
string[] | Properties [get]
ReportChapter | Chapter [get, set]
Generated on Tue Dec 15 2015 18:15:14 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • ReportItem
Deltares.Standard.Forms.DExpress.ReportItem Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.ReportItem, including all inherited members.

Chapter (defined in Deltares.Standard.Forms.DExpress.ReportItem) | Deltares.Standard.Forms.DExpress.ReportItem
Properties (defined in Deltares.Standard.Forms.DExpress.ReportItem) | Deltares.Standard.Forms.DExpress.ReportItem
ReportItem(ReportItemType reportItemType, Type type, params string[] properties) (defined in Deltares.Standard.Forms.DExpress.ReportItem) | Deltares.Standard.Forms.DExpress.ReportItem
ReportItemType (defined in Deltares.Standard.Forms.DExpress.ReportItem) | Deltares.Standard.Forms.DExpress.ReportItem
ToString() (defined in Deltares.Standard.Forms.DExpress.ReportItem) | Deltares.Standard.Forms.DExpress.ReportItem
Type (defined in Deltares.Standard.Forms.DExpress.ReportItem) | Deltares.Standard.Forms.DExpress.ReportItem
Generated on Tue Dec 15 2015 18:15:14 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.ReportManager Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • ReportManager
Static Public Member Functions | List of all members
Deltares.Standard.Forms.DExpress.ReportManager Class Reference

Static Public Member Functions

static void | Register (Type type, Report report)
static Report | GetRegisteredReport (Type type)
Generated on Tue Dec 15 2015 18:15:14 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • ReportManager
Deltares.Standard.Forms.DExpress.ReportManager Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.ReportManager, including all inherited members.

GetRegisteredReport(Type type) (defined in Deltares.Standard.Forms.DExpress.ReportManager) | Deltares.Standard.Forms.DExpress.ReportManager | static
Register(Type type, Report report) (defined in Deltares.Standard.Forms.DExpress.ReportManager) | Deltares.Standard.Forms.DExpress.ReportManager | static
Generated on Tue Dec 15 2015 18:15:14 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.RepositoryItemTrackBarBinding Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • RepositoryItemTrackBarBinding
Public Member Functions | Properties | List of all members
Deltares.Standard.Forms.DExpress.RepositoryItemTrackBarBinding Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.RepositoryItemTrackBarBinding:
Deltares.Standard.Forms.DExpress.BaseControlBinding Deltares.Standard.Forms.DExpress.ControlBinding Deltares.Standard.Forms.DExpress.ComponentBinding Deltares.Standard.Forms.DExpress.ComponentWrappers.IGetBoundControl

Public Member Functions

RepositoryItemTrackBarBinding (Component component)
override void | Initialize (BindPropertyInfo propertyInfo, params string[] properties)
override void | SetValue (object value)
override object | GetValue ()
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.BaseControlBinding
override void | SetLabel (string text)
override void | SetDescription (string description)
override void | Invalidate ()
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.ControlBinding
override void | SetVisible (bool visible)
override void | SetEnabled (bool enabled)
override void | SetLabel (string text)
Sets the label/title/name associated with this control. More...
override void | SetDescription (string description)
Sets the textual description associated with this control. More...
override void | SetForegroundColor (Color color)
override void | SetBackgroundColor (Color color)
override void | Invalidate ()
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
ComponentBinding (Component component)
virtual void | Initialize (BindPropertyInfo propertyInfo, Type rootObjectType, params string[] properties)
virtual void | SetTrueMapping (object trueMapping)
virtual void | SetValue (object value, object parent)
virtual void | SetDomain (ICollection collection)
virtual void | Refresh ()
virtual void | RegisterSelectionAssignment (Component targetComponent, IConverter converter=null)
Indicates that the selection of the bound control must be assigned to another control. More...
virtual void | SetControlColors (Color fore, Color back)
Sets the controls foreground and background colors. Can be overridden by a specific binding to set other colors if necessary. More...

Properties

override HandleType | HandleDelayed [get]
- Properties inherited from Deltares.Standard.Forms.DExpress.ControlBinding
ToolTip | Tooltip [get]
Gets the tooltip for the bound control. More...
Control | BoundControl [get]
- Properties inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
Component | Component [get]
virtual bool | IsTransparant [get]
virtual HandleType | HandleDelayed [get]
virtual bool | HasDomain [get]
- Properties inherited from Deltares.Standard.Forms.DExpress.ComponentWrappers.IGetBoundControl
Control | BoundControl [get]

Additional Inherited Members

- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.BaseControlBinding
BaseControlBinding (Component component)
DXPopupMenu | GetPopupMenu ()
This method uses reflection to make the context menu accessible, which otherwise is protected. The Menu property is implemented for TextEdit, so we first make sure the control is actually of this type. More...
override void | OnToolTipShown (PopupEventArgs e)
Called when Tooltip is shown, and fires ToolTipShown event. More...
override void | OnToolTipClosed ()
Called when Tooltip is hidden, and fires ToolTipHidden. More...
override void | Dispose (bool disposing)
- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.ControlBinding
ControlBinding (Component component)
void | ThreadSafeRefresh ()
override void | Dispose (bool disposing)
- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
void | RaiseValueChanged ()
void | RaiseLeave ()
void | RaiseActionPerformed ()
Type | GetGenericType (Type type)
string | ValueToString (object value)
bool | IsAssociatedPropertyVisible (object source, BindPropertyInfo associatedPropertyInfo)
Indicates whether the associated property (i.e. the property which is used to display the original property in a textbox) is visible More...
void | EditFileInfo (object source, BindPropertyInfo propertyInfo)
string | EditFileInfo (string value, string format, string label, string description, bool isDirectory)
string | GetDoubleString (string text)
bool | HasValidNumericValue (string text)
double | GetNumericValue (string text)
List< BindPropertyInfo > | GetDictionaryProperties (ICollection domain, BindPropertyInfo dynamicPropertyInfo)
- Protected Attributes inherited from Deltares.Standard.Forms.DExpress.BaseControlBinding
readonly SuperToolTip | superTip
- Protected Attributes inherited from Deltares.Standard.Forms.DExpress.ControlBinding
readonly ToolTip | tooltip
string | Description
The textual description associated with this

See also
Control

. More...

string | Label
The label/title/name associated with this Control. More...
- Protected Attributes inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
BindPropertyInfo | propInfo
- Events inherited from Deltares.Standard.Forms.DExpress.ControlBinding
ToolTipVisibilityEventHandler | ToolTipHidden
ToolTipVisibilityEventHandler | ToolTipShown
- Events inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
EventHandler< EventArgs > | ActionPerformed
EventHandler< EventArgs > | Leave
EventHandler< EventArgs > | ValueChanged
Generated on Tue Dec 15 2015 18:15:14 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • RepositoryItemTrackBarBinding
Deltares.Standard.Forms.DExpress.RepositoryItemTrackBarBinding Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.RepositoryItemTrackBarBinding, including all inherited members.

ActionPerformed (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
BaseControlBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.BaseControlBinding) | Deltares.Standard.Forms.DExpress.BaseControlBinding | protected
BoundControl (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding |
Component (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ComponentBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ControlBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Description | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Dispose(bool disposing) (defined in Deltares.Standard.Forms.DExpress.BaseControlBinding) | Deltares.Standard.Forms.DExpress.BaseControlBinding | protected
EditFileInfo(object source, BindPropertyInfo propertyInfo) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
EditFileInfo(string value, string format, string label, string description, bool isDirectory) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetDictionaryProperties(ICollection domain, BindPropertyInfo dynamicPropertyInfo) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetDoubleString(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetGenericType(Type type) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetNumericValue(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetPopupMenu() | Deltares.Standard.Forms.DExpress.BaseControlBinding | protected
GetValue() (defined in Deltares.Standard.Forms.DExpress.RepositoryItemTrackBarBinding) | Deltares.Standard.Forms.DExpress.RepositoryItemTrackBarBinding | virtual
HandleDelayed (defined in Deltares.Standard.Forms.DExpress.RepositoryItemTrackBarBinding) | Deltares.Standard.Forms.DExpress.RepositoryItemTrackBarBinding |
HasDomain (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
HasValidNumericValue(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Initialize(BindPropertyInfo propertyInfo, params string[] properties) (defined in Deltares.Standard.Forms.DExpress.RepositoryItemTrackBarBinding) | Deltares.Standard.Forms.DExpress.RepositoryItemTrackBarBinding | virtual
Initialize(BindPropertyInfo propertyInfo, Type rootObjectType, params string[] properties) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
Invalidate() (defined in Deltares.Standard.Forms.DExpress.BaseControlBinding) | Deltares.Standard.Forms.DExpress.BaseControlBinding | virtual
IsAssociatedPropertyVisible(object source, BindPropertyInfo associatedPropertyInfo) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
IsTransparant (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
Label | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Leave (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
OnToolTipClosed() | Deltares.Standard.Forms.DExpress.BaseControlBinding | protectedvirtual
OnToolTipShown(PopupEventArgs e) | Deltares.Standard.Forms.DExpress.BaseControlBinding | protectedvirtual
propInfo (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseActionPerformed() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseLeave() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseValueChanged() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Refresh() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
RegisterSelectionAssignment(Component targetComponent, IConverter converter=null) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
RepositoryItemTrackBarBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.RepositoryItemTrackBarBinding) | Deltares.Standard.Forms.DExpress.RepositoryItemTrackBarBinding |
SetBackgroundColor(Color color) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
SetControlColors(Color fore, Color back) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetDescription(string description) (defined in Deltares.Standard.Forms.DExpress.BaseControlBinding) | Deltares.Standard.Forms.DExpress.BaseControlBinding | virtual
SetDomain(ICollection collection) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetEnabled(bool enabled) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
SetForegroundColor(Color color) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
SetLabel(string text) (defined in Deltares.Standard.Forms.DExpress.BaseControlBinding) | Deltares.Standard.Forms.DExpress.BaseControlBinding | virtual
SetTrueMapping(object trueMapping) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetValue(object value) (defined in Deltares.Standard.Forms.DExpress.RepositoryItemTrackBarBinding) | Deltares.Standard.Forms.DExpress.RepositoryItemTrackBarBinding | virtual
SetValue(object value, object parent) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetVisible(bool visible) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
superTip (defined in Deltares.Standard.Forms.DExpress.BaseControlBinding) | Deltares.Standard.Forms.DExpress.BaseControlBinding | protected
ThreadSafeRefresh() (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Tooltip | Deltares.Standard.Forms.DExpress.ControlBinding | protected
tooltip (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | protected
ToolTipHidden (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding |
ToolTipShown (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding |
ValueChanged (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ValueToString(object value) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Generated on Tue Dec 15 2015 18:15:14 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.ScrollableControlBinding Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • ScrollableControlBinding
Public Member Functions | List of all members
Deltares.Standard.Forms.DExpress.ScrollableControlBinding Class Reference

Binding class for GroupBox, GroupControl, Panel, XtraTabPage and UserControl More...

Inheritance diagram for Deltares.Standard.Forms.DExpress.ScrollableControlBinding:
Deltares.Standard.Forms.DExpress.ControlBinding Deltares.Standard.Forms.DExpress.ComponentBinding Deltares.Standard.Forms.DExpress.ComponentWrappers.IGetBoundControl Deltares.Standard.Forms.DExpress.DockPanelBinding Deltares.Standard.Forms.DExpress.PictureBoxBinding Deltares.Standard.Forms.DExpress.XtraTabPageBinding

Public Member Functions

ScrollableControlBinding (Component component)
override void | SetEnabled (bool enabled)
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.ControlBinding
override void | SetVisible (bool visible)
override void | SetLabel (string text)
Sets the label/title/name associated with this control. More...
override void | SetDescription (string description)
Sets the textual description associated with this control. More...
override void | SetForegroundColor (Color color)
override void | SetBackgroundColor (Color color)
override void | Invalidate ()
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
ComponentBinding (Component component)
virtual void | Initialize (BindPropertyInfo propertyInfo, params string[] properties)
virtual void | Initialize (BindPropertyInfo propertyInfo, Type rootObjectType, params string[] properties)
virtual void | SetTrueMapping (object trueMapping)
virtual void | SetValue (object value)
virtual void | SetValue (object value, object parent)
virtual void | SetDomain (ICollection collection)
virtual object | GetValue ()
virtual void | Refresh ()
virtual void | RegisterSelectionAssignment (Component targetComponent, IConverter converter=null)
Indicates that the selection of the bound control must be assigned to another control. More...
virtual void | SetControlColors (Color fore, Color back)
Sets the controls foreground and background colors. Can be overridden by a specific binding to set other colors if necessary. More...

Additional Inherited Members

- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.ControlBinding
ControlBinding (Component component)
virtual void | OnToolTipShown (PopupEventArgs e)
Called when Tooltip is shown, and fires ToolTipShown event. More...
virtual void | OnToolTipClosed ()
Called when Tooltip is hidden, and fires ToolTipHidden. More...
void | ThreadSafeRefresh ()
override void | Dispose (bool disposing)
- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
void | RaiseValueChanged ()
void | RaiseLeave ()
void | RaiseActionPerformed ()
Type | GetGenericType (Type type)
string | ValueToString (object value)
bool | IsAssociatedPropertyVisible (object source, BindPropertyInfo associatedPropertyInfo)
Indicates whether the associated property (i.e. the property which is used to display the original property in a textbox) is visible More...
void | EditFileInfo (object source, BindPropertyInfo propertyInfo)
string | EditFileInfo (string value, string format, string label, string description, bool isDirectory)
string | GetDoubleString (string text)
bool | HasValidNumericValue (string text)
double | GetNumericValue (string text)
List< BindPropertyInfo > | GetDictionaryProperties (ICollection domain, BindPropertyInfo dynamicPropertyInfo)
- Protected Attributes inherited from Deltares.Standard.Forms.DExpress.ControlBinding
readonly ToolTip | tooltip
string | Description
The textual description associated with this

See also
Control

. More...

string | Label
The label/title/name associated with this Control. More...
- Protected Attributes inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
BindPropertyInfo | propInfo
- Properties inherited from Deltares.Standard.Forms.DExpress.ControlBinding
ToolTip | Tooltip [get]
Gets the tooltip for the bound control. More...
Control | BoundControl [get]
- Properties inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
Component | Component [get]
virtual bool | IsTransparant [get]
virtual HandleType | HandleDelayed [get]
virtual bool | HasDomain [get]
- Properties inherited from Deltares.Standard.Forms.DExpress.ComponentWrappers.IGetBoundControl
Control | BoundControl [get]
- Events inherited from Deltares.Standard.Forms.DExpress.ControlBinding
ToolTipVisibilityEventHandler | ToolTipHidden
ToolTipVisibilityEventHandler | ToolTipShown
- Events inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
EventHandler< EventArgs > | ActionPerformed
EventHandler< EventArgs > | Leave
EventHandler< EventArgs > | ValueChanged

Detailed Description

Binding class for GroupBox, GroupControl, Panel, XtraTabPage and UserControl

Generated on Tue Dec 15 2015 18:15:15 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • ScrollableControlBinding
Deltares.Standard.Forms.DExpress.ScrollableControlBinding Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.ScrollableControlBinding, including all inherited members.

ActionPerformed (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
BoundControl (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding |
Component (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ComponentBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ControlBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Description | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Dispose(bool disposing) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | protected
EditFileInfo(object source, BindPropertyInfo propertyInfo) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
EditFileInfo(string value, string format, string label, string description, bool isDirectory) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetDictionaryProperties(ICollection domain, BindPropertyInfo dynamicPropertyInfo) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetDoubleString(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetGenericType(Type type) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetNumericValue(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetValue() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
HandleDelayed (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
HasDomain (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
HasValidNumericValue(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Initialize(BindPropertyInfo propertyInfo, params string[] properties) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
Initialize(BindPropertyInfo propertyInfo, Type rootObjectType, params string[] properties) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
Invalidate() (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
IsAssociatedPropertyVisible(object source, BindPropertyInfo associatedPropertyInfo) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
IsTransparant (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
Label | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Leave (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
OnToolTipClosed() | Deltares.Standard.Forms.DExpress.ControlBinding | protectedvirtual
OnToolTipShown(PopupEventArgs e) | Deltares.Standard.Forms.DExpress.ControlBinding | protectedvirtual
propInfo (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseActionPerformed() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseLeave() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseValueChanged() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Refresh() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
RegisterSelectionAssignment(Component targetComponent, IConverter converter=null) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
ScrollableControlBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.ScrollableControlBinding) | Deltares.Standard.Forms.DExpress.ScrollableControlBinding |
SetBackgroundColor(Color color) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
SetControlColors(Color fore, Color back) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetDescription(string description) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
SetDomain(ICollection collection) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetEnabled(bool enabled) (defined in Deltares.Standard.Forms.DExpress.ScrollableControlBinding) | Deltares.Standard.Forms.DExpress.ScrollableControlBinding | virtual
SetForegroundColor(Color color) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
SetLabel(string text) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
SetTrueMapping(object trueMapping) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetValue(object value) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetValue(object value, object parent) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetVisible(bool visible) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
ThreadSafeRefresh() (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Tooltip | Deltares.Standard.Forms.DExpress.ControlBinding | protected
tooltip (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | protected
ToolTipHidden (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding |
ToolTipShown (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding |
ValueChanged (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ValueToString(object value) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Generated on Tue Dec 15 2015 18:15:15 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.SelectionHyperLinkEdit Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • SelectionHyperLinkEdit
Properties | List of all members
Deltares.Standard.Forms.DExpress.SelectionHyperLinkEdit Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.SelectionHyperLinkEdit:

Properties

object | AssignedObject [get, set]
HyperLinkSelectionAction | SelectionAction [get, set]
Generated on Tue Dec 15 2015 18:15:15 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • SelectionHyperLinkEdit
Deltares.Standard.Forms.DExpress.SelectionHyperLinkEdit Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.SelectionHyperLinkEdit, including all inherited members.

AssignedObject (defined in Deltares.Standard.Forms.DExpress.SelectionHyperLinkEdit) | Deltares.Standard.Forms.DExpress.SelectionHyperLinkEdit
SelectionAction (defined in Deltares.Standard.Forms.DExpress.SelectionHyperLinkEdit) | Deltares.Standard.Forms.DExpress.SelectionHyperLinkEdit
SelectionHyperLinkEdit() (defined in Deltares.Standard.Forms.DExpress.SelectionHyperLinkEdit) | Deltares.Standard.Forms.DExpress.SelectionHyperLinkEdit
Generated on Tue Dec 15 2015 18:15:15 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.ShapeFileImporter Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • ShapeFileImporter
Public Member Functions | Protected Member Functions | List of all members
Deltares.Standard.Forms.DExpress.ShapeFileImporter Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.ShapeFileImporter:
Deltares.Standard.Forms.DExpress.ShapeFileMetaDataImporter Deltares.Standard.Forms.DExpress.AbstractShapeFileImporter

Public Member Functions

ShapeFileImporter (string filename, Type type, IDataFactory factory, FieldPropertyMap propertyMaps)
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.ShapeFileMetaDataImporter
ShapeFileMetaDataImporter (string filename, Type type, IDataFactory factory, FieldPropertyMap propertyMaps)
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.AbstractShapeFileImporter
void | RegisterShapeImporter (IShapeImporter importer)
Registers the shape importer. More...
override void | Import ()
Imports data from the shape file. More...

Protected Member Functions

override void | ImportFeature (object target, IFeature feature, IFeatureSet featureSet)
- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.ShapeFileMetaDataImporter
override void | ImportFeature (object target, IFeature feature, IFeatureSet featureSet)
void | ImportMappings (IFeature feature, IFeatureSet featureSet, object obj)
- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.AbstractShapeFileImporter
AbstractShapeFileImporter (string filename, Type type, IDataFactory factory, FieldPropertyMap propertyMaps)
IShapeImporter | GetConverter (string geometryType)
object | CreateTarget (FieldDefinition idFieldDefinition, IFeature feature, IFeatureSet featureSet)

Additional Inherited Members

- Public Types inherited from Deltares.Standard.Forms.DExpress.AbstractShapeFileImporter
enum GeometryTypes {
Point = 1, LineString = 2, Polygon = 3, MultiPoint = 4,
MultiLineString = 5, MultiPolygon = 6, GeometryCollection = 7
}
Defines the different geometry types More...
- Static Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.AbstractShapeFileImporter
static object GetValue (FieldDefinition field, IFeature feature, IFeatureSet featureSet)
Generated on Tue Dec 15 2015 18:15:15 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • ShapeFileImporter
Deltares.Standard.Forms.DExpress.ShapeFileImporter Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.ShapeFileImporter, including all inherited members.

AbstractShapeFileImporter() (defined in Deltares.Standard.Forms.DExpress.AbstractShapeFileImporter) | Deltares.Standard.Forms.DExpress.AbstractShapeFileImporter | protected
AbstractShapeFileImporter(string filename, Type type, IDataFactory factory, FieldPropertyMap propertyMaps) (defined in Deltares.Standard.Forms.DExpress.AbstractShapeFileImporter) | Deltares.Standard.Forms.DExpress.AbstractShapeFileImporter | protected
CreateTarget(FieldDefinition idFieldDefinition, IFeature feature, IFeatureSet featureSet) (defined in Deltares.Standard.Forms.DExpress.AbstractShapeFileImporter) | Deltares.Standard.Forms.DExpress.AbstractShapeFileImporter | protected
GeometryTypes enum name | Deltares.Standard.Forms.DExpress.AbstractShapeFileImporter |
GetConverter(string geometryType) (defined in Deltares.Standard.Forms.DExpress.AbstractShapeFileImporter) | Deltares.Standard.Forms.DExpress.AbstractShapeFileImporter | protected
GetValue(FieldDefinition field, IFeature feature, IFeatureSet featureSet) (defined in Deltares.Standard.Forms.DExpress.AbstractShapeFileImporter) | Deltares.Standard.Forms.DExpress.AbstractShapeFileImporter | protectedstatic
Import() | Deltares.Standard.Forms.DExpress.AbstractShapeFileImporter |
ImportFeature(object target, IFeature feature, IFeatureSet featureSet) (defined in Deltares.Standard.Forms.DExpress.ShapeFileImporter) | Deltares.Standard.Forms.DExpress.ShapeFileImporter | protectedvirtual
ImportMappings(IFeature feature, IFeatureSet featureSet, object obj) (defined in Deltares.Standard.Forms.DExpress.ShapeFileMetaDataImporter) | Deltares.Standard.Forms.DExpress.ShapeFileMetaDataImporter | protected
RegisterShapeImporter(IShapeImporter importer) | Deltares.Standard.Forms.DExpress.AbstractShapeFileImporter |
ShapeFileImporter() (defined in Deltares.Standard.Forms.DExpress.ShapeFileImporter) | Deltares.Standard.Forms.DExpress.ShapeFileImporter |
ShapeFileImporter(string filename, Type type, IDataFactory factory, FieldPropertyMap propertyMaps) (defined in Deltares.Standard.Forms.DExpress.ShapeFileImporter) | Deltares.Standard.Forms.DExpress.ShapeFileImporter |
ShapeFileMetaDataImporter() (defined in Deltares.Standard.Forms.DExpress.ShapeFileMetaDataImporter) | Deltares.Standard.Forms.DExpress.ShapeFileMetaDataImporter |
ShapeFileMetaDataImporter(string filename, Type type, IDataFactory factory, FieldPropertyMap propertyMaps) (defined in Deltares.Standard.Forms.DExpress.ShapeFileMetaDataImporter) | Deltares.Standard.Forms.DExpress.ShapeFileMetaDataImporter |
Generated on Tue Dec 15 2015 18:15:15 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.ShapeFileMetaDataImporter Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • ShapeFileMetaDataImporter
Public Member Functions | Protected Member Functions | List of all members
Deltares.Standard.Forms.DExpress.ShapeFileMetaDataImporter Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.ShapeFileMetaDataImporter:
Deltares.Standard.Forms.DExpress.AbstractShapeFileImporter Deltares.Standard.Forms.DExpress.ShapeFileImporter

Public Member Functions

ShapeFileMetaDataImporter (string filename, Type type, IDataFactory factory, FieldPropertyMap propertyMaps)
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.AbstractShapeFileImporter
void | RegisterShapeImporter (IShapeImporter importer)
Registers the shape importer. More...
override void | Import ()
Imports data from the shape file. More...

Protected Member Functions

override void | ImportFeature (object target, IFeature feature, IFeatureSet featureSet)
void | ImportMappings (IFeature feature, IFeatureSet featureSet, object obj)
- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.AbstractShapeFileImporter
AbstractShapeFileImporter (string filename, Type type, IDataFactory factory, FieldPropertyMap propertyMaps)
IShapeImporter | GetConverter (string geometryType)
object | CreateTarget (FieldDefinition idFieldDefinition, IFeature feature, IFeatureSet featureSet)

Additional Inherited Members

- Public Types inherited from Deltares.Standard.Forms.DExpress.AbstractShapeFileImporter
enum GeometryTypes {
Point = 1, LineString = 2, Polygon = 3, MultiPoint = 4,
MultiLineString = 5, MultiPolygon = 6, GeometryCollection = 7
}
Defines the different geometry types More...
- Static Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.AbstractShapeFileImporter
static object GetValue (FieldDefinition field, IFeature feature, IFeatureSet featureSet)
Generated on Tue Dec 15 2015 18:15:16 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • ShapeFileMetaDataImporter
Deltares.Standard.Forms.DExpress.ShapeFileMetaDataImporter Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.ShapeFileMetaDataImporter, including all inherited members.

AbstractShapeFileImporter() (defined in Deltares.Standard.Forms.DExpress.AbstractShapeFileImporter) | Deltares.Standard.Forms.DExpress.AbstractShapeFileImporter | protected
AbstractShapeFileImporter(string filename, Type type, IDataFactory factory, FieldPropertyMap propertyMaps) (defined in Deltares.Standard.Forms.DExpress.AbstractShapeFileImporter) | Deltares.Standard.Forms.DExpress.AbstractShapeFileImporter | protected
CreateTarget(FieldDefinition idFieldDefinition, IFeature feature, IFeatureSet featureSet) (defined in Deltares.Standard.Forms.DExpress.AbstractShapeFileImporter) | Deltares.Standard.Forms.DExpress.AbstractShapeFileImporter | protected
GeometryTypes enum name | Deltares.Standard.Forms.DExpress.AbstractShapeFileImporter |
GetConverter(string geometryType) (defined in Deltares.Standard.Forms.DExpress.AbstractShapeFileImporter) | Deltares.Standard.Forms.DExpress.AbstractShapeFileImporter | protected
GetValue(FieldDefinition field, IFeature feature, IFeatureSet featureSet) (defined in Deltares.Standard.Forms.DExpress.AbstractShapeFileImporter) | Deltares.Standard.Forms.DExpress.AbstractShapeFileImporter | protectedstatic
Import() | Deltares.Standard.Forms.DExpress.AbstractShapeFileImporter |
ImportFeature(object target, IFeature feature, IFeatureSet featureSet) (defined in Deltares.Standard.Forms.DExpress.ShapeFileMetaDataImporter) | Deltares.Standard.Forms.DExpress.ShapeFileMetaDataImporter | protectedvirtual
ImportMappings(IFeature feature, IFeatureSet featureSet, object obj) (defined in Deltares.Standard.Forms.DExpress.ShapeFileMetaDataImporter) | Deltares.Standard.Forms.DExpress.ShapeFileMetaDataImporter | protected
RegisterShapeImporter(IShapeImporter importer) | Deltares.Standard.Forms.DExpress.AbstractShapeFileImporter |
ShapeFileMetaDataImporter() (defined in Deltares.Standard.Forms.DExpress.ShapeFileMetaDataImporter) | Deltares.Standard.Forms.DExpress.ShapeFileMetaDataImporter |
ShapeFileMetaDataImporter(string filename, Type type, IDataFactory factory, FieldPropertyMap propertyMaps) (defined in Deltares.Standard.Forms.DExpress.ShapeFileMetaDataImporter) | Deltares.Standard.Forms.DExpress.ShapeFileMetaDataImporter |
Generated on Tue Dec 15 2015 18:15:16 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.SimpleButtonBinding Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • SimpleButtonBinding
Public Member Functions | List of all members
Deltares.Standard.Forms.DExpress.SimpleButtonBinding Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.SimpleButtonBinding:
Deltares.Standard.Forms.DExpress.BaseControlBinding Deltares.Standard.Forms.DExpress.ControlBinding Deltares.Standard.Forms.DExpress.ComponentBinding Deltares.Standard.Forms.DExpress.ComponentWrappers.IGetBoundControl

Public Member Functions

SimpleButtonBinding (Component component)
override void | Initialize (BindPropertyInfo propertyInfo, params string[] properties)
override void | SetLabel (string text)
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.BaseControlBinding
override void | SetDescription (string description)
override void | Invalidate ()
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.ControlBinding
override void | SetVisible (bool visible)
override void | SetEnabled (bool enabled)
override void | SetDescription (string description)
Sets the textual description associated with this control. More...
override void | SetForegroundColor (Color color)
override void | SetBackgroundColor (Color color)
override void | Invalidate ()
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
ComponentBinding (Component component)
virtual void | Initialize (BindPropertyInfo propertyInfo, Type rootObjectType, params string[] properties)
virtual void | SetTrueMapping (object trueMapping)
virtual void | SetValue (object value)
virtual void | SetValue (object value, object parent)
virtual void | SetDomain (ICollection collection)
virtual object | GetValue ()
virtual void | Refresh ()
virtual void | RegisterSelectionAssignment (Component targetComponent, IConverter converter=null)
Indicates that the selection of the bound control must be assigned to another control. More...
virtual void | SetControlColors (Color fore, Color back)
Sets the controls foreground and background colors. Can be overridden by a specific binding to set other colors if necessary. More...

Additional Inherited Members

- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.BaseControlBinding
BaseControlBinding (Component component)
DXPopupMenu | GetPopupMenu ()
This method uses reflection to make the context menu accessible, which otherwise is protected. The Menu property is implemented for TextEdit, so we first make sure the control is actually of this type. More...
override void | OnToolTipShown (PopupEventArgs e)
Called when Tooltip is shown, and fires ToolTipShown event. More...
override void | OnToolTipClosed ()
Called when Tooltip is hidden, and fires ToolTipHidden. More...
override void | Dispose (bool disposing)
- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.ControlBinding
ControlBinding (Component component)
void | ThreadSafeRefresh ()
override void | Dispose (bool disposing)
- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
void | RaiseValueChanged ()
void | RaiseLeave ()
void | RaiseActionPerformed ()
Type | GetGenericType (Type type)
string | ValueToString (object value)
bool | IsAssociatedPropertyVisible (object source, BindPropertyInfo associatedPropertyInfo)
Indicates whether the associated property (i.e. the property which is used to display the original property in a textbox) is visible More...
void | EditFileInfo (object source, BindPropertyInfo propertyInfo)
string | EditFileInfo (string value, string format, string label, string description, bool isDirectory)
string | GetDoubleString (string text)
bool | HasValidNumericValue (string text)
double | GetNumericValue (string text)
List< BindPropertyInfo > | GetDictionaryProperties (ICollection domain, BindPropertyInfo dynamicPropertyInfo)
- Protected Attributes inherited from Deltares.Standard.Forms.DExpress.BaseControlBinding
readonly SuperToolTip | superTip
- Protected Attributes inherited from Deltares.Standard.Forms.DExpress.ControlBinding
readonly ToolTip | tooltip
string | Description
The textual description associated with this

See also
Control

. More...

string | Label
The label/title/name associated with this Control. More...
- Protected Attributes inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
BindPropertyInfo | propInfo
- Properties inherited from Deltares.Standard.Forms.DExpress.ControlBinding
ToolTip | Tooltip [get]
Gets the tooltip for the bound control. More...
Control | BoundControl [get]
- Properties inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
Component | Component [get]
virtual bool | IsTransparant [get]
virtual HandleType | HandleDelayed [get]
virtual bool | HasDomain [get]
- Properties inherited from Deltares.Standard.Forms.DExpress.ComponentWrappers.IGetBoundControl
Control | BoundControl [get]
- Events inherited from Deltares.Standard.Forms.DExpress.ControlBinding
ToolTipVisibilityEventHandler | ToolTipHidden
ToolTipVisibilityEventHandler | ToolTipShown
- Events inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
EventHandler< EventArgs > | ActionPerformed
EventHandler< EventArgs > | Leave
EventHandler< EventArgs > | ValueChanged
Generated on Tue Dec 15 2015 18:15:16 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • SimpleButtonBinding
Deltares.Standard.Forms.DExpress.SimpleButtonBinding Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.SimpleButtonBinding, including all inherited members.

ActionPerformed (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
BaseControlBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.BaseControlBinding) | Deltares.Standard.Forms.DExpress.BaseControlBinding | protected
BoundControl (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding |
Component (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ComponentBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ControlBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Description | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Dispose(bool disposing) (defined in Deltares.Standard.Forms.DExpress.BaseControlBinding) | Deltares.Standard.Forms.DExpress.BaseControlBinding | protected
EditFileInfo(object source, BindPropertyInfo propertyInfo) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
EditFileInfo(string value, string format, string label, string description, bool isDirectory) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetDictionaryProperties(ICollection domain, BindPropertyInfo dynamicPropertyInfo) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetDoubleString(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetGenericType(Type type) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetNumericValue(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetPopupMenu() | Deltares.Standard.Forms.DExpress.BaseControlBinding | protected
GetValue() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
HandleDelayed (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
HasDomain (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
HasValidNumericValue(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Initialize(BindPropertyInfo propertyInfo, params string[] properties) (defined in Deltares.Standard.Forms.DExpress.SimpleButtonBinding) | Deltares.Standard.Forms.DExpress.SimpleButtonBinding | virtual
Initialize(BindPropertyInfo propertyInfo, Type rootObjectType, params string[] properties) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
Invalidate() (defined in Deltares.Standard.Forms.DExpress.BaseControlBinding) | Deltares.Standard.Forms.DExpress.BaseControlBinding | virtual
IsAssociatedPropertyVisible(object source, BindPropertyInfo associatedPropertyInfo) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
IsTransparant (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
Label | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Leave (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
OnToolTipClosed() | Deltares.Standard.Forms.DExpress.BaseControlBinding | protectedvirtual
OnToolTipShown(PopupEventArgs e) | Deltares.Standard.Forms.DExpress.BaseControlBinding | protectedvirtual
propInfo (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseActionPerformed() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseLeave() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseValueChanged() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Refresh() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
RegisterSelectionAssignment(Component targetComponent, IConverter converter=null) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetBackgroundColor(Color color) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
SetControlColors(Color fore, Color back) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetDescription(string description) (defined in Deltares.Standard.Forms.DExpress.BaseControlBinding) | Deltares.Standard.Forms.DExpress.BaseControlBinding | virtual
SetDomain(ICollection collection) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetEnabled(bool enabled) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
SetForegroundColor(Color color) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
SetLabel(string text) (defined in Deltares.Standard.Forms.DExpress.SimpleButtonBinding) | Deltares.Standard.Forms.DExpress.SimpleButtonBinding | virtual
SetTrueMapping(object trueMapping) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetValue(object value) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetValue(object value, object parent) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetVisible(bool visible) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
SimpleButtonBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.SimpleButtonBinding) | Deltares.Standard.Forms.DExpress.SimpleButtonBinding |
superTip (defined in Deltares.Standard.Forms.DExpress.BaseControlBinding) | Deltares.Standard.Forms.DExpress.BaseControlBinding | protected
ThreadSafeRefresh() (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Tooltip | Deltares.Standard.Forms.DExpress.ControlBinding | protected
tooltip (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | protected
ToolTipHidden (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding |
ToolTipShown (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding |
ValueChanged (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ValueToString(object value) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Generated on Tue Dec 15 2015 18:15:16 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.SimplePropertySubControlFactory< ShownDataType, ControlType > Class Template Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • SimplePropertySubControlFactory
Protected Member Functions | List of all members
Deltares.Standard.Forms.DExpress.SimplePropertySubControlFactory< ShownDataType, ControlType > Class Template Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.SimplePropertySubControlFactory< ShownDataType, ControlType >:
Deltares.Standard.Forms.DExpress.BasicPropertySubControlFactory< ShownDataType, ControlType > Deltares.Standard.Forms.DExpress.IPropertySubControlFactory< ControlType >

Protected Member Functions

override void | BindControl (ControlType control, bool hasUnitInfo, string propertyName)
- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.BasicPropertySubControlFactory< ShownDataType, ControlType >
abstract ControlType | CreateControl (string name)

Additional Inherited Members

- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.BasicPropertySubControlFactory< ShownDataType, ControlType >
ControlType | CreateBoundControl (PropertyInfo propertyInfo, Type dataType, Component parentComponent)
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.IPropertySubControlFactory< ControlType >
ControlType | CreateBoundControl (PropertyInfo propertyInfo, Type dataType, Component parentComponent)
- Properties inherited from Deltares.Standard.Forms.DExpress.BasicPropertySubControlFactory< ShownDataType, ControlType >
Type | ValueType [get]
PropertyInfo | PropertyInfo [get]
Type | DataType [get]
Component | ParentComponent [get]
- Properties inherited from Deltares.Standard.Forms.DExpress.IPropertySubControlFactory< ControlType >
Type | ValueType [get]
Generated on Tue Dec 15 2015 18:15:16 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • SimplePropertySubControlFactory
Deltares.Standard.Forms.DExpress.SimplePropertySubControlFactory< ShownDataType, ControlType > Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.SimplePropertySubControlFactory< ShownDataType, ControlType >, including all inherited members.

BindControl(ControlType control, bool hasUnitInfo, string propertyName) (defined in Deltares.Standard.Forms.DExpress.SimplePropertySubControlFactory< ShownDataType, ControlType >) | Deltares.Standard.Forms.DExpress.SimplePropertySubControlFactory< ShownDataType, ControlType > | protectedvirtual
CreateBoundControl(PropertyInfo propertyInfo, Type dataType, Component parentComponent) (defined in Deltares.Standard.Forms.DExpress.BasicPropertySubControlFactory< ShownDataType, ControlType >) | Deltares.Standard.Forms.DExpress.BasicPropertySubControlFactory< ShownDataType, ControlType > |
CreateControl(string name) (defined in Deltares.Standard.Forms.DExpress.BasicPropertySubControlFactory< ShownDataType, ControlType >) | Deltares.Standard.Forms.DExpress.BasicPropertySubControlFactory< ShownDataType, ControlType > | protectedpure virtual
DataType (defined in Deltares.Standard.Forms.DExpress.BasicPropertySubControlFactory< ShownDataType, ControlType >) | Deltares.Standard.Forms.DExpress.BasicPropertySubControlFactory< ShownDataType, ControlType > | protected
ParentComponent (defined in Deltares.Standard.Forms.DExpress.BasicPropertySubControlFactory< ShownDataType, ControlType >) | Deltares.Standard.Forms.DExpress.BasicPropertySubControlFactory< ShownDataType, ControlType > | protected
PropertyInfo (defined in Deltares.Standard.Forms.DExpress.BasicPropertySubControlFactory< ShownDataType, ControlType >) | Deltares.Standard.Forms.DExpress.BasicPropertySubControlFactory< ShownDataType, ControlType > | protected
ValueType (defined in Deltares.Standard.Forms.DExpress.BasicPropertySubControlFactory< ShownDataType, ControlType >) | Deltares.Standard.Forms.DExpress.BasicPropertySubControlFactory< ShownDataType, ControlType > |
Generated on Tue Dec 15 2015 18:15:16 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.SingleUnitDialog Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • SingleUnitDialog
Classes | Public Member Functions | Protected Member Functions | List of all members
Deltares.Standard.Forms.DExpress.SingleUnitDialog Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.SingleUnitDialog:

Public Member Functions

void SetUnit (string unit)

Protected Member Functions

override void Dispose (bool disposing)
Clean up any resources being used. More...

Member Function Documentation

override void Deltares.Standard.Forms.DExpress.SingleUnitDialog.Dispose ( bool disposing )
protected

Clean up any resources being used.

Parameters
disposing true if managed resources should be disposed; otherwise, false.
Generated on Tue Dec 15 2015 18:15:16 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • SingleUnitDialog
Deltares.Standard.Forms.DExpress.SingleUnitDialog Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.SingleUnitDialog, including all inherited members.

Dispose(bool disposing) | Deltares.Standard.Forms.DExpress.SingleUnitDialog | protected
SetUnit(string unit) (defined in Deltares.Standard.Forms.DExpress.SingleUnitDialog) | Deltares.Standard.Forms.DExpress.SingleUnitDialog |
SingleUnitDialog() (defined in Deltares.Standard.Forms.DExpress.SingleUnitDialog) | Deltares.Standard.Forms.DExpress.SingleUnitDialog |
Generated on Tue Dec 15 2015 18:15:16 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.SpatialEditorProperties Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • SpatialEditorProperties
Public Member Functions | Protected Member Functions | Properties | List of all members
Deltares.Standard.Forms.DExpress.SpatialEditorProperties Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.SpatialEditorProperties:
Deltares.Standard.Forms.IPropertyControl

Public Member Functions

void | RefreshControl ()
void | RefreshObject (object changedObject, bool isSelected)
void | FocusData (object data)
bool | IsValidObject (object identifierObject, object changedObject)
void | OnLoadPropertyControl ()

Protected Member Functions

override void Dispose (bool disposing)
Clean up any resources being used. More...

Properties

bool | IsMultiselectObject [get, set]
bool | IsSelectionChanging [get]
object | SelectedObject [get, set]
bool | IsVisible [get]
- Properties inherited from Deltares.Standard.Forms.IPropertyControl
string | Name [get, set]
Gets or sets the name to be displayed property. More...
object | SelectedObject [get, set]
Gets or sets the object to be displayed in the property window. More...
bool | IsVisible [get]
Whether or not the property control should be displayed. More...

Member Function Documentation

override void Deltares.Standard.Forms.DExpress.SpatialEditorProperties.Dispose ( bool disposing )
protected

Clean up any resources being used.

Parameters
disposing true if managed resources should be disposed; otherwise, false.
Generated on Tue Dec 15 2015 18:15:17 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • SpatialEditorProperties
Deltares.Standard.Forms.DExpress.SpatialEditorProperties Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.SpatialEditorProperties, including all inherited members.

Dispose(bool disposing) | Deltares.Standard.Forms.DExpress.SpatialEditorProperties | protected
FocusData(object data) (defined in Deltares.Standard.Forms.DExpress.SpatialEditorProperties) | Deltares.Standard.Forms.DExpress.SpatialEditorProperties |
IsMultiselectObject (defined in Deltares.Standard.Forms.DExpress.SpatialEditorProperties) | Deltares.Standard.Forms.DExpress.SpatialEditorProperties |
IsSelectionChanging (defined in Deltares.Standard.Forms.DExpress.SpatialEditorProperties) | Deltares.Standard.Forms.DExpress.SpatialEditorProperties |
IsValidObject(object identifierObject, object changedObject) (defined in Deltares.Standard.Forms.DExpress.SpatialEditorProperties) | Deltares.Standard.Forms.DExpress.SpatialEditorProperties |
IsVisible (defined in Deltares.Standard.Forms.DExpress.SpatialEditorProperties) | Deltares.Standard.Forms.DExpress.SpatialEditorProperties |
Name | Deltares.Standard.Forms.IPropertyControl |
OnLoadPropertyControl() (defined in Deltares.Standard.Forms.DExpress.SpatialEditorProperties) | Deltares.Standard.Forms.DExpress.SpatialEditorProperties |
RefreshControl() (defined in Deltares.Standard.Forms.DExpress.SpatialEditorProperties) | Deltares.Standard.Forms.DExpress.SpatialEditorProperties |
RefreshObject(object changedObject, bool isSelected) (defined in Deltares.Standard.Forms.DExpress.SpatialEditorProperties) | Deltares.Standard.Forms.DExpress.SpatialEditorProperties |
SelectedObject (defined in Deltares.Standard.Forms.DExpress.SpatialEditorProperties) | Deltares.Standard.Forms.DExpress.SpatialEditorProperties |
SpatialEditorProperties() (defined in Deltares.Standard.Forms.DExpress.SpatialEditorProperties) | Deltares.Standard.Forms.DExpress.SpatialEditorProperties |
Generated on Tue Dec 15 2015 18:15:17 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.SpinEditBinding Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • SpinEditBinding
Public Member Functions | Properties | List of all members
Deltares.Standard.Forms.DExpress.SpinEditBinding Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.SpinEditBinding:
Deltares.Standard.Forms.DExpress.BaseControlBinding Deltares.Standard.Forms.DExpress.ControlBinding Deltares.Standard.Forms.DExpress.ComponentBinding Deltares.Standard.Forms.DExpress.ComponentWrappers.IGetBoundControl

Public Member Functions

SpinEditBinding (Component component)
override void | Initialize (BindPropertyInfo propertyInfo, params string[] properties)
override void | SetValue (object value, object parent)
override object | GetValue ()
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.BaseControlBinding
override void | SetLabel (string text)
override void | SetDescription (string description)
override void | Invalidate ()
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.ControlBinding
override void | SetVisible (bool visible)
override void | SetEnabled (bool enabled)
override void | SetLabel (string text)
Sets the label/title/name associated with this control. More...
override void | SetDescription (string description)
Sets the textual description associated with this control. More...
override void | SetForegroundColor (Color color)
override void | SetBackgroundColor (Color color)
override void | Invalidate ()
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
ComponentBinding (Component component)
virtual void | Initialize (BindPropertyInfo propertyInfo, Type rootObjectType, params string[] properties)
virtual void | SetTrueMapping (object trueMapping)
virtual void | SetValue (object value)
virtual void | SetDomain (ICollection collection)
virtual void | Refresh ()
virtual void | RegisterSelectionAssignment (Component targetComponent, IConverter converter=null)
Indicates that the selection of the bound control must be assigned to another control. More...
virtual void | SetControlColors (Color fore, Color back)
Sets the controls foreground and background colors. Can be overridden by a specific binding to set other colors if necessary. More...

Properties

override HandleType | HandleDelayed [get]
- Properties inherited from Deltares.Standard.Forms.DExpress.ControlBinding
ToolTip | Tooltip [get]
Gets the tooltip for the bound control. More...
Control | BoundControl [get]
- Properties inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
Component | Component [get]
virtual bool | IsTransparant [get]
virtual HandleType | HandleDelayed [get]
virtual bool | HasDomain [get]
- Properties inherited from Deltares.Standard.Forms.DExpress.ComponentWrappers.IGetBoundControl
Control | BoundControl [get]

Additional Inherited Members

- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.BaseControlBinding
BaseControlBinding (Component component)
DXPopupMenu | GetPopupMenu ()
This method uses reflection to make the context menu accessible, which otherwise is protected. The Menu property is implemented for TextEdit, so we first make sure the control is actually of this type. More...
override void | OnToolTipShown (PopupEventArgs e)
Called when Tooltip is shown, and fires ToolTipShown event. More...
override void | OnToolTipClosed ()
Called when Tooltip is hidden, and fires ToolTipHidden. More...
override void | Dispose (bool disposing)
- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.ControlBinding
ControlBinding (Component component)
void | ThreadSafeRefresh ()
override void | Dispose (bool disposing)
- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
void | RaiseValueChanged ()
void | RaiseLeave ()
void | RaiseActionPerformed ()
Type | GetGenericType (Type type)
string | ValueToString (object value)
bool | IsAssociatedPropertyVisible (object source, BindPropertyInfo associatedPropertyInfo)
Indicates whether the associated property (i.e. the property which is used to display the original property in a textbox) is visible More...
void | EditFileInfo (object source, BindPropertyInfo propertyInfo)
string | EditFileInfo (string value, string format, string label, string description, bool isDirectory)
string | GetDoubleString (string text)
bool | HasValidNumericValue (string text)
double | GetNumericValue (string text)
List< BindPropertyInfo > | GetDictionaryProperties (ICollection domain, BindPropertyInfo dynamicPropertyInfo)
- Protected Attributes inherited from Deltares.Standard.Forms.DExpress.BaseControlBinding
readonly SuperToolTip | superTip
- Protected Attributes inherited from Deltares.Standard.Forms.DExpress.ControlBinding
readonly ToolTip | tooltip
string | Description
The textual description associated with this

See also
Control

. More...

string | Label
The label/title/name associated with this Control. More...
- Protected Attributes inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
BindPropertyInfo | propInfo
- Events inherited from Deltares.Standard.Forms.DExpress.ControlBinding
ToolTipVisibilityEventHandler | ToolTipHidden
ToolTipVisibilityEventHandler | ToolTipShown
- Events inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
EventHandler< EventArgs > | ActionPerformed
EventHandler< EventArgs > | Leave
EventHandler< EventArgs > | ValueChanged
Generated on Tue Dec 15 2015 18:15:17 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • SpinEditBinding
Deltares.Standard.Forms.DExpress.SpinEditBinding Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.SpinEditBinding, including all inherited members.

ActionPerformed (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
BaseControlBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.BaseControlBinding) | Deltares.Standard.Forms.DExpress.BaseControlBinding | protected
BoundControl (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding |
Component (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ComponentBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ControlBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Description | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Dispose(bool disposing) (defined in Deltares.Standard.Forms.DExpress.BaseControlBinding) | Deltares.Standard.Forms.DExpress.BaseControlBinding | protected
EditFileInfo(object source, BindPropertyInfo propertyInfo) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
EditFileInfo(string value, string format, string label, string description, bool isDirectory) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetDictionaryProperties(ICollection domain, BindPropertyInfo dynamicPropertyInfo) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetDoubleString(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetGenericType(Type type) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetNumericValue(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetPopupMenu() | Deltares.Standard.Forms.DExpress.BaseControlBinding | protected
GetValue() (defined in Deltares.Standard.Forms.DExpress.SpinEditBinding) | Deltares.Standard.Forms.DExpress.SpinEditBinding | virtual
HandleDelayed (defined in Deltares.Standard.Forms.DExpress.SpinEditBinding) | Deltares.Standard.Forms.DExpress.SpinEditBinding |
HasDomain (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
HasValidNumericValue(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Initialize(BindPropertyInfo propertyInfo, params string[] properties) (defined in Deltares.Standard.Forms.DExpress.SpinEditBinding) | Deltares.Standard.Forms.DExpress.SpinEditBinding | virtual
Initialize(BindPropertyInfo propertyInfo, Type rootObjectType, params string[] properties) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
Invalidate() (defined in Deltares.Standard.Forms.DExpress.BaseControlBinding) | Deltares.Standard.Forms.DExpress.BaseControlBinding | virtual
IsAssociatedPropertyVisible(object source, BindPropertyInfo associatedPropertyInfo) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
IsTransparant (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
Label | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Leave (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
OnToolTipClosed() | Deltares.Standard.Forms.DExpress.BaseControlBinding | protectedvirtual
OnToolTipShown(PopupEventArgs e) | Deltares.Standard.Forms.DExpress.BaseControlBinding | protectedvirtual
propInfo (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseActionPerformed() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseLeave() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseValueChanged() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Refresh() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
RegisterSelectionAssignment(Component targetComponent, IConverter converter=null) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetBackgroundColor(Color color) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
SetControlColors(Color fore, Color back) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetDescription(string description) (defined in Deltares.Standard.Forms.DExpress.BaseControlBinding) | Deltares.Standard.Forms.DExpress.BaseControlBinding | virtual
SetDomain(ICollection collection) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetEnabled(bool enabled) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
SetForegroundColor(Color color) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
SetLabel(string text) (defined in Deltares.Standard.Forms.DExpress.BaseControlBinding) | Deltares.Standard.Forms.DExpress.BaseControlBinding | virtual
SetTrueMapping(object trueMapping) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetValue(object value, object parent) (defined in Deltares.Standard.Forms.DExpress.SpinEditBinding) | Deltares.Standard.Forms.DExpress.SpinEditBinding | virtual
SetValue(object value) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetVisible(bool visible) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
SpinEditBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.SpinEditBinding) | Deltares.Standard.Forms.DExpress.SpinEditBinding |
superTip (defined in Deltares.Standard.Forms.DExpress.BaseControlBinding) | Deltares.Standard.Forms.DExpress.BaseControlBinding | protected
ThreadSafeRefresh() (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | protected
tooltip (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Tooltip | Deltares.Standard.Forms.DExpress.ControlBinding | protected
ToolTipHidden (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding |
ToolTipShown (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding |
ValueChanged (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ValueToString(object value) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Generated on Tue Dec 15 2015 18:15:17 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.SplashDialog Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • SplashDialog
Public Member Functions | Protected Member Functions | Properties | List of all members
Deltares.Standard.Forms.DExpress.SplashDialog Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.SplashDialog:

Public Member Functions

void | SetAssemblyInfo (Type type, string email=DEFAULT_EMAIL, string telephoneNumber=DEFAULT_TELEPHONE_NUMBER)
void | SetAssemblyInfo (string company, string version, string license, string email, string telephoneNumber, string copyright)
void | SetFractionPerStep (float fractionPerStep)
void | IncrementToMaximum ()
void | IncrementToMaximum (string text)
void | SetProgress (float fraction)
void | SetProgress (float fraction, string text)
void | IncrementProgress (float fraction)
void | IncrementProgress (float fraction, string text)
void | IncrementProgress ()

Protected Member Functions

override void Dispose (bool disposing)
Clean up any resources being used. More...

Properties

bool | DemoMode [get, set]
Image | Splash [get, set]
override CreateParams | CreateParams [get]

Member Function Documentation

override void Deltares.Standard.Forms.DExpress.SplashDialog.Dispose ( bool disposing )
protected

Clean up any resources being used.

Parameters
disposing true if managed resources should be disposed; otherwise, false.
Generated on Tue Dec 15 2015 18:15:17 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • SplashDialog
Deltares.Standard.Forms.DExpress.SplashDialog Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.SplashDialog, including all inherited members.

CreateParams (defined in Deltares.Standard.Forms.DExpress.SplashDialog) | Deltares.Standard.Forms.DExpress.SplashDialog | protected
DemoMode (defined in Deltares.Standard.Forms.DExpress.SplashDialog) | Deltares.Standard.Forms.DExpress.SplashDialog |
Dispose(bool disposing) | Deltares.Standard.Forms.DExpress.SplashDialog | protected
IncrementProgress(float fraction) (defined in Deltares.Standard.Forms.DExpress.SplashDialog) | Deltares.Standard.Forms.DExpress.SplashDialog |
IncrementProgress(float fraction, string text) (defined in Deltares.Standard.Forms.DExpress.SplashDialog) | Deltares.Standard.Forms.DExpress.SplashDialog |
IncrementProgress() (defined in Deltares.Standard.Forms.DExpress.SplashDialog) | Deltares.Standard.Forms.DExpress.SplashDialog |
IncrementToMaximum() (defined in Deltares.Standard.Forms.DExpress.SplashDialog) | Deltares.Standard.Forms.DExpress.SplashDialog |
IncrementToMaximum(string text) (defined in Deltares.Standard.Forms.DExpress.SplashDialog) | Deltares.Standard.Forms.DExpress.SplashDialog |
SetAssemblyInfo(Type type, string email=DEFAULT_EMAIL, string telephoneNumber=DEFAULT_TELEPHONE_NUMBER) (defined in Deltares.Standard.Forms.DExpress.SplashDialog) | Deltares.Standard.Forms.DExpress.SplashDialog |
SetAssemblyInfo(string company, string version, string license, string email, string telephoneNumber, string copyright) (defined in Deltares.Standard.Forms.DExpress.SplashDialog) | Deltares.Standard.Forms.DExpress.SplashDialog |
SetFractionPerStep(float fractionPerStep) (defined in Deltares.Standard.Forms.DExpress.SplashDialog) | Deltares.Standard.Forms.DExpress.SplashDialog |
SetProgress(float fraction) (defined in Deltares.Standard.Forms.DExpress.SplashDialog) | Deltares.Standard.Forms.DExpress.SplashDialog |
SetProgress(float fraction, string text) (defined in Deltares.Standard.Forms.DExpress.SplashDialog) | Deltares.Standard.Forms.DExpress.SplashDialog |
Splash (defined in Deltares.Standard.Forms.DExpress.SplashDialog) | Deltares.Standard.Forms.DExpress.SplashDialog |
SplashDialog() (defined in Deltares.Standard.Forms.DExpress.SplashDialog) | Deltares.Standard.Forms.DExpress.SplashDialog |
Generated on Tue Dec 15 2015 18:15:17 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.StateIndicatorGaugeBinding Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • StateIndicatorGaugeBinding
Public Member Functions | List of all members
Deltares.Standard.Forms.DExpress.StateIndicatorGaugeBinding Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.StateIndicatorGaugeBinding:
Deltares.Standard.Forms.DExpress.BaseControlBinding Deltares.Standard.Forms.DExpress.ControlBinding Deltares.Standard.Forms.DExpress.ComponentBinding Deltares.Standard.Forms.DExpress.ComponentWrappers.IGetBoundControl

Public Member Functions

StateIndicatorGaugeBinding (Component component)
override void | SetValue (object value)
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.BaseControlBinding
override void | Initialize (BindPropertyInfo propertyInfo, params string[] properties)
override void | SetLabel (string text)
override void | SetDescription (string description)
override void | Invalidate ()
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.ControlBinding
override void | SetVisible (bool visible)
override void | SetEnabled (bool enabled)
override void | SetLabel (string text)
Sets the label/title/name associated with this control. More...
override void | SetDescription (string description)
Sets the textual description associated with this control. More...
override void | SetForegroundColor (Color color)
override void | SetBackgroundColor (Color color)
override void | Invalidate ()
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
ComponentBinding (Component component)
virtual void | Initialize (BindPropertyInfo propertyInfo, Type rootObjectType, params string[] properties)
virtual void | SetTrueMapping (object trueMapping)
virtual void | SetValue (object value, object parent)
virtual void | SetDomain (ICollection collection)
virtual object | GetValue ()
virtual void | Refresh ()
virtual void | RegisterSelectionAssignment (Component targetComponent, IConverter converter=null)
Indicates that the selection of the bound control must be assigned to another control. More...
virtual void | SetControlColors (Color fore, Color back)
Sets the controls foreground and background colors. Can be overridden by a specific binding to set other colors if necessary. More...

Additional Inherited Members

- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.BaseControlBinding
BaseControlBinding (Component component)
DXPopupMenu | GetPopupMenu ()
This method uses reflection to make the context menu accessible, which otherwise is protected. The Menu property is implemented for TextEdit, so we first make sure the control is actually of this type. More...
override void | OnToolTipShown (PopupEventArgs e)
Called when Tooltip is shown, and fires ToolTipShown event. More...
override void | OnToolTipClosed ()
Called when Tooltip is hidden, and fires ToolTipHidden. More...
override void | Dispose (bool disposing)
- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.ControlBinding
ControlBinding (Component component)
void | ThreadSafeRefresh ()
override void | Dispose (bool disposing)
- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
void | RaiseValueChanged ()
void | RaiseLeave ()
void | RaiseActionPerformed ()
Type | GetGenericType (Type type)
string | ValueToString (object value)
bool | IsAssociatedPropertyVisible (object source, BindPropertyInfo associatedPropertyInfo)
Indicates whether the associated property (i.e. the property which is used to display the original property in a textbox) is visible More...
void | EditFileInfo (object source, BindPropertyInfo propertyInfo)
string | EditFileInfo (string value, string format, string label, string description, bool isDirectory)
string | GetDoubleString (string text)
bool | HasValidNumericValue (string text)
double | GetNumericValue (string text)
List< BindPropertyInfo > | GetDictionaryProperties (ICollection domain, BindPropertyInfo dynamicPropertyInfo)
- Protected Attributes inherited from Deltares.Standard.Forms.DExpress.BaseControlBinding
readonly SuperToolTip | superTip
- Protected Attributes inherited from Deltares.Standard.Forms.DExpress.ControlBinding
readonly ToolTip | tooltip
string | Description
The textual description associated with this

See also
Control

. More...

string | Label
The label/title/name associated with this Control. More...
- Protected Attributes inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
BindPropertyInfo | propInfo
- Properties inherited from Deltares.Standard.Forms.DExpress.ControlBinding
ToolTip | Tooltip [get]
Gets the tooltip for the bound control. More...
Control | BoundControl [get]
- Properties inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
Component | Component [get]
virtual bool | IsTransparant [get]
virtual HandleType | HandleDelayed [get]
virtual bool | HasDomain [get]
- Properties inherited from Deltares.Standard.Forms.DExpress.ComponentWrappers.IGetBoundControl
Control | BoundControl [get]
- Events inherited from Deltares.Standard.Forms.DExpress.ControlBinding
ToolTipVisibilityEventHandler | ToolTipHidden
ToolTipVisibilityEventHandler | ToolTipShown
- Events inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
EventHandler< EventArgs > | ActionPerformed
EventHandler< EventArgs > | Leave
EventHandler< EventArgs > | ValueChanged
Generated on Tue Dec 15 2015 18:15:18 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • StateIndicatorGaugeBinding
Deltares.Standard.Forms.DExpress.StateIndicatorGaugeBinding Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.StateIndicatorGaugeBinding, including all inherited members.

ActionPerformed (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
BaseControlBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.BaseControlBinding) | Deltares.Standard.Forms.DExpress.BaseControlBinding | protected
BoundControl (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding |
Component (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ComponentBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ControlBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Description | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Dispose(bool disposing) (defined in Deltares.Standard.Forms.DExpress.BaseControlBinding) | Deltares.Standard.Forms.DExpress.BaseControlBinding | protected
EditFileInfo(object source, BindPropertyInfo propertyInfo) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
EditFileInfo(string value, string format, string label, string description, bool isDirectory) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetDictionaryProperties(ICollection domain, BindPropertyInfo dynamicPropertyInfo) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetDoubleString(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetGenericType(Type type) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetNumericValue(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetPopupMenu() | Deltares.Standard.Forms.DExpress.BaseControlBinding | protected
GetValue() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
HandleDelayed (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
HasDomain (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
HasValidNumericValue(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Initialize(BindPropertyInfo propertyInfo, params string[] properties) (defined in Deltares.Standard.Forms.DExpress.BaseControlBinding) | Deltares.Standard.Forms.DExpress.BaseControlBinding | virtual
Initialize(BindPropertyInfo propertyInfo, Type rootObjectType, params string[] properties) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
Invalidate() (defined in Deltares.Standard.Forms.DExpress.BaseControlBinding) | Deltares.Standard.Forms.DExpress.BaseControlBinding | virtual
IsAssociatedPropertyVisible(object source, BindPropertyInfo associatedPropertyInfo) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
IsTransparant (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
Label | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Leave (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
OnToolTipClosed() | Deltares.Standard.Forms.DExpress.BaseControlBinding | protectedvirtual
OnToolTipShown(PopupEventArgs e) | Deltares.Standard.Forms.DExpress.BaseControlBinding | protectedvirtual
propInfo (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseActionPerformed() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseLeave() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseValueChanged() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Refresh() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
RegisterSelectionAssignment(Component targetComponent, IConverter converter=null) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetBackgroundColor(Color color) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
SetControlColors(Color fore, Color back) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetDescription(string description) (defined in Deltares.Standard.Forms.DExpress.BaseControlBinding) | Deltares.Standard.Forms.DExpress.BaseControlBinding | virtual
SetDomain(ICollection collection) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetEnabled(bool enabled) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
SetForegroundColor(Color color) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
SetLabel(string text) (defined in Deltares.Standard.Forms.DExpress.BaseControlBinding) | Deltares.Standard.Forms.DExpress.BaseControlBinding | virtual
SetTrueMapping(object trueMapping) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetValue(object value) (defined in Deltares.Standard.Forms.DExpress.StateIndicatorGaugeBinding) | Deltares.Standard.Forms.DExpress.StateIndicatorGaugeBinding | virtual
SetValue(object value, object parent) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetVisible(bool visible) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
StateIndicatorGaugeBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.StateIndicatorGaugeBinding) | Deltares.Standard.Forms.DExpress.StateIndicatorGaugeBinding |
superTip (defined in Deltares.Standard.Forms.DExpress.BaseControlBinding) | Deltares.Standard.Forms.DExpress.BaseControlBinding | protected
ThreadSafeRefresh() (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | protected
tooltip (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Tooltip | Deltares.Standard.Forms.DExpress.ControlBinding | protected
ToolTipHidden (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding |
ToolTipShown (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding |
ValueChanged (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ValueToString(object value) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Generated on Tue Dec 15 2015 18:15:18 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.StatusBar Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • StatusBar
Public Member Functions | Protected Member Functions | Properties | List of all members
Deltares.Standard.Forms.DExpress.StatusBar Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.StatusBar:

Public Member Functions

new void | Dispose ()
void | BindErrorButtonClick (ItemClickEventHandler handler)
void | BindWarningButtonClick (ItemClickEventHandler handler)
void | BindSuccessButtonClick (ItemClickEventHandler handler)
void | DoProgress (double progress)
Show the progress on the progress bar. More...
void | SetProgressText (string text)
Show textual progress information on the progress bar. More...

Protected Member Functions

override void Dispose (bool disposing)
Clean up any resources being used. More...

Properties

BarEditItem ProgressBar StatusBar showing progressbar and error/warning information"StatusBar"StatusBar showing progressbar and error/warning information"StatusBar" [get]

Member Function Documentation

override void Deltares.Standard.Forms.DExpress.StatusBar.Dispose ( bool disposing )
protected

Clean up any resources being used.

Parameters
disposing true if managed resources should be disposed; otherwise, false.
void Deltares.Standard.Forms.DExpress.StatusBar.DoProgress ( double progress )

Show the progress on the progress bar.

Parameters
progress The progress as a fraction.

References Deltares.Standard.Forms.DExpress.BindSupport.InvokeControl.

void Deltares.Standard.Forms.DExpress.StatusBar.SetProgressText ( string text )

Show textual progress information on the progress bar.

Parameters
text The progress information to show.

References Deltares.Standard.Forms.DExpress.BindSupport.InvokeControl.

Generated on Tue Dec 15 2015 18:15:18 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • StatusBar
Deltares.Standard.Forms.DExpress.StatusBar Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.StatusBar, including all inherited members.

BindErrorButtonClick(ItemClickEventHandler handler) (defined in Deltares.Standard.Forms.DExpress.StatusBar) | Deltares.Standard.Forms.DExpress.StatusBar |
BindSuccessButtonClick(ItemClickEventHandler handler) (defined in Deltares.Standard.Forms.DExpress.StatusBar) | Deltares.Standard.Forms.DExpress.StatusBar |
BindWarningButtonClick(ItemClickEventHandler handler) (defined in Deltares.Standard.Forms.DExpress.StatusBar) | Deltares.Standard.Forms.DExpress.StatusBar |
Dispose() (defined in Deltares.Standard.Forms.DExpress.StatusBar) | Deltares.Standard.Forms.DExpress.StatusBar |
Dispose(bool disposing) | Deltares.Standard.Forms.DExpress.StatusBar | protected
DoProgress(double progress) | Deltares.Standard.Forms.DExpress.StatusBar |
ProgressBar (defined in Deltares.Standard.Forms.DExpress.StatusBar) | Deltares.Standard.Forms.DExpress.StatusBar |
SetProgressText(string text) | Deltares.Standard.Forms.DExpress.StatusBar |
StatusBar() (defined in Deltares.Standard.Forms.DExpress.StatusBar) | Deltares.Standard.Forms.DExpress.StatusBar |
Generated on Tue Dec 15 2015 18:15:18 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.SubControlFactoryForBoolean Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • SubControlFactoryForBoolean
Protected Member Functions | List of all members
Deltares.Standard.Forms.DExpress.SubControlFactoryForBoolean Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.SubControlFactoryForBoolean:
Deltares.Standard.Forms.DExpress.SimplePropertySubControlFactory< bool, PanelTextBooleanValue >

Protected Member Functions

override PanelTextBooleanValue | CreateControl (string name)
override void | BindControl (PanelTextBooleanValue control, bool hasUnitInfo, string propertyName)
- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.SimplePropertySubControlFactory< bool, PanelTextBooleanValue >
override void | BindControl (ControlType control, bool hasUnitInfo, string propertyName)
Generated on Tue Dec 15 2015 18:15:18 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • SubControlFactoryForBoolean
Deltares.Standard.Forms.DExpress.SubControlFactoryForBoolean Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.SubControlFactoryForBoolean, including all inherited members.

BindControl(PanelTextBooleanValue control, bool hasUnitInfo, string propertyName) (defined in Deltares.Standard.Forms.DExpress.SubControlFactoryForBoolean) | Deltares.Standard.Forms.DExpress.SubControlFactoryForBoolean | protected
BindControl(ControlType control, bool hasUnitInfo, string propertyName) (defined in Deltares.Standard.Forms.DExpress.SimplePropertySubControlFactory< bool, PanelTextBooleanValue >) | Deltares.Standard.Forms.DExpress.SimplePropertySubControlFactory< bool, PanelTextBooleanValue > | protected
CreateControl(string name) (defined in Deltares.Standard.Forms.DExpress.SubControlFactoryForBoolean) | Deltares.Standard.Forms.DExpress.SubControlFactoryForBoolean | protected
Generated on Tue Dec 15 2015 18:15:18 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.SubControlFactoryForDecimal Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • SubControlFactoryForDecimal
Protected Member Functions | List of all members
Deltares.Standard.Forms.DExpress.SubControlFactoryForDecimal Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.SubControlFactoryForDecimal:
Deltares.Standard.Forms.DExpress.SimplePropertySubControlFactory< decimal, PanelTextNumericValue >

Protected Member Functions

override PanelTextNumericValue | CreateControl (string name)
- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.SimplePropertySubControlFactory< decimal, PanelTextNumericValue >
override void | BindControl (ControlType control, bool hasUnitInfo, string propertyName)
Generated on Tue Dec 15 2015 18:15:19 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • SubControlFactoryForDecimal
Deltares.Standard.Forms.DExpress.SubControlFactoryForDecimal Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.SubControlFactoryForDecimal, including all inherited members.

BindControl(ControlType control, bool hasUnitInfo, string propertyName) (defined in Deltares.Standard.Forms.DExpress.SimplePropertySubControlFactory< decimal, PanelTextNumericValue >) | Deltares.Standard.Forms.DExpress.SimplePropertySubControlFactory< decimal, PanelTextNumericValue > | protected
CreateControl(string name) (defined in Deltares.Standard.Forms.DExpress.SubControlFactoryForDecimal) | Deltares.Standard.Forms.DExpress.SubControlFactoryForDecimal | protected
Generated on Tue Dec 15 2015 18:15:19 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.SubControlFactoryForDomainProperty Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • SubControlFactoryForDomainProperty
Protected Member Functions | List of all members
Deltares.Standard.Forms.DExpress.SubControlFactoryForDomainProperty Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.SubControlFactoryForDomainProperty:
Deltares.Standard.Forms.DExpress.SimplePropertySubControlFactory< object, PanelTextComboBoxValue >

Protected Member Functions

override PanelTextComboBoxValue | CreateControl (string name)
- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.SimplePropertySubControlFactory< object, PanelTextComboBoxValue >
override void | BindControl (ControlType control, bool hasUnitInfo, string propertyName)
Generated on Tue Dec 15 2015 18:15:19 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • SubControlFactoryForDomainProperty
Deltares.Standard.Forms.DExpress.SubControlFactoryForDomainProperty Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.SubControlFactoryForDomainProperty, including all inherited members.

BindControl(ControlType control, bool hasUnitInfo, string propertyName) (defined in Deltares.Standard.Forms.DExpress.SimplePropertySubControlFactory< object, PanelTextComboBoxValue >) | Deltares.Standard.Forms.DExpress.SimplePropertySubControlFactory< object, PanelTextComboBoxValue > | protected
CreateControl(string name) (defined in Deltares.Standard.Forms.DExpress.SubControlFactoryForDomainProperty) | Deltares.Standard.Forms.DExpress.SubControlFactoryForDomainProperty | protected
Generated on Tue Dec 15 2015 18:15:19 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.SubControlFactoryForDouble Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • SubControlFactoryForDouble
Protected Member Functions | List of all members
Deltares.Standard.Forms.DExpress.SubControlFactoryForDouble Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.SubControlFactoryForDouble:
Deltares.Standard.Forms.DExpress.SimplePropertySubControlFactory< double, PanelTextNumericValue >

Protected Member Functions

override PanelTextNumericValue | CreateControl (string name)
- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.SimplePropertySubControlFactory< double, PanelTextNumericValue >
override void | BindControl (ControlType control, bool hasUnitInfo, string propertyName)
Generated on Tue Dec 15 2015 18:15:19 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • SubControlFactoryForDouble
Deltares.Standard.Forms.DExpress.SubControlFactoryForDouble Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.SubControlFactoryForDouble, including all inherited members.

BindControl(ControlType control, bool hasUnitInfo, string propertyName) (defined in Deltares.Standard.Forms.DExpress.SimplePropertySubControlFactory< double, PanelTextNumericValue >) | Deltares.Standard.Forms.DExpress.SimplePropertySubControlFactory< double, PanelTextNumericValue > | protected
CreateControl(string name) (defined in Deltares.Standard.Forms.DExpress.SubControlFactoryForDouble) | Deltares.Standard.Forms.DExpress.SubControlFactoryForDouble | protected
Generated on Tue Dec 15 2015 18:15:19 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.SubControlFactoryForEnum Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • SubControlFactoryForEnum
Protected Member Functions | List of all members
Deltares.Standard.Forms.DExpress.SubControlFactoryForEnum Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.SubControlFactoryForEnum:
Deltares.Standard.Forms.DExpress.SimplePropertySubControlFactory< Enum, PanelTextComboBoxValue >

Protected Member Functions

override PanelTextComboBoxValue | CreateControl (string name)
- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.SimplePropertySubControlFactory< Enum, PanelTextComboBoxValue >
override void | BindControl (ControlType control, bool hasUnitInfo, string propertyName)
Generated on Tue Dec 15 2015 18:15:19 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • SubControlFactoryForEnum
Deltares.Standard.Forms.DExpress.SubControlFactoryForEnum Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.SubControlFactoryForEnum, including all inherited members.

BindControl(ControlType control, bool hasUnitInfo, string propertyName) (defined in Deltares.Standard.Forms.DExpress.SimplePropertySubControlFactory< Enum, PanelTextComboBoxValue >) | Deltares.Standard.Forms.DExpress.SimplePropertySubControlFactory< Enum, PanelTextComboBoxValue > | protected
CreateControl(string name) (defined in Deltares.Standard.Forms.DExpress.SubControlFactoryForEnum) | Deltares.Standard.Forms.DExpress.SubControlFactoryForEnum | protected
Generated on Tue Dec 15 2015 18:15:19 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.SubControlFactoryForFileInfo Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • SubControlFactoryForFileInfo
Protected Member Functions | List of all members
Deltares.Standard.Forms.DExpress.SubControlFactoryForFileInfo Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.SubControlFactoryForFileInfo:
Deltares.Standard.Forms.DExpress.SimplePropertySubControlFactory< FileInfo, PanelTextPathValue >

Protected Member Functions

override PanelTextPathValue | CreateControl (string name)
- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.SimplePropertySubControlFactory< FileInfo, PanelTextPathValue >
override void | BindControl (ControlType control, bool hasUnitInfo, string propertyName)
Generated on Tue Dec 15 2015 18:15:20 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • SubControlFactoryForFileInfo
Deltares.Standard.Forms.DExpress.SubControlFactoryForFileInfo Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.SubControlFactoryForFileInfo, including all inherited members.

BindControl(ControlType control, bool hasUnitInfo, string propertyName) (defined in Deltares.Standard.Forms.DExpress.SimplePropertySubControlFactory< FileInfo, PanelTextPathValue >) | Deltares.Standard.Forms.DExpress.SimplePropertySubControlFactory< FileInfo, PanelTextPathValue > | protected
CreateControl(string name) (defined in Deltares.Standard.Forms.DExpress.SubControlFactoryForFileInfo) | Deltares.Standard.Forms.DExpress.SubControlFactoryForFileInfo | protected
Generated on Tue Dec 15 2015 18:15:20 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.SubControlFactoryForInteger Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • SubControlFactoryForInteger
Protected Member Functions | List of all members
Deltares.Standard.Forms.DExpress.SubControlFactoryForInteger Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.SubControlFactoryForInteger:
Deltares.Standard.Forms.DExpress.SimplePropertySubControlFactory< int, PanelTextNumericValue >

Protected Member Functions

override PanelTextNumericValue | CreateControl (string name)
- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.SimplePropertySubControlFactory< int, PanelTextNumericValue >
override void | BindControl (ControlType control, bool hasUnitInfo, string propertyName)
Generated on Tue Dec 15 2015 18:15:20 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • SubControlFactoryForInteger
Deltares.Standard.Forms.DExpress.SubControlFactoryForInteger Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.SubControlFactoryForInteger, including all inherited members.

BindControl(ControlType control, bool hasUnitInfo, string propertyName) (defined in Deltares.Standard.Forms.DExpress.SimplePropertySubControlFactory< int, PanelTextNumericValue >) | Deltares.Standard.Forms.DExpress.SimplePropertySubControlFactory< int, PanelTextNumericValue > | protected
CreateControl(string name) (defined in Deltares.Standard.Forms.DExpress.SubControlFactoryForInteger) | Deltares.Standard.Forms.DExpress.SubControlFactoryForInteger | protected
Generated on Tue Dec 15 2015 18:15:20 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.SubControlFactoryForLinkedObject Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • SubControlFactoryForLinkedObject
Protected Member Functions | List of all members
Deltares.Standard.Forms.DExpress.SubControlFactoryForLinkedObject Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.SubControlFactoryForLinkedObject:
Deltares.Standard.Forms.DExpress.SimplePropertySubControlFactory< List< object >, PanelTextLinkValue >

Protected Member Functions

override PanelTextLinkValue | CreateControl (string name)
- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.SimplePropertySubControlFactory< List< object >, PanelTextLinkValue >
override void | BindControl (ControlType control, bool hasUnitInfo, string propertyName)
Generated on Tue Dec 15 2015 18:15:20 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • SubControlFactoryForLinkedObject
Deltares.Standard.Forms.DExpress.SubControlFactoryForLinkedObject Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.SubControlFactoryForLinkedObject, including all inherited members.

BindControl(ControlType control, bool hasUnitInfo, string propertyName) (defined in Deltares.Standard.Forms.DExpress.SimplePropertySubControlFactory< List< object >, PanelTextLinkValue >) | Deltares.Standard.Forms.DExpress.SimplePropertySubControlFactory< List< object >, PanelTextLinkValue > | protected
CreateControl(string name) (defined in Deltares.Standard.Forms.DExpress.SubControlFactoryForLinkedObject) | Deltares.Standard.Forms.DExpress.SubControlFactoryForLinkedObject | protected
Generated on Tue Dec 15 2015 18:15:20 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.SubControlFactoryForList Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • SubControlFactoryForList
Protected Member Functions | List of all members
Deltares.Standard.Forms.DExpress.SubControlFactoryForList Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.SubControlFactoryForList:
Deltares.Standard.Forms.DExpress.BasicPropertySubControlFactory< IList, GridViewControl >

Protected Member Functions

override GridViewControl | CreateControl (string name)
override void | BindControl (GridViewControl control, bool hasUnitInfo, string propertyName)
- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.BasicPropertySubControlFactory< IList, GridViewControl >
abstract void | BindControl (ControlType control, bool hasUnitInfo, string propertyName)

Additional Inherited Members

- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.BasicPropertySubControlFactory< IList, GridViewControl >
ControlType | CreateBoundControl (PropertyInfo propertyInfo, Type dataType, Component parentComponent)
- Properties inherited from Deltares.Standard.Forms.DExpress.BasicPropertySubControlFactory< IList, GridViewControl >
Type | ValueType [get]
PropertyInfo | PropertyInfo [get]
Type | DataType [get]
Component | ParentComponent [get]
Generated on Tue Dec 15 2015 18:15:21 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • SubControlFactoryForList
Deltares.Standard.Forms.DExpress.SubControlFactoryForList Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.SubControlFactoryForList, including all inherited members.

BindControl(GridViewControl control, bool hasUnitInfo, string propertyName) (defined in Deltares.Standard.Forms.DExpress.SubControlFactoryForList) | Deltares.Standard.Forms.DExpress.SubControlFactoryForList | protected
BindControl(ControlType control, bool hasUnitInfo, string propertyName) (defined in Deltares.Standard.Forms.DExpress.BasicPropertySubControlFactory< IList, GridViewControl >) | Deltares.Standard.Forms.DExpress.BasicPropertySubControlFactory< IList, GridViewControl > | protectedpure virtual
CreateBoundControl(PropertyInfo propertyInfo, Type dataType, Component parentComponent) (defined in Deltares.Standard.Forms.DExpress.BasicPropertySubControlFactory< IList, GridViewControl >) | Deltares.Standard.Forms.DExpress.BasicPropertySubControlFactory< IList, GridViewControl > |
CreateControl(string name) (defined in Deltares.Standard.Forms.DExpress.SubControlFactoryForList) | Deltares.Standard.Forms.DExpress.SubControlFactoryForList | protectedvirtual
DataType (defined in Deltares.Standard.Forms.DExpress.BasicPropertySubControlFactory< IList, GridViewControl >) | Deltares.Standard.Forms.DExpress.BasicPropertySubControlFactory< IList, GridViewControl > | protected
ParentComponent (defined in Deltares.Standard.Forms.DExpress.BasicPropertySubControlFactory< IList, GridViewControl >) | Deltares.Standard.Forms.DExpress.BasicPropertySubControlFactory< IList, GridViewControl > | protected
PropertyInfo (defined in Deltares.Standard.Forms.DExpress.BasicPropertySubControlFactory< IList, GridViewControl >) | Deltares.Standard.Forms.DExpress.BasicPropertySubControlFactory< IList, GridViewControl > | protected
ValueType (defined in Deltares.Standard.Forms.DExpress.BasicPropertySubControlFactory< IList, GridViewControl >) | Deltares.Standard.Forms.DExpress.BasicPropertySubControlFactory< IList, GridViewControl > |
Generated on Tue Dec 15 2015 18:15:21 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.SubControlFactoryForStochast Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • SubControlFactoryForStochast
Protected Member Functions | List of all members
Deltares.Standard.Forms.DExpress.SubControlFactoryForStochast Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.SubControlFactoryForStochast:
Deltares.Standard.Forms.DExpress.SimplePropertySubControlFactory< Stochast, PanelTextPopupContainerEdit >

Protected Member Functions

override PanelTextPopupContainerEdit | CreateControl (string name)
- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.SimplePropertySubControlFactory< Stochast, PanelTextPopupContainerEdit >
override void | BindControl (ControlType control, bool hasUnitInfo, string propertyName)
Generated on Tue Dec 15 2015 18:15:21 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • SubControlFactoryForStochast
Deltares.Standard.Forms.DExpress.SubControlFactoryForStochast Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.SubControlFactoryForStochast, including all inherited members.

BindControl(ControlType control, bool hasUnitInfo, string propertyName) (defined in Deltares.Standard.Forms.DExpress.SimplePropertySubControlFactory< Stochast, PanelTextPopupContainerEdit >) | Deltares.Standard.Forms.DExpress.SimplePropertySubControlFactory< Stochast, PanelTextPopupContainerEdit > | protected
CreateControl(string name) (defined in Deltares.Standard.Forms.DExpress.SubControlFactoryForStochast) | Deltares.Standard.Forms.DExpress.SubControlFactoryForStochast | protected
Generated on Tue Dec 15 2015 18:15:21 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.SubControlFactoryForString Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • SubControlFactoryForString
Protected Member Functions | List of all members
Deltares.Standard.Forms.DExpress.SubControlFactoryForString Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.SubControlFactoryForString:
Deltares.Standard.Forms.DExpress.SimplePropertySubControlFactory< string, PanelTextStringValue >

Protected Member Functions

override PanelTextStringValue | CreateControl (string name)
- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.SimplePropertySubControlFactory< string, PanelTextStringValue >
override void | BindControl (ControlType control, bool hasUnitInfo, string propertyName)
Generated on Tue Dec 15 2015 18:15:21 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • SubControlFactoryForString
Deltares.Standard.Forms.DExpress.SubControlFactoryForString Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.SubControlFactoryForString, including all inherited members.

BindControl(ControlType control, bool hasUnitInfo, string propertyName) (defined in Deltares.Standard.Forms.DExpress.SimplePropertySubControlFactory< string, PanelTextStringValue >) | Deltares.Standard.Forms.DExpress.SimplePropertySubControlFactory< string, PanelTextStringValue > | protected
CreateControl(string name) (defined in Deltares.Standard.Forms.DExpress.SubControlFactoryForString) | Deltares.Standard.Forms.DExpress.SubControlFactoryForString | protected
Generated on Tue Dec 15 2015 18:15:21 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.TextEditBinding Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • TextEditBinding
Public Member Functions | Properties | List of all members
Deltares.Standard.Forms.DExpress.TextEditBinding Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.TextEditBinding:
Deltares.Standard.Forms.DExpress.BaseControlBinding Deltares.Standard.Forms.DExpress.ControlBinding Deltares.Standard.Forms.DExpress.ComponentBinding Deltares.Standard.Forms.DExpress.ComponentWrappers.IGetBoundControl

Public Member Functions

TextEditBinding (Component component)
override void | Initialize (BindPropertyInfo propertyInfo, params string[] properties)
override void | SetValue (object value, object parent)
override object | GetValue ()
override void | SetEnabled (bool enabled)
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.BaseControlBinding
override void | SetLabel (string text)
override void | SetDescription (string description)
override void | Invalidate ()
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.ControlBinding
override void | SetVisible (bool visible)
override void | SetLabel (string text)
Sets the label/title/name associated with this control. More...
override void | SetDescription (string description)
Sets the textual description associated with this control. More...
override void | SetForegroundColor (Color color)
override void | SetBackgroundColor (Color color)
override void | Invalidate ()
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
ComponentBinding (Component component)
virtual void | Initialize (BindPropertyInfo propertyInfo, Type rootObjectType, params string[] properties)
virtual void | SetTrueMapping (object trueMapping)
virtual void | SetValue (object value)
virtual void | SetDomain (ICollection collection)
virtual void | Refresh ()
virtual void | RegisterSelectionAssignment (Component targetComponent, IConverter converter=null)
Indicates that the selection of the bound control must be assigned to another control. More...
virtual void | SetControlColors (Color fore, Color back)
Sets the controls foreground and background colors. Can be overridden by a specific binding to set other colors if necessary. More...

Properties

override HandleType | HandleDelayed [get]
- Properties inherited from Deltares.Standard.Forms.DExpress.ControlBinding
ToolTip | Tooltip [get]
Gets the tooltip for the bound control. More...
Control | BoundControl [get]
- Properties inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
Component | Component [get]
virtual bool | IsTransparant [get]
virtual HandleType | HandleDelayed [get]
virtual bool | HasDomain [get]
- Properties inherited from Deltares.Standard.Forms.DExpress.ComponentWrappers.IGetBoundControl
Control | BoundControl [get]

Additional Inherited Members

- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.BaseControlBinding
BaseControlBinding (Component component)
DXPopupMenu | GetPopupMenu ()
This method uses reflection to make the context menu accessible, which otherwise is protected. The Menu property is implemented for TextEdit, so we first make sure the control is actually of this type. More...
override void | OnToolTipShown (PopupEventArgs e)
Called when Tooltip is shown, and fires ToolTipShown event. More...
override void | OnToolTipClosed ()
Called when Tooltip is hidden, and fires ToolTipHidden. More...
override void | Dispose (bool disposing)
- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.ControlBinding
ControlBinding (Component component)
void | ThreadSafeRefresh ()
override void | Dispose (bool disposing)
- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
void | RaiseValueChanged ()
void | RaiseLeave ()
void | RaiseActionPerformed ()
Type | GetGenericType (Type type)
string | ValueToString (object value)
bool | IsAssociatedPropertyVisible (object source, BindPropertyInfo associatedPropertyInfo)
Indicates whether the associated property (i.e. the property which is used to display the original property in a textbox) is visible More...
void | EditFileInfo (object source, BindPropertyInfo propertyInfo)
string | EditFileInfo (string value, string format, string label, string description, bool isDirectory)
string | GetDoubleString (string text)
bool | HasValidNumericValue (string text)
double | GetNumericValue (string text)
List< BindPropertyInfo > | GetDictionaryProperties (ICollection domain, BindPropertyInfo dynamicPropertyInfo)
- Protected Attributes inherited from Deltares.Standard.Forms.DExpress.BaseControlBinding
readonly SuperToolTip | superTip
- Protected Attributes inherited from Deltares.Standard.Forms.DExpress.ControlBinding
readonly ToolTip | tooltip
string | Description
The textual description associated with this

See also
Control

. More...

string | Label
The label/title/name associated with this Control. More...
- Protected Attributes inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
BindPropertyInfo | propInfo
- Events inherited from Deltares.Standard.Forms.DExpress.ControlBinding
ToolTipVisibilityEventHandler | ToolTipHidden
ToolTipVisibilityEventHandler | ToolTipShown
- Events inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
EventHandler< EventArgs > | ActionPerformed
EventHandler< EventArgs > | Leave
EventHandler< EventArgs > | ValueChanged
Generated on Tue Dec 15 2015 18:15:21 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • TextEditBinding
Deltares.Standard.Forms.DExpress.TextEditBinding Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.TextEditBinding, including all inherited members.

ActionPerformed (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
BaseControlBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.BaseControlBinding) | Deltares.Standard.Forms.DExpress.BaseControlBinding | protected
BoundControl (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding |
Component (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ComponentBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ControlBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Description | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Dispose(bool disposing) (defined in Deltares.Standard.Forms.DExpress.BaseControlBinding) | Deltares.Standard.Forms.DExpress.BaseControlBinding | protected
EditFileInfo(object source, BindPropertyInfo propertyInfo) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
EditFileInfo(string value, string format, string label, string description, bool isDirectory) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetDictionaryProperties(ICollection domain, BindPropertyInfo dynamicPropertyInfo) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetDoubleString(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetGenericType(Type type) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetNumericValue(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetPopupMenu() | Deltares.Standard.Forms.DExpress.BaseControlBinding | protected
GetValue() (defined in Deltares.Standard.Forms.DExpress.TextEditBinding) | Deltares.Standard.Forms.DExpress.TextEditBinding | virtual
HandleDelayed (defined in Deltares.Standard.Forms.DExpress.TextEditBinding) | Deltares.Standard.Forms.DExpress.TextEditBinding |
HasDomain (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
HasValidNumericValue(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Initialize(BindPropertyInfo propertyInfo, params string[] properties) (defined in Deltares.Standard.Forms.DExpress.TextEditBinding) | Deltares.Standard.Forms.DExpress.TextEditBinding | virtual
Initialize(BindPropertyInfo propertyInfo, Type rootObjectType, params string[] properties) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
Invalidate() (defined in Deltares.Standard.Forms.DExpress.BaseControlBinding) | Deltares.Standard.Forms.DExpress.BaseControlBinding | virtual
IsAssociatedPropertyVisible(object source, BindPropertyInfo associatedPropertyInfo) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
IsTransparant (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
Label | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Leave (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
OnToolTipClosed() | Deltares.Standard.Forms.DExpress.BaseControlBinding | protectedvirtual
OnToolTipShown(PopupEventArgs e) | Deltares.Standard.Forms.DExpress.BaseControlBinding | protectedvirtual
propInfo (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseActionPerformed() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseLeave() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseValueChanged() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Refresh() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
RegisterSelectionAssignment(Component targetComponent, IConverter converter=null) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetBackgroundColor(Color color) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
SetControlColors(Color fore, Color back) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetDescription(string description) (defined in Deltares.Standard.Forms.DExpress.BaseControlBinding) | Deltares.Standard.Forms.DExpress.BaseControlBinding | virtual
SetDomain(ICollection collection) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetEnabled(bool enabled) (defined in Deltares.Standard.Forms.DExpress.TextEditBinding) | Deltares.Standard.Forms.DExpress.TextEditBinding | virtual
SetForegroundColor(Color color) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
SetLabel(string text) (defined in Deltares.Standard.Forms.DExpress.BaseControlBinding) | Deltares.Standard.Forms.DExpress.BaseControlBinding | virtual
SetTrueMapping(object trueMapping) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetValue(object value, object parent) (defined in Deltares.Standard.Forms.DExpress.TextEditBinding) | Deltares.Standard.Forms.DExpress.TextEditBinding | virtual
SetValue(object value) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetVisible(bool visible) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
superTip (defined in Deltares.Standard.Forms.DExpress.BaseControlBinding) | Deltares.Standard.Forms.DExpress.BaseControlBinding | protected
TextEditBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.TextEditBinding) | Deltares.Standard.Forms.DExpress.TextEditBinding |
ThreadSafeRefresh() (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | protected
tooltip (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Tooltip | Deltares.Standard.Forms.DExpress.ControlBinding | protected
ToolTipHidden (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding |
ToolTipShown (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding |
ValueChanged (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ValueToString(object value) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Generated on Tue Dec 15 2015 18:15:21 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.ToolStripMenuItemBinding Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • ToolStripMenuItemBinding
Public Member Functions | List of all members
Deltares.Standard.Forms.DExpress.ToolStripMenuItemBinding Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.ToolStripMenuItemBinding:
Deltares.Standard.Forms.DExpress.ComponentBinding

Public Member Functions

ToolStripMenuItemBinding (Component component)
override void | Initialize (BindPropertyInfo propertyInfo, params string[] properties)
override void | SetValue (object value)
override object | GetValue ()
override void | SetEnabled (bool enabled)
override void | SetVisible (bool visible)
override void | SetLabel (string text)
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
ComponentBinding (Component component)
virtual void | Initialize (BindPropertyInfo propertyInfo, Type rootObjectType, params string[] properties)
virtual void | SetTrueMapping (object trueMapping)
virtual void | SetValue (object value, object parent)
virtual void | SetDomain (ICollection collection)
virtual void | SetDescription (string description)
virtual void | SetForegroundColor (Color color)
virtual void | SetBackgroundColor (Color color)
virtual void | Refresh ()
virtual void | Invalidate ()
virtual void | RegisterSelectionAssignment (Component targetComponent, IConverter converter=null)
Indicates that the selection of the bound control must be assigned to another control. More...
virtual void | SetControlColors (Color fore, Color back)
Sets the controls foreground and background colors. Can be overridden by a specific binding to set other colors if necessary. More...

Additional Inherited Members

- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
void | RaiseValueChanged ()
void | RaiseLeave ()
void | RaiseActionPerformed ()
Type | GetGenericType (Type type)
string | ValueToString (object value)
bool | IsAssociatedPropertyVisible (object source, BindPropertyInfo associatedPropertyInfo)
Indicates whether the associated property (i.e. the property which is used to display the original property in a textbox) is visible More...
void | EditFileInfo (object source, BindPropertyInfo propertyInfo)
string | EditFileInfo (string value, string format, string label, string description, bool isDirectory)
string | GetDoubleString (string text)
bool | HasValidNumericValue (string text)
double | GetNumericValue (string text)
List< BindPropertyInfo > | GetDictionaryProperties (ICollection domain, BindPropertyInfo dynamicPropertyInfo)
- Protected Attributes inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
BindPropertyInfo | propInfo
- Properties inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
Component | Component [get]
virtual bool | IsTransparant [get]
virtual HandleType | HandleDelayed [get]
virtual bool | HasDomain [get]
- Events inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
EventHandler< EventArgs > | ActionPerformed
EventHandler< EventArgs > | Leave
EventHandler< EventArgs > | ValueChanged
Generated on Tue Dec 15 2015 18:15:22 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • ToolStripMenuItemBinding
Deltares.Standard.Forms.DExpress.ToolStripMenuItemBinding Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.ToolStripMenuItemBinding, including all inherited members.

ActionPerformed (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
Component (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ComponentBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
EditFileInfo(object source, BindPropertyInfo propertyInfo) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
EditFileInfo(string value, string format, string label, string description, bool isDirectory) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetDictionaryProperties(ICollection domain, BindPropertyInfo dynamicPropertyInfo) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetDoubleString(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetGenericType(Type type) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetNumericValue(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetValue() (defined in Deltares.Standard.Forms.DExpress.ToolStripMenuItemBinding) | Deltares.Standard.Forms.DExpress.ToolStripMenuItemBinding | virtual
HandleDelayed (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
HasDomain (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
HasValidNumericValue(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Initialize(BindPropertyInfo propertyInfo, params string[] properties) (defined in Deltares.Standard.Forms.DExpress.ToolStripMenuItemBinding) | Deltares.Standard.Forms.DExpress.ToolStripMenuItemBinding | virtual
Initialize(BindPropertyInfo propertyInfo, Type rootObjectType, params string[] properties) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
Invalidate() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
IsAssociatedPropertyVisible(object source, BindPropertyInfo associatedPropertyInfo) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
IsTransparant (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
Leave (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
propInfo (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseActionPerformed() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseLeave() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseValueChanged() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Refresh() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
RegisterSelectionAssignment(Component targetComponent, IConverter converter=null) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetBackgroundColor(Color color) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetControlColors(Color fore, Color back) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetDescription(string description) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetDomain(ICollection collection) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetEnabled(bool enabled) (defined in Deltares.Standard.Forms.DExpress.ToolStripMenuItemBinding) | Deltares.Standard.Forms.DExpress.ToolStripMenuItemBinding | virtual
SetForegroundColor(Color color) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetLabel(string text) (defined in Deltares.Standard.Forms.DExpress.ToolStripMenuItemBinding) | Deltares.Standard.Forms.DExpress.ToolStripMenuItemBinding | virtual
SetTrueMapping(object trueMapping) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetValue(object value) (defined in Deltares.Standard.Forms.DExpress.ToolStripMenuItemBinding) | Deltares.Standard.Forms.DExpress.ToolStripMenuItemBinding | virtual
SetValue(object value, object parent) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetVisible(bool visible) (defined in Deltares.Standard.Forms.DExpress.ToolStripMenuItemBinding) | Deltares.Standard.Forms.DExpress.ToolStripMenuItemBinding | virtual
ToolStripMenuItemBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.ToolStripMenuItemBinding) | Deltares.Standard.Forms.DExpress.ToolStripMenuItemBinding |
ValueChanged (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ValueToString(object value) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Generated on Tue Dec 15 2015 18:15:22 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.ToolTipVisibilityEventArgs Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • ToolTipVisibilityEventArgs
Properties | List of all members
Deltares.Standard.Forms.DExpress.ToolTipVisibilityEventArgs Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.ToolTipVisibilityEventArgs:

Properties

Control Control [get, set]
Gets or sets the control for which a tooltip was shown or hidden. More...

Property Documentation

Control Deltares.Standard.Forms.DExpress.ToolTipVisibilityEventArgs.Control
getset

Gets or sets the control for which a tooltip was shown or hidden.

Generated on Tue Dec 15 2015 18:15:22 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • ToolTipVisibilityEventArgs
Deltares.Standard.Forms.DExpress.ToolTipVisibilityEventArgs Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.ToolTipVisibilityEventArgs, including all inherited members.

Control Deltares.Standard.Forms.DExpress.ToolTipVisibilityEventArgs
Generated on Tue Dec 15 2015 18:15:22 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.TrackBarControlBinding Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • TrackBarControlBinding
Public Member Functions | Properties | List of all members
Deltares.Standard.Forms.DExpress.TrackBarControlBinding Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.TrackBarControlBinding:
Deltares.Standard.Forms.DExpress.BaseControlBinding Deltares.Standard.Forms.DExpress.ControlBinding Deltares.Standard.Forms.DExpress.ComponentBinding Deltares.Standard.Forms.DExpress.ComponentWrappers.IGetBoundControl

Public Member Functions

TrackBarControlBinding (Component component)
override void | Initialize (BindPropertyInfo propertyInfo, params string[] properties)
override void | SetValue (object value)
override object | GetValue ()
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.BaseControlBinding
override void | SetLabel (string text)
override void | SetDescription (string description)
override void | Invalidate ()
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.ControlBinding
override void | SetVisible (bool visible)
override void | SetEnabled (bool enabled)
override void | SetLabel (string text)
Sets the label/title/name associated with this control. More...
override void | SetDescription (string description)
Sets the textual description associated with this control. More...
override void | SetForegroundColor (Color color)
override void | SetBackgroundColor (Color color)
override void | Invalidate ()
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
ComponentBinding (Component component)
virtual void | Initialize (BindPropertyInfo propertyInfo, Type rootObjectType, params string[] properties)
virtual void | SetTrueMapping (object trueMapping)
virtual void | SetValue (object value, object parent)
virtual void | SetDomain (ICollection collection)
virtual void | Refresh ()
virtual void | RegisterSelectionAssignment (Component targetComponent, IConverter converter=null)
Indicates that the selection of the bound control must be assigned to another control. More...
virtual void | SetControlColors (Color fore, Color back)
Sets the controls foreground and background colors. Can be overridden by a specific binding to set other colors if necessary. More...

Properties

override HandleType | HandleDelayed [get]
- Properties inherited from Deltares.Standard.Forms.DExpress.ControlBinding
ToolTip | Tooltip [get]
Gets the tooltip for the bound control. More...
Control | BoundControl [get]
- Properties inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
Component | Component [get]
virtual bool | IsTransparant [get]
virtual HandleType | HandleDelayed [get]
virtual bool | HasDomain [get]
- Properties inherited from Deltares.Standard.Forms.DExpress.ComponentWrappers.IGetBoundControl
Control | BoundControl [get]

Additional Inherited Members

- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.BaseControlBinding
BaseControlBinding (Component component)
DXPopupMenu | GetPopupMenu ()
This method uses reflection to make the context menu accessible, which otherwise is protected. The Menu property is implemented for TextEdit, so we first make sure the control is actually of this type. More...
override void | OnToolTipShown (PopupEventArgs e)
Called when Tooltip is shown, and fires ToolTipShown event. More...
override void | OnToolTipClosed ()
Called when Tooltip is hidden, and fires ToolTipHidden. More...
override void | Dispose (bool disposing)
- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.ControlBinding
ControlBinding (Component component)
void | ThreadSafeRefresh ()
override void | Dispose (bool disposing)
- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
void | RaiseValueChanged ()
void | RaiseLeave ()
void | RaiseActionPerformed ()
Type | GetGenericType (Type type)
string | ValueToString (object value)
bool | IsAssociatedPropertyVisible (object source, BindPropertyInfo associatedPropertyInfo)
Indicates whether the associated property (i.e. the property which is used to display the original property in a textbox) is visible More...
void | EditFileInfo (object source, BindPropertyInfo propertyInfo)
string | EditFileInfo (string value, string format, string label, string description, bool isDirectory)
string | GetDoubleString (string text)
bool | HasValidNumericValue (string text)
double | GetNumericValue (string text)
List< BindPropertyInfo > | GetDictionaryProperties (ICollection domain, BindPropertyInfo dynamicPropertyInfo)
- Protected Attributes inherited from Deltares.Standard.Forms.DExpress.BaseControlBinding
readonly SuperToolTip | superTip
- Protected Attributes inherited from Deltares.Standard.Forms.DExpress.ControlBinding
readonly ToolTip | tooltip
string | Description
The textual description associated with this

See also
Control

. More...

string | Label
The label/title/name associated with this Control. More...
- Protected Attributes inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
BindPropertyInfo | propInfo
- Events inherited from Deltares.Standard.Forms.DExpress.ControlBinding
ToolTipVisibilityEventHandler | ToolTipHidden
ToolTipVisibilityEventHandler | ToolTipShown
- Events inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
EventHandler< EventArgs > | ActionPerformed
EventHandler< EventArgs > | Leave
EventHandler< EventArgs > | ValueChanged
Generated on Tue Dec 15 2015 18:15:22 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • TrackBarControlBinding
Deltares.Standard.Forms.DExpress.TrackBarControlBinding Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.TrackBarControlBinding, including all inherited members.

ActionPerformed (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
BaseControlBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.BaseControlBinding) | Deltares.Standard.Forms.DExpress.BaseControlBinding | protected
BoundControl (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding |
Component (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ComponentBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ControlBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Description | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Dispose(bool disposing) (defined in Deltares.Standard.Forms.DExpress.BaseControlBinding) | Deltares.Standard.Forms.DExpress.BaseControlBinding | protected
EditFileInfo(object source, BindPropertyInfo propertyInfo) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
EditFileInfo(string value, string format, string label, string description, bool isDirectory) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetDictionaryProperties(ICollection domain, BindPropertyInfo dynamicPropertyInfo) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetDoubleString(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetGenericType(Type type) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetNumericValue(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetPopupMenu() | Deltares.Standard.Forms.DExpress.BaseControlBinding | protected
GetValue() (defined in Deltares.Standard.Forms.DExpress.TrackBarControlBinding) | Deltares.Standard.Forms.DExpress.TrackBarControlBinding | virtual
HandleDelayed (defined in Deltares.Standard.Forms.DExpress.TrackBarControlBinding) | Deltares.Standard.Forms.DExpress.TrackBarControlBinding |
HasDomain (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
HasValidNumericValue(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Initialize(BindPropertyInfo propertyInfo, params string[] properties) (defined in Deltares.Standard.Forms.DExpress.TrackBarControlBinding) | Deltares.Standard.Forms.DExpress.TrackBarControlBinding | virtual
Initialize(BindPropertyInfo propertyInfo, Type rootObjectType, params string[] properties) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
Invalidate() (defined in Deltares.Standard.Forms.DExpress.BaseControlBinding) | Deltares.Standard.Forms.DExpress.BaseControlBinding | virtual
IsAssociatedPropertyVisible(object source, BindPropertyInfo associatedPropertyInfo) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
IsTransparant (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
Label | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Leave (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
OnToolTipClosed() | Deltares.Standard.Forms.DExpress.BaseControlBinding | protectedvirtual
OnToolTipShown(PopupEventArgs e) | Deltares.Standard.Forms.DExpress.BaseControlBinding | protectedvirtual
propInfo (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseActionPerformed() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseLeave() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseValueChanged() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Refresh() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
RegisterSelectionAssignment(Component targetComponent, IConverter converter=null) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetBackgroundColor(Color color) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
SetControlColors(Color fore, Color back) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetDescription(string description) (defined in Deltares.Standard.Forms.DExpress.BaseControlBinding) | Deltares.Standard.Forms.DExpress.BaseControlBinding | virtual
SetDomain(ICollection collection) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetEnabled(bool enabled) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
SetForegroundColor(Color color) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
SetLabel(string text) (defined in Deltares.Standard.Forms.DExpress.BaseControlBinding) | Deltares.Standard.Forms.DExpress.BaseControlBinding | virtual
SetTrueMapping(object trueMapping) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetValue(object value) (defined in Deltares.Standard.Forms.DExpress.TrackBarControlBinding) | Deltares.Standard.Forms.DExpress.TrackBarControlBinding | virtual
SetValue(object value, object parent) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetVisible(bool visible) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
superTip (defined in Deltares.Standard.Forms.DExpress.BaseControlBinding) | Deltares.Standard.Forms.DExpress.BaseControlBinding | protected
ThreadSafeRefresh() (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | protected
tooltip (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Tooltip | Deltares.Standard.Forms.DExpress.ControlBinding | protected
ToolTipHidden (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding |
ToolTipShown (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding |
TrackBarControlBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.TrackBarControlBinding) | Deltares.Standard.Forms.DExpress.TrackBarControlBinding |
ValueChanged (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ValueToString(object value) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Generated on Tue Dec 15 2015 18:15:22 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.TreeListBinding Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • TreeListBinding
Public Member Functions | List of all members
Deltares.Standard.Forms.DExpress.TreeListBinding Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.TreeListBinding:
Deltares.Standard.Forms.DExpress.ControlBinding Deltares.Standard.Forms.DExpress.ComponentBinding Deltares.Standard.Forms.DExpress.ComponentWrappers.IGetBoundControl

Public Member Functions

TreeListBinding (Component component)
override void | Refresh ()
override void | SetEnabled (bool enabled)
override void | Initialize (BindPropertyInfo propertyInfo, params string[] properties)
override void | Initialize (BindPropertyInfo propertyInfo, Type rootObjectType, params string[] properties)
override void | SetValue (object value)
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.ControlBinding
override void | SetVisible (bool visible)
override void | SetLabel (string text)
Sets the label/title/name associated with this control. More...
override void | SetDescription (string description)
Sets the textual description associated with this control. More...
override void | SetForegroundColor (Color color)
override void | SetBackgroundColor (Color color)
override void | Invalidate ()
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
ComponentBinding (Component component)
virtual void | SetTrueMapping (object trueMapping)
virtual void | SetValue (object value, object parent)
virtual void | SetDomain (ICollection collection)
virtual object | GetValue ()
virtual void | RegisterSelectionAssignment (Component targetComponent, IConverter converter=null)
Indicates that the selection of the bound control must be assigned to another control. More...
virtual void | SetControlColors (Color fore, Color back)
Sets the controls foreground and background colors. Can be overridden by a specific binding to set other colors if necessary. More...

Additional Inherited Members

- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.ControlBinding
ControlBinding (Component component)
virtual void | OnToolTipShown (PopupEventArgs e)
Called when Tooltip is shown, and fires ToolTipShown event. More...
virtual void | OnToolTipClosed ()
Called when Tooltip is hidden, and fires ToolTipHidden. More...
void | ThreadSafeRefresh ()
override void | Dispose (bool disposing)
- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
void | RaiseValueChanged ()
void | RaiseLeave ()
void | RaiseActionPerformed ()
Type | GetGenericType (Type type)
string | ValueToString (object value)
bool | IsAssociatedPropertyVisible (object source, BindPropertyInfo associatedPropertyInfo)
Indicates whether the associated property (i.e. the property which is used to display the original property in a textbox) is visible More...
void | EditFileInfo (object source, BindPropertyInfo propertyInfo)
string | EditFileInfo (string value, string format, string label, string description, bool isDirectory)
string | GetDoubleString (string text)
bool | HasValidNumericValue (string text)
double | GetNumericValue (string text)
List< BindPropertyInfo > | GetDictionaryProperties (ICollection domain, BindPropertyInfo dynamicPropertyInfo)
- Protected Attributes inherited from Deltares.Standard.Forms.DExpress.ControlBinding
readonly ToolTip | tooltip
string | Description
The textual description associated with this

See also
Control

. More...

string | Label
The label/title/name associated with this Control. More...
- Protected Attributes inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
BindPropertyInfo | propInfo
- Properties inherited from Deltares.Standard.Forms.DExpress.ControlBinding
ToolTip | Tooltip [get]
Gets the tooltip for the bound control. More...
Control | BoundControl [get]
- Properties inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
Component | Component [get]
virtual bool | IsTransparant [get]
virtual HandleType | HandleDelayed [get]
virtual bool | HasDomain [get]
- Properties inherited from Deltares.Standard.Forms.DExpress.ComponentWrappers.IGetBoundControl
Control | BoundControl [get]
- Events inherited from Deltares.Standard.Forms.DExpress.ControlBinding
ToolTipVisibilityEventHandler | ToolTipHidden
ToolTipVisibilityEventHandler | ToolTipShown
- Events inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
EventHandler< EventArgs > | ActionPerformed
EventHandler< EventArgs > | Leave
EventHandler< EventArgs > | ValueChanged
Generated on Tue Dec 15 2015 18:15:23 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • TreeListBinding
Deltares.Standard.Forms.DExpress.TreeListBinding Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.TreeListBinding, including all inherited members.

ActionPerformed (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
BoundControl (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding |
Component (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ComponentBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ControlBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Description | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Dispose(bool disposing) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | protected
EditFileInfo(object source, BindPropertyInfo propertyInfo) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
EditFileInfo(string value, string format, string label, string description, bool isDirectory) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetDictionaryProperties(ICollection domain, BindPropertyInfo dynamicPropertyInfo) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetDoubleString(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetGenericType(Type type) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetNumericValue(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetValue() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
HandleDelayed (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
HasDomain (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
HasValidNumericValue(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Initialize(BindPropertyInfo propertyInfo, params string[] properties) (defined in Deltares.Standard.Forms.DExpress.TreeListBinding) | Deltares.Standard.Forms.DExpress.TreeListBinding | virtual
Initialize(BindPropertyInfo propertyInfo, Type rootObjectType, params string[] properties) (defined in Deltares.Standard.Forms.DExpress.TreeListBinding) | Deltares.Standard.Forms.DExpress.TreeListBinding | virtual
Invalidate() (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
IsAssociatedPropertyVisible(object source, BindPropertyInfo associatedPropertyInfo) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
IsTransparant (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
Label | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Leave (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
OnToolTipClosed() | Deltares.Standard.Forms.DExpress.ControlBinding | protectedvirtual
OnToolTipShown(PopupEventArgs e) | Deltares.Standard.Forms.DExpress.ControlBinding | protectedvirtual
propInfo (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseActionPerformed() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseLeave() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseValueChanged() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Refresh() (defined in Deltares.Standard.Forms.DExpress.TreeListBinding) | Deltares.Standard.Forms.DExpress.TreeListBinding | virtual
RegisterSelectionAssignment(Component targetComponent, IConverter converter=null) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetBackgroundColor(Color color) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
SetControlColors(Color fore, Color back) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetDescription(string description) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
SetDomain(ICollection collection) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetEnabled(bool enabled) (defined in Deltares.Standard.Forms.DExpress.TreeListBinding) | Deltares.Standard.Forms.DExpress.TreeListBinding | virtual
SetForegroundColor(Color color) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
SetLabel(string text) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
SetTrueMapping(object trueMapping) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetValue(object value) (defined in Deltares.Standard.Forms.DExpress.TreeListBinding) | Deltares.Standard.Forms.DExpress.TreeListBinding | virtual
SetValue(object value, object parent) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetVisible(bool visible) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
ThreadSafeRefresh() (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Tooltip | Deltares.Standard.Forms.DExpress.ControlBinding | protected
tooltip (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | protected
ToolTipHidden (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding |
ToolTipShown (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding |
TreeListBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.TreeListBinding) | Deltares.Standard.Forms.DExpress.TreeListBinding |
ValueChanged (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ValueToString(object value) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Generated on Tue Dec 15 2015 18:15:23 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.TreeListColumnBinding Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • TreeListColumnBinding
Public Member Functions | Properties | List of all members
Deltares.Standard.Forms.DExpress.TreeListColumnBinding Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.TreeListColumnBinding:
Deltares.Standard.Forms.DExpress.ComponentBinding

Public Member Functions

TreeListColumnBinding (Component component)
override void | SetEnabled (bool enabled)
override void | SetVisible (bool visible)
override void | SetLabel (string text)
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
ComponentBinding (Component component)
virtual void | Initialize (BindPropertyInfo propertyInfo, params string[] properties)
virtual void | Initialize (BindPropertyInfo propertyInfo, Type rootObjectType, params string[] properties)
virtual void | SetTrueMapping (object trueMapping)
virtual void | SetValue (object value)
virtual void | SetValue (object value, object parent)
virtual void | SetDomain (ICollection collection)
virtual object | GetValue ()
virtual void | SetDescription (string description)
virtual void | SetForegroundColor (Color color)
virtual void | SetBackgroundColor (Color color)
virtual void | Refresh ()
virtual void | Invalidate ()
virtual void | RegisterSelectionAssignment (Component targetComponent, IConverter converter=null)
Indicates that the selection of the bound control must be assigned to another control. More...
virtual void | SetControlColors (Color fore, Color back)
Sets the controls foreground and background colors. Can be overridden by a specific binding to set other colors if necessary. More...

Properties

override bool | IsTransparant [get]
- Properties inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
Component | Component [get]
virtual bool | IsTransparant [get]
virtual HandleType | HandleDelayed [get]
virtual bool | HasDomain [get]

Additional Inherited Members

- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
void | RaiseValueChanged ()
void | RaiseLeave ()
void | RaiseActionPerformed ()
Type | GetGenericType (Type type)
string | ValueToString (object value)
bool | IsAssociatedPropertyVisible (object source, BindPropertyInfo associatedPropertyInfo)
Indicates whether the associated property (i.e. the property which is used to display the original property in a textbox) is visible More...
void | EditFileInfo (object source, BindPropertyInfo propertyInfo)
string | EditFileInfo (string value, string format, string label, string description, bool isDirectory)
string | GetDoubleString (string text)
bool | HasValidNumericValue (string text)
double | GetNumericValue (string text)
List< BindPropertyInfo > | GetDictionaryProperties (ICollection domain, BindPropertyInfo dynamicPropertyInfo)
- Protected Attributes inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
BindPropertyInfo | propInfo
- Events inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
EventHandler< EventArgs > | ActionPerformed
EventHandler< EventArgs > | Leave
EventHandler< EventArgs > | ValueChanged
Generated on Tue Dec 15 2015 18:15:23 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • TreeListColumnBinding
Deltares.Standard.Forms.DExpress.TreeListColumnBinding Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.TreeListColumnBinding, including all inherited members.

ActionPerformed (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
Component (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ComponentBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
EditFileInfo(object source, BindPropertyInfo propertyInfo) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
EditFileInfo(string value, string format, string label, string description, bool isDirectory) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetDictionaryProperties(ICollection domain, BindPropertyInfo dynamicPropertyInfo) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetDoubleString(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetGenericType(Type type) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetNumericValue(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetValue() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
HandleDelayed (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
HasDomain (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
HasValidNumericValue(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Initialize(BindPropertyInfo propertyInfo, params string[] properties) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
Initialize(BindPropertyInfo propertyInfo, Type rootObjectType, params string[] properties) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
Invalidate() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
IsAssociatedPropertyVisible(object source, BindPropertyInfo associatedPropertyInfo) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
IsTransparant (defined in Deltares.Standard.Forms.DExpress.TreeListColumnBinding) | Deltares.Standard.Forms.DExpress.TreeListColumnBinding |
Leave (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
propInfo (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseActionPerformed() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseLeave() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseValueChanged() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Refresh() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
RegisterSelectionAssignment(Component targetComponent, IConverter converter=null) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetBackgroundColor(Color color) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetControlColors(Color fore, Color back) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetDescription(string description) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetDomain(ICollection collection) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetEnabled(bool enabled) (defined in Deltares.Standard.Forms.DExpress.TreeListColumnBinding) | Deltares.Standard.Forms.DExpress.TreeListColumnBinding | virtual
SetForegroundColor(Color color) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetLabel(string text) (defined in Deltares.Standard.Forms.DExpress.TreeListColumnBinding) | Deltares.Standard.Forms.DExpress.TreeListColumnBinding | virtual
SetTrueMapping(object trueMapping) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetValue(object value) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetValue(object value, object parent) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetVisible(bool visible) (defined in Deltares.Standard.Forms.DExpress.TreeListColumnBinding) | Deltares.Standard.Forms.DExpress.TreeListColumnBinding | virtual
TreeListColumnBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.TreeListColumnBinding) | Deltares.Standard.Forms.DExpress.TreeListColumnBinding |
ValueChanged (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ValueToString(object value) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Generated on Tue Dec 15 2015 18:15:23 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.TreeViewControl Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • TreeViewControl
Public Member Functions | Static Public Member Functions | Public Attributes | Protected Member Functions | Protected Attributes | Properties | List of all members
Deltares.Standard.Forms.DExpress.TreeViewControl Class Reference

Generic Grid Control extend from DXTreeList More...

Inheritance diagram for Deltares.Standard.Forms.DExpress.TreeViewControl:

Public Member Functions

TreeViewControl ()
Initializes a new instance of the GeoGrid class. More...
bool | IsVisible (string property)
Determines whether the specified property is visible. More...
bool | IsEnabled (string property)
Determines whether the specified property is enabled. More...
IEnumerable< Component > | GetChildComponents ()

Static Public Member Functions

static object GetInnerDataObject (object dataObject)

Public Attributes

DevExpress.XtraTreeList.TreeList | TreeList
Bar | Toolbar
ImageCollection | TemplateImageCollection
PopupMenu | GeoPopupMenu

Protected Member Functions

void | DeleteRowCommand ()
Triggered when the DeleteRow button is clicked. More...
override void | Dispose (bool disposing)

Protected Attributes

BarManager barManager1

Properties

bool | SendSelectionChanged [get, set]
PropertyEditorReactionType | PropertyEditorReactionType [get, set]
bool | HideUnusedColumns [get, set]
bool | ShowRoot [get, set]
Indicates whether the root node is shown More...
bool | ShowToolbar [get, set]
Gets or sets a value indicating whether to show the toolbar. More...
bool | MultiSelect [get, set]
Gets or sets a value indicating whether multple selction can be made More...

Detailed Description

Generic Grid Control extend from DXTreeList

Constructor & Destructor Documentation

Deltares.Standard.Forms.DExpress.TreeViewControl.TreeViewControl ( )

Initializes a new instance of the GeoGrid class.

References Deltares.Standard.Forms.DExpress.BindSupport.Assign(), Deltares.Standard.Forms.DExpress.BindSupport.Bind(), and Deltares.Standard.Forms.DExpress.TreeViewControl.DeleteRowCommand().

Member Function Documentation

void Deltares.Standard.Forms.DExpress.TreeViewControl.DeleteRowCommand ( )
protected

Triggered when the DeleteRow button is clicked.

Referenced by Deltares.Standard.Forms.DExpress.TreeViewControl.TreeViewControl().

bool Deltares.Standard.Forms.DExpress.TreeViewControl.IsEnabled ( string property )

Determines whether the specified property is enabled.

Parameters
property The property.
Returns
bool Deltares.Standard.Forms.DExpress.TreeViewControl.IsVisible ( string property )

Determines whether the specified property is visible.

Parameters
property The property.
Returns

Property Documentation

bool Deltares.Standard.Forms.DExpress.TreeViewControl.MultiSelect
getset

Gets or sets a value indicating whether multple selction can be made

bool Deltares.Standard.Forms.DExpress.TreeViewControl.ShowRoot
getset

Indicates whether the root node is shown

bool Deltares.Standard.Forms.DExpress.TreeViewControl.ShowToolbar
getset

Gets or sets a value indicating whether to show the toolbar.

Generated on Tue Dec 15 2015 18:15:23 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • TreeViewControl
Deltares.Standard.Forms.DExpress.TreeViewControl Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.TreeViewControl, including all inherited members.

barManager1 (defined in Deltares.Standard.Forms.DExpress.TreeViewControl) | Deltares.Standard.Forms.DExpress.TreeViewControl | protected
DeleteRowCommand() | Deltares.Standard.Forms.DExpress.TreeViewControl | protected
Dispose(bool disposing) (defined in Deltares.Standard.Forms.DExpress.TreeViewControl) | Deltares.Standard.Forms.DExpress.TreeViewControl | protected
GeoPopupMenu (defined in Deltares.Standard.Forms.DExpress.TreeViewControl) | Deltares.Standard.Forms.DExpress.TreeViewControl |
GetChildComponents() (defined in Deltares.Standard.Forms.DExpress.TreeViewControl) | Deltares.Standard.Forms.DExpress.TreeViewControl |
GetInnerDataObject(object dataObject) (defined in Deltares.Standard.Forms.DExpress.TreeViewControl) | Deltares.Standard.Forms.DExpress.TreeViewControl | static
HideUnusedColumns (defined in Deltares.Standard.Forms.DExpress.TreeViewControl) | Deltares.Standard.Forms.DExpress.TreeViewControl |
IsEnabled(string property) | Deltares.Standard.Forms.DExpress.TreeViewControl |
IsVisible(string property) | Deltares.Standard.Forms.DExpress.TreeViewControl |
MultiSelect | Deltares.Standard.Forms.DExpress.TreeViewControl |
PropertyEditorReactionType (defined in Deltares.Standard.Forms.DExpress.TreeViewControl) | Deltares.Standard.Forms.DExpress.TreeViewControl |
SendSelectionChanged (defined in Deltares.Standard.Forms.DExpress.TreeViewControl) | Deltares.Standard.Forms.DExpress.TreeViewControl |
ShowRoot | Deltares.Standard.Forms.DExpress.TreeViewControl |
ShowToolbar | Deltares.Standard.Forms.DExpress.TreeViewControl |
TemplateImageCollection (defined in Deltares.Standard.Forms.DExpress.TreeViewControl) | Deltares.Standard.Forms.DExpress.TreeViewControl |
Toolbar (defined in Deltares.Standard.Forms.DExpress.TreeViewControl) | Deltares.Standard.Forms.DExpress.TreeViewControl |
TreeList (defined in Deltares.Standard.Forms.DExpress.TreeViewControl) | Deltares.Standard.Forms.DExpress.TreeViewControl |
TreeViewControl() | Deltares.Standard.Forms.DExpress.TreeViewControl |
Generated on Tue Dec 15 2015 18:15:23 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.UnitsDialog Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • UnitsDialog
Protected Member Functions | Properties | List of all members
Deltares.Standard.Forms.DExpress.UnitsDialog Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.UnitsDialog:
Deltares.Standard.Forms.IPropertyControl

Protected Member Functions

override void Dispose (bool disposing)
Clean up any resources being used. More...

Properties

object | SelectedObject [get, set]
bool | IsVisible [get]
- Properties inherited from Deltares.Standard.Forms.IPropertyControl
string | Name [get, set]
Gets or sets the name to be displayed property. More...
object | SelectedObject [get, set]
Gets or sets the object to be displayed in the property window. More...
bool | IsVisible [get]
Whether or not the property control should be displayed. More...

Member Function Documentation

override void Deltares.Standard.Forms.DExpress.UnitsDialog.Dispose ( bool disposing )
protected

Clean up any resources being used.

Parameters
disposing true if managed resources should be disposed; otherwise, false.
Generated on Tue Dec 15 2015 18:15:24 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • UnitsDialog
Deltares.Standard.Forms.DExpress.UnitsDialog Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.UnitsDialog, including all inherited members.

Dispose(bool disposing) | Deltares.Standard.Forms.DExpress.UnitsDialog | protected
IsVisible (defined in Deltares.Standard.Forms.DExpress.UnitsDialog) | Deltares.Standard.Forms.DExpress.UnitsDialog |
Name | Deltares.Standard.Forms.IPropertyControl |
SelectedObject (defined in Deltares.Standard.Forms.DExpress.UnitsDialog) | Deltares.Standard.Forms.DExpress.UnitsDialog |
UnitsDialog() (defined in Deltares.Standard.Forms.DExpress.UnitsDialog) | Deltares.Standard.Forms.DExpress.UnitsDialog |
Generated on Tue Dec 15 2015 18:15:24 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.UserColumnFilterDisplayItem Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • UserColumnFilterDisplayItem
Public Member Functions | List of all members
Deltares.Standard.Forms.DExpress.UserColumnFilterDisplayItem Class Reference

More...

Inheritance diagram for Deltares.Standard.Forms.DExpress.UserColumnFilterDisplayItem:
Deltares.Standard.Forms.DExpress.ComboBoxDisplayItem

Public Member Functions

UserColumnFilterDisplayItem (string text, string translatedText)
Initializes a new instance of the UserColumnFilterDisplayItem class. More...
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.ComboBoxDisplayItem
ComboBoxDisplayItem (string text, string translatedText)
Initializes a new instance of the CategoryDisplayItem class. More...
override string ToString ()
Returns a System.String that represents this instance. More...

Additional Inherited Members

- Protected Attributes inherited from Deltares.Standard.Forms.DExpress.ComboBoxDisplayItem
string | TranslatedText
- Properties inherited from Deltares.Standard.Forms.DExpress.ComboBoxDisplayItem
string | Text [get]
Gets the category. More...

Detailed Description

Constructor & Destructor Documentation

Deltares.Standard.Forms.DExpress.UserColumnFilterDisplayItem.UserColumnFilterDisplayItem | ( | string | text,
 |  | string | translatedText
 | ) |  |

Initializes a new instance of the UserColumnFilterDisplayItem class.

Parameters
text | The text.
translatedText | The translated text.
Generated on Tue Dec 15 2015 18:15:24 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • UserColumnFilterDisplayItem
Deltares.Standard.Forms.DExpress.UserColumnFilterDisplayItem Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.UserColumnFilterDisplayItem, including all inherited members.

ComboBoxDisplayItem(string text, string translatedText) | Deltares.Standard.Forms.DExpress.ComboBoxDisplayItem |
Text | Deltares.Standard.Forms.DExpress.ComboBoxDisplayItem |
ToString() | Deltares.Standard.Forms.DExpress.ComboBoxDisplayItem |
TranslatedText (defined in Deltares.Standard.Forms.DExpress.ComboBoxDisplayItem) | Deltares.Standard.Forms.DExpress.ComboBoxDisplayItem | protected
UserColumnFilterDisplayItem(string text, string translatedText) | Deltares.Standard.Forms.DExpress.UserColumnFilterDisplayItem |
Generated on Tue Dec 15 2015 18:15:24 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.WebMapPlugin Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • WebMapPlugin
Public Member Functions | List of all members
Deltares.Standard.Forms.DExpress.WebMapPlugin Class Reference

Public Member Functions

WebMapPlugin (Map map, MapFrame frame)
void | DisableBasemapLayer ()
IMapLayer | ShowMap (ServiceProvider serviceProvider)

Member Function Documentation

void Deltares.Standard.Forms.DExpress.WebMapPlugin.DisableBasemapLayer ( )

Generated on Tue Dec 15 2015 18:15:24 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • WebMapPlugin
Deltares.Standard.Forms.DExpress.WebMapPlugin Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.WebMapPlugin, including all inherited members.

DisableBasemapLayer() | Deltares.Standard.Forms.DExpress.WebMapPlugin
ShowMap(ServiceProvider serviceProvider) (defined in Deltares.Standard.Forms.DExpress.WebMapPlugin) | Deltares.Standard.Forms.DExpress.WebMapPlugin
WebMapPlugin(Map map, MapFrame frame) (defined in Deltares.Standard.Forms.DExpress.WebMapPlugin) | Deltares.Standard.Forms.DExpress.WebMapPlugin
Generated on Tue Dec 15 2015 18:15:24 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.XRCheckBoxBinding Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • XRCheckBoxBinding
Public Member Functions | List of all members
Deltares.Standard.Forms.DExpress.XRCheckBoxBinding Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.XRCheckBoxBinding:
Deltares.Standard.Forms.DExpress.XRControlBinding Deltares.Standard.Forms.DExpress.ComponentBinding

Public Member Functions

XRCheckBoxBinding (Component component)
override void | SetValue (object value)
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.XRControlBinding
XRControlBinding (Component component)
override void | Initialize (BindPropertyInfo propertyInfo, params string[] properties)
override void | SetLabel (string text)
override void | SetVisible (bool visible)
override void | SetForegroundColor (Color color)
override void | SetBackgroundColor (Color color)
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
ComponentBinding (Component component)
virtual void | Initialize (BindPropertyInfo propertyInfo, Type rootObjectType, params string[] properties)
virtual void | SetTrueMapping (object trueMapping)
virtual void | SetValue (object value, object parent)
virtual void | SetDomain (ICollection collection)
virtual object | GetValue ()
virtual void | SetEnabled (bool enabled)
virtual void | SetDescription (string description)
virtual void | Refresh ()
virtual void | Invalidate ()
virtual void | RegisterSelectionAssignment (Component targetComponent, IConverter converter=null)
Indicates that the selection of the bound control must be assigned to another control. More...
virtual void | SetControlColors (Color fore, Color back)
Sets the controls foreground and background colors. Can be overridden by a specific binding to set other colors if necessary. More...

Additional Inherited Members

- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.XRControlBinding
virtual void | BindSupport_BeforePrint (object sender, PrintEventArgs e)
- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
void | RaiseValueChanged ()
void | RaiseLeave ()
void | RaiseActionPerformed ()
Type | GetGenericType (Type type)
string | ValueToString (object value)
bool | IsAssociatedPropertyVisible (object source, BindPropertyInfo associatedPropertyInfo)
Indicates whether the associated property (i.e. the property which is used to display the original property in a textbox) is visible More...
void | EditFileInfo (object source, BindPropertyInfo propertyInfo)
string | EditFileInfo (string value, string format, string label, string description, bool isDirectory)
string | GetDoubleString (string text)
bool | HasValidNumericValue (string text)
double | GetNumericValue (string text)
List< BindPropertyInfo > | GetDictionaryProperties (ICollection domain, BindPropertyInfo dynamicPropertyInfo)
- Protected Attributes inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
BindPropertyInfo | propInfo
- Properties inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
Component | Component [get]
virtual bool | IsTransparant [get]
virtual HandleType | HandleDelayed [get]
virtual bool | HasDomain [get]
- Events inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
EventHandler< EventArgs > | ActionPerformed
EventHandler< EventArgs > | Leave
EventHandler< EventArgs > | ValueChanged
Generated on Tue Dec 15 2015 18:15:24 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • XRCheckBoxBinding
Deltares.Standard.Forms.DExpress.XRCheckBoxBinding Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.XRCheckBoxBinding, including all inherited members.

ActionPerformed (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
BindSupport_BeforePrint(object sender, PrintEventArgs e) (defined in Deltares.Standard.Forms.DExpress.XRControlBinding) | Deltares.Standard.Forms.DExpress.XRControlBinding | protectedvirtual
Component (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ComponentBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
EditFileInfo(object source, BindPropertyInfo propertyInfo) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
EditFileInfo(string value, string format, string label, string description, bool isDirectory) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetDictionaryProperties(ICollection domain, BindPropertyInfo dynamicPropertyInfo) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetDoubleString(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetGenericType(Type type) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetNumericValue(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetValue() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
HandleDelayed (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
HasDomain (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
HasValidNumericValue(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Initialize(BindPropertyInfo propertyInfo, params string[] properties) (defined in Deltares.Standard.Forms.DExpress.XRControlBinding) | Deltares.Standard.Forms.DExpress.XRControlBinding | virtual
Initialize(BindPropertyInfo propertyInfo, Type rootObjectType, params string[] properties) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
Invalidate() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
IsAssociatedPropertyVisible(object source, BindPropertyInfo associatedPropertyInfo) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
IsTransparant (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
Leave (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
propInfo (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseActionPerformed() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseLeave() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseValueChanged() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Refresh() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
RegisterSelectionAssignment(Component targetComponent, IConverter converter=null) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetBackgroundColor(Color color) (defined in Deltares.Standard.Forms.DExpress.XRControlBinding) | Deltares.Standard.Forms.DExpress.XRControlBinding | virtual
SetControlColors(Color fore, Color back) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetDescription(string description) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetDomain(ICollection collection) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetEnabled(bool enabled) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetForegroundColor(Color color) (defined in Deltares.Standard.Forms.DExpress.XRControlBinding) | Deltares.Standard.Forms.DExpress.XRControlBinding | virtual
SetLabel(string text) (defined in Deltares.Standard.Forms.DExpress.XRControlBinding) | Deltares.Standard.Forms.DExpress.XRControlBinding | virtual
SetTrueMapping(object trueMapping) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetValue(object value) (defined in Deltares.Standard.Forms.DExpress.XRCheckBoxBinding) | Deltares.Standard.Forms.DExpress.XRCheckBoxBinding | virtual
SetValue(object value, object parent) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetVisible(bool visible) (defined in Deltares.Standard.Forms.DExpress.XRControlBinding) | Deltares.Standard.Forms.DExpress.XRControlBinding | virtual
ValueChanged (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ValueToString(object value) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
XRCheckBoxBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.XRCheckBoxBinding) | Deltares.Standard.Forms.DExpress.XRCheckBoxBinding |
XRControlBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.XRControlBinding) | Deltares.Standard.Forms.DExpress.XRControlBinding |
Generated on Tue Dec 15 2015 18:15:24 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.XRControlBinding Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • XRControlBinding
Public Member Functions | Protected Member Functions | List of all members
Deltares.Standard.Forms.DExpress.XRControlBinding Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.XRControlBinding:
Deltares.Standard.Forms.DExpress.ComponentBinding Deltares.Standard.Forms.DExpress.DetailReportBandBinding Deltares.Standard.Forms.DExpress.XRCheckBoxBinding Deltares.Standard.Forms.DExpress.XRLabelBinding Deltares.Standard.Forms.DExpress.XRPictureBoxBinding Deltares.Standard.Forms.DExpress.XRShapeBinding Deltares.Standard.Forms.DExpress.XRSubreportBinding

Public Member Functions

XRControlBinding (Component component)
override void | Initialize (BindPropertyInfo propertyInfo, params string[] properties)
override void | SetLabel (string text)
override void | SetVisible (bool visible)
override void | SetForegroundColor (Color color)
override void | SetBackgroundColor (Color color)
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
ComponentBinding (Component component)
virtual void | Initialize (BindPropertyInfo propertyInfo, Type rootObjectType, params string[] properties)
virtual void | SetTrueMapping (object trueMapping)
virtual void | SetValue (object value)
virtual void | SetValue (object value, object parent)
virtual void | SetDomain (ICollection collection)
virtual object | GetValue ()
virtual void | SetEnabled (bool enabled)
virtual void | SetDescription (string description)
virtual void | Refresh ()
virtual void | Invalidate ()
virtual void | RegisterSelectionAssignment (Component targetComponent, IConverter converter=null)
Indicates that the selection of the bound control must be assigned to another control. More...
virtual void | SetControlColors (Color fore, Color back)
Sets the controls foreground and background colors. Can be overridden by a specific binding to set other colors if necessary. More...

Protected Member Functions

virtual void | BindSupport_BeforePrint (object sender, PrintEventArgs e)
- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
void | RaiseValueChanged ()
void | RaiseLeave ()
void | RaiseActionPerformed ()
Type | GetGenericType (Type type)
string | ValueToString (object value)
bool | IsAssociatedPropertyVisible (object source, BindPropertyInfo associatedPropertyInfo)
Indicates whether the associated property (i.e. the property which is used to display the original property in a textbox) is visible More...
void | EditFileInfo (object source, BindPropertyInfo propertyInfo)
string | EditFileInfo (string value, string format, string label, string description, bool isDirectory)
string | GetDoubleString (string text)
bool | HasValidNumericValue (string text)
double | GetNumericValue (string text)
List< BindPropertyInfo > | GetDictionaryProperties (ICollection domain, BindPropertyInfo dynamicPropertyInfo)

Additional Inherited Members

- Protected Attributes inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
BindPropertyInfo | propInfo
- Properties inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
Component | Component [get]
virtual bool | IsTransparant [get]
virtual HandleType | HandleDelayed [get]
virtual bool | HasDomain [get]
- Events inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
EventHandler< EventArgs > | ActionPerformed
EventHandler< EventArgs > | Leave
EventHandler< EventArgs > | ValueChanged
Generated on Tue Dec 15 2015 18:15:24 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • XRControlBinding
Deltares.Standard.Forms.DExpress.XRControlBinding Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.XRControlBinding, including all inherited members.

ActionPerformed (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
BindSupport_BeforePrint(object sender, PrintEventArgs e) (defined in Deltares.Standard.Forms.DExpress.XRControlBinding) | Deltares.Standard.Forms.DExpress.XRControlBinding | protectedvirtual
Component (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ComponentBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
EditFileInfo(object source, BindPropertyInfo propertyInfo) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
EditFileInfo(string value, string format, string label, string description, bool isDirectory) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetDictionaryProperties(ICollection domain, BindPropertyInfo dynamicPropertyInfo) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetDoubleString(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetGenericType(Type type) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetNumericValue(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetValue() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
HandleDelayed (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
HasDomain (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
HasValidNumericValue(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Initialize(BindPropertyInfo propertyInfo, params string[] properties) (defined in Deltares.Standard.Forms.DExpress.XRControlBinding) | Deltares.Standard.Forms.DExpress.XRControlBinding | virtual
Initialize(BindPropertyInfo propertyInfo, Type rootObjectType, params string[] properties) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
Invalidate() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
IsAssociatedPropertyVisible(object source, BindPropertyInfo associatedPropertyInfo) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
IsTransparant (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
Leave (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
propInfo (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseActionPerformed() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseLeave() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseValueChanged() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Refresh() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
RegisterSelectionAssignment(Component targetComponent, IConverter converter=null) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetBackgroundColor(Color color) (defined in Deltares.Standard.Forms.DExpress.XRControlBinding) | Deltares.Standard.Forms.DExpress.XRControlBinding | virtual
SetControlColors(Color fore, Color back) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetDescription(string description) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetDomain(ICollection collection) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetEnabled(bool enabled) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetForegroundColor(Color color) (defined in Deltares.Standard.Forms.DExpress.XRControlBinding) | Deltares.Standard.Forms.DExpress.XRControlBinding | virtual
SetLabel(string text) (defined in Deltares.Standard.Forms.DExpress.XRControlBinding) | Deltares.Standard.Forms.DExpress.XRControlBinding | virtual
SetTrueMapping(object trueMapping) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetValue(object value) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetValue(object value, object parent) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetVisible(bool visible) (defined in Deltares.Standard.Forms.DExpress.XRControlBinding) | Deltares.Standard.Forms.DExpress.XRControlBinding | virtual
ValueChanged (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ValueToString(object value) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
XRControlBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.XRControlBinding) | Deltares.Standard.Forms.DExpress.XRControlBinding |
Generated on Tue Dec 15 2015 18:15:24 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.XRLabelBinding Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • XRLabelBinding
Public Member Functions | Protected Member Functions | List of all members
Deltares.Standard.Forms.DExpress.XRLabelBinding Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.XRLabelBinding:
Deltares.Standard.Forms.DExpress.XRControlBinding Deltares.Standard.Forms.DExpress.ComponentBinding

Public Member Functions

XRLabelBinding (Component component)
override void | SetValue (object value, object parent)
override void | SetLabel (string text)
override void | SetVisible (bool visible)
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.XRControlBinding
XRControlBinding (Component component)
override void | Initialize (BindPropertyInfo propertyInfo, params string[] properties)
override void | SetForegroundColor (Color color)
override void | SetBackgroundColor (Color color)
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
ComponentBinding (Component component)
virtual void | Initialize (BindPropertyInfo propertyInfo, Type rootObjectType, params string[] properties)
virtual void | SetTrueMapping (object trueMapping)
virtual void | SetValue (object value)
virtual void | SetDomain (ICollection collection)
virtual object | GetValue ()
virtual void | SetEnabled (bool enabled)
virtual void | SetDescription (string description)
virtual void | Refresh ()
virtual void | Invalidate ()
virtual void | RegisterSelectionAssignment (Component targetComponent, IConverter converter=null)
Indicates that the selection of the bound control must be assigned to another control. More...
virtual void | SetControlColors (Color fore, Color back)
Sets the controls foreground and background colors. Can be overridden by a specific binding to set other colors if necessary. More...

Protected Member Functions

override void | BindSupport_BeforePrint (object sender, PrintEventArgs e)
- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
void | RaiseValueChanged ()
void | RaiseLeave ()
void | RaiseActionPerformed ()
Type | GetGenericType (Type type)
string | ValueToString (object value)
bool | IsAssociatedPropertyVisible (object source, BindPropertyInfo associatedPropertyInfo)
Indicates whether the associated property (i.e. the property which is used to display the original property in a textbox) is visible More...
void | EditFileInfo (object source, BindPropertyInfo propertyInfo)
string | EditFileInfo (string value, string format, string label, string description, bool isDirectory)
string | GetDoubleString (string text)
bool | HasValidNumericValue (string text)
double | GetNumericValue (string text)
List< BindPropertyInfo > | GetDictionaryProperties (ICollection domain, BindPropertyInfo dynamicPropertyInfo)

Additional Inherited Members

- Protected Attributes inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
BindPropertyInfo | propInfo
- Properties inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
Component | Component [get]
virtual bool | IsTransparant [get]
virtual HandleType | HandleDelayed [get]
virtual bool | HasDomain [get]
- Events inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
EventHandler< EventArgs > | ActionPerformed
EventHandler< EventArgs > | Leave
EventHandler< EventArgs > | ValueChanged
Generated on Tue Dec 15 2015 18:15:25 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • XRLabelBinding
Deltares.Standard.Forms.DExpress.XRLabelBinding Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.XRLabelBinding, including all inherited members.

ActionPerformed (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
BindSupport_BeforePrint(object sender, PrintEventArgs e) (defined in Deltares.Standard.Forms.DExpress.XRLabelBinding) | Deltares.Standard.Forms.DExpress.XRLabelBinding | protectedvirtual
Component (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ComponentBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
EditFileInfo(object source, BindPropertyInfo propertyInfo) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
EditFileInfo(string value, string format, string label, string description, bool isDirectory) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetDictionaryProperties(ICollection domain, BindPropertyInfo dynamicPropertyInfo) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetDoubleString(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetGenericType(Type type) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetNumericValue(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetValue() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
HandleDelayed (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
HasDomain (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
HasValidNumericValue(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Initialize(BindPropertyInfo propertyInfo, params string[] properties) (defined in Deltares.Standard.Forms.DExpress.XRControlBinding) | Deltares.Standard.Forms.DExpress.XRControlBinding | virtual
Initialize(BindPropertyInfo propertyInfo, Type rootObjectType, params string[] properties) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
Invalidate() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
IsAssociatedPropertyVisible(object source, BindPropertyInfo associatedPropertyInfo) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
IsTransparant (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
Leave (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
propInfo (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseActionPerformed() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseLeave() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseValueChanged() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Refresh() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
RegisterSelectionAssignment(Component targetComponent, IConverter converter=null) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetBackgroundColor(Color color) (defined in Deltares.Standard.Forms.DExpress.XRControlBinding) | Deltares.Standard.Forms.DExpress.XRControlBinding | virtual
SetControlColors(Color fore, Color back) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetDescription(string description) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetDomain(ICollection collection) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetEnabled(bool enabled) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetForegroundColor(Color color) (defined in Deltares.Standard.Forms.DExpress.XRControlBinding) | Deltares.Standard.Forms.DExpress.XRControlBinding | virtual
SetLabel(string text) (defined in Deltares.Standard.Forms.DExpress.XRLabelBinding) | Deltares.Standard.Forms.DExpress.XRLabelBinding | virtual
SetTrueMapping(object trueMapping) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetValue(object value, object parent) (defined in Deltares.Standard.Forms.DExpress.XRLabelBinding) | Deltares.Standard.Forms.DExpress.XRLabelBinding | virtual
SetValue(object value) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetVisible(bool visible) (defined in Deltares.Standard.Forms.DExpress.XRLabelBinding) | Deltares.Standard.Forms.DExpress.XRLabelBinding | virtual
ValueChanged (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ValueToString(object value) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
XRControlBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.XRControlBinding) | Deltares.Standard.Forms.DExpress.XRControlBinding |
XRLabelBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.XRLabelBinding) | Deltares.Standard.Forms.DExpress.XRLabelBinding |
Generated on Tue Dec 15 2015 18:15:25 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.XRPictureBoxBinding Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • XRPictureBoxBinding
Public Member Functions | List of all members
Deltares.Standard.Forms.DExpress.XRPictureBoxBinding Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.XRPictureBoxBinding:
Deltares.Standard.Forms.DExpress.XRControlBinding Deltares.Standard.Forms.DExpress.ComponentBinding

Public Member Functions

XRPictureBoxBinding (Component component)
override void | SetValue (object value)
override void | SetLabel (string text)
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.XRControlBinding
XRControlBinding (Component component)
override void | Initialize (BindPropertyInfo propertyInfo, params string[] properties)
override void | SetVisible (bool visible)
override void | SetForegroundColor (Color color)
override void | SetBackgroundColor (Color color)
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
ComponentBinding (Component component)
virtual void | Initialize (BindPropertyInfo propertyInfo, Type rootObjectType, params string[] properties)
virtual void | SetTrueMapping (object trueMapping)
virtual void | SetValue (object value, object parent)
virtual void | SetDomain (ICollection collection)
virtual object | GetValue ()
virtual void | SetEnabled (bool enabled)
virtual void | SetDescription (string description)
virtual void | Refresh ()
virtual void | Invalidate ()
virtual void | RegisterSelectionAssignment (Component targetComponent, IConverter converter=null)
Indicates that the selection of the bound control must be assigned to another control. More...
virtual void | SetControlColors (Color fore, Color back)
Sets the controls foreground and background colors. Can be overridden by a specific binding to set other colors if necessary. More...

Additional Inherited Members

- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.XRControlBinding
virtual void | BindSupport_BeforePrint (object sender, PrintEventArgs e)
- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
void | RaiseValueChanged ()
void | RaiseLeave ()
void | RaiseActionPerformed ()
Type | GetGenericType (Type type)
string | ValueToString (object value)
bool | IsAssociatedPropertyVisible (object source, BindPropertyInfo associatedPropertyInfo)
Indicates whether the associated property (i.e. the property which is used to display the original property in a textbox) is visible More...
void | EditFileInfo (object source, BindPropertyInfo propertyInfo)
string | EditFileInfo (string value, string format, string label, string description, bool isDirectory)
string | GetDoubleString (string text)
bool | HasValidNumericValue (string text)
double | GetNumericValue (string text)
List< BindPropertyInfo > | GetDictionaryProperties (ICollection domain, BindPropertyInfo dynamicPropertyInfo)
- Protected Attributes inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
BindPropertyInfo | propInfo
- Properties inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
Component | Component [get]
virtual bool | IsTransparant [get]
virtual HandleType | HandleDelayed [get]
virtual bool | HasDomain [get]
- Events inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
EventHandler< EventArgs > | ActionPerformed
EventHandler< EventArgs > | Leave
EventHandler< EventArgs > | ValueChanged
Generated on Tue Dec 15 2015 18:15:25 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • XRPictureBoxBinding
Deltares.Standard.Forms.DExpress.XRPictureBoxBinding Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.XRPictureBoxBinding, including all inherited members.

ActionPerformed (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
BindSupport_BeforePrint(object sender, PrintEventArgs e) (defined in Deltares.Standard.Forms.DExpress.XRControlBinding) | Deltares.Standard.Forms.DExpress.XRControlBinding | protectedvirtual
Component (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ComponentBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
EditFileInfo(object source, BindPropertyInfo propertyInfo) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
EditFileInfo(string value, string format, string label, string description, bool isDirectory) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetDictionaryProperties(ICollection domain, BindPropertyInfo dynamicPropertyInfo) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetDoubleString(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetGenericType(Type type) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetNumericValue(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetValue() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
HandleDelayed (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
HasDomain (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
HasValidNumericValue(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Initialize(BindPropertyInfo propertyInfo, params string[] properties) (defined in Deltares.Standard.Forms.DExpress.XRControlBinding) | Deltares.Standard.Forms.DExpress.XRControlBinding | virtual
Initialize(BindPropertyInfo propertyInfo, Type rootObjectType, params string[] properties) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
Invalidate() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
IsAssociatedPropertyVisible(object source, BindPropertyInfo associatedPropertyInfo) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
IsTransparant (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
Leave (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
propInfo (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseActionPerformed() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseLeave() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseValueChanged() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Refresh() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
RegisterSelectionAssignment(Component targetComponent, IConverter converter=null) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetBackgroundColor(Color color) (defined in Deltares.Standard.Forms.DExpress.XRControlBinding) | Deltares.Standard.Forms.DExpress.XRControlBinding | virtual
SetControlColors(Color fore, Color back) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetDescription(string description) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetDomain(ICollection collection) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetEnabled(bool enabled) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetForegroundColor(Color color) (defined in Deltares.Standard.Forms.DExpress.XRControlBinding) | Deltares.Standard.Forms.DExpress.XRControlBinding | virtual
SetLabel(string text) (defined in Deltares.Standard.Forms.DExpress.XRPictureBoxBinding) | Deltares.Standard.Forms.DExpress.XRPictureBoxBinding | virtual
SetTrueMapping(object trueMapping) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetValue(object value) (defined in Deltares.Standard.Forms.DExpress.XRPictureBoxBinding) | Deltares.Standard.Forms.DExpress.XRPictureBoxBinding | virtual
SetValue(object value, object parent) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetVisible(bool visible) (defined in Deltares.Standard.Forms.DExpress.XRControlBinding) | Deltares.Standard.Forms.DExpress.XRControlBinding | virtual
ValueChanged (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ValueToString(object value) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
XRControlBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.XRControlBinding) | Deltares.Standard.Forms.DExpress.XRControlBinding |
XRPictureBoxBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.XRPictureBoxBinding) | Deltares.Standard.Forms.DExpress.XRPictureBoxBinding |
Generated on Tue Dec 15 2015 18:15:25 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.XRShapeBinding Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • XRShapeBinding
Public Member Functions | List of all members
Deltares.Standard.Forms.DExpress.XRShapeBinding Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.XRShapeBinding:
Deltares.Standard.Forms.DExpress.XRControlBinding Deltares.Standard.Forms.DExpress.ComponentBinding

Public Member Functions

XRShapeBinding (Component component)
override void | SetValue (object value)
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.XRControlBinding
XRControlBinding (Component component)
override void | Initialize (BindPropertyInfo propertyInfo, params string[] properties)
override void | SetLabel (string text)
override void | SetVisible (bool visible)
override void | SetForegroundColor (Color color)
override void | SetBackgroundColor (Color color)
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
ComponentBinding (Component component)
virtual void | Initialize (BindPropertyInfo propertyInfo, Type rootObjectType, params string[] properties)
virtual void | SetTrueMapping (object trueMapping)
virtual void | SetValue (object value, object parent)
virtual void | SetDomain (ICollection collection)
virtual object | GetValue ()
virtual void | SetEnabled (bool enabled)
virtual void | SetDescription (string description)
virtual void | Refresh ()
virtual void | Invalidate ()
virtual void | RegisterSelectionAssignment (Component targetComponent, IConverter converter=null)
Indicates that the selection of the bound control must be assigned to another control. More...
virtual void | SetControlColors (Color fore, Color back)
Sets the controls foreground and background colors. Can be overridden by a specific binding to set other colors if necessary. More...

Additional Inherited Members

- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.XRControlBinding
virtual void | BindSupport_BeforePrint (object sender, PrintEventArgs e)
- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
void | RaiseValueChanged ()
void | RaiseLeave ()
void | RaiseActionPerformed ()
Type | GetGenericType (Type type)
string | ValueToString (object value)
bool | IsAssociatedPropertyVisible (object source, BindPropertyInfo associatedPropertyInfo)
Indicates whether the associated property (i.e. the property which is used to display the original property in a textbox) is visible More...
void | EditFileInfo (object source, BindPropertyInfo propertyInfo)
string | EditFileInfo (string value, string format, string label, string description, bool isDirectory)
string | GetDoubleString (string text)
bool | HasValidNumericValue (string text)
double | GetNumericValue (string text)
List< BindPropertyInfo > | GetDictionaryProperties (ICollection domain, BindPropertyInfo dynamicPropertyInfo)
- Protected Attributes inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
BindPropertyInfo | propInfo
- Properties inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
Component | Component [get]
virtual bool | IsTransparant [get]
virtual HandleType | HandleDelayed [get]
virtual bool | HasDomain [get]
- Events inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
EventHandler< EventArgs > | ActionPerformed
EventHandler< EventArgs > | Leave
EventHandler< EventArgs > | ValueChanged
Generated on Tue Dec 15 2015 18:15:25 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • XRShapeBinding
Deltares.Standard.Forms.DExpress.XRShapeBinding Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.XRShapeBinding, including all inherited members.

ActionPerformed (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
BindSupport_BeforePrint(object sender, PrintEventArgs e) (defined in Deltares.Standard.Forms.DExpress.XRControlBinding) | Deltares.Standard.Forms.DExpress.XRControlBinding | protectedvirtual
Component (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ComponentBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
EditFileInfo(object source, BindPropertyInfo propertyInfo) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
EditFileInfo(string value, string format, string label, string description, bool isDirectory) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetDictionaryProperties(ICollection domain, BindPropertyInfo dynamicPropertyInfo) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetDoubleString(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetGenericType(Type type) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetNumericValue(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetValue() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
HandleDelayed (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
HasDomain (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
HasValidNumericValue(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Initialize(BindPropertyInfo propertyInfo, params string[] properties) (defined in Deltares.Standard.Forms.DExpress.XRControlBinding) | Deltares.Standard.Forms.DExpress.XRControlBinding | virtual
Initialize(BindPropertyInfo propertyInfo, Type rootObjectType, params string[] properties) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
Invalidate() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
IsAssociatedPropertyVisible(object source, BindPropertyInfo associatedPropertyInfo) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
IsTransparant (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
Leave (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
propInfo (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseActionPerformed() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseLeave() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseValueChanged() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Refresh() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
RegisterSelectionAssignment(Component targetComponent, IConverter converter=null) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetBackgroundColor(Color color) (defined in Deltares.Standard.Forms.DExpress.XRControlBinding) | Deltares.Standard.Forms.DExpress.XRControlBinding | virtual
SetControlColors(Color fore, Color back) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetDescription(string description) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetDomain(ICollection collection) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetEnabled(bool enabled) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetForegroundColor(Color color) (defined in Deltares.Standard.Forms.DExpress.XRControlBinding) | Deltares.Standard.Forms.DExpress.XRControlBinding | virtual
SetLabel(string text) (defined in Deltares.Standard.Forms.DExpress.XRControlBinding) | Deltares.Standard.Forms.DExpress.XRControlBinding | virtual
SetTrueMapping(object trueMapping) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetValue(object value) (defined in Deltares.Standard.Forms.DExpress.XRShapeBinding) | Deltares.Standard.Forms.DExpress.XRShapeBinding | virtual
SetValue(object value, object parent) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetVisible(bool visible) (defined in Deltares.Standard.Forms.DExpress.XRControlBinding) | Deltares.Standard.Forms.DExpress.XRControlBinding | virtual
ValueChanged (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ValueToString(object value) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
XRControlBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.XRControlBinding) | Deltares.Standard.Forms.DExpress.XRControlBinding |
XRShapeBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.XRShapeBinding) | Deltares.Standard.Forms.DExpress.XRShapeBinding |
Generated on Tue Dec 15 2015 18:15:25 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.XRSubreportBinding Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • XRSubreportBinding
Public Member Functions | List of all members
Deltares.Standard.Forms.DExpress.XRSubreportBinding Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.XRSubreportBinding:
Deltares.Standard.Forms.DExpress.XRControlBinding Deltares.Standard.Forms.DExpress.ComponentBinding

Public Member Functions

XRSubreportBinding (Component component)
override void | SetValue (object value)
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.XRControlBinding
XRControlBinding (Component component)
override void | Initialize (BindPropertyInfo propertyInfo, params string[] properties)
override void | SetLabel (string text)
override void | SetVisible (bool visible)
override void | SetForegroundColor (Color color)
override void | SetBackgroundColor (Color color)
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
ComponentBinding (Component component)
virtual void | Initialize (BindPropertyInfo propertyInfo, Type rootObjectType, params string[] properties)
virtual void | SetTrueMapping (object trueMapping)
virtual void | SetValue (object value, object parent)
virtual void | SetDomain (ICollection collection)
virtual object | GetValue ()
virtual void | SetEnabled (bool enabled)
virtual void | SetDescription (string description)
virtual void | Refresh ()
virtual void | Invalidate ()
virtual void | RegisterSelectionAssignment (Component targetComponent, IConverter converter=null)
Indicates that the selection of the bound control must be assigned to another control. More...
virtual void | SetControlColors (Color fore, Color back)
Sets the controls foreground and background colors. Can be overridden by a specific binding to set other colors if necessary. More...

Additional Inherited Members

- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.XRControlBinding
virtual void | BindSupport_BeforePrint (object sender, PrintEventArgs e)
- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
void | RaiseValueChanged ()
void | RaiseLeave ()
void | RaiseActionPerformed ()
Type | GetGenericType (Type type)
string | ValueToString (object value)
bool | IsAssociatedPropertyVisible (object source, BindPropertyInfo associatedPropertyInfo)
Indicates whether the associated property (i.e. the property which is used to display the original property in a textbox) is visible More...
void | EditFileInfo (object source, BindPropertyInfo propertyInfo)
string | EditFileInfo (string value, string format, string label, string description, bool isDirectory)
string | GetDoubleString (string text)
bool | HasValidNumericValue (string text)
double | GetNumericValue (string text)
List< BindPropertyInfo > | GetDictionaryProperties (ICollection domain, BindPropertyInfo dynamicPropertyInfo)
- Protected Attributes inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
BindPropertyInfo | propInfo
- Properties inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
Component | Component [get]
virtual bool | IsTransparant [get]
virtual HandleType | HandleDelayed [get]
virtual bool | HasDomain [get]
- Events inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
EventHandler< EventArgs > | ActionPerformed
EventHandler< EventArgs > | Leave
EventHandler< EventArgs > | ValueChanged
Generated on Tue Dec 15 2015 18:15:26 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • XRSubreportBinding
Deltares.Standard.Forms.DExpress.XRSubreportBinding Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.XRSubreportBinding, including all inherited members.

ActionPerformed (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
BindSupport_BeforePrint(object sender, PrintEventArgs e) (defined in Deltares.Standard.Forms.DExpress.XRControlBinding) | Deltares.Standard.Forms.DExpress.XRControlBinding | protectedvirtual
Component (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ComponentBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
EditFileInfo(object source, BindPropertyInfo propertyInfo) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
EditFileInfo(string value, string format, string label, string description, bool isDirectory) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetDictionaryProperties(ICollection domain, BindPropertyInfo dynamicPropertyInfo) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetDoubleString(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetGenericType(Type type) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetNumericValue(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetValue() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
HandleDelayed (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
HasDomain (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
HasValidNumericValue(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Initialize(BindPropertyInfo propertyInfo, params string[] properties) (defined in Deltares.Standard.Forms.DExpress.XRControlBinding) | Deltares.Standard.Forms.DExpress.XRControlBinding | virtual
Initialize(BindPropertyInfo propertyInfo, Type rootObjectType, params string[] properties) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
Invalidate() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
IsAssociatedPropertyVisible(object source, BindPropertyInfo associatedPropertyInfo) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
IsTransparant (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
Leave (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
propInfo (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseActionPerformed() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseLeave() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseValueChanged() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Refresh() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
RegisterSelectionAssignment(Component targetComponent, IConverter converter=null) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetBackgroundColor(Color color) (defined in Deltares.Standard.Forms.DExpress.XRControlBinding) | Deltares.Standard.Forms.DExpress.XRControlBinding | virtual
SetControlColors(Color fore, Color back) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetDescription(string description) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetDomain(ICollection collection) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetEnabled(bool enabled) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetForegroundColor(Color color) (defined in Deltares.Standard.Forms.DExpress.XRControlBinding) | Deltares.Standard.Forms.DExpress.XRControlBinding | virtual
SetLabel(string text) (defined in Deltares.Standard.Forms.DExpress.XRControlBinding) | Deltares.Standard.Forms.DExpress.XRControlBinding | virtual
SetTrueMapping(object trueMapping) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetValue(object value) (defined in Deltares.Standard.Forms.DExpress.XRSubreportBinding) | Deltares.Standard.Forms.DExpress.XRSubreportBinding | virtual
SetValue(object value, object parent) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetVisible(bool visible) (defined in Deltares.Standard.Forms.DExpress.XRControlBinding) | Deltares.Standard.Forms.DExpress.XRControlBinding | virtual
ValueChanged (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ValueToString(object value) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
XRControlBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.XRControlBinding) | Deltares.Standard.Forms.DExpress.XRControlBinding |
XRSubreportBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.XRSubreportBinding) | Deltares.Standard.Forms.DExpress.XRSubreportBinding |
Generated on Tue Dec 15 2015 18:15:26 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DExpress.XtraTabPageBinding Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • XtraTabPageBinding
Public Member Functions | List of all members
Deltares.Standard.Forms.DExpress.XtraTabPageBinding Class Reference
Inheritance diagram for Deltares.Standard.Forms.DExpress.XtraTabPageBinding:
Deltares.Standard.Forms.DExpress.ScrollableControlBinding Deltares.Standard.Forms.DExpress.ControlBinding Deltares.Standard.Forms.DExpress.ComponentBinding Deltares.Standard.Forms.DExpress.ComponentWrappers.IGetBoundControl

Public Member Functions

XtraTabPageBinding (Component component)
override void | SetVisible (bool visible)
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.ScrollableControlBinding
ScrollableControlBinding (Component component)
override void | SetEnabled (bool enabled)
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.ControlBinding
override void | SetLabel (string text)
Sets the label/title/name associated with this control. More...
override void | SetDescription (string description)
Sets the textual description associated with this control. More...
override void | SetForegroundColor (Color color)
override void | SetBackgroundColor (Color color)
override void | Invalidate ()
- Public Member Functions inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
ComponentBinding (Component component)
virtual void | Initialize (BindPropertyInfo propertyInfo, params string[] properties)
virtual void | Initialize (BindPropertyInfo propertyInfo, Type rootObjectType, params string[] properties)
virtual void | SetTrueMapping (object trueMapping)
virtual void | SetValue (object value)
virtual void | SetValue (object value, object parent)
virtual void | SetDomain (ICollection collection)
virtual object | GetValue ()
virtual void | Refresh ()
virtual void | RegisterSelectionAssignment (Component targetComponent, IConverter converter=null)
Indicates that the selection of the bound control must be assigned to another control. More...
virtual void | SetControlColors (Color fore, Color back)
Sets the controls foreground and background colors. Can be overridden by a specific binding to set other colors if necessary. More...

Additional Inherited Members

- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.ControlBinding
ControlBinding (Component component)
virtual void | OnToolTipShown (PopupEventArgs e)
Called when Tooltip is shown, and fires ToolTipShown event. More...
virtual void | OnToolTipClosed ()
Called when Tooltip is hidden, and fires ToolTipHidden. More...
void | ThreadSafeRefresh ()
override void | Dispose (bool disposing)
- Protected Member Functions inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
void | RaiseValueChanged ()
void | RaiseLeave ()
void | RaiseActionPerformed ()
Type | GetGenericType (Type type)
string | ValueToString (object value)
bool | IsAssociatedPropertyVisible (object source, BindPropertyInfo associatedPropertyInfo)
Indicates whether the associated property (i.e. the property which is used to display the original property in a textbox) is visible More...
void | EditFileInfo (object source, BindPropertyInfo propertyInfo)
string | EditFileInfo (string value, string format, string label, string description, bool isDirectory)
string | GetDoubleString (string text)
bool | HasValidNumericValue (string text)
double | GetNumericValue (string text)
List< BindPropertyInfo > | GetDictionaryProperties (ICollection domain, BindPropertyInfo dynamicPropertyInfo)
- Protected Attributes inherited from Deltares.Standard.Forms.DExpress.ControlBinding
readonly ToolTip | tooltip
string | Description
The textual description associated with this

See also
Control

. More...

string | Label
The label/title/name associated with this Control. More...
- Protected Attributes inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
BindPropertyInfo | propInfo
- Properties inherited from Deltares.Standard.Forms.DExpress.ControlBinding
ToolTip | Tooltip [get]
Gets the tooltip for the bound control. More...
Control | BoundControl [get]
- Properties inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
Component | Component [get]
virtual bool | IsTransparant [get]
virtual HandleType | HandleDelayed [get]
virtual bool | HasDomain [get]
- Properties inherited from Deltares.Standard.Forms.DExpress.ComponentWrappers.IGetBoundControl
Control | BoundControl [get]
- Events inherited from Deltares.Standard.Forms.DExpress.ControlBinding
ToolTipVisibilityEventHandler | ToolTipHidden
ToolTipVisibilityEventHandler | ToolTipShown
- Events inherited from Deltares.Standard.Forms.DExpress.ComponentBinding
EventHandler< EventArgs > | ActionPerformed
EventHandler< EventArgs > | Leave
EventHandler< EventArgs > | ValueChanged
Generated on Tue Dec 15 2015 18:15:26 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DExpress
  • XtraTabPageBinding
Deltares.Standard.Forms.DExpress.XtraTabPageBinding Member List

This is the complete list of members for Deltares.Standard.Forms.DExpress.XtraTabPageBinding, including all inherited members.

ActionPerformed (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
BoundControl (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding |
Component (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ComponentBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ControlBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Description | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Dispose(bool disposing) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | protected
EditFileInfo(object source, BindPropertyInfo propertyInfo) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
EditFileInfo(string value, string format, string label, string description, bool isDirectory) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetDictionaryProperties(ICollection domain, BindPropertyInfo dynamicPropertyInfo) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetDoubleString(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetGenericType(Type type) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetNumericValue(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
GetValue() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
HandleDelayed (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
HasDomain (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
HasValidNumericValue(string text) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Initialize(BindPropertyInfo propertyInfo, params string[] properties) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
Initialize(BindPropertyInfo propertyInfo, Type rootObjectType, params string[] properties) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
Invalidate() (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
IsAssociatedPropertyVisible(object source, BindPropertyInfo associatedPropertyInfo) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
IsTransparant (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
Label | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Leave (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
OnToolTipClosed() | Deltares.Standard.Forms.DExpress.ControlBinding | protectedvirtual
OnToolTipShown(PopupEventArgs e) | Deltares.Standard.Forms.DExpress.ControlBinding | protectedvirtual
propInfo (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseActionPerformed() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseLeave() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
RaiseValueChanged() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
Refresh() (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
RegisterSelectionAssignment(Component targetComponent, IConverter converter=null) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
ScrollableControlBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.ScrollableControlBinding) | Deltares.Standard.Forms.DExpress.ScrollableControlBinding |
SetBackgroundColor(Color color) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
SetControlColors(Color fore, Color back) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetDescription(string description) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
SetDomain(ICollection collection) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetEnabled(bool enabled) (defined in Deltares.Standard.Forms.DExpress.ScrollableControlBinding) | Deltares.Standard.Forms.DExpress.ScrollableControlBinding | virtual
SetForegroundColor(Color color) (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
SetLabel(string text) | Deltares.Standard.Forms.DExpress.ControlBinding | virtual
SetTrueMapping(object trueMapping) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetValue(object value) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetValue(object value, object parent) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | virtual
SetVisible(bool visible) (defined in Deltares.Standard.Forms.DExpress.XtraTabPageBinding) | Deltares.Standard.Forms.DExpress.XtraTabPageBinding | virtual
ThreadSafeRefresh() (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | protected
Tooltip | Deltares.Standard.Forms.DExpress.ControlBinding | protected
tooltip (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding | protected
ToolTipHidden (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding |
ToolTipShown (defined in Deltares.Standard.Forms.DExpress.ControlBinding) | Deltares.Standard.Forms.DExpress.ControlBinding |
ValueChanged (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding |
ValueToString(object value) (defined in Deltares.Standard.Forms.DExpress.ComponentBinding) | Deltares.Standard.Forms.DExpress.ComponentBinding | protected
XtraTabPageBinding(Component component) (defined in Deltares.Standard.Forms.DExpress.XtraTabPageBinding) | Deltares.Standard.Forms.DExpress.XtraTabPageBinding |
Generated on Tue Dec 15 2015 18:15:26 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DotSpatial.IShapeImporter Interface Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DotSpatial
  • IShapeImporter
Public Member Functions | List of all members
Deltares.Standard.Forms.DotSpatial.IShapeImporter Interface Reference
Inheritance diagram for Deltares.Standard.Forms.DotSpatial.IShapeImporter:
Deltares.Standard.Forms.DotSpatial.LineStringImporter Deltares.Standard.Forms.DotSpatial.PointImporter

Public Member Functions

void ImportShape (IBasicGeometry geometry, object target)
Sets the geometry data on the target object More...

Member Function Documentation

void Deltares.Standard.Forms.DotSpatial.IShapeImporter.ImportShape | ( | IBasicGeometry | geometry,
 |  | object | target
 | ) |  |

Sets the geometry data on the target object

Parameters
geometry | The base geometry
target | The target

Implemented in Deltares.Standard.Forms.DotSpatial.LineStringImporter, and Deltares.Standard.Forms.DotSpatial.PointImporter.

Generated on Tue Dec 15 2015 18:15:34 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DotSpatial
  • IShapeImporter
Deltares.Standard.Forms.DotSpatial.IShapeImporter Member List

This is the complete list of members for Deltares.Standard.Forms.DotSpatial.IShapeImporter, including all inherited members.

ImportShape(IBasicGeometry geometry, object target) Deltares.Standard.Forms.DotSpatial.IShapeImporter
Generated on Tue Dec 15 2015 18:15:34 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DotSpatial.LineStringImporter Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DotSpatial
  • LineStringImporter
Public Member Functions | List of all members
Deltares.Standard.Forms.DotSpatial.LineStringImporter Class Reference
Inheritance diagram for Deltares.Standard.Forms.DotSpatial.LineStringImporter:
Deltares.Standard.Forms.DotSpatial.IShapeImporter

Public Member Functions

void ImportShape (IBasicGeometry geometry, object target)
Sets the geometry data on the target object More...

Member Function Documentation

void Deltares.Standard.Forms.DotSpatial.LineStringImporter.ImportShape | ( | IBasicGeometry | geometry,
 |  | object | target
 | ) |  |

Sets the geometry data on the target object

Parameters
geometry | The base geometry
target | The target

Implements Deltares.Standard.Forms.DotSpatial.IShapeImporter.

Generated on Tue Dec 15 2015 18:15:34 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DotSpatial
  • LineStringImporter
Deltares.Standard.Forms.DotSpatial.LineStringImporter Member List

This is the complete list of members for Deltares.Standard.Forms.DotSpatial.LineStringImporter, including all inherited members.

ImportShape(IBasicGeometry geometry, object target) Deltares.Standard.Forms.DotSpatial.LineStringImporter
Generated on Tue Dec 15 2015 18:15:34 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DotSpatial.PointImporter Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DotSpatial
  • PointImporter
Public Member Functions | List of all members
Deltares.Standard.Forms.DotSpatial.PointImporter Class Reference
Inheritance diagram for Deltares.Standard.Forms.DotSpatial.PointImporter:
Deltares.Standard.Forms.DotSpatial.IShapeImporter

Public Member Functions

void ImportShape (IBasicGeometry geometry, object target)
Sets the geometry data on the target object More...

Member Function Documentation

void Deltares.Standard.Forms.DotSpatial.PointImporter.ImportShape | ( | IBasicGeometry | geometry,
 |  | object | target
 | ) |  |

Sets the geometry data on the target object

Parameters
geometry | The base geometry
target | The target

Implements Deltares.Standard.Forms.DotSpatial.IShapeImporter.

Generated on Tue Dec 15 2015 18:15:35 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DotSpatial
  • PointImporter
Deltares.Standard.Forms.DotSpatial.PointImporter Member List

This is the complete list of members for Deltares.Standard.Forms.DotSpatial.PointImporter, including all inherited members.

ImportShape(IBasicGeometry geometry, object target) Deltares.Standard.Forms.DotSpatial.PointImporter
Generated on Tue Dec 15 2015 18:15:35 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.Properties.Resources Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • Properties
  • Resources
Properties | List of all members
Deltares.Standard.Forms.Properties.Resources Class Reference

A strongly-typed resource class, for looking up localized strings, etc. More...

Properties

static global::System.Resources.ResourceManager | ResourceManager [get]
Returns the cached ResourceManager instance used by this class. More...
static global::System.Globalization.CultureInfo | Culture [get, set]
Overrides the current thread's CurrentUICulture property for all resource lookups using this strongly typed resource class. More...
static System.Drawing.Bitmap | accept [get]
Looks up a localized resource of type System.Drawing.Bitmap. More...
static System.Drawing.Bitmap | Add [get]
Looks up a localized resource of type System.Drawing.Bitmap. More...
static string | ApplicationLanguageGroupBoxCaption [get]
Looks up a localized string similar to Application language. More...
static string | ApplicationLanguageLabelCaption [get]
Looks up a localized string similar to Language. More...
static string | ApplicationViewButtonCaption [get]
Looks up a localized string similar to Application View. More...
static string | ApplicationViewTabPageCaption [get]
Looks up a localized string similar to Application View. More...
static System.Drawing.Bitmap | Attention [get]
Looks up a localized resource of type System.Drawing.Bitmap. More...
static System.Drawing.Bitmap | Back [get]
Looks up a localized resource of type System.Drawing.Bitmap. More...
static System.Drawing.Bitmap | BannerJpg [get]
Looks up a localized resource of type System.Drawing.Bitmap. More...
static System.Drawing.Bitmap | BannerPng [get]
Looks up a localized resource of type System.Drawing.Bitmap. More...
static string | BarStringAddOrRemove [get]
Looks up a localized string similar to Add or remove. More...
static string | BarStringCustomizeButton [get]
Looks up a localized string similar to Customize.... More...
static string | BarStringMenuAnimationFade [get]
Looks up a localized string similar to Fade. More...
static string | BarStringMenuAnimationNone [get]
Looks up a localized string similar to None. More...
static string | BarStringMenuAnimationRandom [get]
Looks up a localized string similar to Random. More...
static string | BarStringMenuAnimationSlide [get]
Looks up a localized string similar to Slide. More...
static string | BarStringMenuAnimationSystem [get]
Looks up a localized string similar to (System default). More...
static string | BarStringMenuAnimationUnfold [get]
Looks up a localized string similar to Unfold. More...
static string | BarStringNewToolbarCaption [get]
Looks up a localized string similar to NewToolbarCaption. More...
static string | BarStringRenameToolbarCaption [get]
Looks up a localized string similar to RenameToolbarCaption. More...
static string | BarStringResetBar [get]
Looks up a localized string similar to ResetBar. More...
static string | BarStringResetBarCaption [get]
Looks up a localized string similar to ResetBarCaption. More...
static string | BarStringResetButton [get]
Looks up a localized string similar to Reset button. More...
static string | BarStringToolBarMenu [get]
Looks up a localized string similar to ToolBarMenu. More...
static System.Drawing.Bitmap | Blank [get]
Looks up a localized resource of type System.Drawing.Bitmap. More...
static string | BrowseForFolder [get]
Looks up a localized string similar to Browse For Folder. More...
static string | btClose [get]
Looks up a localized string similar to Close. More...
static string | btClose1 [get]
Looks up a localized string similar to Close. More...
static string | btDeleteBar [get]
Looks up a localized string similar to &Delete. More...
static string | btDeleteBar1 [get]
Looks up a localized string similar to &Delete. More...
static string | btNBDlgCancel [get]
Looks up a localized string similar to Cancel. More...
static string | btNBDlgCancel1 [get]
Looks up a localized string similar to Cancel. More...
static string | btNBDlgOk [get]
Looks up a localized string similar to OK. More...
static string | btNBDlgOk1 [get]
Looks up a localized string similar to OK. More...
static string | btNewBar [get]
Looks up a localized string similar to New. More...
static string | btNewBar1 [get]
Looks up a localized string similar to New. More...
static string | btRenameBar [get]
Looks up a localized string similar to R&ename. More...
static string | btRenameBar1 [get]
Looks up a localized string similar to R&ename. More...
static string | btResetBar [get]
Looks up a localized string similar to &Reset. More...
static string | btResetBar1 [get]
Looks up a localized string similar to &Reset. More...
static string | ButtonMakeNewFolder [get]
Looks up a localized string similar to Make New Folder. More...
static string | ButtonTextAbort [get]
Looks up a localized string similar to Abort. More...
static string | ButtonTextCancel [get]
Looks up a localized string similar to Cancel. More...
static string | ButtonTextIgnore [get]
Looks up a localized string similar to Ignore. More...
static string | ButtonTextNo [get]
Looks up a localized string similar to No. More...
static string | ButtonTextOk [get]
Looks up a localized string similar to OK. More...
static string | ButtonTextRetry [get]
Looks up a localized string similar to Retry. More...
static string | ButtonTextYes [get]
Looks up a localized string similar to Yes. More...
static string | cbOptionslargeIcons [get]
Looks up a localized string similar to &Large Icons. More...
static string | cbOptionslargeIcons1 [get]
Looks up a localized string similar to &Large Icons. More...
static string | cbOptionsShowFullMenus [get]
Looks up a localized string similar to Always show full menus. More...
static string | cbOptionsShowFullMenus1 [get]
Looks up a localized string similar to Always show full menus. More...
static string | cbOptionsshowTips [get]
Looks up a localized string similar to Show Screen &Tips on toolbars. More...
static string | cbOptionsshowTips1 [get]
Looks up a localized string similar to Show Screen &Tips on toolbars. More...
static string | CloseButtonCaption [get]
Looks up a localized string similar to Cancel. More...
static string | ColorSchemeGroupBoxCaption [get]
Looks up a localized string similar to Color scheme. More...
static string | ColorSchemeLabelCaption [get]
Looks up a localized string similar to Color scheme. More...
static string | CommandLineBadFormat [get]
Looks up a localized string similar to Badformat. More...
static string | CommandlineErrorText [get]
Looks up a localized string similar to Error. More...
static System.Drawing.Bitmap | Copy [get]
Looks up a localized resource of type System.Drawing.Bitmap. More...
static string | CustomizeCaption [get]
Looks up a localized string similar to CustomizeWindowCaption. More...
static string | CustomizeCaption1 [get]
Looks up a localized string similar to Customize Window. More...
static System.Drawing.Bitmap | Debug [get]
Looks up a localized resource of type System.Drawing.Bitmap. More...
static string | DefaultLookAndFeelRadioButtonCaption [get]
Looks up a localized string similar to User defined color scheme. More...
static string | DirectoriesCheckBoxCaption [get]
Looks up a localized string similar to &Save last used directory as working directory. More...
static string | DirectoriesGroupBoxCaption [get]
Looks up a localized string similar to Directories. More...
static string | DirectoriesTabPageCaption [get]
Looks up a localized string similar to Directories. More...
static System.Drawing.Icon | DLTRS [get]
Looks up a localized resource of type System.Drawing.Icon similar to (Icon). More...
static System.Drawing.Bitmap | Error [get]
Looks up a localized resource of type System.Drawing.Bitmap. More...
static string | ExplorerBarRadioButtonCaption [get]
Looks up a localized string similar to Explorer bar. More...
static System.Drawing.Bitmap | Export [get]
Looks up a localized resource of type System.Drawing.Bitmap. More...
static System.Drawing.Bitmap | Forward [get]
Looks up a localized resource of type System.Drawing.Bitmap. More...
static string | GeneralButtonCaption [get]
Looks up a localized string similar to General. More...
static string | GeneralTabPageCaption [get]
Looks up a localized string similar to Start Up With. More...
static System.Drawing.Bitmap | Gridlines [get]
Looks up a localized resource of type System.Drawing.Bitmap. More...
static System.Drawing.Bitmap | Information [get]
Looks up a localized resource of type System.Drawing.Bitmap. More...
static string | InputPointCaption [get]
Looks up a localized string similar to Input Point. More...
static string | LanguageButtonCaption [get]
Looks up a localized string similar to Language. More...
static string | LanguageTabPageCaption [get]
Looks up a localized string similar to Language. More...
static string | LastUsedProjectRadioButtonCaption [get]
Looks up a localized string similar to Last used project. More...
static string | lbCategoriesCaption [get]
Looks up a localized string similar to Categories :. More...
static string | lbCategoriesCaption1 [get]
Looks up a localized string similar to Categories :. More...
static string | lbCommandsCaption [get]
Looks up a localized string similar to Commands :. More...
static string | lbCommandsCaption1 [get]
Looks up a localized string similar to Commands :. More...
static string | lbDescriptionCaption [get]
Looks up a localized string similar to Description. More...
static string | lbDescriptionCaption1 [get]
Looks up a localized string similar to Description. More...
static string | lbOptionsOther [get]
Looks up a localized string similar to Other. More...
static string | lbOptionsOther1 [get]
Looks up a localized string similar to Other. More...
static string | lbOptionsPCaption [get]
Looks up a localized string similar to Personalize Menus and Toolbars. More...
static string | lbOptionsPCaption1 [get]
Looks up a localized string similar to Personalize Menus and Toolbars. More...
static System.Drawing.Bitmap | Legend [get]
Looks up a localized resource of type System.Drawing.Bitmap. More...
static string | LicenceDongleGroupBoxCaption [get]
Looks up a localized string similar to Licence Dongle. More...
static string | MenuAnimation [get]
Looks up a localized string similar to &Menu animations. More...
static string | MenuAnimation1 [get]
Looks up a localized string similar to &Menu animations. More...
static string | ModulesButtonCaption [get]
Looks up a localized string similar to Modules. More...
static string | ModulesTabPageCaption [get]
Looks up a localized string similar to Modules. More...
static string | NavBarRadioButtonCaption [get]
Looks up a localized string similar to Navigation pane. More...
static string | NavigationStyleGroupBoxCaption [get]
Looks up a localized string similar to Navigation style. More...
static string | NewProjectRadioButtonCaption [get]
Looks up a localized string similar to New project. More...
static System.Drawing.Bitmap | Next [get]
Looks up a localized resource of type System.Drawing.Bitmap. More...
static string | NoProjectRadioButtonCaption [get]
Looks up a localized string similar to No project. More...
static string | OkButtonCaption [get]
Looks up a localized string similar to OK. More...
static System.Drawing.Bitmap | Open [get]
Looks up a localized resource of type System.Drawing.Bitmap. More...
static System.Drawing.Bitmap | OpenImage [get]
Looks up a localized resource of type System.Drawing.Bitmap. More...
static System.Drawing.Bitmap | Pan [get]
Looks up a localized resource of type System.Drawing.Bitmap. More...
static System.Drawing.Bitmap | Pause [get]
Looks up a localized resource of type System.Drawing.Bitmap. More...
static System.Drawing.Bitmap | Previous [get]
Looks up a localized resource of type System.Drawing.Bitmap. More...
static System.Drawing.Bitmap | Redo [get]
Looks up a localized resource of type System.Drawing.Bitmap. More...
static System.Drawing.Bitmap | Remove [get]
Looks up a localized resource of type System.Drawing.Bitmap. More...
static string | ReportLanguageGroupboxCaption [get]
Looks up a localized string similar to Report language. More...
static string | ReportLanguageLabelCaption [get]
Looks up a localized string similar to Language. More...
static string | Reset [get]
Looks up a localized string similar to &Reset my usage data. More...
static string | Reset1 [get]
Looks up a localized string similar to &Reset my usage data. More...
static System.Drawing.Bitmap | Save [get]
Looks up a localized resource of type System.Drawing.Bitmap. More...
static System.Drawing.Bitmap | SaveAll [get]
Looks up a localized resource of type System.Drawing.Bitmap. More...
static System.Drawing.Bitmap | SaveImage [get]
Looks up a localized resource of type System.Drawing.Bitmap. More...
static System.Drawing.Bitmap | SaveLayer [get]
Looks up a localized resource of type System.Drawing.Bitmap. More...
static System.Drawing.Bitmap | Select [get]
Looks up a localized resource of type System.Drawing.Bitmap. More...
static string | SelectWorkingDirectory [get]
Looks up a localized string similar to Select working directory. More...
static string | showFullMenusAfterDelay [get]
Looks up a localized string similar to Show full menus after Short delay. More...
static string | showFullMenusAfterDelay1 [get]
Looks up a localized string similar to Show full menus after Short delay. More...
static string | ShowShortcutInTips [get]
Looks up a localized string similar to Show S&hortcut Keys in ScreenTips. More...
static string | ShowShortcutInTips1 [get]
Looks up a localized string similar to Show S&hortcut Keys in ScreenTips. More...
static System.Drawing.Bitmap | Start [get]
Looks up a localized resource of type System.Drawing.Bitmap. More...
static string | StartUpGroupBoxCaption [get]
Looks up a localized string similar to Start up with. More...
static System.Drawing.Bitmap | Stop [get]
Looks up a localized resource of type System.Drawing.Bitmap. More...
static System.Drawing.Bitmap | ToggleExpand [get]
Looks up a localized resource of type System.Drawing.Bitmap. More...
static string | tpCommands [get]
Looks up a localized string similar to Commands. More...
static string | tpCommands1 [get]
Looks up a localized string similar to Commands. More...
static string | tpOptions [get]
Looks up a localized string similar to Options. More...
static string | tpOptions1 [get]
Looks up a localized string similar to Options. More...
static string | tpToolbars [get]
Looks up a localized string similar to Toolbars. More...
static string | tpToolbars1 [get]
Looks up a localized string similar to Toolbars. More...
static System.Drawing.Bitmap | UiButtonToggle [get]
Looks up a localized resource of type System.Drawing.Bitmap. More...
static System.Drawing.Bitmap | Undo [get]
Looks up a localized resource of type System.Drawing.Bitmap. More...
static System.Drawing.Bitmap | Warning [get]
Looks up a localized resource of type System.Drawing.Bitmap. More...
static System.Drawing.Bitmap | Waternet [get]
Looks up a localized resource of type System.Drawing.Bitmap. More...
static System.Drawing.Bitmap | Web [get]
Looks up a localized resource of type System.Drawing.Bitmap. More...
static string | WindowsLookAndFeelRadioButtonCaption [get]
Looks up a localized string similar to Windows color scheme. More...
static string | WorkingDirectoryLabelCaption [get]
Looks up a localized string similar to &Working directory. More...
static System.Drawing.Bitmap | Zoom [get]
Looks up a localized resource of type System.Drawing.Bitmap. More...
static System.Drawing.Bitmap | ZoomAll [get]
Looks up a localized resource of type System.Drawing.Bitmap. More...
static System.Drawing.Bitmap | ZoomExtents [get]
Looks up a localized resource of type System.Drawing.Bitmap. More...
static System.Drawing.Bitmap | ZoomFit [get]
Looks up a localized resource of type System.Drawing.Bitmap. More...
static System.Drawing.Bitmap | ZoomIn [get]
Looks up a localized resource of type System.Drawing.Bitmap. More...
static System.Drawing.Bitmap | ZoomRectangle [get]
Looks up a localized resource of type System.Drawing.Bitmap. More...
static System.Drawing.Bitmap | ZoomSelection [get]
Looks up a localized resource of type System.Drawing.Bitmap. More...
static System.Drawing.Bitmap | ZoomTo [get]
Looks up a localized resource of type System.Drawing.Bitmap. More...

Detailed Description

A strongly-typed resource class, for looking up localized strings, etc.

Property Documentation

System.Drawing.Bitmap Deltares.Standard.Forms.Properties.Resources.accept
staticget

Looks up a localized resource of type System.Drawing.Bitmap.

System.Drawing.Bitmap Deltares.Standard.Forms.Properties.Resources.Add
staticget

Looks up a localized resource of type System.Drawing.Bitmap.

string Deltares.Standard.Forms.Properties.Resources.ApplicationLanguageGroupBoxCaption
staticget

Looks up a localized string similar to Application language.

string Deltares.Standard.Forms.Properties.Resources.ApplicationLanguageLabelCaption
staticget

Looks up a localized string similar to Language.

string Deltares.Standard.Forms.Properties.Resources.ApplicationViewButtonCaption
staticget

Looks up a localized string similar to Application View.

string Deltares.Standard.Forms.Properties.Resources.ApplicationViewTabPageCaption
staticget

Looks up a localized string similar to Application View.

System.Drawing.Bitmap Deltares.Standard.Forms.Properties.Resources.Attention
staticget

Looks up a localized resource of type System.Drawing.Bitmap.

System.Drawing.Bitmap Deltares.Standard.Forms.Properties.Resources.Back
staticget

Looks up a localized resource of type System.Drawing.Bitmap.

System.Drawing.Bitmap Deltares.Standard.Forms.Properties.Resources.BannerJpg
staticget

Looks up a localized resource of type System.Drawing.Bitmap.

System.Drawing.Bitmap Deltares.Standard.Forms.Properties.Resources.BannerPng
staticget

Looks up a localized resource of type System.Drawing.Bitmap.

string Deltares.Standard.Forms.Properties.Resources.BarStringAddOrRemove
staticget

Looks up a localized string similar to Add or remove.

string Deltares.Standard.Forms.Properties.Resources.BarStringCustomizeButton
staticget

Looks up a localized string similar to Customize....

string Deltares.Standard.Forms.Properties.Resources.BarStringMenuAnimationFade
staticget

Looks up a localized string similar to Fade.

string Deltares.Standard.Forms.Properties.Resources.BarStringMenuAnimationNone
staticget

Looks up a localized string similar to None.

string Deltares.Standard.Forms.Properties.Resources.BarStringMenuAnimationRandom
staticget

Looks up a localized string similar to Random.

string Deltares.Standard.Forms.Properties.Resources.BarStringMenuAnimationSlide
staticget

Looks up a localized string similar to Slide.

string Deltares.Standard.Forms.Properties.Resources.BarStringMenuAnimationSystem
staticget

Looks up a localized string similar to (System default).

string Deltares.Standard.Forms.Properties.Resources.BarStringMenuAnimationUnfold
staticget

Looks up a localized string similar to Unfold.

string Deltares.Standard.Forms.Properties.Resources.BarStringNewToolbarCaption
staticget

Looks up a localized string similar to NewToolbarCaption.

string Deltares.Standard.Forms.Properties.Resources.BarStringRenameToolbarCaption
staticget

Looks up a localized string similar to RenameToolbarCaption.

string Deltares.Standard.Forms.Properties.Resources.BarStringResetBar
staticget

Looks up a localized string similar to ResetBar.

string Deltares.Standard.Forms.Properties.Resources.BarStringResetBarCaption
staticget

Looks up a localized string similar to ResetBarCaption.

string Deltares.Standard.Forms.Properties.Resources.BarStringResetButton
staticget

Looks up a localized string similar to Reset button.

string Deltares.Standard.Forms.Properties.Resources.BarStringToolBarMenu
staticget

Looks up a localized string similar to ToolBarMenu.

System.Drawing.Bitmap Deltares.Standard.Forms.Properties.Resources.Blank
staticget

Looks up a localized resource of type System.Drawing.Bitmap.

string Deltares.Standard.Forms.Properties.Resources.BrowseForFolder
staticget

Looks up a localized string similar to Browse For Folder.

string Deltares.Standard.Forms.Properties.Resources.btClose
staticget

Looks up a localized string similar to Close.

string Deltares.Standard.Forms.Properties.Resources.btClose1
staticget

Looks up a localized string similar to Close.

string Deltares.Standard.Forms.Properties.Resources.btDeleteBar
staticget

Looks up a localized string similar to &Delete.

string Deltares.Standard.Forms.Properties.Resources.btDeleteBar1
staticget

Looks up a localized string similar to &Delete.

string Deltares.Standard.Forms.Properties.Resources.btNBDlgCancel
staticget

Looks up a localized string similar to Cancel.

string Deltares.Standard.Forms.Properties.Resources.btNBDlgCancel1
staticget

Looks up a localized string similar to Cancel.

string Deltares.Standard.Forms.Properties.Resources.btNBDlgOk
staticget

Looks up a localized string similar to OK.

string Deltares.Standard.Forms.Properties.Resources.btNBDlgOk1
staticget

Looks up a localized string similar to OK.

string Deltares.Standard.Forms.Properties.Resources.btNewBar
staticget

Looks up a localized string similar to New.

string Deltares.Standard.Forms.Properties.Resources.btNewBar1
staticget

Looks up a localized string similar to New.

string Deltares.Standard.Forms.Properties.Resources.btRenameBar
staticget

Looks up a localized string similar to R&ename.

string Deltares.Standard.Forms.Properties.Resources.btRenameBar1
staticget

Looks up a localized string similar to R&ename.

string Deltares.Standard.Forms.Properties.Resources.btResetBar
staticget

Looks up a localized string similar to &Reset.

string Deltares.Standard.Forms.Properties.Resources.btResetBar1
staticget

Looks up a localized string similar to &Reset.

string Deltares.Standard.Forms.Properties.Resources.ButtonMakeNewFolder
staticget

Looks up a localized string similar to Make New Folder.

string Deltares.Standard.Forms.Properties.Resources.ButtonTextAbort
staticget

Looks up a localized string similar to Abort.

string Deltares.Standard.Forms.Properties.Resources.ButtonTextCancel
staticget

Looks up a localized string similar to Cancel.

string Deltares.Standard.Forms.Properties.Resources.ButtonTextIgnore
staticget

Looks up a localized string similar to Ignore.

string Deltares.Standard.Forms.Properties.Resources.ButtonTextNo
staticget

Looks up a localized string similar to No.

string Deltares.Standard.Forms.Properties.Resources.ButtonTextOk
staticget

Looks up a localized string similar to OK.

string Deltares.Standard.Forms.Properties.Resources.ButtonTextRetry
staticget

Looks up a localized string similar to Retry.

string Deltares.Standard.Forms.Properties.Resources.ButtonTextYes
staticget

Looks up a localized string similar to Yes.

string Deltares.Standard.Forms.Properties.Resources.cbOptionslargeIcons
staticget

Looks up a localized string similar to &Large Icons.

string Deltares.Standard.Forms.Properties.Resources.cbOptionslargeIcons1
staticget

Looks up a localized string similar to &Large Icons.

string Deltares.Standard.Forms.Properties.Resources.cbOptionsShowFullMenus
staticget

Looks up a localized string similar to Always show full menus.

string Deltares.Standard.Forms.Properties.Resources.cbOptionsShowFullMenus1
staticget

Looks up a localized string similar to Always show full menus.

string Deltares.Standard.Forms.Properties.Resources.cbOptionsshowTips
staticget

Looks up a localized string similar to Show Screen &Tips on toolbars.

string Deltares.Standard.Forms.Properties.Resources.cbOptionsshowTips1
staticget

Looks up a localized string similar to Show Screen &Tips on toolbars.

string Deltares.Standard.Forms.Properties.Resources.CloseButtonCaption
staticget

Looks up a localized string similar to Cancel.

string Deltares.Standard.Forms.Properties.Resources.ColorSchemeGroupBoxCaption
staticget

Looks up a localized string similar to Color scheme.

string Deltares.Standard.Forms.Properties.Resources.ColorSchemeLabelCaption
staticget

Looks up a localized string similar to Color scheme.

string Deltares.Standard.Forms.Properties.Resources.CommandLineBadFormat
staticget

Looks up a localized string similar to Badformat.

string Deltares.Standard.Forms.Properties.Resources.CommandlineErrorText
staticget

Looks up a localized string similar to Error.

System.Drawing.Bitmap Deltares.Standard.Forms.Properties.Resources.Copy
staticget

Looks up a localized resource of type System.Drawing.Bitmap.

global.System.Globalization.CultureInfo Deltares.Standard.Forms.Properties.Resources.Culture
staticgetset

Overrides the current thread's CurrentUICulture property for all resource lookups using this strongly typed resource class.

string Deltares.Standard.Forms.Properties.Resources.CustomizeCaption
staticget

Looks up a localized string similar to CustomizeWindowCaption.

string Deltares.Standard.Forms.Properties.Resources.CustomizeCaption1
staticget

Looks up a localized string similar to Customize Window.

System.Drawing.Bitmap Deltares.Standard.Forms.Properties.Resources.Debug
staticget

Looks up a localized resource of type System.Drawing.Bitmap.

string Deltares.Standard.Forms.Properties.Resources.DefaultLookAndFeelRadioButtonCaption
staticget

Looks up a localized string similar to User defined color scheme.

string Deltares.Standard.Forms.Properties.Resources.DirectoriesCheckBoxCaption
staticget

Looks up a localized string similar to &Save last used directory as working directory.

string Deltares.Standard.Forms.Properties.Resources.DirectoriesGroupBoxCaption
staticget

Looks up a localized string similar to Directories.

string Deltares.Standard.Forms.Properties.Resources.DirectoriesTabPageCaption
staticget

Looks up a localized string similar to Directories.

System.Drawing.Icon Deltares.Standard.Forms.Properties.Resources.DLTRS
staticget

Looks up a localized resource of type System.Drawing.Icon similar to (Icon).

System.Drawing.Bitmap Deltares.Standard.Forms.Properties.Resources.Error
staticget

Looks up a localized resource of type System.Drawing.Bitmap.

string Deltares.Standard.Forms.Properties.Resources.ExplorerBarRadioButtonCaption
staticget

Looks up a localized string similar to Explorer bar.

System.Drawing.Bitmap Deltares.Standard.Forms.Properties.Resources.Export
staticget

Looks up a localized resource of type System.Drawing.Bitmap.

Referenced by Deltares.Standard.Forms.DExpress.MapEditor.MapEditor().

System.Drawing.Bitmap Deltares.Standard.Forms.Properties.Resources.Forward
staticget

Looks up a localized resource of type System.Drawing.Bitmap.

string Deltares.Standard.Forms.Properties.Resources.GeneralButtonCaption
staticget

Looks up a localized string similar to General.

string Deltares.Standard.Forms.Properties.Resources.GeneralTabPageCaption
staticget

Looks up a localized string similar to Start Up With.

System.Drawing.Bitmap Deltares.Standard.Forms.Properties.Resources.Gridlines
staticget

Looks up a localized resource of type System.Drawing.Bitmap.

System.Drawing.Bitmap Deltares.Standard.Forms.Properties.Resources.Information
staticget

Looks up a localized resource of type System.Drawing.Bitmap.

string Deltares.Standard.Forms.Properties.Resources.InputPointCaption
staticget

Looks up a localized string similar to Input Point.

string Deltares.Standard.Forms.Properties.Resources.LanguageButtonCaption
staticget

Looks up a localized string similar to Language.

string Deltares.Standard.Forms.Properties.Resources.LanguageTabPageCaption
staticget

Looks up a localized string similar to Language.

string Deltares.Standard.Forms.Properties.Resources.LastUsedProjectRadioButtonCaption
staticget

Looks up a localized string similar to Last used project.

string Deltares.Standard.Forms.Properties.Resources.lbCategoriesCaption
staticget

Looks up a localized string similar to Categories :.

string Deltares.Standard.Forms.Properties.Resources.lbCategoriesCaption1
staticget

Looks up a localized string similar to Categories :.

string Deltares.Standard.Forms.Properties.Resources.lbCommandsCaption
staticget

Looks up a localized string similar to Commands :.

string Deltares.Standard.Forms.Properties.Resources.lbCommandsCaption1
staticget

Looks up a localized string similar to Commands :.

string Deltares.Standard.Forms.Properties.Resources.lbDescriptionCaption
staticget

Looks up a localized string similar to Description.

string Deltares.Standard.Forms.Properties.Resources.lbDescriptionCaption1
staticget

Looks up a localized string similar to Description.

string Deltares.Standard.Forms.Properties.Resources.lbOptionsOther
staticget

Looks up a localized string similar to Other.

string Deltares.Standard.Forms.Properties.Resources.lbOptionsOther1
staticget

Looks up a localized string similar to Other.

string Deltares.Standard.Forms.Properties.Resources.lbOptionsPCaption
staticget

Looks up a localized string similar to Personalize Menus and Toolbars.

string Deltares.Standard.Forms.Properties.Resources.lbOptionsPCaption1
staticget

Looks up a localized string similar to Personalize Menus and Toolbars.

System.Drawing.Bitmap Deltares.Standard.Forms.Properties.Resources.Legend
staticget

Looks up a localized resource of type System.Drawing.Bitmap.

string Deltares.Standard.Forms.Properties.Resources.LicenceDongleGroupBoxCaption
staticget

Looks up a localized string similar to Licence Dongle.

string Deltares.Standard.Forms.Properties.Resources.MenuAnimation
staticget

Looks up a localized string similar to &Menu animations.

string Deltares.Standard.Forms.Properties.Resources.MenuAnimation1
staticget

Looks up a localized string similar to &Menu animations.

string Deltares.Standard.Forms.Properties.Resources.ModulesButtonCaption
staticget

Looks up a localized string similar to Modules.

string Deltares.Standard.Forms.Properties.Resources.ModulesTabPageCaption
staticget

Looks up a localized string similar to Modules.

string Deltares.Standard.Forms.Properties.Resources.NavBarRadioButtonCaption
staticget

Looks up a localized string similar to Navigation pane.

string Deltares.Standard.Forms.Properties.Resources.NavigationStyleGroupBoxCaption
staticget

Looks up a localized string similar to Navigation style.

string Deltares.Standard.Forms.Properties.Resources.NewProjectRadioButtonCaption
staticget

Looks up a localized string similar to New project.

System.Drawing.Bitmap Deltares.Standard.Forms.Properties.Resources.Next
staticget

Looks up a localized resource of type System.Drawing.Bitmap.

string Deltares.Standard.Forms.Properties.Resources.NoProjectRadioButtonCaption
staticget

Looks up a localized string similar to No project.

string Deltares.Standard.Forms.Properties.Resources.OkButtonCaption
staticget

Looks up a localized string similar to OK.

System.Drawing.Bitmap Deltares.Standard.Forms.Properties.Resources.Open
staticget

Looks up a localized resource of type System.Drawing.Bitmap.

System.Drawing.Bitmap Deltares.Standard.Forms.Properties.Resources.OpenImage
staticget

Looks up a localized resource of type System.Drawing.Bitmap.

Referenced by Deltares.Standard.Forms.DExpress.MapEditor.MapEditor().

System.Drawing.Bitmap Deltares.Standard.Forms.Properties.Resources.Pan
staticget

Looks up a localized resource of type System.Drawing.Bitmap.

System.Drawing.Bitmap Deltares.Standard.Forms.Properties.Resources.Pause
staticget

Looks up a localized resource of type System.Drawing.Bitmap.

System.Drawing.Bitmap Deltares.Standard.Forms.Properties.Resources.Previous
staticget

Looks up a localized resource of type System.Drawing.Bitmap.

System.Drawing.Bitmap Deltares.Standard.Forms.Properties.Resources.Redo
staticget

Looks up a localized resource of type System.Drawing.Bitmap.

System.Drawing.Bitmap Deltares.Standard.Forms.Properties.Resources.Remove
staticget

Looks up a localized resource of type System.Drawing.Bitmap.

string Deltares.Standard.Forms.Properties.Resources.ReportLanguageGroupboxCaption
staticget

Looks up a localized string similar to Report language.

string Deltares.Standard.Forms.Properties.Resources.ReportLanguageLabelCaption
staticget

Looks up a localized string similar to Language.

string Deltares.Standard.Forms.Properties.Resources.Reset
staticget

Looks up a localized string similar to &Reset my usage data.

string Deltares.Standard.Forms.Properties.Resources.Reset1
staticget

Looks up a localized string similar to &Reset my usage data.

global.System.Resources.ResourceManager Deltares.Standard.Forms.Properties.Resources.ResourceManager
staticget

Returns the cached ResourceManager instance used by this class.

System.Drawing.Bitmap Deltares.Standard.Forms.Properties.Resources.Save
staticget

Looks up a localized resource of type System.Drawing.Bitmap.

System.Drawing.Bitmap Deltares.Standard.Forms.Properties.Resources.SaveAll
staticget

Looks up a localized resource of type System.Drawing.Bitmap.

System.Drawing.Bitmap Deltares.Standard.Forms.Properties.Resources.SaveImage
staticget

Looks up a localized resource of type System.Drawing.Bitmap.

Referenced by Deltares.Standard.Forms.DExpress.MapEditor.MapEditor().

System.Drawing.Bitmap Deltares.Standard.Forms.Properties.Resources.SaveLayer
staticget

Looks up a localized resource of type System.Drawing.Bitmap.

System.Drawing.Bitmap Deltares.Standard.Forms.Properties.Resources.Select
staticget

Looks up a localized resource of type System.Drawing.Bitmap.

string Deltares.Standard.Forms.Properties.Resources.SelectWorkingDirectory
staticget

Looks up a localized string similar to Select working directory.

string Deltares.Standard.Forms.Properties.Resources.showFullMenusAfterDelay
staticget

Looks up a localized string similar to Show full menus after Short delay.

string Deltares.Standard.Forms.Properties.Resources.showFullMenusAfterDelay1
staticget

Looks up a localized string similar to Show full menus after Short delay.

string Deltares.Standard.Forms.Properties.Resources.ShowShortcutInTips
staticget

Looks up a localized string similar to Show S&hortcut Keys in ScreenTips.

string Deltares.Standard.Forms.Properties.Resources.ShowShortcutInTips1
staticget

Looks up a localized string similar to Show S&hortcut Keys in ScreenTips.

System.Drawing.Bitmap Deltares.Standard.Forms.Properties.Resources.Start
staticget

Looks up a localized resource of type System.Drawing.Bitmap.

string Deltares.Standard.Forms.Properties.Resources.StartUpGroupBoxCaption
staticget

Looks up a localized string similar to Start up with.

System.Drawing.Bitmap Deltares.Standard.Forms.Properties.Resources.Stop
staticget

Looks up a localized resource of type System.Drawing.Bitmap.

System.Drawing.Bitmap Deltares.Standard.Forms.Properties.Resources.ToggleExpand
staticget

Looks up a localized resource of type System.Drawing.Bitmap.

string Deltares.Standard.Forms.Properties.Resources.tpCommands
staticget

Looks up a localized string similar to Commands.

string Deltares.Standard.Forms.Properties.Resources.tpCommands1
staticget

Looks up a localized string similar to Commands.

string Deltares.Standard.Forms.Properties.Resources.tpOptions
staticget

Looks up a localized string similar to Options.

string Deltares.Standard.Forms.Properties.Resources.tpOptions1
staticget

Looks up a localized string similar to Options.

string Deltares.Standard.Forms.Properties.Resources.tpToolbars
staticget

Looks up a localized string similar to Toolbars.

string Deltares.Standard.Forms.Properties.Resources.tpToolbars1
staticget

Looks up a localized string similar to Toolbars.

System.Drawing.Bitmap Deltares.Standard.Forms.Properties.Resources.UiButtonToggle
staticget

Looks up a localized resource of type System.Drawing.Bitmap.

System.Drawing.Bitmap Deltares.Standard.Forms.Properties.Resources.Undo
staticget

Looks up a localized resource of type System.Drawing.Bitmap.

System.Drawing.Bitmap Deltares.Standard.Forms.Properties.Resources.Warning
staticget

Looks up a localized resource of type System.Drawing.Bitmap.

System.Drawing.Bitmap Deltares.Standard.Forms.Properties.Resources.Waternet
staticget

Looks up a localized resource of type System.Drawing.Bitmap.

System.Drawing.Bitmap Deltares.Standard.Forms.Properties.Resources.Web
staticget

Looks up a localized resource of type System.Drawing.Bitmap.

Referenced by Deltares.Standard.Forms.DExpress.MapEditor.MapEditor().

string Deltares.Standard.Forms.Properties.Resources.WindowsLookAndFeelRadioButtonCaption
staticget

Looks up a localized string similar to Windows color scheme.

string Deltares.Standard.Forms.Properties.Resources.WorkingDirectoryLabelCaption
staticget

Looks up a localized string similar to &Working directory.

System.Drawing.Bitmap Deltares.Standard.Forms.Properties.Resources.Zoom
staticget

Looks up a localized resource of type System.Drawing.Bitmap.

System.Drawing.Bitmap Deltares.Standard.Forms.Properties.Resources.ZoomAll
staticget

Looks up a localized resource of type System.Drawing.Bitmap.

Referenced by Deltares.Standard.Forms.DExpress.MapEditor.MapEditor().

System.Drawing.Bitmap Deltares.Standard.Forms.Properties.Resources.ZoomExtents
staticget

Looks up a localized resource of type System.Drawing.Bitmap.

Referenced by Deltares.Standard.Forms.DExpress.MapEditor.MapEditor().

System.Drawing.Bitmap Deltares.Standard.Forms.Properties.Resources.ZoomFit
staticget

Looks up a localized resource of type System.Drawing.Bitmap.

System.Drawing.Bitmap Deltares.Standard.Forms.Properties.Resources.ZoomIn
staticget

Looks up a localized resource of type System.Drawing.Bitmap.

System.Drawing.Bitmap Deltares.Standard.Forms.Properties.Resources.ZoomRectangle
staticget

Looks up a localized resource of type System.Drawing.Bitmap.

Referenced by Deltares.Standard.Forms.DExpress.MapEditor.MapEditor().

System.Drawing.Bitmap Deltares.Standard.Forms.Properties.Resources.ZoomSelection
staticget

Looks up a localized resource of type System.Drawing.Bitmap.

Referenced by Deltares.Standard.Forms.DExpress.MapEditor.MapEditor().

System.Drawing.Bitmap Deltares.Standard.Forms.Properties.Resources.ZoomTo
staticget

Looks up a localized resource of type System.Drawing.Bitmap.

Generated on Tue Dec 15 2015 18:15:35 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • Properties
  • Resources
Deltares.Standard.Forms.Properties.Resources Member List

This is the complete list of members for Deltares.Standard.Forms.Properties.Resources, including all inherited members.

accept | Deltares.Standard.Forms.Properties.Resources | static
Add | Deltares.Standard.Forms.Properties.Resources | static
ApplicationLanguageGroupBoxCaption | Deltares.Standard.Forms.Properties.Resources | static
ApplicationLanguageLabelCaption | Deltares.Standard.Forms.Properties.Resources | static
ApplicationViewButtonCaption | Deltares.Standard.Forms.Properties.Resources | static
ApplicationViewTabPageCaption | Deltares.Standard.Forms.Properties.Resources | static
Attention | Deltares.Standard.Forms.Properties.Resources | static
Back | Deltares.Standard.Forms.Properties.Resources | static
BannerJpg | Deltares.Standard.Forms.Properties.Resources | static
BannerPng | Deltares.Standard.Forms.Properties.Resources | static
BarStringAddOrRemove | Deltares.Standard.Forms.Properties.Resources | static
BarStringCustomizeButton | Deltares.Standard.Forms.Properties.Resources | static
BarStringMenuAnimationFade | Deltares.Standard.Forms.Properties.Resources | static
BarStringMenuAnimationNone | Deltares.Standard.Forms.Properties.Resources | static
BarStringMenuAnimationRandom | Deltares.Standard.Forms.Properties.Resources | static
BarStringMenuAnimationSlide | Deltares.Standard.Forms.Properties.Resources | static
BarStringMenuAnimationSystem | Deltares.Standard.Forms.Properties.Resources | static
BarStringMenuAnimationUnfold | Deltares.Standard.Forms.Properties.Resources | static
BarStringNewToolbarCaption | Deltares.Standard.Forms.Properties.Resources | static
BarStringRenameToolbarCaption | Deltares.Standard.Forms.Properties.Resources | static
BarStringResetBar | Deltares.Standard.Forms.Properties.Resources | static
BarStringResetBarCaption | Deltares.Standard.Forms.Properties.Resources | static
BarStringResetButton | Deltares.Standard.Forms.Properties.Resources | static
BarStringToolBarMenu | Deltares.Standard.Forms.Properties.Resources | static
Blank | Deltares.Standard.Forms.Properties.Resources | static
BrowseForFolder | Deltares.Standard.Forms.Properties.Resources | static
btClose | Deltares.Standard.Forms.Properties.Resources | static
btClose1 | Deltares.Standard.Forms.Properties.Resources | static
btDeleteBar | Deltares.Standard.Forms.Properties.Resources | static
btDeleteBar1 | Deltares.Standard.Forms.Properties.Resources | static
btNBDlgCancel | Deltares.Standard.Forms.Properties.Resources | static
btNBDlgCancel1 | Deltares.Standard.Forms.Properties.Resources | static
btNBDlgOk | Deltares.Standard.Forms.Properties.Resources | static
btNBDlgOk1 | Deltares.Standard.Forms.Properties.Resources | static
btNewBar | Deltares.Standard.Forms.Properties.Resources | static
btNewBar1 | Deltares.Standard.Forms.Properties.Resources | static
btRenameBar | Deltares.Standard.Forms.Properties.Resources | static
btRenameBar1 | Deltares.Standard.Forms.Properties.Resources | static
btResetBar | Deltares.Standard.Forms.Properties.Resources | static
btResetBar1 | Deltares.Standard.Forms.Properties.Resources | static
ButtonMakeNewFolder | Deltares.Standard.Forms.Properties.Resources | static
ButtonTextAbort | Deltares.Standard.Forms.Properties.Resources | static
ButtonTextCancel | Deltares.Standard.Forms.Properties.Resources | static
ButtonTextIgnore | Deltares.Standard.Forms.Properties.Resources | static
ButtonTextNo | Deltares.Standard.Forms.Properties.Resources | static
ButtonTextOk | Deltares.Standard.Forms.Properties.Resources | static
ButtonTextRetry | Deltares.Standard.Forms.Properties.Resources | static
ButtonTextYes | Deltares.Standard.Forms.Properties.Resources | static
cbOptionslargeIcons | Deltares.Standard.Forms.Properties.Resources | static
cbOptionslargeIcons1 | Deltares.Standard.Forms.Properties.Resources | static
cbOptionsShowFullMenus | Deltares.Standard.Forms.Properties.Resources | static
cbOptionsShowFullMenus1 | Deltares.Standard.Forms.Properties.Resources | static
cbOptionsshowTips | Deltares.Standard.Forms.Properties.Resources | static
cbOptionsshowTips1 | Deltares.Standard.Forms.Properties.Resources | static
CloseButtonCaption | Deltares.Standard.Forms.Properties.Resources | static
ColorSchemeGroupBoxCaption | Deltares.Standard.Forms.Properties.Resources | static
ColorSchemeLabelCaption | Deltares.Standard.Forms.Properties.Resources | static
CommandLineBadFormat | Deltares.Standard.Forms.Properties.Resources | static
CommandlineErrorText | Deltares.Standard.Forms.Properties.Resources | static
Copy | Deltares.Standard.Forms.Properties.Resources | static
Culture | Deltares.Standard.Forms.Properties.Resources | static
CustomizeCaption | Deltares.Standard.Forms.Properties.Resources | static
CustomizeCaption1 | Deltares.Standard.Forms.Properties.Resources | static
Debug | Deltares.Standard.Forms.Properties.Resources | static
DefaultLookAndFeelRadioButtonCaption | Deltares.Standard.Forms.Properties.Resources | static
DirectoriesCheckBoxCaption | Deltares.Standard.Forms.Properties.Resources | static
DirectoriesGroupBoxCaption | Deltares.Standard.Forms.Properties.Resources | static
DirectoriesTabPageCaption | Deltares.Standard.Forms.Properties.Resources | static
DLTRS | Deltares.Standard.Forms.Properties.Resources | static
Error | Deltares.Standard.Forms.Properties.Resources | static
ExplorerBarRadioButtonCaption | Deltares.Standard.Forms.Properties.Resources | static
Export | Deltares.Standard.Forms.Properties.Resources | static
Forward | Deltares.Standard.Forms.Properties.Resources | static
GeneralButtonCaption | Deltares.Standard.Forms.Properties.Resources | static
GeneralTabPageCaption | Deltares.Standard.Forms.Properties.Resources | static
Gridlines | Deltares.Standard.Forms.Properties.Resources | static
Information | Deltares.Standard.Forms.Properties.Resources | static
InputPointCaption | Deltares.Standard.Forms.Properties.Resources | static
LanguageButtonCaption | Deltares.Standard.Forms.Properties.Resources | static
LanguageTabPageCaption | Deltares.Standard.Forms.Properties.Resources | static
LastUsedProjectRadioButtonCaption | Deltares.Standard.Forms.Properties.Resources | static
lbCategoriesCaption | Deltares.Standard.Forms.Properties.Resources | static
lbCategoriesCaption1 | Deltares.Standard.Forms.Properties.Resources | static
lbCommandsCaption | Deltares.Standard.Forms.Properties.Resources | static
lbCommandsCaption1 | Deltares.Standard.Forms.Properties.Resources | static
lbDescriptionCaption | Deltares.Standard.Forms.Properties.Resources | static
lbDescriptionCaption1 | Deltares.Standard.Forms.Properties.Resources | static
lbOptionsOther | Deltares.Standard.Forms.Properties.Resources | static
lbOptionsOther1 | Deltares.Standard.Forms.Properties.Resources | static
lbOptionsPCaption | Deltares.Standard.Forms.Properties.Resources | static
lbOptionsPCaption1 | Deltares.Standard.Forms.Properties.Resources | static
Legend | Deltares.Standard.Forms.Properties.Resources | static
LicenceDongleGroupBoxCaption | Deltares.Standard.Forms.Properties.Resources | static
MenuAnimation | Deltares.Standard.Forms.Properties.Resources | static
MenuAnimation1 | Deltares.Standard.Forms.Properties.Resources | static
ModulesButtonCaption | Deltares.Standard.Forms.Properties.Resources | static
ModulesTabPageCaption | Deltares.Standard.Forms.Properties.Resources | static
NavBarRadioButtonCaption | Deltares.Standard.Forms.Properties.Resources | static
NavigationStyleGroupBoxCaption | Deltares.Standard.Forms.Properties.Resources | static
NewProjectRadioButtonCaption | Deltares.Standard.Forms.Properties.Resources | static
Next | Deltares.Standard.Forms.Properties.Resources | static
NoProjectRadioButtonCaption | Deltares.Standard.Forms.Properties.Resources | static
OkButtonCaption | Deltares.Standard.Forms.Properties.Resources | static
Open | Deltares.Standard.Forms.Properties.Resources | static
OpenImage | Deltares.Standard.Forms.Properties.Resources | static
Pan | Deltares.Standard.Forms.Properties.Resources | static
Pause | Deltares.Standard.Forms.Properties.Resources | static
Previous | Deltares.Standard.Forms.Properties.Resources | static
Redo | Deltares.Standard.Forms.Properties.Resources | static
Remove | Deltares.Standard.Forms.Properties.Resources | static
ReportLanguageGroupboxCaption | Deltares.Standard.Forms.Properties.Resources | static
ReportLanguageLabelCaption | Deltares.Standard.Forms.Properties.Resources | static
Reset | Deltares.Standard.Forms.Properties.Resources | static
Reset1 | Deltares.Standard.Forms.Properties.Resources | static
ResourceManager | Deltares.Standard.Forms.Properties.Resources | static
Resources() (defined in Deltares.Standard.Forms.Properties.Resources) | Deltares.Standard.Forms.Properties.Resources | package
Save | Deltares.Standard.Forms.Properties.Resources | static
SaveAll | Deltares.Standard.Forms.Properties.Resources | static
SaveImage | Deltares.Standard.Forms.Properties.Resources | static
SaveLayer | Deltares.Standard.Forms.Properties.Resources | static
Select | Deltares.Standard.Forms.Properties.Resources | static
SelectWorkingDirectory | Deltares.Standard.Forms.Properties.Resources | static
showFullMenusAfterDelay | Deltares.Standard.Forms.Properties.Resources | static
showFullMenusAfterDelay1 | Deltares.Standard.Forms.Properties.Resources | static
ShowShortcutInTips | Deltares.Standard.Forms.Properties.Resources | static
ShowShortcutInTips1 | Deltares.Standard.Forms.Properties.Resources | static
Start | Deltares.Standard.Forms.Properties.Resources | static
StartUpGroupBoxCaption | Deltares.Standard.Forms.Properties.Resources | static
Stop | Deltares.Standard.Forms.Properties.Resources | static
ToggleExpand | Deltares.Standard.Forms.Properties.Resources | static
tpCommands | Deltares.Standard.Forms.Properties.Resources | static
tpCommands1 | Deltares.Standard.Forms.Properties.Resources | static
tpOptions | Deltares.Standard.Forms.Properties.Resources | static
tpOptions1 | Deltares.Standard.Forms.Properties.Resources | static
tpToolbars | Deltares.Standard.Forms.Properties.Resources | static
tpToolbars1 | Deltares.Standard.Forms.Properties.Resources | static
UiButtonToggle | Deltares.Standard.Forms.Properties.Resources | static
Undo | Deltares.Standard.Forms.Properties.Resources | static
Warning | Deltares.Standard.Forms.Properties.Resources | static
Waternet | Deltares.Standard.Forms.Properties.Resources | static
Web | Deltares.Standard.Forms.Properties.Resources | static
WindowsLookAndFeelRadioButtonCaption | Deltares.Standard.Forms.Properties.Resources | static
WorkingDirectoryLabelCaption | Deltares.Standard.Forms.Properties.Resources | static
Zoom | Deltares.Standard.Forms.Properties.Resources | static
ZoomAll | Deltares.Standard.Forms.Properties.Resources | static
ZoomExtents | Deltares.Standard.Forms.Properties.Resources | static
ZoomFit | Deltares.Standard.Forms.Properties.Resources | static
ZoomIn | Deltares.Standard.Forms.Properties.Resources | static
ZoomRectangle | Deltares.Standard.Forms.Properties.Resources | static
ZoomSelection | Deltares.Standard.Forms.Properties.Resources | static
ZoomTo | Deltares.Standard.Forms.Properties.Resources | static
Generated on Tue Dec 15 2015 18:15:35 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.Properties.Settings Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • Properties
  • Settings
Properties | List of all members
Deltares.Standard.Forms.Properties.Settings Class Reference
Inheritance diagram for Deltares.Standard.Forms.Properties.Settings:

Properties

static Settings | Default [get]
string | SpatialEditor [get, set]
string | MRUFile1 [get, set]
string | MRUFile2 [get, set]
string | MRUFile3 [get, set]
string | MRUFile4 [get, set]
string | InterfaceLanguage [get, set]
string | OutPutLanguage [get, set]
bool | StartUpIsLastProject [get, set]
bool | StartUpIsNewProject [get, set]
bool | AppViewIsWindowsColor [get, set]
bool | AppViewIsUserDefinedColor [get, set]
string | LastSavedProject [get, set]
int | AppViewDXSkinSelectedIndex [get, set]
bool | ShowLicenseAtStartUp [get, set]
int | OpenFileFilterIndex [get, set]
bool | IsApplicationFirstRun [get, set]
string | TranslationsDirectory [get, set]
int | MaxCalculationCores [get, set]
string | Units [get, set]
Generated on Tue Dec 15 2015 18:15:35 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • Properties
  • Settings
Deltares.Standard.Forms.Properties.Settings Member List

This is the complete list of members for Deltares.Standard.Forms.Properties.Settings, including all inherited members.

AppViewDXSkinSelectedIndex (defined in Deltares.Standard.Forms.Properties.Settings) | Deltares.Standard.Forms.Properties.Settings |
AppViewIsUserDefinedColor (defined in Deltares.Standard.Forms.Properties.Settings) | Deltares.Standard.Forms.Properties.Settings |
AppViewIsWindowsColor (defined in Deltares.Standard.Forms.Properties.Settings) | Deltares.Standard.Forms.Properties.Settings |
Default (defined in Deltares.Standard.Forms.Properties.Settings) | Deltares.Standard.Forms.Properties.Settings | static
InterfaceLanguage (defined in Deltares.Standard.Forms.Properties.Settings) | Deltares.Standard.Forms.Properties.Settings |
IsApplicationFirstRun (defined in Deltares.Standard.Forms.Properties.Settings) | Deltares.Standard.Forms.Properties.Settings |
LastSavedProject (defined in Deltares.Standard.Forms.Properties.Settings) | Deltares.Standard.Forms.Properties.Settings |
MaxCalculationCores (defined in Deltares.Standard.Forms.Properties.Settings) | Deltares.Standard.Forms.Properties.Settings |
MRUFile1 (defined in Deltares.Standard.Forms.Properties.Settings) | Deltares.Standard.Forms.Properties.Settings |
MRUFile2 (defined in Deltares.Standard.Forms.Properties.Settings) | Deltares.Standard.Forms.Properties.Settings |
MRUFile3 (defined in Deltares.Standard.Forms.Properties.Settings) | Deltares.Standard.Forms.Properties.Settings |
MRUFile4 (defined in Deltares.Standard.Forms.Properties.Settings) | Deltares.Standard.Forms.Properties.Settings |
OpenFileFilterIndex (defined in Deltares.Standard.Forms.Properties.Settings) | Deltares.Standard.Forms.Properties.Settings |
OutPutLanguage (defined in Deltares.Standard.Forms.Properties.Settings) | Deltares.Standard.Forms.Properties.Settings |
Settings() (defined in Deltares.Standard.Forms.Properties.Settings) | Deltares.Standard.Forms.Properties.Settings |
ShowLicenseAtStartUp (defined in Deltares.Standard.Forms.Properties.Settings) | Deltares.Standard.Forms.Properties.Settings |
SpatialEditor (defined in Deltares.Standard.Forms.Properties.Settings) | Deltares.Standard.Forms.Properties.Settings |
StartUpIsLastProject (defined in Deltares.Standard.Forms.Properties.Settings) | Deltares.Standard.Forms.Properties.Settings |
StartUpIsNewProject (defined in Deltares.Standard.Forms.Properties.Settings) | Deltares.Standard.Forms.Properties.Settings |
TranslationsDirectory (defined in Deltares.Standard.Forms.Properties.Settings) | Deltares.Standard.Forms.Properties.Settings |
Units (defined in Deltares.Standard.Forms.Properties.Settings) | Deltares.Standard.Forms.Properties.Settings |
Generated on Tue Dec 15 2015 18:15:35 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.ArrowShape Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • ArrowShape
Public Member Functions | Properties | List of all members
Deltares.Standard.Forms.ArrowShape Class Reference
Inheritance diagram for Deltares.Standard.Forms.ArrowShape:
Deltares.Standard.Forms.Shape Deltares.Standard.Forms.IShape

Public Member Functions

override Rectangle | GetExtents (IProjection projection)
override void | Draw (GraphicsInfo info)
- Public Member Functions inherited from Deltares.Standard.Forms.Shape
virtual void | AddPoint (Point2D point)
virtual IEnumerable< object > | DataItemAt (Point point, Projection projection)
virtual bool | AllowDrop (object data)
virtual void | Drop (object data)
virtual bool | ContainsPoint (IProjection projection, Point point)
virtual void | DrawLabel (GraphicsInfo info)
virtual void | Move (IProjection projection, Point2D startPosition, SizeF worldSize)
virtual void | BeginMove (IProjection projection, Point2D startPosition)
virtual CardinalDirection | GetCardinalDirectionOnEdgeContainingPoint (Point point)
virtual void | EndMove (IProjection projection, Point2D startPosition, SizeF worldSize)

Properties

Point2D | BeginPoint [get, set]
Point2D | HeadPoint [get, set]
- Properties inherited from Deltares.Standard.Forms.Shape
Point | Location [get, set]
Size | Size [get, set]
virtual bool | CanResize [get]
Color | ForeColor [get, set]
Color | BackColor [get, set]
IProjection | CoordinateSystem [get, set]
Point2D | WorldLocation [get, set]
SizeF | WorldSize [get, set]
virtual int | Layer [get, set]
virtual object | DataObject [get, set]
- Properties inherited from Deltares.Standard.Forms.IShape
object | DataObject [get, set]
int | Layer [get]

Additional Inherited Members

- Protected Attributes inherited from Deltares.Standard.Forms.Shape
GraphicsPath path = null
Generated on Tue Dec 15 2015 18:14:28 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • ArrowShape
Deltares.Standard.Forms.ArrowShape Member List

This is the complete list of members for Deltares.Standard.Forms.ArrowShape, including all inherited members.

AddPoint(Point2D point) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
AllowDrop(object data) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
ArrowShape() (defined in Deltares.Standard.Forms.ArrowShape) | Deltares.Standard.Forms.ArrowShape |
BackColor (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
BeginMove(IProjection projection, Point2D startPosition) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
BeginPoint (defined in Deltares.Standard.Forms.ArrowShape) | Deltares.Standard.Forms.ArrowShape |
CanResize (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
ContainsPoint(IProjection projection, Point point) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
CoordinateSystem (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
DataItemAt(Point point, Projection projection) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
DataObject (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
Draw(GraphicsInfo info) (defined in Deltares.Standard.Forms.ArrowShape) | Deltares.Standard.Forms.ArrowShape | virtual
DrawLabel(GraphicsInfo info) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
Drop(object data) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
EndMove(IProjection projection, Point2D startPosition, SizeF worldSize) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
ForeColor (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
GetCardinalDirectionOnEdgeContainingPoint(Point point) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
GetExtents(IProjection projection) (defined in Deltares.Standard.Forms.ArrowShape) | Deltares.Standard.Forms.ArrowShape | virtual
HeadPoint (defined in Deltares.Standard.Forms.ArrowShape) | Deltares.Standard.Forms.ArrowShape |
Layer (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
Location (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
Move(IProjection projection, Point2D startPosition, SizeF worldSize) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
path (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | protected
Shape() (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
Size (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
WorldLocation (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
WorldSize (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
Generated on Tue Dec 15 2015 18:14:28 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.AxesShape Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • AxesShape
Public Member Functions | List of all members
Deltares.Standard.Forms.AxesShape Class Reference
Inheritance diagram for Deltares.Standard.Forms.AxesShape:
Deltares.Standard.Forms.Shape Deltares.Standard.Forms.IShape

Public Member Functions

override bool | ContainsPoint (IProjection projection, Point point)
override Rectangle | GetExtents (IProjection projection)
override void | Draw (GraphicsInfo info)
- Public Member Functions inherited from Deltares.Standard.Forms.Shape
virtual void | AddPoint (Point2D point)
virtual IEnumerable< object > | DataItemAt (Point point, Projection projection)
virtual bool | AllowDrop (object data)
virtual void | Drop (object data)
virtual void | DrawLabel (GraphicsInfo info)
virtual void | Move (IProjection projection, Point2D startPosition, SizeF worldSize)
virtual void | BeginMove (IProjection projection, Point2D startPosition)
virtual CardinalDirection | GetCardinalDirectionOnEdgeContainingPoint (Point point)
virtual void | EndMove (IProjection projection, Point2D startPosition, SizeF worldSize)

Additional Inherited Members

- Protected Attributes inherited from Deltares.Standard.Forms.Shape
GraphicsPath | path = null
- Properties inherited from Deltares.Standard.Forms.Shape
Point | Location [get, set]
Size | Size [get, set]
virtual bool | CanResize [get]
Color | ForeColor [get, set]
Color | BackColor [get, set]
IProjection | CoordinateSystem [get, set]
Point2D | WorldLocation [get, set]
SizeF | WorldSize [get, set]
virtual int | Layer [get, set]
virtual object | DataObject [get, set]
- Properties inherited from Deltares.Standard.Forms.IShape
object | DataObject [get, set]
int | Layer [get]
Generated on Tue Dec 15 2015 18:14:28 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • AxesShape
Deltares.Standard.Forms.AxesShape Member List

This is the complete list of members for Deltares.Standard.Forms.AxesShape, including all inherited members.

AddPoint(Point2D point) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
AllowDrop(object data) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
BackColor (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
BeginMove(IProjection projection, Point2D startPosition) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
CanResize (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
ContainsPoint(IProjection projection, Point point) (defined in Deltares.Standard.Forms.AxesShape) | Deltares.Standard.Forms.AxesShape | virtual
CoordinateSystem (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
DataItemAt(Point point, Projection projection) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
DataObject (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
Draw(GraphicsInfo info) (defined in Deltares.Standard.Forms.AxesShape) | Deltares.Standard.Forms.AxesShape | virtual
DrawLabel(GraphicsInfo info) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
Drop(object data) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
EndMove(IProjection projection, Point2D startPosition, SizeF worldSize) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
ForeColor (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
GetCardinalDirectionOnEdgeContainingPoint(Point point) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
GetExtents(IProjection projection) (defined in Deltares.Standard.Forms.AxesShape) | Deltares.Standard.Forms.AxesShape | virtual
Layer (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
Location (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
Move(IProjection projection, Point2D startPosition, SizeF worldSize) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
path (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | protected
Shape() (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
Size (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
WorldLocation (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
WorldSize (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
Generated on Tue Dec 15 2015 18:14:28 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.ColumnDescription Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • ColumnDescription
Public Member Functions | Properties | List of all members
Deltares.Standard.Forms.ColumnDescription Class Reference

Contains all data for layout of the columns More...

Public Member Functions

ColumnDescription ()
Initializes a new instance of the ColumnDescription class. More...

Properties

ColumnType | ColumnType [get, set]
Gets or sets the column type. More...
bool | ReadOnly [get, set]
Gets or sets a value indicating whether it is read only or not. More...
string | Format [get, set]
Gets or sets the format. More...
object[] | Choices [get, set]
Gets or sets the choices. More...

Detailed Description

Contains all data for layout of the columns

Constructor & Destructor Documentation

Deltares.Standard.Forms.ColumnDescription.ColumnDescription ( )

Initializes a new instance of the ColumnDescription class.

Property Documentation

object [] Deltares.Standard.Forms.ColumnDescription.Choices
getset

Gets or sets the choices.

ColumnType Deltares.Standard.Forms.ColumnDescription.ColumnType
getset

Gets or sets the column type.

string Deltares.Standard.Forms.ColumnDescription.Format
getset

Gets or sets the format.

bool Deltares.Standard.Forms.ColumnDescription.ReadOnly
getset

Gets or sets a value indicating whether it is read only or not.

Generated on Tue Dec 15 2015 18:14:28 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • ColumnDescription
Deltares.Standard.Forms.ColumnDescription Member List

This is the complete list of members for Deltares.Standard.Forms.ColumnDescription, including all inherited members.

Choices | Deltares.Standard.Forms.ColumnDescription
ColumnDescription() | Deltares.Standard.Forms.ColumnDescription
ColumnType | Deltares.Standard.Forms.ColumnDescription
Format | Deltares.Standard.Forms.ColumnDescription
ReadOnly | Deltares.Standard.Forms.ColumnDescription
Generated on Tue Dec 15 2015 18:14:28 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.CommandLineWindow Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • CommandLineWindow
Public Member Functions | Properties | Events | List of all members
Deltares.Standard.Forms.CommandLineWindow Class Reference

Public Member Functions

CommandLineWindow (BarManager amanger)
void | ShowCommandLineWindow (bool aVisibility)
Display's The Command Line Window More...
void | DeleteAllEventHandlers ()
Deletes All EventHandlers More...
void | HandleFocusCommandLineWindow (int aWindowParameter)
Handle to input TextBox focus More...
void | SetTextToolTip (object aBasePlane)
Set tooltip text for command line text box More...

Properties

Bar | CommandWindowBar [get]
bool | CommandlineVisibility [get, set]
bool | UseInputCount [get, set]

Events

CommandLinePointInputHandler PointInput = null

Member Function Documentation

void Deltares.Standard.Forms.CommandLineWindow.DeleteAllEventHandlers ( )

Deletes All EventHandlers

void Deltares.Standard.Forms.CommandLineWindow.HandleFocusCommandLineWindow ( int aWindowParameter )

Handle to input TextBox focus

Parameters
aWindowParameter
void Deltares.Standard.Forms.CommandLineWindow.SetTextToolTip ( object aBasePlane )

Set tooltip text for command line text box

Parameters
aBasePlane
void Deltares.Standard.Forms.CommandLineWindow.ShowCommandLineWindow ( bool aVisibility )

Display's The Command Line Window

Parameters
aVisibility
Generated on Tue Dec 15 2015 18:14:28 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • CommandLineWindow
Deltares.Standard.Forms.CommandLineWindow Member List

This is the complete list of members for Deltares.Standard.Forms.CommandLineWindow, including all inherited members.

CommandlineVisibility (defined in Deltares.Standard.Forms.CommandLineWindow) | Deltares.Standard.Forms.CommandLineWindow
CommandLineWindow(BarManager amanger) (defined in Deltares.Standard.Forms.CommandLineWindow) | Deltares.Standard.Forms.CommandLineWindow
CommandWindowBar (defined in Deltares.Standard.Forms.CommandLineWindow) | Deltares.Standard.Forms.CommandLineWindow
DeleteAllEventHandlers() | Deltares.Standard.Forms.CommandLineWindow
HandleFocusCommandLineWindow(int aWindowParameter) | Deltares.Standard.Forms.CommandLineWindow
PointInput (defined in Deltares.Standard.Forms.CommandLineWindow) | Deltares.Standard.Forms.CommandLineWindow
SetTextToolTip(object aBasePlane) | Deltares.Standard.Forms.CommandLineWindow
ShowCommandLineWindow(bool aVisibility) | Deltares.Standard.Forms.CommandLineWindow
UseInputCount (defined in Deltares.Standard.Forms.CommandLineWindow) | Deltares.Standard.Forms.CommandLineWindow
Generated on Tue Dec 15 2015 18:14:28 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.CustomConfirmDialog Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • CustomConfirmDialog
Static Public Member Functions | Protected Member Functions | Properties | List of all members
Deltares.Standard.Forms.CustomConfirmDialog Class Reference
Inheritance diagram for Deltares.Standard.Forms.CustomConfirmDialog:

Static Public Member Functions

static DialogResult ShowDialog (string caption, string message, Icon icon, Image messageIcon, string okButtonText, string cancelButtonText)

Protected Member Functions

override void Dispose (bool disposing)
Clean up any resources being used. More...

Properties

string | OkButtonText [get, set]
string | CancelButtonText [get, set]
string | Caption [get, set]
string | Message [get, set]
Image | MessageIcon [get, set]

Member Function Documentation

override void Deltares.Standard.Forms.CustomConfirmDialog.Dispose ( bool disposing )
protected

Clean up any resources being used.

Parameters
disposing true if managed resources should be disposed; otherwise, false.
Generated on Tue Dec 15 2015 18:14:29 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • CustomConfirmDialog
Deltares.Standard.Forms.CustomConfirmDialog Member List

This is the complete list of members for Deltares.Standard.Forms.CustomConfirmDialog, including all inherited members.

CancelButtonText (defined in Deltares.Standard.Forms.CustomConfirmDialog) | Deltares.Standard.Forms.CustomConfirmDialog |
Caption (defined in Deltares.Standard.Forms.CustomConfirmDialog) | Deltares.Standard.Forms.CustomConfirmDialog |
Dispose(bool disposing) | Deltares.Standard.Forms.CustomConfirmDialog | protected
Message (defined in Deltares.Standard.Forms.CustomConfirmDialog) | Deltares.Standard.Forms.CustomConfirmDialog |
MessageIcon (defined in Deltares.Standard.Forms.CustomConfirmDialog) | Deltares.Standard.Forms.CustomConfirmDialog |
OkButtonText (defined in Deltares.Standard.Forms.CustomConfirmDialog) | Deltares.Standard.Forms.CustomConfirmDialog |
ShowDialog(string caption, string message, Icon icon, Image messageIcon, string okButtonText, string cancelButtonText) (defined in Deltares.Standard.Forms.CustomConfirmDialog) | Deltares.Standard.Forms.CustomConfirmDialog | static
Generated on Tue Dec 15 2015 18:14:29 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DataGridViewManager Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DataGridViewManager
Static Public Member Functions | Static Package Attributes | List of all members
Deltares.Standard.Forms.DataGridViewManager Class Reference

Static Public Member Functions

static void | AssignList (DataGridView dataGridView, IList aList, Type rowType)
static void | CopySelectedCells (DataGridView dataGridView)
static void | PasteSelectedCells (DataGridView dataGridView)

Static Package Attributes

static object cellValue
Generated on Tue Dec 15 2015 18:14:29 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DataGridViewManager
Deltares.Standard.Forms.DataGridViewManager Member List

This is the complete list of members for Deltares.Standard.Forms.DataGridViewManager, including all inherited members.

AssignList(DataGridView dataGridView, IList aList, Type rowType) (defined in Deltares.Standard.Forms.DataGridViewManager) | Deltares.Standard.Forms.DataGridViewManager | static
cellValue (defined in Deltares.Standard.Forms.DataGridViewManager) | Deltares.Standard.Forms.DataGridViewManager | packagestatic
CopySelectedCells(DataGridView dataGridView) (defined in Deltares.Standard.Forms.DataGridViewManager) | Deltares.Standard.Forms.DataGridViewManager | static
PasteSelectedCells(DataGridView dataGridView) (defined in Deltares.Standard.Forms.DataGridViewManager) | Deltares.Standard.Forms.DataGridViewManager | static
Generated on Tue Dec 15 2015 18:14:29 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DBTableLayoutPanel Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DBTableLayoutPanel
List of all members
Deltares.Standard.Forms.DBTableLayoutPanel Class Reference

Double buffered

See also
TableLayoutPanel

. More...

Inheritance diagram for Deltares.Standard.Forms.DBTableLayoutPanel:

Detailed Description

Double buffered

See also
TableLayoutPanel

.

Generated on Tue Dec 15 2015 18:14:29 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DBTableLayoutPanel
Deltares.Standard.Forms.DBTableLayoutPanel Member List

This is the complete list of members for Deltares.Standard.Forms.DBTableLayoutPanel, including all inherited members.

DBTableLayoutPanel() (defined in Deltares.Standard.Forms.DBTableLayoutPanel) Deltares.Standard.Forms.DBTableLayoutPanel
Generated on Tue Dec 15 2015 18:14:29 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DirectoryEditor Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DirectoryEditor
Public Member Functions | List of all members
Deltares.Standard.Forms.DirectoryEditor Class Reference
Inheritance diagram for Deltares.Standard.Forms.DirectoryEditor:

Public Member Functions

void | Assign (IPropertyObject propertyObject, string property)
override UITypeEditorEditStyle | GetEditStyle (ITypeDescriptorContext context)
override object | EditValue (ITypeDescriptorContext context, IServiceProvider provider, object value)
Generated on Tue Dec 15 2015 18:14:29 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DirectoryEditor
Deltares.Standard.Forms.DirectoryEditor Member List

This is the complete list of members for Deltares.Standard.Forms.DirectoryEditor, including all inherited members.

Assign(IPropertyObject propertyObject, string property) (defined in Deltares.Standard.Forms.DirectoryEditor) | Deltares.Standard.Forms.DirectoryEditor
DirectoryEditor() (defined in Deltares.Standard.Forms.DirectoryEditor) | Deltares.Standard.Forms.DirectoryEditor
EditValue(ITypeDescriptorContext context, IServiceProvider provider, object value) (defined in Deltares.Standard.Forms.DirectoryEditor) | Deltares.Standard.Forms.DirectoryEditor
GetEditStyle(ITypeDescriptorContext context) (defined in Deltares.Standard.Forms.DirectoryEditor) | Deltares.Standard.Forms.DirectoryEditor
Generated on Tue Dec 15 2015 18:14:29 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.DrawingSupport Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DrawingSupport
Static Public Member Functions | Static Public Attributes | List of all members
Deltares.Standard.Forms.DrawingSupport Class Reference

Static Public Member Functions

static Color | GetDarkerColor (Color color)
Gets the darker shade of the color. More...
static Color | GetLighterColor (Color color)
Gets the lighter shade of the color. More...
static Color | GetOppositeColor (Color color)
Gets the opposite of the color. More...
static Color | GetColor (double fraction, params Color[] colors)
Gets the color from the given set of colors using the fraction. More...
static void | DrawLabelAtPoint (GraphicsInfo aGraphics, Point dataPoint, Point labelPoint, string text, Brush textBrush, Brush backgroundBrush, Brush borderBrush)
Draws the label at point. More...
static void | DrawLabelAtPoint (GraphicsInfo aGraphics, Point labelPoint, string text, Brush textBrush, Brush backgroundBrush, Brush borderBrush)
Draws the label at point. More...
static void | DrawLabelAtPoint (GraphicsInfo aGraphics, Point labelPoint, string text, Brush textBrush, Brush backgroundBrush, Brush borderBrush, ContentAlignment alignment, float fontSize)
Draws the label at point. More...
static void | DrawLabelAtPoint (GraphicsInfo aGraphics, Point labelPoint, string text, Brush textBrush, Brush backgroundBrush, Brush borderBrush, ContentAlignment alignment)
Draws the label at point. More...
static double | GetStandardSize (object aDraw3DInterface, double x, double y, double z)
Gets the size of the standard. More...
static void | SetIEPDraw3D (object aDraw3D)
Sets the iep draw3 d. More...
static void | Arrow_Symbol3D (double dX, double dY, double dZ, double dNX, double dNY, double dNZ, double dSize, double dArrowSize, short nPoint, short nStyle)
Draws a 3D arrow. More...
static void | Brush3D (Color color)
Set the brush from the color. More...
static void | CirclePolygon3D (double x, double z, double radius)
Draws a circle in the X-Z plane (or its bounding rectangle?). More...
static void | CirclePolygon3D (double dX, double dY, double dZ, double dNX, double dNY, double dNZ, double dRadius)
Draws a circle in the 3D plane (or its bounding rectangle?). More...
static void | Circle3D (Point3D center, double radius)
Draws a 3D circle. More...
static void | Circle3D (double centerX, double centerY, double centerZ, double radius)
Draws a 3D circle. More...
static void | ColorMaterial3D (Color color)
Set the brush from the color. Is identical to Brush3D(Color color) More...
static void | ConvexPolygon3D (IEnumerable< Point3D > EPVertex3d, object normal)
Draws a filled polygon in the X-Z plane More...
static void | ConvexPolygon3D (IEnumerable< Point > points)
Draws a filled polygon in X-Y plane More...
static void | ConvexPolygon3D (Point[] points)
Draws a filled polygon in X-Y plane More...
static void | ConvexPolygon3D (IEnumerable< Point3D > EPVertex3d)
Draws a filled polygon in X-Z plane More...
static void | Rectangle3D (Point3D topLeft, Point3D bottomRight)
Draws a filled rectangle in the X-Z plane. More...
static void | Rectangle3D (Rectangle rectangle)
Draws a filled rectangle in the X-Y plane. More...
static Point[] | ConvertToPoints (IEnumerable< Point3D > points)
Converts 3D points to points in the X-Z plane. More...
static Point | ToPoint (Point3D point)
Converts a 3D point to a point in the X-Z plane. More...
static Point | ToPoint (Point2D point)
Converts a 2D point to a 2D point in the X-Y plane. More...
static Point[] | ConvertToPoints (IEnumerable< Point2D > points)
Converts 2D points to points in the X-Y plane. More...
static void | Cross_Symbol3D (double dX, double dZ, double dSize)
Draws a cross as symbol in the X-Z plane. More...
static void | Font3D (string faceName, short nCharSet, int bBold, int bItalic, int bUnderline, int bStrikeOut)
Sets the font. More...
static void | Line_Symbol3D (double dXs, double dZs, double dXe, double dZe)
Draws a line in the X-Z plane More...
static void | Line3D (PointF beginPoint, PointF endPoint)
Draws a line in the X-Y plane More...
static void | Line3D (Point3D beginPoint, Point3D endPoint)
Draws a line in the X-Z plane More...
static void | Line3D (double xs, double ys, double zs, double xe, double ye, double ze)
Draws a line in the X-Z plane More...
static void | Line3D (double xs, double ys, double xe, double ye)
Draws a line in the X-Y plane More...
static void | LineLoop3D (object eP_3DVertexes)
Draws a filled polygon in the X-Z plane More...
static void | Material3D (Brush aBrush)
Sets the brush (i.e. the fill style and color for amongst other things drawing materials) More...
static void | Pen3D (DashStyle dashStyle, int width, Color color)
Sets the Pen More...
static void | Text3D (string text, double dX, double dZ)
Draws the specified text string in the X-Z plane. More...
static void | Text3D (Graphics graph, string text, double dX, double dZ)
Draws the specified text string in the X-Z plane. More...
static void | CreateConvexPolygonBox (List< Point3D > points3D)
Draws a filled polygon in the X-Z plane More...
static void | CreateConvexPolygonBox (List< Point2D > points2D)
Draws a filled polygon in the X-Y plane More...
static void | CreateConvexPolygonBox (List< Point > points)
Draws a filled polygon in the X-Y plane More...
static object | GetCurrentDraw3DInterface ()
Gets the current draw3 d interface (graphics). More...
static void | DrawLegend (Graphics aGraphics, int width, int height, List< LegendItem > legendItems)
Draws the legend. More...
static int | GetTextWidth (string text, Graphics aGraphics, Font aFont)
Gets the size of the text. More...
static int | GetLabelTextWidth (string text, Graphics aGraphics)
Gets the size of the label text with the default label Font. More...
static int | GetLabelTextHeigt (string text, Graphics aGraphics)
Gets the label text heigt. More...
static void | DrawPointSelector (Graphics graph, double x, double y, int radiusOutside, int radiusInside)
Draws the point selector with default colors. More...
static void | DrawPointSelector (Graphics graph, double x, double y, int radiusOutside, int radiusInside, Color colorOutside, Color colorInside)
Draws the point selector. More...
static List< Point2D > | DrawSelector (GraphicsInfo info, Point2D point2D, int width, int height)
Draws the selector in the X-Y plane. More...
static Point3D | GetScaled3DPoint (IProjection projection, Point3D aOrginalPoint)
Gets the scaled 3d point (point in screen coordinates). More...

Static Public Attributes

static Color | SelectorInsideColor = Color.Yellow
static Color | SelectorOutsideColor = Color.Black

Member Function Documentation

static void Deltares.Standard.Forms.DrawingSupport.Arrow_Symbol3D | ( | double | dX,
 |  | double | dY,
 |  | double | dZ,
 |  | double | dNX,
 |  | double | dNY,
 |  | double | dNZ,
 |  | double | dSize,
 |  | double | dArrowSize,
 |  | short | nPoint,
 |  | short | nStyle
 | ) |  |
static

Draws a 3D arrow.

Parameters
dX | The d x.
dY | The d y.
dZ | The d z.
dNX | The d nx.
dNY | The d ny.
dNZ | The d nz.
dSize | Size of the d.
dArrowSize | Size of the d arrow.
nPoint | The n point.
nStyle | The n style.
static void Deltares.Standard.Forms.DrawingSupport.Brush3D ( Color color )
static

Set the brush from the color.

Parameters
color The color.

Referenced by Deltares.Geotechnics.Forms.DrawingWaterLevel.Draw3D(), Deltares.Geotechnics.Forms.DrawingBlockRevetmentSegment.Draw3D(), Deltares.Geotechnics.Forms.DrawingRevetment.Draw3D(), Deltares.Geotechnics.Forms.DrawingPiezometricHead.Draw3D(), Deltares.Geotechnics.Forms.DrawingSurfaceLine2.Draw3D(), Deltares.Geometry.Forms.DrawingLine.Draw3D(), and Deltares.Geometry.Forms.DrawingSurface.Draw3D().

static void Deltares.Standard.Forms.DrawingSupport.Circle3D | ( | Point3D | center,
 |  | double | radius
 | ) |  |
static

Draws a 3D circle.

Parameters
center | The center.
radius | The radius.
static void Deltares.Standard.Forms.DrawingSupport.Circle3D | ( | double | centerX,
 |  | double | centerY,
 |  | double | centerZ,
 |  | double | radius
 | ) |  |
static

Draws a 3D circle.

Parameters
centerX | The center x.
centerY | The center y.
centerZ | The center z.
radius | The radius.
static void Deltares.Standard.Forms.DrawingSupport.CirclePolygon3D | ( | double | x,
 |  | double | z,
 |  | double | radius
 | ) |  |
static

Draws a circle in the X-Z plane (or its bounding rectangle?).

Parameters
x | The x.
z | The z.
radius | The radius.
static void Deltares.Standard.Forms.DrawingSupport.CirclePolygon3D | ( | double | dX,
 |  | double | dY,
 |  | double | dZ,
 |  | double | dNX,
 |  | double | dNY,
 |  | double | dNZ,
 |  | double | dRadius
 | ) |  |
static

Draws a circle in the 3D plane (or its bounding rectangle?).

Parameters
dX | The d x.
dY | The d y.
dZ | The d z.
dNX | The d nx.
dNY | The d ny.
dNZ | The d nz.
dRadius | The d radius.
static void Deltares.Standard.Forms.DrawingSupport.ColorMaterial3D ( Color color )
static

Set the brush from the color. Is identical to Brush3D(Color color)

Parameters
color The color.

Referenced by Deltares.Geotechnics.Forms.DrawingWaterLevel.Draw3D(), Deltares.Geotechnics.Forms.DrawingBlockRevetmentSegment.Draw3D(), Deltares.Geotechnics.Forms.DrawingPreConsolidationStress.Draw3D(), Deltares.Geotechnics.Forms.DrawingRevetment.Draw3D(), Deltares.Geotechnics.Forms.DrawingPiezometricHead.Draw3D(), Deltares.Geotechnics.Forms.DrawingCharacteristicPoint.Draw3D(), Deltares.Geotechnics.Forms.DrawingSurfaceLine2.Draw3D(), Deltares.Geometry.Forms.DrawingLine.Draw3D(), Deltares.Geometry.Forms.DrawingSurface.Draw3D(), Deltares.Geometry.Forms.DrawingPoint.Draw3D(), and Deltares.Geometry.Forms.DrawingPointString.Draw3D().

static Point [] Deltares.Standard.Forms.DrawingSupport.ConvertToPoints ( IEnumerable< Point3D > points )
static

Converts 3D points to points in the X-Z plane.

Parameters
points The points.
Returns
static Point [] Deltares.Standard.Forms.DrawingSupport.ConvertToPoints ( IEnumerable< Point2D > points )
static

Converts 2D points to points in the X-Y plane.

Parameters
points The points.
Returns
static void Deltares.Standard.Forms.DrawingSupport.ConvexPolygon3D | ( | IEnumerable< Point3D > | EPVertex3d,
 |  | object | normal
 | ) |  |
static

Draws a filled polygon in the X-Z plane

Parameters
EPVertex3d | The ep vertex3d.
normal | The normal.
static void Deltares.Standard.Forms.DrawingSupport.ConvexPolygon3D ( IEnumerable< Point > points )
static

Draws a filled polygon in X-Y plane

Parameters
points The points.
static void Deltares.Standard.Forms.DrawingSupport.ConvexPolygon3D ( Point[] points )
static

Draws a filled polygon in X-Y plane

Parameters
points The points.
static void Deltares.Standard.Forms.DrawingSupport.ConvexPolygon3D ( IEnumerable< Point3D > EPVertex3d )
static

Draws a filled polygon in X-Z plane

Parameters
EPVertex3d The ep vertex3d.
static void Deltares.Standard.Forms.DrawingSupport.CreateConvexPolygonBox ( List< Point3D > points3D )
static

Draws a filled polygon in the X-Z plane

Parameters
points3D The points3 d.

Referenced by Deltares.DSoilModel.Forms.DrawingBoringLayer.Draw3D(), Deltares.Geotechnics.Forms.DrawingSwell.Draw3D(), Deltares.Geometry.Forms.DrawingSurface.Draw3D(), Deltares.DSoilModel.Forms.DrawingLayerObsolete.Draw3D(), Deltares.Geotechnics.Forms.DrawingLayer.Draw3D(), and Deltares.DSoilModel.Forms.DrawingSosSoilLayer1D.Draw3D().

static void Deltares.Standard.Forms.DrawingSupport.CreateConvexPolygonBox ( List< Point2D > points2D )
static

Draws a filled polygon in the X-Y plane

Parameters
points2D The points2 d.
static void Deltares.Standard.Forms.DrawingSupport.CreateConvexPolygonBox ( List< Point > points )
static

Draws a filled polygon in the X-Y plane

Parameters
points The points.
static void Deltares.Standard.Forms.DrawingSupport.Cross_Symbol3D | ( | double | dX,
 |  | double | dZ,
 |  | double | dSize
 | ) |  |
static

Draws a cross as symbol in the X-Z plane.

Parameters
dX | The d x.
dZ | The d z.
dSize | Size of the d.
static void Deltares.Standard.Forms.DrawingSupport.DrawLabelAtPoint | ( | GraphicsInfo | aGraphics,
 |  | Point | dataPoint,
 |  | Point | labelPoint,
 |  | string | text,
 |  | Brush | textBrush,
 |  | Brush | backgroundBrush,
 |  | Brush | borderBrush
 | ) |  |
static

Draws the label at point.

Parameters
aGraphics | a graphics.
dataPoint | The data point.
labelPoint | The label point.
text | The text.
textBrush | The text brush.
backgroundBrush | The background brush.
borderBrush | The border brush.

Referenced by Deltares.Geotechnics.Forms.DrawingLocalisedGeometryPointString.DrawLabel(), Deltares.Geotechnics.Forms.DrawingWaternetPointString.DrawLabel(), Deltares.Geotechnics.Forms.DrawingWaterBasin.DrawLabel(), Deltares.Geotechnics.Forms.DrawingWaterLevel.DrawLabel(), Deltares.Geotechnics.Forms.DrawingPreConsolidationStress.DrawLabel(), Deltares.Geotechnics.Forms.DrawingCharacteristicPoint.DrawLabel(), Deltares.Geotechnics.Forms.DrawingBlockRevetmentSegment.DrawLabel(), Deltares.Geometry.Forms.DrawingLine.DrawLabel(), Deltares.Geotechnics.Forms.DrawingWaterPolderBasin.DrawLabel(), Deltares.Geotechnics.Forms.DrawingSurfaceLine2.DrawLabel(), Deltares.Geotechnics.Forms.DrawingRevetment.DrawLabel(), Deltares.Geotechnics.Forms.DrawingSoilSurface.DrawLabel(), Deltares.Geotechnics.Forms.DrawingSwell.DrawLabel(), Deltares.DSoilModel.Forms.DrawingLayerObsolete.DrawLabel(), Deltares.Geotechnics.Forms.DrawingLayer.DrawLabel(), Deltares.DSoilModel.Forms.DrawingSoilSegmentSplitLocation.DrawLabel(), Deltares.DSoilModel.Forms.DrawingCenterCrestLocation.DrawLabel(), Deltares.Geotechnics.Forms.DrawingSpecificMechanismPointLocation.DrawLabel(), Deltares.DSoilModel.Forms.DrawingSosSoilLayer1D.DrawLabel(), Deltares.Geometry.Forms.DrawingPointString.DrawLabel(), and Deltares.Geotechnics.Forms.DrawingCPT.DrawLabel().

static void Deltares.Standard.Forms.DrawingSupport.DrawLabelAtPoint | ( | GraphicsInfo | aGraphics,
 |  | Point | labelPoint,
 |  | string | text,
 |  | Brush | textBrush,
 |  | Brush | backgroundBrush,
 |  | Brush | borderBrush
 | ) |  |
static

Draws the label at point.

Parameters
aGraphics | a graphics.
labelPoint | The label point.
text | The text.
textBrush | The text brush.
backgroundBrush | The background brush.
borderBrush | The border brush.
static void Deltares.Standard.Forms.DrawingSupport.DrawLabelAtPoint | ( | GraphicsInfo | aGraphics,
 |  | Point | labelPoint,
 |  | string | text,
 |  | Brush | textBrush,
 |  | Brush | backgroundBrush,
 |  | Brush | borderBrush,
 |  | ContentAlignment | alignment,
 |  | float | fontSize
 | ) |  |
static

Draws the label at point.

Parameters
aGraphics | a graphics.
labelPoint | The label point.
text | The text.
textBrush | The text brush.
backgroundBrush | The background brush.
borderBrush | The border brush.
alignment | The alignment.
fontSize | Size of the font.
static void Deltares.Standard.Forms.DrawingSupport.DrawLabelAtPoint | ( | GraphicsInfo | aGraphics,
 |  | Point | labelPoint,
 |  | string | text,
 |  | Brush | textBrush,
 |  | Brush | backgroundBrush,
 |  | Brush | borderBrush,
 |  | ContentAlignment | alignment
 | ) |  |
static

Draws the label at point.

Parameters
aGraphics | a graphics.
labelPoint | The label point.
text | The text.
textBrush | The text brush.
backgroundBrush | The background brush.
borderBrush | The border brush.
alignment | The alignment.
static void Deltares.Standard.Forms.DrawingSupport.DrawLegend | ( | Graphics | aGraphics,
 |  | int | width,
 |  | int | height,
 |  | List< LegendItem > | legendItems
 | ) |  |
static

Draws the legend.

Parameters
aGraphics | a graphics.
width | The width.
height | The height.
legendItems | The legend items.

References Deltares.Standard.Forms.Text.

static void Deltares.Standard.Forms.DrawingSupport.DrawPointSelector | ( | Graphics | graph,
 |  | double | x,
 |  | double | y,
 |  | int | radiusOutside,
 |  | int | radiusInside
 | ) |  |
static

Draws the point selector with default colors.

Parameters
graph | The graphics object.
x | The center point X value.
y | The center point Y value.
radiusOutside | The outside circle radius.
radiusInside | The inside circle radius.

Referenced by Deltares.Geotechnics.Forms.DrawingPreConsolidationStress.Draw3D(), Deltares.Geotechnics.Forms.DrawingWaternetPointString.Draw3D(), Deltares.Geotechnics.Forms.DrawingCharacteristicPoint.Draw3D(), and Deltares.Geometry.Forms.DrawingPointString.Draw3D().

static void Deltares.Standard.Forms.DrawingSupport.DrawPointSelector | ( | Graphics | graph,
 |  | double | x,
 |  | double | y,
 |  | int | radiusOutside,
 |  | int | radiusInside,
 |  | Color | colorOutside,
 |  | Color | colorInside
 | ) |  |
static

Draws the point selector.

Parameters
graph | The graphics object.
x | The center point X value.
y | The center point Y value.
radiusOutside | The outside circle radius.
radiusInside | The inside circle radius.
colorOutside | The outside cirle color.
colorInside | The inside circle color.
static List<Point2D> Deltares.Standard.Forms.DrawingSupport.DrawSelector | ( | GraphicsInfo | info,
 |  | Point2D | point2D,
 |  | int | width,
 |  | int | height
 | ) |  |
static

Draws the selector in the X-Y plane.

Parameters
info | The information.
point2D | The point2 d.
width | The width.
height | The height.
Returns
static void Deltares.Standard.Forms.DrawingSupport.Font3D | ( | string | faceName,
 |  | short | nCharSet,
 |  | int | bBold,
 |  | int | bItalic,
 |  | int | bUnderline,
 |  | int | bStrikeOut
 | ) |  |
static

Sets the font.

Parameters
faceName | Name of the face.
nCharSet | The n character set.
bBold | The b bold.
bItalic | The b italic.
bUnderline | The b underline.
bStrikeOut | The b strike out.

Referenced by Deltares.Geometry.Forms.DrawingSurface.Draw3D().

static Color Deltares.Standard.Forms.DrawingSupport.GetColor | ( | double | fraction,
 |  | params Color[] | colors
 | ) |  |
static

Gets the color from the given set of colors using the fraction.

Parameters
fraction | The fraction.
colors | The colors.
Returns
static object Deltares.Standard.Forms.DrawingSupport.GetCurrentDraw3DInterface ( )
static

Gets the current draw3 d interface (graphics).

Returns
static Color Deltares.Standard.Forms.DrawingSupport.GetDarkerColor ( Color color )
static

Gets the darker shade of the color.

Parameters
color The color.
Returns

Referenced by Deltares.DSoilModel.Forms.DrawingBoringLayer.Draw3D(), Deltares.DSoilModel.Forms.DrawingLayerObsolete.Draw3D(), Deltares.Geotechnics.Forms.DrawingLayer.Draw3D(), Deltares.DSoilModel.Forms.DrawingSosSoilLayer1D.Draw3D(), Deltares.Geotechnics.Forms.DrawingSoilSurface.DrawLabel(), Deltares.DSoilModel.Forms.DrawingLayerObsolete.DrawLabel(), Deltares.Geotechnics.Forms.DrawingLayer.DrawLabel(), Deltares.DSoilModel.Forms.DrawingSoilSegmentSplitLocation.DrawLabel(), Deltares.DSoilModel.Forms.DrawingCenterCrestLocation.DrawLabel(), Deltares.Geotechnics.Forms.DrawingSpecificMechanismPointLocation.DrawLabel(), Deltares.DSoilModel.Forms.DrawingSosSoilLayer1D.DrawLabel(), Deltares.Geotechnics.Forms.DrawingCPT.DrawLabel(), and Deltares.Geotechnics.Forms.DrawingSwell.SetDrawingProperties().

static int Deltares.Standard.Forms.DrawingSupport.GetLabelTextHeigt | ( | string | text,
 |  | Graphics | aGraphics
 | ) |  |
static

Gets the label text heigt.

Parameters
text | The text.
aGraphics | My graphics.
Returns
static int Deltares.Standard.Forms.DrawingSupport.GetLabelTextWidth | ( | string | text,
 |  | Graphics | aGraphics
 | ) |  |
static

Gets the size of the label text with the default label Font.

Parameters
text | The text.
aGraphics | The graphics.
Returns
static Color Deltares.Standard.Forms.DrawingSupport.GetLighterColor ( Color color )
static

Gets the lighter shade of the color.

Parameters
color The color.
Returns

Referenced by Deltares.Geotechnics.Forms.DrawingWaternetPointString.Draw3D(), Deltares.Geotechnics.Forms.DrawingSoilProfile1D.Draw3D(), Deltares.Geotechnics.Forms.DrawingBoring.Draw3D(), Deltares.Geometry.Forms.DrawingPointString.Draw3D(), Deltares.Geotechnics.Forms.DrawingLocalisedGeometryPointString.DrawLabel(), Deltares.Geotechnics.Forms.DrawingSoilSurface.DrawLabel(), Deltares.DSoilModel.Forms.DrawingLayerObsolete.DrawLabel(), Deltares.Geotechnics.Forms.DrawingLayer.DrawLabel(), Deltares.DSoilModel.Forms.DrawingSoilSegmentSplitLocation.DrawLabel(), Deltares.DSoilModel.Forms.DrawingCenterCrestLocation.DrawLabel(), Deltares.Geotechnics.Forms.DrawingSpecificMechanismPointLocation.DrawLabel(), Deltares.DSoilModel.Forms.DrawingSosSoilLayer1D.DrawLabel(), Deltares.Geotechnics.Forms.DrawingCPT.DrawLabel(), and Deltares.Geotechnics.Forms.DrawingSwell.GetColor().

static Color Deltares.Standard.Forms.DrawingSupport.GetOppositeColor ( Color color )
static

Gets the opposite of the color.

Parameters
color The color.
Returns
static Point3D Deltares.Standard.Forms.DrawingSupport.GetScaled3DPoint | ( | IProjection | projection,
 |  | Point3D | aOrginalPoint
 | ) |  |
static

Gets the scaled 3d point (point in screen coordinates).

Parameters
projection | The projection.
aOrginalPoint | a orginal point.
Returns
static double Deltares.Standard.Forms.DrawingSupport.GetStandardSize | ( | object | aDraw3DInterface,
 |  | double | x,
 |  | double | y,
 |  | double | z
 | ) |  |
static

Gets the size of the standard.

Parameters
aDraw3DInterface | a draw3 d interface.
x | The x.
y | The y.
z | The z.
Returns
static int Deltares.Standard.Forms.DrawingSupport.GetTextWidth | ( | string | text,
 |  | Graphics | aGraphics,
 |  | Font | aFont
 | ) |  |
static

Gets the size of the text.

Parameters
text | The text.
aGraphics | The graphics.
aFont | The Font.
Returns
static void Deltares.Standard.Forms.DrawingSupport.Line3D | ( | PointF | beginPoint,
 |  | PointF | endPoint
 | ) |  |
static

Draws a line in the X-Y plane

Parameters
beginPoint | The begin point.
endPoint | The end point.

Referenced by Deltares.Geotechnics.Forms.DrawingWaterLevel.Draw3D(), Deltares.Geotechnics.Forms.DrawingBlockRevetmentSegment.Draw3D(), Deltares.Geotechnics.Forms.DrawingRevetment.Draw3D(), Deltares.Geotechnics.Forms.DrawingSurfaceLine2.Draw3D(), and Deltares.Geometry.Forms.DrawingPointString.Draw3D().

static void Deltares.Standard.Forms.DrawingSupport.Line3D | ( | Point3D | beginPoint,
 |  | Point3D | endPoint
 | ) |  |
static

Draws a line in the X-Z plane

Parameters
beginPoint | The begin point.
endPoint | The end point.
static void Deltares.Standard.Forms.DrawingSupport.Line3D | ( | double | xs,
 |  | double | ys,
 |  | double | zs,
 |  | double | xe,
 |  | double | ye,
 |  | double | ze
 | ) |  |
static

Draws a line in the X-Z plane

Parameters
xs | The xs.
ys | The ys.
zs | The zs.
xe | The xe.
ye | The ye.
ze | The ze.
static void Deltares.Standard.Forms.DrawingSupport.Line3D | ( | double | xs,
 |  | double | ys,
 |  | double | xe,
 |  | double | ye
 | ) |  |
static

Draws a line in the X-Y plane

Parameters
xs | The xs.
ys | The ys.
xe | The xe.
ye | The ye.
static void Deltares.Standard.Forms.DrawingSupport.Line_Symbol3D | ( | double | dXs,
 |  | double | dZs,
 |  | double | dXe,
 |  | double | dZe
 | ) |  |
static

Draws a line in the X-Z plane

Parameters
dXs | The d xs.
dZs | The d zs.
dXe | The d xe.
dZe | The d ze.
static void Deltares.Standard.Forms.DrawingSupport.LineLoop3D ( object eP_3DVertexes )
static

Draws a filled polygon in the X-Z plane

Parameters
eP_3DVertexes The e P_3 d vertexes.
static void Deltares.Standard.Forms.DrawingSupport.Material3D ( Brush aBrush )
static

Sets the brush (i.e. the fill style and color for amongst other things drawing materials)

Parameters
aBrush The brush.

Referenced by Deltares.DSoilModel.Forms.DrawingBoringLayer.Draw3D(), Deltares.Geotechnics.Forms.DrawingBlockRevetmentSegment.Draw3D(), Deltares.Geotechnics.Forms.DrawingRevetment.Draw3D(), Deltares.Geotechnics.Forms.DrawingPiezometricHead.Draw3D(), Deltares.DSoilModel.Forms.DrawingLayerObsolete.Draw3D(), Deltares.Geotechnics.Forms.DrawingLayer.Draw3D(), Deltares.DSoilModel.Forms.DrawingSosSoilLayer1D.Draw3D(), and Deltares.Geotechnics.Forms.DrawingSwell.SetDrawingProperties().

static void Deltares.Standard.Forms.DrawingSupport.Pen3D | ( | DashStyle | dashStyle,
 |  | int | width,
 |  | Color | color
 | ) |  |
static

Sets the Pen

Parameters
dashStyle | The dash style.
width | The width.
color | The color.

Referenced by Deltares.DSoilModel.Forms.DrawingBoringLayer.Draw3D(), Deltares.Geotechnics.Forms.DrawingWaterLevel.Draw3D(), Deltares.Geotechnics.Forms.DrawingBlockRevetmentSegment.Draw3D(), Deltares.Geotechnics.Forms.DrawingRevetment.Draw3D(), Deltares.Geotechnics.Forms.DrawingPiezometricHead.Draw3D(), Deltares.Geotechnics.Forms.DrawingSurfaceLine2.Draw3D(), Deltares.Geometry.Forms.DrawingLine.Draw3D(), Deltares.Geometry.Forms.DrawingSurface.Draw3D(), Deltares.DSoilModel.Forms.DrawingLayerObsolete.Draw3D(), Deltares.Geotechnics.Forms.DrawingLayer.Draw3D(), Deltares.DSoilModel.Forms.DrawingSosSoilLayer1D.Draw3D(), Deltares.Geometry.Forms.DrawingPointString.Draw3D(), and Deltares.Geotechnics.Forms.DrawingSwell.SetDrawingProperties().

static void Deltares.Standard.Forms.DrawingSupport.Rectangle3D | ( | Point3D | topLeft,
 |  | Point3D | bottomRight
 | ) |  |
static

Draws a filled rectangle in the X-Z plane.

Parameters
topLeft | The top left.
bottomRight | The bottom right.

Referenced by Deltares.Geotechnics.Forms.DrawingSheetPiling.Draw3D().

static void Deltares.Standard.Forms.DrawingSupport.Rectangle3D ( Rectangle rectangle )
static

Draws a filled rectangle in the X-Y plane.

Parameters
rectangle The rectangle.
static void Deltares.Standard.Forms.DrawingSupport.SetIEPDraw3D ( object aDraw3D )
static

Sets the iep draw3 d.

Parameters
aDraw3D a draw3 d.

Referenced by Deltares.Geotechnics.Forms.DrawingSettlementCurve.Draw3D(), Deltares.DSoilModel.Forms.DrawingBoringLayer.Draw3D(), Deltares.Geotechnics.Forms.DrawingWaterLevel.Draw3D(), Deltares.Geotechnics.Forms.DrawingBlockRevetmentSegment.Draw3D(), Deltares.Geotechnics.Forms.DrawingRevetment.Draw3D(), Deltares.Geotechnics.Forms.DrawingPiezometricHead.Draw3D(), Deltares.Geotechnics.Forms.DrawingSurfaceLine2.Draw3D(), Deltares.Geotechnics.Forms.DrawingAnchorAttachment.Draw3D(), Deltares.Geotechnics.Forms.DrawingSheetPiling.Draw3D(), Deltares.DSoilModel.Forms.DrawingLayerObsolete.Draw3D(), Deltares.Geotechnics.Forms.DrawingLayer.Draw3D(), Deltares.DSoilModel.Forms.DrawingSoilSegmentSplitLocation.Draw3D(), Deltares.DSoilModel.Forms.DrawingCenterCrestLocation.Draw3D(), Deltares.Geotechnics.Forms.DrawingSpecificMechanismPointLocation.Draw3D(), Deltares.Geotechnics.Forms.DrawingSoilProfile1D.Draw3D(), Deltares.DSoilModel.Forms.DrawingSosSoilLayer1D.Draw3D(), Deltares.Geotechnics.Forms.DrawingBoring.Draw3D(), Deltares.Geometry.Forms.DrawingPointString.Draw3D(), Deltares.Geotechnics.Forms.DrawingCPT.Draw3D(), and Deltares.Geotechnics.Forms.DrawingSwell.SetDrawingProperties().

static void Deltares.Standard.Forms.DrawingSupport.Text3D | ( | string | text,
 |  | double | dX,
 |  | double | dZ
 | ) |  |
static

Draws the specified text string in the X-Z plane.

Parameters
text | The text.
dX | The d x.
dZ | The d z.

Referenced by Deltares.Geometry.Forms.DrawingSurface.Draw3D().

static void Deltares.Standard.Forms.DrawingSupport.Text3D | ( | Graphics | graph,
 |  | string | text,
 |  | double | dX,
 |  | double | dZ
 | ) |  |
static

Draws the specified text string in the X-Z plane.

Parameters
graph | The graph.
text | The text.
dX | The d x.
dZ | The d z.
static Point Deltares.Standard.Forms.DrawingSupport.ToPoint ( Point3D point )
static

Converts a 3D point to a point in the X-Z plane.

Parameters
point The point.
Returns
static Point Deltares.Standard.Forms.DrawingSupport.ToPoint ( Point2D point )
static

Converts a 2D point to a 2D point in the X-Y plane.

Parameters
point The point.
Returns
Generated on Tue Dec 15 2015 18:14:29 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • DrawingSupport
Deltares.Standard.Forms.DrawingSupport Member List

This is the complete list of members for Deltares.Standard.Forms.DrawingSupport, including all inherited members.

Arrow_Symbol3D(double dX, double dY, double dZ, double dNX, double dNY, double dNZ, double dSize, double dArrowSize, short nPoint, short nStyle) | Deltares.Standard.Forms.DrawingSupport | static
Brush3D(Color color) | Deltares.Standard.Forms.DrawingSupport | static
Circle3D(Point3D center, double radius) | Deltares.Standard.Forms.DrawingSupport | static
Circle3D(double centerX, double centerY, double centerZ, double radius) | Deltares.Standard.Forms.DrawingSupport | static
CirclePolygon3D(double x, double z, double radius) | Deltares.Standard.Forms.DrawingSupport | static
CirclePolygon3D(double dX, double dY, double dZ, double dNX, double dNY, double dNZ, double dRadius) | Deltares.Standard.Forms.DrawingSupport | static
ColorMaterial3D(Color color) | Deltares.Standard.Forms.DrawingSupport | static
ConvertToPoints(IEnumerable< Point3D > points) | Deltares.Standard.Forms.DrawingSupport | static
ConvertToPoints(IEnumerable< Point2D > points) | Deltares.Standard.Forms.DrawingSupport | static
ConvexPolygon3D(IEnumerable< Point3D > EPVertex3d, object normal) | Deltares.Standard.Forms.DrawingSupport | static
ConvexPolygon3D(IEnumerable< Point > points) | Deltares.Standard.Forms.DrawingSupport | static
ConvexPolygon3D(Point[] points) | Deltares.Standard.Forms.DrawingSupport | static
ConvexPolygon3D(IEnumerable< Point3D > EPVertex3d) | Deltares.Standard.Forms.DrawingSupport | static
CreateConvexPolygonBox(List< Point3D > points3D) | Deltares.Standard.Forms.DrawingSupport | static
CreateConvexPolygonBox(List< Point2D > points2D) | Deltares.Standard.Forms.DrawingSupport | static
CreateConvexPolygonBox(List< Point > points) | Deltares.Standard.Forms.DrawingSupport | static
Cross_Symbol3D(double dX, double dZ, double dSize) | Deltares.Standard.Forms.DrawingSupport | static
DrawLabelAtPoint(GraphicsInfo aGraphics, Point dataPoint, Point labelPoint, string text, Brush textBrush, Brush backgroundBrush, Brush borderBrush) | Deltares.Standard.Forms.DrawingSupport | static
DrawLabelAtPoint(GraphicsInfo aGraphics, Point labelPoint, string text, Brush textBrush, Brush backgroundBrush, Brush borderBrush) | Deltares.Standard.Forms.DrawingSupport | static
DrawLabelAtPoint(GraphicsInfo aGraphics, Point labelPoint, string text, Brush textBrush, Brush backgroundBrush, Brush borderBrush, ContentAlignment alignment, float fontSize) | Deltares.Standard.Forms.DrawingSupport | static
DrawLabelAtPoint(GraphicsInfo aGraphics, Point labelPoint, string text, Brush textBrush, Brush backgroundBrush, Brush borderBrush, ContentAlignment alignment) | Deltares.Standard.Forms.DrawingSupport | static
DrawLegend(Graphics aGraphics, int width, int height, List< LegendItem > legendItems) | Deltares.Standard.Forms.DrawingSupport | static
DrawPointSelector(Graphics graph, double x, double y, int radiusOutside, int radiusInside) | Deltares.Standard.Forms.DrawingSupport | static
DrawPointSelector(Graphics graph, double x, double y, int radiusOutside, int radiusInside, Color colorOutside, Color colorInside) | Deltares.Standard.Forms.DrawingSupport | static
DrawSelector(GraphicsInfo info, Point2D point2D, int width, int height) | Deltares.Standard.Forms.DrawingSupport | static
Font3D(string faceName, short nCharSet, int bBold, int bItalic, int bUnderline, int bStrikeOut) | Deltares.Standard.Forms.DrawingSupport | static
GetColor(double fraction, params Color[] colors) | Deltares.Standard.Forms.DrawingSupport | static
GetCurrentDraw3DInterface() | Deltares.Standard.Forms.DrawingSupport | static
GetDarkerColor(Color color) | Deltares.Standard.Forms.DrawingSupport | static
GetLabelTextHeigt(string text, Graphics aGraphics) | Deltares.Standard.Forms.DrawingSupport | static
GetLabelTextWidth(string text, Graphics aGraphics) | Deltares.Standard.Forms.DrawingSupport | static
GetLighterColor(Color color) | Deltares.Standard.Forms.DrawingSupport | static
GetOppositeColor(Color color) | Deltares.Standard.Forms.DrawingSupport | static
GetScaled3DPoint(IProjection projection, Point3D aOrginalPoint) | Deltares.Standard.Forms.DrawingSupport | static
GetStandardSize(object aDraw3DInterface, double x, double y, double z) | Deltares.Standard.Forms.DrawingSupport | static
GetTextWidth(string text, Graphics aGraphics, Font aFont) | Deltares.Standard.Forms.DrawingSupport | static
Line3D(PointF beginPoint, PointF endPoint) | Deltares.Standard.Forms.DrawingSupport | static
Line3D(Point3D beginPoint, Point3D endPoint) | Deltares.Standard.Forms.DrawingSupport | static
Line3D(double xs, double ys, double zs, double xe, double ye, double ze) | Deltares.Standard.Forms.DrawingSupport | static
Line3D(double xs, double ys, double xe, double ye) | Deltares.Standard.Forms.DrawingSupport | static
Line_Symbol3D(double dXs, double dZs, double dXe, double dZe) | Deltares.Standard.Forms.DrawingSupport | static
LineLoop3D(object eP_3DVertexes) | Deltares.Standard.Forms.DrawingSupport | static
Material3D(Brush aBrush) | Deltares.Standard.Forms.DrawingSupport | static
Pen3D(DashStyle dashStyle, int width, Color color) | Deltares.Standard.Forms.DrawingSupport | static
Rectangle3D(Point3D topLeft, Point3D bottomRight) | Deltares.Standard.Forms.DrawingSupport | static
Rectangle3D(Rectangle rectangle) | Deltares.Standard.Forms.DrawingSupport | static
SelectorInsideColor (defined in Deltares.Standard.Forms.DrawingSupport) | Deltares.Standard.Forms.DrawingSupport | static
SelectorOutsideColor (defined in Deltares.Standard.Forms.DrawingSupport) | Deltares.Standard.Forms.DrawingSupport | static
SetIEPDraw3D(object aDraw3D) | Deltares.Standard.Forms.DrawingSupport | static
Text3D(string text, double dX, double dZ) | Deltares.Standard.Forms.DrawingSupport | static
Text3D(Graphics graph, string text, double dX, double dZ) | Deltares.Standard.Forms.DrawingSupport | static
ToPoint(Point3D point) | Deltares.Standard.Forms.DrawingSupport | static
ToPoint(Point2D point) | Deltares.Standard.Forms.DrawingSupport | static
Generated on Tue Dec 15 2015 18:14:29 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.EllipseShape Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • EllipseShape
Public Member Functions | List of all members
Deltares.Standard.Forms.EllipseShape Class Reference
Inheritance diagram for Deltares.Standard.Forms.EllipseShape:
Deltares.Standard.Forms.Shape Deltares.Standard.Forms.IShape

Public Member Functions

override void | Draw (GraphicsInfo info)
- Public Member Functions inherited from Deltares.Standard.Forms.Shape
virtual void | AddPoint (Point2D point)
virtual IEnumerable< object > | DataItemAt (Point point, Projection projection)
virtual bool | AllowDrop (object data)
virtual void | Drop (object data)
virtual bool | ContainsPoint (IProjection projection, Point point)
virtual Rectangle | GetExtents (IProjection projection)
virtual void | DrawLabel (GraphicsInfo info)
virtual void | Move (IProjection projection, Point2D startPosition, SizeF worldSize)
virtual void | BeginMove (IProjection projection, Point2D startPosition)
virtual CardinalDirection | GetCardinalDirectionOnEdgeContainingPoint (Point point)
virtual void | EndMove (IProjection projection, Point2D startPosition, SizeF worldSize)

Additional Inherited Members

- Protected Attributes inherited from Deltares.Standard.Forms.Shape
GraphicsPath | path = null
- Properties inherited from Deltares.Standard.Forms.Shape
Point | Location [get, set]
Size | Size [get, set]
virtual bool | CanResize [get]
Color | ForeColor [get, set]
Color | BackColor [get, set]
IProjection | CoordinateSystem [get, set]
Point2D | WorldLocation [get, set]
SizeF | WorldSize [get, set]
virtual int | Layer [get, set]
virtual object | DataObject [get, set]
- Properties inherited from Deltares.Standard.Forms.IShape
object | DataObject [get, set]
int | Layer [get]
Generated on Tue Dec 15 2015 18:14:29 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • EllipseShape
Deltares.Standard.Forms.EllipseShape Member List

This is the complete list of members for Deltares.Standard.Forms.EllipseShape, including all inherited members.

AddPoint(Point2D point) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
AllowDrop(object data) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
BackColor (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
BeginMove(IProjection projection, Point2D startPosition) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
CanResize (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
ContainsPoint(IProjection projection, Point point) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
CoordinateSystem (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
DataItemAt(Point point, Projection projection) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
DataObject (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
Draw(GraphicsInfo info) (defined in Deltares.Standard.Forms.EllipseShape) | Deltares.Standard.Forms.EllipseShape | virtual
DrawLabel(GraphicsInfo info) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
Drop(object data) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
EndMove(IProjection projection, Point2D startPosition, SizeF worldSize) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
ForeColor (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
GetCardinalDirectionOnEdgeContainingPoint(Point point) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
GetExtents(IProjection projection) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
Layer (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
Location (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
Move(IProjection projection, Point2D startPosition, SizeF worldSize) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
path (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | protected
Shape() (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
Size (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
WorldLocation (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
WorldSize (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
Generated on Tue Dec 15 2015 18:14:29 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.EmptyShape Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • EmptyShape
Public Member Functions | List of all members
Deltares.Standard.Forms.EmptyShape Class Reference
Inheritance diagram for Deltares.Standard.Forms.EmptyShape:
Deltares.Standard.Forms.Shape Deltares.Standard.Forms.IShape

Public Member Functions

EmptyShape (object dataObject)
- Public Member Functions inherited from Deltares.Standard.Forms.Shape
virtual void | AddPoint (Point2D point)
virtual IEnumerable< object > | DataItemAt (Point point, Projection projection)
virtual bool | AllowDrop (object data)
virtual void | Drop (object data)
virtual bool | ContainsPoint (IProjection projection, Point point)
virtual Rectangle | GetExtents (IProjection projection)
virtual void | Draw (GraphicsInfo info)
virtual void | DrawLabel (GraphicsInfo info)
virtual void | Move (IProjection projection, Point2D startPosition, SizeF worldSize)
virtual void | BeginMove (IProjection projection, Point2D startPosition)
virtual CardinalDirection | GetCardinalDirectionOnEdgeContainingPoint (Point point)
virtual void | EndMove (IProjection projection, Point2D startPosition, SizeF worldSize)

Additional Inherited Members

- Protected Attributes inherited from Deltares.Standard.Forms.Shape
GraphicsPath | path = null
- Properties inherited from Deltares.Standard.Forms.Shape
Point | Location [get, set]
Size | Size [get, set]
virtual bool | CanResize [get]
Color | ForeColor [get, set]
Color | BackColor [get, set]
IProjection | CoordinateSystem [get, set]
Point2D | WorldLocation [get, set]
SizeF | WorldSize [get, set]
virtual int | Layer [get, set]
virtual object | DataObject [get, set]
- Properties inherited from Deltares.Standard.Forms.IShape
object | DataObject [get, set]
int | Layer [get]
Generated on Tue Dec 15 2015 18:14:30 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • EmptyShape
Deltares.Standard.Forms.EmptyShape Member List

This is the complete list of members for Deltares.Standard.Forms.EmptyShape, including all inherited members.

AddPoint(Point2D point) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
AllowDrop(object data) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
BackColor (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
BeginMove(IProjection projection, Point2D startPosition) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
CanResize (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
ContainsPoint(IProjection projection, Point point) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
CoordinateSystem (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
DataItemAt(Point point, Projection projection) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
DataObject (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
Draw(GraphicsInfo info) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
DrawLabel(GraphicsInfo info) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
Drop(object data) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
EmptyShape(object dataObject) (defined in Deltares.Standard.Forms.EmptyShape) | Deltares.Standard.Forms.EmptyShape |
EndMove(IProjection projection, Point2D startPosition, SizeF worldSize) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
ForeColor (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
GetCardinalDirectionOnEdgeContainingPoint(Point point) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
GetExtents(IProjection projection) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
Layer (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
Location (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
Move(IProjection projection, Point2D startPosition, SizeF worldSize) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
path (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | protected
Shape() (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
Size (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
WorldLocation (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
WorldSize (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
Generated on Tue Dec 15 2015 18:14:30 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.FileEditor Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • FileEditor
Public Member Functions | List of all members
Deltares.Standard.Forms.FileEditor Class Reference
Inheritance diagram for Deltares.Standard.Forms.FileEditor:

Public Member Functions

void | Assign (IPropertyObject propertyObject, string property)
override UITypeEditorEditStyle | GetEditStyle (ITypeDescriptorContext context)
override object | EditValue (ITypeDescriptorContext context, IServiceProvider provider, object value)
Generated on Tue Dec 15 2015 18:14:30 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • FileEditor
Deltares.Standard.Forms.FileEditor Member List

This is the complete list of members for Deltares.Standard.Forms.FileEditor, including all inherited members.

Assign(IPropertyObject propertyObject, string property) (defined in Deltares.Standard.Forms.FileEditor) | Deltares.Standard.Forms.FileEditor
EditValue(ITypeDescriptorContext context, IServiceProvider provider, object value) (defined in Deltares.Standard.Forms.FileEditor) | Deltares.Standard.Forms.FileEditor
FileEditor() (defined in Deltares.Standard.Forms.FileEditor) | Deltares.Standard.Forms.FileEditor
GetEditStyle(ITypeDescriptorContext context) (defined in Deltares.Standard.Forms.FileEditor) | Deltares.Standard.Forms.FileEditor
Generated on Tue Dec 15 2015 18:14:30 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.FormSupport Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • FormSupport
Properties | List of all members
Deltares.Standard.Forms.FormSupport Class Reference

Properties

Form | Form [get, set]
IPropertyObject | Source [get, set]
ArrayList | AdditionalControls [get]
Generated on Tue Dec 15 2015 18:14:30 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • FormSupport
Deltares.Standard.Forms.FormSupport Member List

This is the complete list of members for Deltares.Standard.Forms.FormSupport, including all inherited members.

AdditionalControls (defined in Deltares.Standard.Forms.FormSupport) | Deltares.Standard.Forms.FormSupport
Form (defined in Deltares.Standard.Forms.FormSupport) | Deltares.Standard.Forms.FormSupport
Source (defined in Deltares.Standard.Forms.FormSupport) | Deltares.Standard.Forms.FormSupport
Generated on Tue Dec 15 2015 18:14:30 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.GraphicsInfo Struct Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • GraphicsInfo
Public Attributes | List of all members
Deltares.Standard.Forms.GraphicsInfo Struct Reference

Public Attributes

Graphics | Graphics
int | Height
bool | Hovered
Point | MousePosition
Snapped mouse position in screen coordinates (pixels) More...
IProjection | Projection
bool | Selected
Point | UnsnappedMousePosition
Unsnapped mouse position in screen coordinates (pixels) More...
int | Width
Point2D | WorldMousePosition
Snapped mouse position in world coordinates More...

Member Data Documentation

Point Deltares.Standard.Forms.GraphicsInfo.MousePosition

Snapped mouse position in screen coordinates (pixels)

Referenced by Deltares.Standard.Forms.InsertShape.Draw(), Deltares.Geotechnics.Forms.DrawingWaternetPointString.Draw3D(), Deltares.Geometry.Forms.DrawingPointString.Draw3D(), Deltares.Geotechnics.Forms.DrawingWaternetLine.DrawLabel(), and Deltares.Geotechnics.Forms.DrawingWaternetPointString.DrawLabel().

Point Deltares.Standard.Forms.GraphicsInfo.UnsnappedMousePosition

Unsnapped mouse position in screen coordinates (pixels)

Point2D Deltares.Standard.Forms.GraphicsInfo.WorldMousePosition

Snapped mouse position in world coordinates

Referenced by Deltares.Standard.Forms.InsertShape.Draw().

Generated on Tue Dec 15 2015 18:14:30 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • GraphicsInfo
Deltares.Standard.Forms.GraphicsInfo Member List

This is the complete list of members for Deltares.Standard.Forms.GraphicsInfo, including all inherited members.

Graphics (defined in Deltares.Standard.Forms.GraphicsInfo) | Deltares.Standard.Forms.GraphicsInfo
Height (defined in Deltares.Standard.Forms.GraphicsInfo) | Deltares.Standard.Forms.GraphicsInfo
Hovered (defined in Deltares.Standard.Forms.GraphicsInfo) | Deltares.Standard.Forms.GraphicsInfo
MousePosition | Deltares.Standard.Forms.GraphicsInfo
Projection (defined in Deltares.Standard.Forms.GraphicsInfo) | Deltares.Standard.Forms.GraphicsInfo
Selected (defined in Deltares.Standard.Forms.GraphicsInfo) | Deltares.Standard.Forms.GraphicsInfo
UnsnappedMousePosition | Deltares.Standard.Forms.GraphicsInfo
Width (defined in Deltares.Standard.Forms.GraphicsInfo) | Deltares.Standard.Forms.GraphicsInfo
WorldMousePosition | Deltares.Standard.Forms.GraphicsInfo
Generated on Tue Dec 15 2015 18:14:30 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.GridViewCellChangeArgs Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • GridViewCellChangeArgs
Public Member Functions | Properties | List of all members
Deltares.Standard.Forms.GridViewCellChangeArgs Class Reference

Used for cell changes in the grid view. More...

Inheritance diagram for Deltares.Standard.Forms.GridViewCellChangeArgs:
Deltares.Standard.Forms.GridViewChangeArgs

Public Member Functions

GridViewCellChangeArgs (object subject, int index, string propertyName, object propertyValue)
Initializes a new instance of the GridViewCellChangeArgs class. More...
- Public Member Functions inherited from Deltares.Standard.Forms.GridViewChangeArgs
GridViewChangeArgs (object data)
Initializes a new instance of the GridViewChangeArgs class. More...
GridViewChangeArgs (int index, object data)
Initializes a new instance of the GridViewChangeArgs class. More...

Properties

string | PropertyName [get]
Gets the name of the property that was changed through the grid view. More...
object | PropertyValue [get]
Gets the new property value. More...
- Properties inherited from Deltares.Standard.Forms.GridViewChangeArgs
int | Index [get]
Gets or sets the index. More...

Detailed Description

Used for cell changes in the grid view.

Constructor & Destructor Documentation

Deltares.Standard.Forms.GridViewCellChangeArgs.GridViewCellChangeArgs | ( | object | subject,
 |  | int | index,
 |  | string | propertyName,
 |  | object | propertyValue
 | ) |  |

Initializes a new instance of the GridViewCellChangeArgs class.

Parameters
subject | The object instance that changed.
index | The list index of the object
propertyName | Name of the property
propertyValue | The new value of the property

Property Documentation

string Deltares.Standard.Forms.GridViewCellChangeArgs.PropertyName
get

Gets the name of the property that was changed through the grid view.

The name of the property.

object Deltares.Standard.Forms.GridViewCellChangeArgs.PropertyValue
get

Gets the new property value.

Generated on Tue Dec 15 2015 18:14:30 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • GridViewCellChangeArgs
Deltares.Standard.Forms.GridViewCellChangeArgs Member List

This is the complete list of members for Deltares.Standard.Forms.GridViewCellChangeArgs, including all inherited members.

GridViewCellChangeArgs(object subject, int index, string propertyName, object propertyValue) | Deltares.Standard.Forms.GridViewCellChangeArgs
GridViewChangeArgs(object data) | Deltares.Standard.Forms.GridViewChangeArgs
GridViewChangeArgs(int index, object data) | Deltares.Standard.Forms.GridViewChangeArgs
Index | Deltares.Standard.Forms.GridViewChangeArgs
PropertyName | Deltares.Standard.Forms.GridViewCellChangeArgs
PropertyValue | Deltares.Standard.Forms.GridViewCellChangeArgs
Generated on Tue Dec 15 2015 18:14:30 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.GridViewChangeArgs Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • GridViewChangeArgs
Public Member Functions | Properties | List of all members
Deltares.Standard.Forms.GridViewChangeArgs Class Reference

Used for change actions in the grid view. (add, delete and insert) More...

Inheritance diagram for Deltares.Standard.Forms.GridViewChangeArgs:
Deltares.Standard.Forms.GridViewCellChangeArgs

Public Member Functions

GridViewChangeArgs (object data)
Initializes a new instance of the GridViewChangeArgs class. More...
GridViewChangeArgs (int index, object data)
Initializes a new instance of the GridViewChangeArgs class. More...

Properties

int Index [get]
Gets or sets the index. More...

Detailed Description

Used for change actions in the grid view. (add, delete and insert)

Constructor & Destructor Documentation

Deltares.Standard.Forms.GridViewChangeArgs.GridViewChangeArgs ( object data )

Initializes a new instance of the GridViewChangeArgs class.

Parameters
data The data.
Deltares.Standard.Forms.GridViewChangeArgs.GridViewChangeArgs | ( | int | index,
 |  | object | data
 | ) |  |

Initializes a new instance of the GridViewChangeArgs class.

Parameters
index | The index.
data | The data.

Property Documentation

int Deltares.Standard.Forms.GridViewChangeArgs.Index
get

Gets or sets the index.

The index.

Generated on Tue Dec 15 2015 18:14:31 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • GridViewChangeArgs
Deltares.Standard.Forms.GridViewChangeArgs Member List

This is the complete list of members for Deltares.Standard.Forms.GridViewChangeArgs, including all inherited members.

GridViewChangeArgs(object data) | Deltares.Standard.Forms.GridViewChangeArgs
GridViewChangeArgs(int index, object data) | Deltares.Standard.Forms.GridViewChangeArgs
Index | Deltares.Standard.Forms.GridViewChangeArgs
Generated on Tue Dec 15 2015 18:14:31 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.ICommand Interface Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • ICommand
Properties | List of all members
Deltares.Standard.Forms.ICommand Interface Reference

Properties

string | CommandName [get]
The command name to identify the UICommand object. More...
object | CommandArgument [get, set]
The command arguments More...
bool | Enabled [get, set]
Sets or Gets the Enabled property of the attached controls. More...
bool | Visible [get, set]
Sets or Gets the Visible property of the attached controls. More...
Image | Icon [get, set]
Sets or Gets the Icon/Gylph property of the attached controls. More...
string | Text [get, set]
Sets or Gets the Text property of the attached controls. More...
Shortcut | ShortCut [get, set]
Sets or Gets the ShortCut property of the attached controls. More...
string | Hint [get, set]
Sets or Gets the Hint property of the attached controls. More...
Action< object, EventArgs > | Execute [get, set]
This event is raised whenever the attached control is clicked More...
Func< object, bool > | CanExecute [get, set]
Can execute should be used to evaluate if the command in its current context can be executed More...

Property Documentation

Func<object, bool> Deltares.Standard.Forms.ICommand.CanExecute
getset

Can execute should be used to evaluate if the command in its current context can be executed

object Deltares.Standard.Forms.ICommand.CommandArgument
getset

The command arguments

string Deltares.Standard.Forms.ICommand.CommandName
get

The command name to identify the UICommand object.

bool Deltares.Standard.Forms.ICommand.Enabled
getset

Sets or Gets the Enabled property of the attached controls.

Action<object, EventArgs> Deltares.Standard.Forms.ICommand.Execute
getset

This event is raised whenever the attached control is clicked

string Deltares.Standard.Forms.ICommand.Hint
getset

Sets or Gets the Hint property of the attached controls.

Image Deltares.Standard.Forms.ICommand.Icon
getset

Sets or Gets the Icon/Gylph property of the attached controls.

Shortcut Deltares.Standard.Forms.ICommand.ShortCut
getset

Sets or Gets the ShortCut property of the attached controls.

string Deltares.Standard.Forms.ICommand.Text
getset

Sets or Gets the Text property of the attached controls.

bool Deltares.Standard.Forms.ICommand.Visible
getset

Sets or Gets the Visible property of the attached controls.

Generated on Tue Dec 15 2015 18:14:31 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • ICommand
Deltares.Standard.Forms.ICommand Member List

This is the complete list of members for Deltares.Standard.Forms.ICommand, including all inherited members.

CanExecute | Deltares.Standard.Forms.ICommand
CommandArgument | Deltares.Standard.Forms.ICommand
CommandName | Deltares.Standard.Forms.ICommand
Enabled | Deltares.Standard.Forms.ICommand
Execute | Deltares.Standard.Forms.ICommand
Hint | Deltares.Standard.Forms.ICommand
Icon | Deltares.Standard.Forms.ICommand
ShortCut | Deltares.Standard.Forms.ICommand
Text | Deltares.Standard.Forms.ICommand
Visible | Deltares.Standard.Forms.ICommand
Generated on Tue Dec 15 2015 18:14:31 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.IController Interface Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • IController
Public Member Functions | Properties | List of all members
Deltares.Standard.Forms.IController Interface Reference

Defines a Interface for controlling the commands. More...

Public Member Functions

void | Execute (string commandName)
Executes the given command More...
bool | IsChecked (string commandName)
Detrmines whether a command is checked or not. More...
bool | IsEnabled (string commandName)
Detrmines whether a command is enabled or not. More...
bool | IsVisible (string commandName)
Detrmines whether a command is visible or not. More...
void | SetValue (object sourceObject, string propertyName, object value)
Documenation to be written More...

Properties

object | Source [get, set]
Gets or sets the source object More...
object[] | Selection [get, set]
Gets or sets the array of objects selected. More...

Detailed Description

Defines a Interface for controlling the commands.

Member Function Documentation

void Deltares.Standard.Forms.IController.Execute ( string commandName )

Executes the given command

Parameters
commandName The name of the command to be executed
bool Deltares.Standard.Forms.IController.IsChecked ( string commandName )

Detrmines whether a command is checked or not.

Parameters
commandName The name of the command
Returns
True if selected else false
bool Deltares.Standard.Forms.IController.IsEnabled ( string commandName )

Detrmines whether a command is enabled or not.

Parameters
commandName The name of the command
Returns
True if selected else false
bool Deltares.Standard.Forms.IController.IsVisible ( string commandName )

Detrmines whether a command is visible or not.

Parameters
commandName The name of the command
Returns
True if visible else false
void Deltares.Standard.Forms.IController.SetValue | ( | object | sourceObject,
 |  | string | propertyName,
 |  | object | value
 | ) |  |

Documenation to be written

Parameters
sourceObject | source object
commandName | command name
value | value object

Property Documentation

object [] Deltares.Standard.Forms.IController.Selection
getset

Gets or sets the array of objects selected.

object Deltares.Standard.Forms.IController.Source
getset

Gets or sets the source object

Generated on Tue Dec 15 2015 18:14:31 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • IController
Deltares.Standard.Forms.IController Member List

This is the complete list of members for Deltares.Standard.Forms.IController, including all inherited members.

Execute(string commandName) | Deltares.Standard.Forms.IController
IsChecked(string commandName) | Deltares.Standard.Forms.IController
IsEnabled(string commandName) | Deltares.Standard.Forms.IController
IsVisible(string commandName) | Deltares.Standard.Forms.IController
Selection | Deltares.Standard.Forms.IController
SetValue(object sourceObject, string propertyName, object value) | Deltares.Standard.Forms.IController
Source | Deltares.Standard.Forms.IController
Generated on Tue Dec 15 2015 18:14:31 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.ICustomView Interface Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • ICustomView
Public Member Functions | Events | List of all members
Deltares.Standard.Forms.ICustomView Interface Reference

Public Member Functions

Dictionary< string, object > | GetCurrentView ()
void | UpdateView (Dictionary< string, object > aProperties)

Events

ViewChanged OnViewChaged
Generated on Tue Dec 15 2015 18:14:31 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • ICustomView
Deltares.Standard.Forms.ICustomView Member List

This is the complete list of members for Deltares.Standard.Forms.ICustomView, including all inherited members.

GetCurrentView() (defined in Deltares.Standard.Forms.ICustomView) | Deltares.Standard.Forms.ICustomView
OnViewChaged (defined in Deltares.Standard.Forms.ICustomView) | Deltares.Standard.Forms.ICustomView
UpdateView(Dictionary< string, object > aProperties) (defined in Deltares.Standard.Forms.ICustomView) | Deltares.Standard.Forms.ICustomView
Generated on Tue Dec 15 2015 18:14:31 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.IDynamicPropertyControl Interface Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • IDynamicPropertyControl
Public Member Functions | Properties | List of all members
Deltares.Standard.Forms.IDynamicPropertyControl Interface Reference

interface to display custom property windows More...

Inheritance diagram for Deltares.Standard.Forms.IDynamicPropertyControl:
Deltares.Standard.Forms.DExpress.DynamicPropertyControl

Public Member Functions

void BuildPropertyControlTabsForType (Type type, params IPropertyControl[] controls)
Registers the custom property coltrol More...

Properties

object | SelectedObject [get, set]
Gets or sets the value of the object to be displayed in the property grid More...
IPropertyControl | DefaultPropertyGrid [get]
Default property grid More...

Detailed Description

interface to display custom property windows

Member Function Documentation

void Deltares.Standard.Forms.IDynamicPropertyControl.BuildPropertyControlTabsForType | ( | Type | type,
 |  | params IPropertyControl[] | controls
 | ) |  |

Registers the custom property coltrol

Parameters
type | type of the object handled by the control
controls | custom property control to handle the specific type

Implemented in Deltares.Standard.Forms.DExpress.DynamicPropertyControl.

Property Documentation

IPropertyControl Deltares.Standard.Forms.IDynamicPropertyControl.DefaultPropertyGrid
get

Default property grid

object Deltares.Standard.Forms.IDynamicPropertyControl.SelectedObject
getset

Gets or sets the value of the object to be displayed in the property grid

Generated on Tue Dec 15 2015 18:14:31 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • IDynamicPropertyControl
Deltares.Standard.Forms.IDynamicPropertyControl Member List

This is the complete list of members for Deltares.Standard.Forms.IDynamicPropertyControl, including all inherited members.

BuildPropertyControlTabsForType(Type type, params IPropertyControl[] controls) | Deltares.Standard.Forms.IDynamicPropertyControl
DefaultPropertyGrid | Deltares.Standard.Forms.IDynamicPropertyControl
SelectedObject | Deltares.Standard.Forms.IDynamicPropertyControl
Generated on Tue Dec 15 2015 18:14:31 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.IDynamicTableControl Interface Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • IDynamicTableControl
Public Member Functions | List of all members
Deltares.Standard.Forms.IDynamicTableControl Interface Reference
Inheritance diagram for Deltares.Standard.Forms.IDynamicTableControl:
Deltares.Standard.Forms.DExpress.DynamicTableControl

Public Member Functions

Component | GetComponent ()
XtraTabPage | RegisterTable (Type type, Control control, string caption)
Generated on Tue Dec 15 2015 18:14:31 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • IDynamicTableControl
Deltares.Standard.Forms.IDynamicTableControl Member List

This is the complete list of members for Deltares.Standard.Forms.IDynamicTableControl, including all inherited members.

GetComponent() (defined in Deltares.Standard.Forms.IDynamicTableControl) | Deltares.Standard.Forms.IDynamicTableControl
RegisterTable(Type type, Control control, string caption) (defined in Deltares.Standard.Forms.IDynamicTableControl) | Deltares.Standard.Forms.IDynamicTableControl
Generated on Tue Dec 15 2015 18:14:31 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.IGridController Interface Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • IGridController
Public Member Functions | Properties | List of all members
Deltares.Standard.Forms.IGridController Interface Reference
Inheritance diagram for Deltares.Standard.Forms.IGridController:
Deltares.Standard.Forms.IGridViewControl Deltares.Standard.Forms.DExpress.GridViewControl

Public Member Functions

void | AddRow ()
Appends a row at the end of the grid. More...
void | DeleteRow (int index)
Removes an item at the given index in the collection which is bound to the grid control. More...
void | InsertRow (int index)
Inserts a new object at the given index in the collection which is bound to the grid control. More...

Properties

Func< object > CreateNew [set]
Sets the object factory method. More...

Member Function Documentation

void Deltares.Standard.Forms.IGridController.AddRow ( )

Appends a row at the end of the grid.

Returns
The object created

Implemented in Deltares.Standard.Forms.DExpress.GridViewControl.

void Deltares.Standard.Forms.IGridController.DeleteRow ( int index )

Removes an item at the given index in the collection which is bound to the grid control.

Parameters
index The index.
Returns
The deleted object

Implemented in Deltares.Standard.Forms.DExpress.GridViewControl.

void Deltares.Standard.Forms.IGridController.InsertRow ( int index )

Inserts a new object at the given index in the collection which is bound to the grid control.

Parameters
index The index.
Returns

Implemented in Deltares.Standard.Forms.DExpress.GridViewControl.

Property Documentation

Func<object> Deltares.Standard.Forms.IGridController.CreateNew
set

Sets the object factory method.

The object factory method.

Generated on Tue Dec 15 2015 18:14:32 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • IGridController
Deltares.Standard.Forms.IGridController Member List

This is the complete list of members for Deltares.Standard.Forms.IGridController, including all inherited members.

AddRow() | Deltares.Standard.Forms.IGridController
CreateNew | Deltares.Standard.Forms.IGridController
DeleteRow(int index) | Deltares.Standard.Forms.IGridController
InsertRow(int index) | Deltares.Standard.Forms.IGridController
Generated on Tue Dec 15 2015 18:14:32 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.IGridViewControl Interface Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • IGridViewControl
Public Member Functions | Properties | Events | List of all members
Deltares.Standard.Forms.IGridViewControl Interface Reference
Inheritance diagram for Deltares.Standard.Forms.IGridViewControl:
Deltares.Standard.Forms.IGridController Deltares.Standard.Forms.DExpress.GridViewControl

Public Member Functions

object | GetControl ()
void | Dispose ()
- Public Member Functions inherited from Deltares.Standard.Forms.IGridController
void | AddRow ()
Appends a row at the end of the grid. More...
void | DeleteRow (int index)
Removes an item at the given index in the collection which is bound to the grid control. More...
void | InsertRow (int index)
Inserts a new object at the given index in the collection which is bound to the grid control. More...

Properties

string | Caption [get]
bool | AllowInserts [get, set]
- Properties inherited from Deltares.Standard.Forms.IGridController
Func< object > | CreateNew [set]
Sets the object factory method. More...

Events

EventHandler< GridViewChangeArgs > | AfterRowAdd
EventHandler< GridViewChangeArgs > | AfterRowDelete
EventHandler< GridViewChangeArgs > | AfterRowInsert
Generated on Tue Dec 15 2015 18:14:32 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • IGridViewControl
Deltares.Standard.Forms.IGridViewControl Member List

This is the complete list of members for Deltares.Standard.Forms.IGridViewControl, including all inherited members.

AddRow() | Deltares.Standard.Forms.IGridController
AfterRowAdd (defined in Deltares.Standard.Forms.IGridViewControl) | Deltares.Standard.Forms.IGridViewControl
AfterRowDelete (defined in Deltares.Standard.Forms.IGridViewControl) | Deltares.Standard.Forms.IGridViewControl
AfterRowInsert (defined in Deltares.Standard.Forms.IGridViewControl) | Deltares.Standard.Forms.IGridViewControl
AllowInserts (defined in Deltares.Standard.Forms.IGridViewControl) | Deltares.Standard.Forms.IGridViewControl
Caption (defined in Deltares.Standard.Forms.IGridViewControl) | Deltares.Standard.Forms.IGridViewControl
CreateNew | Deltares.Standard.Forms.IGridController
DeleteRow(int index) | Deltares.Standard.Forms.IGridController
Dispose() (defined in Deltares.Standard.Forms.IGridViewControl) | Deltares.Standard.Forms.IGridViewControl
GetControl() (defined in Deltares.Standard.Forms.IGridViewControl) | Deltares.Standard.Forms.IGridViewControl
InsertRow(int index) | Deltares.Standard.Forms.IGridController
Generated on Tue Dec 15 2015 18:14:32 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.InsertShape Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • InsertShape
Public Member Functions | Properties | List of all members
Deltares.Standard.Forms.InsertShape Class Reference
Inheritance diagram for Deltares.Standard.Forms.InsertShape:
Deltares.Standard.Forms.Shape Deltares.Standard.Forms.IShape

Public Member Functions

Point2D | AddMousePoint ()
void | Clear ()
override void | AddPoint (Point2D point)
override void | Draw (GraphicsInfo info)
Draws publisherEventArgs Curve from the set of points. More...
override void | DrawLabel (GraphicsInfo info)
- Public Member Functions inherited from Deltares.Standard.Forms.Shape
virtual IEnumerable< object > | DataItemAt (Point point, Projection projection)
virtual bool | AllowDrop (object data)
virtual void | Drop (object data)
virtual bool | ContainsPoint (IProjection projection, Point point)
virtual Rectangle | GetExtents (IProjection projection)
virtual void | Move (IProjection projection, Point2D startPosition, SizeF worldSize)
virtual void | BeginMove (IProjection projection, Point2D startPosition)
virtual CardinalDirection | GetCardinalDirectionOnEdgeContainingPoint (Point point)
virtual void | EndMove (IProjection projection, Point2D startPosition, SizeF worldSize)

Properties

List< Point2D > | Points [get]
bool | MustIncrease [get, set]
- Properties inherited from Deltares.Standard.Forms.Shape
Point | Location [get, set]
Size | Size [get, set]
virtual bool | CanResize [get]
Color | ForeColor [get, set]
Color | BackColor [get, set]
IProjection | CoordinateSystem [get, set]
Point2D | WorldLocation [get, set]
SizeF | WorldSize [get, set]
virtual int | Layer [get, set]
virtual object | DataObject [get, set]
- Properties inherited from Deltares.Standard.Forms.IShape
object | DataObject [get, set]
int | Layer [get]

Additional Inherited Members

- Protected Attributes inherited from Deltares.Standard.Forms.Shape
GraphicsPath path = null

Member Function Documentation

override void Deltares.Standard.Forms.InsertShape.Draw ( GraphicsInfo info )
virtual

Draws publisherEventArgs Curve from the set of points.

Parameters
aDraw3D

Reimplemented from Deltares.Standard.Forms.Shape.

References Deltares.Standard.Forms.GraphicsInfo.MousePosition, and Deltares.Standard.Forms.GraphicsInfo.WorldMousePosition.

Generated on Tue Dec 15 2015 18:14:32 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • InsertShape
Deltares.Standard.Forms.InsertShape Member List

This is the complete list of members for Deltares.Standard.Forms.InsertShape, including all inherited members.

AddMousePoint() (defined in Deltares.Standard.Forms.InsertShape) | Deltares.Standard.Forms.InsertShape |
AddPoint(Point2D point) (defined in Deltares.Standard.Forms.InsertShape) | Deltares.Standard.Forms.InsertShape | virtual
AllowDrop(object data) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
BackColor (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
BeginMove(IProjection projection, Point2D startPosition) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
CanResize (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
Clear() (defined in Deltares.Standard.Forms.InsertShape) | Deltares.Standard.Forms.InsertShape |
ContainsPoint(IProjection projection, Point point) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
CoordinateSystem (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
DataItemAt(Point point, Projection projection) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
DataObject (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
Draw(GraphicsInfo info) | Deltares.Standard.Forms.InsertShape | virtual
DrawLabel(GraphicsInfo info) (defined in Deltares.Standard.Forms.InsertShape) | Deltares.Standard.Forms.InsertShape | virtual
Drop(object data) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
EndMove(IProjection projection, Point2D startPosition, SizeF worldSize) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
ForeColor (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
GetCardinalDirectionOnEdgeContainingPoint(Point point) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
GetExtents(IProjection projection) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
InsertShape() (defined in Deltares.Standard.Forms.InsertShape) | Deltares.Standard.Forms.InsertShape |
Layer (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
Location (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
Move(IProjection projection, Point2D startPosition, SizeF worldSize) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
MustIncrease (defined in Deltares.Standard.Forms.InsertShape) | Deltares.Standard.Forms.InsertShape |
path (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | protected
Points (defined in Deltares.Standard.Forms.InsertShape) | Deltares.Standard.Forms.InsertShape |
Shape() (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
Size (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
WorldLocation (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
WorldSize (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
Generated on Tue Dec 15 2015 18:14:32 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.IPresentable Interface Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • IPresentable
Public Member Functions | List of all members
Deltares.Standard.Forms.IPresentable Interface Reference

Public Member Functions

object | GetValue (string path)
void | SetValue (string path, object newValue)
void | Execute (string path)
bool | IsVisible (string path)
bool | IsEnabled (string path)
string | GetFormat (string path)
object | GetMinimum (string path)
object | GetMaximum (string path)
Generated on Tue Dec 15 2015 18:14:32 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • IPresentable
Deltares.Standard.Forms.IPresentable Member List

This is the complete list of members for Deltares.Standard.Forms.IPresentable, including all inherited members.

Execute(string path) (defined in Deltares.Standard.Forms.IPresentable) | Deltares.Standard.Forms.IPresentable
GetFormat(string path) (defined in Deltares.Standard.Forms.IPresentable) | Deltares.Standard.Forms.IPresentable
GetMaximum(string path) (defined in Deltares.Standard.Forms.IPresentable) | Deltares.Standard.Forms.IPresentable
GetMinimum(string path) (defined in Deltares.Standard.Forms.IPresentable) | Deltares.Standard.Forms.IPresentable
GetValue(string path) (defined in Deltares.Standard.Forms.IPresentable) | Deltares.Standard.Forms.IPresentable
IsEnabled(string path) (defined in Deltares.Standard.Forms.IPresentable) | Deltares.Standard.Forms.IPresentable
IsVisible(string path) (defined in Deltares.Standard.Forms.IPresentable) | Deltares.Standard.Forms.IPresentable
SetValue(string path, object newValue) (defined in Deltares.Standard.Forms.IPresentable) | Deltares.Standard.Forms.IPresentable
Generated on Tue Dec 15 2015 18:14:32 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.IPresenter Interface Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • IPresenter
Public Member Functions | Properties | List of all members
Deltares.Standard.Forms.IPresenter Interface Reference

Public Member Functions

void | Register (Control control, string path)
void | UpdateControl (Control control, string path)
void | UpdateSource (Control control, string path)

Properties

IPresentable Source [get, set]
Generated on Tue Dec 15 2015 18:14:32 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • IPresenter
Deltares.Standard.Forms.IPresenter Member List

This is the complete list of members for Deltares.Standard.Forms.IPresenter, including all inherited members.

Register(Control control, string path) (defined in Deltares.Standard.Forms.IPresenter) | Deltares.Standard.Forms.IPresenter
Source (defined in Deltares.Standard.Forms.IPresenter) | Deltares.Standard.Forms.IPresenter
UpdateControl(Control control, string path) (defined in Deltares.Standard.Forms.IPresenter) | Deltares.Standard.Forms.IPresenter
UpdateSource(Control control, string path) (defined in Deltares.Standard.Forms.IPresenter) | Deltares.Standard.Forms.IPresenter
Generated on Tue Dec 15 2015 18:14:32 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.IProjection Interface Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • IProjection
Public Member Functions | Events | List of all members
Deltares.Standard.Forms.IProjection Interface Reference
Inheritance diagram for Deltares.Standard.Forms.IProjection:
Deltares.Standard.Forms.Projection

Public Member Functions

Point | ConvertToScreen (Point2D worldPoint)
Size | ConvertToScreen (SizeF worldSize)
SizeF | ConvertToWorld (Size screenSize)
Point2D | ConvertToWorld (Point screenPoint)

Events

EventHandler CoordinateSystemChanged
Generated on Tue Dec 15 2015 18:14:32 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • IProjection
Deltares.Standard.Forms.IProjection Member List

This is the complete list of members for Deltares.Standard.Forms.IProjection, including all inherited members.

ConvertToScreen(Point2D worldPoint) (defined in Deltares.Standard.Forms.IProjection) | Deltares.Standard.Forms.IProjection
ConvertToScreen(SizeF worldSize) (defined in Deltares.Standard.Forms.IProjection) | Deltares.Standard.Forms.IProjection
ConvertToWorld(Size screenSize) (defined in Deltares.Standard.Forms.IProjection) | Deltares.Standard.Forms.IProjection
ConvertToWorld(Point screenPoint) (defined in Deltares.Standard.Forms.IProjection) | Deltares.Standard.Forms.IProjection
CoordinateSystemChanged (defined in Deltares.Standard.Forms.IProjection) | Deltares.Standard.Forms.IProjection
Generated on Tue Dec 15 2015 18:14:32 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.IPropertyControl Interface Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • IPropertyControl
Properties | List of all members
Deltares.Standard.Forms.IPropertyControl Interface Reference

Interface for custom property windows. More...

Inheritance diagram for Deltares.Standard.Forms.IPropertyControl:
Deltares.Standard.Forms.DExpress.AboutControl Deltares.Standard.Forms.DExpress.DynamicPropertyTabControl< T > Deltares.Standard.Forms.DExpress.GeoPropertyGrid Deltares.Standard.Forms.DExpress.MapLayersPropertyControl Deltares.Standard.Forms.DExpress.MapLegendPropertyControl Deltares.Standard.Forms.DExpress.ProgramOptionsControl Deltares.Standard.Forms.DExpress.Project.DescriptionDialog Deltares.Standard.Forms.DExpress.PropertyControl Deltares.Standard.Forms.DExpress.ReportControl Deltares.Standard.Forms.DExpress.SpatialEditorProperties Deltares.Standard.Forms.DExpress.UnitsDialog

Properties

string | Name [get, set]
Gets or sets the name to be displayed property. More...
object | SelectedObject [get, set]
Gets or sets the object to be displayed in the property window. More...
bool | IsVisible [get]
Whether or not the property control should be displayed. More...

Detailed Description

Interface for custom property windows.

Property Documentation

bool Deltares.Standard.Forms.IPropertyControl.IsVisible
get

Whether or not the property control should be displayed.

string Deltares.Standard.Forms.IPropertyControl.Name
getset

Gets or sets the name to be displayed property.

object Deltares.Standard.Forms.IPropertyControl.SelectedObject
getset

Gets or sets the object to be displayed in the property window.

Generated on Tue Dec 15 2015 18:14:33 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • IPropertyControl
Deltares.Standard.Forms.IPropertyControl Member List

This is the complete list of members for Deltares.Standard.Forms.IPropertyControl, including all inherited members.

IsVisible | Deltares.Standard.Forms.IPropertyControl
Name | Deltares.Standard.Forms.IPropertyControl
SelectedObject | Deltares.Standard.Forms.IPropertyControl
Generated on Tue Dec 15 2015 18:14:33 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.IReloadableUI Interface Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • IReloadableUI
Public Member Functions | List of all members
Deltares.Standard.Forms.IReloadableUI Interface Reference
Inheritance diagram for Deltares.Standard.Forms.IReloadableUI:
Deltares.Standard.Forms.DExpress.GeometryEditor Deltares.Standard.Forms.DExpress.MainForm Deltares.Standard.Forms.DExpress.Project.DescriptionDialog

Public Member Functions

void | RegisterUIComponent (IReloadManager aReloadManager)
void | Reload ()
void | UpdateData (params object[] models)
Generated on Tue Dec 15 2015 18:14:33 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • IReloadableUI
Deltares.Standard.Forms.IReloadableUI Member List

This is the complete list of members for Deltares.Standard.Forms.IReloadableUI, including all inherited members.

RegisterUIComponent(IReloadManager aReloadManager) (defined in Deltares.Standard.Forms.IReloadableUI) | Deltares.Standard.Forms.IReloadableUI
Reload() (defined in Deltares.Standard.Forms.IReloadableUI) | Deltares.Standard.Forms.IReloadableUI
UpdateData(params object[] models) (defined in Deltares.Standard.Forms.IReloadableUI) | Deltares.Standard.Forms.IReloadableUI
Generated on Tue Dec 15 2015 18:14:33 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.IReloadManager Interface Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • IReloadManager
Public Member Functions | Properties | List of all members
Deltares.Standard.Forms.IReloadManager Interface Reference
Inheritance diagram for Deltares.Standard.Forms.IReloadManager:
Deltares.Standard.Forms.DExpress.ReloadManager

Public Member Functions

void | AddComponent (object sender, EventArgs e)
void | RemoveComponent (object sender, EventArgs aArgs)
void | ApplyCurrentUiCulture (IReloadableUI aform)
void | ApplyCulture (IReloadableUI aform)
void | ApplyCurrentUiCultureToAll ()
void | SetLanguage (string aXmlPath, string aXsdPath, string aLanguage)
void | ApplyDataChangeToAll (List< object > models)

Properties

IReloadableUI[] Forms [get]
Generated on Tue Dec 15 2015 18:14:33 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • IReloadManager
Deltares.Standard.Forms.IReloadManager Member List

This is the complete list of members for Deltares.Standard.Forms.IReloadManager, including all inherited members.

AddComponent(object sender, EventArgs e) (defined in Deltares.Standard.Forms.IReloadManager) | Deltares.Standard.Forms.IReloadManager
ApplyCulture(IReloadableUI aform) (defined in Deltares.Standard.Forms.IReloadManager) | Deltares.Standard.Forms.IReloadManager
ApplyCurrentUiCulture(IReloadableUI aform) (defined in Deltares.Standard.Forms.IReloadManager) | Deltares.Standard.Forms.IReloadManager
ApplyCurrentUiCultureToAll() (defined in Deltares.Standard.Forms.IReloadManager) | Deltares.Standard.Forms.IReloadManager
ApplyDataChangeToAll(List< object > models) (defined in Deltares.Standard.Forms.IReloadManager) | Deltares.Standard.Forms.IReloadManager
Forms (defined in Deltares.Standard.Forms.IReloadManager) | Deltares.Standard.Forms.IReloadManager
RemoveComponent(object sender, EventArgs aArgs) (defined in Deltares.Standard.Forms.IReloadManager) | Deltares.Standard.Forms.IReloadManager
SetLanguage(string aXmlPath, string aXsdPath, string aLanguage) (defined in Deltares.Standard.Forms.IReloadManager) | Deltares.Standard.Forms.IReloadManager
Generated on Tue Dec 15 2015 18:14:33 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.IShape Interface Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • IShape
Public Member Functions | Properties | List of all members
Deltares.Standard.Forms.IShape Interface Reference
Inheritance diagram for Deltares.Standard.Forms.IShape:
Deltares.Geometry.Forms.IDrawingObject Deltares.Standard.Forms.Shape Deltares.Geometry.Forms.DrawingObject Deltares.Standard.Forms.ArrowShape Deltares.Standard.Forms.AxesShape Deltares.Standard.Forms.EllipseShape Deltares.Standard.Forms.EmptyShape Deltares.Standard.Forms.InsertShape Deltares.Standard.Forms.LegendShape Deltares.Standard.Forms.PolygonShape Deltares.Standard.Forms.PolylineShape Deltares.Standard.Forms.RectangleShape Deltares.Standard.Forms.TestRectangleShape Deltares.Standard.Forms.TriangleShape

Public Member Functions

bool | ContainsPoint (IProjection projection, Point point)
void | Move (IProjection projection, Point2D startPosition, SizeF worldSize)
void | BeginMove (IProjection projection, Point2D startPosition)
CardinalDirection | GetCardinalDirectionOnEdgeContainingPoint (Point point)
void | EndMove (IProjection projection, Point2D startPosition, SizeF worldSize)
bool | AllowDrop (object data)
void | Drop (object data)
void | Draw (GraphicsInfo info)
void | DrawLabel (GraphicsInfo info)
Rectangle | GetExtents (IProjection projection)
IEnumerable< object > | DataItemAt (Point point, Projection projection)

Properties

object | DataObject [get, set]
int | Layer [get]
Generated on Tue Dec 15 2015 18:14:34 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • IShape
Deltares.Standard.Forms.IShape Member List

This is the complete list of members for Deltares.Standard.Forms.IShape, including all inherited members.

AllowDrop(object data) (defined in Deltares.Standard.Forms.IShape) | Deltares.Standard.Forms.IShape
BeginMove(IProjection projection, Point2D startPosition) (defined in Deltares.Standard.Forms.IShape) | Deltares.Standard.Forms.IShape
ContainsPoint(IProjection projection, Point point) (defined in Deltares.Standard.Forms.IShape) | Deltares.Standard.Forms.IShape
DataItemAt(Point point, Projection projection) (defined in Deltares.Standard.Forms.IShape) | Deltares.Standard.Forms.IShape
DataObject (defined in Deltares.Standard.Forms.IShape) | Deltares.Standard.Forms.IShape
Draw(GraphicsInfo info) (defined in Deltares.Standard.Forms.IShape) | Deltares.Standard.Forms.IShape
DrawLabel(GraphicsInfo info) (defined in Deltares.Standard.Forms.IShape) | Deltares.Standard.Forms.IShape
Drop(object data) (defined in Deltares.Standard.Forms.IShape) | Deltares.Standard.Forms.IShape
EndMove(IProjection projection, Point2D startPosition, SizeF worldSize) (defined in Deltares.Standard.Forms.IShape) | Deltares.Standard.Forms.IShape
GetCardinalDirectionOnEdgeContainingPoint(Point point) (defined in Deltares.Standard.Forms.IShape) | Deltares.Standard.Forms.IShape
GetExtents(IProjection projection) (defined in Deltares.Standard.Forms.IShape) | Deltares.Standard.Forms.IShape
Layer (defined in Deltares.Standard.Forms.IShape) | Deltares.Standard.Forms.IShape
Move(IProjection projection, Point2D startPosition, SizeF worldSize) (defined in Deltares.Standard.Forms.IShape) | Deltares.Standard.Forms.IShape
Generated on Tue Dec 15 2015 18:14:34 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.IViewConfiguration Interface Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • IViewConfiguration
Public Member Functions | List of all members
Deltares.Standard.Forms.IViewConfiguration Interface Reference

Contains the properties which will be shown as columns in the table. More...

Public Member Functions

string[] | GetColumns (Type columnType)
Gets the columns for the table. More...
string[] | GetChildren (Type columnType)
Tells which property to access for getting the sub data. More...
ColumnDescription | GetColumnDescription (Type columnType, string columnDescriptionString)
Gets the column description. More...

Detailed Description

Contains the properties which will be shown as columns in the table.

Member Function Documentation

string [] Deltares.Standard.Forms.IViewConfiguration.GetChildren ( Type columnType )

Tells which property to access for getting the sub data.

Parameters
columnType Gets the type.
Returns
returns string[]
ColumnDescription Deltares.Standard.Forms.IViewConfiguration.GetColumnDescription | ( | Type | columnType,
 |  | string | columnDescriptionString
 | ) |  |

Gets the column description.

Parameters
columnType | Gets the type.
columnDescriptionString | Gets the string.
Returns
returns ColumnDescription
string [] Deltares.Standard.Forms.IViewConfiguration.GetColumns ( Type columnType )

Gets the columns for the table.

Parameters
columnType Gets the column type.
Returns
returns string[]
Generated on Tue Dec 15 2015 18:14:34 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • IViewConfiguration
Deltares.Standard.Forms.IViewConfiguration Member List

This is the complete list of members for Deltares.Standard.Forms.IViewConfiguration, including all inherited members.

GetChildren(Type columnType) | Deltares.Standard.Forms.IViewConfiguration
GetColumnDescription(Type columnType, string columnDescriptionString) | Deltares.Standard.Forms.IViewConfiguration
GetColumns(Type columnType) | Deltares.Standard.Forms.IViewConfiguration
Generated on Tue Dec 15 2015 18:14:34 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.LegendItem Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • LegendItem
Public Member Functions | Properties | List of all members
Deltares.Standard.Forms.LegendItem Class Reference

Public Member Functions

LegendItem (Color color, string text)

Properties

Color | Color [get, set]
string | Text [get, set]
Generated on Tue Dec 15 2015 18:14:34 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • LegendItem
Deltares.Standard.Forms.LegendItem Member List

This is the complete list of members for Deltares.Standard.Forms.LegendItem, including all inherited members.

Color (defined in Deltares.Standard.Forms.LegendItem) | Deltares.Standard.Forms.LegendItem
LegendItem() (defined in Deltares.Standard.Forms.LegendItem) | Deltares.Standard.Forms.LegendItem
LegendItem(Color color, string text) (defined in Deltares.Standard.Forms.LegendItem) | Deltares.Standard.Forms.LegendItem
Text (defined in Deltares.Standard.Forms.LegendItem) | Deltares.Standard.Forms.LegendItem
Generated on Tue Dec 15 2015 18:14:34 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.LegendShape Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • LegendShape
Public Member Functions | Properties | List of all members
Deltares.Standard.Forms.LegendShape Class Reference
Inheritance diagram for Deltares.Standard.Forms.LegendShape:
Deltares.Standard.Forms.Shape Deltares.Standard.Forms.IShape

Public Member Functions

override bool | ContainsPoint (IProjection projection, Point point)
override Rectangle | GetExtents (IProjection projection)
override void | Draw (GraphicsInfo info)
- Public Member Functions inherited from Deltares.Standard.Forms.Shape
virtual void | AddPoint (Point2D point)
virtual IEnumerable< object > | DataItemAt (Point point, Projection projection)
virtual bool | AllowDrop (object data)
virtual void | Drop (object data)
virtual void | DrawLabel (GraphicsInfo info)
virtual void | Move (IProjection projection, Point2D startPosition, SizeF worldSize)
virtual void | BeginMove (IProjection projection, Point2D startPosition)
virtual CardinalDirection | GetCardinalDirectionOnEdgeContainingPoint (Point point)
virtual void | EndMove (IProjection projection, Point2D startPosition, SizeF worldSize)

Properties

List< LegendItem > | LegendItems [get, set]
override object | DataObject [get, set]
- Properties inherited from Deltares.Standard.Forms.Shape
Point | Location [get, set]
Size | Size [get, set]
virtual bool | CanResize [get]
Color | ForeColor [get, set]
Color | BackColor [get, set]
IProjection | CoordinateSystem [get, set]
Point2D | WorldLocation [get, set]
SizeF | WorldSize [get, set]
virtual int | Layer [get, set]
virtual object | DataObject [get, set]
- Properties inherited from Deltares.Standard.Forms.IShape
object | DataObject [get, set]
int | Layer [get]

Additional Inherited Members

- Protected Attributes inherited from Deltares.Standard.Forms.Shape
GraphicsPath path = null
Generated on Tue Dec 15 2015 18:14:34 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • LegendShape
Deltares.Standard.Forms.LegendShape Member List

This is the complete list of members for Deltares.Standard.Forms.LegendShape, including all inherited members.

AddPoint(Point2D point) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
AllowDrop(object data) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
BackColor (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
BeginMove(IProjection projection, Point2D startPosition) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
CanResize (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
ContainsPoint(IProjection projection, Point point) (defined in Deltares.Standard.Forms.LegendShape) | Deltares.Standard.Forms.LegendShape | virtual
CoordinateSystem (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
DataItemAt(Point point, Projection projection) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
DataObject (defined in Deltares.Standard.Forms.LegendShape) | Deltares.Standard.Forms.LegendShape |
Draw(GraphicsInfo info) (defined in Deltares.Standard.Forms.LegendShape) | Deltares.Standard.Forms.LegendShape | virtual
DrawLabel(GraphicsInfo info) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
Drop(object data) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
EndMove(IProjection projection, Point2D startPosition, SizeF worldSize) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
ForeColor (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
GetCardinalDirectionOnEdgeContainingPoint(Point point) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
GetExtents(IProjection projection) (defined in Deltares.Standard.Forms.LegendShape) | Deltares.Standard.Forms.LegendShape | virtual
Layer (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
LegendItems (defined in Deltares.Standard.Forms.LegendShape) | Deltares.Standard.Forms.LegendShape |
LegendShape() (defined in Deltares.Standard.Forms.LegendShape) | Deltares.Standard.Forms.LegendShape |
Location (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
Move(IProjection projection, Point2D startPosition, SizeF worldSize) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
path (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | protected
Shape() (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
Size (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
WorldLocation (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
WorldSize (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
Generated on Tue Dec 15 2015 18:14:34 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.MatrixViewer Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • MatrixViewer
Public Member Functions | Protected Member Functions | Properties | List of all members
Deltares.Standard.Forms.MatrixViewer Class Reference
Inheritance diagram for Deltares.Standard.Forms.MatrixViewer:

Public Member Functions

void UpdateGrid ()

Protected Member Functions

override void Dispose (bool disposing)
Clean up any resources being used. More...

Properties

object[,] | Source [get, set]
int | FirstColumn [get, set]
int | FirstRow [get, set]
Color | FirstColor [get, set]
Color | LastColor [get, set]
double | FirstColorMatch [get, set]
double | LastColorMatch [get, set]
DataGridView | DataGridView [get]

Member Function Documentation

override void Deltares.Standard.Forms.MatrixViewer.Dispose ( bool disposing )
protected

Clean up any resources being used.

Parameters
disposing true if managed resources should be disposed; otherwise, false.
Generated on Tue Dec 15 2015 18:14:34 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • MatrixViewer
Deltares.Standard.Forms.MatrixViewer Member List

This is the complete list of members for Deltares.Standard.Forms.MatrixViewer, including all inherited members.

DataGridView (defined in Deltares.Standard.Forms.MatrixViewer) | Deltares.Standard.Forms.MatrixViewer |
Dispose(bool disposing) | Deltares.Standard.Forms.MatrixViewer | protected
FirstColor (defined in Deltares.Standard.Forms.MatrixViewer) | Deltares.Standard.Forms.MatrixViewer |
FirstColorMatch (defined in Deltares.Standard.Forms.MatrixViewer) | Deltares.Standard.Forms.MatrixViewer |
FirstColumn (defined in Deltares.Standard.Forms.MatrixViewer) | Deltares.Standard.Forms.MatrixViewer |
FirstRow (defined in Deltares.Standard.Forms.MatrixViewer) | Deltares.Standard.Forms.MatrixViewer |
LastColor (defined in Deltares.Standard.Forms.MatrixViewer) | Deltares.Standard.Forms.MatrixViewer |
LastColorMatch (defined in Deltares.Standard.Forms.MatrixViewer) | Deltares.Standard.Forms.MatrixViewer |
MatrixViewer() (defined in Deltares.Standard.Forms.MatrixViewer) | Deltares.Standard.Forms.MatrixViewer |
Source (defined in Deltares.Standard.Forms.MatrixViewer) | Deltares.Standard.Forms.MatrixViewer |
UpdateGrid() (defined in Deltares.Standard.Forms.MatrixViewer) | Deltares.Standard.Forms.MatrixViewer |
Generated on Tue Dec 15 2015 18:14:34 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.MessageBoxManager Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • MessageBoxManager
Classes | Static Public Member Functions | Static Public Attributes | List of all members
Deltares.Standard.Forms.MessageBoxManager Class Reference

Classes

struct CWPRETSTRUCT

Static Public Member Functions

static void | Register ()
Enables MessageBoxManager functionality More...
static void | Unregister ()
Disables MessageBoxManager functionality More...

Static Public Attributes

static string | OK = "&OK"
OK text More...
static string | Cancel = "&Cancel"
Cancel text More...
static string | Abort = "&Abort"
Abort text More...
static string | Retry = "&Retry"
Retry text More...
static string | Ignore = "&Ignore"
Ignore text More...
static string | Yes = "&Yes"
Yes text More...
static string | No = "&No"
No text More...

Member Function Documentation

static void Deltares.Standard.Forms.MessageBoxManager.Register ( )
static

Enables MessageBoxManager functionality

MessageBoxManager functionality is enabled on current thread only. Each thread that needs MessageBoxManager functionality has to call this method.

static void Deltares.Standard.Forms.MessageBoxManager.Unregister ( )
static

Disables MessageBoxManager functionality

Disables MessageBoxManager functionality on current thread only.

Member Data Documentation

string Deltares.Standard.Forms.MessageBoxManager.Abort = "&Abort"
static

Abort text

string Deltares.Standard.Forms.MessageBoxManager.Cancel = "&Cancel"
static

Cancel text

string Deltares.Standard.Forms.MessageBoxManager.Ignore = "&Ignore"
static

Ignore text

string Deltares.Standard.Forms.MessageBoxManager.No = "&No"
static

No text

string Deltares.Standard.Forms.MessageBoxManager.OK = "&OK"
static

OK text

string Deltares.Standard.Forms.MessageBoxManager.Retry = "&Retry"
static

Retry text

string Deltares.Standard.Forms.MessageBoxManager.Yes = "&Yes"
static

Yes text

Generated on Tue Dec 15 2015 18:14:34 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • MessageBoxManager
Deltares.Standard.Forms.MessageBoxManager Member List

This is the complete list of members for Deltares.Standard.Forms.MessageBoxManager, including all inherited members.

Abort | Deltares.Standard.Forms.MessageBoxManager | static
Cancel | Deltares.Standard.Forms.MessageBoxManager | static
Ignore | Deltares.Standard.Forms.MessageBoxManager | static
No | Deltares.Standard.Forms.MessageBoxManager | static
OK | Deltares.Standard.Forms.MessageBoxManager | static
Register() | Deltares.Standard.Forms.MessageBoxManager | static
Retry | Deltares.Standard.Forms.MessageBoxManager | static
Unregister() | Deltares.Standard.Forms.MessageBoxManager | static
Yes | Deltares.Standard.Forms.MessageBoxManager | static
Generated on Tue Dec 15 2015 18:14:34 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.MessageBoxManager.CWPRETSTRUCT Struct Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • MessageBoxManager
  • CWPRETSTRUCT
Public Attributes | List of all members
Deltares.Standard.Forms.MessageBoxManager.CWPRETSTRUCT Struct Reference

Public Attributes

IntPtr | lResult
IntPtr | lParam
IntPtr | wParam
uint | message
IntPtr | hwnd
Generated on Tue Dec 15 2015 18:14:34 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • MessageBoxManager
  • CWPRETSTRUCT
Deltares.Standard.Forms.MessageBoxManager.CWPRETSTRUCT Member List

This is the complete list of members for Deltares.Standard.Forms.MessageBoxManager.CWPRETSTRUCT, including all inherited members.

hwnd (defined in Deltares.Standard.Forms.MessageBoxManager.CWPRETSTRUCT) | Deltares.Standard.Forms.MessageBoxManager.CWPRETSTRUCT
lParam (defined in Deltares.Standard.Forms.MessageBoxManager.CWPRETSTRUCT) | Deltares.Standard.Forms.MessageBoxManager.CWPRETSTRUCT
lResult (defined in Deltares.Standard.Forms.MessageBoxManager.CWPRETSTRUCT) | Deltares.Standard.Forms.MessageBoxManager.CWPRETSTRUCT
message (defined in Deltares.Standard.Forms.MessageBoxManager.CWPRETSTRUCT) | Deltares.Standard.Forms.MessageBoxManager.CWPRETSTRUCT
wParam (defined in Deltares.Standard.Forms.MessageBoxManager.CWPRETSTRUCT) | Deltares.Standard.Forms.MessageBoxManager.CWPRETSTRUCT
Generated on Tue Dec 15 2015 18:14:34 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.Messenger Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • Messenger
Static Public Member Functions | Properties | List of all members
Deltares.Standard.Forms.Messenger Class Reference

Wrapper around MessageBox, allowing messages to be send via console or message box itself. More...

Static Public Member Functions

static DialogResult | Show (string message, string caption)
static DialogResult | Show (string message, string caption, MessageBoxButtons ok, MessageBoxIcon information)
static DialogResult | Show (string message)

Properties

static bool RerouteMessageBoxMessages [get, set]
Reroute message box messages to console out if true. More...

Detailed Description

Wrapper around MessageBox, allowing messages to be send via console or message box itself.

Property Documentation

bool Deltares.Standard.Forms.Messenger.RerouteMessageBoxMessages
staticgetset

Reroute message box messages to console out if true.

Generated on Tue Dec 15 2015 18:14:34 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • Messenger
Deltares.Standard.Forms.Messenger Member List

This is the complete list of members for Deltares.Standard.Forms.Messenger, including all inherited members.

RerouteMessageBoxMessages | Deltares.Standard.Forms.Messenger | static
Show(string message, string caption) (defined in Deltares.Standard.Forms.Messenger) | Deltares.Standard.Forms.Messenger | static
Show(string message, string caption, MessageBoxButtons ok, MessageBoxIcon information) (defined in Deltares.Standard.Forms.Messenger) | Deltares.Standard.Forms.Messenger | static
Show(string message) (defined in Deltares.Standard.Forms.Messenger) | Deltares.Standard.Forms.Messenger | static
Generated on Tue Dec 15 2015 18:14:34 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.PolygonShape Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • PolygonShape
Public Member Functions | Properties | List of all members
Deltares.Standard.Forms.PolygonShape Class Reference
Inheritance diagram for Deltares.Standard.Forms.PolygonShape:
Deltares.Standard.Forms.Shape Deltares.Standard.Forms.IShape

Public Member Functions

PolygonShape (Color color)
override bool | ContainsPoint (IProjection projection, Point point)
override Rectangle | GetExtents (IProjection projection)
override void | Draw (GraphicsInfo info)
- Public Member Functions inherited from Deltares.Standard.Forms.Shape
virtual void | AddPoint (Point2D point)
virtual IEnumerable< object > | DataItemAt (Point point, Projection projection)
virtual bool | AllowDrop (object data)
virtual void | Drop (object data)
virtual void | DrawLabel (GraphicsInfo info)
virtual void | Move (IProjection projection, Point2D startPosition, SizeF worldSize)
virtual void | BeginMove (IProjection projection, Point2D startPosition)
virtual CardinalDirection | GetCardinalDirectionOnEdgeContainingPoint (Point point)
virtual void | EndMove (IProjection projection, Point2D startPosition, SizeF worldSize)

Properties

Color | Color [get, set]
List< Point > | Points [get]
bool | Visible [get, set]
- Properties inherited from Deltares.Standard.Forms.Shape
Point | Location [get, set]
Size | Size [get, set]
virtual bool | CanResize [get]
Color | ForeColor [get, set]
Color | BackColor [get, set]
IProjection | CoordinateSystem [get, set]
Point2D | WorldLocation [get, set]
SizeF | WorldSize [get, set]
virtual int | Layer [get, set]
virtual object | DataObject [get, set]
- Properties inherited from Deltares.Standard.Forms.IShape
object | DataObject [get, set]
int | Layer [get]

Additional Inherited Members

- Protected Attributes inherited from Deltares.Standard.Forms.Shape
GraphicsPath path = null
Generated on Tue Dec 15 2015 18:14:35 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • PolygonShape
Deltares.Standard.Forms.PolygonShape Member List

This is the complete list of members for Deltares.Standard.Forms.PolygonShape, including all inherited members.

AddPoint(Point2D point) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
AllowDrop(object data) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
BackColor (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
BeginMove(IProjection projection, Point2D startPosition) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
CanResize (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
Color (defined in Deltares.Standard.Forms.PolygonShape) | Deltares.Standard.Forms.PolygonShape |
ContainsPoint(IProjection projection, Point point) (defined in Deltares.Standard.Forms.PolygonShape) | Deltares.Standard.Forms.PolygonShape | virtual
CoordinateSystem (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
DataItemAt(Point point, Projection projection) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
DataObject (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
Draw(GraphicsInfo info) (defined in Deltares.Standard.Forms.PolygonShape) | Deltares.Standard.Forms.PolygonShape | virtual
DrawLabel(GraphicsInfo info) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
Drop(object data) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
EndMove(IProjection projection, Point2D startPosition, SizeF worldSize) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
ForeColor (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
GetCardinalDirectionOnEdgeContainingPoint(Point point) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
GetExtents(IProjection projection) (defined in Deltares.Standard.Forms.PolygonShape) | Deltares.Standard.Forms.PolygonShape | virtual
Layer (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
Location (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
Move(IProjection projection, Point2D startPosition, SizeF worldSize) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
path (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | protected
Points (defined in Deltares.Standard.Forms.PolygonShape) | Deltares.Standard.Forms.PolygonShape |
PolygonShape(Color color) (defined in Deltares.Standard.Forms.PolygonShape) | Deltares.Standard.Forms.PolygonShape |
Shape() (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
Size (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
Visible (defined in Deltares.Standard.Forms.PolygonShape) | Deltares.Standard.Forms.PolygonShape |
WorldLocation (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
WorldSize (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
Generated on Tue Dec 15 2015 18:14:35 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.PolylineShape Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • PolylineShape
Public Member Functions | Properties | List of all members
Deltares.Standard.Forms.PolylineShape Class Reference
Inheritance diagram for Deltares.Standard.Forms.PolylineShape:
Deltares.Standard.Forms.Shape Deltares.Standard.Forms.IShape

Public Member Functions

override void | Draw (GraphicsInfo info)
override void | AddPoint (Point2D point)
override void | Move (IProjection projection, Point2D startPosition, SizeF worldSize)
- Public Member Functions inherited from Deltares.Standard.Forms.Shape
virtual IEnumerable< object > | DataItemAt (Point point, Projection projection)
virtual bool | AllowDrop (object data)
virtual void | Drop (object data)
virtual bool | ContainsPoint (IProjection projection, Point point)
virtual Rectangle | GetExtents (IProjection projection)
virtual void | DrawLabel (GraphicsInfo info)
virtual void | BeginMove (IProjection projection, Point2D startPosition)
virtual CardinalDirection | GetCardinalDirectionOnEdgeContainingPoint (Point point)
virtual void | EndMove (IProjection projection, Point2D startPosition, SizeF worldSize)

Properties

override bool | CanResize [get]
- Properties inherited from Deltares.Standard.Forms.Shape
Point | Location [get, set]
Size | Size [get, set]
virtual bool | CanResize [get]
Color | ForeColor [get, set]
Color | BackColor [get, set]
IProjection | CoordinateSystem [get, set]
Point2D | WorldLocation [get, set]
SizeF | WorldSize [get, set]
virtual int | Layer [get, set]
virtual object | DataObject [get, set]
- Properties inherited from Deltares.Standard.Forms.IShape
object | DataObject [get, set]
int | Layer [get]

Additional Inherited Members

- Protected Attributes inherited from Deltares.Standard.Forms.Shape
GraphicsPath path = null
Generated on Tue Dec 15 2015 18:14:35 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • PolylineShape
Deltares.Standard.Forms.PolylineShape Member List

This is the complete list of members for Deltares.Standard.Forms.PolylineShape, including all inherited members.

AddPoint(Point2D point) (defined in Deltares.Standard.Forms.PolylineShape) | Deltares.Standard.Forms.PolylineShape | virtual
AllowDrop(object data) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
BackColor (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
BeginMove(IProjection projection, Point2D startPosition) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
CanResize (defined in Deltares.Standard.Forms.PolylineShape) | Deltares.Standard.Forms.PolylineShape |
ContainsPoint(IProjection projection, Point point) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
CoordinateSystem (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
DataItemAt(Point point, Projection projection) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
DataObject (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
Draw(GraphicsInfo info) (defined in Deltares.Standard.Forms.PolylineShape) | Deltares.Standard.Forms.PolylineShape | virtual
DrawLabel(GraphicsInfo info) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
Drop(object data) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
EndMove(IProjection projection, Point2D startPosition, SizeF worldSize) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
ForeColor (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
GetCardinalDirectionOnEdgeContainingPoint(Point point) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
GetExtents(IProjection projection) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
Layer (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
Location (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
Move(IProjection projection, Point2D startPosition, SizeF worldSize) (defined in Deltares.Standard.Forms.PolylineShape) | Deltares.Standard.Forms.PolylineShape | virtual
path (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | protected
PolylineShape() (defined in Deltares.Standard.Forms.PolylineShape) | Deltares.Standard.Forms.PolylineShape |
Shape() (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
Size (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
WorldLocation (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
WorldSize (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
Generated on Tue Dec 15 2015 18:14:35 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.Presenter Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • Presenter
Public Member Functions | Properties | List of all members
Deltares.Standard.Forms.Presenter Class Reference

Public Member Functions

virtual void | Register (Control control, string path)
virtual void | UpdateControl (Control control, string path)

Properties

virtual IPresentable Source [get, set]
Generated on Tue Dec 15 2015 18:14:35 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • Presenter
Deltares.Standard.Forms.Presenter Member List

This is the complete list of members for Deltares.Standard.Forms.Presenter, including all inherited members.

Presenter() (defined in Deltares.Standard.Forms.Presenter) | Deltares.Standard.Forms.Presenter |
Register(Control control, string path) (defined in Deltares.Standard.Forms.Presenter) | Deltares.Standard.Forms.Presenter | virtual
Source (defined in Deltares.Standard.Forms.Presenter) | Deltares.Standard.Forms.Presenter |
UpdateControl(Control control, string path) (defined in Deltares.Standard.Forms.Presenter) | Deltares.Standard.Forms.Presenter | virtual
Generated on Tue Dec 15 2015 18:14:35 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.ProgramSettings Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • ProgramSettings
Public Member Functions | Static Public Member Functions | Properties | List of all members
Deltares.Standard.Forms.ProgramSettings Class Reference
Inheritance diagram for Deltares.Standard.Forms.ProgramSettings:

Public Member Functions

void | UpdateSettingsFileOnClose ()
IList< string > | GetSettingsOnLoad ()
void | SetStartUpFilePath ()
bool | IsVisible (string property)
bool | IsEnabled (string property)

Static Public Member Functions

static bool | IsInitialUnitUsage ()
static void | LoadUserUnitValues ()
static void | SaveUserUnitValues ()

Properties

bool | AllowLanguageSelection [get, set]
bool | AllowMultiCoreSelection [get, set]
Select whether multi core can be set via the settings dialog. More...
string | ReportLanguageItem [get, set]
List< string > | MRUFilePathList [get]
int | DXSkinSelectedIndex [get, set]
bool | IsWindowsColorRadioButtonSelected [get, set]
bool | IsUserDefinedColorRadioButtonSelected [get, set]
string | InterfaceLanguage [get, set]
string | LastSavedProject [get, set]
bool | ModifiedFlag [get, set]
bool | ShowLicenseAtStartUp [get, set]
int | OpenFileFiterIndex [get, set]
bool | IsApplicationFirstRun [get, set]
LanguageType | Language [get, set]
int | MaxCalculationCores [get, set]
ProjectStartMode | ProjectStartMode [get, set]
string | TranslationsDirectory [get, set]

Property Documentation

bool Deltares.Standard.Forms.ProgramSettings.AllowMultiCoreSelection
getset

Select whether multi core can be set via the settings dialog.

Generated on Tue Dec 15 2015 18:14:35 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • ProgramSettings
Deltares.Standard.Forms.ProgramSettings Member List

This is the complete list of members for Deltares.Standard.Forms.ProgramSettings, including all inherited members.

AllowLanguageSelection (defined in Deltares.Standard.Forms.ProgramSettings) | Deltares.Standard.Forms.ProgramSettings |
AllowMultiCoreSelection | Deltares.Standard.Forms.ProgramSettings |
DXSkinSelectedIndex (defined in Deltares.Standard.Forms.ProgramSettings) | Deltares.Standard.Forms.ProgramSettings |
GetSettingsOnLoad() (defined in Deltares.Standard.Forms.ProgramSettings) | Deltares.Standard.Forms.ProgramSettings |
InterfaceLanguage (defined in Deltares.Standard.Forms.ProgramSettings) | Deltares.Standard.Forms.ProgramSettings |
IsApplicationFirstRun (defined in Deltares.Standard.Forms.ProgramSettings) | Deltares.Standard.Forms.ProgramSettings |
IsEnabled(string property) (defined in Deltares.Standard.Forms.ProgramSettings) | Deltares.Standard.Forms.ProgramSettings |
IsInitialUnitUsage() (defined in Deltares.Standard.Forms.ProgramSettings) | Deltares.Standard.Forms.ProgramSettings | static
IsUserDefinedColorRadioButtonSelected (defined in Deltares.Standard.Forms.ProgramSettings) | Deltares.Standard.Forms.ProgramSettings |
IsVisible(string property) (defined in Deltares.Standard.Forms.ProgramSettings) | Deltares.Standard.Forms.ProgramSettings |
IsWindowsColorRadioButtonSelected (defined in Deltares.Standard.Forms.ProgramSettings) | Deltares.Standard.Forms.ProgramSettings |
Language (defined in Deltares.Standard.Forms.ProgramSettings) | Deltares.Standard.Forms.ProgramSettings |
LastSavedProject (defined in Deltares.Standard.Forms.ProgramSettings) | Deltares.Standard.Forms.ProgramSettings |
LoadUserUnitValues() (defined in Deltares.Standard.Forms.ProgramSettings) | Deltares.Standard.Forms.ProgramSettings | static
MaxCalculationCores (defined in Deltares.Standard.Forms.ProgramSettings) | Deltares.Standard.Forms.ProgramSettings |
ModifiedFlag (defined in Deltares.Standard.Forms.ProgramSettings) | Deltares.Standard.Forms.ProgramSettings |
MRUFilePathList (defined in Deltares.Standard.Forms.ProgramSettings) | Deltares.Standard.Forms.ProgramSettings |
OpenFileFiterIndex (defined in Deltares.Standard.Forms.ProgramSettings) | Deltares.Standard.Forms.ProgramSettings |
ProgramSettings() (defined in Deltares.Standard.Forms.ProgramSettings) | Deltares.Standard.Forms.ProgramSettings |
ProjectStartMode (defined in Deltares.Standard.Forms.ProgramSettings) | Deltares.Standard.Forms.ProgramSettings |
ReportLanguageItem (defined in Deltares.Standard.Forms.ProgramSettings) | Deltares.Standard.Forms.ProgramSettings |
SaveUserUnitValues() (defined in Deltares.Standard.Forms.ProgramSettings) | Deltares.Standard.Forms.ProgramSettings | static
SetStartUpFilePath() (defined in Deltares.Standard.Forms.ProgramSettings) | Deltares.Standard.Forms.ProgramSettings |
ShowLicenseAtStartUp (defined in Deltares.Standard.Forms.ProgramSettings) | Deltares.Standard.Forms.ProgramSettings |
TranslationsDirectory (defined in Deltares.Standard.Forms.ProgramSettings) | Deltares.Standard.Forms.ProgramSettings |
UpdateSettingsFileOnClose() (defined in Deltares.Standard.Forms.ProgramSettings) | Deltares.Standard.Forms.ProgramSettings |
Generated on Tue Dec 15 2015 18:14:35 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.ProgressBarWithText Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • ProgressBarWithText
Public Types | Public Member Functions | Protected Member Functions | Properties | List of all members
Deltares.Standard.Forms.ProgressBarWithText Class Reference
Inheritance diagram for Deltares.Standard.Forms.ProgressBarWithText:

Public Types

enum AnnotationType { Percentage, CustomText, None }

Public Member Functions

ProgressBarWithText (AnnotationType type=AnnotationType.Percentage, Font font=null)
void | Increment (int step)
void | PerformStep ()
double | ProgressBarPercentageCompleted ()

Protected Member Functions

override void | OnPaint (PaintEventArgs e)
override void | Dispose (bool disposing)
Clean up any resources being used. More...

Properties

int | Value [get, set]
int | Minimum [get, set]
int | Maximum [get, set]
int | Step [get, set]
AnnotationType | LabelAnnotationType [get, set]
Font | AnnotationFont [get, set]
string | AnnotationText [get, set]
ContentAlignment | AnnotationFontAlignment [get, set]

Member Function Documentation

override void Deltares.Standard.Forms.ProgressBarWithText.Dispose ( bool disposing )
protected

Clean up any resources being used.

Parameters
disposing true if managed resources should be disposed; otherwise, false.
Generated on Tue Dec 15 2015 18:14:35 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • ProgressBarWithText
Deltares.Standard.Forms.ProgressBarWithText Member List

This is the complete list of members for Deltares.Standard.Forms.ProgressBarWithText, including all inherited members.

AnnotationFont (defined in Deltares.Standard.Forms.ProgressBarWithText) | Deltares.Standard.Forms.ProgressBarWithText |
AnnotationFontAlignment (defined in Deltares.Standard.Forms.ProgressBarWithText) | Deltares.Standard.Forms.ProgressBarWithText |
AnnotationText (defined in Deltares.Standard.Forms.ProgressBarWithText) | Deltares.Standard.Forms.ProgressBarWithText |
AnnotationType enum name (defined in Deltares.Standard.Forms.ProgressBarWithText) | Deltares.Standard.Forms.ProgressBarWithText |
Dispose(bool disposing) | Deltares.Standard.Forms.ProgressBarWithText | protected
Increment(int step) (defined in Deltares.Standard.Forms.ProgressBarWithText) | Deltares.Standard.Forms.ProgressBarWithText |
LabelAnnotationType (defined in Deltares.Standard.Forms.ProgressBarWithText) | Deltares.Standard.Forms.ProgressBarWithText |
Maximum (defined in Deltares.Standard.Forms.ProgressBarWithText) | Deltares.Standard.Forms.ProgressBarWithText |
Minimum (defined in Deltares.Standard.Forms.ProgressBarWithText) | Deltares.Standard.Forms.ProgressBarWithText |
OnPaint(PaintEventArgs e) (defined in Deltares.Standard.Forms.ProgressBarWithText) | Deltares.Standard.Forms.ProgressBarWithText | protected
PerformStep() (defined in Deltares.Standard.Forms.ProgressBarWithText) | Deltares.Standard.Forms.ProgressBarWithText |
ProgressBarPercentageCompleted() (defined in Deltares.Standard.Forms.ProgressBarWithText) | Deltares.Standard.Forms.ProgressBarWithText |
ProgressBarWithText() (defined in Deltares.Standard.Forms.ProgressBarWithText) | Deltares.Standard.Forms.ProgressBarWithText |
ProgressBarWithText(AnnotationType type=AnnotationType.Percentage, Font font=null) (defined in Deltares.Standard.Forms.ProgressBarWithText) | Deltares.Standard.Forms.ProgressBarWithText |
Step (defined in Deltares.Standard.Forms.ProgressBarWithText) | Deltares.Standard.Forms.ProgressBarWithText |
Value (defined in Deltares.Standard.Forms.ProgressBarWithText) | Deltares.Standard.Forms.ProgressBarWithText |
Generated on Tue Dec 15 2015 18:14:35 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.Projection Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • Projection
Public Member Functions | Properties | Events | List of all members
Deltares.Standard.Forms.Projection Class Reference
Inheritance diagram for Deltares.Standard.Forms.Projection:
Deltares.Standard.Forms.IProjection

Public Member Functions

void | Apply ()
Point | ConvertToScreen (Point2D worldPoint)
Point2D | ConvertToWorld (Point screenPoint)
Size | ConvertToScreen (SizeF worldSize)
SizeF | ConvertToWorld (Size screenSize)

Properties

float | XFactor [get, set]
float | YFactor [get, set]
float | XOffset [get, set]
float | YOffset [get, set]

Events

EventHandler | CoordinateSystemChanged
- Events inherited from Deltares.Standard.Forms.IProjection
EventHandler | CoordinateSystemChanged
Generated on Tue Dec 15 2015 18:14:36 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • Projection
Deltares.Standard.Forms.Projection Member List

This is the complete list of members for Deltares.Standard.Forms.Projection, including all inherited members.

Apply() (defined in Deltares.Standard.Forms.Projection) | Deltares.Standard.Forms.Projection
ConvertToScreen(Point2D worldPoint) (defined in Deltares.Standard.Forms.Projection) | Deltares.Standard.Forms.Projection
ConvertToScreen(SizeF worldSize) (defined in Deltares.Standard.Forms.Projection) | Deltares.Standard.Forms.Projection
ConvertToWorld(Point screenPoint) (defined in Deltares.Standard.Forms.Projection) | Deltares.Standard.Forms.Projection
ConvertToWorld(Size screenSize) (defined in Deltares.Standard.Forms.Projection) | Deltares.Standard.Forms.Projection
CoordinateSystemChanged (defined in Deltares.Standard.Forms.Projection) | Deltares.Standard.Forms.Projection
Projection() (defined in Deltares.Standard.Forms.Projection) | Deltares.Standard.Forms.Projection
XFactor (defined in Deltares.Standard.Forms.Projection) | Deltares.Standard.Forms.Projection
XOffset (defined in Deltares.Standard.Forms.Projection) | Deltares.Standard.Forms.Projection
YFactor (defined in Deltares.Standard.Forms.Projection) | Deltares.Standard.Forms.Projection
YOffset (defined in Deltares.Standard.Forms.Projection) | Deltares.Standard.Forms.Projection
Generated on Tue Dec 15 2015 18:14:36 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.RealTimeBackgroundValidator Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • RealTimeBackgroundValidator
Classes | Public Member Functions | Static Public Attributes | Properties | List of all members
Deltares.Standard.Forms.RealTimeBackgroundValidator Class Reference
Inheritance diagram for Deltares.Standard.Forms.RealTimeBackgroundValidator:

Public Member Functions

void | Dispose ()
void | Register (params object[] source)
Register a data source so the validator will run validation for it on a background thread. More...
void | Start ()
Start validation on the registered sources More...
void | Stop ()
Stop the validator if it is running and prevent it from responding to data events More...

Static Public Attributes

static readonly List< IValidationResult > | ValidationResults = new List<IValidationResult>()
static RealTimeBackgroundValidator | Instance = new RealTimeBackgroundValidator()
The instance which is bound to listen for events. More...

Properties

static bool | IsValidating [get]
Flag set to true during validation. More...
bool | IsUsed [get]
Flag which is true if one or more data sources have been registered. More...

Member Function Documentation

void Deltares.Standard.Forms.RealTimeBackgroundValidator.Register ( params object[] source )

Register a data source so the validator will run validation for it on a background thread.

Parameters
source
void Deltares.Standard.Forms.RealTimeBackgroundValidator.Start ( )

Start validation on the registered sources

Returns

Referenced by Deltares.DSoilModel.Data.DSoilModelProject.RepairAllValidationResults().

void Deltares.Standard.Forms.RealTimeBackgroundValidator.Stop ( )

Stop the validator if it is running and prevent it from responding to data events

Referenced by Deltares.DSoilModel.Data.DSoilModelProject.RepairAllValidationResults().

Member Data Documentation

RealTimeBackgroundValidator Deltares.Standard.Forms.RealTimeBackgroundValidator.Instance = new RealTimeBackgroundValidator()
static

The instance which is bound to listen for events.

Referenced by Deltares.DSoilModel.Data.DSoilModelProject.RepairAllValidationResults().

Property Documentation

bool Deltares.Standard.Forms.RealTimeBackgroundValidator.IsUsed
get

Flag which is true if one or more data sources have been registered.

bool Deltares.Standard.Forms.RealTimeBackgroundValidator.IsValidating
staticget

Flag set to true during validation.

Generated on Tue Dec 15 2015 18:14:36 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • RealTimeBackgroundValidator
Deltares.Standard.Forms.RealTimeBackgroundValidator Member List

This is the complete list of members for Deltares.Standard.Forms.RealTimeBackgroundValidator, including all inherited members.

Dispose() (defined in Deltares.Standard.Forms.RealTimeBackgroundValidator) | Deltares.Standard.Forms.RealTimeBackgroundValidator |
Instance | Deltares.Standard.Forms.RealTimeBackgroundValidator | static
IsUsed | Deltares.Standard.Forms.RealTimeBackgroundValidator |
IsValidating | Deltares.Standard.Forms.RealTimeBackgroundValidator | static
RealTimeBackgroundValidator() (defined in Deltares.Standard.Forms.RealTimeBackgroundValidator) | Deltares.Standard.Forms.RealTimeBackgroundValidator |
Register(params object[] source) | Deltares.Standard.Forms.RealTimeBackgroundValidator |
Start() | Deltares.Standard.Forms.RealTimeBackgroundValidator |
Stop() | Deltares.Standard.Forms.RealTimeBackgroundValidator |
ValidationResults (defined in Deltares.Standard.Forms.RealTimeBackgroundValidator) | Deltares.Standard.Forms.RealTimeBackgroundValidator | static
Generated on Tue Dec 15 2015 18:14:36 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.RectangleShape Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • RectangleShape
Public Member Functions | Properties | List of all members
Deltares.Standard.Forms.RectangleShape Class Reference
Inheritance diagram for Deltares.Standard.Forms.RectangleShape:
Deltares.Standard.Forms.Shape Deltares.Standard.Forms.IShape

Public Member Functions

RectangleShape (Color color)
override bool | ContainsPoint (IProjection projection, Point point)
override Rectangle | GetExtents (IProjection projection)
override void | Draw (GraphicsInfo info)
- Public Member Functions inherited from Deltares.Standard.Forms.Shape
virtual void | AddPoint (Point2D point)
virtual IEnumerable< object > | DataItemAt (Point point, Projection projection)
virtual bool | AllowDrop (object data)
virtual void | Drop (object data)
virtual void | DrawLabel (GraphicsInfo info)
virtual void | Move (IProjection projection, Point2D startPosition, SizeF worldSize)
virtual void | BeginMove (IProjection projection, Point2D startPosition)
virtual CardinalDirection | GetCardinalDirectionOnEdgeContainingPoint (Point point)
virtual void | EndMove (IProjection projection, Point2D startPosition, SizeF worldSize)

Properties

Color | Color [get, set]
Point | StartPoint [get, set]
Point | EndPoint [get, set]
bool | Visible [get, set]
- Properties inherited from Deltares.Standard.Forms.Shape
Point | Location [get, set]
Size | Size [get, set]
virtual bool | CanResize [get]
Color | ForeColor [get, set]
Color | BackColor [get, set]
IProjection | CoordinateSystem [get, set]
Point2D | WorldLocation [get, set]
SizeF | WorldSize [get, set]
virtual int | Layer [get, set]
virtual object | DataObject [get, set]
- Properties inherited from Deltares.Standard.Forms.IShape
object | DataObject [get, set]
int | Layer [get]

Additional Inherited Members

- Protected Attributes inherited from Deltares.Standard.Forms.Shape
GraphicsPath path = null
Generated on Tue Dec 15 2015 18:14:36 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • RectangleShape
Deltares.Standard.Forms.RectangleShape Member List

This is the complete list of members for Deltares.Standard.Forms.RectangleShape, including all inherited members.

AddPoint(Point2D point) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
AllowDrop(object data) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
BackColor (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
BeginMove(IProjection projection, Point2D startPosition) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
CanResize (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
Color (defined in Deltares.Standard.Forms.RectangleShape) | Deltares.Standard.Forms.RectangleShape |
ContainsPoint(IProjection projection, Point point) (defined in Deltares.Standard.Forms.RectangleShape) | Deltares.Standard.Forms.RectangleShape | virtual
CoordinateSystem (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
DataItemAt(Point point, Projection projection) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
DataObject (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
Draw(GraphicsInfo info) (defined in Deltares.Standard.Forms.RectangleShape) | Deltares.Standard.Forms.RectangleShape | virtual
DrawLabel(GraphicsInfo info) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
Drop(object data) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
EndMove(IProjection projection, Point2D startPosition, SizeF worldSize) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
EndPoint (defined in Deltares.Standard.Forms.RectangleShape) | Deltares.Standard.Forms.RectangleShape |
ForeColor (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
GetCardinalDirectionOnEdgeContainingPoint(Point point) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
GetExtents(IProjection projection) (defined in Deltares.Standard.Forms.RectangleShape) | Deltares.Standard.Forms.RectangleShape | virtual
Layer (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
Location (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
Move(IProjection projection, Point2D startPosition, SizeF worldSize) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
path (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | protected
RectangleShape(Color color) (defined in Deltares.Standard.Forms.RectangleShape) | Deltares.Standard.Forms.RectangleShape |
Shape() (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
Size (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
StartPoint (defined in Deltares.Standard.Forms.RectangleShape) | Deltares.Standard.Forms.RectangleShape |
Visible (defined in Deltares.Standard.Forms.RectangleShape) | Deltares.Standard.Forms.RectangleShape |
WorldLocation (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
WorldSize (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
Generated on Tue Dec 15 2015 18:14:36 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.Shape Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • Shape
Public Member Functions | Protected Attributes | Properties | List of all members
Deltares.Standard.Forms.Shape Class Reference
Inheritance diagram for Deltares.Standard.Forms.Shape:
Deltares.Standard.Forms.IShape Deltares.Standard.Forms.ArrowShape Deltares.Standard.Forms.AxesShape Deltares.Standard.Forms.EllipseShape Deltares.Standard.Forms.EmptyShape Deltares.Standard.Forms.InsertShape Deltares.Standard.Forms.LegendShape Deltares.Standard.Forms.PolygonShape Deltares.Standard.Forms.PolylineShape Deltares.Standard.Forms.RectangleShape Deltares.Standard.Forms.TestRectangleShape Deltares.Standard.Forms.TriangleShape

Public Member Functions

virtual void | AddPoint (Point2D point)
virtual IEnumerable< object > | DataItemAt (Point point, Projection projection)
virtual bool | AllowDrop (object data)
virtual void | Drop (object data)
virtual bool | ContainsPoint (IProjection projection, Point point)
virtual Rectangle | GetExtents (IProjection projection)
virtual void | Draw (GraphicsInfo info)
virtual void | DrawLabel (GraphicsInfo info)
virtual void | Move (IProjection projection, Point2D startPosition, SizeF worldSize)
virtual void | BeginMove (IProjection projection, Point2D startPosition)
virtual CardinalDirection | GetCardinalDirectionOnEdgeContainingPoint (Point point)
virtual void | EndMove (IProjection projection, Point2D startPosition, SizeF worldSize)

Protected Attributes

GraphicsPath path = null

Properties

Point | Location [get, set]
Size | Size [get, set]
virtual bool | CanResize [get]
Color | ForeColor [get, set]
Color | BackColor [get, set]
IProjection | CoordinateSystem [get, set]
Point2D | WorldLocation [get, set]
SizeF | WorldSize [get, set]
virtual int | Layer [get, set]
virtual object | DataObject [get, set]
- Properties inherited from Deltares.Standard.Forms.IShape
object | DataObject [get, set]
int | Layer [get]
Generated on Tue Dec 15 2015 18:14:37 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • Shape
Deltares.Standard.Forms.Shape Member List

This is the complete list of members for Deltares.Standard.Forms.Shape, including all inherited members.

AddPoint(Point2D point) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
AllowDrop(object data) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
BackColor (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
BeginMove(IProjection projection, Point2D startPosition) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
CanResize (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
ContainsPoint(IProjection projection, Point point) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
CoordinateSystem (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
DataItemAt(Point point, Projection projection) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
DataObject (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
Draw(GraphicsInfo info) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
DrawLabel(GraphicsInfo info) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
Drop(object data) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
EndMove(IProjection projection, Point2D startPosition, SizeF worldSize) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
ForeColor (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
GetCardinalDirectionOnEdgeContainingPoint(Point point) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
GetExtents(IProjection projection) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
Layer (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
Location (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
Move(IProjection projection, Point2D startPosition, SizeF worldSize) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
path (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | protected
Shape() (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
Size (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
WorldLocation (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
WorldSize (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
Generated on Tue Dec 15 2015 18:14:37 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.ShapeComparer Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • ShapeComparer
Public Member Functions | Properties | List of all members
Deltares.Standard.Forms.ShapeComparer Class Reference

Comparer class for Shapes More...

Inheritance diagram for Deltares.Standard.Forms.ShapeComparer:

Public Member Functions

int Compare (IShape x, IShape y)
Compares two shapes based on their areas More...

Properties

IProjection | CoordinateSystem [get, set]
Gets or sets the coordinate system. More...
List< IShape > | HoveredShapes [get, set]
List< IShape > | SelectedShapes [get, set]

Detailed Description

Comparer class for Shapes

Member Function Documentation

int Deltares.Standard.Forms.ShapeComparer.Compare | ( | IShape | x,
 |  | IShape | y
 | ) |  |

Compares two shapes based on their areas

Parameters
x | The first object to compare.
y | The second object to compare.

Property Documentation

IProjection Deltares.Standard.Forms.ShapeComparer.CoordinateSystem
getset

Gets or sets the coordinate system.

The coordinate system.

Generated on Tue Dec 15 2015 18:14:37 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • ShapeComparer
Deltares.Standard.Forms.ShapeComparer Member List

This is the complete list of members for Deltares.Standard.Forms.ShapeComparer, including all inherited members.

Compare(IShape x, IShape y) | Deltares.Standard.Forms.ShapeComparer
CoordinateSystem | Deltares.Standard.Forms.ShapeComparer
HoveredShapes (defined in Deltares.Standard.Forms.ShapeComparer) | Deltares.Standard.Forms.ShapeComparer
SelectedShapes (defined in Deltares.Standard.Forms.ShapeComparer) | Deltares.Standard.Forms.ShapeComparer
Generated on Tue Dec 15 2015 18:14:37 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.ShapeEventArgs Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • ShapeEventArgs
Public Member Functions | Properties | List of all members
Deltares.Standard.Forms.ShapeEventArgs Class Reference

Arguments for Shape Events More...

Inheritance diagram for Deltares.Standard.Forms.ShapeEventArgs:

Public Member Functions

ShapeEventArgs (IShape shape, ShapeAction action)
Initializes a new instance of the ShapeEventArgs class with given shape and action. More...
ShapeEventArgs (IShape shape, ShapeAction action, PointF worldPoint)
Initializes a new instance of the ShapeEventArgs class with given shape, action and world point. More...

Properties

IShape | Shape [get]
Gets the shape. More...
ShapeAction | Action [get]
Gets the action. More...
PointF | Point [get]
Gets the point. More...

Detailed Description

Arguments for Shape Events

Constructor & Destructor Documentation

Deltares.Standard.Forms.ShapeEventArgs.ShapeEventArgs | ( | IShape | shape,
 |  | ShapeAction | action
 | ) |  |

Initializes a new instance of the ShapeEventArgs class with given shape and action.

Deltares.Standard.Forms.ShapeEventArgs.ShapeEventArgs | ( | IShape | shape,
 |  | ShapeAction | action,
 |  | PointF | worldPoint
 | ) |  |

Initializes a new instance of the ShapeEventArgs class with given shape, action and world point.

Property Documentation

ShapeAction Deltares.Standard.Forms.ShapeEventArgs.Action
get

Gets the action.

The action.

PointF Deltares.Standard.Forms.ShapeEventArgs.Point
get

Gets the point.

The point.

IShape Deltares.Standard.Forms.ShapeEventArgs.Shape
get

Gets the shape.

The shape.

Generated on Tue Dec 15 2015 18:14:37 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • ShapeEventArgs
Deltares.Standard.Forms.ShapeEventArgs Member List

This is the complete list of members for Deltares.Standard.Forms.ShapeEventArgs, including all inherited members.

Action | Deltares.Standard.Forms.ShapeEventArgs
Point | Deltares.Standard.Forms.ShapeEventArgs
Shape | Deltares.Standard.Forms.ShapeEventArgs
ShapeEventArgs(IShape shape, ShapeAction action) | Deltares.Standard.Forms.ShapeEventArgs
ShapeEventArgs(IShape shape, ShapeAction action, PointF worldPoint) | Deltares.Standard.Forms.ShapeEventArgs
Generated on Tue Dec 15 2015 18:14:37 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.ShapeInfo Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • ShapeInfo
Public Member Functions | Properties | List of all members
Deltares.Standard.Forms.ShapeInfo Class Reference

Information about the Shape More...

Inheritance diagram for Deltares.Standard.Forms.ShapeInfo:

Public Member Functions

ShapeInfo ()
Parameterless constructor More...
bool | IsVisible ()
Determines whether this instance is visible. More...
bool | IsLabelVisible (bool selected)
Determines whether the label is visible. More...
bool | IsEnabled (string property)
Determines whether the specified property is enabled. More...
bool | IsVisible (string property)
Determines whether the specified property is visible. More...
int | CompareTo (object obj)
Compares the current instance with ShapeInfo object. More...

Properties

string | Name [get, set]
Gets or sets the name. More...
bool | Visible [get, set]
Gets or sets the visibility. More...
bool | LabelVisible [get, set]
Gets or sets if the label is visible. More...
bool | UserVisible [get, set]
Gets or sets a value indicating whether the user is visible. More...
bool | UserLabelVisible [get, set]
Gets or sets if the user label is visible. More...
SpatialEditor | SpatialEditor [get, set]
Gets or sets the spatial editor. More...
bool | AllowSelect [get, set]
Gets or sets a value indicating whether selecting is allowed. More...
bool | AllowHover [get, set]
Indicates if hovering is allowed More...
bool | AllowEdit [get, set]
Gets or sets a value indicating whether editing is allowed. More...
bool | AllowDelete [get, set]
Indicates whether an object can be deleted More...

Detailed Description

Information about the Shape

Constructor & Destructor Documentation

Deltares.Standard.Forms.ShapeInfo.ShapeInfo ( )

Parameterless constructor

Member Function Documentation

int Deltares.Standard.Forms.ShapeInfo.CompareTo ( object obj )

Compares the current instance with ShapeInfo object.

Parameters
obj An object to compare with this instance.
bool Deltares.Standard.Forms.ShapeInfo.IsEnabled ( string property )

Determines whether the specified property is enabled.

Parameters
property The property.
Returns
false for name, otherwise true
bool Deltares.Standard.Forms.ShapeInfo.IsLabelVisible ( bool selected )

Determines whether the label is visible.

Parameters
selected if set to true [selected].
Returns
bool Deltares.Standard.Forms.ShapeInfo.IsVisible ( )

Determines whether this instance is visible.

Returns
bool Deltares.Standard.Forms.ShapeInfo.IsVisible ( string property )

Determines whether the specified property is visible.

Parameters
property The property.
Returns

Property Documentation

bool Deltares.Standard.Forms.ShapeInfo.AllowDelete
getset

Indicates whether an object can be deleted

Referenced by Deltares.Standard.Forms.DExpress.GeometryEditor.IsEnabled().

bool Deltares.Standard.Forms.ShapeInfo.AllowEdit
getset

Gets or sets a value indicating whether editing is allowed.

Referenced by Deltares.DSoilModel.Forms.DSoilModelSegmentGeometryEditor.DSoilModelSegmentGeometryEditor().

bool Deltares.Standard.Forms.ShapeInfo.AllowHover
getset

Indicates if hovering is allowed

bool Deltares.Standard.Forms.ShapeInfo.AllowSelect
getset

Gets or sets a value indicating whether selecting is allowed.

Referenced by Deltares.DSoilModel.Forms.DSoilModelSegmentGeometryEditor.DSoilModelSegmentGeometryEditor().

bool Deltares.Standard.Forms.ShapeInfo.LabelVisible
getset

Gets or sets if the label is visible.

The label visibility.

Referenced by Deltares.Standard.Forms.SpatialEditor.CopyShapeInfos().

string Deltares.Standard.Forms.ShapeInfo.Name
getset

Gets or sets the name.

The name.

Referenced by Deltares.Standard.Forms.SpatialEditor.CopyShapeInfos().

SpatialEditor Deltares.Standard.Forms.ShapeInfo.SpatialEditor
getset

Gets or sets the spatial editor.

bool Deltares.Standard.Forms.ShapeInfo.UserLabelVisible
getset

Gets or sets if the user label is visible.

The user label visible.

bool Deltares.Standard.Forms.ShapeInfo.UserVisible
getset

Gets or sets a value indicating whether the user is visible.

true if [user visible]; otherwise, false.

bool Deltares.Standard.Forms.ShapeInfo.Visible
getset

Gets or sets the visibility.

The visible.

Referenced by Deltares.Standard.Forms.SpatialEditor.CopyShapeInfos().

Generated on Tue Dec 15 2015 18:14:37 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • ShapeInfo
Deltares.Standard.Forms.ShapeInfo Member List

This is the complete list of members for Deltares.Standard.Forms.ShapeInfo, including all inherited members.

AllowDelete | Deltares.Standard.Forms.ShapeInfo
AllowEdit | Deltares.Standard.Forms.ShapeInfo
AllowHover | Deltares.Standard.Forms.ShapeInfo
AllowSelect | Deltares.Standard.Forms.ShapeInfo
CompareTo(object obj) | Deltares.Standard.Forms.ShapeInfo
IsEnabled(string property) | Deltares.Standard.Forms.ShapeInfo
IsLabelVisible(bool selected) | Deltares.Standard.Forms.ShapeInfo
IsVisible() | Deltares.Standard.Forms.ShapeInfo
IsVisible(string property) | Deltares.Standard.Forms.ShapeInfo
LabelVisible | Deltares.Standard.Forms.ShapeInfo
Name | Deltares.Standard.Forms.ShapeInfo
ShapeInfo() | Deltares.Standard.Forms.ShapeInfo
SpatialEditor | Deltares.Standard.Forms.ShapeInfo
UserLabelVisible | Deltares.Standard.Forms.ShapeInfo
UserVisible | Deltares.Standard.Forms.ShapeInfo
Visible | Deltares.Standard.Forms.ShapeInfo
Generated on Tue Dec 15 2015 18:14:37 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.ShapesEventArgs Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • ShapesEventArgs
Public Member Functions | Properties | List of all members
Deltares.Standard.Forms.ShapesEventArgs Class Reference

Arguments for Collections of Shape Events More...

Inheritance diagram for Deltares.Standard.Forms.ShapesEventArgs:

Public Member Functions

ShapesEventArgs (IShape[] shapes)
Initializes a new instance of the ShapesEventArgs class. More...
ShapesEventArgs (Point mousePosition, Projection coordinateSystem, IShape[] shapes)
Initializes a new instance of the ShapesEventArgs class. More...

Properties

IShape[] | Shapes [get]
Gets the shapes. More...
Point | MousePosition [get]
Gets the mouse position. More...
Projection | Projection [get]
Gets the projection. More...

Detailed Description

Arguments for Collections of Shape Events

Constructor & Destructor Documentation

Deltares.Standard.Forms.ShapesEventArgs.ShapesEventArgs ( IShape[] shapes )

Initializes a new instance of the ShapesEventArgs class.

Parameters
shapes The shapes.
Deltares.Standard.Forms.ShapesEventArgs.ShapesEventArgs | ( | Point | mousePosition,
 |  | Projection | coordinateSystem,
 |  | IShape[] | shapes
 | ) |  |

Initializes a new instance of the ShapesEventArgs class.

Parameters
mousePosition | The mouse position.
coordinateSystem | The coordinate system.
shapes | The shapes.

Property Documentation

Point Deltares.Standard.Forms.ShapesEventArgs.MousePosition
get

Gets the mouse position.

The mouse position.

Projection Deltares.Standard.Forms.ShapesEventArgs.Projection
get

Gets the projection.

The projection.

IShape [] Deltares.Standard.Forms.ShapesEventArgs.Shapes
get

Gets the shapes.

The shapes.

Generated on Tue Dec 15 2015 18:14:38 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • ShapesEventArgs
Deltares.Standard.Forms.ShapesEventArgs Member List

This is the complete list of members for Deltares.Standard.Forms.ShapesEventArgs, including all inherited members.

MousePosition | Deltares.Standard.Forms.ShapesEventArgs
Projection | Deltares.Standard.Forms.ShapesEventArgs
Shapes | Deltares.Standard.Forms.ShapesEventArgs
ShapesEventArgs(IShape[] shapes) | Deltares.Standard.Forms.ShapesEventArgs
ShapesEventArgs(Point mousePosition, Projection coordinateSystem, IShape[] shapes) | Deltares.Standard.Forms.ShapesEventArgs
Generated on Tue Dec 15 2015 18:14:38 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.SourceProperty Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • SourceProperty
Public Member Functions | Properties | List of all members
Deltares.Standard.Forms.SourceProperty Class Reference

Public Member Functions

SourceProperty (object source, string property)
void | Update ()
override string | ToString ()

Properties

bool | IsVisible [get]
bool | IsEnabled [get]
object | Value [get]
string | Property [get]
object | Source [get]
Generated on Tue Dec 15 2015 18:14:38 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • SourceProperty
Deltares.Standard.Forms.SourceProperty Member List

This is the complete list of members for Deltares.Standard.Forms.SourceProperty, including all inherited members.

IsEnabled (defined in Deltares.Standard.Forms.SourceProperty) | Deltares.Standard.Forms.SourceProperty
IsVisible (defined in Deltares.Standard.Forms.SourceProperty) | Deltares.Standard.Forms.SourceProperty
Property (defined in Deltares.Standard.Forms.SourceProperty) | Deltares.Standard.Forms.SourceProperty
Source (defined in Deltares.Standard.Forms.SourceProperty) | Deltares.Standard.Forms.SourceProperty
SourceProperty(object source, string property) (defined in Deltares.Standard.Forms.SourceProperty) | Deltares.Standard.Forms.SourceProperty
ToString() (defined in Deltares.Standard.Forms.SourceProperty) | Deltares.Standard.Forms.SourceProperty
Update() (defined in Deltares.Standard.Forms.SourceProperty) | Deltares.Standard.Forms.SourceProperty
Value (defined in Deltares.Standard.Forms.SourceProperty) | Deltares.Standard.Forms.SourceProperty
Generated on Tue Dec 15 2015 18:14:38 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.SpatialEditor Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • SpatialEditor
Public Member Functions | Static Public Member Functions | Protected Member Functions | Package Attributes | Properties | Events | List of all members
Deltares.Standard.Forms.SpatialEditor Class Reference

TODO: Comment More...

Inheritance diagram for Deltares.Standard.Forms.SpatialEditor:

Public Member Functions

SpatialEditor ()
Initializes a new instance of the SpatialEditor class. TODO: Comment More...
Point2D | GetMousePosition ()
Gets the mouse position. More...
void | Select (params IShape[] shapes)
Selects the specified shapes. More...
IShape[] GetSelectedShapes ()
Gets the selected shapes. More...
IShape[] GetHoveredShapes ()
Gets the hovered shapes. More...
void | AddRectangle ()
Adds a rectangle. More...
void | AddEllipse ()
Adds a ellipse. More...
void | AddTriangle ()
Adds a triangle. More...
void | AddArrow (Point2D beginPoint, Point2D headPoint)
Adds an arrow. More...
void | AddShape (IShape newShape)
Adds a shape. More...
void | Remove (IShape ctrlShape)
Removes the specified control shape. More...
void | RegisterShapeType (Type dataType, Type shapeType, string name=null, bool?visible=null, bool?labelVisible=null, bool?allowEdit=null)
Registers the type of the shape. More...
void | ReadUserValues ()
void | SaveUserValues ()
ShapeInfo | GetShapeInfo (Type shapeType)
Gets the shape information. More...
void | CopyShapeInfos (SpatialEditor spatialEditor)
Copies the shape infos. More...
void | AddProperty (object source, params string[] properties)
Adds the property. TODO: Comment More...
SourceProperty | GetSourceProperty (object dataObject)
void | AddList (IEnumerable list)
Adds the list. More...
void | AddObject (object dataObject)
Adds the object. More...
void | RemoveObject (object dataObject)
Removes the object. More...
void | RemoveDataObjectFromList (object dataObject)
Removes the data object from the list. More...
void | Clear ()
Clears the shapes, source properties and list of contents. More...
void | Zoom (bool zoomIn, bool doZoomX, bool doZoomY)
Zooms to the specified values. More...
void | Zoom (Point startPoint, Point endPoint)
Zooms to the area between the given start point and end point. More...
void | SuspendRendering ()
Suspends the rendering of the editor's content. More...
void | ResumeRendering ()
Resumes the rendering of the editor's content. More...
void | MakeProportional ()
Makes the view proportional (x to y) More...
void | CenterExtents ()
Moves the view to the center of the extents. More...
void | ZoomToExtents (bool maintainAspectRatio)
Zooms until all contents fit on screen. (Calls function ZoomToExtents() or ZoomToExtendsMaintainAspectRatio(); More...
void | ZoomToExtendsMaintainAspectRatio ()
Zooms to extends and maintains aspect ratio. More...
void | ZoomToExtents ()
Zooms out/in until all contents fit on screen. More...
IShape | GetShape (object dataObject)
Gets the shape of the given dataObject. More...
void | AddInsertPoint (Point2D point)
Adds the insert point. More...
Image | GetImage (int width, int height)
Returns an image takien from the View with the given width and height. More...

Static Public Member Functions

static string | NaiveCamelCaseToSpacedName (Type type)
Converts the camelCase type to a naively spaced type. More...
static string | NaiveCamelCaseToSpacedName (string camelCase)
Converts the camelCase string to a naively spaced string. More...

Protected Member Functions

override void | OnPaint (PaintEventArgs e)
override void | Dispose (bool disposing)
Clean up any resources being used. More...

Package Attributes

System.Windows.Forms.ContextMenu | mnuLabel
System.Windows.Forms.MenuItem | mnuColorChange

Properties

Rectangle | WorldBounds [get, set]
Defines the size of the world in the editor. A user cannot navigate beyond these borders. The given rectangle's:

  • X is used as minimum X value,
  • Y is used as minimum Y value,
  • X + Width is used as maximum X value,
  • Y + Height is used as maximum Y value
More...
int | ZoomOutLevels [get, set]
Defines the number of levels a user can zoom out from the default zoom level. More...
int | ZoomInLevels [get, set]
Defines the number of levels a user can zoom in from the default zoom level. More...
static bool | OnlyHoverTopPickedObject [get, set]
bool | ViewGrid [get, set]
Gets or sets a value indicating whether the grid lines displayed in the editor area are shown. More...
bool | SnapGrid [get, set]
Gets or sets a value indicating whether to snap a point to a grid when inserting. More...
float | SnapDistance [get, set]
Gets or sets internal grid to snap to. More...
bool | SnapAngle [get, set]
Gets or sets a value indicating whether the line will be snapped to an angle when inserting. More...
bool | AllowEditing [get, set]
Gets or sets a value indicating whether editing is allowed. More...
bool | AllowPanning [get, set]
Gets or sets a value indicating whether panning is allowed. More...
bool | AllowSelecting [get, set]
Gets or sets a value indicating whether selecting is allowed. More...
bool | AllowZooming [get, set]
Gets or sets a value indicating whether zooming is allowed. More...
bool | WaitForInsert [get, set]
Gets or sets a value indicating whether it will be waited for an insert. More...
bool | ZoomOnResize [get, set]
Gets or sets a value indicating whether view will be zoomed on resize. More...
bool | MakeProportionalOnResize [get, set]
Gets or sets a value indicating whether view will be made proportional on resize. More...
ShapeInsertMode | InsertMode [get, set]
Gets or sets the Shape Insert Mode. More...
ShapeInsertRepeatMode | InsertRepeatMode [get, set]
Gets or sets the Shape Insert Repeat Mode. More...
bool | InsertIncrease [get, set]
Gets or sets a value indicating whether insert is increase. TODO: Check Comment More...
float | InsertIncreaseOffset [get, set]
Gets or sets the insert increase offset. More...
object | InsertType [get, set]
Gets or sets the type of the insert. More...
Pen | InsertPen [get, set]
Gets or sets the insert pen. More...
Projection | CoordinateSystem [get, set]
Gets or sets the coordinate system. More...
List< IShape > | Shapes [get]
Gets the shapes. More...
bool | CursorOnControl [get]
Gets a value indicating whether the cursor is on a control. More...
EditorMode | EditorMode [get, set]
Gets or sets the editor mode with the corresponding cursor. More...
List< ShapeInfo > | ShapeInfos [get]
Gets the shape infos. More...
List< ShapeInfo > | UsedShapeInfos [get]
Gets the used shape infos. More...
bool | IsRenderingSuspended [get]
Gets a value indicating whether this instance's rendering is suspended. More...
IShape | EmptySelection [get, set]
Gets or sets the empty selection which is the default object which is being edited in the Geometry Editor. More...
int | MarginLeft [get, set]
Gets or sets the left margin. More...
int | MarginRight [get, set]
Gets or sets the right margin. More...
int | MarginTop [get, set]
Gets or sets the top margin. More...
int | MarginBottom [get, set]
Gets or sets the bottom margin. More...
List< LegendItem > | LegendItems [get, set]
Gets or sets the legend items. More...

Events

EventHandler< EventArgs > | EditorModeChanged
Event occurs when the editor mode changed. More...
EventHandler< ShapesEventArgs > | SelectionChanged
Event occurs when the selection changed. More...
EventHandler< ShapeEventArgs > | ShapeCreated
Event occurs when a new shape has been created. More...
EventHandler< ShapeEventArgs > | ShapeModified
Event occurs when a shape is modified. More...
EventHandler< ShapeEventArgs > | ShapeRemoved
Event occurs when a shape has been removed. More...

Detailed Description

TODO: Comment

Constructor & Destructor Documentation

Deltares.Standard.Forms.SpatialEditor.SpatialEditor ( )

Initializes a new instance of the SpatialEditor class. TODO: Comment

Member Function Documentation

void Deltares.Standard.Forms.SpatialEditor.AddArrow | ( | Point2D | beginPoint,
 |  | Point2D | headPoint
 | ) |  |

Adds an arrow.

Parameters
beginPoint | The begin point.
headPoint | The head point.
void Deltares.Standard.Forms.SpatialEditor.AddEllipse ( )

Adds a ellipse.

void Deltares.Standard.Forms.SpatialEditor.AddInsertPoint ( Point2D point )

Adds the insert point.

Parameters
point The point.
void Deltares.Standard.Forms.SpatialEditor.AddList ( IEnumerable list )

Adds the list.

Parameters
list The list.
void Deltares.Standard.Forms.SpatialEditor.AddObject ( object dataObject )

Adds the object.

Parameters
dataObject The data object.
void Deltares.Standard.Forms.SpatialEditor.AddProperty | ( | object | source,
 |  | params string[] | properties
 | ) |  |

Adds the property. TODO: Comment

Parameters
source | The source.
properties | The properties.
void Deltares.Standard.Forms.SpatialEditor.AddRectangle ( )

Adds a rectangle.

void Deltares.Standard.Forms.SpatialEditor.AddShape ( IShape newShape )

Adds a shape.

Parameters
newShape The new shape.
void Deltares.Standard.Forms.SpatialEditor.AddTriangle ( )

Adds a triangle.

void Deltares.Standard.Forms.SpatialEditor.CenterExtents ( )

Moves the view to the center of the extents.

void Deltares.Standard.Forms.SpatialEditor.Clear ( )

Clears the shapes, source properties and list of contents.

Referenced by Deltares.Standard.Forms.DExpress.GeometryEditor.Clear().

void Deltares.Standard.Forms.SpatialEditor.CopyShapeInfos ( SpatialEditor spatialEditor )

Copies the shape infos.

Parameters
spatialEditor The spatial editor.

References Deltares.Standard.Forms.ShapeInfo.LabelVisible, Deltares.Standard.Forms.ShapeInfo.Name, and Deltares.Standard.Forms.ShapeInfo.Visible.

Referenced by Deltares.DSoilModel.Forms.FilmStrip.FilmStrip().

override void Deltares.Standard.Forms.SpatialEditor.Dispose ( bool disposing )
protected

Clean up any resources being used.

Parameters
disposing true if managed resources should be disposed; otherwise, false.
IShape [] Deltares.Standard.Forms.SpatialEditor.GetHoveredShapes ( )

Gets the hovered shapes.

Returns
Image Deltares.Standard.Forms.SpatialEditor.GetImage | ( | int | width,
 |  | int | height
 | ) |  |

Returns an image takien from the View with the given width and height.

Parameters
width | The width.
height | The height.
Returns
Point2D Deltares.Standard.Forms.SpatialEditor.GetMousePosition ( )

Gets the mouse position.

Returns
IShape [] Deltares.Standard.Forms.SpatialEditor.GetSelectedShapes ( )

Gets the selected shapes.

Returns
IShape Deltares.Standard.Forms.SpatialEditor.GetShape ( object dataObject )

Gets the shape of the given dataObject.

Parameters
dataObject The data object.
Returns
ShapeInfo Deltares.Standard.Forms.SpatialEditor.GetShapeInfo ( Type shapeType )

Gets the shape information.

Parameters
shapeType Type of the shape.
Returns

This method creates a new ShapeInfo and caches it for the given type.

void Deltares.Standard.Forms.SpatialEditor.MakeProportional ( )

Makes the view proportional (x to y)

static string Deltares.Standard.Forms.SpatialEditor.NaiveCamelCaseToSpacedName ( Type type )
static

Converts the camelCase type to a naively spaced type.

Parameters
type The type.
Returns
static string Deltares.Standard.Forms.SpatialEditor.NaiveCamelCaseToSpacedName ( string camelCase )
static

Converts the camelCase string to a naively spaced string.

Parameters
camelCase The camel case.
Returns
void Deltares.Standard.Forms.SpatialEditor.RegisterShapeType | ( | Type | dataType,
 |  | Type | shapeType,
 |  | string | name = null,
 |  | bool? | visible = null,
 |  | bool? | labelVisible = null,
 |  | bool? | allowEdit = null
 | ) |  |

Registers the type of the shape.

Parameters
dataType | Type of the data.
shapeType | Type of the shape.
name | The name.
visible | is visible.
labelVisible | is label visible.
allowEdit | specifies wether editing is allowed for the shape

Referenced by Deltares.DSoilModel.Forms.DSoilModelGeometryEditor.DSoilModelGeometryEditor().

void Deltares.Standard.Forms.SpatialEditor.Remove ( IShape ctrlShape )

Removes the specified control shape.

Parameters
ctrlShape The control shape.
void Deltares.Standard.Forms.SpatialEditor.RemoveDataObjectFromList ( object dataObject )

Removes the data object from the list.

Parameters
dataObject The data object.
void Deltares.Standard.Forms.SpatialEditor.RemoveObject ( object dataObject )

Removes the object.

Parameters
dataObject The data object.
void Deltares.Standard.Forms.SpatialEditor.ResumeRendering ( )

Resumes the rendering of the editor's content.

Supports nested calls.

void Deltares.Standard.Forms.SpatialEditor.Select ( params IShape[] shapes )

Selects the specified shapes.

Parameters
shapes The shapes.

Referenced by Deltares.Standard.Forms.DExpress.GeometryEditor.DeleteSelectedObjects(), and Deltares.Standard.Forms.DExpress.GeometryEditor.DeselectAllObjects().

void Deltares.Standard.Forms.SpatialEditor.SuspendRendering ( )

Suspends the rendering of the editor's content.

Supports nested calls.

void Deltares.Standard.Forms.SpatialEditor.Zoom | ( | bool | zoomIn,
 |  | bool | doZoomX,
 |  | bool | doZoomY
 | ) |  |

Zooms to the specified values.

Parameters
zoomIn | if set to true zooms in.
doZoomX | if set to true zooms to X.
doZoomY | if set to true zooms to Y.
void Deltares.Standard.Forms.SpatialEditor.Zoom | ( | Point | startPoint,
 |  | Point | endPoint
 | ) |  |

Zooms to the area between the given start point and end point.

Parameters
startPoint | The start point.
endPoint | The end point.
void Deltares.Standard.Forms.SpatialEditor.ZoomToExtendsMaintainAspectRatio ( )

Zooms to extends and maintains aspect ratio.

void Deltares.Standard.Forms.SpatialEditor.ZoomToExtents ( bool maintainAspectRatio )

Zooms until all contents fit on screen. (Calls function ZoomToExtents() or ZoomToExtendsMaintainAspectRatio();

Parameters
maintainAspectRatio if set to true [maintain aspect ratio].
void Deltares.Standard.Forms.SpatialEditor.ZoomToExtents ( )

Zooms out/in until all contents fit on screen.

Property Documentation

bool Deltares.Standard.Forms.SpatialEditor.AllowEditing
getset

Gets or sets a value indicating whether editing is allowed.

true if allow editing; otherwise, false.

bool Deltares.Standard.Forms.SpatialEditor.AllowPanning
getset

Gets or sets a value indicating whether panning is allowed.

true if allow panning; otherwise, false.

bool Deltares.Standard.Forms.SpatialEditor.AllowSelecting
getset

Gets or sets a value indicating whether selecting is allowed.

true if allow selecting; otherwise, false.

bool Deltares.Standard.Forms.SpatialEditor.AllowZooming
getset

Gets or sets a value indicating whether zooming is allowed.

true if allow zooming; otherwise, false.

Projection Deltares.Standard.Forms.SpatialEditor.CoordinateSystem
getset

Gets or sets the coordinate system.

The coordinate system.

bool Deltares.Standard.Forms.SpatialEditor.CursorOnControl
get

Gets a value indicating whether the cursor is on a control.

true if cursor on control; otherwise, false.

EditorMode Deltares.Standard.Forms.SpatialEditor.EditorMode
getset

Gets or sets the editor mode with the corresponding cursor.

The editor mode.

IShape Deltares.Standard.Forms.SpatialEditor.EmptySelection
getset

Gets or sets the empty selection which is the default object which is being edited in the Geometry Editor.

The empty selection.

bool Deltares.Standard.Forms.SpatialEditor.InsertIncrease
getset

Gets or sets a value indicating whether insert is increase. TODO: Check Comment

true if insert increase; otherwise, false.

float Deltares.Standard.Forms.SpatialEditor.InsertIncreaseOffset
getset

Gets or sets the insert increase offset.

The insert increase offset.

ShapeInsertMode Deltares.Standard.Forms.SpatialEditor.InsertMode
getset

Gets or sets the Shape Insert Mode.

The insert mode.

Pen Deltares.Standard.Forms.SpatialEditor.InsertPen
getset

Gets or sets the insert pen.

The insert pen.

ShapeInsertRepeatMode Deltares.Standard.Forms.SpatialEditor.InsertRepeatMode
getset

Gets or sets the Shape Insert Repeat Mode.

The insert repeat mode.

object Deltares.Standard.Forms.SpatialEditor.InsertType
getset

Gets or sets the type of the insert.

The type of the insert.

bool Deltares.Standard.Forms.SpatialEditor.IsRenderingSuspended
get

Gets a value indicating whether this instance's rendering is suspended.

true if this instance's rendering is suspended; otherwise, false.

List<LegendItem> Deltares.Standard.Forms.SpatialEditor.LegendItems
getset

Gets or sets the legend items.

The legend items.

bool Deltares.Standard.Forms.SpatialEditor.MakeProportionalOnResize
getset

Gets or sets a value indicating whether view will be made proportional on resize.

true if make proportional on resize; otherwise, false.

int Deltares.Standard.Forms.SpatialEditor.MarginBottom
getset

Gets or sets the bottom margin.

The margin bottom.

int Deltares.Standard.Forms.SpatialEditor.MarginLeft
getset

Gets or sets the left margin.

The margin left.

int Deltares.Standard.Forms.SpatialEditor.MarginRight
getset

Gets or sets the right margin.

The margin right.

int Deltares.Standard.Forms.SpatialEditor.MarginTop
getset

Gets or sets the top margin.

The margin top.

List<ShapeInfo> Deltares.Standard.Forms.SpatialEditor.ShapeInfos
get

Gets the shape infos.

The shape infos.

List<IShape> Deltares.Standard.Forms.SpatialEditor.Shapes
get

Gets the shapes.

The shapes.

bool Deltares.Standard.Forms.SpatialEditor.SnapAngle
getset

Gets or sets a value indicating whether the line will be snapped to an angle when inserting.

true if snap angle; otherwise, false.

float Deltares.Standard.Forms.SpatialEditor.SnapDistance
getset

Gets or sets internal grid to snap to.

The snap distance.

bool Deltares.Standard.Forms.SpatialEditor.SnapGrid
getset

Gets or sets a value indicating whether to snap a point to a grid when inserting.

true if [snap grid]; otherwise, false.

List<ShapeInfo> Deltares.Standard.Forms.SpatialEditor.UsedShapeInfos
get

Gets the used shape infos.

The used shape infos.

bool Deltares.Standard.Forms.SpatialEditor.ViewGrid
getset

Gets or sets a value indicating whether the grid lines displayed in the editor area are shown.

true if [view grid]; otherwise, false.

bool Deltares.Standard.Forms.SpatialEditor.WaitForInsert
getset

Gets or sets a value indicating whether it will be waited for an insert.

true if wait for insert; otherwise, false.

Rectangle Deltares.Standard.Forms.SpatialEditor.WorldBounds
getset

Defines the size of the world in the editor. A user cannot navigate beyond these borders. The given rectangle's:

  • X is used as minimum X value,
  • Y is used as minimum Y value,
  • X + Width is used as maximum X value,
  • Y + Height is used as maximum Y value

int Deltares.Standard.Forms.SpatialEditor.ZoomInLevels
getset

Defines the number of levels a user can zoom in from the default zoom level.

bool Deltares.Standard.Forms.SpatialEditor.ZoomOnResize
getset

Gets or sets a value indicating whether view will be zoomed on resize.

true if zoom on resize; otherwise, false.

int Deltares.Standard.Forms.SpatialEditor.ZoomOutLevels
getset

Defines the number of levels a user can zoom out from the default zoom level.

Event Documentation

EventHandler<EventArgs> Deltares.Standard.Forms.SpatialEditor.EditorModeChanged

Event occurs when the editor mode changed.

EventHandler<ShapesEventArgs> Deltares.Standard.Forms.SpatialEditor.SelectionChanged

Event occurs when the selection changed.

EventHandler<ShapeEventArgs> Deltares.Standard.Forms.SpatialEditor.ShapeCreated

Event occurs when a new shape has been created.

EventHandler<ShapeEventArgs> Deltares.Standard.Forms.SpatialEditor.ShapeModified

Event occurs when a shape is modified.

EventHandler<ShapeEventArgs> Deltares.Standard.Forms.SpatialEditor.ShapeRemoved

Event occurs when a shape has been removed.

Generated on Tue Dec 15 2015 18:14:38 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • SpatialEditor
Deltares.Standard.Forms.SpatialEditor Member List

This is the complete list of members for Deltares.Standard.Forms.SpatialEditor, including all inherited members.

AddArrow(Point2D beginPoint, Point2D headPoint) | Deltares.Standard.Forms.SpatialEditor |
AddEllipse() | Deltares.Standard.Forms.SpatialEditor |
AddInsertPoint(Point2D point) | Deltares.Standard.Forms.SpatialEditor |
AddList(IEnumerable list) | Deltares.Standard.Forms.SpatialEditor |
AddObject(object dataObject) | Deltares.Standard.Forms.SpatialEditor |
AddProperty(object source, params string[] properties) | Deltares.Standard.Forms.SpatialEditor |
AddRectangle() | Deltares.Standard.Forms.SpatialEditor |
AddShape(IShape newShape) | Deltares.Standard.Forms.SpatialEditor |
AddTriangle() | Deltares.Standard.Forms.SpatialEditor |
AllowEditing | Deltares.Standard.Forms.SpatialEditor |
AllowPanning | Deltares.Standard.Forms.SpatialEditor |
AllowSelecting | Deltares.Standard.Forms.SpatialEditor |
AllowZooming | Deltares.Standard.Forms.SpatialEditor |
CenterExtents() | Deltares.Standard.Forms.SpatialEditor |
Clear() | Deltares.Standard.Forms.SpatialEditor |
CoordinateSystem | Deltares.Standard.Forms.SpatialEditor |
CopyShapeInfos(SpatialEditor spatialEditor) | Deltares.Standard.Forms.SpatialEditor |
CursorOnControl | Deltares.Standard.Forms.SpatialEditor |
Dispose(bool disposing) | Deltares.Standard.Forms.SpatialEditor | protected
EditorMode | Deltares.Standard.Forms.SpatialEditor |
EditorModeChanged | Deltares.Standard.Forms.SpatialEditor |
EmptySelection | Deltares.Standard.Forms.SpatialEditor |
GetHoveredShapes() | Deltares.Standard.Forms.SpatialEditor |
GetImage(int width, int height) | Deltares.Standard.Forms.SpatialEditor |
GetMousePosition() | Deltares.Standard.Forms.SpatialEditor |
GetSelectedShapes() | Deltares.Standard.Forms.SpatialEditor |
GetShape(object dataObject) | Deltares.Standard.Forms.SpatialEditor |
GetShapeInfo(Type shapeType) | Deltares.Standard.Forms.SpatialEditor |
GetSourceProperty(object dataObject) (defined in Deltares.Standard.Forms.SpatialEditor) | Deltares.Standard.Forms.SpatialEditor |
InsertIncrease | Deltares.Standard.Forms.SpatialEditor |
InsertIncreaseOffset | Deltares.Standard.Forms.SpatialEditor |
InsertMode | Deltares.Standard.Forms.SpatialEditor |
InsertPen | Deltares.Standard.Forms.SpatialEditor |
InsertRepeatMode | Deltares.Standard.Forms.SpatialEditor |
InsertType | Deltares.Standard.Forms.SpatialEditor |
IsRenderingSuspended | Deltares.Standard.Forms.SpatialEditor |
LegendItems | Deltares.Standard.Forms.SpatialEditor |
MakeProportional() | Deltares.Standard.Forms.SpatialEditor |
MakeProportionalOnResize | Deltares.Standard.Forms.SpatialEditor |
MarginBottom | Deltares.Standard.Forms.SpatialEditor |
MarginLeft | Deltares.Standard.Forms.SpatialEditor |
MarginRight | Deltares.Standard.Forms.SpatialEditor |
MarginTop | Deltares.Standard.Forms.SpatialEditor |
mnuColorChange (defined in Deltares.Standard.Forms.SpatialEditor) | Deltares.Standard.Forms.SpatialEditor | package
mnuLabel (defined in Deltares.Standard.Forms.SpatialEditor) | Deltares.Standard.Forms.SpatialEditor | package
NaiveCamelCaseToSpacedName(Type type) | Deltares.Standard.Forms.SpatialEditor | static
NaiveCamelCaseToSpacedName(string camelCase) | Deltares.Standard.Forms.SpatialEditor | static
OnlyHoverTopPickedObject (defined in Deltares.Standard.Forms.SpatialEditor) | Deltares.Standard.Forms.SpatialEditor | static
OnPaint(PaintEventArgs e) (defined in Deltares.Standard.Forms.SpatialEditor) | Deltares.Standard.Forms.SpatialEditor | protected
ReadUserValues() (defined in Deltares.Standard.Forms.SpatialEditor) | Deltares.Standard.Forms.SpatialEditor |
RegisterShapeType(Type dataType, Type shapeType, string name=null, bool?visible=null, bool?labelVisible=null, bool?allowEdit=null) | Deltares.Standard.Forms.SpatialEditor |
Remove(IShape ctrlShape) | Deltares.Standard.Forms.SpatialEditor |
RemoveDataObjectFromList(object dataObject) | Deltares.Standard.Forms.SpatialEditor |
RemoveObject(object dataObject) | Deltares.Standard.Forms.SpatialEditor |
ResumeRendering() | Deltares.Standard.Forms.SpatialEditor |
SaveUserValues() (defined in Deltares.Standard.Forms.SpatialEditor) | Deltares.Standard.Forms.SpatialEditor |
Select(params IShape[] shapes) | Deltares.Standard.Forms.SpatialEditor |
SelectionChanged | Deltares.Standard.Forms.SpatialEditor |
ShapeCreated | Deltares.Standard.Forms.SpatialEditor |
ShapeInfos | Deltares.Standard.Forms.SpatialEditor |
ShapeModified | Deltares.Standard.Forms.SpatialEditor |
ShapeRemoved | Deltares.Standard.Forms.SpatialEditor |
Shapes | Deltares.Standard.Forms.SpatialEditor |
SnapAngle | Deltares.Standard.Forms.SpatialEditor |
SnapDistance | Deltares.Standard.Forms.SpatialEditor |
SnapGrid | Deltares.Standard.Forms.SpatialEditor |
SpatialEditor() | Deltares.Standard.Forms.SpatialEditor |
SuspendRendering() | Deltares.Standard.Forms.SpatialEditor |
UsedShapeInfos | Deltares.Standard.Forms.SpatialEditor |
ViewGrid | Deltares.Standard.Forms.SpatialEditor |
WaitForInsert | Deltares.Standard.Forms.SpatialEditor |
WorldBounds | Deltares.Standard.Forms.SpatialEditor |
Zoom(bool zoomIn, bool doZoomX, bool doZoomY) | Deltares.Standard.Forms.SpatialEditor |
Zoom(Point startPoint, Point endPoint) | Deltares.Standard.Forms.SpatialEditor |
ZoomInLevels | Deltares.Standard.Forms.SpatialEditor |
ZoomOnResize | Deltares.Standard.Forms.SpatialEditor |
ZoomOutLevels | Deltares.Standard.Forms.SpatialEditor |
ZoomToExtendsMaintainAspectRatio() | Deltares.Standard.Forms.SpatialEditor |
ZoomToExtents(bool maintainAspectRatio) | Deltares.Standard.Forms.SpatialEditor |
ZoomToExtents() | Deltares.Standard.Forms.SpatialEditor |
Generated on Tue Dec 15 2015 18:14:38 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.SpatialEditorBarSupport Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • SpatialEditorBarSupport
Static Public Member Functions | List of all members
Deltares.Standard.Forms.SpatialEditorBarSupport Class Reference

Static Public Member Functions

static BarEditItem | BuildBarEditItem (BarManager manager, Bar bar, RepositoryItem item)
static void | RemoveBarItem (BarManager manager, Bar bar, BarItem item)
Generated on Tue Dec 15 2015 18:14:38 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • SpatialEditorBarSupport
Deltares.Standard.Forms.SpatialEditorBarSupport Member List

This is the complete list of members for Deltares.Standard.Forms.SpatialEditorBarSupport, including all inherited members.

BuildBarEditItem(BarManager manager, Bar bar, RepositoryItem item) (defined in Deltares.Standard.Forms.SpatialEditorBarSupport) | Deltares.Standard.Forms.SpatialEditorBarSupport | static
RemoveBarItem(BarManager manager, Bar bar, BarItem item) (defined in Deltares.Standard.Forms.SpatialEditorBarSupport) | Deltares.Standard.Forms.SpatialEditorBarSupport | static
Generated on Tue Dec 15 2015 18:14:38 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.TestRectangleShape Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • TestRectangleShape
Public Member Functions | List of all members
Deltares.Standard.Forms.TestRectangleShape Class Reference
Inheritance diagram for Deltares.Standard.Forms.TestRectangleShape:
Deltares.Standard.Forms.Shape Deltares.Standard.Forms.IShape

Public Member Functions

override void | Draw (GraphicsInfo info)
- Public Member Functions inherited from Deltares.Standard.Forms.Shape
virtual void | AddPoint (Point2D point)
virtual IEnumerable< object > | DataItemAt (Point point, Projection projection)
virtual bool | AllowDrop (object data)
virtual void | Drop (object data)
virtual bool | ContainsPoint (IProjection projection, Point point)
virtual Rectangle | GetExtents (IProjection projection)
virtual void | DrawLabel (GraphicsInfo info)
virtual void | Move (IProjection projection, Point2D startPosition, SizeF worldSize)
virtual void | BeginMove (IProjection projection, Point2D startPosition)
virtual CardinalDirection | GetCardinalDirectionOnEdgeContainingPoint (Point point)
virtual void | EndMove (IProjection projection, Point2D startPosition, SizeF worldSize)

Additional Inherited Members

- Protected Attributes inherited from Deltares.Standard.Forms.Shape
GraphicsPath | path = null
- Properties inherited from Deltares.Standard.Forms.Shape
Point | Location [get, set]
Size | Size [get, set]
virtual bool | CanResize [get]
Color | ForeColor [get, set]
Color | BackColor [get, set]
IProjection | CoordinateSystem [get, set]
Point2D | WorldLocation [get, set]
SizeF | WorldSize [get, set]
virtual int | Layer [get, set]
virtual object | DataObject [get, set]
- Properties inherited from Deltares.Standard.Forms.IShape
object | DataObject [get, set]
int | Layer [get]
Generated on Tue Dec 15 2015 18:14:38 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • TestRectangleShape
Deltares.Standard.Forms.TestRectangleShape Member List

This is the complete list of members for Deltares.Standard.Forms.TestRectangleShape, including all inherited members.

AddPoint(Point2D point) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
AllowDrop(object data) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
BackColor (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
BeginMove(IProjection projection, Point2D startPosition) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
CanResize (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
ContainsPoint(IProjection projection, Point point) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
CoordinateSystem (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
DataItemAt(Point point, Projection projection) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
DataObject (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
Draw(GraphicsInfo info) (defined in Deltares.Standard.Forms.TestRectangleShape) | Deltares.Standard.Forms.TestRectangleShape | virtual
DrawLabel(GraphicsInfo info) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
Drop(object data) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
EndMove(IProjection projection, Point2D startPosition, SizeF worldSize) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
ForeColor (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
GetCardinalDirectionOnEdgeContainingPoint(Point point) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
GetExtents(IProjection projection) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
Layer (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
Location (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
Move(IProjection projection, Point2D startPosition, SizeF worldSize) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
path (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | protected
Shape() (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
Size (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
WorldLocation (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
WorldSize (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
Generated on Tue Dec 15 2015 18:14:38 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.TransparentLabel Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • TransparentLabel
Properties | List of all members
Deltares.Standard.Forms.TransparentLabel Class Reference
Inheritance diagram for Deltares.Standard.Forms.TransparentLabel:

Properties

override CreateParams CreateParams [get]
Generated on Tue Dec 15 2015 18:14:39 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • TransparentLabel
Deltares.Standard.Forms.TransparentLabel Member List

This is the complete list of members for Deltares.Standard.Forms.TransparentLabel, including all inherited members.

CreateParams (defined in Deltares.Standard.Forms.TransparentLabel) | Deltares.Standard.Forms.TransparentLabel | protected
TransparentLabel() (defined in Deltares.Standard.Forms.TransparentLabel) | Deltares.Standard.Forms.TransparentLabel |
Generated on Tue Dec 15 2015 18:14:39 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.TriangleShape Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • TriangleShape
Public Member Functions | List of all members
Deltares.Standard.Forms.TriangleShape Class Reference
Inheritance diagram for Deltares.Standard.Forms.TriangleShape:
Deltares.Standard.Forms.Shape Deltares.Standard.Forms.IShape

Public Member Functions

override void | Draw (GraphicsInfo info)
- Public Member Functions inherited from Deltares.Standard.Forms.Shape
virtual void | AddPoint (Point2D point)
virtual IEnumerable< object > | DataItemAt (Point point, Projection projection)
virtual bool | AllowDrop (object data)
virtual void | Drop (object data)
virtual bool | ContainsPoint (IProjection projection, Point point)
virtual Rectangle | GetExtents (IProjection projection)
virtual void | DrawLabel (GraphicsInfo info)
virtual void | Move (IProjection projection, Point2D startPosition, SizeF worldSize)
virtual void | BeginMove (IProjection projection, Point2D startPosition)
virtual CardinalDirection | GetCardinalDirectionOnEdgeContainingPoint (Point point)
virtual void | EndMove (IProjection projection, Point2D startPosition, SizeF worldSize)

Additional Inherited Members

- Protected Attributes inherited from Deltares.Standard.Forms.Shape
GraphicsPath | path = null
- Properties inherited from Deltares.Standard.Forms.Shape
Point | Location [get, set]
Size | Size [get, set]
virtual bool | CanResize [get]
Color | ForeColor [get, set]
Color | BackColor [get, set]
IProjection | CoordinateSystem [get, set]
Point2D | WorldLocation [get, set]
SizeF | WorldSize [get, set]
virtual int | Layer [get, set]
virtual object | DataObject [get, set]
- Properties inherited from Deltares.Standard.Forms.IShape
object | DataObject [get, set]
int | Layer [get]
Generated on Tue Dec 15 2015 18:14:39 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • TriangleShape
Deltares.Standard.Forms.TriangleShape Member List

This is the complete list of members for Deltares.Standard.Forms.TriangleShape, including all inherited members.

AddPoint(Point2D point) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
AllowDrop(object data) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
BackColor (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
BeginMove(IProjection projection, Point2D startPosition) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
CanResize (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
ContainsPoint(IProjection projection, Point point) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
CoordinateSystem (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
DataItemAt(Point point, Projection projection) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
DataObject (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
Draw(GraphicsInfo info) (defined in Deltares.Standard.Forms.TriangleShape) | Deltares.Standard.Forms.TriangleShape | virtual
DrawLabel(GraphicsInfo info) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
Drop(object data) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
EndMove(IProjection projection, Point2D startPosition, SizeF worldSize) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
ForeColor (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
GetCardinalDirectionOnEdgeContainingPoint(Point point) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
GetExtents(IProjection projection) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
Layer (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
Location (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
Move(IProjection projection, Point2D startPosition, SizeF worldSize) (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | virtual
path (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape | protected
Shape() (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
Size (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
WorldLocation (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
WorldSize (defined in Deltares.Standard.Forms.Shape) | Deltares.Standard.Forms.Shape |
Generated on Tue Dec 15 2015 18:14:39 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.ViewCommand Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • ViewCommand
Public Member Functions | Properties | List of all members
Deltares.Standard.Forms.ViewCommand Class Reference

Represnts a view command More...

Public Member Functions

ViewCommand (string id)
Initializes a new instance of the ViewCommand class. More...

Properties

string | Id [get]
Gets the unique identification for this view command. More...
string | Text [get, set]
Gets or sets the text associated(Displayed) with this view command More...
string | Description [get, set]
Gets or sets the description for this view comamnd. More...
string | Image [get, set]
Gets or sets the Image that has to displayed with this command. More...
Shortcut | Shortcut [get, set]
Gets or sets the shortcut key associated with this command. More...

Detailed Description

Represnts a view command

Constructor & Destructor Documentation

Deltares.Standard.Forms.ViewCommand.ViewCommand ( string id )

Initializes a new instance of the ViewCommand class.

Parameters
id Id for the command.

Property Documentation

string Deltares.Standard.Forms.ViewCommand.Description
getset

Gets or sets the description for this view comamnd.

string Deltares.Standard.Forms.ViewCommand.Id
get

Gets the unique identification for this view command.

string Deltares.Standard.Forms.ViewCommand.Image
getset

Gets or sets the Image that has to displayed with this command.

Shortcut Deltares.Standard.Forms.ViewCommand.Shortcut
getset

Gets or sets the shortcut key associated with this command.

string Deltares.Standard.Forms.ViewCommand.Text
getset

Gets or sets the text associated(Displayed) with this view command

Generated on Tue Dec 15 2015 18:14:39 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • ViewCommand
Deltares.Standard.Forms.ViewCommand Member List

This is the complete list of members for Deltares.Standard.Forms.ViewCommand, including all inherited members.

Description | Deltares.Standard.Forms.ViewCommand
Id | Deltares.Standard.Forms.ViewCommand
Image | Deltares.Standard.Forms.ViewCommand
Shortcut | Deltares.Standard.Forms.ViewCommand
Text | Deltares.Standard.Forms.ViewCommand
ViewCommand(string id) | Deltares.Standard.Forms.ViewCommand
Generated on Tue Dec 15 2015 18:14:39 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.VisualValidationResult Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • VisualValidationResult
Public Member Functions | Properties | List of all members
Deltares.Standard.Forms.VisualValidationResult Class Reference
Inheritance diagram for Deltares.Standard.Forms.VisualValidationResult:

Public Member Functions

VisualValidationResult (ValidationResult result)
void | Select ()
void | Repair ()
void | ClearValidationResult ()
string | GetName (string property)
string | GetDescription (string property)
string | GetCategory (string property)
string | GetFormat (string property)
Impact | GetImpact (string property)
UnitType | GetUnit (string property)
bool | IsVisible (string property)
bool | IsEnabled (string property)

Properties

ValidationResultType | MessageType [get]
List< string > | InvalidProperties [get]
string | Text [get, set]
object | Subject [get, set]
List< string > | ID [get]
IRepairer | Repairer [get]
Image | Severity [get]
Generated on Tue Dec 15 2015 18:14:39 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • VisualValidationResult
Deltares.Standard.Forms.VisualValidationResult Member List

This is the complete list of members for Deltares.Standard.Forms.VisualValidationResult, including all inherited members.

ClearValidationResult() (defined in Deltares.Standard.Forms.VisualValidationResult) | Deltares.Standard.Forms.VisualValidationResult
GetCategory(string property) (defined in Deltares.Standard.Forms.VisualValidationResult) | Deltares.Standard.Forms.VisualValidationResult
GetDescription(string property) (defined in Deltares.Standard.Forms.VisualValidationResult) | Deltares.Standard.Forms.VisualValidationResult
GetFormat(string property) (defined in Deltares.Standard.Forms.VisualValidationResult) | Deltares.Standard.Forms.VisualValidationResult
GetImpact(string property) (defined in Deltares.Standard.Forms.VisualValidationResult) | Deltares.Standard.Forms.VisualValidationResult
GetName(string property) (defined in Deltares.Standard.Forms.VisualValidationResult) | Deltares.Standard.Forms.VisualValidationResult
GetUnit(string property) (defined in Deltares.Standard.Forms.VisualValidationResult) | Deltares.Standard.Forms.VisualValidationResult
ID (defined in Deltares.Standard.Forms.VisualValidationResult) | Deltares.Standard.Forms.VisualValidationResult
InvalidProperties (defined in Deltares.Standard.Forms.VisualValidationResult) | Deltares.Standard.Forms.VisualValidationResult
IsEnabled(string property) (defined in Deltares.Standard.Forms.VisualValidationResult) | Deltares.Standard.Forms.VisualValidationResult
IsVisible(string property) (defined in Deltares.Standard.Forms.VisualValidationResult) | Deltares.Standard.Forms.VisualValidationResult
MessageType (defined in Deltares.Standard.Forms.VisualValidationResult) | Deltares.Standard.Forms.VisualValidationResult
Repair() (defined in Deltares.Standard.Forms.VisualValidationResult) | Deltares.Standard.Forms.VisualValidationResult
Repairer (defined in Deltares.Standard.Forms.VisualValidationResult) | Deltares.Standard.Forms.VisualValidationResult
Select() (defined in Deltares.Standard.Forms.VisualValidationResult) | Deltares.Standard.Forms.VisualValidationResult
Severity (defined in Deltares.Standard.Forms.VisualValidationResult) | Deltares.Standard.Forms.VisualValidationResult
Subject (defined in Deltares.Standard.Forms.VisualValidationResult) | Deltares.Standard.Forms.VisualValidationResult
Text (defined in Deltares.Standard.Forms.VisualValidationResult) | Deltares.Standard.Forms.VisualValidationResult
VisualValidationResult(ValidationResult result) (defined in Deltares.Standard.Forms.VisualValidationResult) | Deltares.Standard.Forms.VisualValidationResult
Generated on Tue Dec 15 2015 18:14:39 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Forms.ZoomablePictureBox Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • ZoomablePictureBox
Public Member Functions | Protected Member Functions | Properties | List of all members
Deltares.Standard.Forms.ZoomablePictureBox Class Reference
Inheritance diagram for Deltares.Standard.Forms.ZoomablePictureBox:

Public Member Functions

void LoadFile (string fileName)

Protected Member Functions

override void Dispose (bool disposing)
Clean up any resources being used. More...

Properties

int | Zoom [get, set]
bool | AutoFit [get, set]
Image | Image [get, set]
FillZoom | FillZoom [get, set]

Member Function Documentation

override void Deltares.Standard.Forms.ZoomablePictureBox.Dispose ( bool disposing )
protected

Clean up any resources being used.

Parameters
disposing true if managed resources should be disposed; otherwise, false.
Generated on Tue Dec 15 2015 18:14:40 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Forms
  • ZoomablePictureBox
Deltares.Standard.Forms.ZoomablePictureBox Member List

This is the complete list of members for Deltares.Standard.Forms.ZoomablePictureBox, including all inherited members.

AutoFit (defined in Deltares.Standard.Forms.ZoomablePictureBox) | Deltares.Standard.Forms.ZoomablePictureBox |
Dispose(bool disposing) | Deltares.Standard.Forms.ZoomablePictureBox | protected
FillZoom (defined in Deltares.Standard.Forms.ZoomablePictureBox) | Deltares.Standard.Forms.ZoomablePictureBox |
Image (defined in Deltares.Standard.Forms.ZoomablePictureBox) | Deltares.Standard.Forms.ZoomablePictureBox |
LoadFile(string fileName) (defined in Deltares.Standard.Forms.ZoomablePictureBox) | Deltares.Standard.Forms.ZoomablePictureBox |
Zoom (defined in Deltares.Standard.Forms.ZoomablePictureBox) | Deltares.Standard.Forms.ZoomablePictureBox |
ZoomablePictureBox() (defined in Deltares.Standard.Forms.ZoomablePictureBox) | Deltares.Standard.Forms.ZoomablePictureBox |
Generated on Tue Dec 15 2015 18:14:40 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Web.Ajax.AjaxPageSupportHandler Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Web
  • Ajax
  • AjaxPageSupportHandler
Public Member Functions | List of all members
Deltares.Standard.Web.Ajax.AjaxPageSupportHandler Class Reference
Inheritance diagram for Deltares.Standard.Web.Ajax.AjaxPageSupportHandler:
Deltares.Standard.Web.IPageSupportHandler

Public Member Functions

bool | PageNeedsUpdate (Page page)
bool | CanHandle (Control subControl)
void | UpdateOnPostback (Control subControl, IPropertyObject source, string property, CultureInfo culture)
void | UpdateControl (Control subControl, IPropertyObject source, string property, CultureInfo culture)
void | UpdateSource (Control control, IPropertyObject source, string property, CultureInfo culture)
void | AssignHandler (Control subControl)
List< Control > | GetControls (ControlCollection controls)
bool | InheritsParentSource (Control control)
bool | IsUpdatePanel (Control control, bool preferUpperPanel)
bool | IsAutoPostBack (Control control)
Generated on Tue Dec 15 2015 18:15:37 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Web
  • Ajax
  • AjaxPageSupportHandler
Deltares.Standard.Web.Ajax.AjaxPageSupportHandler Member List

This is the complete list of members for Deltares.Standard.Web.Ajax.AjaxPageSupportHandler, including all inherited members.

AjaxPageSupportHandler() (defined in Deltares.Standard.Web.Ajax.AjaxPageSupportHandler) | Deltares.Standard.Web.Ajax.AjaxPageSupportHandler
AssignHandler(Control subControl) (defined in Deltares.Standard.Web.Ajax.AjaxPageSupportHandler) | Deltares.Standard.Web.Ajax.AjaxPageSupportHandler
CanHandle(Control subControl) (defined in Deltares.Standard.Web.Ajax.AjaxPageSupportHandler) | Deltares.Standard.Web.Ajax.AjaxPageSupportHandler
GetControls(ControlCollection controls) (defined in Deltares.Standard.Web.Ajax.AjaxPageSupportHandler) | Deltares.Standard.Web.Ajax.AjaxPageSupportHandler
InheritsParentSource(Control control) (defined in Deltares.Standard.Web.Ajax.AjaxPageSupportHandler) | Deltares.Standard.Web.Ajax.AjaxPageSupportHandler
IsAutoPostBack(Control control) (defined in Deltares.Standard.Web.Ajax.AjaxPageSupportHandler) | Deltares.Standard.Web.Ajax.AjaxPageSupportHandler
IsUpdatePanel(Control control, bool preferUpperPanel) (defined in Deltares.Standard.Web.Ajax.AjaxPageSupportHandler) | Deltares.Standard.Web.Ajax.AjaxPageSupportHandler
PageNeedsUpdate(Page page) (defined in Deltares.Standard.Web.Ajax.AjaxPageSupportHandler) | Deltares.Standard.Web.Ajax.AjaxPageSupportHandler
UpdateControl(Control subControl, IPropertyObject source, string property, CultureInfo culture) (defined in Deltares.Standard.Web.Ajax.AjaxPageSupportHandler) | Deltares.Standard.Web.Ajax.AjaxPageSupportHandler
UpdateOnPostback(Control subControl, IPropertyObject source, string property, CultureInfo culture) (defined in Deltares.Standard.Web.Ajax.AjaxPageSupportHandler) | Deltares.Standard.Web.Ajax.AjaxPageSupportHandler
UpdateSource(Control control, IPropertyObject source, string property, CultureInfo culture) (defined in Deltares.Standard.Web.Ajax.AjaxPageSupportHandler) | Deltares.Standard.Web.Ajax.AjaxPageSupportHandler
Generated on Tue Dec 15 2015 18:15:37 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Web.Ajax.ExtenderControlBase Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Web
  • Ajax
  • ExtenderControlBase
Protected Member Functions | List of all members
Deltares.Standard.Web.Ajax.ExtenderControlBase Class Reference
Inheritance diagram for Deltares.Standard.Web.Ajax.ExtenderControlBase:

Protected Member Functions

override IEnumerable< ScriptDescriptor > | GetScriptDescriptors (Control targetControl)
override IEnumerable< ScriptReference > | GetScriptReferences ()
Generated on Tue Dec 15 2015 18:15:37 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Web
  • Ajax
  • ExtenderControlBase
Deltares.Standard.Web.Ajax.ExtenderControlBase Member List

This is the complete list of members for Deltares.Standard.Web.Ajax.ExtenderControlBase, including all inherited members.

GetScriptDescriptors(Control targetControl) (defined in Deltares.Standard.Web.Ajax.ExtenderControlBase) | Deltares.Standard.Web.Ajax.ExtenderControlBase | protected
GetScriptReferences() (defined in Deltares.Standard.Web.Ajax.ExtenderControlBase) | Deltares.Standard.Web.Ajax.ExtenderControlBase | protected
Generated on Tue Dec 15 2015 18:15:37 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Web.Ajax.ExtenderControlPropertyAttribute Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Web
  • Ajax
  • ExtenderControlPropertyAttribute
Public Member Functions | Properties | List of all members
Deltares.Standard.Web.Ajax.ExtenderControlPropertyAttribute Class Reference
Inheritance diagram for Deltares.Standard.Web.Ajax.ExtenderControlPropertyAttribute:

Public Member Functions

ExtenderControlPropertyAttribute (string name)

Properties

string Name [get, set]
Generated on Tue Dec 15 2015 18:15:37 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Web
  • Ajax
  • ExtenderControlPropertyAttribute
Deltares.Standard.Web.Ajax.ExtenderControlPropertyAttribute Member List

This is the complete list of members for Deltares.Standard.Web.Ajax.ExtenderControlPropertyAttribute, including all inherited members.

ExtenderControlPropertyAttribute() (defined in Deltares.Standard.Web.Ajax.ExtenderControlPropertyAttribute) | Deltares.Standard.Web.Ajax.ExtenderControlPropertyAttribute
ExtenderControlPropertyAttribute(string name) (defined in Deltares.Standard.Web.Ajax.ExtenderControlPropertyAttribute) | Deltares.Standard.Web.Ajax.ExtenderControlPropertyAttribute
Name (defined in Deltares.Standard.Web.Ajax.ExtenderControlPropertyAttribute) | Deltares.Standard.Web.Ajax.ExtenderControlPropertyAttribute
Generated on Tue Dec 15 2015 18:15:37 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Web.Ajax.ScriptControlBase Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Web
  • Ajax
  • ScriptControlBase
Protected Member Functions | List of all members
Deltares.Standard.Web.Ajax.ScriptControlBase Class Reference
Inheritance diagram for Deltares.Standard.Web.Ajax.ScriptControlBase:

Protected Member Functions

override IEnumerable< ScriptDescriptor > | GetScriptDescriptors ()
override IEnumerable< ScriptReference > | GetScriptReferences ()
Generated on Tue Dec 15 2015 18:15:38 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Web
  • Ajax
  • ScriptControlBase
Deltares.Standard.Web.Ajax.ScriptControlBase Member List

This is the complete list of members for Deltares.Standard.Web.Ajax.ScriptControlBase, including all inherited members.

GetScriptDescriptors() (defined in Deltares.Standard.Web.Ajax.ScriptControlBase) | Deltares.Standard.Web.Ajax.ScriptControlBase | protected
GetScriptReferences() (defined in Deltares.Standard.Web.Ajax.ScriptControlBase) | Deltares.Standard.Web.Ajax.ScriptControlBase | protected
Generated on Tue Dec 15 2015 18:15:38 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Web.Ajax.ScriptControlPropertyAttribute Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Web
  • Ajax
  • ScriptControlPropertyAttribute
Public Member Functions | Properties | List of all members
Deltares.Standard.Web.Ajax.ScriptControlPropertyAttribute Class Reference
Inheritance diagram for Deltares.Standard.Web.Ajax.ScriptControlPropertyAttribute:

Public Member Functions

ScriptControlPropertyAttribute (string name)

Properties

string Name [get, set]
Generated on Tue Dec 15 2015 18:15:38 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Web
  • Ajax
  • ScriptControlPropertyAttribute
Deltares.Standard.Web.Ajax.ScriptControlPropertyAttribute Member List

This is the complete list of members for Deltares.Standard.Web.Ajax.ScriptControlPropertyAttribute, including all inherited members.

Name (defined in Deltares.Standard.Web.Ajax.ScriptControlPropertyAttribute) | Deltares.Standard.Web.Ajax.ScriptControlPropertyAttribute
ScriptControlPropertyAttribute() (defined in Deltares.Standard.Web.Ajax.ScriptControlPropertyAttribute) | Deltares.Standard.Web.Ajax.ScriptControlPropertyAttribute
ScriptControlPropertyAttribute(string name) (defined in Deltares.Standard.Web.Ajax.ScriptControlPropertyAttribute) | Deltares.Standard.Web.Ajax.ScriptControlPropertyAttribute
Generated on Tue Dec 15 2015 18:15:38 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Web.Ajax.ScriptReferenceAttribute Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Web
  • Ajax
  • ScriptReferenceAttribute
Public Member Functions | Properties | List of all members
Deltares.Standard.Web.Ajax.ScriptReferenceAttribute Class Reference
Inheritance diagram for Deltares.Standard.Web.Ajax.ScriptReferenceAttribute:

Public Member Functions

ScriptReferenceAttribute (string path)
ScriptReferenceAttribute (string name, string assembly)
ScriptReference | GetScriptReference ()
string | GetScriptTypeName ()

Properties

string | Path [get, set]
string | Name [get, set]
string | Assembly [get, set]
Generated on Tue Dec 15 2015 18:15:38 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Web
  • Ajax
  • ScriptReferenceAttribute
Deltares.Standard.Web.Ajax.ScriptReferenceAttribute Member List

This is the complete list of members for Deltares.Standard.Web.Ajax.ScriptReferenceAttribute, including all inherited members.

Assembly (defined in Deltares.Standard.Web.Ajax.ScriptReferenceAttribute) | Deltares.Standard.Web.Ajax.ScriptReferenceAttribute
GetScriptReference() (defined in Deltares.Standard.Web.Ajax.ScriptReferenceAttribute) | Deltares.Standard.Web.Ajax.ScriptReferenceAttribute
GetScriptTypeName() (defined in Deltares.Standard.Web.Ajax.ScriptReferenceAttribute) | Deltares.Standard.Web.Ajax.ScriptReferenceAttribute
Name (defined in Deltares.Standard.Web.Ajax.ScriptReferenceAttribute) | Deltares.Standard.Web.Ajax.ScriptReferenceAttribute
Path (defined in Deltares.Standard.Web.Ajax.ScriptReferenceAttribute) | Deltares.Standard.Web.Ajax.ScriptReferenceAttribute
ScriptReferenceAttribute(string path) (defined in Deltares.Standard.Web.Ajax.ScriptReferenceAttribute) | Deltares.Standard.Web.Ajax.ScriptReferenceAttribute
ScriptReferenceAttribute(string name, string assembly) (defined in Deltares.Standard.Web.Ajax.ScriptReferenceAttribute) | Deltares.Standard.Web.Ajax.ScriptReferenceAttribute
Generated on Tue Dec 15 2015 18:15:38 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Web.DevExpress.DevExpressPageSupportHandler Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Web
  • DevExpress
  • DevExpressPageSupportHandler
Public Member Functions | List of all members
Deltares.Standard.Web.DevExpress.DevExpressPageSupportHandler Class Reference
Inheritance diagram for Deltares.Standard.Web.DevExpress.DevExpressPageSupportHandler:
Deltares.Standard.Web.IPageSupportHandler

Public Member Functions

bool | PageNeedsUpdate (Page page)
bool | CanHandle (Control subControl)
void | UpdateOnPostback (Control subControl, IPropertyObject source, string property, CultureInfo culture)
void | UpdateControl (Control subControl, IPropertyObject source, string property, CultureInfo culture)
void | UpdateSource (Control control, IPropertyObject source, string property, CultureInfo culture)
void | AssignHandler (Control subControl)
bool | IsAutoPostBack (Control control)
List< Control > | GetControls (ControlCollection controls)
bool | InheritsParentSource (Control control)
bool | IsUpdatePanel (Control control, bool preferUpperPanel)
Generated on Tue Dec 15 2015 18:15:38 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Web
  • DevExpress
  • DevExpressPageSupportHandler
Deltares.Standard.Web.DevExpress.DevExpressPageSupportHandler Member List

This is the complete list of members for Deltares.Standard.Web.DevExpress.DevExpressPageSupportHandler, including all inherited members.

AssignHandler(Control subControl) (defined in Deltares.Standard.Web.DevExpress.DevExpressPageSupportHandler) | Deltares.Standard.Web.DevExpress.DevExpressPageSupportHandler
CanHandle(Control subControl) (defined in Deltares.Standard.Web.DevExpress.DevExpressPageSupportHandler) | Deltares.Standard.Web.DevExpress.DevExpressPageSupportHandler
DevExpressPageSupportHandler() (defined in Deltares.Standard.Web.DevExpress.DevExpressPageSupportHandler) | Deltares.Standard.Web.DevExpress.DevExpressPageSupportHandler
GetControls(ControlCollection controls) (defined in Deltares.Standard.Web.DevExpress.DevExpressPageSupportHandler) | Deltares.Standard.Web.DevExpress.DevExpressPageSupportHandler
InheritsParentSource(Control control) (defined in Deltares.Standard.Web.DevExpress.DevExpressPageSupportHandler) | Deltares.Standard.Web.DevExpress.DevExpressPageSupportHandler
IsAutoPostBack(Control control) (defined in Deltares.Standard.Web.DevExpress.DevExpressPageSupportHandler) | Deltares.Standard.Web.DevExpress.DevExpressPageSupportHandler
IsUpdatePanel(Control control, bool preferUpperPanel) (defined in Deltares.Standard.Web.DevExpress.DevExpressPageSupportHandler) | Deltares.Standard.Web.DevExpress.DevExpressPageSupportHandler
PageNeedsUpdate(Page page) (defined in Deltares.Standard.Web.DevExpress.DevExpressPageSupportHandler) | Deltares.Standard.Web.DevExpress.DevExpressPageSupportHandler
UpdateControl(Control subControl, IPropertyObject source, string property, CultureInfo culture) (defined in Deltares.Standard.Web.DevExpress.DevExpressPageSupportHandler) | Deltares.Standard.Web.DevExpress.DevExpressPageSupportHandler
UpdateOnPostback(Control subControl, IPropertyObject source, string property, CultureInfo culture) (defined in Deltares.Standard.Web.DevExpress.DevExpressPageSupportHandler) | Deltares.Standard.Web.DevExpress.DevExpressPageSupportHandler
UpdateSource(Control control, IPropertyObject source, string property, CultureInfo culture) (defined in Deltares.Standard.Web.DevExpress.DevExpressPageSupportHandler) | Deltares.Standard.Web.DevExpress.DevExpressPageSupportHandler
Generated on Tue Dec 15 2015 18:15:38 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Web.dinoservices.CptService Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Web
  • dinoservices
  • CptService
Public Member Functions | Properties | Events | List of all members
Deltares.Standard.Web.dinoservices.CptService Class Reference

More...

Inheritance diagram for Deltares.Standard.Web.dinoservices.CptService:

Public Member Functions

CptService ()
CPTType[] | findCPT ([System.Xml.Serialization.XmlElementAttribute(Namespace="http://dino.tno.nl/ConePenetrationTest_0_1.xsd")] EnvelopeType findCPTRequest)
void | findCPTAsync (EnvelopeType findCPTRequest)
void | findCPTAsync (EnvelopeType findCPTRequest, object userState)
CPTType[] | findCPTWithCriteria ([System.Xml.Serialization.XmlElementAttribute(Namespace="http://dino.tno.nl/ConePenetrationTest_0_1.xsd")] RequestWithCriteriaType findCPTWithCriteriaRequest)
void | findCPTWithCriteriaAsync (RequestWithCriteriaType findCPTWithCriteriaRequest)
void | findCPTWithCriteriaAsync (RequestWithCriteriaType findCPTWithCriteriaRequest, object userState)
byte[] | getGEF ([System.Xml.Serialization.XmlElementAttribute(Namespace="http://dino.tno.nl/ConePenetrationTest_0_1.xsd")] string getGEFRequest)
void | getGEFAsync (string getGEFRequest)
void | getGEFAsync (string getGEFRequest, object userState)
new void | CancelAsync (object userState)

Properties

new string | Url [get, set]
new bool | UseDefaultCredentials [get, set]

Events

findCPTCompletedEventHandler findCPTCompleted
findCPTWithCriteriaCompletedEventHandler findCPTWithCriteriaCompleted
getGEFCompletedEventHandler getGEFCompleted

Detailed Description

Generated on Tue Dec 15 2015 18:15:39 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Web
  • dinoservices
  • CptService
Deltares.Standard.Web.dinoservices.CptService Member List

This is the complete list of members for Deltares.Standard.Web.dinoservices.CptService, including all inherited members.

CancelAsync(object userState) | Deltares.Standard.Web.dinoservices.CptService
CptService() | Deltares.Standard.Web.dinoservices.CptService
findCPT([System.Xml.Serialization.XmlElementAttribute(Namespace="http://dino.tno.nl/ConePenetrationTest_0_1.xsd")] EnvelopeType findCPTRequest) | Deltares.Standard.Web.dinoservices.CptService
findCPTAsync(EnvelopeType findCPTRequest) | Deltares.Standard.Web.dinoservices.CptService
findCPTAsync(EnvelopeType findCPTRequest, object userState) | Deltares.Standard.Web.dinoservices.CptService
findCPTCompleted | Deltares.Standard.Web.dinoservices.CptService
findCPTWithCriteria([System.Xml.Serialization.XmlElementAttribute(Namespace="http://dino.tno.nl/ConePenetrationTest_0_1.xsd")] RequestWithCriteriaType findCPTWithCriteriaRequest) | Deltares.Standard.Web.dinoservices.CptService
findCPTWithCriteriaAsync(RequestWithCriteriaType findCPTWithCriteriaRequest) | Deltares.Standard.Web.dinoservices.CptService
findCPTWithCriteriaAsync(RequestWithCriteriaType findCPTWithCriteriaRequest, object userState) | Deltares.Standard.Web.dinoservices.CptService
findCPTWithCriteriaCompleted | Deltares.Standard.Web.dinoservices.CptService
getGEF([System.Xml.Serialization.XmlElementAttribute(Namespace="http://dino.tno.nl/ConePenetrationTest_0_1.xsd")] string getGEFRequest) | Deltares.Standard.Web.dinoservices.CptService
getGEFAsync(string getGEFRequest) | Deltares.Standard.Web.dinoservices.CptService
getGEFAsync(string getGEFRequest, object userState) | Deltares.Standard.Web.dinoservices.CptService
getGEFCompleted | Deltares.Standard.Web.dinoservices.CptService
Url (defined in Deltares.Standard.Web.dinoservices.CptService) | Deltares.Standard.Web.dinoservices.CptService
UseDefaultCredentials (defined in Deltares.Standard.Web.dinoservices.CptService) | Deltares.Standard.Web.dinoservices.CptService
Generated on Tue Dec 15 2015 18:15:39 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Web.dinoservices.CPTType Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Web
  • dinoservices
  • CPTType
Properties | List of all members
Deltares.Standard.Web.dinoservices.CPTType Class Reference

More...

Properties

string | id [get, set]
double | x_rd [get, set]
double | y_rd [get, set]

Detailed Description

Generated on Tue Dec 15 2015 18:15:39 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Web
  • dinoservices
  • CPTType
Deltares.Standard.Web.dinoservices.CPTType Member List

This is the complete list of members for Deltares.Standard.Web.dinoservices.CPTType, including all inherited members.

id | Deltares.Standard.Web.dinoservices.CPTType
x_rd | Deltares.Standard.Web.dinoservices.CPTType
y_rd | Deltares.Standard.Web.dinoservices.CPTType
Generated on Tue Dec 15 2015 18:15:39 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Web.dinoservices.CriteriaType Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Web
  • dinoservices
  • CriteriaType
Properties | List of all members
Deltares.Standard.Web.dinoservices.CriteriaType Class Reference

More...

Properties

System.Nullable< long > | minLength [get, set]
System.Nullable< long > | maxLength [get, set]
System.Nullable< bool > | frictionMeasured [get, set]

Detailed Description

Generated on Tue Dec 15 2015 18:15:39 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Web
  • dinoservices
  • CriteriaType
Deltares.Standard.Web.dinoservices.CriteriaType Member List

This is the complete list of members for Deltares.Standard.Web.dinoservices.CriteriaType, including all inherited members.

frictionMeasured | Deltares.Standard.Web.dinoservices.CriteriaType
maxLength | Deltares.Standard.Web.dinoservices.CriteriaType
minLength | Deltares.Standard.Web.dinoservices.CriteriaType
Generated on Tue Dec 15 2015 18:15:39 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Web.dinoservices.EnvelopeType Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Web
  • dinoservices
  • EnvelopeType
Properties | List of all members
Deltares.Standard.Web.dinoservices.EnvelopeType Class Reference

More...

Properties

double | lowerX_rd [get, set]
double | lowerY_rd [get, set]
double | upperX_rd [get, set]
double | upperY_rd [get, set]

Detailed Description

Generated on Tue Dec 15 2015 18:15:39 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Web
  • dinoservices
  • EnvelopeType
Deltares.Standard.Web.dinoservices.EnvelopeType Member List

This is the complete list of members for Deltares.Standard.Web.dinoservices.EnvelopeType, including all inherited members.

lowerX_rd | Deltares.Standard.Web.dinoservices.EnvelopeType
lowerY_rd | Deltares.Standard.Web.dinoservices.EnvelopeType
upperX_rd | Deltares.Standard.Web.dinoservices.EnvelopeType
upperY_rd | Deltares.Standard.Web.dinoservices.EnvelopeType
Generated on Tue Dec 15 2015 18:15:39 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Web.dinoservices.findCPTCompletedEventArgs Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Web
  • dinoservices
  • findCPTCompletedEventArgs
Package Functions | Properties | List of all members
Deltares.Standard.Web.dinoservices.findCPTCompletedEventArgs Class Reference

More...

Inheritance diagram for Deltares.Standard.Web.dinoservices.findCPTCompletedEventArgs:

Package Functions

findCPTCompletedEventArgs (object[] results, System.Exception exception, bool cancelled, object userState)

Properties

CPTType[] Result [get]

Detailed Description

Generated on Tue Dec 15 2015 18:15:39 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Web
  • dinoservices
  • findCPTCompletedEventArgs
Deltares.Standard.Web.dinoservices.findCPTCompletedEventArgs Member List

This is the complete list of members for Deltares.Standard.Web.dinoservices.findCPTCompletedEventArgs, including all inherited members.

findCPTCompletedEventArgs(object[] results, System.Exception exception, bool cancelled, object userState) (defined in Deltares.Standard.Web.dinoservices.findCPTCompletedEventArgs) | Deltares.Standard.Web.dinoservices.findCPTCompletedEventArgs | package
Result | Deltares.Standard.Web.dinoservices.findCPTCompletedEventArgs |
Generated on Tue Dec 15 2015 18:15:39 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Web.dinoservices.findCPTWithCriteriaCompletedEventArgs Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Web
  • dinoservices
  • findCPTWithCriteriaCompletedEventArgs
Package Functions | Properties | List of all members
Deltares.Standard.Web.dinoservices.findCPTWithCriteriaCompletedEventArgs Class Reference

More...

Inheritance diagram for Deltares.Standard.Web.dinoservices.findCPTWithCriteriaCompletedEventArgs:

Package Functions

findCPTWithCriteriaCompletedEventArgs (object[] results, System.Exception exception, bool cancelled, object userState)

Properties

CPTType[] Result [get]

Detailed Description

Generated on Tue Dec 15 2015 18:15:39 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Web
  • dinoservices
  • findCPTWithCriteriaCompletedEventArgs
Deltares.Standard.Web.dinoservices.findCPTWithCriteriaCompletedEventArgs Member List

This is the complete list of members for Deltares.Standard.Web.dinoservices.findCPTWithCriteriaCompletedEventArgs, including all inherited members.

findCPTWithCriteriaCompletedEventArgs(object[] results, System.Exception exception, bool cancelled, object userState) (defined in Deltares.Standard.Web.dinoservices.findCPTWithCriteriaCompletedEventArgs) | Deltares.Standard.Web.dinoservices.findCPTWithCriteriaCompletedEventArgs | package
Result | Deltares.Standard.Web.dinoservices.findCPTWithCriteriaCompletedEventArgs |
Generated on Tue Dec 15 2015 18:15:39 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Web.dinoservices.getGEFCompletedEventArgs Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Web
  • dinoservices
  • getGEFCompletedEventArgs
Package Functions | Properties | List of all members
Deltares.Standard.Web.dinoservices.getGEFCompletedEventArgs Class Reference

More...

Inheritance diagram for Deltares.Standard.Web.dinoservices.getGEFCompletedEventArgs:

Package Functions

getGEFCompletedEventArgs (object[] results, System.Exception exception, bool cancelled, object userState)

Properties

byte[] Result [get]

Detailed Description

Generated on Tue Dec 15 2015 18:15:40 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Web
  • dinoservices
  • getGEFCompletedEventArgs
Deltares.Standard.Web.dinoservices.getGEFCompletedEventArgs Member List

This is the complete list of members for Deltares.Standard.Web.dinoservices.getGEFCompletedEventArgs, including all inherited members.

getGEFCompletedEventArgs(object[] results, System.Exception exception, bool cancelled, object userState) (defined in Deltares.Standard.Web.dinoservices.getGEFCompletedEventArgs) | Deltares.Standard.Web.dinoservices.getGEFCompletedEventArgs | package
Result | Deltares.Standard.Web.dinoservices.getGEFCompletedEventArgs |
Generated on Tue Dec 15 2015 18:15:40 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Web.dinoservices.RequestWithCriteriaType Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Web
  • dinoservices
  • RequestWithCriteriaType
Properties | List of all members
Deltares.Standard.Web.dinoservices.RequestWithCriteriaType Class Reference

More...

Properties

EnvelopeType | envelope [get, set]
CriteriaType | criteria [get, set]

Detailed Description

Generated on Tue Dec 15 2015 18:15:40 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Web
  • dinoservices
  • RequestWithCriteriaType
Deltares.Standard.Web.dinoservices.RequestWithCriteriaType Member List

This is the complete list of members for Deltares.Standard.Web.dinoservices.RequestWithCriteriaType, including all inherited members.

criteria | Deltares.Standard.Web.dinoservices.RequestWithCriteriaType
envelope | Deltares.Standard.Web.dinoservices.RequestWithCriteriaType
Generated on Tue Dec 15 2015 18:15:40 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Web.Properties.Settings Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Web
  • Properties
  • Settings
Properties | List of all members
Deltares.Standard.Web.Properties.Settings Class Reference
Inheritance diagram for Deltares.Standard.Web.Properties.Settings:

Properties

static Settings | Default [get]
string | Deltares_Standard_Web_nl_tno_nitg_dinolks03_CptService [get]
string | Deltares_Standard_Web_dinoservices_CptService [get]
Generated on Tue Dec 15 2015 18:15:40 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Web
  • Properties
  • Settings
Deltares.Standard.Web.Properties.Settings Member List

This is the complete list of members for Deltares.Standard.Web.Properties.Settings, including all inherited members.

Default (defined in Deltares.Standard.Web.Properties.Settings) | Deltares.Standard.Web.Properties.Settings | static
Deltares_Standard_Web_dinoservices_CptService (defined in Deltares.Standard.Web.Properties.Settings) | Deltares.Standard.Web.Properties.Settings |
Deltares_Standard_Web_nl_tno_nitg_dinolks03_CptService (defined in Deltares.Standard.Web.Properties.Settings) | Deltares.Standard.Web.Properties.Settings |
Generated on Tue Dec 15 2015 18:15:40 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Web.ASPPageSupportHandler Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Web
  • ASPPageSupportHandler
Public Member Functions | Protected Member Functions | List of all members
Deltares.Standard.Web.ASPPageSupportHandler Class Reference
Inheritance diagram for Deltares.Standard.Web.ASPPageSupportHandler:
Deltares.Standard.Web.IPageSupportHandler

Public Member Functions

bool | PageNeedsUpdate (Page page)
bool | CanHandle (Control subControl)
void | UpdateOnPostback (Control subControl, IPropertyObject source, string property, CultureInfo culture)
void | UpdateControl (Control subControl, IPropertyObject source, string property, CultureInfo culture)
void | UpdateSource (Control control, IPropertyObject source, string property, CultureInfo culture)
void | AssignHandler (Control subControl)
List< Control > | GetControls (ControlCollection controls)
bool | InheritsParentSource (Control control)
bool | IsUpdatePanel (Control control, bool preferUpperPanel)
bool | IsAutoPostBack (Control control)

Protected Member Functions

void PageSupport_ImageMapClick (object sender, ImageMapEventArgs e)
Generated on Tue Dec 15 2015 18:15:35 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Web
  • ASPPageSupportHandler
Deltares.Standard.Web.ASPPageSupportHandler Member List

This is the complete list of members for Deltares.Standard.Web.ASPPageSupportHandler, including all inherited members.

ASPPageSupportHandler() (defined in Deltares.Standard.Web.ASPPageSupportHandler) | Deltares.Standard.Web.ASPPageSupportHandler |
AssignHandler(Control subControl) (defined in Deltares.Standard.Web.ASPPageSupportHandler) | Deltares.Standard.Web.ASPPageSupportHandler |
CanHandle(Control subControl) (defined in Deltares.Standard.Web.ASPPageSupportHandler) | Deltares.Standard.Web.ASPPageSupportHandler |
GetControls(ControlCollection controls) (defined in Deltares.Standard.Web.ASPPageSupportHandler) | Deltares.Standard.Web.ASPPageSupportHandler |
InheritsParentSource(Control control) (defined in Deltares.Standard.Web.ASPPageSupportHandler) | Deltares.Standard.Web.ASPPageSupportHandler |
IsAutoPostBack(Control control) (defined in Deltares.Standard.Web.ASPPageSupportHandler) | Deltares.Standard.Web.ASPPageSupportHandler |
IsUpdatePanel(Control control, bool preferUpperPanel) (defined in Deltares.Standard.Web.ASPPageSupportHandler) | Deltares.Standard.Web.ASPPageSupportHandler |
PageNeedsUpdate(Page page) (defined in Deltares.Standard.Web.ASPPageSupportHandler) | Deltares.Standard.Web.ASPPageSupportHandler |
PageSupport_ImageMapClick(object sender, ImageMapEventArgs e) (defined in Deltares.Standard.Web.ASPPageSupportHandler) | Deltares.Standard.Web.ASPPageSupportHandler | protected
UpdateControl(Control subControl, IPropertyObject source, string property, CultureInfo culture) (defined in Deltares.Standard.Web.ASPPageSupportHandler) | Deltares.Standard.Web.ASPPageSupportHandler |
UpdateOnPostback(Control subControl, IPropertyObject source, string property, CultureInfo culture) (defined in Deltares.Standard.Web.ASPPageSupportHandler) | Deltares.Standard.Web.ASPPageSupportHandler |
UpdateSource(Control control, IPropertyObject source, string property, CultureInfo culture) (defined in Deltares.Standard.Web.ASPPageSupportHandler) | Deltares.Standard.Web.ASPPageSupportHandler |
Generated on Tue Dec 15 2015 18:15:35 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Web.Chart Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Web
  • Chart
Properties | List of all members
Deltares.Standard.Web.Chart Class Reference
Inheritance diagram for Deltares.Standard.Web.Chart:
Deltares.Standard.Web.IChart

Properties

string | Title [get, set]
string | XAxis [get, set]
string | YAxis [get, set]
List< ISeries > | Series [get]
object[] | XConstants [get, set]
double[] | YConstants [get, set]
object[] | XLabels [get, set]
- Properties inherited from Deltares.Standard.Web.IChart
List< ISeries > | Series [get]
object[] | XConstants [get]
double[] | YConstants [get]
object[] | XLabels [get]
string | Title [get]
string | XAxis [get]
string | YAxis [get]
Generated on Tue Dec 15 2015 18:15:36 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Web
  • Chart
Deltares.Standard.Web.Chart Member List

This is the complete list of members for Deltares.Standard.Web.Chart, including all inherited members.

Series (defined in Deltares.Standard.Web.Chart) | Deltares.Standard.Web.Chart
Title (defined in Deltares.Standard.Web.Chart) | Deltares.Standard.Web.Chart
XAxis (defined in Deltares.Standard.Web.Chart) | Deltares.Standard.Web.Chart
XConstants (defined in Deltares.Standard.Web.Chart) | Deltares.Standard.Web.Chart
XLabels (defined in Deltares.Standard.Web.Chart) | Deltares.Standard.Web.Chart
YAxis (defined in Deltares.Standard.Web.Chart) | Deltares.Standard.Web.Chart
YConstants (defined in Deltares.Standard.Web.Chart) | Deltares.Standard.Web.Chart
Generated on Tue Dec 15 2015 18:15:36 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Web.Cpt Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Web
  • Cpt
Public Member Functions | Static Public Member Functions | Properties | List of all members
Deltares.Standard.Web.Cpt Class Reference

Public Member Functions

Cpt (double aX, double aY, string aID)
Image DisplayResults (string cptId, string location, string imageName, string rulesFile, string rule, bool createBitmap)
Static function you can use to generate a picture of a CPT using a gef file from the DINO database. More...

Static Public Member Functions

static string | RetrieveGefFile (string cptId)
Retrieves the gef file name as string. More...
static void | WriteGefFile (string cptId, string gefFileName)

Properties

double | X [get]
Gets the x-coordinate value. More...
double | Y [get]
Gets the y-coordinate value. More...
string | ID [get]
Gets the identifier. More...

Member Function Documentation

Image Deltares.Standard.Web.Cpt.DisplayResults | ( | string | cptId,
 |  | string | location,
 |  | string | imageName,
 |  | string | rulesFile,
 |  | string | rule,
 |  | bool | createBitmap
 | ) |  |

Static function you can use to generate a picture of a CPT using a gef file from the DINO database.

Parameters
cptId | Id of the CPT as it is known in the DINO database
location | Path to where the image should be located
imageName | Name the image will be given. Provide without extension.
rule | What rule should be used when interpreting the gef file.
rulesFile | Location of DGSCPTipRules.xml file.
createBitmap | If true, the result will be a bitmap, else a jpg.
Returns
static string Deltares.Standard.Web.Cpt.RetrieveGefFile ( string cptId )
static

Retrieves the gef file name as string.

Parameters
cptId The CPT identifier.
Returns
The file name

Property Documentation

string Deltares.Standard.Web.Cpt.ID
get

Gets the identifier.

The identifier.

double Deltares.Standard.Web.Cpt.X
get

Gets the x-coordinate value.

The x.

double Deltares.Standard.Web.Cpt.Y
get

Gets the y-coordinate value.

The y.

Generated on Tue Dec 15 2015 18:15:36 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Web
  • Cpt
Deltares.Standard.Web.Cpt Member List

This is the complete list of members for Deltares.Standard.Web.Cpt, including all inherited members.

Cpt(double aX, double aY, string aID) (defined in Deltares.Standard.Web.Cpt) | Deltares.Standard.Web.Cpt |
DisplayResults(string cptId, string location, string imageName, string rulesFile, string rule, bool createBitmap) | Deltares.Standard.Web.Cpt |
ID | Deltares.Standard.Web.Cpt |
RetrieveGefFile(string cptId) | Deltares.Standard.Web.Cpt | static
WriteGefFile(string cptId, string gefFileName) (defined in Deltares.Standard.Web.Cpt) | Deltares.Standard.Web.Cpt | static
X | Deltares.Standard.Web.Cpt |
Y | Deltares.Standard.Web.Cpt |
Generated on Tue Dec 15 2015 18:15:36 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Web.CptServiceAgent Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Web
  • CptServiceAgent
Public Member Functions | List of all members
Deltares.Standard.Web.CptServiceAgent Class Reference

TODO add more actions to current class (maybe redesign). Now this agent only supports the GetGEF action More...

Public Member Functions

string GetGEFAsString (string cptId)
Gets the gef file name as string. More...

Detailed Description

TODO add more actions to current class (maybe redesign). Now this agent only supports the GetGEF action

Member Function Documentation

string Deltares.Standard.Web.CptServiceAgent.GetGEFAsString ( string cptId )

Gets the gef file name as string.

Parameters
cptId The CPT identifier.
Returns
Exceptions
System.ArgumentException Invalid cpt id in argument
Generated on Tue Dec 15 2015 18:15:36 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Web
  • CptServiceAgent
Deltares.Standard.Web.CptServiceAgent Member List

This is the complete list of members for Deltares.Standard.Web.CptServiceAgent, including all inherited members.

GetGEFAsString(string cptId) Deltares.Standard.Web.CptServiceAgent
Generated on Tue Dec 15 2015 18:15:36 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Web.DINOInterface Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Web
  • DINOInterface
Public Member Functions | List of all members
Deltares.Standard.Web.DINOInterface Class Reference

Public Member Functions

bool | GetCPTsFromDINO (int aLower_rdx, int aLower_rdy, int aUpper_rdx, int aUpper_rdy)
bool | GetCPTsFromDINOWithCriteria (int aLower_rdx, int aLower_rdy, int aUpper_rdx, int aUpper_rdy, bool aFriction, long aMinLength, long aMaxLength)
int | CPTCount ()
Cpt | GetCPT (int aIndex)
Generated on Tue Dec 15 2015 18:15:36 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Web
  • DINOInterface
Deltares.Standard.Web.DINOInterface Member List

This is the complete list of members for Deltares.Standard.Web.DINOInterface, including all inherited members.

CPTCount() (defined in Deltares.Standard.Web.DINOInterface) | Deltares.Standard.Web.DINOInterface
GetCPT(int aIndex) (defined in Deltares.Standard.Web.DINOInterface) | Deltares.Standard.Web.DINOInterface
GetCPTsFromDINO(int aLower_rdx, int aLower_rdy, int aUpper_rdx, int aUpper_rdy) (defined in Deltares.Standard.Web.DINOInterface) | Deltares.Standard.Web.DINOInterface
GetCPTsFromDINOWithCriteria(int aLower_rdx, int aLower_rdy, int aUpper_rdx, int aUpper_rdy, bool aFriction, long aMinLength, long aMaxLength) (defined in Deltares.Standard.Web.DINOInterface) | Deltares.Standard.Web.DINOInterface
Generated on Tue Dec 15 2015 18:15:36 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Web.Encryption Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Web
  • Encryption
Static Public Member Functions | List of all members
Deltares.Standard.Web.Encryption Class Reference

Static Public Member Functions

static string | CreateSessionID (string AString, bool AIsTimeLimited)
static bool | IsSessionIDOK (string ASessionID, string AString, int AMaxMinutes)
Generated on Tue Dec 15 2015 18:15:36 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Web
  • Encryption
Deltares.Standard.Web.Encryption Member List

This is the complete list of members for Deltares.Standard.Web.Encryption, including all inherited members.

CreateSessionID(string AString, bool AIsTimeLimited) (defined in Deltares.Standard.Web.Encryption) | Deltares.Standard.Web.Encryption | static
IsSessionIDOK(string ASessionID, string AString, int AMaxMinutes) (defined in Deltares.Standard.Web.Encryption) | Deltares.Standard.Web.Encryption | static
Generated on Tue Dec 15 2015 18:15:36 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Web.IChart Interface Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Web
  • IChart
Properties | List of all members
Deltares.Standard.Web.IChart Interface Reference
Inheritance diagram for Deltares.Standard.Web.IChart:
Deltares.Standard.Web.Chart

Properties

List< ISeries > | Series [get]
object[] | XConstants [get]
double[] | YConstants [get]
object[] | XLabels [get]
string | Title [get]
string | XAxis [get]
string | YAxis [get]
Generated on Tue Dec 15 2015 18:15:36 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Web
  • IChart
Deltares.Standard.Web.IChart Member List

This is the complete list of members for Deltares.Standard.Web.IChart, including all inherited members.

Series (defined in Deltares.Standard.Web.IChart) | Deltares.Standard.Web.IChart
Title (defined in Deltares.Standard.Web.IChart) | Deltares.Standard.Web.IChart
XAxis (defined in Deltares.Standard.Web.IChart) | Deltares.Standard.Web.IChart
XConstants (defined in Deltares.Standard.Web.IChart) | Deltares.Standard.Web.IChart
XLabels (defined in Deltares.Standard.Web.IChart) | Deltares.Standard.Web.IChart
YAxis (defined in Deltares.Standard.Web.IChart) | Deltares.Standard.Web.IChart
YConstants (defined in Deltares.Standard.Web.IChart) | Deltares.Standard.Web.IChart
Generated on Tue Dec 15 2015 18:15:36 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Web.ImageHttpHandler Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Web
  • ImageHttpHandler
Public Member Functions | Properties | List of all members
Deltares.Standard.Web.ImageHttpHandler Class Reference
Inheritance diagram for Deltares.Standard.Web.ImageHttpHandler:

Public Member Functions

void ProcessRequest (HttpContext context)

Properties

bool IsReusable [get]
Generated on Tue Dec 15 2015 18:15:36 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Web
  • ImageHttpHandler
Deltares.Standard.Web.ImageHttpHandler Member List

This is the complete list of members for Deltares.Standard.Web.ImageHttpHandler, including all inherited members.

IsReusable (defined in Deltares.Standard.Web.ImageHttpHandler) | Deltares.Standard.Web.ImageHttpHandler
ProcessRequest(HttpContext context) (defined in Deltares.Standard.Web.ImageHttpHandler) | Deltares.Standard.Web.ImageHttpHandler
Generated on Tue Dec 15 2015 18:15:36 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Web.IPageSupportHandler Interface Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Web
  • IPageSupportHandler
Public Member Functions | List of all members
Deltares.Standard.Web.IPageSupportHandler Interface Reference
Inheritance diagram for Deltares.Standard.Web.IPageSupportHandler:
Deltares.Standard.Web.Ajax.AjaxPageSupportHandler Deltares.Standard.Web.ASPPageSupportHandler Deltares.Standard.Web.DevExpress.DevExpressPageSupportHandler

Public Member Functions

bool | PageNeedsUpdate (Page page)
bool | CanHandle (Control subControl)
void | UpdateControl (Control subControl, IPropertyObject source, string property, CultureInfo culture)
void | UpdateOnPostback (Control subControl, IPropertyObject source, string property, CultureInfo culture)
void | UpdateSource (Control control, IPropertyObject source, string property, CultureInfo culture)
void | AssignHandler (Control subControl)
List< Control > | GetControls (ControlCollection controls)
bool | InheritsParentSource (Control control)
bool | IsUpdatePanel (Control control, bool preferUpperPanel)
bool | IsAutoPostBack (Control control)
Generated on Tue Dec 15 2015 18:15:36 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Web
  • IPageSupportHandler
Deltares.Standard.Web.IPageSupportHandler Member List

This is the complete list of members for Deltares.Standard.Web.IPageSupportHandler, including all inherited members.

AssignHandler(Control subControl) (defined in Deltares.Standard.Web.IPageSupportHandler) | Deltares.Standard.Web.IPageSupportHandler
CanHandle(Control subControl) (defined in Deltares.Standard.Web.IPageSupportHandler) | Deltares.Standard.Web.IPageSupportHandler
GetControls(ControlCollection controls) (defined in Deltares.Standard.Web.IPageSupportHandler) | Deltares.Standard.Web.IPageSupportHandler
InheritsParentSource(Control control) (defined in Deltares.Standard.Web.IPageSupportHandler) | Deltares.Standard.Web.IPageSupportHandler
IsAutoPostBack(Control control) (defined in Deltares.Standard.Web.IPageSupportHandler) | Deltares.Standard.Web.IPageSupportHandler
IsUpdatePanel(Control control, bool preferUpperPanel) (defined in Deltares.Standard.Web.IPageSupportHandler) | Deltares.Standard.Web.IPageSupportHandler
PageNeedsUpdate(Page page) (defined in Deltares.Standard.Web.IPageSupportHandler) | Deltares.Standard.Web.IPageSupportHandler
UpdateControl(Control subControl, IPropertyObject source, string property, CultureInfo culture) (defined in Deltares.Standard.Web.IPageSupportHandler) | Deltares.Standard.Web.IPageSupportHandler
UpdateOnPostback(Control subControl, IPropertyObject source, string property, CultureInfo culture) (defined in Deltares.Standard.Web.IPageSupportHandler) | Deltares.Standard.Web.IPageSupportHandler
UpdateSource(Control control, IPropertyObject source, string property, CultureInfo culture) (defined in Deltares.Standard.Web.IPageSupportHandler) | Deltares.Standard.Web.IPageSupportHandler
Generated on Tue Dec 15 2015 18:15:36 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Web.IUploadDownload Interface Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Web
  • IUploadDownload
Public Member Functions | List of all members
Deltares.Standard.Web.IUploadDownload Interface Reference

Public Member Functions

void | UploadFile (string property, FileInfo file)
FileInfo | DownloadFile (string property)
Generated on Tue Dec 15 2015 18:15:36 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Web
  • IUploadDownload
Deltares.Standard.Web.IUploadDownload Member List

This is the complete list of members for Deltares.Standard.Web.IUploadDownload, including all inherited members.

DownloadFile(string property) (defined in Deltares.Standard.Web.IUploadDownload) | Deltares.Standard.Web.IUploadDownload
UploadFile(string property, FileInfo file) (defined in Deltares.Standard.Web.IUploadDownload) | Deltares.Standard.Web.IUploadDownload
Generated on Tue Dec 15 2015 18:15:36 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Web.Log Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Web
  • Log
Static Public Member Functions | Properties | List of all members
Deltares.Standard.Web.Log Class Reference

Static Public Member Functions

static void | Write (Exception exception)
static void | Write (string message, LogType logType)
static void | Write (string applicationName, string action, string userID, string ipAddress)
static void | Detect (Type type, string method, string alias)
static string | ShouldLog (Type type, string method)

Properties

static string FileName [get, set]
Generated on Tue Dec 15 2015 18:15:36 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Web
  • Log
Deltares.Standard.Web.Log Member List

This is the complete list of members for Deltares.Standard.Web.Log, including all inherited members.

Detect(Type type, string method, string alias) (defined in Deltares.Standard.Web.Log) | Deltares.Standard.Web.Log | static
FileName (defined in Deltares.Standard.Web.Log) | Deltares.Standard.Web.Log | static
ShouldLog(Type type, string method) (defined in Deltares.Standard.Web.Log) | Deltares.Standard.Web.Log | static
Write(Exception exception) (defined in Deltares.Standard.Web.Log) | Deltares.Standard.Web.Log | static
Write(string message, LogType logType) (defined in Deltares.Standard.Web.Log) | Deltares.Standard.Web.Log | static
Write(string applicationName, string action, string userID, string ipAddress) (defined in Deltares.Standard.Web.Log) | Deltares.Standard.Web.Log | static
Generated on Tue Dec 15 2015 18:15:36 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Web.LogDetect Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Web
  • LogDetect
Public Member Functions | Properties | List of all members
Deltares.Standard.Web.LogDetect Class Reference

Public Member Functions

LogDetect (Type type, string method, string alias)

Properties

Type | Type [get]
string | Method [get]
string | Alias [get]
Generated on Tue Dec 15 2015 18:15:36 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Web
  • LogDetect
Deltares.Standard.Web.LogDetect Member List

This is the complete list of members for Deltares.Standard.Web.LogDetect, including all inherited members.

Alias (defined in Deltares.Standard.Web.LogDetect) | Deltares.Standard.Web.LogDetect
LogDetect(Type type, string method, string alias) (defined in Deltares.Standard.Web.LogDetect) | Deltares.Standard.Web.LogDetect
Method (defined in Deltares.Standard.Web.LogDetect) | Deltares.Standard.Web.LogDetect
Type (defined in Deltares.Standard.Web.LogDetect) | Deltares.Standard.Web.LogDetect
Generated on Tue Dec 15 2015 18:15:36 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.Web.PageSupport Class Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Web
  • PageSupport
Static Public Member Functions | List of all members
Deltares.Standard.Web.PageSupport Class Reference

Class which takes care for all interaction between an ASP page and an IPropertyObject. This class takes care that properties are displayed in the ASP page and in the event the user changes values, they are sent back to the source object. All web controls in your web page associated with a property or method in the source object, should start with an underscoare followed by the property or method name. More...

Static Public Member Functions

static void | PageLoad (Page page, IPropertyObject source)
Use this method in the page load event of your page More...
static void | AddPageSupportHandler (IPageSupportHandler pageSupportHandler)
static IPropertyObject | GetSource (Control control)
static void | SetSource (Control control, IPropertyObject source)
static void | UpdateControlContainer (Control control, IPropertyObject source)
static void | UpdateControl (Control control)
static void | UpdateControl (Control control, IPropertyObject source)
static void | UpdateOnPostback (Control control, IPropertyObject source)
static void | UpdateSource (Control control, IPropertyObject source)
static void | AssignHandlers (Control control)
static List< Control > | GetControls (ControlCollection controls)
static void | ValueChanged (object sender, EventArgs e)
static void | ButtonClick (object sender, EventArgs e)
static Control | GetPostBackControl (Page page)
static void | SetUrl (Control control, string url)
static string | GetUrl (Control control)
static void | DownloadFile (Page page, FileInfo file)
static CultureInfo | GetCultureInfo (string language)
static string | GetNumericValidationScript (Control control, double minValue, double maxValue)
static string | GetDataPath (string serverPath)
static string | GetSessionPath (HttpServerUtility server)
static string | GetLogFile (string serverPath)
static void | LogEvent (HttpSessionState session, string action)

Detailed Description

Class which takes care for all interaction between an ASP page and an IPropertyObject. This class takes care that properties are displayed in the ASP page and in the event the user changes values, they are sent back to the source object. All web controls in your web page associated with a property or method in the source object, should start with an underscoare followed by the property or method name.

Member Function Documentation

static void Deltares.Standard.Web.PageSupport.PageLoad | ( | Page | page,
 |  | IPropertyObject | source
 | ) |  |
static

Use this method in the page load event of your page

Parameters
control | The ASP page
source | The underlying business object
Generated on Tue Dec 15 2015 18:15:36 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • Web
  • PageSupport
Deltares.Standard.Web.PageSupport Member List

This is the complete list of members for Deltares.Standard.Web.PageSupport, including all inherited members.

AddPageSupportHandler(IPageSupportHandler pageSupportHandler) (defined in Deltares.Standard.Web.PageSupport) | Deltares.Standard.Web.PageSupport | static
AssignHandlers(Control control) (defined in Deltares.Standard.Web.PageSupport) | Deltares.Standard.Web.PageSupport | static
ButtonClick(object sender, EventArgs e) (defined in Deltares.Standard.Web.PageSupport) | Deltares.Standard.Web.PageSupport | static
DownloadFile(Page page, FileInfo file) (defined in Deltares.Standard.Web.PageSupport) | Deltares.Standard.Web.PageSupport | static
GetControls(ControlCollection controls) (defined in Deltares.Standard.Web.PageSupport) | Deltares.Standard.Web.PageSupport | static
GetCultureInfo(string language) (defined in Deltares.Standard.Web.PageSupport) | Deltares.Standard.Web.PageSupport | static
GetDataPath(string serverPath) (defined in Deltares.Standard.Web.PageSupport) | Deltares.Standard.Web.PageSupport | static
GetLogFile(string serverPath) (defined in Deltares.Standard.Web.PageSupport) | Deltares.Standard.Web.PageSupport | static
GetNumericValidationScript(Control control, double minValue, double maxValue) (defined in Deltares.Standard.Web.PageSupport) | Deltares.Standard.Web.PageSupport | static
GetPostBackControl(Page page) (defined in Deltares.Standard.Web.PageSupport) | Deltares.Standard.Web.PageSupport | static
GetSessionPath(HttpServerUtility server) (defined in Deltares.Standard.Web.PageSupport) | Deltares.Standard.Web.PageSupport | static
GetSource(Control control) (defined in Deltares.Standard.Web.PageSupport) | Deltares.Standard.Web.PageSupport | static
GetUrl(Control control) (defined in Deltares.Standard.Web.PageSupport) | Deltares.Standard.Web.PageSupport | static
LogEvent(HttpSessionState session, string action) (defined in Deltares.Standard.Web.PageSupport) | Deltares.Standard.Web.PageSupport | static
PageLoad(Page page, IPropertyObject source) | Deltares.Standard.Web.PageSupport | static
SetSource(Control control, IPropertyObject source) (defined in Deltares.Standard.Web.PageSupport) | Deltares.Standard.Web.PageSupport | static
SetUrl(Control control, string url) (defined in Deltares.Standard.Web.PageSupport) | Deltares.Standard.Web.PageSupport | static
UpdateControl(Control control) (defined in Deltares.Standard.Web.PageSupport) | Deltares.Standard.Web.PageSupport | static
UpdateControl(Control control, IPropertyObject source) (defined in Deltares.Standard.Web.PageSupport) | Deltares.Standard.Web.PageSupport | static
UpdateControlContainer(Control control, IPropertyObject source) (defined in Deltares.Standard.Web.PageSupport) | Deltares.Standard.Web.PageSupport | static
UpdateOnPostback(Control control, IPropertyObject source) (defined in Deltares.Standard.Web.PageSupport) | Deltares.Standard.Web.PageSupport | static
UpdateSource(Control control, IPropertyObject source) (defined in Deltares.Standard.Web.PageSupport) | Deltares.Standard.Web.PageSupport | static
ValueChanged(object sender, EventArgs e) (defined in Deltares.Standard.Web.PageSupport) | Deltares.Standard.Web.PageSupport | static
Generated on Tue Dec 15 2015 18:15:36 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.ICircleHotSpot Interface Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • ICircleHotSpot
Properties | List of all members
Deltares.Standard.ICircleHotSpot Interface Reference
Inheritance diagram for Deltares.Standard.ICircleHotSpot:
Deltares.Standard.IHotSpot

Properties

int | X [get]
int | Y [get]
int | Radius [get]
- Properties inherited from Deltares.Standard.IHotSpot
HotSpotAction | Action [get]
string | Property [get]
object | Data [get]
Generated on Tue Dec 15 2015 18:14:25 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • ICircleHotSpot
Deltares.Standard.ICircleHotSpot Member List

This is the complete list of members for Deltares.Standard.ICircleHotSpot, including all inherited members.

Action (defined in Deltares.Standard.IHotSpot) | Deltares.Standard.IHotSpot
Data (defined in Deltares.Standard.IHotSpot) | Deltares.Standard.IHotSpot
Property (defined in Deltares.Standard.IHotSpot) | Deltares.Standard.IHotSpot
Radius (defined in Deltares.Standard.ICircleHotSpot) | Deltares.Standard.ICircleHotSpot
X (defined in Deltares.Standard.ICircleHotSpot) | Deltares.Standard.ICircleHotSpot
Y (defined in Deltares.Standard.ICircleHotSpot) | Deltares.Standard.ICircleHotSpot
Generated on Tue Dec 15 2015 18:14:25 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.ICurrent Interface Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • ICurrent
Properties | List of all members
Deltares.Standard.ICurrent Interface Reference

Properties

bool Current [get, set]
Generated on Tue Dec 15 2015 18:14:25 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • ICurrent
Deltares.Standard.ICurrent Member List

This is the complete list of members for Deltares.Standard.ICurrent, including all inherited members.

Current (defined in Deltares.Standard.ICurrent) Deltares.Standard.ICurrent
Generated on Tue Dec 15 2015 18:14:25 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.IHotSpot Interface Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • IHotSpot
Properties | List of all members
Deltares.Standard.IHotSpot Interface Reference
Inheritance diagram for Deltares.Standard.IHotSpot:
Deltares.Standard.ICircleHotSpot Deltares.Standard.IPolygonHotSpot Deltares.Standard.IRectangleHotSpot Deltares.Standard.ITriangleHotSpot

Properties

HotSpotAction | Action [get]
string | Property [get]
object | Data [get]
Generated on Tue Dec 15 2015 18:14:25 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • IHotSpot
Deltares.Standard.IHotSpot Member List

This is the complete list of members for Deltares.Standard.IHotSpot, including all inherited members.

Action (defined in Deltares.Standard.IHotSpot) | Deltares.Standard.IHotSpot
Data (defined in Deltares.Standard.IHotSpot) | Deltares.Standard.IHotSpot
Property (defined in Deltares.Standard.IHotSpot) | Deltares.Standard.IHotSpot
Generated on Tue Dec 15 2015 18:14:25 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.IMap Interface Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • IMap
Properties | List of all members
Deltares.Standard.IMap Interface Reference

This interface is a helper for interfacing with ImageMap web control More...

Properties

Image | Image [get]
IList< IHotSpot > | HotSpots [get]
IHotSpot | SelectedHotSpot [get, set]

Detailed Description

This interface is a helper for interfacing with ImageMap web control

See also
Deltares.Standard.PropertyObject
Generated on Tue Dec 15 2015 18:14:25 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • IMap
Deltares.Standard.IMap Member List

This is the complete list of members for Deltares.Standard.IMap, including all inherited members.

HotSpots (defined in Deltares.Standard.IMap) | Deltares.Standard.IMap
Image (defined in Deltares.Standard.IMap) | Deltares.Standard.IMap
SelectedHotSpot (defined in Deltares.Standard.IMap) | Deltares.Standard.IMap
Generated on Tue Dec 15 2015 18:14:25 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.IPolygonHotSpot Interface Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • IPolygonHotSpot
Properties | List of all members
Deltares.Standard.IPolygonHotSpot Interface Reference
Inheritance diagram for Deltares.Standard.IPolygonHotSpot:
Deltares.Standard.IHotSpot

Properties

int[] | X [get]
int[] | Y [get]
- Properties inherited from Deltares.Standard.IHotSpot
HotSpotAction | Action [get]
string | Property [get]
object | Data [get]
Generated on Tue Dec 15 2015 18:14:26 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • IPolygonHotSpot
Deltares.Standard.IPolygonHotSpot Member List

This is the complete list of members for Deltares.Standard.IPolygonHotSpot, including all inherited members.

Action (defined in Deltares.Standard.IHotSpot) | Deltares.Standard.IHotSpot
Data (defined in Deltares.Standard.IHotSpot) | Deltares.Standard.IHotSpot
Property (defined in Deltares.Standard.IHotSpot) | Deltares.Standard.IHotSpot
X (defined in Deltares.Standard.IPolygonHotSpot) | Deltares.Standard.IPolygonHotSpot
Y (defined in Deltares.Standard.IPolygonHotSpot) | Deltares.Standard.IPolygonHotSpot
Generated on Tue Dec 15 2015 18:14:26 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.IRectangleHotSpot Interface Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • IRectangleHotSpot
Properties | List of all members
Deltares.Standard.IRectangleHotSpot Interface Reference
Inheritance diagram for Deltares.Standard.IRectangleHotSpot:
Deltares.Standard.IHotSpot

Properties

int | Left [get]
int | Right [get]
int | Top [get]
int | Bottom [get]
- Properties inherited from Deltares.Standard.IHotSpot
HotSpotAction | Action [get]
string | Property [get]
object | Data [get]
Generated on Tue Dec 15 2015 18:14:26 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • IRectangleHotSpot
Deltares.Standard.IRectangleHotSpot Member List

This is the complete list of members for Deltares.Standard.IRectangleHotSpot, including all inherited members.

Action (defined in Deltares.Standard.IHotSpot) | Deltares.Standard.IHotSpot
Bottom (defined in Deltares.Standard.IRectangleHotSpot) | Deltares.Standard.IRectangleHotSpot
Data (defined in Deltares.Standard.IHotSpot) | Deltares.Standard.IHotSpot
Left (defined in Deltares.Standard.IRectangleHotSpot) | Deltares.Standard.IRectangleHotSpot
Property (defined in Deltares.Standard.IHotSpot) | Deltares.Standard.IHotSpot
Right (defined in Deltares.Standard.IRectangleHotSpot) | Deltares.Standard.IRectangleHotSpot
Top (defined in Deltares.Standard.IRectangleHotSpot) | Deltares.Standard.IRectangleHotSpot
Generated on Tue Dec 15 2015 18:14:26 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.ITriangleHotSpot Interface Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • ITriangleHotSpot
Properties | List of all members
Deltares.Standard.ITriangleHotSpot Interface Reference
Inheritance diagram for Deltares.Standard.ITriangleHotSpot:
Deltares.Standard.IHotSpot

Properties

int | Left [get]
int | Right [get]
int | Top [get]
int | Bottom [get]
- Properties inherited from Deltares.Standard.IHotSpot
HotSpotAction | Action [get]
string | Property [get]
object | Data [get]
Generated on Tue Dec 15 2015 18:14:26 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • ITriangleHotSpot
Deltares.Standard.ITriangleHotSpot Member List

This is the complete list of members for Deltares.Standard.ITriangleHotSpot, including all inherited members.

Action (defined in Deltares.Standard.IHotSpot) | Deltares.Standard.IHotSpot
Bottom (defined in Deltares.Standard.ITriangleHotSpot) | Deltares.Standard.ITriangleHotSpot
Data (defined in Deltares.Standard.IHotSpot) | Deltares.Standard.IHotSpot
Left (defined in Deltares.Standard.ITriangleHotSpot) | Deltares.Standard.ITriangleHotSpot
Property (defined in Deltares.Standard.IHotSpot) | Deltares.Standard.IHotSpot
Right (defined in Deltares.Standard.ITriangleHotSpot) | Deltares.Standard.ITriangleHotSpot
Top (defined in Deltares.Standard.ITriangleHotSpot) | Deltares.Standard.ITriangleHotSpot
Generated on Tue Dec 15 2015 18:14:26 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Deltares.Standard.IUrl Interface Reference

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • IUrl
Properties | List of all members
Deltares.Standard.IUrl Interface Reference

Properties

string Url [get]
Generated on Tue Dec 15 2015 18:14:26 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Deltares
  • Standard
  • IUrl
Deltares.Standard.IUrl Member List

This is the complete list of members for Deltares.Standard.IUrl, including all inherited members.

Url (defined in Deltares.Standard.IUrl) Deltares.Standard.IUrl
Generated on Tue Dec 15 2015 18:14:26 for D-SoilModel by doxygen 1.8.10


D-SoilModel: DeltaresStandardNative::Class1 Class Reference

Tool for the (stochastic) subsoil definition.
  • DeltaresStandardNative
  • Class1
DeltaresStandardNative::Class1 Class Reference
Generated on Tue Dec 15 2015 18:15:40 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Waternet.HeadLine Class Reference

Tool for the (stochastic) subsoil definition.
  • Waternet
  • HeadLine
Properties | List of all members
Waternet.HeadLine Class Reference

Properties

WaternetPolyCurve PolyCurve [get, set]
Generated on Tue Dec 15 2015 18:15:40 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Waternet
  • HeadLine
Waternet.HeadLine Member List

This is the complete list of members for Waternet.HeadLine, including all inherited members.

PolyCurve (defined in Waternet.HeadLine) Waternet.HeadLine
Generated on Tue Dec 15 2015 18:15:40 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Waternet.PhreaticLine Class Reference

Tool for the (stochastic) subsoil definition.
  • Waternet
  • PhreaticLine
Properties | List of all members
Waternet.PhreaticLine Class Reference

Properties

WaternetPolyCurve PolyCurve [get, set]
Generated on Tue Dec 15 2015 18:15:40 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Waternet
  • PhreaticLine
Waternet.PhreaticLine Member List

This is the complete list of members for Waternet.PhreaticLine, including all inherited members.

PolyCurve (defined in Waternet.PhreaticLine) Waternet.PhreaticLine
Generated on Tue Dec 15 2015 18:15:40 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Waternet.Waternet Class Reference

Tool for the (stochastic) subsoil definition.
  • Waternet
  • Waternet
Properties | List of all members
Waternet.Waternet Class Reference

Properties

ArrayList | WaternetCurves [get, set]
ArrayList | WaternetLines [get, set]
ArrayList | HeadLines [get, set]
Generated on Tue Dec 15 2015 18:15:40 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Waternet
  • Waternet
Waternet.Waternet Member List

This is the complete list of members for Waternet.Waternet, including all inherited members.

HeadLines (defined in Waternet.Waternet) | Waternet.Waternet
WaternetCurves (defined in Waternet.Waternet) | Waternet.Waternet
WaternetLines (defined in Waternet.Waternet) | Waternet.Waternet
Generated on Tue Dec 15 2015 18:15:40 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Waternet.WaternetCurve Class Reference

Tool for the (stochastic) subsoil definition.
  • Waternet
  • WaternetCurve
Properties | List of all members
Waternet.WaternetCurve Class Reference

Properties

WaternetPoint | BeginPoint [get, set]
WaternetPoint | EndPoint [get, set]
Generated on Tue Dec 15 2015 18:15:40 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Waternet
  • WaternetCurve
Waternet.WaternetCurve Member List

This is the complete list of members for Waternet.WaternetCurve, including all inherited members.

BeginPoint (defined in Waternet.WaternetCurve) | Waternet.WaternetCurve
EndPoint (defined in Waternet.WaternetCurve) | Waternet.WaternetCurve
Generated on Tue Dec 15 2015 18:15:40 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Waternet.WaternetLine Class Reference

Tool for the (stochastic) subsoil definition.
  • Waternet
  • WaternetLine
Properties | List of all members
Waternet.WaternetLine Class Reference

Properties

WaternetPolyCurve | PolyCurve [get, set]
HeadLine | HeadLine [get, set]
Generated on Tue Dec 15 2015 18:15:40 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Waternet
  • WaternetLine
Waternet.WaternetLine Member List

This is the complete list of members for Waternet.WaternetLine, including all inherited members.

HeadLine (defined in Waternet.WaternetLine) | Waternet.WaternetLine
PolyCurve (defined in Waternet.WaternetLine) | Waternet.WaternetLine
Generated on Tue Dec 15 2015 18:15:40 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Waternet.WaternetPoint Class Reference

Tool for the (stochastic) subsoil definition.
  • Waternet
  • WaternetPoint
Properties | List of all members
Waternet.WaternetPoint Class Reference

Properties

double | X [get, set]
double | Y [get, set]
double | Z [get, set]
Generated on Tue Dec 15 2015 18:15:40 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Waternet
  • WaternetPoint
Waternet.WaternetPoint Member List

This is the complete list of members for Waternet.WaternetPoint, including all inherited members.

X (defined in Waternet.WaternetPoint) | Waternet.WaternetPoint
Y (defined in Waternet.WaternetPoint) | Waternet.WaternetPoint
Z (defined in Waternet.WaternetPoint) | Waternet.WaternetPoint
Generated on Tue Dec 15 2015 18:15:40 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Waternet.WaternetPolyCurve Class Reference

Tool for the (stochastic) subsoil definition.
  • Waternet
  • WaternetPolyCurve
Properties | List of all members
Waternet.WaternetPolyCurve Class Reference

Properties

ArrayList | WaternetCurveReferences [get, set]
bool | IsIncreasingX [get, set]
bool | IsClosed [get, set]
Generated on Tue Dec 15 2015 18:15:40 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Member List

Tool for the (stochastic) subsoil definition.
  • Waternet
  • WaternetPolyCurve
Waternet.WaternetPolyCurve Member List

This is the complete list of members for Waternet.WaternetPolyCurve, including all inherited members.

IsClosed (defined in Waternet.WaternetPolyCurve) | Waternet.WaternetPolyCurve
IsIncreasingX (defined in Waternet.WaternetPolyCurve) | Waternet.WaternetPolyCurve
WaternetCurveReferences (defined in Waternet.WaternetPolyCurve) | Waternet.WaternetPolyCurve
Generated on Tue Dec 15 2015 18:15:40 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Class Index

Tool for the (stochastic) subsoil definition.
Class Index
A | B | C | D | E | F | G | H | I | L | M | N | O | P | R | S | T | U | V | W | X | Z
A
DotSpatialGeographicConverter (Deltares.Standard.DotSpatialDgs) GraphicsInfo (Deltares.Standard.Forms) MessageBoxManager (Deltares.Standard.Forms) SimpleButtonBinding (Deltares.Standard.Forms.DExpress)
DotSpatialGeographicHelper (Deltares.Standard.DotSpatialDgs) GreaterThanStrategy (Deltares.Standard.Forms.DExpress) Messenger (Deltares.Standard.Forms) SimplePropertySubControlFactory (Deltares.Standard.Forms.DExpress)
AboutControl (Deltares.Standard.Forms.DExpress) DotSpatialUtil (Deltares.Standard.DotSpatialDgs) GridColumnBinding (Deltares.Standard.Forms.DExpress) MinusStrategy (Deltares.Standard.Forms.DExpress) SingleUnitDialog (Deltares.Standard.Forms.DExpress)
AbstractShapeFileImporter (Deltares.Standard.Forms.DExpress) DrawingAnchorAttachment (Deltares.Geotechnics.Forms) GridControlBinding (Deltares.Standard.Forms.DExpress) ModalListBox (Deltares.DSoilModel.Forms) SmartLineStringImporter (Deltares.Standard.Forms.DExpress.ShapeImporters)
ActionSubControlFactory (Deltares.Standard.Forms.DExpress) DrawingAsphaltRevetment (Deltares.Geotechnics.Forms) GridEditValueStrategy (Deltares.Standard.Forms.DExpress) ModelDialog (Deltares.Standard.Forms.DExpress) SoilBondStressCurveControl (Deltares.Geotechnics.Forms)
ActiveWindowReport (Deltares.Standard.Forms.DExpress) DrawingBlockRevetmentSegment (Deltares.Geotechnics.Forms) GridViewCellChangeArgs (Deltares.Standard.Forms) MoveFeatureMapTool (Deltares.Standard.Forms.DExpress.MapTools) SoilLayer2DControl (Deltares.Geotechnics.Forms)
AddFeatureMapTool (Deltares.Standard.Forms.DExpress.MapTools) DrawingBoring (Deltares.Geotechnics.Forms) GridViewChangeArgs (Deltares.Standard.Forms) MultiLineStringImporter (Deltares.Standard.Forms.DExpress.ShapeImporters) SoilLayerControl (Deltares.Geotechnics.Forms)
AggregatePlugin (Deltares.Standard.Forms.DExpress) DrawingBoringLayer (Deltares.DSoilModel.Forms) GridViewControl (Deltares.Standard.Forms.DExpress) MultiplyStrategy (Deltares.Standard.Forms.DExpress) SoilProfile1D (Deltares.Geotechnics)
AjaxPageSupportHandler (Deltares.Standard.Web.Ajax) DrawingBoundingBox (Deltares.Geometry.Forms) GridViewController (Deltares.Standard.Forms.DExpress) MultiPolygonImporter (Deltares.Standard.Forms.DExpress.ShapeImporters) SoilProfile1DControl (Deltares.Geotechnics.Forms)
AnchorAttachmentControl (Deltares.Geotechnics.Forms) DrawingCenterCrestLocation (Deltares.DSoilModel.Forms)
H
MyFeatureSet (Deltares.Standard.Forms.DExpress) SoilProfile1DException (Deltares.Geotechnics)
ArrowShape (Deltares.Standard.Forms) DrawingCharacteristicPoint (Deltares.Geotechnics.Forms) MyMapLineLayer (Deltares.Standard.Forms.DExpress) SoilProfile2DControl (Deltares.Geotechnics.Forms)
ASPPageSupportHandler (Deltares.Standard.Web) DrawingCPT (Deltares.Geotechnics.Forms) HeadLine (Waternet) MyMapPointLayer (Deltares.Standard.Forms.DExpress) SoilProfileLayersNotSortedDescendingException (Deltares.Geotechnics)
NewDataSet.AssembliesDataTable (Deltares.Standard.Forms.DExpress) DrawingGeometry (Deltares.Geotechnics.Forms) HelpLocationShower (Deltares.Standard.Forms.DExpress) MyMapPolygonLayer (Deltares.Standard.Forms.DExpress) SoilProfilesImporter (Deltares.Geotechnics.IO.Importers)
NewDataSet.AssembliesRow (Deltares.Standard.Forms.DExpress) DrawingHeadLine (Deltares.Geotechnics.Forms) HighlightSoilSegment (Deltares.DSoilModel.Forms)
N
SoilSegmentsImporter (Deltares.Geotechnics.IO.Importers)
NewDataSet.AssembliesRowChangeEvent (Deltares.Standard.Forms.DExpress) DrawingLayer (Deltares.Geotechnics.Forms) HydraulicBoundaryControl (Deltares.Geotechnics.Forms) SoilSegmentSplitLocation (Deltares.DSoilModel.Data)
NewDataSet.AssemblyDataTable (Deltares.Standard.Forms.DExpress) DrawingLayerObsolete (Deltares.DSoilModel.Forms) HyperLinkEditBinding (Deltares.Standard.Forms.DExpress) NavBarItemBinding (Deltares.Standard.Forms.DExpress) SoilSegmentSplitLocationControl (Deltares.DSoilModel.Forms)
NewDataSet.AssemblyRow (Deltares.Standard.Forms.DExpress) DrawingLine (Deltares.Geometry.Forms)
I
NewDataSet (Deltares.Standard.Forms.DExpress) SoilStressCurveControl (Deltares.Geotechnics.Forms)
NewDataSet.AssemblyRowChangeEvent (Deltares.Standard.Forms.DExpress) DrawingLocalisedGeometryPointString (Deltares.Geotechnics.Forms)
O
SoilSurfacePointsControl (Deltares.Geotechnics.Forms)
AssignStrategy (Deltares.Standard.Forms.DExpress) DrawingObject (Deltares.Geometry.Forms) IActionSubControlFactory (Deltares.Standard.Forms.DExpress) SoilSurfacePropertyControl (Deltares.Geotechnics.Forms)
AxesShape (Deltares.Standard.Forms) DrawingPhreaticLine (Deltares.Geotechnics.Forms) IChart (Deltares.Standard.Web) OldBoundary (Deltares.Geotechnics.IO.Importers) SoilVolumeMassCalculator (Deltares.Geotechnics.WaternetCreator)
B
DrawingPiezometricHead (Deltares.Geotechnics.Forms) ICircleHotSpot (Deltares.Standard) OldGeometryFileImporter (Deltares.Geotechnics.IO.Importers) SosDeltaModelDatabase (Deltares.DSoilModel.Data)
DrawingPoint (Deltares.Geometry.Forms) ICommand (Deltares.Standard.Forms)
P
SosSoilLayer1D (Deltares.DSoilModel.Data)
BackgroundFeature (Deltares.Standard.DotSpatialDgs) DrawingPointString (Deltares.Geometry.Forms) IContextMenuMapTool (Deltares.Standard.Forms.DExpress.MapTools) SosSoilLayer1DControl (Deltares.DSoilModel.Forms)
BackgroundMap (Deltares.Standard.DotSpatialDgs) DrawingPreConsolidationStress (Deltares.Geotechnics.Forms) IController (Deltares.Standard.Forms) PageSupport (Deltares.Standard.Web) SosSoilProfile1DControl (Deltares.DSoilModel.Forms)
BarButtonItemBinding (Deltares.Standard.Forms.DExpress) DrawingRevetment (Deltares.Geotechnics.Forms) ICurrent (Deltares.Standard) PanelAction (Deltares.Standard.Forms.DExpress) SosSoilProfilesImporter (Deltares.DSoilModel.Data)
BarEditItemBinding (Deltares.Standard.Forms.DExpress) DrawingRoughnessRevetment (Deltares.Geotechnics.Forms) ICustomView (Deltares.Standard.Forms) PanelLinearConversionValue (Deltares.Standard.Forms.DExpress) SourceProperty (Deltares.Standard.Forms)
BarItemBinding (Deltares.Standard.Forms.DExpress) DrawingSettlementCurve (Deltares.Geotechnics.Forms) NewDataSet.IDDataTable (Deltares.Standard.Forms.DExpress) PanelTextBooleanValue (Deltares.Standard.Forms.DExpress) SpatialEditor (Deltares.Standard.Forms)
BarItemExtensions (Deltares.Standard.Forms.DExpress) DrawingSheetPiling (Deltares.Geotechnics.Forms) IDefinitionViewSettings (Deltares.Geometry.Forms) PanelTextComboBoxValue (Deltares.Standard.Forms.DExpress) SpatialEditorBarSupport (Deltares.Standard.Forms)
BarStaticItemBinding (Deltares.Standard.Forms.DExpress) DrawingSoilLayerSurface (Deltares.Geotechnics.Forms) IDrawingObject (Deltares.Geometry.Forms) PanelTextLinkValue (Deltares.Standard.Forms.DExpress) SpatialEditorColors (Deltares.Geometry.Forms)
BarSubItemBinding (Deltares.Standard.Forms.DExpress) DrawingSoilProfile1D (Deltares.Geotechnics.Forms) NewDataSet.IDRow (Deltares.Standard.Forms.DExpress) PanelTextNumericValue (Deltares.Standard.Forms.DExpress) SpatialEditorProperties (Deltares.Standard.Forms.DExpress)
BaseControlBinding (Deltares.Standard.Forms.DExpress) DrawingSoilSegmentSplitLocation (Deltares.DSoilModel.Forms) NewDataSet.IDRowChangeEvent (Deltares.Standard.Forms.DExpress) PanelTextPathValue (Deltares.Standard.Forms.DExpress) SpecificMechanismPointLocationControl (Deltares.Geotechnics.Forms)
BaseMapTool (Deltares.Standard.Forms.DExpress.MapTools) DrawingSoilSurface (Deltares.Geotechnics.Forms) IDynamicPropertyControl (Deltares.Standard.Forms) PanelTextPopupContainerEdit (Deltares.Standard.Forms.DExpress) SpinEditBinding (Deltares.Standard.Forms.DExpress)
BasicPropertySubControlFactory (Deltares.Standard.Forms.DExpress) DrawingSosSoilLayer1D (Deltares.DSoilModel.Forms) IDynamicTableControl (Deltares.Standard.Forms) PanelTextStringValue (Deltares.Standard.Forms.DExpress) SplashDialog (Deltares.Standard.Forms.DExpress)
BindingRegistration (Deltares.Standard.Forms.DExpress) DrawingSpecificMechanismPointLocation (Deltares.Geotechnics.Forms) IExportLayersDialog (Deltares.Standard.Forms.DExpress.Forms) PdfHelpFileManager (Deltares.Standard.Forms.DExpress) StateIndicatorGaugeBinding (Deltares.Standard.Forms.DExpress)
BindSupport (Deltares.Standard.Forms.DExpress) DrawingSupport (Deltares.Standard.Forms) IGeographicFactory (Deltares.Standard.DotSpatialDgs) PhreaticLine (Waternet) StatusBar (Deltares.Standard.Forms.DExpress)
BindSupportAsHelpLocationProvider (Deltares.Standard.Forms.DExpress) DrawingSurface (Deltares.Geometry.Forms) IGeometryViewSettings (Deltares.Geometry.Forms) PictureBoxBinding (Deltares.Standard.Forms.DExpress) StochastControl (Deltares.Geotechnics.Forms)
BindSupportChartHelper (Deltares.Standard.Forms.DExpress) DrawingSurfaceLine2 (Deltares.Geotechnics.Forms) IGetBoundControl (Deltares.Standard.Forms.DExpress.ComponentWrappers) PlLinesCreator (Deltares.Geotechnics.WaternetCreator) StressCurveControl (Deltares.Geotechnics.Forms)
BindSupportLateBinding (Deltares.Standard.Forms.DExpress) DrawingSwell (Deltares.Geotechnics.Forms) IGridController (Deltares.Standard.Forms) PlusStrategy (Deltares.Standard.Forms.DExpress) StressCurveReader (Deltares.Geotechnics.Forms)
BindSupportTreeHelper (Deltares.Standard.Forms.DExpress) DrawingWaterBasin (Deltares.Geotechnics.Forms) IGridViewControl (Deltares.Standard.Forms) PointImporter (Deltares.Standard.Forms.DotSpatial) NewDataSet.StringDataTable (Deltares.Standard.Forms.DExpress)
BondStressCurveControl (Deltares.Geotechnics.Forms) DrawingWaterLevel (Deltares.Geotechnics.Forms) IHasBindableChildren (Deltares.Standard.Forms.DExpress.Interfaces) PointImporter (Deltares.Standard.Forms.DExpress.ShapeImporters) NewDataSet.StringRow (Deltares.Standard.Forms.DExpress)
BoringControl (Deltares.Geotechnics.Forms) DrawingWaternetLine (Deltares.Geotechnics.Forms) IHasRaster (Deltares.Standard.DotSpatialDgs) PolygonImporter (Deltares.Standard.Forms.DExpress.ShapeImporters) NewDataSet.StringRowChangeEvent (Deltares.Standard.Forms.DExpress)
BoringLookupControl (Deltares.Geotechnics.Forms) DrawingWaternetPointString (Deltares.Geotechnics.Forms) IHelpFileManager (Deltares.Standard.Forms.DExpress.Interfaces) PolygonShape (Deltares.Standard.Forms) SubControlFactoryForBoolean (Deltares.Standard.Forms.DExpress)
ButtonBinding (Deltares.Standard.Forms.DExpress) DrawingWaterPolderBasin (Deltares.Geotechnics.Forms) IHelpLocationProvider (Deltares.Standard.Forms.DExpress.Interfaces) PolylineShape (Deltares.Standard.Forms) SubControlFactoryForDecimal (Deltares.Standard.Forms.DExpress)
ButtonEditBinding (Deltares.Standard.Forms.DExpress) DSoilModelContext (Deltares.DSoilModel.Forms) IHotSpot (Deltares.Standard) PopupContainerEditBinding (Deltares.Standard.Forms.DExpress) SubControlFactoryForDomainProperty (Deltares.Standard.Forms.DExpress)
C
DSoilModelDataSourceRedirector (Deltares.DSoilModel.Data) ILabelEditControl (Deltares.Standard.Forms.DExpress) PreconsolidationStressControl (Deltares.Geotechnics.Forms) SubControlFactoryForDouble (Deltares.Standard.Forms.DExpress)
DSoilModelGeometryEditor (Deltares.DSoilModel.Forms) ILateBinding (Deltares.Standard.Forms.DExpress.Interfaces) Presenter (Deltares.Standard.Forms) SubControlFactoryForEnum (Deltares.Standard.Forms.DExpress)
CategoryDisplayItem (Deltares.Standard.Forms.DExpress) DSoilModelIO (Deltares.DSoilModel.Data) ILocationMapViewSettings (Deltares.Geometry.Forms) ProbabilisticControl (Deltares.Geotechnics.Forms) SubControlFactoryForFileInfo (Deltares.Standard.Forms.DExpress)
CenterCrestLocation (Deltares.DSoilModel.Data) DSoilModelMapEditor (Deltares.DSoilModel.Forms) ImageHttpHandler (Deltares.Standard.Web) Program (Deltares.DSoilModel.Application) SubControlFactoryForInteger (Deltares.Standard.Forms.DExpress)
CenterCrestLocationPropertyControl (Deltares.DSoilModel.Forms) DSoilModelPlugin (Deltares.DSoilModel.Forms) ImageListBoxBinding (Deltares.Standard.Forms.DExpress) ProgramBase (Deltares.Standard.Application) SubControlFactoryForLinkedObject (Deltares.Standard.Forms.DExpress)
ChangeInfo (Deltares.Standard.Forms.DExpress) DSoilModelProject (Deltares.DSoilModel.Data) IMainForm (Deltares.Standard.Forms.DExpress) ProgramOptionsControl (Deltares.Standard.Forms.DExpress) SubControlFactoryForList (Deltares.Standard.Forms.DExpress)
CharacteristicPointsImporter (Deltares.Geotechnics.IO.Importers) DSoilModelSegmentGeometryEditor (Deltares.DSoilModel.Forms) IMainFormActiveControlController (Deltares.Standard.Forms.DExpress) ProgramSettings (Deltares.Standard.Forms) SubControlFactoryForStochast (Deltares.Standard.Forms.DExpress)
CharacteristicPointsImporterException (Deltares.Geotechnics.IO.Importers.Exception) DSoilModelStiFileTransformer (Deltares.DSoilModel.Data) IMainFormPlugin (Deltares.Standard.Forms.DExpress) ProgressBarWithText (Deltares.Standard.Forms) SubControlFactoryForString (Deltares.Standard.Forms.DExpress)
Chart (Deltares.Standard.Web) DSoilModelTransformer (Deltares.DSoilModel.Data) IMap (Deltares.Standard) ProgressDialog (Deltares.Standard.Forms.DExpress) SurfaceLine2Control (Deltares.Geotechnics.Forms)
ChartControlBinding (Deltares.Standard.Forms.DExpress) DupuitPLLinesCreator (Deltares.Geotechnics.WaternetCreator) IMapTool (Deltares.Standard.Forms.DExpress.MapTools) Projection (Deltares.Standard.Forms) SurfaceLineClassFactory (Deltares.Geotechnics.IO)
CheckBoxBinding (Deltares.Standard.Forms.DExpress) DynamicChartControl (Deltares.Standard.Forms.DExpress) InsertShape (Deltares.Standard.Forms) PropertyControl (Deltares.Standard.Forms.DExpress) SurfaceLineInstanceFactory (Deltares.Geotechnics.IO)
CheckEditBinding (Deltares.Standard.Forms.DExpress) DynamicImageControl (Deltares.Standard.Forms.DExpress) IPageSupportHandler (Deltares.Standard.Web) PropertyControlFactory (Deltares.Standard.Forms.DExpress) SurfaceLinesImporter (Deltares.Geotechnics.IO.Importers)
ChildObject (Deltares.Standard.Forms.DExpress) DynamicMessagesControl (Deltares.Standard.Forms.DExpress) IPolygonHotSpot (Deltares.Standard)
R
SurfaceLineXmlHandler (Deltares.Geotechnics.IO)
Class1 (DeltaresStandardNative) DynamicNavigatorControl (Deltares.Standard.Forms.DExpress) IPresentable (Deltares.Standard.Forms)
T
ColoredDrawingObject (Deltares.Geometry.Forms) DynamicOutputControl (Deltares.Standard.Forms.DExpress) IPresenter (Deltares.Standard.Forms) RadioButtonBinding (Deltares.Standard.Forms.DExpress)
ColorEditBinding (Deltares.Standard.Forms.DExpress) DynamicPropertyControl (Deltares.Standard.Forms.DExpress) IProjection (Deltares.Standard.Forms) RadioGroupBinding (Deltares.Standard.Forms.DExpress) TestRectangleShape (Deltares.Standard.Forms)
ColumnDescription (Deltares.Standard.Forms) DynamicPropertyControlDefinition (Deltares.Standard.Forms.DExpress) IPropertyControl (Deltares.Standard.Forms) RasterLayerDefinition (Deltares.Standard.Forms.DExpress) TextEditBinding (Deltares.Standard.Forms.DExpress)
ColumnWidth (Deltares.Standard.Forms.DExpress) DynamicPropertyTabControl (Deltares.Standard.Forms.DExpress) IPropertySubControlFactory (Deltares.Standard.Forms.DExpress) RealTimeBackgroundValidator (Deltares.Standard.Forms) ToolStripMenuItemBinding (Deltares.Standard.Forms.DExpress)
ComboBoxDisplayItem (Deltares.Standard.Forms.DExpress) DynamicPropertyTabControl (Deltares.Standard.Forms.DExpress) IRectangleHotSpot (Deltares.Standard) RectangleShape (Deltares.Standard.Forms) ToolTipVisibilityEventArgs (Deltares.Standard.Forms.DExpress)
ComboBoxEditBinding (Deltares.Standard.Forms.DExpress) DynamicResourcesControl (Deltares.Standard.Forms.DExpress) IReloadableUI (Deltares.Standard.Forms) RectangleZoomMapTool (Deltares.Standard.Forms.DExpress.MapTools) TrackBarControlBinding (Deltares.Standard.Forms.DExpress)
CommandLineWindow (Deltares.Standard.Forms) DynamicTableControl (Deltares.Standard.Forms.DExpress) IReloadManager (Deltares.Standard.Forms) RegisteredSubControlFactories (Deltares.Standard.Forms.DExpress) TransparentLabel (Deltares.Standard.Forms)
ComponentBinding (Deltares.Standard.Forms.DExpress)
E
ISelectableLayer (Deltares.Standard.Forms.DExpress.Interfaces) ReloadManager (Deltares.Standard.Forms.DExpress) TreeListBinding (Deltares.Standard.Forms.DExpress)
ConnectFeaturesMapTool (Deltares.Standard.Forms.DExpress.MapTools) ISettingsDialogPlugin (Deltares.Standard.Forms.DExpress.Interfaces) Report (Deltares.Standard.Forms.DExpress) TreeListColumnBinding (Deltares.Standard.Forms.DExpress)
ControlBinding (Deltares.Standard.Forms.DExpress) EllipseShape (Deltares.Standard.Forms) ISettingsFormPlugin (Deltares.Standard.Forms.DExpress.Interfaces) ReportChapter (Deltares.Standard.Forms.DExpress) TreeViewControl (Deltares.Standard.Forms.DExpress)
ControlsRecord (Deltares.Standard.Forms.DExpress) EmptyShape (Deltares.Standard.Forms) ISettingsValidator (Deltares.Standard.Forms.DExpress.Interfaces) ReportControl (Deltares.Standard.Forms.DExpress) TriangleShape (Deltares.Standard.Forms)
Coordinate (Deltares.Geotechnics.IO.Importers) Encryption (Deltares.Standard.Web) IShape (Deltares.Standard.Forms) ReportDlg (Deltares.Standard.Forms.DExpress)
U
Cpt (Deltares.Standard.Web) EnvelopeType (Deltares.Standard.Web.dinoservices) IShapeImporter (Deltares.Standard.Forms.DExpress) ReportItem (Deltares.Standard.Forms.DExpress)
CPTControl (Deltares.Geotechnics.Forms) ExpertKnowledgePLLinesCreator (Deltares.Geotechnics.WaternetCreator) IShapeImporter (Deltares.Standard.Forms.DotSpatial) ReportManager (Deltares.Standard.Forms.DExpress) UnitsDialog (Deltares.Standard.Forms.DExpress)
CPTLookupControl (Deltares.Geotechnics.Forms) ExportLayersController (Deltares.Standard.Forms.DExpress.Forms) ISoilGeometryViewSettings (Deltares.Geometry.Forms) RepositoryItemTrackBarBinding (Deltares.Standard.Forms.DExpress) UpliftCalculator (Deltares.Geotechnics.WaternetCreator)
CptService (Deltares.Standard.Web.dinoservices) ExportLayersDialog (Deltares.Standard.Forms.DExpress.Forms) ISoilProfileProvider (Deltares.Geotechnics) RequestWithCriteriaType (Deltares.Standard.Web.dinoservices) UserColumnFilterDisplayItem (Deltares.Standard.Forms.DExpress)
CptServiceAgent (Deltares.Standard.Web) ExtenderControlBase (Deltares.Standard.Web.Ajax) ITriangleHotSpot (Deltares.Standard) Resources (Deltares.Geometry.Forms.Properties)
V
CPTType (Deltares.Standard.Web.dinoservices) ExtenderControlPropertyAttribute (Deltares.Standard.Web.Ajax) IUploadDownload (Deltares.Standard.Web) Resources (Deltares.DSoilModel.Application.Properties)
CriteriaType (Deltares.Standard.Web.dinoservices)
F
IUrl (Deltares.Standard) Resources (Deltares.Standard.Forms.Properties) ViewCommand (Deltares.Standard.Forms)
CsvImporterSoilProfilesException (Deltares.Geotechnics.IO.Exception) IViewConfiguration (Deltares.Standard.Forms) Resources (Deltares.DSoilModel.Forms.Properties) VisualValidationResult (Deltares.Standard.Forms)
CsvImporterSurfaceLinesException (Deltares.Geotechnics.IO.Importers) FeatureSupport (Deltares.Standard.DotSpatialDgs) IWaternetViewSettings (Deltares.Geometry.Forms) Resources (Deltares.Standard.Forms.DExpress.Properties)
W
SoilSegmentsImporter.CsvRecordClass (Deltares.Geotechnics.IO.Importers) FetchesImporter (Deltares.Geotechnics.IO.Importers)
L
Resources (Deltares.Geotechnics.Forms.Properties)
CustomConfirmDialog (Deltares.Standard.Forms) FetchesImporterException (Deltares.Geotechnics.IO.Importers.Exception) RevetmentLayerControl (Deltares.Geotechnics.Forms) WaterLineControl (Deltares.Geotechnics.Forms)
CustomDockManagerResXLocalizer (Deltares.Standard.Forms.DExpress) FieldMappingControl (Deltares.Standard.Forms.DExpress.Forms) LabelBinding (Deltares.Standard.Forms.DExpress) RingtoetsWTI2017PLLinesCreator (Deltares.Geotechnics.WaternetCreator) Waternet (Waternet)
CustomLocalizer (Deltares.Standard.Forms.DExpress) NewDataSet.FileDataTable (Deltares.Standard.Forms.DExpress) LabelControlBinding (Deltares.Standard.Forms.DExpress)
S
WaternetControl (Deltares.Geotechnics.Forms)
MessageBoxManager.CWPRETSTRUCT (Deltares.Standard.Forms) FileEditor (Deltares.Standard.Forms) LateBindingComponent (Deltares.Standard.Forms.DExpress) WaternetCreator (Deltares.Geotechnics.WaternetCreator)
D
NewDataSet.FileRow (Deltares.Standard.Forms.DExpress) LegendItem (Deltares.Standard.Forms) SchematizedSurfaceLineControl (Deltares.Geotechnics.Forms) WaternetCurve (Waternet)
NewDataSet.FileRowChangeEvent (Deltares.Standard.Forms.DExpress) LegendShape (Deltares.Standard.Forms) ScriptControlBase (Deltares.Standard.Web.Ajax) WaternetLine (Waternet)
DataGridViewManager (Deltares.Standard.Forms) FilmStrip (Deltares.DSoilModel.Forms) LessThanStrategy (Deltares.Standard.Forms.DExpress) ScriptControlPropertyAttribute (Deltares.Standard.Web.Ajax) WaternetPoint (Waternet)
DateEditBinding (Deltares.Standard.Forms.DExpress) FilmStripThumbnail (Deltares.DSoilModel.Forms) LineHelper (Deltares.Geotechnics.WaternetCreator) ScriptReferenceAttribute (Deltares.Standard.Web.Ajax) WaternetPolyCurve (Waternet)
DBTableLayoutPanel (Deltares.Standard.Forms) FormsSupport (Deltares.Standard.Forms.DExpress) LineStringImporter (Deltares.Standard.Forms.DotSpatial) ScrollableControlBinding (Deltares.Standard.Forms.DExpress) WebMapPlugin (Deltares.Standard.Forms.DExpress)
DegreeOfConsolidationDialog (Deltares.Geotechnics.Forms) FormSupport (Deltares.Standard.Forms) LineStringImporter (Deltares.Standard.Forms.DExpress.ShapeImporters) SegmentControl (Deltares.Geotechnics.Forms)
X
DegreeOfConsolidationMatrixControl (Deltares.Geotechnics.Forms)
G
ListBoxBinding (Deltares.Standard.Forms.DExpress) SelectableLayerItem (Deltares.Standard.Forms.DExpress.Forms)
DeleteFeatureMapTool (Deltares.Standard.Forms.DExpress.MapTools) ListViewControl (Deltares.Standard.Forms.DExpress) SelectFeatureMapTool (Deltares.Standard.Forms.DExpress.MapTools) XmlAquiferHandler (Deltares.Geotechnics.IO)
DescriptionDialog (Deltares.Standard.Forms.DExpress.Project) GaugeControlBinding (Deltares.Standard.Forms.DExpress.ComponentWrappers) LocalizationSupport (Deltares.Standard.Forms.DExpress) SelectionHyperLinkEdit (Deltares.Standard.Forms.DExpress) XmlSoilsToSoilListHandler (Deltares.Geotechnics.IO)
DesignPointControl (Deltares.Geotechnics.Forms) GefBoringFileImporter (Deltares.Geotechnics.IO.Importers) Location (Deltares.Geotechnics.WaternetCreator) Settings (Deltares.Standard.Forms.DExpress.Properties) XRCheckBoxBinding (Deltares.Standard.Forms.DExpress)
DetailReportBandBinding (Deltares.Standard.Forms.DExpress) GefCptFileImporter (Deltares.Geotechnics.IO.Importers) Log (Deltares.Standard.Web) Settings (Deltares.DSoilModel.Application.Properties) XRControlBinding (Deltares.Standard.Forms.DExpress)
DevExpressPageSupportHandler (Deltares.Standard.Web.DevExpress) GEFXmlImporter (Deltares.Geotechnics.IO.Importers) LogDetect (Deltares.Standard.Web) Settings (Deltares.Standard.Forms.Properties) XRLabelBinding (Deltares.Standard.Forms.DExpress)
DGSGEFInterface (Deltares.Geotechnics.IO.Importers) GeoChartControl (Deltares.Standard.Forms.DExpress) LogHelper (Deltares.Standard.Application) Settings (Deltares.Standard.Web.Properties) XRPictureBoxBinding (Deltares.Standard.Forms.DExpress)
DGSStandardDLLInterface (Deltares.Geotechnics.IO.Importers) GeometryCurveControl (Deltares.Geometry.Forms)
M
SettlementCurveControl (Deltares.Geotechnics.Forms) XRShapeBinding (Deltares.Standard.Forms.DExpress)
DialogTemplate (Deltares.Standard.Forms.DExpress) GeometryEditor (Deltares.Standard.Forms.DExpress) Shape (Deltares.Standard.Forms) XRSubreportBinding (Deltares.Standard.Forms.DExpress)
DikeLineControl (Deltares.Geotechnics.Forms) GeometryPlugin (Deltares.Geometry.Forms) MainForm (Deltares.Standard.Forms.DExpress) ShapeComparer (Deltares.Standard.Forms) XtraTabPageBinding (Deltares.Standard.Forms.DExpress)
DINOInterface (Deltares.Standard.Web) GeometryPointControl (Deltares.Geometry.Forms) MapEditor (Deltares.Standard.Forms.DExpress) ShapeEventArgs (Deltares.Standard.Forms)
Z
DirectoryEditor (Deltares.Standard.Forms) GeometryPropertyControl (Deltares.Geotechnics.Forms) MapLayerDefinition (Deltares.Standard.Forms.DExpress) ShapeFileImporter (Deltares.Standard.Forms.DExpress)
DisclaimerDialog (Deltares.Standard.Forms.DExpress) GeometryStringControl (Deltares.Geometry.Forms) MapLayersPropertyControl (Deltares.Standard.Forms.DExpress) ShapeFileMetaDataImporter (Deltares.Standard.Forms.DExpress) ZoomablePictureBox (Deltares.Standard.Forms)
DisplayItem (Deltares.Standard.Forms.DExpress) GeometryViewSettings (Deltares.Geometry.Forms) MapLegendPropertyControl (Deltares.Standard.Forms.DExpress) ShapeImporter (Deltares.Standard.Forms.DExpress.ShapeImporters)
f
DivideStrategy (Deltares.Standard.Forms.DExpress) GeoPropertyGrid (Deltares.Standard.Forms.DExpress) MapProjectionManager (Deltares.Standard.DotSpatialDgs) ShapeInfo (Deltares.Standard.Forms)
DllVersionInfoStructure (Deltares.Geotechnics.IO.Importers) GeoRepositoryTextEdit (Deltares.Standard.Forms.DExpress) MapProjectionManagerException (Deltares.Standard.DotSpatialDgs) ShapesEventArgs (Deltares.Standard.Forms) findCPTCompletedEventArgs (Deltares.Standard.Web.dinoservices)
DockPanelBinding (Deltares.Standard.Forms.DExpress) GeotechnicsPlugin (Deltares.Geotechnics.Forms) MaterialEditorDialog (Deltares.Geotechnics.Forms) ShearStressCurveControl (Deltares.Geotechnics.Forms) findCPTWithCriteriaCompletedEventArgs (Deltares.Standard.Web.dinoservices)
DotSpatialGeographicAlgorithms (Deltares.Standard.DotSpatialDgs) GeotechnicsViewSettings (Deltares.Geotechnics.Forms) MatrixViewer (Deltares.Standard.Forms) SheetPilingControl (Deltares.Geotechnics.Forms)
g
getGEFCompletedEventArgs (Deltares.Standard.Web.dinoservices)
A | B | C | D | E | F | G | H | I | L | M | N | O | P | R | S | T | U | V | W | X | Z
Generated on Tue Dec 15 2015 18:15:40 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Class Hierarchy

Tool for the (stochastic) subsoil definition.
Class Hierarchy
This inheritance list is sorted roughly, but not completely, alphabetically:
[detail level 123456]
►C ApplicationSettingsBase
C Deltares.DSoilModel.Application.Properties.Settings
C Deltares.Standard.Forms.DExpress.Properties.Settings
C Deltares.Standard.Forms.Properties.Settings
C Deltares.Standard.Web.Properties.Settings
►C AsyncCompletedEventArgs
C Deltares.Standard.Web.dinoservices.findCPTCompletedEventArgs
C Deltares.Standard.Web.dinoservices.findCPTWithCriteriaCompletedEventArgs
C Deltares.Standard.Web.dinoservices.getGEFCompletedEventArgs
C Deltares.Standard.DotSpatialDgs.BackgroundMap
►C Bar
C Deltares.Standard.Forms.DExpress.StatusBar
C Deltares.Standard.Forms.DExpress.BarItemExtensions
►C Deltares.Standard.Forms.DExpress.BasicPropertySubControlFactory< IList, GridViewControl >
C Deltares.Standard.Forms.DExpress.SubControlFactoryForList
C Deltares.Standard.Forms.DExpress.BindingRegistration
C Deltares.Standard.Forms.DExpress.BindSupport | TODO: Comment Explain concept of Binding, how does it work?
C Deltares.Standard.Forms.DExpress.BindSupportChartHelper
C Deltares.Standard.Forms.DExpress.BindSupportLateBinding
C Deltares.Standard.Forms.DExpress.BindSupportTreeHelper
C Deltares.DSoilModel.Data.CenterCrestLocation | Helper class to be able to draw the CenterCrestLocation property of a SoilProfile2D.
C Deltares.Standard.Forms.DExpress.ChangeInfo
►C ChartControl
C Deltares.Standard.Forms.DExpress.GeoChartControl
C Deltares.Standard.Forms.DExpress.ChildObject
C DeltaresStandardNative::Class1
C Deltares.Standard.Forms.ColumnDescription | Contains all data for layout of the columns
C Deltares.Standard.Forms.DExpress.ColumnWidth
►C Deltares.Standard.Forms.DExpress.ComboBoxDisplayItem | This class is used for items displayed in a combo box.
C Deltares.Standard.Forms.DExpress.CategoryDisplayItem | TODO: Comment
C Deltares.Standard.Forms.DExpress.UserColumnFilterDisplayItem
C Deltares.Standard.Forms.CommandLineWindow
►C Component
C Deltares.Geometry.Forms.GeometryPlugin
►C Deltares.Standard.Forms.DExpress.ComponentBinding
►C Deltares.Standard.Forms.DExpress.BarItemBinding
C Deltares.Standard.Forms.DExpress.BarButtonItemBinding
C Deltares.Standard.Forms.DExpress.BarEditItemBinding
C Deltares.Standard.Forms.DExpress.BarStaticItemBinding
C Deltares.Standard.Forms.DExpress.BarSubItemBinding
►C Deltares.Standard.Forms.DExpress.ControlBinding
►C Deltares.Standard.Forms.DExpress.BaseControlBinding
C Deltares.Standard.Forms.DExpress.ButtonEditBinding
C Deltares.Standard.Forms.DExpress.CheckEditBinding
C Deltares.Standard.Forms.DExpress.ColorEditBinding
C Deltares.Standard.Forms.DExpress.ComboBoxEditBinding
C Deltares.Standard.Forms.DExpress.ComponentWrappers.GaugeControlBinding | Binding for the parent of StateIndicatorGaugeBinding.
C Deltares.Standard.Forms.DExpress.DateEditBinding
C Deltares.Standard.Forms.DExpress.HyperLinkEditBinding
C Deltares.Standard.Forms.DExpress.LabelControlBinding
C Deltares.Standard.Forms.DExpress.PopupContainerEditBinding
C Deltares.Standard.Forms.DExpress.RadioGroupBinding
C Deltares.Standard.Forms.DExpress.RepositoryItemTrackBarBinding
C Deltares.Standard.Forms.DExpress.SimpleButtonBinding
C Deltares.Standard.Forms.DExpress.SpinEditBinding
C Deltares.Standard.Forms.DExpress.StateIndicatorGaugeBinding
C Deltares.Standard.Forms.DExpress.TextEditBinding
C Deltares.Standard.Forms.DExpress.TrackBarControlBinding
C Deltares.Standard.Forms.DExpress.ButtonBinding
C Deltares.Standard.Forms.DExpress.ChartControlBinding
C Deltares.Standard.Forms.DExpress.CheckBoxBinding
C Deltares.Standard.Forms.DExpress.GridControlBinding
C Deltares.Standard.Forms.DExpress.ImageListBoxBinding
C Deltares.Standard.Forms.DExpress.LabelBinding
C Deltares.Standard.Forms.DExpress.ListBoxBinding
C Deltares.Standard.Forms.DExpress.RadioButtonBinding
►C Deltares.Standard.Forms.DExpress.ScrollableControlBinding | Binding class for GroupBox, GroupControl, Panel, XtraTabPage and UserControl
C Deltares.Standard.Forms.DExpress.DockPanelBinding
C Deltares.Standard.Forms.DExpress.PictureBoxBinding
C Deltares.Standard.Forms.DExpress.XtraTabPageBinding
C Deltares.Standard.Forms.DExpress.TreeListBinding
C Deltares.Standard.Forms.DExpress.GridColumnBinding
C Deltares.Standard.Forms.DExpress.NavBarItemBinding
C Deltares.Standard.Forms.DExpress.ToolStripMenuItemBinding
C Deltares.Standard.Forms.DExpress.TreeListColumnBinding
►C Deltares.Standard.Forms.DExpress.XRControlBinding
C Deltares.Standard.Forms.DExpress.DetailReportBandBinding
C Deltares.Standard.Forms.DExpress.XRCheckBoxBinding
C Deltares.Standard.Forms.DExpress.XRLabelBinding
C Deltares.Standard.Forms.DExpress.XRPictureBoxBinding
C Deltares.Standard.Forms.DExpress.XRShapeBinding
C Deltares.Standard.Forms.DExpress.XRSubreportBinding
C Deltares.Standard.Forms.DExpress.ControlsRecord
C Deltares.Geotechnics.IO.Importers.Coordinate
C Deltares.Standard.Web.Cpt
C Deltares.Standard.Web.CptServiceAgent | TODO add more actions to current class (maybe redesign). Now this agent only supports the GetGEF action
C Deltares.Standard.Web.dinoservices.CPTType
C Deltares.Standard.Web.dinoservices.CriteriaType
C Deltares.Geotechnics.IO.Importers.SoilSegmentsImporter.CsvRecordClass
C Deltares.Standard.Forms.MessageBoxManager.CWPRETSTRUCT
►C DataEventArgs
►C Deltares.Standard.Forms.GridViewChangeArgs | Used for change actions in the grid view. (add, delete and insert)
C Deltares.Standard.Forms.GridViewCellChangeArgs | Used for cell changes in the grid view.
C Deltares.Standard.Forms.DataGridViewManager
►C DataRow
C Deltares.Standard.Forms.DExpress.NewDataSet.AssembliesRow | Represents strongly named DataRow class. /summary>
C Deltares.Standard.Forms.DExpress.NewDataSet.AssemblyRow | Represents strongly named DataRow class. /summary>
C Deltares.Standard.Forms.DExpress.NewDataSet.FileRow | Represents strongly named DataRow class. /summary>
C Deltares.Standard.Forms.DExpress.NewDataSet.IDRow | Represents strongly named DataRow class. /summary>
C Deltares.Standard.Forms.DExpress.NewDataSet.StringRow | Represents strongly named DataRow class. /summary>
►C DataSet
C Deltares.Standard.Forms.DExpress.NewDataSet | Represents a strongly typed in-memory cache of data. /summary>
►C DeltaModelDatabase
C Deltares.DSoilModel.Data.SosDeltaModelDatabase | Derived Version of GeoTechnics.IO.DeltaModelDatabase, providing access to WTI-SOS specific data
►C Deltares.Geotechnics.IO.Importers.DGSStandardDLLInterface
C Deltares.Geotechnics.IO.Importers.DGSGEFInterface | Interface for the functions of the DGSGEF.dll
C Deltares.Standard.Web.DINOInterface
C Deltares.Geotechnics.IO.Importers.DllVersionInfoStructure
►C DockManagerResXLocalizer
C Deltares.Standard.Forms.DExpress.CustomDockManagerResXLocalizer
C Deltares.Standard.DotSpatialDgs.DotSpatialGeographicAlgorithms
C Deltares.Standard.DotSpatialDgs.DotSpatialGeographicConverter
C Deltares.Standard.DotSpatialDgs.DotSpatialUtil
C Deltares.Standard.Forms.DrawingSupport
C Deltares.DSoilModel.Data.DSoilModelIO
C Deltares.Geotechnics.WaternetCreator.DupuitPLLinesCreator
C Deltares.Standard.Forms.DExpress.DynamicPropertyControlDefinition
C Deltares.Standard.Forms.DExpress.DynamicPropertyTabControl< T > Container for showing a collection of controls, that can all interpret the same type SelectedObject (type

Template Parameters
T ) based on a conversion delegate.
C Deltares.Standard.Web.Encryption
C Deltares.Standard.Web.dinoservices.EnvelopeType
►C EventArgs
C Deltares.Standard.Forms.DExpress.ToolTipVisibilityEventArgs
C Deltares.Standard.Forms.ShapeEventArgs | Arguments for Shape Events
C Deltares.Standard.Forms.ShapesEventArgs | Arguments for Collections of Shape Events
►C Exception
C Deltares.Geotechnics.IO.Exception.CsvImporterSoilProfilesException
C Deltares.Geotechnics.IO.Importers.CsvImporterSurfaceLinesException
C Deltares.Geotechnics.IO.Importers.Exception.CharacteristicPointsImporterException
C Deltares.Geotechnics.IO.Importers.Exception.FetchesImporterException
C Deltares.Geotechnics.SoilProfile1DException | Exception for SoilProfile 1D problem handeling.
C Deltares.Standard.Forms.DExpress.Forms.ExportLayersController | Controller of MVC pattern, V = ExportLayerDialog, M = Layers
►C ExtenderControl
C Deltares.Standard.Web.Ajax.ExtenderControlBase
►C FeatureSet
C Deltares.Standard.Forms.DExpress.MyFeatureSet | This class is a customized version of DotSpatial FeatureSet adding specific feature selection functionality
C Deltares.Standard.DotSpatialDgs.FeatureSupport
C Deltares.DSoilModel.Forms.FilmStripThumbnail
►C Form
C Deltares.DSoilModel.Forms.ModalListBox | The ModalListBox class
C Deltares.Standard.Forms.CustomConfirmDialog
C Deltares.Standard.Forms.DExpress.DialogTemplate
C Deltares.Standard.Forms.DExpress.DisclaimerDialog
C Deltares.Standard.Forms.DExpress.SingleUnitDialog
C Deltares.Standard.Forms.DExpress.FormsSupport
C Deltares.Standard.Forms.FormSupport
C Deltares.Geotechnics.IO.Importers.GefBoringFileImporter | Imports a Boring from a GEF-file given by filename or as string
C Deltares.Geotechnics.IO.Importers.GefCptFileImporter | Imports a CPT from a GEF-file given by filename or as string
C Deltares.Geotechnics.IO.Importers.GEFXmlImporter | This class is used to import data (CPT, Profile, Soils) from a CPTip xml format string or stream
►C GeographicPoint
C Deltares.DSoilModel.Data.SoilSegmentSplitLocation | Class to hold the location of the proposed split of a segment.
►C GeotechnicsContext
C Deltares.DSoilModel.Forms.DSoilModelContext
C Deltares.Standard.Forms.GraphicsInfo
►C Deltares.Standard.Forms.DExpress.GridEditValueStrategy | This class represents an edit action which can be performed on cell values. These so called GridEditValueStrategies take a gridview and finds the selected cell values for which each strategy can determine a sensible default value and/or can edit the value based on an entered "edit value".
C Deltares.Standard.Forms.DExpress.AssignStrategy
C Deltares.Standard.Forms.DExpress.DivideStrategy
C Deltares.Standard.Forms.DExpress.GreaterThanStrategy
C Deltares.Standard.Forms.DExpress.LessThanStrategy
C Deltares.Standard.Forms.DExpress.MinusStrategy
C Deltares.Standard.Forms.DExpress.MultiplyStrategy
C Deltares.Standard.Forms.DExpress.PlusStrategy
C Waternet.HeadLine
►C HyperLinkEdit
C Deltares.Standard.Forms.DExpress.SelectionHyperLinkEdit
C Deltares.Standard.Forms.DExpress.IActionSubControlFactory< out out ControlType >
C Deltares.Standard.Forms.DExpress.IActionSubControlFactory< Control >
►C Deltares.Standard.Forms.DExpress.IActionSubControlFactory< PanelAction >
C Deltares.Standard.Forms.DExpress.ActionSubControlFactory
►C Deltares.Standard.Web.IChart
C Deltares.Standard.Web.Chart
►C IClassInstanceFactory
C Deltares.Geotechnics.IO.SurfaceLineClassFactory
C Deltares.Geotechnics.IO.SurfaceLineInstanceFactory | This factory creates a SurfaceLine instance if it is required by the XML definition This factory exists for backwards compatibility for SurfaceLine2 refactoring
►C ICloneable
C Deltares.Geotechnics.SoilProfile1D | 1D Soil Profile Object TODO: Comment
C Deltares.Standard.Forms.ICommand
►C IComparable
C Deltares.Geotechnics.SoilProfile1D | 1D Soil Profile Object TODO: Comment
C Deltares.Standard.Forms.DExpress.DisplayItem
C Deltares.Standard.Forms.ShapeInfo | Information about the Shape
►C IComparer
C Deltares.Standard.Forms.ShapeComparer | Comparer class for Shapes
►C IComponent
►C Deltares.Standard.Forms.IPropertyControl | Interface for custom property windows.
C Deltares.Standard.Forms.DExpress.AboutControl
C Deltares.Standard.Forms.DExpress.DynamicPropertyTabControl< T >
C Deltares.Standard.Forms.DExpress.GeoPropertyGrid
C Deltares.Standard.Forms.DExpress.MapLayersPropertyControl
C Deltares.Standard.Forms.DExpress.MapLegendPropertyControl
C Deltares.Standard.Forms.DExpress.ProgramOptionsControl
C Deltares.Standard.Forms.DExpress.Project.DescriptionDialog
C Deltares.Standard.Forms.DExpress.PropertyControl
C Deltares.Standard.Forms.DExpress.ReportControl
C Deltares.Standard.Forms.DExpress.SpatialEditorProperties
C Deltares.Standard.Forms.DExpress.UnitsDialog
►C Deltares.Standard.Forms.DExpress.MapTools.IContextMenuMapTool | Interface for providing menu items for context menu
C Deltares.Standard.Forms.DExpress.MapTools.AddFeatureMapTool | Add features map tool
C Deltares.Standard.Forms.DExpress.MapTools.DeleteFeatureMapTool | Delete featute on map
C Deltares.Standard.Forms.DExpress.MapTools.SelectFeatureMapTool | Select object on the map map tool
C Deltares.Standard.Forms.IController | Defines a Interface for controlling the commands.
C Deltares.Standard.ICurrent
C Deltares.Standard.Forms.ICustomView
►C IDataSourceRedirector
C Deltares.DSoilModel.Data.DSoilModelDataSourceRedirector | Redirects the data source of a source/property to the data source of another property
C Deltares.Geometry.Forms.IDefinitionViewSettings
►C IDescriptive
C Deltares.Standard.Forms.DExpress.MainForm | TODO: Comment
C Deltares.Standard.Forms.VisualValidationResult
►C IDisposable
C Deltares.DSoilModel.Data.DSoilModelProject | D-Soil Model Project
C Deltares.DSoilModel.Forms.DSoilModelGeometryEditor | The D-Soil Model Geometry Editor
C Deltares.DSoilModel.Forms.DSoilModelMapEditor | The D-Soil Model MapEditor
C Deltares.DSoilModel.Forms.DSoilModelPlugin | Main Class for D-Soil Model
C Deltares.DSoilModel.Forms.DSoilModelSegmentGeometryEditor | Class to be able to show a soilsegment as length profile (based on a fictive 2D profile with the length of the segment) In the length profile, the mapped CPTs and Borings belonging to the segment are shown.
►C Deltares.Geotechnics.Forms.DrawingSoilSurface | Drawing object that represents 2D soil layers (SoilLayer2D) entities in the geometry (crossection) editor.
C Deltares.Geotechnics.Forms.DrawingSoilLayerSurface | Drawing object that represents soil layers (SoilLayerSurface) entities in the geometry (crossection) editor.
C Deltares.Geotechnics.WaternetCreator.Location
C Deltares.Standard.Forms.DExpress.GridViewController< T >
C Deltares.Standard.Forms.DExpress.MapEditor | Map component of DSL Mainform
C Deltares.Standard.Forms.RealTimeBackgroundValidator
►C IDomain
C Deltares.DSoilModel.Data.DSoilModelProject | D-Soil Model Project
C Deltares.Geotechnics.SoilProfile1D | 1D Soil Profile Object TODO: Comment
►C Deltares.Standard.Forms.IDynamicPropertyControl | interface to display custom property windows
C Deltares.Standard.Forms.DExpress.DynamicPropertyControl | Control to display custom property windows
►C Deltares.Standard.Forms.IDynamicTableControl
C Deltares.Standard.Forms.DExpress.DynamicTableControl
►C Deltares.Standard.Forms.DExpress.Forms.IExportLayersDialog | Interface (for testing)
C Deltares.Standard.Forms.DExpress.Forms.ExportLayersDialog
C Deltares.Standard.DotSpatialDgs.IGeographicFactory
►C IGeographicHelper
C Deltares.Standard.DotSpatialDgs.DotSpatialGeographicHelper
►C IGeographicPoint
C Deltares.Geotechnics.SoilProfile1D | 1D Soil Profile Object TODO: Comment
C Deltares.Geotechnics.WaternetCreator.Location
►C IGeographicString
C Deltares.DSoilModel.Forms.HighlightSoilSegment | UI element used for interactively splitting SoilSegments in the map
►C Deltares.Geometry.Forms.IGeometryViewSettings
C Deltares.Geometry.Forms.GeometryViewSettings
►C Deltares.Standard.Forms.DExpress.ComponentWrappers.IGetBoundControl
C Deltares.Standard.Forms.DExpress.ControlBinding
C Deltares.Standard.Forms.DExpress.GridColumnBinding
►C Deltares.Standard.Forms.IGridController
►C Deltares.Standard.Forms.IGridViewControl
C Deltares.Standard.Forms.DExpress.GridViewControl | Generic Grid Control extend from DXGridControl
►C IHasBindableChildren
C Deltares.Standard.Forms.DExpress.GridViewControl | Generic Grid Control extend from DXGridControl
C Deltares.Standard.Forms.DExpress.ListViewControl
C Deltares.Standard.Forms.DExpress.TreeViewControl | Generic Grid Control extend from DXTreeList
C Deltares.Standard.Forms.DExpress.Interfaces.IHasBindableChildren | Class with child components that also need to be bound by BindSupport.
C Deltares.Standard.DotSpatialDgs.IHasRaster
►C Deltares.Standard.Forms.DExpress.Interfaces.IHelpFileManager | Interface for interacting with help files
C Deltares.Standard.Forms.DExpress.HelpLocationShower | This help file manager will open message box pop-ups, displaying the
C Deltares.Standard.Forms.DExpress.PdfHelpFileManager | Interacts with a pdf help file.
►C Deltares.Standard.Forms.DExpress.Interfaces.IHelpLocationProvider | Interface for classes that provide a help location to be consumed by IHelpFileManager classes.
C Deltares.Standard.Forms.DExpress.BindSupportAsHelpLocationProvider | Uses BindSupport to determine the help file location.
►C Deltares.Standard.IHotSpot
C Deltares.Standard.ICircleHotSpot
C Deltares.Standard.IPolygonHotSpot
C Deltares.Standard.IRectangleHotSpot
C Deltares.Standard.ITriangleHotSpot
►C IHttpHandler
C Deltares.Standard.Web.ImageHttpHandler
►C Deltares.Standard.Forms.DExpress.ILabelEditControl | a simple interface to help with binding of controls
C Deltares.Standard.Forms.DExpress.PanelLinearConversionValue
C Deltares.Standard.Forms.DExpress.PanelTextBooleanValue
C Deltares.Standard.Forms.DExpress.PanelTextComboBoxValue
C Deltares.Standard.Forms.DExpress.PanelTextLinkValue
C Deltares.Standard.Forms.DExpress.PanelTextNumericValue
C Deltares.Standard.Forms.DExpress.PanelTextPathValue
C Deltares.Standard.Forms.DExpress.PanelTextPopupContainerEdit
C Deltares.Standard.Forms.DExpress.PanelTextStringValue
C Deltares.Standard.Forms.DExpress.Interfaces.ILateBinding
C Deltares.Geometry.Forms.ILocationMapViewSettings
►C Deltares.Standard.Forms.DExpress.IMainForm
C Deltares.Standard.Forms.DExpress.MainForm | TODO: Comment
►C Deltares.Standard.Forms.DExpress.IMainFormActiveControlController | Allows for controls in the MainForm to be put in the front and active.
C Deltares.Standard.Forms.DExpress.MainForm | TODO: Comment
►C Deltares.Standard.Forms.DExpress.IMainFormPlugin | TODO: Comment
C Deltares.DSoilModel.Forms.DSoilModelPlugin | Main Class for D-Soil Model
C Deltares.Geometry.Forms.GeometryPlugin
C Deltares.Geotechnics.Forms.GeotechnicsPlugin
C Deltares.Standard.Forms.DExpress.AggregatePlugin< ProjectType > | TODO: Comment (Only used by Koswat, so not commented by DSoil-Team)
C Deltares.Standard.IMap | This interface is a helper for interfacing with ImageMap web control
►C Deltares.Standard.Forms.DExpress.MapTools.IMapTool | Interface for Map tools
►C Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool | Base tool for all maptools
C Deltares.Standard.Forms.DExpress.MapTools.AddFeatureMapTool | Add features map tool
C Deltares.Standard.Forms.DExpress.MapTools.ConnectFeaturesMapTool | Connect features map tool
C Deltares.Standard.Forms.DExpress.MapTools.DeleteFeatureMapTool | Delete featute on map
C Deltares.Standard.Forms.DExpress.MapTools.MoveFeatureMapTool | MoveTool moves features on the map. A related layer can be used for snapping
C Deltares.Standard.Forms.DExpress.MapTools.RectangleZoomMapTool | Rectangle Zoom in/out map tool
C Deltares.Standard.Forms.DExpress.MapTools.SelectFeatureMapTool | Select object on the map map tool
►C Importer
C Deltares.Geotechnics.IO.Importers.CharacteristicPointsImporter
C Deltares.Geotechnics.IO.Importers.FetchesImporter | Imports the fetches from a csv file.
►C Deltares.Geotechnics.IO.Importers.SoilProfilesImporter | Importer for reading 1D soil profiles from CSV format files
C Deltares.DSoilModel.Data.SosSoilProfilesImporter
C Deltares.Geotechnics.IO.Importers.SoilSegmentsImporter | Imports SoilSegment (stochastic soil models) from DAM style segments.csv file Each segment contains an ID/Name and reference to failure mechanism specific soil Models, but no spatial information
C Deltares.Geotechnics.IO.Importers.SurfaceLinesImporter | Imports surface line from DAM style surfacelines.csv file
►C Deltares.Standard.Forms.DExpress.AbstractShapeFileImporter | This class is reponsible to handle the import from ShapeFiles
►C Deltares.Standard.Forms.DExpress.ShapeFileMetaDataImporter
C Deltares.Standard.Forms.DExpress.ShapeFileImporter
►C IName
C Deltares.DSoilModel.Data.SoilSegmentSplitLocation | Class to hold the location of the proposed split of a segment.
C Deltares.Geotechnics.SoilProfile1D | 1D Soil Profile Object TODO: Comment
►C Deltares.Standard.Web.IPageSupportHandler
C Deltares.Standard.Web.Ajax.AjaxPageSupportHandler
C Deltares.Standard.Web.ASPPageSupportHandler
C Deltares.Standard.Web.DevExpress.DevExpressPageSupportHandler
C Deltares.Standard.Forms.IPresentable
C Deltares.Standard.Forms.IPresenter
►C IProgramInfo
C Deltares.DSoilModel.Application.Program
C Deltares.Standard.Application.ProgramBase
►C Deltares.Standard.Forms.IProjection
C Deltares.Standard.Forms.Projection
►C IPropertyControl
C Deltares.DSoilModel.Forms.CenterCrestLocationPropertyControl
C Deltares.DSoilModel.Forms.SoilSegmentSplitLocationControl
C Deltares.DSoilModel.Forms.SosSoilLayer1DControl
C Deltares.DSoilModel.Forms.SosSoilProfile1DControl
C Deltares.Geometry.Forms.GeometryCurveControl
C Deltares.Geometry.Forms.GeometryPointControl
C Deltares.Geometry.Forms.GeometryStringControl
C Deltares.Geotechnics.Forms.AnchorAttachmentControl
C Deltares.Geotechnics.Forms.BondStressCurveControl | Earthquake Dialog.
C Deltares.Geotechnics.Forms.BoringControl | Earthquake Dialog.
C Deltares.Geotechnics.Forms.BoringLookupControl
C Deltares.Geotechnics.Forms.CPTControl | Earthquake Dialog.
C Deltares.Geotechnics.Forms.CPTLookupControl
C Deltares.Geotechnics.Forms.DesignPointControl | Earthquake Dialog.
C Deltares.Geotechnics.Forms.DikeLineControl | Earthquake Dialog.
C Deltares.Geotechnics.Forms.GeometryPropertyControl
C Deltares.Geotechnics.Forms.HydraulicBoundaryControl | Hydraulic boundary Dialog.
C Deltares.Geotechnics.Forms.MaterialEditorDialog
C Deltares.Geotechnics.Forms.PreconsolidationStressControl
C Deltares.Geotechnics.Forms.ProbabilisticControl | Earthquake Dialog.
C Deltares.Geotechnics.Forms.RevetmentLayerControl
C Deltares.Geotechnics.Forms.SchematizedSurfaceLineControl
C Deltares.Geotechnics.Forms.SegmentControl | Soil Segment property control.
C Deltares.Geotechnics.Forms.SettlementCurveControl
C Deltares.Geotechnics.Forms.ShearStressCurveControl | Earthquake Dialog.
C Deltares.Geotechnics.Forms.SheetPilingControl
C Deltares.Geotechnics.Forms.SoilBondStressCurveControl | same as SoilStressCurveControl, except StressCurve is BondStressCurve
C Deltares.Geotechnics.Forms.SoilLayer2DControl
C Deltares.Geotechnics.Forms.SoilLayerControl
C Deltares.Geotechnics.Forms.SoilProfile1DControl | SoilProfile 1D properties control
C Deltares.Geotechnics.Forms.SoilProfile2DControl | SoilProfile 2D Dialog.
C Deltares.Geotechnics.Forms.SoilStressCurveControl | custom property control for soilsurface and geometrypoints
C Deltares.Geotechnics.Forms.SoilSurfacePointsControl
C Deltares.Geotechnics.Forms.SoilSurfacePropertyControl | Custom property control for soilsurface and geometrypoints.
C Deltares.Geotechnics.Forms.SpecificMechanismPointLocationControl
C Deltares.Geotechnics.Forms.StressCurveControl | Earthquake Dialog.
C Deltares.Geotechnics.Forms.SurfaceLine2Control
C Deltares.Geotechnics.Forms.WaterLineControl
C Deltares.Geotechnics.Forms.WaternetControl | Tree on slope dialog.
►C IPropertyObjectAssignable
C Deltares.Standard.Forms.DirectoryEditor
C Deltares.Standard.Forms.FileEditor
C Deltares.Standard.Forms.DExpress.IPropertySubControlFactory< out out ControlType >
C Deltares.Standard.Forms.DExpress.IPropertySubControlFactory< Control >
►C Deltares.Standard.Forms.DExpress.IPropertySubControlFactory< ControlType >
►C Deltares.Standard.Forms.DExpress.BasicPropertySubControlFactory< ShownDataType, ControlType > | the basic abstract class
C Deltares.Standard.Forms.DExpress.SimplePropertySubControlFactory< ShownDataType, ControlType >
►C IReloadableUI
C Deltares.Geotechnics.Forms.DegreeOfConsolidationDialog
C Deltares.Geotechnics.Forms.GeometryPropertyControl
C Deltares.Geotechnics.Forms.MaterialEditorDialog
C Deltares.Geotechnics.Forms.SoilBondStressCurveControl | same as SoilStressCurveControl, except StressCurve is BondStressCurve
C Deltares.Geotechnics.Forms.WaterLineControl
C Deltares.Geotechnics.Forms.WaternetControl | Tree on slope dialog.
►C Deltares.Standard.Forms.IReloadableUI
C Deltares.Standard.Forms.DExpress.GeometryEditor | TODO: Comment
C Deltares.Standard.Forms.DExpress.MainForm | TODO: Comment
C Deltares.Standard.Forms.DExpress.Project.DescriptionDialog
►C Deltares.Standard.Forms.IReloadManager
C Deltares.Standard.Forms.DExpress.ReloadManager
►C Deltares.Standard.Forms.DExpress.Interfaces.ISelectableLayer | Interface for selectable map layers
C Deltares.Standard.Forms.DExpress.MyMapLineLayer | This class is a customized version of DotSpatial MapLineLayer, adding specific feature selection functionality
C Deltares.Standard.Forms.DExpress.MyMapPointLayer | This class is a customized version of DotSpatial MapPointLayer, adding specific feature selection functionality
C Deltares.Standard.Forms.DExpress.MyMapPolygonLayer | This class is a customized version of DotSpatial MapPolygonLayer, adding specific feature selection functionality
C Deltares.Standard.Forms.DExpress.Interfaces.ISettingsDialogPlugin
C Deltares.Standard.Forms.DExpress.Interfaces.ISettingsFormPlugin
C Deltares.Standard.Forms.DExpress.Interfaces.ISettingsValidator
►C Deltares.Standard.Forms.IShape
►C Deltares.Geometry.Forms.IDrawingObject
►C Deltares.Geometry.Forms.DrawingObject | Base class for drawing objects that represents geotechnical entities in the geometry (crossection) editor.
C Deltares.DSoilModel.Forms.DrawingCenterCrestLocation
C Deltares.DSoilModel.Forms.DrawingLayerObsolete
C Deltares.DSoilModel.Forms.DrawingSoilSegmentSplitLocation | Class for drawing a SoilSegmentSplitLocation on a 2D geometry.
C Deltares.DSoilModel.Forms.DrawingSosSoilLayer1D
►C Deltares.Geometry.Forms.ColoredDrawingObject
C Deltares.Geotechnics.Forms.DrawingAnchorAttachment
C Deltares.Geotechnics.Forms.DrawingSheetPiling
C Deltares.Geometry.Forms.DrawingBoundingBox | Drawing object that represents bounding box (rectangle) entities in the geometry (cross section) editor.
C Deltares.Geometry.Forms.DrawingLine | Drawing object that represents line (GeometryCurve) entities in the geometry (crossection) editor.
►C Deltares.Geometry.Forms.DrawingPoint
C Deltares.Geotechnics.Forms.DrawingCharacteristicPoint
C Deltares.Geotechnics.Forms.DrawingPreConsolidationStress | Drawable for an instance of PreConsolidationStress.
►C Deltares.Geometry.Forms.DrawingPointString
C Deltares.Geotechnics.Forms.DrawingLocalisedGeometryPointString
►C Deltares.Geotechnics.Forms.DrawingWaternetPointString
C Deltares.Geotechnics.Forms.DrawingHeadLine
C Deltares.Geotechnics.Forms.DrawingPhreaticLine
C Deltares.Geotechnics.Forms.DrawingWaternetLine
C Deltares.Geometry.Forms.DrawingSurface
C Deltares.Geotechnics.Forms.DrawingBlockRevetmentSegment | drawing revetment segment
C Deltares.Geotechnics.Forms.DrawingBoring | Drawing class for displaying a Boring in the DSL geometry editor see http://www.geffiles.nl/cur/BORE_nl.html
C Deltares.Geotechnics.Forms.DrawingCPT | Drawing class for displaying a CPT (sondering) in the DSL geometry editor see http://www.geffiles.nl/cur/CPT_nl.html (second graph, combined plot used as example)
C Deltares.Geotechnics.Forms.DrawingGeometry
►C Deltares.Geotechnics.Forms.DrawingLayer
C Deltares.DSoilModel.Forms.DrawingBoringLayer
C Deltares.Geotechnics.Forms.DrawingPiezometricHead | Draws the piezometric head.
►C Deltares.Geotechnics.Forms.DrawingRevetment | Draws the piezometric head.
C Deltares.Geotechnics.Forms.DrawingAsphaltRevetment | Draws the asphalt segment
C Deltares.Geotechnics.Forms.DrawingRoughnessRevetment | Draws the roughness segment
C Deltares.Geotechnics.Forms.DrawingSettlementCurve
C Deltares.Geotechnics.Forms.DrawingSoilProfile1D | Drawing class for displaying a 1D soilprofile
C Deltares.Geotechnics.Forms.DrawingSoilSurface | Drawing object that represents 2D soil layers (SoilLayer2D) entities in the geometry (crossection) editor.
C Deltares.Geotechnics.Forms.DrawingSpecificMechanismPointLocation | Drawing class for a new specific point for a mechanism (like Piping Location), which draws a simple square into a 2D Soil Profile. Simplicfication of DrawingCPT class.
C Deltares.Geotechnics.Forms.DrawingSurfaceLine2
C Deltares.Geotechnics.Forms.DrawingSwell | Draws a wave object.
C Deltares.Geotechnics.Forms.DrawingWaterBasin
C Deltares.Geotechnics.Forms.DrawingWaterLevel
C Deltares.Geotechnics.Forms.DrawingWaterPolderBasin
►C Deltares.Standard.Forms.Shape
C Deltares.Standard.Forms.ArrowShape
C Deltares.Standard.Forms.AxesShape
C Deltares.Standard.Forms.EllipseShape
C Deltares.Standard.Forms.EmptyShape
C Deltares.Standard.Forms.InsertShape
C Deltares.Standard.Forms.LegendShape
C Deltares.Standard.Forms.PolygonShape
C Deltares.Standard.Forms.PolylineShape
C Deltares.Standard.Forms.RectangleShape
C Deltares.Standard.Forms.TestRectangleShape
C Deltares.Standard.Forms.TriangleShape
►C Deltares.Standard.Forms.DExpress.IShapeImporter
►C Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter
C Deltares.Standard.Forms.DExpress.ShapeImporters.LineStringImporter
C Deltares.Standard.Forms.DExpress.ShapeImporters.MultiLineStringImporter
C Deltares.Standard.Forms.DExpress.ShapeImporters.MultiPolygonImporter
C Deltares.Standard.Forms.DExpress.ShapeImporters.PointImporter
C Deltares.Standard.Forms.DExpress.ShapeImporters.PolygonImporter
C Deltares.Standard.Forms.DExpress.ShapeImporters.SmartLineStringImporter | This class initializes the geometry of different types in the data model from imported geometries of type GeometryType.LineString. Either the geometry of the type in the data model IS a point string, or ACCEPTS a point string. This can be defined by implementing the IGeographicString or the IGeographicPointFromString interfaces.
►C Deltares.Standard.Forms.DotSpatial.IShapeImporter
C Deltares.Standard.Forms.DotSpatial.LineStringImporter
C Deltares.Standard.Forms.DotSpatial.PointImporter
C Deltares.Geometry.Forms.ISoilGeometryViewSettings
C Deltares.Geotechnics.ISoilProfileProvider | Interface for providing the 1D Soil Profile TODO: Comment
►C ITransformer
C Deltares.DSoilModel.Data.DSoilModelStiFileTransformer
C Deltares.DSoilModel.Data.DSoilModelTransformer
C Deltares.Standard.Web.IUploadDownload
C Deltares.Standard.IUrl
►C IValidationResult
C Deltares.Standard.Forms.VisualValidationResult
C Deltares.Standard.Forms.IViewConfiguration | Contains the properties which will be shown as columns in the table.
►C IVisibleEnabled
C Deltares.DSoilModel.Forms.DSoilModelGeometryEditor | The D-Soil Model Geometry Editor
C Deltares.DSoilModel.Forms.DSoilModelMapEditor | The D-Soil Model MapEditor
C Deltares.DSoilModel.Forms.DSoilModelPlugin | Main Class for D-Soil Model
C Deltares.DSoilModel.Forms.DSoilModelSegmentGeometryEditor | Class to be able to show a soilsegment as length profile (based on a fictive 2D profile with the length of the segment) In the length profile, the mapped CPTs and Borings belonging to the segment are shown.
C Deltares.Geotechnics.SoilProfile1D | 1D Soil Profile Object TODO: Comment
C Deltares.Geotechnics.WaternetCreator.Location
C Deltares.Standard.Forms.DExpress.GeometryEditor | TODO: Comment
C Deltares.Standard.Forms.DExpress.GridViewControl | Generic Grid Control extend from DXGridControl
C Deltares.Standard.Forms.DExpress.MainForm | TODO: Comment
C Deltares.Standard.Forms.DExpress.MapEditor | Map component of DSL Mainform
C Deltares.Standard.Forms.DExpress.TreeViewControl | Generic Grid Control extend from DXTreeList
C Deltares.Standard.Forms.ProgramSettings
C Deltares.Standard.Forms.ShapeInfo | Information about the Shape
C Deltares.Standard.Forms.VisualValidationResult
►C Deltares.Geometry.Forms.IWaternetViewSettings
C Deltares.Geotechnics.Forms.GeotechnicsViewSettings
►C IWKT
C Deltares.Standard.DotSpatialDgs.BackgroundFeature
►C IXmlHandler
C Deltares.Geotechnics.IO.SurfaceLineXmlHandler | This handler is responsible for handling an object which has been created with the SurfaceLine type. Since the old SurfaceLine has been refactored, this handler will convert the old SurfaceLine to a SurfaceLine2.
C Deltares.Geotechnics.IO.XmlAquiferHandler
C Deltares.Geotechnics.IO.XmlSoilsToSoilListHandler
►C Label
C Deltares.Standard.Forms.TransparentLabel
C Deltares.Standard.Forms.DExpress.LateBindingComponent
C Deltares.Standard.Forms.LegendItem
C Deltares.Geotechnics.WaternetCreator.LineHelper
C Deltares.Standard.Forms.DExpress.LocalizationSupport | Allows components to register to be automatically translated.
►C Localizer
C Deltares.Standard.Forms.DExpress.CustomLocalizer
C Deltares.Standard.Web.Log
C Deltares.Standard.Web.LogDetect
C Deltares.Standard.Application.LogHelper | LogHelper is a utility class to simplify logging to different appenders. This class uses log4net to delegate the actual logging. See the log4net documentation to configure this API in the client application using either the configuration file or programmaticaly
C Deltares.Standard.Forms.DExpress.MapLayerDefinition | Class defining various property of a map layer, like feature type, name, symbology.
►C MapLineLayer
C Deltares.Standard.Forms.DExpress.MyMapLineLayer | This class is a customized version of DotSpatial MapLineLayer, adding specific feature selection functionality
►C MapPointLayer
C Deltares.Standard.Forms.DExpress.MyMapPointLayer | This class is a customized version of DotSpatial MapPointLayer, adding specific feature selection functionality
►C MapPolygonLayer
C Deltares.Standard.Forms.DExpress.MyMapPolygonLayer | This class is a customized version of DotSpatial MapPolygonLayer, adding specific feature selection functionality
C Deltares.Standard.DotSpatialDgs.MapProjectionManager | Class for managing the map projections. Add a mapping of the internally used map projections definition (an enumeration) to the map projection definition of the mapping component in use in methode "InitializeMappings()".
C Deltares.Standard.Forms.MessageBoxManager
C Deltares.Standard.Forms.Messenger | Wrapper around MessageBox, allowing messages to be send via console or message box itself.
C Deltares.Geotechnics.IO.Importers.OldBoundary
C Deltares.Geotechnics.IO.Importers.OldGeometryFileImporter
C Deltares.Standard.Web.PageSupport | Class which takes care for all interaction between an ASP page and an IPropertyObject. This class takes care that properties are displayed in the ASP page and in the event the user changes values, they are sent back to the source object. All web controls in your web page associated with a property or method in the source object, should start with an underscoare followed by the property or method name.
►C PanelControl
C Deltares.Standard.Forms.DExpress.ModelDialog
C Waternet.PhreaticLine
►C Deltares.Geotechnics.WaternetCreator.PlLinesCreator
C Deltares.Geotechnics.WaternetCreator.ExpertKnowledgePLLinesCreator
C Deltares.Standard.Forms.Presenter
C Deltares.Standard.Forms.DExpress.PropertyControlFactory< T > | A factory to dynamically create property controls for data classes. (easiest way to use this is from the mainform: MainForm.CreateAndRegisterPropertyFormFor<T>(System.Linq.Expressions.Expression<System.Func<T,object>>[])
►C PropertyGridControl
C Deltares.Standard.Forms.DExpress.GeoPropertyGrid
C Deltares.Standard.Forms.DExpress.RasterLayerDefinition
C Deltares.Standard.Forms.DExpress.RegisteredSubControlFactories | class that manages IPropertySubControlFactory objects, so the PropertyControlFactory can get them to create controls for properties
C Deltares.Standard.Forms.DExpress.Report
C Deltares.Standard.Forms.DExpress.ReportChapter
C Deltares.Standard.Forms.DExpress.ReportItem
C Deltares.Standard.Forms.DExpress.ReportManager
►C RepositoryItemTextEdit
C Deltares.Standard.Forms.DExpress.GeoRepositoryTextEdit
C Deltares.Standard.Web.dinoservices.RequestWithCriteriaType
C Deltares.Geometry.Forms.Properties.Resources | A strongly-typed resource class, for looking up localized strings, etc.
C Deltares.DSoilModel.Application.Properties.Resources | A strongly-typed resource class, for looking up localized strings, etc.
C Deltares.Standard.Forms.Properties.Resources | A strongly-typed resource class, for looking up localized strings, etc.
C Deltares.DSoilModel.Forms.Properties.Resources | A strongly-typed resource class, for looking up localized strings, etc.
C Deltares.Standard.Forms.DExpress.Properties.Resources | A strongly-typed resource class, for looking up localized strings, etc.
C Deltares.Geotechnics.Forms.Properties.Resources | A strongly-typed resource class, for looking up localized strings, etc.
C Deltares.Geotechnics.WaternetCreator.RingtoetsWTI2017PLLinesCreator
►C ScriptControl
C Deltares.Standard.Web.Ajax.ScriptControlBase
C Deltares.Standard.Forms.DExpress.Forms.SelectableLayerItem | Data item for binding
►C Deltares.Standard.Forms.DExpress.SimplePropertySubControlFactory< bool, PanelTextBooleanValue >
C Deltares.Standard.Forms.DExpress.SubControlFactoryForBoolean
►C Deltares.Standard.Forms.DExpress.SimplePropertySubControlFactory< decimal, PanelTextNumericValue >
C Deltares.Standard.Forms.DExpress.SubControlFactoryForDecimal
►C Deltares.Standard.Forms.DExpress.SimplePropertySubControlFactory< double, PanelTextNumericValue >
C Deltares.Standard.Forms.DExpress.SubControlFactoryForDouble
►C Deltares.Standard.Forms.DExpress.SimplePropertySubControlFactory< Enum, PanelTextComboBoxValue >
C Deltares.Standard.Forms.DExpress.SubControlFactoryForEnum
►C Deltares.Standard.Forms.DExpress.SimplePropertySubControlFactory< FileInfo, PanelTextPathValue >
C Deltares.Standard.Forms.DExpress.SubControlFactoryForFileInfo
►C Deltares.Standard.Forms.DExpress.SimplePropertySubControlFactory< int, PanelTextNumericValue >
C Deltares.Standard.Forms.DExpress.SubControlFactoryForInteger
►C Deltares.Standard.Forms.DExpress.SimplePropertySubControlFactory< List< object >, PanelTextLinkValue >
C Deltares.Standard.Forms.DExpress.SubControlFactoryForLinkedObject
►C Deltares.Standard.Forms.DExpress.SimplePropertySubControlFactory< object, PanelTextComboBoxValue >
C Deltares.Standard.Forms.DExpress.SubControlFactoryForDomainProperty
►C Deltares.Standard.Forms.DExpress.SimplePropertySubControlFactory< Stochast, PanelTextPopupContainerEdit >
C Deltares.Standard.Forms.DExpress.SubControlFactoryForStochast
►C Deltares.Standard.Forms.DExpress.SimplePropertySubControlFactory< string, PanelTextStringValue >
C Deltares.Standard.Forms.DExpress.SubControlFactoryForString
►C SoapHttpClientProtocol
C Deltares.Standard.Web.dinoservices.CptService
►C SoilLayer1D
C Deltares.DSoilModel.Data.SosSoilLayer1D
►C SoilProfile
C Deltares.Geotechnics.SoilProfile1D | 1D Soil Profile Object TODO: Comment
C Deltares.Geotechnics.WaternetCreator.SoilVolumeMassCalculator
C Deltares.Standard.Forms.SourceProperty
C Deltares.Standard.Forms.SpatialEditorBarSupport
C Deltares.Geometry.Forms.SpatialEditorColors
C Deltares.Geotechnics.Forms.StressCurveReader
►C StringConverter
C Deltares.Geometry.Forms.GeometryViewSettings
C Deltares.Geotechnics.Forms.GeotechnicsViewSettings
►C SystemEventArgs
C Deltares.Standard.Forms.DExpress.NewDataSet.AssembliesRowChangeEvent | Row event argument class /summary>
C Deltares.Standard.Forms.DExpress.NewDataSet.AssemblyRowChangeEvent | Row event argument class /summary>
C Deltares.Standard.Forms.DExpress.NewDataSet.FileRowChangeEvent | Row event argument class /summary>
C Deltares.Standard.Forms.DExpress.NewDataSet.IDRowChangeEvent | Row event argument class /summary>
C Deltares.Standard.Forms.DExpress.NewDataSet.StringRowChangeEvent | Row event argument class /summary>
►C TableLayoutPanel
C Deltares.Standard.Forms.DBTableLayoutPanel Double buffered

See also
TableLayoutPanel

.

►C TypedTableBase
C Deltares.Standard.Forms.DExpress.NewDataSet.AssembliesDataTable | Represents the strongly named DataTable class. /summary>
C Deltares.Standard.Forms.DExpress.NewDataSet.AssemblyDataTable | Represents the strongly named DataTable class. /summary>
C Deltares.Standard.Forms.DExpress.NewDataSet.FileDataTable | Represents the strongly named DataTable class. /summary>
C Deltares.Standard.Forms.DExpress.NewDataSet.IDDataTable | Represents the strongly named DataTable class. /summary>
C Deltares.Standard.Forms.DExpress.NewDataSet.StringDataTable | Represents the strongly named DataTable class. /summary>
►C UITypeEditor
C Deltares.Standard.Forms.DirectoryEditor
C Deltares.Standard.Forms.FileEditor
C Deltares.Geotechnics.WaternetCreator.UpliftCalculator
►C UserControl
C Deltares.DSoilModel.Forms.CenterCrestLocationPropertyControl
C Deltares.DSoilModel.Forms.SoilSegmentSplitLocationControl
C Deltares.DSoilModel.Forms.SosSoilLayer1DControl
C Deltares.DSoilModel.Forms.SosSoilProfile1DControl
C Deltares.Geometry.Forms.GeometryCurveControl
C Deltares.Geometry.Forms.GeometryPointControl
C Deltares.Geometry.Forms.GeometryStringControl
C Deltares.Geotechnics.Forms.AnchorAttachmentControl
C Deltares.Geotechnics.Forms.BondStressCurveControl | Earthquake Dialog.
C Deltares.Geotechnics.Forms.BoringControl | Earthquake Dialog.
C Deltares.Geotechnics.Forms.BoringLookupControl
C Deltares.Geotechnics.Forms.CPTControl | Earthquake Dialog.
C Deltares.Geotechnics.Forms.CPTLookupControl
C Deltares.Geotechnics.Forms.DegreeOfConsolidationDialog
C Deltares.Geotechnics.Forms.DegreeOfConsolidationMatrixControl
C Deltares.Geotechnics.Forms.DesignPointControl | Earthquake Dialog.
C Deltares.Geotechnics.Forms.DikeLineControl | Earthquake Dialog.
C Deltares.Geotechnics.Forms.GeometryPropertyControl
C Deltares.Geotechnics.Forms.HydraulicBoundaryControl | Hydraulic boundary Dialog.
C Deltares.Geotechnics.Forms.MaterialEditorDialog
C Deltares.Geotechnics.Forms.PreconsolidationStressControl
C Deltares.Geotechnics.Forms.ProbabilisticControl | Earthquake Dialog.
C Deltares.Geotechnics.Forms.RevetmentLayerControl
C Deltares.Geotechnics.Forms.SchematizedSurfaceLineControl
C Deltares.Geotechnics.Forms.SegmentControl | Soil Segment property control.
C Deltares.Geotechnics.Forms.SettlementCurveControl
C Deltares.Geotechnics.Forms.ShearStressCurveControl | Earthquake Dialog.
C Deltares.Geotechnics.Forms.SheetPilingControl
C Deltares.Geotechnics.Forms.SoilBondStressCurveControl | same as SoilStressCurveControl, except StressCurve is BondStressCurve
C Deltares.Geotechnics.Forms.SoilLayer2DControl
C Deltares.Geotechnics.Forms.SoilLayerControl
C Deltares.Geotechnics.Forms.SoilProfile1DControl | SoilProfile 1D properties control
C Deltares.Geotechnics.Forms.SoilProfile2DControl | SoilProfile 2D Dialog.
C Deltares.Geotechnics.Forms.SoilStressCurveControl | custom property control for soilsurface and geometrypoints
C Deltares.Geotechnics.Forms.SoilSurfacePointsControl
C Deltares.Geotechnics.Forms.SoilSurfacePropertyControl | Custom property control for soilsurface and geometrypoints.
C Deltares.Geotechnics.Forms.SpecificMechanismPointLocationControl
C Deltares.Geotechnics.Forms.StochastControl
C Deltares.Geotechnics.Forms.StressCurveControl | Earthquake Dialog.
C Deltares.Geotechnics.Forms.SurfaceLine2Control
C Deltares.Geotechnics.Forms.WaterLineControl
C Deltares.Geotechnics.Forms.WaternetControl | Tree on slope dialog.
C Deltares.Standard.Forms.DExpress.AboutControl
C Deltares.Standard.Forms.DExpress.DynamicChartControl
C Deltares.Standard.Forms.DExpress.DynamicImageControl
C Deltares.Standard.Forms.DExpress.DynamicMessagesControl
C Deltares.Standard.Forms.DExpress.DynamicNavigatorControl
C Deltares.Standard.Forms.DExpress.DynamicOutputControl
C Deltares.Standard.Forms.DExpress.DynamicPropertyControl | Control to display custom property windows
C Deltares.Standard.Forms.DExpress.DynamicPropertyTabControl< T >
C Deltares.Standard.Forms.DExpress.DynamicResourcesControl
C Deltares.Standard.Forms.DExpress.DynamicTableControl
C Deltares.Standard.Forms.DExpress.Forms.FieldMappingControl
C Deltares.Standard.Forms.DExpress.GeometryEditor | TODO: Comment
C Deltares.Standard.Forms.DExpress.GridViewControl | Generic Grid Control extend from DXGridControl
C Deltares.Standard.Forms.DExpress.ListViewControl
C Deltares.Standard.Forms.DExpress.MapEditor | Map component of DSL Mainform
C Deltares.Standard.Forms.DExpress.MapLayersPropertyControl
C Deltares.Standard.Forms.DExpress.MapLegendPropertyControl
C Deltares.Standard.Forms.DExpress.PanelAction
C Deltares.Standard.Forms.DExpress.PanelLinearConversionValue
C Deltares.Standard.Forms.DExpress.PanelTextBooleanValue
C Deltares.Standard.Forms.DExpress.PanelTextComboBoxValue
C Deltares.Standard.Forms.DExpress.PanelTextLinkValue
C Deltares.Standard.Forms.DExpress.PanelTextNumericValue
C Deltares.Standard.Forms.DExpress.PanelTextPathValue
C Deltares.Standard.Forms.DExpress.PanelTextPopupContainerEdit
C Deltares.Standard.Forms.DExpress.PanelTextStringValue
C Deltares.Standard.Forms.DExpress.ProgramOptionsControl
C Deltares.Standard.Forms.DExpress.Project.DescriptionDialog
C Deltares.Standard.Forms.DExpress.PropertyControl
C Deltares.Standard.Forms.DExpress.ReportControl
C Deltares.Standard.Forms.DExpress.ReportDlg | Form that displays a report document
C Deltares.Standard.Forms.DExpress.SpatialEditorProperties
C Deltares.Standard.Forms.DExpress.TreeViewControl | Generic Grid Control extend from DXTreeList
C Deltares.Standard.Forms.DExpress.UnitsDialog
C Deltares.Standard.Forms.MatrixViewer
C Deltares.Standard.Forms.ProgressBarWithText
C Deltares.Standard.Forms.SpatialEditor | TODO: Comment
C Deltares.Standard.Forms.ZoomablePictureBox
C Deltares.Standard.Forms.ViewCommand | Represnts a view command
C Waternet.Waternet
C Deltares.Geotechnics.WaternetCreator.WaternetCreator
C Waternet.WaternetCurve
C Waternet.WaternetLine
C Waternet.WaternetPoint
C Waternet.WaternetPolyCurve
C Deltares.Standard.Forms.DExpress.WebMapPlugin
►C XtraForm
C Deltares.Standard.Forms.DExpress.Forms.ExportLayersDialog
C Deltares.Standard.Forms.DExpress.MainForm | TODO: Comment
C Deltares.Standard.Forms.DExpress.ProgressDialog
C Deltares.Standard.Forms.DExpress.SplashDialog
►C XtraReport
C Deltares.Standard.Forms.DExpress.ActiveWindowReport
►C XtraUserControl
C Deltares.DSoilModel.Forms.FilmStrip | Control to show the Stochastic Soil Profiles of a Stochastic Soil Model as a film strip under the Geometry Editor.
►C Attribute
C Deltares.Standard.Web.Ajax.ExtenderControlPropertyAttribute
C Deltares.Standard.Web.Ajax.ScriptControlPropertyAttribute
C Deltares.Standard.Web.Ajax.ScriptReferenceAttribute
►C Exception
C Deltares.Geotechnics.SoilProfileLayersNotSortedDescendingException | Exception for indicating that the soil profile layers are not sorted in descending order.
C Deltares.Standard.DotSpatialDgs.MapProjectionManagerException | Exception class for MapProjectionManager
►C Project
C Deltares.DSoilModel.Data.DSoilModelProject | D-Soil Model Project
Generated on Tue Dec 15 2015 18:15:40 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Class Members

Tool for the (stochastic) subsoil definition.
Here is a list of all documented class members with links to the class documentation for each member:

- a -

  • Abort : Deltares.Standard.Forms.MessageBoxManager
  • accept : Deltares.Standard.Forms.Properties.Resources
  • Action : Deltares.Standard.Forms.ShapeEventArgs
  • ActivateFirstData() : Deltares.DSoilModel.Data.DSoilModelProject
  • Add : Deltares.Standard.Forms.Properties.Resources
  • AddArrow() : Deltares.Standard.Forms.SpatialEditor
  • AddCaption : Deltares.Standard.Forms.DExpress.Properties.Resources
  • AddCenterCrestLocationTo2DProfile() : Deltares.DSoilModel.Forms.DSoilModelGeometryEditor
  • AddCharacteristicPointToSurfaceLine() : Deltares.Geotechnics.IO.Importers.CharacteristicPointsImporter
  • AddComponent() : Deltares.Standard.Forms.DExpress.ReloadManager
  • AddCPTCallback : Deltares.DSoilModel.Forms.DSoilModelGeometryEditor , Deltares.DSoilModel.Forms.DSoilModelSegmentGeometryEditor
  • AddEllipse() : Deltares.Standard.Forms.SpatialEditor
  • AddFeatureMapTool() : Deltares.Standard.Forms.DExpress.MapTools.AddFeatureMapTool
  • AddHeadlineCaption : Deltares.Geotechnics.Forms.Properties.Resources
  • AddInsertPoint() : Deltares.Standard.Forms.SpatialEditor
  • AddItem_Glyph : Deltares.Standard.Forms.DExpress.Properties.Resources
  • AddItemHint : Deltares.Standard.Forms.DExpress.Properties.Resources
  • AddLayer() : Deltares.Standard.Forms.DExpress.MapEditor
  • AddList() : Deltares.Standard.Forms.SpatialEditor
  • AddObject() : Deltares.Standard.Forms.SpatialEditor
  • AddOldProjectDataBaseToProject() : Deltares.DSoilModel.Data.DSoilModelIO
  • AddOldSoilDBToProject() : Deltares.DSoilModel.Data.DSoilModelIO
  • AddPointCaption : Deltares.Geometry.Forms.Properties.Resources , Deltares.Geotechnics.Forms.Properties.Resources
  • AddPointContextItem : Deltares.Standard.Forms.DExpress.GeometryEditor
  • AddPolylineCaption : Deltares.Geometry.Forms.Properties.Resources
  • AddProgramSettingsToSettingsDialog() : Deltares.Standard.Forms.DExpress.MainForm
  • AddProperty() : Deltares.Standard.Forms.DExpress.MapEditor , Deltares.Standard.Forms.SpatialEditor
  • AddRaster() : Deltares.Standard.Forms.DExpress.MapEditor
  • AddRectangle() : Deltares.Standard.Forms.SpatialEditor
  • AddRow() : Deltares.Standard.Forms.DExpress.GridViewControl , Deltares.Standard.Forms.DExpress.GridViewController< T > , Deltares.Standard.Forms.IGridController
  • AddRowCaption : Deltares.Standard.Forms.DExpress.Properties.Resources
  • AddRowCommand() : Deltares.Standard.Forms.DExpress.GridViewControl
  • AddselectedobjectCaption : Deltares.Standard.Forms.DExpress.Properties.Resources
  • AddShape() : Deltares.Standard.Forms.SpatialEditor
  • AddSoilDataToProject() : Deltares.DSoilModel.Data.DSoilModelProject
  • AddSurfaceLineToCreateNew2DProfile() : Deltares.DSoilModel.Forms.DSoilModelGeometryEditor
  • AddTabPage() : Deltares.Standard.Forms.DExpress.DialogTemplate
  • AddTabPageToAboutDialog() : Deltares.Standard.Forms.DExpress.MainForm
  • AddTabPageToSettingsDialog() : Deltares.Standard.Forms.DExpress.MainForm
  • AddToolBarItem() : Deltares.Standard.Forms.DExpress.GeometryEditor
  • AddToolbarItems() : Deltares.Standard.Forms.DExpress.GeometryEditor
  • AddTriangle() : Deltares.Standard.Forms.SpatialEditor
  • AddUnitsSettingsToSettingsDialog() : Deltares.Standard.Forms.DExpress.MainForm
  • AddWaternetlineCaption : Deltares.Geotechnics.Forms.Properties.Resources
  • AdjustHeightToFit : Deltares.Standard.Forms.DExpress.GridViewControl
  • AfterAdd : Deltares.Standard.Forms.DExpress.GridViewController< T >
  • AfterDelete : Deltares.Standard.Forms.DExpress.GridViewController< T >
  • AfterInsert : Deltares.Standard.Forms.DExpress.GridViewController< T >
  • AfterRowAdd : Deltares.Standard.Forms.DExpress.GridViewControl
  • AfterRowDelete : Deltares.Standard.Forms.DExpress.GridViewControl
  • AfterRowInsert : Deltares.Standard.Forms.DExpress.GridViewControl
  • AfterRowUpdate : Deltares.Standard.Forms.DExpress.GridViewControl
  • AfterUpdate : Deltares.Standard.Forms.DExpress.GridViewController< T >
  • AllCaption : Deltares.Standard.Forms.DExpress.Properties.Resources
  • AllowAddDeleteOnly : Deltares.Standard.Forms.DExpress.GridViewControl
  • AllowAddNewFeature : Deltares.Standard.Forms.DExpress.MapLayerDefinition
  • AllowConnectingFeature : Deltares.Standard.Forms.DExpress.MapLayerDefinition
  • AllowDelete : Deltares.Standard.Forms.ShapeInfo
  • AllowDeleteFeature : Deltares.Standard.Forms.DExpress.MapLayerDefinition
  • AllowDrop() : Deltares.DSoilModel.Forms.DrawingLayerObsolete , Deltares.DSoilModel.Forms.DrawingSosSoilLayer1D , Deltares.Geometry.Forms.DrawingObject , Deltares.Geotechnics.Forms.DrawingLayer , Deltares.Geotechnics.Forms.DrawingSoilSurface
  • AllowEdit : Deltares.Standard.Forms.ShapeInfo
  • AllowEditing : Deltares.Standard.Forms.SpatialEditor
  • AllowHover : Deltares.Standard.Forms.ShapeInfo
  • AllowInserts : Deltares.Standard.Forms.DExpress.GridViewControl , Deltares.Standard.Forms.DExpress.GridViewController< T >
  • AllowLanguageSelection : Deltares.Standard.Forms.DExpress.MainForm
  • AllowMoveFeature : Deltares.Standard.Forms.DExpress.MapLayerDefinition
  • AllowMultiCoreSelection : Deltares.Standard.Forms.DExpress.MainForm , Deltares.Standard.Forms.ProgramSettings
  • AllowPanning : Deltares.Standard.Forms.SpatialEditor
  • AllowSelect : Deltares.Standard.Forms.ShapeInfo
  • AllowSelecting : Deltares.Standard.Forms.SpatialEditor
  • AllowUserColumnFilterEdit : Deltares.Standard.Forms.DExpress.GridViewControl
  • AllowZooming : Deltares.Standard.Forms.SpatialEditor
  • AlwaysAdjustHeightToFit : Deltares.Standard.Forms.DExpress.GridViewControl
  • Append() : Deltares.Standard.Forms.DExpress.GridViewControl
  • ApplicationLanguageGroupBoxCaption : Deltares.Standard.Forms.Properties.Resources
  • ApplicationLanguageLabelCaption : Deltares.Standard.Forms.Properties.Resources
  • ApplicationViewButtonCaption : Deltares.Standard.Forms.Properties.Resources
  • ApplicationViewTabPageCaption : Deltares.Standard.Forms.Properties.Resources
  • ApplyCulture() : Deltares.Standard.Forms.DExpress.ReloadManager
  • ApplyCurrentUiCulture() : Deltares.Standard.Forms.DExpress.ReloadManager
  • ApplyCurrentUiCultureToAll() : Deltares.Standard.Forms.DExpress.ReloadManager
  • ApplyDataChangeToAll() : Deltares.Standard.Forms.DExpress.ReloadManager
  • AreAllLayerIdsUnique() : Deltares.Geotechnics.SoilProfile1D
  • AreGeometryCurvesVisible : Deltares.Geometry.Forms.GeometryViewSettings , Deltares.Geometry.Forms.IGeometryViewSettings
  • AreGeometryPointsVisible : Deltares.Geometry.Forms.GeometryViewSettings
  • AreGeometrySurfaceVisible : Deltares.Geometry.Forms.GeometryViewSettings , Deltares.Geometry.Forms.IGeometryViewSettings
  • AreLoadsVisible : Deltares.Geometry.Forms.IDefinitionViewSettings
  • AreLocationMapVisible : Deltares.Geometry.Forms.ILocationMapViewSettings
  • AreSoilSurfaceLabelsOn : Deltares.Geometry.Forms.ISoilGeometryViewSettings
  • AreSoilSurfaceMaterialLabelsOn : Deltares.Geometry.Forms.ISoilGeometryViewSettings
  • Arrow_Symbol3D() : Deltares.Standard.Forms.DrawingSupport
  • Assign() : Deltares.DSoilModel.Data.SosSoilLayer1D , Deltares.Geotechnics.SoilProfile1D , Deltares.Standard.Forms.DExpress.BindSupport , Deltares.Standard.Forms.DExpress.GridViewController< T >
  • AssignProfileToLayers() : Deltares.Geotechnics.SoilProfile1D
  • Attention : Deltares.Standard.Forms.Properties.Resources
  • AutomaticRegenerationCaption : Deltares.Geometry.Forms.Properties.Resources
Generated on Tue Dec 15 2015 18:15:40 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Class Members

Tool for the (stochastic) subsoil definition.
Here is a list of all documented class members with links to the class documentation for each member:

- b -

  • Back : Deltares.Standard.Forms.Properties.Resources
  • BackgroundMaps : Deltares.Standard.Forms.DExpress.MapEditor
  • BannerJpg : Deltares.Standard.Forms.Properties.Resources
  • BannerPng : Deltares.Standard.Forms.Properties.Resources
  • BarStringAddOrRemove : Deltares.Standard.Forms.Properties.Resources
  • BarStringCustomizeButton : Deltares.Standard.Forms.Properties.Resources
  • BarStringMenuAnimationFade : Deltares.Standard.Forms.Properties.Resources
  • BarStringMenuAnimationNone : Deltares.Standard.Forms.Properties.Resources
  • BarStringMenuAnimationRandom : Deltares.Standard.Forms.Properties.Resources
  • BarStringMenuAnimationSlide : Deltares.Standard.Forms.Properties.Resources
  • BarStringMenuAnimationSystem : Deltares.Standard.Forms.Properties.Resources
  • BarStringMenuAnimationUnfold : Deltares.Standard.Forms.Properties.Resources
  • BarStringNewToolbarCaption : Deltares.Standard.Forms.Properties.Resources
  • BarStringRenameToolbarCaption : Deltares.Standard.Forms.Properties.Resources
  • BarStringResetBar : Deltares.Standard.Forms.Properties.Resources
  • BarStringResetBarCaption : Deltares.Standard.Forms.Properties.Resources
  • BarStringResetButton : Deltares.Standard.Forms.Properties.Resources
  • BarStringToolBarMenu : Deltares.Standard.Forms.Properties.Resources
  • BaseMapTool() : Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool
  • BeginUndoAction() : Deltares.Standard.Forms.DExpress.GeometryEditor
  • Bind() : Deltares.Standard.Forms.DExpress.BindSupport
  • Bind2() : Deltares.Standard.Forms.DExpress.BindSupport
  • Bind2< T >() : Deltares.Standard.Forms.DExpress.BindSupport
  • Bind< T >() : Deltares.Standard.Forms.DExpress.BindSupport
  • Bind< T, U >() : Deltares.Standard.Forms.DExpress.BindSupport
  • Bind< T1, T2 >() : Deltares.Standard.Forms.DExpress.BindSupport
  • BindProperties() : Deltares.Standard.Forms.DExpress.BindSupport
  • BindSelection() : Deltares.Standard.Forms.DExpress.BindSupport
  • BindText() : Deltares.Standard.Forms.DExpress.BindSupport
  • BindTextAndValue() : Deltares.Standard.Forms.DExpress.BindSupport
  • BindTextAndValue< T >() : Deltares.Standard.Forms.DExpress.BindSupport
  • BindTextValueAndUnit() : Deltares.Standard.Forms.DExpress.BindSupport
  • BindTextValueAndUnit< T >() : Deltares.Standard.Forms.DExpress.BindSupport
  • Blank : Deltares.Standard.Forms.Properties.Resources
  • BondStressCurveControl() : Deltares.Geotechnics.Forms.BondStressCurveControl
  • BondStressCurves : Deltares.DSoilModel.Data.DSoilModelProject
  • Boring : Deltares.DSoilModel.Forms.Properties.Resources
  • BoringControl() : Deltares.Geotechnics.Forms.BoringControl
  • BoringLookup1Ds : Deltares.DSoilModel.Data.DSoilModelProject
  • BoringLookup2Ds : Deltares.DSoilModel.Data.DSoilModelProject
  • Borings : Deltares.DSoilModel.Data.DSoilModelProject
  • Bottom : Deltares.Geotechnics.Forms.DrawingBoring , Deltares.Geotechnics.Forms.DrawingCPT , Deltares.Geotechnics.Forms.DrawingSoilProfile1D
  • BottomAquiferLayer : Deltares.Geotechnics.SoilProfile1D
  • BottomForDrawing() : Deltares.DSoilModel.Forms.DrawingCenterCrestLocation , Deltares.DSoilModel.Forms.DrawingSoilSegmentSplitLocation , Deltares.Geotechnics.Forms.DrawingSpecificMechanismPointLocation
  • BottomLevel : Deltares.Geotechnics.SoilProfile1D
  • BrowseForFolder : Deltares.Standard.Forms.Properties.Resources
  • Brush3D() : Deltares.Standard.Forms.DrawingSupport
  • btClose : Deltares.Standard.Forms.Properties.Resources
  • btClose1 : Deltares.Standard.Forms.Properties.Resources
  • btDeleteBar : Deltares.Standard.Forms.Properties.Resources
  • btDeleteBar1 : Deltares.Standard.Forms.Properties.Resources
  • btNBDlgCancel : Deltares.Standard.Forms.Properties.Resources
  • btNBDlgCancel1 : Deltares.Standard.Forms.Properties.Resources
  • btNBDlgOk : Deltares.Standard.Forms.Properties.Resources
  • btNBDlgOk1 : Deltares.Standard.Forms.Properties.Resources
  • btNewBar : Deltares.Standard.Forms.Properties.Resources
  • btNewBar1 : Deltares.Standard.Forms.Properties.Resources
  • btRenameBar : Deltares.Standard.Forms.Properties.Resources
  • btRenameBar1 : Deltares.Standard.Forms.Properties.Resources
  • btResetBar : Deltares.Standard.Forms.Properties.Resources
  • btResetBar1 : Deltares.Standard.Forms.Properties.Resources
  • BuildDelayedPropertyControlForTypes() : Deltares.Standard.Forms.DExpress.DynamicPropertyControl
  • BuildDelayedPropertyControlsForProperty< T >() : Deltares.Standard.Forms.DExpress.DynamicPropertyControl
  • BuildDelayedPropertyControlsForType() : Deltares.Standard.Forms.DExpress.DynamicPropertyControl
  • BuildPropertyControlTabForTypes() : Deltares.Standard.Forms.DExpress.DynamicPropertyControl
  • BuildPropertyControlTabsForProperty< T >() : Deltares.Standard.Forms.DExpress.DynamicPropertyControl
  • BuildPropertyControlTabsForType() : Deltares.Standard.Forms.DExpress.DynamicPropertyControl , Deltares.Standard.Forms.IDynamicPropertyControl
  • ButtonMakeNewFolder : Deltares.Standard.Forms.Properties.Resources
  • ButtonTextAbort : Deltares.Standard.Forms.Properties.Resources
  • ButtonTextCancel : Deltares.Standard.Forms.Properties.Resources
  • ButtonTextIgnore : Deltares.Standard.Forms.Properties.Resources
  • ButtonTextNo : Deltares.Standard.Forms.Properties.Resources
  • ButtonTextOk : Deltares.Standard.Forms.Properties.Resources
  • ButtonTextRetry : Deltares.Standard.Forms.Properties.Resources
  • ButtonTextYes : Deltares.Standard.Forms.Properties.Resources
  • BypassTimerForUnitTest : Deltares.Standard.Forms.DExpress.BindSupport
Generated on Tue Dec 15 2015 18:15:40 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Class Members

Tool for the (stochastic) subsoil definition.
Here is a list of all documented class members with links to the class documentation for each member:

- c -

  • CalculateExtraHeight() : Deltares.Geotechnics.WaternetCreator.UpliftCalculator
  • CalculateHeadOfPLLine() : Deltares.Geotechnics.WaternetCreator.UpliftCalculator
  • CalculateUpliftFactor() : Deltares.Geotechnics.WaternetCreator.UpliftCalculator
  • CalculationManager : Deltares.Standard.Forms.DExpress.MainForm
  • Cancel : Deltares.Standard.Forms.MessageBoxManager
  • CancelAsync() : Deltares.Standard.Web.dinoservices.CptService
  • CancelCaption : Deltares.Standard.Forms.DExpress.Properties.Resources
  • CancelCommand() : Deltares.Standard.Forms.DExpress.GeometryEditor
  • CanExecute : Deltares.Standard.Forms.ICommand
  • CanHandle() : Deltares.Geotechnics.IO.SurfaceLineInstanceFactory , Deltares.Geotechnics.IO.SurfaceLineXmlHandler
  • CannotPasteInSameRow : Deltares.Standard.Forms.DExpress.Properties.Resources
  • CanResize : Deltares.Geometry.Forms.DrawingObject
  • Caption : Deltares.Standard.Forms.DExpress.GridViewControl
  • CategoryDisplayItem() : Deltares.Standard.Forms.DExpress.CategoryDisplayItem
  • cbOptionslargeIcons : Deltares.Standard.Forms.Properties.Resources
  • cbOptionslargeIcons1 : Deltares.Standard.Forms.Properties.Resources
  • cbOptionsShowFullMenus : Deltares.Standard.Forms.Properties.Resources
  • cbOptionsShowFullMenus1 : Deltares.Standard.Forms.Properties.Resources
  • cbOptionsshowTips : Deltares.Standard.Forms.Properties.Resources
  • cbOptionsshowTips1 : Deltares.Standard.Forms.Properties.Resources
  • CenterExtents() : Deltares.Standard.Forms.SpatialEditor
  • ChartPopupMenu : Deltares.Standard.Forms.DExpress.GeoChartControl
  • ChartToTable() : Deltares.Standard.Forms.DExpress.GeoChartControl
  • CheckHitForSelection() : Deltares.Geometry.Forms.DrawingObject , Deltares.Geometry.Forms.IDrawingObject
  • Choices : Deltares.Standard.Forms.ColumnDescription
  • Circle3D() : Deltares.Standard.Forms.DrawingSupport
  • CirclePolygon3D() : Deltares.Standard.Forms.DrawingSupport
  • Clear() : Deltares.Standard.Application.LogHelper , Deltares.Standard.Forms.DExpress.GeometryEditor , Deltares.Standard.Forms.DExpress.MapEditor , Deltares.Standard.Forms.SpatialEditor
  • ClearAssignObjectOfType() : Deltares.Standard.Forms.DExpress.DynamicTableControl
  • ClearCaches() : Deltares.Standard.Forms.DExpress.BindSupport
  • ClearControl() : Deltares.DSoilModel.Forms.SosSoilProfile1DControl , Deltares.Geotechnics.Forms.SoilProfile1DControl , Deltares.Geotechnics.Forms.SoilProfile2DControl
  • ClearOpenFileHandlers() : Deltares.Standard.Forms.DExpress.MainForm
  • ClearRegistrationsForType() : Deltares.Standard.Forms.DExpress.DynamicPropertyControl
  • ClearSaveFileHandlers() : Deltares.Standard.Forms.DExpress.MainForm
  • ClearSeries() : Deltares.Standard.Forms.DExpress.GeoChartControl
  • ClearWaternet() : Deltares.Geotechnics.WaternetCreator.WaternetCreator
  • ClipBoardCleared : Deltares.Standard.Forms.DExpress.Properties.Resources
  • ClipBoardEmpty : Deltares.Standard.Forms.DExpress.Properties.Resources
  • Clone() : Deltares.DSoilModel.Data.SosSoilLayer1D , Deltares.Geotechnics.SoilProfile1D
  • CloseButtonCaption : Deltares.Standard.Forms.Properties.Resources
  • ClosedCaption : Deltares.Geometry.Forms.Properties.Resources
  • CollapseAll_Glyph : Deltares.Standard.Forms.DExpress.Properties.Resources
  • CollapseAllCaption : Deltares.Standard.Forms.DExpress.Properties.Resources
  • CollapseallHint : Deltares.Standard.Forms.DExpress.Properties.Resources
  • Color : Deltares.Standard.Forms.DExpress.MapLayerDefinition
  • ColorMaterial3D() : Deltares.Standard.Forms.DrawingSupport
  • ColorSchemeGroupBoxCaption : Deltares.Standard.Forms.Properties.Resources
  • ColorSchemeLabelCaption : Deltares.Standard.Forms.Properties.Resources
  • Column : Deltares.Standard.Forms.DExpress.Properties.Resources
  • ColumnDescription() : Deltares.Standard.Forms.ColumnDescription
  • ColumnType : Deltares.Standard.Forms.ColumnDescription
  • CombinedMessage : Deltares.Standard.Forms.DExpress.Properties.Resources
  • ComboBoxDisplayItem() : Deltares.Standard.Forms.DExpress.ComboBoxDisplayItem
  • CommandArgument : Deltares.Standard.Forms.ICommand
  • CommandLineBadFormat : Deltares.Standard.Forms.Properties.Resources
  • CommandlineErrorText : Deltares.Standard.Forms.Properties.Resources
  • CommandName : Deltares.Standard.Forms.ICommand
  • Compare() : Deltares.Standard.Forms.ShapeComparer
  • CompareTo() : Deltares.Geotechnics.SoilProfile1D , Deltares.Standard.Forms.ShapeInfo
  • CondensedviewCaption : Deltares.Standard.Forms.DExpress.Properties.Resources
  • ContainsPoint() : Deltares.DSoilModel.Forms.DrawingCenterCrestLocation , Deltares.DSoilModel.Forms.DrawingLayerObsolete , Deltares.DSoilModel.Forms.DrawingSoilSegmentSplitLocation , Deltares.DSoilModel.Forms.DrawingSosSoilLayer1D , Deltares.Geometry.Forms.DrawingLine , Deltares.Geometry.Forms.DrawingObject , Deltares.Geometry.Forms.DrawingPoint , Deltares.Geotechnics.Forms.DrawingBlockRevetmentSegment , Deltares.Geotechnics.Forms.DrawingBoring , Deltares.Geotechnics.Forms.DrawingCharacteristicPoint , Deltares.Geotechnics.Forms.DrawingCPT , Deltares.Geotechnics.Forms.DrawingGeometry , Deltares.Geotechnics.Forms.DrawingLayer , Deltares.Geotechnics.Forms.DrawingPiezometricHead , Deltares.Geotechnics.Forms.DrawingRevetment , Deltares.Geotechnics.Forms.DrawingSoilProfile1D , Deltares.Geotechnics.Forms.DrawingSoilSurface , Deltares.Geotechnics.Forms.DrawingSpecificMechanismPointLocation , Deltares.Geotechnics.Forms.DrawingSwell , Deltares.Geotechnics.Forms.DrawingWaterBasin , Deltares.Geotechnics.Forms.DrawingWaterPolderBasin
  • Control : Deltares.Standard.Forms.DExpress.GeometryEditor , Deltares.Standard.Forms.DExpress.ToolTipVisibilityEventArgs
  • ControlWithOpenToolTip : Deltares.Standard.Forms.DExpress.BindSupport
  • ConvertToPoints() : Deltares.Standard.Forms.DrawingSupport
  • ConvexPolygon3D() : Deltares.Standard.Forms.DrawingSupport
  • CoordinateSystem : Deltares.Standard.Forms.ShapeComparer , Deltares.Standard.Forms.SpatialEditor
  • Copy : Deltares.Standard.Forms.Properties.Resources
  • CopyCaption : Deltares.Standard.Forms.DExpress.Properties.Resources
  • CopyCommand() : Deltares.Standard.Forms.DExpress.GridViewControl
  • CopyHeadlineCaption : Deltares.Geotechnics.Forms.Properties.Resources
  • CopyItem_Glyph : Deltares.Standard.Forms.DExpress.Properties.Resources
  • CopyItemHint : Deltares.Standard.Forms.DExpress.Properties.Resources
  • CopyPointCaption : Deltares.Geometry.Forms.Properties.Resources , Deltares.Geotechnics.Forms.Properties.Resources
  • CopyPolylineCaption : Deltares.Geometry.Forms.Properties.Resources
  • CopyShapeInfos() : Deltares.Standard.Forms.SpatialEditor
  • CopytoClipBoard() : Deltares.Standard.Forms.DExpress.GeoChartControl
  • CopytoClipboardCaption : Deltares.Standard.Forms.DExpress.Properties.Resources
  • CopyWaternetlineCaption : Deltares.Geotechnics.Forms.Properties.Resources
  • CPT : Deltares.DSoilModel.Forms.Properties.Resources
  • CPTControl() : Deltares.Geotechnics.Forms.CPTControl
  • CptLookup1Ds : Deltares.DSoilModel.Data.DSoilModelProject
  • CptLookup2Ds : Deltares.DSoilModel.Data.DSoilModelProject
  • CPTs : Deltares.DSoilModel.Data.DSoilModelProject
  • CptService() : Deltares.Standard.Web.dinoservices.CptService
  • Create() : Deltares.Standard.Application.LogHelper , Deltares.Standard.Forms.DExpress.GeometryEditor
  • Create< T >() : Deltares.Standard.Application.LogHelper
  • CreateAllPLLines() : Deltares.Geotechnics.WaternetCreator.PlLinesCreator
  • CreateAndBindBarItem< T >() : Deltares.Standard.Forms.DExpress.BarItemExtensions
  • CreateAndBindMenuItem< T >() : Deltares.Standard.Forms.DExpress.BarItemExtensions
  • CreateAndRegisterPropertyFormFor< T >() : Deltares.Standard.Forms.DExpress.MainForm
  • CreateAndRegisterUICommand() : Deltares.Standard.Forms.DExpress.GeometryEditor
  • CreateButton() : Deltares.DSoilModel.Forms.DSoilModelMapEditor , Deltares.Standard.Forms.DExpress.GeometryEditor
  • CreateConvexPolygonBox() : Deltares.Standard.Forms.DrawingSupport
  • CreateInstance() : Deltares.Geotechnics.IO.SurfaceLineInstanceFactory
  • CreateNew : Deltares.Standard.Forms.DExpress.GridViewControl , Deltares.Standard.Forms.DExpress.GridViewController< T > , Deltares.Standard.Forms.IGridController
  • CreateParallelCurve() : Deltares.Geotechnics.WaternetCreator.WaternetCreator
  • CreatePLLine1ByExpertKnowledge() : Deltares.Geotechnics.WaternetCreator.PlLinesCreator
  • CreatePLLine2ByExpertKnowledge() : Deltares.Geotechnics.WaternetCreator.PlLinesCreator
  • CreatePLLine3ByExpertKnowledge() : Deltares.Geotechnics.WaternetCreator.PlLinesCreator
  • CreatePLLine3ClayDikeOnSand() : Deltares.Geotechnics.WaternetCreator.PlLinesCreator
  • CreatePLLine4ByExpertKnowledge() : Deltares.Geotechnics.WaternetCreator.PlLinesCreator
  • CreatePLLineByExpertKnowledge() : Deltares.Geotechnics.WaternetCreator.PlLinesCreator
  • CreatePointInLine : Deltares.DSoilModel.Forms.DSoilModelGeometryEditor , Deltares.DSoilModel.Forms.Properties.Resources
  • CreatePolyline : Deltares.DSoilModel.Forms.DSoilModelGeometryEditor , Deltares.DSoilModel.Forms.Properties.Resources
  • CreateRecentlyUsedFilesButton() : Deltares.Standard.Forms.DExpress.MainForm
  • CreateSettingsDialog() : Deltares.Standard.Forms.DExpress.MainForm
  • Creator : Deltares.Standard.Forms.DExpress.GridViewController< T >
  • criteria : Deltares.Standard.Web.dinoservices.RequestWithCriteriaType
  • Cross_Symbol3D() : Deltares.Standard.Forms.DrawingSupport
  • csNotRes : Deltares.DSoilModel.Forms.Properties.Resources
  • csNotRes_Approved : Deltares.DSoilModel.Forms.Properties.Resources
  • csNotRes_ApprovedEarlier : Deltares.DSoilModel.Forms.Properties.Resources
  • csNotRes_NotCalculated : Deltares.DSoilModel.Forms.Properties.Resources
  • csNotRes_Rejected : Deltares.DSoilModel.Forms.Properties.Resources
  • Culture : Deltares.DSoilModel.Application.Properties.Resources , Deltares.DSoilModel.Forms.Properties.Resources , Deltares.Geometry.Forms.Properties.Resources , Deltares.Geotechnics.Forms.Properties.Resources , Deltares.Standard.Forms.DExpress.Properties.Resources , Deltares.Standard.Forms.Properties.Resources
  • CurrentContext : Deltares.Standard.Forms.DExpress.GridViewControl
  • CurrentFailureMechanism : Deltares.DSoilModel.Data.DSoilModelProject
  • CurrentSeriesView : Deltares.Standard.Forms.DExpress.GeoChartControl
  • CurrentSoilSegments : Deltares.DSoilModel.Data.DSoilModelProject
  • Currentwaternet : Deltares.Geotechnics.Forms.Properties.Resources
  • CursorOnControl : Deltares.Standard.Forms.SpatialEditor
  • CursorOnMap : Deltares.Standard.Forms.DExpress.MapEditor
  • CustomizeCaption : Deltares.Standard.Forms.Properties.Resources
  • CustomizeCaption1 : Deltares.Standard.Forms.Properties.Resources
  • CutCaption : Deltares.Standard.Forms.DExpress.Properties.Resources
  • CutCommand() : Deltares.Standard.Forms.DExpress.GridViewControl
  • CutHeadlineCaption : Deltares.Geotechnics.Forms.Properties.Resources
  • CutItem_Glyph : Deltares.Standard.Forms.DExpress.Properties.Resources
  • CutItemHint : Deltares.Standard.Forms.DExpress.Properties.Resources
  • CutItemsRemoved : Deltares.Standard.Forms.DExpress.Properties.Resources
  • CutPointCaption : Deltares.Geometry.Forms.Properties.Resources , Deltares.Geotechnics.Forms.Properties.Resources
  • CutPolylineCaption : Deltares.Geometry.Forms.Properties.Resources
  • CutWaternetlineCaption : Deltares.Geotechnics.Forms.Properties.Resources
Generated on Tue Dec 15 2015 18:15:40 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Class Members

Tool for the (stochastic) subsoil definition.
Here is a list of all documented class members with links to the class documentation for each member:

- d -

  • DataSource : Deltares.Standard.Forms.DExpress.MyMapLineLayer , Deltares.Standard.Forms.DExpress.MyMapPointLayer , Deltares.Standard.Forms.DExpress.MyMapPolygonLayer
  • DataSourceEmpty : Deltares.Standard.Forms.DExpress.Properties.Resources
  • DataSources : Deltares.DSoilModel.Data.DSoilModelProject
  • DataTableList : Deltares.Standard.Forms.DExpress.GeoChartControl
  • Debug : Deltares.Standard.Forms.Properties.Resources
  • DecimateHeightCaption : Deltares.Geotechnics.Forms.Properties.Resources
  • DefaultEmail : Deltares.Standard.Forms.DExpress.Properties.Resources
  • DefaultForSelected() : Deltares.Standard.Forms.DExpress.AssignStrategy , Deltares.Standard.Forms.DExpress.DivideStrategy , Deltares.Standard.Forms.DExpress.GreaterThanStrategy , Deltares.Standard.Forms.DExpress.GridEditValueStrategy , Deltares.Standard.Forms.DExpress.LessThanStrategy , Deltares.Standard.Forms.DExpress.MinusStrategy , Deltares.Standard.Forms.DExpress.MultiplyStrategy , Deltares.Standard.Forms.DExpress.PlusStrategy
  • DefaultLayoutXML : Deltares.Standard.Forms.DExpress.MainForm
  • DefaultLookAndFeelRadioButtonCaption : Deltares.Standard.Forms.Properties.Resources
  • DefaultPropertyGrid : Deltares.Standard.Forms.IDynamicPropertyControl
  • DefaultTelephoneNumber : Deltares.Standard.Forms.DExpress.Properties.Resources
  • DegreeOfConsolidationCaption : Deltares.Geotechnics.Forms.Properties.Resources
  • DegreeOfConsolidationMatrixControl() : Deltares.Geotechnics.Forms.DegreeOfConsolidationMatrixControl
  • Delayed : Deltares.Standard.Forms.DExpress.BindSupport
  • Delete : Deltares.Standard.Forms.DExpress.Properties.Resources
  • DeleteAllEventHandlers() : Deltares.Standard.Forms.CommandLineWindow
  • DeleteCaption : Deltares.Standard.Forms.DExpress.Properties.Resources
  • DeleteCoinsidingPoints() : Deltares.Geotechnics.WaternetCreator.LineHelper
  • DeleteFeatureMapTool() : Deltares.Standard.Forms.DExpress.MapTools.DeleteFeatureMapTool
  • DeleteHeadlineCaption : Deltares.Geotechnics.Forms.Properties.Resources
  • DeleteItem_Glyph : Deltares.Standard.Forms.DExpress.Properties.Resources
  • DeleteItemHint : Deltares.Standard.Forms.DExpress.Properties.Resources
  • deleteMenuItem_Click() : Deltares.Standard.Forms.DExpress.MapTools.DeleteFeatureMapTool
  • DeletePointCaption : Deltares.Geometry.Forms.Properties.Resources , Deltares.Geotechnics.Forms.Properties.Resources
  • DeletePolylineCaption : Deltares.Geometry.Forms.Properties.Resources
  • DeleteRow() : Deltares.Standard.Forms.DExpress.GridViewControl , Deltares.Standard.Forms.DExpress.GridViewController< T > , Deltares.Standard.Forms.IGridController
  • DeleterowCaption : Deltares.Standard.Forms.DExpress.Properties.Resources
  • DeleteRowCommand() : Deltares.Standard.Forms.DExpress.GridViewControl , Deltares.Standard.Forms.DExpress.TreeViewControl
  • DeleteselectedobjectCaption : Deltares.Standard.Forms.DExpress.Properties.Resources
  • DeleteSelectedObjects() : Deltares.Standard.Forms.DExpress.GeometryEditor
  • DeleteWaternetlineCaption : Deltares.Geotechnics.Forms.Properties.Resources
  • Deletion : Deltares.Standard.Forms.DExpress.Properties.Resources
  • Description : Deltares.Standard.Forms.DExpress.ControlBinding , Deltares.Standard.Forms.ViewCommand
  • DescriptionCaption : Deltares.Geotechnics.Forms.Properties.Resources , Deltares.Standard.Forms.DExpress.Properties.Resources
  • DeselectAllObjects() : Deltares.Standard.Forms.DExpress.GeometryEditor
  • DesignLevelCaption : Deltares.Geotechnics.Forms.Properties.Resources
  • DesignPointControl() : Deltares.Geotechnics.Forms.DesignPointControl
  • DestinationDirectory : Deltares.Standard.Forms.DExpress.Forms.ExportLayersDialog , Deltares.Standard.Forms.DExpress.Forms.IExportLayersDialog
  • determineAverageSandDiameters() : Deltares.Geotechnics.SoilProfile1D
  • DetermineInfiltrationLayer() : Deltares.Geotechnics.SoilProfile1D
  • DetermineIntersectionBetweenTaludRiverSideAndWaterLevel() : Deltares.Geotechnics.WaternetCreator.PlLinesCreator
  • DetermineIntersectionBetweenWaterLevelAndDike() : Deltares.Geotechnics.WaternetCreator.PlLinesCreator
  • DikeLineControl() : Deltares.Geotechnics.Forms.DikeLineControl
  • dinocpt2b : Deltares.DSoilModel.Forms.Properties.Resources
  • dinocpt2b1 : Deltares.DSoilModel.Forms.Properties.Resources
  • dinocpt2b2 : Deltares.DSoilModel.Forms.Properties.Resources
  • dinocpt2b3 : Deltares.DSoilModel.Forms.Properties.Resources
  • DirectoriesCheckBoxCaption : Deltares.Standard.Forms.Properties.Resources
  • DirectoriesGroupBoxCaption : Deltares.Standard.Forms.Properties.Resources
  • DirectoriesTabPageCaption : Deltares.Standard.Forms.Properties.Resources
  • Dirty : Deltares.Standard.Forms.DExpress.MyFeatureSet
  • DisableAll() : Deltares.Standard.Forms.DExpress.BindSupport
  • DisableAllButtonDownState() : Deltares.Standard.Forms.DExpress.GeometryEditor
  • DisableBasemapLayer() : Deltares.Standard.Forms.DExpress.WebMapPlugin
  • DisplayResults() : Deltares.Standard.Web.Cpt
  • DisplaySelectedObject() : Deltares.Standard.Forms.DExpress.DynamicPropertyControl
  • Dispose() : Deltares.DSoilModel.Data.DSoilModelProject , Deltares.DSoilModel.Forms.CenterCrestLocationPropertyControl , Deltares.DSoilModel.Forms.DSoilModelMapEditor , Deltares.DSoilModel.Forms.DSoilModelSegmentGeometryEditor , Deltares.DSoilModel.Forms.FilmStrip , Deltares.DSoilModel.Forms.ModalListBox , Deltares.DSoilModel.Forms.SoilSegmentSplitLocationControl , Deltares.DSoilModel.Forms.SosSoilLayer1DControl , Deltares.DSoilModel.Forms.SosSoilProfile1DControl , Deltares.Geometry.Forms.GeometryCurveControl , Deltares.Geometry.Forms.GeometryPointControl , Deltares.Geometry.Forms.GeometryStringControl , Deltares.Geotechnics.Forms.AnchorAttachmentControl , Deltares.Geotechnics.Forms.BondStressCurveControl , Deltares.Geotechnics.Forms.BoringControl , Deltares.Geotechnics.Forms.BoringLookupControl , Deltares.Geotechnics.Forms.CPTControl , Deltares.Geotechnics.Forms.CPTLookupControl , Deltares.Geotechnics.Forms.DegreeOfConsolidationDialog , Deltares.Geotechnics.Forms.DegreeOfConsolidationMatrixControl , Deltares.Geotechnics.Forms.DesignPointControl , Deltares.Geotechnics.Forms.DikeLineControl , Deltares.Geotechnics.Forms.GeometryPropertyControl , Deltares.Geotechnics.Forms.HydraulicBoundaryControl , Deltares.Geotechnics.Forms.MaterialEditorDialog , Deltares.Geotechnics.Forms.PreconsolidationStressControl , Deltares.Geotechnics.Forms.ProbabilisticControl , Deltares.Geotechnics.Forms.RevetmentLayerControl , Deltares.Geotechnics.Forms.SchematizedSurfaceLineControl , Deltares.Geotechnics.Forms.SegmentControl , Deltares.Geotechnics.Forms.SettlementCurveControl , Deltares.Geotechnics.Forms.ShearStressCurveControl , Deltares.Geotechnics.Forms.SheetPilingControl , Deltares.Geotechnics.Forms.SoilBondStressCurveControl , Deltares.Geotechnics.Forms.SoilLayer2DControl , Deltares.Geotechnics.Forms.SoilLayerControl , Deltares.Geotechnics.Forms.SoilProfile1DControl , Deltares.Geotechnics.Forms.SoilProfile2DControl , Deltares.Geotechnics.Forms.SoilStressCurveControl , Deltares.Geotechnics.Forms.SoilSurfacePointsControl , Deltares.Geotechnics.Forms.SoilSurfacePropertyControl , Deltares.Geotechnics.Forms.SpecificMechanismPointLocationControl , Deltares.Geotechnics.Forms.StochastControl , Deltares.Geotechnics.Forms.StressCurveControl , Deltares.Geotechnics.Forms.SurfaceLine2Control , Deltares.Geotechnics.Forms.WaterLineControl , Deltares.Geotechnics.Forms.WaternetControl , Deltares.Standard.Forms.CustomConfirmDialog , Deltares.Standard.Forms.DExpress.AboutControl , Deltares.Standard.Forms.DExpress.ActiveWindowReport , Deltares.Standard.Forms.DExpress.ComponentWrappers.GaugeControlBinding , Deltares.Standard.Forms.DExpress.DialogTemplate , Deltares.Standard.Forms.DExpress.DisclaimerDialog , Deltares.Standard.Forms.DExpress.DynamicChartControl , Deltares.Standard.Forms.DExpress.DynamicImageControl , Deltares.Standard.Forms.DExpress.DynamicMessagesControl , Deltares.Standard.Forms.DExpress.DynamicNavigatorControl , Deltares.Standard.Forms.DExpress.DynamicOutputControl , Deltares.Standard.Forms.DExpress.DynamicPropertyControl , Deltares.Standard.Forms.DExpress.DynamicPropertyTabControl< T > , Deltares.Standard.Forms.DExpress.DynamicResourcesControl , Deltares.Standard.Forms.DExpress.DynamicTableControl , Deltares.Standard.Forms.DExpress.Forms.ExportLayersDialog , Deltares.Standard.Forms.DExpress.Forms.FieldMappingControl , Deltares.Standard.Forms.DExpress.ListViewControl , Deltares.Standard.Forms.DExpress.MainForm , Deltares.Standard.Forms.DExpress.MapEditor , Deltares.Standard.Forms.DExpress.MapLayersPropertyControl , Deltares.Standard.Forms.DExpress.MapLegendPropertyControl , Deltares.Standard.Forms.DExpress.PanelAction , Deltares.Standard.Forms.DExpress.PanelLinearConversionValue , Deltares.Standard.Forms.DExpress.PanelTextBooleanValue , Deltares.Standard.Forms.DExpress.PanelTextComboBoxValue , Deltares.Standard.Forms.DExpress.PanelTextLinkValue , Deltares.Standard.Forms.DExpress.PanelTextNumericValue , Deltares.Standard.Forms.DExpress.PanelTextPathValue , Deltares.Standard.Forms.DExpress.PanelTextPopupContainerEdit , Deltares.Standard.Forms.DExpress.PanelTextStringValue , Deltares.Standard.Forms.DExpress.ProgramOptionsControl , Deltares.Standard.Forms.DExpress.ProgressDialog , Deltares.Standard.Forms.DExpress.Project.DescriptionDialog , Deltares.Standard.Forms.DExpress.PropertyControl , Deltares.Standard.Forms.DExpress.ReportControl , Deltares.Standard.Forms.DExpress.ReportDlg , Deltares.Standard.Forms.DExpress.SingleUnitDialog , Deltares.Standard.Forms.DExpress.SpatialEditorProperties , Deltares.Standard.Forms.DExpress.SplashDialog , Deltares.Standard.Forms.DExpress.StatusBar , Deltares.Standard.Forms.DExpress.UnitsDialog , Deltares.Standard.Forms.MatrixViewer , Deltares.Standard.Forms.ProgressBarWithText , Deltares.Standard.Forms.SpatialEditor , Deltares.Standard.Forms.ZoomablePictureBox
  • Distance() : Deltares.Standard.DotSpatialDgs.DotSpatialGeographicAlgorithms
  • DllErrorNone : Deltares.Geotechnics.IO.Importers.DGSStandardDLLInterface
  • DLTRS : Deltares.Standard.Forms.Properties.Resources
  • DoLateBinding() : Deltares.Standard.Forms.DExpress.Interfaces.ILateBinding
  • DoProgress() : Deltares.Standard.Forms.DExpress.StatusBar
  • DownArrow : Deltares.Standard.Forms.DExpress.Properties.Resources
  • DragObjectList : Deltares.Standard.Forms.DExpress.GeometryEditor
  • Draw() : Deltares.Geometry.Forms.DrawingObject , Deltares.Standard.Forms.InsertShape
  • Draw3D() : Deltares.DSoilModel.Forms.DrawingBoringLayer , Deltares.DSoilModel.Forms.DrawingCenterCrestLocation , Deltares.DSoilModel.Forms.DrawingLayerObsolete , Deltares.DSoilModel.Forms.DrawingSoilSegmentSplitLocation , Deltares.DSoilModel.Forms.DrawingSosSoilLayer1D , Deltares.Geometry.Forms.DrawingBoundingBox , Deltares.Geometry.Forms.DrawingLine , Deltares.Geometry.Forms.DrawingObject , Deltares.Geometry.Forms.DrawingPoint , Deltares.Geometry.Forms.DrawingPointString , Deltares.Geometry.Forms.DrawingSurface , Deltares.Geometry.Forms.IDrawingObject , Deltares.Geotechnics.Forms.DrawingAnchorAttachment , Deltares.Geotechnics.Forms.DrawingBlockRevetmentSegment , Deltares.Geotechnics.Forms.DrawingBoring , Deltares.Geotechnics.Forms.DrawingCharacteristicPoint , Deltares.Geotechnics.Forms.DrawingCPT , Deltares.Geotechnics.Forms.DrawingGeometry , Deltares.Geotechnics.Forms.DrawingLayer , Deltares.Geotechnics.Forms.DrawingPiezometricHead , Deltares.Geotechnics.Forms.DrawingPreConsolidationStress , Deltares.Geotechnics.Forms.DrawingRevetment , Deltares.Geotechnics.Forms.DrawingSettlementCurve , Deltares.Geotechnics.Forms.DrawingSheetPiling , Deltares.Geotechnics.Forms.DrawingSoilLayerSurface , Deltares.Geotechnics.Forms.DrawingSoilProfile1D , Deltares.Geotechnics.Forms.DrawingSoilSurface , Deltares.Geotechnics.Forms.DrawingSpecificMechanismPointLocation , Deltares.Geotechnics.Forms.DrawingSurfaceLine2 , Deltares.Geotechnics.Forms.DrawingSwell , Deltares.Geotechnics.Forms.DrawingWaterBasin , Deltares.Geotechnics.Forms.DrawingWaterLevel , Deltares.Geotechnics.Forms.DrawingWaternetPointString , Deltares.Geotechnics.Forms.DrawingWaterPolderBasin
  • DrawingPreConsolidationStress() : Deltares.Geotechnics.Forms.DrawingPreConsolidationStress
  • DrawingSosSoilLayer1D() : Deltares.DSoilModel.Forms.DrawingSosSoilLayer1D
  • DrawLabel() : Deltares.DSoilModel.Forms.DrawingCenterCrestLocation , Deltares.DSoilModel.Forms.DrawingLayerObsolete , Deltares.DSoilModel.Forms.DrawingSoilSegmentSplitLocation , Deltares.DSoilModel.Forms.DrawingSosSoilLayer1D , Deltares.Geometry.Forms.DrawingLine , Deltares.Geometry.Forms.DrawingObject , Deltares.Geometry.Forms.DrawingPoint , Deltares.Geometry.Forms.DrawingPointString , Deltares.Geotechnics.Forms.DrawingBlockRevetmentSegment , Deltares.Geotechnics.Forms.DrawingCharacteristicPoint , Deltares.Geotechnics.Forms.DrawingCPT , Deltares.Geotechnics.Forms.DrawingGeometry , Deltares.Geotechnics.Forms.DrawingLayer , Deltares.Geotechnics.Forms.DrawingLocalisedGeometryPointString , Deltares.Geotechnics.Forms.DrawingPiezometricHead , Deltares.Geotechnics.Forms.DrawingPreConsolidationStress , Deltares.Geotechnics.Forms.DrawingRevetment , Deltares.Geotechnics.Forms.DrawingSoilSurface , Deltares.Geotechnics.Forms.DrawingSpecificMechanismPointLocation , Deltares.Geotechnics.Forms.DrawingSurfaceLine2 , Deltares.Geotechnics.Forms.DrawingSwell , Deltares.Geotechnics.Forms.DrawingWaterBasin , Deltares.Geotechnics.Forms.DrawingWaterLevel , Deltares.Geotechnics.Forms.DrawingWaternetLine , Deltares.Geotechnics.Forms.DrawingWaternetPointString , Deltares.Geotechnics.Forms.DrawingWaterPolderBasin
  • DrawLabelAtPoint() : Deltares.Standard.Forms.DrawingSupport
  • DrawLegend() : Deltares.Standard.Forms.DrawingSupport
  • DrawPointSelector() : Deltares.Standard.Forms.DrawingSupport
  • DrawSelector() : Deltares.Standard.Forms.DrawingSupport
  • DrawToNegativeInfinity : Deltares.Geotechnics.Forms.DrawingSurfaceLine2
  • DrawToPositiveInfinity : Deltares.Geotechnics.Forms.DrawingSurfaceLine2
  • drillicon1 : Deltares.DSoilModel.Forms.Properties.Resources
  • drillicon11 : Deltares.DSoilModel.Forms.Properties.Resources
  • drillicon12 : Deltares.DSoilModel.Forms.Properties.Resources
  • drillicon13 : Deltares.DSoilModel.Forms.Properties.Resources
  • drillicon14 : Deltares.DSoilModel.Forms.Properties.Resources
  • drillicon2 : Deltares.DSoilModel.Forms.Properties.Resources
  • drillicon3 : Deltares.DSoilModel.Forms.Properties.Resources
  • drillicon4 : Deltares.DSoilModel.Forms.Properties.Resources
  • Drop() : Deltares.DSoilModel.Forms.DrawingLayerObsolete , Deltares.DSoilModel.Forms.DrawingSosSoilLayer1D , Deltares.Geometry.Forms.DrawingObject , Deltares.Geotechnics.Forms.DrawingLayer , Deltares.Geotechnics.Forms.DrawingSoilSurface
  • DSoilModelGeometryEditor() : Deltares.DSoilModel.Forms.DSoilModelGeometryEditor
  • DSoilModelMapEditor() : Deltares.DSoilModel.Forms.DSoilModelMapEditor
  • DSoilModelSegmentGeometryEditor() : Deltares.DSoilModel.Forms.DSoilModelSegmentGeometryEditor
  • DynamicPropertyControl() : Deltares.Standard.Forms.DExpress.DynamicPropertyControl
  • DynamicPropertyTabControl() : Deltares.Standard.Forms.DExpress.DynamicPropertyTabControl< T >
  • DynamicVisibilityMode : Deltares.Standard.Forms.DExpress.MapLayerDefinition
  • DynamicVisibilityWidth : Deltares.Standard.Forms.DExpress.MapLayerDefinition
Generated on Tue Dec 15 2015 18:15:40 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Class Members

Tool for the (stochastic) subsoil definition.
Here is a list of all documented class members with links to the class documentation for each member:

- e -

  • EditCaption : Deltares.Standard.Forms.DExpress.Properties.Resources
  • EditCaptionHint : Deltares.Standard.Forms.DExpress.Properties.Resources
  • EditCommand() : Deltares.Standard.Forms.DExpress.GridViewControl
  • EditorMode : Deltares.Standard.Forms.SpatialEditor
  • EditorModeChanged : Deltares.Standard.Forms.SpatialEditor
  • EditUnit5 : Deltares.Standard.Forms.DExpress.Properties.Resources
  • EmptySelection : Deltares.Standard.Forms.DExpress.MapEditor , Deltares.Standard.Forms.SpatialEditor
  • EmptyThumbnail : Deltares.DSoilModel.Forms.Properties.Resources
  • EnableAll() : Deltares.Standard.Forms.DExpress.BindSupport
  • Enabled : Deltares.Standard.Forms.ICommand
  • EnabledRule : Deltares.Standard.Forms.DExpress.MapLayerDefinition
  • EnableMasterViewMode : Deltares.Standard.Forms.DExpress.GridViewControl
  • EnableSelectButton : Deltares.Standard.Forms.DExpress.MapEditor
  • EnableZoomRectangle : Deltares.Standard.Forms.DExpress.MapEditor
  • EnableZoomToData : Deltares.Standard.Forms.DExpress.MapEditor
  • EnableZoomToSelection : Deltares.Standard.Forms.DExpress.MapEditor
  • EnsureLastLayerHasHeight() : Deltares.Geotechnics.SoilProfile1D
  • EnsurePointAtX() : Deltares.Geotechnics.WaternetCreator.LineHelper
  • EnsureUniqueLayerIds() : Deltares.Geotechnics.SoilProfile1D
  • EnsureWaterLevelIsAboveRiverBottom() : Deltares.Geotechnics.WaternetCreator.PlLinesCreator
  • envelope : Deltares.Standard.Web.dinoservices.RequestWithCriteriaType
  • Error : Deltares.Standard.Forms.DExpress.Properties.Resources , Deltares.Standard.Forms.Properties.Resources
  • Evaluate() : Deltares.Standard.Forms.DExpress.AssignStrategy , Deltares.Standard.Forms.DExpress.DivideStrategy , Deltares.Standard.Forms.DExpress.GreaterThanStrategy , Deltares.Standard.Forms.DExpress.GridEditValueStrategy , Deltares.Standard.Forms.DExpress.LessThanStrategy , Deltares.Standard.Forms.DExpress.MinusStrategy , Deltares.Standard.Forms.DExpress.MultiplyStrategy , Deltares.Standard.Forms.DExpress.PlusStrategy
  • EvaluateForSelected() : Deltares.Standard.Forms.DExpress.GridEditValueStrategy
  • Execute : Deltares.Standard.Forms.ICommand , Deltares.Standard.Forms.IController
  • ExpandAll_Glyph : Deltares.Standard.Forms.DExpress.Properties.Resources
  • ExpandAllCaption : Deltares.Standard.Forms.DExpress.Properties.Resources
  • ExpandallItemHint : Deltares.Standard.Forms.DExpress.Properties.Resources
  • ExplorerBarRadioButtonCaption : Deltares.Standard.Forms.Properties.Resources
  • Export : Deltares.Standard.Forms.Properties.Resources
  • ExportLayers : Deltares.Standard.Forms.DExpress.Properties.Resources
  • ExportTo() : Deltares.Standard.Forms.DExpress.GeoChartControl
  • ExporttoFileCaption : Deltares.Standard.Forms.DExpress.Properties.Resources
Generated on Tue Dec 15 2015 18:15:40 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Class Members

Tool for the (stochastic) subsoil definition.
Here is a list of all documented class members with links to the class documentation for each member:

- f -

  • FeatureType : Deltares.Standard.Forms.DExpress.MapLayerDefinition
  • FileName : Deltares.Standard.Forms.DExpress.MainForm
  • FillFromGefFile() : Deltares.Geotechnics.IO.Importers.GefBoringFileImporter , Deltares.Geotechnics.IO.Importers.GefCptFileImporter
  • FillFromGefString() : Deltares.Geotechnics.IO.Importers.GefBoringFileImporter , Deltares.Geotechnics.IO.Importers.GefCptFileImporter
  • FilmStrip() : Deltares.DSoilModel.Forms.FilmStrip
  • Filter : Deltares.Standard.Forms.DExpress.PanelTextPathValue
  • findCPT() : Deltares.Standard.Web.dinoservices.CptService
  • findCPTAsync() : Deltares.Standard.Web.dinoservices.CptService
  • findCPTCompleted : Deltares.Standard.Web.dinoservices.CptService
  • findCPTWithCriteria() : Deltares.Standard.Web.dinoservices.CptService
  • findCPTWithCriteriaAsync() : Deltares.Standard.Web.dinoservices.CptService
  • findCPTWithCriteriaCompleted : Deltares.Standard.Web.dinoservices.CptService
  • Flush() : Deltares.Standard.Application.LogHelper
  • FocusData() : Deltares.Standard.Forms.DExpress.GeoPropertyGrid
  • Font3D() : Deltares.Standard.Forms.DrawingSupport
  • ForceBeginAction : Deltares.Standard.Forms.DExpress.BindSupport
  • Format : Deltares.Standard.Forms.ColumnDescription
  • Forward : Deltares.Standard.Forms.Properties.Resources
  • FrictionMax : Deltares.Geotechnics.Forms.DrawingCPT
  • frictionMeasured : Deltares.Standard.Web.dinoservices.CriteriaType
Generated on Tue Dec 15 2015 18:15:40 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Class Members

Tool for the (stochastic) subsoil definition.
Here is a list of all documented class members with links to the class documentation for each member:

- g -

  • GeneralButtonCaption : Deltares.Standard.Forms.Properties.Resources
  • GeneralTabPageCaption : Deltares.Standard.Forms.Properties.Resources
  • GenericProgressScreen : Deltares.DSoilModel.Application.Properties.Resources , Deltares.Standard.Forms.DExpress.Properties.Resources
  • GenericSplashScreen : Deltares.DSoilModel.Application.Properties.Resources , Deltares.Standard.Forms.DExpress.Properties.Resources
  • GeoGrid : Deltares.Standard.Forms.DExpress.Properties.Resources
  • GeometryEditor : Deltares.DSoilModel.Forms.DSoilModelPlugin , Deltares.Standard.Forms.DExpress.GeometryEditor
  • GeometryEditor_MouseLeave() : Deltares.Standard.Forms.DExpress.GeometryEditor
  • GeometryEditorMode : Deltares.Standard.Forms.DExpress.GeometryEditor
  • GeometryModels : Deltares.Standard.Forms.DExpress.GeometryEditor
  • GeometryType : Deltares.Standard.Forms.DExpress.IShapeImporter , Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter
  • GeometryTypes : Deltares.Standard.Forms.DExpress.AbstractShapeFileImporter
  • GeoTextEditDimensionalToolTip : Deltares.Standard.Forms.DExpress.Properties.Resources
  • GeoTextEditNonDimensionalToolTip : Deltares.Standard.Forms.DExpress.Properties.Resources
  • GeoTextEditToolTip : Deltares.Standard.Forms.DExpress.Properties.Resources
  • Get3dTopPoint() : Deltares.Standard.Forms.DExpress.GeometryEditor
  • GetActionsSortedByPropertyOrderAttribute() : Deltares.Standard.Forms.DExpress.BindSupport
  • GetActiveMapProjectionAsDotSpatial() : Deltares.Standard.DotSpatialDgs.MapProjectionManager
  • GetAquiferLayers() : Deltares.Geotechnics.SoilProfile1D
  • GetAssignedObject() : Deltares.Standard.Forms.DExpress.BindSupport
  • GetBackgroundLayer() : Deltares.Standard.Forms.DExpress.MapEditor
  • GetBackgroundMap() : Deltares.Standard.DotSpatialDgs.FeatureSupport
  • GetBorings() : Deltares.DSoilModel.Data.DSoilModelProject
  • GetBoringXmlFromGefBoringFile() : Deltares.Geotechnics.IO.Importers.DGSGEFInterface
  • GetBoringXmlFromGefBoringString() : Deltares.Geotechnics.IO.Importers.DGSGEFInterface
  • GetBottomLevel() : Deltares.Geotechnics.SoilProfile1D
  • GetChildComponents() : Deltares.Standard.Forms.DExpress.Interfaces.IHasBindableChildren
  • GetChildren() : Deltares.Standard.Forms.IViewConfiguration
  • GetColor() : Deltares.Geotechnics.Forms.DrawingSwell , Deltares.Standard.Forms.DrawingSupport
  • GetColumnDescription() : Deltares.Standard.Forms.IViewConfiguration
  • GetColumns() : Deltares.Standard.Forms.IViewConfiguration
  • GetContainedProperties() : Deltares.Standard.Forms.DExpress.BindSupport
  • GetControl() : Deltares.Standard.Forms.DExpress.GridViewControl
  • GetCpts() : Deltares.DSoilModel.Data.DSoilModelProject
  • GetCptXmlFromGefCptFile() : Deltares.Geotechnics.IO.Importers.DGSGEFInterface
  • GetCptXmlFromGefCptString() : Deltares.Geotechnics.IO.Importers.DGSGEFInterface
  • GetCurrentDraw3DInterface() : Deltares.Standard.Forms.DrawingSupport
  • GetDarkerColor() : Deltares.Standard.Forms.DrawingSupport
  • GetDataObject() : Deltares.DSoilModel.Forms.DrawingBoringLayer , Deltares.DSoilModel.Forms.DrawingCenterCrestLocation , Deltares.DSoilModel.Forms.DrawingLayerObsolete , Deltares.DSoilModel.Forms.DrawingSoilSegmentSplitLocation , Deltares.DSoilModel.Forms.DrawingSosSoilLayer1D , Deltares.Geometry.Forms.DrawingBoundingBox , Deltares.Geometry.Forms.DrawingLine , Deltares.Geometry.Forms.DrawingObject , Deltares.Geometry.Forms.DrawingPoint , Deltares.Geometry.Forms.DrawingPointString , Deltares.Geometry.Forms.DrawingSurface , Deltares.Geometry.Forms.IDrawingObject , Deltares.Geotechnics.Forms.DrawingAnchorAttachment , Deltares.Geotechnics.Forms.DrawingBlockRevetmentSegment , Deltares.Geotechnics.Forms.DrawingBoring , Deltares.Geotechnics.Forms.DrawingCharacteristicPoint , Deltares.Geotechnics.Forms.DrawingCPT , Deltares.Geotechnics.Forms.DrawingGeometry , Deltares.Geotechnics.Forms.DrawingLayer , Deltares.Geotechnics.Forms.DrawingPiezometricHead , Deltares.Geotechnics.Forms.DrawingRevetment , Deltares.Geotechnics.Forms.DrawingSettlementCurve , Deltares.Geotechnics.Forms.DrawingSheetPiling , Deltares.Geotechnics.Forms.DrawingSoilProfile1D , Deltares.Geotechnics.Forms.DrawingSoilSurface , Deltares.Geotechnics.Forms.DrawingSpecificMechanismPointLocation , Deltares.Geotechnics.Forms.DrawingSurfaceLine2 , Deltares.Geotechnics.Forms.DrawingSwell , Deltares.Geotechnics.Forms.DrawingWaterBasin , Deltares.Geotechnics.Forms.DrawingWaterLevel , Deltares.Geotechnics.Forms.DrawingWaterPolderBasin
  • GetDikeToeInward() : Deltares.Geotechnics.WaternetCreator.PlLinesCreator
  • GetDllVersion() : Deltares.Geotechnics.IO.Importers.DGSGEFInterface , Deltares.Geotechnics.IO.Importers.DGSStandardDLLInterface
  • GetDomain() : Deltares.DSoilModel.Data.DSoilModelProject , Deltares.Geotechnics.SoilProfile1D
  • GetExtents() : Deltares.DSoilModel.Forms.DrawingCenterCrestLocation , Deltares.DSoilModel.Forms.DrawingLayerObsolete , Deltares.DSoilModel.Forms.DrawingSoilSegmentSplitLocation , Deltares.DSoilModel.Forms.DrawingSosSoilLayer1D , Deltares.Geometry.Forms.DrawingBoundingBox , Deltares.Geometry.Forms.DrawingObject , Deltares.Geotechnics.Forms.DrawingBoring , Deltares.Geotechnics.Forms.DrawingCharacteristicPoint , Deltares.Geotechnics.Forms.DrawingCPT , Deltares.Geotechnics.Forms.DrawingLayer , Deltares.Geotechnics.Forms.DrawingPreConsolidationStress , Deltares.Geotechnics.Forms.DrawingSoilProfile1D , Deltares.Geotechnics.Forms.DrawingSpecificMechanismPointLocation
  • GetFeature() : Deltares.Standard.Forms.DExpress.MyMapLineLayer , Deltares.Standard.Forms.DExpress.MyMapPointLayer , Deltares.Standard.Forms.DExpress.MyMapPolygonLayer
  • getGEF() : Deltares.Standard.Web.dinoservices.CptService
  • GetGEFAsString() : Deltares.Standard.Web.CptServiceAgent
  • getGEFAsync() : Deltares.Standard.Web.dinoservices.CptService
  • getGEFCompleted : Deltares.Standard.Web.dinoservices.CptService
  • GetHelpLocation() : Deltares.Standard.Forms.DExpress.BindSupport , Deltares.Standard.Forms.DExpress.BindSupportAsHelpLocationProvider , Deltares.Standard.Forms.DExpress.Interfaces.IHelpLocationProvider
  • GetHoveredShapes() : Deltares.Standard.Forms.SpatialEditor
  • GetImage() : Deltares.Standard.Forms.SpatialEditor
  • GetIntersectPoint() : Deltares.Geotechnics.WaternetCreator.LineHelper
  • GetLabelTextHeigt() : Deltares.Standard.Forms.DrawingSupport
  • GetLabelTextWidth() : Deltares.Standard.Forms.DrawingSupport
  • GetLayerAbove() : Deltares.Geotechnics.SoilProfile1D
  • GetLayerAt() : Deltares.Geotechnics.SoilProfile1D
  • GetLayerBelow() : Deltares.Geotechnics.SoilProfile1D
  • GetLayerByInsetOffset() : Deltares.Geotechnics.SoilProfile1D
  • GetLayerHeight() : Deltares.Geotechnics.SoilProfile1D
  • GetLayerIndexAt() : Deltares.Geotechnics.SoilProfile1D
  • GetLayerIndexAtCoordinate() : Deltares.Geotechnics.SoilProfile1D
  • GetLayerWithId() : Deltares.Geotechnics.SoilProfile1D
  • GetLighterColor() : Deltares.Standard.Forms.DrawingSupport
  • GetLocalUserDeltaresDirectoryPath() : Deltares.Standard.Forms.DExpress.MainForm
  • GetMainBar() : Deltares.Standard.Forms.DExpress.GeometryEditor
  • GetMainBarManager() : Deltares.Standard.Forms.DExpress.GeometryEditor
  • GetMapProjectionAsDotSpatial() : Deltares.Standard.DotSpatialDgs.MapProjectionManager
  • GetMousePosition() : Deltares.Standard.Forms.SpatialEditor
  • GetNearestGeographicString() : Deltares.Standard.DotSpatialDgs.DotSpatialGeographicHelper
  • GetNewUniqueLayerId() : Deltares.Geotechnics.SoilProfile1D
  • GetNextCurve() : Deltares.Geotechnics.WaternetCreator.WaternetCreator
  • GetOffsetOnGeographicLineString() : Deltares.Standard.DotSpatialDgs.DotSpatialGeographicHelper
  • GetOppositeColor() : Deltares.Standard.Forms.DrawingSupport
  • GetOwner() : Deltares.Standard.Forms.DExpress.BindSupport
  • GetParentOfType() : Deltares.Standard.Forms.DExpress.FormsSupport
  • GetPoint() : Deltares.Standard.Forms.DExpress.MapEditor
  • GetPointAtX() : Deltares.Geotechnics.WaternetCreator.LineHelper
  • GetPoints() : Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter
  • GetPointSegmentBetween() : Deltares.Geotechnics.WaternetCreator.LineHelper
  • GetPopupControl() : Deltares.Standard.Forms.DExpress.BindSupport
  • GetPopupMenu() : Deltares.Standard.Forms.DExpress.BaseControlBinding
  • GetProfiles() : Deltares.DSoilModel.Data.DSoilModelProject
  • GetProjectFileName() : Deltares.Standard.Forms.DExpress.MainForm
  • GetPropertiesSortedByPropertyOrderAttribute() : Deltares.Standard.Forms.DExpress.BindSupport
  • GetPropertyControl() : Deltares.Standard.Forms.DExpress.PropertyControlFactory< T >
  • GetPropertyControlForType() : Deltares.Standard.Forms.DExpress.PropertyControlFactory< T >
  • GetPropertyControlUsingCustomSelector() : Deltares.Standard.Forms.DExpress.PropertyControlFactory< T >
  • GetPropertyInfo< TSource >() : Deltares.Standard.Forms.DExpress.BindSupport
  • GetScaled3DPoint() : Deltares.Geometry.Forms.DrawingObject , Deltares.Geometry.Forms.IDrawingObject , Deltares.Standard.Forms.DrawingSupport
  • GetScaledXPoint() : Deltares.Geometry.Forms.DrawingObject , Deltares.Geometry.Forms.IDrawingObject
  • GetScreenPoint() : Deltares.Geometry.Forms.DrawingObject
  • GetSelectedShapes() : Deltares.Standard.Forms.SpatialEditor
  • GetShape() : Deltares.Standard.Forms.SpatialEditor
  • GetShapeFileProjection() : Deltares.Standard.DotSpatialDgs.DotSpatialUtil
  • GetShapeInfo() : Deltares.Standard.Forms.SpatialEditor
  • GetSnapObject() : Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool
  • GetSnapPointCoordinates() : Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool
  • GetSnapPointMouse() : Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool
  • GetSnapPointSplitSegment() : Deltares.DSoilModel.Forms.DSoilModelMapEditor
  • GetStandardSize() : Deltares.Standard.Forms.DrawingSupport
  • GetString() : Deltares.Standard.Forms.DExpress.MapEditor
  • GetSurfaceLines() : Deltares.DSoilModel.Data.DSoilModelProject
  • GetText() : Deltares.Standard.Forms.DExpress.LocalizationSupport
  • GetTextWidth() : Deltares.Standard.Forms.DrawingSupport
  • GetThickness() : Deltares.Geometry.Forms.DrawingObject
  • GetTopLevelOfHighestAquifer() : Deltares.Geotechnics.SoilProfile1D
  • GetTotalPressure() : Deltares.Geotechnics.SoilProfile1D
  • GetUpliftOutputValuesPl3() : Deltares.Geotechnics.WaternetCreator.PlLinesCreator , Deltares.Geotechnics.WaternetCreator.WaternetCreator
  • GetUpliftOutputValuesPl4() : Deltares.Geotechnics.WaternetCreator.PlLinesCreator , Deltares.Geotechnics.WaternetCreator.WaternetCreator
  • GetValue() : Deltares.Standard.Forms.DExpress.PopupContainerEditBinding
  • GetWorldPoint() : Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool
  • Gridlines : Deltares.Standard.Forms.Properties.Resources
  • GridViewCellChangeArgs() : Deltares.Standard.Forms.GridViewCellChangeArgs
  • GridViewChangeArgs() : Deltares.Standard.Forms.GridViewChangeArgs
  • GridViewControl() : Deltares.Standard.Forms.DExpress.GridViewControl
  • GridViewController() : Deltares.Standard.Forms.DExpress.GridViewController< T >
  • GridVisible : Deltares.Standard.Forms.DExpress.GeometryEditor
Generated on Tue Dec 15 2015 18:15:40 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Class Members

Tool for the (stochastic) subsoil definition.
Here is a list of all documented class members with links to the class documentation for each member:

- h -

  • Handle() : Deltares.Geotechnics.IO.SurfaceLineXmlHandler
  • HandleFocusCommandLineWindow() : Deltares.Standard.Forms.CommandLineWindow
  • HandleObject() : Deltares.Geotechnics.IO.SurfaceLineXmlHandler
  • HasBeenUpdated : Deltares.Geometry.Forms.IDrawingObject
  • HasInvalidThicknessLayers() : Deltares.Geotechnics.SoilProfile1D
  • HasLayersWithoutSoil() : Deltares.Geotechnics.SoilProfile1D
  • HasLoggedExceptions : Deltares.Standard.Application.LogHelper
  • HasPhreaticLevel : Deltares.Geotechnics.SoilProfile1D
  • HasSearchTree : Deltares.Standard.Forms.DExpress.MapLayerDefinition
  • HeadLinesCaption : Deltares.Geotechnics.Forms.Properties.Resources
  • Height : Deltares.Geotechnics.SoilProfile1D
  • HelpFile : Deltares.Standard.Forms.DExpress.MainForm
  • HelpFileManager : Deltares.Standard.Forms.DExpress.MainForm
  • HelpFilePath : Deltares.Standard.Forms.DExpress.Interfaces.IHelpFileManager
  • HelpLocationProvider : Deltares.Standard.Forms.DExpress.Interfaces.IHelpFileManager
  • HideUnusedColumns : Deltares.Standard.Forms.DExpress.GridViewControl
  • Hint : Deltares.Standard.Forms.ICommand
  • HorizonDistance : Deltares.Geotechnics.Forms.DrawingSurfaceLine2
  • HorizontalViewCaption : Deltares.Standard.Forms.DExpress.Properties.Resources
  • hydraulicboundary : Deltares.DSoilModel.Forms.Properties.Resources
  • HydraulicBoundaryControl() : Deltares.Geotechnics.Forms.HydraulicBoundaryControl
Generated on Tue Dec 15 2015 18:15:40 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Class Members

Tool for the (stochastic) subsoil definition.
Here is a list of all documented class members with links to the class documentation for each member:

- i -

  • Icon : Deltares.Standard.Application.ProgramBase , Deltares.Standard.Forms.ICommand
  • Id : Deltares.Standard.Forms.ViewCommand
  • ID : Deltares.Standard.Web.Cpt
  • id : Deltares.Standard.Web.dinoservices.CPTType
  • Ignore : Deltares.Standard.Forms.MessageBoxManager
  • Image : Deltares.Standard.Forms.DExpress.MapLayerDefinition , Deltares.Standard.Forms.ViewCommand
  • Import() : Deltares.Geotechnics.IO.Importers.FetchesImporter , Deltares.Geotechnics.IO.Importers.SoilProfilesImporter , Deltares.Standard.Forms.DExpress.AbstractShapeFileImporter
  • ImportShape() : Deltares.Standard.Forms.DotSpatial.IShapeImporter , Deltares.Standard.Forms.DotSpatial.LineStringImporter , Deltares.Standard.Forms.DotSpatial.PointImporter
  • ImportShapeGeometry() : Deltares.Standard.Forms.DExpress.IShapeImporter , Deltares.Standard.Forms.DExpress.ShapeImporters.LineStringImporter , Deltares.Standard.Forms.DExpress.ShapeImporters.MultiLineStringImporter , Deltares.Standard.Forms.DExpress.ShapeImporters.MultiPolygonImporter , Deltares.Standard.Forms.DExpress.ShapeImporters.PointImporter , Deltares.Standard.Forms.DExpress.ShapeImporters.PolygonImporter , Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter , Deltares.Standard.Forms.DExpress.ShapeImporters.SmartLineStringImporter
  • InBetweenAquiferLayer : Deltares.Geotechnics.SoilProfile1D
  • Index : Deltares.Standard.Forms.GridViewChangeArgs
  • InfiltrationLayer : Deltares.Geotechnics.SoilProfile1D
  • Information : Deltares.Standard.Forms.Properties.Resources
  • Initialize() : Deltares.Standard.Application.ProgramBase , Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool , Deltares.Standard.Forms.DExpress.PopupContainerEditBinding
  • InitializeUIBeforeNewAndOpen() : Deltares.Standard.Forms.DExpress.MainForm
  • InputPointCaption : Deltares.Standard.Forms.Properties.Resources
  • InsertCaption : Deltares.Standard.Forms.DExpress.Properties.Resources
  • InsertHeadlineCaption : Deltares.Geotechnics.Forms.Properties.Resources
  • InsertIncrease : Deltares.Standard.Forms.SpatialEditor
  • InsertIncreaseOffset : Deltares.Standard.Forms.SpatialEditor
  • InsertionPoint : Deltares.DSoilModel.Forms.DrawingSosSoilLayer1D , Deltares.Geotechnics.Forms.DrawingCPT
  • InsertItem_Glyph : Deltares.Standard.Forms.DExpress.Properties.Resources
  • InsertItemHint : Deltares.Standard.Forms.DExpress.Properties.Resources
  • InsertMode : Deltares.Standard.Forms.SpatialEditor
  • InsertPen : Deltares.Standard.Forms.SpatialEditor
  • InsertPointCaption : Deltares.Geometry.Forms.Properties.Resources , Deltares.Geotechnics.Forms.Properties.Resources
  • InsertPolylineCaption : Deltares.Geometry.Forms.Properties.Resources
  • InsertRepeatMode : Deltares.Standard.Forms.SpatialEditor
  • InsertRow() : Deltares.Standard.Forms.DExpress.GridViewControl , Deltares.Standard.Forms.DExpress.GridViewController< T > , Deltares.Standard.Forms.IGridController
  • InsertRowCaption : Deltares.Standard.Forms.DExpress.Properties.Resources
  • InsertRowCommand() : Deltares.Standard.Forms.DExpress.GridViewControl
  • InsertselectedobjectCaption : Deltares.Standard.Forms.DExpress.Properties.Resources
  • InsertSpecificMechanismPointLocation() : Deltares.DSoilModel.Forms.DSoilModelGeometryEditor
  • InsertType : Deltares.Standard.Forms.SpatialEditor
  • InsertWaternetlineCaption : Deltares.Geotechnics.Forms.Properties.Resources
  • Instance : Deltares.Standard.DotSpatialDgs.MapProjectionManager , Deltares.Standard.Forms.RealTimeBackgroundValidator
  • Intersection() : Deltares.Standard.DotSpatialDgs.DotSpatialGeographicAlgorithms , Deltares.Standard.DotSpatialDgs.DotSpatialUtil
  • IntersectionPoint() : Deltares.Geotechnics.WaternetCreator.LineHelper
  • Intersects() : Deltares.Standard.DotSpatialDgs.DotSpatialGeographicAlgorithms
  • InValidMessage : Deltares.Standard.Forms.DExpress.Properties.Resources
  • InvokeControl : Deltares.Standard.Forms.DExpress.BindSupport
  • IsActive : Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool , Deltares.Standard.Forms.DExpress.MapTools.IMapTool
  • IsAssociatedPropertyVisible() : Deltares.Standard.Forms.DExpress.ComponentBinding
  • IsAutomaticRegeneration : Deltares.Geometry.Forms.IGeometryViewSettings
  • IsBound() : Deltares.Standard.Forms.DExpress.BindSupport
  • IsChecked() : Deltares.Standard.Forms.IController
  • IsEnabled() : Deltares.DSoilModel.Forms.DSoilModelMapEditor , Deltares.DSoilModel.Forms.DSoilModelSegmentGeometryEditor , Deltares.Geotechnics.SoilProfile1D , Deltares.Standard.Forms.DExpress.GeometryEditor , Deltares.Standard.Forms.DExpress.GridViewControl , Deltares.Standard.Forms.DExpress.MainForm , Deltares.Standard.Forms.DExpress.MapEditor , Deltares.Standard.Forms.DExpress.TreeViewControl , Deltares.Standard.Forms.IController , Deltares.Standard.Forms.ShapeInfo
  • IsGeometryCurveLabelsOn : Deltares.Geometry.Forms.GeometryViewSettings , Deltares.Geometry.Forms.IGeometryViewSettings
  • IsGeometryPointLabelsOn : Deltares.Geometry.Forms.GeometryViewSettings , Deltares.Geometry.Forms.IGeometryViewSettings
  • IsGeometrySurfaceLabelsOn : Deltares.Geometry.Forms.GeometryViewSettings , Deltares.Geometry.Forms.IGeometryViewSettings
  • IsGeometrySurfaceMaterialLabelsOn : Deltares.Geometry.Forms.GeometryViewSettings , Deltares.Geometry.Forms.IGeometryViewSettings
  • IsGeometrySurfaceNameLabelsOn : Deltares.Geometry.Forms.GeometryViewSettings
  • IsLabelVisible() : Deltares.Standard.Forms.ShapeInfo
  • IsLayerVisible() : Deltares.Standard.Forms.DExpress.MapEditor
  • IsLoadsLabelsOn : Deltares.Geometry.Forms.IDefinitionViewSettings
  • IsMultiselectObject : Deltares.Standard.Forms.DExpress.GeoPropertyGrid
  • IsNonEditableMode : Deltares.Standard.Forms.DExpress.GeometryEditor
  • IsRenderingSuspended : Deltares.Standard.Forms.SpatialEditor
  • IsSelectionChanging : Deltares.Standard.Forms.DExpress.GeoPropertyGrid , Deltares.Standard.Forms.DExpress.GridViewControl
  • IsStrictlyDescending() : Deltares.Geotechnics.SoilProfile1D
  • IsUsed : Deltares.Standard.Forms.RealTimeBackgroundValidator
  • IsValidating : Deltares.Standard.Forms.RealTimeBackgroundValidator
  • IsValidObject() : Deltares.Standard.Forms.DExpress.GeoPropertyGrid
  • IsVisible() : Deltares.DSoilModel.Forms.DSoilModelMapEditor , Deltares.DSoilModel.Forms.DSoilModelSegmentGeometryEditor , Deltares.DSoilModel.Forms.SosSoilProfile1DControl , Deltares.Geotechnics.Forms.SoilProfile1DControl , Deltares.Geotechnics.SoilProfile1D , Deltares.Standard.Forms.DExpress.GeometryEditor , Deltares.Standard.Forms.DExpress.GridViewControl , Deltares.Standard.Forms.DExpress.MainForm , Deltares.Standard.Forms.DExpress.MapEditor , Deltares.Standard.Forms.DExpress.TreeViewControl , Deltares.Standard.Forms.IController , Deltares.Standard.Forms.IPropertyControl , Deltares.Standard.Forms.ShapeInfo
  • IsVisibleCallback : Deltares.DSoilModel.Forms.DSoilModelGeometryEditor , Deltares.DSoilModel.Forms.DSoilModelSegmentGeometryEditor
  • IsXAscending() : Deltares.Geotechnics.WaternetCreator.LineHelper
  • IsZoomRectange : Deltares.Standard.Forms.DExpress.GeometryEditor
  • Items : Deltares.DSoilModel.Forms.ModalListBox , Deltares.Standard.Forms.DExpress.GridViewController< T >
Generated on Tue Dec 15 2015 18:15:40 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Class Members

Tool for the (stochastic) subsoil definition.
Here is a list of all documented class members with links to the class documentation for each member:

- l -

  • Label : Deltares.Standard.Forms.DExpress.ControlBinding
  • LabelVisible : Deltares.Standard.Forms.ShapeInfo
  • LanguageButtonCaption : Deltares.Standard.Forms.Properties.Resources
  • LanguageTabPageCaption : Deltares.Standard.Forms.Properties.Resources
  • LastUsedProjectRadioButtonCaption : Deltares.Standard.Forms.Properties.Resources
  • LayerCount : Deltares.Geotechnics.SoilProfile1D
  • Layers : Deltares.Geotechnics.SoilProfile1D
  • lbCategoriesCaption : Deltares.Standard.Forms.Properties.Resources
  • lbCategoriesCaption1 : Deltares.Standard.Forms.Properties.Resources
  • lbCommandsCaption : Deltares.Standard.Forms.Properties.Resources
  • lbCommandsCaption1 : Deltares.Standard.Forms.Properties.Resources
  • lbDescriptionCaption : Deltares.Standard.Forms.Properties.Resources
  • lbDescriptionCaption1 : Deltares.Standard.Forms.Properties.Resources
  • lbOptionsOther : Deltares.Standard.Forms.Properties.Resources
  • lbOptionsOther1 : Deltares.Standard.Forms.Properties.Resources
  • lbOptionsPCaption : Deltares.Standard.Forms.Properties.Resources
  • lbOptionsPCaption1 : Deltares.Standard.Forms.Properties.Resources
  • Left : Deltares.DSoilModel.Forms.DrawingCenterCrestLocation , Deltares.DSoilModel.Forms.DrawingSoilSegmentSplitLocation , Deltares.Geotechnics.Forms.DrawingBoring , Deltares.Geotechnics.Forms.DrawingCPT , Deltares.Geotechnics.Forms.DrawingSoilProfile1D , Deltares.Geotechnics.Forms.DrawingSpecificMechanismPointLocation
  • Legend : Deltares.Standard.Forms.Properties.Resources
  • LegendItems : Deltares.Standard.Forms.SpatialEditor
  • LegendPropertyControlHasBeenSet : Deltares.Standard.Forms.DExpress.MapEditor
  • LevelPrefrenceCaption : Deltares.Standard.Forms.DExpress.Properties.Resources
  • LicenceDongleGroupBoxCaption : Deltares.Standard.Forms.Properties.Resources
  • Line3D() : Deltares.Standard.Forms.DrawingSupport
  • Line_Symbol3D() : Deltares.Standard.Forms.DrawingSupport
  • LineLoop3D() : Deltares.Standard.Forms.DrawingSupport
  • LineStringImporter() : Deltares.Standard.Forms.DExpress.ShapeImporters.LineStringImporter
  • LineStringLength() : Deltares.Standard.DotSpatialDgs.DotSpatialGeographicAlgorithms
  • LineWidth : Deltares.Geometry.Forms.DrawingLine
  • ListInValidMessage : Deltares.Standard.Forms.DExpress.Properties.Resources
  • ListTemplateBarCaption : Deltares.Standard.Forms.DExpress.Properties.Resources
  • LoadDefaultLayoutXML() : Deltares.Standard.Forms.DExpress.MainForm
  • Location : Deltares.DSoilModel.Data.CenterCrestLocation
  • LogDebug() : Deltares.Standard.Application.LogHelper
  • LogError() : Deltares.Standard.Application.LogHelper
  • LogFatal() : Deltares.Standard.Application.LogHelper
  • LogInfo() : Deltares.Standard.Application.LogHelper
  • LogMessages : Deltares.Standard.Forms.DExpress.MainForm
  • LogWarning() : Deltares.Standard.Application.LogHelper
  • lowerX_rd : Deltares.Standard.Web.dinoservices.EnvelopeType
  • lowerY_rd : Deltares.Standard.Web.dinoservices.EnvelopeType
Generated on Tue Dec 15 2015 18:15:40 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Class Members

Tool for the (stochastic) subsoil definition.
Here is a list of all documented class members with links to the class documentation for each member:

- m -

  • MainForm() : Deltares.Standard.Forms.DExpress.MainForm
  • MaintainLayerOrder : Deltares.Geotechnics.SoilProfile1D
  • MaintainLayerOrderNonStatic : Deltares.Geotechnics.SoilProfile1D
  • MakeProportional() : Deltares.Standard.Forms.SpatialEditor
  • MakeProportionalOnResize : Deltares.Standard.Forms.SpatialEditor
  • MakeTreeVisible() : Deltares.Standard.Forms.DExpress.FormsSupport
  • MapControl : Deltares.Standard.Forms.DExpress.MapTools.IMapTool
  • MapControl_MouseDown() : Deltares.Standard.Forms.DExpress.MapEditor , Deltares.Standard.Forms.DExpress.MapTools.AddFeatureMapTool , Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool , Deltares.Standard.Forms.DExpress.MapTools.ConnectFeaturesMapTool , Deltares.Standard.Forms.DExpress.MapTools.IMapTool , Deltares.Standard.Forms.DExpress.MapTools.MoveFeatureMapTool , Deltares.Standard.Forms.DExpress.MapTools.RectangleZoomMapTool , Deltares.Standard.Forms.DExpress.MapTools.SelectFeatureMapTool
  • MapControl_MouseMove() : Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool , Deltares.Standard.Forms.DExpress.MapTools.ConnectFeaturesMapTool , Deltares.Standard.Forms.DExpress.MapTools.IMapTool , Deltares.Standard.Forms.DExpress.MapTools.MoveFeatureMapTool , Deltares.Standard.Forms.DExpress.MapTools.RectangleZoomMapTool , Deltares.Standard.Forms.DExpress.MapTools.SelectFeatureMapTool
  • MapControl_MouseUp() : Deltares.Standard.Forms.DExpress.MapEditor , Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool , Deltares.Standard.Forms.DExpress.MapTools.ConnectFeaturesMapTool , Deltares.Standard.Forms.DExpress.MapTools.DeleteFeatureMapTool , Deltares.Standard.Forms.DExpress.MapTools.IMapTool , Deltares.Standard.Forms.DExpress.MapTools.MoveFeatureMapTool , Deltares.Standard.Forms.DExpress.MapTools.RectangleZoomMapTool , Deltares.Standard.Forms.DExpress.MapTools.SelectFeatureMapTool
  • MapControl_MouseWheel() : Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool , Deltares.Standard.Forms.DExpress.MapTools.IMapTool
  • MapControl_Paint() : Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool , Deltares.Standard.Forms.DExpress.MapTools.ConnectFeaturesMapTool , Deltares.Standard.Forms.DExpress.MapTools.IMapTool , Deltares.Standard.Forms.DExpress.MapTools.MoveFeatureMapTool , Deltares.Standard.Forms.DExpress.MapTools.RectangleZoomMapTool , Deltares.Standard.Forms.DExpress.MapTools.SelectFeatureMapTool
  • MapEditor() : Deltares.Standard.Forms.DExpress.MapEditor
  • MapExtent : Deltares.Standard.Forms.DExpress.MapEditor
  • MapLayerDefinition() : Deltares.Standard.Forms.DExpress.MapLayerDefinition
  • MapTools : Deltares.Standard.Forms.DExpress.MapEditor
  • MarginBottom : Deltares.Standard.Forms.SpatialEditor
  • MarginLeft : Deltares.Standard.Forms.SpatialEditor
  • MarginRight : Deltares.Standard.Forms.SpatialEditor
  • MarginTop : Deltares.Standard.Forms.SpatialEditor
  • Material3D() : Deltares.Standard.Forms.DrawingSupport
  • Materials : Deltares.Standard.Forms.DExpress.Properties.Resources
  • MaximumTopLevel : Deltares.DSoilModel.Data.SosSoilLayer1D
  • maxLength : Deltares.Standard.Web.dinoservices.CriteriaType
  • MenuAnimation : Deltares.Standard.Forms.Properties.Resources
  • MenuAnimation1 : Deltares.Standard.Forms.Properties.Resources
  • MenuColumnBestFit : Deltares.Standard.Forms.DExpress.Properties.Resources
  • MenuColumnBestFitAllColumns : Deltares.Standard.Forms.DExpress.Properties.Resources
  • MenuColumnClearFilter : Deltares.Standard.Forms.DExpress.Properties.Resources
  • MenuColumnClearSorting : Deltares.Standard.Forms.DExpress.Properties.Resources
  • MenuColumnColumnCustomization : Deltares.Standard.Forms.DExpress.Properties.Resources
  • MenuColumnFilterEditor : Deltares.Standard.Forms.DExpress.Properties.Resources
  • MenuColumnGroup : Deltares.Standard.Forms.DExpress.Properties.Resources
  • MenuColumnGroupBox : Deltares.Standard.Forms.DExpress.Properties.Resources
  • MenuColumnSortAscending : Deltares.Standard.Forms.DExpress.Properties.Resources
  • MenuColumnSortDescending : Deltares.Standard.Forms.DExpress.Properties.Resources
  • MinimumTopLevel : Deltares.DSoilModel.Data.SosSoilLayer1D
  • minLength : Deltares.Standard.Web.dinoservices.CriteriaType
  • ModalListBox() : Deltares.DSoilModel.Forms.ModalListBox
  • ModulesButtonCaption : Deltares.Standard.Forms.Properties.Resources
  • ModulesTabPageCaption : Deltares.Standard.Forms.Properties.Resources
  • MousePosition : Deltares.Standard.Forms.GraphicsInfo , Deltares.Standard.Forms.ShapesEventArgs
  • Movable : Deltares.Standard.Forms.DExpress.MapLayerDefinition
  • MoveDownButtonCaption : Deltares.Standard.Forms.DExpress.Properties.Resources
  • MoveDownCaption : Deltares.Geometry.Forms.Properties.Resources , Deltares.Standard.Forms.DExpress.Properties.Resources
  • MoveDownHint : Deltares.Standard.Forms.DExpress.Properties.Resources
  • MoveDownPopUpBarButton_Glyph : Deltares.Standard.Forms.DExpress.Properties.Resources
  • MoveHeadlineDownCaption : Deltares.Geotechnics.Forms.Properties.Resources
  • MoveHeadlineupCaption : Deltares.Geotechnics.Forms.Properties.Resources
  • MoveToFront() : Deltares.Standard.Forms.DExpress.MapEditor
  • MoveUpButton_Glyph : Deltares.Standard.Forms.DExpress.Properties.Resources
  • MoveUpButtonCaption : Deltares.Standard.Forms.DExpress.Properties.Resources
  • MoveupCaption : Deltares.Geometry.Forms.Properties.Resources , Deltares.Standard.Forms.DExpress.Properties.Resources
  • MoveupHint : Deltares.Standard.Forms.DExpress.Properties.Resources
  • MoveWaternetlineDownCaption : Deltares.Geotechnics.Forms.Properties.Resources
  • MoveWaternetlineupCaption : Deltares.Geotechnics.Forms.Properties.Resources
  • MRUFileOpen() : Deltares.Standard.Forms.DExpress.MainForm
  • MultiSelect : Deltares.Standard.Forms.DExpress.TreeViewControl
  • MyMapLineLayer() : Deltares.Standard.Forms.DExpress.MyMapLineLayer
  • MyMapPointLayer() : Deltares.Standard.Forms.DExpress.MyMapPointLayer
  • MyMapPolygonLayer() : Deltares.Standard.Forms.DExpress.MyMapPolygonLayer
Generated on Tue Dec 15 2015 18:15:41 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Class Members

Tool for the (stochastic) subsoil definition.
Here is a list of all documented class members with links to the class documentation for each member:

- n -

  • NaiveCamelCaseToSpacedName() : Deltares.Standard.Forms.SpatialEditor
  • Name : Deltares.Geometry.Forms.DrawingObject , Deltares.Standard.Forms.DExpress.MapLayerDefinition , Deltares.Standard.Forms.IPropertyControl , Deltares.Standard.Forms.ShapeInfo
  • NameCaption : Deltares.Geotechnics.Forms.Properties.Resources , Deltares.Standard.Forms.DExpress.Properties.Resources
  • NavBarRadioButtonCaption : Deltares.Standard.Forms.Properties.Resources
  • NavigationStyleGroupBoxCaption : Deltares.Standard.Forms.Properties.Resources
  • NearestPointOnGeographicString() : Deltares.Standard.DotSpatialDgs.DotSpatialGeographicAlgorithms
  • NewProjectRadioButtonCaption : Deltares.Standard.Forms.Properties.Resources
  • Next : Deltares.Standard.Forms.Properties.Resources
  • No : Deltares.Standard.Forms.MessageBoxManager
  • NoItemtoDeleteCaption : Deltares.Standard.Forms.DExpress.Properties.Resources
  • NoObjectDeleted : Deltares.Standard.Forms.DExpress.Properties.Resources
  • NoProjectRadioButtonCaption : Deltares.Standard.Forms.Properties.Resources
  • NoRowSelected : Deltares.Standard.Forms.DExpress.Properties.Resources
Generated on Tue Dec 15 2015 18:15:41 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Class Members

Tool for the (stochastic) subsoil definition.
Here is a list of all documented class members with links to the class documentation for each member:

- o -

  • OK : Deltares.Standard.Forms.MessageBoxManager
  • OkButtonCaption : Deltares.Standard.Forms.Properties.Resources
  • OKCaption : Deltares.Standard.Forms.DExpress.Properties.Resources
  • OnAfterRowAdd() : Deltares.Standard.Forms.DExpress.GridViewController< T >
  • OnAfterRowDelete() : Deltares.Standard.Forms.DExpress.GridViewController< T >
  • OnAfterRowInsert() : Deltares.Standard.Forms.DExpress.GridViewController< T >
  • OnAfterRowUpdate() : Deltares.Standard.Forms.DExpress.GridViewController< T >
  • OnBeginDrag() : Deltares.DSoilModel.Forms.DrawingCenterCrestLocation , Deltares.DSoilModel.Forms.DrawingSoilSegmentSplitLocation , Deltares.Geometry.Forms.DrawingLine , Deltares.Geometry.Forms.DrawingObject , Deltares.Geometry.Forms.DrawingPoint , Deltares.Geometry.Forms.IDrawingObject , Deltares.Geotechnics.Forms.DrawingAnchorAttachment , Deltares.Geotechnics.Forms.DrawingBoring , Deltares.Geotechnics.Forms.DrawingCPT , Deltares.Geotechnics.Forms.DrawingGeometry , Deltares.Geotechnics.Forms.DrawingRevetment , Deltares.Geotechnics.Forms.DrawingSheetPiling , Deltares.Geotechnics.Forms.DrawingSoilLayerSurface , Deltares.Geotechnics.Forms.DrawingSoilProfile1D , Deltares.Geotechnics.Forms.DrawingSoilSurface , Deltares.Geotechnics.Forms.DrawingSpecificMechanismPointLocation
  • OnBeginValidationOrSave : Deltares.Standard.Forms.DExpress.MainForm
  • OnClickMStabGraphicInputBarSelectionItem() : Deltares.Standard.Forms.DExpress.GeometryEditor
  • OnDragDropEndEvent : Deltares.Standard.Forms.DExpress.GeometryEditor
  • OnDragging() : Deltares.Geometry.Forms.DrawingObject , Deltares.Geometry.Forms.IDrawingObject , Deltares.Geotechnics.Forms.DrawingRevetment
  • OnEndDrag() : Deltares.DSoilModel.Forms.DrawingCenterCrestLocation , Deltares.DSoilModel.Forms.DrawingSoilSegmentSplitLocation , Deltares.Geometry.Forms.DrawingObject , Deltares.Geometry.Forms.DrawingPoint , Deltares.Geometry.Forms.IDrawingObject , Deltares.Geotechnics.Forms.DrawingAnchorAttachment , Deltares.Geotechnics.Forms.DrawingBoring , Deltares.Geotechnics.Forms.DrawingCPT , Deltares.Geotechnics.Forms.DrawingSheetPiling , Deltares.Geotechnics.Forms.DrawingSoilLayerSurface , Deltares.Geotechnics.Forms.DrawingSoilProfile1D , Deltares.Geotechnics.Forms.DrawingSpecificMechanismPointLocation
  • OnLoadPropertyControl() : Deltares.Standard.Forms.DExpress.GeoPropertyGrid
  • OnPopupMenu : Deltares.Standard.Forms.DExpress.GeometryEditor
  • OnPrint() : Deltares.Standard.Forms.DExpress.GeoChartControl
  • OnShapeAction() : Deltares.Standard.Forms.DExpress.GeometryEditor
  • OnToolTipClosed() : Deltares.Standard.Forms.DExpress.BaseControlBinding , Deltares.Standard.Forms.DExpress.ControlBinding
  • OnToolTipShown() : Deltares.Standard.Forms.DExpress.BaseControlBinding , Deltares.Standard.Forms.DExpress.ControlBinding
  • Open : Deltares.Standard.Forms.Properties.Resources
  • OpenHelp() : Deltares.Standard.Forms.DExpress.HelpLocationShower , Deltares.Standard.Forms.DExpress.Interfaces.IHelpFileManager , Deltares.Standard.Forms.DExpress.PdfHelpFileManager
  • OpenImage : Deltares.Standard.Forms.Properties.Resources
  • OpenSoilDatabase() : Deltares.DSoilModel.Data.DSoilModelIO
  • OpenXML() : Deltares.DSoilModel.Data.DSoilModelIO
  • OrderCurves() : Deltares.Geotechnics.WaternetCreator.WaternetCreator
  • OrderLayersByDescending() : Deltares.Geotechnics.SoilProfile1D
Generated on Tue Dec 15 2015 18:15:41 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Class Members

Tool for the (stochastic) subsoil definition.
Here is a list of all documented class members with links to the class documentation for each member:

- p -

  • PageLoad() : Deltares.Standard.Web.PageSupport
  • Pan : Deltares.Standard.Forms.DExpress.Properties.Resources , Deltares.Standard.Forms.Properties.Resources
  • PanMove : Deltares.Standard.Forms.DExpress.Properties.Resources
  • ParameterView : Deltares.DSoilModel.Data.DSoilModelProject , Deltares.DSoilModel.Forms.DSoilModelContext
  • ParseDouble() : Deltares.Standard.Forms.DExpress.GridViewControl
  • PasteCaption : Deltares.Standard.Forms.DExpress.Properties.Resources
  • PasteCommand() : Deltares.Standard.Forms.DExpress.GridViewControl
  • PasteHeadlineCaption : Deltares.Geotechnics.Forms.Properties.Resources
  • PasteItem_Glyph : Deltares.Standard.Forms.DExpress.Properties.Resources
  • PasteItemHint : Deltares.Standard.Forms.DExpress.Properties.Resources
  • PastePointCaption : Deltares.Geometry.Forms.Properties.Resources , Deltares.Geotechnics.Forms.Properties.Resources
  • PastePolylineCaption : Deltares.Geometry.Forms.Properties.Resources
  • PasteWaternetlineCaption : Deltares.Geotechnics.Forms.Properties.Resources
  • Pause : Deltares.Standard.Forms.Properties.Resources
  • PdfHelpFileManager() : Deltares.Standard.Forms.DExpress.PdfHelpFileManager
  • Pen3D() : Deltares.Standard.Forms.DrawingSupport
  • PhreaticLevel : Deltares.Geotechnics.SoilProfile1D
  • PhreaticLineCaption : Deltares.Geotechnics.Forms.Properties.Resources
  • PhreaticLineDescription : Deltares.Geotechnics.Forms.Properties.Resources
  • PlLineOffsetBelowPointBRingtoetsWti2017 : Deltares.Geotechnics.WaternetCreator.Location
  • PlLinesCreator() : Deltares.Geotechnics.WaternetCreator.PlLinesCreator
  • point : Deltares.Geometry.Forms.DrawingPoint
  • Point : Deltares.Standard.Forms.ShapeEventArgs
  • Point_grey : Deltares.DSoilModel.Forms.Properties.Resources
  • PointImporter() : Deltares.Standard.Forms.DExpress.ShapeImporters.PointImporter
  • PolygonImporter() : Deltares.Standard.Forms.DExpress.ShapeImporters.PolygonImporter
  • PopulateDataTable() : Deltares.Standard.Forms.DExpress.GeoChartControl
  • PopulateMRUList() : Deltares.Standard.Forms.DExpress.MainForm
  • PositionXzOfPointRelatedToPLLine() : Deltares.Geotechnics.WaternetCreator.LineHelper
  • Preferences_Glyph : Deltares.Standard.Forms.DExpress.Properties.Resources
  • PreferencesFormText : Deltares.Standard.Forms.DExpress.Properties.Resources
  • Previous : Deltares.Standard.Forms.Properties.Resources
  • PreviousMRUList : Deltares.Standard.Forms.DExpress.MainForm
  • PrintCaption : Deltares.Standard.Forms.DExpress.Properties.Resources
  • ProbabilisticControl() : Deltares.Geotechnics.Forms.ProbabilisticControl
  • ProbabilityOfOccurrence : Deltares.Geotechnics.SoilProfile1D
  • ProgramSettings : Deltares.Standard.Forms.DExpress.MainForm
  • ProgressBackgroundImage : Deltares.Standard.Forms.DExpress.ProgressDialog
  • ProgressDialog() : Deltares.Standard.Forms.DExpress.ProgressDialog
  • Project : Deltares.DSoilModel.Forms.DSoilModelGeometryEditor , Deltares.DSoilModel.Forms.DSoilModelMapEditor , Deltares.DSoilModel.Forms.DSoilModelPlugin , Deltares.DSoilModel.Forms.DSoilModelSegmentGeometryEditor
  • ProjectDescriptionCaption : Deltares.Standard.Forms.DExpress.Properties.Resources
  • Projection : Deltares.Standard.Forms.ShapesEventArgs
  • ProjectIsSaved() : Deltares.Standard.Forms.DExpress.MainForm
  • PropertyEditorReactionType : Deltares.Standard.Forms.DExpress.GridViewControl
  • PropertyName : Deltares.Standard.Forms.GridViewCellChangeArgs
  • PropertyValue : Deltares.Standard.Forms.GridViewCellChangeArgs
Generated on Tue Dec 15 2015 18:15:41 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Class Members

Tool for the (stochastic) subsoil definition.
Here is a list of all documented class members with links to the class documentation for each member:

- q -

  • QcMax : Deltares.Geotechnics.Forms.DrawingCPT
Generated on Tue Dec 15 2015 18:15:41 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Class Members

Tool for the (stochastic) subsoil definition.
Here is a list of all documented class members with links to the class documentation for each member:

- r -

  • RaiseBeginValidationOrSave() : Deltares.Standard.Forms.DExpress.MainForm
  • Read() : Deltares.Geotechnics.IO.Importers.CharacteristicPointsImporter
  • ReadBoring() : Deltares.Geotechnics.IO.Importers.GEFXmlImporter
  • ReadCPT() : Deltares.Geotechnics.IO.Importers.GEFXmlImporter
  • ReadCsvCharacteristicPointsFromFileAndAddToProject() : Deltares.DSoilModel.Data.DSoilModelIO
  • ReadCsvSegmentsFromFileAndAddToProject() : Deltares.DSoilModel.Data.DSoilModelIO
  • ReadCsvSurfaceLineFromFileAndAddToProject() : Deltares.DSoilModel.Data.DSoilModelIO
  • ReadDamDefinitionsFromFileAndAddToProject() : Deltares.DSoilModel.Data.DSoilModelIO
  • ReadGefBoringFromFile() : Deltares.DSoilModel.Data.DSoilModelProject
  • ReadGefCptFromFile() : Deltares.DSoilModel.Data.DSoilModelProject
  • ReadGeometryFromFile() : Deltares.DSoilModel.Data.DSoilModelProject
  • ReadOldProjectFromDatabase() : Deltares.DSoilModel.Data.DSoilModelProject
  • ReadOnly : Deltares.Standard.Forms.ColumnDescription
  • ReadSoilProfile1D() : Deltares.Geotechnics.IO.Importers.GEFXmlImporter
  • ReadSoilProfiles() : Deltares.DSoilModel.Data.SosSoilProfilesImporter , Deltares.Geotechnics.IO.Importers.SoilProfilesImporter
  • ReadSoilProfiles1DFromFile() : Deltares.DSoilModel.Data.DSoilModelProject
  • ReadSoils() : Deltares.Geotechnics.IO.Importers.GEFXmlImporter
  • ReadSoilsFromDatabase() : Deltares.DSoilModel.Data.DSoilModelProject
  • ReadSurfacesLines() : Deltares.Geotechnics.IO.Importers.SurfaceLinesImporter
  • Rectangle3D() : Deltares.Standard.Forms.DrawingSupport
  • Redo : Deltares.Standard.Forms.Properties.Resources
  • RedrawView() : Deltares.Standard.Forms.DExpress.GeometryEditor
  • Refresh() : Deltares.DSoilModel.Forms.FilmStrip , Deltares.Standard.Forms.DExpress.GridViewControl
  • RefreshObject() : Deltares.Standard.Forms.DExpress.GeoPropertyGrid
  • Register() : Deltares.Standard.Forms.DExpress.LocalizationSupport , Deltares.Standard.Forms.DExpress.MainForm , Deltares.Standard.Forms.MessageBoxManager , Deltares.Standard.Forms.RealTimeBackgroundValidator
  • RegisterAndTranslate() : Deltares.Standard.Forms.DExpress.LocalizationSupport
  • RegisterComponentsToReloadUI() : Deltares.Standard.Forms.DExpress.GeometryEditor
  • RegisterControl() : Deltares.Standard.Forms.DExpress.GridViewController< T >
  • RegisteredLayers : Deltares.Standard.Forms.DExpress.MapEditor , Deltares.Standard.Forms.DExpress.MapTools.IMapTool
  • RegisterLayer() : Deltares.Standard.Forms.DExpress.MapEditor
  • RegisterNewFileHandler() : Deltares.Standard.Forms.DExpress.MainForm
  • RegisterOpenFileHandler() : Deltares.Standard.Forms.DExpress.MainForm
  • RegisterPlugin() : Deltares.Standard.Application.ProgramBase
  • RegisterPopupControl() : Deltares.Standard.Forms.DExpress.BindSupport
  • RegisterSaveFileHandler() : Deltares.Standard.Forms.DExpress.MainForm
  • RegisterSelectionAssignment() : Deltares.Standard.Forms.DExpress.ComponentBinding , Deltares.Standard.Forms.DExpress.GridControlBinding
  • RegisterShapeImporter() : Deltares.Standard.Forms.DExpress.AbstractShapeFileImporter
  • RegisterShapeType() : Deltares.Standard.Forms.SpatialEditor
  • RegisterTable() : Deltares.Standard.Forms.DExpress.GridViewController< T >
  • RegisterTable< ContainerType, ObjectType >() : Deltares.Standard.Forms.DExpress.MainForm
  • RegisterTableControl() : Deltares.Standard.Forms.DExpress.MainForm
  • RegisterTables< ContainerType >() : Deltares.Standard.Forms.DExpress.MainForm
  • RegisterUIComponent() : Deltares.Geotechnics.Forms.SoilBondStressCurveControl , Deltares.Standard.Forms.DExpress.GeometryEditor , Deltares.Standard.Forms.DExpress.MainForm
  • Reload() : Deltares.Geotechnics.Forms.SoilBondStressCurveControl , Deltares.Standard.Forms.DExpress.GeometryEditor , Deltares.Standard.Forms.DExpress.MainForm
  • ReloadManager : Deltares.Standard.Forms.DExpress.MainForm
  • ReloadUI() : Deltares.Standard.Forms.DExpress.GeoPropertyGrid , Deltares.Standard.Forms.DExpress.GridViewControl
  • RemarkTopLevel : Deltares.DSoilModel.Data.SosSoilLayer1D
  • Remove : Deltares.Standard.Forms.Properties.Resources , Deltares.Standard.Forms.SpatialEditor
  • RemoveAllPointsOfGeometryPointStringAfterIndex() : Deltares.Geotechnics.WaternetCreator.LineHelper
  • RemoveAt() : Deltares.Standard.Forms.DExpress.GridViewControl
  • RemoveComponent() : Deltares.Standard.Forms.DExpress.ReloadManager
  • RemoveDataObjectFromList() : Deltares.Standard.Forms.SpatialEditor
  • RemoveLateBinding() : Deltares.Standard.Forms.DExpress.BindSupportLateBinding , Deltares.Standard.Forms.DExpress.Interfaces.ILateBinding
  • RemoveLayer() : Deltares.Standard.Forms.DExpress.MapEditor
  • RemoveObject() : Deltares.Standard.Forms.DExpress.GeometryEditor , Deltares.Standard.Forms.SpatialEditor
  • RemoveRaster() : Deltares.Standard.Forms.DExpress.MapEditor
  • RemoveTabFromAboutDialog() : Deltares.Standard.Forms.DExpress.MainForm
  • Rename_Glyph : Deltares.Standard.Forms.DExpress.Properties.Resources
  • RenameCaption : Deltares.Standard.Forms.DExpress.Properties.Resources
  • RenameFormCaption : Deltares.Standard.Forms.DExpress.Properties.Resources
  • RenameItemHint : Deltares.Standard.Forms.DExpress.Properties.Resources
  • RenameselectedobjectCaption : Deltares.Standard.Forms.DExpress.Properties.Resources
  • RenamewaternetCaption : Deltares.Geotechnics.Forms.Properties.Resources
  • RepairAllValidationResults() : Deltares.DSoilModel.Data.DSoilModelProject
  • ReportDlg() : Deltares.Standard.Forms.DExpress.ReportDlg
  • ReportLanguageGroupboxCaption : Deltares.Standard.Forms.Properties.Resources
  • ReportLanguageLabelCaption : Deltares.Standard.Forms.Properties.Resources
  • Reproject() : Deltares.Standard.Forms.DExpress.MyFeatureSet
  • RerouteMessageBoxMessages : Deltares.Standard.Forms.Messenger
  • Reset : Deltares.Standard.Forms.Properties.Resources
  • Reset1 : Deltares.Standard.Forms.Properties.Resources
  • ResourceManager : Deltares.DSoilModel.Application.Properties.Resources , Deltares.DSoilModel.Forms.Properties.Resources , Deltares.Geometry.Forms.Properties.Resources , Deltares.Geotechnics.Forms.Properties.Resources , Deltares.Standard.Forms.DExpress.Properties.Resources , Deltares.Standard.Forms.Properties.Resources
  • Result : Deltares.Standard.Web.dinoservices.findCPTCompletedEventArgs , Deltares.Standard.Web.dinoservices.findCPTWithCriteriaCompletedEventArgs , Deltares.Standard.Web.dinoservices.getGEFCompletedEventArgs
  • ResumeLayerEvents() : Deltares.Standard.Forms.DExpress.MapEditor
  • ResumeRendering() : Deltares.Standard.Forms.SpatialEditor
  • RetrieveGefFile() : Deltares.Standard.Web.Cpt
  • Retry : Deltares.Standard.Forms.MessageBoxManager
  • Right : Deltares.DSoilModel.Forms.DrawingCenterCrestLocation , Deltares.DSoilModel.Forms.DrawingSoilSegmentSplitLocation , Deltares.Geotechnics.Forms.DrawingBoring , Deltares.Geotechnics.Forms.DrawingCPT , Deltares.Geotechnics.Forms.DrawingSoilProfile1D , Deltares.Geotechnics.Forms.DrawingSpecificMechanismPointLocation
  • RowHeaderToolTip : Deltares.Standard.Forms.DExpress.GeoPropertyGrid
  • RunInDebugMode() : Deltares.Standard.Application.ProgramBase
  • RunInReleaseMode() : Deltares.Standard.Application.ProgramBase
Generated on Tue Dec 15 2015 18:15:41 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Class Members

Tool for the (stochastic) subsoil definition.
Here is a list of all documented class members with links to the class documentation for each member:

- s -

  • Save : Deltares.Standard.Forms.Properties.Resources
  • SaveAll : Deltares.Standard.Forms.Properties.Resources
  • SaveImage : Deltares.Standard.Forms.Properties.Resources
  • SaveLayer : Deltares.Standard.Forms.Properties.Resources
  • SaveSoilDatabase() : Deltares.DSoilModel.Data.DSoilModelIO
  • SaveXML() : Deltares.DSoilModel.Data.DSoilModelIO
  • Scheme : Deltares.Standard.Forms.DExpress.MapLayerDefinition
  • SegmentGeometryEditor : Deltares.DSoilModel.Forms.DSoilModelPlugin
  • Select() : Deltares.Standard.Forms.DExpress.MyFeatureSet , Deltares.Standard.Forms.Properties.Resources , Deltares.Standard.Forms.SpatialEditor
  • Selectable : Deltares.Standard.Forms.DExpress.MapLayerDefinition , Deltares.Standard.Forms.DExpress.MyMapLineLayer , Deltares.Standard.Forms.DExpress.MyMapPointLayer
  • SelectableLayerItems : Deltares.Standard.Forms.DExpress.Forms.ExportLayersDialog , Deltares.Standard.Forms.DExpress.Forms.IExportLayersDialog
  • SelectColumnFilterAll() : Deltares.Standard.Forms.DExpress.GridViewControl
  • Selected : Deltares.DSoilModel.Forms.FilmStripThumbnail , Deltares.Geometry.Forms.DrawingObject
  • SelectedCategory : Deltares.Standard.Forms.DExpress.GridViewControl
  • SelectedFeature : Deltares.Standard.Forms.DExpress.MapTools.ConnectFeaturesMapTool , Deltares.Standard.Forms.DExpress.MapTools.IMapTool
  • SelectedFilter : Deltares.Standard.Forms.DExpress.GridViewControl
  • SelectedItem : Deltares.DSoilModel.Forms.ModalListBox
  • SelectedLayer : Deltares.Standard.Forms.DExpress.MapTools.IMapTool
  • SelectedList : Deltares.Standard.Forms.DExpress.MapTools.IMapTool
  • SelectedObject : Deltares.DSoilModel.Forms.SosSoilProfile1DControl , Deltares.Geotechnics.Forms.SoilBondStressCurveControl , Deltares.Geotechnics.Forms.SoilProfile1DControl , Deltares.Geotechnics.Forms.SoilStressCurveControl , Deltares.Geotechnics.Forms.SoilSurfacePropertyControl , Deltares.Geotechnics.Forms.WaterLineControl , Deltares.Geotechnics.Forms.WaternetControl , Deltares.Standard.Forms.DExpress.DynamicPropertyControl , Deltares.Standard.Forms.IDynamicPropertyControl , Deltares.Standard.Forms.IPropertyControl
  • SelectedObjectCount : Deltares.Standard.Forms.DExpress.GeometryEditor
  • SelectedObjects : Deltares.Standard.Forms.DExpress.GeometryEditor , Deltares.Standard.Forms.DExpress.MapEditor , Deltares.Standard.Forms.DExpress.MapTools.SelectFeatureMapTool
  • SelectedRow : Deltares.Standard.Forms.DExpress.Properties.Resources
  • SelectedStochasticSoilModel : Deltares.DSoilModel.Forms.FilmStrip
  • SelectedStochasticSoilProfile : Deltares.DSoilModel.Forms.FilmStrip
  • Selection : Deltares.Standard.Forms.IController
  • SelectionChanged : Deltares.Standard.Forms.SpatialEditor
  • SelectLicense() : Deltares.Standard.Forms.DExpress.MainForm
  • SelectOrRowCaption : Deltares.Standard.Forms.DExpress.Properties.Resources
  • SelectProgramOptions() : Deltares.Standard.Forms.DExpress.MainForm
  • SelectUnits() : Deltares.Standard.Forms.DExpress.MainForm
  • SelectWorkingDirectory : Deltares.Standard.Forms.Properties.Resources
  • SendLegendEvent : Deltares.Standard.Forms.DExpress.MapEditor
  • SendSelectionChanged : Deltares.Standard.Forms.DExpress.GridViewControl
  • SeriesCount : Deltares.Standard.Forms.DExpress.GeoChartControl
  • SeriesList : Deltares.Standard.Forms.DExpress.GeoChartControl
  • SetActiveMapProjection() : Deltares.Standard.DotSpatialDgs.MapProjectionManager
  • SetActiveMapProjectionAsDotSpatial() : Deltares.Standard.DotSpatialDgs.MapProjectionManager
  • SetAsActiveChart() : Deltares.Standard.Forms.DExpress.IMainFormActiveControlController , Deltares.Standard.Forms.DExpress.MainForm
  • SetAsActivePropertyEditor() : Deltares.Standard.Forms.DExpress.IMainFormActiveControlController , Deltares.Standard.Forms.DExpress.MainForm
  • SetAsActiveTable() : Deltares.Standard.Forms.DExpress.IMainFormActiveControlController , Deltares.Standard.Forms.DExpress.MainForm
  • SetAsActiveTabOnMainPanel() : Deltares.Standard.Forms.DExpress.IMainFormActiveControlController , Deltares.Standard.Forms.DExpress.MainForm
  • Setascurrentwaternet : Deltares.Geotechnics.Forms.Properties.Resources
  • SetCaption() : Deltares.DSoilModel.Forms.DSoilModelSegmentGeometryEditor
  • SetControlColors() : Deltares.Standard.Forms.DExpress.ComponentBinding
  • SetCoordinate() : Deltares.DSoilModel.Data.SoilSegmentSplitLocation
  • SetDataObject() : Deltares.DSoilModel.Forms.DrawingBoringLayer , Deltares.DSoilModel.Forms.DrawingCenterCrestLocation , Deltares.DSoilModel.Forms.DrawingLayerObsolete , Deltares.DSoilModel.Forms.DrawingSoilSegmentSplitLocation , Deltares.DSoilModel.Forms.DrawingSosSoilLayer1D , Deltares.Geometry.Forms.DrawingBoundingBox , Deltares.Geometry.Forms.DrawingLine , Deltares.Geometry.Forms.DrawingObject , Deltares.Geometry.Forms.DrawingPoint , Deltares.Geometry.Forms.DrawingPointString , Deltares.Geometry.Forms.DrawingSurface , Deltares.Geometry.Forms.IDrawingObject , Deltares.Geotechnics.Forms.DrawingAnchorAttachment , Deltares.Geotechnics.Forms.DrawingBlockRevetmentSegment , Deltares.Geotechnics.Forms.DrawingBoring , Deltares.Geotechnics.Forms.DrawingCharacteristicPoint , Deltares.Geotechnics.Forms.DrawingCPT , Deltares.Geotechnics.Forms.DrawingGeometry , Deltares.Geotechnics.Forms.DrawingHeadLine , Deltares.Geotechnics.Forms.DrawingLayer , Deltares.Geotechnics.Forms.DrawingPhreaticLine , Deltares.Geotechnics.Forms.DrawingPiezometricHead , Deltares.Geotechnics.Forms.DrawingPreConsolidationStress , Deltares.Geotechnics.Forms.DrawingRevetment , Deltares.Geotechnics.Forms.DrawingSettlementCurve , Deltares.Geotechnics.Forms.DrawingSheetPiling , Deltares.Geotechnics.Forms.DrawingSoilLayerSurface , Deltares.Geotechnics.Forms.DrawingSoilProfile1D , Deltares.Geotechnics.Forms.DrawingSoilSurface , Deltares.Geotechnics.Forms.DrawingSpecificMechanismPointLocation , Deltares.Geotechnics.Forms.DrawingSurfaceLine2 , Deltares.Geotechnics.Forms.DrawingSwell , Deltares.Geotechnics.Forms.DrawingWaterBasin , Deltares.Geotechnics.Forms.DrawingWaterLevel , Deltares.Geotechnics.Forms.DrawingWaternetLine , Deltares.Geotechnics.Forms.DrawingWaterPolderBasin
  • SetDataSource() : Deltares.Standard.Forms.DExpress.GeoChartControl
  • SetDefaultWidthPropertyWindow() : Deltares.Standard.Forms.DExpress.MainForm
  • SetDescription() : Deltares.Standard.Forms.DExpress.ControlBinding , Deltares.Standard.Forms.DExpress.GridControlBinding
  • SetDirty() : Deltares.Standard.Forms.DExpress.BindSupportLateBinding
  • SetDirtyIfUsingLateBinding() : Deltares.Standard.Forms.DExpress.BindSupportLateBinding
  • SetDrawingProperties() : Deltares.Geotechnics.Forms.DrawingSwell
  • SetIconFromManifestResourceStream() : Deltares.Standard.Application.ProgramBase
  • SetIEPDraw3D() : Deltares.Standard.Forms.DrawingSupport
  • SetInsertMode() : Deltares.Standard.Forms.DExpress.GeometryEditor
  • SetLabel() : Deltares.Standard.Forms.DExpress.ControlBinding
  • SetLanguage() : Deltares.Standard.Forms.DExpress.ReloadManager
  • SetLateBinding() : Deltares.Standard.Forms.DExpress.BindSupport , Deltares.Standard.Forms.DExpress.BindSupportLateBinding
  • SetLocalizedString() : Deltares.Standard.Forms.DExpress.GridViewControl
  • SetLocalizedStrings() : Deltares.Standard.Forms.DExpress.GeoChartControl
  • SetMainWindowCaption() : Deltares.Standard.Forms.DExpress.MainForm
  • SetMessage() : Deltares.Standard.Forms.DExpress.ProgressDialog
  • SetMinMax() : Deltares.Standard.Forms.DExpress.GeoChartControl
  • SetProgress() : Deltares.Standard.Forms.DExpress.ProgressDialog
  • SetProgressText() : Deltares.Standard.Forms.DExpress.StatusBar
  • SetSelected() : Deltares.Standard.Forms.DExpress.MyMapLineLayer , Deltares.Standard.Forms.DExpress.MyMapPointLayer , Deltares.Standard.Forms.DExpress.MyMapPolygonLayer
  • SetSeriesProperties() : Deltares.Standard.Forms.DExpress.GeoChartControl
  • SetSplashImageFromManifestResourceStream() : Deltares.Standard.Application.ProgramBase
  • SetTextToolTip() : Deltares.Standard.Forms.CommandLineWindow
  • SetupViewEditor() : Deltares.Standard.Forms.DExpress.GeometryEditor
  • SetValue() : Deltares.Standard.Forms.DExpress.PopupContainerEditBinding , Deltares.Standard.Forms.IController
  • SetViewType() : Deltares.Standard.Forms.DExpress.GeoChartControl
  • SetVisible() : Deltares.Standard.Forms.DExpress.FormsSupport
  • Shape : Deltares.Standard.Forms.ShapeEventArgs
  • ShapeCreated : Deltares.Standard.Forms.SpatialEditor
  • ShapeEventArgs() : Deltares.Standard.Forms.ShapeEventArgs
  • ShapeInfo() : Deltares.Standard.Forms.ShapeInfo
  • ShapeInfos : Deltares.Standard.Forms.SpatialEditor
  • ShapeModified : Deltares.Standard.Forms.SpatialEditor
  • ShapeRemoved : Deltares.Standard.Forms.SpatialEditor
  • Shapes : Deltares.Standard.Forms.ShapesEventArgs , Deltares.Standard.Forms.SpatialEditor
  • ShapesEventArgs() : Deltares.Standard.Forms.ShapesEventArgs
  • ShearStressCurveControl() : Deltares.Geotechnics.Forms.ShearStressCurveControl
  • ShortCut : Deltares.Standard.Forms.ICommand
  • Shortcut : Deltares.Standard.Forms.ViewCommand
  • Showallcolumnsbutton_Glyph : Deltares.Standard.Forms.DExpress.Properties.Resources
  • ShowallcolumnsCaption : Deltares.Standard.Forms.DExpress.Properties.Resources
  • ShowallcolumnsHint : Deltares.Standard.Forms.DExpress.Properties.Resources
  • ShowAxes : Deltares.DSoilModel.Forms.DrawingCenterCrestLocation , Deltares.Geotechnics.Forms.DrawingCPT , Deltares.Geotechnics.Forms.DrawingSpecificMechanismPointLocation
  • ShowBestColumnFitCaption : Deltares.Standard.Forms.DExpress.Properties.Resources
  • ShowCharts() : Deltares.Standard.Forms.DExpress.MainForm
  • ShowColumnsCommand() : Deltares.Standard.Forms.DExpress.GridViewControl
  • ShowCommandLineWindow() : Deltares.Standard.Forms.CommandLineWindow
  • ShowExportLayersButton : Deltares.Standard.Forms.DExpress.MapEditor
  • ShowFeatureTextInMapInfoBar : Deltares.Standard.Forms.DExpress.MapEditor
  • ShowForm() : Deltares.Standard.Forms.DExpress.MainForm
  • showFullMenusAfterDelay : Deltares.Standard.Forms.Properties.Resources
  • showFullMenusAfterDelay1 : Deltares.Standard.Forms.Properties.Resources
  • ShowRoot : Deltares.Standard.Forms.DExpress.TreeViewControl
  • ShowSelectedNonvisibleItems() : Deltares.Standard.Forms.DExpress.GeometryEditor
  • ShowSelectWebLayer : Deltares.Standard.Forms.DExpress.MapEditor
  • ShowSettingsDialog() : Deltares.Standard.Forms.DExpress.MainForm
  • ShowShortcutInTips : Deltares.Standard.Forms.Properties.Resources
  • ShowShortcutInTips1 : Deltares.Standard.Forms.Properties.Resources
  • ShowSoilSegment() : Deltares.DSoilModel.Forms.DSoilModelGeometryEditor
  • ShowToolbar : Deltares.Standard.Forms.DExpress.GridViewControl , Deltares.Standard.Forms.DExpress.TreeViewControl
  • ShowToolTipOnIndexer : Deltares.Standard.Forms.DExpress.GeoPropertyGrid
  • ShowWebLayer : Deltares.Standard.Forms.DExpress.MapEditor
  • SmartLineStringImporter() : Deltares.Standard.Forms.DExpress.ShapeImporters.SmartLineStringImporter
  • SnapAngle : Deltares.Standard.Forms.SpatialEditor
  • SnapDistance : Deltares.Standard.Forms.SpatialEditor
  • SnapGrid : Deltares.Standard.Forms.SpatialEditor
  • SnapRule : Deltares.Standard.Forms.DExpress.MapLayerDefinition
  • SoilbaseDb : Deltares.DSoilModel.Data.DSoilModelProject
  • SoilBondStressCurveControl() : Deltares.Geotechnics.Forms.SoilBondStressCurveControl
  • SoilProfile : Deltares.DSoilModel.Forms.Properties.Resources
  • SoilProfile1D() : Deltares.Geotechnics.SoilProfile1D
  • SoilProfile1DControl() : Deltares.Geotechnics.Forms.SoilProfile1DControl
  • Soilprofile1DLookup2Ds : Deltares.DSoilModel.Data.DSoilModelProject
  • SoilProfile2D : Deltares.DSoilModel.Data.CenterCrestLocation , Deltares.DSoilModel.Data.SoilSegmentSplitLocation
  • soilprofile2d : Deltares.DSoilModel.Forms.Properties.Resources
  • SoilProfile2DControl() : Deltares.Geotechnics.Forms.SoilProfile2DControl
  • SoilProfiles1D : Deltares.DSoilModel.Data.DSoilModelProject
  • SoilProfiles2D : Deltares.DSoilModel.Data.DSoilModelProject
  • SoilPropertyManager : Deltares.Geotechnics.SoilProfile1D
  • Soils : Deltares.DSoilModel.Data.DSoilModelProject , Deltares.Geotechnics.SoilProfile1D
  • SoilSegment : Deltares.DSoilModel.Data.SoilSegmentSplitLocation
  • SoilSegments : Deltares.DSoilModel.Data.DSoilModelProject
  • SoilStressCurveControl() : Deltares.Geotechnics.Forms.SoilStressCurveControl
  • SoilSurfacePropertyControl() : Deltares.Geotechnics.Forms.SoilSurfacePropertyControl
  • Source : Deltares.Standard.Forms.IController
  • SpatialEditor : Deltares.Standard.Forms.DExpress.GeometryEditor , Deltares.Standard.Forms.ShapeInfo , Deltares.Standard.Forms.SpatialEditor
  • SpecificMechanismPointLocations : Deltares.DSoilModel.Data.DSoilModelProject
  • SplashDialog : Deltares.Standard.Forms.DExpress.MainForm
  • SplashImage : Deltares.Standard.Application.ProgramBase
  • SplitPoint : Deltares.DSoilModel.Forms.Properties.Resources
  • SplitSegment() : Deltares.DSoilModel.Forms.DSoilModelMapEditor , Deltares.DSoilModel.Forms.Properties.Resources
  • SplitSegmentLocation() : Deltares.DSoilModel.Forms.DSoilModelMapEditor
  • SplitSoilSegment() : Deltares.DSoilModel.Data.DSoilModelProject
  • Start() : Deltares.Standard.Application.ProgramBase , Deltares.Standard.Forms.Properties.Resources , Deltares.Standard.Forms.RealTimeBackgroundValidator
  • StartUpGroupBoxCaption : Deltares.Standard.Forms.Properties.Resources
  • StatusBarProjection : Deltares.Standard.Forms.DExpress.MapEditor
  • StatusString : Deltares.Standard.Forms.DExpress.GeometryEditor
  • StochasticSoilProfile : Deltares.DSoilModel.Forms.FilmStripThumbnail
  • StochastProperties : Deltares.DSoilModel.Data.DSoilModelDataSourceRedirector
  • Stop : Deltares.Standard.Forms.Properties.Resources , Deltares.Standard.Forms.RealTimeBackgroundValidator
  • Strategies : Deltares.Standard.Forms.DExpress.GridEditValueStrategy
  • StressCurveControl() : Deltares.Geotechnics.Forms.StressCurveControl
  • StressCurves : Deltares.DSoilModel.Data.DSoilModelProject
  • structure_00 : Deltares.DSoilModel.Forms.Properties.Resources
  • structure_01 : Deltares.DSoilModel.Forms.Properties.Resources
  • structure_02 : Deltares.DSoilModel.Forms.Properties.Resources
  • structure_03 : Deltares.DSoilModel.Forms.Properties.Resources
  • structure_04 : Deltares.DSoilModel.Forms.Properties.Resources
  • structure_05 : Deltares.DSoilModel.Forms.Properties.Resources
  • structure_06 : Deltares.DSoilModel.Forms.Properties.Resources
  • structure_07 : Deltares.DSoilModel.Forms.Properties.Resources
  • structure_08 : Deltares.DSoilModel.Forms.Properties.Resources
  • structure_09 : Deltares.DSoilModel.Forms.Properties.Resources
  • structure_approved_earlier : Deltares.DSoilModel.Forms.Properties.Resources
  • structure_not_calculated : Deltares.DSoilModel.Forms.Properties.Resources
  • SurfaceLines : Deltares.DSoilModel.Data.DSoilModelProject
  • SuspendLayerEvents() : Deltares.Standard.Forms.DExpress.MapEditor
  • SuspendRendering() : Deltares.Standard.Forms.SpatialEditor
Generated on Tue Dec 15 2015 18:15:41 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Class Members

Tool for the (stochastic) subsoil definition.
Here is a list of all documented class members with links to the class documentation for each member:

- t -

  • TableToChart() : Deltares.Standard.Forms.DExpress.GeoChartControl
  • Text : Deltares.Standard.Forms.DExpress.ComboBoxDisplayItem , Deltares.Standard.Forms.ICommand , Deltares.Standard.Forms.ViewCommand
  • Text3D() : Deltares.Standard.Forms.DrawingSupport
  • ThrowIfGeometryIsNotValid() : Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter
  • ThrowIfTargetIsNull() : Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter
  • ThumbnailImage : Deltares.DSoilModel.Forms.FilmStripThumbnail
  • TitleCaption1 : Deltares.Standard.Forms.DExpress.Properties.Resources
  • TitleCaption2 : Deltares.Standard.Forms.DExpress.Properties.Resources
  • TitleCaption3 : Deltares.Standard.Forms.DExpress.Properties.Resources
  • ToCoordinates() : Deltares.Standard.DotSpatialDgs.DotSpatialGeographicConverter
  • ToFeature() : Deltares.Standard.DotSpatialDgs.DotSpatialGeographicConverter
  • ToGeographic() : Deltares.Standard.DotSpatialDgs.DotSpatialGeographicConverter
  • ToGeographicLoop() : Deltares.Standard.DotSpatialDgs.DotSpatialGeographicConverter
  • ToGeographicMultiPolygon() : Deltares.Standard.DotSpatialDgs.DotSpatialGeographicConverter
  • ToGeographicMultiString() : Deltares.Standard.DotSpatialDgs.DotSpatialGeographicConverter
  • ToGeographicPoint() : Deltares.Standard.DotSpatialDgs.DotSpatialGeographicConverter
  • ToGeographicPoints() : Deltares.Standard.DotSpatialDgs.DotSpatialGeographicConverter
  • ToGeographicPolygon() : Deltares.Standard.DotSpatialDgs.DotSpatialGeographicConverter
  • ToGeographicString() : Deltares.Standard.DotSpatialDgs.DotSpatialGeographicConverter
  • ToggleExpand : Deltares.Standard.Forms.Properties.Resources
  • ToLinearRing() : Deltares.Standard.DotSpatialDgs.DotSpatialGeographicConverter
  • ToolStripMenuItem : Deltares.Standard.Forms.DExpress.MapTools.AddFeatureMapTool , Deltares.Standard.Forms.DExpress.MapTools.DeleteFeatureMapTool , Deltares.Standard.Forms.DExpress.MapTools.SelectFeatureMapTool
  • ToolTip : Deltares.Geometry.Forms.DrawingObject
  • Tooltip : Deltares.Standard.Forms.DExpress.ControlBinding
  • Top : Deltares.Geotechnics.Forms.DrawingBoring , Deltares.Geotechnics.Forms.DrawingCPT , Deltares.Geotechnics.Forms.DrawingSoilProfile1D
  • TopAquiferLayer : Deltares.Geotechnics.SoilProfile1D
  • TopForDrawing() : Deltares.DSoilModel.Forms.DrawingCenterCrestLocation , Deltares.DSoilModel.Forms.DrawingSoilSegmentSplitLocation , Deltares.Geotechnics.Forms.DrawingSpecificMechanismPointLocation
  • TopLevel : Deltares.Geotechnics.SoilProfile1D
  • ToPoint() : Deltares.Standard.Forms.DrawingSupport
  • ToString() : Deltares.DSoilModel.Data.CenterCrestLocation , Deltares.Geotechnics.SoilProfile1D , Deltares.Standard.Forms.DExpress.AssignStrategy , Deltares.Standard.Forms.DExpress.ComboBoxDisplayItem , Deltares.Standard.Forms.DExpress.DivideStrategy , Deltares.Standard.Forms.DExpress.GreaterThanStrategy , Deltares.Standard.Forms.DExpress.GridEditValueStrategy , Deltares.Standard.Forms.DExpress.LessThanStrategy , Deltares.Standard.Forms.DExpress.MinusStrategy , Deltares.Standard.Forms.DExpress.MultiplyStrategy , Deltares.Standard.Forms.DExpress.PlusStrategy
  • ToWKT() : Deltares.Standard.DotSpatialDgs.DotSpatialGeographicConverter
  • tpCommands : Deltares.Standard.Forms.Properties.Resources
  • tpCommands1 : Deltares.Standard.Forms.Properties.Resources
  • tpOptions : Deltares.Standard.Forms.Properties.Resources
  • tpOptions1 : Deltares.Standard.Forms.Properties.Resources
  • tpToolbars : Deltares.Standard.Forms.Properties.Resources
  • tpToolbars1 : Deltares.Standard.Forms.Properties.Resources
  • TreeViewControl() : Deltares.Standard.Forms.DExpress.TreeViewControl
Generated on Tue Dec 15 2015 18:15:41 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Class Members

Tool for the (stochastic) subsoil definition.
Here is a list of all documented class members with links to the class documentation for each member:

- u -

  • UiButtonToggle : Deltares.Standard.Forms.Properties.Resources
  • Unbind() : Deltares.Standard.Forms.DExpress.BindSupport
  • Undo : Deltares.Standard.Forms.Properties.Resources
  • UnitCategory : Deltares.Standard.Forms.DExpress.Properties.Resources
  • UnitForProperty() : Deltares.Standard.Forms.DExpress.BindSupport
  • UnitForProperty< T >() : Deltares.Standard.Forms.DExpress.BindSupport
  • UnitType : Deltares.Standard.Forms.DExpress.Properties.Resources
  • UnitweightCaption : Deltares.Geotechnics.Forms.Properties.Resources
  • UnitWeightOfWaterCaption : Deltares.Geotechnics.Forms.Properties.Resources
  • Unregister() : Deltares.Standard.Forms.DExpress.LocalizationSupport , Deltares.Standard.Forms.MessageBoxManager
  • UnsnappedMousePosition : Deltares.Standard.Forms.GraphicsInfo
  • UpArrow : Deltares.Standard.Forms.DExpress.Properties.Resources
  • Update() : Deltares.Standard.Forms.DExpress.BindSupport
  • UpdateAll() : Deltares.Standard.Forms.DExpress.BindSupport
  • UpdateAllLayers() : Deltares.Standard.Forms.DExpress.MapEditor
  • UpdateData() : Deltares.Standard.Forms.DExpress.GeometryEditor , Deltares.Standard.Forms.DExpress.MainForm
  • UpdateDataDragDrop() : Deltares.DSoilModel.Forms.DrawingCenterCrestLocation , Deltares.DSoilModel.Forms.DrawingSoilSegmentSplitLocation , Deltares.Geometry.Forms.DrawingLine , Deltares.Geometry.Forms.DrawingObject , Deltares.Geometry.Forms.DrawingPoint , Deltares.Geometry.Forms.DrawingPointString , Deltares.Geometry.Forms.DrawingSurface , Deltares.Geometry.Forms.IDrawingObject , Deltares.Geotechnics.Forms.DrawingAnchorAttachment , Deltares.Geotechnics.Forms.DrawingBoring , Deltares.Geotechnics.Forms.DrawingCPT , Deltares.Geotechnics.Forms.DrawingGeometry , Deltares.Geotechnics.Forms.DrawingSettlementCurve , Deltares.Geotechnics.Forms.DrawingSheetPiling , Deltares.Geotechnics.Forms.DrawingSoilLayerSurface , Deltares.Geotechnics.Forms.DrawingSoilProfile1D , Deltares.Geotechnics.Forms.DrawingSoilSurface , Deltares.Geotechnics.Forms.DrawingSpecificMechanismPointLocation , Deltares.Geotechnics.Forms.DrawingSurfaceLine2 , Deltares.Geotechnics.Forms.DrawingWaterBasin , Deltares.Geotechnics.Forms.DrawingWaterLevel , Deltares.Geotechnics.Forms.DrawingWaterPolderBasin
  • UpdateDirtyControls() : Deltares.Standard.Forms.DExpress.FormsSupport
  • UpdateLists() : Deltares.DSoilModel.Data.DSoilModelProject
  • UpdateMenuTablesView() : Deltares.Standard.Forms.DExpress.MainForm
  • UpdateWaternet() : Deltares.Geotechnics.WaternetCreator.WaternetCreator
  • upperX_rd : Deltares.Standard.Web.dinoservices.EnvelopeType
  • upperY_rd : Deltares.Standard.Web.dinoservices.EnvelopeType
  • Use1DProfiles : Deltares.DSoilModel.Forms.DSoilModelPlugin
  • Use2DProfiles : Deltares.DSoilModel.Forms.DSoilModelPlugin
  • UseBorings : Deltares.DSoilModel.Forms.DSoilModelPlugin
  • UseCharts() : Deltares.Standard.Forms.DExpress.MainForm
  • UsedShapeInfos : Deltares.Standard.Forms.SpatialEditor
  • UseDynamicVisibility : Deltares.Standard.Forms.DExpress.MapLayerDefinition
  • UseExtraGeometryEditor() : Deltares.Standard.Forms.DExpress.MainForm
  • UseIcon() : Deltares.Standard.Forms.DExpress.MainForm
  • UseImage() : Deltares.Standard.Forms.DExpress.MainForm
  • UseLateBinding() : Deltares.Standard.Forms.DExpress.BindSupport , Deltares.Standard.Forms.DExpress.Interfaces.ILateBinding
  • UseMap() : Deltares.Standard.Forms.DExpress.MainForm
  • UseNavigation() : Deltares.Standard.Forms.DExpress.MainForm
  • UseOutput() : Deltares.Standard.Forms.DExpress.MainForm
  • UseProperties() : Deltares.Standard.Forms.DExpress.MainForm
  • UserColumnFilterDisplayItem() : Deltares.Standard.Forms.DExpress.UserColumnFilterDisplayItem
  • UseReport() : Deltares.Standard.Forms.DExpress.MainForm
  • UseResources() : Deltares.Standard.Forms.DExpress.MainForm
  • UserLabelVisible : Deltares.Standard.Forms.ShapeInfo
  • UserUnitIndex : Deltares.Standard.Forms.DExpress.Properties.Resources
  • UserVisible : Deltares.Standard.Forms.ShapeInfo
  • UseSoilSegments : Deltares.DSoilModel.Forms.DSoilModelPlugin
  • UseSpatialEditor() : Deltares.Standard.Forms.DExpress.MainForm
  • UseStatusBar() : Deltares.Standard.Forms.DExpress.MainForm
  • UseSurfaceLines : Deltares.DSoilModel.Forms.DSoilModelPlugin
  • UseTables() : Deltares.Standard.Forms.DExpress.MainForm
  • UseValidation() : Deltares.Standard.Forms.DExpress.MainForm
Generated on Tue Dec 15 2015 18:15:41 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Class Members

Tool for the (stochastic) subsoil definition.
Here is a list of all documented class members with links to the class documentation for each member:

- v -

  • Validate() : Deltares.Geotechnics.SoilProfile1D
  • ValidateAquifers() : Deltares.Geotechnics.WaternetCreator.Location
  • ValidateCaption : Deltares.Standard.Forms.DExpress.Properties.Resources
  • ValidateDirect() : Deltares.Geotechnics.SoilProfile1D
  • ValidateItemHint : Deltares.Standard.Forms.DExpress.Properties.Resources
  • ValidateSoilProfile() : Deltares.Geotechnics.WaternetCreator.Location
  • ValidateSpecificMechanismPointLocations() : Deltares.DSoilModel.Data.DSoilModelProject
  • ValidateWaterLevelRiver() : Deltares.Geotechnics.WaternetCreator.Location
  • Validation : Deltares.Standard.Forms.DExpress.Properties.Resources
  • ValidationResults : Deltares.Standard.Forms.DExpress.MainForm
  • ValueCaption : Deltares.Standard.Forms.DExpress.Properties.Resources
  • VericalViewCaption : Deltares.Standard.Forms.DExpress.Properties.Resources
  • ViewCommand() : Deltares.Standard.Forms.ViewCommand
  • ViewGrid : Deltares.Standard.Forms.SpatialEditor
  • ViewType : Deltares.Standard.Forms.DExpress.GeoChartControl
  • ViewType2D : Deltares.Standard.Forms.DExpress.GeoChartControl
  • ViewType3D : Deltares.Standard.Forms.DExpress.GeoChartControl
  • Visible : Deltares.Standard.Forms.ICommand , Deltares.Standard.Forms.ShapeInfo
Generated on Tue Dec 15 2015 18:15:41 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Class Members

Tool for the (stochastic) subsoil definition.
Here is a list of all documented class members with links to the class documentation for each member:

- w -

  • WaitForInsert : Deltares.Standard.Forms.SpatialEditor
  • Warning : Deltares.Standard.Forms.DExpress.Properties.Resources , Deltares.Standard.Forms.Properties.Resources
  • WaterDataNameCaption : Deltares.Geotechnics.Forms.Properties.Resources
  • WaterLevelCaption : Deltares.Geotechnics.Forms.Properties.Resources
  • WaterLineControl() : Deltares.Geotechnics.Forms.WaterLineControl
  • Waternet : Deltares.Standard.Forms.Properties.Resources
  • WaternetCaption : Deltares.Geotechnics.Forms.Properties.Resources
  • WaternetControl() : Deltares.Geotechnics.Forms.WaternetControl
  • WaternetCreationMode : Deltares.Geotechnics.WaternetCreator.Location
  • WaternetLinesCaption : Deltares.Geotechnics.Forms.Properties.Resources
  • WaterPressureMax : Deltares.Geotechnics.Forms.DrawingCPT
  • Web : Deltares.Standard.Forms.Properties.Resources
  • WebLayerType : Deltares.Standard.Forms.DExpress.MapEditor
  • WebLayerTypes : Deltares.Standard.Forms.DExpress.MapEditor
  • Width : Deltares.DSoilModel.Forms.DrawingSosSoilLayer1D , Deltares.Geotechnics.Forms.DrawingBoring , Deltares.Geotechnics.Forms.DrawingCPT , Deltares.Geotechnics.Forms.DrawingSoilProfile1D
  • WidthForDrawing() : Deltares.DSoilModel.Forms.DrawingCenterCrestLocation , Deltares.DSoilModel.Forms.DrawingSoilSegmentSplitLocation , Deltares.Geotechnics.Forms.DrawingSpecificMechanismPointLocation
  • WindowsLookAndFeelRadioButtonCaption : Deltares.Standard.Forms.Properties.Resources
  • WorkingDirectoryLabelCaption : Deltares.Standard.Forms.Properties.Resources
  • WorldBounds : Deltares.Standard.Forms.SpatialEditor
  • WorldMousePosition : Deltares.Standard.Forms.GraphicsInfo
Generated on Tue Dec 15 2015 18:15:41 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Class Members

Tool for the (stochastic) subsoil definition.
Here is a list of all documented class members with links to the class documentation for each member:

- x -

  • X : Deltares.DSoilModel.Forms.DrawingCenterCrestLocation , Deltares.DSoilModel.Forms.DrawingSoilSegmentSplitLocation , Deltares.Geotechnics.Forms.DrawingBoring , Deltares.Geotechnics.Forms.DrawingCPT , Deltares.Geotechnics.Forms.DrawingSoilProfile1D , Deltares.Geotechnics.Forms.DrawingSpecificMechanismPointLocation , Deltares.Geotechnics.SoilProfile1D , Deltares.Standard.Web.Cpt
  • x_rd : Deltares.Standard.Web.dinoservices.CPTType
  • XAxisTitle() : Deltares.Standard.Forms.DExpress.GeoChartControl
  • XCoordinate : Deltares.DSoilModel.Data.SoilSegmentSplitLocation
  • XValueNotIncreasing : Deltares.Standard.Forms.DExpress.Properties.Resources
Generated on Tue Dec 15 2015 18:15:41 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Class Members

Tool for the (stochastic) subsoil definition.
Here is a list of all documented class members with links to the class documentation for each member:

- y -

  • Y : Deltares.Geotechnics.SoilProfile1D , Deltares.Standard.Web.Cpt
  • y_rd : Deltares.Standard.Web.dinoservices.CPTType
  • YAxisTitle() : Deltares.Standard.Forms.DExpress.GeoChartControl
  • Yes : Deltares.Standard.Forms.MessageBoxManager
Generated on Tue Dec 15 2015 18:15:41 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Class Members

Tool for the (stochastic) subsoil definition.
Here is a list of all documented class members with links to the class documentation for each member:

- z -

  • Z : Deltares.Geotechnics.Forms.DrawingBoring , Deltares.Geotechnics.Forms.DrawingCPT , Deltares.Geotechnics.Forms.DrawingSoilProfile1D
  • Zoom : Deltares.Standard.Forms.Properties.Resources , Deltares.Standard.Forms.SpatialEditor
  • ZoomAll : Deltares.Standard.Forms.Properties.Resources
  • ZoomData() : Deltares.DSoilModel.Forms.DSoilModelMapEditor , Deltares.Standard.Forms.DExpress.MapEditor
  • ZoomExtents() : Deltares.Standard.Forms.DExpress.MapEditor , Deltares.Standard.Forms.Properties.Resources
  • ZoomFit : Deltares.Standard.Forms.Properties.Resources
  • ZoomIn : Deltares.Standard.Forms.Properties.Resources
  • ZoomInLevels : Deltares.Standard.Forms.SpatialEditor
  • ZoomOnResize : Deltares.Standard.Forms.SpatialEditor
  • ZoomOutLevels : Deltares.Standard.Forms.SpatialEditor
  • ZoomRectangle() : Deltares.Standard.Forms.DExpress.MapEditor , Deltares.Standard.Forms.Properties.Resources
  • ZoomSelection : Deltares.Standard.Forms.Properties.Resources
  • ZoomTo : Deltares.Standard.Forms.Properties.Resources
  • ZoomToExtends() : Deltares.Standard.Forms.DExpress.GeometryEditor
  • ZoomToExtendsMaintainAspectRatio() : Deltares.Standard.Forms.SpatialEditor
  • ZoomToExtents() : Deltares.Standard.Forms.SpatialEditor
  • ZoomtoExtentsCaption : Deltares.Standard.Forms.DExpress.Properties.Resources
Generated on Tue Dec 15 2015 18:15:41 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Class Members - Functions

Tool for the (stochastic) subsoil definition.

- a -

  • ActivateFirstData() : Deltares.DSoilModel.Data.DSoilModelProject
  • AddArrow() : Deltares.Standard.Forms.SpatialEditor
  • AddCenterCrestLocationTo2DProfile() : Deltares.DSoilModel.Forms.DSoilModelGeometryEditor
  • AddCharacteristicPointToSurfaceLine() : Deltares.Geotechnics.IO.Importers.CharacteristicPointsImporter
  • AddComponent() : Deltares.Standard.Forms.DExpress.ReloadManager
  • AddEllipse() : Deltares.Standard.Forms.SpatialEditor
  • AddFeatureMapTool() : Deltares.Standard.Forms.DExpress.MapTools.AddFeatureMapTool
  • AddInsertPoint() : Deltares.Standard.Forms.SpatialEditor
  • AddLayer() : Deltares.Standard.Forms.DExpress.MapEditor
  • AddList() : Deltares.Standard.Forms.SpatialEditor
  • AddObject() : Deltares.Standard.Forms.SpatialEditor
  • AddOldProjectDataBaseToProject() : Deltares.DSoilModel.Data.DSoilModelIO
  • AddOldSoilDBToProject() : Deltares.DSoilModel.Data.DSoilModelIO
  • AddProgramSettingsToSettingsDialog() : Deltares.Standard.Forms.DExpress.MainForm
  • AddProperty() : Deltares.Standard.Forms.DExpress.MapEditor , Deltares.Standard.Forms.SpatialEditor
  • AddRaster() : Deltares.Standard.Forms.DExpress.MapEditor
  • AddRectangle() : Deltares.Standard.Forms.SpatialEditor
  • AddRow() : Deltares.Standard.Forms.DExpress.GridViewControl , Deltares.Standard.Forms.DExpress.GridViewController< T > , Deltares.Standard.Forms.IGridController
  • AddRowCommand() : Deltares.Standard.Forms.DExpress.GridViewControl
  • AddShape() : Deltares.Standard.Forms.SpatialEditor
  • AddSoilDataToProject() : Deltares.DSoilModel.Data.DSoilModelProject
  • AddSurfaceLineToCreateNew2DProfile() : Deltares.DSoilModel.Forms.DSoilModelGeometryEditor
  • AddTabPage() : Deltares.Standard.Forms.DExpress.DialogTemplate
  • AddTabPageToAboutDialog() : Deltares.Standard.Forms.DExpress.MainForm
  • AddTabPageToSettingsDialog() : Deltares.Standard.Forms.DExpress.MainForm
  • AddToolBarItem() : Deltares.Standard.Forms.DExpress.GeometryEditor
  • AddToolbarItems() : Deltares.Standard.Forms.DExpress.GeometryEditor
  • AddTriangle() : Deltares.Standard.Forms.SpatialEditor
  • AddUnitsSettingsToSettingsDialog() : Deltares.Standard.Forms.DExpress.MainForm
  • AllowDrop() : Deltares.DSoilModel.Forms.DrawingLayerObsolete , Deltares.DSoilModel.Forms.DrawingSosSoilLayer1D , Deltares.Geometry.Forms.DrawingObject , Deltares.Geotechnics.Forms.DrawingLayer , Deltares.Geotechnics.Forms.DrawingSoilSurface
  • Append() : Deltares.Standard.Forms.DExpress.GridViewControl
  • ApplyCulture() : Deltares.Standard.Forms.DExpress.ReloadManager
  • ApplyCurrentUiCulture() : Deltares.Standard.Forms.DExpress.ReloadManager
  • ApplyCurrentUiCultureToAll() : Deltares.Standard.Forms.DExpress.ReloadManager
  • ApplyDataChangeToAll() : Deltares.Standard.Forms.DExpress.ReloadManager
  • AreAllLayerIdsUnique() : Deltares.Geotechnics.SoilProfile1D
  • Arrow_Symbol3D() : Deltares.Standard.Forms.DrawingSupport
  • Assign() : Deltares.DSoilModel.Data.SosSoilLayer1D , Deltares.Geotechnics.SoilProfile1D , Deltares.Standard.Forms.DExpress.BindSupport , Deltares.Standard.Forms.DExpress.GridViewController< T >
  • AssignProfileToLayers() : Deltares.Geotechnics.SoilProfile1D
Generated on Tue Dec 15 2015 18:15:41 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Class Members - Functions

Tool for the (stochastic) subsoil definition.

- b -

  • BaseMapTool() : Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool
  • BeginUndoAction() : Deltares.Standard.Forms.DExpress.GeometryEditor
  • Bind() : Deltares.Standard.Forms.DExpress.BindSupport
  • Bind2() : Deltares.Standard.Forms.DExpress.BindSupport
  • Bind2< T >() : Deltares.Standard.Forms.DExpress.BindSupport
  • Bind< T >() : Deltares.Standard.Forms.DExpress.BindSupport
  • Bind< T, U >() : Deltares.Standard.Forms.DExpress.BindSupport
  • Bind< T1, T2 >() : Deltares.Standard.Forms.DExpress.BindSupport
  • BindProperties() : Deltares.Standard.Forms.DExpress.BindSupport
  • BindSelection() : Deltares.Standard.Forms.DExpress.BindSupport
  • BindText() : Deltares.Standard.Forms.DExpress.BindSupport
  • BindTextAndValue() : Deltares.Standard.Forms.DExpress.BindSupport
  • BindTextAndValue< T >() : Deltares.Standard.Forms.DExpress.BindSupport
  • BindTextValueAndUnit() : Deltares.Standard.Forms.DExpress.BindSupport
  • BindTextValueAndUnit< T >() : Deltares.Standard.Forms.DExpress.BindSupport
  • BondStressCurveControl() : Deltares.Geotechnics.Forms.BondStressCurveControl
  • BoringControl() : Deltares.Geotechnics.Forms.BoringControl
  • BottomForDrawing() : Deltares.DSoilModel.Forms.DrawingCenterCrestLocation , Deltares.DSoilModel.Forms.DrawingSoilSegmentSplitLocation , Deltares.Geotechnics.Forms.DrawingSpecificMechanismPointLocation
  • Brush3D() : Deltares.Standard.Forms.DrawingSupport
  • BuildDelayedPropertyControlForTypes() : Deltares.Standard.Forms.DExpress.DynamicPropertyControl
  • BuildDelayedPropertyControlsForProperty< T >() : Deltares.Standard.Forms.DExpress.DynamicPropertyControl
  • BuildDelayedPropertyControlsForType() : Deltares.Standard.Forms.DExpress.DynamicPropertyControl
  • BuildPropertyControlTabForTypes() : Deltares.Standard.Forms.DExpress.DynamicPropertyControl
  • BuildPropertyControlTabsForProperty< T >() : Deltares.Standard.Forms.DExpress.DynamicPropertyControl
  • BuildPropertyControlTabsForType() : Deltares.Standard.Forms.DExpress.DynamicPropertyControl , Deltares.Standard.Forms.IDynamicPropertyControl
Generated on Tue Dec 15 2015 18:15:41 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Class Members - Functions

Tool for the (stochastic) subsoil definition.

- c -

  • CalculateExtraHeight() : Deltares.Geotechnics.WaternetCreator.UpliftCalculator
  • CalculateHeadOfPLLine() : Deltares.Geotechnics.WaternetCreator.UpliftCalculator
  • CalculateUpliftFactor() : Deltares.Geotechnics.WaternetCreator.UpliftCalculator
  • CancelAsync() : Deltares.Standard.Web.dinoservices.CptService
  • CancelCommand() : Deltares.Standard.Forms.DExpress.GeometryEditor
  • CanHandle() : Deltares.Geotechnics.IO.SurfaceLineInstanceFactory , Deltares.Geotechnics.IO.SurfaceLineXmlHandler
  • CategoryDisplayItem() : Deltares.Standard.Forms.DExpress.CategoryDisplayItem
  • CenterExtents() : Deltares.Standard.Forms.SpatialEditor
  • ChartToTable() : Deltares.Standard.Forms.DExpress.GeoChartControl
  • CheckHitForSelection() : Deltares.Geometry.Forms.DrawingObject , Deltares.Geometry.Forms.IDrawingObject
  • Circle3D() : Deltares.Standard.Forms.DrawingSupport
  • CirclePolygon3D() : Deltares.Standard.Forms.DrawingSupport
  • Clear() : Deltares.Standard.Application.LogHelper , Deltares.Standard.Forms.DExpress.GeometryEditor , Deltares.Standard.Forms.DExpress.MapEditor , Deltares.Standard.Forms.SpatialEditor
  • ClearAssignObjectOfType() : Deltares.Standard.Forms.DExpress.DynamicTableControl
  • ClearCaches() : Deltares.Standard.Forms.DExpress.BindSupport
  • ClearControl() : Deltares.DSoilModel.Forms.SosSoilProfile1DControl , Deltares.Geotechnics.Forms.SoilProfile1DControl , Deltares.Geotechnics.Forms.SoilProfile2DControl
  • ClearOpenFileHandlers() : Deltares.Standard.Forms.DExpress.MainForm
  • ClearRegistrationsForType() : Deltares.Standard.Forms.DExpress.DynamicPropertyControl
  • ClearSaveFileHandlers() : Deltares.Standard.Forms.DExpress.MainForm
  • ClearSeries() : Deltares.Standard.Forms.DExpress.GeoChartControl
  • ClearWaternet() : Deltares.Geotechnics.WaternetCreator.WaternetCreator
  • Clone() : Deltares.DSoilModel.Data.SosSoilLayer1D , Deltares.Geotechnics.SoilProfile1D
  • ColorMaterial3D() : Deltares.Standard.Forms.DrawingSupport
  • ColumnDescription() : Deltares.Standard.Forms.ColumnDescription
  • ComboBoxDisplayItem() : Deltares.Standard.Forms.DExpress.ComboBoxDisplayItem
  • Compare() : Deltares.Standard.Forms.ShapeComparer
  • CompareTo() : Deltares.Geotechnics.SoilProfile1D , Deltares.Standard.Forms.ShapeInfo
  • ContainsPoint() : Deltares.DSoilModel.Forms.DrawingCenterCrestLocation , Deltares.DSoilModel.Forms.DrawingLayerObsolete , Deltares.DSoilModel.Forms.DrawingSoilSegmentSplitLocation , Deltares.DSoilModel.Forms.DrawingSosSoilLayer1D , Deltares.Geometry.Forms.DrawingLine , Deltares.Geometry.Forms.DrawingObject , Deltares.Geometry.Forms.DrawingPoint , Deltares.Geotechnics.Forms.DrawingBlockRevetmentSegment , Deltares.Geotechnics.Forms.DrawingBoring , Deltares.Geotechnics.Forms.DrawingCharacteristicPoint , Deltares.Geotechnics.Forms.DrawingCPT , Deltares.Geotechnics.Forms.DrawingGeometry , Deltares.Geotechnics.Forms.DrawingLayer , Deltares.Geotechnics.Forms.DrawingPiezometricHead , Deltares.Geotechnics.Forms.DrawingRevetment , Deltares.Geotechnics.Forms.DrawingSoilProfile1D , Deltares.Geotechnics.Forms.DrawingSoilSurface , Deltares.Geotechnics.Forms.DrawingSpecificMechanismPointLocation , Deltares.Geotechnics.Forms.DrawingSwell , Deltares.Geotechnics.Forms.DrawingWaterBasin , Deltares.Geotechnics.Forms.DrawingWaterPolderBasin
  • ConvertToPoints() : Deltares.Standard.Forms.DrawingSupport
  • ConvexPolygon3D() : Deltares.Standard.Forms.DrawingSupport
  • CopyCommand() : Deltares.Standard.Forms.DExpress.GridViewControl
  • CopyShapeInfos() : Deltares.Standard.Forms.SpatialEditor
  • CopytoClipBoard() : Deltares.Standard.Forms.DExpress.GeoChartControl
  • CPTControl() : Deltares.Geotechnics.Forms.CPTControl
  • CptService() : Deltares.Standard.Web.dinoservices.CptService
  • Create() : Deltares.Standard.Application.LogHelper , Deltares.Standard.Forms.DExpress.GeometryEditor
  • Create< T >() : Deltares.Standard.Application.LogHelper
  • CreateAllPLLines() : Deltares.Geotechnics.WaternetCreator.PlLinesCreator
  • CreateAndBindBarItem< T >() : Deltares.Standard.Forms.DExpress.BarItemExtensions
  • CreateAndBindMenuItem< T >() : Deltares.Standard.Forms.DExpress.BarItemExtensions
  • CreateAndRegisterPropertyFormFor< T >() : Deltares.Standard.Forms.DExpress.MainForm
  • CreateAndRegisterUICommand() : Deltares.Standard.Forms.DExpress.GeometryEditor
  • CreateButton() : Deltares.DSoilModel.Forms.DSoilModelMapEditor , Deltares.Standard.Forms.DExpress.GeometryEditor
  • CreateConvexPolygonBox() : Deltares.Standard.Forms.DrawingSupport
  • CreateInstance() : Deltares.Geotechnics.IO.SurfaceLineInstanceFactory
  • CreateParallelCurve() : Deltares.Geotechnics.WaternetCreator.WaternetCreator
  • CreatePLLine1ByExpertKnowledge() : Deltares.Geotechnics.WaternetCreator.PlLinesCreator
  • CreatePLLine2ByExpertKnowledge() : Deltares.Geotechnics.WaternetCreator.PlLinesCreator
  • CreatePLLine3ByExpertKnowledge() : Deltares.Geotechnics.WaternetCreator.PlLinesCreator
  • CreatePLLine3ClayDikeOnSand() : Deltares.Geotechnics.WaternetCreator.PlLinesCreator
  • CreatePLLine4ByExpertKnowledge() : Deltares.Geotechnics.WaternetCreator.PlLinesCreator
  • CreatePLLineByExpertKnowledge() : Deltares.Geotechnics.WaternetCreator.PlLinesCreator
  • CreateRecentlyUsedFilesButton() : Deltares.Standard.Forms.DExpress.MainForm
  • CreateSettingsDialog() : Deltares.Standard.Forms.DExpress.MainForm
  • Cross_Symbol3D() : Deltares.Standard.Forms.DrawingSupport
  • CutCommand() : Deltares.Standard.Forms.DExpress.GridViewControl
Generated on Tue Dec 15 2015 18:15:41 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Class Members - Functions

Tool for the (stochastic) subsoil definition.

- d -

  • DefaultForSelected() : Deltares.Standard.Forms.DExpress.AssignStrategy , Deltares.Standard.Forms.DExpress.DivideStrategy , Deltares.Standard.Forms.DExpress.GreaterThanStrategy , Deltares.Standard.Forms.DExpress.GridEditValueStrategy , Deltares.Standard.Forms.DExpress.LessThanStrategy , Deltares.Standard.Forms.DExpress.MinusStrategy , Deltares.Standard.Forms.DExpress.MultiplyStrategy , Deltares.Standard.Forms.DExpress.PlusStrategy
  • DegreeOfConsolidationMatrixControl() : Deltares.Geotechnics.Forms.DegreeOfConsolidationMatrixControl
  • DeleteAllEventHandlers() : Deltares.Standard.Forms.CommandLineWindow
  • DeleteCoinsidingPoints() : Deltares.Geotechnics.WaternetCreator.LineHelper
  • DeleteFeatureMapTool() : Deltares.Standard.Forms.DExpress.MapTools.DeleteFeatureMapTool
  • deleteMenuItem_Click() : Deltares.Standard.Forms.DExpress.MapTools.DeleteFeatureMapTool
  • DeleteRow() : Deltares.Standard.Forms.DExpress.GridViewControl , Deltares.Standard.Forms.DExpress.GridViewController< T > , Deltares.Standard.Forms.IGridController
  • DeleteRowCommand() : Deltares.Standard.Forms.DExpress.GridViewControl , Deltares.Standard.Forms.DExpress.TreeViewControl
  • DeleteSelectedObjects() : Deltares.Standard.Forms.DExpress.GeometryEditor
  • DeselectAllObjects() : Deltares.Standard.Forms.DExpress.GeometryEditor
  • DesignPointControl() : Deltares.Geotechnics.Forms.DesignPointControl
  • determineAverageSandDiameters() : Deltares.Geotechnics.SoilProfile1D
  • DetermineInfiltrationLayer() : Deltares.Geotechnics.SoilProfile1D
  • DetermineIntersectionBetweenTaludRiverSideAndWaterLevel() : Deltares.Geotechnics.WaternetCreator.PlLinesCreator
  • DetermineIntersectionBetweenWaterLevelAndDike() : Deltares.Geotechnics.WaternetCreator.PlLinesCreator
  • DikeLineControl() : Deltares.Geotechnics.Forms.DikeLineControl
  • DisableAll() : Deltares.Standard.Forms.DExpress.BindSupport
  • DisableAllButtonDownState() : Deltares.Standard.Forms.DExpress.GeometryEditor
  • DisableBasemapLayer() : Deltares.Standard.Forms.DExpress.WebMapPlugin
  • DisplayResults() : Deltares.Standard.Web.Cpt
  • DisplaySelectedObject() : Deltares.Standard.Forms.DExpress.DynamicPropertyControl
  • Dispose() : Deltares.DSoilModel.Data.DSoilModelProject , Deltares.DSoilModel.Forms.CenterCrestLocationPropertyControl , Deltares.DSoilModel.Forms.DSoilModelMapEditor , Deltares.DSoilModel.Forms.DSoilModelSegmentGeometryEditor , Deltares.DSoilModel.Forms.FilmStrip , Deltares.DSoilModel.Forms.ModalListBox , Deltares.DSoilModel.Forms.SoilSegmentSplitLocationControl , Deltares.DSoilModel.Forms.SosSoilLayer1DControl , Deltares.DSoilModel.Forms.SosSoilProfile1DControl , Deltares.Geometry.Forms.GeometryCurveControl , Deltares.Geometry.Forms.GeometryPointControl , Deltares.Geometry.Forms.GeometryStringControl , Deltares.Geotechnics.Forms.AnchorAttachmentControl , Deltares.Geotechnics.Forms.BondStressCurveControl , Deltares.Geotechnics.Forms.BoringControl , Deltares.Geotechnics.Forms.BoringLookupControl , Deltares.Geotechnics.Forms.CPTControl , Deltares.Geotechnics.Forms.CPTLookupControl , Deltares.Geotechnics.Forms.DegreeOfConsolidationDialog , Deltares.Geotechnics.Forms.DegreeOfConsolidationMatrixControl , Deltares.Geotechnics.Forms.DesignPointControl , Deltares.Geotechnics.Forms.DikeLineControl , Deltares.Geotechnics.Forms.GeometryPropertyControl , Deltares.Geotechnics.Forms.HydraulicBoundaryControl , Deltares.Geotechnics.Forms.MaterialEditorDialog , Deltares.Geotechnics.Forms.PreconsolidationStressControl , Deltares.Geotechnics.Forms.ProbabilisticControl , Deltares.Geotechnics.Forms.RevetmentLayerControl , Deltares.Geotechnics.Forms.SchematizedSurfaceLineControl , Deltares.Geotechnics.Forms.SegmentControl , Deltares.Geotechnics.Forms.SettlementCurveControl , Deltares.Geotechnics.Forms.ShearStressCurveControl , Deltares.Geotechnics.Forms.SheetPilingControl , Deltares.Geotechnics.Forms.SoilBondStressCurveControl , Deltares.Geotechnics.Forms.SoilLayer2DControl , Deltares.Geotechnics.Forms.SoilLayerControl , Deltares.Geotechnics.Forms.SoilProfile1DControl , Deltares.Geotechnics.Forms.SoilProfile2DControl , Deltares.Geotechnics.Forms.SoilStressCurveControl , Deltares.Geotechnics.Forms.SoilSurfacePointsControl , Deltares.Geotechnics.Forms.SoilSurfacePropertyControl , Deltares.Geotechnics.Forms.SpecificMechanismPointLocationControl , Deltares.Geotechnics.Forms.StochastControl , Deltares.Geotechnics.Forms.StressCurveControl , Deltares.Geotechnics.Forms.SurfaceLine2Control , Deltares.Geotechnics.Forms.WaterLineControl , Deltares.Geotechnics.Forms.WaternetControl , Deltares.Standard.Forms.CustomConfirmDialog , Deltares.Standard.Forms.DExpress.AboutControl , Deltares.Standard.Forms.DExpress.ActiveWindowReport , Deltares.Standard.Forms.DExpress.ComponentWrappers.GaugeControlBinding , Deltares.Standard.Forms.DExpress.DialogTemplate , Deltares.Standard.Forms.DExpress.DisclaimerDialog , Deltares.Standard.Forms.DExpress.DynamicChartControl , Deltares.Standard.Forms.DExpress.DynamicImageControl , Deltares.Standard.Forms.DExpress.DynamicMessagesControl , Deltares.Standard.Forms.DExpress.DynamicNavigatorControl , Deltares.Standard.Forms.DExpress.DynamicOutputControl , Deltares.Standard.Forms.DExpress.DynamicPropertyControl , Deltares.Standard.Forms.DExpress.DynamicPropertyTabControl< T > , Deltares.Standard.Forms.DExpress.DynamicResourcesControl , Deltares.Standard.Forms.DExpress.DynamicTableControl , Deltares.Standard.Forms.DExpress.Forms.ExportLayersDialog , Deltares.Standard.Forms.DExpress.Forms.FieldMappingControl , Deltares.Standard.Forms.DExpress.ListViewControl , Deltares.Standard.Forms.DExpress.MainForm , Deltares.Standard.Forms.DExpress.MapEditor , Deltares.Standard.Forms.DExpress.MapLayersPropertyControl , Deltares.Standard.Forms.DExpress.MapLegendPropertyControl , Deltares.Standard.Forms.DExpress.PanelAction , Deltares.Standard.Forms.DExpress.PanelLinearConversionValue , Deltares.Standard.Forms.DExpress.PanelTextBooleanValue , Deltares.Standard.Forms.DExpress.PanelTextComboBoxValue , Deltares.Standard.Forms.DExpress.PanelTextLinkValue , Deltares.Standard.Forms.DExpress.PanelTextNumericValue , Deltares.Standard.Forms.DExpress.PanelTextPathValue , Deltares.Standard.Forms.DExpress.PanelTextPopupContainerEdit , Deltares.Standard.Forms.DExpress.PanelTextStringValue , Deltares.Standard.Forms.DExpress.ProgramOptionsControl , Deltares.Standard.Forms.DExpress.ProgressDialog , Deltares.Standard.Forms.DExpress.Project.DescriptionDialog , Deltares.Standard.Forms.DExpress.PropertyControl , Deltares.Standard.Forms.DExpress.ReportControl , Deltares.Standard.Forms.DExpress.ReportDlg , Deltares.Standard.Forms.DExpress.SingleUnitDialog , Deltares.Standard.Forms.DExpress.SpatialEditorProperties , Deltares.Standard.Forms.DExpress.SplashDialog , Deltares.Standard.Forms.DExpress.StatusBar , Deltares.Standard.Forms.DExpress.UnitsDialog , Deltares.Standard.Forms.MatrixViewer , Deltares.Standard.Forms.ProgressBarWithText , Deltares.Standard.Forms.SpatialEditor , Deltares.Standard.Forms.ZoomablePictureBox
  • Distance() : Deltares.Standard.DotSpatialDgs.DotSpatialGeographicAlgorithms
  • DoLateBinding() : Deltares.Standard.Forms.DExpress.Interfaces.ILateBinding
  • DoProgress() : Deltares.Standard.Forms.DExpress.StatusBar
  • Draw() : Deltares.Geometry.Forms.DrawingObject , Deltares.Standard.Forms.InsertShape
  • Draw3D() : Deltares.DSoilModel.Forms.DrawingBoringLayer , Deltares.DSoilModel.Forms.DrawingCenterCrestLocation , Deltares.DSoilModel.Forms.DrawingLayerObsolete , Deltares.DSoilModel.Forms.DrawingSoilSegmentSplitLocation , Deltares.DSoilModel.Forms.DrawingSosSoilLayer1D , Deltares.Geometry.Forms.DrawingBoundingBox , Deltares.Geometry.Forms.DrawingLine , Deltares.Geometry.Forms.DrawingObject , Deltares.Geometry.Forms.DrawingPoint , Deltares.Geometry.Forms.DrawingPointString , Deltares.Geometry.Forms.DrawingSurface , Deltares.Geometry.Forms.IDrawingObject , Deltares.Geotechnics.Forms.DrawingAnchorAttachment , Deltares.Geotechnics.Forms.DrawingBlockRevetmentSegment , Deltares.Geotechnics.Forms.DrawingBoring , Deltares.Geotechnics.Forms.DrawingCharacteristicPoint , Deltares.Geotechnics.Forms.DrawingCPT , Deltares.Geotechnics.Forms.DrawingGeometry , Deltares.Geotechnics.Forms.DrawingLayer , Deltares.Geotechnics.Forms.DrawingPiezometricHead , Deltares.Geotechnics.Forms.DrawingPreConsolidationStress , Deltares.Geotechnics.Forms.DrawingRevetment , Deltares.Geotechnics.Forms.DrawingSettlementCurve , Deltares.Geotechnics.Forms.DrawingSheetPiling , Deltares.Geotechnics.Forms.DrawingSoilLayerSurface , Deltares.Geotechnics.Forms.DrawingSoilProfile1D , Deltares.Geotechnics.Forms.DrawingSoilSurface , Deltares.Geotechnics.Forms.DrawingSpecificMechanismPointLocation , Deltares.Geotechnics.Forms.DrawingSurfaceLine2 , Deltares.Geotechnics.Forms.DrawingSwell , Deltares.Geotechnics.Forms.DrawingWaterBasin , Deltares.Geotechnics.Forms.DrawingWaterLevel , Deltares.Geotechnics.Forms.DrawingWaternetPointString , Deltares.Geotechnics.Forms.DrawingWaterPolderBasin
  • DrawingPreConsolidationStress() : Deltares.Geotechnics.Forms.DrawingPreConsolidationStress
  • DrawingSosSoilLayer1D() : Deltares.DSoilModel.Forms.DrawingSosSoilLayer1D
  • DrawLabel() : Deltares.DSoilModel.Forms.DrawingCenterCrestLocation , Deltares.DSoilModel.Forms.DrawingLayerObsolete , Deltares.DSoilModel.Forms.DrawingSoilSegmentSplitLocation , Deltares.DSoilModel.Forms.DrawingSosSoilLayer1D , Deltares.Geometry.Forms.DrawingLine , Deltares.Geometry.Forms.DrawingObject , Deltares.Geometry.Forms.DrawingPoint , Deltares.Geometry.Forms.DrawingPointString , Deltares.Geotechnics.Forms.DrawingBlockRevetmentSegment , Deltares.Geotechnics.Forms.DrawingCharacteristicPoint , Deltares.Geotechnics.Forms.DrawingCPT , Deltares.Geotechnics.Forms.DrawingGeometry , Deltares.Geotechnics.Forms.DrawingLayer , Deltares.Geotechnics.Forms.DrawingLocalisedGeometryPointString , Deltares.Geotechnics.Forms.DrawingPiezometricHead , Deltares.Geotechnics.Forms.DrawingPreConsolidationStress , Deltares.Geotechnics.Forms.DrawingRevetment , Deltares.Geotechnics.Forms.DrawingSoilSurface , Deltares.Geotechnics.Forms.DrawingSpecificMechanismPointLocation , Deltares.Geotechnics.Forms.DrawingSurfaceLine2 , Deltares.Geotechnics.Forms.DrawingSwell , Deltares.Geotechnics.Forms.DrawingWaterBasin , Deltares.Geotechnics.Forms.DrawingWaterLevel , Deltares.Geotechnics.Forms.DrawingWaternetLine , Deltares.Geotechnics.Forms.DrawingWaternetPointString , Deltares.Geotechnics.Forms.DrawingWaterPolderBasin
  • DrawLabelAtPoint() : Deltares.Standard.Forms.DrawingSupport
  • DrawLegend() : Deltares.Standard.Forms.DrawingSupport
  • DrawPointSelector() : Deltares.Standard.Forms.DrawingSupport
  • DrawSelector() : Deltares.Standard.Forms.DrawingSupport
  • Drop() : Deltares.DSoilModel.Forms.DrawingLayerObsolete , Deltares.DSoilModel.Forms.DrawingSosSoilLayer1D , Deltares.Geometry.Forms.DrawingObject , Deltares.Geotechnics.Forms.DrawingLayer , Deltares.Geotechnics.Forms.DrawingSoilSurface
  • DSoilModelGeometryEditor() : Deltares.DSoilModel.Forms.DSoilModelGeometryEditor
  • DSoilModelMapEditor() : Deltares.DSoilModel.Forms.DSoilModelMapEditor
  • DSoilModelSegmentGeometryEditor() : Deltares.DSoilModel.Forms.DSoilModelSegmentGeometryEditor
  • DynamicPropertyControl() : Deltares.Standard.Forms.DExpress.DynamicPropertyControl
  • DynamicPropertyTabControl() : Deltares.Standard.Forms.DExpress.DynamicPropertyTabControl< T >
Generated on Tue Dec 15 2015 18:15:41 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Class Members - Functions

Tool for the (stochastic) subsoil definition.

- e -

  • EditCommand() : Deltares.Standard.Forms.DExpress.GridViewControl
  • EnableAll() : Deltares.Standard.Forms.DExpress.BindSupport
  • EnsureLastLayerHasHeight() : Deltares.Geotechnics.SoilProfile1D
  • EnsurePointAtX() : Deltares.Geotechnics.WaternetCreator.LineHelper
  • EnsureUniqueLayerIds() : Deltares.Geotechnics.SoilProfile1D
  • EnsureWaterLevelIsAboveRiverBottom() : Deltares.Geotechnics.WaternetCreator.PlLinesCreator
  • Evaluate() : Deltares.Standard.Forms.DExpress.AssignStrategy , Deltares.Standard.Forms.DExpress.DivideStrategy , Deltares.Standard.Forms.DExpress.GreaterThanStrategy , Deltares.Standard.Forms.DExpress.GridEditValueStrategy , Deltares.Standard.Forms.DExpress.LessThanStrategy , Deltares.Standard.Forms.DExpress.MinusStrategy , Deltares.Standard.Forms.DExpress.MultiplyStrategy , Deltares.Standard.Forms.DExpress.PlusStrategy
  • EvaluateForSelected() : Deltares.Standard.Forms.DExpress.GridEditValueStrategy
  • Execute() : Deltares.Standard.Forms.IController
  • ExportTo() : Deltares.Standard.Forms.DExpress.GeoChartControl
Generated on Tue Dec 15 2015 18:15:41 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Class Members - Functions

Tool for the (stochastic) subsoil definition.

- f -

  • FillFromGefFile() : Deltares.Geotechnics.IO.Importers.GefBoringFileImporter , Deltares.Geotechnics.IO.Importers.GefCptFileImporter
  • FillFromGefString() : Deltares.Geotechnics.IO.Importers.GefBoringFileImporter , Deltares.Geotechnics.IO.Importers.GefCptFileImporter
  • FilmStrip() : Deltares.DSoilModel.Forms.FilmStrip
  • findCPT() : Deltares.Standard.Web.dinoservices.CptService
  • findCPTAsync() : Deltares.Standard.Web.dinoservices.CptService
  • findCPTWithCriteria() : Deltares.Standard.Web.dinoservices.CptService
  • findCPTWithCriteriaAsync() : Deltares.Standard.Web.dinoservices.CptService
  • Flush() : Deltares.Standard.Application.LogHelper
  • FocusData() : Deltares.Standard.Forms.DExpress.GeoPropertyGrid
  • Font3D() : Deltares.Standard.Forms.DrawingSupport
Generated on Tue Dec 15 2015 18:15:41 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Class Members - Functions

Tool for the (stochastic) subsoil definition.

- g -

  • GeometryEditor() : Deltares.Standard.Forms.DExpress.GeometryEditor
  • GeometryEditor_MouseLeave() : Deltares.Standard.Forms.DExpress.GeometryEditor
  • Get3dTopPoint() : Deltares.Standard.Forms.DExpress.GeometryEditor
  • GetActionsSortedByPropertyOrderAttribute() : Deltares.Standard.Forms.DExpress.BindSupport
  • GetActiveMapProjectionAsDotSpatial() : Deltares.Standard.DotSpatialDgs.MapProjectionManager
  • GetAquiferLayers() : Deltares.Geotechnics.SoilProfile1D
  • GetAssignedObject() : Deltares.Standard.Forms.DExpress.BindSupport
  • GetBackgroundLayer() : Deltares.Standard.Forms.DExpress.MapEditor
  • GetBackgroundMap() : Deltares.Standard.DotSpatialDgs.FeatureSupport
  • GetBorings() : Deltares.DSoilModel.Data.DSoilModelProject
  • GetBoringXmlFromGefBoringFile() : Deltares.Geotechnics.IO.Importers.DGSGEFInterface
  • GetBoringXmlFromGefBoringString() : Deltares.Geotechnics.IO.Importers.DGSGEFInterface
  • GetBottomLevel() : Deltares.Geotechnics.SoilProfile1D
  • GetChildComponents() : Deltares.Standard.Forms.DExpress.Interfaces.IHasBindableChildren
  • GetChildren() : Deltares.Standard.Forms.IViewConfiguration
  • GetColor() : Deltares.Geotechnics.Forms.DrawingSwell , Deltares.Standard.Forms.DrawingSupport
  • GetColumnDescription() : Deltares.Standard.Forms.IViewConfiguration
  • GetColumns() : Deltares.Standard.Forms.IViewConfiguration
  • GetContainedProperties() : Deltares.Standard.Forms.DExpress.BindSupport
  • GetControl() : Deltares.Standard.Forms.DExpress.GridViewControl
  • GetCpts() : Deltares.DSoilModel.Data.DSoilModelProject
  • GetCptXmlFromGefCptFile() : Deltares.Geotechnics.IO.Importers.DGSGEFInterface
  • GetCptXmlFromGefCptString() : Deltares.Geotechnics.IO.Importers.DGSGEFInterface
  • GetCurrentDraw3DInterface() : Deltares.Standard.Forms.DrawingSupport
  • GetDarkerColor() : Deltares.Standard.Forms.DrawingSupport
  • GetDataObject() : Deltares.DSoilModel.Forms.DrawingBoringLayer , Deltares.DSoilModel.Forms.DrawingCenterCrestLocation , Deltares.DSoilModel.Forms.DrawingLayerObsolete , Deltares.DSoilModel.Forms.DrawingSoilSegmentSplitLocation , Deltares.DSoilModel.Forms.DrawingSosSoilLayer1D , Deltares.Geometry.Forms.DrawingBoundingBox , Deltares.Geometry.Forms.DrawingLine , Deltares.Geometry.Forms.DrawingObject , Deltares.Geometry.Forms.DrawingPoint , Deltares.Geometry.Forms.DrawingPointString , Deltares.Geometry.Forms.DrawingSurface , Deltares.Geometry.Forms.IDrawingObject , Deltares.Geotechnics.Forms.DrawingAnchorAttachment , Deltares.Geotechnics.Forms.DrawingBlockRevetmentSegment , Deltares.Geotechnics.Forms.DrawingBoring , Deltares.Geotechnics.Forms.DrawingCharacteristicPoint , Deltares.Geotechnics.Forms.DrawingCPT , Deltares.Geotechnics.Forms.DrawingGeometry , Deltares.Geotechnics.Forms.DrawingLayer , Deltares.Geotechnics.Forms.DrawingPiezometricHead , Deltares.Geotechnics.Forms.DrawingRevetment , Deltares.Geotechnics.Forms.DrawingSettlementCurve , Deltares.Geotechnics.Forms.DrawingSheetPiling , Deltares.Geotechnics.Forms.DrawingSoilProfile1D , Deltares.Geotechnics.Forms.DrawingSoilSurface , Deltares.Geotechnics.Forms.DrawingSpecificMechanismPointLocation , Deltares.Geotechnics.Forms.DrawingSurfaceLine2 , Deltares.Geotechnics.Forms.DrawingSwell , Deltares.Geotechnics.Forms.DrawingWaterBasin , Deltares.Geotechnics.Forms.DrawingWaterLevel , Deltares.Geotechnics.Forms.DrawingWaterPolderBasin
  • GetDikeToeInward() : Deltares.Geotechnics.WaternetCreator.PlLinesCreator
  • GetDllVersion() : Deltares.Geotechnics.IO.Importers.DGSGEFInterface , Deltares.Geotechnics.IO.Importers.DGSStandardDLLInterface
  • GetDomain() : Deltares.DSoilModel.Data.DSoilModelProject , Deltares.Geotechnics.SoilProfile1D
  • GetExtents() : Deltares.DSoilModel.Forms.DrawingCenterCrestLocation , Deltares.DSoilModel.Forms.DrawingLayerObsolete , Deltares.DSoilModel.Forms.DrawingSoilSegmentSplitLocation , Deltares.DSoilModel.Forms.DrawingSosSoilLayer1D , Deltares.Geometry.Forms.DrawingBoundingBox , Deltares.Geometry.Forms.DrawingObject , Deltares.Geotechnics.Forms.DrawingBoring , Deltares.Geotechnics.Forms.DrawingCharacteristicPoint , Deltares.Geotechnics.Forms.DrawingCPT , Deltares.Geotechnics.Forms.DrawingLayer , Deltares.Geotechnics.Forms.DrawingPreConsolidationStress , Deltares.Geotechnics.Forms.DrawingSoilProfile1D , Deltares.Geotechnics.Forms.DrawingSpecificMechanismPointLocation
  • GetFeature() : Deltares.Standard.Forms.DExpress.MyMapLineLayer , Deltares.Standard.Forms.DExpress.MyMapPointLayer , Deltares.Standard.Forms.DExpress.MyMapPolygonLayer
  • getGEF() : Deltares.Standard.Web.dinoservices.CptService
  • GetGEFAsString() : Deltares.Standard.Web.CptServiceAgent
  • getGEFAsync() : Deltares.Standard.Web.dinoservices.CptService
  • GetHelpLocation() : Deltares.Standard.Forms.DExpress.BindSupport , Deltares.Standard.Forms.DExpress.BindSupportAsHelpLocationProvider , Deltares.Standard.Forms.DExpress.Interfaces.IHelpLocationProvider
  • GetHoveredShapes() : Deltares.Standard.Forms.SpatialEditor
  • GetImage() : Deltares.Standard.Forms.SpatialEditor
  • GetIntersectPoint() : Deltares.Geotechnics.WaternetCreator.LineHelper
  • GetLabelTextHeigt() : Deltares.Standard.Forms.DrawingSupport
  • GetLabelTextWidth() : Deltares.Standard.Forms.DrawingSupport
  • GetLayerAbove() : Deltares.Geotechnics.SoilProfile1D
  • GetLayerAt() : Deltares.Geotechnics.SoilProfile1D
  • GetLayerBelow() : Deltares.Geotechnics.SoilProfile1D
  • GetLayerByInsetOffset() : Deltares.Geotechnics.SoilProfile1D
  • GetLayerHeight() : Deltares.Geotechnics.SoilProfile1D
  • GetLayerIndexAt() : Deltares.Geotechnics.SoilProfile1D
  • GetLayerIndexAtCoordinate() : Deltares.Geotechnics.SoilProfile1D
  • GetLayerWithId() : Deltares.Geotechnics.SoilProfile1D
  • GetLighterColor() : Deltares.Standard.Forms.DrawingSupport
  • GetLocalUserDeltaresDirectoryPath() : Deltares.Standard.Forms.DExpress.MainForm
  • GetMainBar() : Deltares.Standard.Forms.DExpress.GeometryEditor
  • GetMainBarManager() : Deltares.Standard.Forms.DExpress.GeometryEditor
  • GetMapProjectionAsDotSpatial() : Deltares.Standard.DotSpatialDgs.MapProjectionManager
  • GetMousePosition() : Deltares.Standard.Forms.SpatialEditor
  • GetNearestGeographicString() : Deltares.Standard.DotSpatialDgs.DotSpatialGeographicHelper
  • GetNewUniqueLayerId() : Deltares.Geotechnics.SoilProfile1D
  • GetNextCurve() : Deltares.Geotechnics.WaternetCreator.WaternetCreator
  • GetOffsetOnGeographicLineString() : Deltares.Standard.DotSpatialDgs.DotSpatialGeographicHelper
  • GetOppositeColor() : Deltares.Standard.Forms.DrawingSupport
  • GetOwner() : Deltares.Standard.Forms.DExpress.BindSupport
  • GetParentOfType() : Deltares.Standard.Forms.DExpress.FormsSupport
  • GetPoint() : Deltares.Standard.Forms.DExpress.MapEditor
  • GetPointAtX() : Deltares.Geotechnics.WaternetCreator.LineHelper
  • GetPoints() : Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter
  • GetPointSegmentBetween() : Deltares.Geotechnics.WaternetCreator.LineHelper
  • GetPopupControl() : Deltares.Standard.Forms.DExpress.BindSupport
  • GetPopupMenu() : Deltares.Standard.Forms.DExpress.BaseControlBinding
  • GetProfiles() : Deltares.DSoilModel.Data.DSoilModelProject
  • GetProjectFileName() : Deltares.Standard.Forms.DExpress.MainForm
  • GetPropertiesSortedByPropertyOrderAttribute() : Deltares.Standard.Forms.DExpress.BindSupport
  • GetPropertyControl() : Deltares.Standard.Forms.DExpress.PropertyControlFactory< T >
  • GetPropertyControlForType() : Deltares.Standard.Forms.DExpress.PropertyControlFactory< T >
  • GetPropertyControlUsingCustomSelector() : Deltares.Standard.Forms.DExpress.PropertyControlFactory< T >
  • GetPropertyInfo< TSource >() : Deltares.Standard.Forms.DExpress.BindSupport
  • GetScaled3DPoint() : Deltares.Geometry.Forms.DrawingObject , Deltares.Geometry.Forms.IDrawingObject , Deltares.Standard.Forms.DrawingSupport
  • GetScaledXPoint() : Deltares.Geometry.Forms.DrawingObject , Deltares.Geometry.Forms.IDrawingObject
  • GetScreenPoint() : Deltares.Geometry.Forms.DrawingObject
  • GetSelectedShapes() : Deltares.Standard.Forms.SpatialEditor
  • GetShape() : Deltares.Standard.Forms.SpatialEditor
  • GetShapeFileProjection() : Deltares.Standard.DotSpatialDgs.DotSpatialUtil
  • GetShapeInfo() : Deltares.Standard.Forms.SpatialEditor
  • GetSnapObject() : Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool
  • GetSnapPointCoordinates() : Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool
  • GetSnapPointMouse() : Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool
  • GetSnapPointSplitSegment() : Deltares.DSoilModel.Forms.DSoilModelMapEditor
  • GetStandardSize() : Deltares.Standard.Forms.DrawingSupport
  • GetString() : Deltares.Standard.Forms.DExpress.MapEditor
  • GetSurfaceLines() : Deltares.DSoilModel.Data.DSoilModelProject
  • GetText() : Deltares.Standard.Forms.DExpress.LocalizationSupport
  • GetTextWidth() : Deltares.Standard.Forms.DrawingSupport
  • GetThickness() : Deltares.Geometry.Forms.DrawingObject
  • GetTopLevelOfHighestAquifer() : Deltares.Geotechnics.SoilProfile1D
  • GetTotalPressure() : Deltares.Geotechnics.SoilProfile1D
  • GetUpliftOutputValuesPl3() : Deltares.Geotechnics.WaternetCreator.PlLinesCreator , Deltares.Geotechnics.WaternetCreator.WaternetCreator
  • GetUpliftOutputValuesPl4() : Deltares.Geotechnics.WaternetCreator.PlLinesCreator , Deltares.Geotechnics.WaternetCreator.WaternetCreator
  • GetValue() : Deltares.Standard.Forms.DExpress.PopupContainerEditBinding
  • GetWorldPoint() : Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool
  • GridViewCellChangeArgs() : Deltares.Standard.Forms.GridViewCellChangeArgs
  • GridViewChangeArgs() : Deltares.Standard.Forms.GridViewChangeArgs
  • GridViewControl() : Deltares.Standard.Forms.DExpress.GridViewControl
  • GridViewController() : Deltares.Standard.Forms.DExpress.GridViewController< T >
Generated on Tue Dec 15 2015 18:15:41 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Class Members - Functions

Tool for the (stochastic) subsoil definition.

- h -

  • Handle() : Deltares.Geotechnics.IO.SurfaceLineXmlHandler
  • HandleFocusCommandLineWindow() : Deltares.Standard.Forms.CommandLineWindow
  • HandleObject() : Deltares.Geotechnics.IO.SurfaceLineXmlHandler
  • HasInvalidThicknessLayers() : Deltares.Geotechnics.SoilProfile1D
  • HasLayersWithoutSoil() : Deltares.Geotechnics.SoilProfile1D
  • HydraulicBoundaryControl() : Deltares.Geotechnics.Forms.HydraulicBoundaryControl
Generated on Tue Dec 15 2015 18:15:41 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Class Members - Functions

Tool for the (stochastic) subsoil definition.

- i -

  • Import() : Deltares.Geotechnics.IO.Importers.FetchesImporter , Deltares.Geotechnics.IO.Importers.SoilProfilesImporter , Deltares.Standard.Forms.DExpress.AbstractShapeFileImporter
  • ImportShape() : Deltares.Standard.Forms.DotSpatial.IShapeImporter , Deltares.Standard.Forms.DotSpatial.LineStringImporter , Deltares.Standard.Forms.DotSpatial.PointImporter
  • ImportShapeGeometry() : Deltares.Standard.Forms.DExpress.IShapeImporter , Deltares.Standard.Forms.DExpress.ShapeImporters.LineStringImporter , Deltares.Standard.Forms.DExpress.ShapeImporters.MultiLineStringImporter , Deltares.Standard.Forms.DExpress.ShapeImporters.MultiPolygonImporter , Deltares.Standard.Forms.DExpress.ShapeImporters.PointImporter , Deltares.Standard.Forms.DExpress.ShapeImporters.PolygonImporter , Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter , Deltares.Standard.Forms.DExpress.ShapeImporters.SmartLineStringImporter
  • Initialize() : Deltares.Standard.Application.ProgramBase , Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool , Deltares.Standard.Forms.DExpress.PopupContainerEditBinding
  • InitializeUIBeforeNewAndOpen() : Deltares.Standard.Forms.DExpress.MainForm
  • InsertRow() : Deltares.Standard.Forms.DExpress.GridViewControl , Deltares.Standard.Forms.DExpress.GridViewController< T > , Deltares.Standard.Forms.IGridController
  • InsertRowCommand() : Deltares.Standard.Forms.DExpress.GridViewControl
  • InsertSpecificMechanismPointLocation() : Deltares.DSoilModel.Forms.DSoilModelGeometryEditor
  • Intersection() : Deltares.Standard.DotSpatialDgs.DotSpatialGeographicAlgorithms , Deltares.Standard.DotSpatialDgs.DotSpatialUtil
  • IntersectionPoint() : Deltares.Geotechnics.WaternetCreator.LineHelper
  • Intersects() : Deltares.Standard.DotSpatialDgs.DotSpatialGeographicAlgorithms
  • IsAssociatedPropertyVisible() : Deltares.Standard.Forms.DExpress.ComponentBinding
  • IsBound() : Deltares.Standard.Forms.DExpress.BindSupport
  • IsChecked() : Deltares.Standard.Forms.IController
  • IsEnabled() : Deltares.DSoilModel.Forms.DSoilModelMapEditor , Deltares.DSoilModel.Forms.DSoilModelSegmentGeometryEditor , Deltares.Geotechnics.SoilProfile1D , Deltares.Standard.Forms.DExpress.GeometryEditor , Deltares.Standard.Forms.DExpress.GridViewControl , Deltares.Standard.Forms.DExpress.MainForm , Deltares.Standard.Forms.DExpress.MapEditor , Deltares.Standard.Forms.DExpress.TreeViewControl , Deltares.Standard.Forms.IController , Deltares.Standard.Forms.ShapeInfo
  • IsLabelVisible() : Deltares.Standard.Forms.ShapeInfo
  • IsLayerVisible() : Deltares.Standard.Forms.DExpress.MapEditor
  • IsStrictlyDescending() : Deltares.Geotechnics.SoilProfile1D
  • IsValidObject() : Deltares.Standard.Forms.DExpress.GeoPropertyGrid
  • IsVisible() : Deltares.DSoilModel.Forms.DSoilModelMapEditor , Deltares.DSoilModel.Forms.DSoilModelSegmentGeometryEditor , Deltares.Geotechnics.SoilProfile1D , Deltares.Standard.Forms.DExpress.GeometryEditor , Deltares.Standard.Forms.DExpress.GridViewControl , Deltares.Standard.Forms.DExpress.MainForm , Deltares.Standard.Forms.DExpress.MapEditor , Deltares.Standard.Forms.DExpress.TreeViewControl , Deltares.Standard.Forms.IController , Deltares.Standard.Forms.ShapeInfo
  • IsXAscending() : Deltares.Geotechnics.WaternetCreator.LineHelper
Generated on Tue Dec 15 2015 18:15:41 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Class Members - Functions

Tool for the (stochastic) subsoil definition.

- l -

  • Line3D() : Deltares.Standard.Forms.DrawingSupport
  • Line_Symbol3D() : Deltares.Standard.Forms.DrawingSupport
  • LineLoop3D() : Deltares.Standard.Forms.DrawingSupport
  • LineStringImporter() : Deltares.Standard.Forms.DExpress.ShapeImporters.LineStringImporter
  • LineStringLength() : Deltares.Standard.DotSpatialDgs.DotSpatialGeographicAlgorithms
  • LoadDefaultLayoutXML() : Deltares.Standard.Forms.DExpress.MainForm
  • LogDebug() : Deltares.Standard.Application.LogHelper
  • LogError() : Deltares.Standard.Application.LogHelper
  • LogFatal() : Deltares.Standard.Application.LogHelper
  • LogInfo() : Deltares.Standard.Application.LogHelper
  • LogWarning() : Deltares.Standard.Application.LogHelper
Generated on Tue Dec 15 2015 18:15:41 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Class Members - Functions

Tool for the (stochastic) subsoil definition.

- m -

  • MainForm() : Deltares.Standard.Forms.DExpress.MainForm
  • MakeProportional() : Deltares.Standard.Forms.SpatialEditor
  • MakeTreeVisible() : Deltares.Standard.Forms.DExpress.FormsSupport
  • MapControl_MouseDown() : Deltares.Standard.Forms.DExpress.MapEditor , Deltares.Standard.Forms.DExpress.MapTools.AddFeatureMapTool , Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool , Deltares.Standard.Forms.DExpress.MapTools.ConnectFeaturesMapTool , Deltares.Standard.Forms.DExpress.MapTools.IMapTool , Deltares.Standard.Forms.DExpress.MapTools.MoveFeatureMapTool , Deltares.Standard.Forms.DExpress.MapTools.RectangleZoomMapTool , Deltares.Standard.Forms.DExpress.MapTools.SelectFeatureMapTool
  • MapControl_MouseMove() : Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool , Deltares.Standard.Forms.DExpress.MapTools.ConnectFeaturesMapTool , Deltares.Standard.Forms.DExpress.MapTools.IMapTool , Deltares.Standard.Forms.DExpress.MapTools.MoveFeatureMapTool , Deltares.Standard.Forms.DExpress.MapTools.RectangleZoomMapTool , Deltares.Standard.Forms.DExpress.MapTools.SelectFeatureMapTool
  • MapControl_MouseUp() : Deltares.Standard.Forms.DExpress.MapEditor , Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool , Deltares.Standard.Forms.DExpress.MapTools.ConnectFeaturesMapTool , Deltares.Standard.Forms.DExpress.MapTools.DeleteFeatureMapTool , Deltares.Standard.Forms.DExpress.MapTools.IMapTool , Deltares.Standard.Forms.DExpress.MapTools.MoveFeatureMapTool , Deltares.Standard.Forms.DExpress.MapTools.RectangleZoomMapTool , Deltares.Standard.Forms.DExpress.MapTools.SelectFeatureMapTool
  • MapControl_MouseWheel() : Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool , Deltares.Standard.Forms.DExpress.MapTools.IMapTool
  • MapControl_Paint() : Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool , Deltares.Standard.Forms.DExpress.MapTools.ConnectFeaturesMapTool , Deltares.Standard.Forms.DExpress.MapTools.IMapTool , Deltares.Standard.Forms.DExpress.MapTools.MoveFeatureMapTool , Deltares.Standard.Forms.DExpress.MapTools.RectangleZoomMapTool , Deltares.Standard.Forms.DExpress.MapTools.SelectFeatureMapTool
  • MapEditor() : Deltares.Standard.Forms.DExpress.MapEditor
  • MapLayerDefinition() : Deltares.Standard.Forms.DExpress.MapLayerDefinition
  • Material3D() : Deltares.Standard.Forms.DrawingSupport
  • ModalListBox() : Deltares.DSoilModel.Forms.ModalListBox
  • MoveToFront() : Deltares.Standard.Forms.DExpress.MapEditor
  • MRUFileOpen() : Deltares.Standard.Forms.DExpress.MainForm
  • MyMapLineLayer() : Deltares.Standard.Forms.DExpress.MyMapLineLayer
  • MyMapPointLayer() : Deltares.Standard.Forms.DExpress.MyMapPointLayer
  • MyMapPolygonLayer() : Deltares.Standard.Forms.DExpress.MyMapPolygonLayer
Generated on Tue Dec 15 2015 18:15:41 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Class Members - Functions

Tool for the (stochastic) subsoil definition.

- n -

  • NaiveCamelCaseToSpacedName() : Deltares.Standard.Forms.SpatialEditor
  • NearestPointOnGeographicString() : Deltares.Standard.DotSpatialDgs.DotSpatialGeographicAlgorithms
Generated on Tue Dec 15 2015 18:15:41 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Class Members - Functions

Tool for the (stochastic) subsoil definition.

- o -

  • OnAfterRowAdd() : Deltares.Standard.Forms.DExpress.GridViewController< T >
  • OnAfterRowDelete() : Deltares.Standard.Forms.DExpress.GridViewController< T >
  • OnAfterRowInsert() : Deltares.Standard.Forms.DExpress.GridViewController< T >
  • OnAfterRowUpdate() : Deltares.Standard.Forms.DExpress.GridViewController< T >
  • OnBeginDrag() : Deltares.DSoilModel.Forms.DrawingCenterCrestLocation , Deltares.DSoilModel.Forms.DrawingSoilSegmentSplitLocation , Deltares.Geometry.Forms.DrawingLine , Deltares.Geometry.Forms.DrawingObject , Deltares.Geometry.Forms.DrawingPoint , Deltares.Geometry.Forms.IDrawingObject , Deltares.Geotechnics.Forms.DrawingAnchorAttachment , Deltares.Geotechnics.Forms.DrawingBoring , Deltares.Geotechnics.Forms.DrawingCPT , Deltares.Geotechnics.Forms.DrawingGeometry , Deltares.Geotechnics.Forms.DrawingRevetment , Deltares.Geotechnics.Forms.DrawingSheetPiling , Deltares.Geotechnics.Forms.DrawingSoilLayerSurface , Deltares.Geotechnics.Forms.DrawingSoilProfile1D , Deltares.Geotechnics.Forms.DrawingSoilSurface , Deltares.Geotechnics.Forms.DrawingSpecificMechanismPointLocation
  • OnClickMStabGraphicInputBarSelectionItem() : Deltares.Standard.Forms.DExpress.GeometryEditor
  • OnDragging() : Deltares.Geometry.Forms.DrawingObject , Deltares.Geometry.Forms.IDrawingObject , Deltares.Geotechnics.Forms.DrawingRevetment
  • OnEndDrag() : Deltares.DSoilModel.Forms.DrawingCenterCrestLocation , Deltares.DSoilModel.Forms.DrawingSoilSegmentSplitLocation , Deltares.Geometry.Forms.DrawingObject , Deltares.Geometry.Forms.DrawingPoint , Deltares.Geometry.Forms.IDrawingObject , Deltares.Geotechnics.Forms.DrawingAnchorAttachment , Deltares.Geotechnics.Forms.DrawingBoring , Deltares.Geotechnics.Forms.DrawingCPT , Deltares.Geotechnics.Forms.DrawingSheetPiling , Deltares.Geotechnics.Forms.DrawingSoilLayerSurface , Deltares.Geotechnics.Forms.DrawingSoilProfile1D , Deltares.Geotechnics.Forms.DrawingSpecificMechanismPointLocation
  • OnLoadPropertyControl() : Deltares.Standard.Forms.DExpress.GeoPropertyGrid
  • OnPrint() : Deltares.Standard.Forms.DExpress.GeoChartControl
  • OnShapeAction() : Deltares.Standard.Forms.DExpress.GeometryEditor
  • OnToolTipClosed() : Deltares.Standard.Forms.DExpress.BaseControlBinding , Deltares.Standard.Forms.DExpress.ControlBinding
  • OnToolTipShown() : Deltares.Standard.Forms.DExpress.BaseControlBinding , Deltares.Standard.Forms.DExpress.ControlBinding
  • OpenHelp() : Deltares.Standard.Forms.DExpress.HelpLocationShower , Deltares.Standard.Forms.DExpress.Interfaces.IHelpFileManager , Deltares.Standard.Forms.DExpress.PdfHelpFileManager
  • OpenSoilDatabase() : Deltares.DSoilModel.Data.DSoilModelIO
  • OpenXML() : Deltares.DSoilModel.Data.DSoilModelIO
  • OrderCurves() : Deltares.Geotechnics.WaternetCreator.WaternetCreator
  • OrderLayersByDescending() : Deltares.Geotechnics.SoilProfile1D
Generated on Tue Dec 15 2015 18:15:41 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Class Members - Functions

Tool for the (stochastic) subsoil definition.

- p -

  • PageLoad() : Deltares.Standard.Web.PageSupport
  • ParseDouble() : Deltares.Standard.Forms.DExpress.GridViewControl
  • PasteCommand() : Deltares.Standard.Forms.DExpress.GridViewControl
  • PdfHelpFileManager() : Deltares.Standard.Forms.DExpress.PdfHelpFileManager
  • Pen3D() : Deltares.Standard.Forms.DrawingSupport
  • PlLinesCreator() : Deltares.Geotechnics.WaternetCreator.PlLinesCreator
  • PointImporter() : Deltares.Standard.Forms.DExpress.ShapeImporters.PointImporter
  • PolygonImporter() : Deltares.Standard.Forms.DExpress.ShapeImporters.PolygonImporter
  • PopulateDataTable() : Deltares.Standard.Forms.DExpress.GeoChartControl
  • PopulateMRUList() : Deltares.Standard.Forms.DExpress.MainForm
  • PositionXzOfPointRelatedToPLLine() : Deltares.Geotechnics.WaternetCreator.LineHelper
  • ProbabilisticControl() : Deltares.Geotechnics.Forms.ProbabilisticControl
  • ProgressDialog() : Deltares.Standard.Forms.DExpress.ProgressDialog
  • ProjectIsSaved() : Deltares.Standard.Forms.DExpress.MainForm
Generated on Tue Dec 15 2015 18:15:41 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Class Members - Functions

Tool for the (stochastic) subsoil definition.

- r -

  • RaiseBeginValidationOrSave() : Deltares.Standard.Forms.DExpress.MainForm
  • Read() : Deltares.Geotechnics.IO.Importers.CharacteristicPointsImporter
  • ReadBoring() : Deltares.Geotechnics.IO.Importers.GEFXmlImporter
  • ReadCPT() : Deltares.Geotechnics.IO.Importers.GEFXmlImporter
  • ReadCsvCharacteristicPointsFromFileAndAddToProject() : Deltares.DSoilModel.Data.DSoilModelIO
  • ReadCsvSegmentsFromFileAndAddToProject() : Deltares.DSoilModel.Data.DSoilModelIO
  • ReadCsvSurfaceLineFromFileAndAddToProject() : Deltares.DSoilModel.Data.DSoilModelIO
  • ReadDamDefinitionsFromFileAndAddToProject() : Deltares.DSoilModel.Data.DSoilModelIO
  • ReadGefBoringFromFile() : Deltares.DSoilModel.Data.DSoilModelProject
  • ReadGefCptFromFile() : Deltares.DSoilModel.Data.DSoilModelProject
  • ReadGeometryFromFile() : Deltares.DSoilModel.Data.DSoilModelProject
  • ReadOldProjectFromDatabase() : Deltares.DSoilModel.Data.DSoilModelProject
  • ReadSoilProfile1D() : Deltares.Geotechnics.IO.Importers.GEFXmlImporter
  • ReadSoilProfiles() : Deltares.DSoilModel.Data.SosSoilProfilesImporter , Deltares.Geotechnics.IO.Importers.SoilProfilesImporter
  • ReadSoilProfiles1DFromFile() : Deltares.DSoilModel.Data.DSoilModelProject
  • ReadSoils() : Deltares.Geotechnics.IO.Importers.GEFXmlImporter
  • ReadSoilsFromDatabase() : Deltares.DSoilModel.Data.DSoilModelProject
  • ReadSurfacesLines() : Deltares.Geotechnics.IO.Importers.SurfaceLinesImporter
  • Rectangle3D() : Deltares.Standard.Forms.DrawingSupport
  • RedrawView() : Deltares.Standard.Forms.DExpress.GeometryEditor
  • Refresh() : Deltares.DSoilModel.Forms.FilmStrip , Deltares.Standard.Forms.DExpress.GridViewControl
  • RefreshObject() : Deltares.Standard.Forms.DExpress.GeoPropertyGrid
  • Register() : Deltares.Standard.Forms.DExpress.LocalizationSupport , Deltares.Standard.Forms.DExpress.MainForm , Deltares.Standard.Forms.MessageBoxManager , Deltares.Standard.Forms.RealTimeBackgroundValidator
  • RegisterAndTranslate() : Deltares.Standard.Forms.DExpress.LocalizationSupport
  • RegisterComponentsToReloadUI() : Deltares.Standard.Forms.DExpress.GeometryEditor
  • RegisterControl() : Deltares.Standard.Forms.DExpress.GridViewController< T >
  • RegisterLayer() : Deltares.Standard.Forms.DExpress.MapEditor
  • RegisterNewFileHandler() : Deltares.Standard.Forms.DExpress.MainForm
  • RegisterOpenFileHandler() : Deltares.Standard.Forms.DExpress.MainForm
  • RegisterPlugin() : Deltares.Standard.Application.ProgramBase
  • RegisterPopupControl() : Deltares.Standard.Forms.DExpress.BindSupport
  • RegisterSaveFileHandler() : Deltares.Standard.Forms.DExpress.MainForm
  • RegisterSelectionAssignment() : Deltares.Standard.Forms.DExpress.ComponentBinding , Deltares.Standard.Forms.DExpress.GridControlBinding
  • RegisterShapeImporter() : Deltares.Standard.Forms.DExpress.AbstractShapeFileImporter
  • RegisterShapeType() : Deltares.Standard.Forms.SpatialEditor
  • RegisterTable() : Deltares.Standard.Forms.DExpress.GridViewController< T >
  • RegisterTable< ContainerType, ObjectType >() : Deltares.Standard.Forms.DExpress.MainForm
  • RegisterTableControl() : Deltares.Standard.Forms.DExpress.MainForm
  • RegisterTables< ContainerType >() : Deltares.Standard.Forms.DExpress.MainForm
  • RegisterUIComponent() : Deltares.Geotechnics.Forms.SoilBondStressCurveControl , Deltares.Standard.Forms.DExpress.GeometryEditor , Deltares.Standard.Forms.DExpress.MainForm
  • Reload() : Deltares.Geotechnics.Forms.SoilBondStressCurveControl , Deltares.Standard.Forms.DExpress.GeometryEditor , Deltares.Standard.Forms.DExpress.MainForm
  • ReloadUI() : Deltares.Standard.Forms.DExpress.GeoPropertyGrid , Deltares.Standard.Forms.DExpress.GridViewControl
  • Remove() : Deltares.Standard.Forms.SpatialEditor
  • RemoveAllPointsOfGeometryPointStringAfterIndex() : Deltares.Geotechnics.WaternetCreator.LineHelper
  • RemoveAt() : Deltares.Standard.Forms.DExpress.GridViewControl
  • RemoveComponent() : Deltares.Standard.Forms.DExpress.ReloadManager
  • RemoveDataObjectFromList() : Deltares.Standard.Forms.SpatialEditor
  • RemoveLateBinding() : Deltares.Standard.Forms.DExpress.BindSupportLateBinding , Deltares.Standard.Forms.DExpress.Interfaces.ILateBinding
  • RemoveLayer() : Deltares.Standard.Forms.DExpress.MapEditor
  • RemoveObject() : Deltares.Standard.Forms.DExpress.GeometryEditor , Deltares.Standard.Forms.SpatialEditor
  • RemoveRaster() : Deltares.Standard.Forms.DExpress.MapEditor
  • RemoveTabFromAboutDialog() : Deltares.Standard.Forms.DExpress.MainForm
  • RepairAllValidationResults() : Deltares.DSoilModel.Data.DSoilModelProject
  • ReportDlg() : Deltares.Standard.Forms.DExpress.ReportDlg
  • Reproject() : Deltares.Standard.Forms.DExpress.MyFeatureSet
  • ResumeLayerEvents() : Deltares.Standard.Forms.DExpress.MapEditor
  • ResumeRendering() : Deltares.Standard.Forms.SpatialEditor
  • RetrieveGefFile() : Deltares.Standard.Web.Cpt
  • RunInDebugMode() : Deltares.Standard.Application.ProgramBase
  • RunInReleaseMode() : Deltares.Standard.Application.ProgramBase
Generated on Tue Dec 15 2015 18:15:41 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Class Members - Functions

Tool for the (stochastic) subsoil definition.

- s -

  • SaveSoilDatabase() : Deltares.DSoilModel.Data.DSoilModelIO
  • SaveXML() : Deltares.DSoilModel.Data.DSoilModelIO
  • Select() : Deltares.Standard.Forms.DExpress.MyFeatureSet , Deltares.Standard.Forms.SpatialEditor
  • SelectColumnFilterAll() : Deltares.Standard.Forms.DExpress.GridViewControl
  • SelectLicense() : Deltares.Standard.Forms.DExpress.MainForm
  • SelectProgramOptions() : Deltares.Standard.Forms.DExpress.MainForm
  • SelectUnits() : Deltares.Standard.Forms.DExpress.MainForm
  • SetActiveMapProjection() : Deltares.Standard.DotSpatialDgs.MapProjectionManager
  • SetActiveMapProjectionAsDotSpatial() : Deltares.Standard.DotSpatialDgs.MapProjectionManager
  • SetAsActiveChart() : Deltares.Standard.Forms.DExpress.IMainFormActiveControlController , Deltares.Standard.Forms.DExpress.MainForm
  • SetAsActivePropertyEditor() : Deltares.Standard.Forms.DExpress.IMainFormActiveControlController , Deltares.Standard.Forms.DExpress.MainForm
  • SetAsActiveTable() : Deltares.Standard.Forms.DExpress.IMainFormActiveControlController , Deltares.Standard.Forms.DExpress.MainForm
  • SetAsActiveTabOnMainPanel() : Deltares.Standard.Forms.DExpress.IMainFormActiveControlController , Deltares.Standard.Forms.DExpress.MainForm
  • SetCaption() : Deltares.DSoilModel.Forms.DSoilModelSegmentGeometryEditor
  • SetControlColors() : Deltares.Standard.Forms.DExpress.ComponentBinding
  • SetCoordinate() : Deltares.DSoilModel.Data.SoilSegmentSplitLocation
  • SetDataObject() : Deltares.DSoilModel.Forms.DrawingBoringLayer , Deltares.DSoilModel.Forms.DrawingCenterCrestLocation , Deltares.DSoilModel.Forms.DrawingLayerObsolete , Deltares.DSoilModel.Forms.DrawingSoilSegmentSplitLocation , Deltares.DSoilModel.Forms.DrawingSosSoilLayer1D , Deltares.Geometry.Forms.DrawingBoundingBox , Deltares.Geometry.Forms.DrawingLine , Deltares.Geometry.Forms.DrawingObject , Deltares.Geometry.Forms.DrawingPoint , Deltares.Geometry.Forms.DrawingPointString , Deltares.Geometry.Forms.DrawingSurface , Deltares.Geometry.Forms.IDrawingObject , Deltares.Geotechnics.Forms.DrawingAnchorAttachment , Deltares.Geotechnics.Forms.DrawingBlockRevetmentSegment , Deltares.Geotechnics.Forms.DrawingBoring , Deltares.Geotechnics.Forms.DrawingCharacteristicPoint , Deltares.Geotechnics.Forms.DrawingCPT , Deltares.Geotechnics.Forms.DrawingGeometry , Deltares.Geotechnics.Forms.DrawingHeadLine , Deltares.Geotechnics.Forms.DrawingLayer , Deltares.Geotechnics.Forms.DrawingPhreaticLine , Deltares.Geotechnics.Forms.DrawingPiezometricHead , Deltares.Geotechnics.Forms.DrawingPreConsolidationStress , Deltares.Geotechnics.Forms.DrawingRevetment , Deltares.Geotechnics.Forms.DrawingSettlementCurve , Deltares.Geotechnics.Forms.DrawingSheetPiling , Deltares.Geotechnics.Forms.DrawingSoilLayerSurface , Deltares.Geotechnics.Forms.DrawingSoilProfile1D , Deltares.Geotechnics.Forms.DrawingSoilSurface , Deltares.Geotechnics.Forms.DrawingSpecificMechanismPointLocation , Deltares.Geotechnics.Forms.DrawingSurfaceLine2 , Deltares.Geotechnics.Forms.DrawingSwell , Deltares.Geotechnics.Forms.DrawingWaterBasin , Deltares.Geotechnics.Forms.DrawingWaterLevel , Deltares.Geotechnics.Forms.DrawingWaternetLine , Deltares.Geotechnics.Forms.DrawingWaterPolderBasin
  • SetDataSource() : Deltares.Standard.Forms.DExpress.GeoChartControl
  • SetDefaultWidthPropertyWindow() : Deltares.Standard.Forms.DExpress.MainForm
  • SetDescription() : Deltares.Standard.Forms.DExpress.ControlBinding , Deltares.Standard.Forms.DExpress.GridControlBinding
  • SetDirty() : Deltares.Standard.Forms.DExpress.BindSupportLateBinding
  • SetDirtyIfUsingLateBinding() : Deltares.Standard.Forms.DExpress.BindSupportLateBinding
  • SetDrawingProperties() : Deltares.Geotechnics.Forms.DrawingSwell
  • SetIconFromManifestResourceStream() : Deltares.Standard.Application.ProgramBase
  • SetIEPDraw3D() : Deltares.Standard.Forms.DrawingSupport
  • SetInsertMode() : Deltares.Standard.Forms.DExpress.GeometryEditor
  • SetLabel() : Deltares.Standard.Forms.DExpress.ControlBinding
  • SetLanguage() : Deltares.Standard.Forms.DExpress.ReloadManager
  • SetLateBinding() : Deltares.Standard.Forms.DExpress.BindSupport , Deltares.Standard.Forms.DExpress.BindSupportLateBinding
  • SetLocalizedString() : Deltares.Standard.Forms.DExpress.GridViewControl
  • SetLocalizedStrings() : Deltares.Standard.Forms.DExpress.GeoChartControl
  • SetMainWindowCaption() : Deltares.Standard.Forms.DExpress.MainForm
  • SetMessage() : Deltares.Standard.Forms.DExpress.ProgressDialog
  • SetMinMax() : Deltares.Standard.Forms.DExpress.GeoChartControl
  • SetProgress() : Deltares.Standard.Forms.DExpress.ProgressDialog
  • SetProgressText() : Deltares.Standard.Forms.DExpress.StatusBar
  • SetSelected() : Deltares.Standard.Forms.DExpress.MyMapLineLayer , Deltares.Standard.Forms.DExpress.MyMapPointLayer , Deltares.Standard.Forms.DExpress.MyMapPolygonLayer
  • SetSeriesProperties() : Deltares.Standard.Forms.DExpress.GeoChartControl
  • SetSplashImageFromManifestResourceStream() : Deltares.Standard.Application.ProgramBase
  • SetTextToolTip() : Deltares.Standard.Forms.CommandLineWindow
  • SetupViewEditor() : Deltares.Standard.Forms.DExpress.GeometryEditor
  • SetValue() : Deltares.Standard.Forms.DExpress.PopupContainerEditBinding , Deltares.Standard.Forms.IController
  • SetViewType() : Deltares.Standard.Forms.DExpress.GeoChartControl
  • SetVisible() : Deltares.Standard.Forms.DExpress.FormsSupport
  • ShapeEventArgs() : Deltares.Standard.Forms.ShapeEventArgs
  • ShapeInfo() : Deltares.Standard.Forms.ShapeInfo
  • ShapesEventArgs() : Deltares.Standard.Forms.ShapesEventArgs
  • ShearStressCurveControl() : Deltares.Geotechnics.Forms.ShearStressCurveControl
  • ShowCharts() : Deltares.Standard.Forms.DExpress.MainForm
  • ShowColumnsCommand() : Deltares.Standard.Forms.DExpress.GridViewControl
  • ShowCommandLineWindow() : Deltares.Standard.Forms.CommandLineWindow
  • ShowForm() : Deltares.Standard.Forms.DExpress.MainForm
  • ShowSelectedNonvisibleItems() : Deltares.Standard.Forms.DExpress.GeometryEditor
  • ShowSettingsDialog() : Deltares.Standard.Forms.DExpress.MainForm
  • ShowSoilSegment() : Deltares.DSoilModel.Forms.DSoilModelGeometryEditor
  • SmartLineStringImporter() : Deltares.Standard.Forms.DExpress.ShapeImporters.SmartLineStringImporter
  • SoilBondStressCurveControl() : Deltares.Geotechnics.Forms.SoilBondStressCurveControl
  • SoilProfile1D() : Deltares.Geotechnics.SoilProfile1D
  • SoilProfile1DControl() : Deltares.Geotechnics.Forms.SoilProfile1DControl
  • SoilProfile2DControl() : Deltares.Geotechnics.Forms.SoilProfile2DControl
  • SoilStressCurveControl() : Deltares.Geotechnics.Forms.SoilStressCurveControl
  • SoilSurfacePropertyControl() : Deltares.Geotechnics.Forms.SoilSurfacePropertyControl
  • SpatialEditor() : Deltares.Standard.Forms.SpatialEditor
  • SplitSegment() : Deltares.DSoilModel.Forms.DSoilModelMapEditor
  • SplitSegmentLocation() : Deltares.DSoilModel.Forms.DSoilModelMapEditor
  • SplitSoilSegment() : Deltares.DSoilModel.Data.DSoilModelProject
  • Start() : Deltares.Standard.Application.ProgramBase , Deltares.Standard.Forms.RealTimeBackgroundValidator
  • Stop() : Deltares.Standard.Forms.RealTimeBackgroundValidator
  • StressCurveControl() : Deltares.Geotechnics.Forms.StressCurveControl
  • SuspendLayerEvents() : Deltares.Standard.Forms.DExpress.MapEditor
  • SuspendRendering() : Deltares.Standard.Forms.SpatialEditor
Generated on Tue Dec 15 2015 18:15:41 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Class Members - Functions

Tool for the (stochastic) subsoil definition.

- t -

  • TableToChart() : Deltares.Standard.Forms.DExpress.GeoChartControl
  • Text3D() : Deltares.Standard.Forms.DrawingSupport
  • ThrowIfGeometryIsNotValid() : Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter
  • ThrowIfTargetIsNull() : Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter
  • ToCoordinates() : Deltares.Standard.DotSpatialDgs.DotSpatialGeographicConverter
  • ToFeature() : Deltares.Standard.DotSpatialDgs.DotSpatialGeographicConverter
  • ToGeographic() : Deltares.Standard.DotSpatialDgs.DotSpatialGeographicConverter
  • ToGeographicLoop() : Deltares.Standard.DotSpatialDgs.DotSpatialGeographicConverter
  • ToGeographicMultiPolygon() : Deltares.Standard.DotSpatialDgs.DotSpatialGeographicConverter
  • ToGeographicMultiString() : Deltares.Standard.DotSpatialDgs.DotSpatialGeographicConverter
  • ToGeographicPoint() : Deltares.Standard.DotSpatialDgs.DotSpatialGeographicConverter
  • ToGeographicPoints() : Deltares.Standard.DotSpatialDgs.DotSpatialGeographicConverter
  • ToGeographicPolygon() : Deltares.Standard.DotSpatialDgs.DotSpatialGeographicConverter
  • ToGeographicString() : Deltares.Standard.DotSpatialDgs.DotSpatialGeographicConverter
  • ToLinearRing() : Deltares.Standard.DotSpatialDgs.DotSpatialGeographicConverter
  • TopForDrawing() : Deltares.DSoilModel.Forms.DrawingCenterCrestLocation , Deltares.DSoilModel.Forms.DrawingSoilSegmentSplitLocation , Deltares.Geotechnics.Forms.DrawingSpecificMechanismPointLocation
  • ToPoint() : Deltares.Standard.Forms.DrawingSupport
  • ToString() : Deltares.DSoilModel.Data.CenterCrestLocation , Deltares.Geotechnics.SoilProfile1D , Deltares.Standard.Forms.DExpress.AssignStrategy , Deltares.Standard.Forms.DExpress.ComboBoxDisplayItem , Deltares.Standard.Forms.DExpress.DivideStrategy , Deltares.Standard.Forms.DExpress.GreaterThanStrategy , Deltares.Standard.Forms.DExpress.GridEditValueStrategy , Deltares.Standard.Forms.DExpress.LessThanStrategy , Deltares.Standard.Forms.DExpress.MinusStrategy , Deltares.Standard.Forms.DExpress.MultiplyStrategy , Deltares.Standard.Forms.DExpress.PlusStrategy
  • ToWKT() : Deltares.Standard.DotSpatialDgs.DotSpatialGeographicConverter
  • TreeViewControl() : Deltares.Standard.Forms.DExpress.TreeViewControl
Generated on Tue Dec 15 2015 18:15:41 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Class Members - Functions

Tool for the (stochastic) subsoil definition.

- u -

  • Unbind() : Deltares.Standard.Forms.DExpress.BindSupport
  • UnitForProperty() : Deltares.Standard.Forms.DExpress.BindSupport
  • UnitForProperty< T >() : Deltares.Standard.Forms.DExpress.BindSupport
  • Unregister() : Deltares.Standard.Forms.DExpress.LocalizationSupport , Deltares.Standard.Forms.MessageBoxManager
  • Update() : Deltares.Standard.Forms.DExpress.BindSupport
  • UpdateAll() : Deltares.Standard.Forms.DExpress.BindSupport
  • UpdateAllLayers() : Deltares.Standard.Forms.DExpress.MapEditor
  • UpdateData() : Deltares.Standard.Forms.DExpress.GeometryEditor , Deltares.Standard.Forms.DExpress.MainForm
  • UpdateDataDragDrop() : Deltares.DSoilModel.Forms.DrawingCenterCrestLocation , Deltares.DSoilModel.Forms.DrawingSoilSegmentSplitLocation , Deltares.Geometry.Forms.DrawingLine , Deltares.Geometry.Forms.DrawingObject , Deltares.Geometry.Forms.DrawingPoint , Deltares.Geometry.Forms.DrawingPointString , Deltares.Geometry.Forms.DrawingSurface , Deltares.Geometry.Forms.IDrawingObject , Deltares.Geotechnics.Forms.DrawingAnchorAttachment , Deltares.Geotechnics.Forms.DrawingBoring , Deltares.Geotechnics.Forms.DrawingCPT , Deltares.Geotechnics.Forms.DrawingGeometry , Deltares.Geotechnics.Forms.DrawingSettlementCurve , Deltares.Geotechnics.Forms.DrawingSheetPiling , Deltares.Geotechnics.Forms.DrawingSoilLayerSurface , Deltares.Geotechnics.Forms.DrawingSoilProfile1D , Deltares.Geotechnics.Forms.DrawingSoilSurface , Deltares.Geotechnics.Forms.DrawingSpecificMechanismPointLocation , Deltares.Geotechnics.Forms.DrawingSurfaceLine2 , Deltares.Geotechnics.Forms.DrawingWaterBasin , Deltares.Geotechnics.Forms.DrawingWaterLevel , Deltares.Geotechnics.Forms.DrawingWaterPolderBasin
  • UpdateDirtyControls() : Deltares.Standard.Forms.DExpress.FormsSupport
  • UpdateLists() : Deltares.DSoilModel.Data.DSoilModelProject
  • UpdateMenuTablesView() : Deltares.Standard.Forms.DExpress.MainForm
  • UpdateWaternet() : Deltares.Geotechnics.WaternetCreator.WaternetCreator
  • UseCharts() : Deltares.Standard.Forms.DExpress.MainForm
  • UseExtraGeometryEditor() : Deltares.Standard.Forms.DExpress.MainForm
  • UseIcon() : Deltares.Standard.Forms.DExpress.MainForm
  • UseImage() : Deltares.Standard.Forms.DExpress.MainForm
  • UseLateBinding() : Deltares.Standard.Forms.DExpress.BindSupport
  • UseMap() : Deltares.Standard.Forms.DExpress.MainForm
  • UseNavigation() : Deltares.Standard.Forms.DExpress.MainForm
  • UseOutput() : Deltares.Standard.Forms.DExpress.MainForm
  • UseProperties() : Deltares.Standard.Forms.DExpress.MainForm
  • UserColumnFilterDisplayItem() : Deltares.Standard.Forms.DExpress.UserColumnFilterDisplayItem
  • UseReport() : Deltares.Standard.Forms.DExpress.MainForm
  • UseResources() : Deltares.Standard.Forms.DExpress.MainForm
  • UseSpatialEditor() : Deltares.Standard.Forms.DExpress.MainForm
  • UseStatusBar() : Deltares.Standard.Forms.DExpress.MainForm
  • UseTables() : Deltares.Standard.Forms.DExpress.MainForm
  • UseValidation() : Deltares.Standard.Forms.DExpress.MainForm
Generated on Tue Dec 15 2015 18:15:41 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Class Members - Functions

Tool for the (stochastic) subsoil definition.

- v -

  • Validate() : Deltares.Geotechnics.SoilProfile1D
  • ValidateAquifers() : Deltares.Geotechnics.WaternetCreator.Location
  • ValidateDirect() : Deltares.Geotechnics.SoilProfile1D
  • ValidateSoilProfile() : Deltares.Geotechnics.WaternetCreator.Location
  • ValidateSpecificMechanismPointLocations() : Deltares.DSoilModel.Data.DSoilModelProject
  • ValidateWaterLevelRiver() : Deltares.Geotechnics.WaternetCreator.Location
  • ViewCommand() : Deltares.Standard.Forms.ViewCommand
Generated on Tue Dec 15 2015 18:15:41 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Class Members - Functions

Tool for the (stochastic) subsoil definition.

- w -

  • WaterLineControl() : Deltares.Geotechnics.Forms.WaterLineControl
  • WaternetControl() : Deltares.Geotechnics.Forms.WaternetControl
  • WidthForDrawing() : Deltares.DSoilModel.Forms.DrawingCenterCrestLocation , Deltares.DSoilModel.Forms.DrawingSoilSegmentSplitLocation , Deltares.Geotechnics.Forms.DrawingSpecificMechanismPointLocation
Generated on Tue Dec 15 2015 18:15:41 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Class Members - Functions

Tool for the (stochastic) subsoil definition.

- x -

  • XAxisTitle() : Deltares.Standard.Forms.DExpress.GeoChartControl
Generated on Tue Dec 15 2015 18:15:41 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Class Members - Functions

Tool for the (stochastic) subsoil definition.

- y -

  • YAxisTitle() : Deltares.Standard.Forms.DExpress.GeoChartControl
Generated on Tue Dec 15 2015 18:15:41 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Class Members - Functions

Tool for the (stochastic) subsoil definition.

- z -

  • Zoom() : Deltares.Standard.Forms.SpatialEditor
  • ZoomData() : Deltares.DSoilModel.Forms.DSoilModelMapEditor , Deltares.Standard.Forms.DExpress.MapEditor
  • ZoomExtents() : Deltares.Standard.Forms.DExpress.MapEditor
  • ZoomRectangle() : Deltares.Standard.Forms.DExpress.MapEditor
  • ZoomToExtends() : Deltares.Standard.Forms.DExpress.GeometryEditor
  • ZoomToExtendsMaintainAspectRatio() : Deltares.Standard.Forms.SpatialEditor
  • ZoomToExtents() : Deltares.Standard.Forms.SpatialEditor
Generated on Tue Dec 15 2015 18:15:41 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Class Members - Variables

Tool for the (stochastic) subsoil definition.
  • Abort : Deltares.Standard.Forms.MessageBoxManager
  • Cancel : Deltares.Standard.Forms.MessageBoxManager
  • Description : Deltares.Standard.Forms.DExpress.ControlBinding
  • DllErrorNone : Deltares.Geotechnics.IO.Importers.DGSStandardDLLInterface
  • HorizonDistance : Deltares.Geotechnics.Forms.DrawingSurfaceLine2
  • Ignore : Deltares.Standard.Forms.MessageBoxManager
  • Instance : Deltares.Standard.Forms.RealTimeBackgroundValidator
  • Label : Deltares.Standard.Forms.DExpress.ControlBinding
  • MousePosition : Deltares.Standard.Forms.GraphicsInfo
  • No : Deltares.Standard.Forms.MessageBoxManager
  • OK : Deltares.Standard.Forms.MessageBoxManager
  • point : Deltares.Geometry.Forms.DrawingPoint
  • Retry : Deltares.Standard.Forms.MessageBoxManager
  • Strategies : Deltares.Standard.Forms.DExpress.GridEditValueStrategy
  • UnsnappedMousePosition : Deltares.Standard.Forms.GraphicsInfo
  • WorldMousePosition : Deltares.Standard.Forms.GraphicsInfo
  • Yes : Deltares.Standard.Forms.MessageBoxManager
Generated on Tue Dec 15 2015 18:15:41 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Class Members - Enumerations

Tool for the (stochastic) subsoil definition.
  • GeometryTypes : Deltares.Standard.Forms.DExpress.AbstractShapeFileImporter
  • WebLayerTypes : Deltares.Standard.Forms.DExpress.MapEditor
Generated on Tue Dec 15 2015 18:15:41 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Class Members - Properties

Tool for the (stochastic) subsoil definition.

- a -

  • accept : Deltares.Standard.Forms.Properties.Resources
  • Action : Deltares.Standard.Forms.ShapeEventArgs
  • Add : Deltares.Standard.Forms.Properties.Resources
  • AddCaption : Deltares.Standard.Forms.DExpress.Properties.Resources
  • AddCPTCallback : Deltares.DSoilModel.Forms.DSoilModelGeometryEditor , Deltares.DSoilModel.Forms.DSoilModelSegmentGeometryEditor
  • AddHeadlineCaption : Deltares.Geotechnics.Forms.Properties.Resources
  • AddItem_Glyph : Deltares.Standard.Forms.DExpress.Properties.Resources
  • AddItemHint : Deltares.Standard.Forms.DExpress.Properties.Resources
  • AddPointCaption : Deltares.Geometry.Forms.Properties.Resources , Deltares.Geotechnics.Forms.Properties.Resources
  • AddPointContextItem : Deltares.Standard.Forms.DExpress.GeometryEditor
  • AddPolylineCaption : Deltares.Geometry.Forms.Properties.Resources
  • AddRowCaption : Deltares.Standard.Forms.DExpress.Properties.Resources
  • AddselectedobjectCaption : Deltares.Standard.Forms.DExpress.Properties.Resources
  • AddWaternetlineCaption : Deltares.Geotechnics.Forms.Properties.Resources
  • AdjustHeightToFit : Deltares.Standard.Forms.DExpress.GridViewControl
  • AfterAdd : Deltares.Standard.Forms.DExpress.GridViewController< T >
  • AfterDelete : Deltares.Standard.Forms.DExpress.GridViewController< T >
  • AfterInsert : Deltares.Standard.Forms.DExpress.GridViewController< T >
  • AfterUpdate : Deltares.Standard.Forms.DExpress.GridViewController< T >
  • AllCaption : Deltares.Standard.Forms.DExpress.Properties.Resources
  • AllowAddDeleteOnly : Deltares.Standard.Forms.DExpress.GridViewControl
  • AllowAddNewFeature : Deltares.Standard.Forms.DExpress.MapLayerDefinition
  • AllowConnectingFeature : Deltares.Standard.Forms.DExpress.MapLayerDefinition
  • AllowDelete : Deltares.Standard.Forms.ShapeInfo
  • AllowDeleteFeature : Deltares.Standard.Forms.DExpress.MapLayerDefinition
  • AllowEdit : Deltares.Standard.Forms.ShapeInfo
  • AllowEditing : Deltares.Standard.Forms.SpatialEditor
  • AllowHover : Deltares.Standard.Forms.ShapeInfo
  • AllowInserts : Deltares.Standard.Forms.DExpress.GridViewControl , Deltares.Standard.Forms.DExpress.GridViewController< T >
  • AllowLanguageSelection : Deltares.Standard.Forms.DExpress.MainForm
  • AllowMoveFeature : Deltares.Standard.Forms.DExpress.MapLayerDefinition
  • AllowMultiCoreSelection : Deltares.Standard.Forms.DExpress.MainForm , Deltares.Standard.Forms.ProgramSettings
  • AllowPanning : Deltares.Standard.Forms.SpatialEditor
  • AllowSelect : Deltares.Standard.Forms.ShapeInfo
  • AllowSelecting : Deltares.Standard.Forms.SpatialEditor
  • AllowUserColumnFilterEdit : Deltares.Standard.Forms.DExpress.GridViewControl
  • AllowZooming : Deltares.Standard.Forms.SpatialEditor
  • AlwaysAdjustHeightToFit : Deltares.Standard.Forms.DExpress.GridViewControl
  • ApplicationLanguageGroupBoxCaption : Deltares.Standard.Forms.Properties.Resources
  • ApplicationLanguageLabelCaption : Deltares.Standard.Forms.Properties.Resources
  • ApplicationViewButtonCaption : Deltares.Standard.Forms.Properties.Resources
  • ApplicationViewTabPageCaption : Deltares.Standard.Forms.Properties.Resources
  • AreGeometryCurvesVisible : Deltares.Geometry.Forms.GeometryViewSettings , Deltares.Geometry.Forms.IGeometryViewSettings
  • AreGeometryPointsVisible : Deltares.Geometry.Forms.GeometryViewSettings
  • AreGeometrySurfaceVisible : Deltares.Geometry.Forms.GeometryViewSettings , Deltares.Geometry.Forms.IGeometryViewSettings
  • AreLoadsVisible : Deltares.Geometry.Forms.IDefinitionViewSettings
  • AreLocationMapVisible : Deltares.Geometry.Forms.ILocationMapViewSettings
  • AreSoilSurfaceLabelsOn : Deltares.Geometry.Forms.ISoilGeometryViewSettings
  • AreSoilSurfaceMaterialLabelsOn : Deltares.Geometry.Forms.ISoilGeometryViewSettings
  • Attention : Deltares.Standard.Forms.Properties.Resources
  • AutomaticRegenerationCaption : Deltares.Geometry.Forms.Properties.Resources
Generated on Tue Dec 15 2015 18:15:41 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Class Members - Properties

Tool for the (stochastic) subsoil definition.

- b -

  • Back : Deltares.Standard.Forms.Properties.Resources
  • BackgroundMaps : Deltares.Standard.Forms.DExpress.MapEditor
  • BannerJpg : Deltares.Standard.Forms.Properties.Resources
  • BannerPng : Deltares.Standard.Forms.Properties.Resources
  • BarStringAddOrRemove : Deltares.Standard.Forms.Properties.Resources
  • BarStringCustomizeButton : Deltares.Standard.Forms.Properties.Resources
  • BarStringMenuAnimationFade : Deltares.Standard.Forms.Properties.Resources
  • BarStringMenuAnimationNone : Deltares.Standard.Forms.Properties.Resources
  • BarStringMenuAnimationRandom : Deltares.Standard.Forms.Properties.Resources
  • BarStringMenuAnimationSlide : Deltares.Standard.Forms.Properties.Resources
  • BarStringMenuAnimationSystem : Deltares.Standard.Forms.Properties.Resources
  • BarStringMenuAnimationUnfold : Deltares.Standard.Forms.Properties.Resources
  • BarStringNewToolbarCaption : Deltares.Standard.Forms.Properties.Resources
  • BarStringRenameToolbarCaption : Deltares.Standard.Forms.Properties.Resources
  • BarStringResetBar : Deltares.Standard.Forms.Properties.Resources
  • BarStringResetBarCaption : Deltares.Standard.Forms.Properties.Resources
  • BarStringResetButton : Deltares.Standard.Forms.Properties.Resources
  • BarStringToolBarMenu : Deltares.Standard.Forms.Properties.Resources
  • Blank : Deltares.Standard.Forms.Properties.Resources
  • BondStressCurves : Deltares.DSoilModel.Data.DSoilModelProject
  • Boring : Deltares.DSoilModel.Forms.Properties.Resources
  • BoringLookup1Ds : Deltares.DSoilModel.Data.DSoilModelProject
  • BoringLookup2Ds : Deltares.DSoilModel.Data.DSoilModelProject
  • Borings : Deltares.DSoilModel.Data.DSoilModelProject
  • Bottom : Deltares.Geotechnics.Forms.DrawingBoring , Deltares.Geotechnics.Forms.DrawingCPT , Deltares.Geotechnics.Forms.DrawingSoilProfile1D
  • BottomAquiferLayer : Deltares.Geotechnics.SoilProfile1D
  • BottomLevel : Deltares.Geotechnics.SoilProfile1D
  • BrowseForFolder : Deltares.Standard.Forms.Properties.Resources
  • btClose : Deltares.Standard.Forms.Properties.Resources
  • btClose1 : Deltares.Standard.Forms.Properties.Resources
  • btDeleteBar : Deltares.Standard.Forms.Properties.Resources
  • btDeleteBar1 : Deltares.Standard.Forms.Properties.Resources
  • btNBDlgCancel : Deltares.Standard.Forms.Properties.Resources
  • btNBDlgCancel1 : Deltares.Standard.Forms.Properties.Resources
  • btNBDlgOk : Deltares.Standard.Forms.Properties.Resources
  • btNBDlgOk1 : Deltares.Standard.Forms.Properties.Resources
  • btNewBar : Deltares.Standard.Forms.Properties.Resources
  • btNewBar1 : Deltares.Standard.Forms.Properties.Resources
  • btRenameBar : Deltares.Standard.Forms.Properties.Resources
  • btRenameBar1 : Deltares.Standard.Forms.Properties.Resources
  • btResetBar : Deltares.Standard.Forms.Properties.Resources
  • btResetBar1 : Deltares.Standard.Forms.Properties.Resources
  • ButtonMakeNewFolder : Deltares.Standard.Forms.Properties.Resources
  • ButtonTextAbort : Deltares.Standard.Forms.Properties.Resources
  • ButtonTextCancel : Deltares.Standard.Forms.Properties.Resources
  • ButtonTextIgnore : Deltares.Standard.Forms.Properties.Resources
  • ButtonTextNo : Deltares.Standard.Forms.Properties.Resources
  • ButtonTextOk : Deltares.Standard.Forms.Properties.Resources
  • ButtonTextRetry : Deltares.Standard.Forms.Properties.Resources
  • ButtonTextYes : Deltares.Standard.Forms.Properties.Resources
  • BypassTimerForUnitTest : Deltares.Standard.Forms.DExpress.BindSupport
Generated on Tue Dec 15 2015 18:15:41 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Class Members - Properties

Tool for the (stochastic) subsoil definition.

- c -

  • CalculationManager : Deltares.Standard.Forms.DExpress.MainForm
  • CancelCaption : Deltares.Standard.Forms.DExpress.Properties.Resources
  • CanExecute : Deltares.Standard.Forms.ICommand
  • CannotPasteInSameRow : Deltares.Standard.Forms.DExpress.Properties.Resources
  • CanResize : Deltares.Geometry.Forms.DrawingObject
  • Caption : Deltares.Standard.Forms.DExpress.GridViewControl
  • cbOptionslargeIcons : Deltares.Standard.Forms.Properties.Resources
  • cbOptionslargeIcons1 : Deltares.Standard.Forms.Properties.Resources
  • cbOptionsShowFullMenus : Deltares.Standard.Forms.Properties.Resources
  • cbOptionsShowFullMenus1 : Deltares.Standard.Forms.Properties.Resources
  • cbOptionsshowTips : Deltares.Standard.Forms.Properties.Resources
  • cbOptionsshowTips1 : Deltares.Standard.Forms.Properties.Resources
  • ChartPopupMenu : Deltares.Standard.Forms.DExpress.GeoChartControl
  • Choices : Deltares.Standard.Forms.ColumnDescription
  • ClipBoardCleared : Deltares.Standard.Forms.DExpress.Properties.Resources
  • ClipBoardEmpty : Deltares.Standard.Forms.DExpress.Properties.Resources
  • CloseButtonCaption : Deltares.Standard.Forms.Properties.Resources
  • ClosedCaption : Deltares.Geometry.Forms.Properties.Resources
  • CollapseAll_Glyph : Deltares.Standard.Forms.DExpress.Properties.Resources
  • CollapseAllCaption : Deltares.Standard.Forms.DExpress.Properties.Resources
  • CollapseallHint : Deltares.Standard.Forms.DExpress.Properties.Resources
  • Color : Deltares.Standard.Forms.DExpress.MapLayerDefinition
  • ColorSchemeGroupBoxCaption : Deltares.Standard.Forms.Properties.Resources
  • ColorSchemeLabelCaption : Deltares.Standard.Forms.Properties.Resources
  • Column : Deltares.Standard.Forms.DExpress.Properties.Resources
  • ColumnType : Deltares.Standard.Forms.ColumnDescription
  • CombinedMessage : Deltares.Standard.Forms.DExpress.Properties.Resources
  • CommandArgument : Deltares.Standard.Forms.ICommand
  • CommandLineBadFormat : Deltares.Standard.Forms.Properties.Resources
  • CommandlineErrorText : Deltares.Standard.Forms.Properties.Resources
  • CommandName : Deltares.Standard.Forms.ICommand
  • CondensedviewCaption : Deltares.Standard.Forms.DExpress.Properties.Resources
  • Control : Deltares.Standard.Forms.DExpress.GeometryEditor , Deltares.Standard.Forms.DExpress.ToolTipVisibilityEventArgs
  • ControlWithOpenToolTip : Deltares.Standard.Forms.DExpress.BindSupport
  • CoordinateSystem : Deltares.Standard.Forms.ShapeComparer , Deltares.Standard.Forms.SpatialEditor
  • Copy : Deltares.Standard.Forms.Properties.Resources
  • CopyCaption : Deltares.Standard.Forms.DExpress.Properties.Resources
  • CopyHeadlineCaption : Deltares.Geotechnics.Forms.Properties.Resources
  • CopyItem_Glyph : Deltares.Standard.Forms.DExpress.Properties.Resources
  • CopyItemHint : Deltares.Standard.Forms.DExpress.Properties.Resources
  • CopyPointCaption : Deltares.Geometry.Forms.Properties.Resources , Deltares.Geotechnics.Forms.Properties.Resources
  • CopyPolylineCaption : Deltares.Geometry.Forms.Properties.Resources
  • CopytoClipboardCaption : Deltares.Standard.Forms.DExpress.Properties.Resources
  • CopyWaternetlineCaption : Deltares.Geotechnics.Forms.Properties.Resources
  • CPT : Deltares.DSoilModel.Forms.Properties.Resources
  • CptLookup1Ds : Deltares.DSoilModel.Data.DSoilModelProject
  • CptLookup2Ds : Deltares.DSoilModel.Data.DSoilModelProject
  • CPTs : Deltares.DSoilModel.Data.DSoilModelProject
  • CreateNew : Deltares.Standard.Forms.DExpress.GridViewControl , Deltares.Standard.Forms.DExpress.GridViewController< T > , Deltares.Standard.Forms.IGridController
  • CreatePointInLine : Deltares.DSoilModel.Forms.DSoilModelGeometryEditor , Deltares.DSoilModel.Forms.Properties.Resources
  • CreatePolyline : Deltares.DSoilModel.Forms.DSoilModelGeometryEditor , Deltares.DSoilModel.Forms.Properties.Resources
  • Creator : Deltares.Standard.Forms.DExpress.GridViewController< T >
  • criteria : Deltares.Standard.Web.dinoservices.RequestWithCriteriaType
  • csNotRes : Deltares.DSoilModel.Forms.Properties.Resources
  • csNotRes_Approved : Deltares.DSoilModel.Forms.Properties.Resources
  • csNotRes_ApprovedEarlier : Deltares.DSoilModel.Forms.Properties.Resources
  • csNotRes_NotCalculated : Deltares.DSoilModel.Forms.Properties.Resources
  • csNotRes_Rejected : Deltares.DSoilModel.Forms.Properties.Resources
  • Culture : Deltares.DSoilModel.Application.Properties.Resources , Deltares.DSoilModel.Forms.Properties.Resources , Deltares.Geometry.Forms.Properties.Resources , Deltares.Geotechnics.Forms.Properties.Resources , Deltares.Standard.Forms.DExpress.Properties.Resources , Deltares.Standard.Forms.Properties.Resources
  • CurrentContext : Deltares.Standard.Forms.DExpress.GridViewControl
  • CurrentFailureMechanism : Deltares.DSoilModel.Data.DSoilModelProject
  • CurrentSeriesView : Deltares.Standard.Forms.DExpress.GeoChartControl
  • CurrentSoilSegments : Deltares.DSoilModel.Data.DSoilModelProject
  • Currentwaternet : Deltares.Geotechnics.Forms.Properties.Resources
  • CursorOnControl : Deltares.Standard.Forms.SpatialEditor
  • CursorOnMap : Deltares.Standard.Forms.DExpress.MapEditor
  • CustomizeCaption : Deltares.Standard.Forms.Properties.Resources
  • CustomizeCaption1 : Deltares.Standard.Forms.Properties.Resources
  • CutCaption : Deltares.Standard.Forms.DExpress.Properties.Resources
  • CutHeadlineCaption : Deltares.Geotechnics.Forms.Properties.Resources
  • CutItem_Glyph : Deltares.Standard.Forms.DExpress.Properties.Resources
  • CutItemHint : Deltares.Standard.Forms.DExpress.Properties.Resources
  • CutItemsRemoved : Deltares.Standard.Forms.DExpress.Properties.Resources
  • CutPointCaption : Deltares.Geometry.Forms.Properties.Resources , Deltares.Geotechnics.Forms.Properties.Resources
  • CutPolylineCaption : Deltares.Geometry.Forms.Properties.Resources
  • CutWaternetlineCaption : Deltares.Geotechnics.Forms.Properties.Resources
Generated on Tue Dec 15 2015 18:15:41 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Class Members - Properties

Tool for the (stochastic) subsoil definition.

- d -

  • DataSource : Deltares.Standard.Forms.DExpress.MyMapLineLayer , Deltares.Standard.Forms.DExpress.MyMapPointLayer , Deltares.Standard.Forms.DExpress.MyMapPolygonLayer
  • DataSourceEmpty : Deltares.Standard.Forms.DExpress.Properties.Resources
  • DataSources : Deltares.DSoilModel.Data.DSoilModelProject
  • DataTableList : Deltares.Standard.Forms.DExpress.GeoChartControl
  • Debug : Deltares.Standard.Forms.Properties.Resources
  • DecimateHeightCaption : Deltares.Geotechnics.Forms.Properties.Resources
  • DefaultEmail : Deltares.Standard.Forms.DExpress.Properties.Resources
  • DefaultLayoutXML : Deltares.Standard.Forms.DExpress.MainForm
  • DefaultLookAndFeelRadioButtonCaption : Deltares.Standard.Forms.Properties.Resources
  • DefaultPropertyGrid : Deltares.Standard.Forms.IDynamicPropertyControl
  • DefaultTelephoneNumber : Deltares.Standard.Forms.DExpress.Properties.Resources
  • DegreeOfConsolidationCaption : Deltares.Geotechnics.Forms.Properties.Resources
  • Delayed : Deltares.Standard.Forms.DExpress.BindSupport
  • Delete : Deltares.Standard.Forms.DExpress.Properties.Resources
  • DeleteCaption : Deltares.Standard.Forms.DExpress.Properties.Resources
  • DeleteHeadlineCaption : Deltares.Geotechnics.Forms.Properties.Resources
  • DeleteItem_Glyph : Deltares.Standard.Forms.DExpress.Properties.Resources
  • DeleteItemHint : Deltares.Standard.Forms.DExpress.Properties.Resources
  • DeletePointCaption : Deltares.Geometry.Forms.Properties.Resources , Deltares.Geotechnics.Forms.Properties.Resources
  • DeletePolylineCaption : Deltares.Geometry.Forms.Properties.Resources
  • DeleterowCaption : Deltares.Standard.Forms.DExpress.Properties.Resources
  • DeleteselectedobjectCaption : Deltares.Standard.Forms.DExpress.Properties.Resources
  • DeleteWaternetlineCaption : Deltares.Geotechnics.Forms.Properties.Resources
  • Deletion : Deltares.Standard.Forms.DExpress.Properties.Resources
  • Description : Deltares.Standard.Forms.ViewCommand
  • DescriptionCaption : Deltares.Geotechnics.Forms.Properties.Resources , Deltares.Standard.Forms.DExpress.Properties.Resources
  • DesignLevelCaption : Deltares.Geotechnics.Forms.Properties.Resources
  • DestinationDirectory : Deltares.Standard.Forms.DExpress.Forms.ExportLayersDialog , Deltares.Standard.Forms.DExpress.Forms.IExportLayersDialog
  • dinocpt2b : Deltares.DSoilModel.Forms.Properties.Resources
  • dinocpt2b1 : Deltares.DSoilModel.Forms.Properties.Resources
  • dinocpt2b2 : Deltares.DSoilModel.Forms.Properties.Resources
  • dinocpt2b3 : Deltares.DSoilModel.Forms.Properties.Resources
  • DirectoriesCheckBoxCaption : Deltares.Standard.Forms.Properties.Resources
  • DirectoriesGroupBoxCaption : Deltares.Standard.Forms.Properties.Resources
  • DirectoriesTabPageCaption : Deltares.Standard.Forms.Properties.Resources
  • Dirty : Deltares.Standard.Forms.DExpress.MyFeatureSet
  • DLTRS : Deltares.Standard.Forms.Properties.Resources
  • DownArrow : Deltares.Standard.Forms.DExpress.Properties.Resources
  • DragObjectList : Deltares.Standard.Forms.DExpress.GeometryEditor
  • DrawToNegativeInfinity : Deltares.Geotechnics.Forms.DrawingSurfaceLine2
  • DrawToPositiveInfinity : Deltares.Geotechnics.Forms.DrawingSurfaceLine2
  • drillicon1 : Deltares.DSoilModel.Forms.Properties.Resources
  • drillicon11 : Deltares.DSoilModel.Forms.Properties.Resources
  • drillicon12 : Deltares.DSoilModel.Forms.Properties.Resources
  • drillicon13 : Deltares.DSoilModel.Forms.Properties.Resources
  • drillicon14 : Deltares.DSoilModel.Forms.Properties.Resources
  • drillicon2 : Deltares.DSoilModel.Forms.Properties.Resources
  • drillicon3 : Deltares.DSoilModel.Forms.Properties.Resources
  • drillicon4 : Deltares.DSoilModel.Forms.Properties.Resources
  • DynamicVisibilityMode : Deltares.Standard.Forms.DExpress.MapLayerDefinition
  • DynamicVisibilityWidth : Deltares.Standard.Forms.DExpress.MapLayerDefinition
Generated on Tue Dec 15 2015 18:15:41 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Class Members - Properties

Tool for the (stochastic) subsoil definition.

- e -

  • EditCaption : Deltares.Standard.Forms.DExpress.Properties.Resources
  • EditCaptionHint : Deltares.Standard.Forms.DExpress.Properties.Resources
  • EditorMode : Deltares.Standard.Forms.SpatialEditor
  • EditUnit5 : Deltares.Standard.Forms.DExpress.Properties.Resources
  • EmptySelection : Deltares.Standard.Forms.DExpress.MapEditor , Deltares.Standard.Forms.SpatialEditor
  • EmptyThumbnail : Deltares.DSoilModel.Forms.Properties.Resources
  • Enabled : Deltares.Standard.Forms.ICommand
  • EnabledRule : Deltares.Standard.Forms.DExpress.MapLayerDefinition
  • EnableMasterViewMode : Deltares.Standard.Forms.DExpress.GridViewControl
  • EnableSelectButton : Deltares.Standard.Forms.DExpress.MapEditor
  • EnableZoomRectangle : Deltares.Standard.Forms.DExpress.MapEditor
  • EnableZoomToData : Deltares.Standard.Forms.DExpress.MapEditor
  • EnableZoomToSelection : Deltares.Standard.Forms.DExpress.MapEditor
  • envelope : Deltares.Standard.Web.dinoservices.RequestWithCriteriaType
  • Error : Deltares.Standard.Forms.DExpress.Properties.Resources , Deltares.Standard.Forms.Properties.Resources
  • Execute : Deltares.Standard.Forms.ICommand
  • ExpandAll_Glyph : Deltares.Standard.Forms.DExpress.Properties.Resources
  • ExpandAllCaption : Deltares.Standard.Forms.DExpress.Properties.Resources
  • ExpandallItemHint : Deltares.Standard.Forms.DExpress.Properties.Resources
  • ExplorerBarRadioButtonCaption : Deltares.Standard.Forms.Properties.Resources
  • Export : Deltares.Standard.Forms.Properties.Resources
  • ExportLayers : Deltares.Standard.Forms.DExpress.Properties.Resources
  • ExporttoFileCaption : Deltares.Standard.Forms.DExpress.Properties.Resources
Generated on Tue Dec 15 2015 18:15:41 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Class Members - Properties

Tool for the (stochastic) subsoil definition.

- f -

  • FeatureType : Deltares.Standard.Forms.DExpress.MapLayerDefinition
  • FileName : Deltares.Standard.Forms.DExpress.MainForm
  • Filter : Deltares.Standard.Forms.DExpress.PanelTextPathValue
  • ForceBeginAction : Deltares.Standard.Forms.DExpress.BindSupport
  • Format : Deltares.Standard.Forms.ColumnDescription
  • Forward : Deltares.Standard.Forms.Properties.Resources
  • FrictionMax : Deltares.Geotechnics.Forms.DrawingCPT
  • frictionMeasured : Deltares.Standard.Web.dinoservices.CriteriaType
Generated on Tue Dec 15 2015 18:15:41 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Class Members - Properties

Tool for the (stochastic) subsoil definition.

- g -

  • GeneralButtonCaption : Deltares.Standard.Forms.Properties.Resources
  • GeneralTabPageCaption : Deltares.Standard.Forms.Properties.Resources
  • GenericProgressScreen : Deltares.DSoilModel.Application.Properties.Resources , Deltares.Standard.Forms.DExpress.Properties.Resources
  • GenericSplashScreen : Deltares.DSoilModel.Application.Properties.Resources , Deltares.Standard.Forms.DExpress.Properties.Resources
  • GeoGrid : Deltares.Standard.Forms.DExpress.Properties.Resources
  • GeometryEditor : Deltares.DSoilModel.Forms.DSoilModelPlugin
  • GeometryEditorMode : Deltares.Standard.Forms.DExpress.GeometryEditor
  • GeometryModels : Deltares.Standard.Forms.DExpress.GeometryEditor
  • GeometryType : Deltares.Standard.Forms.DExpress.IShapeImporter , Deltares.Standard.Forms.DExpress.ShapeImporters.ShapeImporter
  • GeoTextEditDimensionalToolTip : Deltares.Standard.Forms.DExpress.Properties.Resources
  • GeoTextEditNonDimensionalToolTip : Deltares.Standard.Forms.DExpress.Properties.Resources
  • GeoTextEditToolTip : Deltares.Standard.Forms.DExpress.Properties.Resources
  • Gridlines : Deltares.Standard.Forms.Properties.Resources
  • GridVisible : Deltares.Standard.Forms.DExpress.GeometryEditor
Generated on Tue Dec 15 2015 18:15:41 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Class Members - Properties

Tool for the (stochastic) subsoil definition.

- h -

  • HasBeenUpdated : Deltares.Geometry.Forms.IDrawingObject
  • HasLoggedExceptions : Deltares.Standard.Application.LogHelper
  • HasPhreaticLevel : Deltares.Geotechnics.SoilProfile1D
  • HasSearchTree : Deltares.Standard.Forms.DExpress.MapLayerDefinition
  • HeadLinesCaption : Deltares.Geotechnics.Forms.Properties.Resources
  • Height : Deltares.Geotechnics.SoilProfile1D
  • HelpFile : Deltares.Standard.Forms.DExpress.MainForm
  • HelpFileManager : Deltares.Standard.Forms.DExpress.MainForm
  • HelpFilePath : Deltares.Standard.Forms.DExpress.Interfaces.IHelpFileManager
  • HelpLocationProvider : Deltares.Standard.Forms.DExpress.Interfaces.IHelpFileManager
  • HideUnusedColumns : Deltares.Standard.Forms.DExpress.GridViewControl
  • Hint : Deltares.Standard.Forms.ICommand
  • HorizontalViewCaption : Deltares.Standard.Forms.DExpress.Properties.Resources
  • hydraulicboundary : Deltares.DSoilModel.Forms.Properties.Resources
Generated on Tue Dec 15 2015 18:15:41 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Class Members - Properties

Tool for the (stochastic) subsoil definition.

- i -

  • Icon : Deltares.Standard.Application.ProgramBase , Deltares.Standard.Forms.ICommand
  • Id : Deltares.Standard.Forms.ViewCommand
  • ID : Deltares.Standard.Web.Cpt
  • id : Deltares.Standard.Web.dinoservices.CPTType
  • Image : Deltares.Standard.Forms.DExpress.MapLayerDefinition , Deltares.Standard.Forms.ViewCommand
  • InBetweenAquiferLayer : Deltares.Geotechnics.SoilProfile1D
  • Index : Deltares.Standard.Forms.GridViewChangeArgs
  • InfiltrationLayer : Deltares.Geotechnics.SoilProfile1D
  • Information : Deltares.Standard.Forms.Properties.Resources
  • InputPointCaption : Deltares.Standard.Forms.Properties.Resources
  • InsertCaption : Deltares.Standard.Forms.DExpress.Properties.Resources
  • InsertHeadlineCaption : Deltares.Geotechnics.Forms.Properties.Resources
  • InsertIncrease : Deltares.Standard.Forms.SpatialEditor
  • InsertIncreaseOffset : Deltares.Standard.Forms.SpatialEditor
  • InsertionPoint : Deltares.DSoilModel.Forms.DrawingSosSoilLayer1D , Deltares.Geotechnics.Forms.DrawingCPT
  • InsertItem_Glyph : Deltares.Standard.Forms.DExpress.Properties.Resources
  • InsertItemHint : Deltares.Standard.Forms.DExpress.Properties.Resources
  • InsertMode : Deltares.Standard.Forms.SpatialEditor
  • InsertPen : Deltares.Standard.Forms.SpatialEditor
  • InsertPointCaption : Deltares.Geometry.Forms.Properties.Resources , Deltares.Geotechnics.Forms.Properties.Resources
  • InsertPolylineCaption : Deltares.Geometry.Forms.Properties.Resources
  • InsertRepeatMode : Deltares.Standard.Forms.SpatialEditor
  • InsertRowCaption : Deltares.Standard.Forms.DExpress.Properties.Resources
  • InsertselectedobjectCaption : Deltares.Standard.Forms.DExpress.Properties.Resources
  • InsertType : Deltares.Standard.Forms.SpatialEditor
  • InsertWaternetlineCaption : Deltares.Geotechnics.Forms.Properties.Resources
  • Instance : Deltares.Standard.DotSpatialDgs.MapProjectionManager
  • InValidMessage : Deltares.Standard.Forms.DExpress.Properties.Resources
  • InvokeControl : Deltares.Standard.Forms.DExpress.BindSupport
  • IsActive : Deltares.Standard.Forms.DExpress.MapTools.BaseMapTool , Deltares.Standard.Forms.DExpress.MapTools.IMapTool
  • IsAutomaticRegeneration : Deltares.Geometry.Forms.IGeometryViewSettings
  • IsGeometryCurveLabelsOn : Deltares.Geometry.Forms.GeometryViewSettings , Deltares.Geometry.Forms.IGeometryViewSettings
  • IsGeometryPointLabelsOn : Deltares.Geometry.Forms.GeometryViewSettings , Deltares.Geometry.Forms.IGeometryViewSettings
  • IsGeometrySurfaceLabelsOn : Deltares.Geometry.Forms.GeometryViewSettings , Deltares.Geometry.Forms.IGeometryViewSettings
  • IsGeometrySurfaceMaterialLabelsOn : Deltares.Geometry.Forms.GeometryViewSettings , Deltares.Geometry.Forms.IGeometryViewSettings
  • IsGeometrySurfaceNameLabelsOn : Deltares.Geometry.Forms.GeometryViewSettings
  • IsLoadsLabelsOn : Deltares.Geometry.Forms.IDefinitionViewSettings
  • IsMultiselectObject : Deltares.Standard.Forms.DExpress.GeoPropertyGrid
  • IsNonEditableMode : Deltares.Standard.Forms.DExpress.GeometryEditor
  • IsRenderingSuspended : Deltares.Standard.Forms.SpatialEditor
  • IsSelectionChanging : Deltares.Standard.Forms.DExpress.GeoPropertyGrid , Deltares.Standard.Forms.DExpress.GridViewControl
  • IsUsed : Deltares.Standard.Forms.RealTimeBackgroundValidator
  • IsValidating : Deltares.Standard.Forms.RealTimeBackgroundValidator
  • IsVisible : Deltares.DSoilModel.Forms.SosSoilProfile1DControl , Deltares.Geotechnics.Forms.SoilProfile1DControl , Deltares.Standard.Forms.IPropertyControl
  • IsVisibleCallback : Deltares.DSoilModel.Forms.DSoilModelGeometryEditor , Deltares.DSoilModel.Forms.DSoilModelSegmentGeometryEditor
  • IsZoomRectange : Deltares.Standard.Forms.DExpress.GeometryEditor
  • Items : Deltares.DSoilModel.Forms.ModalListBox , Deltares.Standard.Forms.DExpress.GridViewController< T >
Generated on Tue Dec 15 2015 18:15:41 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Class Members - Properties

Tool for the (stochastic) subsoil definition.

- l -

  • LabelVisible : Deltares.Standard.Forms.ShapeInfo
  • LanguageButtonCaption : Deltares.Standard.Forms.Properties.Resources
  • LanguageTabPageCaption : Deltares.Standard.Forms.Properties.Resources
  • LastUsedProjectRadioButtonCaption : Deltares.Standard.Forms.Properties.Resources
  • LayerCount : Deltares.Geotechnics.SoilProfile1D
  • Layers : Deltares.Geotechnics.SoilProfile1D
  • lbCategoriesCaption : Deltares.Standard.Forms.Properties.Resources
  • lbCategoriesCaption1 : Deltares.Standard.Forms.Properties.Resources
  • lbCommandsCaption : Deltares.Standard.Forms.Properties.Resources
  • lbCommandsCaption1 : Deltares.Standard.Forms.Properties.Resources
  • lbDescriptionCaption : Deltares.Standard.Forms.Properties.Resources
  • lbDescriptionCaption1 : Deltares.Standard.Forms.Properties.Resources
  • lbOptionsOther : Deltares.Standard.Forms.Properties.Resources
  • lbOptionsOther1 : Deltares.Standard.Forms.Properties.Resources
  • lbOptionsPCaption : Deltares.Standard.Forms.Properties.Resources
  • lbOptionsPCaption1 : Deltares.Standard.Forms.Properties.Resources
  • Left : Deltares.DSoilModel.Forms.DrawingCenterCrestLocation , Deltares.DSoilModel.Forms.DrawingSoilSegmentSplitLocation , Deltares.Geotechnics.Forms.DrawingBoring , Deltares.Geotechnics.Forms.DrawingCPT , Deltares.Geotechnics.Forms.DrawingSoilProfile1D , Deltares.Geotechnics.Forms.DrawingSpecificMechanismPointLocation
  • Legend : Deltares.Standard.Forms.Properties.Resources
  • LegendItems : Deltares.Standard.Forms.SpatialEditor
  • LegendPropertyControlHasBeenSet : Deltares.Standard.Forms.DExpress.MapEditor
  • LevelPrefrenceCaption : Deltares.Standard.Forms.DExpress.Properties.Resources
  • LicenceDongleGroupBoxCaption : Deltares.Standard.Forms.Properties.Resources
  • LineWidth : Deltares.Geometry.Forms.DrawingLine
  • ListInValidMessage : Deltares.Standard.Forms.DExpress.Properties.Resources
  • ListTemplateBarCaption : Deltares.Standard.Forms.DExpress.Properties.Resources
  • Location : Deltares.DSoilModel.Data.CenterCrestLocation
  • LogMessages : Deltares.Standard.Forms.DExpress.MainForm
  • lowerX_rd : Deltares.Standard.Web.dinoservices.EnvelopeType
  • lowerY_rd : Deltares.Standard.Web.dinoservices.EnvelopeType
Generated on Tue Dec 15 2015 18:15:41 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Class Members - Properties

Tool for the (stochastic) subsoil definition.

- m -

  • MaintainLayerOrder : Deltares.Geotechnics.SoilProfile1D
  • MaintainLayerOrderNonStatic : Deltares.Geotechnics.SoilProfile1D
  • MakeProportionalOnResize : Deltares.Standard.Forms.SpatialEditor
  • MapControl : Deltares.Standard.Forms.DExpress.MapTools.IMapTool
  • MapExtent : Deltares.Standard.Forms.DExpress.MapEditor
  • MapTools : Deltares.Standard.Forms.DExpress.MapEditor
  • MarginBottom : Deltares.Standard.Forms.SpatialEditor
  • MarginLeft : Deltares.Standard.Forms.SpatialEditor
  • MarginRight : Deltares.Standard.Forms.SpatialEditor
  • MarginTop : Deltares.Standard.Forms.SpatialEditor
  • Materials : Deltares.Standard.Forms.DExpress.Properties.Resources
  • MaximumTopLevel : Deltares.DSoilModel.Data.SosSoilLayer1D
  • maxLength : Deltares.Standard.Web.dinoservices.CriteriaType
  • MenuAnimation : Deltares.Standard.Forms.Properties.Resources
  • MenuAnimation1 : Deltares.Standard.Forms.Properties.Resources
  • MenuColumnBestFit : Deltares.Standard.Forms.DExpress.Properties.Resources
  • MenuColumnBestFitAllColumns : Deltares.Standard.Forms.DExpress.Properties.Resources
  • MenuColumnClearFilter : Deltares.Standard.Forms.DExpress.Properties.Resources
  • MenuColumnClearSorting : Deltares.Standard.Forms.DExpress.Properties.Resources
  • MenuColumnColumnCustomization : Deltares.Standard.Forms.DExpress.Properties.Resources
  • MenuColumnFilterEditor : Deltares.Standard.Forms.DExpress.Properties.Resources
  • MenuColumnGroup : Deltares.Standard.Forms.DExpress.Properties.Resources
  • MenuColumnGroupBox : Deltares.Standard.Forms.DExpress.Properties.Resources
  • MenuColumnSortAscending : Deltares.Standard.Forms.DExpress.Properties.Resources
  • MenuColumnSortDescending : Deltares.Standard.Forms.DExpress.Properties.Resources
  • MinimumTopLevel : Deltares.DSoilModel.Data.SosSoilLayer1D
  • minLength : Deltares.Standard.Web.dinoservices.CriteriaType
  • ModulesButtonCaption : Deltares.Standard.Forms.Properties.Resources
  • ModulesTabPageCaption : Deltares.Standard.Forms.Properties.Resources
  • MousePosition : Deltares.Standard.Forms.ShapesEventArgs
  • Movable : Deltares.Standard.Forms.DExpress.MapLayerDefinition
  • MoveDownButtonCaption : Deltares.Standard.Forms.DExpress.Properties.Resources
  • MoveDownCaption : Deltares.Geometry.Forms.Properties.Resources , Deltares.Standard.Forms.DExpress.Properties.Resources
  • MoveDownHint : Deltares.Standard.Forms.DExpress.Properties.Resources
  • MoveDownPopUpBarButton_Glyph : Deltares.Standard.Forms.DExpress.Properties.Resources
  • MoveHeadlineDownCaption : Deltares.Geotechnics.Forms.Properties.Resources
  • MoveHeadlineupCaption : Deltares.Geotechnics.Forms.Properties.Resources
  • MoveUpButton_Glyph : Deltares.Standard.Forms.DExpress.Properties.Resources
  • MoveUpButtonCaption : Deltares.Standard.Forms.DExpress.Properties.Resources
  • MoveupCaption : Deltares.Geometry.Forms.Properties.Resources , Deltares.Standard.Forms.DExpress.Properties.Resources
  • MoveupHint : Deltares.Standard.Forms.DExpress.Properties.Resources
  • MoveWaternetlineDownCaption : Deltares.Geotechnics.Forms.Properties.Resources
  • MoveWaternetlineupCaption : Deltares.Geotechnics.Forms.Properties.Resources
  • MultiSelect : Deltares.Standard.Forms.DExpress.TreeViewControl
Generated on Tue Dec 15 2015 18:15:41 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Class Members - Properties

Tool for the (stochastic) subsoil definition.

- n -

  • Name : Deltares.Geometry.Forms.DrawingObject , Deltares.Standard.Forms.DExpress.MapLayerDefinition , Deltares.Standard.Forms.IPropertyControl , Deltares.Standard.Forms.ShapeInfo
  • NameCaption : Deltares.Geotechnics.Forms.Properties.Resources , Deltares.Standard.Forms.DExpress.Properties.Resources
  • NavBarRadioButtonCaption : Deltares.Standard.Forms.Properties.Resources
  • NavigationStyleGroupBoxCaption : Deltares.Standard.Forms.Properties.Resources
  • NewProjectRadioButtonCaption : Deltares.Standard.Forms.Properties.Resources
  • Next : Deltares.Standard.Forms.Properties.Resources
  • NoItemtoDeleteCaption : Deltares.Standard.Forms.DExpress.Properties.Resources
  • NoObjectDeleted : Deltares.Standard.Forms.DExpress.Properties.Resources
  • NoProjectRadioButtonCaption : Deltares.Standard.Forms.Properties.Resources
  • NoRowSelected : Deltares.Standard.Forms.DExpress.Properties.Resources
Generated on Tue Dec 15 2015 18:15:41 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Class Members - Properties

Tool for the (stochastic) subsoil definition.

- o -

  • OkButtonCaption : Deltares.Standard.Forms.Properties.Resources
  • OKCaption : Deltares.Standard.Forms.DExpress.Properties.Resources
  • Open : Deltares.Standard.Forms.Properties.Resources
  • OpenImage : Deltares.Standard.Forms.Properties.Resources
Generated on Tue Dec 15 2015 18:15:41 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Class Members - Properties

Tool for the (stochastic) subsoil definition.

- p -

  • Pan : Deltares.Standard.Forms.DExpress.Properties.Resources , Deltares.Standard.Forms.Properties.Resources
  • PanMove : Deltares.Standard.Forms.DExpress.Properties.Resources
  • ParameterView : Deltares.DSoilModel.Data.DSoilModelProject , Deltares.DSoilModel.Forms.DSoilModelContext
  • PasteCaption : Deltares.Standard.Forms.DExpress.Properties.Resources
  • PasteHeadlineCaption : Deltares.Geotechnics.Forms.Properties.Resources
  • PasteItem_Glyph : Deltares.Standard.Forms.DExpress.Properties.Resources
  • PasteItemHint : Deltares.Standard.Forms.DExpress.Properties.Resources
  • PastePointCaption : Deltares.Geometry.Forms.Properties.Resources , Deltares.Geotechnics.Forms.Properties.Resources
  • PastePolylineCaption : Deltares.Geometry.Forms.Properties.Resources
  • PasteWaternetlineCaption : Deltares.Geotechnics.Forms.Properties.Resources
  • Pause : Deltares.Standard.Forms.Properties.Resources
  • PhreaticLevel : Deltares.Geotechnics.SoilProfile1D
  • PhreaticLineCaption : Deltares.Geotechnics.Forms.Properties.Resources
  • PhreaticLineDescription : Deltares.Geotechnics.Forms.Properties.Resources
  • PlLineOffsetBelowPointBRingtoetsWti2017 : Deltares.Geotechnics.WaternetCreator.Location
  • Point : Deltares.Standard.Forms.ShapeEventArgs
  • Point_grey : Deltares.DSoilModel.Forms.Properties.Resources
  • Preferences_Glyph : Deltares.Standard.Forms.DExpress.Properties.Resources
  • PreferencesFormText : Deltares.Standard.Forms.DExpress.Properties.Resources
  • Previous : Deltares.Standard.Forms.Properties.Resources
  • PreviousMRUList : Deltares.Standard.Forms.DExpress.MainForm
  • PrintCaption : Deltares.Standard.Forms.DExpress.Properties.Resources
  • ProbabilityOfOccurrence : Deltares.Geotechnics.SoilProfile1D
  • ProgramSettings : Deltares.Standard.Forms.DExpress.MainForm
  • ProgressBackgroundImage : Deltares.Standard.Forms.DExpress.ProgressDialog
  • Project : Deltares.DSoilModel.Forms.DSoilModelGeometryEditor , Deltares.DSoilModel.Forms.DSoilModelMapEditor , Deltares.DSoilModel.Forms.DSoilModelPlugin , Deltares.DSoilModel.Forms.DSoilModelSegmentGeometryEditor
  • ProjectDescriptionCaption : Deltares.Standard.Forms.DExpress.Properties.Resources
  • Projection : Deltares.Standard.Forms.ShapesEventArgs
  • PropertyEditorReactionType : Deltares.Standard.Forms.DExpress.GridViewControl
  • PropertyName : Deltares.Standard.Forms.GridViewCellChangeArgs
  • PropertyValue : Deltares.Standard.Forms.GridViewCellChangeArgs
Generated on Tue Dec 15 2015 18:15:41 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Class Members - Properties

Tool for the (stochastic) subsoil definition.

- q -

  • QcMax : Deltares.Geotechnics.Forms.DrawingCPT
Generated on Tue Dec 15 2015 18:15:41 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Class Members - Properties

Tool for the (stochastic) subsoil definition.

- r -

  • ReadOnly : Deltares.Standard.Forms.ColumnDescription
  • Redo : Deltares.Standard.Forms.Properties.Resources
  • RegisteredLayers : Deltares.Standard.Forms.DExpress.MapEditor , Deltares.Standard.Forms.DExpress.MapTools.IMapTool
  • ReloadManager : Deltares.Standard.Forms.DExpress.MainForm
  • RemarkTopLevel : Deltares.DSoilModel.Data.SosSoilLayer1D
  • Remove : Deltares.Standard.Forms.Properties.Resources
  • Rename_Glyph : Deltares.Standard.Forms.DExpress.Properties.Resources
  • RenameCaption : Deltares.Standard.Forms.DExpress.Properties.Resources
  • RenameFormCaption : Deltares.Standard.Forms.DExpress.Properties.Resources
  • RenameItemHint : Deltares.Standard.Forms.DExpress.Properties.Resources
  • RenameselectedobjectCaption : Deltares.Standard.Forms.DExpress.Properties.Resources
  • RenamewaternetCaption : Deltares.Geotechnics.Forms.Properties.Resources
  • ReportLanguageGroupboxCaption : Deltares.Standard.Forms.Properties.Resources
  • ReportLanguageLabelCaption : Deltares.Standard.Forms.Properties.Resources
  • RerouteMessageBoxMessages : Deltares.Standard.Forms.Messenger
  • Reset : Deltares.Standard.Forms.Properties.Resources
  • Reset1 : Deltares.Standard.Forms.Properties.Resources
  • ResourceManager : Deltares.DSoilModel.Application.Properties.Resources , Deltares.DSoilModel.Forms.Properties.Resources , Deltares.Geometry.Forms.Properties.Resources , Deltares.Geotechnics.Forms.Properties.Resources , Deltares.Standard.Forms.DExpress.Properties.Resources , Deltares.Standard.Forms.Properties.Resources
  • Result : Deltares.Standard.Web.dinoservices.findCPTCompletedEventArgs , Deltares.Standard.Web.dinoservices.findCPTWithCriteriaCompletedEventArgs , Deltares.Standard.Web.dinoservices.getGEFCompletedEventArgs
  • Right : Deltares.DSoilModel.Forms.DrawingCenterCrestLocation , Deltares.DSoilModel.Forms.DrawingSoilSegmentSplitLocation , Deltares.Geotechnics.Forms.DrawingBoring , Deltares.Geotechnics.Forms.DrawingCPT , Deltares.Geotechnics.Forms.DrawingSoilProfile1D , Deltares.Geotechnics.Forms.DrawingSpecificMechanismPointLocation
  • RowHeaderToolTip : Deltares.Standard.Forms.DExpress.GeoPropertyGrid
Generated on Tue Dec 15 2015 18:15:41 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Class Members - Properties

Tool for the (stochastic) subsoil definition.

- s -

  • Save : Deltares.Standard.Forms.Properties.Resources
  • SaveAll : Deltares.Standard.Forms.Properties.Resources
  • SaveImage : Deltares.Standard.Forms.Properties.Resources
  • SaveLayer : Deltares.Standard.Forms.Properties.Resources
  • Scheme : Deltares.Standard.Forms.DExpress.MapLayerDefinition
  • SegmentGeometryEditor : Deltares.DSoilModel.Forms.DSoilModelPlugin
  • Select : Deltares.Standard.Forms.Properties.Resources
  • Selectable : Deltares.Standard.Forms.DExpress.MapLayerDefinition , Deltares.Standard.Forms.DExpress.MyMapLineLayer , Deltares.Standard.Forms.DExpress.MyMapPointLayer
  • SelectableLayerItems : Deltares.Standard.Forms.DExpress.Forms.ExportLayersDialog , Deltares.Standard.Forms.DExpress.Forms.IExportLayersDialog
  • Selected : Deltares.DSoilModel.Forms.FilmStripThumbnail , Deltares.Geometry.Forms.DrawingObject
  • SelectedCategory : Deltares.Standard.Forms.DExpress.GridViewControl
  • SelectedFeature : Deltares.Standard.Forms.DExpress.MapTools.ConnectFeaturesMapTool , Deltares.Standard.Forms.DExpress.MapTools.IMapTool
  • SelectedFilter : Deltares.Standard.Forms.DExpress.GridViewControl
  • SelectedItem : Deltares.DSoilModel.Forms.ModalListBox
  • SelectedLayer : Deltares.Standard.Forms.DExpress.MapTools.IMapTool
  • SelectedList : Deltares.Standard.Forms.DExpress.MapTools.IMapTool
  • SelectedObject : Deltares.DSoilModel.Forms.SosSoilProfile1DControl , Deltares.Geotechnics.Forms.SoilBondStressCurveControl , Deltares.Geotechnics.Forms.SoilProfile1DControl , Deltares.Geotechnics.Forms.SoilStressCurveControl , Deltares.Geotechnics.Forms.SoilSurfacePropertyControl , Deltares.Geotechnics.Forms.WaterLineControl , Deltares.Geotechnics.Forms.WaternetControl , Deltares.Standard.Forms.DExpress.DynamicPropertyControl , Deltares.Standard.Forms.IDynamicPropertyControl , Deltares.Standard.Forms.IPropertyControl
  • SelectedObjectCount : Deltares.Standard.Forms.DExpress.GeometryEditor
  • SelectedObjects : Deltares.Standard.Forms.DExpress.GeometryEditor , Deltares.Standard.Forms.DExpress.MapEditor , Deltares.Standard.Forms.DExpress.MapTools.SelectFeatureMapTool
  • SelectedRow : Deltares.Standard.Forms.DExpress.Properties.Resources
  • SelectedStochasticSoilModel : Deltares.DSoilModel.Forms.FilmStrip
  • SelectedStochasticSoilProfile : Deltares.DSoilModel.Forms.FilmStrip
  • Selection : Deltares.Standard.Forms.IController
  • SelectOrRowCaption : Deltares.Standard.Forms.DExpress.Properties.Resources
  • SelectWorkingDirectory : Deltares.Standard.Forms.Properties.Resources
  • SendLegendEvent : Deltares.Standard.Forms.DExpress.MapEditor
  • SendSelectionChanged : Deltares.Standard.Forms.DExpress.GridViewControl
  • SeriesCount : Deltares.Standard.Forms.DExpress.GeoChartControl
  • SeriesList : Deltares.Standard.Forms.DExpress.GeoChartControl
  • Setascurrentwaternet : Deltares.Geotechnics.Forms.Properties.Resources
  • Shape : Deltares.Standard.Forms.ShapeEventArgs
  • ShapeInfos : Deltares.Standard.Forms.SpatialEditor
  • Shapes : Deltares.Standard.Forms.ShapesEventArgs , Deltares.Standard.Forms.SpatialEditor
  • ShortCut : Deltares.Standard.Forms.ICommand
  • Shortcut : Deltares.Standard.Forms.ViewCommand
  • Showallcolumnsbutton_Glyph : Deltares.Standard.Forms.DExpress.Properties.Resources
  • ShowallcolumnsCaption : Deltares.Standard.Forms.DExpress.Properties.Resources
  • ShowallcolumnsHint : Deltares.Standard.Forms.DExpress.Properties.Resources
  • ShowAxes : Deltares.DSoilModel.Forms.DrawingCenterCrestLocation , Deltares.Geotechnics.Forms.DrawingCPT , Deltares.Geotechnics.Forms.DrawingSpecificMechanismPointLocation
  • ShowBestColumnFitCaption : Deltares.Standard.Forms.DExpress.Properties.Resources
  • ShowExportLayersButton : Deltares.Standard.Forms.DExpress.MapEditor
  • ShowFeatureTextInMapInfoBar : Deltares.Standard.Forms.DExpress.MapEditor
  • showFullMenusAfterDelay : Deltares.Standard.Forms.Properties.Resources
  • showFullMenusAfterDelay1 : Deltares.Standard.Forms.Properties.Resources
  • ShowRoot : Deltares.Standard.Forms.DExpress.TreeViewControl
  • ShowSelectWebLayer : Deltares.Standard.Forms.DExpress.MapEditor
  • ShowShortcutInTips : Deltares.Standard.Forms.Properties.Resources
  • ShowShortcutInTips1 : Deltares.Standard.Forms.Properties.Resources
  • ShowToolbar : Deltares.Standard.Forms.DExpress.GridViewControl , Deltares.Standard.Forms.DExpress.TreeViewControl
  • ShowToolTipOnIndexer : Deltares.Standard.Forms.DExpress.GeoPropertyGrid
  • ShowWebLayer : Deltares.Standard.Forms.DExpress.MapEditor
  • SnapAngle : Deltares.Standard.Forms.SpatialEditor
  • SnapDistance : Deltares.Standard.Forms.SpatialEditor
  • SnapGrid : Deltares.Standard.Forms.SpatialEditor
  • SnapRule : Deltares.Standard.Forms.DExpress.MapLayerDefinition
  • SoilbaseDb : Deltares.DSoilModel.Data.DSoilModelProject
  • SoilProfile : Deltares.DSoilModel.Forms.Properties.Resources
  • Soilprofile1DLookup2Ds : Deltares.DSoilModel.Data.DSoilModelProject
  • SoilProfile2D : Deltares.DSoilModel.Data.CenterCrestLocation , Deltares.DSoilModel.Data.SoilSegmentSplitLocation
  • soilprofile2d : Deltares.DSoilModel.Forms.Properties.Resources
  • SoilProfiles1D : Deltares.DSoilModel.Data.DSoilModelProject
  • SoilProfiles2D : Deltares.DSoilModel.Data.DSoilModelProject
  • SoilPropertyManager : Deltares.Geotechnics.SoilProfile1D
  • Soils : Deltares.DSoilModel.Data.DSoilModelProject , Deltares.Geotechnics.SoilProfile1D
  • SoilSegment : Deltares.DSoilModel.Data.SoilSegmentSplitLocation
  • SoilSegments : Deltares.DSoilModel.Data.DSoilModelProject
  • Source : Deltares.Standard.Forms.IController
  • SpatialEditor : Deltares.Standard.Forms.DExpress.GeometryEditor , Deltares.Standard.Forms.ShapeInfo
  • SpecificMechanismPointLocations : Deltares.DSoilModel.Data.DSoilModelProject
  • SplashDialog : Deltares.Standard.Forms.DExpress.MainForm
  • SplashImage : Deltares.Standard.Application.ProgramBase
  • SplitPoint : Deltares.DSoilModel.Forms.Properties.Resources
  • SplitSegment : Deltares.DSoilModel.Forms.Properties.Resources
  • Start : Deltares.Standard.Forms.Properties.Resources
  • StartUpGroupBoxCaption : Deltares.Standard.Forms.Properties.Resources
  • StatusBarProjection : Deltares.Standard.Forms.DExpress.MapEditor
  • StatusString : Deltares.Standard.Forms.DExpress.GeometryEditor
  • StochasticSoilProfile : Deltares.DSoilModel.Forms.FilmStripThumbnail
  • StochastProperties : Deltares.DSoilModel.Data.DSoilModelDataSourceRedirector
  • Stop : Deltares.Standard.Forms.Properties.Resources
  • StressCurves : Deltares.DSoilModel.Data.DSoilModelProject
  • structure_00 : Deltares.DSoilModel.Forms.Properties.Resources
  • structure_01 : Deltares.DSoilModel.Forms.Properties.Resources
  • structure_02 : Deltares.DSoilModel.Forms.Properties.Resources
  • structure_03 : Deltares.DSoilModel.Forms.Properties.Resources
  • structure_04 : Deltares.DSoilModel.Forms.Properties.Resources
  • structure_05 : Deltares.DSoilModel.Forms.Properties.Resources
  • structure_06 : Deltares.DSoilModel.Forms.Properties.Resources
  • structure_07 : Deltares.DSoilModel.Forms.Properties.Resources
  • structure_08 : Deltares.DSoilModel.Forms.Properties.Resources
  • structure_09 : Deltares.DSoilModel.Forms.Properties.Resources
  • structure_approved_earlier : Deltares.DSoilModel.Forms.Properties.Resources
  • structure_not_calculated : Deltares.DSoilModel.Forms.Properties.Resources
  • SurfaceLines : Deltares.DSoilModel.Data.DSoilModelProject
Generated on Tue Dec 15 2015 18:15:41 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Class Members - Properties

Tool for the (stochastic) subsoil definition.

- t -

  • Text : Deltares.Standard.Forms.DExpress.ComboBoxDisplayItem , Deltares.Standard.Forms.ICommand , Deltares.Standard.Forms.ViewCommand
  • ThumbnailImage : Deltares.DSoilModel.Forms.FilmStripThumbnail
  • TitleCaption1 : Deltares.Standard.Forms.DExpress.Properties.Resources
  • TitleCaption2 : Deltares.Standard.Forms.DExpress.Properties.Resources
  • TitleCaption3 : Deltares.Standard.Forms.DExpress.Properties.Resources
  • ToggleExpand : Deltares.Standard.Forms.Properties.Resources
  • ToolStripMenuItem : Deltares.Standard.Forms.DExpress.MapTools.AddFeatureMapTool , Deltares.Standard.Forms.DExpress.MapTools.DeleteFeatureMapTool , Deltares.Standard.Forms.DExpress.MapTools.SelectFeatureMapTool
  • ToolTip : Deltares.Geometry.Forms.DrawingObject
  • Tooltip : Deltares.Standard.Forms.DExpress.ControlBinding
  • Top : Deltares.Geotechnics.Forms.DrawingBoring , Deltares.Geotechnics.Forms.DrawingCPT , Deltares.Geotechnics.Forms.DrawingSoilProfile1D
  • TopAquiferLayer : Deltares.Geotechnics.SoilProfile1D
  • TopLevel : Deltares.Geotechnics.SoilProfile1D
  • tpCommands : Deltares.Standard.Forms.Properties.Resources
  • tpCommands1 : Deltares.Standard.Forms.Properties.Resources
  • tpOptions : Deltares.Standard.Forms.Properties.Resources
  • tpOptions1 : Deltares.Standard.Forms.Properties.Resources
  • tpToolbars : Deltares.Standard.Forms.Properties.Resources
  • tpToolbars1 : Deltares.Standard.Forms.Properties.Resources
Generated on Tue Dec 15 2015 18:15:41 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Class Members - Properties

Tool for the (stochastic) subsoil definition.

- u -

  • UiButtonToggle : Deltares.Standard.Forms.Properties.Resources
  • Undo : Deltares.Standard.Forms.Properties.Resources
  • UnitCategory : Deltares.Standard.Forms.DExpress.Properties.Resources
  • UnitType : Deltares.Standard.Forms.DExpress.Properties.Resources
  • UnitweightCaption : Deltares.Geotechnics.Forms.Properties.Resources
  • UnitWeightOfWaterCaption : Deltares.Geotechnics.Forms.Properties.Resources
  • UpArrow : Deltares.Standard.Forms.DExpress.Properties.Resources
  • upperX_rd : Deltares.Standard.Web.dinoservices.EnvelopeType
  • upperY_rd : Deltares.Standard.Web.dinoservices.EnvelopeType
  • Use1DProfiles : Deltares.DSoilModel.Forms.DSoilModelPlugin
  • Use2DProfiles : Deltares.DSoilModel.Forms.DSoilModelPlugin
  • UseBorings : Deltares.DSoilModel.Forms.DSoilModelPlugin
  • UsedShapeInfos : Deltares.Standard.Forms.SpatialEditor
  • UseDynamicVisibility : Deltares.Standard.Forms.DExpress.MapLayerDefinition
  • UseLateBinding : Deltares.Standard.Forms.DExpress.Interfaces.ILateBinding
  • UserLabelVisible : Deltares.Standard.Forms.ShapeInfo
  • UserUnitIndex : Deltares.Standard.Forms.DExpress.Properties.Resources
  • UserVisible : Deltares.Standard.Forms.ShapeInfo
  • UseSoilSegments : Deltares.DSoilModel.Forms.DSoilModelPlugin
  • UseSurfaceLines : Deltares.DSoilModel.Forms.DSoilModelPlugin
Generated on Tue Dec 15 2015 18:15:41 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Class Members - Properties

Tool for the (stochastic) subsoil definition.

- v -

  • ValidateCaption : Deltares.Standard.Forms.DExpress.Properties.Resources
  • ValidateItemHint : Deltares.Standard.Forms.DExpress.Properties.Resources
  • Validation : Deltares.Standard.Forms.DExpress.Properties.Resources
  • ValidationResults : Deltares.Standard.Forms.DExpress.MainForm
  • ValueCaption : Deltares.Standard.Forms.DExpress.Properties.Resources
  • VericalViewCaption : Deltares.Standard.Forms.DExpress.Properties.Resources
  • ViewGrid : Deltares.Standard.Forms.SpatialEditor
  • ViewType : Deltares.Standard.Forms.DExpress.GeoChartControl
  • ViewType2D : Deltares.Standard.Forms.DExpress.GeoChartControl
  • ViewType3D : Deltares.Standard.Forms.DExpress.GeoChartControl
  • Visible : Deltares.Standard.Forms.ICommand , Deltares.Standard.Forms.ShapeInfo
Generated on Tue Dec 15 2015 18:15:41 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Class Members - Properties

Tool for the (stochastic) subsoil definition.

- w -

  • WaitForInsert : Deltares.Standard.Forms.SpatialEditor
  • Warning : Deltares.Standard.Forms.DExpress.Properties.Resources , Deltares.Standard.Forms.Properties.Resources
  • WaterDataNameCaption : Deltares.Geotechnics.Forms.Properties.Resources
  • WaterLevelCaption : Deltares.Geotechnics.Forms.Properties.Resources
  • Waternet : Deltares.Standard.Forms.Properties.Resources
  • WaternetCaption : Deltares.Geotechnics.Forms.Properties.Resources
  • WaternetCreationMode : Deltares.Geotechnics.WaternetCreator.Location
  • WaternetLinesCaption : Deltares.Geotechnics.Forms.Properties.Resources
  • WaterPressureMax : Deltares.Geotechnics.Forms.DrawingCPT
  • Web : Deltares.Standard.Forms.Properties.Resources
  • WebLayerType : Deltares.Standard.Forms.DExpress.MapEditor
  • Width : Deltares.DSoilModel.Forms.DrawingSosSoilLayer1D , Deltares.Geotechnics.Forms.DrawingBoring , Deltares.Geotechnics.Forms.DrawingCPT , Deltares.Geotechnics.Forms.DrawingSoilProfile1D
  • WindowsLookAndFeelRadioButtonCaption : Deltares.Standard.Forms.Properties.Resources
  • WorkingDirectoryLabelCaption : Deltares.Standard.Forms.Properties.Resources
  • WorldBounds : Deltares.Standard.Forms.SpatialEditor
Generated on Tue Dec 15 2015 18:15:41 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Class Members - Properties

Tool for the (stochastic) subsoil definition.

- x -

  • X : Deltares.DSoilModel.Forms.DrawingCenterCrestLocation , Deltares.DSoilModel.Forms.DrawingSoilSegmentSplitLocation , Deltares.Geotechnics.Forms.DrawingBoring , Deltares.Geotechnics.Forms.DrawingCPT , Deltares.Geotechnics.Forms.DrawingSoilProfile1D , Deltares.Geotechnics.Forms.DrawingSpecificMechanismPointLocation , Deltares.Geotechnics.SoilProfile1D , Deltares.Standard.Web.Cpt
  • x_rd : Deltares.Standard.Web.dinoservices.CPTType
  • XCoordinate : Deltares.DSoilModel.Data.SoilSegmentSplitLocation
  • XValueNotIncreasing : Deltares.Standard.Forms.DExpress.Properties.Resources
Generated on Tue Dec 15 2015 18:15:41 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Class Members - Properties

Tool for the (stochastic) subsoil definition.

- y -

  • Y : Deltares.Geotechnics.SoilProfile1D , Deltares.Standard.Web.Cpt
  • y_rd : Deltares.Standard.Web.dinoservices.CPTType
Generated on Tue Dec 15 2015 18:15:41 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Class Members - Properties

Tool for the (stochastic) subsoil definition.

- z -

  • Z : Deltares.Geotechnics.Forms.DrawingBoring , Deltares.Geotechnics.Forms.DrawingCPT , Deltares.Geotechnics.Forms.DrawingSoilProfile1D
  • Zoom : Deltares.Standard.Forms.Properties.Resources
  • ZoomAll : Deltares.Standard.Forms.Properties.Resources
  • ZoomExtents : Deltares.Standard.Forms.Properties.Resources
  • ZoomFit : Deltares.Standard.Forms.Properties.Resources
  • ZoomIn : Deltares.Standard.Forms.Properties.Resources
  • ZoomInLevels : Deltares.Standard.Forms.SpatialEditor
  • ZoomOnResize : Deltares.Standard.Forms.SpatialEditor
  • ZoomOutLevels : Deltares.Standard.Forms.SpatialEditor
  • ZoomRectangle : Deltares.Standard.Forms.Properties.Resources
  • ZoomSelection : Deltares.Standard.Forms.Properties.Resources
  • ZoomTo : Deltares.Standard.Forms.Properties.Resources
  • ZoomtoExtentsCaption : Deltares.Standard.Forms.DExpress.Properties.Resources
Generated on Tue Dec 15 2015 18:15:41 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Class Members - Events

Tool for the (stochastic) subsoil definition.
  • AfterRowAdd : Deltares.Standard.Forms.DExpress.GridViewControl
  • AfterRowDelete : Deltares.Standard.Forms.DExpress.GridViewControl
  • AfterRowInsert : Deltares.Standard.Forms.DExpress.GridViewControl
  • AfterRowUpdate : Deltares.Standard.Forms.DExpress.GridViewControl
  • EditorModeChanged : Deltares.Standard.Forms.SpatialEditor
  • findCPTCompleted : Deltares.Standard.Web.dinoservices.CptService
  • findCPTWithCriteriaCompleted : Deltares.Standard.Web.dinoservices.CptService
  • getGEFCompleted : Deltares.Standard.Web.dinoservices.CptService
  • OnBeginValidationOrSave : Deltares.Standard.Forms.DExpress.MainForm
  • OnDragDropEndEvent : Deltares.Standard.Forms.DExpress.GeometryEditor
  • OnPopupMenu : Deltares.Standard.Forms.DExpress.GeometryEditor
  • SelectionChanged : Deltares.Standard.Forms.SpatialEditor
  • ShapeCreated : Deltares.Standard.Forms.SpatialEditor
  • ShapeModified : Deltares.Standard.Forms.SpatialEditor
  • ShapeRemoved : Deltares.Standard.Forms.SpatialEditor
Generated on Tue Dec 15 2015 18:15:41 for D-SoilModel by doxygen 1.8.10


D-SoilModel: D:/Projects/delftgeosystems/sources/Standard/Deltares.Standard.Native/Deltares.Standard.Native.h Source File

Tool for the (stochastic) subsoil definition.
  • Standard
  • Deltares.Standard.Native
Deltares.Standard.Native.h
1 // Deltares.Standard.Native.h
2
3 #pragma once
4
5 using namespace System;
6
7 namespace DeltaresStandardNative {
8
9 public ref class Class1
10 {
11 // TODO: Add your methods for this class here.
12 };
13 }
System
DeltaresStandardNative::Class1
Definition: Deltares.Standard.Native.h:9
DeltaresStandardNative
Definition: Deltares.Standard.Native.h:7
Generated on Tue Dec 15 2015 18:13:45 for D-SoilModel by doxygen 1.8.10


D-SoilModel: D:/Projects/delftgeosystems/sources/Standard/Deltares.Standard.Native/Stdafx.h Source File

Tool for the (stochastic) subsoil definition.
  • Standard
  • Deltares.Standard.Native
Stdafx.h
1 // stdafx.h : include file for standard system include files,
2 // or project specific include files that are used frequently,
3 // but are changed infrequently
4
5 #pragma once
6
7
Generated on Tue Dec 15 2015 18:13:45 for D-SoilModel by doxygen 1.8.10


D-SoilModel: D:/Projects/delftgeosystems/sources/Geotechnics Directory Reference

Tool for the (stochastic) subsoil definition.
  • Geotechnics
Geotechnics Directory Reference

Directories

directory | Forms
directory | IO
directory | Properties
directory | WaternetCreator

Files

file SoilProfile1D - Copy.cs
Generated on Tue Dec 15 2015 18:15:40 for D-SoilModel by doxygen 1.8.10


D-SoilModel: D:/Projects/delftgeosystems/sources/Standard/Web/Ajax Directory Reference

Tool for the (stochastic) subsoil definition.
  • Standard
  • Web
  • Ajax
Ajax Directory Reference

Directories

directory Properties

Files

file | AjaxPageSupportHandler.cs
file | Attributes.cs
file | ExtenderControlBase.cs
file | ScriptControlBase.cs
Generated on Tue Dec 15 2015 18:15:40 for D-SoilModel by doxygen 1.8.10


D-SoilModel: D:/Projects/delftgeosystems/sources/Standard/Forms/DevExpress/ShapeImporters Directory Reference

Tool for the (stochastic) subsoil definition.
  • Standard
  • Forms
  • DevExpress
  • ShapeImporters
ShapeImporters Directory Reference

Files

file | LineStringImporter.cs
file | MultiLineStringImporter.cs
file | MultiPolygonImporter.cs
file | PointImporter.cs
file | PolygonImporter.cs
file | ShapeImporter.cs
file | SmartLineStringImporter.cs
Generated on Tue Dec 15 2015 18:15:40 for D-SoilModel by doxygen 1.8.10


D-SoilModel: D:/Projects/delftgeosystems/sources/Standard/Application Directory Reference

Tool for the (stochastic) subsoil definition.
  • Standard
  • Application
Application Directory Reference

Directories

directory Properties

Files

file | LogHelper.cs
file | ProgramBase.cs
Generated on Tue Dec 15 2015 18:15:40 for D-SoilModel by doxygen 1.8.10


D-SoilModel: D:/Projects/delftgeosystems/sources/Standard/Forms/DevExpress/PropertyControl Directory Reference

Tool for the (stochastic) subsoil definition.
  • Standard
  • Forms
  • DevExpress
  • PropertyControl
PropertyControl Directory Reference

Files

file | PanelAction.cs
file | PanelAction.Designer.cs
file | PanelLinearConversionValue.cs
file | PanelLinearConversionValue.Designer.cs
file | PanelTextBooleanValue.cs
file | PanelTextBooleanValue.Designer.cs
file | PanelTextComboBoxValue.cs
file | PanelTextComboBoxValue.Designer.cs
file | PanelTextLinkValue.cs
file | PanelTextLinkValue.Designer.cs
file | PanelTextNumericValue.cs
file | PanelTextNumericValue.Designer.cs
file | PanelTextPathValue.cs
file | PanelTextPathValue.Designer.cs
file | PanelTextPopupContainerEdit.cs
file | PanelTextPopupContainerEdit.Designer.cs
file | PanelTextStringValue.cs
file | PanelTextStringValue.Designer.cs
file | PropertyControl.cs
file | PropertyControl.Designer.cs
file | PropertyControlFactory.cs
file | PropertySubControlFactory.cs
file | RegisteredSubControlFactories.cs
file | SelectionHyperLinkEdit.cs
Generated on Tue Dec 15 2015 18:15:40 for D-SoilModel by doxygen 1.8.10


D-SoilModel: D:/Projects/delftgeosystems/sources/Standard/Deltares.Standard.Native Directory Reference

Tool for the (stochastic) subsoil definition.
  • Standard
  • Deltares.Standard.Native
Deltares.Standard.Native Directory Reference

Files

file | AssemblyInfo.cpp
file | Deltares.Standard.Native.cpp
file | Deltares.Standard.Native.h [code]
file | resource.h [code]
file | Stdafx.cpp
file | Stdafx.h [code]
Generated on Tue Dec 15 2015 18:15:40 for D-SoilModel by doxygen 1.8.10


D-SoilModel: D:/Projects/delftgeosystems/sources/Standard/DotSpatial/Properties Directory Reference

Tool for the (stochastic) subsoil definition.
  • Standard
  • DotSpatial
  • Properties
Properties Directory Reference

Files

file AssemblyInfo.cs
Generated on Tue Dec 15 2015 18:15:40 for D-SoilModel by doxygen 1.8.10


D-SoilModel: D:/Projects/delftgeosystems/sources/Geotechnics/Properties Directory Reference

Tool for the (stochastic) subsoil definition.
  • Geotechnics
  • Properties
Properties Directory Reference

Files

file AssemblyInfo.cs
Generated on Tue Dec 15 2015 18:15:40 for D-SoilModel by doxygen 1.8.10


D-SoilModel: D:/Projects/delftgeosystems/sources/Geometry/Forms/Properties Directory Reference

Tool for the (stochastic) subsoil definition.
  • Geometry
  • Forms
  • Properties
Properties Directory Reference

Files

file | AssemblyInfo.cs
file | Resources.Designer.cs
Generated on Tue Dec 15 2015 18:15:40 for D-SoilModel by doxygen 1.8.10


D-SoilModel: D:/Projects/delftgeosystems/sources/Geotechnics/WaternetCreator/PlLineCreator/Properties Directory Reference

Tool for the (stochastic) subsoil definition.
  • Geotechnics
  • WaternetCreator
  • PlLineCreator
  • Properties
Properties Directory Reference

Files

file AssemblyInfo.cs
Generated on Tue Dec 15 2015 18:15:40 for D-SoilModel by doxygen 1.8.10


D-SoilModel: D:/Projects/delftgeosystems/sources/Standard/DotSpatial Directory Reference

Tool for the (stochastic) subsoil definition.
  • Standard
  • DotSpatial
DotSpatial Directory Reference

Directories

directory Properties

Files

file | BackgroundFeature.cs
file | BackgroundMap.cs
file | DotSpatialGeographicAlgorithms.cs
file | DotSpatialGeographicConverter.cs
file | DotSpatialGeographicHelper.cs
file | DotSpatialUtil.cs
file | FeatureSupport.cs
file | IHasRaster.cs
file | MapProjection.cs
file | MapProjectionManager.cs
file | MapProjectionManagerException.cs
Generated on Tue Dec 15 2015 18:15:40 for D-SoilModel by doxygen 1.8.10


D-SoilModel: D:/Projects/delftgeosystems/sources/Geometry/Forms Directory Reference

Tool for the (stochastic) subsoil definition.
  • Geometry
  • Forms
Forms Directory Reference

Directories

directory Properties

Files

file | ColoredDrawingObject.cs
file | DrawingBoundingBox.cs
file | DrawingLine.cs
file | DrawingObject.cs
file | DrawingPoint.cs
file | DrawingPointString.cs
file | DrawingSurface.cs
file | GeometryCurveControl.cs
file | GeometryCurveControl.Designer.cs
file | GeometryPlugin.cs
file | GeometryPointControl.cs
file | GeometryPointControl.Designer.cs
file | GeometryStringControl.cs
file | GeometryStringControl.Designer.cs
file | GeometryViewSettings.cs
file | IDrawingObject.cs
file | IViewSettings.cs
file | SpatialEditorColors.cs
Generated on Tue Dec 15 2015 18:15:40 for D-SoilModel by doxygen 1.8.10


D-SoilModel: D:/Projects/delftgeosystems/sources/DSoilModel/Application/Properties Directory Reference

Tool for the (stochastic) subsoil definition.
  • Application
  • Properties
Properties Directory Reference

Files

file | AssemblyInfo.cs
file | Resources.Designer.cs
file | Settings.Designer.cs
Generated on Tue Dec 15 2015 18:15:40 for D-SoilModel by doxygen 1.8.10


D-SoilModel: D:/Projects/delftgeosystems/sources/Standard/Waternet/Data/Properties Directory Reference

Tool for the (stochastic) subsoil definition.
  • Standard
  • Waternet
  • Data
  • Properties
Properties Directory Reference

Files

file AssemblyInfo.cs
Generated on Tue Dec 15 2015 18:15:40 for D-SoilModel by doxygen 1.8.10


D-SoilModel: D:/Projects/delftgeosystems/sources/Standard/Forms Directory Reference

Tool for the (stochastic) subsoil definition.
  • Standard
  • Forms
Forms Directory Reference

Directories

directory | DevExpress
directory | DotSpatial
directory | Properties

Files

file | ColumnDescription.cs
file | ColumnType.cs
file | CommandLineWindow.cs
file | CustomConfirmDialog.cs
file | CustomConfirmDialog.Designer.cs
file | DataGridViewManager.cs
file | DBTableLayoutPanel.cs
file | DrawingSupport.cs
file | Editors.cs
file | FormSupport.cs
file | GridViewChangeArgs.cs
file | ICommand.cs
file | IController.cs
file | ICustomView.cs
file | IDynamicPropertyControl.cs
file | IDynamicTableControl.cs
file | InsertShape.cs
file | IPresenter.cs
file | IProjection.cs
file | IPropertyControl.cs
file | IReloadableUI.cs
file | IReloadManager.cs
file | IShape.cs
file | IViewConfiguration.cs
file | MatrixViewer.cs
file | MatrixViewer.Designer.cs
file | MessageBoxManager.cs
file | Messenger.cs
file | ProgramSettings.cs
file | ProgressBarWithText.cs
file | ProgressBarWithText.Designer.cs
file | Projection.cs
file | RealTimeBackgroundValidator.cs
file | Settings.cs
file | Shapes.cs
file | SourceProperty.cs
file | SpatialEditor.cs
file | SpatialEditor.designer.cs
file | SpatialEditorBarSupport.cs
file | TransparentLabel.cs
file | ViewCommand.cs
file | VisualValidationResult.cs
file | ZoomablePictureBox.cs
file | ZoomablePictureBox.Designer.cs
Generated on Tue Dec 15 2015 18:15:40 for D-SoilModel by doxygen 1.8.10


D-SoilModel: D:/Projects/delftgeosystems/sources/Standard/Web/Web References/dinoservices Directory Reference

Tool for the (stochastic) subsoil definition.
  • Standard
  • Web
  • Web References
  • dinoservices
dinoservices Directory Reference

Files

file Reference.cs
Generated on Tue Dec 15 2015 18:15:40 for D-SoilModel by doxygen 1.8.10


D-SoilModel: D:/Projects/delftgeosystems/sources/Standard/Web/DevExpress Directory Reference

Tool for the (stochastic) subsoil definition.
  • Standard
  • Web
  • DevExpress
DevExpress Directory Reference

Directories

directory Properties

Files

file DevExpressPageSupportHandler.cs
Generated on Tue Dec 15 2015 18:15:40 for D-SoilModel by doxygen 1.8.10


D-SoilModel: D:/Projects/delftgeosystems/sources/Standard/Forms/Properties Directory Reference

Tool for the (stochastic) subsoil definition.
  • Standard
  • Forms
  • Properties
Properties Directory Reference

Files

file | AssemblyInfo.cs
file | Resources.Designer.cs
file | Settings.Designer.cs
Generated on Tue Dec 15 2015 18:15:40 for D-SoilModel by doxygen 1.8.10


D-SoilModel: D:/Projects/delftgeosystems/sources/Geotechnics/IO/Importers/Exception Directory Reference

Tool for the (stochastic) subsoil definition.
  • Geotechnics
  • IO
  • Importers
  • Exception
Exception Directory Reference

Files

file | CharacteristicPointsImporterException.cs
file | FetchesImporterException.cs
Generated on Tue Dec 15 2015 18:15:40 for D-SoilModel by doxygen 1.8.10


D-SoilModel: D:/Projects/delftgeosystems/sources/Standard/Web Directory Reference

Tool for the (stochastic) subsoil definition.
  • Standard
  • Web
Web Directory Reference

Directories

directory | Ajax
directory | bin
directory | DevExpress
directory | Properties
directory | Web References

Files

file | ASPPageSupportHandler.cs
file | Chart.cs
file | CPT.cs
file | CptServiceAgent.cs
file | DINOInterface.cs
file | Encryption.cs
file | IChart.cs
file | ICurrent.cs
file | IHotSpot.cs
file | ImageHttpHandler.cs
file | IMap.cs
file | IPageSupportHandler.cs
file | IUploadDownload.cs
file | IUrl.cs
file | Log.cs
file | PageSupport.cs
file | PageSupport.js
Generated on Tue Dec 15 2015 18:15:40 for D-SoilModel by doxygen 1.8.10


D-SoilModel: D:/Projects/delftgeosystems/sources/Standard/Web/Properties Directory Reference

Tool for the (stochastic) subsoil definition.
  • Standard
  • Web
  • Properties
Properties Directory Reference

Files

file | AssemblyInfo.cs
file | Settings.Designer.cs
Generated on Tue Dec 15 2015 18:15:40 for D-SoilModel by doxygen 1.8.10


D-SoilModel: D:/Projects/delftgeosystems/sources/DSoilModel/Data Directory Reference

Tool for the (stochastic) subsoil definition.
  • Data
Data Directory Reference

Directories

directory Properties

Files

file | CenterCrestLocation.cs
file | DSoilModelDataSourceRedirector.cs
file | DSoilModelEnumerations.cs
file | DSoilModelIO.cs
file | DSoilModelProject.cs
file | DSoilModelStiFileTransformer.cs
file | DSoilModelTransformer.cs
file | SoilSegmentSplitLocation.cs
file | SOSDeltaModelDataBase.cs
file | SosSoilLayer1D.cs
file | SosSoilProfilesImporter.cs
Generated on Tue Dec 15 2015 18:15:40 for D-SoilModel by doxygen 1.8.10


D-SoilModel: D:/Projects/delftgeosystems/sources/Standard/Waternet/Data Directory Reference

Tool for the (stochastic) subsoil definition.
  • Standard
  • Waternet
  • Data
Data Directory Reference

Directories

directory Properties

Files

file | HeadLine.cs
file | Waternet.cs
file | WaternetCurve.cs
file | WaternetLine.cs
file | WaternetPoint.cs
file | WaternetPolyCurve.cs
Generated on Tue Dec 15 2015 18:15:40 for D-SoilModel by doxygen 1.8.10


D-SoilModel: D:/Projects/delftgeosystems/sources/Standard Directory Reference

Tool for the (stochastic) subsoil definition.
  • Standard
Standard Directory Reference

Directories

directory | Application
directory | Deltares.Standard.Native
directory | DotSpatial
directory | Forms
directory | Properties
directory | Waternet
directory | Web
Generated on Tue Dec 15 2015 18:15:40 for D-SoilModel by doxygen 1.8.10


D-SoilModel: D:/Projects/delftgeosystems/sources/Standard/Web/bin Directory Reference

Tool for the (stochastic) subsoil definition.
  • Standard
  • Web
  • bin
bin Directory Reference

Directories

directory Release
Generated on Tue Dec 15 2015 18:15:40 for D-SoilModel by doxygen 1.8.10


D-SoilModel: D:/Projects/delftgeosystems/sources/DSoilModel/Forms Directory Reference

Tool for the (stochastic) subsoil definition.
  • Forms
Forms Directory Reference

Directories

directory Properties

Files

file | CenterCrestLocationPropertyControl.cs
file | CenterCrestLocationPropertyControl.Designer.cs
file | DrawingBoringLayer.cs
file | DrawingCenterCrestLocation.cs
file | DrawingLayerObsolete.cs
file | DrawingSoilSegmentSplitLocation.cs
file | DrawingSosSoilLayer1D.cs
file | DSoilModelContext.cs
file | DSoilModelGeometryEditor.cs
file | DSoilModelMapEditor.cs
file | DSoilModelPlugin.cs
file | DSoilModelSegmentGeometryEditor.cs
file | FilmStrip.cs
file | FilmStrip.Designer.cs
file | FilmStripThumbnail.cs
file | HighlightSoilSegment.cs
file | ModalListBox.cs
file | ModalListBox.Designer.cs
file | SoilSegmentSplitLocationControl.cs
file | SoilSegmentSplitLocationControl.Designer.cs
file | SosSoilLayer1DControl.cs
file | SosSoilLayer1DControl.Designer.cs
file | SosSoilProfile1DControl.cs
file | SosSoilProfile1DControl.Designer.cs
Generated on Tue Dec 15 2015 18:15:40 for D-SoilModel by doxygen 1.8.10


D-SoilModel: D:/Projects/delftgeosystems/sources/Standard/Waternet Directory Reference

Tool for the (stochastic) subsoil definition.
  • Standard
  • Waternet
Waternet Directory Reference

Directories

directory Data
Generated on Tue Dec 15 2015 18:15:40 for D-SoilModel by doxygen 1.8.10


D-SoilModel: D:/Projects/delftgeosystems/sources/Standard/Forms/DevExpress/Properties Directory Reference

Tool for the (stochastic) subsoil definition.
  • Standard
  • Forms
  • DevExpress
  • Properties
Properties Directory Reference

Files

file | AssemblyInfo.cs
file | Resources.Designer.cs
file | Settings.Designer.cs
Generated on Tue Dec 15 2015 18:15:40 for D-SoilModel by doxygen 1.8.10


D-SoilModel: D:/Projects/delftgeosystems/sources/Standard/Application/Properties Directory Reference

Tool for the (stochastic) subsoil definition.
  • Standard
  • Application
  • Properties
Properties Directory Reference

Files

file AssemblyInfo.cs
Generated on Tue Dec 15 2015 18:15:40 for D-SoilModel by doxygen 1.8.10


D-SoilModel: D:/Projects/delftgeosystems/sources/Geotechnics/IO/Importers Directory Reference

Tool for the (stochastic) subsoil definition.
  • Geotechnics
  • IO
  • Importers
Importers Directory Reference

Directories

directory Exception

Files

file | CharacteristicPointsImporter.cs
file | DGSGEFInterface.cs
file | DGSStandardDLLInterface.cs
file | FetchesImporter.cs
file | GefBoringFileImporter.cs
file | GefCptFileImporter.cs
file | GEFXmlImporter.cs
file | OldGeometryFileImporter.cs
file | SoilProfilesImporter.cs
file | SoilSegmentsImporter.cs
file | SurfaceLinesImporter.cs
Generated on Tue Dec 15 2015 18:15:40 for D-SoilModel by doxygen 1.8.10


D-SoilModel: D:/Projects/delftgeosystems/sources/Standard/Forms/DevExpress/ComponentWrappers Directory Reference

Tool for the (stochastic) subsoil definition.
  • Standard
  • Forms
  • DevExpress
  • ComponentWrappers
ComponentWrappers Directory Reference

Files

file | BarButtonItemBinding.cs
file | BarEditItemBinding.cs
file | BarItemBinding.cs
file | BarStaticItemBinding.cs
file | BarSubItemBinding.cs
file | BaseControlBinding.cs
file | BindingRegistration.cs
file | ButtonBinding.cs
file | ButtonEditBinding.cs
file | ChartControlBinding.cs
file | CheckBoxBinding.cs
file | CheckEditBinding.cs
file | ColorEditBinding.cs
file | ComboBoxEditBinding.cs
file | ComponentBinding.cs
file | ControlBinding.cs
file | DateEditBinding.cs
file | DetailReportBandBinding.cs
file | DockPanelBinding.cs
file | GaugeControlBinding.cs
file | GaugeControlBinding.Designer.cs
file | GridColumnBinding.cs
file | GridControlBinding.cs
file | HyperLinkEditBinding.cs
file | IGetBindingControl.cs
file | ImageListBoxBinding.cs
file | LabelBinding.cs
file | LabelControlBinding.cs
file | ListBoxBinding.cs
file | NavBarItemBinding.cs
file | PictureBoxBinding.cs
file | PopupContainerEditBinding.cs
file | RadioButtonBinding.cs
file | RadioGroupBinding.cs
file | RepositoryItemTrackBarBinding.cs
file | ScrollableControlBinding.cs
file | SimpleButtonBinding.cs
file | SpinEditBinding.cs
file | StateIndicatorGaugeBinding.cs
file | TextEditBinding.cs
file | ToolStripMenuItemBinding.cs
file | TrackBarControlBinding.cs
file | TreeListBinding.cs
file | TreeListColumnBinding.cs
file | XRCheckBoxBinding.cs
file | XRControlBinding.cs
file | XRLabelBinding.cs
file | XRPictureBoxBinding.cs
file | XRShapeBinding.cs
file | XRSubreportBinding.cs
file | XtraTabPageBinding.cs
Generated on Tue Dec 15 2015 18:15:40 for D-SoilModel by doxygen 1.8.10


D-SoilModel: D:/Projects/delftgeosystems/sources/Standard/Forms/DotSpatial/Properties Directory Reference

Tool for the (stochastic) subsoil definition.
  • Standard
  • Forms
  • DotSpatial
  • Properties
Properties Directory Reference

Files

file AssemblyInfo.cs
Generated on Tue Dec 15 2015 18:15:40 for D-SoilModel by doxygen 1.8.10


D-SoilModel: D:/Projects/delftgeosystems/sources/Standard/Forms/DevExpress/Project Directory Reference

Tool for the (stochastic) subsoil definition.
  • Standard
  • Forms
  • DevExpress
  • Project
Project Directory Reference

Files

file | DescriptionDialog.cs
file | DescriptionDialog.Designer.cs
Generated on Tue Dec 15 2015 18:15:40 for D-SoilModel by doxygen 1.8.10


D-SoilModel: D:/Projects/delftgeosystems/sources/Geotechnics/Forms/Properties Directory Reference

Tool for the (stochastic) subsoil definition.
  • Geotechnics
  • Forms
  • Properties
Properties Directory Reference

Files

file | AssemblyInfo.cs
file | Resources.Designer.cs
Generated on Tue Dec 15 2015 18:15:40 for D-SoilModel by doxygen 1.8.10


D-SoilModel: D:/Projects/delftgeosystems/sources/Standard/Web/DevExpress/Properties Directory Reference

Tool for the (stochastic) subsoil definition.
  • Standard
  • Web
  • DevExpress
  • Properties
Properties Directory Reference

Files

file AssemblyInfo.cs
Generated on Tue Dec 15 2015 18:15:40 for D-SoilModel by doxygen 1.8.10


D-SoilModel: D:/Projects/delftgeosystems/sources/Geometry/Properties Directory Reference

Tool for the (stochastic) subsoil definition.
  • Geometry
  • Properties
Properties Directory Reference

Files

file AssemblyInfo.cs
Generated on Tue Dec 15 2015 18:15:40 for D-SoilModel by doxygen 1.8.10


D-SoilModel: D:/Projects/delftgeosystems/sources/Standard/Forms/DotSpatial Directory Reference

Tool for the (stochastic) subsoil definition.
  • Standard
  • Forms
  • DotSpatial
DotSpatial Directory Reference

Directories

directory Properties

Files

file | GeometrySetter.cs
file | LineStringImporter.cs
file | PointImporter.cs
Generated on Tue Dec 15 2015 18:15:40 for D-SoilModel by doxygen 1.8.10


D-SoilModel: D:/Projects/delftgeosystems/sources/DSoilModel/Application Directory Reference

Tool for the (stochastic) subsoil definition.
  • Application
Application Directory Reference

Directories

directory Properties

Files

file Program.cs
Generated on Tue Dec 15 2015 18:15:40 for D-SoilModel by doxygen 1.8.10


D-SoilModel: D:/Projects/delftgeosystems/sources/Standard/Web/Web References Directory Reference

Tool for the (stochastic) subsoil definition.
  • Standard
  • Web
  • Web References
Web References Directory Reference

Directories

directory dinoservices
Generated on Tue Dec 15 2015 18:15:40 for D-SoilModel by doxygen 1.8.10


D-SoilModel: D:/Projects/delftgeosystems/sources/Geotechnics/WaternetCreator Directory Reference

Tool for the (stochastic) subsoil definition.
  • Geotechnics
  • WaternetCreator
WaternetCreator Directory Reference

Directories

directory PlLineCreator
Generated on Tue Dec 15 2015 18:15:40 for D-SoilModel by doxygen 1.8.10


D-SoilModel: D:/Projects/delftgeosystems/sources/Geotechnics/Forms Directory Reference

Tool for the (stochastic) subsoil definition.
  • Geotechnics
  • Forms
Forms Directory Reference

Directories

directory Properties

Files

file | AnchorAttachmentControl.cs
file | AnchorAttachmentControl.Designer.cs
file | BondStressCurveControl.cs
file | BondStressCurveControl.designer.cs
file | BoringControl.cs
file | BoringControl.designer.cs
file | BoringLookupControl.cs
file | BoringLookupControl.Designer.cs
file | CPTControl.cs
file | CPTControl.designer.cs
file | CPTLookupControl.cs
file | CPTLookupControl.Designer.cs
file | DegreeOfConsolidationDialog.cs
file | DegreeOfConsolidationDialog.Designer.cs
file | DegreeOfConsolidationMatrixControl.cs
file | DegreeOfConsolidationMatrixControl.designer.cs
file | DesignPointControl.cs
file | DesignPointControl.designer.cs
file | DikeLineControl.cs
file | DikeLineControl.designer.cs
file | DrawingAnchorAttachment.cs
file | DrawingAsphaltRevetment.cs
file | DrawingBlockRevetmentSegment.cs
file | DrawingBoring.cs
file | DrawingCharacteristicPoint.cs
file | DrawingCPT.cs
file | DrawingGeometry.cs
file | DrawingHeadLine.cs
file | DrawingLayer.cs
file | DrawingLocalisedGeometryPointString.cs
file | DrawingPhreaticLine.cs
file | DrawingPiezometricHead.cs
file | DrawingPreConsolidationStress.cs
file | DrawingRevetment.cs
file | DrawingRoughnessRevetment.cs
file | DrawingSettlementCurve.cs
file | DrawingSheetPiling.cs
file | DrawingSoilLayerSurface.cs
file | DrawingSoilProfile1D.cs
file | DrawingSoilSurface.cs
file | DrawingSpecificMechanismPointLocation.cs
file | DrawingSurfaceLine2.cs
file | DrawingSwell.cs
file | DrawingWaterBasin.cs
file | DrawingWaterLevel.cs
file | DrawingWaternetLine.cs
file | DrawingWaternetPointString.cs
file | DrawingWaterPolderBasin.cs
file | GeometryPropertyControl.cs
file | GeometryPropertyControl.Designer.cs
file | GeotechnicsPlugin.cs
file | GeotechnicsViewSettings.cs
file | HydraulicBoundaryControl.cs
file | HydraulicBoundaryControl.designer.cs
file | MaterialEditorDialog.cs
file | MaterialEditorDialog.designer.cs
file | PreconsolidationStressControl.cs
file | PreconsolidationStressControl.Designer.cs
file | ProbabilisticInfoControl.cs
file | ProbabilisticInfoControl.designer.cs
file | RevetmentLayerControl.cs
file | RevetmentLayerControl.Designer.cs
file | SchematizedSurfaceLineControl.cs
file | SchematizedSurfaceLineControl.Designer.cs
file | SegmentControl.cs
file | SegmentControl.designer.cs
file | SettlementCurveControl.cs
file | SettlementCurveControl.Designer.cs
file | ShearStressCurveControl.cs
file | ShearStressCurveControl.designer.cs
file | SheetPilingControl.cs
file | SheetPilingControl.Designer.cs
file | SoilBondStressCurveControl.cs
file | SoilBondStressCurveControl.Designer.cs
file | SoilLayer2DControl.cs
file | SoilLayer2DControl.Designer.cs
file | SoilLayerControl.cs
file | SoilLayerControl.designer.cs
file | SoilProfile1DControl.cs
file | SoilProfile1DControl.designer.cs
file | SoilProfile2DControl.cs
file | SoilProfile2DControl.designer.cs
file | SoilStressCurveControl.cs
file | SoilStressCurveControl.Designer.cs
file | SoilSurfacePointsControl.cs
file | SoilSurfacePointsControl.Designer.cs
file | SoilSurfacePropertyControl.cs
file | SoilSurfacePropertyControl.Designer.cs
file | SpecificMechanismPointLocationControl.cs
file | SpecificMechanismPointLocationControl.Designer.cs
file | StochastControl.cs
file | StochastControl.Designer.cs
file | StressCurveControl.cs
file | StressCurveControl.designer.cs
file | StressCurveReader.cs
file | SurfaceLine2Control.cs
file | SurfaceLine2Control.Designer.cs
file | WaterLineControl.cs
file | WaterLineControl.Designer.cs
file | WaternetControl.cs
file | WaternetControl.Designer.cs
Generated on Tue Dec 15 2015 18:15:40 for D-SoilModel by doxygen 1.8.10


D-SoilModel: D:/Projects/delftgeosystems/sources/Standard/Forms/DevExpress/Interfaces Directory Reference

Tool for the (stochastic) subsoil definition.
  • Standard
  • Forms
  • DevExpress
  • Interfaces
Interfaces Directory Reference

Files

file | IHasBindableChildren.cs
file | IHelpFileManager.cs
file | IHelpLocationProvider.cs
file | ILateBinding.cs
file | ISelectableLayer.cs
file | ISettingsDialogPlugin.cs
file | ISettingsFormPlugin.cs
file | ISettingsValidator.cs
Generated on Tue Dec 15 2015 18:15:40 for D-SoilModel by doxygen 1.8.10


D-SoilModel: D:/Projects/delftgeosystems/sources/Standard/Properties Directory Reference

Tool for the (stochastic) subsoil definition.
  • Standard
  • Properties
Properties Directory Reference

Files

file AssemblyInfo.cs
Generated on Tue Dec 15 2015 18:15:40 for D-SoilModel by doxygen 1.8.10


D-SoilModel: D:/Projects/delftgeosystems/sources/DSoilModel/Data/Properties Directory Reference

Tool for the (stochastic) subsoil definition.
  • Data
  • Properties
Properties Directory Reference

Files

file AssemblyInfo.cs
Generated on Tue Dec 15 2015 18:15:40 for D-SoilModel by doxygen 1.8.10


D-SoilModel: D:/Projects/delftgeosystems/sources/Geotechnics/IO/Exception Directory Reference

Tool for the (stochastic) subsoil definition.
  • Geotechnics
  • IO
  • Exception
Exception Directory Reference

Files

file CsvImporterSoilProfilesException.cs
Generated on Tue Dec 15 2015 18:15:40 for D-SoilModel by doxygen 1.8.10


D-SoilModel: D:/Projects/delftgeosystems/sources/Standard/Forms/DevExpress/MapTools Directory Reference

Tool for the (stochastic) subsoil definition.
  • Standard
  • Forms
  • DevExpress
  • MapTools
MapTools Directory Reference

Files

file | AddFeatureMapTool.cs
file | BaseMapTool.cs
file | ConnectFeaturesMapTool.cs
file | DeleteFeatureMapTool.cs
file | IContextMenuMapTool.cs
file | IMapTool.cs
file | MoveFeatureMapTool.cs
file | RectangleZoomMapTool.cs
file | SelectFeatureMapTool.cs
Generated on Tue Dec 15 2015 18:15:40 for D-SoilModel by doxygen 1.8.10


D-SoilModel: D:/Projects/delftgeosystems/sources/Standard/Forms/DevExpress Directory Reference

Tool for the (stochastic) subsoil definition.
  • Standard
  • Forms
  • DevExpress
DevExpress Directory Reference

Directories

directory | ComponentWrappers
directory | Forms
directory | Interfaces
directory | MapTools
directory | Project
directory | Properties
directory | PropertyControl
directory | ShapeImporters

Files

file | AboutControl.cs
file | AboutControl.Designer.cs
file | AbstractShapeFileImporter.cs
file | ActiveWindowReport.cs
file | ActiveWindowReport.Designer.cs
file | BarItemExtensions.cs
file | BindingType.cs
file | BindSupport.cs
file | BindSupport2.cs
file | BindSupportAsHelpLocationProvider.cs
file | BindSupportChartHelper.cs
file | BindSupportLateBinding.cs
file | BindSupportTreeHelper.cs
file | CategoryDisplayItem.cs
file | ChangeInfo.cs
file | ColumnWidth.cs
file | ComboBoxDisplayItem.cs
file | CustomLocalizer.cs
file | DialogTemplate.cs
file | DialogTemplate.Designer.cs
file | DisclaimerDialog.cs
file | DisclaimerDialog.Designer.cs
file | DisplayItem.cs
file | DynamicChartControl.cs
file | DynamicChartControl.Designer.cs
file | DynamicImageControl.cs
file | DynamicImageControl.Designer.cs
file | DynamicMesssagesControl.cs
file | DynamicMesssagesControl.Designer.cs
file | DynamicNavigatorControl.cs
file | DynamicNavigatorControl.Designer.cs
file | DynamicOutputControl.cs
file | DynamicOutputControl.Designer.cs
file | DynamicPropertyControl.cs
file | DynamicPropertyControl.Designer.cs
file | DynamicPropertyTabControl.cs
file | DynamicPropertyTabControl.Designer.cs
file | DynamicResourcesControl.cs
file | DynamicResourcesControl.Designer.cs
file | DynamicTableControl.cs
file | DynamicTableControl.Designer.cs
file | FormsSupport.cs
file | GeoChartControl.cs
file | GeometryEditor.cs
file | GeometryEditor.Designer.cs
file | GeometryTypes.cs
file | GeoPropertyGrid.cs
file | GeoRepositoryTextEdit.cs
file | GridEditValueStrategy.cs
file | GridViewControl.cs
file | GridViewControl.designer.cs
file | GridViewController.cs
file | HelpLocationShower.cs
file | IMainForm.cs
file | IMainFormActiveControlController.cs
file | IMainFormPlugin.cs
file | IShapeImporter.cs
file | ListViewControl.cs
file | ListViewControl.Designer.cs
file | LocalizationSupport.cs
file | MainForm.cs
file | MainForm.Designer.cs
file | MapEditor.cs
file | MapEditor.Designer.cs
file | MapLayerDefinition.cs
file | MapLayersPropertyControl.cs
file | MapLayersPropertyControl.Designer.cs
file | MapLegendPropertyControl.cs
file | MapLegendPropertyControl.Designer.cs
file | ModelDialog.cs
file | MyFeatureSet.cs
file | MyMapLineLayer.cs
file | MyMapPointLayer.cs
file | MyMapPolygonLayer.cs
file | PdfHelpFileManager.cs
file | ProgramOptionsControl.cs
file | ProgramOptionsControl.designer.cs
file | ProgressDialog.cs
file | ProgressDialog.designer.cs
file | RasterLayerDefinition.cs
file | ReloadManager.cs
file | Report.cs
file | ReportChapter.cs
file | ReportControl.cs
file | ReportControl.Designer.cs
file | ReportDlg.cs
file | ReportDlg.designer.cs
file | ReportItem.cs
file | ReportManager.cs
file | Settings.cs
file | ShapeFileImporter.cs
file | ShapeFileMetaDataImporter.cs
file | SingleUnitDialog.cs
file | SingleUnitDialog.designer.cs
file | SpatialEditorProperties.cs
file | SpatialEditorProperties.Designer.cs
file | SplashDialog.cs
file | SplashDialog.designer.cs
file | StatusBar.cs
file | StatusBar.Designer.cs
file | Translation.Designer.cs
file | TreeViewControl.cs
file | TreeViewControl.designer.cs
file | UnitsDialog.cs
file | UnitsDialog.designer.cs
file | UserColumnFilterDisplayItem.cs
file | WebMapPlugin.cs
Generated on Tue Dec 15 2015 18:15:40 for D-SoilModel by doxygen 1.8.10


D-SoilModel: D:/Projects/delftgeosystems/sources/Geotechnics/IO/Properties Directory Reference

Tool for the (stochastic) subsoil definition.
  • Geotechnics
  • IO
  • Properties
Properties Directory Reference

Files

file AssemblyInfo.cs
Generated on Tue Dec 15 2015 18:15:40 for D-SoilModel by doxygen 1.8.10


D-SoilModel: D:/Projects/delftgeosystems/sources/Standard/Web/bin/Release Directory Reference

Tool for the (stochastic) subsoil definition.
  • Standard
  • Web
  • bin
  • Release
Release Directory Reference

Files

file PageSupport.js
Generated on Tue Dec 15 2015 18:15:40 for D-SoilModel by doxygen 1.8.10


D-SoilModel: D:/Projects/delftgeosystems/sources/Geotechnics/WaternetCreator/PlLineCreator Directory Reference

Tool for the (stochastic) subsoil definition.
  • Geotechnics
  • WaternetCreator
  • PlLineCreator
PlLineCreator Directory Reference

Directories

directory Properties

Files

file | LineHelper.cs
file | Location.cs
file | ModelParametersForPlLines.cs
file | PlLinesCreator.cs
file | SoilVolumeMassCalculator.cs
file | UpliftCalculator.cs
file | WaternetCreator.cs
Generated on Tue Dec 15 2015 18:15:40 for D-SoilModel by doxygen 1.8.10


D-SoilModel: D:/Projects/delftgeosystems/sources/Standard/Web/Ajax/Properties Directory Reference

Tool for the (stochastic) subsoil definition.
  • Standard
  • Web
  • Ajax
  • Properties
Properties Directory Reference

Files

file AssemblyInfo.cs
Generated on Tue Dec 15 2015 18:15:40 for D-SoilModel by doxygen 1.8.10


D-SoilModel: D:/Projects/delftgeosystems/sources/Geometry Directory Reference

Tool for the (stochastic) subsoil definition.
  • Geometry
Geometry Directory Reference

Directories

directory | Forms
directory | Properties
Generated on Tue Dec 15 2015 18:15:40 for D-SoilModel by doxygen 1.8.10


D-SoilModel: D:/Projects/delftgeosystems/sources/Standard/Forms/DevExpress/Forms Directory Reference

Tool for the (stochastic) subsoil definition.
  • Standard
  • Forms
  • DevExpress
  • Forms
Forms Directory Reference

Files

file | ExportLayersController.cs
file | ExportLayersDialog.cs
file | ExportLayersDialog.Designer.cs
file | FieldMappingControl.cs
file | FieldMappingControl.Designer.cs
file | IExportLayersDialog.cs
file | SelectLayerItem.cs
Generated on Tue Dec 15 2015 18:15:40 for D-SoilModel by doxygen 1.8.10


D-SoilModel: D:/Projects/delftgeosystems/sources/DSoilModel/Forms/Properties Directory Reference

Tool for the (stochastic) subsoil definition.
  • Forms
  • Properties
Properties Directory Reference

Files

file | AssemblyInfo.cs
file | Resources.Designer.cs
Generated on Tue Dec 15 2015 18:15:40 for D-SoilModel by doxygen 1.8.10


D-SoilModel: D:/Projects/delftgeosystems/sources/Geotechnics/IO Directory Reference

Tool for the (stochastic) subsoil definition.
  • Geotechnics
  • IO
IO Directory Reference

Directories

directory | Exception
directory | Importers
directory | Properties

Files

file | SurfaceLineClassFactory.cs
file | SurfaceLineInstanceFactory.cs
file | SurfaceLineXmlHandler.cs
file | XmlAquiferHandler.cs
file | XmlSoilsToSoilListHandler.cs
Generated on Tue Dec 15 2015 18:15:40 for D-SoilModel by doxygen 1.8.10


D-SoilModel: Main Page

Tool for the (stochastic) subsoil definition.
D-SoilModel Documentation
  • Main Page
  • Packages
    • Packages
    • Package Functions
  • Classes
    • Class List
    • Class Index
    • Class Hierarchy
    • Class Members
Generated on Tue Dec 15 2015 18:15:40 for D-SoilModel by doxygen 1.8.10


D-SoilModel: D:/Projects/delftgeosystems/sources/Standard/Deltares.Standard.Native/resource.h Source File

Tool for the (stochastic) subsoil definition.
  • Standard
  • Deltares.Standard.Native
resource.h
1 //{{NO_DEPENDENCIES}}
2 // Microsoft Visual C++ generated include file.
3 // Used by app.rc
Generated on Tue Dec 15 2015 18:13:45 for D-SoilModel by doxygen 1.8.10